Double-Take Powershell Overview

Double-Take SOAP SDK 8.0
Double-Take Powershell Overview

Double-Take includes Windows PowerShell cmdlets that you can use to control most Double-Take features. This guide includes all of the Double-Take cmdlets available. However, this guide does not explain how to use Windows PowerShell. You should reference your Windows PowerShell documentation and the many web sites devoted to PowerShell to learn how to use and script with Windows PowerShell.

The following terms and definitions will help you understand Double-Take basics. See the User's Guide for your Double-Take product for complete details on how that product works.

  • Source—The source is the server that has the data you want to protect or migrate. Typically this is a machine on the production network that serves data to clients.

  • Target—The target is the server that maintains the replicated copy of the data that is being protected on the source. Typically this is a backup server that may be local or in a remote data center. For migration jobs, this is the final destination for your data.

  • Workload—A workload is a logical definition of the data that is being protected or migrated on the source. A workload can be a simple set of paths, for example, C:\Data or /usr. It may also be a more complex logical item that maps to multiple paths. For example, protecting a virtual machine means you are protecting multiple, specific virtual machine files, or protecting Microsoft SQL means you are protecting a SQL database and its related files.

  • Workload manager—The workload manager is a web service that creates and configures the Double-Take workload.

  • Job—A job is a logical unit that includes the source, target, and the workload. The job is what you create and monitor in order to protect or migrate your data.

  • Job manager—The job manager is a web service that creates, monitors, and controls the Double-Take job.

  • Connection—The engine connection is the underlying stream that sends the actual replicated data between the source and target servers. Jobs are higher-level objects that use the lower-level connection to protect data.

  • Architecture—Each Double-Take installation has two services, the Management Service and Engine.

    • Management Service—This service is displayed as Double-Take Management Service in the Windows services list and jsvc on Linux. The service hosts the job manager and provides monitoring and control for all job types. For WCF clients, the service listens on port 6325. For non-WCF clients, the service listens on port 6326. This service offers a SOAP-based XML web services interface.

    • Engine—This service is displayed as Double-Take in the Windows service list and DT on Linux. The service transmits the replicated data between the source and target servers. By default this service listens on port 6320. You do not interact directly with this service.

  • Roles—Any Double-Take installation can be a source, target, or both. The existence of a job between two servers and which direction data is being transmitted determines the server’s role.

  • Security—Double-Take enforces security by using local groups on each server where Double-Take is installed. There are two levels of security. Administrator access allows full control of Double-Take on a server, and monitor access allows read-only views of job information. When you connect to the job manager on a server, you will need to provide the credentials of a user who is a member of one of the local groups on that server.

  • Job creation—To create a job, you will first communicate with the source to create a workload. You will then use that workload object and communicate with the target to create the job.

  • Monitoring and controlling jobs—To monitor and control jobs, you will communicate with the job manager on the target of the job.


Add-DtPhysicalRule

Add-DtPhysicalRule

Syntax

Add-DtPhysicalRule[-Exclude] <SwitchParameter> [-NonRecursive] <SwitchParameter> [-Path] <String> [-WorkloadId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Add-DtPhysicalRule[-Rule] <PhysicalRule> [-WorkloadId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-Exclude<SwitchParameter>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-NonRecursive<SwitchParameter>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Path<String>
Required? | true
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Rule<PhysicalRule>
Required? | true
Position? | 3
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-WorkloadId<Guid>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Add-DtUvraPhysicalRule

Add-DtUvraPhysicalRule

Syntax

Add-DtUvraPhysicalRule[-Path] <String> [-Recurse] <SwitchParameter> [-Exclude] <SwitchParameter> [-Workload] <Workload> [-ServiceHost] <Server> [<CommonParameters>]

Add-DtUvraPhysicalRule[-Rule] <PhysicalRule> [-Workload] <Workload> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-Workload<Workload>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Path<String>
Required? | true
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Recurse<SwitchParameter>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Exclude<SwitchParameter>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Rule<PhysicalRule>
Required? | true
Position? | 3
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Checkpoint-DtConnection

Checkpoint-DtConnection

Syntax

Checkpoint-DtConnection[-JobId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Checkpoint-DtConnection[-JobInfo] <JobInfo> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-JobId<Guid>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobInfo<JobInfo>
Required? | true
Position? | named
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Close-DtWorkload

Close-DtWorkload

Syntax

Close-DtWorkload[-WorkloadId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-WorkloadId<Guid>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Confirm-DtJobOptions

Confirm-DtJobOptions

Syntax

Confirm-DtJobOptions[-JobId] <Guid> [-JobOptions] <JobOptions> [-ServiceHost] <Server> [<CommonParameters>]

Confirm-DtJobOptions[-Source] <Server> [-JobType] <String> [-JobOptions] <JobOptions> [-OtherServers] <Server[]> [-ServiceHost] <Server> [<CommonParameters>]

Confirm-DtJobOptions[-CreateOptions] <CreateOptions> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-JobId<Guid>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Source<Server>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobType<String>
Required? | true
Position? | 3
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobOptions<JobOptions>
Required? | true
Position? | 3
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-OtherServers<Server[]>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-CreateOptions<CreateOptions>
Required? | true
Position? | 2
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Disconnect-DtServer

Disconnect-DtServer

Syntax

Disconnect-DtServer[-ServiceHost] <Server> [<CommonParameters>]

Parameters
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Edit-DtJob

Edit-DtJob

Syntax

Edit-DtJob[-JobId] <Guid> [-JobOptions] <JobOptions> [-ServiceHost] <Server> [<CommonParameters>]

Edit-DtJob[-JobInfo] <JobInfo> [-JobOptions] <JobOptions> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-JobOptions<JobOptions>
Required? | true
Position? | 3
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobId<Guid>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobInfo<JobInfo>
Required? | true
Position? | named
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Get-DtAccessLevel

Get-DtAccessLevel

Syntax

Get-DtAccessLevel[-ServiceHost] <Server> [<CommonParameters>]

Parameters
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Get-DtActivationStatus

Get-DtActivationStatus

Syntax

Get-DtActivationStatus[-Code] <String[]> [-AdditionalCode] <String[]> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-Code<String[]>
Required? | false
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-AdditionalCode<String[]>
Required? | false
Position? | 3
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Get-DtBandwidthLimit

Get-DtBandwidthLimit

Syntax

Get-DtBandwidthLimit[-JobId] <Guid> [-ConnectionId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Get-DtBandwidthLimit[-JobInfo] <JobInfo> [-ConnectionId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-ConnectionId<Guid>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobId<Guid>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobInfo<JobInfo>
Required? | true
Position? | named
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Get-DtConnectionIds

Get-DtConnectionIds

Syntax

Get-DtConnectionIds[-JobId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-JobId<Guid>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Get-DtDiagnostics

Get-DtDiagnostics

Syntax

Get-DtDiagnostics[-OutputDirectory] <String> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-OutputDirectory<String>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Get-DtDiskIdentifiers

Get-DtDiskIdentifiers

Syntax

Get-DtDiskIdentifiers[-ServiceHost] <Server> [<CommonParameters>]

Parameters
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Get-DtEmailNotificationOptions

Get-DtEmailNotificationOptions

Syntax

Get-DtEmailNotificationOptions[-ServiceHost] <Server> [<CommonParameters>]

Parameters
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Get-DtEventLogEntry

Get-DtEventLogEntry

Syntax

Get-DtEventLogEntry[-LastIndex] <Int32> [-ChunkSize] <Int32> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-LastIndex<Int32>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ChunkSize<Int32>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Get-DtHvSystemState

Get-DtHvSystemState

Syntax

Get-DtHvSystemState[-Credential] <PSCredential> [-BiosGuid] <Guid> [-GuestDnsName] <String> [-ServiceHost] <Server> [<CommonParameters>]

Get-DtHvSystemState[-Domain] <String> [-Password] <String> [-UserName] <String> [-BiosGuid] <Guid> [-GuestDnsName] <String> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-BiosGuid<Guid>
Required? | true
Position? | 3
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Credential<PSCredential>
Required? | true
Position? | 4
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Domain<String>
Required? | false
Position? | 6
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-GuestDnsName<String>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Password<String>
Required? | true
Position? | 5
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-UserName<String>
Required? | true
Position? | 4
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Get-DtImages

Get-DtImages

Syntax

Get-DtImages[-ImageIds] <List`1> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-ImageIds<List`1>
Required? | false
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Get-DtJob

Get-DtJob

Syntax

Get-DtJob[-JobId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-JobId<Guid>
Required? | false
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Get-DtJobActionStatus

Get-DtJobActionStatus

Syntax

Get-DtJobActionStatus[-JobId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Get-DtJobActionStatus[-Action] <ActivityToken> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-JobId<Guid>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Action<ActivityToken>
Required? | true
Position? | 2
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Get-DtLogicalItem

Get-DtLogicalItem

Syntax

Get-DtLogicalItem[-RefItem] <LogicalItem> [-WorkloadId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-RefItem<LogicalItem>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-WorkloadId<Guid>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Get-DtLogMessage

Get-DtLogMessage

Syntax

Get-DtLogMessage[-Source] <String> [-LastSequenceNumber] <Int32> [-LastTimestamp] <DateTimeOffset> [-ChunkSize] <Int32> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-Source<String>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-LastSequenceNumber<Int32>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-LastTimestamp<DateTimeOffset>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ChunkSize<Int32>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Get-DtOnlineActivationRequest

Get-DtOnlineActivationRequest

Syntax

Get-DtOnlineActivationRequest[-ServiceHost] <Server> [<CommonParameters>]

Parameters
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Get-DtOption

Get-DtOption

Syntax

Get-DtOption[-Name] <String[]> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-Name<String[]>
Required? | false
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Get-DtPathBlocking

Get-DtPathBlocking

Syntax

Get-DtPathBlocking[-ServiceHost] <Server> [<CommonParameters>]

Parameters
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Get-DtPhysicalItem

Get-DtPhysicalItem

Syntax

Get-DtPhysicalItem[-Ref] <PhysicalItem> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-Ref<PhysicalItem>
Required? | false
Position? | named
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Get-DtProductInfo

Get-DtProductInfo

Syntax

Get-DtProductInfo[-ServiceHost] <Server> [<CommonParameters>]

Parameters
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Get-DtQualificationResults

Get-DtQualificationResults

Syntax

Get-DtQualificationResults[-JobId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Get-DtQualificationResults[-JobInfo] <JobInfo> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-JobId<Guid>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobInfo<JobInfo>
Required? | true
Position? | named
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Get-DtRecommendedFailbackOptions

Get-DtRecommendedFailbackOptions

Syntax

Get-DtRecommendedFailbackOptions[-JobId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Get-DtRecommendedFailbackOptions[-JobInfo] <JobInfo> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-JobId<Guid>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobInfo<JobInfo>
Required? | true
Position? | named
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Get-DtRecommendedFailoverOptions

Get-DtRecommendedFailoverOptions

Syntax

Get-DtRecommendedFailoverOptions[-JobId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Get-DtRecommendedFailoverOptions[-JobInfo] <JobInfo> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-JobId<Guid>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobInfo<JobInfo>
Required? | true
Position? | named
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Get-DtRecommendedJobOptions

Get-DtRecommendedJobOptions

Syntax

Get-DtRecommendedJobOptions[-Source] <Server> [-JobType] <String> [-Workload] <Workload> [-OtherServers] <Server[]> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-Source<Server>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobType<String>
Required? | true
Position? | 3
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Workload<Workload>
Required? | true
Position? | 4
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-OtherServers<Server[]>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Get-DtRecommendedPathTransform

Get-DtRecommendedPathTransform

Syntax

Get-DtRecommendedPathTransform[-BasePath] <String> [-WorkloadId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-BasePath<String>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-WorkloadId<Guid>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Get-DtRecommendedRestoreOptions

Get-DtRecommendedRestoreOptions

Syntax

Get-DtRecommendedRestoreOptions[-JobId] <Guid> [-RestoreTarget] <Server> [-RequestCanClearRestoreRequired] <SwitchParameter> [-ServiceHost] <Server> [<CommonParameters>]

Get-DtRecommendedRestoreOptions[-JobInfo] <JobInfo> [-RestoreTarget] <Server> [-RequestCanClearRestoreRequired] <SwitchParameter> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-RestoreTarget<Server>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-RequestCanClearRestoreRequired<SwitchParameter>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobId<Guid>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobInfo<JobInfo>
Required? | true
Position? | named
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Get-DtRepairJobOptionsStatus

Get-DtRepairJobOptionsStatus

Syntax

Get-DtRepairJobOptionsStatus[-Token] <ActivityToken> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-Token<ActivityToken>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Get-DtScriptCredentials

Get-DtScriptCredentials

Syntax

Get-DtScriptCredentials[-ServiceHost] <Server> [<CommonParameters>]

Parameters
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Get-DtServerInfo

Get-DtServerInfo

Syntax

Get-DtServerInfo[-ServiceHost] <Server> [<CommonParameters>]

Parameters
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Get-DtSnapshot

Get-DtSnapshot

Syntax

Get-DtSnapshot[-JobId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Get-DtSnapshot[-JobInfo] <JobInfo> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-JobId<Guid>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobInfo<JobInfo>
Required? | true
Position? | named
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Get-DtUvraRecommendedFailoverOptions

Get-DtUvraRecommendedFailoverOptions

Syntax

Get-DtUvraRecommendedFailoverOptions[-JobId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Get-DtUvraRecommendedFailoverOptions[-JobInfo] <JobInfo> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-JobId<Guid>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobInfo<JobInfo>
Required? | true
Position? | named
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Get-DtUvraRecommendedRemoveOptions

Get-DtUvraRecommendedRemoveOptions

Syntax

Get-DtUvraRecommendedRemoveOptions[-JobId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Get-DtUvraRecommendedRemoveOptions[-JobInfo] <JobInfo> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-JobId<Guid>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobInfo<JobInfo>
Required? | true
Position? | named
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Get-DtVerificationStatus

Get-DtVerificationStatus

Syntax

Get-DtVerificationStatus[-Token] <ActivityToken> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-Token<ActivityToken>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Get-DtVirtualNetworkInterfaceInfos

Get-DtVirtualNetworkInterfaceInfos

Syntax

Get-DtVirtualNetworkInterfaceInfos[-SystemStateXML] <String> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-SystemStateXML<String>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Get-DtWorkload

Get-DtWorkload

Syntax

Get-DtWorkload[-WorkloadId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-WorkloadId<Guid>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Get-DtWorkloadPhysicalItem

Get-DtWorkloadPhysicalItem

Syntax

Get-DtWorkloadPhysicalItem[-RefItem] <PhysicalItem> [-WorkloadId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-RefItem<PhysicalItem>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-WorkloadId<Guid>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Get-DtWorkloadType

Get-DtWorkloadType

Syntax

Get-DtWorkloadType[-ServiceHost] <Server> [<CommonParameters>]

Parameters
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Install-DoubleTake

Install-DoubleTake

Syntax

Install-DoubleTake[-ActivationCode] <String[]> [-DiskQueueFolder] <String> [-DiskQueueLimit] <Nullable`1> [-DotNetPackagePath] <String> [-InstallationFolder] <String> [-MaxMemoryUsage] <Nullable`1> [-MinFreeDiskSpace] <Nullable`1> [-NoReboot] <SwitchParameter> [-PackageBaseFolder] <String> [-Schedule] <DateTime> [-SimultaneousFilePushLimit] <Nullable`1> [-TempFolder] <String> [-X64PackageFolder] <String> [-X86PackageFolder] <String> [-RemoteServer] <Server> [-AsJob] <SwitchParameter> [<CommonParameters>]

Install-DoubleTake[-ActivationCode] <String[]> [-DiskQueueFolder] <String> [-DiskQueueLimit] <Nullable`1> [-DotNetPackagePath] <String> [-InstallationFolder] <String> [-MaxMemoryUsage] <Nullable`1> [-MinFreeDiskSpace] <Nullable`1> [-PackageBaseFolder] <String> [-SimultaneousFilePushLimit] <Nullable`1> [-TempFolder] <String> [-X64PackageFolder] <String> [-X86PackageFolder] <String> [-LinuxPackageFolder] <String> [-RemoteServer] <Server> [-AsJob] <SwitchParameter> [<CommonParameters>]

Parameters
-ActivationCode<String[]>
Required? | true
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-DiskQueueFolder<String>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-DiskQueueLimit<Nullable`1>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-DotNetPackagePath<String>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-InstallationFolder<String>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-MaxMemoryUsage<Nullable`1>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-MinFreeDiskSpace<Nullable`1>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-NoReboot<SwitchParameter>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-PackageBaseFolder<String>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Schedule<DateTime>
Required? | true
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-SimultaneousFilePushLimit<Nullable`1>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-TempFolder<String>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-X64PackageFolder<String>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-X86PackageFolder<String>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-LinuxPackageFolder<String>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-RemoteServer<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByValue, ByPropertyName)
Accept Wildcard Characters? | false
-AsJob<SwitchParameter>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Invoke-DtAddShares

Invoke-DtAddShares

Syntax

Invoke-DtAddShares[-JobXmlPath] <String> [-SharePathFilter] <String> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-JobXmlPath<String>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-SharePathFilter<String>
Required? | false
Position? | 3
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Invoke-DtBootProcessingScrape

Invoke-DtBootProcessingScrape

Syntax

Invoke-DtBootProcessingScrape[-ServiceHost] <Server> [<CommonParameters>]

Parameters
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Invoke-DtInitializeDisk

Invoke-DtInitializeDisk

Syntax

Invoke-DtInitializeDisk[-ServiceHost] <Server> [-DiskInitInfo] <DiskInitializationInfo> [<CommonParameters>]

Parameters
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
-DiskInitInfo<DiskInitializationInfo>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Invoke-DtMakeBootable

Invoke-DtMakeBootable

Syntax

Invoke-DtMakeBootable[-BootProcInfo] <BootProcessingInfo> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-BootProcInfo<BootProcessingInfo>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Invoke-DtQueueTask

Invoke-DtQueueTask

Syntax

Invoke-DtQueueTask[-JobId] <Guid> [-OnQueue] <TaskParameters> [-OnTransmit] <TaskParameters> [-OnReceive] <TaskParameters> [-OnExecute] <TaskParameters> [-InteractWithDesktop] <SwitchParameter> [-Timeout] <TimeSpan> [-ConnectionId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Invoke-DtQueueTask[-JobInfo] <JobInfo> [-OnQueue] <TaskParameters> [-OnTransmit] <TaskParameters> [-OnReceive] <TaskParameters> [-OnExecute] <TaskParameters> [-InteractWithDesktop] <SwitchParameter> [-Timeout] <TimeSpan> [-ConnectionId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-OnQueue<TaskParameters>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-OnTransmit<TaskParameters>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-OnReceive<TaskParameters>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-OnExecute<TaskParameters>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-InteractWithDesktop<SwitchParameter>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Timeout<TimeSpan>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ConnectionId<Guid>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobId<Guid>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobInfo<JobInfo>
Required? | true
Position? | named
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Invoke-DtRemoveMountpoint

Invoke-DtRemoveMountpoint

Syntax

Invoke-DtRemoveMountpoint[-ServiceHost] <Server> [-MountPoint] <String> [<CommonParameters>]

Parameters
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
-MountPoint<String>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Invoke-DtRemoveShares

Invoke-DtRemoveShares

Syntax

Invoke-DtRemoveShares[-JobXmlPath] <String> [-SharePathFilter] <String> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-JobXmlPath<String>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-SharePathFilter<String>
Required? | false
Position? | 3
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Invoke-DtUnmountDisk

Invoke-DtUnmountDisk

Syntax

Invoke-DtUnmountDisk[-ServiceHost] <Server> [-DiskIdentifier] <String> [<CommonParameters>]

Parameters
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
-DiskIdentifier<String>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Invoke-DtUnmountVolumeFromMountpoint

Invoke-DtUnmountVolumeFromMountpoint

Syntax

Invoke-DtUnmountVolumeFromMountpoint[-ServiceHost] <Server> [-MountPoint] <String> [<CommonParameters>]

Parameters
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
-MountPoint<String>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Merge-DtConsoleServerData

Merge-DtConsoleServerData

Syntax

Merge-DtConsoleServerData[-ImportFilePath] <String> [-Replace] <SwitchParameter> [<CommonParameters>]

Parameters
-ImportFilePath<String>
Required? | true
Position? | 1
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Replace<SwitchParameter>
Required? | false
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


New-DtFilesAndFoldersJob

New-DtFilesAndFoldersJob

Syntax

New-DtFilesAndFoldersJob[-Source] <Server> [-Path] <String> [-TargetPath] <String> [-Name] <String> [-JobOptions] <JobOptions> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-Source<Server>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Path<String>
Required? | true
Position? | 3
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-TargetPath<String>
Required? | false
Position? | 4
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Name<String>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobOptions<JobOptions>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


New-DtJob

New-DtJob

Syntax

New-DtJob[-Source] <Server> [-JobType] <String> [-JobOptions] <JobOptions> [-OtherServers] <Server[]> [-ServiceHost] <Server> [<CommonParameters>]

New-DtJob[-CreateOptions] <CreateOptions> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-Source<Server>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobType<String>
Required? | true
Position? | 3
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobOptions<JobOptions>
Required? | true
Position? | 4
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-OtherServers<Server[]>
Required? | false
Position? | 5
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-CreateOptions<CreateOptions>
Required? | true
Position? | 2
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


New-DtServer

New-DtServer

Syntax

New-DtServer[-UserName] <String> [-Password] <String> [-Name] <String> [-Role] <String> [<CommonParameters>]

New-DtServer[-Credential] <PSCredential> [-Name] <String> [-Role] <String> [<CommonParameters>]

Parameters
-Name<String>
Required? | true
Position? | 1
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-UserName<String>
Required? | false
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Password<String>
Required? | false
Position? | 3
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Credential<PSCredential>
Required? | true
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Role<String>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


New-DtTaskParameters

New-DtTaskParameters

Syntax

New-DtTaskParameters[-ScriptPath] <String> [-Arguments] <String> [<CommonParameters>]

Parameters
-ScriptPath<String>
Required? | true
Position? | 1
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Arguments<String>
Required? | false
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


New-DtUri

New-DtUri

Syntax

New-DtUri[-Literal] <String> [<CommonParameters>]

New-DtUri[-NetworkId] <String> [-Credential] <PSCredential> [-Port] <Nullable`1> [-Scheme] <String> [-Query] <String> [-Fragment] <String> [<CommonParameters>]

Parameters
-Literal<String>
Required? | true
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-NetworkId<String>
Required? | true
Position? | 1
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Credential<PSCredential>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Port<Nullable`1>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Scheme<String>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Query<String>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Fragment<String>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


New-DtUvraServer

New-DtUvraServer

Syntax

New-DtUvraServer[-UserName] <String> [-Password] <String> [-Port] <Int32> [-Name] <String> [-Role] <String> [<CommonParameters>]

New-DtUvraServer[-Credential] <PSCredential> [-Port] <Int32> [-Name] <String> [-Role] <String> [<CommonParameters>]

Parameters
-Port<Int32>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Name<String>
Required? | true
Position? | 1
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-UserName<String>
Required? | false
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Password<String>
Required? | false
Position? | 3
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Credential<PSCredential>
Required? | true
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Role<String>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


New-DtWorkload

New-DtWorkload

Syntax

New-DtWorkload[-WorkloadTypeName] <String> [-ImageId] <Guid> [-SnapshotId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

New-DtWorkload[-Workload] <Workload> [-ImageId] <Guid> [-SnapshotId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-WorkloadTypeName<String>
Required? | true
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Workload<Workload>
Required? | true
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ImageId<Guid>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-SnapshotId<Guid>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Remove-DtJob

Remove-DtJob

Syntax

Remove-DtJob[-JobId] <Guid> [-DeleteOptions] <DeleteOptions> [-ServiceHost] <Server> [<CommonParameters>]

Remove-DtJob[-JobInfo] <JobInfo> [-DeleteOptions] <DeleteOptions> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-DeleteOptions<DeleteOptions>
Required? | false
Position? | 3
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobId<Guid>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobInfo<JobInfo>
Required? | true
Position? | named
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Remove-DtPhysicalRule

Remove-DtPhysicalRule

Syntax

Remove-DtPhysicalRule[-Rule] <PhysicalRule> [-WorkloadId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-Rule<PhysicalRule>
Required? | true
Position? | 3
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-WorkloadId<Guid>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Remove-DtSnapshot

Remove-DtSnapshot

Syntax

Remove-DtSnapshot[-Snapshot] <SnapshotEntry> [-JobId] <Guid> [-ConnectionId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Remove-DtSnapshot[-SnapshotId] <Guid> [-JobId] <Guid> [-ConnectionId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-JobId<Guid>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ConnectionId<Guid>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Snapshot<SnapshotEntry>
Required? | true
Position? | 3
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-SnapshotId<Guid>
Required? | true
Position? | 3
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Repair-DtJobOptions

Repair-DtJobOptions

Syntax

Repair-DtJobOptions[-JobId] <Guid> [-JobOptions] <JobOptions> [-Step] <VerificationStep[]> [-ServiceHost] <Server> [<CommonParameters>]

Repair-DtJobOptions[-CreateOptions] <CreateOptions> [-Step] <VerificationStep[]> [-ServiceHost] <Server> [<CommonParameters>]

Repair-DtJobOptions[-Source] <Server> [-JobType] <String> [-JobOptions] <JobOptions> [-Step] <VerificationStep[]> [-OtherServers] <Server[]> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-JobId<Guid>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-CreateOptions<CreateOptions>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Source<Server>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobType<String>
Required? | true
Position? | 3
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobOptions<JobOptions>
Required? | true
Position? | 3
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Step<VerificationStep[]>
Required? | true
Position? | 3
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-OtherServers<Server[]>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Request-DtOnlineActivation

Request-DtOnlineActivation

Syntax

Request-DtOnlineActivation[-Code] <String> [-ServerName] <String> [-ServerInformation] <String> [-ServiceHost] <Server> [-EmailAddress] <String> [<CommonParameters>]

Parameters
-Code<String>
Required? | true
Position? | named
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
-ServerName<String>
Required? | true
Position? | named
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
-ServerInformation<String>
Required? | true
Position? | named
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | false
Position? | named
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
-EmailAddress<String>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Request-DtOnlineDeactivation

Request-DtOnlineDeactivation

Syntax

Request-DtOnlineDeactivation[-ServiceHost] <Server> [-EmailAddress] <String> [<CommonParameters>]

Parameters
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
-EmailAddress<String>
Required? | false
Position? | 2
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Restart-DtReplicationService

Restart-DtReplicationService

Syntax

Restart-DtReplicationService[-ServiceHost] <Server> [<CommonParameters>]

Parameters
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Resume-DtJob

Resume-DtJob

Syntax

Resume-DtJob[-JobId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Resume-DtJob[-JobInfo] <JobInfo> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-JobId<Guid>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobInfo<JobInfo>
Required? | true
Position? | named
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Resume-DtMirror

Resume-DtMirror

Syntax

Resume-DtMirror[-JobId] <Guid> [-ConnectionId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Resume-DtMirror[-JobInfo] <JobInfo> [-ConnectionId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-ConnectionId<Guid>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobId<Guid>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobInfo<JobInfo>
Required? | true
Position? | named
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Resume-DtTarget

Resume-DtTarget

Syntax

Resume-DtTarget[-ServiceHost] <Server> [-JobInfo] <JobInfo> [-ConnectionId] <Guid> [<CommonParameters>]

Resume-DtTarget[-ServiceHost] <Server> [-All] <SwitchParameter> [<CommonParameters>]

Resume-DtTarget[-ServiceHost] <Server> [-JobId] <Guid> [-ConnectionId] <Guid> [<CommonParameters>]

Parameters
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-All<SwitchParameter>
Required? | true
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobId<Guid>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobInfo<JobInfo>
Required? | true
Position? | named
Accept Pipeline Input? | true (ByValue, ByPropertyName)
Accept Wildcard Characters? | false
-ConnectionId<Guid>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Save-DtConsoleServerData

Save-DtConsoleServerData

Syntax

Save-DtConsoleServerData[-FilePath] <String> [<CommonParameters>]

Parameters
-FilePath<String>
Required? | true
Position? | 1
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Save-DtJobDiagnostics

Save-DtJobDiagnostics

Syntax

Save-DtJobDiagnostics[-JobId] <Guid[]> [-ServiceHost] <Server> [<CommonParameters>]

Save-DtJobDiagnostics[-JobInfo] <JobInfo[]> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-JobId<Guid[]>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobInfo<JobInfo[]>
Required? | true
Position? | named
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Set-DtActivationCode

Set-DtActivationCode

Syntax

Set-DtActivationCode[-Code] <String[]> [-AdditionalCode] <String[]> [-ActivationKey] <String> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-Code<String[]>
Required? | true
Position? | 2
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
-AdditionalCode<String[]>
Required? | false
Position? | named
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
-ActivationKey<String>
Required? | false
Position? | named
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Set-DtBandwidthLimit

Set-DtBandwidthLimit

Syntax

Set-DtBandwidthLimit[-JobId] <Guid> [-BandwidthLimit] <BandwidthLimit> [-ConnectionId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Set-DtBandwidthLimit[-JobInfo] <JobInfo> [-BandwidthLimit] <BandwidthLimit> [-ConnectionId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-BandwidthLimit<BandwidthLimit>
Required? | true
Position? | 4
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ConnectionId<Guid>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobId<Guid>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobInfo<JobInfo>
Required? | true
Position? | named
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Set-DtEmailNotificationOptions

Set-DtEmailNotificationOptions

Syntax

Set-DtEmailNotificationOptions[-Options] <EmailNotificationOptions> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-Options<EmailNotificationOptions>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Set-DtJobCredentials

Set-DtJobCredentials

Syntax

Set-DtJobCredentials[-JobId] <Guid> [-Source] <PSCredential> [-Target] <PSCredential> [-OtherServers] <Server[]> [-ServiceHost] <Server> [<CommonParameters>]

Set-DtJobCredentials[-JobInfo] <JobInfo> [-Source] <PSCredential> [-Target] <PSCredential> [-OtherServers] <Server[]> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-Source<PSCredential>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Target<PSCredential>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-OtherServers<Server[]>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobId<Guid>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobInfo<JobInfo>
Required? | true
Position? | named
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Set-DtLogicalItemSelection

Set-DtLogicalItemSelection

Syntax

Set-DtLogicalItemSelection[-LogicalPath] <String> [-Unselect] <SwitchParameter> [-WorkloadId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-LogicalPath<String>
Required? | true
Position? | 3
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Unselect<SwitchParameter>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-WorkloadId<Guid>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Set-DtOption

Set-DtOption

Syntax

Set-DtOption[-Setting] <Hashtable> [-ServiceHost] <Server> [<CommonParameters>]

Set-DtOption[-Name] <String> [-MultiStringValue] <String[]> [-ServiceHost] <Server> [<CommonParameters>]

Set-DtOption[-Name] <String> [-IntValue] <Int64> [-ServiceHost] <Server> [<CommonParameters>]

Set-DtOption[-Name] <String> [-StringValue] <String> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-Setting<Hashtable>
Required? | true
Position? | 2
Accept Pipeline Input? | true (ByValue, ByPropertyName)
Accept Wildcard Characters? | false
-Name<String>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-IntValue<Int64>
Required? | true
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-StringValue<String>
Required? | true
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-MultiStringValue<String[]>
Required? | true
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Set-DtPathBlocking

Set-DtPathBlocking

Syntax

Set-DtPathBlocking[-SourceAddress] <String> [-Mode] <PathBlockingMode> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-SourceAddress<String>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Mode<PathBlockingMode>
Required? | false
Position? | 3
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Set-DtScriptCredentials

Set-DtScriptCredentials

Syntax

Set-DtScriptCredentials[-Credential] <PSCredential> [-ServiceHost] <Server> [<CommonParameters>]

Set-DtScriptCredentials[-UserName] <String> [-Password] <String> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-Credential<PSCredential>
Required? | true
Position? | 2
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-UserName<String>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Password<String>
Required? | true
Position? | 3
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Set-DtServerCredential

Set-DtServerCredential

Syntax

Set-DtServerCredential[-Input] <Server> [-Credential] <PSCredential> [<CommonParameters>]

Parameters
-Input<Server>
Required? | true
Position? | named
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-Credential<PSCredential>
Required? | true
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Start-DtJob

Start-DtJob

Syntax

Start-DtJob[-JobId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Start-DtJob[-JobInfo] <JobInfo> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-JobId<Guid>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobInfo<JobInfo>
Required? | true
Position? | named
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Start-DtJobFailback

Start-DtJobFailback

Syntax

Start-DtJobFailback[-JobId] <Guid> [-FailbackOptions] <FailbackOptions> [-ServiceHost] <Server> [<CommonParameters>]

Start-DtJobFailback[-JobInfo] <JobInfo> [-FailbackOptions] <FailbackOptions> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-FailbackOptions<FailbackOptions>
Required? | true
Position? | 3
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobId<Guid>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobInfo<JobInfo>
Required? | true
Position? | named
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Start-DtJobFailover

Start-DtJobFailover

Syntax

Start-DtJobFailover[-JobId] <Guid> [-FailoverOptions] <FailoverOptions> [-ServiceHost] <Server> [<CommonParameters>]

Start-DtJobFailover[-JobInfo] <JobInfo> [-FailoverOptions] <FailoverOptions> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-FailoverOptions<FailoverOptions>
Required? | true
Position? | 3
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobId<Guid>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobInfo<JobInfo>
Required? | true
Position? | named
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Start-DtJobRestore

Start-DtJobRestore

Syntax

Start-DtJobRestore[-JobId] <Guid> [-RestoreOptions] <RestoreOptions> [-ServiceHost] <Server> [<CommonParameters>]

Start-DtJobRestore[-JobInfo] <JobInfo> [-RestoreOptions] <RestoreOptions> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-RestoreOptions<RestoreOptions>
Required? | true
Position? | 3
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobId<Guid>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobInfo<JobInfo>
Required? | true
Position? | named
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Start-DtJobReverse

Start-DtJobReverse

Syntax

Start-DtJobReverse[-JobId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Start-DtJobReverse[-JobInfo] <JobInfo> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-JobId<Guid>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobInfo<JobInfo>
Required? | true
Position? | named
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Start-DtMirror

Start-DtMirror

Syntax

Start-DtMirror[-JobId] <Guid> [-MirrorParameters] <MirrorParameters> [-ConnectionId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Start-DtMirror[-JobInfo] <JobInfo> [-MirrorParameters] <MirrorParameters> [-ConnectionId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-MirrorParameters<MirrorParameters>
Required? | true
Position? | 3
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ConnectionId<Guid>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobId<Guid>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobInfo<JobInfo>
Required? | true
Position? | named
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Start-DtOrphansProcessing

Start-DtOrphansProcessing

Initiates an operation that will move or delete orphans

Syntax

Start-DtOrphansProcessing[-JobId] <Guid> [-ConnectionId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Start-DtOrphansProcessing[-JobInfo] <JobInfo> [-ConnectionId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-ConnectionId<Guid>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobId<Guid>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobInfo<JobInfo>
Required? | true
Position? | named
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Start-DtReplication

Start-DtReplication

Syntax

Start-DtReplication[-JobId] <Guid> [-ConnectionId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Start-DtReplication[-JobInfo] <JobInfo> [-ConnectionId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-ConnectionId<Guid>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobId<Guid>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobInfo<JobInfo>
Required? | true
Position? | named
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Start-DtVerify

Start-DtVerify

Syntax

Start-DtVerify[-JobId] <Guid> [-Synchronize] <SwitchParameter> [-Newer] <SwitchParameter> [-Checksum] <SwitchParameter> [-ProcessOrphans] <SwitchParameter> [-ConnectionId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Start-DtVerify[-JobInfo] <JobInfo> [-Synchronize] <SwitchParameter> [-Newer] <SwitchParameter> [-Checksum] <SwitchParameter> [-ProcessOrphans] <SwitchParameter> [-ConnectionId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-Synchronize<SwitchParameter>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Newer<SwitchParameter>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Checksum<SwitchParameter>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ProcessOrphans<SwitchParameter>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ConnectionId<Guid>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobId<Guid>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobInfo<JobInfo>
Required? | true
Position? | named
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Stop-DtJob

Stop-DtJob

Syntax

Stop-DtJob[-JobId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Stop-DtJob[-JobInfo] <JobInfo> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-JobId<Guid>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobInfo<JobInfo>
Required? | true
Position? | named
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Stop-DtMirror

Stop-DtMirror

Syntax

Stop-DtMirror[-JobId] <Guid> [-ConnectionId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Stop-DtMirror[-JobInfo] <JobInfo> [-ConnectionId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-ConnectionId<Guid>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobId<Guid>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobInfo<JobInfo>
Required? | true
Position? | named
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Stop-DtReplication

Stop-DtReplication

Syntax

Stop-DtReplication[-JobId] <Guid> [-ConnectionId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Stop-DtReplication[-JobInfo] <JobInfo> [-ConnectionId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-ConnectionId<Guid>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobId<Guid>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobInfo<JobInfo>
Required? | true
Position? | named
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Stop-DtReplicationService

Stop-DtReplicationService

Syntax

Stop-DtReplicationService[-ServiceHost] <Server> [<CommonParameters>]

Parameters
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Suspend-DtJob

Suspend-DtJob

Syntax

Suspend-DtJob[-JobId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Suspend-DtJob[-JobInfo] <JobInfo> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-JobId<Guid>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobInfo<JobInfo>
Required? | true
Position? | named
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Suspend-DtMirror

Suspend-DtMirror

Syntax

Suspend-DtMirror[-JobId] <Guid> [-ConnectionId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Suspend-DtMirror[-JobInfo] <JobInfo> [-ConnectionId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-ConnectionId<Guid>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobId<Guid>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobInfo<JobInfo>
Required? | true
Position? | named
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Suspend-DtTarget

Suspend-DtTarget

Syntax

Suspend-DtTarget[-ServiceHost] <Server> [-JobInfo] <JobInfo> [-ConnectionId] <Guid> [<CommonParameters>]

Suspend-DtTarget[-ServiceHost] <Server> [-All] <SwitchParameter> [<CommonParameters>]

Suspend-DtTarget[-ServiceHost] <Server> [-JobId] <Guid> [-ConnectionId] <Guid> [<CommonParameters>]

Parameters
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-All<SwitchParameter>
Required? | true
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobId<Guid>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobInfo<JobInfo>
Required? | true
Position? | named
Accept Pipeline Input? | true (ByValue, ByPropertyName)
Accept Wildcard Characters? | false
-ConnectionId<Guid>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Test-DtActiveDirectoryCredentials

Test-DtActiveDirectoryCredentials

Syntax

Test-DtActiveDirectoryCredentials[-Credential] <PSCredential> [-ComputerDomain] <String> [-ComputerName] <String> [-ServiceHost] <Server> [<CommonParameters>]

Test-DtActiveDirectoryCredentials[-UserName] <String> [-Password] <String> [-ComputerDomain] <String> [-ComputerName] <String> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-ComputerDomain<String>
Required? | true
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ComputerName<String>
Required? | true
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Credential<PSCredential>
Required? | true
Position? | 2
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-UserName<String>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Password<String>
Required? | true
Position? | 3
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Test-DtEmailNotification

Test-DtEmailNotification

Syntax

Test-DtEmailNotification[-Options] <EmailNotificationOptions> [-To] <String> [-Body] <String> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-Options<EmailNotificationOptions>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-To<String>
Required? | true
Position? | 3
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Body<String>
Required? | true
Position? | 4
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Test-DtScript

Test-DtScript

Syntax

Test-DtScript[-Path] <String> [-Arguments] <String> [-InteractionMode] <DesktopInteractionMode> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-Path<String>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Arguments<String>
Required? | false
Position? | 3
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-InteractionMode<DesktopInteractionMode>
Required? | false
Position? | 4
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Test-DtScriptCredentials

Test-DtScriptCredentials

Syntax

Test-DtScriptCredentials[-Credential] <PSCredential> [-ServiceHost] <Server> [<CommonParameters>]

Test-DtScriptCredentials[-UserName] <String> [-Password] <String> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-Credential<PSCredential>
Required? | true
Position? | 2
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-UserName<String>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Password<String>
Required? | true
Position? | 3
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Undo-DtJobFailover

Undo-DtJobFailover

Syntax

Undo-DtJobFailover[-JobId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Undo-DtJobFailover[-JobInfo] <JobInfo> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-JobId<Guid>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobInfo<JobInfo>
Required? | true
Position? | named
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Uninstall-DoubleTake

Uninstall-DoubleTake

Syntax

Uninstall-DoubleTake[-RemoteServer] <Server> [-AsJob] <SwitchParameter> [<CommonParameters>]

Parameters
-RemoteServer<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByValue, ByPropertyName)
Accept Wildcard Characters? | false
-AsJob<SwitchParameter>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Update-DtShares

Update-DtShares

Syntax

Update-DtShares[-JobId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Update-DtShares[-JobInfo] <JobInfo> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-JobId<Guid>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobInfo<JobInfo>
Required? | true
Position? | named
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Wait-DtConfirmJobOptions

Wait-DtConfirmJobOptions

Syntax

Wait-DtConfirmJobOptions[-Token] <ActivityToken> [-Any] <SwitchParameter> [-Timeout] <Int32> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-Token<ActivityToken>
Required? | true
Position? | named
Accept Pipeline Input? | true (ByValue, ByPropertyName)
Accept Wildcard Characters? | false
-Any<SwitchParameter>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Timeout<Int32>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Wait-DtMirrorComplete

Wait-DtMirrorComplete

Syntax

Wait-DtMirrorComplete[-JobId] <Guid> [-PollingInterval] <Nullable`1> [-ConnectionId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Wait-DtMirrorComplete[-JobInfo] <JobInfo> [-PollingInterval] <Nullable`1> [-ConnectionId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-PollingInterval<Nullable`1>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ConnectionId<Guid>
Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobId<Guid>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobInfo<JobInfo>
Required? | true
Position? | named
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-ServiceHost<Server>
Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


DoubleTake.Common.Contract Namespace

DoubleTake.Common.Contract Namespace
Classes
 | Class | Description
Public class | AccessLevelRequiredFault |
Public class | ArgumentFault | Represents a fault that is thrown when one of the arguments to a method is not valid.
Public class | ChangedItems | Indicates the workload items whose status changed as the result of modifying a workload.
Public class | CommonFault | Represents a fault that is thrown when there is an error executing a management service method.
Public class | Credentials | Represents credentials used to authenticate with a service.
Public class | DashboardEngineOptions |
Public class | DirectoryItem | Represents a directory item.
Public class | EmailNotificationOptions |
Public class | EngineCommandFailedFault | Represents a fault that is thrown when the engine is unable to execute a command.
Public class | EngineCommunicationFault | Represents a fault thrown when the management service cannot communicate with the engine.
Public class | FileItem | Represents a file item.
Public class | FileSystemItem | Represents a file system item.
Public class | InvalidEmailAddressFormatFault | Represents a fault thrown when an invalid email address is specified for an operation.
Public class | InvalidOperationFault | Represents a fault that is thrown when a method call is invalid for the service's current state.
Public class | LogicalItem | Represents an item that can be protected in workload. Logical items are meaningful to the user outside of a specific file system item.
Public class | NameValuePair | Represents a generic name-value pair data structure.
Public class | PathTransformation | Represents a transform path for a replication rule.
Public class | PhysicalItem | Represents an item that can be protected in workload. Physical items map directly to file system items.
Public class | PhysicalRule | Defines a physical rule for replicating data.
Public class | PropertyBag | A container for name-value pairs where the value can be any of the primitive data types.
Public class | ProtectableItemTypes | Defines constants that represent known types of protectable items. These constants are used as values for the ItemType property.
Public class | Volume | Represents a volume on a server.
Public class | Workload | Describes the data on a server that will be protected as part of a job.
Public class | WorkloadSupportSummary | Represents a summary of the licensing determination process for a workload type.
Public class | WorkloadType | Describes the type of workloads that can be created on a server.
Public class | WorkloadTypeNames | Defines constants that represent known workload type names. These constants are used as values for the Name property.
Interfaces
 | Interface | Description
Public interface | ICommonFault | Defines common aspects of all faults thrown by management service methods.
Public interface | IProtectableItem | Defines a common interface between LogicalItem and PhysicalItem.
Public interface | IWorkloadManager | Provides methods for creating and managing workloads on a server.
Enumerations
 | Enumeration | Description
Public enumeration | FileSystemAttributes | Describes the attributes of a file system item.
Public enumeration | InclusionMode | Indicates whether a certain data path in a workload should be replicated.
Public enumeration | RecursionMode | Indicates whether recursion is used when replicating a data path.
Public enumeration | SaturationLevel | Indicates the saturation level of a protectable item.
Public enumeration | ServerRegistrationMethod |
Public enumeration | SmtpConnectionSecurity |
Public enumeration | ValidateActiveDirectoryCredentialsResult |


AccessLevelRequiredFault Class

AccessLevelRequiredFault Class
Inheritance Hierarchy
SystemObject
DoubleTake.Common.ContractAccessLevelRequiredFault

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public sealed class AccessLevelRequiredFault : ICommonFault,
    IExtensibleDataObject
Public NotInheritable Class AccessLevelRequiredFault
    Implements ICommonFault, IExtensibleDataObject
public ref class AccessLevelRequiredFault sealed : ICommonFault,
    IExtensibleDataObject
DoubleTake.Common.Contract.AccessLevelRequiredFault = function();

Type.createClass(
    'DoubleTake.Common.Contract.AccessLevelRequiredFault',
    null,
    DoubleTake.Common.Contract.ICommonFault,
    IExtensibleDataObject);

The AccessLevelRequiredFault type exposes the following members.

Constructors
 | Name | Description
Public method | AccessLevelRequiredFault | Initializes a new instance of the AccessLevelRequiredFault class
Top
Properties
 | Name | Description
Public property | CurrentAccessLevel | Gets or sets the current access level.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | InnerFault | Gets or sets the inner fault.
Public property | Message | Gets or sets the fault error message.
Public property | Name | Gets or sets the name of the fault.
Public property | RequiredAccessLevel | Gets or sets the access level required to perform the requested operation.
Public property | StackTrace | Gets or sets the stack trace on the service that indicates where an unhandled exception occurred.
Top
See Also

Reference

DoubleTake.Common.Contract Namespace


AccessLevelRequiredFault Constructor

AccessLevelRequiredFault Constructor
Initializes a new instance of the AccessLevelRequiredFault class

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public AccessLevelRequiredFault()
Public Sub New
public:
AccessLevelRequiredFault()
DoubleTake.Common.Contract.AccessLevelRequiredFault = function();
See Also

Reference

AccessLevelRequiredFault Class
DoubleTake.Common.Contract Namespace


AccessLevelRequiredFault Properties

AccessLevelRequiredFault Properties

The AccessLevelRequiredFault type exposes the following members.

Properties
 | Name | Description
Public property | CurrentAccessLevel | Gets or sets the current access level.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | InnerFault | Gets or sets the inner fault.
Public property | Message | Gets or sets the fault error message.
Public property | Name | Gets or sets the name of the fault.
Public property | RequiredAccessLevel | Gets or sets the access level required to perform the requested operation.
Public property | StackTrace | Gets or sets the stack trace on the service that indicates where an unhandled exception occurred.
Top
See Also

Reference

AccessLevelRequiredFault Class
DoubleTake.Common.Contract Namespace


AccessLevelRequiredFault.CurrentAccessLevel Property

AccessLevelRequiredFaultCurrentAccessLevel Property
Gets or sets the current access level.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public AccessLevel CurrentAccessLevel { get; set; }
Public Property CurrentAccessLevel As AccessLevel
    Get
    Set
public:
property AccessLevel CurrentAccessLevel {
    AccessLevel get ();
    void set (AccessLevel value);
}
function get_CurrentAccessLevel();
function set_CurrentAccessLevel(value);

Property Value

Type: AccessLevel
The current access level.
See Also

Reference

AccessLevelRequiredFault Class
DoubleTake.Common.Contract Namespace


AccessLevelRequiredFault.ExtensionData Property

AccessLevelRequiredFaultExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

AccessLevelRequiredFault Class
DoubleTake.Common.Contract Namespace


AccessLevelRequiredFault.InnerFault Property

AccessLevelRequiredFaultInnerFault Property
Gets or sets the inner fault.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ICommonFault InnerFault { get; set; }
Public Property InnerFault As ICommonFault
    Get
    Set
public:
virtual property ICommonFault^ InnerFault {
    ICommonFault^ get () sealed;
    void set (ICommonFault^ value) sealed;
}
function get_InnerFault();
function set_InnerFault(value);

Property Value

Type: ICommonFault
The inner fault.

Implements

ICommonFaultInnerFault
Remarks
Populate this property if this fault was triggered by another fault and you need to convey the information from that fault up to the consumer.
See Also

Reference

AccessLevelRequiredFault Class
DoubleTake.Common.Contract Namespace


AccessLevelRequiredFault.Message Property

AccessLevelRequiredFaultMessage Property
Gets or sets the fault error message.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Message { get; set; }
Public Property Message As String
    Get
    Set
public:
virtual property String^ Message {
    String^ get () sealed;
    void set (String^ value) sealed;
}
function get_Message();
function set_Message(value);

Property Value

Type: String
The fault error message.

Implements

ICommonFaultMessage
See Also

Reference

AccessLevelRequiredFault Class
DoubleTake.Common.Contract Namespace


AccessLevelRequiredFault.Name Property

AccessLevelRequiredFaultName Property
Gets or sets the name of the fault.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get () sealed;
    void set (String^ value) sealed;
}
function get_Name();
function set_Name(value);

Property Value

Type: String
The name of the fault.

Implements

ICommonFaultName
See Also

Reference

AccessLevelRequiredFault Class
DoubleTake.Common.Contract Namespace


AccessLevelRequiredFault.RequiredAccessLevel Property

AccessLevelRequiredFaultRequiredAccessLevel Property
Gets or sets the access level required to perform the requested operation.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public AccessLevel RequiredAccessLevel { get; set; }
Public Property RequiredAccessLevel As AccessLevel
    Get
    Set
public:
property AccessLevel RequiredAccessLevel {
    AccessLevel get ();
    void set (AccessLevel value);
}
function get_RequiredAccessLevel();
function set_RequiredAccessLevel(value);

Property Value

Type: AccessLevel
The access level required to perform the requested operation.
See Also

Reference

AccessLevelRequiredFault Class
DoubleTake.Common.Contract Namespace


AccessLevelRequiredFault.StackTrace Property

AccessLevelRequiredFaultStackTrace Property
Gets or sets the stack trace on the service that indicates where an unhandled exception occurred.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string StackTrace { get; set; }
Public Property StackTrace As String
    Get
    Set
public:
virtual property String^ StackTrace {
    String^ get () sealed;
    void set (String^ value) sealed;
}
function get_StackTrace();
function set_StackTrace(value);

Property Value

Type: String
The stack trace.

Implements

ICommonFaultStackTrace
See Also

Reference

AccessLevelRequiredFault Class
DoubleTake.Common.Contract Namespace


ArgumentFault Class

ArgumentFault Class
Represents a fault that is thrown when one of the arguments to a method is not valid.
Inheritance Hierarchy
SystemObject
DoubleTake.Common.ContractArgumentFault

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public sealed class ArgumentFault : ICommonFault,
    IExtensibleDataObject
Public NotInheritable Class ArgumentFault
    Implements ICommonFault, IExtensibleDataObject
public ref class ArgumentFault sealed : ICommonFault,
    IExtensibleDataObject
DoubleTake.Common.Contract.ArgumentFault = function();

Type.createClass(
    'DoubleTake.Common.Contract.ArgumentFault',
    null,
    DoubleTake.Common.Contract.ICommonFault,
    IExtensibleDataObject);

The ArgumentFault type exposes the following members.

Constructors
 | Name | Description
Public method | ArgumentFault | Initializes a new instance of the ArgumentFault class
Top
Properties
 | Name | Description
Public property | ActualValue | Gets or sets the actual value of the parameter that is not valid.
Public property | ExceptionType | Gets or sets the type of the exception that triggered this fault.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | InnerFault | Gets or sets the inner fault.
Public property | Message | Gets or sets the fault error message.
Public property | Name | Gets or sets the name of the fault.
Public property | ParameterName | Gets or sets the name of the parameter that is not valid.
Public property | StackTrace | Gets or sets the stack trace from the service that indicates where an unhandled exception occurred.
Top
See Also

Reference

DoubleTake.Common.Contract Namespace


ArgumentFault Constructor

ArgumentFault Constructor
Initializes a new instance of the ArgumentFault class

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ArgumentFault()
Public Sub New
public:
ArgumentFault()
DoubleTake.Common.Contract.ArgumentFault = function();
See Also

Reference

ArgumentFault Class
DoubleTake.Common.Contract Namespace


ArgumentFault Properties

ArgumentFault Properties

The ArgumentFault type exposes the following members.

Properties
 | Name | Description
Public property | ActualValue | Gets or sets the actual value of the parameter that is not valid.
Public property | ExceptionType | Gets or sets the type of the exception that triggered this fault.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | InnerFault | Gets or sets the inner fault.
Public property | Message | Gets or sets the fault error message.
Public property | Name | Gets or sets the name of the fault.
Public property | ParameterName | Gets or sets the name of the parameter that is not valid.
Public property | StackTrace | Gets or sets the stack trace from the service that indicates where an unhandled exception occurred.
Top
See Also

Reference

ArgumentFault Class
DoubleTake.Common.Contract Namespace


ArgumentFault.ActualValue Property

ArgumentFaultActualValue Property
Gets or sets the actual value of the parameter that is not valid.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string ActualValue { get; set; }
Public Property ActualValue As String
    Get
    Set
public:
property String^ ActualValue {
    String^ get ();
    void set (String^ value);
}
function get_ActualValue();
function set_ActualValue(value);

Property Value

Type: String
The actual value of the parameter that is not valid.
See Also

Reference

ArgumentFault Class
DoubleTake.Common.Contract Namespace


ArgumentFault.ExceptionType Property

ArgumentFaultExceptionType Property
Gets or sets the type of the exception that triggered this fault.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string ExceptionType { get; set; }
Public Property ExceptionType As String
    Get
    Set
public:
property String^ ExceptionType {
    String^ get ();
    void set (String^ value);
}
function get_ExceptionType();
function set_ExceptionType(value);

Property Value

Type: String
The type of the exception that triggered this fault.
Remarks
Possible values are as follows:
Exception type | Description
ArgumentException | The specified parameter is not valid.
ArgumentNullException | The specified parameter is when is not valid.
ArgumentOutOfRangeException | The specified parameter is outside the allowable range as defined by this method.
See Also

Reference

ArgumentFault Class
DoubleTake.Common.Contract Namespace


ArgumentFault.ExtensionData Property

ArgumentFaultExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

ArgumentFault Class
DoubleTake.Common.Contract Namespace


ArgumentFault.InnerFault Property

ArgumentFaultInnerFault Property
Gets or sets the inner fault.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ICommonFault InnerFault { get; set; }
Public Property InnerFault As ICommonFault
    Get
    Set
public:
virtual property ICommonFault^ InnerFault {
    ICommonFault^ get () sealed;
    void set (ICommonFault^ value) sealed;
}
function get_InnerFault();
function set_InnerFault(value);

Property Value

Type: ICommonFault
An instance of ICommonFault that represents the inner fault.

Implements

ICommonFaultInnerFault
Remarks
This property contains a value if this fault was triggered by another fault that is of interest to the caller.
See Also

Reference

ArgumentFault Class
DoubleTake.Common.Contract Namespace


ArgumentFault.Message Property

ArgumentFaultMessage Property
Gets or sets the fault error message.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Message { get; set; }
Public Property Message As String
    Get
    Set
public:
virtual property String^ Message {
    String^ get () sealed;
    void set (String^ value) sealed;
}
function get_Message();
function set_Message(value);

Property Value

Type: String
The fault error message.

Implements

ICommonFaultMessage
See Also

Reference

ArgumentFault Class
DoubleTake.Common.Contract Namespace


ArgumentFault.Name Property

ArgumentFaultName Property
Gets or sets the name of the fault.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get () sealed;
    void set (String^ value) sealed;
}
function get_Name();
function set_Name(value);

Property Value

Type: String
The name of the fault.

Implements

ICommonFaultName
See Also

Reference

ArgumentFault Class
DoubleTake.Common.Contract Namespace


ArgumentFault.ParameterName Property

ArgumentFaultParameterName Property
Gets or sets the name of the parameter that is not valid.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string ParameterName { get; set; }
Public Property ParameterName As String
    Get
    Set
public:
property String^ ParameterName {
    String^ get ();
    void set (String^ value);
}
function get_ParameterName();
function set_ParameterName(value);

Property Value

Type: String
The name of the parameter that is not valid.
See Also

Reference

ArgumentFault Class
DoubleTake.Common.Contract Namespace


ArgumentFault.StackTrace Property

ArgumentFaultStackTrace Property
Gets or sets the stack trace from the service that indicates where an unhandled exception occurred.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string StackTrace { get; set; }
Public Property StackTrace As String
    Get
    Set
public:
virtual property String^ StackTrace {
    String^ get () sealed;
    void set (String^ value) sealed;
}
function get_StackTrace();
function set_StackTrace(value);

Property Value

Type: String
The stack trace from the service.

Implements

ICommonFaultStackTrace
See Also

Reference

ArgumentFault Class
DoubleTake.Common.Contract Namespace


ChangedItems Class

ChangedItems Class
Indicates the workload items whose status changed as the result of modifying a workload.
Inheritance Hierarchy
SystemObject
DoubleTake.Common.ContractChangedItems

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class ChangedItems : IExtensibleDataObject
Public Class ChangedItems
    Implements IExtensibleDataObject
public ref class ChangedItems : IExtensibleDataObject
DoubleTake.Common.Contract.ChangedItems = function();

Type.createClass(
    'DoubleTake.Common.Contract.ChangedItems',
    null,
    IExtensibleDataObject);

The ChangedItems type exposes the following members.

Constructors
 | Name | Description
Public method | ChangedItems | Initializes a new instance of the ChangedItems class
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | LogicalItems | This value represents the logical items that changed.
Public property | LogicalRules | This value is the current logical rules of the workload.
Public property | PhysicalItems | This value represents the physical items that changed.
Public property | PhysicalRules | This value represents the current physical rules of the workload.
Top
See Also

Reference

DoubleTake.Common.Contract Namespace


ChangedItems Constructor

ChangedItems Constructor
Initializes a new instance of the ChangedItems class

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ChangedItems()
Public Sub New
public:
ChangedItems()
DoubleTake.Common.Contract.ChangedItems = function();
See Also

Reference

ChangedItems Class
DoubleTake.Common.Contract Namespace


ChangedItems Properties

ChangedItems Properties

The ChangedItems type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | LogicalItems | This value represents the logical items that changed.
Public property | LogicalRules | This value is the current logical rules of the workload.
Public property | PhysicalItems | This value represents the physical items that changed.
Public property | PhysicalRules | This value represents the current physical rules of the workload.
Top
See Also

Reference

ChangedItems Class
DoubleTake.Common.Contract Namespace


ChangedItems.ExtensionData Property

ChangedItemsExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

ChangedItems Class
DoubleTake.Common.Contract Namespace


ChangedItems.LogicalItems Property

ChangedItemsLogicalItems Property
This value represents the logical items that changed.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public LogicalItem[] LogicalItems { get; set; }
Public Property LogicalItems As LogicalItem()
    Get
    Set
public:
property array<LogicalItem^>^ LogicalItems {
    array<LogicalItem^>^ get ();
    void set (array<LogicalItem^>^ value);
}
function get_LogicalItems();
function set_LogicalItems(value);

Property Value

Type: LogicalItem
An array of LogicalItem that indicates the logical items that changed.
See Also

Reference

ChangedItems Class
DoubleTake.Common.Contract Namespace


ChangedItems.LogicalRules Property

ChangedItemsLogicalRules Property
This value is the current logical rules of the workload.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string[] LogicalRules { get; set; }
Public Property LogicalRules As String()
    Get
    Set
public:
property array<String^>^ LogicalRules {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
function get_LogicalRules();
function set_LogicalRules(value);

Property Value

Type: String
An array of String that represents the current logical rules of this workload.
See Also

Reference

ChangedItems Class
DoubleTake.Common.Contract Namespace


ChangedItems.PhysicalItems Property

ChangedItemsPhysicalItems Property
This value represents the physical items that changed.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public PhysicalItem[] PhysicalItems { get; set; }
Public Property PhysicalItems As PhysicalItem()
    Get
    Set
public:
property array<PhysicalItem^>^ PhysicalItems {
    array<PhysicalItem^>^ get ();
    void set (array<PhysicalItem^>^ value);
}
function get_PhysicalItems();
function set_PhysicalItems(value);

Property Value

Type: PhysicalItem
An array of PhysicalItem that indicates the physical items that changed.
See Also

Reference

ChangedItems Class
DoubleTake.Common.Contract Namespace


ChangedItems.PhysicalRules Property

ChangedItemsPhysicalRules Property
This value represents the current physical rules of the workload.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public PhysicalRule[] PhysicalRules { get; set; }
Public Property PhysicalRules As PhysicalRule()
    Get
    Set
public:
property array<PhysicalRule^>^ PhysicalRules {
    array<PhysicalRule^>^ get ();
    void set (array<PhysicalRule^>^ value);
}
function get_PhysicalRules();
function set_PhysicalRules(value);

Property Value

Type: PhysicalRule
An array of PhysicalRule that represents the current physical rules of this workload.
See Also

Reference

ChangedItems Class
DoubleTake.Common.Contract Namespace


CommonFault Class

CommonFault Class
Represents a fault that is thrown when there is an error executing a management service method.
Inheritance Hierarchy
SystemObject
DoubleTake.Common.ContractCommonFault

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public sealed class CommonFault : ICommonFault,
    IExtensibleDataObject
Public NotInheritable Class CommonFault
    Implements ICommonFault, IExtensibleDataObject
public ref class CommonFault sealed : ICommonFault,
    IExtensibleDataObject
DoubleTake.Common.Contract.CommonFault = function();

Type.createClass(
    'DoubleTake.Common.Contract.CommonFault',
    null,
    DoubleTake.Common.Contract.ICommonFault,
    IExtensibleDataObject);

The CommonFault type exposes the following members.

Constructors
 | Name | Description
Public method | CommonFault | Initializes a new instance of the CommonFault class
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | InnerFault | Gets or sets the inner fault.
Public property | Message | Gets or sets the fault error message.
Public property | Name | Gets or sets the name of the fault.
Public property | StackTrace | Gets or sets the stack trace from the service that indicates where an unhandled exception occurred.
Top
See Also

Reference

DoubleTake.Common.Contract Namespace


CommonFault Constructor

CommonFault Constructor
Initializes a new instance of the CommonFault class

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public CommonFault()
Public Sub New
public:
CommonFault()
DoubleTake.Common.Contract.CommonFault = function();
See Also

Reference

CommonFault Class
DoubleTake.Common.Contract Namespace


CommonFault Properties

CommonFault Properties

The CommonFault type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | InnerFault | Gets or sets the inner fault.
Public property | Message | Gets or sets the fault error message.
Public property | Name | Gets or sets the name of the fault.
Public property | StackTrace | Gets or sets the stack trace from the service that indicates where an unhandled exception occurred.
Top
See Also

Reference

CommonFault Class
DoubleTake.Common.Contract Namespace


CommonFault.ExtensionData Property

CommonFaultExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

CommonFault Class
DoubleTake.Common.Contract Namespace


CommonFault.InnerFault Property

CommonFaultInnerFault Property
Gets or sets the inner fault.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ICommonFault InnerFault { get; set; }
Public Property InnerFault As ICommonFault
    Get
    Set
public:
virtual property ICommonFault^ InnerFault {
    ICommonFault^ get () sealed;
    void set (ICommonFault^ value) sealed;
}
function get_InnerFault();
function set_InnerFault(value);

Property Value

Type: ICommonFault
An instance of ICommonFault that represents the inner fault.

Implements

ICommonFaultInnerFault
Remarks
This property contains a value if this fault was triggered by another fault that is of interest to the caller.
See Also

Reference

CommonFault Class
DoubleTake.Common.Contract Namespace


CommonFault.Message Property

CommonFaultMessage Property
Gets or sets the fault error message.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Message { get; set; }
Public Property Message As String
    Get
    Set
public:
virtual property String^ Message {
    String^ get () sealed;
    void set (String^ value) sealed;
}
function get_Message();
function set_Message(value);

Property Value

Type: String
The fault error message.

Implements

ICommonFaultMessage
See Also

Reference

CommonFault Class
DoubleTake.Common.Contract Namespace


CommonFault.Name Property

CommonFaultName Property
Gets or sets the name of the fault.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get () sealed;
    void set (String^ value) sealed;
}
function get_Name();
function set_Name(value);

Property Value

Type: String
The name of the fault.

Implements

ICommonFaultName
See Also

Reference

CommonFault Class
DoubleTake.Common.Contract Namespace


CommonFault.StackTrace Property

CommonFaultStackTrace Property
Gets or sets the stack trace from the service that indicates where an unhandled exception occurred.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string StackTrace { get; set; }
Public Property StackTrace As String
    Get
    Set
public:
virtual property String^ StackTrace {
    String^ get () sealed;
    void set (String^ value) sealed;
}
function get_StackTrace();
function set_StackTrace(value);

Property Value

Type: String
The stack trace from the service.

Implements

ICommonFaultStackTrace
See Also

Reference

CommonFault Class
DoubleTake.Common.Contract Namespace


Credentials Class

Credentials Class
Represents credentials used to authenticate with a service.
Inheritance Hierarchy
SystemObject
DoubleTake.Common.ContractCredentials

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class Credentials : IExtensibleDataObject
Public Class Credentials
    Implements IExtensibleDataObject
public ref class Credentials : IExtensibleDataObject
DoubleTake.Common.Contract.Credentials = function();

Type.createClass(
    'DoubleTake.Common.Contract.Credentials',
    null,
    IExtensibleDataObject);

The Credentials type exposes the following members.

Constructors
 | Name | Description
Public method | Credentials | Initializes a new instance of the Credentials class.
Public method | Credentials(NetworkCredential) | Initializes a new instance of the Credentials class.
Public method | Credentials(String, String, String) | Initializes a new instance of the Credentials class
Top
Properties
 | Name | Description
Public property | Domain | This value is the name of the domain.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Password | This value is the password.
Public property | UserName | This value is the name of the user.
Top
Methods
 | Name | Description
Public method | GetDeserializedObject |
Public method | GetObjectToSerialize |
Top
Operators
Name | Description
(Credentials to NetworkCredential) | Performs an implicit conversion from Credentials to NetworkCredential.
Top
See Also

Reference

DoubleTake.Common.Contract Namespace


Credentials Constructor

Credentials Constructor
Overload List
 | Name | Description
Public method | Credentials | Initializes a new instance of the Credentials class.
Public method | Credentials(NetworkCredential) | Initializes a new instance of the Credentials class.
Public method | Credentials(String, String, String) | Initializes a new instance of the Credentials class
Top
See Also

Reference

Credentials Class
DoubleTake.Common.Contract Namespace


Credentials Constructor

Credentials Constructor
Initializes a new instance of the Credentials class.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Credentials()
Public Sub New
public:
Credentials()
DoubleTake.Common.Contract.Credentials = function();
See Also

Reference

Credentials Class
Credentials Overload
DoubleTake.Common.Contract Namespace


Credentials Constructor (NetworkCredential)

Credentials Constructor (NetworkCredential)
Initializes a new instance of the Credentials class.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Credentials(
    NetworkCredential credentials
)
Public Sub New (
    credentials As NetworkCredential
)
public:
Credentials(
    NetworkCredential^ credentials
)
DoubleTake.Common.Contract.Credentials = function(credentials);

Parameters

credentials
Type: System.NetNetworkCredential
The credentials.
See Also

Reference

Credentials Class
Credentials Overload
DoubleTake.Common.Contract Namespace


Credentials Constructor (String, String, String)

Credentials Constructor (String, String, String)
Initializes a new instance of the Credentials class

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Credentials(
    string userName,
    string password,
    string domain
)
Public Sub New (
    userName As String,
    password As String,
    domain As String
)
public:
Credentials(
    String^ userName,
    String^ password,
    String^ domain
)
DoubleTake.Common.Contract.Credentials = function(userName, password, domain);

Parameters

userName
Type: SystemString
password
Type: SystemString
domain
Type: SystemString
See Also

Reference

Credentials Class
Credentials Overload
DoubleTake.Common.Contract Namespace


Credentials Properties

Credentials Properties

The Credentials type exposes the following members.

Properties
 | Name | Description
Public property | Domain | This value is the name of the domain.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Password | This value is the password.
Public property | UserName | This value is the name of the user.
Top
See Also

Reference

Credentials Class
DoubleTake.Common.Contract Namespace


Credentials.Domain Property

CredentialsDomain Property
This value is the name of the domain.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Domain { get; set; }
Public Property Domain As String
    Get
    Set
public:
property String^ Domain {
    String^ get ();
    void set (String^ value);
}
function get_Domain();
function set_Domain(value);

Property Value

Type: String
The domain.
See Also

Reference

Credentials Class
DoubleTake.Common.Contract Namespace


Credentials.ExtensionData Property

CredentialsExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

Credentials Class
DoubleTake.Common.Contract Namespace


Credentials.Password Property

CredentialsPassword Property
This value is the password.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Password { get; set; }
Public Property Password As String
    Get
    Set
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}
function get_Password();
function set_Password(value);

Property Value

Type: String
The password.
See Also

Reference

Credentials Class
DoubleTake.Common.Contract Namespace


Credentials.UserName Property

CredentialsUserName Property
This value is the name of the user.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string UserName { get; set; }
Public Property UserName As String
    Get
    Set
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}
function get_UserName();
function set_UserName(value);

Property Value

Type: String
The user name.
See Also

Reference

Credentials Class
DoubleTake.Common.Contract Namespace


Credentials Methods

Credentials Methods

The Credentials type exposes the following members.

Methods
 | Name | Description
Public method | GetDeserializedObject |
Public method | GetObjectToSerialize |
Top
See Also

Reference

Credentials Class
DoubleTake.Common.Contract Namespace


Credentials.GetDeserializedObject Method

CredentialsGetDeserializedObject Method

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Object GetDeserializedObject(
    Type targetType
)
Public Function GetDeserializedObject (
    targetType As Type
) As Object
public:
virtual Object^ GetDeserializedObject(
    Type^ targetType
) sealed
function GetDeserializedObject(targetType);

Parameters

targetType
Type: SystemType

Return Value

Type: Object
See Also

Reference

Credentials Class
DoubleTake.Common.Contract Namespace


Credentials.GetObjectToSerialize Method

CredentialsGetObjectToSerialize Method

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Object GetObjectToSerialize(
    Type targetType
)
Public Function GetObjectToSerialize (
    targetType As Type
) As Object
public:
virtual Object^ GetObjectToSerialize(
    Type^ targetType
) sealed
function GetObjectToSerialize(targetType);

Parameters

targetType
Type: SystemType

Return Value

Type: Object
See Also

Reference

Credentials Class
DoubleTake.Common.Contract Namespace


Credentials Type Conversions

Credentials Type Conversions

The Credentials type exposes the following members.

Operators
Name | Description
(Credentials to NetworkCredential) | Performs an implicit conversion from Credentials to NetworkCredential.
Top
See Also

Reference

Credentials Class
DoubleTake.Common.Contract Namespace


Credentials Implicit Conversion (Credentials to NetworkCredential)

Credentials Conversion (Credentials to NetworkCredential)
Performs an implicit conversion from Credentials to NetworkCredential.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public static implicit operator NetworkCredential (
    Credentials credentials
)
Public Shared Widening Operator CType (
    credentials As Credentials
) As NetworkCredential
static implicit operator NetworkCredential^ (
    Credentials^ credentials
)
JavaScript does not support the declaration of new casting operators.

Parameters

credentials
Type: DoubleTake.Common.ContractCredentials
The credentials.

Return Value

Type: NetworkCredential
The result of the conversion.
See Also

Reference

Credentials Class
DoubleTake.Common.Contract Namespace


DashboardEngineOptions Class

DashboardEngineOptions Class
Inheritance Hierarchy
SystemObject
DoubleTake.Common.ContractDashboardEngineOptions

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class DashboardEngineOptions
Public Class DashboardEngineOptions
public ref class DashboardEngineOptions
DoubleTake.Common.Contract.DashboardEngineOptions = function();

Type.createClass(
    'DoubleTake.Common.Contract.DashboardEngineOptions');

The DashboardEngineOptions type exposes the following members.

Constructors
 | Name | Description
Public method | DashboardEngineOptions | Initializes a new instance of the DashboardEngineOptions class
Top
Properties
 | Name | Description
Public property | DelayedPollIntervalInMinutes |
Top
See Also

Reference

DoubleTake.Common.Contract Namespace


DashboardEngineOptions Constructor

DashboardEngineOptions Constructor
Initializes a new instance of the DashboardEngineOptions class

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public DashboardEngineOptions()
Public Sub New
public:
DashboardEngineOptions()
DoubleTake.Common.Contract.DashboardEngineOptions = function();
See Also

Reference

DashboardEngineOptions Class
DoubleTake.Common.Contract Namespace


DashboardEngineOptions Properties

DashboardEngineOptions Properties

The DashboardEngineOptions type exposes the following members.

Properties
 | Name | Description
Public property | DelayedPollIntervalInMinutes |
Top
See Also

Reference

DashboardEngineOptions Class
DoubleTake.Common.Contract Namespace


DashboardEngineOptions.DelayedPollIntervalInMinutes Property

DashboardEngineOptionsDelayedPollIntervalInMinutes Property

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int DelayedPollIntervalInMinutes { get; set; }
Public Property DelayedPollIntervalInMinutes As Integer
    Get
    Set
public:
property int DelayedPollIntervalInMinutes {
    int get ();
    void set (int value);
}
function get_DelayedPollIntervalInMinutes();
function set_DelayedPollIntervalInMinutes(value);

Property Value

Type: Int32
See Also

Reference

DashboardEngineOptions Class
DoubleTake.Common.Contract Namespace


DirectoryItem Class

DirectoryItem Class
Represents a directory item.
Inheritance Hierarchy
SystemObject
DoubleTake.Common.ContractPhysicalItem
DoubleTake.Common.ContractFileSystemItem
DoubleTake.Common.ContractDirectoryItem

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class DirectoryItem : FileSystemItem
Public Class DirectoryItem
    Inherits FileSystemItem
public ref class DirectoryItem : public FileSystemItem
DoubleTake.Common.Contract.DirectoryItem = function();

Type.createClass(
    'DoubleTake.Common.Contract.DirectoryItem',
    DoubleTake.Common.Contract.FileSystemItem);

The DirectoryItem type exposes the following members.

Constructors
 | Name | Description
Public method | DirectoryItem | Initializes a new instance of the DirectoryItem class.
Top
Properties
 | Name | Description
Public property | Attributes | This value represents the file system attributes. (Inherited from PhysicalItem.)
Public property | CreationTime | This value is the time when the item was created. (Inherited from PhysicalItem.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from PhysicalItem.)
Public property | IsContainer | This value is true if the item is a container of other items; otherwise, it is false. (Inherited from PhysicalItem.)
Public property | IsReadOnly | This value is true if the item is read-only (meaning the Saturation cannot be changed); otherwise, it is false. (Inherited from PhysicalItem.)
Public property | ItemType | This value is the type of item. (Inherited from PhysicalItem.)
Public property | LastAccessTime | This value is the time when the item was last accessed. (Inherited from PhysicalItem.)
Public property | LastWriteTime | This value is the time when the item was last written to. (Inherited from PhysicalItem.)
Public property | Metadata | This value is any additional metadata that may be displayed for a particular type of item. This metadata is not in any particular format, but you must be able to determine the format and decipher the metadata based on the type. (Inherited from PhysicalItem.)
Public property | Name | This value is the name of the item. Typically, this name is used for display in the user interface. (Inherited from PhysicalItem.)
Public property | Path | This value is the path of the item. (Inherited from PhysicalItem.)
Public property | Saturation | This value represents the saturation level of the item. Typically, this value is used to display a visual state in the user interface. (Inherited from PhysicalItem.)
Public property | Size | This value is the physical size of the item. (Inherited from PhysicalItem.)
Top
See Also

Reference

DoubleTake.Common.Contract Namespace


DirectoryItem Constructor

DirectoryItem Constructor
Initializes a new instance of the DirectoryItem class.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public DirectoryItem()
Public Sub New
public:
DirectoryItem()
DoubleTake.Common.Contract.DirectoryItem = function();
See Also

Reference

DirectoryItem Class
DoubleTake.Common.Contract Namespace


DirectoryItem Properties

DirectoryItem Properties

The DirectoryItem type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | This value represents the file system attributes. (Inherited from PhysicalItem.)
Public property | CreationTime | This value is the time when the item was created. (Inherited from PhysicalItem.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from PhysicalItem.)
Public property | IsContainer | This value is true if the item is a container of other items; otherwise, it is false. (Inherited from PhysicalItem.)
Public property | IsReadOnly | This value is true if the item is read-only (meaning the Saturation cannot be changed); otherwise, it is false. (Inherited from PhysicalItem.)
Public property | ItemType | This value is the type of item. (Inherited from PhysicalItem.)
Public property | LastAccessTime | This value is the time when the item was last accessed. (Inherited from PhysicalItem.)
Public property | LastWriteTime | This value is the time when the item was last written to. (Inherited from PhysicalItem.)
Public property | Metadata | This value is any additional metadata that may be displayed for a particular type of item. This metadata is not in any particular format, but you must be able to determine the format and decipher the metadata based on the type. (Inherited from PhysicalItem.)
Public property | Name | This value is the name of the item. Typically, this name is used for display in the user interface. (Inherited from PhysicalItem.)
Public property | Path | This value is the path of the item. (Inherited from PhysicalItem.)
Public property | Saturation | This value represents the saturation level of the item. Typically, this value is used to display a visual state in the user interface. (Inherited from PhysicalItem.)
Public property | Size | This value is the physical size of the item. (Inherited from PhysicalItem.)
Top
See Also

Reference

DirectoryItem Class
DoubleTake.Common.Contract Namespace


EmailNotificationOptions Class

EmailNotificationOptions Class
Inheritance Hierarchy
SystemObject
DoubleTake.Common.ContractEmailNotificationOptions

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class EmailNotificationOptions : IExtensibleDataObject
Public Class EmailNotificationOptions
    Implements IExtensibleDataObject
public ref class EmailNotificationOptions : IExtensibleDataObject
DoubleTake.Common.Contract.EmailNotificationOptions = function();

Type.createClass(
    'DoubleTake.Common.Contract.EmailNotificationOptions',
    null,
    IExtensibleDataObject);

The EmailNotificationOptions type exposes the following members.

Constructors
 | Name | Description
Public method | EmailNotificationOptions | Initializes a new instance of the EmailNotificationOptions class
Top
Properties
 | Name | Description
Public property | ConnectionSecurity | This value represents the SMTP server connection security.
Public property | Enabled | This value is true if email notification is enabled; otherwise, it is false.
Public property | EntryIdFilter | This value is one or more comma-delimited Windows Event Log entry IDs for which email notifications should be sent.
Public property | EntryTypeFilter | This value is one or more comma-delimited Windows Event Log entry types (error, warning, or information) for which email notifications should be sent.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | From | This value is the e-mail address that will be placed in the From field of the email message.
Public property | IncludeEventDescriptionInSubject | This value is true if the event description is included in the email subject; otherwise, it is false.
Public property | LoginToSmtpServer | This value is true if you must log in to the SMTP server; otherwise, it is false.
Public property | SmtpCredentials | This value represents the credentials used to log into the SMTP server. Do not set this value if you want to user the SMTP server anonymously.
Public property | SmtpPort | This value is the SMTP port. The default port is 25.
Public property | SmtpServer | This value is the name of the SMTP server.
Public property | SubjectPrefix | This value is the text that will be added to the beginning of the email subject.
Public property | To | This value can contain one or more comma-delimited e-mail addresses to which the email notifications will be sent.
Top
See Also

Reference

DoubleTake.Common.Contract Namespace


EmailNotificationOptions Constructor

EmailNotificationOptions Constructor
Initializes a new instance of the EmailNotificationOptions class

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public EmailNotificationOptions()
Public Sub New
public:
EmailNotificationOptions()
DoubleTake.Common.Contract.EmailNotificationOptions = function();
See Also

Reference

EmailNotificationOptions Class
DoubleTake.Common.Contract Namespace


EmailNotificationOptions Properties

EmailNotificationOptions Properties

The EmailNotificationOptions type exposes the following members.

Properties
 | Name | Description
Public property | ConnectionSecurity | This value represents the SMTP server connection security.
Public property | Enabled | This value is true if email notification is enabled; otherwise, it is false.
Public property | EntryIdFilter | This value is one or more comma-delimited Windows Event Log entry IDs for which email notifications should be sent.
Public property | EntryTypeFilter | This value is one or more comma-delimited Windows Event Log entry types (error, warning, or information) for which email notifications should be sent.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | From | This value is the e-mail address that will be placed in the From field of the email message.
Public property | IncludeEventDescriptionInSubject | This value is true if the event description is included in the email subject; otherwise, it is false.
Public property | LoginToSmtpServer | This value is true if you must log in to the SMTP server; otherwise, it is false.
Public property | SmtpCredentials | This value represents the credentials used to log into the SMTP server. Do not set this value if you want to user the SMTP server anonymously.
Public property | SmtpPort | This value is the SMTP port. The default port is 25.
Public property | SmtpServer | This value is the name of the SMTP server.
Public property | SubjectPrefix | This value is the text that will be added to the beginning of the email subject.
Public property | To | This value can contain one or more comma-delimited e-mail addresses to which the email notifications will be sent.
Top
See Also

Reference

EmailNotificationOptions Class
DoubleTake.Common.Contract Namespace


EmailNotificationOptions.ConnectionSecurity Property

EmailNotificationOptionsConnectionSecurity Property
This value represents the SMTP server connection security.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public SmtpConnectionSecurity ConnectionSecurity { get; set; }
Public Property ConnectionSecurity As SmtpConnectionSecurity
    Get
    Set
public:
property SmtpConnectionSecurity ConnectionSecurity {
    SmtpConnectionSecurity get ();
    void set (SmtpConnectionSecurity value);
}
function get_ConnectionSecurity();
function set_ConnectionSecurity(value);

Property Value

Type: SmtpConnectionSecurity
Connection security
See Also

Reference

EmailNotificationOptions Class
DoubleTake.Common.Contract Namespace


EmailNotificationOptions.Enabled Property

EmailNotificationOptionsEnabled Property
This value is true if email notification is enabled; otherwise, it is false.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool Enabled { get; set; }
Public Property Enabled As Boolean
    Get
    Set
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
function get_Enabled();
function set_Enabled(value);

Property Value

Type: Boolean
if enabled; otherwise, .
See Also

Reference

EmailNotificationOptions Class
DoubleTake.Common.Contract Namespace


EmailNotificationOptions.EntryIdFilter Property

EmailNotificationOptionsEntryIdFilter Property
This value is one or more comma-delimited Windows Event Log entry IDs for which email notifications should be sent.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string EntryIdFilter { get; set; }
Public Property EntryIdFilter As String
    Get
    Set
public:
property String^ EntryIdFilter {
    String^ get ();
    void set (String^ value);
}
function get_EntryIdFilter();
function set_EntryIdFilter(value);

Property Value

Type: String
The entry id filter.
See Also

Reference

EmailNotificationOptions Class
DoubleTake.Common.Contract Namespace


EmailNotificationOptions.EntryTypeFilter Property

EmailNotificationOptionsEntryTypeFilter Property
This value is one or more comma-delimited Windows Event Log entry types (error, warning, or information) for which email notifications should be sent.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string EntryTypeFilter { get; set; }
Public Property EntryTypeFilter As String
    Get
    Set
public:
property String^ EntryTypeFilter {
    String^ get ();
    void set (String^ value);
}
function get_EntryTypeFilter();
function set_EntryTypeFilter(value);

Property Value

Type: String
The entry type filter.
See Also

Reference

EmailNotificationOptions Class
DoubleTake.Common.Contract Namespace


EmailNotificationOptions.ExtensionData Property

EmailNotificationOptionsExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The structure that contains extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

EmailNotificationOptions Class
DoubleTake.Common.Contract Namespace


EmailNotificationOptions.From Property

EmailNotificationOptionsFrom Property
This value is the e-mail address that will be placed in the From field of the email message.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string From { get; set; }
Public Property From As String
    Get
    Set
public:
property String^ From {
    String^ get ();
    void set (String^ value);
}
function get_From();
function set_From(value);

Property Value

Type: String
An e-mail address that will be placed in the From field of the e-mail message.
See Also

Reference

EmailNotificationOptions Class
DoubleTake.Common.Contract Namespace


EmailNotificationOptions.IncludeEventDescriptionInSubject Property

EmailNotificationOptionsIncludeEventDescriptionInSubject Property
This value is true if the event description is included in the email subject; otherwise, it is false.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool IncludeEventDescriptionInSubject { get; set; }
Public Property IncludeEventDescriptionInSubject As Boolean
    Get
    Set
public:
property bool IncludeEventDescriptionInSubject {
    bool get ();
    void set (bool value);
}
function get_IncludeEventDescriptionInSubject();
function set_IncludeEventDescriptionInSubject(value);

Property Value

Type: Boolean
if the event description is to be included in the subject; otherwise, .
See Also

Reference

EmailNotificationOptions Class
DoubleTake.Common.Contract Namespace


EmailNotificationOptions.LoginToSmtpServer Property

EmailNotificationOptionsLoginToSmtpServer Property
This value is true if you must log in to the SMTP server; otherwise, it is false.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool LoginToSmtpServer { get; set; }
Public Property LoginToSmtpServer As Boolean
    Get
    Set
public:
property bool LoginToSmtpServer {
    bool get ();
    void set (bool value);
}
function get_LoginToSmtpServer();
function set_LoginToSmtpServer(value);

Property Value

Type: Boolean
to login to the SMTP server; otherwise, .
See Also

Reference

EmailNotificationOptions Class
DoubleTake.Common.Contract Namespace


EmailNotificationOptions.SmtpCredentials Property

EmailNotificationOptionsSmtpCredentials Property
This value represents the credentials used to log into the SMTP server. Do not set this value if you want to user the SMTP server anonymously.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Credentials SmtpCredentials { get; set; }
Public Property SmtpCredentials As Credentials
    Get
    Set
public:
property Credentials^ SmtpCredentials {
    Credentials^ get ();
    void set (Credentials^ value);
}
function get_SmtpCredentials();
function set_SmtpCredentials(value);

Property Value

Type: Credentials
The SMTP credentials.
Remarks
Set this value to if you would like to use the SMTP server anonymously.
See Also

Reference

EmailNotificationOptions Class
DoubleTake.Common.Contract Namespace


EmailNotificationOptions.SmtpPort Property

EmailNotificationOptionsSmtpPort Property
This value is the SMTP port. The default port is 25.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Nullable<int> SmtpPort { get; set; }
Public Property SmtpPort As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> SmtpPort {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
function get_SmtpPort();
function set_SmtpPort(value);

Property Value

Type: Nullable Int32
The SMTP port.
Remarks
Set this property to to use the default SMTP port (25).
See Also

Reference

EmailNotificationOptions Class
DoubleTake.Common.Contract Namespace


EmailNotificationOptions.SmtpServer Property

EmailNotificationOptionsSmtpServer Property
This value is the name of the SMTP server.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string SmtpServer { get; set; }
Public Property SmtpServer As String
    Get
    Set
public:
property String^ SmtpServer {
    String^ get ();
    void set (String^ value);
}
function get_SmtpServer();
function set_SmtpServer(value);

Property Value

Type: String
The SMTP server.
See Also

Reference

EmailNotificationOptions Class
DoubleTake.Common.Contract Namespace


EmailNotificationOptions.SubjectPrefix Property

EmailNotificationOptionsSubjectPrefix Property
This value is the text that will be added to the beginning of the email subject.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string SubjectPrefix { get; set; }
Public Property SubjectPrefix As String
    Get
    Set
public:
property String^ SubjectPrefix {
    String^ get ();
    void set (String^ value);
}
function get_SubjectPrefix();
function set_SubjectPrefix(value);

Property Value

Type: String
The subject prefix.
See Also

Reference

EmailNotificationOptions Class
DoubleTake.Common.Contract Namespace


EmailNotificationOptions.To Property

EmailNotificationOptionsTo Property
This value can contain one or more comma-delimited e-mail addresses to which the email notifications will be sent.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string To { get; set; }
Public Property To As String
    Get
    Set
public:
property String^ To {
    String^ get ();
    void set (String^ value);
}
function get_To();
function set_To(value);

Property Value

Type: String
A string containing one or more comma-delimited e-mail addresses to which the e-mail notifications will be sent.
See Also

Reference

EmailNotificationOptions Class
DoubleTake.Common.Contract Namespace


EngineCommandFailedFault Class

EngineCommandFailedFault Class
Represents a fault that is thrown when the engine is unable to execute a command.
Inheritance Hierarchy
SystemObject
DoubleTake.Common.ContractEngineCommandFailedFault

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public sealed class EngineCommandFailedFault : ICommonFault,
    IExtensibleDataObject
Public NotInheritable Class EngineCommandFailedFault
    Implements ICommonFault, IExtensibleDataObject
public ref class EngineCommandFailedFault sealed : ICommonFault,
    IExtensibleDataObject
DoubleTake.Common.Contract.EngineCommandFailedFault = function();

Type.createClass(
    'DoubleTake.Common.Contract.EngineCommandFailedFault',
    null,
    DoubleTake.Common.Contract.ICommonFault,
    IExtensibleDataObject);

The EngineCommandFailedFault type exposes the following members.

Constructors
 | Name | Description
Public method | EngineCommandFailedFault | Initializes a new instance of the EngineCommandFailedFault class
Top
Properties
 | Name | Description
Public property | CommandName | Gets or sets the name of the engine command that failed.
Public property | ErrorCode | Gets or sets the error code that was returned in the engine response.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | InnerFault | Gets or sets the inner fault.
Public property | Message | Gets or sets the fault error message.
Public property | Name | Gets or sets the name of the fault.
Public property | StackTrace | Gets or sets the stack trace from the service that indicates where an unhandled exception occurred.
Top
See Also

Reference

DoubleTake.Common.Contract Namespace


EngineCommandFailedFault Constructor

EngineCommandFailedFault Constructor
Initializes a new instance of the EngineCommandFailedFault class

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public EngineCommandFailedFault()
Public Sub New
public:
EngineCommandFailedFault()
DoubleTake.Common.Contract.EngineCommandFailedFault = function();
See Also

Reference

EngineCommandFailedFault Class
DoubleTake.Common.Contract Namespace


EngineCommandFailedFault Properties

EngineCommandFailedFault Properties

The EngineCommandFailedFault type exposes the following members.

Properties
 | Name | Description
Public property | CommandName | Gets or sets the name of the engine command that failed.
Public property | ErrorCode | Gets or sets the error code that was returned in the engine response.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | InnerFault | Gets or sets the inner fault.
Public property | Message | Gets or sets the fault error message.
Public property | Name | Gets or sets the name of the fault.
Public property | StackTrace | Gets or sets the stack trace from the service that indicates where an unhandled exception occurred.
Top
See Also

Reference

EngineCommandFailedFault Class
DoubleTake.Common.Contract Namespace


EngineCommandFailedFault.CommandName Property

EngineCommandFailedFaultCommandName Property
Gets or sets the name of the engine command that failed.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string CommandName { get; set; }
Public Property CommandName As String
    Get
    Set
public:
property String^ CommandName {
    String^ get ();
    void set (String^ value);
}
function get_CommandName();
function set_CommandName(value);

Property Value

Type: String
The name of the engine command that failed.
See Also

Reference

EngineCommandFailedFault Class
DoubleTake.Common.Contract Namespace


EngineCommandFailedFault.ErrorCode Property

EngineCommandFailedFaultErrorCode Property
Gets or sets the error code that was returned in the engine response.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int ErrorCode { get; set; }
Public Property ErrorCode As Integer
    Get
    Set
public:
property int ErrorCode {
    int get ();
    void set (int value);
}
function get_ErrorCode();
function set_ErrorCode(value);

Property Value

Type: Int32
The error code returned in the engine response.
See Also

Reference

EngineCommandFailedFault Class
DoubleTake.Common.Contract Namespace


EngineCommandFailedFault.ExtensionData Property

EngineCommandFailedFaultExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

EngineCommandFailedFault Class
DoubleTake.Common.Contract Namespace


EngineCommandFailedFault.InnerFault Property

EngineCommandFailedFaultInnerFault Property
Gets or sets the inner fault.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ICommonFault InnerFault { get; set; }
Public Property InnerFault As ICommonFault
    Get
    Set
public:
virtual property ICommonFault^ InnerFault {
    ICommonFault^ get () sealed;
    void set (ICommonFault^ value) sealed;
}
function get_InnerFault();
function set_InnerFault(value);

Property Value

Type: ICommonFault
An instance of ICommonFault that represents the inner fault.

Implements

ICommonFaultInnerFault
Remarks
This property contains a value if this fault was triggered by another fault that is of interest to the caller.
See Also

Reference

EngineCommandFailedFault Class
DoubleTake.Common.Contract Namespace


EngineCommandFailedFault.Message Property

EngineCommandFailedFaultMessage Property
Gets or sets the fault error message.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Message { get; set; }
Public Property Message As String
    Get
    Set
public:
virtual property String^ Message {
    String^ get () sealed;
    void set (String^ value) sealed;
}
function get_Message();
function set_Message(value);

Property Value

Type: String
The fault error message.

Implements

ICommonFaultMessage
See Also

Reference

EngineCommandFailedFault Class
DoubleTake.Common.Contract Namespace


EngineCommandFailedFault.Name Property

EngineCommandFailedFaultName Property
Gets or sets the name of the fault.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get () sealed;
    void set (String^ value) sealed;
}
function get_Name();
function set_Name(value);

Property Value

Type: String
The name of the fault.

Implements

ICommonFaultName
See Also

Reference

EngineCommandFailedFault Class
DoubleTake.Common.Contract Namespace


EngineCommandFailedFault.StackTrace Property

EngineCommandFailedFaultStackTrace Property
Gets or sets the stack trace from the service that indicates where an unhandled exception occurred.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string StackTrace { get; set; }
Public Property StackTrace As String
    Get
    Set
public:
virtual property String^ StackTrace {
    String^ get () sealed;
    void set (String^ value) sealed;
}
function get_StackTrace();
function set_StackTrace(value);

Property Value

Type: String
The stack trace from the service.

Implements

ICommonFaultStackTrace
See Also

Reference

EngineCommandFailedFault Class
DoubleTake.Common.Contract Namespace


EngineCommunicationFault Class

EngineCommunicationFault Class
Represents a fault thrown when the management service cannot communicate with the engine.
Inheritance Hierarchy
SystemObject
DoubleTake.Common.ContractEngineCommunicationFault

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public sealed class EngineCommunicationFault : ICommonFault,
    IExtensibleDataObject
Public NotInheritable Class EngineCommunicationFault
    Implements ICommonFault, IExtensibleDataObject
public ref class EngineCommunicationFault sealed : ICommonFault,
    IExtensibleDataObject
DoubleTake.Common.Contract.EngineCommunicationFault = function();

Type.createClass(
    'DoubleTake.Common.Contract.EngineCommunicationFault',
    null,
    DoubleTake.Common.Contract.ICommonFault,
    IExtensibleDataObject);

The EngineCommunicationFault type exposes the following members.

Constructors
 | Name | Description
Public method | EngineCommunicationFault | Initializes a new instance of the EngineCommunicationFault class
Top
Properties
 | Name | Description
Public property | ErrorCode | Gets or sets the error code.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | InnerFault | Gets or sets the inner fault.
Public property | Message | Gets or sets the fault error message.
Public property | Name | Gets or sets the name of the fault.
Public property | Reason | Gets or sets the reason the management service cannot communicate with the engine.
Public property | StackTrace | Gets or sets the stack trace from the service that indicates where an unhandled exception occurred.
Top
See Also

Reference

DoubleTake.Common.Contract Namespace


EngineCommunicationFault Constructor

EngineCommunicationFault Constructor
Initializes a new instance of the EngineCommunicationFault class

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public EngineCommunicationFault()
Public Sub New
public:
EngineCommunicationFault()
DoubleTake.Common.Contract.EngineCommunicationFault = function();
See Also

Reference

EngineCommunicationFault Class
DoubleTake.Common.Contract Namespace


EngineCommunicationFault Properties

EngineCommunicationFault Properties

The EngineCommunicationFault type exposes the following members.

Properties
 | Name | Description
Public property | ErrorCode | Gets or sets the error code.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | InnerFault | Gets or sets the inner fault.
Public property | Message | Gets or sets the fault error message.
Public property | Name | Gets or sets the name of the fault.
Public property | Reason | Gets or sets the reason the management service cannot communicate with the engine.
Public property | StackTrace | Gets or sets the stack trace from the service that indicates where an unhandled exception occurred.
Top
See Also

Reference

EngineCommunicationFault Class
DoubleTake.Common.Contract Namespace


EngineCommunicationFault.ErrorCode Property

EngineCommunicationFaultErrorCode Property
Gets or sets the error code.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int ErrorCode { get; set; }
Public Property ErrorCode As Integer
    Get
    Set
public:
property int ErrorCode {
    int get ();
    void set (int value);
}
function get_ErrorCode();
function set_ErrorCode(value);

Property Value

Type: Int32
The error code.
See Also

Reference

EngineCommunicationFault Class
DoubleTake.Common.Contract Namespace


EngineCommunicationFault.ExtensionData Property

EngineCommunicationFaultExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

EngineCommunicationFault Class
DoubleTake.Common.Contract Namespace


EngineCommunicationFault.InnerFault Property

EngineCommunicationFaultInnerFault Property
Gets or sets the inner fault.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ICommonFault InnerFault { get; set; }
Public Property InnerFault As ICommonFault
    Get
    Set
public:
virtual property ICommonFault^ InnerFault {
    ICommonFault^ get () sealed;
    void set (ICommonFault^ value) sealed;
}
function get_InnerFault();
function set_InnerFault(value);

Property Value

Type: ICommonFault
An instance of ICommonFault that represents the inner fault.

Implements

ICommonFaultInnerFault
Remarks
This property contains a value if this fault was triggered by another fault that is of interest to the caller.
See Also

Reference

EngineCommunicationFault Class
DoubleTake.Common.Contract Namespace


EngineCommunicationFault.Message Property

EngineCommunicationFaultMessage Property
Gets or sets the fault error message.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Message { get; set; }
Public Property Message As String
    Get
    Set
public:
virtual property String^ Message {
    String^ get () sealed;
    void set (String^ value) sealed;
}
function get_Message();
function set_Message(value);

Property Value

Type: String
The fault error message.

Implements

ICommonFaultMessage
See Also

Reference

EngineCommunicationFault Class
DoubleTake.Common.Contract Namespace


EngineCommunicationFault.Name Property

EngineCommunicationFaultName Property
Gets or sets the name of the fault.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get () sealed;
    void set (String^ value) sealed;
}
function get_Name();
function set_Name(value);

Property Value

Type: String
The name of the fault.

Implements

ICommonFaultName
See Also

Reference

EngineCommunicationFault Class
DoubleTake.Common.Contract Namespace


EngineCommunicationFault.Reason Property

EngineCommunicationFaultReason Property
Gets or sets the reason the management service cannot communicate with the engine.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Reason { get; set; }
Public Property Reason As String
    Get
    Set
public:
property String^ Reason {
    String^ get ();
    void set (String^ value);
}
function get_Reason();
function set_Reason(value);

Property Value

Type: String
The reason the management service cannot communicate with the engine.
See Also

Reference

EngineCommunicationFault Class
DoubleTake.Common.Contract Namespace


EngineCommunicationFault.StackTrace Property

EngineCommunicationFaultStackTrace Property
Gets or sets the stack trace from the service that indicates where an unhandled exception occurred.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string StackTrace { get; set; }
Public Property StackTrace As String
    Get
    Set
public:
virtual property String^ StackTrace {
    String^ get () sealed;
    void set (String^ value) sealed;
}
function get_StackTrace();
function set_StackTrace(value);

Property Value

Type: String
The stack trace from the service.

Implements

ICommonFaultStackTrace
See Also

Reference

EngineCommunicationFault Class
DoubleTake.Common.Contract Namespace


FileItem Class

FileItem Class
Represents a file item.
Inheritance Hierarchy
SystemObject
DoubleTake.Common.ContractPhysicalItem
DoubleTake.Common.ContractFileSystemItem
DoubleTake.Common.ContractFileItem

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class FileItem : FileSystemItem
Public Class FileItem
    Inherits FileSystemItem
public ref class FileItem : public FileSystemItem
DoubleTake.Common.Contract.FileItem = function();

Type.createClass(
    'DoubleTake.Common.Contract.FileItem',
    DoubleTake.Common.Contract.FileSystemItem);

The FileItem type exposes the following members.

Constructors
 | Name | Description
Public method | FileItem | Initializes a new instance of the FileItem class.
Top
Properties
 | Name | Description
Public property | Attributes | This value represents the file system attributes. (Inherited from PhysicalItem.)
Public property | CreationTime | This value is the time when the item was created. (Inherited from PhysicalItem.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from PhysicalItem.)
Public property | IsContainer | This value is true if the item is a container of other items; otherwise, it is false. (Inherited from PhysicalItem.)
Public property | IsReadOnly | This value is true if the item is read-only (meaning the Saturation cannot be changed); otherwise, it is false. (Inherited from PhysicalItem.)
Public property | ItemType | This value is the type of item. (Inherited from PhysicalItem.)
Public property | LastAccessTime | This value is the time when the item was last accessed. (Inherited from PhysicalItem.)
Public property | LastWriteTime | This value is the time when the item was last written to. (Inherited from PhysicalItem.)
Public property | Metadata | This value is any additional metadata that may be displayed for a particular type of item. This metadata is not in any particular format, but you must be able to determine the format and decipher the metadata based on the type. (Inherited from PhysicalItem.)
Public property | Name | This value is the name of the item. Typically, this name is used for display in the user interface. (Inherited from PhysicalItem.)
Public property | Path | This value is the path of the item. (Inherited from PhysicalItem.)
Public property | Saturation | This value represents the saturation level of the item. Typically, this value is used to display a visual state in the user interface. (Inherited from PhysicalItem.)
Public property | Size | This value is the physical size of the item. (Inherited from PhysicalItem.)
Top
See Also

Reference

DoubleTake.Common.Contract Namespace


FileItem Constructor

FileItem Constructor
Initializes a new instance of the FileItem class.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public FileItem()
Public Sub New
public:
FileItem()
DoubleTake.Common.Contract.FileItem = function();
See Also

Reference

FileItem Class
DoubleTake.Common.Contract Namespace


FileItem Properties

FileItem Properties

The FileItem type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | This value represents the file system attributes. (Inherited from PhysicalItem.)
Public property | CreationTime | This value is the time when the item was created. (Inherited from PhysicalItem.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from PhysicalItem.)
Public property | IsContainer | This value is true if the item is a container of other items; otherwise, it is false. (Inherited from PhysicalItem.)
Public property | IsReadOnly | This value is true if the item is read-only (meaning the Saturation cannot be changed); otherwise, it is false. (Inherited from PhysicalItem.)
Public property | ItemType | This value is the type of item. (Inherited from PhysicalItem.)
Public property | LastAccessTime | This value is the time when the item was last accessed. (Inherited from PhysicalItem.)
Public property | LastWriteTime | This value is the time when the item was last written to. (Inherited from PhysicalItem.)
Public property | Metadata | This value is any additional metadata that may be displayed for a particular type of item. This metadata is not in any particular format, but you must be able to determine the format and decipher the metadata based on the type. (Inherited from PhysicalItem.)
Public property | Name | This value is the name of the item. Typically, this name is used for display in the user interface. (Inherited from PhysicalItem.)
Public property | Path | This value is the path of the item. (Inherited from PhysicalItem.)
Public property | Saturation | This value represents the saturation level of the item. Typically, this value is used to display a visual state in the user interface. (Inherited from PhysicalItem.)
Public property | Size | This value is the physical size of the item. (Inherited from PhysicalItem.)
Top
See Also

Reference

FileItem Class
DoubleTake.Common.Contract Namespace


FileSystemAttributes Enumeration

FileSystemAttributes Enumeration
Describes the attributes of a file system item.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public enum FileSystemAttributes
Public Enumeration FileSystemAttributes
public enum class FileSystemAttributes
DoubleTake.Common.Contract.FileSystemAttributes = function();
DoubleTake.Common.Contract.FileSystemAttributes.createEnum('DoubleTake.Common.Contract.FileSystemAttributes', false);
Members
Member name | Value | Description
ReadOnly | 1 | The file system item is read-only.
Hidden | 2 | The file system item is hidden.
System | 4 | The file system item is a system item.
Directory | 16 | The file system item is a directory.
Archive | 32 | The file system item is is marked to be archived.
Normal | 128 | The file system item is normal.
Temporary | 256 | The file system item is temporary.
SparseFile | 512 | The file system item is a sparse file.
ReparsePoint | 1024 | The file system item is a reparse point.
Compressed | 2048 | The file system item is compressed.
Offline | 4096 | The file system item is offline.
NotContentIndexed | 8192 | The file system item is not content indexed.
Encrypted | 16384 | The file system item is encrypted.
See Also

Reference

DoubleTake.Common.Contract Namespace


FileSystemItem Class

FileSystemItem Class
Represents a file system item.
Inheritance Hierarchy
SystemObject
DoubleTake.Common.ContractPhysicalItem
DoubleTake.Common.ContractFileSystemItem
DoubleTake.Common.ContractDirectoryItem
DoubleTake.Common.ContractFileItem

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class FileSystemItem : PhysicalItem
Public Class FileSystemItem
    Inherits PhysicalItem
public ref class FileSystemItem : public PhysicalItem
DoubleTake.Common.Contract.FileSystemItem = function();

Type.createClass(
    'DoubleTake.Common.Contract.FileSystemItem',
    DoubleTake.Common.Contract.PhysicalItem);

The FileSystemItem type exposes the following members.

Constructors
 | Name | Description
Public method | FileSystemItem | Initializes a new instance of the FileSystemItem class
Top
Properties
 | Name | Description
Public property | Attributes | This value represents the file system attributes. (Inherited from PhysicalItem.)
Public property | CreationTime | This value is the time when the item was created. (Inherited from PhysicalItem.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from PhysicalItem.)
Public property | IsContainer | This value is true if the item is a container of other items; otherwise, it is false. (Inherited from PhysicalItem.)
Public property | IsReadOnly | This value is true if the item is read-only (meaning the Saturation cannot be changed); otherwise, it is false. (Inherited from PhysicalItem.)
Public property | ItemType | This value is the type of item. (Inherited from PhysicalItem.)
Public property | LastAccessTime | This value is the time when the item was last accessed. (Inherited from PhysicalItem.)
Public property | LastWriteTime | This value is the time when the item was last written to. (Inherited from PhysicalItem.)
Public property | Metadata | This value is any additional metadata that may be displayed for a particular type of item. This metadata is not in any particular format, but you must be able to determine the format and decipher the metadata based on the type. (Inherited from PhysicalItem.)
Public property | Name | This value is the name of the item. Typically, this name is used for display in the user interface. (Inherited from PhysicalItem.)
Public property | Path | This value is the path of the item. (Inherited from PhysicalItem.)
Public property | Saturation | This value represents the saturation level of the item. Typically, this value is used to display a visual state in the user interface. (Inherited from PhysicalItem.)
Public property | Size | This value is the physical size of the item. (Inherited from PhysicalItem.)
Top
See Also

Reference

DoubleTake.Common.Contract Namespace


FileSystemItem Constructor

FileSystemItem Constructor
Initializes a new instance of the FileSystemItem class

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public FileSystemItem()
Public Sub New
public:
FileSystemItem()
DoubleTake.Common.Contract.FileSystemItem = function();
See Also

Reference

FileSystemItem Class
DoubleTake.Common.Contract Namespace


FileSystemItem Properties

FileSystemItem Properties

The FileSystemItem type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | This value represents the file system attributes. (Inherited from PhysicalItem.)
Public property | CreationTime | This value is the time when the item was created. (Inherited from PhysicalItem.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from PhysicalItem.)
Public property | IsContainer | This value is true if the item is a container of other items; otherwise, it is false. (Inherited from PhysicalItem.)
Public property | IsReadOnly | This value is true if the item is read-only (meaning the Saturation cannot be changed); otherwise, it is false. (Inherited from PhysicalItem.)
Public property | ItemType | This value is the type of item. (Inherited from PhysicalItem.)
Public property | LastAccessTime | This value is the time when the item was last accessed. (Inherited from PhysicalItem.)
Public property | LastWriteTime | This value is the time when the item was last written to. (Inherited from PhysicalItem.)
Public property | Metadata | This value is any additional metadata that may be displayed for a particular type of item. This metadata is not in any particular format, but you must be able to determine the format and decipher the metadata based on the type. (Inherited from PhysicalItem.)
Public property | Name | This value is the name of the item. Typically, this name is used for display in the user interface. (Inherited from PhysicalItem.)
Public property | Path | This value is the path of the item. (Inherited from PhysicalItem.)
Public property | Saturation | This value represents the saturation level of the item. Typically, this value is used to display a visual state in the user interface. (Inherited from PhysicalItem.)
Public property | Size | This value is the physical size of the item. (Inherited from PhysicalItem.)
Top
See Also

Reference

FileSystemItem Class
DoubleTake.Common.Contract Namespace


ICommonFault Interface

ICommonFault Interface
Defines common aspects of all faults thrown by management service methods.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public interface ICommonFault
Public Interface ICommonFault
public interface class ICommonFault
DoubleTake.Common.Contract.ICommonFault = function();
DoubleTake.Common.Contract.ICommonFault.createInterface('DoubleTake.Common.Contract.ICommonFault');

The ICommonFault type exposes the following members.

Properties
 | Name | Description
Public property | InnerFault | Gets or sets the inner fault.
Public property | Message | Gets or sets the fault error message.
Public property | Name | Gets or sets the name of the fault.
Public property | StackTrace | Gets or sets the stack trace from the service that indicates where an unhandled exception occurred.
Top
See Also

Reference

DoubleTake.Common.Contract Namespace


ICommonFault Properties

ICommonFault Properties

The ICommonFault type exposes the following members.

Properties
 | Name | Description
Public property | InnerFault | Gets or sets the inner fault.
Public property | Message | Gets or sets the fault error message.
Public property | Name | Gets or sets the name of the fault.
Public property | StackTrace | Gets or sets the stack trace from the service that indicates where an unhandled exception occurred.
Top
See Also

Reference

ICommonFault Interface
DoubleTake.Common.Contract Namespace


ICommonFault.InnerFault Property

ICommonFaultInnerFault Property
Gets or sets the inner fault.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
ICommonFault InnerFault { get; set; }
Property InnerFault As ICommonFault
    Get
    Set
property ICommonFault^ InnerFault {
    ICommonFault^ get ();
    void set (ICommonFault^ value);
}
function get_InnerFault();
function set_InnerFault(value);

Property Value

Type: ICommonFault
An instance of ICommonFault that represents the inner fault.
Remarks
This property contains a value if this fault was triggered by another fault that is of interest to the caller.
See Also

Reference

ICommonFault Interface
DoubleTake.Common.Contract Namespace


ICommonFault.Message Property

ICommonFaultMessage Property
Gets or sets the fault error message.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
string Message { get; set; }
Property Message As String
    Get
    Set
property String^ Message {
    String^ get ();
    void set (String^ value);
}
function get_Message();
function set_Message(value);

Property Value

Type: String
The fault error message.
See Also

Reference

ICommonFault Interface
DoubleTake.Common.Contract Namespace


ICommonFault.Name Property

ICommonFaultName Property
Gets or sets the name of the fault.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
string Name { get; set; }
Property Name As String
    Get
    Set
property String^ Name {
    String^ get ();
    void set (String^ value);
}
function get_Name();
function set_Name(value);

Property Value

Type: String
The name of the fault.
See Also

Reference

ICommonFault Interface
DoubleTake.Common.Contract Namespace


ICommonFault.StackTrace Property

ICommonFaultStackTrace Property
Gets or sets the stack trace from the service that indicates where an unhandled exception occurred.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
string StackTrace { get; set; }
Property StackTrace As String
    Get
    Set
property String^ StackTrace {
    String^ get ();
    void set (String^ value);
}
function get_StackTrace();
function set_StackTrace(value);

Property Value

Type: String
The stack trace from the service.
See Also

Reference

ICommonFault Interface
DoubleTake.Common.Contract Namespace


InclusionMode Enumeration

InclusionMode Enumeration
Indicates whether a certain data path in a workload should be replicated.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public enum InclusionMode
Public Enumeration InclusionMode
public enum class InclusionMode
DoubleTake.Common.Contract.InclusionMode = function();
DoubleTake.Common.Contract.InclusionMode.createEnum('DoubleTake.Common.Contract.InclusionMode', false);
Members
Member name | Value | Description
Include | 0 | The data path is included in replication.
Exclude | 1 | The data path is excluded from replication.
See Also

Reference

DoubleTake.Common.Contract Namespace


InvalidEmailAddressFormatFault Class

InvalidEmailAddressFormatFault Class
Represents a fault thrown when an invalid email address is specified for an operation.
Inheritance Hierarchy
SystemObject
DoubleTake.Common.ContractInvalidEmailAddressFormatFault

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class InvalidEmailAddressFormatFault : ICommonFault,
    IExtensibleDataObject
Public Class InvalidEmailAddressFormatFault
    Implements ICommonFault, IExtensibleDataObject
public ref class InvalidEmailAddressFormatFault : ICommonFault,
    IExtensibleDataObject
DoubleTake.Common.Contract.InvalidEmailAddressFormatFault = function();

Type.createClass(
    'DoubleTake.Common.Contract.InvalidEmailAddressFormatFault',
    null,
    DoubleTake.Common.Contract.ICommonFault,
    IExtensibleDataObject);

The InvalidEmailAddressFormatFault type exposes the following members.

Constructors
 | Name | Description
Public method | InvalidEmailAddressFormatFault | Initializes a new instance of the InvalidEmailAddressFormatFault class
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | InnerFault | Gets or sets the inner fault.
Public property | Message | Gets or sets the fault error message.
Public property | Name | Gets or sets the name of the fault.
Public property | StackTrace | Gets or sets the stack trace from the service that indicates where an unhandled exception occurred.
Top
See Also

Reference

DoubleTake.Common.Contract Namespace


InvalidEmailAddressFormatFault Constructor

InvalidEmailAddressFormatFault Constructor
Initializes a new instance of the InvalidEmailAddressFormatFault class

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public InvalidEmailAddressFormatFault()
Public Sub New
public:
InvalidEmailAddressFormatFault()
DoubleTake.Common.Contract.InvalidEmailAddressFormatFault = function();
See Also

Reference

InvalidEmailAddressFormatFault Class
DoubleTake.Common.Contract Namespace


InvalidEmailAddressFormatFault Properties

InvalidEmailAddressFormatFault Properties

The InvalidEmailAddressFormatFault type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | InnerFault | Gets or sets the inner fault.
Public property | Message | Gets or sets the fault error message.
Public property | Name | Gets or sets the name of the fault.
Public property | StackTrace | Gets or sets the stack trace from the service that indicates where an unhandled exception occurred.
Top
See Also

Reference

InvalidEmailAddressFormatFault Class
DoubleTake.Common.Contract Namespace


InvalidEmailAddressFormatFault.ExtensionData Property

InvalidEmailAddressFormatFaultExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

InvalidEmailAddressFormatFault Class
DoubleTake.Common.Contract Namespace


InvalidEmailAddressFormatFault.InnerFault Property

InvalidEmailAddressFormatFaultInnerFault Property
Gets or sets the inner fault.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ICommonFault InnerFault { get; set; }
Public Property InnerFault As ICommonFault
    Get
    Set
public:
virtual property ICommonFault^ InnerFault {
    ICommonFault^ get () sealed;
    void set (ICommonFault^ value) sealed;
}
function get_InnerFault();
function set_InnerFault(value);

Property Value

Type: ICommonFault
An instance of ICommonFault that represents the inner fault.

Implements

ICommonFaultInnerFault
Remarks
This property contains a value if this fault was triggered by another fault that is of interest to the caller.
See Also

Reference

InvalidEmailAddressFormatFault Class
DoubleTake.Common.Contract Namespace


InvalidEmailAddressFormatFault.Message Property

InvalidEmailAddressFormatFaultMessage Property
Gets or sets the fault error message.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Message { get; set; }
Public Property Message As String
    Get
    Set
public:
virtual property String^ Message {
    String^ get () sealed;
    void set (String^ value) sealed;
}
function get_Message();
function set_Message(value);

Property Value

Type: String
The fault error message.

Implements

ICommonFaultMessage
See Also

Reference

InvalidEmailAddressFormatFault Class
DoubleTake.Common.Contract Namespace


InvalidEmailAddressFormatFault.Name Property

InvalidEmailAddressFormatFaultName Property
Gets or sets the name of the fault.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get () sealed;
    void set (String^ value) sealed;
}
function get_Name();
function set_Name(value);

Property Value

Type: String
The name of the fault.

Implements

ICommonFaultName
See Also

Reference

InvalidEmailAddressFormatFault Class
DoubleTake.Common.Contract Namespace


InvalidEmailAddressFormatFault.StackTrace Property

InvalidEmailAddressFormatFaultStackTrace Property
Gets or sets the stack trace from the service that indicates where an unhandled exception occurred.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string StackTrace { get; set; }
Public Property StackTrace As String
    Get
    Set
public:
virtual property String^ StackTrace {
    String^ get () sealed;
    void set (String^ value) sealed;
}
function get_StackTrace();
function set_StackTrace(value);

Property Value

Type: String
The stack trace from the service.

Implements

ICommonFaultStackTrace
See Also

Reference

InvalidEmailAddressFormatFault Class
DoubleTake.Common.Contract Namespace


InvalidOperationFault Class

InvalidOperationFault Class
Represents a fault that is thrown when a method call is invalid for the service's current state.
Inheritance Hierarchy
SystemObject
DoubleTake.Common.ContractInvalidOperationFault

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public sealed class InvalidOperationFault : ICommonFault,
    IExtensibleDataObject
Public NotInheritable Class InvalidOperationFault
    Implements ICommonFault, IExtensibleDataObject
public ref class InvalidOperationFault sealed : ICommonFault,
    IExtensibleDataObject
DoubleTake.Common.Contract.InvalidOperationFault = function();

Type.createClass(
    'DoubleTake.Common.Contract.InvalidOperationFault',
    null,
    DoubleTake.Common.Contract.ICommonFault,
    IExtensibleDataObject);

The InvalidOperationFault type exposes the following members.

Constructors
 | Name | Description
Public method | InvalidOperationFault | Initializes a new instance of the InvalidOperationFault class
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | InnerFault | Gets or sets the inner fault.
Public property | Message | Gets or sets the fault error message.
Public property | Name | Gets or sets the name of the fault.
Public property | StackTrace | Gets or sets the stack trace from the service that indicates where an unhandled exception occurred.
Top
See Also

Reference

DoubleTake.Common.Contract Namespace


InvalidOperationFault Constructor

InvalidOperationFault Constructor
Initializes a new instance of the InvalidOperationFault class

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public InvalidOperationFault()
Public Sub New
public:
InvalidOperationFault()
DoubleTake.Common.Contract.InvalidOperationFault = function();
See Also

Reference

InvalidOperationFault Class
DoubleTake.Common.Contract Namespace


InvalidOperationFault Properties

InvalidOperationFault Properties

The InvalidOperationFault type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | InnerFault | Gets or sets the inner fault.
Public property | Message | Gets or sets the fault error message.
Public property | Name | Gets or sets the name of the fault.
Public property | StackTrace | Gets or sets the stack trace from the service that indicates where an unhandled exception occurred.
Top
See Also

Reference

InvalidOperationFault Class
DoubleTake.Common.Contract Namespace


InvalidOperationFault.ExtensionData Property

InvalidOperationFaultExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

InvalidOperationFault Class
DoubleTake.Common.Contract Namespace


InvalidOperationFault.InnerFault Property

InvalidOperationFaultInnerFault Property
Gets or sets the inner fault.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ICommonFault InnerFault { get; set; }
Public Property InnerFault As ICommonFault
    Get
    Set
public:
virtual property ICommonFault^ InnerFault {
    ICommonFault^ get () sealed;
    void set (ICommonFault^ value) sealed;
}
function get_InnerFault();
function set_InnerFault(value);

Property Value

Type: ICommonFault
An instance of ICommonFault that represents the inner fault.

Implements

ICommonFaultInnerFault
Remarks
This property contains a value if this fault was triggered by another fault that is of interest to the caller.
See Also

Reference

InvalidOperationFault Class
DoubleTake.Common.Contract Namespace


InvalidOperationFault.Message Property

InvalidOperationFaultMessage Property
Gets or sets the fault error message.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Message { get; set; }
Public Property Message As String
    Get
    Set
public:
virtual property String^ Message {
    String^ get () sealed;
    void set (String^ value) sealed;
}
function get_Message();
function set_Message(value);

Property Value

Type: String
The fault error message.

Implements

ICommonFaultMessage
See Also

Reference

InvalidOperationFault Class
DoubleTake.Common.Contract Namespace


InvalidOperationFault.Name Property

InvalidOperationFaultName Property
Gets or sets the name of the fault.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get () sealed;
    void set (String^ value) sealed;
}
function get_Name();
function set_Name(value);

Property Value

Type: String
The name of the fault.

Implements

ICommonFaultName
See Also

Reference

InvalidOperationFault Class
DoubleTake.Common.Contract Namespace


InvalidOperationFault.StackTrace Property

InvalidOperationFaultStackTrace Property
Gets or sets the stack trace from the service that indicates where an unhandled exception occurred.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string StackTrace { get; set; }
Public Property StackTrace As String
    Get
    Set
public:
virtual property String^ StackTrace {
    String^ get () sealed;
    void set (String^ value) sealed;
}
function get_StackTrace();
function set_StackTrace(value);

Property Value

Type: String
The stack trace from the service.

Implements

ICommonFaultStackTrace
See Also

Reference

InvalidOperationFault Class
DoubleTake.Common.Contract Namespace


IProtectableItem Interface

IProtectableItem Interface
Defines a common interface between LogicalItem and PhysicalItem.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public interface IProtectableItem
Public Interface IProtectableItem
public interface class IProtectableItem
DoubleTake.Common.Contract.IProtectableItem = function();
DoubleTake.Common.Contract.IProtectableItem.createInterface('DoubleTake.Common.Contract.IProtectableItem');

The IProtectableItem type exposes the following members.

Properties
 | Name | Description
Public property | IsContainer | Gets a value indicating whether this item is a container of other items.
Public property | IsReadOnly | Gets a value indicating whether this item is read only; that is, its [P:Saturation] cannot be changed.
Public property | ItemType | Gets the type of this item.
Public property | Name | Gets the name of this item. Typically this name is displayed in the user interface.
Public property | Path | Gets the path that unique identifies this item.
Public property | Saturation | Gets or sets the saturation level of this item. Typically this value is used to display a visual state in the user interface.
Top
See Also

Reference

DoubleTake.Common.Contract Namespace


IProtectableItem Properties

IProtectableItem Properties

The IProtectableItem type exposes the following members.

Properties
 | Name | Description
Public property | IsContainer | Gets a value indicating whether this item is a container of other items.
Public property | IsReadOnly | Gets a value indicating whether this item is read only; that is, its [P:Saturation] cannot be changed.
Public property | ItemType | Gets the type of this item.
Public property | Name | Gets the name of this item. Typically this name is displayed in the user interface.
Public property | Path | Gets the path that unique identifies this item.
Public property | Saturation | Gets or sets the saturation level of this item. Typically this value is used to display a visual state in the user interface.
Top
See Also

Reference

IProtectableItem Interface
DoubleTake.Common.Contract Namespace


IProtectableItem.IsContainer Property

IProtectableItemIsContainer Property
Gets a value indicating whether this item is a container of other items.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
bool IsContainer { get; }
ReadOnly Property IsContainer As Boolean
    Get
property bool IsContainer {
    bool get ();
}
function get_IsContainer();

Property Value

Type: Boolean
if this item is a container; otherwise, .
See Also

Reference

IProtectableItem Interface
DoubleTake.Common.Contract Namespace


IProtectableItem.IsReadOnly Property

IProtectableItemIsReadOnly Property
Gets a value indicating whether this item is read only; that is, its [P:Saturation] cannot be changed.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
bool IsReadOnly { get; set; }
Property IsReadOnly As Boolean
    Get
    Set
property bool IsReadOnly {
    bool get ();
    void set (bool value);
}
function get_IsReadOnly();
function set_IsReadOnly(value);

Property Value

Type: Boolean
if this item is read only; otherwise, .
See Also

Reference

IProtectableItem Interface
DoubleTake.Common.Contract Namespace


IProtectableItem.ItemType Property

IProtectableItemItemType Property
Gets the type of this item.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
string ItemType { get; }
ReadOnly Property ItemType As String
    Get
property String^ ItemType {
    String^ get ();
}
function get_ItemType();

Property Value

Type: String
The type of this item.
See Also

Reference

IProtectableItem Interface
DoubleTake.Common.Contract Namespace


IProtectableItem.Name Property

IProtectableItemName Property
Gets the name of this item. Typically this name is displayed in the user interface.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
string Name { get; }
ReadOnly Property Name As String
    Get
property String^ Name {
    String^ get ();
}
function get_Name();

Property Value

Type: String
The name of this item.
See Also

Reference

IProtectableItem Interface
DoubleTake.Common.Contract Namespace


IProtectableItem.Path Property

IProtectableItemPath Property
Gets the path that unique identifies this item.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
string Path { get; }
ReadOnly Property Path As String
    Get
property String^ Path {
    String^ get ();
}
function get_Path();

Property Value

Type: String
The path of this item.
See Also

Reference

IProtectableItem Interface
DoubleTake.Common.Contract Namespace


IProtectableItem.Saturation Property

IProtectableItemSaturation Property
Gets or sets the saturation level of this item. Typically this value is used to display a visual state in the user interface.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
SaturationLevel Saturation { get; set; }
Property Saturation As SaturationLevel
    Get
    Set
property SaturationLevel Saturation {
    SaturationLevel get ();
    void set (SaturationLevel value);
}
function get_Saturation();
function set_Saturation(value);

Property Value

Type: SaturationLevel
The saturation level.
See Also

Reference

IProtectableItem Interface
DoubleTake.Common.Contract Namespace


IWorkloadManager Interface

IWorkloadManager Interface
Provides methods for creating and managing workloads on a server.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public interface IWorkloadManager
Public Interface IWorkloadManager
public interface class IWorkloadManager
DoubleTake.Common.Contract.IWorkloadManager = function();
DoubleTake.Common.Contract.IWorkloadManager.createInterface('DoubleTake.Common.Contract.IWorkloadManager');

The IWorkloadManager type exposes the following members.

Methods
 | Name | Description
Public method | AddPhysicalRule | Adds a physical rule to a workload.
Public method | Close | Closes the workload instance on the server.
Public method | Create | Creates a new workload instance of the given type on the server.
Public method | CreateFrom | Creates a new workload instance on the server, given an existing workload.
Public method | CreateFromWithDelegation | Creates a new workload instance on the server, given an existing workload. Credentials are provided to enable delegation to other machines.
Public method | CreateUsingImage | Creates a new workload instance of the given type on the server using the image at the given image path. Optionally, pass in a snapshot id to use that snapshot of the image.
Public method | CreateUsingImageWithDelegation | Creates a new workload instance of the given type on the server using the image at the given image path. Optionally, pass in a snapshot id to use that snapshot of the image.
Public method | CreateWithDelegation | Creates a new workload instance of the given type on the server.
Public method | GetLogicalItems | Gets the logical items that can be included in a workload.
Public method | GetPhysicalItems | Gets the physical items that can be included in a workload.
Public method | GetRecommendedPathTransformations | Gets the recommended path transformations for a workload.
Public method | GetWorkload | Gets the workload from the server.
Public method | GetWorkloads | Gets all the active workloads from the server.
Public method | GetWorkloadTypes | Gets the workload types available on a server.
Public method | RemovePhysicalRule | Removes a physical rule from a workload.
Public method | SelectLogicalItem | Selects a logical item for a workload.
Public method | UnselectLogicalItem | Unselects a logical item for a workload.
Top
See Also

Reference

DoubleTake.Common.Contract Namespace


IWorkloadManager Methods

IWorkloadManager Methods

The IWorkloadManager type exposes the following members.

Methods
 | Name | Description
Public method | AddPhysicalRule | Adds a physical rule to a workload.
Public method | Close | Closes the workload instance on the server.
Public method | Create | Creates a new workload instance of the given type on the server.
Public method | CreateFrom | Creates a new workload instance on the server, given an existing workload.
Public method | CreateFromWithDelegation | Creates a new workload instance on the server, given an existing workload. Credentials are provided to enable delegation to other machines.
Public method | CreateUsingImage | Creates a new workload instance of the given type on the server using the image at the given image path. Optionally, pass in a snapshot id to use that snapshot of the image.
Public method | CreateUsingImageWithDelegation | Creates a new workload instance of the given type on the server using the image at the given image path. Optionally, pass in a snapshot id to use that snapshot of the image.
Public method | CreateWithDelegation | Creates a new workload instance of the given type on the server.
Public method | GetLogicalItems | Gets the logical items that can be included in a workload.
Public method | GetPhysicalItems | Gets the physical items that can be included in a workload.
Public method | GetRecommendedPathTransformations | Gets the recommended path transformations for a workload.
Public method | GetWorkload | Gets the workload from the server.
Public method | GetWorkloads | Gets all the active workloads from the server.
Public method | GetWorkloadTypes | Gets the workload types available on a server.
Public method | RemovePhysicalRule | Removes a physical rule from a workload.
Public method | SelectLogicalItem | Selects a logical item for a workload.
Public method | UnselectLogicalItem | Unselects a logical item for a workload.
Top
See Also

Reference

IWorkloadManager Interface
DoubleTake.Common.Contract Namespace


IWorkloadManager.AddPhysicalRule Method

IWorkloadManagerAddPhysicalRule Method
Adds a physical rule to a workload.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
ChangedItems AddPhysicalRule(
    Guid workloadId,
    PhysicalRule physicalRule
)
Function AddPhysicalRule (
    workloadId As Guid,
    physicalRule As PhysicalRule
) As ChangedItems
ChangedItems^ AddPhysicalRule(
    Guid workloadId,
    PhysicalRule^ physicalRule
)
function AddPhysicalRule(workloadId, physicalRule);

Parameters

workloadId
Type: SystemGuid
The workload id.
physicalRule
Type: DoubleTake.Common.ContractPhysicalRule
The physical rule.

Return Value

Type: ChangedItems
A ChangedItems that includes all affected physical items, logical items, and physical rules.
Exceptions
Exception | Condition
ArgumentNullException | workloadId is .
ArgumentOutOfRangeException | There is no workload whose id matches workloadId.
See Also

Reference

IWorkloadManager Interface
DoubleTake.Common.Contract Namespace


IWorkloadManager.Close Method

IWorkloadManagerClose Method
Closes the workload instance on the server.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
void Close(
    Guid workloadId
)
Sub Close (
    workloadId As Guid
)
void Close(
    Guid workloadId
)
function Close(workloadId);

Parameters

workloadId
Type: SystemGuid
The workload id.
Exceptions
Exception | Condition
ArgumentNullException | workloadId is .
Remarks
Clients should close workloads after they are done manipulating them on the server. Closing a workload will release its unmanaged resources and allow its memory to be garbage collected.
See Also

Reference

IWorkloadManager Interface
DoubleTake.Common.Contract Namespace


IWorkloadManager.Create Method

IWorkloadManagerCreate Method
Creates a new workload instance of the given type on the server.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
Guid Create(
    string workloadTypeName
)
Function Create (
    workloadTypeName As String
) As Guid
Guid Create(
    String^ workloadTypeName
)
function Create(workloadTypeName);

Parameters

workloadTypeName
Type: SystemString
Name of the workload type.

Return Value

Type: Guid
An id that uniquely identifies this instance of the workload on the server.
Exceptions
Exception | Condition
ArgumentNullException | workloadTypeName is or a zero-length string.
ArgumentOutOfRangeException | There is no registered workload type whose name matches workloadTypeName.
Remarks
This method will typically be called by clients creating new workloads for the first time. The id returned from [M:Create] can be used for further operations on the workload. Clients should call [M:Close] when they are finished modifying the workload instance.
See Also

Reference

IWorkloadManager Interface
DoubleTake.Common.Contract Namespace


IWorkloadManager.CreateFrom Method

IWorkloadManagerCreateFrom Method
Creates a new workload instance on the server, given an existing workload.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
Guid CreateFrom(
    Workload workload
)
Function CreateFrom (
    workload As Workload
) As Guid
Guid CreateFrom(
    Workload^ workload
)
function CreateFrom(workload);

Parameters

workload
Type: DoubleTake.Common.ContractWorkload
An existing Workload that describes the workload to be created on the server.

Return Value

Type: Guid
An id that uniquely identifies this instance of the workload on the server.
Exceptions
Exception | Condition
ArgumentNullException | workload is .
ArgumentOutOfRangeException | There is no registered workload type whose name matches the value for [P:WorkloadTypeName] on workload.
Remarks
This method will typically be called by clients creating workloads that already exist with a job. The id returned from [M:Create] can be used for further operations on the workload. Clients should call [M:Close] when they are finished modifying the workload instance.
See Also

Reference

IWorkloadManager Interface
DoubleTake.Common.Contract Namespace


IWorkloadManager.CreateFromWithDelegation Method

IWorkloadManagerCreateFromWithDelegation Method
Creates a new workload instance on the server, given an existing workload. Credentials are provided to enable delegation to other machines.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
Guid CreateFromWithDelegation(
    Workload workload,
    Uri hostUri
)
Function CreateFromWithDelegation (
    workload As Workload,
    hostUri As Uri
) As Guid
Guid CreateFromWithDelegation(
    Workload^ workload,
    Uri^ hostUri
)
function CreateFromWithDelegation(workload, hostUri);

Parameters

workload
Type: DoubleTake.Common.ContractWorkload
An existing Workload that describes the workload to be created on the server.
hostUri
Type: SystemUri
The host URI that contains the credentials.

Return Value

Type: Guid
An id that uniquely identifies this instance of the workload on the server.
Exceptions
Exception | Condition
ArgumentNullException | workload is .
ArgumentOutOfRangeException | There is no registered workload type whose name matches the value for [P:WorkloadTypeName] on workload.
Remarks
This method will typically be called by clients creating workloads that already exist with a job. The id returned from [M:Create] can be used for further operations on the workload. Clients should call [M:Close] when they are finished modifying the workload instance.
See Also

Reference

IWorkloadManager Interface
DoubleTake.Common.Contract Namespace


IWorkloadManager.CreateUsingImage Method

IWorkloadManagerCreateUsingImage Method
Creates a new workload instance of the given type on the server using the image at the given image path. Optionally, pass in a snapshot id to use that snapshot of the image.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
Guid CreateUsingImage(
    string workloadTypeName,
    Guid imageId,
    Guid snapshotId
)
Function CreateUsingImage (
    workloadTypeName As String,
    imageId As Guid,
    snapshotId As Guid
) As Guid
Guid CreateUsingImage(
    String^ workloadTypeName,
    Guid imageId,
    Guid snapshotId
)
function CreateUsingImage(workloadTypeName, imageId, snapshotId);

Parameters

workloadTypeName
Type: SystemString
Name of the workload type.
imageId
Type: SystemGuid
Id of the image.
snapshotId
Type: SystemGuid
Optional ID of the snapshot of the image to use.

Return Value

Type: Guid
An id that uniquely identifies this instance of the workload on the server.
Exceptions
Exception | Condition
ArgumentNullException | workloadTypeName is or a zero-length string.
ArgumentOutOfRangeException | There is no registered workload type whose name matches workloadTypeName.
Remarks
This method will typically be called by clients creating new workloads for the first time. The id returned from [M:Create] can be used for further operations on the workload. Clients should call [M:Close] when they are finished modifying the workload instance.
See Also

Reference

IWorkloadManager Interface
DoubleTake.Common.Contract Namespace


IWorkloadManager.CreateUsingImageWithDelegation Method

IWorkloadManagerCreateUsingImageWithDelegation Method
Creates a new workload instance of the given type on the server using the image at the given image path. Optionally, pass in a snapshot id to use that snapshot of the image.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
Guid CreateUsingImageWithDelegation(
    string workloadTypeName,
    Uri hostUri,
    Guid imageId,
    Guid snapshotId
)
Function CreateUsingImageWithDelegation (
    workloadTypeName As String,
    hostUri As Uri,
    imageId As Guid,
    snapshotId As Guid
) As Guid
Guid CreateUsingImageWithDelegation(
    String^ workloadTypeName,
    Uri^ hostUri,
    Guid imageId,
    Guid snapshotId
)
function CreateUsingImageWithDelegation(workloadTypeName, hostUri, imageId, snapshotId);

Parameters

workloadTypeName
Type: SystemString
Name of the workload type.
hostUri
Type: SystemUri
The host URI that contains the credentials.
imageId
Type: SystemGuid
Id of the image.
snapshotId
Type: SystemGuid
Optional ID of the snapshot of the image to use.

Return Value

Type: Guid
An id that uniquely identifies this instance of the workload on the server.
Exceptions
Exception | Condition
ArgumentNullException | workloadTypeName is or a zero-length string.
ArgumentOutOfRangeException | There is no registered workload type whose name matches workloadTypeName.
Remarks
This method will typically be called by clients creating new workloads for the first time. The id returned from [M:Create] can be used for further operations on the workload. Clients should call [M:Close] when they are finished modifying the workload instance.
See Also

Reference

IWorkloadManager Interface
DoubleTake.Common.Contract Namespace


IWorkloadManager.CreateWithDelegation Method

IWorkloadManagerCreateWithDelegation Method
Creates a new workload instance of the given type on the server.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
Guid CreateWithDelegation(
    string workloadTypeName,
    Uri hostUri
)
Function CreateWithDelegation (
    workloadTypeName As String,
    hostUri As Uri
) As Guid
Guid CreateWithDelegation(
    String^ workloadTypeName,
    Uri^ hostUri
)
function CreateWithDelegation(workloadTypeName, hostUri);

Parameters

workloadTypeName
Type: SystemString
Name of the workload type.
hostUri
Type: SystemUri
The host URI that contains the credentials.

Return Value

Type: Guid
An id that uniquely identifies this instance of the workload on the server.
Exceptions
Exception | Condition
ArgumentNullException | workloadTypeName is or a zero-length string.
ArgumentOutOfRangeException | There is no registered workload type whose name matches workloadTypeName.
Remarks
This method will typically be called by clients creating new workloads for the first time. The id returned from [M:Create] can be used for further operations on the workload. Clients should call [M:Close] when they are finished modifying the workload instance.
See Also

Reference

IWorkloadManager Interface
DoubleTake.Common.Contract Namespace


IWorkloadManager.GetLogicalItems Method

IWorkloadManagerGetLogicalItems Method
Gets the logical items that can be included in a workload.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
LogicalItem[] GetLogicalItems(
    Guid workloadId,
    LogicalItem referenceItem
)
Function GetLogicalItems (
    workloadId As Guid,
    referenceItem As LogicalItem
) As LogicalItem()
array<LogicalItem^>^ GetLogicalItems(
    Guid workloadId,
    LogicalItem^ referenceItem
)
function GetLogicalItems(workloadId, referenceItem);

Parameters

workloadId
Type: SystemGuid
The workload id.
referenceItem
Type: DoubleTake.Common.ContractLogicalItem
The item whose children should be enumerated and returned.

Return Value

Type: LogicalItem
An array of LogicalItem that represents the children of referenceItem.
Exceptions
Exception | Condition
ArgumentNullException | workloadId is .
ArgumentOutOfRangeException | There is no workload whose id matches workloadId.
See Also

Reference

IWorkloadManager Interface
DoubleTake.Common.Contract Namespace


IWorkloadManager.GetPhysicalItems Method

IWorkloadManagerGetPhysicalItems Method
Gets the physical items that can be included in a workload.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
PhysicalItem[] GetPhysicalItems(
    Guid workloadId,
    PhysicalItem referenceItem
)
Function GetPhysicalItems (
    workloadId As Guid,
    referenceItem As PhysicalItem
) As PhysicalItem()
array<PhysicalItem^>^ GetPhysicalItems(
    Guid workloadId,
    PhysicalItem^ referenceItem
)
function GetPhysicalItems(workloadId, referenceItem);

Parameters

workloadId
Type: SystemGuid
The workload id.
referenceItem
Type: DoubleTake.Common.ContractPhysicalItem
The item whose children should be enumerated and returned.

Return Value

Type: PhysicalItem
An array of PhysicalItem that represents the children of referenceItem.
Exceptions
Exception | Condition
ArgumentNullException | workloadId is .
ArgumentOutOfRangeException | There is no workload whose id matches workloadId.
See Also

Reference

IWorkloadManager Interface
DoubleTake.Common.Contract Namespace


IWorkloadManager.GetRecommendedPathTransformations Method

IWorkloadManagerGetRecommendedPathTransformations Method
Gets the recommended path transformations for a workload.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
PathTransformation[] GetRecommendedPathTransformations(
    Guid workloadId,
    string basePath
)
Function GetRecommendedPathTransformations (
    workloadId As Guid,
    basePath As String
) As PathTransformation()
array<PathTransformation^>^ GetRecommendedPathTransformations(
    Guid workloadId,
    String^ basePath
)
function GetRecommendedPathTransformations(workloadId, basePath);

Parameters

workloadId
Type: SystemGuid
The workload id.
basePath
Type: SystemString
The base path.

Return Value

Type: PathTransformation
An array of PathTransformation objects, one element in the array for each volume.
Exceptions
Exception | Condition
ArgumentNullException | workloadId is .
ArgumentOutOfRangeException | There is no workload whose id matches workloadId.
Remarks
Providing a base path of will result in a one-to-one volume mapping; otherwise you will be provided with a many-to-one volume mapping based on the provided path.
See Also

Reference

IWorkloadManager Interface
DoubleTake.Common.Contract Namespace


IWorkloadManager.GetWorkload Method

IWorkloadManagerGetWorkload Method
Gets the workload from the server.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
Workload GetWorkload(
    Guid workloadId
)
Function GetWorkload (
    workloadId As Guid
) As Workload
Workload^ GetWorkload(
    Guid workloadId
)
function GetWorkload(workloadId);

Parameters

workloadId
Type: SystemGuid
The workload id.

Return Value

Type: Workload
The workload.
Exceptions
Exception | Condition
ArgumentNullException | workloadId is .
ArgumentOutOfRangeException | There is no workload whose id matches workloadId.
See Also

Reference

IWorkloadManager Interface
DoubleTake.Common.Contract Namespace


IWorkloadManager.GetWorkloads Method

IWorkloadManagerGetWorkloads Method
Gets all the active workloads from the server.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
Workload[] GetWorkloads()
Function GetWorkloads As Workload()
array<Workload^>^ GetWorkloads()
function GetWorkloads();

Return Value

Type: Workload
An array of Workload that represents the active workloads on the server.
See Also

Reference

IWorkloadManager Interface
DoubleTake.Common.Contract Namespace


IWorkloadManager.GetWorkloadTypes Method

IWorkloadManagerGetWorkloadTypes Method
Gets the workload types available on a server.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
WorkloadType[] GetWorkloadTypes(
    ActivationStatus sourceActivationStatus,
    ActivationStatus targetActivationStatus
)
Function GetWorkloadTypes (
    sourceActivationStatus As ActivationStatus,
    targetActivationStatus As ActivationStatus
) As WorkloadType()
array<WorkloadType^>^ GetWorkloadTypes(
    ActivationStatus^ sourceActivationStatus,
    ActivationStatus^ targetActivationStatus
)
function GetWorkloadTypes(sourceActivationStatus, targetActivationStatus);

Parameters

sourceActivationStatus
Type: DoubleTake.Core.ContractActivationStatus
An ActivationStatus value that represents the source server of the job. Pass to use the activation status of the server hosting IWorkloadManager.
targetActivationStatus
Type: DoubleTake.Core.ContractActivationStatus
An ActivationStatus value that represents the target server of the job. Pass to use the activation status of the server hosting IWorkloadManager.

Return Value

Type: WorkloadType
An array of WorkloadType representing the possible workload types on a server.
Remarks
Typically, clients will communicate with IWorkloadManager on the source server to configure a workload, then pass that workload to the target when creating a job. Thus, when retrieving workload types to display to the user, clients will frequently pass for sourceActivationStatus, and a target activation status that represents likely target servers for targetActivationStatus.
See Also

Reference

IWorkloadManager Interface
DoubleTake.Common.Contract Namespace


IWorkloadManager.RemovePhysicalRule Method

IWorkloadManagerRemovePhysicalRule Method
Removes a physical rule from a workload.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
ChangedItems RemovePhysicalRule(
    Guid workloadId,
    PhysicalRule physicalRule
)
Function RemovePhysicalRule (
    workloadId As Guid,
    physicalRule As PhysicalRule
) As ChangedItems
ChangedItems^ RemovePhysicalRule(
    Guid workloadId,
    PhysicalRule^ physicalRule
)
function RemovePhysicalRule(workloadId, physicalRule);

Parameters

workloadId
Type: SystemGuid
The workload id.
physicalRule
Type: DoubleTake.Common.ContractPhysicalRule
The physical rule.

Return Value

Type: ChangedItems
A ChangedItems that includes all affected physical items, logical items, and physical rules.
Exceptions
Exception | Condition
ArgumentNullException | workloadId is .
ArgumentOutOfRangeException | There is no workload whose id matches workloadId.
See Also

Reference

IWorkloadManager Interface
DoubleTake.Common.Contract Namespace


IWorkloadManager.SelectLogicalItem Method

IWorkloadManagerSelectLogicalItem Method
Selects a logical item for a workload.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
ChangedItems SelectLogicalItem(
    Guid workloadId,
    string logicalItemPath
)
Function SelectLogicalItem (
    workloadId As Guid,
    logicalItemPath As String
) As ChangedItems
ChangedItems^ SelectLogicalItem(
    Guid workloadId,
    String^ logicalItemPath
)
function SelectLogicalItem(workloadId, logicalItemPath);

Parameters

workloadId
Type: SystemGuid
The workload id.
logicalItemPath
Type: SystemString
The logical item path.

Return Value

Type: ChangedItems
A ChangedItems that includes all affected physical items, logical items, and physical rules.
Exceptions
Exception | Condition
ArgumentNullException | workloadId is .
ArgumentOutOfRangeException | There is no workload whose id matches workloadId.
See Also

Reference

IWorkloadManager Interface
DoubleTake.Common.Contract Namespace


IWorkloadManager.UnselectLogicalItem Method

IWorkloadManagerUnselectLogicalItem Method
Unselects a logical item for a workload.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
ChangedItems UnselectLogicalItem(
    Guid workloadId,
    string logicalItemPath
)
Function UnselectLogicalItem (
    workloadId As Guid,
    logicalItemPath As String
) As ChangedItems
ChangedItems^ UnselectLogicalItem(
    Guid workloadId,
    String^ logicalItemPath
)
function UnselectLogicalItem(workloadId, logicalItemPath);

Parameters

workloadId
Type: SystemGuid
The workload id.
logicalItemPath
Type: SystemString
The logical item path.

Return Value

Type: ChangedItems
A ChangedItems that includes all affected physical items, logical items, and physical rules.
Exceptions
Exception | Condition
ArgumentNullException | workloadId is .
ArgumentOutOfRangeException | There is no workload whose id matches workloadId.
See Also

Reference

IWorkloadManager Interface
DoubleTake.Common.Contract Namespace


LogicalItem Class

LogicalItem Class
Represents an item that can be protected in workload. Logical items are meaningful to the user outside of a specific file system item.
Inheritance Hierarchy
SystemObject
DoubleTake.Common.ContractLogicalItem

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class LogicalItem : IProtectableItem,
    IExtensibleDataObject
Public Class LogicalItem
    Implements IProtectableItem, IExtensibleDataObject
public ref class LogicalItem : IProtectableItem,
    IExtensibleDataObject
DoubleTake.Common.Contract.LogicalItem = function();

Type.createClass(
    'DoubleTake.Common.Contract.LogicalItem',
    null,
    DoubleTake.Common.Contract.IProtectableItem,
    IExtensibleDataObject);

The LogicalItem type exposes the following members.

Constructors
 | Name | Description
Public method | LogicalItem | Initializes a new instance of the LogicalItem class
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | IsContainer | Gets or sets a value indicating whether this item is a container of other items.
Public property | IsReadOnly | Gets or sets a value indicating whether this item is read only; that is, its [P:Saturation] cannot be changed.
Public property | ItemType | Gets or sets the type of this item.
Public property | Metadata | This value is any additional metadata that may be displayed for a particular type of item. This metadata is not in any particular format, but you must be able to determine the format and decipher the metadata based on the type.
Public property | Name | Gets or sets the name of this item. Typically this name is displayed in the user interface.
Public property | Path | Gets or sets the path that unique identifies this item.
Public property | Saturation | Gets or sets the saturation level of this item. Typically this value is used to display a visual state in the user interface.
Public property | SaturationDefault | This value is the default saturation level of the item. Typically, this value is used to display a visual state in the user interface.
Top
See Also

Reference

DoubleTake.Common.Contract Namespace


LogicalItem Constructor

LogicalItem Constructor
Initializes a new instance of the LogicalItem class

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public LogicalItem()
Public Sub New
public:
LogicalItem()
DoubleTake.Common.Contract.LogicalItem = function();
See Also

Reference

LogicalItem Class
DoubleTake.Common.Contract Namespace


LogicalItem Properties

LogicalItem Properties

The LogicalItem type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | IsContainer | Gets or sets a value indicating whether this item is a container of other items.
Public property | IsReadOnly | Gets or sets a value indicating whether this item is read only; that is, its [P:Saturation] cannot be changed.
Public property | ItemType | Gets or sets the type of this item.
Public property | Metadata | This value is any additional metadata that may be displayed for a particular type of item. This metadata is not in any particular format, but you must be able to determine the format and decipher the metadata based on the type.
Public property | Name | Gets or sets the name of this item. Typically this name is displayed in the user interface.
Public property | Path | Gets or sets the path that unique identifies this item.
Public property | Saturation | Gets or sets the saturation level of this item. Typically this value is used to display a visual state in the user interface.
Public property | SaturationDefault | This value is the default saturation level of the item. Typically, this value is used to display a visual state in the user interface.
Top
See Also

Reference

LogicalItem Class
DoubleTake.Common.Contract Namespace


LogicalItem.ExtensionData Property

LogicalItemExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

LogicalItem Class
DoubleTake.Common.Contract Namespace


LogicalItem.IsContainer Property

LogicalItemIsContainer Property
Gets or sets a value indicating whether this item is a container of other items.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsContainer { get; set; }
Public Property IsContainer As Boolean
    Get
    Set
public:
virtual property bool IsContainer {
    bool get () sealed;
    void set (bool value) sealed;
}
function get_IsContainer();
function set_IsContainer(value);

Property Value

Type: Boolean
if this item is a container; otherwise, .

Implements

IProtectableItemIsContainer
See Also

Reference

LogicalItem Class
DoubleTake.Common.Contract Namespace


LogicalItem.IsReadOnly Property

LogicalItemIsReadOnly Property
Gets or sets a value indicating whether this item is read only; that is, its [P:Saturation] cannot be changed.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsReadOnly { get; set; }
Public Property IsReadOnly As Boolean
    Get
    Set
public:
virtual property bool IsReadOnly {
    bool get () sealed;
    void set (bool value) sealed;
}
function get_IsReadOnly();
function set_IsReadOnly(value);

Property Value

Type: Boolean
if this item is read only; otherwise, .

Implements

IProtectableItemIsReadOnly
See Also

Reference

LogicalItem Class
DoubleTake.Common.Contract Namespace


LogicalItem.ItemType Property

LogicalItemItemType Property
Gets or sets the type of this item.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string ItemType { get; set; }
Public Property ItemType As String
    Get
    Set
public:
virtual property String^ ItemType {
    String^ get () sealed;
    void set (String^ value) sealed;
}
function get_ItemType();
function set_ItemType(value);

Property Value

Type: String
The type of this item.

Implements

IProtectableItemItemType
See Also

Reference

LogicalItem Class
DoubleTake.Common.Contract Namespace


LogicalItem.Metadata Property

LogicalItemMetadata Property
This value is any additional metadata that may be displayed for a particular type of item. This metadata is not in any particular format, but you must be able to determine the format and decipher the metadata based on the type.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Metadata { get; set; }
Public Property Metadata As String
    Get
    Set
public:
property String^ Metadata {
    String^ get ();
    void set (String^ value);
}
function get_Metadata();
function set_Metadata(value);

Property Value

Type: String
The metadata.
Remarks
This property is used to specify any additional metadata that may be displayed for a particular type of item. This metadata is not in any particular format, but one must be able to determine the format and decipher the metadata based on the type.
See Also

Reference

LogicalItem Class
DoubleTake.Common.Contract Namespace


LogicalItem.Name Property

LogicalItemName Property
Gets or sets the name of this item. Typically this name is displayed in the user interface.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get () sealed;
    void set (String^ value) sealed;
}
function get_Name();
function set_Name(value);

Property Value

Type: String
The name of this item.

Implements

IProtectableItemName
See Also

Reference

LogicalItem Class
DoubleTake.Common.Contract Namespace


LogicalItem.Path Property

LogicalItemPath Property
Gets or sets the path that unique identifies this item.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Path { get; set; }
Public Property Path As String
    Get
    Set
public:
virtual property String^ Path {
    String^ get () sealed;
    void set (String^ value) sealed;
}
function get_Path();
function set_Path(value);

Property Value

Type: String
The path of this item.

Implements

IProtectableItemPath
See Also

Reference

LogicalItem Class
DoubleTake.Common.Contract Namespace


LogicalItem.Saturation Property

LogicalItemSaturation Property
Gets or sets the saturation level of this item. Typically this value is used to display a visual state in the user interface.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public SaturationLevel Saturation { get; set; }
Public Property Saturation As SaturationLevel
    Get
    Set
public:
virtual property SaturationLevel Saturation {
    SaturationLevel get () sealed;
    void set (SaturationLevel value) sealed;
}
function get_Saturation();
function set_Saturation(value);

Property Value

Type: SaturationLevel
The saturation level.

Implements

IProtectableItemSaturation
See Also

Reference

LogicalItem Class
DoubleTake.Common.Contract Namespace


LogicalItem.SaturationDefault Property

LogicalItemSaturationDefault Property
This value is the default saturation level of the item. Typically, this value is used to display a visual state in the user interface.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public SaturationLevel SaturationDefault { get; set; }
Public Property SaturationDefault As SaturationLevel
    Get
    Set
public:
property SaturationLevel SaturationDefault {
    SaturationLevel get ();
    void set (SaturationLevel value);
}
function get_SaturationDefault();
function set_SaturationDefault(value);

Property Value

Type: SaturationLevel
The default saturation level.
See Also

Reference

LogicalItem Class
DoubleTake.Common.Contract Namespace


NameValuePair Class

NameValuePair Class
Represents a generic name-value pair data structure.
Inheritance Hierarchy
SystemObject
DoubleTake.Common.ContractNameValuePair

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class NameValuePair : IExtensibleDataObject
Public Class NameValuePair
    Implements IExtensibleDataObject
public ref class NameValuePair : IExtensibleDataObject
DoubleTake.Common.Contract.NameValuePair = function();

Type.createClass(
    'DoubleTake.Common.Contract.NameValuePair',
    null,
    IExtensibleDataObject);

The NameValuePair type exposes the following members.

Constructors
 | Name | Description
Public method | NameValuePair | Initializes a new instance of the NameValuePair class
Top
Properties
 | Name | Description
Public property | Encrypted | Gets or sets a value indicating whether this NameValuePair is encrypted.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Name | Gets or sets the name associated with the value.
Public property | Value | Gets or sets the value associated with the name.
Top
See Also

Reference

DoubleTake.Common.Contract Namespace


NameValuePair Constructor

NameValuePair Constructor
Initializes a new instance of the NameValuePair class

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public NameValuePair()
Public Sub New
public:
NameValuePair()
DoubleTake.Common.Contract.NameValuePair = function();
See Also

Reference

NameValuePair Class
DoubleTake.Common.Contract Namespace


NameValuePair Properties

NameValuePair Properties

The NameValuePair type exposes the following members.

Properties
 | Name | Description
Public property | Encrypted | Gets or sets a value indicating whether this NameValuePair is encrypted.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Name | Gets or sets the name associated with the value.
Public property | Value | Gets or sets the value associated with the name.
Top
See Also

Reference

NameValuePair Class
DoubleTake.Common.Contract Namespace


NameValuePair.Encrypted Property

NameValuePairEncrypted Property
Gets or sets a value indicating whether this NameValuePair is encrypted.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool Encrypted { get; set; }
Public Property Encrypted As Boolean
    Get
    Set
public:
property bool Encrypted {
    bool get ();
    void set (bool value);
}
function get_Encrypted();
function set_Encrypted(value);

Property Value

Type: Boolean
if encrypted; otherwise, .
See Also

Reference

NameValuePair Class
DoubleTake.Common.Contract Namespace


NameValuePair.ExtensionData Property

NameValuePairExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

NameValuePair Class
DoubleTake.Common.Contract Namespace


NameValuePair.Name Property

NameValuePairName Property
Gets or sets the name associated with the value.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
function get_Name();
function set_Name(value);

Property Value

Type: String
The name associated with the value.
See Also

Reference

NameValuePair Class
DoubleTake.Common.Contract Namespace


NameValuePair.Value Property

NameValuePairValue Property
Gets or sets the value associated with the name.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Object Value { get; set; }
Public Property Value As Object
    Get
    Set
public:
property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}
function get_Value();
function set_Value(value);

Property Value

Type: Object
The value associated with the name.
See Also

Reference

NameValuePair Class
DoubleTake.Common.Contract Namespace


PathTransformation Class

PathTransformation Class
Represents a transform path for a replication rule.
Inheritance Hierarchy
SystemObject
DoubleTake.Common.ContractPathTransformation

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public sealed class PathTransformation : IExtensibleDataObject
Public NotInheritable Class PathTransformation
    Implements IExtensibleDataObject
public ref class PathTransformation sealed : IExtensibleDataObject
DoubleTake.Common.Contract.PathTransformation = function();

Type.createClass(
    'DoubleTake.Common.Contract.PathTransformation',
    null,
    IExtensibleDataObject);

The PathTransformation type exposes the following members.

Constructors
 | Name | Description
Public method | PathTransformation | Initializes a new instance of the PathTransformation class
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | SourcePath | This value is the path on the source.
Public property | TargetPath | This value is the path on the target.
Top
Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | ToString | Returns a String that represents this instance. (Overrides ObjectToString.)
Top
See Also

Reference

DoubleTake.Common.Contract Namespace


PathTransformation Constructor

PathTransformation Constructor
Initializes a new instance of the PathTransformation class

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public PathTransformation()
Public Sub New
public:
PathTransformation()
DoubleTake.Common.Contract.PathTransformation = function();
See Also

Reference

PathTransformation Class
DoubleTake.Common.Contract Namespace


PathTransformation Properties

PathTransformation Properties

The PathTransformation type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | SourcePath | This value is the path on the source.
Public property | TargetPath | This value is the path on the target.
Top
See Also

Reference

PathTransformation Class
DoubleTake.Common.Contract Namespace


PathTransformation.ExtensionData Property

PathTransformationExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

PathTransformation Class
DoubleTake.Common.Contract Namespace


PathTransformation.SourcePath Property

PathTransformationSourcePath Property
This value is the path on the source.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string SourcePath { get; set; }
Public Property SourcePath As String
    Get
    Set
public:
property String^ SourcePath {
    String^ get ();
    void set (String^ value);
}
function get_SourcePath();
function set_SourcePath(value);

Property Value

Type: String
The source path.
See Also

Reference

PathTransformation Class
DoubleTake.Common.Contract Namespace


PathTransformation.TargetPath Property

PathTransformationTargetPath Property
This value is the path on the target.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string TargetPath { get; set; }
Public Property TargetPath As String
    Get
    Set
public:
property String^ TargetPath {
    String^ get ();
    void set (String^ value);
}
function get_TargetPath();
function set_TargetPath(value);

Property Value

Type: String
The target path.
See Also

Reference

PathTransformation Class
DoubleTake.Common.Contract Namespace


PathTransformation Methods

PathTransformation Methods

The PathTransformation type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | ToString | Returns a String that represents this instance. (Overrides ObjectToString.)
Top
See Also

Reference

PathTransformation Class
DoubleTake.Common.Contract Namespace


PathTransformation.Clone Method

PathTransformationClone Method
Creates a new object that is a copy of the current instance.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
function Clone();

Return Value

Type: Object
A new object that is a copy of this instance.
See Also

Reference

PathTransformation Class
DoubleTake.Common.Contract Namespace


PathTransformation.ToString Method

PathTransformationToString Method
Returns a String that represents this instance.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
function ToString();

Return Value

Type: String
A String that represents this instance.
See Also

Reference

PathTransformation Class
DoubleTake.Common.Contract Namespace


PhysicalItem Class

PhysicalItem Class
Represents an item that can be protected in workload. Physical items map directly to file system items.
Inheritance Hierarchy
SystemObject
DoubleTake.Common.ContractPhysicalItem
DoubleTake.Common.ContractFileSystemItem
DoubleTake.Common.ContractVolume

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class PhysicalItem : IProtectableItem,
    IExtensibleDataObject
Public Class PhysicalItem
    Implements IProtectableItem, IExtensibleDataObject
public ref class PhysicalItem : IProtectableItem,
    IExtensibleDataObject
DoubleTake.Common.Contract.PhysicalItem = function();

Type.createClass(
    'DoubleTake.Common.Contract.PhysicalItem',
    null,
    DoubleTake.Common.Contract.IProtectableItem,
    IExtensibleDataObject);

The PhysicalItem type exposes the following members.

Constructors
 | Name | Description
Public method | PhysicalItem | Initializes a new instance of the PhysicalItem class
Top
Properties
 | Name | Description
Public property | Attributes | This value represents the file system attributes.
Public property | CreationTime | This value is the time when the item was created.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | IsContainer | This value is true if the item is a container of other items; otherwise, it is false.
Public property | IsReadOnly | This value is true if the item is read-only (meaning the Saturation cannot be changed); otherwise, it is false.
Public property | ItemType | This value is the type of item.
Public property | LastAccessTime | This value is the time when the item was last accessed.
Public property | LastWriteTime | This value is the time when the item was last written to.
Public property | Metadata | This value is any additional metadata that may be displayed for a particular type of item. This metadata is not in any particular format, but you must be able to determine the format and decipher the metadata based on the type.
Public property | Name | This value is the name of the item. Typically, this name is used for display in the user interface.
Public property | Path | This value is the path of the item.
Public property | Saturation | This value represents the saturation level of the item. Typically, this value is used to display a visual state in the user interface.
Public property | Size | This value is the physical size of the item.
Top
See Also

Reference

DoubleTake.Common.Contract Namespace


PhysicalItem Constructor

PhysicalItem Constructor
Initializes a new instance of the PhysicalItem class

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public PhysicalItem()
Public Sub New
public:
PhysicalItem()
DoubleTake.Common.Contract.PhysicalItem = function();
See Also

Reference

PhysicalItem Class
DoubleTake.Common.Contract Namespace


PhysicalItem Properties

PhysicalItem Properties

The PhysicalItem type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | This value represents the file system attributes.
Public property | CreationTime | This value is the time when the item was created.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | IsContainer | This value is true if the item is a container of other items; otherwise, it is false.
Public property | IsReadOnly | This value is true if the item is read-only (meaning the Saturation cannot be changed); otherwise, it is false.
Public property | ItemType | This value is the type of item.
Public property | LastAccessTime | This value is the time when the item was last accessed.
Public property | LastWriteTime | This value is the time when the item was last written to.
Public property | Metadata | This value is any additional metadata that may be displayed for a particular type of item. This metadata is not in any particular format, but you must be able to determine the format and decipher the metadata based on the type.
Public property | Name | This value is the name of the item. Typically, this name is used for display in the user interface.
Public property | Path | This value is the path of the item.
Public property | Saturation | This value represents the saturation level of the item. Typically, this value is used to display a visual state in the user interface.
Public property | Size | This value is the physical size of the item.
Top
See Also

Reference

PhysicalItem Class
DoubleTake.Common.Contract Namespace


PhysicalItem.Attributes Property

PhysicalItemAttributes Property
This value represents the file system attributes.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Nullable<FileSystemAttributes> Attributes { get; set; }
Public Property Attributes As Nullable(Of FileSystemAttributes)
    Get
    Set
public:
property Nullable<FileSystemAttributes> Attributes {
    Nullable<FileSystemAttributes> get ();
    void set (Nullable<FileSystemAttributes> value);
}
function get_Attributes();
function set_Attributes(value);

Property Value

Type: Nullable FileSystemAttributes
The FileSystemAttributes of this item, or if this property does not apply to this type of item.
See Also

Reference

PhysicalItem Class
DoubleTake.Common.Contract Namespace


PhysicalItem.CreationTime Property

PhysicalItemCreationTime Property
This value is the time when the item was created.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Nullable<DateTime> CreationTime { get; set; }
Public Property CreationTime As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> CreationTime {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
function get_CreationTime();
function set_CreationTime(value);

Property Value

Type: Nullable DateTime
The time this item was created, or if this property does not apply to this type of item.
See Also

Reference

PhysicalItem Class
DoubleTake.Common.Contract Namespace
DateTime


PhysicalItem.ExtensionData Property

PhysicalItemExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

PhysicalItem Class
DoubleTake.Common.Contract Namespace


PhysicalItem.IsContainer Property

PhysicalItemIsContainer Property
This value is true if the item is a container of other items; otherwise, it is false.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsContainer { get; set; }
Public Property IsContainer As Boolean
    Get
    Set
public:
virtual property bool IsContainer {
    bool get () sealed;
    void set (bool value) sealed;
}
function get_IsContainer();
function set_IsContainer(value);

Property Value

Type: Boolean
if this item is a container; otherwise, .

Implements

IProtectableItemIsContainer
See Also

Reference

PhysicalItem Class
DoubleTake.Common.Contract Namespace


PhysicalItem.IsReadOnly Property

PhysicalItemIsReadOnly Property
This value is true if the item is read-only (meaning the Saturation cannot be changed); otherwise, it is false.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsReadOnly { get; set; }
Public Property IsReadOnly As Boolean
    Get
    Set
public:
virtual property bool IsReadOnly {
    bool get () sealed;
    void set (bool value) sealed;
}
function get_IsReadOnly();
function set_IsReadOnly(value);

Property Value

Type: Boolean
if this item is read only; otherwise, .

Implements

IProtectableItemIsReadOnly
See Also

Reference

PhysicalItem Class
DoubleTake.Common.Contract Namespace


PhysicalItem.ItemType Property

PhysicalItemItemType Property
This value is the type of item.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string ItemType { get; set; }
Public Property ItemType As String
    Get
    Set
public:
virtual property String^ ItemType {
    String^ get () sealed;
    void set (String^ value) sealed;
}
function get_ItemType();
function set_ItemType(value);

Property Value

Type: String
The type of this item.

Implements

IProtectableItemItemType
See Also

Reference

PhysicalItem Class
DoubleTake.Common.Contract Namespace


PhysicalItem.LastAccessTime Property

PhysicalItemLastAccessTime Property
This value is the time when the item was last accessed.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Nullable<DateTime> LastAccessTime { get; set; }
Public Property LastAccessTime As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> LastAccessTime {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
function get_LastAccessTime();
function set_LastAccessTime(value);

Property Value

Type: Nullable DateTime
The time this item was last accessed, or if this property does not apply to this type of item.
See Also

Reference

PhysicalItem Class
DoubleTake.Common.Contract Namespace
DateTime


PhysicalItem.LastWriteTime Property

PhysicalItemLastWriteTime Property
This value is the time when the item was last written to.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Nullable<DateTime> LastWriteTime { get; set; }
Public Property LastWriteTime As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> LastWriteTime {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
function get_LastWriteTime();
function set_LastWriteTime(value);

Property Value

Type: Nullable DateTime
The time this item was last written to, or if this property does not apply to this type of item.
See Also

Reference

PhysicalItem Class
DoubleTake.Common.Contract Namespace
DateTime


PhysicalItem.Metadata Property

PhysicalItemMetadata Property
This value is any additional metadata that may be displayed for a particular type of item. This metadata is not in any particular format, but you must be able to determine the format and decipher the metadata based on the type.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Metadata { get; set; }
Public Property Metadata As String
    Get
    Set
public:
property String^ Metadata {
    String^ get ();
    void set (String^ value);
}
function get_Metadata();
function set_Metadata(value);

Property Value

Type: String
The metadata.
Remarks
This property is used to specify any additional metadata that may be displayed for a particular type of item. This metadata is not in any particular format, but one must be able to determine the format and decipher the metadata based on the type.
See Also

Reference

PhysicalItem Class
DoubleTake.Common.Contract Namespace


PhysicalItem.Name Property

PhysicalItemName Property
This value is the name of the item. Typically, this name is used for display in the user interface.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get () sealed;
    void set (String^ value) sealed;
}
function get_Name();
function set_Name(value);

Property Value

Type: String
The name of this item.

Implements

IProtectableItemName
See Also

Reference

PhysicalItem Class
DoubleTake.Common.Contract Namespace


PhysicalItem.Path Property

PhysicalItemPath Property
This value is the path of the item.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Path { get; set; }
Public Property Path As String
    Get
    Set
public:
virtual property String^ Path {
    String^ get () sealed;
    void set (String^ value) sealed;
}
function get_Path();
function set_Path(value);

Property Value

Type: String
The path of this item.

Implements

IProtectableItemPath
See Also

Reference

PhysicalItem Class
DoubleTake.Common.Contract Namespace


PhysicalItem.Saturation Property

PhysicalItemSaturation Property
This value represents the saturation level of the item. Typically, this value is used to display a visual state in the user interface.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public SaturationLevel Saturation { get; set; }
Public Property Saturation As SaturationLevel
    Get
    Set
public:
virtual property SaturationLevel Saturation {
    SaturationLevel get () sealed;
    void set (SaturationLevel value) sealed;
}
function get_Saturation();
function set_Saturation(value);

Property Value

Type: SaturationLevel
The saturation level.

Implements

IProtectableItemSaturation
See Also

Reference

PhysicalItem Class
DoubleTake.Common.Contract Namespace


PhysicalItem.Size Property

PhysicalItemSize Property
This value is the physical size of the item.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Nullable<long> Size { get; set; }
Public Property Size As Nullable(Of Long)
    Get
    Set
public:
property Nullable<long long> Size {
    Nullable<long long> get ();
    void set (Nullable<long long> value);
}
function get_Size();
function set_Size(value);

Property Value

Type: Nullable Int64
The physical size of the item, or if this property does not apply to this type of item.
See Also

Reference

PhysicalItem Class
DoubleTake.Common.Contract Namespace


PhysicalRule Class

PhysicalRule Class
Defines a physical rule for replicating data.
Inheritance Hierarchy
SystemObject
DoubleTake.Common.ContractPhysicalRule

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class PhysicalRule : IExtensibleDataObject
Public Class PhysicalRule
    Implements IExtensibleDataObject
public ref class PhysicalRule : IExtensibleDataObject
DoubleTake.Common.Contract.PhysicalRule = function();

Type.createClass(
    'DoubleTake.Common.Contract.PhysicalRule',
    null,
    IExtensibleDataObject);

The PhysicalRule type exposes the following members.

Constructors
 | Name | Description
Public method | PhysicalRule | Initializes a new instance of the PhysicalRule class
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Inclusion | This value represents if the rule will be included in or excluded from replication.
Public property | IsReadOnly | This value is true if the rule is read-only; otherwise, it is false.
Public property | Metadata | This value is any additional metadata for the rule. This property can be used by specialized workload implementations to provide additional hints to the job-creation process.
Public property | Path | This value is the path of the data to be replicated.
Public property | Recursion | This value represents if the rule will be applied to this path only or to all children of the path as well.
Top
Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | Equals(Object) | Determines whether the specified Object is equal to this instance. (Overrides ObjectEquals(Object).)
Public method | Equals(PhysicalRule) | Indicates whether the current object is equal to another object of the same type.
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ObjectGetHashCode.)
Public method | ToString | Returns a String that represents this instance. (Overrides ObjectToString.)
Top
See Also

Reference

DoubleTake.Common.Contract Namespace


PhysicalRule Constructor

PhysicalRule Constructor
Initializes a new instance of the PhysicalRule class

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public PhysicalRule()
Public Sub New
public:
PhysicalRule()
DoubleTake.Common.Contract.PhysicalRule = function();
See Also

Reference

PhysicalRule Class
DoubleTake.Common.Contract Namespace


PhysicalRule Properties

PhysicalRule Properties

The PhysicalRule type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Inclusion | This value represents if the rule will be included in or excluded from replication.
Public property | IsReadOnly | This value is true if the rule is read-only; otherwise, it is false.
Public property | Metadata | This value is any additional metadata for the rule. This property can be used by specialized workload implementations to provide additional hints to the job-creation process.
Public property | Path | This value is the path of the data to be replicated.
Public property | Recursion | This value represents if the rule will be applied to this path only or to all children of the path as well.
Top
See Also

Reference

PhysicalRule Class
DoubleTake.Common.Contract Namespace


PhysicalRule.ExtensionData Property

PhysicalRuleExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

PhysicalRule Class
DoubleTake.Common.Contract Namespace


PhysicalRule.Inclusion Property

PhysicalRuleInclusion Property
This value represents if the rule will be included in or excluded from replication.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public InclusionMode Inclusion { get; set; }
Public Property Inclusion As InclusionMode
    Get
    Set
public:
property InclusionMode Inclusion {
    InclusionMode get ();
    void set (InclusionMode value);
}
function get_Inclusion();
function set_Inclusion(value);

Property Value

Type: InclusionMode
The inclusion mode.
See Also

Reference

PhysicalRule Class
DoubleTake.Common.Contract Namespace


PhysicalRule.IsReadOnly Property

PhysicalRuleIsReadOnly Property
This value is true if the rule is read-only; otherwise, it is false.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsReadOnly { get; set; }
Public Property IsReadOnly As Boolean
    Get
    Set
public:
property bool IsReadOnly {
    bool get ();
    void set (bool value);
}
function get_IsReadOnly();
function set_IsReadOnly(value);

Property Value

Type: Boolean
if this rule is read only; otherwise, .
See Also

Reference

PhysicalRule Class
DoubleTake.Common.Contract Namespace


PhysicalRule.Metadata Property

PhysicalRuleMetadata Property
This value is any additional metadata for the rule. This property can be used by specialized workload implementations to provide additional hints to the job-creation process.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Metadata { get; set; }
Public Property Metadata As String
    Get
    Set
public:
property String^ Metadata {
    String^ get ();
    void set (String^ value);
}
function get_Metadata();
function set_Metadata(value);

Property Value

Type: String
The metadata.
Remarks
Use this property to store additional rule information. This property can be used by specialized workload implementations to provide additional hints to the job-creation process.
See Also

Reference

PhysicalRule Class
DoubleTake.Common.Contract Namespace


PhysicalRule.Path Property

PhysicalRulePath Property
This value is the path of the data to be replicated.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Path { get; set; }
Public Property Path As String
    Get
    Set
public:
property String^ Path {
    String^ get ();
    void set (String^ value);
}
function get_Path();
function set_Path(value);

Property Value

Type: String
The path of the data to be replicated.
See Also

Reference

PhysicalRule Class
DoubleTake.Common.Contract Namespace


PhysicalRule.Recursion Property

PhysicalRuleRecursion Property
This value represents if the rule will be applied to this path only or to all children of the path as well.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public RecursionMode Recursion { get; set; }
Public Property Recursion As RecursionMode
    Get
    Set
public:
property RecursionMode Recursion {
    RecursionMode get ();
    void set (RecursionMode value);
}
function get_Recursion();
function set_Recursion(value);

Property Value

Type: RecursionMode
The recursion mode.
See Also

Reference

PhysicalRule Class
DoubleTake.Common.Contract Namespace


PhysicalRule Methods

PhysicalRule Methods

The PhysicalRule type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | Equals(Object) | Determines whether the specified Object is equal to this instance. (Overrides ObjectEquals(Object).)
Public method | Equals(PhysicalRule) | Indicates whether the current object is equal to another object of the same type.
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ObjectGetHashCode.)
Public method | ToString | Returns a String that represents this instance. (Overrides ObjectToString.)
Top
See Also

Reference

PhysicalRule Class
DoubleTake.Common.Contract Namespace


PhysicalRule.Clone Method

PhysicalRuleClone Method
Creates a new object that is a copy of the current instance.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
function Clone();

Return Value

Type: Object
A new object that is a copy of this instance.
See Also

Reference

PhysicalRule Class
DoubleTake.Common.Contract Namespace


PhysicalRule.Equals Method

PhysicalRuleEquals Method
Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to this instance. (Overrides ObjectEquals(Object).)
Public method | Equals(PhysicalRule) | Indicates whether the current object is equal to another object of the same type.
Top
See Also

Reference

PhysicalRule Class
DoubleTake.Common.Contract Namespace


PhysicalRule.Equals Method (Object)

PhysicalRuleEquals Method (Object)
Determines whether the specified Object is equal to this instance.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
function Equals(obj);

Parameters

obj
Type: SystemObject
The Object to compare with this instance.

Return Value

Type: Boolean
if the specified Object is equal to this instance; otherwise, .
Exceptions
Exception | Condition
NullReferenceException | The obj parameter is null.
See Also

Reference

PhysicalRule Class
Equals Overload
DoubleTake.Common.Contract Namespace


PhysicalRule.Equals Method (PhysicalRule)

PhysicalRuleEquals Method (PhysicalRule)
Indicates whether the current object is equal to another object of the same type.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool Equals(
    PhysicalRule other
)
Public Function Equals (
    other As PhysicalRule
) As Boolean
public:
virtual bool Equals(
    PhysicalRule^ other
) sealed
function Equals(other);

Parameters

other
Type: DoubleTake.Common.ContractPhysicalRule
An object to compare with this object.

Return Value

Type: Boolean
if the current object is equal to the other parameter; otherwise, .
See Also

Reference

PhysicalRule Class
Equals Overload
DoubleTake.Common.Contract Namespace


PhysicalRule.GetHashCode Method

PhysicalRuleGetHashCode Method
Returns a hash code for this instance.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
function GetHashCode();

Return Value

Type: Int32
A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.
See Also

Reference

PhysicalRule Class
DoubleTake.Common.Contract Namespace


PhysicalRule.ToString Method

PhysicalRuleToString Method
Returns a String that represents this instance.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
function ToString();

Return Value

Type: String
A String that represents this instance.
See Also

Reference

PhysicalRule Class
DoubleTake.Common.Contract Namespace


PropertyBag Class

PropertyBag Class
A container for name-value pairs where the value can be any of the primitive data types.
Inheritance Hierarchy
SystemObject
DoubleTake.Common.ContractPropertyBag

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class PropertyBag : IEnumerable,
    IExtensibleDataObject
Public Class PropertyBag
    Implements IEnumerable, IExtensibleDataObject
public ref class PropertyBag : IEnumerable,
    IExtensibleDataObject
DoubleTake.Common.Contract.PropertyBag = function();

Type.createClass(
    'DoubleTake.Common.Contract.PropertyBag',
    null,
    IEnumerable,
    IExtensibleDataObject);

The PropertyBag type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyBag | Initializes a new instance of the PropertyBag class.
Public method | PropertyBag(Hashtable) | Initializes a new instance of the PropertyBag class.
Public method | PropertyBag(NameValuePair) | Initializes a new instance of the PropertyBag class.
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only.
Public property | Item | Gets or sets the Object with the specified key.
Public property | Keys | Gets an ICollectionT containing the keys of the IDictionaryTKey, TValue.
Public property | NameValuePairs | Gets the name-value pairs.
Public property | Values | Gets an ICollectionT containing the values in the IDictionaryTKey, TValue.
Top
Methods
 | Name | Description
Public method | Add(KeyValuePairString, Object) | Adds an item to the ICollectionT.
Public method | Add(String, Object) | Adds an element with the provided key and value to the IDictionaryTKey, TValue.
Public method | Clear | Removes all items from the ICollectionT.
Public method | Contains | Determines whether the ICollectionT contains a specific value.
Public method | ContainsKey | Determines whether the IDictionaryTKey, TValue contains an element with the specified key.
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index.
Public method | GetAsT(String) | Gets the property value as an instance of type T.
Public method | GetAsT(String, T) | Gets the property value as an instance of type T.
Public method | GetAsArrayOfT(String) | Gets the property value as an array of T.
Public method | GetAsArrayOfT(String, FuncT, T) | Gets a value as array of the specified type.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | Remove(KeyValuePairString, Object) | Removes the first occurrence of a specific object from the ICollectionT.
Public method | Remove(String) | Removes the element with the specified key from the IDictionaryTKey, TValue.
Public method | ToHashtable |
Public method | TryGetValue | Gets the value associated with the specified key.
Top
See Also

Reference

DoubleTake.Common.Contract Namespace


PropertyBag Constructor

PropertyBag Constructor
Overload List
 | Name | Description
Public method | PropertyBag | Initializes a new instance of the PropertyBag class.
Public method | PropertyBag(Hashtable) | Initializes a new instance of the PropertyBag class.
Public method | PropertyBag(NameValuePair) | Initializes a new instance of the PropertyBag class.
Top
See Also

Reference

PropertyBag Class
DoubleTake.Common.Contract Namespace


PropertyBag Constructor

PropertyBag Constructor
Initializes a new instance of the PropertyBag class.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public PropertyBag()
Public Sub New
public:
PropertyBag()
DoubleTake.Common.Contract.PropertyBag = function();
See Also

Reference

PropertyBag Class
PropertyBag Overload
DoubleTake.Common.Contract Namespace


PropertyBag Constructor (Hashtable)

PropertyBag Constructor (Hashtable)
Initializes a new instance of the PropertyBag class.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public PropertyBag(
    Hashtable hashtable
)
Public Sub New (
    hashtable As Hashtable
)
public:
PropertyBag(
    Hashtable^ hashtable
)
DoubleTake.Common.Contract.PropertyBag = function(hashtable);

Parameters

hashtable
Type: System.CollectionsHashtable
The hashtable.
See Also

Reference

PropertyBag Class
PropertyBag Overload
DoubleTake.Common.Contract Namespace


PropertyBag Constructor (NameValuePair[])

PropertyBag Constructor (NameValuePair)
Initializes a new instance of the PropertyBag class.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public PropertyBag(
    NameValuePair[] nameValuePairs
)
Public Sub New (
    nameValuePairs As NameValuePair()
)
public:
PropertyBag(
    array<NameValuePair^>^ nameValuePairs
)
DoubleTake.Common.Contract.PropertyBag = function(nameValuePairs);

Parameters

nameValuePairs
Type: DoubleTake.Common.ContractNameValuePair
The name value pairs.
See Also

Reference

PropertyBag Class
PropertyBag Overload
DoubleTake.Common.Contract Namespace


PropertyBag Properties

PropertyBag Properties

The PropertyBag type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only.
Public property | Item | Gets or sets the Object with the specified key.
Public property | Keys | Gets an ICollectionT containing the keys of the IDictionaryTKey, TValue.
Public property | NameValuePairs | Gets the name-value pairs.
Public property | Values | Gets an ICollectionT containing the values in the IDictionaryTKey, TValue.
Top
See Also

Reference

PropertyBag Class
DoubleTake.Common.Contract Namespace


PropertyBag.Count Property

PropertyBagCount Property
Gets the number of elements contained in the ICollectionT.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get () sealed;
}
function get_Count();

Property Value

Type: Int32
The number of elements contained in the ICollectionT.
See Also

Reference

PropertyBag Class
DoubleTake.Common.Contract Namespace


PropertyBag.ExtensionData Property

PropertyBagExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

PropertyBag Class
DoubleTake.Common.Contract Namespace


PropertyBag.IsReadOnly Property

PropertyBagIsReadOnly Property
Gets a value indicating whether the ICollectionT is read-only.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
virtual property bool IsReadOnly {
    bool get () sealed;
}
function get_IsReadOnly();

Property Value

Type: Boolean
if the ICollectionT is read-only; otherwise, .
See Also

Reference

PropertyBag Class
DoubleTake.Common.Contract Namespace


PropertyBag.Item Property

PropertyBagItem Property
Gets or sets the Object with the specified key.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Object this[
    string key
] { get; set; }
Public Default Property Item (
    key As String
) As Object
    Get
    Set
public:
virtual property Object^ default[String^ key] {
    Object^ get (String^ key) sealed;
    void set (String^ key, Object^ value) sealed;
}
function get_Item(key);
function set_Item(value);

Parameters

key
Type: SystemString
The key whose value should be returned.

Property Value

Type: Object
The Object with the specified key.
See Also

Reference

PropertyBag Class
DoubleTake.Common.Contract Namespace


PropertyBag.Keys Property

PropertyBagKeys Property
Gets an ICollectionT containing the keys of the IDictionaryTKey, TValue.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ICollection<string> Keys { get; }
Public ReadOnly Property Keys As ICollection(Of String)
    Get
public:
virtual property ICollection<String^>^ Keys {
    ICollection<String^>^ get () sealed;
}
function get_Keys();

Property Value

Type: ICollection String
An ICollectionT containing the keys of the object that implements IDictionaryTKey, TValue.
See Also

Reference

PropertyBag Class
DoubleTake.Common.Contract Namespace


PropertyBag.NameValuePairs Property

PropertyBagNameValuePairs Property
Gets the name-value pairs.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public NameValuePair[] NameValuePairs { get; }
Public ReadOnly Property NameValuePairs As NameValuePair()
    Get
public:
property array<NameValuePair^>^ NameValuePairs {
    array<NameValuePair^>^ get ();
}
function get_NameValuePairs();

Property Value

Type: NameValuePair
The name-value pairs.
See Also

Reference

PropertyBag Class
DoubleTake.Common.Contract Namespace


PropertyBag.Values Property

PropertyBagValues Property
Gets an ICollectionT containing the values in the IDictionaryTKey, TValue.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ICollection<Object> Values { get; }
Public ReadOnly Property Values As ICollection(Of Object)
    Get
public:
virtual property ICollection<Object^>^ Values {
    ICollection<Object^>^ get () sealed;
}
function get_Values();

Property Value

Type: ICollection Object
An ICollectionT containing the values in the object that implements IDictionaryTKey, TValue.
See Also

Reference

PropertyBag Class
DoubleTake.Common.Contract Namespace


PropertyBag Methods

PropertyBag Methods

The PropertyBag type exposes the following members.

Methods
 | Name | Description
Public method | Add(KeyValuePairString, Object) | Adds an item to the ICollectionT.
Public method | Add(String, Object) | Adds an element with the provided key and value to the IDictionaryTKey, TValue.
Public method | Clear | Removes all items from the ICollectionT.
Public method | Contains | Determines whether the ICollectionT contains a specific value.
Public method | ContainsKey | Determines whether the IDictionaryTKey, TValue contains an element with the specified key.
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index.
Public method | GetAsT(String) | Gets the property value as an instance of type T.
Public method | GetAsT(String, T) | Gets the property value as an instance of type T.
Public method | GetAsArrayOfT(String) | Gets the property value as an array of T.
Public method | GetAsArrayOfT(String, FuncT, T) | Gets a value as array of the specified type.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | Remove(KeyValuePairString, Object) | Removes the first occurrence of a specific object from the ICollectionT.
Public method | Remove(String) | Removes the element with the specified key from the IDictionaryTKey, TValue.
Public method | ToHashtable |
Public method | TryGetValue | Gets the value associated with the specified key.
Top
See Also

Reference

PropertyBag Class
DoubleTake.Common.Contract Namespace


PropertyBag.Add Method

PropertyBagAdd Method
Overload List
 | Name | Description
Public method | Add(KeyValuePairString, Object) | Adds an item to the ICollectionT.
Public method | Add(String, Object) | Adds an element with the provided key and value to the IDictionaryTKey, TValue.
Top
See Also

Reference

PropertyBag Class
DoubleTake.Common.Contract Namespace


PropertyBag.Add Method (KeyValuePair(String, Object))

PropertyBagAdd Method (KeyValuePairString, Object)
Adds an item to the ICollectionT.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public void Add(
    KeyValuePair<string, Object> item
)
Public Sub Add (
    item As KeyValuePair(Of String, Object)
)
public:
virtual void Add(
    KeyValuePair<String^, Object^> item
) sealed
function Add(item);

Parameters

item
Type: System.Collections.GenericKeyValuePair String, Object
The object to add to the ICollectionT.
Exceptions
Exception | Condition
NotSupportedException | The ICollectionT is read-only.
See Also

Reference

PropertyBag Class
Add Overload
DoubleTake.Common.Contract Namespace


PropertyBag.Add Method (String, Object)

PropertyBagAdd Method (String, Object)
Adds an element with the provided key and value to the IDictionaryTKey, TValue.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public void Add(
    string key,
    Object value
)
Public Sub Add (
    key As String,
    value As Object
)
public:
virtual void Add(
    String^ key,
    Object^ value
) sealed
function Add(key, value);

Parameters

key
Type: SystemString
The object to use as the key of the element to add.
value
Type: SystemObject
The object to use as the value of the element to add.
Exceptions
Exception | Condition
ArgumentNullException | key is null.
ArgumentException | An element with the same key already exists in the IDictionaryTKey, TValue.
NotSupportedException | The IDictionaryTKey, TValue is read-only.
See Also

Reference

PropertyBag Class
Add Overload
DoubleTake.Common.Contract Namespace


PropertyBag.Clear Method

PropertyBagClear Method
Removes all items from the ICollectionT.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public void Clear()
Public Sub Clear
public:
virtual void Clear() sealed
function Clear();
Exceptions
Exception | Condition
NotSupportedException | The ICollectionT is read-only.
See Also

Reference

PropertyBag Class
DoubleTake.Common.Contract Namespace


PropertyBag.Contains Method

PropertyBagContains Method
Determines whether the ICollectionT contains a specific value.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool Contains(
    KeyValuePair<string, Object> item
)
Public Function Contains (
    item As KeyValuePair(Of String, Object)
) As Boolean
public:
virtual bool Contains(
    KeyValuePair<String^, Object^> item
) sealed
function Contains(item);

Parameters

item
Type: System.Collections.GenericKeyValuePair String, Object
The object to locate in the ICollectionT.

Return Value

Type: Boolean
if item is found in the ICollectionT; otherwise, .
See Also

Reference

PropertyBag Class
DoubleTake.Common.Contract Namespace


PropertyBag.ContainsKey Method

PropertyBagContainsKey Method
Determines whether the IDictionaryTKey, TValue contains an element with the specified key.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool ContainsKey(
    string key
)
Public Function ContainsKey (
    key As String
) As Boolean
public:
virtual bool ContainsKey(
    String^ key
) sealed
function ContainsKey(key);

Parameters

key
Type: SystemString
The key to locate in the IDictionaryTKey, TValue.

Return Value

Type: Boolean
if the IDictionaryTKey, TValue contains an element with the key; otherwise, .
Exceptions
Exception | Condition
ArgumentNullException | key is null.
See Also

Reference

PropertyBag Class
DoubleTake.Common.Contract Namespace


PropertyBag.CopyTo Method

PropertyBagCopyTo Method
Copies the elements of the ICollectionT to an Array, starting at a particular Array index.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public void CopyTo(
    KeyValuePair<string, Object>[] array,
    int arrayIndex
)
Public Sub CopyTo (
    array As KeyValuePair(Of String, Object)(),
    arrayIndex As Integer
)
public:
virtual void CopyTo(
    array<KeyValuePair<String^, Object^>>^ array,
    int arrayIndex
) sealed
function CopyTo(array, arrayIndex);

Parameters

array
Type: System.Collections.GenericKeyValuePair String, Object
The one-dimensional Array that is the destination of the elements copied from ICollectionT. The Array must have zero-based indexing.
arrayIndex
Type: SystemInt32
The zero-based index in array at which copying begins.
Exceptions
Exception | Condition
ArgumentNullException | array is null.
ArgumentOutOfRangeException | arrayIndex is less than 0.
ArgumentException | array is multidimensional. -or- arrayIndex is equal to or greater than the length of array. -or- The number of elements in the source ICollectionT is greater than the available space from arrayIndex to the end of the destination array.
See Also

Reference

PropertyBag Class
DoubleTake.Common.Contract Namespace


PropertyBag.GetAs Method

PropertyBagGetAs Method
Overload List
 | Name | Description
Public method | GetAsT(String) | Gets the property value as an instance of type T.
Public method | GetAsT(String, T) | Gets the property value as an instance of type T.
Top
See Also

Reference

PropertyBag Class
DoubleTake.Common.Contract Namespace


PropertyBag.GetAs(T) Method (String)

PropertyBagGetAsT Method (String)
Gets the property value as an instance of type T.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public T GetAs<T>(
    string propertyName
)

Public Function GetAs(Of T) (
    propertyName As String
) As T
public:
generic<typename T>
T GetAs(
    String^ propertyName
)
JavaScript does not support generic types or methods.

Parameters

propertyName
Type: SystemString
Name of the property.

Type Parameters

T
The type of the property value.

Return Value

Type: T
The property value as an instance of type T.
Exceptions
Exception | Condition
InvalidCastException | The property value could not be cast to T.
KeyNotFoundException | The property specified by propertyName does not exist.
See Also

Reference

PropertyBag Class
GetAs Overload
DoubleTake.Common.Contract Namespace


PropertyBag.GetAs(T) Method (String, T)

PropertyBagGetAsT Method (String, T)
Gets the property value as an instance of type T.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public T GetAs<T>(
    string propertyName,
    T defaultValue
)

Public Function GetAs(Of T) (
    propertyName As String,
    defaultValue As T
) As T
public:
generic<typename T>
T GetAs(
    String^ propertyName,
    T defaultValue
)
JavaScript does not support generic types or methods.

Parameters

propertyName
Type: SystemString
Name of the property.
defaultValue
Type: T
A default value to return when a property with the requested name does not exist in this property bag.

Type Parameters

T
The type of the property value.

Return Value

Type: T
The property value as an instance of type T.
Exceptions
Exception | Condition
InvalidCastException | The property value could not be cast to T.
See Also

Reference

PropertyBag Class
GetAs Overload
DoubleTake.Common.Contract Namespace


PropertyBag.GetAsArrayOf Method

PropertyBagGetAsArrayOf Method
Overload List
 | Name | Description
Public method | GetAsArrayOfT(String) | Gets the property value as an array of T.
Public method | GetAsArrayOfT(String, FuncT, T) | Gets a value as array of the specified type.
Top
See Also

Reference

PropertyBag Class
DoubleTake.Common.Contract Namespace


PropertyBag.GetAsArrayOf(T) Method (String)

PropertyBagGetAsArrayOfT Method (String)
Gets the property value as an array of T.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public T[] GetAsArrayOf<T>(
    string propertyName
)

Public Function GetAsArrayOf(Of T) (
    propertyName As String
) As T()
public:
generic<typename T>
array<T>^ GetAsArrayOf(
    String^ propertyName
)
JavaScript does not support generic types or methods.

Parameters

propertyName
Type: SystemString
Name of the property.

Type Parameters

T
The array element type.

Return Value

Type: T
An array of values that are of type T.
Exceptions
Exception | Condition
InvalidCastException | The property value could not be cast to T.
KeyNotFoundException | The property specified by propertyName does not exist.
See Also

Reference

PropertyBag Class
GetAsArrayOf Overload
DoubleTake.Common.Contract Namespace


PropertyBag.GetAsArrayOf(T) Method (String, Func(T, T))

PropertyBagGetAsArrayOfT Method (String, FuncT, T)
Gets a value as array of the specified type.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public T[] GetAsArrayOf<T>(
    string propertyName,
    Func<T, T> passThrough
)

Public Function GetAsArrayOf(Of T) (
    propertyName As String,
    passThrough As Func(Of T, T)
) As T()
public:
generic<typename T>
array<T>^ GetAsArrayOf(
    String^ propertyName,
    Func<T, T>^ passThrough
)
JavaScript does not support generic types or methods.

Parameters

propertyName
Type: SystemString
Name of the property.
passThrough
Type: SystemFunc T, T
A function for converting from the underlying type to the specified type.

Type Parameters

T
The array element type.

Return Value

Type: T
An array of values that are of type T.
Exceptions
Exception | Condition
InvalidCastException | The property value could not be cast to T.
KeyNotFoundException | The property specified by propertyName does not exist.
See Also

Reference

PropertyBag Class
GetAsArrayOf Overload
DoubleTake.Common.Contract Namespace


PropertyBag.GetEnumerator Method

PropertyBagGetEnumerator Method
Returns an enumerator that iterates through the collection.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public IEnumerator<KeyValuePair<string, Object>> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of KeyValuePair(Of String, Object))
public:
virtual IEnumerator<KeyValuePair<String^, Object^>>^ GetEnumerator() sealed
function GetEnumerator();

Return Value

Type: IEnumerator KeyValuePair String, Object
A IEnumeratorT that can be used to iterate through the collection.
See Also

Reference

PropertyBag Class
DoubleTake.Common.Contract Namespace


PropertyBag.Remove Method

PropertyBagRemove Method
Overload List
 | Name | Description
Public method | Remove(KeyValuePairString, Object) | Removes the first occurrence of a specific object from the ICollectionT.
Public method | Remove(String) | Removes the element with the specified key from the IDictionaryTKey, TValue.
Top
See Also

Reference

PropertyBag Class
DoubleTake.Common.Contract Namespace


PropertyBag.Remove Method (KeyValuePair(String, Object))

PropertyBagRemove Method (KeyValuePairString, Object)
Removes the first occurrence of a specific object from the ICollectionT.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool Remove(
    KeyValuePair<string, Object> item
)
Public Function Remove (
    item As KeyValuePair(Of String, Object)
) As Boolean
public:
virtual bool Remove(
    KeyValuePair<String^, Object^> item
) sealed
function Remove(item);

Parameters

item
Type: System.Collections.GenericKeyValuePair String, Object
The object to remove from the ICollectionT.

Return Value

Type: Boolean
true if item was successfully removed from the ICollectionT; otherwise, false. This method also returns false if item is not found in the original ICollectionT.
Exceptions
Exception | Condition
NotSupportedException | The ICollectionT is read-only.
See Also

Reference

PropertyBag Class
Remove Overload
DoubleTake.Common.Contract Namespace


PropertyBag.Remove Method (String)

PropertyBagRemove Method (String)
Removes the element with the specified key from the IDictionaryTKey, TValue.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool Remove(
    string key
)
Public Function Remove (
    key As String
) As Boolean
public:
virtual bool Remove(
    String^ key
) sealed
function Remove(key);

Parameters

key
Type: SystemString
The key of the element to remove.

Return Value

Type: Boolean
if the element is successfully removed; otherwise, . This method also returns false if key was not found in the original IDictionaryTKey, TValue.
Exceptions
Exception | Condition
ArgumentNullException | key is null.
NotSupportedException | The IDictionaryTKey, TValue is read-only.
See Also

Reference

PropertyBag Class
Remove Overload
DoubleTake.Common.Contract Namespace


PropertyBag.ToHashtable Method

PropertyBagToHashtable Method

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Hashtable ToHashtable()
Public Function ToHashtable As Hashtable
public:
Hashtable^ ToHashtable()
function ToHashtable();

Return Value

Type: Hashtable
See Also

Reference

PropertyBag Class
DoubleTake.Common.Contract Namespace


PropertyBag.TryGetValue Method

PropertyBagTryGetValue Method
Gets the value associated with the specified key.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool TryGetValue(
    string key,
    out Object value
)
Public Function TryGetValue (
    key As String,
    <OutAttribute> ByRef value As Object
) As Boolean
public:
virtual bool TryGetValue(
    String^ key,
    [OutAttribute] Object^% value
) sealed
function TryGetValue(key, value);

Parameters

key
Type: SystemString
The key whose value to get.
value
Type: SystemObject
When this method returns, the value associated with the specified key, if the key is found; otherwise, the default value for the type of the value parameter. This parameter is passed uninitialized.

Return Value

Type: Boolean
if the object that implements IDictionaryTKey, TValue contains an element with the specified key; otherwise, .
Exceptions
Exception | Condition
ArgumentNullException | key is null.
See Also

Reference

PropertyBag Class
DoubleTake.Common.Contract Namespace


ProtectableItemTypes Class

ProtectableItemTypes Class
Defines constants that represent known types of protectable items. These constants are used as values for the ItemType property.
Inheritance Hierarchy
SystemObject
DoubleTake.Common.ContractProtectableItemTypes

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class ProtectableItemTypes
Public Class ProtectableItemTypes
public ref class ProtectableItemTypes
DoubleTake.Common.Contract.ProtectableItemTypes = function();

Type.createClass(
    'DoubleTake.Common.Contract.ProtectableItemTypes');

The ProtectableItemTypes type exposes the following members.

Constructors
 | Name | Description
Public method | ProtectableItemTypes | Initializes a new instance of the ProtectableItemTypes class
Top
Fields
Name | Description
Directory | A protectable item that is a directory.
File | A protectable item that is a file.
Volume | A protectable item that is a volume.
Top
See Also

Reference

DoubleTake.Common.Contract Namespace


ProtectableItemTypes Constructor

ProtectableItemTypes Constructor
Initializes a new instance of the ProtectableItemTypes class

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ProtectableItemTypes()
Public Sub New
public:
ProtectableItemTypes()
DoubleTake.Common.Contract.ProtectableItemTypes = function();
See Also

Reference

ProtectableItemTypes Class
DoubleTake.Common.Contract Namespace


ProtectableItemTypes Fields

ProtectableItemTypes Fields

The ProtectableItemTypes type exposes the following members.

Fields
Name | Description
Directory | A protectable item that is a directory.
File | A protectable item that is a file.
Volume | A protectable item that is a volume.
Top
See Also

Reference

ProtectableItemTypes Class
DoubleTake.Common.Contract Namespace


ProtectableItemTypes.Directory Field

ProtectableItemTypesDirectory Field
A protectable item that is a directory.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string Directory
Public Const Directory As String
public:
literal String^ Directory
var DoubleTake.Common.Contract.ProtectableItemTypes.Directory

Field Value

Type: String
See Also

Reference

ProtectableItemTypes Class
DoubleTake.Common.Contract Namespace


ProtectableItemTypes.File Field

ProtectableItemTypesFile Field
A protectable item that is a file.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string File
Public Const File As String
public:
literal String^ File
var DoubleTake.Common.Contract.ProtectableItemTypes.File

Field Value

Type: String
See Also

Reference

ProtectableItemTypes Class
DoubleTake.Common.Contract Namespace


ProtectableItemTypes.Volume Field

ProtectableItemTypesVolume Field
A protectable item that is a volume.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string Volume
Public Const Volume As String
public:
literal String^ Volume
var DoubleTake.Common.Contract.ProtectableItemTypes.Volume

Field Value

Type: String
See Also

Reference

ProtectableItemTypes Class
DoubleTake.Common.Contract Namespace


RecursionMode Enumeration

RecursionMode Enumeration
Indicates whether recursion is used when replicating a data path.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public enum RecursionMode
Public Enumeration RecursionMode
public enum class RecursionMode
DoubleTake.Common.Contract.RecursionMode = function();
DoubleTake.Common.Contract.RecursionMode.createEnum('DoubleTake.Common.Contract.RecursionMode', false);
Members
Member name | Value | Description
Recursive | 0 | The physical rule will be applied to this path and all of its children paths.
NonRecursive | 1 | The physical rule will be applied to this path only.
See Also

Reference

DoubleTake.Common.Contract Namespace


SaturationLevel Enumeration

SaturationLevel Enumeration
Indicates the saturation level of a protectable item.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public enum SaturationLevel
Public Enumeration SaturationLevel
public enum class SaturationLevel
DoubleTake.Common.Contract.SaturationLevel = function();
DoubleTake.Common.Contract.SaturationLevel.createEnum('DoubleTake.Common.Contract.SaturationLevel', false);
Members
Member name | Value | Description
Unknown | 0 | The saturation level is unknown.
None | 1 | The item will not be replicated.
Partial | 2 | Some, but not all, of the item will be replicated.
Full | 3 | The item and all of its children (if a container) will be replicated.
Error | 4 | An error occurred while calculating the saturation for the item.
See Also

Reference

DoubleTake.Common.Contract Namespace


ServerRegistrationMethod Enumeration

ServerRegistrationMethod Enumeration

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public enum ServerRegistrationMethod
Public Enumeration ServerRegistrationMethod
public enum class ServerRegistrationMethod
DoubleTake.Common.Contract.ServerRegistrationMethod = function();
DoubleTake.Common.Contract.ServerRegistrationMethod.createEnum('DoubleTake.Common.Contract.ServerRegistrationMethod', false);
Members
Member name | Value | Description
None | 0 |
ActiveDirectory | 1 |
See Also

Reference

DoubleTake.Common.Contract Namespace


SmtpConnectionSecurity Enumeration

SmtpConnectionSecurity Enumeration

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public enum SmtpConnectionSecurity
Public Enumeration SmtpConnectionSecurity
public enum class SmtpConnectionSecurity
DoubleTake.Common.Contract.SmtpConnectionSecurity = function();
DoubleTake.Common.Contract.SmtpConnectionSecurity.createEnum('DoubleTake.Common.Contract.SmtpConnectionSecurity', false);
Members
Member name | Value | Description
Plain | 0 | The security is plain.
SSL | 1 | The security is Secure Sockets Layer.
TLS | 2 | The security is Transport Layer Security.
See Also

Reference

DoubleTake.Common.Contract Namespace


ValidateActiveDirectoryCredentialsResult Enumeration

ValidateActiveDirectoryCredentialsResult Enumeration

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public enum ValidateActiveDirectoryCredentialsResult
Public Enumeration ValidateActiveDirectoryCredentialsResult
public enum class ValidateActiveDirectoryCredentialsResult
DoubleTake.Common.Contract.ValidateActiveDirectoryCredentialsResult = function();
DoubleTake.Common.Contract.ValidateActiveDirectoryCredentialsResult.createEnum('DoubleTake.Common.Contract.ValidateActiveDirectoryCredentialsResult', false);
Members
Member name | Value | Description
Ok | 0 |
InvalidCredentials | 1 |
ModifySpnPermissionFail | 2 |
SynchronizationPermissionFail | 3 |
See Also

Reference

DoubleTake.Common.Contract Namespace


Volume Class

Volume Class
Represents a volume on a server.
Inheritance Hierarchy
SystemObject
DoubleTake.Common.ContractPhysicalItem
DoubleTake.Common.ContractVolume
DoubleTake.Core.ContractVolumeOptions

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class Volume : PhysicalItem
Public Class Volume
    Inherits PhysicalItem
public ref class Volume : public PhysicalItem
DoubleTake.Common.Contract.Volume = function();

Type.createClass(
    'DoubleTake.Common.Contract.Volume',
    DoubleTake.Common.Contract.PhysicalItem);

The Volume type exposes the following members.

Constructors
 | Name | Description
Public method | Volume | This value is true if the volume is a container of other volumes; otherwise, it is false.
Top
Properties
 | Name | Description
Public property | Attributes | This value represents the file system attributes. (Inherited from PhysicalItem.)
Public property | AvailableFreeSpace | This value is the amount of free space on the volume.
Public property | CreationTime | This value is the time when the item was created. (Inherited from PhysicalItem.)
Public property | DriveFormat | This value is the file system format of the volume.
Public property | DriveType | This value is the drive type.
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from PhysicalItem.)
Public property | IsContainer | This value is true if the item is a container of other items; otherwise, it is false. (Inherited from PhysicalItem.)
Public property | IsReadOnly | This value is true if the item is read-only (meaning the Saturation cannot be changed); otherwise, it is false. (Inherited from PhysicalItem.)
Public property | IsSystemDrive | This value is true if the volume is the system volume; otherwise, it is false.
Public property | ItemType | This value is the type of item. (Inherited from PhysicalItem.)
Public property | Label | This value is the label assigned to the volume.
Public property | LastAccessTime | This value is the time when the item was last accessed. (Inherited from PhysicalItem.)
Public property | LastWriteTime | This value is the time when the item was last written to. (Inherited from PhysicalItem.)
Public property | Metadata | This value is any additional metadata that may be displayed for a particular type of item. This metadata is not in any particular format, but you must be able to determine the format and decipher the metadata based on the type. (Inherited from PhysicalItem.)
Public property | Name | This value is the name of the item. Typically, this name is used for display in the user interface. (Inherited from PhysicalItem.)
Public property | Path | This value is the path of the item. (Inherited from PhysicalItem.)
Public property | Saturation | This value represents the saturation level of the item. Typically, this value is used to display a visual state in the user interface. (Inherited from PhysicalItem.)
Public property | Size | This value is the physical size of the item. (Inherited from PhysicalItem.)
Public property | TotalSize | This value is the total size of the volume.
Public property | VolumeType | This value is the type of volume.
Top
See Also

Reference

DoubleTake.Common.Contract Namespace


Volume Constructor

Volume Constructor
This value is true if the volume is a container of other volumes; otherwise, it is false.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Volume()
Public Sub New
public:
Volume()
DoubleTake.Common.Contract.Volume = function();
See Also

Reference

Volume Class
DoubleTake.Common.Contract Namespace


Volume Properties

Volume Properties

The Volume type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | This value represents the file system attributes. (Inherited from PhysicalItem.)
Public property | AvailableFreeSpace | This value is the amount of free space on the volume.
Public property | CreationTime | This value is the time when the item was created. (Inherited from PhysicalItem.)
Public property | DriveFormat | This value is the file system format of the volume.
Public property | DriveType | This value is the drive type.
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from PhysicalItem.)
Public property | IsContainer | This value is true if the item is a container of other items; otherwise, it is false. (Inherited from PhysicalItem.)
Public property | IsReadOnly | This value is true if the item is read-only (meaning the Saturation cannot be changed); otherwise, it is false. (Inherited from PhysicalItem.)
Public property | IsSystemDrive | This value is true if the volume is the system volume; otherwise, it is false.
Public property | ItemType | This value is the type of item. (Inherited from PhysicalItem.)
Public property | Label | This value is the label assigned to the volume.
Public property | LastAccessTime | This value is the time when the item was last accessed. (Inherited from PhysicalItem.)
Public property | LastWriteTime | This value is the time when the item was last written to. (Inherited from PhysicalItem.)
Public property | Metadata | This value is any additional metadata that may be displayed for a particular type of item. This metadata is not in any particular format, but you must be able to determine the format and decipher the metadata based on the type. (Inherited from PhysicalItem.)
Public property | Name | This value is the name of the item. Typically, this name is used for display in the user interface. (Inherited from PhysicalItem.)
Public property | Path | This value is the path of the item. (Inherited from PhysicalItem.)
Public property | Saturation | This value represents the saturation level of the item. Typically, this value is used to display a visual state in the user interface. (Inherited from PhysicalItem.)
Public property | Size | This value is the physical size of the item. (Inherited from PhysicalItem.)
Public property | TotalSize | This value is the total size of the volume.
Public property | VolumeType | This value is the type of volume.
Top
See Also

Reference

Volume Class
DoubleTake.Common.Contract Namespace


Volume.AvailableFreeSpace Property

VolumeAvailableFreeSpace Property
This value is the amount of free space on the volume.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public long AvailableFreeSpace { get; set; }
Public Property AvailableFreeSpace As Long
    Get
    Set
public:
property long long AvailableFreeSpace {
    long long get ();
    void set (long long value);
}
function get_AvailableFreeSpace();
function set_AvailableFreeSpace(value);

Property Value

Type: Int64
The available free space on this volume.
See Also

Reference

Volume Class
DoubleTake.Common.Contract Namespace


Volume.DriveFormat Property

VolumeDriveFormat Property
This value is the file system format of the volume.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string DriveFormat { get; set; }
Public Property DriveFormat As String
    Get
    Set
public:
property String^ DriveFormat {
    String^ get ();
    void set (String^ value);
}
function get_DriveFormat();
function set_DriveFormat(value);

Property Value

Type: String
The format of the drive.
See Also

Reference

Volume Class
DoubleTake.Common.Contract Namespace


Volume.DriveType Property

VolumeDriveType Property
This value is the drive type.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public DriveType DriveType { get; set; }
Public Property DriveType As DriveType
    Get
    Set
public:
property DriveType DriveType {
    DriveType get ();
    void set (DriveType value);
}
function get_DriveType();
function set_DriveType(value);

Property Value

Type: DriveType
The type of the drive.
See Also

Reference

Volume Class
DoubleTake.Common.Contract Namespace


Volume.IsSystemDrive Property

VolumeIsSystemDrive Property
This value is true if the volume is the system volume; otherwise, it is false.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsSystemDrive { get; set; }
Public Property IsSystemDrive As Boolean
    Get
    Set
public:
property bool IsSystemDrive {
    bool get ();
    void set (bool value);
}
function get_IsSystemDrive();
function set_IsSystemDrive(value);

Property Value

Type: Boolean
if this volume is the system drive; otherwise, .
See Also

Reference

Volume Class
DoubleTake.Common.Contract Namespace


Volume.Label Property

VolumeLabel Property
This value is the label assigned to the volume.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Label { get; set; }
Public Property Label As String
    Get
    Set
public:
property String^ Label {
    String^ get ();
    void set (String^ value);
}
function get_Label();
function set_Label(value);

Property Value

Type: String
The volume label.
See Also

Reference

Volume Class
DoubleTake.Common.Contract Namespace


Volume.TotalSize Property

VolumeTotalSize Property
This value is the total size of the volume.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public long TotalSize { get; set; }
Public Property TotalSize As Long
    Get
    Set
public:
property long long TotalSize {
    long long get ();
    void set (long long value);
}
function get_TotalSize();
function set_TotalSize(value);

Property Value

Type: Int64
The total size of the volume.
See Also

Reference

Volume Class
DoubleTake.Common.Contract Namespace


Volume.VolumeType Property

VolumeVolumeType Property
This value is the type of volume.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string VolumeType { get; set; }
Public Property VolumeType As String
    Get
    Set
public:
property String^ VolumeType {
    String^ get ();
    void set (String^ value);
}
function get_VolumeType();
function set_VolumeType(value);

Property Value

Type: String
if this volume is the system drive; otherwise, .
See Also

Reference

Volume Class
DoubleTake.Common.Contract Namespace


Workload Class

Workload Class
Describes the data on a server that will be protected as part of a job.
Inheritance Hierarchy
SystemObject
DoubleTake.Common.ContractWorkload

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class Workload : IExtensibleDataObject
Public Class Workload
    Implements IExtensibleDataObject
public ref class Workload : IExtensibleDataObject
DoubleTake.Common.Contract.Workload = function();

Type.createClass(
    'DoubleTake.Common.Contract.Workload',
    null,
    IExtensibleDataObject);

The Workload type exposes the following members.

Constructors
 | Name | Description
Public method | Workload | Initializes a new instance of the Workload class
Top
Properties
Name Description
Public property ExtensionData
Gets or sets the structure that contains extra data.
Public property LogicalRules
This value is the logical replication rules that define the workload.
Public property PhysicalRules
This value represents the physical replication rules that define the workload.
Public property RecoveryImageDataPath
This value is for image based recoveries and is the full path to the recovery image.
Public property RecoveryImageId
This value is for image based recoveries and is the ID of the recovery image.
Public property RecoverySnapshotSetId
This value is for image based recoveries and is the ID of a recovery snapshot.
Public property WorkloadTypeName
This value is the workload type name. ClusterAwareDthv—Cluster-aware agentless Hyper-V job ClusterAwareExchange—Cluster-aware Exchange job ClusterAwareFilesAndFolders—Cluster-aware files and folders job ClusterAwareHV2V—Cluster-aware virtual to Hyper-V job ClusterAwareMultiSelectDTHV—Cluster-aware agentless Hyper-V job ClusterAwareSql—Cluster-aware SQL job DataOnlyImageProtection—DR data protection job DataOnlyImageRecovery—DR data recovery job Diagnostics—Throughput Diagnostic Utility job DTHV—Agentless Hyper-V job Exchange—Exchange job FilesAndFolders—Files and folders job FullServerFailover—Full server job FullServerImageProtection—DR full server protection job FullServerImageRecovery—DR full server recovery job LinuxFullServerFailover—Full server for Linux job Lvra—Full server to ESX appliance job MoveDataOnlyMigration—Data migration job MoveServerMigration—Full server migration job MultiSelectDTHV—Agentless Hyper-V job SQL—SQL job UvraWorkload—Double-Take version 7.0.1 or earler full server to ESX appliance job V2V—V to ESX or V to Hyper-V job VRA—Full server to ESX or full server to Hyper-V job VraMove—Full server to ESX migration or full server to Hyper-V migration job
Top
See Also

Reference

DoubleTake.Common.Contract Namespace


Workload Constructor

Workload Constructor
Initializes a new instance of the Workload class

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Workload()
Public Sub New
public:
Workload()
DoubleTake.Common.Contract.Workload = function();
See Also

Reference

Workload Class
DoubleTake.Common.Contract Namespace


Workload Properties

Workload Properties

The Workload type exposes the following members.

Properties
Name Description
Public property ExtensionData
Gets or sets the structure that contains extra data.
Public property LogicalRules
This value is the logical replication rules that define the workload.
Public property PhysicalRules
This value represents the physical replication rules that define the workload.
Public property RecoveryImageDataPath
This value is for image based recoveries and is the full path to the recovery image.
Public property RecoveryImageId
This value is for image based recoveries and is the ID of the recovery image.
Public property RecoverySnapshotSetId
This value is for image based recoveries and is the ID of a recovery snapshot.
Public property WorkloadTypeName
This value is the workload type name. ClusterAwareDthv—Cluster-aware agentless Hyper-V job ClusterAwareExchange—Cluster-aware Exchange job ClusterAwareFilesAndFolders—Cluster-aware files and folders job ClusterAwareHV2V—Cluster-aware virtual to Hyper-V job ClusterAwareMultiSelectDTHV—Cluster-aware agentless Hyper-V job ClusterAwareSql—Cluster-aware SQL job DataOnlyImageProtection—DR data protection job DataOnlyImageRecovery—DR data recovery job Diagnostics—Throughput Diagnostic Utility job DTHV—Agentless Hyper-V job Exchange—Exchange job FilesAndFolders—Files and folders job FullServerFailover—Full server job FullServerImageProtection—DR full server protection job FullServerImageRecovery—DR full server recovery job LinuxFullServerFailover—Full server for Linux job Lvra—Full server to ESX appliance job MoveDataOnlyMigration—Data migration job MoveServerMigration—Full server migration job MultiSelectDTHV—Agentless Hyper-V job SQL—SQL job UvraWorkload—Double-Take version 7.0.1 or earler full server to ESX appliance job V2V—V to ESX or V to Hyper-V job VRA—Full server to ESX or full server to Hyper-V job VraMove—Full server to ESX migration or full server to Hyper-V migration job
Top
See Also

Reference

Workload Class
DoubleTake.Common.Contract Namespace


Workload.ExtensionData Property

WorkloadExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

Workload Class
DoubleTake.Common.Contract Namespace


Workload.LogicalRules Property

WorkloadLogicalRules Property
This value is the logical replication rules that define the workload.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string[] LogicalRules { get; set; }
Public Property LogicalRules As String()
    Get
    Set
public:
property array<String^>^ LogicalRules {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
function get_LogicalRules();
function set_LogicalRules(value);

Property Value

Type: String
An array of String that represents the logical replication rules that compose this workload.
See Also

Reference

Workload Class
DoubleTake.Common.Contract Namespace


Workload.PhysicalRules Property

WorkloadPhysicalRules Property
This value represents the physical replication rules that define the workload.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public PhysicalRule[] PhysicalRules { get; set; }
Public Property PhysicalRules As PhysicalRule()
    Get
    Set
public:
property array<PhysicalRule^>^ PhysicalRules {
    array<PhysicalRule^>^ get ();
    void set (array<PhysicalRule^>^ value);
}
function get_PhysicalRules();
function set_PhysicalRules(value);

Property Value

Type: PhysicalRule
An array of PhysicalRule that represents the physical replication rules that compose this workload.
See Also

Reference

Workload Class
DoubleTake.Common.Contract Namespace


Workload.RecoveryImageDataPath Property

WorkloadRecoveryImageDataPath Property
This value is for image based recoveries and is the full path to the recovery image.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string RecoveryImageDataPath { get; set; }
Public Property RecoveryImageDataPath As String
    Get
    Set
public:
property String^ RecoveryImageDataPath {
    String^ get ();
    void set (String^ value);
}
function get_RecoveryImageDataPath();
function set_RecoveryImageDataPath(value);

Property Value

Type: String
Full path to the root of the image
See Also

Reference

Workload Class
DoubleTake.Common.Contract Namespace


Workload.RecoveryImageId Property

WorkloadRecoveryImageId Property
This value is for image based recoveries and is the ID of the recovery image.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Guid RecoveryImageId { get; set; }
Public Property RecoveryImageId As Guid
    Get
    Set
public:
property Guid RecoveryImageId {
    Guid get ();
    void set (Guid value);
}
function get_RecoveryImageId();
function set_RecoveryImageId(value);

Property Value

Type: Guid
Unique identifier of the image
See Also

Reference

Workload Class
DoubleTake.Common.Contract Namespace


Workload.RecoverySnapshotSetId Property

WorkloadRecoverySnapshotSetId Property
This value is for image based recoveries and is the ID of a recovery snapshot.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Guid RecoverySnapshotSetId { get; set; }
Public Property RecoverySnapshotSetId As Guid
    Get
    Set
public:
property Guid RecoverySnapshotSetId {
    Guid get ();
    void set (Guid value);
}
function get_RecoverySnapshotSetId();
function set_RecoverySnapshotSetId(value);

Property Value

Type: Guid
Unique identifier of the image
See Also

Reference

Workload Class
DoubleTake.Common.Contract Namespace


Workload.WorkloadTypeName Property

WorkloadWorkloadTypeName Property
This value is the workload type name. ClusterAwareDthv—Cluster-aware agentless Hyper-V job ClusterAwareExchange—Cluster-aware Exchange job ClusterAwareFilesAndFolders—Cluster-aware files and folders job ClusterAwareHV2V—Cluster-aware virtual to Hyper-V job ClusterAwareMultiSelectDTHV—Cluster-aware agentless Hyper-V job ClusterAwareSql—Cluster-aware SQL job DataOnlyImageProtection—DR data protection job DataOnlyImageRecovery—DR data recovery job Diagnostics—Throughput Diagnostic Utility job DTHV—Agentless Hyper-V job Exchange—Exchange job FilesAndFolders—Files and folders job FullServerFailover—Full server job FullServerImageProtection—DR full server protection job FullServerImageRecovery—DR full server recovery job LinuxFullServerFailover—Full server for Linux job Lvra—Full server to ESX appliance job MoveDataOnlyMigration—Data migration job MoveServerMigration—Full server migration job MultiSelectDTHV—Agentless Hyper-V job SQL—SQL job UvraWorkload—Double-Take version 7.0.1 or earler full server to ESX appliance job V2V—V to ESX or V to Hyper-V job VRA—Full server to ESX or full server to Hyper-V job VraMove—Full server to ESX migration or full server to Hyper-V migration job

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string WorkloadTypeName { get; set; }
Public Property WorkloadTypeName As String
    Get
    Set
public:
property String^ WorkloadTypeName {
    String^ get ();
    void set (String^ value);
}
function get_WorkloadTypeName();
function set_WorkloadTypeName(value);

Property Value

Type: String
The name of the workload type.
See Also

Reference

Workload Class
DoubleTake.Common.Contract Namespace


WorkloadSupportSummary Class

WorkloadSupportSummary Class
Represents a summary of the licensing determination process for a workload type.
Inheritance Hierarchy
SystemObject
DoubleTake.Common.ContractWorkloadSupportSummary

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class WorkloadSupportSummary : IExtensibleDataObject
Public Class WorkloadSupportSummary
    Implements IExtensibleDataObject
public ref class WorkloadSupportSummary : IExtensibleDataObject
DoubleTake.Common.Contract.WorkloadSupportSummary = function();

Type.createClass(
    'DoubleTake.Common.Contract.WorkloadSupportSummary',
    null,
    IExtensibleDataObject);

The WorkloadSupportSummary type exposes the following members.

Constructors
 | Name | Description
Public method | WorkloadSupportSummary | Initializes a new instance of the WorkloadSupportSummary class
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Reason | This value can be a string resource ID used for obtaining the reason text in the client or the reason text itself. If the reason text needs to be formatted with parameters, use ReasonFormatParameters.
Public property | ReasonFormatParameters | This value is format parameters for Reason.
Top
See Also

Reference

DoubleTake.Common.Contract Namespace


WorkloadSupportSummary Constructor

WorkloadSupportSummary Constructor
Initializes a new instance of the WorkloadSupportSummary class

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public WorkloadSupportSummary()
Public Sub New
public:
WorkloadSupportSummary()
DoubleTake.Common.Contract.WorkloadSupportSummary = function();
See Also

Reference

WorkloadSupportSummary Class
DoubleTake.Common.Contract Namespace


WorkloadSupportSummary Properties

WorkloadSupportSummary Properties

The WorkloadSupportSummary type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Reason | This value can be a string resource ID used for obtaining the reason text in the client or the reason text itself. If the reason text needs to be formatted with parameters, use ReasonFormatParameters.
Public property | ReasonFormatParameters | This value is format parameters for Reason.
Top
See Also

Reference

WorkloadSupportSummary Class
DoubleTake.Common.Contract Namespace


WorkloadSupportSummary.ExtensionData Property

WorkloadSupportSummaryExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The structure that contains extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

WorkloadSupportSummary Class
DoubleTake.Common.Contract Namespace


WorkloadSupportSummary.Reason Property

WorkloadSupportSummaryReason Property
This value can be a string resource ID used for obtaining the reason text in the client or the reason text itself. If the reason text needs to be formatted with parameters, use ReasonFormatParameters.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Reason { get; set; }
Public Property Reason As String
    Get
    Set
public:
property String^ Reason {
    String^ get ();
    void set (String^ value);
}
function get_Reason();
function set_Reason(value);

Property Value

Type: String
The reason why the workload type is licensed or not.
Remarks
This value can be a string resource ID used for obtaining the reason text in the client or the reason text itself. If the reason text needs to be formatted with parameters, use the ReasonFormatParameters property.
See Also

Reference

WorkloadSupportSummary Class
DoubleTake.Common.Contract Namespace


WorkloadSupportSummary.ReasonFormatParameters Property

WorkloadSupportSummaryReasonFormatParameters Property
This value is format parameters for Reason.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string[] ReasonFormatParameters { get; set; }
Public Property ReasonFormatParameters As String()
    Get
    Set
public:
property array<String^>^ ReasonFormatParameters {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
function get_ReasonFormatParameters();
function set_ReasonFormatParameters(value);

Property Value

Type: String
The reason format parameters.
See Also

Reference

WorkloadSupportSummary Class
DoubleTake.Common.Contract Namespace
WorkloadSupportSummary.Reason


WorkloadType Class

WorkloadType Class
Describes the type of workloads that can be created on a server.
Inheritance Hierarchy
SystemObject
DoubleTake.Common.ContractWorkloadType

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class WorkloadType : IExtensibleDataObject
Public Class WorkloadType
    Implements IExtensibleDataObject
public ref class WorkloadType : IExtensibleDataObject
DoubleTake.Common.Contract.WorkloadType = function();

Type.createClass(
    'DoubleTake.Common.Contract.WorkloadType',
    null,
    IExtensibleDataObject);

The WorkloadType type exposes the following members.

Constructors
 | Name | Description
Public method | WorkloadType | Initializes a new instance of the WorkloadType class
Top
Properties
Name Description
Public property ExtensionData
Gets or sets the structure that contains extra data.
Public property IsLicensed
This value is true if this type of workload is licensed for the server; otherwise, it is false.
Public property IsPresent
This value is true if this type of workload is present on the server; otherwise, it is false.
Public property Name
This value is the workload type name. ClusterAwareDthv—Cluster-aware agentless Hyper-V job ClusterAwareExchange—Cluster-aware Exchange job ClusterAwareFilesAndFolders—Cluster-aware files and folders job ClusterAwareHV2V—Cluster-aware virtual to Hyper-V job ClusterAwareMultiSelectDTHV—Cluster-aware agentless Hyper-V job ClusterAwareSql—Cluster-aware SQL job DataOnlyImageProtection—DR data protection job DataOnlyImageRecovery—DR data recovery job Diagnostics—Throughput Diagnostic Utility job DTHV—Agentless Hyper-V job Exchange—Exchange job FilesAndFolders—Files and folders job FullServerFailover—Full server job FullServerImageProtection—DR full server protection job FullServerImageRecovery—DR full server recovery job LinuxFullServerFailover—Full server for Linux job Lvra—Full server to ESX appliance job MoveDataOnlyMigration—Data migration job MoveServerMigration—Full server migration job MultiSelectDTHV—Agentless Hyper-V job SQL—SQL job UvraWorkload—Double-Take version 7.0.1 or earler full server to ESX appliance job V2V—V to ESX or V to Hyper-V job VRA—Full server to ESX or full server to Hyper-V job VraMove—Full server to ESX migration or full server to Hyper-V migration job
Public property SupportSummary
This value is a summary of the licensing for the workload type. The summary can be null if there is no reason to report any details about the license calculation. Otherwise, it should be non-null and populated with details about the license calculation that the client can use for reporting purposes.
Top
See Also

Reference

DoubleTake.Common.Contract Namespace


WorkloadType Constructor

WorkloadType Constructor
Initializes a new instance of the WorkloadType class

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public WorkloadType()
Public Sub New
public:
WorkloadType()
DoubleTake.Common.Contract.WorkloadType = function();
See Also

Reference

WorkloadType Class
DoubleTake.Common.Contract Namespace


WorkloadType Properties

WorkloadType Properties

The WorkloadType type exposes the following members.

Properties
Name Description
Public property ExtensionData
Gets or sets the structure that contains extra data.
Public property IsLicensed
This value is true if this type of workload is licensed for the server; otherwise, it is false.
Public property IsPresent
This value is true if this type of workload is present on the server; otherwise, it is false.
Public property Name
This value is the workload type name. ClusterAwareDthv—Cluster-aware agentless Hyper-V job ClusterAwareExchange—Cluster-aware Exchange job ClusterAwareFilesAndFolders—Cluster-aware files and folders job ClusterAwareHV2V—Cluster-aware virtual to Hyper-V job ClusterAwareMultiSelectDTHV—Cluster-aware agentless Hyper-V job ClusterAwareSql—Cluster-aware SQL job DataOnlyImageProtection—DR data protection job DataOnlyImageRecovery—DR data recovery job Diagnostics—Throughput Diagnostic Utility job DTHV—Agentless Hyper-V job Exchange—Exchange job FilesAndFolders—Files and folders job FullServerFailover—Full server job FullServerImageProtection—DR full server protection job FullServerImageRecovery—DR full server recovery job LinuxFullServerFailover—Full server for Linux job Lvra—Full server to ESX appliance job MoveDataOnlyMigration—Data migration job MoveServerMigration—Full server migration job MultiSelectDTHV—Agentless Hyper-V job SQL—SQL job UvraWorkload—Double-Take version 7.0.1 or earler full server to ESX appliance job V2V—V to ESX or V to Hyper-V job VRA—Full server to ESX or full server to Hyper-V job VraMove—Full server to ESX migration or full server to Hyper-V migration job
Public property SupportSummary
This value is a summary of the licensing for the workload type. The summary can be null if there is no reason to report any details about the license calculation. Otherwise, it should be non-null and populated with details about the license calculation that the client can use for reporting purposes.
Top
See Also

Reference

WorkloadType Class
DoubleTake.Common.Contract Namespace


WorkloadType.ExtensionData Property

WorkloadTypeExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

WorkloadType Class
DoubleTake.Common.Contract Namespace


WorkloadType.IsLicensed Property

WorkloadTypeIsLicensed Property
This value is true if this type of workload is licensed for the server; otherwise, it is false.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsLicensed { get; set; }
Public Property IsLicensed As Boolean
    Get
    Set
public:
property bool IsLicensed {
    bool get ();
    void set (bool value);
}
function get_IsLicensed();
function set_IsLicensed(value);

Property Value

Type: Boolean
if this type of workload is licensed; otherwise, .
See Also

Reference

WorkloadType Class
DoubleTake.Common.Contract Namespace


WorkloadType.IsPresent Property

WorkloadTypeIsPresent Property
This value is true if this type of workload is present on the server; otherwise, it is false.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsPresent { get; set; }
Public Property IsPresent As Boolean
    Get
    Set
public:
property bool IsPresent {
    bool get ();
    void set (bool value);
}
function get_IsPresent();
function set_IsPresent(value);

Property Value

Type: Boolean
if this instance is present; otherwise, .
See Also

Reference

WorkloadType Class
DoubleTake.Common.Contract Namespace


WorkloadType.Name Property

WorkloadTypeName Property
This value is the workload type name. ClusterAwareDthv—Cluster-aware agentless Hyper-V job ClusterAwareExchange—Cluster-aware Exchange job ClusterAwareFilesAndFolders—Cluster-aware files and folders job ClusterAwareHV2V—Cluster-aware virtual to Hyper-V job ClusterAwareMultiSelectDTHV—Cluster-aware agentless Hyper-V job ClusterAwareSql—Cluster-aware SQL job DataOnlyImageProtection—DR data protection job DataOnlyImageRecovery—DR data recovery job Diagnostics—Throughput Diagnostic Utility job DTHV—Agentless Hyper-V job Exchange—Exchange job FilesAndFolders—Files and folders job FullServerFailover—Full server job FullServerImageProtection—DR full server protection job FullServerImageRecovery—DR full server recovery job LinuxFullServerFailover—Full server for Linux job Lvra—Full server to ESX appliance job MoveDataOnlyMigration—Data migration job MoveServerMigration—Full server migration job MultiSelectDTHV—Agentless Hyper-V job SQL—SQL job UvraWorkload—Double-Take version 7.0.1 or earler full server to ESX appliance job V2V—V to ESX or V to Hyper-V job VRA—Full server to ESX or full server to Hyper-V job VraMove—Full server to ESX migration or full server to Hyper-V migration job

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
function get_Name();
function set_Name(value);

Property Value

Type: String
The name of the workload type..
See Also

Reference

WorkloadType Class
DoubleTake.Common.Contract Namespace


WorkloadType.SupportSummary Property

WorkloadTypeSupportSummary Property
This value is a summary of the licensing for the workload type. The summary can be null if there is no reason to report any details about the license calculation. Otherwise, it should be non-null and populated with details about the license calculation that the client can use for reporting purposes.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public WorkloadSupportSummary SupportSummary { get; set; }
Public Property SupportSummary As WorkloadSupportSummary
    Get
    Set
public:
property WorkloadSupportSummary^ SupportSummary {
    WorkloadSupportSummary^ get ();
    void set (WorkloadSupportSummary^ value);
}
function get_SupportSummary();
function set_SupportSummary(value);

Property Value

Type: WorkloadSupportSummary
The summary of the licensing for this workload type.
Remarks
The summary can be null if there's no reason to report any details about the license calculation. Otherwise, it should be non-null and populated with details about the license calculation that the client can use for reporting purposes.
See Also

Reference

WorkloadType Class
DoubleTake.Common.Contract Namespace


WorkloadTypeNames Class

WorkloadTypeNames Class
Defines constants that represent known workload type names. These constants are used as values for the Name property.
Inheritance Hierarchy
SystemObject
DoubleTake.Common.ContractWorkloadTypeNames

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public static class WorkloadTypeNames
Public NotInheritable Class WorkloadTypeNames
public ref class WorkloadTypeNames abstract sealed
DoubleTake.Common.Contract.WorkloadTypeNames = function();

Type.createClass(
    'DoubleTake.Common.Contract.WorkloadTypeNames');

The WorkloadTypeNames type exposes the following members.

Properties
Name | Description
All |
Top
Fields
Name | Description
ClusterAwareDthv | A workload type for a cluster-aware Hyper-V job.
ClusterAwareFilesAndFolders | A workload type for a Cluster Aware Files and Folders Job.
ClusterAwareHV2V | A workload type for a cluster aware virtual to virtual VRA job.
ClusterAwareMultiSelectDthv | A workload type for a multi select cluster-aware Hyper-V job.
DataOnlyImageProtection | A workload type for a data-only image protection job.
DataOnlyImageRecovery | A workload type for a data-only image recovery job.
Diagnostics | Throughput Diagnostic Utility connection workload.
DtavVcdVapp | A workload type for a VMware Vapp to Vapp HostLevel job.
DtavVm | A workload type for a VMware virtual to virtual Host-Level job.
Dthv | A workload type for a Host Hyper-V job.
Exchange | An Exchange application workload.
ExchangeClustered | An clustered Exchange application workload.
FilesAndFolders | A workload type for a files-and-folders job.
FullServerFailover | A workload type for a full-server failover job.
FullServerImageProtection | A workload type for a full-server image protection job.
FullServerImageProtectionSsmConfigurationWorkload | A workload type used internally for a full-server image protection job with an SSM configuration.
FullServerImageRecovery | A workload type for a full-server image recovery job.
FullServerImageRecoverySsmConfigurationWorkload | A workload type used internally for a full-server image recovery job with an SSM configuration.
LinuxFullServerFailover | A workload type for a linux full-server failover job.
LinuxMoveDataOnlyMigration | A workload type for a Linux Move data-only migration job.
LinuxMoveServerMigration | A workload type for a Linux Move server migration job.
Lvra | Linux Virtual recovery assistant jobs.
MoveDataOnlyMigration | A workload type for a Move data-only migration job.
MoveLvra | Linux Move Virtual recovery assistant jobs.
MoveServerMigration | A workload type for a Move server migration job.
MultiSelectDthv | A workload type for a multi select Host Hyper-V job.
Sql | A SQL application workload.
SqlClustered | A workload type for a cluster-aware SQL job.
SsmConfiguration | A workload type used internally for a full-server job with an SSM configuration.
Uvra | Universal Virtual recovery assistant jobs.
V2V | A workload type for a virtual to virtual VRA job.
Vra | A workload type for VRA job.
VraMove | A Move-style VRA workload.
Top
See Also

Reference

DoubleTake.Common.Contract Namespace


WorkloadTypeNames Properties

WorkloadTypeNames Properties

The WorkloadTypeNames type exposes the following members.

Properties
Name | Description
All |
Top
See Also

Reference

WorkloadTypeNames Class
DoubleTake.Common.Contract Namespace


WorkloadTypeNames.All Property

WorkloadTypeNamesAll Property

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public static IEnumerable<string> All { get; }
Public Shared ReadOnly Property All As IEnumerable(Of String)
    Get
public:
static property IEnumerable<String^>^ All {
    IEnumerable<String^>^ get ();
}
DoubleTake.Common.Contract.WorkloadTypeNames.get_All = function();

Property Value

Type: IEnumerable String
See Also

Reference

WorkloadTypeNames Class
DoubleTake.Common.Contract Namespace


WorkloadTypeNames Fields

WorkloadTypeNames Fields

The WorkloadTypeNames type exposes the following members.

Fields
Name | Description
ClusterAwareDthv | A workload type for a cluster-aware Hyper-V job.
ClusterAwareFilesAndFolders | A workload type for a Cluster Aware Files and Folders Job.
ClusterAwareHV2V | A workload type for a cluster aware virtual to virtual VRA job.
ClusterAwareMultiSelectDthv | A workload type for a multi select cluster-aware Hyper-V job.
DataOnlyImageProtection | A workload type for a data-only image protection job.
DataOnlyImageRecovery | A workload type for a data-only image recovery job.
Diagnostics | Throughput Diagnostic Utility connection workload.
DtavVcdVapp | A workload type for a VMware Vapp to Vapp HostLevel job.
DtavVm | A workload type for a VMware virtual to virtual Host-Level job.
Dthv | A workload type for a Host Hyper-V job.
Exchange | An Exchange application workload.
ExchangeClustered | An clustered Exchange application workload.
FilesAndFolders | A workload type for a files-and-folders job.
FullServerFailover | A workload type for a full-server failover job.
FullServerImageProtection | A workload type for a full-server image protection job.
FullServerImageProtectionSsmConfigurationWorkload | A workload type used internally for a full-server image protection job with an SSM configuration.
FullServerImageRecovery | A workload type for a full-server image recovery job.
FullServerImageRecoverySsmConfigurationWorkload | A workload type used internally for a full-server image recovery job with an SSM configuration.
LinuxFullServerFailover | A workload type for a linux full-server failover job.
LinuxMoveDataOnlyMigration | A workload type for a Linux Move data-only migration job.
LinuxMoveServerMigration | A workload type for a Linux Move server migration job.
Lvra | Linux Virtual recovery assistant jobs.
MoveDataOnlyMigration | A workload type for a Move data-only migration job.
MoveLvra | Linux Move Virtual recovery assistant jobs.
MoveServerMigration | A workload type for a Move server migration job.
MultiSelectDthv | A workload type for a multi select Host Hyper-V job.
Sql | A SQL application workload.
SqlClustered | A workload type for a cluster-aware SQL job.
SsmConfiguration | A workload type used internally for a full-server job with an SSM configuration.
Uvra | Universal Virtual recovery assistant jobs.
V2V | A workload type for a virtual to virtual VRA job.
Vra | A workload type for VRA job.
VraMove | A Move-style VRA workload.
Top
See Also

Reference

WorkloadTypeNames Class
DoubleTake.Common.Contract Namespace


WorkloadTypeNames.ClusterAwareDthv Field

WorkloadTypeNamesClusterAwareDthv Field
A workload type for a cluster-aware Hyper-V job.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string ClusterAwareDthv
Public Const ClusterAwareDthv As String
public:
literal String^ ClusterAwareDthv
var DoubleTake.Common.Contract.WorkloadTypeNames.ClusterAwareDthv

Field Value

Type: String
See Also

Reference

WorkloadTypeNames Class
DoubleTake.Common.Contract Namespace


WorkloadTypeNames.ClusterAwareFilesAndFolders Field

WorkloadTypeNamesClusterAwareFilesAndFolders Field
A workload type for a Cluster Aware Files and Folders Job.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string ClusterAwareFilesAndFolders
Public Const ClusterAwareFilesAndFolders As String
public:
literal String^ ClusterAwareFilesAndFolders
var DoubleTake.Common.Contract.WorkloadTypeNames.ClusterAwareFilesAndFolders

Field Value

Type: String
See Also

Reference

WorkloadTypeNames Class
DoubleTake.Common.Contract Namespace


WorkloadTypeNames.ClusterAwareHV2V Field

WorkloadTypeNamesClusterAwareHV2V Field
A workload type for a cluster aware virtual to virtual VRA job.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string ClusterAwareHV2V
Public Const ClusterAwareHV2V As String
public:
literal String^ ClusterAwareHV2V
var DoubleTake.Common.Contract.WorkloadTypeNames.ClusterAwareHV2V

Field Value

Type: String
See Also

Reference

WorkloadTypeNames Class
DoubleTake.Common.Contract Namespace


WorkloadTypeNames.ClusterAwareMultiSelectDthv Field

WorkloadTypeNamesClusterAwareMultiSelectDthv Field
A workload type for a multi select cluster-aware Hyper-V job.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string ClusterAwareMultiSelectDthv
Public Const ClusterAwareMultiSelectDthv As String
public:
literal String^ ClusterAwareMultiSelectDthv
var DoubleTake.Common.Contract.WorkloadTypeNames.ClusterAwareMultiSelectDthv

Field Value

Type: String
See Also

Reference

WorkloadTypeNames Class
DoubleTake.Common.Contract Namespace


WorkloadTypeNames.DataOnlyImageProtection Field

WorkloadTypeNamesDataOnlyImageProtection Field
A workload type for a data-only image protection job.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string DataOnlyImageProtection
Public Const DataOnlyImageProtection As String
public:
literal String^ DataOnlyImageProtection
var DoubleTake.Common.Contract.WorkloadTypeNames.DataOnlyImageProtection

Field Value

Type: String
See Also

Reference

WorkloadTypeNames Class
DoubleTake.Common.Contract Namespace


WorkloadTypeNames.DataOnlyImageRecovery Field

WorkloadTypeNamesDataOnlyImageRecovery Field
A workload type for a data-only image recovery job.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string DataOnlyImageRecovery
Public Const DataOnlyImageRecovery As String
public:
literal String^ DataOnlyImageRecovery
var DoubleTake.Common.Contract.WorkloadTypeNames.DataOnlyImageRecovery

Field Value

Type: String
See Also

Reference

WorkloadTypeNames Class
DoubleTake.Common.Contract Namespace


WorkloadTypeNames.Diagnostics Field

WorkloadTypeNamesDiagnostics Field
Throughput Diagnostic Utility connection workload.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string Diagnostics
Public Const Diagnostics As String
public:
literal String^ Diagnostics
var DoubleTake.Common.Contract.WorkloadTypeNames.Diagnostics

Field Value

Type: String
See Also

Reference

WorkloadTypeNames Class
DoubleTake.Common.Contract Namespace


WorkloadTypeNames.DtavVcdVapp Field

WorkloadTypeNamesDtavVcdVapp Field
A workload type for a VMware Vapp to Vapp HostLevel job.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string DtavVcdVapp
Public Const DtavVcdVapp As String
public:
literal String^ DtavVcdVapp
var DoubleTake.Common.Contract.WorkloadTypeNames.DtavVcdVapp

Field Value

Type: String
See Also

Reference

WorkloadTypeNames Class
DoubleTake.Common.Contract Namespace


WorkloadTypeNames.DtavVm Field

WorkloadTypeNamesDtavVm Field
A workload type for a VMware virtual to virtual Host-Level job.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string DtavVm
Public Const DtavVm As String
public:
literal String^ DtavVm
var DoubleTake.Common.Contract.WorkloadTypeNames.DtavVm

Field Value

Type: String
See Also

Reference

WorkloadTypeNames Class
DoubleTake.Common.Contract Namespace


WorkloadTypeNames.Dthv Field

WorkloadTypeNamesDthv Field
A workload type for a Host Hyper-V job.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string Dthv
Public Const Dthv As String
public:
literal String^ Dthv
var DoubleTake.Common.Contract.WorkloadTypeNames.Dthv

Field Value

Type: String
See Also

Reference

WorkloadTypeNames Class
DoubleTake.Common.Contract Namespace


WorkloadTypeNames.Exchange Field

WorkloadTypeNamesExchange Field
An Exchange application workload.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string Exchange
Public Const Exchange As String
public:
literal String^ Exchange
var DoubleTake.Common.Contract.WorkloadTypeNames.Exchange

Field Value

Type: String
See Also

Reference

WorkloadTypeNames Class
DoubleTake.Common.Contract Namespace


WorkloadTypeNames.ExchangeClustered Field

WorkloadTypeNamesExchangeClustered Field
An clustered Exchange application workload.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string ExchangeClustered
Public Const ExchangeClustered As String
public:
literal String^ ExchangeClustered
var DoubleTake.Common.Contract.WorkloadTypeNames.ExchangeClustered

Field Value

Type: String
See Also

Reference

WorkloadTypeNames Class
DoubleTake.Common.Contract Namespace


WorkloadTypeNames.FilesAndFolders Field

WorkloadTypeNamesFilesAndFolders Field
A workload type for a files-and-folders job.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string FilesAndFolders
Public Const FilesAndFolders As String
public:
literal String^ FilesAndFolders
var DoubleTake.Common.Contract.WorkloadTypeNames.FilesAndFolders

Field Value

Type: String
See Also

Reference

WorkloadTypeNames Class
DoubleTake.Common.Contract Namespace


WorkloadTypeNames.FullServerFailover Field

WorkloadTypeNamesFullServerFailover Field
A workload type for a full-server failover job.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string FullServerFailover
Public Const FullServerFailover As String
public:
literal String^ FullServerFailover
var DoubleTake.Common.Contract.WorkloadTypeNames.FullServerFailover

Field Value

Type: String
See Also

Reference

WorkloadTypeNames Class
DoubleTake.Common.Contract Namespace


WorkloadTypeNames.FullServerImageProtection Field

WorkloadTypeNamesFullServerImageProtection Field
A workload type for a full-server image protection job.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string FullServerImageProtection
Public Const FullServerImageProtection As String
public:
literal String^ FullServerImageProtection
var DoubleTake.Common.Contract.WorkloadTypeNames.FullServerImageProtection

Field Value

Type: String
See Also

Reference

WorkloadTypeNames Class
DoubleTake.Common.Contract Namespace


WorkloadTypeNames.FullServerImageProtectionSsmConfigurationWorkload Field

WorkloadTypeNamesFullServerImageProtectionSsmConfigurationWorkload Field
A workload type used internally for a full-server image protection job with an SSM configuration.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public static string FullServerImageProtectionSsmConfigurationWorkload
Public Shared FullServerImageProtectionSsmConfigurationWorkload As String
public:
static String^ FullServerImageProtectionSsmConfigurationWorkload
var DoubleTake.Common.Contract.WorkloadTypeNames.FullServerImageProtectionSsmConfigurationWorkload

Field Value

Type: String
See Also

Reference

WorkloadTypeNames Class
DoubleTake.Common.Contract Namespace


WorkloadTypeNames.FullServerImageRecovery Field

WorkloadTypeNamesFullServerImageRecovery Field
A workload type for a full-server image recovery job.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string FullServerImageRecovery
Public Const FullServerImageRecovery As String
public:
literal String^ FullServerImageRecovery
var DoubleTake.Common.Contract.WorkloadTypeNames.FullServerImageRecovery

Field Value

Type: String
See Also

Reference

WorkloadTypeNames Class
DoubleTake.Common.Contract Namespace


WorkloadTypeNames.FullServerImageRecoverySsmConfigurationWorkload Field

WorkloadTypeNamesFullServerImageRecoverySsmConfigurationWorkload Field
A workload type used internally for a full-server image recovery job with an SSM configuration.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public static string FullServerImageRecoverySsmConfigurationWorkload
Public Shared FullServerImageRecoverySsmConfigurationWorkload As String
public:
static String^ FullServerImageRecoverySsmConfigurationWorkload
var DoubleTake.Common.Contract.WorkloadTypeNames.FullServerImageRecoverySsmConfigurationWorkload

Field Value

Type: String
See Also

Reference

WorkloadTypeNames Class
DoubleTake.Common.Contract Namespace


WorkloadTypeNames.LinuxFullServerFailover Field

WorkloadTypeNamesLinuxFullServerFailover Field
A workload type for a linux full-server failover job.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string LinuxFullServerFailover
Public Const LinuxFullServerFailover As String
public:
literal String^ LinuxFullServerFailover
var DoubleTake.Common.Contract.WorkloadTypeNames.LinuxFullServerFailover

Field Value

Type: String
See Also

Reference

WorkloadTypeNames Class
DoubleTake.Common.Contract Namespace


WorkloadTypeNames.LinuxMoveDataOnlyMigration Field

WorkloadTypeNamesLinuxMoveDataOnlyMigration Field
A workload type for a Linux Move data-only migration job.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string LinuxMoveDataOnlyMigration
Public Const LinuxMoveDataOnlyMigration As String
public:
literal String^ LinuxMoveDataOnlyMigration
var DoubleTake.Common.Contract.WorkloadTypeNames.LinuxMoveDataOnlyMigration

Field Value

Type: String
See Also

Reference

WorkloadTypeNames Class
DoubleTake.Common.Contract Namespace


WorkloadTypeNames.LinuxMoveServerMigration Field

WorkloadTypeNamesLinuxMoveServerMigration Field
A workload type for a Linux Move server migration job.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string LinuxMoveServerMigration
Public Const LinuxMoveServerMigration As String
public:
literal String^ LinuxMoveServerMigration
var DoubleTake.Common.Contract.WorkloadTypeNames.LinuxMoveServerMigration

Field Value

Type: String
See Also

Reference

WorkloadTypeNames Class
DoubleTake.Common.Contract Namespace


WorkloadTypeNames.Lvra Field

WorkloadTypeNamesLvra Field
Linux Virtual recovery assistant jobs.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string Lvra
Public Const Lvra As String
public:
literal String^ Lvra
var DoubleTake.Common.Contract.WorkloadTypeNames.Lvra

Field Value

Type: String
See Also

Reference

WorkloadTypeNames Class
DoubleTake.Common.Contract Namespace


WorkloadTypeNames.MoveDataOnlyMigration Field

WorkloadTypeNamesMoveDataOnlyMigration Field
A workload type for a Move data-only migration job.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string MoveDataOnlyMigration
Public Const MoveDataOnlyMigration As String
public:
literal String^ MoveDataOnlyMigration
var DoubleTake.Common.Contract.WorkloadTypeNames.MoveDataOnlyMigration

Field Value

Type: String
See Also

Reference

WorkloadTypeNames Class
DoubleTake.Common.Contract Namespace


WorkloadTypeNames.MoveLvra Field

WorkloadTypeNamesMoveLvra Field
Linux Move Virtual recovery assistant jobs.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string MoveLvra
Public Const MoveLvra As String
public:
literal String^ MoveLvra
var DoubleTake.Common.Contract.WorkloadTypeNames.MoveLvra

Field Value

Type: String
See Also

Reference

WorkloadTypeNames Class
DoubleTake.Common.Contract Namespace


WorkloadTypeNames.MoveServerMigration Field

WorkloadTypeNamesMoveServerMigration Field
A workload type for a Move server migration job.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string MoveServerMigration
Public Const MoveServerMigration As String
public:
literal String^ MoveServerMigration
var DoubleTake.Common.Contract.WorkloadTypeNames.MoveServerMigration

Field Value

Type: String
See Also

Reference

WorkloadTypeNames Class
DoubleTake.Common.Contract Namespace


WorkloadTypeNames.MultiSelectDthv Field

WorkloadTypeNamesMultiSelectDthv Field
A workload type for a multi select Host Hyper-V job.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string MultiSelectDthv
Public Const MultiSelectDthv As String
public:
literal String^ MultiSelectDthv
var DoubleTake.Common.Contract.WorkloadTypeNames.MultiSelectDthv

Field Value

Type: String
See Also

Reference

WorkloadTypeNames Class
DoubleTake.Common.Contract Namespace


WorkloadTypeNames.Sql Field

WorkloadTypeNamesSql Field
A SQL application workload.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string Sql
Public Const Sql As String
public:
literal String^ Sql
var DoubleTake.Common.Contract.WorkloadTypeNames.Sql

Field Value

Type: String
See Also

Reference

WorkloadTypeNames Class
DoubleTake.Common.Contract Namespace


WorkloadTypeNames.SqlClustered Field

WorkloadTypeNamesSqlClustered Field
A workload type for a cluster-aware SQL job.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string SqlClustered
Public Const SqlClustered As String
public:
literal String^ SqlClustered
var DoubleTake.Common.Contract.WorkloadTypeNames.SqlClustered

Field Value

Type: String
See Also

Reference

WorkloadTypeNames Class
DoubleTake.Common.Contract Namespace


WorkloadTypeNames.SsmConfiguration Field

WorkloadTypeNamesSsmConfiguration Field
A workload type used internally for a full-server job with an SSM configuration.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public static string SsmConfiguration
Public Shared SsmConfiguration As String
public:
static String^ SsmConfiguration
var DoubleTake.Common.Contract.WorkloadTypeNames.SsmConfiguration

Field Value

Type: String
See Also

Reference

WorkloadTypeNames Class
DoubleTake.Common.Contract Namespace


WorkloadTypeNames.Uvra Field

WorkloadTypeNamesUvra Field
Universal Virtual recovery assistant jobs.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string Uvra
Public Const Uvra As String
public:
literal String^ Uvra
var DoubleTake.Common.Contract.WorkloadTypeNames.Uvra

Field Value

Type: String
See Also

Reference

WorkloadTypeNames Class
DoubleTake.Common.Contract Namespace


WorkloadTypeNames.V2V Field

WorkloadTypeNamesV2V Field
A workload type for a virtual to virtual VRA job.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string V2V
Public Const V2V As String
public:
literal String^ V2V
var DoubleTake.Common.Contract.WorkloadTypeNames.V2V

Field Value

Type: String
See Also

Reference

WorkloadTypeNames Class
DoubleTake.Common.Contract Namespace


WorkloadTypeNames.Vra Field

WorkloadTypeNamesVra Field
A workload type for VRA job.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string Vra
Public Const Vra As String
public:
literal String^ Vra
var DoubleTake.Common.Contract.WorkloadTypeNames.Vra

Field Value

Type: String
See Also

Reference

WorkloadTypeNames Class
DoubleTake.Common.Contract Namespace


WorkloadTypeNames.VraMove Field

WorkloadTypeNamesVraMove Field
A Move-style VRA workload.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string VraMove
Public Const VraMove As String
public:
literal String^ VraMove
var DoubleTake.Common.Contract.WorkloadTypeNames.VraMove

Field Value

Type: String
See Also

Reference

WorkloadTypeNames Class
DoubleTake.Common.Contract Namespace


DoubleTake.Communication Namespace

DoubleTake.Communication Namespace
Classes
 | Class | Description
Public class | ActivityPropagationBehavior |
Public class | ActivityPropagationInspector |
Public class | BasicHttpEndpointSpecificationBase |
Public class | BasicHttpNoSecurityEndpointSpecification |
Public class | CommunicationAspects |
Public class | CommunicationSettings |
Public class | DefaultEndpointSpecification |
Public class | EndpointSpecificationBase |
Public class | EndpointSpecificationExtensions |
Public class | EndpointSpecifications |
Public class | LinuxServiceInteropCertificateValidator |
Public class | LinuxServiceInteropEndpointSpecification |
Public class | LinuxServiceInteropProxyFactory |
Public class | MessageTracer |
Public class | MessageTracingBehaviorAttribute |
Public class | ProxyFactory |
Public class | ProxyFactoryBase |
Public class | ProxyFactoryExtensions |
Public class | ServiceConnectionParameters |
Public class | ServiceConnectionParametersExtensions |
Public class | ServiceRelativeAddressAttribute |
Public class | ServiceRelativeUriAttribute |
Public class | WSHttpEndpointSpecificationBase |
Interfaces
 | Interface | Description
Public interface | ICommunicationSettings |
Public interface | IEndpointSpecification |
Public interface | IProxy |
Public interface | IProxyFactory |
Enumerations
 | Enumeration | Description
Public enumeration | AddressingScheme |


ActivityPropagationBehavior Class

ActivityPropagationBehavior Class
Inheritance Hierarchy
SystemObject
DoubleTake.CommunicationActivityPropagationBehavior

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class ActivityPropagationBehavior : IEndpointBehavior,
    IServiceBehavior
Public Class ActivityPropagationBehavior
    Implements IEndpointBehavior, IServiceBehavior
public ref class ActivityPropagationBehavior : IEndpointBehavior,
    IServiceBehavior
DoubleTake.Communication.ActivityPropagationBehavior = function();

Type.createClass(
    'DoubleTake.Communication.ActivityPropagationBehavior',
    null,
    IEndpointBehavior,
    IServiceBehavior);

The ActivityPropagationBehavior type exposes the following members.

Constructors
 | Name | Description
Public method | ActivityPropagationBehavior | Initializes a new instance of the ActivityPropagationBehavior class
Top
Methods
 | Name | Description
Public method | AddBindingParameters(ServiceEndpoint, BindingParameterCollection) |
Public method | AddBindingParameters(ServiceDescription, ServiceHostBase, CollectionServiceEndpoint, BindingParameterCollection) |
Public method | ApplyClientBehavior |
Public method | ApplyDispatchBehavior(ServiceDescription, ServiceHostBase) |
Public method | ApplyDispatchBehavior(ServiceEndpoint, EndpointDispatcher) |
Public method | Validate(ServiceEndpoint) |
Public method | Validate(ServiceDescription, ServiceHostBase) |
Top
See Also

Reference

DoubleTake.Communication Namespace


ActivityPropagationBehavior Constructor

ActivityPropagationBehavior Constructor
Initializes a new instance of the ActivityPropagationBehavior class

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ActivityPropagationBehavior()
Public Sub New
public:
ActivityPropagationBehavior()
DoubleTake.Communication.ActivityPropagationBehavior = function();
See Also

Reference

ActivityPropagationBehavior Class
DoubleTake.Communication Namespace


ActivityPropagationBehavior Methods

ActivityPropagationBehavior Methods

The ActivityPropagationBehavior type exposes the following members.

Methods
 | Name | Description
Public method | AddBindingParameters(ServiceEndpoint, BindingParameterCollection) |
Public method | AddBindingParameters(ServiceDescription, ServiceHostBase, CollectionServiceEndpoint, BindingParameterCollection) |
Public method | ApplyClientBehavior |
Public method | ApplyDispatchBehavior(ServiceDescription, ServiceHostBase) |
Public method | ApplyDispatchBehavior(ServiceEndpoint, EndpointDispatcher) |
Public method | Validate(ServiceEndpoint) |
Public method | Validate(ServiceDescription, ServiceHostBase) |
Top
See Also

Reference

ActivityPropagationBehavior Class
DoubleTake.Communication Namespace


ActivityPropagationBehavior.AddBindingParameters Method

ActivityPropagationBehaviorAddBindingParameters Method
Overload List
 | Name | Description
Public method | AddBindingParameters(ServiceEndpoint, BindingParameterCollection) |
Public method | AddBindingParameters(ServiceDescription, ServiceHostBase, CollectionServiceEndpoint, BindingParameterCollection) |
Top
See Also

Reference

ActivityPropagationBehavior Class
DoubleTake.Communication Namespace


ActivityPropagationBehavior.AddBindingParameters Method (ServiceEndpoint, BindingParameterCollection)

ActivityPropagationBehaviorAddBindingParameters Method (ServiceEndpoint, BindingParameterCollection)

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public void AddBindingParameters(
    ServiceEndpoint endpoint,
    BindingParameterCollection bindingParameters
)
Public Sub AddBindingParameters (
    endpoint As ServiceEndpoint,
    bindingParameters As BindingParameterCollection
)
public:
virtual void AddBindingParameters(
    ServiceEndpoint^ endpoint,
    BindingParameterCollection^ bindingParameters
) sealed
function AddBindingParameters(endpoint, bindingParameters);

Parameters

endpoint
Type: System.ServiceModel.DescriptionServiceEndpoint
bindingParameters
Type: System.ServiceModel.ChannelsBindingParameterCollection

Implements

IEndpointBehaviorAddBindingParameters(ServiceEndpoint, BindingParameterCollection)
See Also

Reference

ActivityPropagationBehavior Class
AddBindingParameters Overload
DoubleTake.Communication Namespace


ActivityPropagationBehavior.AddBindingParameters Method (ServiceDescription, ServiceHostBase, Collection(ServiceEndpoint), BindingParameterCollection)

ActivityPropagationBehaviorAddBindingParameters Method (ServiceDescription, ServiceHostBase, CollectionServiceEndpoint, BindingParameterCollection)

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public void AddBindingParameters(
    ServiceDescription serviceDescription,
    ServiceHostBase serviceHostBase,
    Collection<ServiceEndpoint> endpoints,
    BindingParameterCollection bindingParameters
)
Public Sub AddBindingParameters (
    serviceDescription As ServiceDescription,
    serviceHostBase As ServiceHostBase,
    endpoints As Collection(Of ServiceEndpoint),
    bindingParameters As BindingParameterCollection
)
public:
virtual void AddBindingParameters(
    ServiceDescription^ serviceDescription,
    ServiceHostBase^ serviceHostBase,
    Collection<ServiceEndpoint^>^ endpoints,
    BindingParameterCollection^ bindingParameters
) sealed
function AddBindingParameters(serviceDescription, serviceHostBase, endpoints, bindingParameters);

Parameters

serviceDescription
Type: System.ServiceModel.DescriptionServiceDescription
serviceHostBase
Type: System.ServiceModelServiceHostBase
endpoints
Type: System.Collections.ObjectModelCollection ServiceEndpoint
bindingParameters
Type: System.ServiceModel.ChannelsBindingParameterCollection

Implements

IServiceBehaviorAddBindingParameters(ServiceDescription, ServiceHostBase, CollectionServiceEndpoint, BindingParameterCollection)
See Also

Reference

ActivityPropagationBehavior Class
AddBindingParameters Overload
DoubleTake.Communication Namespace


ActivityPropagationBehavior.ApplyClientBehavior Method

ActivityPropagationBehaviorApplyClientBehavior Method

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public void ApplyClientBehavior(
    ServiceEndpoint endpoint,
    ClientRuntime clientRuntime
)
Public Sub ApplyClientBehavior (
    endpoint As ServiceEndpoint,
    clientRuntime As ClientRuntime
)
public:
virtual void ApplyClientBehavior(
    ServiceEndpoint^ endpoint,
    ClientRuntime^ clientRuntime
) sealed
function ApplyClientBehavior(endpoint, clientRuntime);

Parameters

endpoint
Type: System.ServiceModel.DescriptionServiceEndpoint
clientRuntime
Type: System.ServiceModel.DispatcherClientRuntime

Implements

IEndpointBehaviorApplyClientBehavior(ServiceEndpoint, ClientRuntime)
See Also

Reference

ActivityPropagationBehavior Class
DoubleTake.Communication Namespace


ActivityPropagationBehavior.ApplyDispatchBehavior Method

ActivityPropagationBehaviorApplyDispatchBehavior Method
Overload List
 | Name | Description
Public method | ApplyDispatchBehavior(ServiceDescription, ServiceHostBase) |
Public method | ApplyDispatchBehavior(ServiceEndpoint, EndpointDispatcher) |
Top
See Also

Reference

ActivityPropagationBehavior Class
DoubleTake.Communication Namespace


ActivityPropagationBehavior.ApplyDispatchBehavior Method (ServiceDescription, ServiceHostBase)

ActivityPropagationBehaviorApplyDispatchBehavior Method (ServiceDescription, ServiceHostBase)

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public void ApplyDispatchBehavior(
    ServiceDescription serviceDescription,
    ServiceHostBase serviceHostBase
)
Public Sub ApplyDispatchBehavior (
    serviceDescription As ServiceDescription,
    serviceHostBase As ServiceHostBase
)
public:
virtual void ApplyDispatchBehavior(
    ServiceDescription^ serviceDescription,
    ServiceHostBase^ serviceHostBase
) sealed
function ApplyDispatchBehavior(serviceDescription, serviceHostBase);

Parameters

serviceDescription
Type: System.ServiceModel.DescriptionServiceDescription
serviceHostBase
Type: System.ServiceModelServiceHostBase

Implements

IServiceBehaviorApplyDispatchBehavior(ServiceDescription, ServiceHostBase)
See Also

Reference

ActivityPropagationBehavior Class
ApplyDispatchBehavior Overload
DoubleTake.Communication Namespace


ActivityPropagationBehavior.ApplyDispatchBehavior Method (ServiceEndpoint, EndpointDispatcher)

ActivityPropagationBehaviorApplyDispatchBehavior Method (ServiceEndpoint, EndpointDispatcher)

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public void ApplyDispatchBehavior(
    ServiceEndpoint endpoint,
    EndpointDispatcher endpointDispatcher
)
Public Sub ApplyDispatchBehavior (
    endpoint As ServiceEndpoint,
    endpointDispatcher As EndpointDispatcher
)
public:
virtual void ApplyDispatchBehavior(
    ServiceEndpoint^ endpoint,
    EndpointDispatcher^ endpointDispatcher
) sealed
function ApplyDispatchBehavior(endpoint, endpointDispatcher);

Parameters

endpoint
Type: System.ServiceModel.DescriptionServiceEndpoint
endpointDispatcher
Type: System.ServiceModel.DispatcherEndpointDispatcher

Implements

IEndpointBehaviorApplyDispatchBehavior(ServiceEndpoint, EndpointDispatcher)
See Also

Reference

ActivityPropagationBehavior Class
ApplyDispatchBehavior Overload
DoubleTake.Communication Namespace


ActivityPropagationBehavior.Validate Method

ActivityPropagationBehaviorValidate Method
Overload List
 | Name | Description
Public method | Validate(ServiceEndpoint) |
Public method | Validate(ServiceDescription, ServiceHostBase) |
Top
See Also

Reference

ActivityPropagationBehavior Class
DoubleTake.Communication Namespace


ActivityPropagationBehavior.Validate Method (ServiceEndpoint)

ActivityPropagationBehaviorValidate Method (ServiceEndpoint)

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public void Validate(
    ServiceEndpoint endpoint
)
Public Sub Validate (
    endpoint As ServiceEndpoint
)
public:
virtual void Validate(
    ServiceEndpoint^ endpoint
) sealed
function Validate(endpoint);

Parameters

endpoint
Type: System.ServiceModel.DescriptionServiceEndpoint

Implements

IEndpointBehaviorValidate(ServiceEndpoint)
See Also

Reference

ActivityPropagationBehavior Class
Validate Overload
DoubleTake.Communication Namespace


ActivityPropagationBehavior.Validate Method (ServiceDescription, ServiceHostBase)

ActivityPropagationBehaviorValidate Method (ServiceDescription, ServiceHostBase)

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public void Validate(
    ServiceDescription serviceDescription,
    ServiceHostBase serviceHostBase
)
Public Sub Validate (
    serviceDescription As ServiceDescription,
    serviceHostBase As ServiceHostBase
)
public:
virtual void Validate(
    ServiceDescription^ serviceDescription,
    ServiceHostBase^ serviceHostBase
) sealed
function Validate(serviceDescription, serviceHostBase);

Parameters

serviceDescription
Type: System.ServiceModel.DescriptionServiceDescription
serviceHostBase
Type: System.ServiceModelServiceHostBase

Implements

IServiceBehaviorValidate(ServiceDescription, ServiceHostBase)
See Also

Reference

ActivityPropagationBehavior Class
Validate Overload
DoubleTake.Communication Namespace


ActivityPropagationInspector Class

ActivityPropagationInspector Class
Inheritance Hierarchy
SystemObject
DoubleTake.CommunicationActivityPropagationInspector

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class ActivityPropagationInspector : IClientMessageInspector,
    IDispatchMessageInspector
Public Class ActivityPropagationInspector
    Implements IClientMessageInspector, IDispatchMessageInspector
public ref class ActivityPropagationInspector : IClientMessageInspector,
    IDispatchMessageInspector
DoubleTake.Communication.ActivityPropagationInspector = function();

Type.createClass(
    'DoubleTake.Communication.ActivityPropagationInspector',
    null,
    IClientMessageInspector,
    IDispatchMessageInspector);

The ActivityPropagationInspector type exposes the following members.

Constructors
 | Name | Description
Public method | ActivityPropagationInspector | Initializes a new instance of the ActivityPropagationInspector class
Top
Methods
 | Name | Description
Public method | AfterReceiveReply |
Public method | AfterReceiveRequest |
Public method | BeforeSendReply |
Public method | BeforeSendRequest |
Top
See Also

Reference

DoubleTake.Communication Namespace


ActivityPropagationInspector Constructor

ActivityPropagationInspector Constructor
Initializes a new instance of the ActivityPropagationInspector class

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ActivityPropagationInspector()
Public Sub New
public:
ActivityPropagationInspector()
DoubleTake.Communication.ActivityPropagationInspector = function();
See Also

Reference

ActivityPropagationInspector Class
DoubleTake.Communication Namespace


ActivityPropagationInspector Methods

ActivityPropagationInspector Methods

The ActivityPropagationInspector type exposes the following members.

Methods
 | Name | Description
Public method | AfterReceiveReply |
Public method | AfterReceiveRequest |
Public method | BeforeSendReply |
Public method | BeforeSendRequest |
Top
See Also

Reference

ActivityPropagationInspector Class
DoubleTake.Communication Namespace


ActivityPropagationInspector.AfterReceiveReply Method

ActivityPropagationInspectorAfterReceiveReply Method

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public void AfterReceiveReply(
    ref Message reply,
    Object correlationState
)
Public Sub AfterReceiveReply (
    ByRef reply As Message,
    correlationState As Object
)
public:
virtual void AfterReceiveReply(
    Message^% reply,
    Object^ correlationState
) sealed
function AfterReceiveReply(reply, correlationState);

Parameters

reply
Type: System.ServiceModel.ChannelsMessage
correlationState
Type: SystemObject

Implements

IClientMessageInspectorAfterReceiveReply(Message, Object)
See Also

Reference

ActivityPropagationInspector Class
DoubleTake.Communication Namespace


ActivityPropagationInspector.AfterReceiveRequest Method

ActivityPropagationInspectorAfterReceiveRequest Method

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Object AfterReceiveRequest(
    ref Message request,
    IClientChannel channel,
    InstanceContext instanceContext
)
Public Function AfterReceiveRequest (
    ByRef request As Message,
    channel As IClientChannel,
    instanceContext As InstanceContext
) As Object
public:
virtual Object^ AfterReceiveRequest(
    Message^% request,
    IClientChannel^ channel,
    InstanceContext^ instanceContext
) sealed
function AfterReceiveRequest(request, channel, instanceContext);

Parameters

request
Type: System.ServiceModel.ChannelsMessage
channel
Type: System.ServiceModelIClientChannel
instanceContext
Type: System.ServiceModelInstanceContext

Return Value

Type: Object

Implements

IDispatchMessageInspectorAfterReceiveRequest(Message, IClientChannel, InstanceContext)
See Also

Reference

ActivityPropagationInspector Class
DoubleTake.Communication Namespace


ActivityPropagationInspector.BeforeSendReply Method

ActivityPropagationInspectorBeforeSendReply Method

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public void BeforeSendReply(
    ref Message reply,
    Object correlationState
)
Public Sub BeforeSendReply (
    ByRef reply As Message,
    correlationState As Object
)
public:
virtual void BeforeSendReply(
    Message^% reply,
    Object^ correlationState
) sealed
function BeforeSendReply(reply, correlationState);

Parameters

reply
Type: System.ServiceModel.ChannelsMessage
correlationState
Type: SystemObject

Implements

IDispatchMessageInspectorBeforeSendReply(Message, Object)
See Also

Reference

ActivityPropagationInspector Class
DoubleTake.Communication Namespace


ActivityPropagationInspector.BeforeSendRequest Method

ActivityPropagationInspectorBeforeSendRequest Method

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Object BeforeSendRequest(
    ref Message request,
    IClientChannel channel
)
Public Function BeforeSendRequest (
    ByRef request As Message,
    channel As IClientChannel
) As Object
public:
virtual Object^ BeforeSendRequest(
    Message^% request,
    IClientChannel^ channel
) sealed
function BeforeSendRequest(request, channel);

Parameters

request
Type: System.ServiceModel.ChannelsMessage
channel
Type: System.ServiceModelIClientChannel

Return Value

Type: Object

Implements

IClientMessageInspectorBeforeSendRequest(Message, IClientChannel)
See Also

Reference

ActivityPropagationInspector Class
DoubleTake.Communication Namespace


AddressingScheme Enumeration

AddressingScheme Enumeration

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public enum AddressingScheme
Public Enumeration AddressingScheme
public enum class AddressingScheme
DoubleTake.Communication.AddressingScheme = function();
DoubleTake.Communication.AddressingScheme.createEnum('DoubleTake.Communication.AddressingScheme', false);
Members
Member name | Value | Description
Standard | 0 |
Cluster | 1 |
ClusterNode | 2 |
See Also

Reference

DoubleTake.Communication Namespace


BasicHttpEndpointSpecificationBase Class

BasicHttpEndpointSpecificationBase Class
Inheritance Hierarchy
SystemObject
DoubleTake.CommunicationEndpointSpecificationBase
DoubleTake.CommunicationBasicHttpEndpointSpecificationBase
DoubleTake.CommunicationBasicHttpNoSecurityEndpointSpecification

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public abstract class BasicHttpEndpointSpecificationBase : EndpointSpecificationBase
Public MustInherit Class BasicHttpEndpointSpecificationBase
    Inherits EndpointSpecificationBase
public ref class BasicHttpEndpointSpecificationBase abstract : public EndpointSpecificationBase
DoubleTake.Communication.BasicHttpEndpointSpecificationBase = function();

Type.createClass(
    'DoubleTake.Communication.BasicHttpEndpointSpecificationBase',
    DoubleTake.Communication.EndpointSpecificationBase);

The BasicHttpEndpointSpecificationBase type exposes the following members.

Constructors
 | Name | Description
Protected method | BasicHttpEndpointSpecificationBase | Initializes a new instance of the BasicHttpEndpointSpecificationBase class
Top
Properties
 | Name | Description
Public property | Binding | (Inherited from EndpointSpecificationBase.)
Protected property | CommunicationSettings | (Inherited from EndpointSpecificationBase.)
Top
Methods
 | Name | Description
Protected method | Configure |
Protected method | ConfigureBinding | (Overrides EndpointSpecificationBaseConfigureBinding(Binding).)
Protected method | CreateBinding | (Overrides EndpointSpecificationBaseCreateBinding.)
Public method | GetUri | (Inherited from EndpointSpecificationBase.)
Protected method | TryGetRelativeUri | (Inherited from EndpointSpecificationBase.)
Protected method | TryGetUriPort | (Overrides EndpointSpecificationBaseTryGetUriPort(NullableInt32, Int32).)
Top
See Also

Reference

DoubleTake.Communication Namespace


BasicHttpEndpointSpecificationBase Constructor

BasicHttpEndpointSpecificationBase Constructor
Initializes a new instance of the BasicHttpEndpointSpecificationBase class

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
protected BasicHttpEndpointSpecificationBase(
    ICommunicationSettings communicationSettings
)
Protected Sub New (
    communicationSettings As ICommunicationSettings
)
protected:
BasicHttpEndpointSpecificationBase(
    ICommunicationSettings^ communicationSettings
)
DoubleTake.Communication.BasicHttpEndpointSpecificationBase = function(communicationSettings);

Parameters

communicationSettings
Type: DoubleTake.CommunicationICommunicationSettings
See Also

Reference

BasicHttpEndpointSpecificationBase Class
DoubleTake.Communication Namespace


BasicHttpEndpointSpecificationBase Properties

BasicHttpEndpointSpecificationBase Properties

The BasicHttpEndpointSpecificationBase type exposes the following members.

Properties
 | Name | Description
Public property | Binding | (Inherited from EndpointSpecificationBase.)
Protected property | CommunicationSettings | (Inherited from EndpointSpecificationBase.)
Top
See Also

Reference

BasicHttpEndpointSpecificationBase Class
DoubleTake.Communication Namespace


BasicHttpEndpointSpecificationBase Methods

BasicHttpEndpointSpecificationBase Methods

The BasicHttpEndpointSpecificationBase type exposes the following members.

Methods
 | Name | Description
Protected method | Configure |
Protected method | ConfigureBinding | (Overrides EndpointSpecificationBaseConfigureBinding(Binding).)
Protected method | CreateBinding | (Overrides EndpointSpecificationBaseCreateBinding.)
Public method | GetUri | (Inherited from EndpointSpecificationBase.)
Protected method | TryGetRelativeUri | (Inherited from EndpointSpecificationBase.)
Protected method | TryGetUriPort | (Overrides EndpointSpecificationBaseTryGetUriPort(NullableInt32, Int32).)
Top
See Also

Reference

BasicHttpEndpointSpecificationBase Class
DoubleTake.Communication Namespace


BasicHttpEndpointSpecificationBase.Configure Method

BasicHttpEndpointSpecificationBaseConfigure Method

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
protected abstract Binding Configure(
    BasicHttpBinding binding
)
Protected MustOverride Function Configure (
    binding As BasicHttpBinding
) As Binding
protected:
virtual Binding^ Configure(
    BasicHttpBinding^ binding
) abstract
function Configure(binding);

Parameters

binding
Type: System.ServiceModelBasicHttpBinding

Return Value

Type: Binding
See Also

Reference

BasicHttpEndpointSpecificationBase Class
DoubleTake.Communication Namespace


BasicHttpEndpointSpecificationBase.ConfigureBinding Method

BasicHttpEndpointSpecificationBaseConfigureBinding Method

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
protected override sealed Binding ConfigureBinding(
    Binding binding
)
Protected Overrides NotOverridable Function ConfigureBinding (
    binding As Binding
) As Binding
protected:
virtual Binding^ ConfigureBinding(
    Binding^ binding
) override sealed
function ConfigureBinding(binding);

Parameters

binding
Type: System.ServiceModel.ChannelsBinding

Return Value

Type: Binding
See Also

Reference

BasicHttpEndpointSpecificationBase Class
DoubleTake.Communication Namespace


BasicHttpEndpointSpecificationBase.CreateBinding Method

BasicHttpEndpointSpecificationBaseCreateBinding Method

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
protected override sealed Binding CreateBinding()
Protected Overrides NotOverridable Function CreateBinding As Binding
protected:
virtual Binding^ CreateBinding() override sealed
function CreateBinding();

Return Value

Type: Binding
See Also

Reference

BasicHttpEndpointSpecificationBase Class
DoubleTake.Communication Namespace


BasicHttpEndpointSpecificationBase.TryGetUriPort Method

BasicHttpEndpointSpecificationBaseTryGetUriPort Method

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
protected override bool TryGetUriPort(
    Nullable<int> port,
    out int uriPort
)
Protected Overrides Function TryGetUriPort (
    port As Nullable(Of Integer),
    <OutAttribute> ByRef uriPort As Integer
) As Boolean
protected:
virtual bool TryGetUriPort(
    Nullable<int> port,
    [OutAttribute] int% uriPort
) override
function TryGetUriPort(port, uriPort);

Parameters

port
Type: SystemNullable Int32
uriPort
Type: SystemInt32

Return Value

Type: Boolean
See Also

Reference

BasicHttpEndpointSpecificationBase Class
DoubleTake.Communication Namespace


BasicHttpNoSecurityEndpointSpecification Class

BasicHttpNoSecurityEndpointSpecification Class
Inheritance Hierarchy
SystemObject
DoubleTake.CommunicationEndpointSpecificationBase
DoubleTake.CommunicationBasicHttpEndpointSpecificationBase
DoubleTake.CommunicationBasicHttpNoSecurityEndpointSpecification
DoubleTake.CommunicationLinuxServiceInteropEndpointSpecification

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class BasicHttpNoSecurityEndpointSpecification : BasicHttpEndpointSpecificationBase
Public Class BasicHttpNoSecurityEndpointSpecification
    Inherits BasicHttpEndpointSpecificationBase
public ref class BasicHttpNoSecurityEndpointSpecification : public BasicHttpEndpointSpecificationBase
DoubleTake.Communication.BasicHttpNoSecurityEndpointSpecification = function();

Type.createClass(
    'DoubleTake.Communication.BasicHttpNoSecurityEndpointSpecification',
    DoubleTake.Communication.BasicHttpEndpointSpecificationBase);

The BasicHttpNoSecurityEndpointSpecification type exposes the following members.

Constructors
 | Name | Description
Public method | BasicHttpNoSecurityEndpointSpecification | Initializes a new instance of the BasicHttpNoSecurityEndpointSpecification class
Top
Properties
 | Name | Description
Public property | Binding | (Inherited from EndpointSpecificationBase.)
Protected property | CommunicationSettings | (Inherited from EndpointSpecificationBase.)
Top
Methods
 | Name | Description
Protected method | Configure | (Overrides BasicHttpEndpointSpecificationBaseConfigure(BasicHttpBinding).)
Protected method | ConfigureBinding | (Inherited from BasicHttpEndpointSpecificationBase.)
Protected method | CreateBinding | (Inherited from BasicHttpEndpointSpecificationBase.)
Public method | GetUri | (Inherited from EndpointSpecificationBase.)
Protected method | TryGetRelativeUri | (Overrides EndpointSpecificationBaseTryGetRelativeUri(Uri, Uri).)
Protected method | TryGetUriPort | (Inherited from BasicHttpEndpointSpecificationBase.)
Top
See Also

Reference

DoubleTake.Communication Namespace


BasicHttpNoSecurityEndpointSpecification Constructor

BasicHttpNoSecurityEndpointSpecification Constructor
Initializes a new instance of the BasicHttpNoSecurityEndpointSpecification class

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public BasicHttpNoSecurityEndpointSpecification(
    ICommunicationSettings communicationSettings
)
Public Sub New (
    communicationSettings As ICommunicationSettings
)
public:
BasicHttpNoSecurityEndpointSpecification(
    ICommunicationSettings^ communicationSettings
)
DoubleTake.Communication.BasicHttpNoSecurityEndpointSpecification = function(communicationSettings);

Parameters

communicationSettings
Type: DoubleTake.CommunicationICommunicationSettings
See Also

Reference

BasicHttpNoSecurityEndpointSpecification Class
DoubleTake.Communication Namespace


BasicHttpNoSecurityEndpointSpecification Properties

BasicHttpNoSecurityEndpointSpecification Properties

The BasicHttpNoSecurityEndpointSpecification type exposes the following members.

Properties
 | Name | Description
Public property | Binding | (Inherited from EndpointSpecificationBase.)
Protected property | CommunicationSettings | (Inherited from EndpointSpecificationBase.)
Top
See Also

Reference

BasicHttpNoSecurityEndpointSpecification Class
DoubleTake.Communication Namespace


BasicHttpNoSecurityEndpointSpecification Methods

BasicHttpNoSecurityEndpointSpecification Methods

The BasicHttpNoSecurityEndpointSpecification type exposes the following members.

Methods
 | Name | Description
Protected method | Configure | (Overrides BasicHttpEndpointSpecificationBaseConfigure(BasicHttpBinding).)
Protected method | ConfigureBinding | (Inherited from BasicHttpEndpointSpecificationBase.)
Protected method | CreateBinding | (Inherited from BasicHttpEndpointSpecificationBase.)
Public method | GetUri | (Inherited from EndpointSpecificationBase.)
Protected method | TryGetRelativeUri | (Overrides EndpointSpecificationBaseTryGetRelativeUri(Uri, Uri).)
Protected method | TryGetUriPort | (Inherited from BasicHttpEndpointSpecificationBase.)
Top
See Also

Reference

BasicHttpNoSecurityEndpointSpecification Class
DoubleTake.Communication Namespace


BasicHttpNoSecurityEndpointSpecification.Configure Method

BasicHttpNoSecurityEndpointSpecificationConfigure Method

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
protected override Binding Configure(
    BasicHttpBinding binding
)
Protected Overrides Function Configure (
    binding As BasicHttpBinding
) As Binding
protected:
virtual Binding^ Configure(
    BasicHttpBinding^ binding
) override
function Configure(binding);

Parameters

binding
Type: System.ServiceModelBasicHttpBinding

Return Value

Type: Binding
See Also

Reference

BasicHttpNoSecurityEndpointSpecification Class
DoubleTake.Communication Namespace


BasicHttpNoSecurityEndpointSpecification.TryGetRelativeUri Method

BasicHttpNoSecurityEndpointSpecificationTryGetRelativeUri Method

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
protected override bool TryGetRelativeUri(
    Uri provided,
    out Uri relativeUri
)
Protected Overrides Function TryGetRelativeUri (
    provided As Uri,
    <OutAttribute> ByRef relativeUri As Uri
) As Boolean
protected:
virtual bool TryGetRelativeUri(
    Uri^ provided,
    [OutAttribute] Uri^% relativeUri
) override
function TryGetRelativeUri(provided, relativeUri);

Parameters

provided
Type: SystemUri
relativeUri
Type: SystemUri

Return Value

Type: Boolean
See Also

Reference

BasicHttpNoSecurityEndpointSpecification Class
DoubleTake.Communication Namespace


CommunicationAspects Class

CommunicationAspects Class
Inheritance Hierarchy
SystemObject
DoubleTake.CommunicationCommunicationAspects

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public static class CommunicationAspects
Public NotInheritable Class CommunicationAspects
public ref class CommunicationAspects abstract sealed
DoubleTake.Communication.CommunicationAspects = function();

Type.createClass(
    'DoubleTake.Communication.CommunicationAspects');

The CommunicationAspects type exposes the following members.

Fields
Name | Description
GetCommunicationSettings |
Top
See Also

Reference

DoubleTake.Communication Namespace


CommunicationAspects Fields

CommunicationAspects Fields

The CommunicationAspects type exposes the following members.

Fields
Name | Description
GetCommunicationSettings |
Top
See Also

Reference

CommunicationAspects Class
DoubleTake.Communication Namespace


CommunicationAspects.GetCommunicationSettings Field

CommunicationAspectsGetCommunicationSettings Field

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public static Func<ICommunicationSettings> GetCommunicationSettings
Public Shared GetCommunicationSettings As Func(Of ICommunicationSettings)
public:
static Func<ICommunicationSettings^>^ GetCommunicationSettings
var DoubleTake.Communication.CommunicationAspects.GetCommunicationSettings

Field Value

Type: Func ICommunicationSettings
See Also

Reference

CommunicationAspects Class
DoubleTake.Communication Namespace


CommunicationSettings Class

CommunicationSettings Class
Inheritance Hierarchy
SystemObject
DoubleTake.CommunicationCommunicationSettings

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class CommunicationSettings : ICommunicationSettings
Public Class CommunicationSettings
    Implements ICommunicationSettings
public ref class CommunicationSettings : ICommunicationSettings
DoubleTake.Communication.CommunicationSettings = function();

Type.createClass(
    'DoubleTake.Communication.CommunicationSettings',
    null,
    DoubleTake.Communication.ICommunicationSettings);

The CommunicationSettings type exposes the following members.

Constructors
 | Name | Description
Public method | CommunicationSettings | Initializes a new instance of the CommunicationSettings class
Top
Properties
 | Name | Description
Public property | BypassProxyForLocal |
Public property | CloseTimeout |
Public property | HttpPort |
Public property | InterserviceDefaultPort |
Public property | InterserviceRepollDelay |
Public property | IntraClusterActiveChannelLimit |
Public property | IntraClusterConnectTimeout |
Public property | IntraClusterDataCacheTtl |
Public property | IntraClusterDnsRecordCap |
Public property | IntraClusterNameDataCacheTtl |
Public property | IntraClusterReconnectDelay |
Public property | LinuxServiceInteropPort |
Public property | MaxClockSkew |
Public property | MaxReceivedMessageSize |
Public property | OpenTimeout |
Public property | ReaderQuotas |
Public property | SendTimeout |
Public property | UseDefaultWebProxy |
Top
Methods
Name | Description
GetGenericSettingT |
GetSettingValueT |
ParseSetting |
Top
Fields
Name | Description
RegistryPath |
RegistrySubkeyPath |
Top
See Also

Reference

DoubleTake.Communication Namespace


CommunicationSettings Constructor

CommunicationSettings Constructor
Initializes a new instance of the CommunicationSettings class

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public CommunicationSettings()
Public Sub New
public:
CommunicationSettings()
DoubleTake.Communication.CommunicationSettings = function();
See Also

Reference

CommunicationSettings Class
DoubleTake.Communication Namespace


CommunicationSettings Properties

CommunicationSettings Properties

The CommunicationSettings type exposes the following members.

Properties
 | Name | Description
Public property | BypassProxyForLocal |
Public property | CloseTimeout |
Public property | HttpPort |
Public property | InterserviceDefaultPort |
Public property | InterserviceRepollDelay |
Public property | IntraClusterActiveChannelLimit |
Public property | IntraClusterConnectTimeout |
Public property | IntraClusterDataCacheTtl |
Public property | IntraClusterDnsRecordCap |
Public property | IntraClusterNameDataCacheTtl |
Public property | IntraClusterReconnectDelay |
Public property | LinuxServiceInteropPort |
Public property | MaxClockSkew |
Public property | MaxReceivedMessageSize |
Public property | OpenTimeout |
Public property | ReaderQuotas |
Public property | SendTimeout |
Public property | UseDefaultWebProxy |
Top
See Also

Reference

CommunicationSettings Class
DoubleTake.Communication Namespace


CommunicationSettings.BypassProxyForLocal Property

CommunicationSettingsBypassProxyForLocal Property

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool BypassProxyForLocal { get; }
Public ReadOnly Property BypassProxyForLocal As Boolean
    Get
public:
virtual property bool BypassProxyForLocal {
    bool get () sealed;
}
function get_BypassProxyForLocal();

Property Value

Type: Boolean

Implements

ICommunicationSettingsBypassProxyForLocal
See Also

Reference

CommunicationSettings Class
DoubleTake.Communication Namespace


CommunicationSettings.CloseTimeout Property

CommunicationSettingsCloseTimeout Property

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public TimeSpan CloseTimeout { get; }
Public ReadOnly Property CloseTimeout As TimeSpan
    Get
public:
virtual property TimeSpan CloseTimeout {
    TimeSpan get () sealed;
}
function get_CloseTimeout();

Property Value

Type: TimeSpan

Implements

ICommunicationSettingsCloseTimeout
See Also

Reference

CommunicationSettings Class
DoubleTake.Communication Namespace


CommunicationSettings.HttpPort Property

CommunicationSettingsHttpPort Property

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int HttpPort { get; }
Public ReadOnly Property HttpPort As Integer
    Get
public:
virtual property int HttpPort {
    int get () sealed;
}
function get_HttpPort();

Property Value

Type: Int32

Implements

ICommunicationSettingsHttpPort
See Also

Reference

CommunicationSettings Class
DoubleTake.Communication Namespace


CommunicationSettings.InterserviceDefaultPort Property

CommunicationSettingsInterserviceDefaultPort Property

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int InterserviceDefaultPort { get; }
Public ReadOnly Property InterserviceDefaultPort As Integer
    Get
public:
virtual property int InterserviceDefaultPort {
    int get () sealed;
}
function get_InterserviceDefaultPort();

Property Value

Type: Int32

Implements

ICommunicationSettingsInterserviceDefaultPort
See Also

Reference

CommunicationSettings Class
DoubleTake.Communication Namespace


CommunicationSettings.InterserviceRepollDelay Property

CommunicationSettingsInterserviceRepollDelay Property

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public TimeSpan InterserviceRepollDelay { get; }
Public ReadOnly Property InterserviceRepollDelay As TimeSpan
    Get
public:
virtual property TimeSpan InterserviceRepollDelay {
    TimeSpan get () sealed;
}
function get_InterserviceRepollDelay();

Property Value

Type: TimeSpan

Implements

ICommunicationSettingsInterserviceRepollDelay
See Also

Reference

CommunicationSettings Class
DoubleTake.Communication Namespace


CommunicationSettings.IntraClusterActiveChannelLimit Property

CommunicationSettingsIntraClusterActiveChannelLimit Property

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int IntraClusterActiveChannelLimit { get; }
Public ReadOnly Property IntraClusterActiveChannelLimit As Integer
    Get
public:
virtual property int IntraClusterActiveChannelLimit {
    int get () sealed;
}
function get_IntraClusterActiveChannelLimit();

Property Value

Type: Int32

Implements

ICommunicationSettingsIntraClusterActiveChannelLimit
See Also

Reference

CommunicationSettings Class
DoubleTake.Communication Namespace


CommunicationSettings.IntraClusterConnectTimeout Property

CommunicationSettingsIntraClusterConnectTimeout Property

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public TimeSpan IntraClusterConnectTimeout { get; }
Public ReadOnly Property IntraClusterConnectTimeout As TimeSpan
    Get
public:
virtual property TimeSpan IntraClusterConnectTimeout {
    TimeSpan get () sealed;
}
function get_IntraClusterConnectTimeout();

Property Value

Type: TimeSpan

Implements

ICommunicationSettingsIntraClusterConnectTimeout
See Also

Reference

CommunicationSettings Class
DoubleTake.Communication Namespace


CommunicationSettings.IntraClusterDataCacheTtl Property

CommunicationSettingsIntraClusterDataCacheTtl Property

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public TimeSpan IntraClusterDataCacheTtl { get; }
Public ReadOnly Property IntraClusterDataCacheTtl As TimeSpan
    Get
public:
virtual property TimeSpan IntraClusterDataCacheTtl {
    TimeSpan get () sealed;
}
function get_IntraClusterDataCacheTtl();

Property Value

Type: TimeSpan

Implements

ICommunicationSettingsIntraClusterDataCacheTtl
See Also

Reference

CommunicationSettings Class
DoubleTake.Communication Namespace


CommunicationSettings.IntraClusterDnsRecordCap Property

CommunicationSettingsIntraClusterDnsRecordCap Property

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int IntraClusterDnsRecordCap { get; }
Public ReadOnly Property IntraClusterDnsRecordCap As Integer
    Get
public:
virtual property int IntraClusterDnsRecordCap {
    int get () sealed;
}
function get_IntraClusterDnsRecordCap();

Property Value

Type: Int32

Implements

ICommunicationSettingsIntraClusterDnsRecordCap
See Also

Reference

CommunicationSettings Class
DoubleTake.Communication Namespace


CommunicationSettings.IntraClusterNameDataCacheTtl Property

CommunicationSettingsIntraClusterNameDataCacheTtl Property

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public TimeSpan IntraClusterNameDataCacheTtl { get; }
Public ReadOnly Property IntraClusterNameDataCacheTtl As TimeSpan
    Get
public:
virtual property TimeSpan IntraClusterNameDataCacheTtl {
    TimeSpan get () sealed;
}
function get_IntraClusterNameDataCacheTtl();

Property Value

Type: TimeSpan

Implements

ICommunicationSettingsIntraClusterNameDataCacheTtl
See Also

Reference

CommunicationSettings Class
DoubleTake.Communication Namespace


CommunicationSettings.IntraClusterReconnectDelay Property

CommunicationSettingsIntraClusterReconnectDelay Property

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public TimeSpan IntraClusterReconnectDelay { get; }
Public ReadOnly Property IntraClusterReconnectDelay As TimeSpan
    Get
public:
virtual property TimeSpan IntraClusterReconnectDelay {
    TimeSpan get () sealed;
}
function get_IntraClusterReconnectDelay();

Property Value

Type: TimeSpan

Implements

ICommunicationSettingsIntraClusterReconnectDelay
See Also

Reference

CommunicationSettings Class
DoubleTake.Communication Namespace


CommunicationSettings.LinuxServiceInteropPort Property

CommunicationSettingsLinuxServiceInteropPort Property

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int LinuxServiceInteropPort { get; }
Public ReadOnly Property LinuxServiceInteropPort As Integer
    Get
public:
virtual property int LinuxServiceInteropPort {
    int get () sealed;
}
function get_LinuxServiceInteropPort();

Property Value

Type: Int32

Implements

ICommunicationSettingsLinuxServiceInteropPort
See Also

Reference

CommunicationSettings Class
DoubleTake.Communication Namespace


CommunicationSettings.MaxClockSkew Property

CommunicationSettingsMaxClockSkew Property

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public TimeSpan MaxClockSkew { get; }
Public ReadOnly Property MaxClockSkew As TimeSpan
    Get
public:
virtual property TimeSpan MaxClockSkew {
    TimeSpan get () sealed;
}
function get_MaxClockSkew();

Property Value

Type: TimeSpan

Implements

ICommunicationSettingsMaxClockSkew
See Also

Reference

CommunicationSettings Class
DoubleTake.Communication Namespace


CommunicationSettings.MaxReceivedMessageSize Property

CommunicationSettingsMaxReceivedMessageSize Property

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public long MaxReceivedMessageSize { get; }
Public ReadOnly Property MaxReceivedMessageSize As Long
    Get
public:
virtual property long long MaxReceivedMessageSize {
    long long get () sealed;
}
function get_MaxReceivedMessageSize();

Property Value

Type: Int64

Implements

ICommunicationSettingsMaxReceivedMessageSize
See Also

Reference

CommunicationSettings Class
DoubleTake.Communication Namespace


CommunicationSettings.OpenTimeout Property

CommunicationSettingsOpenTimeout Property

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public TimeSpan OpenTimeout { get; }
Public ReadOnly Property OpenTimeout As TimeSpan
    Get
public:
virtual property TimeSpan OpenTimeout {
    TimeSpan get () sealed;
}
function get_OpenTimeout();

Property Value

Type: TimeSpan

Implements

ICommunicationSettingsOpenTimeout
See Also

Reference

CommunicationSettings Class
DoubleTake.Communication Namespace


CommunicationSettings.ReaderQuotas Property

CommunicationSettingsReaderQuotas Property

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public XmlDictionaryReaderQuotas ReaderQuotas { get; }
Public ReadOnly Property ReaderQuotas As XmlDictionaryReaderQuotas
    Get
public:
virtual property XmlDictionaryReaderQuotas^ ReaderQuotas {
    XmlDictionaryReaderQuotas^ get () sealed;
}
function get_ReaderQuotas();

Property Value

Type: XmlDictionaryReaderQuotas

Implements

ICommunicationSettingsReaderQuotas
See Also

Reference

CommunicationSettings Class
DoubleTake.Communication Namespace


CommunicationSettings.SendTimeout Property

CommunicationSettingsSendTimeout Property

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public TimeSpan SendTimeout { get; }
Public ReadOnly Property SendTimeout As TimeSpan
    Get
public:
virtual property TimeSpan SendTimeout {
    TimeSpan get () sealed;
}
function get_SendTimeout();

Property Value

Type: TimeSpan

Implements

ICommunicationSettingsSendTimeout
See Also

Reference

CommunicationSettings Class
DoubleTake.Communication Namespace


CommunicationSettings.UseDefaultWebProxy Property

CommunicationSettingsUseDefaultWebProxy Property

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool UseDefaultWebProxy { get; }
Public ReadOnly Property UseDefaultWebProxy As Boolean
    Get
public:
virtual property bool UseDefaultWebProxy {
    bool get () sealed;
}
function get_UseDefaultWebProxy();

Property Value

Type: Boolean

Implements

ICommunicationSettingsUseDefaultWebProxy
See Also

Reference

CommunicationSettings Class
DoubleTake.Communication Namespace


CommunicationSettings Methods

CommunicationSettings Methods

The CommunicationSettings type exposes the following members.

Methods
Name | Description
GetGenericSettingT |
GetSettingValueT |
ParseSetting |
Top
See Also

Reference

CommunicationSettings Class
DoubleTake.Communication Namespace


CommunicationSettings.GetGenericSetting(T) Method

CommunicationSettingsGetGenericSettingT Method

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public static T GetGenericSetting<T>(
    ref Nullable<T> setting,
    string name,
    T defaultValue
)
where T : struct, new()

Public Shared Function GetGenericSetting(Of T As {Structure, New}) (
    ByRef setting As Nullable(Of T),
    name As String,
    defaultValue As T
) As T
public:
generic<typename T>
where T : value class, gcnew()
static T GetGenericSetting(
    Nullable<T>% setting,
    String^ name,
    T defaultValue
)
JavaScript does not support generic types or methods.

Parameters

setting
Type: SystemNullable T
name
Type: SystemString
defaultValue
Type: T

Type Parameters

T

Return Value

Type: T
See Also

Reference

CommunicationSettings Class
DoubleTake.Communication Namespace


CommunicationSettings.GetSettingValue(T) Method

CommunicationSettingsGetSettingValueT Method

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public static T GetSettingValue<T>(
    string name,
    T defaultValue
)

Public Shared Function GetSettingValue(Of T) (
    name As String,
    defaultValue As T
) As T
public:
generic<typename T>
static T GetSettingValue(
    String^ name,
    T defaultValue
)
JavaScript does not support generic types or methods.

Parameters

name
Type: SystemString
defaultValue
Type: T

Type Parameters

T

Return Value

Type: T
See Also

Reference

CommunicationSettings Class
DoubleTake.Communication Namespace


CommunicationSettings.ParseSetting Method

CommunicationSettingsParseSetting Method

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public static Object ParseSetting(
    Type type,
    string value
)
Public Shared Function ParseSetting (
    type As Type,
    value As String
) As Object
public:
static Object^ ParseSetting(
    Type^ type,
    String^ value
)
DoubleTake.Communication.CommunicationSettings.ParseSetting = function(type, value);

Parameters

type
Type: SystemType
value
Type: SystemString

Return Value

Type: Object
See Also

Reference

CommunicationSettings Class
DoubleTake.Communication Namespace


CommunicationSettings Fields

CommunicationSettings Fields

The CommunicationSettings type exposes the following members.

Fields
Name | Description
RegistryPath |
RegistrySubkeyPath |
Top
See Also

Reference

CommunicationSettings Class
DoubleTake.Communication Namespace


CommunicationSettings.RegistryPath Field

CommunicationSettingsRegistryPath Field

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string RegistryPath
Public Const RegistryPath As String
public:
literal String^ RegistryPath
var DoubleTake.Communication.CommunicationSettings.RegistryPath

Field Value

Type: String
See Also

Reference

CommunicationSettings Class
DoubleTake.Communication Namespace


CommunicationSettings.RegistrySubkeyPath Field

CommunicationSettingsRegistrySubkeyPath Field

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string RegistrySubkeyPath
Public Const RegistrySubkeyPath As String
public:
literal String^ RegistrySubkeyPath
var DoubleTake.Communication.CommunicationSettings.RegistrySubkeyPath

Field Value

Type: String
See Also

Reference

CommunicationSettings Class
DoubleTake.Communication Namespace


DefaultEndpointSpecification Class

DefaultEndpointSpecification Class
Inheritance Hierarchy
SystemObject
DoubleTake.CommunicationEndpointSpecificationBase
DoubleTake.CommunicationWSHttpEndpointSpecificationBase
DoubleTake.CommunicationDefaultEndpointSpecification

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class DefaultEndpointSpecification : WSHttpEndpointSpecificationBase
Public Class DefaultEndpointSpecification
    Inherits WSHttpEndpointSpecificationBase
public ref class DefaultEndpointSpecification : public WSHttpEndpointSpecificationBase
DoubleTake.Communication.DefaultEndpointSpecification = function();

Type.createClass(
    'DoubleTake.Communication.DefaultEndpointSpecification',
    DoubleTake.Communication.WSHttpEndpointSpecificationBase);

The DefaultEndpointSpecification type exposes the following members.

Constructors
 | Name | Description
Public method | DefaultEndpointSpecification | Initializes a new instance of the DefaultEndpointSpecification class
Top
Properties
 | Name | Description
Public property | Binding | (Inherited from EndpointSpecificationBase.)
Protected property | CommunicationSettings | (Inherited from EndpointSpecificationBase.)
Top
Methods
 | Name | Description
Protected method | Configure | (Overrides WSHttpEndpointSpecificationBaseConfigure(WSHttpBinding).)
Protected method | ConfigureBinding | (Inherited from WSHttpEndpointSpecificationBase.)
Protected method | CreateBinding | (Inherited from WSHttpEndpointSpecificationBase.)
Public method | GetUri | (Inherited from EndpointSpecificationBase.)
Protected method | TryGetRelativeUri | (Inherited from EndpointSpecificationBase.)
Protected method | TryGetUriPort | (Inherited from WSHttpEndpointSpecificationBase.)
Top
See Also

Reference

DoubleTake.Communication Namespace


DefaultEndpointSpecification Constructor

DefaultEndpointSpecification Constructor
Initializes a new instance of the DefaultEndpointSpecification class

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public DefaultEndpointSpecification(
    ICommunicationSettings communicationSettings
)
Public Sub New (
    communicationSettings As ICommunicationSettings
)
public:
DefaultEndpointSpecification(
    ICommunicationSettings^ communicationSettings
)
DoubleTake.Communication.DefaultEndpointSpecification = function(communicationSettings);

Parameters

communicationSettings
Type: DoubleTake.CommunicationICommunicationSettings
See Also

Reference

DefaultEndpointSpecification Class
DoubleTake.Communication Namespace


DefaultEndpointSpecification Properties

DefaultEndpointSpecification Properties

The DefaultEndpointSpecification type exposes the following members.

Properties
 | Name | Description
Public property | Binding | (Inherited from EndpointSpecificationBase.)
Protected property | CommunicationSettings | (Inherited from EndpointSpecificationBase.)
Top
See Also

Reference

DefaultEndpointSpecification Class
DoubleTake.Communication Namespace


DefaultEndpointSpecification Methods

DefaultEndpointSpecification Methods

The DefaultEndpointSpecification type exposes the following members.

Methods
 | Name | Description
Protected method | Configure | (Overrides WSHttpEndpointSpecificationBaseConfigure(WSHttpBinding).)
Protected method | ConfigureBinding | (Inherited from WSHttpEndpointSpecificationBase.)
Protected method | CreateBinding | (Inherited from WSHttpEndpointSpecificationBase.)
Public method | GetUri | (Inherited from EndpointSpecificationBase.)
Protected method | TryGetRelativeUri | (Inherited from EndpointSpecificationBase.)
Protected method | TryGetUriPort | (Inherited from WSHttpEndpointSpecificationBase.)
Top
See Also

Reference

DefaultEndpointSpecification Class
DoubleTake.Communication Namespace


DefaultEndpointSpecification.Configure Method

DefaultEndpointSpecificationConfigure Method

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
protected override Binding Configure(
    WSHttpBinding binding
)
Protected Overrides Function Configure (
    binding As WSHttpBinding
) As Binding
protected:
virtual Binding^ Configure(
    WSHttpBinding^ binding
) override
function Configure(binding);

Parameters

binding
Type: System.ServiceModelWSHttpBinding

Return Value

Type: Binding
See Also

Reference

DefaultEndpointSpecification Class
DoubleTake.Communication Namespace


EndpointSpecificationBase Class

EndpointSpecificationBase Class
Inheritance Hierarchy
SystemObject
DoubleTake.CommunicationEndpointSpecificationBase
DoubleTake.CommunicationBasicHttpEndpointSpecificationBase
DoubleTake.CommunicationWSHttpEndpointSpecificationBase

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public abstract class EndpointSpecificationBase : IEndpointSpecification
Public MustInherit Class EndpointSpecificationBase
    Implements IEndpointSpecification
public ref class EndpointSpecificationBase abstract : IEndpointSpecification
DoubleTake.Communication.EndpointSpecificationBase = function();

Type.createClass(
    'DoubleTake.Communication.EndpointSpecificationBase',
    null,
    DoubleTake.Communication.IEndpointSpecification);

The EndpointSpecificationBase type exposes the following members.

Constructors
 | Name | Description
Protected method | EndpointSpecificationBase | Initializes a new instance of the EndpointSpecificationBase class
Top
Properties
 | Name | Description
Public property | Binding |
Protected property | CommunicationSettings |
Top
Methods
 | Name | Description
Protected method | ConfigureBinding |
Protected method | CreateBinding |
Public method | GetUri |
Protected method | TryGetRelativeUri |
Protected method | TryGetUriPort |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetUri(Type, Type) | Overloaded. (Defined by EndpointSpecificationExtensions.)
Public Extension Method | GetUri(Type, String) | Overloaded. (Defined by EndpointSpecificationExtensions.)
Public Extension Method | GetUri(Type, Type, Uri) | Overloaded. (Defined by EndpointSpecificationExtensions.)
Public Extension Method | GetUri(Type, String, NullableInt32) | Overloaded. (Defined by EndpointSpecificationExtensions.)
Public Extension Method | GetUriTContract(String) | Overloaded. (Defined by EndpointSpecificationExtensions.)
Public Extension Method | GetUriTContract(String, NullableInt32) | Overloaded. (Defined by EndpointSpecificationExtensions.)
Top
See Also

Reference

DoubleTake.Communication Namespace


EndpointSpecificationBase Constructor

EndpointSpecificationBase Constructor
Initializes a new instance of the EndpointSpecificationBase class

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
protected EndpointSpecificationBase(
    ICommunicationSettings communicationSettings
)
Protected Sub New (
    communicationSettings As ICommunicationSettings
)
protected:
EndpointSpecificationBase(
    ICommunicationSettings^ communicationSettings
)
DoubleTake.Communication.EndpointSpecificationBase = function(communicationSettings);

Parameters

communicationSettings
Type: DoubleTake.CommunicationICommunicationSettings
See Also

Reference

EndpointSpecificationBase Class
DoubleTake.Communication Namespace


EndpointSpecificationBase Properties

EndpointSpecificationBase Properties

The EndpointSpecificationBase type exposes the following members.

Properties
 | Name | Description
Public property | Binding |
Protected property | CommunicationSettings |
Top
See Also

Reference

EndpointSpecificationBase Class
DoubleTake.Communication Namespace


EndpointSpecificationBase.Binding Property

EndpointSpecificationBaseBinding Property

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Binding Binding { get; }
Public ReadOnly Property Binding As Binding
    Get
public:
virtual property Binding^ Binding {
    Binding^ get () sealed;
}
function get_Binding();

Property Value

Type: Binding

Implements

IEndpointSpecificationBinding
See Also

Reference

EndpointSpecificationBase Class
DoubleTake.Communication Namespace


EndpointSpecificationBase.CommunicationSettings Property

EndpointSpecificationBaseCommunicationSettings Property

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
protected ICommunicationSettings CommunicationSettings { get; }
Protected ReadOnly Property CommunicationSettings As ICommunicationSettings
    Get
protected:
property ICommunicationSettings^ CommunicationSettings {
    ICommunicationSettings^ get ();
}
function get_CommunicationSettings();

Property Value

Type: ICommunicationSettings
See Also

Reference

EndpointSpecificationBase Class
DoubleTake.Communication Namespace


EndpointSpecificationBase Methods

EndpointSpecificationBase Methods

The EndpointSpecificationBase type exposes the following members.

Methods
 | Name | Description
Protected method | ConfigureBinding |
Protected method | CreateBinding |
Public method | GetUri |
Protected method | TryGetRelativeUri |
Protected method | TryGetUriPort |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetUri(Type, Type) | Overloaded. (Defined by EndpointSpecificationExtensions.)
Public Extension Method | GetUri(Type, String) | Overloaded. (Defined by EndpointSpecificationExtensions.)
Public Extension Method | GetUri(Type, Type, Uri) | Overloaded. (Defined by EndpointSpecificationExtensions.)
Public Extension Method | GetUri(Type, String, NullableInt32) | Overloaded. (Defined by EndpointSpecificationExtensions.)
Public Extension Method | GetUriTContract(String) | Overloaded. (Defined by EndpointSpecificationExtensions.)
Public Extension Method | GetUriTContract(String, NullableInt32) | Overloaded. (Defined by EndpointSpecificationExtensions.)
Top
See Also

Reference

EndpointSpecificationBase Class
DoubleTake.Communication Namespace


EndpointSpecificationBase.ConfigureBinding Method

EndpointSpecificationBaseConfigureBinding Method

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
protected virtual Binding ConfigureBinding(
    Binding binding
)
Protected Overridable Function ConfigureBinding (
    binding As Binding
) As Binding
protected:
virtual Binding^ ConfigureBinding(
    Binding^ binding
)
function ConfigureBinding(binding);

Parameters

binding
Type: System.ServiceModel.ChannelsBinding

Return Value

Type: Binding
See Also

Reference

EndpointSpecificationBase Class
DoubleTake.Communication Namespace


EndpointSpecificationBase.CreateBinding Method

EndpointSpecificationBaseCreateBinding Method

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
protected abstract Binding CreateBinding()
Protected MustOverride Function CreateBinding As Binding
protected:
virtual Binding^ CreateBinding() abstract
function CreateBinding();

Return Value

Type: Binding
See Also

Reference

EndpointSpecificationBase Class
DoubleTake.Communication Namespace


EndpointSpecificationBase.GetUri Method

EndpointSpecificationBaseGetUri Method

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Uri GetUri(
    string hostName,
    Nullable<int> port,
    Uri relativeUri
)
Public Function GetUri (
    hostName As String,
    port As Nullable(Of Integer),
    relativeUri As Uri
) As Uri
public:
virtual Uri^ GetUri(
    String^ hostName,
    Nullable<int> port,
    Uri^ relativeUri
) sealed
function GetUri(hostName, port, relativeUri);

Parameters

hostName
Type: SystemString
port
Type: SystemNullable Int32
relativeUri
Type: SystemUri

Return Value

Type: Uri

Implements

IEndpointSpecificationGetUri(String, NullableInt32, Uri)
See Also

Reference

EndpointSpecificationBase Class
DoubleTake.Communication Namespace


EndpointSpecificationBase.TryGetRelativeUri Method

EndpointSpecificationBaseTryGetRelativeUri Method

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
protected virtual bool TryGetRelativeUri(
    Uri provided,
    out Uri relativeUri
)
Protected Overridable Function TryGetRelativeUri (
    provided As Uri,
    <OutAttribute> ByRef relativeUri As Uri
) As Boolean
protected:
virtual bool TryGetRelativeUri(
    Uri^ provided,
    [OutAttribute] Uri^% relativeUri
)
function TryGetRelativeUri(provided, relativeUri);

Parameters

provided
Type: SystemUri
relativeUri
Type: SystemUri

Return Value

Type: Boolean
See Also

Reference

EndpointSpecificationBase Class
DoubleTake.Communication Namespace


EndpointSpecificationBase.TryGetUriPort Method

EndpointSpecificationBaseTryGetUriPort Method

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
protected virtual bool TryGetUriPort(
    Nullable<int> port,
    out int uriPort
)
Protected Overridable Function TryGetUriPort (
    port As Nullable(Of Integer),
    <OutAttribute> ByRef uriPort As Integer
) As Boolean
protected:
virtual bool TryGetUriPort(
    Nullable<int> port,
    [OutAttribute] int% uriPort
)
function TryGetUriPort(port, uriPort);

Parameters

port
Type: SystemNullable Int32
uriPort
Type: SystemInt32

Return Value

Type: Boolean
See Also

Reference

EndpointSpecificationBase Class
DoubleTake.Communication Namespace


EndpointSpecificationExtensions Class

EndpointSpecificationExtensions Class
Inheritance Hierarchy
SystemObject
DoubleTake.CommunicationEndpointSpecificationExtensions

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public static class EndpointSpecificationExtensions
<ExtensionAttribute>
Public NotInheritable Class EndpointSpecificationExtensions
[ExtensionAttribute]
public ref class EndpointSpecificationExtensions abstract sealed
DoubleTake.Communication.EndpointSpecificationExtensions = function();

Type.createClass(
    'DoubleTake.Communication.EndpointSpecificationExtensions');
Methods
Name | Description
GetUri(IEndpointSpecification, Type, String) |
GetUri(IEndpointSpecification, Type, Type) |
GetUri(IEndpointSpecification, Type, String, NullableInt32) |
GetUri(IEndpointSpecification, Type, Type, Uri) |
GetUriTContract(IEndpointSpecification, String) |
GetUriTContract(IEndpointSpecification, String, NullableInt32) |
Top
See Also

Reference

DoubleTake.Communication Namespace


EndpointSpecificationExtensions Methods

EndpointSpecificationExtensions Methods
Methods
Name | Description
GetUri(IEndpointSpecification, Type, String) |
GetUri(IEndpointSpecification, Type, Type) |
GetUri(IEndpointSpecification, Type, String, NullableInt32) |
GetUri(IEndpointSpecification, Type, Type, Uri) |
GetUriTContract(IEndpointSpecification, String) |
GetUriTContract(IEndpointSpecification, String, NullableInt32) |
Top
See Also

Reference

EndpointSpecificationExtensions Class
DoubleTake.Communication Namespace


EndpointSpecificationExtensions.GetUri Method

EndpointSpecificationExtensionsGetUri Method
Overload List
Name | Description
GetUriTContract(IEndpointSpecification, String) |
GetUriTContract(IEndpointSpecification, String, NullableInt32) |
GetUri(IEndpointSpecification, Type, String) |
GetUri(IEndpointSpecification, Type, Type) |
GetUri(IEndpointSpecification, Type, String, NullableInt32) |
GetUri(IEndpointSpecification, Type, Type, Uri) |
Top
See Also

Reference

EndpointSpecificationExtensions Class
DoubleTake.Communication Namespace


EndpointSpecificationExtensions.GetUri(TContract) Method (IEndpointSpecification, String)

EndpointSpecificationExtensionsGetUriTContract Method (IEndpointSpecification, String)

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public static Uri GetUri<TContract>(
    this IEndpointSpecification specification,
    string host
)

<ExtensionAttribute>
Public Shared Function GetUri(Of TContract) (
    specification As IEndpointSpecification,
    host As String
) As Uri
public:
[ExtensionAttribute]
generic<typename TContract>
static Uri^ GetUri(
    IEndpointSpecification^ specification,
    String^ host
)
JavaScript does not support generic types or methods.

Parameters

specification
Type: DoubleTake.CommunicationIEndpointSpecification
host
Type: SystemString

Type Parameters

TContract

Return Value

Type: Uri

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IEndpointSpecification. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

EndpointSpecificationExtensions Class
GetUri Overload
DoubleTake.Communication Namespace


EndpointSpecificationExtensions.GetUri(TContract) Method (IEndpointSpecification, String, Nullable(Int32))

EndpointSpecificationExtensionsGetUriTContract Method (IEndpointSpecification, String, NullableInt32)

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public static Uri GetUri<TContract>(
    this IEndpointSpecification specification,
    string host,
    Nullable<int> port
)

<ExtensionAttribute>
Public Shared Function GetUri(Of TContract) (
    specification As IEndpointSpecification,
    host As String,
    port As Nullable(Of Integer)
) As Uri
public:
[ExtensionAttribute]
generic<typename TContract>
static Uri^ GetUri(
    IEndpointSpecification^ specification,
    String^ host,
    Nullable<int> port
)
JavaScript does not support generic types or methods.

Parameters

specification
Type: DoubleTake.CommunicationIEndpointSpecification
host
Type: SystemString
port
Type: SystemNullable Int32

Type Parameters

TContract

Return Value

Type: Uri

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IEndpointSpecification. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

EndpointSpecificationExtensions Class
GetUri Overload
DoubleTake.Communication Namespace


EndpointSpecificationExtensions.GetUri Method (IEndpointSpecification, Type, String)

EndpointSpecificationExtensionsGetUri Method (IEndpointSpecification, Type, String)

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public static Uri GetUri(
    this IEndpointSpecification specification,
    Type contractType,
    string host
)
<ExtensionAttribute>
Public Shared Function GetUri (
    specification As IEndpointSpecification,
    contractType As Type,
    host As String
) As Uri
public:
[ExtensionAttribute]
static Uri^ GetUri(
    IEndpointSpecification^ specification,
    Type^ contractType,
    String^ host
)
DoubleTake.Communication.EndpointSpecificationExtensions.GetUri = function(specification, contractType, host);

Parameters

specification
Type: DoubleTake.CommunicationIEndpointSpecification
contractType
Type: SystemType
host
Type: SystemString

Return Value

Type: Uri

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IEndpointSpecification. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

EndpointSpecificationExtensions Class
GetUri Overload
DoubleTake.Communication Namespace


EndpointSpecificationExtensions.GetUri Method (IEndpointSpecification, Type, Type)

EndpointSpecificationExtensionsGetUri Method (IEndpointSpecification, Type, Type)

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public static Uri GetUri(
    this IEndpointSpecification specification,
    Type serviceType,
    Type contractType
)
<ExtensionAttribute>
Public Shared Function GetUri (
    specification As IEndpointSpecification,
    serviceType As Type,
    contractType As Type
) As Uri
public:
[ExtensionAttribute]
static Uri^ GetUri(
    IEndpointSpecification^ specification,
    Type^ serviceType,
    Type^ contractType
)
DoubleTake.Communication.EndpointSpecificationExtensions.GetUri = function(specification, serviceType, contractType);

Parameters

specification
Type: DoubleTake.CommunicationIEndpointSpecification
serviceType
Type: SystemType
contractType
Type: SystemType

Return Value

Type: Uri

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IEndpointSpecification. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

EndpointSpecificationExtensions Class
GetUri Overload
DoubleTake.Communication Namespace


EndpointSpecificationExtensions.GetUri Method (IEndpointSpecification, Type, String, Nullable(Int32))

EndpointSpecificationExtensionsGetUri Method (IEndpointSpecification, Type, String, NullableInt32)

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public static Uri GetUri(
    this IEndpointSpecification specification,
    Type contractType,
    string host,
    Nullable<int> port
)
<ExtensionAttribute>
Public Shared Function GetUri (
    specification As IEndpointSpecification,
    contractType As Type,
    host As String,
    port As Nullable(Of Integer)
) As Uri
public:
[ExtensionAttribute]
static Uri^ GetUri(
    IEndpointSpecification^ specification,
    Type^ contractType,
    String^ host,
    Nullable<int> port
)
DoubleTake.Communication.EndpointSpecificationExtensions.GetUri = function(specification, contractType, host, port);

Parameters

specification
Type: DoubleTake.CommunicationIEndpointSpecification
contractType
Type: SystemType
host
Type: SystemString
port
Type: SystemNullable Int32

Return Value

Type: Uri

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IEndpointSpecification. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

EndpointSpecificationExtensions Class
GetUri Overload
DoubleTake.Communication Namespace


EndpointSpecificationExtensions.GetUri Method (IEndpointSpecification, Type, Type, Uri)

EndpointSpecificationExtensionsGetUri Method (IEndpointSpecification, Type, Type, Uri)

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public static Uri GetUri(
    this IEndpointSpecification specification,
    Type serviceType,
    Type contractType,
    Uri relativeUri
)
<ExtensionAttribute>
Public Shared Function GetUri (
    specification As IEndpointSpecification,
    serviceType As Type,
    contractType As Type,
    relativeUri As Uri
) As Uri
public:
[ExtensionAttribute]
static Uri^ GetUri(
    IEndpointSpecification^ specification,
    Type^ serviceType,
    Type^ contractType,
    Uri^ relativeUri
)
DoubleTake.Communication.EndpointSpecificationExtensions.GetUri = function(specification, serviceType, contractType, relativeUri);

Parameters

specification
Type: DoubleTake.CommunicationIEndpointSpecification
serviceType
Type: SystemType
contractType
Type: SystemType
relativeUri
Type: SystemUri

Return Value

Type: Uri

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IEndpointSpecification. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

EndpointSpecificationExtensions Class
GetUri Overload
DoubleTake.Communication Namespace


EndpointSpecifications Class

EndpointSpecifications Class
Inheritance Hierarchy
SystemObject
DoubleTake.CommunicationEndpointSpecifications

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public static class EndpointSpecifications
Public NotInheritable Class EndpointSpecifications
public ref class EndpointSpecifications abstract sealed
DoubleTake.Communication.EndpointSpecifications = function();

Type.createClass(
    'DoubleTake.Communication.EndpointSpecifications');

The EndpointSpecifications type exposes the following members.

Fields
Name | Description
BasicHttpNoSecurity |
ClusterSharedTrust |
Default |
DtmuService |
LinuxServiceInterop |
WSHttpNoSecurity |
Top
See Also

Reference

DoubleTake.Communication Namespace


EndpointSpecifications Fields

EndpointSpecifications Fields

The EndpointSpecifications type exposes the following members.

Fields
Name | Description
BasicHttpNoSecurity |
ClusterSharedTrust |
Default |
DtmuService |
LinuxServiceInterop |
WSHttpNoSecurity |
Top
See Also

Reference

EndpointSpecifications Class
DoubleTake.Communication Namespace


EndpointSpecifications.BasicHttpNoSecurity Field

EndpointSpecificationsBasicHttpNoSecurity Field

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string BasicHttpNoSecurity
Public Const BasicHttpNoSecurity As String
public:
literal String^ BasicHttpNoSecurity
var DoubleTake.Communication.EndpointSpecifications.BasicHttpNoSecurity

Field Value

Type: String
See Also

Reference

EndpointSpecifications Class
DoubleTake.Communication Namespace


EndpointSpecifications.ClusterSharedTrust Field

EndpointSpecificationsClusterSharedTrust Field

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string ClusterSharedTrust
Public Const ClusterSharedTrust As String
public:
literal String^ ClusterSharedTrust
var DoubleTake.Communication.EndpointSpecifications.ClusterSharedTrust

Field Value

Type: String
See Also

Reference

EndpointSpecifications Class
DoubleTake.Communication Namespace


EndpointSpecifications.Default Field

EndpointSpecificationsDefault Field

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string Default
Public Const Default As String
public:
literal String^ Default
var DoubleTake.Communication.EndpointSpecifications.Default

Field Value

Type: String
See Also

Reference

EndpointSpecifications Class
DoubleTake.Communication Namespace


EndpointSpecifications.DtmuService Field

EndpointSpecificationsDtmuService Field

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string DtmuService
Public Const DtmuService As String
public:
literal String^ DtmuService
var DoubleTake.Communication.EndpointSpecifications.DtmuService

Field Value

Type: String
See Also

Reference

EndpointSpecifications Class
DoubleTake.Communication Namespace


EndpointSpecifications.LinuxServiceInterop Field

EndpointSpecificationsLinuxServiceInterop Field

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string LinuxServiceInterop
Public Const LinuxServiceInterop As String
public:
literal String^ LinuxServiceInterop
var DoubleTake.Communication.EndpointSpecifications.LinuxServiceInterop

Field Value

Type: String
See Also

Reference

EndpointSpecifications Class
DoubleTake.Communication Namespace


EndpointSpecifications.WSHttpNoSecurity Field

EndpointSpecificationsWSHttpNoSecurity Field

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string WSHttpNoSecurity
Public Const WSHttpNoSecurity As String
public:
literal String^ WSHttpNoSecurity
var DoubleTake.Communication.EndpointSpecifications.WSHttpNoSecurity

Field Value

Type: String
See Also

Reference

EndpointSpecifications Class
DoubleTake.Communication Namespace


ICommunicationSettings Interface

ICommunicationSettings Interface

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public interface ICommunicationSettings
Public Interface ICommunicationSettings
public interface class ICommunicationSettings
DoubleTake.Communication.ICommunicationSettings = function();
DoubleTake.Communication.ICommunicationSettings.createInterface('DoubleTake.Communication.ICommunicationSettings');

The ICommunicationSettings type exposes the following members.

Properties
 | Name | Description
Public property | BypassProxyForLocal |
Public property | CloseTimeout |
Public property | HttpPort |
Public property | InterserviceDefaultPort |
Public property | InterserviceRepollDelay |
Public property | IntraClusterActiveChannelLimit |
Public property | IntraClusterConnectTimeout |
Public property | IntraClusterDataCacheTtl |
Public property | IntraClusterDnsRecordCap |
Public property | IntraClusterNameDataCacheTtl |
Public property | IntraClusterReconnectDelay |
Public property | LinuxServiceInteropPort |
Public property | MaxClockSkew |
Public property | MaxReceivedMessageSize |
Public property | OpenTimeout |
Public property | ReaderQuotas |
Public property | SendTimeout |
Public property | UseDefaultWebProxy |
Top
See Also

Reference

DoubleTake.Communication Namespace


ICommunicationSettings Properties

ICommunicationSettings Properties

The ICommunicationSettings type exposes the following members.

Properties
 | Name | Description
Public property | BypassProxyForLocal |
Public property | CloseTimeout |
Public property | HttpPort |
Public property | InterserviceDefaultPort |
Public property | InterserviceRepollDelay |
Public property | IntraClusterActiveChannelLimit |
Public property | IntraClusterConnectTimeout |
Public property | IntraClusterDataCacheTtl |
Public property | IntraClusterDnsRecordCap |
Public property | IntraClusterNameDataCacheTtl |
Public property | IntraClusterReconnectDelay |
Public property | LinuxServiceInteropPort |
Public property | MaxClockSkew |
Public property | MaxReceivedMessageSize |
Public property | OpenTimeout |
Public property | ReaderQuotas |
Public property | SendTimeout |
Public property | UseDefaultWebProxy |
Top
See Also

Reference

ICommunicationSettings Interface
DoubleTake.Communication Namespace


ICommunicationSettings.BypassProxyForLocal Property

ICommunicationSettingsBypassProxyForLocal Property

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
bool BypassProxyForLocal { get; }
ReadOnly Property BypassProxyForLocal As Boolean
    Get
property bool BypassProxyForLocal {
    bool get ();
}
function get_BypassProxyForLocal();

Property Value

Type: Boolean
See Also

Reference

ICommunicationSettings Interface
DoubleTake.Communication Namespace


ICommunicationSettings.CloseTimeout Property

ICommunicationSettingsCloseTimeout Property

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
TimeSpan CloseTimeout { get; }
ReadOnly Property CloseTimeout As TimeSpan
    Get
property TimeSpan CloseTimeout {
    TimeSpan get ();
}
function get_CloseTimeout();

Property Value

Type: TimeSpan
See Also

Reference

ICommunicationSettings Interface
DoubleTake.Communication Namespace


ICommunicationSettings.HttpPort Property

ICommunicationSettingsHttpPort Property

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
int HttpPort { get; }
ReadOnly Property HttpPort As Integer
    Get
property int HttpPort {
    int get ();
}
function get_HttpPort();

Property Value

Type: Int32
See Also

Reference

ICommunicationSettings Interface
DoubleTake.Communication Namespace


ICommunicationSettings.InterserviceDefaultPort Property

ICommunicationSettingsInterserviceDefaultPort Property

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
int InterserviceDefaultPort { get; }
ReadOnly Property InterserviceDefaultPort As Integer
    Get
property int InterserviceDefaultPort {
    int get ();
}
function get_InterserviceDefaultPort();

Property Value

Type: Int32
See Also

Reference

ICommunicationSettings Interface
DoubleTake.Communication Namespace


ICommunicationSettings.InterserviceRepollDelay Property

ICommunicationSettingsInterserviceRepollDelay Property

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
TimeSpan InterserviceRepollDelay { get; }
ReadOnly Property InterserviceRepollDelay As TimeSpan
    Get
property TimeSpan InterserviceRepollDelay {
    TimeSpan get ();
}
function get_InterserviceRepollDelay();

Property Value

Type: TimeSpan
See Also

Reference

ICommunicationSettings Interface
DoubleTake.Communication Namespace


ICommunicationSettings.IntraClusterActiveChannelLimit Property

ICommunicationSettingsIntraClusterActiveChannelLimit Property

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
int IntraClusterActiveChannelLimit { get; }
ReadOnly Property IntraClusterActiveChannelLimit As Integer
    Get
property int IntraClusterActiveChannelLimit {
    int get ();
}
function get_IntraClusterActiveChannelLimit();

Property Value

Type: Int32
See Also

Reference

ICommunicationSettings Interface
DoubleTake.Communication Namespace


ICommunicationSettings.IntraClusterConnectTimeout Property

ICommunicationSettingsIntraClusterConnectTimeout Property

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
TimeSpan IntraClusterConnectTimeout { get; }
ReadOnly Property IntraClusterConnectTimeout As TimeSpan
    Get
property TimeSpan IntraClusterConnectTimeout {
    TimeSpan get ();
}
function get_IntraClusterConnectTimeout();

Property Value

Type: TimeSpan
See Also

Reference

ICommunicationSettings Interface
DoubleTake.Communication Namespace


ICommunicationSettings.IntraClusterDataCacheTtl Property

ICommunicationSettingsIntraClusterDataCacheTtl Property

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
TimeSpan IntraClusterDataCacheTtl { get; }
ReadOnly Property IntraClusterDataCacheTtl As TimeSpan
    Get
property TimeSpan IntraClusterDataCacheTtl {
    TimeSpan get ();
}
function get_IntraClusterDataCacheTtl();

Property Value

Type: TimeSpan
See Also

Reference

ICommunicationSettings Interface
DoubleTake.Communication Namespace


ICommunicationSettings.IntraClusterDnsRecordCap Property

ICommunicationSettingsIntraClusterDnsRecordCap Property

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
int IntraClusterDnsRecordCap { get; }
ReadOnly Property IntraClusterDnsRecordCap As Integer
    Get
property int IntraClusterDnsRecordCap {
    int get ();
}
function get_IntraClusterDnsRecordCap();

Property Value

Type: Int32
See Also

Reference

ICommunicationSettings Interface
DoubleTake.Communication Namespace


ICommunicationSettings.IntraClusterNameDataCacheTtl Property

ICommunicationSettingsIntraClusterNameDataCacheTtl Property

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
TimeSpan IntraClusterNameDataCacheTtl { get; }
ReadOnly Property IntraClusterNameDataCacheTtl As TimeSpan
    Get
property TimeSpan IntraClusterNameDataCacheTtl {
    TimeSpan get ();
}
function get_IntraClusterNameDataCacheTtl();

Property Value

Type: TimeSpan
See Also

Reference

ICommunicationSettings Interface
DoubleTake.Communication Namespace


ICommunicationSettings.IntraClusterReconnectDelay Property

ICommunicationSettingsIntraClusterReconnectDelay Property

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
TimeSpan IntraClusterReconnectDelay { get; }
ReadOnly Property IntraClusterReconnectDelay As TimeSpan
    Get
property TimeSpan IntraClusterReconnectDelay {
    TimeSpan get ();
}
function get_IntraClusterReconnectDelay();

Property Value

Type: TimeSpan
See Also

Reference

ICommunicationSettings Interface
DoubleTake.Communication Namespace


ICommunicationSettings.LinuxServiceInteropPort Property

ICommunicationSettingsLinuxServiceInteropPort Property

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
int LinuxServiceInteropPort { get; }
ReadOnly Property LinuxServiceInteropPort As Integer
    Get
property int LinuxServiceInteropPort {
    int get ();
}
function get_LinuxServiceInteropPort();

Property Value

Type: Int32
See Also

Reference

ICommunicationSettings Interface
DoubleTake.Communication Namespace


ICommunicationSettings.MaxClockSkew Property

ICommunicationSettingsMaxClockSkew Property

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
TimeSpan MaxClockSkew { get; }
ReadOnly Property MaxClockSkew As TimeSpan
    Get
property TimeSpan MaxClockSkew {
    TimeSpan get ();
}
function get_MaxClockSkew();

Property Value

Type: TimeSpan
See Also

Reference

ICommunicationSettings Interface
DoubleTake.Communication Namespace


ICommunicationSettings.MaxReceivedMessageSize Property

ICommunicationSettingsMaxReceivedMessageSize Property

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
long MaxReceivedMessageSize { get; }
ReadOnly Property MaxReceivedMessageSize As Long
    Get
property long long MaxReceivedMessageSize {
    long long get ();
}
function get_MaxReceivedMessageSize();

Property Value

Type: Int64
See Also

Reference

ICommunicationSettings Interface
DoubleTake.Communication Namespace


ICommunicationSettings.OpenTimeout Property

ICommunicationSettingsOpenTimeout Property

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
TimeSpan OpenTimeout { get; }
ReadOnly Property OpenTimeout As TimeSpan
    Get
property TimeSpan OpenTimeout {
    TimeSpan get ();
}
function get_OpenTimeout();

Property Value

Type: TimeSpan
See Also

Reference

ICommunicationSettings Interface
DoubleTake.Communication Namespace


ICommunicationSettings.ReaderQuotas Property

ICommunicationSettingsReaderQuotas Property

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
XmlDictionaryReaderQuotas ReaderQuotas { get; }
ReadOnly Property ReaderQuotas As XmlDictionaryReaderQuotas
    Get
property XmlDictionaryReaderQuotas^ ReaderQuotas {
    XmlDictionaryReaderQuotas^ get ();
}
function get_ReaderQuotas();

Property Value

Type: XmlDictionaryReaderQuotas
See Also

Reference

ICommunicationSettings Interface
DoubleTake.Communication Namespace


ICommunicationSettings.SendTimeout Property

ICommunicationSettingsSendTimeout Property

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
TimeSpan SendTimeout { get; }
ReadOnly Property SendTimeout As TimeSpan
    Get
property TimeSpan SendTimeout {
    TimeSpan get ();
}
function get_SendTimeout();

Property Value

Type: TimeSpan
See Also

Reference

ICommunicationSettings Interface
DoubleTake.Communication Namespace


ICommunicationSettings.UseDefaultWebProxy Property

ICommunicationSettingsUseDefaultWebProxy Property

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
bool UseDefaultWebProxy { get; }
ReadOnly Property UseDefaultWebProxy As Boolean
    Get
property bool UseDefaultWebProxy {
    bool get ();
}
function get_UseDefaultWebProxy();

Property Value

Type: Boolean
See Also

Reference

ICommunicationSettings Interface
DoubleTake.Communication Namespace


IEndpointSpecification Interface

IEndpointSpecification Interface

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public interface IEndpointSpecification
Public Interface IEndpointSpecification
public interface class IEndpointSpecification
DoubleTake.Communication.IEndpointSpecification = function();
DoubleTake.Communication.IEndpointSpecification.createInterface('DoubleTake.Communication.IEndpointSpecification');

The IEndpointSpecification type exposes the following members.

Properties
 | Name | Description
Public property | Binding |
Top
Methods
 | Name | Description
Public method | GetUri |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetUri(Type, Type) | Overloaded. (Defined by EndpointSpecificationExtensions.)
Public Extension Method | GetUri(Type, String) | Overloaded. (Defined by EndpointSpecificationExtensions.)
Public Extension Method | GetUri(Type, Type, Uri) | Overloaded. (Defined by EndpointSpecificationExtensions.)
Public Extension Method | GetUri(Type, String, NullableInt32) | Overloaded. (Defined by EndpointSpecificationExtensions.)
Public Extension Method | GetUriTContract(String) | Overloaded. (Defined by EndpointSpecificationExtensions.)
Public Extension Method | GetUriTContract(String, NullableInt32) | Overloaded. (Defined by EndpointSpecificationExtensions.)
Top
See Also

Reference

DoubleTake.Communication Namespace


IEndpointSpecification Properties

IEndpointSpecification Properties

The IEndpointSpecification type exposes the following members.

Properties
 | Name | Description
Public property | Binding |
Top
See Also

Reference

IEndpointSpecification Interface
DoubleTake.Communication Namespace


IEndpointSpecification.Binding Property

IEndpointSpecificationBinding Property

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
Binding Binding { get; }
ReadOnly Property Binding As Binding
    Get
property Binding^ Binding {
    Binding^ get ();
}
function get_Binding();

Property Value

Type: Binding
See Also

Reference

IEndpointSpecification Interface
DoubleTake.Communication Namespace


IEndpointSpecification Methods

IEndpointSpecification Methods

The IEndpointSpecification type exposes the following members.

Methods
 | Name | Description
Public method | GetUri |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetUri(Type, Type) | Overloaded. (Defined by EndpointSpecificationExtensions.)
Public Extension Method | GetUri(Type, String) | Overloaded. (Defined by EndpointSpecificationExtensions.)
Public Extension Method | GetUri(Type, Type, Uri) | Overloaded. (Defined by EndpointSpecificationExtensions.)
Public Extension Method | GetUri(Type, String, NullableInt32) | Overloaded. (Defined by EndpointSpecificationExtensions.)
Public Extension Method | GetUriTContract(String) | Overloaded. (Defined by EndpointSpecificationExtensions.)
Public Extension Method | GetUriTContract(String, NullableInt32) | Overloaded. (Defined by EndpointSpecificationExtensions.)
Top
See Also

Reference

IEndpointSpecification Interface
DoubleTake.Communication Namespace


IEndpointSpecification.GetUri Method

IEndpointSpecificationGetUri Method

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
Uri GetUri(
    string host,
    Nullable<int> port,
    Uri relativeUri
)
Function GetUri (
    host As String,
    port As Nullable(Of Integer),
    relativeUri As Uri
) As Uri
Uri^ GetUri(
    String^ host,
    Nullable<int> port,
    Uri^ relativeUri
)
function GetUri(host, port, relativeUri);

Parameters

host
Type: SystemString
port
Type: SystemNullable Int32
relativeUri
Type: SystemUri

Return Value

Type: Uri
See Also

Reference

IEndpointSpecification Interface
DoubleTake.Communication Namespace


IProxy Interface

IProxy Interface

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public interface IProxy
Public Interface IProxy
public interface class IProxy
DoubleTake.Communication.IProxy = function();
DoubleTake.Communication.IProxy.createInterface('DoubleTake.Communication.IProxy');

The IProxy type exposes the following members.

Properties
 | Name | Description
Public property | IsAutoRetryEnabled |
Top
Methods
 | Name | Description
Public method | Reset |
Top
See Also

Reference

DoubleTake.Communication Namespace


IProxy Properties

IProxy Properties

The IProxy type exposes the following members.

Properties
 | Name | Description
Public property | IsAutoRetryEnabled |
Top
See Also

Reference

IProxy Interface
DoubleTake.Communication Namespace


IProxy.IsAutoRetryEnabled Property

IProxyIsAutoRetryEnabled Property

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
bool IsAutoRetryEnabled { get; set; }
Property IsAutoRetryEnabled As Boolean
    Get
    Set
property bool IsAutoRetryEnabled {
    bool get ();
    void set (bool value);
}
function get_IsAutoRetryEnabled();
function set_IsAutoRetryEnabled(value);

Property Value

Type: Boolean
See Also

Reference

IProxy Interface
DoubleTake.Communication Namespace


IProxy Methods

IProxy Methods

The IProxy type exposes the following members.

Methods
 | Name | Description
Public method | Reset |
Top
See Also

Reference

IProxy Interface
DoubleTake.Communication Namespace


IProxy.Reset Method

IProxyReset Method

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
void Reset()
Sub Reset
void Reset()
function Reset();
See Also

Reference

IProxy Interface
DoubleTake.Communication Namespace


IProxyFactory Interface

IProxyFactory Interface

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public interface IProxyFactory
Public Interface IProxyFactory
public interface class IProxyFactory
DoubleTake.Communication.IProxyFactory = function();
DoubleTake.Communication.IProxyFactory.createInterface('DoubleTake.Communication.IProxyFactory');

The IProxyFactory type exposes the following members.

Properties
 | Name | Description
Public property | CloseTimeout |
Public property | OpenTimeout |
Public property | ReceiveTimeout |
Public property | SendTimeout |
Top
Methods
 | Name | Description
Public method | CreateTChannel |
Public method | CreateClientTClient |
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateTChannel(Uri) | Overloaded. (Defined by ProxyFactoryExtensions.)
Public Extension Method | CreateTChannel(ServiceConnectionParameters) | Overloaded. (Defined by ProxyFactoryExtensions.)
Public Extension Method | CreateTChannel(Uri, AddressingScheme) | Overloaded. (Defined by ProxyFactoryExtensions.)
Public Extension Method | CreateTChannel(ServiceConnectionParameters, Uri) | Overloaded. (Defined by ProxyFactoryExtensions.)
Public Extension Method | CreateTChannel(ServiceConnectionParameters, AddressingScheme) | Overloaded. (Defined by ProxyFactoryExtensions.)
Public Extension Method | CreateClientTClient(Uri) | Overloaded. (Defined by ProxyFactoryExtensions.)
Public Extension Method | CreateClientTClient(Uri, AddressingScheme) | Overloaded. (Defined by ProxyFactoryExtensions.)
Public Extension Method | CreateClientTClient(Uri, Uri) | Overloaded. (Defined by ProxyFactoryExtensions.)
Public Extension Method | UsingTChannel(Uri, ActionTChannel) | Overloaded. (Defined by ProxyFactoryExtensions.)
Public Extension Method | UsingTChannel(ServiceConnectionParameters, ActionTChannel) | Overloaded. (Defined by ProxyFactoryExtensions.)
Public Extension Method | UsingTChannel(Uri, Uri, ActionTChannel) | Overloaded. (Defined by ProxyFactoryExtensions.)
Public Extension Method | UsingTChannel(Uri, AddressingScheme, ActionTChannel) | Overloaded. (Defined by ProxyFactoryExtensions.)
Public Extension Method | UsingTChannel(ServiceConnectionParameters, Uri, ActionTChannel) | Overloaded. (Defined by ProxyFactoryExtensions.)
Public Extension Method | UsingTChannel, TResult(Uri, FuncTChannel, TResult) | Overloaded. (Defined by ProxyFactoryExtensions.)
Public Extension Method | UsingTChannel, TResult(ServiceConnectionParameters, FuncTChannel, TResult) | Overloaded. (Defined by ProxyFactoryExtensions.)
Public Extension Method | UsingTChannel, TResult(Uri, Uri, FuncTChannel, TResult) | Overloaded. (Defined by ProxyFactoryExtensions.)
Public Extension Method | UsingTChannel, TResult(Uri, AddressingScheme, FuncTChannel, TResult) | Overloaded. (Defined by ProxyFactoryExtensions.)
Public Extension Method | UsingTChannel, TResult(ServiceConnectionParameters, Uri, FuncTChannel, TResult) | Overloaded. (Defined by ProxyFactoryExtensions.)
Top
See Also

Reference

DoubleTake.Communication Namespace


IProxyFactory Properties

IProxyFactory Properties

The IProxyFactory type exposes the following members.

Properties
 | Name | Description
Public property | CloseTimeout |
Public property | OpenTimeout |
Public property | ReceiveTimeout |
Public property | SendTimeout |
Top
See Also

Reference

IProxyFactory Interface
DoubleTake.Communication Namespace


IProxyFactory.CloseTimeout Property

IProxyFactoryCloseTimeout Property

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
TimeSpan CloseTimeout { get; set; }
Property CloseTimeout As TimeSpan
    Get
    Set
property TimeSpan CloseTimeout {
    TimeSpan get ();
    void set (TimeSpan value);
}
function get_CloseTimeout();
function set_CloseTimeout(value);

Property Value

Type: TimeSpan
See Also

Reference

IProxyFactory Interface
DoubleTake.Communication Namespace


IProxyFactory.OpenTimeout Property

IProxyFactoryOpenTimeout Property

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
TimeSpan OpenTimeout { get; set; }
Property OpenTimeout As TimeSpan
    Get
    Set
property TimeSpan OpenTimeout {
    TimeSpan get ();
    void set (TimeSpan value);
}
function get_OpenTimeout();
function set_OpenTimeout(value);

Property Value

Type: TimeSpan
See Also

Reference

IProxyFactory Interface
DoubleTake.Communication Namespace


IProxyFactory.ReceiveTimeout Property

IProxyFactoryReceiveTimeout Property

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
TimeSpan ReceiveTimeout { get; set; }
Property ReceiveTimeout As TimeSpan
    Get
    Set
property TimeSpan ReceiveTimeout {
    TimeSpan get ();
    void set (TimeSpan value);
}
function get_ReceiveTimeout();
function set_ReceiveTimeout(value);

Property Value

Type: TimeSpan
See Also

Reference

IProxyFactory Interface
DoubleTake.Communication Namespace


IProxyFactory.SendTimeout Property

IProxyFactorySendTimeout Property

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
TimeSpan SendTimeout { get; set; }
Property SendTimeout As TimeSpan
    Get
    Set
property TimeSpan SendTimeout {
    TimeSpan get ();
    void set (TimeSpan value);
}
function get_SendTimeout();
function set_SendTimeout(value);

Property Value

Type: TimeSpan
See Also

Reference

IProxyFactory Interface
DoubleTake.Communication Namespace


IProxyFactory Methods

IProxyFactory Methods

The IProxyFactory type exposes the following members.

Methods
 | Name | Description
Public method | CreateTChannel |
Public method | CreateClientTClient |
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateTChannel(Uri) | Overloaded. (Defined by ProxyFactoryExtensions.)
Public Extension Method | CreateTChannel(ServiceConnectionParameters) | Overloaded. (Defined by ProxyFactoryExtensions.)
Public Extension Method | CreateTChannel(Uri, AddressingScheme) | Overloaded. (Defined by ProxyFactoryExtensions.)
Public Extension Method | CreateTChannel(ServiceConnectionParameters, Uri) | Overloaded. (Defined by ProxyFactoryExtensions.)
Public Extension Method | CreateTChannel(ServiceConnectionParameters, AddressingScheme) | Overloaded. (Defined by ProxyFactoryExtensions.)
Public Extension Method | CreateClientTClient(Uri) | Overloaded. (Defined by ProxyFactoryExtensions.)
Public Extension Method | CreateClientTClient(Uri, AddressingScheme) | Overloaded. (Defined by ProxyFactoryExtensions.)
Public Extension Method | CreateClientTClient(Uri, Uri) | Overloaded. (Defined by ProxyFactoryExtensions.)
Public Extension Method | UsingTChannel(Uri, ActionTChannel) | Overloaded. (Defined by ProxyFactoryExtensions.)
Public Extension Method | UsingTChannel(ServiceConnectionParameters, ActionTChannel) | Overloaded. (Defined by ProxyFactoryExtensions.)
Public Extension Method | UsingTChannel(Uri, Uri, ActionTChannel) | Overloaded. (Defined by ProxyFactoryExtensions.)
Public Extension Method | UsingTChannel(Uri, AddressingScheme, ActionTChannel) | Overloaded. (Defined by ProxyFactoryExtensions.)
Public Extension Method | UsingTChannel(ServiceConnectionParameters, Uri, ActionTChannel) | Overloaded. (Defined by ProxyFactoryExtensions.)
Public Extension Method | UsingTChannel, TResult(Uri, FuncTChannel, TResult) | Overloaded. (Defined by ProxyFactoryExtensions.)
Public Extension Method | UsingTChannel, TResult(ServiceConnectionParameters, FuncTChannel, TResult) | Overloaded. (Defined by ProxyFactoryExtensions.)
Public Extension Method | UsingTChannel, TResult(Uri, Uri, FuncTChannel, TResult) | Overloaded. (Defined by ProxyFactoryExtensions.)
Public Extension Method | UsingTChannel, TResult(Uri, AddressingScheme, FuncTChannel, TResult) | Overloaded. (Defined by ProxyFactoryExtensions.)
Public Extension Method | UsingTChannel, TResult(ServiceConnectionParameters, Uri, FuncTChannel, TResult) | Overloaded. (Defined by ProxyFactoryExtensions.)
Top
See Also

Reference

IProxyFactory Interface
DoubleTake.Communication Namespace


IProxyFactory.Create(TChannel) Method

IProxyFactoryCreateTChannel Method

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
TChannel Create<TChannel>(
    Uri hostUri,
    Uri relativeUri
)
where TChannel : class

Function Create(Of TChannel As Class) (
    hostUri As Uri,
    relativeUri As Uri
) As TChannel
generic<typename TChannel>
where TChannel : ref class
TChannel Create(
    Uri^ hostUri,
    Uri^ relativeUri
)
JavaScript does not support generic types or methods.

Parameters

hostUri
Type: SystemUri
relativeUri
Type: SystemUri

Type Parameters

TChannel

Return Value

Type: TChannel
See Also

Reference

IProxyFactory Interface
DoubleTake.Communication Namespace


IProxyFactory.CreateClient(TClient) Method

IProxyFactoryCreateClientTClient Method

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
TClient CreateClient<TClient>(
    Uri hostUri,
    Uri relativeUri
)
where TClient : class

Function CreateClient(Of TClient As Class) (
    hostUri As Uri,
    relativeUri As Uri
) As TClient
generic<typename TClient>
where TClient : ref class
TClient CreateClient(
    Uri^ hostUri,
    Uri^ relativeUri
)
JavaScript does not support generic types or methods.

Parameters

hostUri
Type: SystemUri
relativeUri
Type: SystemUri

Type Parameters

TClient

Return Value

Type: TClient
See Also

Reference

IProxyFactory Interface
DoubleTake.Communication Namespace


LinuxServiceInteropCertificateValidator Class

LinuxServiceInteropCertificateValidator Class
Inheritance Hierarchy
SystemObject
System.IdentityModel.SelectorsX509CertificateValidator
DoubleTake.CommunicationLinuxServiceInteropCertificateValidator

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class LinuxServiceInteropCertificateValidator : X509CertificateValidator
Public Class LinuxServiceInteropCertificateValidator
    Inherits X509CertificateValidator
public ref class LinuxServiceInteropCertificateValidator : public X509CertificateValidator
DoubleTake.Communication.LinuxServiceInteropCertificateValidator = function();

Type.createClass(
    'DoubleTake.Communication.LinuxServiceInteropCertificateValidator',
    X509CertificateValidator);

The LinuxServiceInteropCertificateValidator type exposes the following members.

Constructors
 | Name | Description
Public method | LinuxServiceInteropCertificateValidator | Initializes a new instance of the LinuxServiceInteropCertificateValidator class
Top
Methods
 | Name | Description
Public method | Validate | (Overrides X509CertificateValidatorValidate(X509Certificate2).)
Top
See Also

Reference

DoubleTake.Communication Namespace


LinuxServiceInteropCertificateValidator Constructor

LinuxServiceInteropCertificateValidator Constructor
Initializes a new instance of the LinuxServiceInteropCertificateValidator class

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public LinuxServiceInteropCertificateValidator()
Public Sub New
public:
LinuxServiceInteropCertificateValidator()
DoubleTake.Communication.LinuxServiceInteropCertificateValidator = function();
See Also

Reference

LinuxServiceInteropCertificateValidator Class
DoubleTake.Communication Namespace


LinuxServiceInteropCertificateValidator Methods

LinuxServiceInteropCertificateValidator Methods

The LinuxServiceInteropCertificateValidator type exposes the following members.

Methods
 | Name | Description
Public method | Validate | (Overrides X509CertificateValidatorValidate(X509Certificate2).)
Top
See Also

Reference

LinuxServiceInteropCertificateValidator Class
DoubleTake.Communication Namespace


LinuxServiceInteropCertificateValidator.Validate Method

LinuxServiceInteropCertificateValidatorValidate Method

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public override void Validate(
    X509Certificate2 certificate
)
Public Overrides Sub Validate (
    certificate As X509Certificate2
)
public:
virtual void Validate(
    X509Certificate2^ certificate
) override
function Validate(certificate);

Parameters

certificate
Type: System.Security.Cryptography.X509CertificatesX509Certificate2
See Also

Reference

LinuxServiceInteropCertificateValidator Class
DoubleTake.Communication Namespace


LinuxServiceInteropEndpointSpecification Class

LinuxServiceInteropEndpointSpecification Class
Inheritance Hierarchy
SystemObject
DoubleTake.CommunicationEndpointSpecificationBase
DoubleTake.CommunicationBasicHttpEndpointSpecificationBase
DoubleTake.CommunicationBasicHttpNoSecurityEndpointSpecification
DoubleTake.CommunicationLinuxServiceInteropEndpointSpecification

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class LinuxServiceInteropEndpointSpecification : BasicHttpNoSecurityEndpointSpecification
Public Class LinuxServiceInteropEndpointSpecification
    Inherits BasicHttpNoSecurityEndpointSpecification
public ref class LinuxServiceInteropEndpointSpecification : public BasicHttpNoSecurityEndpointSpecification
DoubleTake.Communication.LinuxServiceInteropEndpointSpecification = function();

Type.createClass(
    'DoubleTake.Communication.LinuxServiceInteropEndpointSpecification',
    DoubleTake.Communication.BasicHttpNoSecurityEndpointSpecification);

The LinuxServiceInteropEndpointSpecification type exposes the following members.

Constructors
 | Name | Description
Public method | LinuxServiceInteropEndpointSpecification | Initializes a new instance of the LinuxServiceInteropEndpointSpecification class
Public method | LinuxServiceInteropEndpointSpecification(ICommunicationSettings) | Initializes a new instance of the LinuxServiceInteropEndpointSpecification class
Top
Properties
 | Name | Description
Public property | Binding | (Inherited from EndpointSpecificationBase.)
Protected property | CommunicationSettings | (Inherited from EndpointSpecificationBase.)
Top
Methods
 | Name | Description
Protected method | Configure | (Overrides BasicHttpNoSecurityEndpointSpecificationConfigure(BasicHttpBinding).)
Protected method | ConfigureBinding | (Inherited from BasicHttpEndpointSpecificationBase.)
Protected method | CreateBinding | (Inherited from BasicHttpEndpointSpecificationBase.)
Public method | GetUri | (Inherited from EndpointSpecificationBase.)
Protected method | TryGetRelativeUri | (Inherited from BasicHttpNoSecurityEndpointSpecification.)
Protected method | TryGetUriPort | (Overrides BasicHttpEndpointSpecificationBaseTryGetUriPort(NullableInt32, Int32).)
Top
See Also

Reference

DoubleTake.Communication Namespace


LinuxServiceInteropEndpointSpecification Constructor

LinuxServiceInteropEndpointSpecification Constructor
Overload List
 | Name | Description
Public method | LinuxServiceInteropEndpointSpecification | Initializes a new instance of the LinuxServiceInteropEndpointSpecification class
Public method | LinuxServiceInteropEndpointSpecification(ICommunicationSettings) | Initializes a new instance of the LinuxServiceInteropEndpointSpecification class
Top
See Also

Reference

LinuxServiceInteropEndpointSpecification Class
DoubleTake.Communication Namespace


LinuxServiceInteropEndpointSpecification Constructor

LinuxServiceInteropEndpointSpecification Constructor
Initializes a new instance of the LinuxServiceInteropEndpointSpecification class

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public LinuxServiceInteropEndpointSpecification()
Public Sub New
public:
LinuxServiceInteropEndpointSpecification()
DoubleTake.Communication.LinuxServiceInteropEndpointSpecification = function();
See Also

Reference

LinuxServiceInteropEndpointSpecification Class
LinuxServiceInteropEndpointSpecification Overload
DoubleTake.Communication Namespace


LinuxServiceInteropEndpointSpecification Constructor (ICommunicationSettings)

LinuxServiceInteropEndpointSpecification Constructor (ICommunicationSettings)
Initializes a new instance of the LinuxServiceInteropEndpointSpecification class

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public LinuxServiceInteropEndpointSpecification(
    ICommunicationSettings communicationSettings
)
Public Sub New (
    communicationSettings As ICommunicationSettings
)
public:
LinuxServiceInteropEndpointSpecification(
    ICommunicationSettings^ communicationSettings
)
DoubleTake.Communication.LinuxServiceInteropEndpointSpecification = function(communicationSettings);

Parameters

communicationSettings
Type: DoubleTake.CommunicationICommunicationSettings
See Also

Reference

LinuxServiceInteropEndpointSpecification Class
LinuxServiceInteropEndpointSpecification Overload
DoubleTake.Communication Namespace


LinuxServiceInteropEndpointSpecification Properties

LinuxServiceInteropEndpointSpecification Properties

The LinuxServiceInteropEndpointSpecification type exposes the following members.

Properties
 | Name | Description
Public property | Binding | (Inherited from EndpointSpecificationBase.)
Protected property | CommunicationSettings | (Inherited from EndpointSpecificationBase.)
Top
See Also

Reference

LinuxServiceInteropEndpointSpecification Class
DoubleTake.Communication Namespace


LinuxServiceInteropEndpointSpecification Methods

LinuxServiceInteropEndpointSpecification Methods

The LinuxServiceInteropEndpointSpecification type exposes the following members.

Methods
 | Name | Description
Protected method | Configure | (Overrides BasicHttpNoSecurityEndpointSpecificationConfigure(BasicHttpBinding).)
Protected method | ConfigureBinding | (Inherited from BasicHttpEndpointSpecificationBase.)
Protected method | CreateBinding | (Inherited from BasicHttpEndpointSpecificationBase.)
Public method | GetUri | (Inherited from EndpointSpecificationBase.)
Protected method | TryGetRelativeUri | (Inherited from BasicHttpNoSecurityEndpointSpecification.)
Protected method | TryGetUriPort | (Overrides BasicHttpEndpointSpecificationBaseTryGetUriPort(NullableInt32, Int32).)
Top
See Also

Reference

LinuxServiceInteropEndpointSpecification Class
DoubleTake.Communication Namespace


LinuxServiceInteropEndpointSpecification.Configure Method

LinuxServiceInteropEndpointSpecificationConfigure Method

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
protected override Binding Configure(
    BasicHttpBinding binding
)
Protected Overrides Function Configure (
    binding As BasicHttpBinding
) As Binding
protected:
virtual Binding^ Configure(
    BasicHttpBinding^ binding
) override
function Configure(binding);

Parameters

binding
Type: System.ServiceModelBasicHttpBinding

Return Value

Type: Binding
See Also

Reference

LinuxServiceInteropEndpointSpecification Class
DoubleTake.Communication Namespace


LinuxServiceInteropEndpointSpecification.TryGetUriPort Method

LinuxServiceInteropEndpointSpecificationTryGetUriPort Method

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
protected override bool TryGetUriPort(
    Nullable<int> port,
    out int uriPort
)
Protected Overrides Function TryGetUriPort (
    port As Nullable(Of Integer),
    <OutAttribute> ByRef uriPort As Integer
) As Boolean
protected:
virtual bool TryGetUriPort(
    Nullable<int> port,
    [OutAttribute] int% uriPort
) override
function TryGetUriPort(port, uriPort);

Parameters

port
Type: SystemNullable Int32
uriPort
Type: SystemInt32

Return Value

Type: Boolean
See Also

Reference

LinuxServiceInteropEndpointSpecification Class
DoubleTake.Communication Namespace


LinuxServiceInteropProxyFactory Class

LinuxServiceInteropProxyFactory Class
Inheritance Hierarchy
SystemObject
DoubleTake.CommunicationProxyFactoryBase
DoubleTake.CommunicationLinuxServiceInteropProxyFactory

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class LinuxServiceInteropProxyFactory : ProxyFactoryBase
Public Class LinuxServiceInteropProxyFactory
    Inherits ProxyFactoryBase
public ref class LinuxServiceInteropProxyFactory : public ProxyFactoryBase
DoubleTake.Communication.LinuxServiceInteropProxyFactory = function();

Type.createClass(
    'DoubleTake.Communication.LinuxServiceInteropProxyFactory',
    DoubleTake.Communication.ProxyFactoryBase);

The LinuxServiceInteropProxyFactory type exposes the following members.

Constructors
 | Name | Description
Public method | LinuxServiceInteropProxyFactory | Initializes a new instance of the LinuxServiceInteropProxyFactory class
Public method | LinuxServiceInteropProxyFactory(IEndpointSpecification) | Initializes a new instance of the LinuxServiceInteropProxyFactory class
Top
Properties
 | Name | Description
Public property | Binding | (Inherited from ProxyFactoryBase.)
Public property | CloseTimeout | (Inherited from ProxyFactoryBase.)
Protected property | EndpointSpecification | (Inherited from ProxyFactoryBase.)
Public property | OpenTimeout | (Inherited from ProxyFactoryBase.)
Public property | ReceiveTimeout | (Inherited from ProxyFactoryBase.)
Public property | SendTimeout | (Inherited from ProxyFactoryBase.)
Top
Methods
 | Name | Description
Protected method | ApplyBehaviorsAndSecurity | (Overrides ProxyFactoryBaseApplyBehaviorsAndSecurity(ChannelFactory, NetworkCredential).)
Public method | CreateTChannel | (Inherited from ProxyFactoryBase.)
Public method | CreateClientTClient | (Inherited from ProxyFactoryBase.)
Protected method | CreateEndpointAddress | (Inherited from ProxyFactoryBase.)
Top
See Also

Reference

DoubleTake.Communication Namespace


LinuxServiceInteropProxyFactory Constructor

LinuxServiceInteropProxyFactory Constructor
Overload List
 | Name | Description
Public method | LinuxServiceInteropProxyFactory | Initializes a new instance of the LinuxServiceInteropProxyFactory class
Public method | LinuxServiceInteropProxyFactory(IEndpointSpecification) | Initializes a new instance of the LinuxServiceInteropProxyFactory class
Top
See Also

Reference

LinuxServiceInteropProxyFactory Class
DoubleTake.Communication Namespace


LinuxServiceInteropProxyFactory Constructor

LinuxServiceInteropProxyFactory Constructor
Initializes a new instance of the LinuxServiceInteropProxyFactory class

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public LinuxServiceInteropProxyFactory()
Public Sub New
public:
LinuxServiceInteropProxyFactory()
DoubleTake.Communication.LinuxServiceInteropProxyFactory = function();
See Also

Reference

LinuxServiceInteropProxyFactory Class
LinuxServiceInteropProxyFactory Overload
DoubleTake.Communication Namespace


LinuxServiceInteropProxyFactory Constructor (IEndpointSpecification)

LinuxServiceInteropProxyFactory Constructor (IEndpointSpecification)
Initializes a new instance of the LinuxServiceInteropProxyFactory class

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public LinuxServiceInteropProxyFactory(
    IEndpointSpecification endpointSpecification
)
Public Sub New (
    endpointSpecification As IEndpointSpecification
)
public:
LinuxServiceInteropProxyFactory(
    IEndpointSpecification^ endpointSpecification
)
DoubleTake.Communication.LinuxServiceInteropProxyFactory = function(endpointSpecification);

Parameters

endpointSpecification
Type: DoubleTake.CommunicationIEndpointSpecification
See Also

Reference

LinuxServiceInteropProxyFactory Class
LinuxServiceInteropProxyFactory Overload
DoubleTake.Communication Namespace


LinuxServiceInteropProxyFactory Properties

LinuxServiceInteropProxyFactory Properties

The LinuxServiceInteropProxyFactory type exposes the following members.

Properties
 | Name | Description
Public property | Binding | (Inherited from ProxyFactoryBase.)
Public property | CloseTimeout | (Inherited from ProxyFactoryBase.)
Protected property | EndpointSpecification | (Inherited from ProxyFactoryBase.)
Public property | OpenTimeout | (Inherited from ProxyFactoryBase.)
Public property | ReceiveTimeout | (Inherited from ProxyFactoryBase.)
Public property | SendTimeout | (Inherited from ProxyFactoryBase.)
Top
See Also

Reference

LinuxServiceInteropProxyFactory Class
DoubleTake.Communication Namespace


LinuxServiceInteropProxyFactory Methods

LinuxServiceInteropProxyFactory Methods

The LinuxServiceInteropProxyFactory type exposes the following members.

Methods
 | Name | Description
Protected method | ApplyBehaviorsAndSecurity | (Overrides ProxyFactoryBaseApplyBehaviorsAndSecurity(ChannelFactory, NetworkCredential).)
Public method | CreateTChannel | (Inherited from ProxyFactoryBase.)
Public method | CreateClientTClient | (Inherited from ProxyFactoryBase.)
Protected method | CreateEndpointAddress | (Inherited from ProxyFactoryBase.)
Top
See Also

Reference

LinuxServiceInteropProxyFactory Class
DoubleTake.Communication Namespace


LinuxServiceInteropProxyFactory.ApplyBehaviorsAndSecurity Method

LinuxServiceInteropProxyFactoryApplyBehaviorsAndSecurity Method

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
protected override void ApplyBehaviorsAndSecurity(
    ChannelFactory channelFactory,
    NetworkCredential credentials
)
Protected Overrides Sub ApplyBehaviorsAndSecurity (
    channelFactory As ChannelFactory,
    credentials As NetworkCredential
)
protected:
virtual void ApplyBehaviorsAndSecurity(
    ChannelFactory^ channelFactory,
    NetworkCredential^ credentials
) override
function ApplyBehaviorsAndSecurity(channelFactory, credentials);

Parameters

channelFactory
Type: System.ServiceModelChannelFactory
credentials
Type: System.NetNetworkCredential
See Also

Reference

LinuxServiceInteropProxyFactory Class
DoubleTake.Communication Namespace


MessageTracer Class

MessageTracer Class
Inheritance Hierarchy
SystemObject
DoubleTake.CommunicationMessageTracer

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class MessageTracer : IDispatchMessageInspector,
    IClientMessageInspector
Public Class MessageTracer
    Implements IDispatchMessageInspector, IClientMessageInspector
public ref class MessageTracer : IDispatchMessageInspector,
    IClientMessageInspector
DoubleTake.Communication.MessageTracer = function();

Type.createClass(
    'DoubleTake.Communication.MessageTracer',
    null,
    IDispatchMessageInspector,
    IClientMessageInspector);

The MessageTracer type exposes the following members.

Constructors
 | Name | Description
Public method | MessageTracer | Initializes a new instance of the MessageTracer class
Top
Methods
 | Name | Description
Public method | AfterReceiveReply |
Public method | AfterReceiveRequest |
Public method | BeforeSendReply |
Public method | BeforeSendRequest |
Top
See Also

Reference

DoubleTake.Communication Namespace


MessageTracer Constructor

MessageTracer Constructor
Initializes a new instance of the MessageTracer class

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public MessageTracer()
Public Sub New
public:
MessageTracer()
DoubleTake.Communication.MessageTracer = function();
See Also

Reference

MessageTracer Class
DoubleTake.Communication Namespace


MessageTracer Methods

MessageTracer Methods

The MessageTracer type exposes the following members.

Methods
 | Name | Description
Public method | AfterReceiveReply |
Public method | AfterReceiveRequest |
Public method | BeforeSendReply |
Public method | BeforeSendRequest |
Top
See Also

Reference

MessageTracer Class
DoubleTake.Communication Namespace


MessageTracer.AfterReceiveReply Method

MessageTracerAfterReceiveReply Method

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public void AfterReceiveReply(
    ref Message reply,
    Object correlationState
)
Public Sub AfterReceiveReply (
    ByRef reply As Message,
    correlationState As Object
)
public:
virtual void AfterReceiveReply(
    Message^% reply,
    Object^ correlationState
) sealed
function AfterReceiveReply(reply, correlationState);

Parameters

reply
Type: System.ServiceModel.ChannelsMessage
correlationState
Type: SystemObject

Implements

IClientMessageInspectorAfterReceiveReply(Message, Object)
See Also

Reference

MessageTracer Class
DoubleTake.Communication Namespace


MessageTracer.AfterReceiveRequest Method

MessageTracerAfterReceiveRequest Method

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Object AfterReceiveRequest(
    ref Message request,
    IClientChannel channel,
    InstanceContext instanceContext
)
Public Function AfterReceiveRequest (
    ByRef request As Message,
    channel As IClientChannel,
    instanceContext As InstanceContext
) As Object
public:
virtual Object^ AfterReceiveRequest(
    Message^% request,
    IClientChannel^ channel,
    InstanceContext^ instanceContext
) sealed
function AfterReceiveRequest(request, channel, instanceContext);

Parameters

request
Type: System.ServiceModel.ChannelsMessage
channel
Type: System.ServiceModelIClientChannel
instanceContext
Type: System.ServiceModelInstanceContext

Return Value

Type: Object

Implements

IDispatchMessageInspectorAfterReceiveRequest(Message, IClientChannel, InstanceContext)
See Also

Reference

MessageTracer Class
DoubleTake.Communication Namespace


MessageTracer.BeforeSendReply Method

MessageTracerBeforeSendReply Method

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public void BeforeSendReply(
    ref Message reply,
    Object correlationState
)
Public Sub BeforeSendReply (
    ByRef reply As Message,
    correlationState As Object
)
public:
virtual void BeforeSendReply(
    Message^% reply,
    Object^ correlationState
) sealed
function BeforeSendReply(reply, correlationState);

Parameters

reply
Type: System.ServiceModel.ChannelsMessage
correlationState
Type: SystemObject

Implements

IDispatchMessageInspectorBeforeSendReply(Message, Object)
See Also

Reference

MessageTracer Class
DoubleTake.Communication Namespace


MessageTracer.BeforeSendRequest Method

MessageTracerBeforeSendRequest Method

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Object BeforeSendRequest(
    ref Message request,
    IClientChannel channel
)
Public Function BeforeSendRequest (
    ByRef request As Message,
    channel As IClientChannel
) As Object
public:
virtual Object^ BeforeSendRequest(
    Message^% request,
    IClientChannel^ channel
) sealed
function BeforeSendRequest(request, channel);

Parameters

request
Type: System.ServiceModel.ChannelsMessage
channel
Type: System.ServiceModelIClientChannel

Return Value

Type: Object

Implements

IClientMessageInspectorBeforeSendRequest(Message, IClientChannel)
See Also

Reference

MessageTracer Class
DoubleTake.Communication Namespace


MessageTracingBehaviorAttribute Class

MessageTracingBehaviorAttribute Class
Inheritance Hierarchy
SystemObject
SystemAttribute
DoubleTake.CommunicationMessageTracingBehaviorAttribute

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public sealed class MessageTracingBehaviorAttribute : Attribute,
    IEndpointBehavior, IServiceBehavior
Public NotInheritable Class MessageTracingBehaviorAttribute
    Inherits Attribute
    Implements IEndpointBehavior, IServiceBehavior
public ref class MessageTracingBehaviorAttribute sealed : public Attribute,
    IEndpointBehavior, IServiceBehavior
DoubleTake.Communication.MessageTracingBehaviorAttribute = function();

Type.createClass(
    'DoubleTake.Communication.MessageTracingBehaviorAttribute',
    Attribute,
    IEndpointBehavior,
    IServiceBehavior);

The MessageTracingBehaviorAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | MessageTracingBehaviorAttribute | Initializes a new instance of the MessageTracingBehaviorAttribute class
Top
Methods
 | Name | Description
Public method | AddBindingParameters(ServiceEndpoint, BindingParameterCollection) |
Public method | AddBindingParameters(ServiceDescription, ServiceHostBase, CollectionServiceEndpoint, BindingParameterCollection) |
Public method | ApplyClientBehavior |
Public method | ApplyDispatchBehavior(ServiceDescription, ServiceHostBase) |
Public method | ApplyDispatchBehavior(ServiceEndpoint, EndpointDispatcher) |
Public method | Validate(ServiceEndpoint) |
Public method | Validate(ServiceDescription, ServiceHostBase) |
Top
See Also

Reference

DoubleTake.Communication Namespace


MessageTracingBehaviorAttribute Constructor

MessageTracingBehaviorAttribute Constructor
Initializes a new instance of the MessageTracingBehaviorAttribute class

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public MessageTracingBehaviorAttribute()
Public Sub New
public:
MessageTracingBehaviorAttribute()
DoubleTake.Communication.MessageTracingBehaviorAttribute = function();
See Also

Reference

MessageTracingBehaviorAttribute Class
DoubleTake.Communication Namespace


MessageTracingBehaviorAttribute Methods

MessageTracingBehaviorAttribute Methods

The MessageTracingBehaviorAttribute type exposes the following members.

Methods
 | Name | Description
Public method | AddBindingParameters(ServiceEndpoint, BindingParameterCollection) |
Public method | AddBindingParameters(ServiceDescription, ServiceHostBase, CollectionServiceEndpoint, BindingParameterCollection) |
Public method | ApplyClientBehavior |
Public method | ApplyDispatchBehavior(ServiceDescription, ServiceHostBase) |
Public method | ApplyDispatchBehavior(ServiceEndpoint, EndpointDispatcher) |
Public method | Validate(ServiceEndpoint) |
Public method | Validate(ServiceDescription, ServiceHostBase) |
Top
See Also

Reference

MessageTracingBehaviorAttribute Class
DoubleTake.Communication Namespace


MessageTracingBehaviorAttribute.AddBindingParameters Method

MessageTracingBehaviorAttributeAddBindingParameters Method
Overload List
 | Name | Description
Public method | AddBindingParameters(ServiceEndpoint, BindingParameterCollection) |
Public method | AddBindingParameters(ServiceDescription, ServiceHostBase, CollectionServiceEndpoint, BindingParameterCollection) |
Top
See Also

Reference

MessageTracingBehaviorAttribute Class
DoubleTake.Communication Namespace


MessageTracingBehaviorAttribute.AddBindingParameters Method (ServiceEndpoint, BindingParameterCollection)

MessageTracingBehaviorAttributeAddBindingParameters Method (ServiceEndpoint, BindingParameterCollection)

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public void AddBindingParameters(
    ServiceEndpoint endpoint,
    BindingParameterCollection bindingParameters
)
Public Sub AddBindingParameters (
    endpoint As ServiceEndpoint,
    bindingParameters As BindingParameterCollection
)
public:
virtual void AddBindingParameters(
    ServiceEndpoint^ endpoint,
    BindingParameterCollection^ bindingParameters
) sealed
function AddBindingParameters(endpoint, bindingParameters);

Parameters

endpoint
Type: System.ServiceModel.DescriptionServiceEndpoint
bindingParameters
Type: System.ServiceModel.ChannelsBindingParameterCollection

Implements

IEndpointBehaviorAddBindingParameters(ServiceEndpoint, BindingParameterCollection)
See Also

Reference

MessageTracingBehaviorAttribute Class
AddBindingParameters Overload
DoubleTake.Communication Namespace


MessageTracingBehaviorAttribute.AddBindingParameters Method (ServiceDescription, ServiceHostBase, Collection(ServiceEndpoint), BindingParameterCollection)

MessageTracingBehaviorAttributeAddBindingParameters Method (ServiceDescription, ServiceHostBase, CollectionServiceEndpoint, BindingParameterCollection)

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public void AddBindingParameters(
    ServiceDescription serviceDescription,
    ServiceHostBase serviceHostBase,
    Collection<ServiceEndpoint> endpoints,
    BindingParameterCollection bindingParameters
)
Public Sub AddBindingParameters (
    serviceDescription As ServiceDescription,
    serviceHostBase As ServiceHostBase,
    endpoints As Collection(Of ServiceEndpoint),
    bindingParameters As BindingParameterCollection
)
public:
virtual void AddBindingParameters(
    ServiceDescription^ serviceDescription,
    ServiceHostBase^ serviceHostBase,
    Collection<ServiceEndpoint^>^ endpoints,
    BindingParameterCollection^ bindingParameters
) sealed
function AddBindingParameters(serviceDescription, serviceHostBase, endpoints, bindingParameters);

Parameters

serviceDescription
Type: System.ServiceModel.DescriptionServiceDescription
serviceHostBase
Type: System.ServiceModelServiceHostBase
endpoints
Type: System.Collections.ObjectModelCollection ServiceEndpoint
bindingParameters
Type: System.ServiceModel.ChannelsBindingParameterCollection

Implements

IServiceBehaviorAddBindingParameters(ServiceDescription, ServiceHostBase, CollectionServiceEndpoint, BindingParameterCollection)
See Also

Reference

MessageTracingBehaviorAttribute Class
AddBindingParameters Overload
DoubleTake.Communication Namespace


MessageTracingBehaviorAttribute.ApplyClientBehavior Method

MessageTracingBehaviorAttributeApplyClientBehavior Method

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public void ApplyClientBehavior(
    ServiceEndpoint endpoint,
    ClientRuntime clientRuntime
)
Public Sub ApplyClientBehavior (
    endpoint As ServiceEndpoint,
    clientRuntime As ClientRuntime
)
public:
virtual void ApplyClientBehavior(
    ServiceEndpoint^ endpoint,
    ClientRuntime^ clientRuntime
) sealed
function ApplyClientBehavior(endpoint, clientRuntime);

Parameters

endpoint
Type: System.ServiceModel.DescriptionServiceEndpoint
clientRuntime
Type: System.ServiceModel.DispatcherClientRuntime

Implements

IEndpointBehaviorApplyClientBehavior(ServiceEndpoint, ClientRuntime)
See Also

Reference

MessageTracingBehaviorAttribute Class
DoubleTake.Communication Namespace


MessageTracingBehaviorAttribute.ApplyDispatchBehavior Method

MessageTracingBehaviorAttributeApplyDispatchBehavior Method
Overload List
 | Name | Description
Public method | ApplyDispatchBehavior(ServiceDescription, ServiceHostBase) |
Public method | ApplyDispatchBehavior(ServiceEndpoint, EndpointDispatcher) |
Top
See Also

Reference

MessageTracingBehaviorAttribute Class
DoubleTake.Communication Namespace


MessageTracingBehaviorAttribute.ApplyDispatchBehavior Method (ServiceDescription, ServiceHostBase)

MessageTracingBehaviorAttributeApplyDispatchBehavior Method (ServiceDescription, ServiceHostBase)

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public void ApplyDispatchBehavior(
    ServiceDescription serviceDescription,
    ServiceHostBase serviceHostBase
)
Public Sub ApplyDispatchBehavior (
    serviceDescription As ServiceDescription,
    serviceHostBase As ServiceHostBase
)
public:
virtual void ApplyDispatchBehavior(
    ServiceDescription^ serviceDescription,
    ServiceHostBase^ serviceHostBase
) sealed
function ApplyDispatchBehavior(serviceDescription, serviceHostBase);

Parameters

serviceDescription
Type: System.ServiceModel.DescriptionServiceDescription
serviceHostBase
Type: System.ServiceModelServiceHostBase

Implements

IServiceBehaviorApplyDispatchBehavior(ServiceDescription, ServiceHostBase)
See Also

Reference

MessageTracingBehaviorAttribute Class
ApplyDispatchBehavior Overload
DoubleTake.Communication Namespace


MessageTracingBehaviorAttribute.ApplyDispatchBehavior Method (ServiceEndpoint, EndpointDispatcher)

MessageTracingBehaviorAttributeApplyDispatchBehavior Method (ServiceEndpoint, EndpointDispatcher)

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public void ApplyDispatchBehavior(
    ServiceEndpoint endpoint,
    EndpointDispatcher endpointDispatcher
)
Public Sub ApplyDispatchBehavior (
    endpoint As ServiceEndpoint,
    endpointDispatcher As EndpointDispatcher
)
public:
virtual void ApplyDispatchBehavior(
    ServiceEndpoint^ endpoint,
    EndpointDispatcher^ endpointDispatcher
) sealed
function ApplyDispatchBehavior(endpoint, endpointDispatcher);

Parameters

endpoint
Type: System.ServiceModel.DescriptionServiceEndpoint
endpointDispatcher
Type: System.ServiceModel.DispatcherEndpointDispatcher

Implements

IEndpointBehaviorApplyDispatchBehavior(ServiceEndpoint, EndpointDispatcher)
See Also

Reference

MessageTracingBehaviorAttribute Class
ApplyDispatchBehavior Overload
DoubleTake.Communication Namespace


MessageTracingBehaviorAttribute.Validate Method

MessageTracingBehaviorAttributeValidate Method
Overload List
 | Name | Description
Public method | Validate(ServiceEndpoint) |
Public method | Validate(ServiceDescription, ServiceHostBase) |
Top
See Also

Reference

MessageTracingBehaviorAttribute Class
DoubleTake.Communication Namespace


MessageTracingBehaviorAttribute.Validate Method (ServiceEndpoint)

MessageTracingBehaviorAttributeValidate Method (ServiceEndpoint)

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public void Validate(
    ServiceEndpoint endpoint
)
Public Sub Validate (
    endpoint As ServiceEndpoint
)
public:
virtual void Validate(
    ServiceEndpoint^ endpoint
) sealed
function Validate(endpoint);

Parameters

endpoint
Type: System.ServiceModel.DescriptionServiceEndpoint

Implements

IEndpointBehaviorValidate(ServiceEndpoint)
See Also

Reference

MessageTracingBehaviorAttribute Class
Validate Overload
DoubleTake.Communication Namespace


MessageTracingBehaviorAttribute.Validate Method (ServiceDescription, ServiceHostBase)

MessageTracingBehaviorAttributeValidate Method (ServiceDescription, ServiceHostBase)

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public void Validate(
    ServiceDescription serviceDescription,
    ServiceHostBase serviceHostBase
)
Public Sub Validate (
    serviceDescription As ServiceDescription,
    serviceHostBase As ServiceHostBase
)
public:
virtual void Validate(
    ServiceDescription^ serviceDescription,
    ServiceHostBase^ serviceHostBase
) sealed
function Validate(serviceDescription, serviceHostBase);

Parameters

serviceDescription
Type: System.ServiceModel.DescriptionServiceDescription
serviceHostBase
Type: System.ServiceModelServiceHostBase

Implements

IServiceBehaviorValidate(ServiceDescription, ServiceHostBase)
See Also

Reference

MessageTracingBehaviorAttribute Class
Validate Overload
DoubleTake.Communication Namespace


ProxyFactory Class

ProxyFactory Class
Inheritance Hierarchy
SystemObject
DoubleTake.CommunicationProxyFactoryBase
DoubleTake.CommunicationProxyFactory

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class ProxyFactory : ProxyFactoryBase
Public Class ProxyFactory
    Inherits ProxyFactoryBase
public ref class ProxyFactory : public ProxyFactoryBase
DoubleTake.Communication.ProxyFactory = function();

Type.createClass(
    'DoubleTake.Communication.ProxyFactory',
    DoubleTake.Communication.ProxyFactoryBase);

The ProxyFactory type exposes the following members.

Constructors
 | Name | Description
Public method | ProxyFactory | Initializes a new instance of the ProxyFactory class
Public method | ProxyFactory(IEndpointSpecification) | Initializes a new instance of the ProxyFactory class
Top
Properties
 | Name | Description
Public property | Binding | (Inherited from ProxyFactoryBase.)
Public property | CloseTimeout | (Inherited from ProxyFactoryBase.)
Protected property | EndpointSpecification | (Inherited from ProxyFactoryBase.)
Public property | OpenTimeout | (Inherited from ProxyFactoryBase.)
Public property | ReceiveTimeout | (Inherited from ProxyFactoryBase.)
Public property | SendTimeout | (Inherited from ProxyFactoryBase.)
Top
Methods
 | Name | Description
Protected method | ApplyBehaviorsAndSecurity | (Overrides ProxyFactoryBaseApplyBehaviorsAndSecurity(ChannelFactory, NetworkCredential).)
Public method | CreateTChannel | (Inherited from ProxyFactoryBase.)
Public method | CreateClientTClient | (Inherited from ProxyFactoryBase.)
Protected method | CreateEndpointAddress | (Inherited from ProxyFactoryBase.)
Top
See Also

Reference

DoubleTake.Communication Namespace


ProxyFactory Constructor

ProxyFactory Constructor
Overload List
 | Name | Description
Public method | ProxyFactory | Initializes a new instance of the ProxyFactory class
Public method | ProxyFactory(IEndpointSpecification) | Initializes a new instance of the ProxyFactory class
Top
See Also

Reference

ProxyFactory Class
DoubleTake.Communication Namespace


ProxyFactory Constructor

ProxyFactory Constructor
Initializes a new instance of the ProxyFactory class

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ProxyFactory()
Public Sub New
public:
ProxyFactory()
DoubleTake.Communication.ProxyFactory = function();
See Also

Reference

ProxyFactory Class
ProxyFactory Overload
DoubleTake.Communication Namespace


ProxyFactory Constructor (IEndpointSpecification)

ProxyFactory Constructor (IEndpointSpecification)
Initializes a new instance of the ProxyFactory class

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ProxyFactory(
    IEndpointSpecification endpointSpecification
)
Public Sub New (
    endpointSpecification As IEndpointSpecification
)
public:
ProxyFactory(
    IEndpointSpecification^ endpointSpecification
)
DoubleTake.Communication.ProxyFactory = function(endpointSpecification);

Parameters

endpointSpecification
Type: DoubleTake.CommunicationIEndpointSpecification
See Also

Reference

ProxyFactory Class
ProxyFactory Overload
DoubleTake.Communication Namespace


ProxyFactory Properties

ProxyFactory Properties

The ProxyFactory type exposes the following members.

Properties
 | Name | Description
Public property | Binding | (Inherited from ProxyFactoryBase.)
Public property | CloseTimeout | (Inherited from ProxyFactoryBase.)
Protected property | EndpointSpecification | (Inherited from ProxyFactoryBase.)
Public property | OpenTimeout | (Inherited from ProxyFactoryBase.)
Public property | ReceiveTimeout | (Inherited from ProxyFactoryBase.)
Public property | SendTimeout | (Inherited from ProxyFactoryBase.)
Top
See Also

Reference

ProxyFactory Class
DoubleTake.Communication Namespace


ProxyFactory Methods

ProxyFactory Methods

The ProxyFactory type exposes the following members.

Methods
 | Name | Description
Protected method | ApplyBehaviorsAndSecurity | (Overrides ProxyFactoryBaseApplyBehaviorsAndSecurity(ChannelFactory, NetworkCredential).)
Public method | CreateTChannel | (Inherited from ProxyFactoryBase.)
Public method | CreateClientTClient | (Inherited from ProxyFactoryBase.)
Protected method | CreateEndpointAddress | (Inherited from ProxyFactoryBase.)
Top
See Also

Reference

ProxyFactory Class
DoubleTake.Communication Namespace


ProxyFactory.ApplyBehaviorsAndSecurity Method

ProxyFactoryApplyBehaviorsAndSecurity Method

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
protected override void ApplyBehaviorsAndSecurity(
    ChannelFactory channelFactory,
    NetworkCredential credentials
)
Protected Overrides Sub ApplyBehaviorsAndSecurity (
    channelFactory As ChannelFactory,
    credentials As NetworkCredential
)
protected:
virtual void ApplyBehaviorsAndSecurity(
    ChannelFactory^ channelFactory,
    NetworkCredential^ credentials
) override
function ApplyBehaviorsAndSecurity(channelFactory, credentials);

Parameters

channelFactory
Type: System.ServiceModelChannelFactory
credentials
Type: System.NetNetworkCredential
See Also

Reference

ProxyFactory Class
DoubleTake.Communication Namespace


ProxyFactoryBase Class

ProxyFactoryBase Class
Inheritance Hierarchy
SystemObject
DoubleTake.CommunicationProxyFactoryBase
DoubleTake.CommunicationLinuxServiceInteropProxyFactory
DoubleTake.CommunicationProxyFactory

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public abstract class ProxyFactoryBase : IProxyFactory
Public MustInherit Class ProxyFactoryBase
    Implements IProxyFactory
public ref class ProxyFactoryBase abstract : IProxyFactory
DoubleTake.Communication.ProxyFactoryBase = function();

Type.createClass(
    'DoubleTake.Communication.ProxyFactoryBase',
    null,
    DoubleTake.Communication.IProxyFactory);

The ProxyFactoryBase type exposes the following members.

Constructors
 | Name | Description
Protected method | ProxyFactoryBase | Initializes a new instance of the ProxyFactoryBase class
Top
Properties
 | Name | Description
Public property | Binding |
Public property | CloseTimeout |
Protected property | EndpointSpecification |
Public property | OpenTimeout |
Public property | ReceiveTimeout |
Public property | SendTimeout |
Top
Methods
 | Name | Description
Protected method | ApplyBehaviorsAndSecurity |
Public method | CreateTChannel |
Public method | CreateClientTClient |
Protected method | CreateEndpointAddress |
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateTChannel(Uri) | Overloaded. (Defined by ProxyFactoryExtensions.)
Public Extension Method | CreateTChannel(ServiceConnectionParameters) | Overloaded. (Defined by ProxyFactoryExtensions.)
Public Extension Method | CreateTChannel(Uri, AddressingScheme) | Overloaded. (Defined by ProxyFactoryExtensions.)
Public Extension Method | CreateTChannel(ServiceConnectionParameters, Uri) | Overloaded. (Defined by ProxyFactoryExtensions.)
Public Extension Method | CreateTChannel(ServiceConnectionParameters, AddressingScheme) | Overloaded. (Defined by ProxyFactoryExtensions.)
Public Extension Method | CreateClientTClient(Uri) | Overloaded. (Defined by ProxyFactoryExtensions.)
Public Extension Method | CreateClientTClient(Uri, AddressingScheme) | Overloaded. (Defined by ProxyFactoryExtensions.)
Public Extension Method | CreateClientTClient(Uri, Uri) | Overloaded. (Defined by ProxyFactoryExtensions.)
Public Extension Method | UsingTChannel(Uri, ActionTChannel) | Overloaded. (Defined by ProxyFactoryExtensions.)
Public Extension Method | UsingTChannel(ServiceConnectionParameters, ActionTChannel) | Overloaded. (Defined by ProxyFactoryExtensions.)
Public Extension Method | UsingTChannel(Uri, Uri, ActionTChannel) | Overloaded. (Defined by ProxyFactoryExtensions.)
Public Extension Method | UsingTChannel(Uri, AddressingScheme, ActionTChannel) | Overloaded. (Defined by ProxyFactoryExtensions.)
Public Extension Method | UsingTChannel(ServiceConnectionParameters, Uri, ActionTChannel) | Overloaded. (Defined by ProxyFactoryExtensions.)
Public Extension Method | UsingTChannel, TResult(Uri, FuncTChannel, TResult) | Overloaded. (Defined by ProxyFactoryExtensions.)
Public Extension Method | UsingTChannel, TResult(ServiceConnectionParameters, FuncTChannel, TResult) | Overloaded. (Defined by ProxyFactoryExtensions.)
Public Extension Method | UsingTChannel, TResult(Uri, Uri, FuncTChannel, TResult) | Overloaded. (Defined by ProxyFactoryExtensions.)
Public Extension Method | UsingTChannel, TResult(Uri, AddressingScheme, FuncTChannel, TResult) | Overloaded. (Defined by ProxyFactoryExtensions.)
Public Extension Method | UsingTChannel, TResult(ServiceConnectionParameters, Uri, FuncTChannel, TResult) | Overloaded. (Defined by ProxyFactoryExtensions.)
Top
See Also

Reference

DoubleTake.Communication Namespace


ProxyFactoryBase Constructor

ProxyFactoryBase Constructor
Initializes a new instance of the ProxyFactoryBase class

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
protected ProxyFactoryBase(
    IEndpointSpecification endpointSpecification
)
Protected Sub New (
    endpointSpecification As IEndpointSpecification
)
protected:
ProxyFactoryBase(
    IEndpointSpecification^ endpointSpecification
)
DoubleTake.Communication.ProxyFactoryBase = function(endpointSpecification);

Parameters

endpointSpecification
Type: DoubleTake.CommunicationIEndpointSpecification
See Also

Reference

ProxyFactoryBase Class
DoubleTake.Communication Namespace


ProxyFactoryBase Properties

ProxyFactoryBase Properties

The ProxyFactoryBase type exposes the following members.

Properties
 | Name | Description
Public property | Binding |
Public property | CloseTimeout |
Protected property | EndpointSpecification |
Public property | OpenTimeout |
Public property | ReceiveTimeout |
Public property | SendTimeout |
Top
See Also

Reference

ProxyFactoryBase Class
DoubleTake.Communication Namespace


ProxyFactoryBase.Binding Property

ProxyFactoryBaseBinding Property

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Binding Binding { get; }
Public ReadOnly Property Binding As Binding
    Get
public:
property Binding^ Binding {
    Binding^ get ();
}
function get_Binding();

Property Value

Type: Binding
See Also

Reference

ProxyFactoryBase Class
DoubleTake.Communication Namespace


ProxyFactoryBase.CloseTimeout Property

ProxyFactoryBaseCloseTimeout Property

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public TimeSpan CloseTimeout { get; set; }
Public Property CloseTimeout As TimeSpan
    Get
    Set
public:
virtual property TimeSpan CloseTimeout {
    TimeSpan get () sealed;
    void set (TimeSpan value) sealed;
}
function get_CloseTimeout();
function set_CloseTimeout(value);

Property Value

Type: TimeSpan

Implements

IProxyFactoryCloseTimeout
See Also

Reference

ProxyFactoryBase Class
DoubleTake.Communication Namespace


ProxyFactoryBase.EndpointSpecification Property

ProxyFactoryBaseEndpointSpecification Property

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
protected IEndpointSpecification EndpointSpecification { get; }
Protected ReadOnly Property EndpointSpecification As IEndpointSpecification
    Get
protected:
property IEndpointSpecification^ EndpointSpecification {
    IEndpointSpecification^ get ();
}
function get_EndpointSpecification();

Property Value

Type: IEndpointSpecification
See Also

Reference

ProxyFactoryBase Class
DoubleTake.Communication Namespace


ProxyFactoryBase.OpenTimeout Property

ProxyFactoryBaseOpenTimeout Property

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public TimeSpan OpenTimeout { get; set; }
Public Property OpenTimeout As TimeSpan
    Get
    Set
public:
virtual property TimeSpan OpenTimeout {
    TimeSpan get () sealed;
    void set (TimeSpan value) sealed;
}
function get_OpenTimeout();
function set_OpenTimeout(value);

Property Value

Type: TimeSpan

Implements

IProxyFactoryOpenTimeout
See Also

Reference

ProxyFactoryBase Class
DoubleTake.Communication Namespace


ProxyFactoryBase.ReceiveTimeout Property

ProxyFactoryBaseReceiveTimeout Property

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public TimeSpan ReceiveTimeout { get; set; }
Public Property ReceiveTimeout As TimeSpan
    Get
    Set
public:
virtual property TimeSpan ReceiveTimeout {
    TimeSpan get () sealed;
    void set (TimeSpan value) sealed;
}
function get_ReceiveTimeout();
function set_ReceiveTimeout(value);

Property Value

Type: TimeSpan

Implements

IProxyFactoryReceiveTimeout
See Also

Reference

ProxyFactoryBase Class
DoubleTake.Communication Namespace


ProxyFactoryBase.SendTimeout Property

ProxyFactoryBaseSendTimeout Property

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public TimeSpan SendTimeout { get; set; }
Public Property SendTimeout As TimeSpan
    Get
    Set
public:
virtual property TimeSpan SendTimeout {
    TimeSpan get () sealed;
    void set (TimeSpan value) sealed;
}
function get_SendTimeout();
function set_SendTimeout(value);

Property Value

Type: TimeSpan

Implements

IProxyFactorySendTimeout
See Also

Reference

ProxyFactoryBase Class
DoubleTake.Communication Namespace


ProxyFactoryBase Methods

ProxyFactoryBase Methods

The ProxyFactoryBase type exposes the following members.

Methods
 | Name | Description
Protected method | ApplyBehaviorsAndSecurity |
Public method | CreateTChannel |
Public method | CreateClientTClient |
Protected method | CreateEndpointAddress |
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateTChannel(Uri) | Overloaded. (Defined by ProxyFactoryExtensions.)
Public Extension Method | CreateTChannel(ServiceConnectionParameters) | Overloaded. (Defined by ProxyFactoryExtensions.)
Public Extension Method | CreateTChannel(Uri, AddressingScheme) | Overloaded. (Defined by ProxyFactoryExtensions.)
Public Extension Method | CreateTChannel(ServiceConnectionParameters, Uri) | Overloaded. (Defined by ProxyFactoryExtensions.)
Public Extension Method | CreateTChannel(ServiceConnectionParameters, AddressingScheme) | Overloaded. (Defined by ProxyFactoryExtensions.)
Public Extension Method | CreateClientTClient(Uri) | Overloaded. (Defined by ProxyFactoryExtensions.)
Public Extension Method | CreateClientTClient(Uri, AddressingScheme) | Overloaded. (Defined by ProxyFactoryExtensions.)
Public Extension Method | CreateClientTClient(Uri, Uri) | Overloaded. (Defined by ProxyFactoryExtensions.)
Public Extension Method | UsingTChannel(Uri, ActionTChannel) | Overloaded. (Defined by ProxyFactoryExtensions.)
Public Extension Method | UsingTChannel(ServiceConnectionParameters, ActionTChannel) | Overloaded. (Defined by ProxyFactoryExtensions.)
Public Extension Method | UsingTChannel(Uri, Uri, ActionTChannel) | Overloaded. (Defined by ProxyFactoryExtensions.)
Public Extension Method | UsingTChannel(Uri, AddressingScheme, ActionTChannel) | Overloaded. (Defined by ProxyFactoryExtensions.)
Public Extension Method | UsingTChannel(ServiceConnectionParameters, Uri, ActionTChannel) | Overloaded. (Defined by ProxyFactoryExtensions.)
Public Extension Method | UsingTChannel, TResult(Uri, FuncTChannel, TResult) | Overloaded. (Defined by ProxyFactoryExtensions.)
Public Extension Method | UsingTChannel, TResult(ServiceConnectionParameters, FuncTChannel, TResult) | Overloaded. (Defined by ProxyFactoryExtensions.)
Public Extension Method | UsingTChannel, TResult(Uri, Uri, FuncTChannel, TResult) | Overloaded. (Defined by ProxyFactoryExtensions.)
Public Extension Method | UsingTChannel, TResult(Uri, AddressingScheme, FuncTChannel, TResult) | Overloaded. (Defined by ProxyFactoryExtensions.)
Public Extension Method | UsingTChannel, TResult(ServiceConnectionParameters, Uri, FuncTChannel, TResult) | Overloaded. (Defined by ProxyFactoryExtensions.)
Top
See Also

Reference

ProxyFactoryBase Class
DoubleTake.Communication Namespace


ProxyFactoryBase.ApplyBehaviorsAndSecurity Method

ProxyFactoryBaseApplyBehaviorsAndSecurity Method

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
protected abstract void ApplyBehaviorsAndSecurity(
    ChannelFactory channelFactory,
    NetworkCredential credentials
)
Protected MustOverride Sub ApplyBehaviorsAndSecurity (
    channelFactory As ChannelFactory,
    credentials As NetworkCredential
)
protected:
virtual void ApplyBehaviorsAndSecurity(
    ChannelFactory^ channelFactory,
    NetworkCredential^ credentials
) abstract
function ApplyBehaviorsAndSecurity(channelFactory, credentials);

Parameters

channelFactory
Type: System.ServiceModelChannelFactory
credentials
Type: System.NetNetworkCredential
See Also

Reference

ProxyFactoryBase Class
DoubleTake.Communication Namespace


ProxyFactoryBase.Create(TChannel) Method

ProxyFactoryBaseCreateTChannel Method

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public TChannel Create<TChannel>(
    Uri hostUri,
    Uri relativeUri
)
where TChannel : class

Public Function Create(Of TChannel As Class) (
    hostUri As Uri,
    relativeUri As Uri
) As TChannel
public:
generic<typename TChannel>
where TChannel : ref class
virtual TChannel Create(
    Uri^ hostUri,
    Uri^ relativeUri
) sealed
JavaScript does not support generic types or methods.

Parameters

hostUri
Type: SystemUri
relativeUri
Type: SystemUri

Type Parameters

TChannel

Return Value

Type: TChannel

Implements

IProxyFactoryCreateTChannel(Uri, Uri)
See Also

Reference

ProxyFactoryBase Class
DoubleTake.Communication Namespace


ProxyFactoryBase.CreateClient(TClient) Method

ProxyFactoryBaseCreateClientTClient Method

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public TClient CreateClient<TClient>(
    Uri hostUri,
    Uri relativeUri
)
where TClient : class

Public Function CreateClient(Of TClient As Class) (
    hostUri As Uri,
    relativeUri As Uri
) As TClient
public:
generic<typename TClient>
where TClient : ref class
virtual TClient CreateClient(
    Uri^ hostUri,
    Uri^ relativeUri
) sealed
JavaScript does not support generic types or methods.

Parameters

hostUri
Type: SystemUri
relativeUri
Type: SystemUri

Type Parameters

TClient

Return Value

Type: TClient

Implements

IProxyFactoryCreateClientTClient(Uri, Uri)
See Also

Reference

ProxyFactoryBase Class
DoubleTake.Communication Namespace


ProxyFactoryBase.CreateEndpointAddress Method

ProxyFactoryBaseCreateEndpointAddress Method

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
protected virtual EndpointAddress CreateEndpointAddress(
    Uri endpointUri
)
Protected Overridable Function CreateEndpointAddress (
    endpointUri As Uri
) As EndpointAddress
protected:
virtual EndpointAddress^ CreateEndpointAddress(
    Uri^ endpointUri
)
function CreateEndpointAddress(endpointUri);

Parameters

endpointUri
Type: SystemUri

Return Value

Type: EndpointAddress
See Also

Reference

ProxyFactoryBase Class
DoubleTake.Communication Namespace


ProxyFactoryExtensions Class

ProxyFactoryExtensions Class
Inheritance Hierarchy
SystemObject
DoubleTake.CommunicationProxyFactoryExtensions

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public static class ProxyFactoryExtensions
<ExtensionAttribute>
Public NotInheritable Class ProxyFactoryExtensions
[ExtensionAttribute]
public ref class ProxyFactoryExtensions abstract sealed
DoubleTake.Communication.ProxyFactoryExtensions = function();

Type.createClass(
    'DoubleTake.Communication.ProxyFactoryExtensions');
Methods
Name | Description
CreateTChannel(IProxyFactory, ServiceConnectionParameters) |
CreateTChannel(IProxyFactory, Uri) |
CreateTChannel(IProxyFactory, ServiceConnectionParameters, AddressingScheme) |
CreateTChannel(IProxyFactory, ServiceConnectionParameters, Uri) |
CreateTChannel(IProxyFactory, Uri, AddressingScheme) |
CreateClientTClient(IProxyFactory, Uri) |
CreateClientTClient(IProxyFactory, Uri, AddressingScheme) |
CreateClientTClient(IProxyFactory, Uri, Uri) |
UsingTChannel(IProxyFactory, ServiceConnectionParameters, ActionTChannel) |
UsingTChannel(IProxyFactory, Uri, ActionTChannel) |
UsingTChannel(IProxyFactory, ServiceConnectionParameters, Uri, ActionTChannel) |
UsingTChannel(IProxyFactory, Uri, AddressingScheme, ActionTChannel) |
UsingTChannel(IProxyFactory, Uri, Uri, ActionTChannel) |
UsingTChannel, TResult(IProxyFactory, ServiceConnectionParameters, FuncTChannel, TResult) |
UsingTChannel, TResult(IProxyFactory, Uri, FuncTChannel, TResult) |
UsingTChannel, TResult(IProxyFactory, ServiceConnectionParameters, Uri, FuncTChannel, TResult) |
UsingTChannel, TResult(IProxyFactory, Uri, AddressingScheme, FuncTChannel, TResult) |
UsingTChannel, TResult(IProxyFactory, Uri, Uri, FuncTChannel, TResult) |
Top
See Also

Reference

DoubleTake.Communication Namespace


ProxyFactoryExtensions Methods

ProxyFactoryExtensions Methods
Methods
Name | Description
CreateTChannel(IProxyFactory, ServiceConnectionParameters) |
CreateTChannel(IProxyFactory, Uri) |
CreateTChannel(IProxyFactory, ServiceConnectionParameters, AddressingScheme) |
CreateTChannel(IProxyFactory, ServiceConnectionParameters, Uri) |
CreateTChannel(IProxyFactory, Uri, AddressingScheme) |
CreateClientTClient(IProxyFactory, Uri) |
CreateClientTClient(IProxyFactory, Uri, AddressingScheme) |
CreateClientTClient(IProxyFactory, Uri, Uri) |
UsingTChannel(IProxyFactory, ServiceConnectionParameters, ActionTChannel) |
UsingTChannel(IProxyFactory, Uri, ActionTChannel) |
UsingTChannel(IProxyFactory, ServiceConnectionParameters, Uri, ActionTChannel) |
UsingTChannel(IProxyFactory, Uri, AddressingScheme, ActionTChannel) |
UsingTChannel(IProxyFactory, Uri, Uri, ActionTChannel) |
UsingTChannel, TResult(IProxyFactory, ServiceConnectionParameters, FuncTChannel, TResult) |
UsingTChannel, TResult(IProxyFactory, Uri, FuncTChannel, TResult) |
UsingTChannel, TResult(IProxyFactory, ServiceConnectionParameters, Uri, FuncTChannel, TResult) |
UsingTChannel, TResult(IProxyFactory, Uri, AddressingScheme, FuncTChannel, TResult) |
UsingTChannel, TResult(IProxyFactory, Uri, Uri, FuncTChannel, TResult) |
Top
See Also

Reference

ProxyFactoryExtensions Class
DoubleTake.Communication Namespace


ProxyFactoryExtensions.Create Method

ProxyFactoryExtensionsCreate Method
Overload List
Name | Description
CreateTChannel(IProxyFactory, ServiceConnectionParameters) |
CreateTChannel(IProxyFactory, Uri) |
CreateTChannel(IProxyFactory, ServiceConnectionParameters, AddressingScheme) |
CreateTChannel(IProxyFactory, ServiceConnectionParameters, Uri) |
CreateTChannel(IProxyFactory, Uri, AddressingScheme) |
Top
See Also

Reference

ProxyFactoryExtensions Class
DoubleTake.Communication Namespace


ProxyFactoryExtensions.Create(TChannel) Method (IProxyFactory, ServiceConnectionParameters)

ProxyFactoryExtensionsCreateTChannel Method (IProxyFactory, ServiceConnectionParameters)

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public static TChannel Create<TChannel>(
    this IProxyFactory factory,
    ServiceConnectionParameters parameters
)
where TChannel : class

<ExtensionAttribute>
Public Shared Function Create(Of TChannel As Class) (
    factory As IProxyFactory,
    parameters As ServiceConnectionParameters
) As TChannel
public:
[ExtensionAttribute]
generic<typename TChannel>
where TChannel : ref class
static TChannel Create(
    IProxyFactory^ factory,
    ServiceConnectionParameters^ parameters
)
JavaScript does not support generic types or methods.

Parameters

factory
Type: DoubleTake.CommunicationIProxyFactory
parameters
Type: DoubleTake.CommunicationServiceConnectionParameters

Type Parameters

TChannel

Return Value

Type: TChannel

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IProxyFactory. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ProxyFactoryExtensions Class
Create Overload
DoubleTake.Communication Namespace


ProxyFactoryExtensions.Create(TChannel) Method (IProxyFactory, Uri)

ProxyFactoryExtensionsCreateTChannel Method (IProxyFactory, Uri)

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public static TChannel Create<TChannel>(
    this IProxyFactory factory,
    Uri hostUri
)
where TChannel : class

<ExtensionAttribute>
Public Shared Function Create(Of TChannel As Class) (
    factory As IProxyFactory,
    hostUri As Uri
) As TChannel
public:
[ExtensionAttribute]
generic<typename TChannel>
where TChannel : ref class
static TChannel Create(
    IProxyFactory^ factory,
    Uri^ hostUri
)
JavaScript does not support generic types or methods.

Parameters

factory
Type: DoubleTake.CommunicationIProxyFactory
hostUri
Type: SystemUri

Type Parameters

TChannel

Return Value

Type: TChannel

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IProxyFactory. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ProxyFactoryExtensions Class
Create Overload
DoubleTake.Communication Namespace


ProxyFactoryExtensions.Create(TChannel) Method (IProxyFactory, ServiceConnectionParameters, AddressingScheme)

ProxyFactoryExtensionsCreateTChannel Method (IProxyFactory, ServiceConnectionParameters, AddressingScheme)

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public static TChannel Create<TChannel>(
    this IProxyFactory factory,
    ServiceConnectionParameters parameters,
    AddressingScheme scheme
)
where TChannel : class

<ExtensionAttribute>
Public Shared Function Create(Of TChannel As Class) (
    factory As IProxyFactory,
    parameters As ServiceConnectionParameters,
    scheme As AddressingScheme
) As TChannel
public:
[ExtensionAttribute]
generic<typename TChannel>
where TChannel : ref class
static TChannel Create(
    IProxyFactory^ factory,
    ServiceConnectionParameters^ parameters,
    AddressingScheme scheme
)
JavaScript does not support generic types or methods.

Parameters

factory
Type: DoubleTake.CommunicationIProxyFactory
parameters
Type: DoubleTake.CommunicationServiceConnectionParameters
scheme
Type: DoubleTake.CommunicationAddressingScheme

Type Parameters

TChannel

Return Value

Type: TChannel

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IProxyFactory. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ProxyFactoryExtensions Class
Create Overload
DoubleTake.Communication Namespace


ProxyFactoryExtensions.Create(TChannel) Method (IProxyFactory, ServiceConnectionParameters, Uri)

ProxyFactoryExtensionsCreateTChannel Method (IProxyFactory, ServiceConnectionParameters, Uri)

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public static TChannel Create<TChannel>(
    this IProxyFactory factory,
    ServiceConnectionParameters parameters,
    Uri relativeUri
)
where TChannel : class

<ExtensionAttribute>
Public Shared Function Create(Of TChannel As Class) (
    factory As IProxyFactory,
    parameters As ServiceConnectionParameters,
    relativeUri As Uri
) As TChannel
public:
[ExtensionAttribute]
generic<typename TChannel>
where TChannel : ref class
static TChannel Create(
    IProxyFactory^ factory,
    ServiceConnectionParameters^ parameters,
    Uri^ relativeUri
)
JavaScript does not support generic types or methods.

Parameters

factory
Type: DoubleTake.CommunicationIProxyFactory
parameters
Type: DoubleTake.CommunicationServiceConnectionParameters
relativeUri
Type: SystemUri

Type Parameters

TChannel

Return Value

Type: TChannel

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IProxyFactory. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ProxyFactoryExtensions Class
Create Overload
DoubleTake.Communication Namespace


ProxyFactoryExtensions.Create(TChannel) Method (IProxyFactory, Uri, AddressingScheme)

ProxyFactoryExtensionsCreateTChannel Method (IProxyFactory, Uri, AddressingScheme)

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public static TChannel Create<TChannel>(
    this IProxyFactory factory,
    Uri hostUri,
    AddressingScheme scheme
)
where TChannel : class

<ExtensionAttribute>
Public Shared Function Create(Of TChannel As Class) (
    factory As IProxyFactory,
    hostUri As Uri,
    scheme As AddressingScheme
) As TChannel
public:
[ExtensionAttribute]
generic<typename TChannel>
where TChannel : ref class
static TChannel Create(
    IProxyFactory^ factory,
    Uri^ hostUri,
    AddressingScheme scheme
)
JavaScript does not support generic types or methods.

Parameters

factory
Type: DoubleTake.CommunicationIProxyFactory
hostUri
Type: SystemUri
scheme
Type: DoubleTake.CommunicationAddressingScheme

Type Parameters

TChannel

Return Value

Type: TChannel

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IProxyFactory. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ProxyFactoryExtensions Class
Create Overload
DoubleTake.Communication Namespace


ProxyFactoryExtensions.CreateClient Method

ProxyFactoryExtensionsCreateClient Method
Overload List
Name | Description
CreateClientTClient(IProxyFactory, Uri) |
CreateClientTClient(IProxyFactory, Uri, AddressingScheme) |
CreateClientTClient(IProxyFactory, Uri, Uri) |
Top
See Also

Reference

ProxyFactoryExtensions Class
DoubleTake.Communication Namespace


ProxyFactoryExtensions.CreateClient(TClient) Method (IProxyFactory, Uri)

ProxyFactoryExtensionsCreateClientTClient Method (IProxyFactory, Uri)

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public static TClient CreateClient<TClient>(
    this IProxyFactory factory,
    Uri hostUri
)
where TClient : class

<ExtensionAttribute>
Public Shared Function CreateClient(Of TClient As Class) (
    factory As IProxyFactory,
    hostUri As Uri
) As TClient
public:
[ExtensionAttribute]
generic<typename TClient>
where TClient : ref class
static TClient CreateClient(
    IProxyFactory^ factory,
    Uri^ hostUri
)
JavaScript does not support generic types or methods.

Parameters

factory
Type: DoubleTake.CommunicationIProxyFactory
hostUri
Type: SystemUri

Type Parameters

TClient

Return Value

Type: TClient

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IProxyFactory. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ProxyFactoryExtensions Class
CreateClient Overload
DoubleTake.Communication Namespace


ProxyFactoryExtensions.CreateClient(TClient) Method (IProxyFactory, Uri, AddressingScheme)

ProxyFactoryExtensionsCreateClientTClient Method (IProxyFactory, Uri, AddressingScheme)

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public static TClient CreateClient<TClient>(
    this IProxyFactory factory,
    Uri hostUri,
    AddressingScheme scheme
)
where TClient : class

<ExtensionAttribute>
Public Shared Function CreateClient(Of TClient As Class) (
    factory As IProxyFactory,
    hostUri As Uri,
    scheme As AddressingScheme
) As TClient
public:
[ExtensionAttribute]
generic<typename TClient>
where TClient : ref class
static TClient CreateClient(
    IProxyFactory^ factory,
    Uri^ hostUri,
    AddressingScheme scheme
)
JavaScript does not support generic types or methods.

Parameters

factory
Type: DoubleTake.CommunicationIProxyFactory
hostUri
Type: SystemUri
scheme
Type: DoubleTake.CommunicationAddressingScheme

Type Parameters

TClient

Return Value

Type: TClient

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IProxyFactory. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ProxyFactoryExtensions Class
CreateClient Overload
DoubleTake.Communication Namespace


ProxyFactoryExtensions.CreateClient(TClient) Method (IProxyFactory, Uri, Uri)

ProxyFactoryExtensionsCreateClientTClient Method (IProxyFactory, Uri, Uri)

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public static TClient CreateClient<TClient>(
    this IProxyFactory factory,
    Uri hostUri,
    Uri relativeUri
)
where TClient : class

<ExtensionAttribute>
Public Shared Function CreateClient(Of TClient As Class) (
    factory As IProxyFactory,
    hostUri As Uri,
    relativeUri As Uri
) As TClient
public:
[ExtensionAttribute]
generic<typename TClient>
where TClient : ref class
static TClient CreateClient(
    IProxyFactory^ factory,
    Uri^ hostUri,
    Uri^ relativeUri
)
JavaScript does not support generic types or methods.

Parameters

factory
Type: DoubleTake.CommunicationIProxyFactory
hostUri
Type: SystemUri
relativeUri
Type: SystemUri

Type Parameters

TClient

Return Value

Type: TClient

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IProxyFactory. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ProxyFactoryExtensions Class
CreateClient Overload
DoubleTake.Communication Namespace


ProxyFactoryExtensions.Using Method

ProxyFactoryExtensionsUsing Method
Overload List
Name | Description
UsingTChannel(IProxyFactory, ServiceConnectionParameters, ActionTChannel) |
UsingTChannel, TResult(IProxyFactory, ServiceConnectionParameters, FuncTChannel, TResult) |
UsingTChannel(IProxyFactory, Uri, ActionTChannel) |
UsingTChannel, TResult(IProxyFactory, Uri, FuncTChannel, TResult) |
UsingTChannel(IProxyFactory, ServiceConnectionParameters, Uri, ActionTChannel) |
UsingTChannel, TResult(IProxyFactory, ServiceConnectionParameters, Uri, FuncTChannel, TResult) |
UsingTChannel(IProxyFactory, Uri, AddressingScheme, ActionTChannel) |
UsingTChannel, TResult(IProxyFactory, Uri, AddressingScheme, FuncTChannel, TResult) |
UsingTChannel(IProxyFactory, Uri, Uri, ActionTChannel) |
UsingTChannel, TResult(IProxyFactory, Uri, Uri, FuncTChannel, TResult) |
Top
See Also

Reference

ProxyFactoryExtensions Class
DoubleTake.Communication Namespace


ProxyFactoryExtensions.Using(TChannel) Method (IProxyFactory, ServiceConnectionParameters, Action(TChannel))

ProxyFactoryExtensionsUsingTChannel Method (IProxyFactory, ServiceConnectionParameters, ActionTChannel)

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public static void Using<TChannel>(
    this IProxyFactory factory,
    ServiceConnectionParameters connectionParameters,
    Action<TChannel> action
)
where TChannel : class

<ExtensionAttribute>
Public Shared Sub Using(Of TChannel As Class) (
    factory As IProxyFactory,
    connectionParameters As ServiceConnectionParameters,
    action As Action(Of TChannel)
)
public:
[ExtensionAttribute]
generic<typename TChannel>
where TChannel : ref class
static void Using(
    IProxyFactory^ factory,
    ServiceConnectionParameters^ connectionParameters,
    Action<TChannel>^ action
)
JavaScript does not support generic types or methods.

Parameters

factory
Type: DoubleTake.CommunicationIProxyFactory
connectionParameters
Type: DoubleTake.CommunicationServiceConnectionParameters
action
Type: SystemAction TChannel

Type Parameters

TChannel

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IProxyFactory. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ProxyFactoryExtensions Class
Using Overload
DoubleTake.Communication Namespace


ProxyFactoryExtensions.Using(TChannel, TResult) Method (IProxyFactory, ServiceConnectionParameters, Func(TChannel, TResult))

ProxyFactoryExtensionsUsingTChannel, TResult Method (IProxyFactory, ServiceConnectionParameters, FuncTChannel, TResult)

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public static TResult Using<TChannel, TResult>(
    this IProxyFactory factory,
    ServiceConnectionParameters parameters,
    Func<TChannel, TResult> func
)
where TChannel : class

<ExtensionAttribute>
Public Shared Function Using(Of TChannel As Class, TResult) (
    factory As IProxyFactory,
    parameters As ServiceConnectionParameters,
    func As Func(Of TChannel, TResult)
) As TResult
public:
[ExtensionAttribute]
generic<typename TChannel, typename TResult>
where TChannel : ref class
static TResult Using(
    IProxyFactory^ factory,
    ServiceConnectionParameters^ parameters,
    Func<TChannel, TResult>^ func
)
JavaScript does not support generic types or methods.

Parameters

factory
Type: DoubleTake.CommunicationIProxyFactory
parameters
Type: DoubleTake.CommunicationServiceConnectionParameters
func
Type: SystemFunc TChannel, TResult

Type Parameters

TChannel
TResult

Return Value

Type: TResult

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IProxyFactory. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ProxyFactoryExtensions Class
Using Overload
DoubleTake.Communication Namespace


ProxyFactoryExtensions.Using(TChannel) Method (IProxyFactory, Uri, Action(TChannel))

ProxyFactoryExtensionsUsingTChannel Method (IProxyFactory, Uri, ActionTChannel)

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public static void Using<TChannel>(
    this IProxyFactory factory,
    Uri hostUri,
    Action<TChannel> action
)
where TChannel : class

<ExtensionAttribute>
Public Shared Sub Using(Of TChannel As Class) (
    factory As IProxyFactory,
    hostUri As Uri,
    action As Action(Of TChannel)
)
public:
[ExtensionAttribute]
generic<typename TChannel>
where TChannel : ref class
static void Using(
    IProxyFactory^ factory,
    Uri^ hostUri,
    Action<TChannel>^ action
)
JavaScript does not support generic types or methods.

Parameters

factory
Type: DoubleTake.CommunicationIProxyFactory
hostUri
Type: SystemUri
action
Type: SystemAction TChannel

Type Parameters

TChannel

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IProxyFactory. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ProxyFactoryExtensions Class
Using Overload
DoubleTake.Communication Namespace


ProxyFactoryExtensions.Using(TChannel, TResult) Method (IProxyFactory, Uri, Func(TChannel, TResult))

ProxyFactoryExtensionsUsingTChannel, TResult Method (IProxyFactory, Uri, FuncTChannel, TResult)

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public static TResult Using<TChannel, TResult>(
    this IProxyFactory factory,
    Uri hostUri,
    Func<TChannel, TResult> func
)
where TChannel : class

<ExtensionAttribute>
Public Shared Function Using(Of TChannel As Class, TResult) (
    factory As IProxyFactory,
    hostUri As Uri,
    func As Func(Of TChannel, TResult)
) As TResult
public:
[ExtensionAttribute]
generic<typename TChannel, typename TResult>
where TChannel : ref class
static TResult Using(
    IProxyFactory^ factory,
    Uri^ hostUri,
    Func<TChannel, TResult>^ func
)
JavaScript does not support generic types or methods.

Parameters

factory
Type: DoubleTake.CommunicationIProxyFactory
hostUri
Type: SystemUri
func
Type: SystemFunc TChannel, TResult

Type Parameters

TChannel
TResult

Return Value

Type: TResult

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IProxyFactory. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ProxyFactoryExtensions Class
Using Overload
DoubleTake.Communication Namespace


ProxyFactoryExtensions.Using(TChannel) Method (IProxyFactory, ServiceConnectionParameters, Uri, Action(TChannel))

ProxyFactoryExtensionsUsingTChannel Method (IProxyFactory, ServiceConnectionParameters, Uri, ActionTChannel)

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public static void Using<TChannel>(
    this IProxyFactory factory,
    ServiceConnectionParameters parameters,
    Uri relativeUri,
    Action<TChannel> action
)
where TChannel : class

<ExtensionAttribute>
Public Shared Sub Using(Of TChannel As Class) (
    factory As IProxyFactory,
    parameters As ServiceConnectionParameters,
    relativeUri As Uri,
    action As Action(Of TChannel)
)
public:
[ExtensionAttribute]
generic<typename TChannel>
where TChannel : ref class
static void Using(
    IProxyFactory^ factory,
    ServiceConnectionParameters^ parameters,
    Uri^ relativeUri,
    Action<TChannel>^ action
)
JavaScript does not support generic types or methods.

Parameters

factory
Type: DoubleTake.CommunicationIProxyFactory
parameters
Type: DoubleTake.CommunicationServiceConnectionParameters
relativeUri
Type: SystemUri
action
Type: SystemAction TChannel

Type Parameters

TChannel

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IProxyFactory. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ProxyFactoryExtensions Class
Using Overload
DoubleTake.Communication Namespace


ProxyFactoryExtensions.Using(TChannel, TResult) Method (IProxyFactory, ServiceConnectionParameters, Uri, Func(TChannel, TResult))

ProxyFactoryExtensionsUsingTChannel, TResult Method (IProxyFactory, ServiceConnectionParameters, Uri, FuncTChannel, TResult)

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public static TResult Using<TChannel, TResult>(
    this IProxyFactory factory,
    ServiceConnectionParameters parameters,
    Uri relativeUri,
    Func<TChannel, TResult> func
)
where TChannel : class

<ExtensionAttribute>
Public Shared Function Using(Of TChannel As Class, TResult) (
    factory As IProxyFactory,
    parameters As ServiceConnectionParameters,
    relativeUri As Uri,
    func As Func(Of TChannel, TResult)
) As TResult
public:
[ExtensionAttribute]
generic<typename TChannel, typename TResult>
where TChannel : ref class
static TResult Using(
    IProxyFactory^ factory,
    ServiceConnectionParameters^ parameters,
    Uri^ relativeUri,
    Func<TChannel, TResult>^ func
)
JavaScript does not support generic types or methods.

Parameters

factory
Type: DoubleTake.CommunicationIProxyFactory
parameters
Type: DoubleTake.CommunicationServiceConnectionParameters
relativeUri
Type: SystemUri
func
Type: SystemFunc TChannel, TResult

Type Parameters

TChannel
TResult

Return Value

Type: TResult

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IProxyFactory. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ProxyFactoryExtensions Class
Using Overload
DoubleTake.Communication Namespace


ProxyFactoryExtensions.Using(TChannel) Method (IProxyFactory, Uri, AddressingScheme, Action(TChannel))

ProxyFactoryExtensionsUsingTChannel Method (IProxyFactory, Uri, AddressingScheme, ActionTChannel)

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public static void Using<TChannel>(
    this IProxyFactory factory,
    Uri hostUri,
    AddressingScheme scheme,
    Action<TChannel> action
)
where TChannel : class

<ExtensionAttribute>
Public Shared Sub Using(Of TChannel As Class) (
    factory As IProxyFactory,
    hostUri As Uri,
    scheme As AddressingScheme,
    action As Action(Of TChannel)
)
public:
[ExtensionAttribute]
generic<typename TChannel>
where TChannel : ref class
static void Using(
    IProxyFactory^ factory,
    Uri^ hostUri,
    AddressingScheme scheme,
    Action<TChannel>^ action
)
JavaScript does not support generic types or methods.

Parameters

factory
Type: DoubleTake.CommunicationIProxyFactory
hostUri
Type: SystemUri
scheme
Type: DoubleTake.CommunicationAddressingScheme
action
Type: SystemAction TChannel

Type Parameters

TChannel

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IProxyFactory. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ProxyFactoryExtensions Class
Using Overload
DoubleTake.Communication Namespace


ProxyFactoryExtensions.Using(TChannel, TResult) Method (IProxyFactory, Uri, AddressingScheme, Func(TChannel, TResult))

ProxyFactoryExtensionsUsingTChannel, TResult Method (IProxyFactory, Uri, AddressingScheme, FuncTChannel, TResult)

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public static TResult Using<TChannel, TResult>(
    this IProxyFactory factory,
    Uri hostUri,
    AddressingScheme scheme,
    Func<TChannel, TResult> func
)
where TChannel : class

<ExtensionAttribute>
Public Shared Function Using(Of TChannel As Class, TResult) (
    factory As IProxyFactory,
    hostUri As Uri,
    scheme As AddressingScheme,
    func As Func(Of TChannel, TResult)
) As TResult
public:
[ExtensionAttribute]
generic<typename TChannel, typename TResult>
where TChannel : ref class
static TResult Using(
    IProxyFactory^ factory,
    Uri^ hostUri,
    AddressingScheme scheme,
    Func<TChannel, TResult>^ func
)
JavaScript does not support generic types or methods.

Parameters

factory
Type: DoubleTake.CommunicationIProxyFactory
hostUri
Type: SystemUri
scheme
Type: DoubleTake.CommunicationAddressingScheme
func
Type: SystemFunc TChannel, TResult

Type Parameters

TChannel
TResult

Return Value

Type: TResult

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IProxyFactory. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ProxyFactoryExtensions Class
Using Overload
DoubleTake.Communication Namespace


ProxyFactoryExtensions.Using(TChannel) Method (IProxyFactory, Uri, Uri, Action(TChannel))

ProxyFactoryExtensionsUsingTChannel Method (IProxyFactory, Uri, Uri, ActionTChannel)

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public static void Using<TChannel>(
    this IProxyFactory factory,
    Uri hostUri,
    Uri relativeUri,
    Action<TChannel> action
)
where TChannel : class

<ExtensionAttribute>
Public Shared Sub Using(Of TChannel As Class) (
    factory As IProxyFactory,
    hostUri As Uri,
    relativeUri As Uri,
    action As Action(Of TChannel)
)
public:
[ExtensionAttribute]
generic<typename TChannel>
where TChannel : ref class
static void Using(
    IProxyFactory^ factory,
    Uri^ hostUri,
    Uri^ relativeUri,
    Action<TChannel>^ action
)
JavaScript does not support generic types or methods.

Parameters

factory
Type: DoubleTake.CommunicationIProxyFactory
hostUri
Type: SystemUri
relativeUri
Type: SystemUri
action
Type: SystemAction TChannel

Type Parameters

TChannel

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IProxyFactory. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ProxyFactoryExtensions Class
Using Overload
DoubleTake.Communication Namespace


ProxyFactoryExtensions.Using(TChannel, TResult) Method (IProxyFactory, Uri, Uri, Func(TChannel, TResult))

ProxyFactoryExtensionsUsingTChannel, TResult Method (IProxyFactory, Uri, Uri, FuncTChannel, TResult)

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public static TResult Using<TChannel, TResult>(
    this IProxyFactory factory,
    Uri hostUri,
    Uri relativeUri,
    Func<TChannel, TResult> func
)
where TChannel : class

<ExtensionAttribute>
Public Shared Function Using(Of TChannel As Class, TResult) (
    factory As IProxyFactory,
    hostUri As Uri,
    relativeUri As Uri,
    func As Func(Of TChannel, TResult)
) As TResult
public:
[ExtensionAttribute]
generic<typename TChannel, typename TResult>
where TChannel : ref class
static TResult Using(
    IProxyFactory^ factory,
    Uri^ hostUri,
    Uri^ relativeUri,
    Func<TChannel, TResult>^ func
)
JavaScript does not support generic types or methods.

Parameters

factory
Type: DoubleTake.CommunicationIProxyFactory
hostUri
Type: SystemUri
relativeUri
Type: SystemUri
func
Type: SystemFunc TChannel, TResult

Type Parameters

TChannel
TResult

Return Value

Type: TResult

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IProxyFactory. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ProxyFactoryExtensions Class
Using Overload
DoubleTake.Communication Namespace


ServiceConnectionParameters Class

ServiceConnectionParameters Class
Inheritance Hierarchy
SystemObject
DoubleTake.CommunicationServiceConnectionParameters

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class ServiceConnectionParameters
Public Class ServiceConnectionParameters
public ref class ServiceConnectionParameters
DoubleTake.Communication.ServiceConnectionParameters = function();

Type.createClass(
    'DoubleTake.Communication.ServiceConnectionParameters');

The ServiceConnectionParameters type exposes the following members.

Constructors
 | Name | Description
Public method | ServiceConnectionParameters | Initializes a new instance of the ServiceConnectionParameters class
Top
Properties
 | Name | Description
Public property | Credentials |
Public property | NetworkId |
Public property | Port |
Top
Methods
Name | Description
CreateHostUri(String) |
CreateHostUri(String, Int32) |
CreateHostUri(String, NetworkCredential) |
CreateHostUri(String, Int32, NetworkCredential) |
CreateHostUri(String, String, String) |
CreateHostUri(String, Int32, String, String) |
CreateHostUri(String, String, String, String) |
CreateHostUri(String, Int32, String, String, String) |
Top
Fields
Name | Description
ManagementServiceUriScheme |
Top
Extension Methods
 | Name | Description
Public Extension Method | ToHostUri | (Defined by ServiceConnectionParametersExtensions.)
Top
See Also

Reference

DoubleTake.Communication Namespace


ServiceConnectionParameters Constructor

ServiceConnectionParameters Constructor
Initializes a new instance of the ServiceConnectionParameters class

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ServiceConnectionParameters()
Public Sub New
public:
ServiceConnectionParameters()
DoubleTake.Communication.ServiceConnectionParameters = function();
See Also

Reference

ServiceConnectionParameters Class
DoubleTake.Communication Namespace


ServiceConnectionParameters Properties

ServiceConnectionParameters Properties

The ServiceConnectionParameters type exposes the following members.

Properties
 | Name | Description
Public property | Credentials |
Public property | NetworkId |
Public property | Port |
Top
See Also

Reference

ServiceConnectionParameters Class
DoubleTake.Communication Namespace


ServiceConnectionParameters.Credentials Property

ServiceConnectionParametersCredentials Property

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public NetworkCredential Credentials { get; set; }
Public Property Credentials As NetworkCredential
    Get
    Set
public:
property NetworkCredential^ Credentials {
    NetworkCredential^ get ();
    void set (NetworkCredential^ value);
}
function get_Credentials();
function set_Credentials(value);

Property Value

Type: NetworkCredential
See Also

Reference

ServiceConnectionParameters Class
DoubleTake.Communication Namespace


ServiceConnectionParameters.NetworkId Property

ServiceConnectionParametersNetworkId Property

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string NetworkId { get; set; }
Public Property NetworkId As String
    Get
    Set
public:
property String^ NetworkId {
    String^ get ();
    void set (String^ value);
}
function get_NetworkId();
function set_NetworkId(value);

Property Value

Type: String
See Also

Reference

ServiceConnectionParameters Class
DoubleTake.Communication Namespace


ServiceConnectionParameters.Port Property

ServiceConnectionParametersPort Property

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Nullable<int> Port { get; set; }
Public Property Port As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> Port {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
function get_Port();
function set_Port(value);

Property Value

Type: Nullable Int32
See Also

Reference

ServiceConnectionParameters Class
DoubleTake.Communication Namespace


ServiceConnectionParameters Methods

ServiceConnectionParameters Methods

The ServiceConnectionParameters type exposes the following members.

Methods
Name | Description
CreateHostUri(String) |
CreateHostUri(String, Int32) |
CreateHostUri(String, NetworkCredential) |
CreateHostUri(String, Int32, NetworkCredential) |
CreateHostUri(String, String, String) |
CreateHostUri(String, Int32, String, String) |
CreateHostUri(String, String, String, String) |
CreateHostUri(String, Int32, String, String, String) |
Top
Extension Methods
 | Name | Description
Public Extension Method | ToHostUri | (Defined by ServiceConnectionParametersExtensions.)
Top
See Also

Reference

ServiceConnectionParameters Class
DoubleTake.Communication Namespace


ServiceConnectionParameters.CreateHostUri Method

ServiceConnectionParametersCreateHostUri Method
Overload List
Name | Description
CreateHostUri(String) |
CreateHostUri(String, Int32) |
CreateHostUri(String, NetworkCredential) |
CreateHostUri(String, Int32, NetworkCredential) |
CreateHostUri(String, String, String) |
CreateHostUri(String, Int32, String, String) |
CreateHostUri(String, String, String, String) |
CreateHostUri(String, Int32, String, String, String) |
Top
See Also

Reference

ServiceConnectionParameters Class
DoubleTake.Communication Namespace


ServiceConnectionParameters.CreateHostUri Method (String)

ServiceConnectionParametersCreateHostUri Method (String)

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public static Uri CreateHostUri(
    string networkId
)
Public Shared Function CreateHostUri (
    networkId As String
) As Uri
public:
static Uri^ CreateHostUri(
    String^ networkId
)
DoubleTake.Communication.ServiceConnectionParameters.CreateHostUri = function(networkId);

Parameters

networkId
Type: SystemString

Return Value

Type: Uri
See Also

Reference

ServiceConnectionParameters Class
CreateHostUri Overload
DoubleTake.Communication Namespace


ServiceConnectionParameters.CreateHostUri Method (String, Int32)

ServiceConnectionParametersCreateHostUri Method (String, Int32)

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public static Uri CreateHostUri(
    string networkId,
    int port
)
Public Shared Function CreateHostUri (
    networkId As String,
    port As Integer
) As Uri
public:
static Uri^ CreateHostUri(
    String^ networkId,
    int port
)
DoubleTake.Communication.ServiceConnectionParameters.CreateHostUri = function(networkId, port);

Parameters

networkId
Type: SystemString
port
Type: SystemInt32

Return Value

Type: Uri
See Also

Reference

ServiceConnectionParameters Class
CreateHostUri Overload
DoubleTake.Communication Namespace


ServiceConnectionParameters.CreateHostUri Method (String, NetworkCredential)

ServiceConnectionParametersCreateHostUri Method (String, NetworkCredential)

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public static Uri CreateHostUri(
    string networkId,
    NetworkCredential credentials
)
Public Shared Function CreateHostUri (
    networkId As String,
    credentials As NetworkCredential
) As Uri
public:
static Uri^ CreateHostUri(
    String^ networkId,
    NetworkCredential^ credentials
)
DoubleTake.Communication.ServiceConnectionParameters.CreateHostUri = function(networkId, credentials);

Parameters

networkId
Type: SystemString
credentials
Type: System.NetNetworkCredential

Return Value

Type: Uri
See Also

Reference

ServiceConnectionParameters Class
CreateHostUri Overload
DoubleTake.Communication Namespace


ServiceConnectionParameters.CreateHostUri Method (String, Int32, NetworkCredential)

ServiceConnectionParametersCreateHostUri Method (String, Int32, NetworkCredential)

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public static Uri CreateHostUri(
    string networkId,
    int port,
    NetworkCredential credentials
)
Public Shared Function CreateHostUri (
    networkId As String,
    port As Integer,
    credentials As NetworkCredential
) As Uri
public:
static Uri^ CreateHostUri(
    String^ networkId,
    int port,
    NetworkCredential^ credentials
)
DoubleTake.Communication.ServiceConnectionParameters.CreateHostUri = function(networkId, port, credentials);

Parameters

networkId
Type: SystemString
port
Type: SystemInt32
credentials
Type: System.NetNetworkCredential

Return Value

Type: Uri
See Also

Reference

ServiceConnectionParameters Class
CreateHostUri Overload
DoubleTake.Communication Namespace


ServiceConnectionParameters.CreateHostUri Method (String, String, String)

ServiceConnectionParametersCreateHostUri Method (String, String, String)

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public static Uri CreateHostUri(
    string networkId,
    string userName,
    string password
)
Public Shared Function CreateHostUri (
    networkId As String,
    userName As String,
    password As String
) As Uri
public:
static Uri^ CreateHostUri(
    String^ networkId,
    String^ userName,
    String^ password
)
DoubleTake.Communication.ServiceConnectionParameters.CreateHostUri = function(networkId, userName, password);

Parameters

networkId
Type: SystemString
userName
Type: SystemString
password
Type: SystemString

Return Value

Type: Uri
See Also

Reference

ServiceConnectionParameters Class
CreateHostUri Overload
DoubleTake.Communication Namespace


ServiceConnectionParameters.CreateHostUri Method (String, Int32, String, String)

ServiceConnectionParametersCreateHostUri Method (String, Int32, String, String)

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public static Uri CreateHostUri(
    string networkId,
    int port,
    string userName,
    string password
)
Public Shared Function CreateHostUri (
    networkId As String,
    port As Integer,
    userName As String,
    password As String
) As Uri
public:
static Uri^ CreateHostUri(
    String^ networkId,
    int port,
    String^ userName,
    String^ password
)
DoubleTake.Communication.ServiceConnectionParameters.CreateHostUri = function(networkId, port, userName, password);

Parameters

networkId
Type: SystemString
port
Type: SystemInt32
userName
Type: SystemString
password
Type: SystemString

Return Value

Type: Uri
See Also

Reference

ServiceConnectionParameters Class
CreateHostUri Overload
DoubleTake.Communication Namespace


ServiceConnectionParameters.CreateHostUri Method (String, String, String, String)

ServiceConnectionParametersCreateHostUri Method (String, String, String, String)

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public static Uri CreateHostUri(
    string networkId,
    string userName,
    string password,
    string domain
)
Public Shared Function CreateHostUri (
    networkId As String,
    userName As String,
    password As String,
    domain As String
) As Uri
public:
static Uri^ CreateHostUri(
    String^ networkId,
    String^ userName,
    String^ password,
    String^ domain
)
DoubleTake.Communication.ServiceConnectionParameters.CreateHostUri = function(networkId, userName, password, domain);

Parameters

networkId
Type: SystemString
userName
Type: SystemString
password
Type: SystemString
domain
Type: SystemString

Return Value

Type: Uri
See Also

Reference

ServiceConnectionParameters Class
CreateHostUri Overload
DoubleTake.Communication Namespace


ServiceConnectionParameters.CreateHostUri Method (String, Int32, String, String, String)

ServiceConnectionParametersCreateHostUri Method (String, Int32, String, String, String)

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public static Uri CreateHostUri(
    string networkId,
    int port,
    string userName,
    string password,
    string domain
)
Public Shared Function CreateHostUri (
    networkId As String,
    port As Integer,
    userName As String,
    password As String,
    domain As String
) As Uri
public:
static Uri^ CreateHostUri(
    String^ networkId,
    int port,
    String^ userName,
    String^ password,
    String^ domain
)
DoubleTake.Communication.ServiceConnectionParameters.CreateHostUri = function(networkId, port, userName, password, domain);

Parameters

networkId
Type: SystemString
port
Type: SystemInt32
userName
Type: SystemString
password
Type: SystemString
domain
Type: SystemString

Return Value

Type: Uri
See Also

Reference

ServiceConnectionParameters Class
CreateHostUri Overload
DoubleTake.Communication Namespace


ServiceConnectionParameters Fields

ServiceConnectionParameters Fields

The ServiceConnectionParameters type exposes the following members.

Fields
Name | Description
ManagementServiceUriScheme |
Top
See Also

Reference

ServiceConnectionParameters Class
DoubleTake.Communication Namespace


ServiceConnectionParameters.ManagementServiceUriScheme Field

ServiceConnectionParametersManagementServiceUriScheme Field

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string ManagementServiceUriScheme
Public Const ManagementServiceUriScheme As String
public:
literal String^ ManagementServiceUriScheme
var DoubleTake.Communication.ServiceConnectionParameters.ManagementServiceUriScheme

Field Value

Type: String
See Also

Reference

ServiceConnectionParameters Class
DoubleTake.Communication Namespace


ServiceConnectionParametersExtensions Class

ServiceConnectionParametersExtensions Class
Inheritance Hierarchy
SystemObject
DoubleTake.CommunicationServiceConnectionParametersExtensions

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public static class ServiceConnectionParametersExtensions
<ExtensionAttribute>
Public NotInheritable Class ServiceConnectionParametersExtensions
[ExtensionAttribute]
public ref class ServiceConnectionParametersExtensions abstract sealed
DoubleTake.Communication.ServiceConnectionParametersExtensions = function();

Type.createClass(
    'DoubleTake.Communication.ServiceConnectionParametersExtensions');

The ServiceConnectionParametersExtensions type exposes the following members.

Methods
Name | Description
ToHostUri |
Top
See Also

Reference

DoubleTake.Communication Namespace


ServiceConnectionParametersExtensions Methods

ServiceConnectionParametersExtensions Methods

The ServiceConnectionParametersExtensions type exposes the following members.

Methods
Name | Description
ToHostUri |
Top
See Also

Reference

ServiceConnectionParametersExtensions Class
DoubleTake.Communication Namespace


ServiceConnectionParametersExtensions.ToHostUri Method

ServiceConnectionParametersExtensionsToHostUri Method

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public static Uri ToHostUri(
    this ServiceConnectionParameters parameters
)
<ExtensionAttribute>
Public Shared Function ToHostUri (
    parameters As ServiceConnectionParameters
) As Uri
public:
[ExtensionAttribute]
static Uri^ ToHostUri(
    ServiceConnectionParameters^ parameters
)
DoubleTake.Communication.ServiceConnectionParametersExtensions.ToHostUri = function(parameters);

Parameters

parameters
Type: DoubleTake.CommunicationServiceConnectionParameters

Return Value

Type: Uri

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ServiceConnectionParameters. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ServiceConnectionParametersExtensions Class
DoubleTake.Communication Namespace


ServiceRelativeAddressAttribute Class

ServiceRelativeAddressAttribute Class
Inheritance Hierarchy
SystemObject
SystemAttribute
DoubleTake.CommunicationServiceRelativeAddressAttribute

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public sealed class ServiceRelativeAddressAttribute : Attribute
Public NotInheritable Class ServiceRelativeAddressAttribute
    Inherits Attribute
public ref class ServiceRelativeAddressAttribute sealed : public Attribute
DoubleTake.Communication.ServiceRelativeAddressAttribute = function();

Type.createClass(
    'DoubleTake.Communication.ServiceRelativeAddressAttribute',
    Attribute);

The ServiceRelativeAddressAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | ServiceRelativeAddressAttribute(String) | Initializes a new instance of the ServiceRelativeAddressAttribute class
Public method | ServiceRelativeAddressAttribute(String, AddressingScheme) | Initializes a new instance of the ServiceRelativeAddressAttribute class
Public method | ServiceRelativeAddressAttribute(String, Type) | Initializes a new instance of the ServiceRelativeAddressAttribute class
Public method | ServiceRelativeAddressAttribute(String, AddressingScheme, Type) | Initializes a new instance of the ServiceRelativeAddressAttribute class
Top
Properties
 | Name | Description
Public property | ContractType |
Public property | RelativeUri |
Public property | Scheme |
Top
See Also

Reference

DoubleTake.Communication Namespace


ServiceRelativeAddressAttribute Constructor

ServiceRelativeAddressAttribute Constructor
Overload List
 | Name | Description
Public method | ServiceRelativeAddressAttribute(String) | Initializes a new instance of the ServiceRelativeAddressAttribute class
Public method | ServiceRelativeAddressAttribute(String, AddressingScheme) | Initializes a new instance of the ServiceRelativeAddressAttribute class
Public method | ServiceRelativeAddressAttribute(String, Type) | Initializes a new instance of the ServiceRelativeAddressAttribute class
Public method | ServiceRelativeAddressAttribute(String, AddressingScheme, Type) | Initializes a new instance of the ServiceRelativeAddressAttribute class
Top
See Also

Reference

ServiceRelativeAddressAttribute Class
DoubleTake.Communication Namespace


ServiceRelativeAddressAttribute Constructor (String)

ServiceRelativeAddressAttribute Constructor (String)
Initializes a new instance of the ServiceRelativeAddressAttribute class

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ServiceRelativeAddressAttribute(
    string relativeUri
)
Public Sub New (
    relativeUri As String
)
public:
ServiceRelativeAddressAttribute(
    String^ relativeUri
)
DoubleTake.Communication.ServiceRelativeAddressAttribute = function(relativeUri);

Parameters

relativeUri
Type: SystemString
See Also

Reference

ServiceRelativeAddressAttribute Class
ServiceRelativeAddressAttribute Overload
DoubleTake.Communication Namespace


ServiceRelativeAddressAttribute Constructor (String, AddressingScheme)

ServiceRelativeAddressAttribute Constructor (String, AddressingScheme)
Initializes a new instance of the ServiceRelativeAddressAttribute class

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ServiceRelativeAddressAttribute(
    string relativeUri,
    AddressingScheme scheme
)
Public Sub New (
    relativeUri As String,
    scheme As AddressingScheme
)
public:
ServiceRelativeAddressAttribute(
    String^ relativeUri,
    AddressingScheme scheme
)
DoubleTake.Communication.ServiceRelativeAddressAttribute = function(relativeUri, scheme);

Parameters

relativeUri
Type: SystemString
scheme
Type: DoubleTake.CommunicationAddressingScheme
See Also

Reference

ServiceRelativeAddressAttribute Class
ServiceRelativeAddressAttribute Overload
DoubleTake.Communication Namespace


ServiceRelativeAddressAttribute Constructor (String, Type)

ServiceRelativeAddressAttribute Constructor (String, Type)
Initializes a new instance of the ServiceRelativeAddressAttribute class

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ServiceRelativeAddressAttribute(
    string relativeUri,
    Type contractType
)
Public Sub New (
    relativeUri As String,
    contractType As Type
)
public:
ServiceRelativeAddressAttribute(
    String^ relativeUri,
    Type^ contractType
)
DoubleTake.Communication.ServiceRelativeAddressAttribute = function(relativeUri, contractType);

Parameters

relativeUri
Type: SystemString
contractType
Type: SystemType
See Also

Reference

ServiceRelativeAddressAttribute Class
ServiceRelativeAddressAttribute Overload
DoubleTake.Communication Namespace


ServiceRelativeAddressAttribute Constructor (String, AddressingScheme, Type)

ServiceRelativeAddressAttribute Constructor (String, AddressingScheme, Type)
Initializes a new instance of the ServiceRelativeAddressAttribute class

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ServiceRelativeAddressAttribute(
    string relativeUri,
    AddressingScheme scheme,
    Type contractType
)
Public Sub New (
    relativeUri As String,
    scheme As AddressingScheme,
    contractType As Type
)
public:
ServiceRelativeAddressAttribute(
    String^ relativeUri,
    AddressingScheme scheme,
    Type^ contractType
)
DoubleTake.Communication.ServiceRelativeAddressAttribute = function(relativeUri, scheme, contractType);

Parameters

relativeUri
Type: SystemString
scheme
Type: DoubleTake.CommunicationAddressingScheme
contractType
Type: SystemType
See Also

Reference

ServiceRelativeAddressAttribute Class
ServiceRelativeAddressAttribute Overload
DoubleTake.Communication Namespace


ServiceRelativeAddressAttribute Properties

ServiceRelativeAddressAttribute Properties

The ServiceRelativeAddressAttribute type exposes the following members.

Properties
 | Name | Description
Public property | ContractType |
Public property | RelativeUri |
Public property | Scheme |
Top
See Also

Reference

ServiceRelativeAddressAttribute Class
DoubleTake.Communication Namespace


ServiceRelativeAddressAttribute.ContractType Property

ServiceRelativeAddressAttributeContractType Property

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Type ContractType { get; }
Public ReadOnly Property ContractType As Type
    Get
public:
property Type^ ContractType {
    Type^ get ();
}
function get_ContractType();

Property Value

Type: Type
See Also

Reference

ServiceRelativeAddressAttribute Class
DoubleTake.Communication Namespace


ServiceRelativeAddressAttribute.RelativeUri Property

ServiceRelativeAddressAttributeRelativeUri Property

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Uri RelativeUri { get; }
Public ReadOnly Property RelativeUri As Uri
    Get
public:
property Uri^ RelativeUri {
    Uri^ get ();
}
function get_RelativeUri();

Property Value

Type: Uri
See Also

Reference

ServiceRelativeAddressAttribute Class
DoubleTake.Communication Namespace


ServiceRelativeAddressAttribute.Scheme Property

ServiceRelativeAddressAttributeScheme Property

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public AddressingScheme Scheme { get; }
Public ReadOnly Property Scheme As AddressingScheme
    Get
public:
property AddressingScheme Scheme {
    AddressingScheme get ();
}
function get_Scheme();

Property Value

Type: AddressingScheme
See Also

Reference

ServiceRelativeAddressAttribute Class
DoubleTake.Communication Namespace


ServiceRelativeUriAttribute Class

ServiceRelativeUriAttribute Class
Inheritance Hierarchy
SystemObject
SystemAttribute
DoubleTake.CommunicationServiceRelativeUriAttribute

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public sealed class ServiceRelativeUriAttribute : Attribute
Public NotInheritable Class ServiceRelativeUriAttribute
    Inherits Attribute
public ref class ServiceRelativeUriAttribute sealed : public Attribute
DoubleTake.Communication.ServiceRelativeUriAttribute = function();

Type.createClass(
    'DoubleTake.Communication.ServiceRelativeUriAttribute',
    Attribute);

The ServiceRelativeUriAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | ServiceRelativeUriAttribute(String) | Initializes a new instance of the ServiceRelativeUriAttribute class
Public method | ServiceRelativeUriAttribute(String, Type) | Initializes a new instance of the ServiceRelativeUriAttribute class
Top
Properties
 | Name | Description
Public property | ContractType |
Public property | RelativeUri |
Top
See Also

Reference

DoubleTake.Communication Namespace


ServiceRelativeUriAttribute Constructor

ServiceRelativeUriAttribute Constructor
Overload List
 | Name | Description
Public method | ServiceRelativeUriAttribute(String) | Initializes a new instance of the ServiceRelativeUriAttribute class
Public method | ServiceRelativeUriAttribute(String, Type) | Initializes a new instance of the ServiceRelativeUriAttribute class
Top
See Also

Reference

ServiceRelativeUriAttribute Class
DoubleTake.Communication Namespace


ServiceRelativeUriAttribute Constructor (String)

ServiceRelativeUriAttribute Constructor (String)
Initializes a new instance of the ServiceRelativeUriAttribute class

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ServiceRelativeUriAttribute(
    string relativeUri
)
Public Sub New (
    relativeUri As String
)
public:
ServiceRelativeUriAttribute(
    String^ relativeUri
)
DoubleTake.Communication.ServiceRelativeUriAttribute = function(relativeUri);

Parameters

relativeUri
Type: SystemString
See Also

Reference

ServiceRelativeUriAttribute Class
ServiceRelativeUriAttribute Overload
DoubleTake.Communication Namespace


ServiceRelativeUriAttribute Constructor (String, Type)

ServiceRelativeUriAttribute Constructor (String, Type)
Initializes a new instance of the ServiceRelativeUriAttribute class

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ServiceRelativeUriAttribute(
    string relativeUri,
    Type contractType
)
Public Sub New (
    relativeUri As String,
    contractType As Type
)
public:
ServiceRelativeUriAttribute(
    String^ relativeUri,
    Type^ contractType
)
DoubleTake.Communication.ServiceRelativeUriAttribute = function(relativeUri, contractType);

Parameters

relativeUri
Type: SystemString
contractType
Type: SystemType
See Also

Reference

ServiceRelativeUriAttribute Class
ServiceRelativeUriAttribute Overload
DoubleTake.Communication Namespace


ServiceRelativeUriAttribute Properties

ServiceRelativeUriAttribute Properties

The ServiceRelativeUriAttribute type exposes the following members.

Properties
 | Name | Description
Public property | ContractType |
Public property | RelativeUri |
Top
See Also

Reference

ServiceRelativeUriAttribute Class
DoubleTake.Communication Namespace


ServiceRelativeUriAttribute.ContractType Property

ServiceRelativeUriAttributeContractType Property

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Type ContractType { get; }
Public ReadOnly Property ContractType As Type
    Get
public:
property Type^ ContractType {
    Type^ get ();
}
function get_ContractType();

Property Value

Type: Type
See Also

Reference

ServiceRelativeUriAttribute Class
DoubleTake.Communication Namespace


ServiceRelativeUriAttribute.RelativeUri Property

ServiceRelativeUriAttributeRelativeUri Property

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Uri RelativeUri { get; }
Public ReadOnly Property RelativeUri As Uri
    Get
public:
property Uri^ RelativeUri {
    Uri^ get ();
}
function get_RelativeUri();

Property Value

Type: Uri
See Also

Reference

ServiceRelativeUriAttribute Class
DoubleTake.Communication Namespace


WSHttpEndpointSpecificationBase Class

WSHttpEndpointSpecificationBase Class
Inheritance Hierarchy
SystemObject
DoubleTake.CommunicationEndpointSpecificationBase
DoubleTake.CommunicationWSHttpEndpointSpecificationBase
DoubleTake.CommunicationDefaultEndpointSpecification

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public abstract class WSHttpEndpointSpecificationBase : EndpointSpecificationBase
Public MustInherit Class WSHttpEndpointSpecificationBase
    Inherits EndpointSpecificationBase
public ref class WSHttpEndpointSpecificationBase abstract : public EndpointSpecificationBase
DoubleTake.Communication.WSHttpEndpointSpecificationBase = function();

Type.createClass(
    'DoubleTake.Communication.WSHttpEndpointSpecificationBase',
    DoubleTake.Communication.EndpointSpecificationBase);

The WSHttpEndpointSpecificationBase type exposes the following members.

Constructors
 | Name | Description
Protected method | WSHttpEndpointSpecificationBase | Initializes a new instance of the WSHttpEndpointSpecificationBase class
Top
Properties
 | Name | Description
Public property | Binding | (Inherited from EndpointSpecificationBase.)
Protected property | CommunicationSettings | (Inherited from EndpointSpecificationBase.)
Top
Methods
 | Name | Description
Protected method | Configure |
Protected method | ConfigureBinding | (Overrides EndpointSpecificationBaseConfigureBinding(Binding).)
Protected method | CreateBinding | (Overrides EndpointSpecificationBaseCreateBinding.)
Public method | GetUri | (Inherited from EndpointSpecificationBase.)
Protected method | TryGetRelativeUri | (Inherited from EndpointSpecificationBase.)
Protected method | TryGetUriPort | (Overrides EndpointSpecificationBaseTryGetUriPort(NullableInt32, Int32).)
Top
See Also

Reference

DoubleTake.Communication Namespace


WSHttpEndpointSpecificationBase Constructor

WSHttpEndpointSpecificationBase Constructor
Initializes a new instance of the WSHttpEndpointSpecificationBase class

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
protected WSHttpEndpointSpecificationBase(
    ICommunicationSettings communicationSettings
)
Protected Sub New (
    communicationSettings As ICommunicationSettings
)
protected:
WSHttpEndpointSpecificationBase(
    ICommunicationSettings^ communicationSettings
)
DoubleTake.Communication.WSHttpEndpointSpecificationBase = function(communicationSettings);

Parameters

communicationSettings
Type: DoubleTake.CommunicationICommunicationSettings
See Also

Reference

WSHttpEndpointSpecificationBase Class
DoubleTake.Communication Namespace


WSHttpEndpointSpecificationBase Properties

WSHttpEndpointSpecificationBase Properties

The WSHttpEndpointSpecificationBase type exposes the following members.

Properties
 | Name | Description
Public property | Binding | (Inherited from EndpointSpecificationBase.)
Protected property | CommunicationSettings | (Inherited from EndpointSpecificationBase.)
Top
See Also

Reference

WSHttpEndpointSpecificationBase Class
DoubleTake.Communication Namespace


WSHttpEndpointSpecificationBase Methods

WSHttpEndpointSpecificationBase Methods

The WSHttpEndpointSpecificationBase type exposes the following members.

Methods
 | Name | Description
Protected method | Configure |
Protected method | ConfigureBinding | (Overrides EndpointSpecificationBaseConfigureBinding(Binding).)
Protected method | CreateBinding | (Overrides EndpointSpecificationBaseCreateBinding.)
Public method | GetUri | (Inherited from EndpointSpecificationBase.)
Protected method | TryGetRelativeUri | (Inherited from EndpointSpecificationBase.)
Protected method | TryGetUriPort | (Overrides EndpointSpecificationBaseTryGetUriPort(NullableInt32, Int32).)
Top
See Also

Reference

WSHttpEndpointSpecificationBase Class
DoubleTake.Communication Namespace


WSHttpEndpointSpecificationBase.Configure Method

WSHttpEndpointSpecificationBaseConfigure Method

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
protected abstract Binding Configure(
    WSHttpBinding binding
)
Protected MustOverride Function Configure (
    binding As WSHttpBinding
) As Binding
protected:
virtual Binding^ Configure(
    WSHttpBinding^ binding
) abstract
function Configure(binding);

Parameters

binding
Type: System.ServiceModelWSHttpBinding

Return Value

Type: Binding
See Also

Reference

WSHttpEndpointSpecificationBase Class
DoubleTake.Communication Namespace


WSHttpEndpointSpecificationBase.ConfigureBinding Method

WSHttpEndpointSpecificationBaseConfigureBinding Method

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
protected override sealed Binding ConfigureBinding(
    Binding binding
)
Protected Overrides NotOverridable Function ConfigureBinding (
    binding As Binding
) As Binding
protected:
virtual Binding^ ConfigureBinding(
    Binding^ binding
) override sealed
function ConfigureBinding(binding);

Parameters

binding
Type: System.ServiceModel.ChannelsBinding

Return Value

Type: Binding
See Also

Reference

WSHttpEndpointSpecificationBase Class
DoubleTake.Communication Namespace


WSHttpEndpointSpecificationBase.CreateBinding Method

WSHttpEndpointSpecificationBaseCreateBinding Method

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
protected override sealed Binding CreateBinding()
Protected Overrides NotOverridable Function CreateBinding As Binding
protected:
virtual Binding^ CreateBinding() override sealed
function CreateBinding();

Return Value

Type: Binding
See Also

Reference

WSHttpEndpointSpecificationBase Class
DoubleTake.Communication Namespace


WSHttpEndpointSpecificationBase.TryGetUriPort Method

WSHttpEndpointSpecificationBaseTryGetUriPort Method

Namespace: DoubleTake.Communication
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
protected override bool TryGetUriPort(
    Nullable<int> port,
    out int uriPort
)
Protected Overrides Function TryGetUriPort (
    port As Nullable(Of Integer),
    <OutAttribute> ByRef uriPort As Integer
) As Boolean
protected:
virtual bool TryGetUriPort(
    Nullable<int> port,
    [OutAttribute] int% uriPort
) override
function TryGetUriPort(port, uriPort);

Parameters

port
Type: SystemNullable Int32
uriPort
Type: SystemInt32

Return Value

Type: Boolean
See Also

Reference

WSHttpEndpointSpecificationBase Class
DoubleTake.Communication Namespace


DoubleTake.Core.Contract Namespace

DoubleTake.Core.Contract Namespace
Classes
 | Class | Description
Public class | ActivationAttribute | Represents an attribute of an ActivationCode.
Public class | ActivationCode | Represents an activation code which entitles a user to a license to use the product.
Public class | ActivationStatus | Represents the current licensing status of a server.
Public class | BooleanSetting |
Public class | EmailNotificationSettings |
Public class | EmailNotificationTestParameters |
Public class | ImageDeleteInfo | Represents information about how to delete an image.
Public class | ImageInfo | Represents information about an image used in an image based job.
Public class | ImageVhdInfo | Represents information about a virtual hard disk used to store an image in an image based job.
Public class | IntegerSetting |
Public class | MachineInfo | Represents product and server information about a server.
Public class | MultiStringSetting |
Public class | NamedSetting |
Public class | NetworkInterfaceInfo | Represents a network interface on a server.
Public class | OperatingSystemInfo | Represent the operating system of a server.
Public class | OperatingSystemVersion | Represents the version of an operating system.
Public class | PathBlockingEntry | A path blocking entry.
Public class | ProductInfo | Represents information about a product.
Public class | ProductVersion | Represents the version of a product.
Public class | Property |
Public class | ServerInfo | Represents information about a server.
Public class | StringSetting |
Public class | SystemStateCutoverStatus | Wraps the System state cutover status
Public class | SystemStateDumpNonDiskSystemStateInfoStatus | Wraps the System State DumpNonDiskSystemStateInfoStatus
Public class | SystemStateVerificationResult |
Public class | SystemStateVerificationStep |
Public class | UnicastIPAddressInfo | Represents a unicast IP address.
Public class | VolumeOptions | Represents a volume to protect and any changes to it's base configuration
Enumerations
 | Enumeration | Description
Public enumeration | AccessLevel | Represents the resulting access level when credentials are provided to the engine service.
Public enumeration | DesktopInteractionMode |
Public enumeration | DnsLockAction |
Public enumeration | EmailNotificationCategories |
Public enumeration | EngineJobType | Defines possible types of an engine connection. These values are referred to as "job types" in the engine infrastructure; they should not be confused with the JobType property.
Public enumeration | FullServerJobType | This enum is used during System State verification as well as rule generation of all full server job types. It is basically a wrapper for the SSMCLI::JobType enum class. It tells system state which rules and transform paths to generate, and/or validators to run. This has been around forever so the names are a little funky and don't really equate to the current job names. I have included what the current jobs should be using. For additional information, see Ed or Louie. Validation: -Move Server Migration job should use MoveServerMigration -All others should use FullServerProtection Rules and transforms: -Any job that is using a snapshot for recovery/failover/failback should use SnapshotMirror -A Full Server Failover job that has a DR image repository server as it's source should use ImageRepositoryFailover -All others should use FullServerProtection
Public enumeration | ImageEditedProperties |
Public enumeration | ImageType | Defines possible types of an image.
Public enumeration | LicenseType | Indicates the type of license permitted by an ActivationCode.
Public enumeration | OperatingSystemArchitecture | Defines possible architectures for an operating system.
Public enumeration | OperatingSystemProductType | Defines possible product types for an operating system.
Public enumeration | PathBlockingMode | This value represents if the path is blocked.
Public enumeration | RebootAction |
Public enumeration | ReplicationSetUsageType | Defines possible usage types for a replication set.
Public enumeration | ShutdownOption |
Public enumeration | VhdDeleteActionType |


AccessLevel Enumeration

AccessLevel Enumeration
Represents the resulting access level when credentials are provided to the engine service.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public enum AccessLevel
Public Enumeration AccessLevel
public enum class AccessLevel
DoubleTake.Core.Contract.AccessLevel = function();
DoubleTake.Core.Contract.AccessLevel.createEnum('DoubleTake.Core.Contract.AccessLevel', false);
Members
Member name | Value | Description
Unknown | -1 | The access level is unknown.
NoAccess | 0 | The credentials are not authenticated.
MonitorOnlyAccess | 1 | This access level is associated with membership in the Double-Take Monitors or dtmon security group.
FullAccess | 2 | This access level is associated with membership in the Double-Take Admin or dtadmin security group.
See Also

Reference

DoubleTake.Core.Contract Namespace


ActivationAttribute Class

ActivationAttribute Class
Represents an attribute of an ActivationCode.
Inheritance Hierarchy
SystemObject
DoubleTake.Core.ContractActivationAttribute

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class ActivationAttribute : IExtensibleDataObject
Public Class ActivationAttribute
    Implements IExtensibleDataObject
public ref class ActivationAttribute : IExtensibleDataObject
DoubleTake.Core.Contract.ActivationAttribute = function();

Type.createClass(
    'DoubleTake.Core.Contract.ActivationAttribute',
    null,
    IExtensibleDataObject);

The ActivationAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | ActivationAttribute | Initializes a new instance of the ActivationAttribute class
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Name | Gets or sets the name of this activation attribute.
Public property | Value | Gets or sets the value of this activation attribute.
Top
See Also

Reference

DoubleTake.Core.Contract Namespace


ActivationAttribute Constructor

ActivationAttribute Constructor
Initializes a new instance of the ActivationAttribute class

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ActivationAttribute()
Public Sub New
public:
ActivationAttribute()
DoubleTake.Core.Contract.ActivationAttribute = function();
See Also

Reference

ActivationAttribute Class
DoubleTake.Core.Contract Namespace


ActivationAttribute Properties

ActivationAttribute Properties

The ActivationAttribute type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Name | Gets or sets the name of this activation attribute.
Public property | Value | Gets or sets the value of this activation attribute.
Top
See Also

Reference

ActivationAttribute Class
DoubleTake.Core.Contract Namespace


ActivationAttribute.ExtensionData Property

ActivationAttributeExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

ActivationAttribute Class
DoubleTake.Core.Contract Namespace


ActivationAttribute.Name Property

ActivationAttributeName Property
Gets or sets the name of this activation attribute.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
function get_Name();
function set_Name(value);

Property Value

Type: String
The name of this activation attribute.
See Also

Reference

ActivationAttribute Class
DoubleTake.Core.Contract Namespace


ActivationAttribute.Value Property

ActivationAttributeValue Property
Gets or sets the value of this activation attribute.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public long Value { get; set; }
Public Property Value As Long
    Get
    Set
public:
property long long Value {
    long long get ();
    void set (long long value);
}
function get_Value();
function set_Value(value);

Property Value

Type: Int64
The value of this activation attribute.
See Also

Reference

ActivationAttribute Class
DoubleTake.Core.Contract Namespace


ActivationCode Class

ActivationCode Class
Represents an activation code which entitles a user to a license to use the product.
Inheritance Hierarchy
SystemObject
DoubleTake.Core.ContractActivationCode

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class ActivationCode : IExtensibleDataObject
Public Class ActivationCode
    Implements IExtensibleDataObject
public ref class ActivationCode : IExtensibleDataObject
DoubleTake.Core.Contract.ActivationCode = function();

Type.createClass(
    'DoubleTake.Core.Contract.ActivationCode',
    null,
    IExtensibleDataObject);

The ActivationCode type exposes the following members.

Constructors
 | Name | Description
Public method | ActivationCode | Initializes a new instance of the ActivationCode class
Top
Properties
 | Name | Description
Public property | Attributes | This value represents the attributes of the license.
Public property | Code | This value is a 24 character, alpha-numeric key which applies the appropriate license to the server.
Public property | ExpirationDate | The value is the license expiration date.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | IsEvaluation | This value is true if the license key is an evaluation license; otherwise, it is false.
Public property | IsExpired | This value is true if the license is expired; otherwise, it is false.
Public property | IsNodeLocked | This value is true if the license key must be activated; otherwise, it is false.
Public property | IsValid | This value is true if the license key is valid; otherwise, it is false.
Public property | LicenseType | This value represents the type of license.
Public property | MajorVersion | This value is the major version of the release associated with this license.
Public property | MinorVersion | This value is the minor version of the release associated with this license.
Public property | ProductCode | This value is the product code associated with this license.
Public property | ProductName | This value is the product name associated with this license.
Public property | SerialNumber | This value is the serial number associated with this license.
Top
See Also

Reference

DoubleTake.Core.Contract Namespace


ActivationCode Constructor

ActivationCode Constructor
Initializes a new instance of the ActivationCode class

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ActivationCode()
Public Sub New
public:
ActivationCode()
DoubleTake.Core.Contract.ActivationCode = function();
See Also

Reference

ActivationCode Class
DoubleTake.Core.Contract Namespace


ActivationCode Properties

ActivationCode Properties

The ActivationCode type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | This value represents the attributes of the license.
Public property | Code | This value is a 24 character, alpha-numeric key which applies the appropriate license to the server.
Public property | ExpirationDate | The value is the license expiration date.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | IsEvaluation | This value is true if the license key is an evaluation license; otherwise, it is false.
Public property | IsExpired | This value is true if the license is expired; otherwise, it is false.
Public property | IsNodeLocked | This value is true if the license key must be activated; otherwise, it is false.
Public property | IsValid | This value is true if the license key is valid; otherwise, it is false.
Public property | LicenseType | This value represents the type of license.
Public property | MajorVersion | This value is the major version of the release associated with this license.
Public property | MinorVersion | This value is the minor version of the release associated with this license.
Public property | ProductCode | This value is the product code associated with this license.
Public property | ProductName | This value is the product name associated with this license.
Public property | SerialNumber | This value is the serial number associated with this license.
Top
See Also

Reference

ActivationCode Class
DoubleTake.Core.Contract Namespace


ActivationCode.Attributes Property

ActivationCodeAttributes Property
This value represents the attributes of the license.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ActivationAttribute[] Attributes { get; set; }
Public Property Attributes As ActivationAttribute()
    Get
    Set
public:
property array<ActivationAttribute^>^ Attributes {
    array<ActivationAttribute^>^ get ();
    void set (array<ActivationAttribute^>^ value);
}
function get_Attributes();
function set_Attributes(value);

Property Value

Type: ActivationAttribute
An array of ActivationAttribute that represents the attributes this activation code.
See Also

Reference

ActivationCode Class
DoubleTake.Core.Contract Namespace


ActivationCode.Code Property

ActivationCodeCode Property
This value is a 24 character, alpha-numeric key which applies the appropriate license to the server.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Code { get; set; }
Public Property Code As String
    Get
    Set
public:
property String^ Code {
    String^ get ();
    void set (String^ value);
}
function get_Code();
function set_Code(value);

Property Value

Type: String
The text of the activation code.
See Also

Reference

ActivationCode Class
DoubleTake.Core.Contract Namespace


ActivationCode.ExpirationDate Property

ActivationCodeExpirationDate Property
The value is the license expiration date.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public DateTime ExpirationDate { get; set; }
Public Property ExpirationDate As DateTime
    Get
    Set
public:
property DateTime ExpirationDate {
    DateTime get ();
    void set (DateTime value);
}
function get_ExpirationDate();
function set_ExpirationDate(value);

Property Value

Type: DateTime
The expiration date of this activation code.
See Also

Reference

ActivationCode Class
DoubleTake.Core.Contract Namespace


ActivationCode.ExtensionData Property

ActivationCodeExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

ActivationCode Class
DoubleTake.Core.Contract Namespace


ActivationCode.IsEvaluation Property

ActivationCodeIsEvaluation Property
This value is true if the license key is an evaluation license; otherwise, it is false.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsEvaluation { get; set; }
Public Property IsEvaluation As Boolean
    Get
    Set
public:
property bool IsEvaluation {
    bool get ();
    void set (bool value);
}
function get_IsEvaluation();
function set_IsEvaluation(value);

Property Value

Type: Boolean
if this this activation code represents an evaluation license; otherwise, .
See Also

Reference

ActivationCode Class
DoubleTake.Core.Contract Namespace


ActivationCode.IsExpired Property

ActivationCodeIsExpired Property
This value is true if the license is expired; otherwise, it is false.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsExpired { get; set; }
Public Property IsExpired As Boolean
    Get
    Set
public:
property bool IsExpired {
    bool get ();
    void set (bool value);
}
function get_IsExpired();
function set_IsExpired(value);

Property Value

Type: Boolean
if this activation code is expired; otherwise, .
See Also

Reference

ActivationCode Class
DoubleTake.Core.Contract Namespace


ActivationCode.IsNodeLocked Property

ActivationCodeIsNodeLocked Property
This value is true if the license key must be activated; otherwise, it is false.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsNodeLocked { get; set; }
Public Property IsNodeLocked As Boolean
    Get
    Set
public:
property bool IsNodeLocked {
    bool get ();
    void set (bool value);
}
function get_IsNodeLocked();
function set_IsNodeLocked(value);

Property Value

Type: Boolean
if this this activation code represents a node-locked license; otherwise, .
See Also

Reference

ActivationCode Class
DoubleTake.Core.Contract Namespace


ActivationCode.IsValid Property

ActivationCodeIsValid Property
This value is true if the license key is valid; otherwise, it is false.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsValid { get; set; }
Public Property IsValid As Boolean
    Get
    Set
public:
property bool IsValid {
    bool get ();
    void set (bool value);
}
function get_IsValid();
function set_IsValid(value);

Property Value

Type: Boolean
if this activation code is valid; otherwise, .
See Also

Reference

ActivationCode Class
DoubleTake.Core.Contract Namespace


ActivationCode.LicenseType Property

ActivationCodeLicenseType Property
This value represents the type of license.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public LicenseType LicenseType { get; set; }
Public Property LicenseType As LicenseType
    Get
    Set
public:
property LicenseType LicenseType {
    LicenseType get ();
    void set (LicenseType value);
}
function get_LicenseType();
function set_LicenseType(value);

Property Value

Type: LicenseType
A LicenseType value that indicates the type of license this activation code entitle the user to.
See Also

Reference

ActivationCode Class
DoubleTake.Core.Contract Namespace


ActivationCode.MajorVersion Property

ActivationCodeMajorVersion Property
This value is the major version of the release associated with this license.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int MajorVersion { get; set; }
Public Property MajorVersion As Integer
    Get
    Set
public:
property int MajorVersion {
    int get ();
    void set (int value);
}
function get_MajorVersion();
function set_MajorVersion(value);

Property Value

Type: Int32
The major version of the release associated with this activation code.
See Also

Reference

ActivationCode Class
DoubleTake.Core.Contract Namespace


ActivationCode.MinorVersion Property

ActivationCodeMinorVersion Property
This value is the minor version of the release associated with this license.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int MinorVersion { get; set; }
Public Property MinorVersion As Integer
    Get
    Set
public:
property int MinorVersion {
    int get ();
    void set (int value);
}
function get_MinorVersion();
function set_MinorVersion(value);

Property Value

Type: Int32
The minor version of the release associated with this activation code.
See Also

Reference

ActivationCode Class
DoubleTake.Core.Contract Namespace


ActivationCode.ProductCode Property

ActivationCodeProductCode Property
This value is the product code associated with this license.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int ProductCode { get; set; }
Public Property ProductCode As Integer
    Get
    Set
public:
property int ProductCode {
    int get ();
    void set (int value);
}
function get_ProductCode();
function set_ProductCode(value);

Property Value

Type: Int32
The product code associated with this activation code.
See Also

Reference

ActivationCode Class
DoubleTake.Core.Contract Namespace


ActivationCode.ProductName Property

ActivationCodeProductName Property
This value is the product name associated with this license.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string ProductName { get; set; }
Public Property ProductName As String
    Get
    Set
public:
property String^ ProductName {
    String^ get ();
    void set (String^ value);
}
function get_ProductName();
function set_ProductName(value);

Property Value

Type: String
The name of the product associated with this activation code.
See Also

Reference

ActivationCode Class
DoubleTake.Core.Contract Namespace


ActivationCode.SerialNumber Property

ActivationCodeSerialNumber Property
This value is the serial number associated with this license.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int SerialNumber { get; set; }
Public Property SerialNumber As Integer
    Get
    Set
public:
property int SerialNumber {
    int get ();
    void set (int value);
}
function get_SerialNumber();
function set_SerialNumber(value);

Property Value

Type: Int32
The serial number associated with this activation code.
See Also

Reference

ActivationCode Class
DoubleTake.Core.Contract Namespace


ActivationStatus Class

ActivationStatus Class
Represents the current licensing status of a server.
Inheritance Hierarchy
SystemObject
DoubleTake.Core.ContractActivationStatus

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class ActivationStatus : IExtensibleDataObject
Public Class ActivationStatus
    Implements IExtensibleDataObject
public ref class ActivationStatus : IExtensibleDataObject
DoubleTake.Core.Contract.ActivationStatus = function();

Type.createClass(
    'DoubleTake.Core.Contract.ActivationStatus',
    null,
    IExtensibleDataObject);

The ActivationStatus type exposes the following members.

Constructors
 | Name | Description
Public method | ActivationStatus | Initializes a new instance of the ActivationStatus class
Top
Properties
 | Name | Description
Public property | AddOnCodes | This value represents the current add-on licenses on this server.This property is no longer used.
Public property | Codes | This value represents the current licenses on this server.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | IsNodeLocked | This value is true if the license key must be activated; otherwise, it is false.
Public property | IsValid | This value is true if the license key is valid; otherwise, it is false.
Top
See Also

Reference

DoubleTake.Core.Contract Namespace


ActivationStatus Constructor

ActivationStatus Constructor
Initializes a new instance of the ActivationStatus class

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ActivationStatus()
Public Sub New
public:
ActivationStatus()
DoubleTake.Core.Contract.ActivationStatus = function();
See Also

Reference

ActivationStatus Class
DoubleTake.Core.Contract Namespace


ActivationStatus Properties

ActivationStatus Properties

The ActivationStatus type exposes the following members.

Properties
 | Name | Description
Public property | AddOnCodes | This value represents the current add-on licenses on this server.This property is no longer used.
Public property | Codes | This value represents the current licenses on this server.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | IsNodeLocked | This value is true if the license key must be activated; otherwise, it is false.
Public property | IsValid | This value is true if the license key is valid; otherwise, it is false.
Top
See Also

Reference

ActivationStatus Class
DoubleTake.Core.Contract Namespace


ActivationStatus.AddOnCodes Property

ActivationStatusAddOnCodes Property
This value represents the current add-on licenses on this server.This property is no longer used.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ActivationCode[] AddOnCodes { get; set; }
Public Property AddOnCodes As ActivationCode()
    Get
    Set
public:
property array<ActivationCode^>^ AddOnCodes {
    array<ActivationCode^>^ get ();
    void set (array<ActivationCode^>^ value);
}
function get_AddOnCodes();
function set_AddOnCodes(value);

Property Value

Type: ActivationCode
An array of ActivationCode that represents the current add-on codes on this server.
Remarks
Add-on codes are not used by recent versions of the product. A single installation of the product may have any number of activation codes, and these are returned by the [P:Codes] property. This property is provided only for compatibility with older versions.
See Also

Reference

ActivationStatus Class
DoubleTake.Core.Contract Namespace


ActivationStatus.Codes Property

ActivationStatusCodes Property
This value represents the current licenses on this server.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ActivationCode[] Codes { get; set; }
Public Property Codes As ActivationCode()
    Get
    Set
public:
property array<ActivationCode^>^ Codes {
    array<ActivationCode^>^ get ();
    void set (array<ActivationCode^>^ value);
}
function get_Codes();
function set_Codes(value);

Property Value

Type: ActivationCode
An array of ActivationCode that represents the current activation codes on this server.
See Also

Reference

ActivationStatus Class
DoubleTake.Core.Contract Namespace


ActivationStatus.ExtensionData Property

ActivationStatusExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

ActivationStatus Class
DoubleTake.Core.Contract Namespace


ActivationStatus.IsNodeLocked Property

ActivationStatusIsNodeLocked Property
This value is true if the license key must be activated; otherwise, it is false.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsNodeLocked { get; set; }
Public Property IsNodeLocked As Boolean
    Get
    Set
public:
property bool IsNodeLocked {
    bool get ();
    void set (bool value);
}
function get_IsNodeLocked();
function set_IsNodeLocked(value);

Property Value

Type: Boolean
if the license on this server is node locked; otherwise, .
See Also

Reference

ActivationStatus Class
DoubleTake.Core.Contract Namespace


ActivationStatus.IsValid Property

ActivationStatusIsValid Property
This value is true if the license key is valid; otherwise, it is false.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsValid { get; set; }
Public Property IsValid As Boolean
    Get
    Set
public:
property bool IsValid {
    bool get ();
    void set (bool value);
}
function get_IsValid();
function set_IsValid(value);

Property Value

Type: Boolean
if the license on this server is valid; otherwise, .
See Also

Reference

ActivationStatus Class
DoubleTake.Core.Contract Namespace


BooleanSetting Class

BooleanSetting Class
Inheritance Hierarchy
SystemObject
ObservableObject
DoubleTake.Core.ContractNamedSetting
DoubleTake.Core.ContractBooleanSetting

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class BooleanSetting : NamedSetting
Public Class BooleanSetting
    Inherits NamedSetting
public ref class BooleanSetting : public NamedSetting
DoubleTake.Core.Contract.BooleanSetting = function();

Type.createClass(
    'DoubleTake.Core.Contract.BooleanSetting',
    DoubleTake.Core.Contract.NamedSetting);

The BooleanSetting type exposes the following members.

Constructors
 | Name | Description
Public method | BooleanSetting | Initializes a new instance of the BooleanSetting class
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from NamedSetting.)
Public property | Name | (Inherited from NamedSetting.)
Public property | TypeName | (Inherited from NamedSetting.)
Public property | Value |
Top
See Also

Reference

DoubleTake.Core.Contract Namespace


BooleanSetting Constructor

BooleanSetting Constructor
Initializes a new instance of the BooleanSetting class

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public BooleanSetting()
Public Sub New
public:
BooleanSetting()
DoubleTake.Core.Contract.BooleanSetting = function();
See Also

Reference

BooleanSetting Class
DoubleTake.Core.Contract Namespace


BooleanSetting Properties

BooleanSetting Properties

The BooleanSetting type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from NamedSetting.)
Public property | Name | (Inherited from NamedSetting.)
Public property | TypeName | (Inherited from NamedSetting.)
Public property | Value |
Top
See Also

Reference

BooleanSetting Class
DoubleTake.Core.Contract Namespace


BooleanSetting.Value Property

BooleanSettingValue Property

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool Value { get; set; }
Public Property Value As Boolean
    Get
    Set
public:
property bool Value {
    bool get ();
    void set (bool value);
}
function get_Value();
function set_Value(value);

Property Value

Type: Boolean
See Also

Reference

BooleanSetting Class
DoubleTake.Core.Contract Namespace


DesktopInteractionMode Enumeration

DesktopInteractionMode Enumeration

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public enum DesktopInteractionMode
Public Enumeration DesktopInteractionMode
public enum class DesktopInteractionMode
DoubleTake.Core.Contract.DesktopInteractionMode = function();
DoubleTake.Core.Contract.DesktopInteractionMode.createEnum('DoubleTake.Core.Contract.DesktopInteractionMode', false);
Members
Member name | Value | Description
None | 0 | The script will execute silently in the background.
Interact | 1 | Script processing will be displayed on screen.
See Also

Reference

DoubleTake.Core.Contract Namespace


DnsLockAction Enumeration

DnsLockAction Enumeration

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public enum DnsLockAction
Public Enumeration DnsLockAction
public enum class DnsLockAction
DoubleTake.Core.Contract.DnsLockAction = function();
DoubleTake.Core.Contract.DnsLockAction.createEnum('DoubleTake.Core.Contract.DnsLockAction', false);
Members
Member name | Value | Description
None | 0 |
LockDnsRecords | 1 |
UnlockDnsRecords | 2 |
See Also

Reference

DoubleTake.Core.Contract Namespace


EmailNotificationCategories Enumeration

EmailNotificationCategories Enumeration

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public enum EmailNotificationCategories
Public Enumeration EmailNotificationCategories
public enum class EmailNotificationCategories
DoubleTake.Core.Contract.EmailNotificationCategories = function();
DoubleTake.Core.Contract.EmailNotificationCategories.createEnum('DoubleTake.Core.Contract.EmailNotificationCategories', false);
Members
Member name | Value | Description
None | 0 |
Information | 1 |
Warning | 2 |
Error | 4 |
All | 255 |
See Also

Reference

DoubleTake.Core.Contract Namespace


EmailNotificationSettings Class

EmailNotificationSettings Class
Inheritance Hierarchy
SystemObject
ObservableObject
DoubleTake.Core.ContractEmailNotificationSettings

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class EmailNotificationSettings : ObservableObject,
    IExtensibleDataObject
Public Class EmailNotificationSettings
    Inherits ObservableObject
    Implements IExtensibleDataObject
public ref class EmailNotificationSettings : public ObservableObject,
    IExtensibleDataObject
DoubleTake.Core.Contract.EmailNotificationSettings = function();

Type.createClass(
    'DoubleTake.Core.Contract.EmailNotificationSettings',
    DoubleTake.Common.ComponentModel.ObservableObject,
    IExtensibleDataObject);

The EmailNotificationSettings type exposes the following members.

Constructors
 | Name | Description
Public method | EmailNotificationSettings | Initializes a new instance of the EmailNotificationSettings class
Top
Properties
 | Name | Description
Public property | Categories | Reflects the Double-Take "EmailIncludeCategories" registry setting.
Public property | ExcludeIds | Reflects the Double-Take "EmailExcludeIds" registry setting.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | FromAddress | Reflects the Double-Take "EmailFromAddress" registry setting.
Public property | IsEnabled | Reflects the Double-Take "EmailEnabled" registry setting.
Public property | IsEventDescriptionInSubject | Reflects the Double-Take "EmailSubjectDesc" registry setting.
Public property | IsSmtpLogOnEnabled | Reflects the Double-Take "EmailSmtpLogin" registry setting.
Public property | Password | Reflects the Double-Take "EmailPassword" registry setting.
Public property | Port | Reflects the Double-Take "EmailServerPort" registry setting.
Public property | Recipients | Reflects the Double-Take "EmailNotificationList" registry setting.
Public property | Server | Reflects the Double-Take "EmailServer" registry setting.
Public property | SubjectPrefix | Reflects the Double-Take "EmailSubjectPrefix" registry setting.
Public property | UserName | Reflects the Double-Take "EmailUsername" registry setting.
Top
See Also

Reference

DoubleTake.Core.Contract Namespace


EmailNotificationSettings Constructor

EmailNotificationSettings Constructor
Initializes a new instance of the EmailNotificationSettings class

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public EmailNotificationSettings()
Public Sub New
public:
EmailNotificationSettings()
DoubleTake.Core.Contract.EmailNotificationSettings = function();
See Also

Reference

EmailNotificationSettings Class
DoubleTake.Core.Contract Namespace


EmailNotificationSettings Properties

EmailNotificationSettings Properties

The EmailNotificationSettings type exposes the following members.

Properties
 | Name | Description
Public property | Categories | Reflects the Double-Take "EmailIncludeCategories" registry setting.
Public property | ExcludeIds | Reflects the Double-Take "EmailExcludeIds" registry setting.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | FromAddress | Reflects the Double-Take "EmailFromAddress" registry setting.
Public property | IsEnabled | Reflects the Double-Take "EmailEnabled" registry setting.
Public property | IsEventDescriptionInSubject | Reflects the Double-Take "EmailSubjectDesc" registry setting.
Public property | IsSmtpLogOnEnabled | Reflects the Double-Take "EmailSmtpLogin" registry setting.
Public property | Password | Reflects the Double-Take "EmailPassword" registry setting.
Public property | Port | Reflects the Double-Take "EmailServerPort" registry setting.
Public property | Recipients | Reflects the Double-Take "EmailNotificationList" registry setting.
Public property | Server | Reflects the Double-Take "EmailServer" registry setting.
Public property | SubjectPrefix | Reflects the Double-Take "EmailSubjectPrefix" registry setting.
Public property | UserName | Reflects the Double-Take "EmailUsername" registry setting.
Top
See Also

Reference

EmailNotificationSettings Class
DoubleTake.Core.Contract Namespace


EmailNotificationSettings.Categories Property

EmailNotificationSettingsCategories Property
Reflects the Double-Take "EmailIncludeCategories" registry setting.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public EmailNotificationCategories Categories { get; set; }
Public Property Categories As EmailNotificationCategories
    Get
    Set
public:
property EmailNotificationCategories Categories {
    EmailNotificationCategories get ();
    void set (EmailNotificationCategories value);
}
function get_Categories();
function set_Categories(value);

Property Value

Type: EmailNotificationCategories
See Also

Reference

EmailNotificationSettings Class
DoubleTake.Core.Contract Namespace


EmailNotificationSettings.ExcludeIds Property

EmailNotificationSettingsExcludeIds Property
Reflects the Double-Take "EmailExcludeIds" registry setting.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string[] ExcludeIds { get; set; }
Public Property ExcludeIds As String()
    Get
    Set
public:
property array<String^>^ ExcludeIds {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
function get_ExcludeIds();
function set_ExcludeIds(value);

Property Value

Type: String
See Also

Reference

EmailNotificationSettings Class
DoubleTake.Core.Contract Namespace


EmailNotificationSettings.ExtensionData Property

EmailNotificationSettingsExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

EmailNotificationSettings Class
DoubleTake.Core.Contract Namespace


EmailNotificationSettings.FromAddress Property

EmailNotificationSettingsFromAddress Property
Reflects the Double-Take "EmailFromAddress" registry setting.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string FromAddress { get; set; }
Public Property FromAddress As String
    Get
    Set
public:
property String^ FromAddress {
    String^ get ();
    void set (String^ value);
}
function get_FromAddress();
function set_FromAddress(value);

Property Value

Type: String
See Also

Reference

EmailNotificationSettings Class
DoubleTake.Core.Contract Namespace


EmailNotificationSettings.IsEnabled Property

EmailNotificationSettingsIsEnabled Property
Reflects the Double-Take "EmailEnabled" registry setting.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsEnabled { get; set; }
Public Property IsEnabled As Boolean
    Get
    Set
public:
property bool IsEnabled {
    bool get ();
    void set (bool value);
}
function get_IsEnabled();
function set_IsEnabled(value);

Property Value

Type: Boolean
See Also

Reference

EmailNotificationSettings Class
DoubleTake.Core.Contract Namespace


EmailNotificationSettings.IsEventDescriptionInSubject Property

EmailNotificationSettingsIsEventDescriptionInSubject Property
Reflects the Double-Take "EmailSubjectDesc" registry setting.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsEventDescriptionInSubject { get; set; }
Public Property IsEventDescriptionInSubject As Boolean
    Get
    Set
public:
property bool IsEventDescriptionInSubject {
    bool get ();
    void set (bool value);
}
function get_IsEventDescriptionInSubject();
function set_IsEventDescriptionInSubject(value);

Property Value

Type: Boolean
See Also

Reference

EmailNotificationSettings Class
DoubleTake.Core.Contract Namespace


EmailNotificationSettings.IsSmtpLogOnEnabled Property

EmailNotificationSettingsIsSmtpLogOnEnabled Property
Reflects the Double-Take "EmailSmtpLogin" registry setting.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsSmtpLogOnEnabled { get; set; }
Public Property IsSmtpLogOnEnabled As Boolean
    Get
    Set
public:
property bool IsSmtpLogOnEnabled {
    bool get ();
    void set (bool value);
}
function get_IsSmtpLogOnEnabled();
function set_IsSmtpLogOnEnabled(value);

Property Value

Type: Boolean
See Also

Reference

EmailNotificationSettings Class
DoubleTake.Core.Contract Namespace


EmailNotificationSettings.Password Property

EmailNotificationSettingsPassword Property
Reflects the Double-Take "EmailPassword" registry setting.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Password { get; set; }
Public Property Password As String
    Get
    Set
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}
function get_Password();
function set_Password(value);

Property Value

Type: String
See Also

Reference

EmailNotificationSettings Class
DoubleTake.Core.Contract Namespace


EmailNotificationSettings.Port Property

EmailNotificationSettingsPort Property
Reflects the Double-Take "EmailServerPort" registry setting.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int Port { get; set; }
Public Property Port As Integer
    Get
    Set
public:
property int Port {
    int get ();
    void set (int value);
}
function get_Port();
function set_Port(value);

Property Value

Type: Int32
See Also

Reference

EmailNotificationSettings Class
DoubleTake.Core.Contract Namespace


EmailNotificationSettings.Recipients Property

EmailNotificationSettingsRecipients Property
Reflects the Double-Take "EmailNotificationList" registry setting.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string[] Recipients { get; set; }
Public Property Recipients As String()
    Get
    Set
public:
property array<String^>^ Recipients {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
function get_Recipients();
function set_Recipients(value);

Property Value

Type: String
See Also

Reference

EmailNotificationSettings Class
DoubleTake.Core.Contract Namespace


EmailNotificationSettings.Server Property

EmailNotificationSettingsServer Property
Reflects the Double-Take "EmailServer" registry setting.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Server { get; set; }
Public Property Server As String
    Get
    Set
public:
property String^ Server {
    String^ get ();
    void set (String^ value);
}
function get_Server();
function set_Server(value);

Property Value

Type: String
See Also

Reference

EmailNotificationSettings Class
DoubleTake.Core.Contract Namespace


EmailNotificationSettings.SubjectPrefix Property

EmailNotificationSettingsSubjectPrefix Property
Reflects the Double-Take "EmailSubjectPrefix" registry setting.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string SubjectPrefix { get; set; }
Public Property SubjectPrefix As String
    Get
    Set
public:
property String^ SubjectPrefix {
    String^ get ();
    void set (String^ value);
}
function get_SubjectPrefix();
function set_SubjectPrefix(value);

Property Value

Type: String
See Also

Reference

EmailNotificationSettings Class
DoubleTake.Core.Contract Namespace


EmailNotificationSettings.UserName Property

EmailNotificationSettingsUserName Property
Reflects the Double-Take "EmailUsername" registry setting.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string UserName { get; set; }
Public Property UserName As String
    Get
    Set
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}
function get_UserName();
function set_UserName(value);

Property Value

Type: String
See Also

Reference

EmailNotificationSettings Class
DoubleTake.Core.Contract Namespace


EmailNotificationTestParameters Class

EmailNotificationTestParameters Class
Inheritance Hierarchy
SystemObject
ObservableObject
DoubleTake.Core.ContractEmailNotificationTestParameters

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class EmailNotificationTestParameters : ObservableObject,
    IExtensibleDataObject
Public Class EmailNotificationTestParameters
    Inherits ObservableObject
    Implements IExtensibleDataObject
public ref class EmailNotificationTestParameters : public ObservableObject,
    IExtensibleDataObject
DoubleTake.Core.Contract.EmailNotificationTestParameters = function();

Type.createClass(
    'DoubleTake.Core.Contract.EmailNotificationTestParameters',
    DoubleTake.Common.ComponentModel.ObservableObject,
    IExtensibleDataObject);

The EmailNotificationTestParameters type exposes the following members.

Constructors
 | Name | Description
Public method | EmailNotificationTestParameters | Initializes a new instance of the EmailNotificationTestParameters class
Top
Properties
 | Name | Description
Public property | BodyText |
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Recipients |
Top
See Also

Reference

DoubleTake.Core.Contract Namespace


EmailNotificationTestParameters Constructor

EmailNotificationTestParameters Constructor
Initializes a new instance of the EmailNotificationTestParameters class

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public EmailNotificationTestParameters()
Public Sub New
public:
EmailNotificationTestParameters()
DoubleTake.Core.Contract.EmailNotificationTestParameters = function();
See Also

Reference

EmailNotificationTestParameters Class
DoubleTake.Core.Contract Namespace


EmailNotificationTestParameters Properties

EmailNotificationTestParameters Properties

The EmailNotificationTestParameters type exposes the following members.

Properties
 | Name | Description
Public property | BodyText |
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Recipients |
Top
See Also

Reference

EmailNotificationTestParameters Class
DoubleTake.Core.Contract Namespace


EmailNotificationTestParameters.BodyText Property

EmailNotificationTestParametersBodyText Property

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string BodyText { get; set; }
Public Property BodyText As String
    Get
    Set
public:
property String^ BodyText {
    String^ get ();
    void set (String^ value);
}
function get_BodyText();
function set_BodyText(value);

Property Value

Type: String
See Also

Reference

EmailNotificationTestParameters Class
DoubleTake.Core.Contract Namespace


EmailNotificationTestParameters.ExtensionData Property

EmailNotificationTestParametersExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

EmailNotificationTestParameters Class
DoubleTake.Core.Contract Namespace


EmailNotificationTestParameters.Recipients Property

EmailNotificationTestParametersRecipients Property

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string[] Recipients { get; set; }
Public Property Recipients As String()
    Get
    Set
public:
property array<String^>^ Recipients {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
function get_Recipients();
function set_Recipients(value);

Property Value

Type: String
See Also

Reference

EmailNotificationTestParameters Class
DoubleTake.Core.Contract Namespace


EngineJobType Enumeration

EngineJobType Enumeration
Defines possible types of an engine connection. These values are referred to as "job types" in the engine infrastructure; they should not be confused with the JobType property.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public enum EngineJobType
Public Enumeration EngineJobType
public enum class EngineJobType
DoubleTake.Core.Contract.EngineJobType = function();
DoubleTake.Core.Contract.EngineJobType.createEnum('DoubleTake.Core.Contract.EngineJobType', false);
Members
Member name | Value | Description
NormalJob | 0 | This value is a files and folders connection.
ImageJob | 1 | This value is a Double-Take DR protection connection.
RecoveryJob | 2 | This value is a Double-Take DR recovery connection.
FullServerJob | 4 | This value is a full server connection.
GeoClusterJob | 8 | This value is a GeoCluster Replicate Disk resource connection.
MigrationJob | 16 | This value is a Double-Take Move connection.
FullServerRevertJob | 32 | This value is a full server reverse connection.
VraRecoveryJob | 64 | This value is a full server to ESX or Hyper-V reverse connection.
VraMigrationJob | 128 | This value is a full server to ESX or Hyper-V Double-Take Move connection.
DataOnlyOption | 256 | This value is for a connection that is replicating data only.
VraJob | 512 | This value is a full server to ESX or Hyper-V Double-Take Availability connection.
HyperVJob | 1024 | This value is a Hyper-V connection.
Win32MirrorOption | 2048 | This value is a connection that will override the server default and use the Win32 mirroring driver.
SourceConnectionResourceJob | 4096 | This value is a connection protecting a source cluster.
FullServerBackupJob | 8192 | This value is a full server reverse connection.
UvraJob | 16384 | This value is a full server to ESX appliance job.
NonClientAccessibleSnapshot | 32768 | Indicates that snapshots created for this connections should not have the VSS_CTX_CLIENT_ACCESSIBLE context.
FFO | 65536 | Indicates a connection used by LFFO jobs. This is not the real value for engine job type. Just for CreateConnectionAction to create connection.
LVRA_JOB | 131072 | Indicates a connection used by UVRA jobs. This is usually a connection to the local server (the source is same as the target) where the target drive is an iSCSI hosted by a Linux appliance. This is not the real value for engine job type. Just for CreateConnectionAction to create connection.
Invalid | 65535 | This value is an unknown connection.
Remarks
Values of this enumeration should not be sent between client and server.
See Also

Reference

DoubleTake.Core.Contract Namespace


FullServerJobType Enumeration

FullServerJobType Enumeration
This enum is used during System State verification as well as rule generation of all full server job types. It is basically a wrapper for the SSMCLI::JobType enum class. It tells system state which rules and transform paths to generate, and/or validators to run. This has been around forever so the names are a little funky and don't really equate to the current job names. I have included what the current jobs should be using. For additional information, see Ed or Louie. Validation: -Move Server Migration job should use MoveServerMigration -All others should use FullServerProtection Rules and transforms: -Any job that is using a snapshot for recovery/failover/failback should use SnapshotMirror -A Full Server Failover job that has a DR image repository server as it's source should use ImageRepositoryFailover -All others should use FullServerProtection

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public enum FullServerJobType
Public Enumeration FullServerJobType
public enum class FullServerJobType
DoubleTake.Core.Contract.FullServerJobType = function();
DoubleTake.Core.Contract.FullServerJobType.createEnum('DoubleTake.Core.Contract.FullServerJobType', false);
Members
Member name | Value | Description
FullServerProtection | 0 |
ImageRepositoryFailover | 1 |
BackupRecovery | 2 |
MoveServerMigration | 3 |
PreFailoverTest | 4 |
PreFailoverTestWithReservedIPs | 5 |
SnapshotMirror | 6 |
See Also

Reference

DoubleTake.Core.Contract Namespace


ImageDeleteInfo Class

ImageDeleteInfo Class
Represents information about how to delete an image.
Inheritance Hierarchy
SystemObject
DoubleTake.Core.ContractImageDeleteInfo

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class ImageDeleteInfo : IExtensibleDataObject
Public Class ImageDeleteInfo
    Implements IExtensibleDataObject
public ref class ImageDeleteInfo : IExtensibleDataObject
DoubleTake.Core.Contract.ImageDeleteInfo = function();

Type.createClass(
    'DoubleTake.Core.Contract.ImageDeleteInfo',
    null,
    IExtensibleDataObject);

The ImageDeleteInfo type exposes the following members.

Constructors
 | Name | Description
Public method | ImageDeleteInfo | Initializes a new instance of the ImageDeleteInfo class
Top
Properties
 | Name | Description
Public property | DeleteImage |
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | ImageId |
Public property | VhdDeleteAction |
Public property | VhdsToDelete |
Top
See Also

Reference

DoubleTake.Core.Contract Namespace


ImageDeleteInfo Constructor

ImageDeleteInfo Constructor
Initializes a new instance of the ImageDeleteInfo class

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ImageDeleteInfo()
Public Sub New
public:
ImageDeleteInfo()
DoubleTake.Core.Contract.ImageDeleteInfo = function();
See Also

Reference

ImageDeleteInfo Class
DoubleTake.Core.Contract Namespace


ImageDeleteInfo Properties

ImageDeleteInfo Properties

The ImageDeleteInfo type exposes the following members.

Properties
 | Name | Description
Public property | DeleteImage |
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | ImageId |
Public property | VhdDeleteAction |
Public property | VhdsToDelete |
Top
See Also

Reference

ImageDeleteInfo Class
DoubleTake.Core.Contract Namespace


ImageDeleteInfo.DeleteImage Property

ImageDeleteInfoDeleteImage Property

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool DeleteImage { get; set; }
Public Property DeleteImage As Boolean
    Get
    Set
public:
property bool DeleteImage {
    bool get ();
    void set (bool value);
}
function get_DeleteImage();
function set_DeleteImage(value);

Property Value

Type: Boolean
See Also

Reference

ImageDeleteInfo Class
DoubleTake.Core.Contract Namespace


ImageDeleteInfo.ExtensionData Property

ImageDeleteInfoExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

ImageDeleteInfo Class
DoubleTake.Core.Contract Namespace


ImageDeleteInfo.ImageId Property

ImageDeleteInfoImageId Property

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Guid ImageId { get; set; }
Public Property ImageId As Guid
    Get
    Set
public:
property Guid ImageId {
    Guid get ();
    void set (Guid value);
}
function get_ImageId();
function set_ImageId(value);

Property Value

Type: Guid
See Also

Reference

ImageDeleteInfo Class
DoubleTake.Core.Contract Namespace


ImageDeleteInfo.VhdDeleteAction Property

ImageDeleteInfoVhdDeleteAction Property

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VhdDeleteActionType VhdDeleteAction { get; set; }
Public Property VhdDeleteAction As VhdDeleteActionType
    Get
    Set
public:
property VhdDeleteActionType VhdDeleteAction {
    VhdDeleteActionType get ();
    void set (VhdDeleteActionType value);
}
function get_VhdDeleteAction();
function set_VhdDeleteAction(value);

Property Value

Type: VhdDeleteActionType
See Also

Reference

ImageDeleteInfo Class
DoubleTake.Core.Contract Namespace


ImageDeleteInfo.VhdsToDelete Property

ImageDeleteInfoVhdsToDelete Property

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public IEnumerable<string> VhdsToDelete { get; set; }
Public Property VhdsToDelete As IEnumerable(Of String)
    Get
    Set
public:
property IEnumerable<String^>^ VhdsToDelete {
    IEnumerable<String^>^ get ();
    void set (IEnumerable<String^>^ value);
}
function get_VhdsToDelete();
function set_VhdsToDelete(value);

Property Value

Type: IEnumerable String
See Also

Reference

ImageDeleteInfo Class
DoubleTake.Core.Contract Namespace


ImageEditedProperties Enumeration

ImageEditedProperties Enumeration

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public enum ImageEditedProperties
Public Enumeration ImageEditedProperties
public enum class ImageEditedProperties
DoubleTake.Core.Contract.ImageEditedProperties = function();
DoubleTake.Core.Contract.ImageEditedProperties.createEnum('DoubleTake.Core.Contract.ImageEditedProperties', false);
Members
Member name | Value | Description
None | 0 | None of the properties have been edited.
Name | 1 | The name has been edited.
Description | 2 | The description has been edited.
See Also

Reference

DoubleTake.Core.Contract Namespace


ImageInfo Class

ImageInfo Class
Represents information about an image used in an image based job.
Inheritance Hierarchy
SystemObject
DoubleTake.Core.ContractImageInfo

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class ImageInfo : IExtensibleDataObject
Public Class ImageInfo
    Implements IExtensibleDataObject
public ref class ImageInfo : IExtensibleDataObject
DoubleTake.Core.Contract.ImageInfo = function();

Type.createClass(
    'DoubleTake.Core.Contract.ImageInfo',
    null,
    IExtensibleDataObject);

The ImageInfo type exposes the following members.

Constructors
 | Name | Description
Public method | ImageInfo | Initializes a new instance of the ImageInfo class
Top
Properties
 | Name | Description
Public property | CreationTimestamp | This value is the date and time when the image was created.
Public property | Description | This value is the description of the image.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Id | This value is the image unique ID.
Public property | ImageName | This value is the name of the image. This value does not need to be unique.
Public property | ImageType | This value represents the type of image.
Public property | ProtectionConnectionId | This value is the connection ID, if there is a protection job using the image.
Public property | ProtectionJobName | This value is the job name, if there is a protection job using the image.
Public property | Snapshots | This value represents the current list of snapshots for the connection.
Public property | SourceImageMountLocation | This value is the full path to the root of image data where each of the .vhd files are mounted in a subdirectory by volume letter.
Public property | SourceName | This value is the name of the source that contained the original the image data.
Public property | State | This values is the state of the target.
Public property | VhdFiles | This value represents information about a virtual hard disk used to store an image.
Top
Fields
Name | Description
DescriptionPropertyName |
ImageCreationTimestampPropertyName |
ImageNamePropertyName |
ImageTypePropertyName |
OriginalImageProtectionJobIdPropertyName |
OriginalSourceDomainRole |
OriginalSourceNetworkIdPropertyName |
OriginalSourceSystemStateDirectories |
OriginalSourceSystemStateVolumes |
ProtectionConnectionIdPropertyName |
ProtectionJobIdPropertyName |
ProtectionJobPropertyName |
RepSetNamePropertyName |
SourceNamePropertyName |
Top
See Also

Reference

DoubleTake.Core.Contract Namespace


ImageInfo Constructor

ImageInfo Constructor
Initializes a new instance of the ImageInfo class

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ImageInfo()
Public Sub New
public:
ImageInfo()
DoubleTake.Core.Contract.ImageInfo = function();
See Also

Reference

ImageInfo Class
DoubleTake.Core.Contract Namespace


ImageInfo Properties

ImageInfo Properties

The ImageInfo type exposes the following members.

Properties
 | Name | Description
Public property | CreationTimestamp | This value is the date and time when the image was created.
Public property | Description | This value is the description of the image.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Id | This value is the image unique ID.
Public property | ImageName | This value is the name of the image. This value does not need to be unique.
Public property | ImageType | This value represents the type of image.
Public property | ProtectionConnectionId | This value is the connection ID, if there is a protection job using the image.
Public property | ProtectionJobName | This value is the job name, if there is a protection job using the image.
Public property | Snapshots | This value represents the current list of snapshots for the connection.
Public property | SourceImageMountLocation | This value is the full path to the root of image data where each of the .vhd files are mounted in a subdirectory by volume letter.
Public property | SourceName | This value is the name of the source that contained the original the image data.
Public property | State | This values is the state of the target.
Public property | VhdFiles | This value represents information about a virtual hard disk used to store an image.
Top
See Also

Reference

ImageInfo Class
DoubleTake.Core.Contract Namespace


ImageInfo.CreationTimestamp Property

ImageInfoCreationTimestamp Property
This value is the date and time when the image was created.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public DateTime CreationTimestamp { get; set; }
Public Property CreationTimestamp As DateTime
    Get
    Set
public:
property DateTime CreationTimestamp {
    DateTime get ();
    void set (DateTime value);
}
function get_CreationTimestamp();
function set_CreationTimestamp(value);

Property Value

Type: DateTime
See Also

Reference

ImageInfo Class
DoubleTake.Core.Contract Namespace


ImageInfo.Description Property

ImageInfoDescription Property
This value is the description of the image.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
function get_Description();
function set_Description(value);

Property Value

Type: String
See Also

Reference

ImageInfo Class
DoubleTake.Core.Contract Namespace


ImageInfo.ExtensionData Property

ImageInfoExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

ImageInfo Class
DoubleTake.Core.Contract Namespace


ImageInfo.Id Property

ImageInfoId Property
This value is the image unique ID.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Guid Id { get; set; }
Public Property Id As Guid
    Get
    Set
public:
property Guid Id {
    Guid get ();
    void set (Guid value);
}
function get_Id();
function set_Id(value);

Property Value

Type: Guid
See Also

Reference

ImageInfo Class
DoubleTake.Core.Contract Namespace


ImageInfo.ImageName Property

ImageInfoImageName Property
This value is the name of the image. This value does not need to be unique.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string ImageName { get; set; }
Public Property ImageName As String
    Get
    Set
public:
property String^ ImageName {
    String^ get ();
    void set (String^ value);
}
function get_ImageName();
function set_ImageName(value);

Property Value

Type: String
See Also

Reference

ImageInfo Class
DoubleTake.Core.Contract Namespace


ImageInfo.ImageType Property

ImageInfoImageType Property
This value represents the type of image.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ImageType ImageType { get; set; }
Public Property ImageType As ImageType
    Get
    Set
public:
property ImageType ImageType {
    ImageType get ();
    void set (ImageType value);
}
function get_ImageType();
function set_ImageType(value);

Property Value

Type: ImageType
See Also

Reference

ImageInfo Class
DoubleTake.Core.Contract Namespace


ImageInfo.ProtectionConnectionId Property

ImageInfoProtectionConnectionId Property
This value is the connection ID, if there is a protection job using the image.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string ProtectionConnectionId { get; set; }
Public Property ProtectionConnectionId As String
    Get
    Set
public:
property String^ ProtectionConnectionId {
    String^ get ();
    void set (String^ value);
}
function get_ProtectionConnectionId();
function set_ProtectionConnectionId(value);

Property Value

Type: String
See Also

Reference

ImageInfo Class
DoubleTake.Core.Contract Namespace


ImageInfo.ProtectionJobName Property

ImageInfoProtectionJobName Property
This value is the job name, if there is a protection job using the image.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string ProtectionJobName { get; set; }
Public Property ProtectionJobName As String
    Get
    Set
public:
property String^ ProtectionJobName {
    String^ get ();
    void set (String^ value);
}
function get_ProtectionJobName();
function set_ProtectionJobName(value);

Property Value

Type: String
See Also

Reference

ImageInfo Class
DoubleTake.Core.Contract Namespace


ImageInfo.Snapshots Property

ImageInfoSnapshots Property
This value represents the current list of snapshots for the connection.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public SnapshotEntry[] Snapshots { get; set; }
Public Property Snapshots As SnapshotEntry()
    Get
    Set
public:
property array<SnapshotEntry^>^ Snapshots {
    array<SnapshotEntry^>^ get ();
    void set (array<SnapshotEntry^>^ value);
}
function get_Snapshots();
function set_Snapshots(value);

Property Value

Type: SnapshotEntry
See Also

Reference

ImageInfo Class
DoubleTake.Core.Contract Namespace


ImageInfo.SourceImageMountLocation Property

ImageInfoSourceImageMountLocation Property
This value is the full path to the root of image data where each of the .vhd files are mounted in a subdirectory by volume letter.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string SourceImageMountLocation { get; set; }
Public Property SourceImageMountLocation As String
    Get
    Set
public:
property String^ SourceImageMountLocation {
    String^ get ();
    void set (String^ value);
}
function get_SourceImageMountLocation();
function set_SourceImageMountLocation(value);

Property Value

Type: String
See Also

Reference

ImageInfo Class
DoubleTake.Core.Contract Namespace


ImageInfo.SourceName Property

ImageInfoSourceName Property
This value is the name of the source that contained the original the image data.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string SourceName { get; set; }
Public Property SourceName As String
    Get
    Set
public:
property String^ SourceName {
    String^ get ();
    void set (String^ value);
}
function get_SourceName();
function set_SourceName(value);

Property Value

Type: String
See Also

Reference

ImageInfo Class
DoubleTake.Core.Contract Namespace


ImageInfo.State Property

ImageInfoState Property
This values is the state of the target.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public TargetStates State { get; set; }
Public Property State As TargetStates
    Get
    Set
public:
property TargetStates State {
    TargetStates get ();
    void set (TargetStates value);
}
function get_State();
function set_State(value);

Property Value

Type: TargetStates
See Also

Reference

ImageInfo Class
DoubleTake.Core.Contract Namespace


ImageInfo.VhdFiles Property

ImageInfoVhdFiles Property
This value represents information about a virtual hard disk used to store an image.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ImageVhdInfo[] VhdFiles { get; set; }
Public Property VhdFiles As ImageVhdInfo()
    Get
    Set
public:
property array<ImageVhdInfo^>^ VhdFiles {
    array<ImageVhdInfo^>^ get ();
    void set (array<ImageVhdInfo^>^ value);
}
function get_VhdFiles();
function set_VhdFiles(value);

Property Value

Type: ImageVhdInfo
See Also

Reference

ImageInfo Class
DoubleTake.Core.Contract Namespace


ImageInfo Fields

ImageInfo Fields

The ImageInfo type exposes the following members.

Fields
Name | Description
DescriptionPropertyName |
ImageCreationTimestampPropertyName |
ImageNamePropertyName |
ImageTypePropertyName |
OriginalImageProtectionJobIdPropertyName |
OriginalSourceDomainRole |
OriginalSourceNetworkIdPropertyName |
OriginalSourceSystemStateDirectories |
OriginalSourceSystemStateVolumes |
ProtectionConnectionIdPropertyName |
ProtectionJobIdPropertyName |
ProtectionJobPropertyName |
RepSetNamePropertyName |
SourceNamePropertyName |
Top
See Also

Reference

ImageInfo Class
DoubleTake.Core.Contract Namespace


ImageInfo.DescriptionPropertyName Field

ImageInfoDescriptionPropertyName Field

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public static readonly string DescriptionPropertyName
Public Shared ReadOnly DescriptionPropertyName As String
public:
static initonly String^ DescriptionPropertyName
var DoubleTake.Core.Contract.ImageInfo.DescriptionPropertyName

Field Value

Type: String
See Also

Reference

ImageInfo Class
DoubleTake.Core.Contract Namespace


ImageInfo.ImageCreationTimestampPropertyName Field

ImageInfoImageCreationTimestampPropertyName Field

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public static readonly string ImageCreationTimestampPropertyName
Public Shared ReadOnly ImageCreationTimestampPropertyName As String
public:
static initonly String^ ImageCreationTimestampPropertyName
var DoubleTake.Core.Contract.ImageInfo.ImageCreationTimestampPropertyName

Field Value

Type: String
See Also

Reference

ImageInfo Class
DoubleTake.Core.Contract Namespace


ImageInfo.ImageNamePropertyName Field

ImageInfoImageNamePropertyName Field

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public static readonly string ImageNamePropertyName
Public Shared ReadOnly ImageNamePropertyName As String
public:
static initonly String^ ImageNamePropertyName
var DoubleTake.Core.Contract.ImageInfo.ImageNamePropertyName

Field Value

Type: String
See Also

Reference

ImageInfo Class
DoubleTake.Core.Contract Namespace


ImageInfo.ImageTypePropertyName Field

ImageInfoImageTypePropertyName Field

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public static readonly string ImageTypePropertyName
Public Shared ReadOnly ImageTypePropertyName As String
public:
static initonly String^ ImageTypePropertyName
var DoubleTake.Core.Contract.ImageInfo.ImageTypePropertyName

Field Value

Type: String
See Also

Reference

ImageInfo Class
DoubleTake.Core.Contract Namespace


ImageInfo.OriginalImageProtectionJobIdPropertyName Field

ImageInfoOriginalImageProtectionJobIdPropertyName Field

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public static readonly string OriginalImageProtectionJobIdPropertyName
Public Shared ReadOnly OriginalImageProtectionJobIdPropertyName As String
public:
static initonly String^ OriginalImageProtectionJobIdPropertyName
var DoubleTake.Core.Contract.ImageInfo.OriginalImageProtectionJobIdPropertyName

Field Value

Type: String
See Also

Reference

ImageInfo Class
DoubleTake.Core.Contract Namespace


ImageInfo.OriginalSourceDomainRole Field

ImageInfoOriginalSourceDomainRole Field

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public static readonly string OriginalSourceDomainRole
Public Shared ReadOnly OriginalSourceDomainRole As String
public:
static initonly String^ OriginalSourceDomainRole
var DoubleTake.Core.Contract.ImageInfo.OriginalSourceDomainRole

Field Value

Type: String
See Also

Reference

ImageInfo Class
DoubleTake.Core.Contract Namespace


ImageInfo.OriginalSourceNetworkIdPropertyName Field

ImageInfoOriginalSourceNetworkIdPropertyName Field

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public static readonly string OriginalSourceNetworkIdPropertyName
Public Shared ReadOnly OriginalSourceNetworkIdPropertyName As String
public:
static initonly String^ OriginalSourceNetworkIdPropertyName
var DoubleTake.Core.Contract.ImageInfo.OriginalSourceNetworkIdPropertyName

Field Value

Type: String
See Also

Reference

ImageInfo Class
DoubleTake.Core.Contract Namespace


ImageInfo.OriginalSourceSystemStateDirectories Field

ImageInfoOriginalSourceSystemStateDirectories Field

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public static readonly string OriginalSourceSystemStateDirectories
Public Shared ReadOnly OriginalSourceSystemStateDirectories As String
public:
static initonly String^ OriginalSourceSystemStateDirectories
var DoubleTake.Core.Contract.ImageInfo.OriginalSourceSystemStateDirectories

Field Value

Type: String
See Also

Reference

ImageInfo Class
DoubleTake.Core.Contract Namespace


ImageInfo.OriginalSourceSystemStateVolumes Field

ImageInfoOriginalSourceSystemStateVolumes Field

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public static readonly string OriginalSourceSystemStateVolumes
Public Shared ReadOnly OriginalSourceSystemStateVolumes As String
public:
static initonly String^ OriginalSourceSystemStateVolumes
var DoubleTake.Core.Contract.ImageInfo.OriginalSourceSystemStateVolumes

Field Value

Type: String
See Also

Reference

ImageInfo Class
DoubleTake.Core.Contract Namespace


ImageInfo.ProtectionConnectionIdPropertyName Field

ImageInfoProtectionConnectionIdPropertyName Field

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public static readonly string ProtectionConnectionIdPropertyName
Public Shared ReadOnly ProtectionConnectionIdPropertyName As String
public:
static initonly String^ ProtectionConnectionIdPropertyName
var DoubleTake.Core.Contract.ImageInfo.ProtectionConnectionIdPropertyName

Field Value

Type: String
See Also

Reference

ImageInfo Class
DoubleTake.Core.Contract Namespace


ImageInfo.ProtectionJobIdPropertyName Field

ImageInfoProtectionJobIdPropertyName Field

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public static readonly string ProtectionJobIdPropertyName
Public Shared ReadOnly ProtectionJobIdPropertyName As String
public:
static initonly String^ ProtectionJobIdPropertyName
var DoubleTake.Core.Contract.ImageInfo.ProtectionJobIdPropertyName

Field Value

Type: String
See Also

Reference

ImageInfo Class
DoubleTake.Core.Contract Namespace


ImageInfo.ProtectionJobPropertyName Field

ImageInfoProtectionJobPropertyName Field

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public static readonly string ProtectionJobPropertyName
Public Shared ReadOnly ProtectionJobPropertyName As String
public:
static initonly String^ ProtectionJobPropertyName
var DoubleTake.Core.Contract.ImageInfo.ProtectionJobPropertyName

Field Value

Type: String
See Also

Reference

ImageInfo Class
DoubleTake.Core.Contract Namespace


ImageInfo.RepSetNamePropertyName Field

ImageInfoRepSetNamePropertyName Field

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public static readonly string RepSetNamePropertyName
Public Shared ReadOnly RepSetNamePropertyName As String
public:
static initonly String^ RepSetNamePropertyName
var DoubleTake.Core.Contract.ImageInfo.RepSetNamePropertyName

Field Value

Type: String
See Also

Reference

ImageInfo Class
DoubleTake.Core.Contract Namespace


ImageInfo.SourceNamePropertyName Field

ImageInfoSourceNamePropertyName Field

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public static readonly string SourceNamePropertyName
Public Shared ReadOnly SourceNamePropertyName As String
public:
static initonly String^ SourceNamePropertyName
var DoubleTake.Core.Contract.ImageInfo.SourceNamePropertyName

Field Value

Type: String
See Also

Reference

ImageInfo Class
DoubleTake.Core.Contract Namespace


ImageType Enumeration

ImageType Enumeration
Defines possible types of an image.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public enum ImageType
Public Enumeration ImageType
public enum class ImageType
DoubleTake.Core.Contract.ImageType = function();
DoubleTake.Core.Contract.ImageType.createEnum('DoubleTake.Core.Contract.ImageType', false);
Members
Member name | Value | Description
DataOnly | 0 | The image was created by a data only protection.
FullServer | 1 | The image was created by full server protection.
Unknown | 2 | The image is an unknown origin.
Remarks
Values of this enumeration should not be sent between client and server.
See Also

Reference

DoubleTake.Core.Contract Namespace


ImageVhdInfo Class

ImageVhdInfo Class
Represents information about a virtual hard disk used to store an image in an image based job.
Inheritance Hierarchy
SystemObject
DoubleTake.Core.ContractImageVhdInfo

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class ImageVhdInfo : IExtensibleDataObject
Public Class ImageVhdInfo
    Implements IExtensibleDataObject
public ref class ImageVhdInfo : IExtensibleDataObject
DoubleTake.Core.Contract.ImageVhdInfo = function();

Type.createClass(
    'DoubleTake.Core.Contract.ImageVhdInfo',
    null,
    IExtensibleDataObject);

The ImageVhdInfo type exposes the following members.

Constructors
 | Name | Description
Public method | ImageVhdInfo | Initializes a new instance of the ImageVhdInfo class
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | FilePath | This value is the full path and file name the .vhd image file.
Public property | FormatType | This value is the file system format for the image, for example NTFS or ReFS.
Public property | SizeInMB | This value is the size of the .vhd image file in megabytes.
Public property | UseExistingVhd | This value is true if an existing .vhd file should be used; otherwise, it is false. If you set this value to true, but no existing .vhd file exists, you will receive an error during job creation. If you set this value to false and an existing .vhd file exists, the file will be deleted and a new one will be created.
Public property | VolumeLetter | This value is the volume letter of the original volume this image is storing.
Top
See Also

Reference

DoubleTake.Core.Contract Namespace


ImageVhdInfo Constructor

ImageVhdInfo Constructor
Initializes a new instance of the ImageVhdInfo class

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ImageVhdInfo()
Public Sub New
public:
ImageVhdInfo()
DoubleTake.Core.Contract.ImageVhdInfo = function();
See Also

Reference

ImageVhdInfo Class
DoubleTake.Core.Contract Namespace


ImageVhdInfo Properties

ImageVhdInfo Properties

The ImageVhdInfo type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | FilePath | This value is the full path and file name the .vhd image file.
Public property | FormatType | This value is the file system format for the image, for example NTFS or ReFS.
Public property | SizeInMB | This value is the size of the .vhd image file in megabytes.
Public property | UseExistingVhd | This value is true if an existing .vhd file should be used; otherwise, it is false. If you set this value to true, but no existing .vhd file exists, you will receive an error during job creation. If you set this value to false and an existing .vhd file exists, the file will be deleted and a new one will be created.
Public property | VolumeLetter | This value is the volume letter of the original volume this image is storing.
Top
See Also

Reference

ImageVhdInfo Class
DoubleTake.Core.Contract Namespace


ImageVhdInfo.ExtensionData Property

ImageVhdInfoExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

ImageVhdInfo Class
DoubleTake.Core.Contract Namespace


ImageVhdInfo.FilePath Property

ImageVhdInfoFilePath Property
This value is the full path and file name the .vhd image file.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string FilePath { get; set; }
Public Property FilePath As String
    Get
    Set
public:
property String^ FilePath {
    String^ get ();
    void set (String^ value);
}
function get_FilePath();
function set_FilePath(value);

Property Value

Type: String
See Also

Reference

ImageVhdInfo Class
DoubleTake.Core.Contract Namespace


ImageVhdInfo.FormatType Property

ImageVhdInfoFormatType Property
This value is the file system format for the image, for example NTFS or ReFS.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string FormatType { get; set; }
Public Property FormatType As String
    Get
    Set
public:
property String^ FormatType {
    String^ get ();
    void set (String^ value);
}
function get_FormatType();
function set_FormatType(value);

Property Value

Type: String
See Also

Reference

ImageVhdInfo Class
DoubleTake.Core.Contract Namespace


ImageVhdInfo.SizeInMB Property

ImageVhdInfoSizeInMB Property
This value is the size of the .vhd image file in megabytes.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public long SizeInMB { get; set; }
Public Property SizeInMB As Long
    Get
    Set
public:
property long long SizeInMB {
    long long get ();
    void set (long long value);
}
function get_SizeInMB();
function set_SizeInMB(value);

Property Value

Type: Int64
See Also

Reference

ImageVhdInfo Class
DoubleTake.Core.Contract Namespace


ImageVhdInfo.UseExistingVhd Property

ImageVhdInfoUseExistingVhd Property
This value is true if an existing .vhd file should be used; otherwise, it is false. If you set this value to true, but no existing .vhd file exists, you will receive an error during job creation. If you set this value to false and an existing .vhd file exists, the file will be deleted and a new one will be created.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool UseExistingVhd { get; set; }
Public Property UseExistingVhd As Boolean
    Get
    Set
public:
property bool UseExistingVhd {
    bool get ();
    void set (bool value);
}
function get_UseExistingVhd();
function set_UseExistingVhd(value);

Property Value

Type: Boolean
See Also

Reference

ImageVhdInfo Class
DoubleTake.Core.Contract Namespace


ImageVhdInfo.VolumeLetter Property

ImageVhdInfoVolumeLetter Property
This value is the volume letter of the original volume this image is storing.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string VolumeLetter { get; set; }
Public Property VolumeLetter As String
    Get
    Set
public:
property String^ VolumeLetter {
    String^ get ();
    void set (String^ value);
}
function get_VolumeLetter();
function set_VolumeLetter(value);

Property Value

Type: String
See Also

Reference

ImageVhdInfo Class
DoubleTake.Core.Contract Namespace


IntegerSetting Class

IntegerSetting Class
Inheritance Hierarchy
SystemObject
ObservableObject
DoubleTake.Core.ContractNamedSetting
DoubleTake.Core.ContractIntegerSetting

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class IntegerSetting : NamedSetting
Public Class IntegerSetting
    Inherits NamedSetting
public ref class IntegerSetting : public NamedSetting
DoubleTake.Core.Contract.IntegerSetting = function();

Type.createClass(
    'DoubleTake.Core.Contract.IntegerSetting',
    DoubleTake.Core.Contract.NamedSetting);

The IntegerSetting type exposes the following members.

Constructors
 | Name | Description
Public method | IntegerSetting | Initializes a new instance of the IntegerSetting class
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from NamedSetting.)
Public property | Name | (Inherited from NamedSetting.)
Public property | TypeName | (Inherited from NamedSetting.)
Public property | Value |
Top
See Also

Reference

DoubleTake.Core.Contract Namespace


IntegerSetting Constructor

IntegerSetting Constructor
Initializes a new instance of the IntegerSetting class

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public IntegerSetting()
Public Sub New
public:
IntegerSetting()
DoubleTake.Core.Contract.IntegerSetting = function();
See Also

Reference

IntegerSetting Class
DoubleTake.Core.Contract Namespace


IntegerSetting Properties

IntegerSetting Properties

The IntegerSetting type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from NamedSetting.)
Public property | Name | (Inherited from NamedSetting.)
Public property | TypeName | (Inherited from NamedSetting.)
Public property | Value |
Top
See Also

Reference

IntegerSetting Class
DoubleTake.Core.Contract Namespace


IntegerSetting.Value Property

IntegerSettingValue Property

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public long Value { get; set; }
Public Property Value As Long
    Get
    Set
public:
property long long Value {
    long long get ();
    void set (long long value);
}
function get_Value();
function set_Value(value);

Property Value

Type: Int64
See Also

Reference

IntegerSetting Class
DoubleTake.Core.Contract Namespace


LicenseType Enumeration

LicenseType Enumeration
Indicates the type of license permitted by an ActivationCode.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public enum LicenseType
Public Enumeration LicenseType
public enum class LicenseType
DoubleTake.Core.Contract.LicenseType = function();
DoubleTake.Core.Contract.LicenseType.createEnum('DoubleTake.Core.Contract.LicenseType', false);
Members
Member name | Value | Description
NotApplicable | 0 | The license type is not applicable.
Limited | 1 | The license type is an evaluation license.
Single | 2 | The license type is a single server license.
Site | 3 | The license type is a site license.
NodeLockedKey | 4 | The key is an activation key.
See Also

Reference

DoubleTake.Core.Contract Namespace


MachineInfo Class

MachineInfo Class
Represents product and server information about a server.
Inheritance Hierarchy
SystemObject
DoubleTake.Core.ContractMachineInfo

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class MachineInfo : IExtensibleDataObject
Public Class MachineInfo
    Implements IExtensibleDataObject
public ref class MachineInfo : IExtensibleDataObject
DoubleTake.Core.Contract.MachineInfo = function();

Type.createClass(
    'DoubleTake.Core.Contract.MachineInfo',
    null,
    IExtensibleDataObject);

The MachineInfo type exposes the following members.

Constructors
 | Name | Description
Public method | MachineInfo | Initializes a new instance of the MachineInfo class
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | ProductInfo | Gets or sets the product information on the server.
Public property | ServerInfo | Gets or sets the server information on the server.
Top
See Also

Reference

DoubleTake.Core.Contract Namespace


MachineInfo Constructor

MachineInfo Constructor
Initializes a new instance of the MachineInfo class

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public MachineInfo()
Public Sub New
public:
MachineInfo()
DoubleTake.Core.Contract.MachineInfo = function();
See Also

Reference

MachineInfo Class
DoubleTake.Core.Contract Namespace


MachineInfo Properties

MachineInfo Properties

The MachineInfo type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | ProductInfo | Gets or sets the product information on the server.
Public property | ServerInfo | Gets or sets the server information on the server.
Top
See Also

Reference

MachineInfo Class
DoubleTake.Core.Contract Namespace


MachineInfo.ExtensionData Property

MachineInfoExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

MachineInfo Class
DoubleTake.Core.Contract Namespace


MachineInfo.ProductInfo Property

MachineInfoProductInfo Property
Gets or sets the product information on the server.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ProductInfo ProductInfo { get; set; }
Public Property ProductInfo As ProductInfo
    Get
    Set
public:
property ProductInfo^ ProductInfo {
    ProductInfo^ get ();
    void set (ProductInfo^ value);
}
function get_ProductInfo();
function set_ProductInfo(value);

Property Value

Type: ProductInfo
The product information.
See Also

Reference

MachineInfo Class
DoubleTake.Core.Contract Namespace


MachineInfo.ServerInfo Property

MachineInfoServerInfo Property
Gets or sets the server information on the server.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ServerInfo ServerInfo { get; set; }
Public Property ServerInfo As ServerInfo
    Get
    Set
public:
property ServerInfo^ ServerInfo {
    ServerInfo^ get ();
    void set (ServerInfo^ value);
}
function get_ServerInfo();
function set_ServerInfo(value);

Property Value

Type: ServerInfo
The server information.
See Also

Reference

MachineInfo Class
DoubleTake.Core.Contract Namespace


MultiStringSetting Class

MultiStringSetting Class
Inheritance Hierarchy
SystemObject
ObservableObject
DoubleTake.Core.ContractNamedSetting
DoubleTake.Core.ContractMultiStringSetting

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class MultiStringSetting : NamedSetting
Public Class MultiStringSetting
    Inherits NamedSetting
public ref class MultiStringSetting : public NamedSetting
DoubleTake.Core.Contract.MultiStringSetting = function();

Type.createClass(
    'DoubleTake.Core.Contract.MultiStringSetting',
    DoubleTake.Core.Contract.NamedSetting);

The MultiStringSetting type exposes the following members.

Constructors
 | Name | Description
Public method | MultiStringSetting | Initializes a new instance of the MultiStringSetting class
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from NamedSetting.)
Public property | Name | (Inherited from NamedSetting.)
Public property | TypeName | (Inherited from NamedSetting.)
Public property | Value |
Top
See Also

Reference

DoubleTake.Core.Contract Namespace


MultiStringSetting Constructor

MultiStringSetting Constructor
Initializes a new instance of the MultiStringSetting class

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public MultiStringSetting()
Public Sub New
public:
MultiStringSetting()
DoubleTake.Core.Contract.MultiStringSetting = function();
See Also

Reference

MultiStringSetting Class
DoubleTake.Core.Contract Namespace


MultiStringSetting Properties

MultiStringSetting Properties

The MultiStringSetting type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from NamedSetting.)
Public property | Name | (Inherited from NamedSetting.)
Public property | TypeName | (Inherited from NamedSetting.)
Public property | Value |
Top
See Also

Reference

MultiStringSetting Class
DoubleTake.Core.Contract Namespace


MultiStringSetting.Value Property

MultiStringSettingValue Property

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string[] Value { get; set; }
Public Property Value As String()
    Get
    Set
public:
property array<String^>^ Value {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
function get_Value();
function set_Value(value);

Property Value

Type: String
See Also

Reference

MultiStringSetting Class
DoubleTake.Core.Contract Namespace


NamedSetting Class

NamedSetting Class
Inheritance Hierarchy
SystemObject
ObservableObject
DoubleTake.Core.ContractNamedSetting
DoubleTake.Core.ContractBooleanSetting
DoubleTake.Core.ContractIntegerSetting
DoubleTake.Core.ContractMultiStringSetting
DoubleTake.Core.ContractStringSetting

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class NamedSetting : ObservableObject,
    IExtensibleDataObject
Public Class NamedSetting
    Inherits ObservableObject
    Implements IExtensibleDataObject
public ref class NamedSetting : public ObservableObject,
    IExtensibleDataObject
DoubleTake.Core.Contract.NamedSetting = function();

Type.createClass(
    'DoubleTake.Core.Contract.NamedSetting',
    DoubleTake.Common.ComponentModel.ObservableObject,
    IExtensibleDataObject);

The NamedSetting type exposes the following members.

Constructors
 | Name | Description
Public method | NamedSetting | Initializes a new instance of the NamedSetting class
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Name |
Public property | TypeName |
Top
See Also

Reference

DoubleTake.Core.Contract Namespace


NamedSetting Constructor

NamedSetting Constructor
Initializes a new instance of the NamedSetting class

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public NamedSetting()
Public Sub New
public:
NamedSetting()
DoubleTake.Core.Contract.NamedSetting = function();
See Also

Reference

NamedSetting Class
DoubleTake.Core.Contract Namespace


NamedSetting Properties

NamedSetting Properties

The NamedSetting type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Name |
Public property | TypeName |
Top
See Also

Reference

NamedSetting Class
DoubleTake.Core.Contract Namespace


NamedSetting.ExtensionData Property

NamedSettingExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

NamedSetting Class
DoubleTake.Core.Contract Namespace


NamedSetting.Name Property

NamedSettingName Property

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
function get_Name();
function set_Name(value);

Property Value

Type: String
See Also

Reference

NamedSetting Class
DoubleTake.Core.Contract Namespace


NamedSetting.TypeName Property

NamedSettingTypeName Property

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string TypeName { get; set; }
Public Property TypeName As String
    Get
    Set
public:
property String^ TypeName {
    String^ get ();
    void set (String^ value);
}
function get_TypeName();
function set_TypeName(value);

Property Value

Type: String
See Also

Reference

NamedSetting Class
DoubleTake.Core.Contract Namespace


NetworkInterfaceInfo Class

NetworkInterfaceInfo Class
Represents a network interface on a server.
Inheritance Hierarchy
SystemObject
DoubleTake.Core.ContractNetworkInterfaceInfo
DoubleTake.Virtualization.ContractVirtualNetworkInterfaceInfo

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class NetworkInterfaceInfo : IExtensibleDataObject
Public Class NetworkInterfaceInfo
    Implements IExtensibleDataObject
public ref class NetworkInterfaceInfo : IExtensibleDataObject
DoubleTake.Core.Contract.NetworkInterfaceInfo = function();

Type.createClass(
    'DoubleTake.Core.Contract.NetworkInterfaceInfo',
    null,
    IExtensibleDataObject);

The NetworkInterfaceInfo type exposes the following members.

Constructors
 | Name | Description
Public method | NetworkInterfaceInfo | Initializes a new instance of the NetworkInterfaceInfo class
Top
Properties
 | Name | Description
Public property | Description | This value is the description of the NIC.
Public property | DnsDomain | This value is the DNS domain assigned to the NIC.
Public property | DnsServers | This value is the DNS server assigned to the NIC.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Gateways | This value is the gateway assigned to the NIC.
Public property | Guid | This value is the unique ID for the NIC. It is equivalent to the SettingID property of the Win32_NetworkAdapterConfiguration WMI class as well as the NetworkInterface.Id property in the Base Class Library (BCL).
Public property | Index | Do not use this property. Double-Take uses it internally.
Public property | InterfaceIndex | Do not use this property. Double-Take uses it internally.
Public property | IPAddresses | This value represents the IP addresses assigned to the NIC.
Public property | MacAddress | This value represents the MAC address of the NIC.
Public property | Name | This value is the friendly name of the NIC.
Public property | PnpInstanceId | This value is the plug and play instance ID of the NIC.
Public property | ServiceName | This value is the service name of the NIC.
Top
See Also

Reference

DoubleTake.Core.Contract Namespace


NetworkInterfaceInfo Constructor

NetworkInterfaceInfo Constructor
Initializes a new instance of the NetworkInterfaceInfo class

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public NetworkInterfaceInfo()
Public Sub New
public:
NetworkInterfaceInfo()
DoubleTake.Core.Contract.NetworkInterfaceInfo = function();
See Also

Reference

NetworkInterfaceInfo Class
DoubleTake.Core.Contract Namespace


NetworkInterfaceInfo Properties

NetworkInterfaceInfo Properties

The NetworkInterfaceInfo type exposes the following members.

Properties
 | Name | Description
Public property | Description | This value is the description of the NIC.
Public property | DnsDomain | This value is the DNS domain assigned to the NIC.
Public property | DnsServers | This value is the DNS server assigned to the NIC.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Gateways | This value is the gateway assigned to the NIC.
Public property | Guid | This value is the unique ID for the NIC. It is equivalent to the SettingID property of the Win32_NetworkAdapterConfiguration WMI class as well as the NetworkInterface.Id property in the Base Class Library (BCL).
Public property | Index | Do not use this property. Double-Take uses it internally.
Public property | InterfaceIndex | Do not use this property. Double-Take uses it internally.
Public property | IPAddresses | This value represents the IP addresses assigned to the NIC.
Public property | MacAddress | This value represents the MAC address of the NIC.
Public property | Name | This value is the friendly name of the NIC.
Public property | PnpInstanceId | This value is the plug and play instance ID of the NIC.
Public property | ServiceName | This value is the service name of the NIC.
Top
See Also

Reference

NetworkInterfaceInfo Class
DoubleTake.Core.Contract Namespace


NetworkInterfaceInfo.Description Property

NetworkInterfaceInfoDescription Property
This value is the description of the NIC.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
function get_Description();
function set_Description(value);

Property Value

Type: String
The description of the network interface.
See Also

Reference

NetworkInterfaceInfo Class
DoubleTake.Core.Contract Namespace


NetworkInterfaceInfo.DnsDomain Property

NetworkInterfaceInfoDnsDomain Property
This value is the DNS domain assigned to the NIC.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string DnsDomain { get; set; }
Public Property DnsDomain As String
    Get
    Set
public:
property String^ DnsDomain {
    String^ get ();
    void set (String^ value);
}
function get_DnsDomain();
function set_DnsDomain(value);

Property Value

Type: String
The DNS Domain .
See Also

Reference

NetworkInterfaceInfo Class
DoubleTake.Core.Contract Namespace


NetworkInterfaceInfo.DnsServers Property

NetworkInterfaceInfoDnsServers Property
This value is the DNS server assigned to the NIC.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string[] DnsServers { get; set; }
Public Property DnsServers As String()
    Get
    Set
public:
property array<String^>^ DnsServers {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
function get_DnsServers();
function set_DnsServers(value);

Property Value

Type: String
The DNS servers.
See Also

Reference

NetworkInterfaceInfo Class
DoubleTake.Core.Contract Namespace


NetworkInterfaceInfo.ExtensionData Property

NetworkInterfaceInfoExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

NetworkInterfaceInfo Class
DoubleTake.Core.Contract Namespace


NetworkInterfaceInfo.Gateways Property

NetworkInterfaceInfoGateways Property
This value is the gateway assigned to the NIC.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string[] Gateways { get; set; }
Public Property Gateways As String()
    Get
    Set
public:
property array<String^>^ Gateways {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
function get_Gateways();
function set_Gateways(value);

Property Value

Type: String
The gateways.
See Also

Reference

NetworkInterfaceInfo Class
DoubleTake.Core.Contract Namespace


NetworkInterfaceInfo.Guid Property

NetworkInterfaceInfoGuid Property
This value is the unique ID for the NIC. It is equivalent to the SettingID property of the Win32_NetworkAdapterConfiguration WMI class as well as the NetworkInterface.Id property in the Base Class Library (BCL).

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Guid { get; set; }
Public Property Guid As String
    Get
    Set
public:
property String^ Guid {
    String^ get ();
    void set (String^ value);
}
function get_Guid();
function set_Guid(value);

Property Value

Type: String
The unique identifier of the network interface.
Remarks
This value is equivalent to the SettingID property of the Win32_NetworkAdapterConfiguration WMI class as well as the NetworkInterface.Id property in the BCL.
See Also

Reference

NetworkInterfaceInfo Class
DoubleTake.Core.Contract Namespace


NetworkInterfaceInfo.Index Property

NetworkInterfaceInfoIndex Property
Do not use this property. Double-Take uses it internally.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int Index { get; set; }
Public Property Index As Integer
    Get
    Set
public:
property int Index {
    int get ();
    void set (int value);
}
function get_Index();
function set_Index(value);

Property Value

Type: Int32
The index of the network interface.
See Also

Reference

NetworkInterfaceInfo Class
DoubleTake.Core.Contract Namespace


NetworkInterfaceInfo.InterfaceIndex Property

NetworkInterfaceInfoInterfaceIndex Property
Do not use this property. Double-Take uses it internally.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int InterfaceIndex { get; set; }
Public Property InterfaceIndex As Integer
    Get
    Set
public:
property int InterfaceIndex {
    int get ();
    void set (int value);
}
function get_InterfaceIndex();
function set_InterfaceIndex(value);

Property Value

Type: Int32
The index of the network interface.
See Also

Reference

NetworkInterfaceInfo Class
DoubleTake.Core.Contract Namespace


NetworkInterfaceInfo.IPAddresses Property

NetworkInterfaceInfoIPAddresses Property
This value represents the IP addresses assigned to the NIC.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public UnicastIPAddressInfo[] IPAddresses { get; set; }
Public Property IPAddresses As UnicastIPAddressInfo()
    Get
    Set
public:
property array<UnicastIPAddressInfo^>^ IPAddresses {
    array<UnicastIPAddressInfo^>^ get ();
    void set (array<UnicastIPAddressInfo^>^ value);
}
function get_IPAddresses();
function set_IPAddresses(value);

Property Value

Type: UnicastIPAddressInfo
An array of UnicastIPAddressInfo that represents the IP addresses on the network interface.
See Also

Reference

NetworkInterfaceInfo Class
DoubleTake.Core.Contract Namespace


NetworkInterfaceInfo.MacAddress Property

NetworkInterfaceInfoMacAddress Property
This value represents the MAC address of the NIC.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string MacAddress { get; set; }
Public Property MacAddress As String
    Get
    Set
public:
property String^ MacAddress {
    String^ get ();
    void set (String^ value);
}
function get_MacAddress();
function set_MacAddress(value);

Property Value

Type: String
The MAC address.
See Also

Reference

NetworkInterfaceInfo Class
DoubleTake.Core.Contract Namespace


NetworkInterfaceInfo.Name Property

NetworkInterfaceInfoName Property
This value is the friendly name of the NIC.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
function get_Name();
function set_Name(value);

Property Value

Type: String
The friendly name of the network interface.
See Also

Reference

NetworkInterfaceInfo Class
DoubleTake.Core.Contract Namespace


NetworkInterfaceInfo.PnpInstanceId Property

NetworkInterfaceInfoPnpInstanceId Property
This value is the plug and play instance ID of the NIC.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string PnpInstanceId { get; set; }
Public Property PnpInstanceId As String
    Get
    Set
public:
property String^ PnpInstanceId {
    String^ get ();
    void set (String^ value);
}
function get_PnpInstanceId();
function set_PnpInstanceId(value);

Property Value

Type: String
The PNP instance id.
See Also

Reference

NetworkInterfaceInfo Class
DoubleTake.Core.Contract Namespace


NetworkInterfaceInfo.ServiceName Property

NetworkInterfaceInfoServiceName Property
This value is the service name of the NIC.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string ServiceName { get; set; }
Public Property ServiceName As String
    Get
    Set
public:
property String^ ServiceName {
    String^ get ();
    void set (String^ value);
}
function get_ServiceName();
function set_ServiceName(value);

Property Value

Type: String
The service name of the network interface.
See Also

Reference

NetworkInterfaceInfo Class
DoubleTake.Core.Contract Namespace


OperatingSystemArchitecture Enumeration

OperatingSystemArchitecture Enumeration
Defines possible architectures for an operating system.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public enum OperatingSystemArchitecture
Public Enumeration OperatingSystemArchitecture
public enum class OperatingSystemArchitecture
DoubleTake.Core.Contract.OperatingSystemArchitecture = function();
DoubleTake.Core.Contract.OperatingSystemArchitecture.createEnum('DoubleTake.Core.Contract.OperatingSystemArchitecture', false);
Members
Member name | Value | Description
x86 | 0 | The operating systems uses the 32-bit architecture.
x64 | 9 | The operating system uses the AMD 64-bit architecture.
ia64 | 6 | The operating system uses the Itanium 64-bit architecture.
See Also

Reference

DoubleTake.Core.Contract Namespace


OperatingSystemInfo Class

OperatingSystemInfo Class
Represent the operating system of a server.
Inheritance Hierarchy
SystemObject
DoubleTake.Core.ContractOperatingSystemInfo

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class OperatingSystemInfo : IExtensibleDataObject
Public Class OperatingSystemInfo
    Implements IExtensibleDataObject
public ref class OperatingSystemInfo : IExtensibleDataObject
DoubleTake.Core.Contract.OperatingSystemInfo = function();

Type.createClass(
    'DoubleTake.Core.Contract.OperatingSystemInfo',
    null,
    IExtensibleDataObject);

The OperatingSystemInfo type exposes the following members.

Constructors
 | Name | Description
Public method | OperatingSystemInfo | Initializes a new instance of the OperatingSystemInfo class
Top
Properties
 | Name | Description
Public property | Architecture | This value represents the operating system architecture.
Public property | CSDVersion | This value is the version of the operating system service pack as a number.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | ProductSuite | This value is the Windows OSVERSIONINFOEX structure, which contains operating system version information including major and minor version numbers, a build number, a platform identifier, and information about product suites and the latest service pack installed on the system.
Public property | ProductType | This value represents the type of operating system.
Public property | ServicePack | This value is the version of the operating system service pack as a string.
Public property | Version | This value is the version of the operating system as a number.
Public property | VersionString | This value is the version of the operating system as a string.
Top
See Also

Reference

DoubleTake.Core.Contract Namespace


OperatingSystemInfo Constructor

OperatingSystemInfo Constructor
Initializes a new instance of the OperatingSystemInfo class

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public OperatingSystemInfo()
Public Sub New
public:
OperatingSystemInfo()
DoubleTake.Core.Contract.OperatingSystemInfo = function();
See Also

Reference

OperatingSystemInfo Class
DoubleTake.Core.Contract Namespace


OperatingSystemInfo Properties

OperatingSystemInfo Properties

The OperatingSystemInfo type exposes the following members.

Properties
 | Name | Description
Public property | Architecture | This value represents the operating system architecture.
Public property | CSDVersion | This value is the version of the operating system service pack as a number.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | ProductSuite | This value is the Windows OSVERSIONINFOEX structure, which contains operating system version information including major and minor version numbers, a build number, a platform identifier, and information about product suites and the latest service pack installed on the system.
Public property | ProductType | This value represents the type of operating system.
Public property | ServicePack | This value is the version of the operating system service pack as a string.
Public property | Version | This value is the version of the operating system as a number.
Public property | VersionString | This value is the version of the operating system as a string.
Top
See Also

Reference

OperatingSystemInfo Class
DoubleTake.Core.Contract Namespace


OperatingSystemInfo.Architecture Property

OperatingSystemInfoArchitecture Property
This value represents the operating system architecture.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public OperatingSystemArchitecture Architecture { get; set; }
Public Property Architecture As OperatingSystemArchitecture
    Get
    Set
public:
property OperatingSystemArchitecture Architecture {
    OperatingSystemArchitecture get ();
    void set (OperatingSystemArchitecture value);
}
function get_Architecture();
function set_Architecture(value);

Property Value

Type: OperatingSystemArchitecture
A OperatingSystemArchitecture value representing the architecture of the operating system.
See Also

Reference

OperatingSystemInfo Class
DoubleTake.Core.Contract Namespace


OperatingSystemInfo.CSDVersion Property

OperatingSystemInfoCSDVersion Property
This value is the version of the operating system service pack as a number.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int CSDVersion { get; set; }
Public Property CSDVersion As Integer
    Get
    Set
public:
property int CSDVersion {
    int get ();
    void set (int value);
}
function get_CSDVersion();
function set_CSDVersion(value);

Property Value

Type: Int32
The service pack major number.
See Also

Reference

OperatingSystemInfo Class
DoubleTake.Core.Contract Namespace


OperatingSystemInfo.ExtensionData Property

OperatingSystemInfoExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

OperatingSystemInfo Class
DoubleTake.Core.Contract Namespace


OperatingSystemInfo.ProductSuite Property

OperatingSystemInfoProductSuite Property
This value is the Windows OSVERSIONINFOEX structure, which contains operating system version information including major and minor version numbers, a build number, a platform identifier, and information about product suites and the latest service pack installed on the system.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int ProductSuite { get; set; }
Public Property ProductSuite As Integer
    Get
    Set
public:
property int ProductSuite {
    int get ();
    void set (int value);
}
function get_ProductSuite();
function set_ProductSuite(value);

Property Value

Type: Int32
A bit mask that identifies the product suites available on the system.
See Also

Reference

OperatingSystemInfo Class
DoubleTake.Core.Contract Namespace


OperatingSystemInfo.ProductType Property

OperatingSystemInfoProductType Property
This value represents the type of operating system.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public OperatingSystemProductType ProductType { get; set; }
Public Property ProductType As OperatingSystemProductType
    Get
    Set
public:
property OperatingSystemProductType ProductType {
    OperatingSystemProductType get ();
    void set (OperatingSystemProductType value);
}
function get_ProductType();
function set_ProductType(value);

Property Value

Type: OperatingSystemProductType
A OperatingSystemProductType representing the product type of the operating system.
See Also

Reference

OperatingSystemInfo Class
DoubleTake.Core.Contract Namespace


OperatingSystemInfo.ServicePack Property

OperatingSystemInfoServicePack Property
This value is the version of the operating system service pack as a string.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string ServicePack { get; set; }
Public Property ServicePack As String
    Get
    Set
public:
property String^ ServicePack {
    String^ get ();
    void set (String^ value);
}
function get_ServicePack();
function set_ServicePack(value);

Property Value

Type: String
The service pack number of the operating system.
See Also

Reference

OperatingSystemInfo Class
DoubleTake.Core.Contract Namespace


OperatingSystemInfo.Version Property

OperatingSystemInfoVersion Property
This value is the version of the operating system as a number.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public OperatingSystemVersion Version { get; set; }
Public Property Version As OperatingSystemVersion
    Get
    Set
public:
property OperatingSystemVersion^ Version {
    OperatingSystemVersion^ get ();
    void set (OperatingSystemVersion^ value);
}
function get_Version();
function set_Version(value);

Property Value

Type: OperatingSystemVersion
A OperatingSystemVersion value representing the version of the operating system.
See Also

Reference

OperatingSystemInfo Class
DoubleTake.Core.Contract Namespace


OperatingSystemInfo.VersionString Property

OperatingSystemInfoVersionString Property
This value is the version of the operating system as a string.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string VersionString { get; set; }
Public Property VersionString As String
    Get
    Set
public:
property String^ VersionString {
    String^ get ();
    void set (String^ value);
}
function get_VersionString();
function set_VersionString(value);

Property Value

Type: String
The version of the operating system as a string.
See Also

Reference

OperatingSystemInfo Class
DoubleTake.Core.Contract Namespace


OperatingSystemProductType Enumeration

OperatingSystemProductType Enumeration
Defines possible product types for an operating system.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public enum OperatingSystemProductType
Public Enumeration OperatingSystemProductType
public enum class OperatingSystemProductType
DoubleTake.Core.Contract.OperatingSystemProductType = function();
DoubleTake.Core.Contract.OperatingSystemProductType.createEnum('DoubleTake.Core.Contract.OperatingSystemProductType', false);
Members
Member name | Value | Description
None | 0 | The operating system product type is not defined.
Workstation | 1 | The operating system is workstation.
DomainController | 2 | The operating system is a domain controller.
Server | 3 | The operating system is server.
See Also

Reference

DoubleTake.Core.Contract Namespace


OperatingSystemVersion Class

OperatingSystemVersion Class
Represents the version of an operating system.
Inheritance Hierarchy
SystemObject
DoubleTake.Core.ContractOperatingSystemVersion

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class OperatingSystemVersion : IExtensibleDataObject
Public Class OperatingSystemVersion
    Implements IExtensibleDataObject
public ref class OperatingSystemVersion : IExtensibleDataObject
DoubleTake.Core.Contract.OperatingSystemVersion = function();

Type.createClass(
    'DoubleTake.Core.Contract.OperatingSystemVersion',
    null,
    IExtensibleDataObject);

The OperatingSystemVersion type exposes the following members.

Constructors
 | Name | Description
Public method | OperatingSystemVersion | Initializes a new instance of the OperatingSystemVersion class
Top
Properties
 | Name | Description
Public property | Build | This value is the build number of the operating system.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Major | This value is the major version of the operating system.
Public property | Minor | This value is the minor version of the operating system.
Public property | Revision | This value is the revision number of the operating system.
Top
See Also

Reference

DoubleTake.Core.Contract Namespace


OperatingSystemVersion Constructor

OperatingSystemVersion Constructor
Initializes a new instance of the OperatingSystemVersion class

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public OperatingSystemVersion()
Public Sub New
public:
OperatingSystemVersion()
DoubleTake.Core.Contract.OperatingSystemVersion = function();
See Also

Reference

OperatingSystemVersion Class
DoubleTake.Core.Contract Namespace


OperatingSystemVersion Properties

OperatingSystemVersion Properties

The OperatingSystemVersion type exposes the following members.

Properties
 | Name | Description
Public property | Build | This value is the build number of the operating system.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Major | This value is the major version of the operating system.
Public property | Minor | This value is the minor version of the operating system.
Public property | Revision | This value is the revision number of the operating system.
Top
See Also

Reference

OperatingSystemVersion Class
DoubleTake.Core.Contract Namespace


OperatingSystemVersion.Build Property

OperatingSystemVersionBuild Property
This value is the build number of the operating system.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int Build { get; set; }
Public Property Build As Integer
    Get
    Set
public:
property int Build {
    int get ();
    void set (int value);
}
function get_Build();
function set_Build(value);

Property Value

Type: Int32
The build number of the operating system.
See Also

Reference

OperatingSystemVersion Class
DoubleTake.Core.Contract Namespace


OperatingSystemVersion.ExtensionData Property

OperatingSystemVersionExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

OperatingSystemVersion Class
DoubleTake.Core.Contract Namespace


OperatingSystemVersion.Major Property

OperatingSystemVersionMajor Property
This value is the major version of the operating system.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int Major { get; set; }
Public Property Major As Integer
    Get
    Set
public:
property int Major {
    int get ();
    void set (int value);
}
function get_Major();
function set_Major(value);

Property Value

Type: Int32
The major version of the operating system.
See Also

Reference

OperatingSystemVersion Class
DoubleTake.Core.Contract Namespace


OperatingSystemVersion.Minor Property

OperatingSystemVersionMinor Property
This value is the minor version of the operating system.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int Minor { get; set; }
Public Property Minor As Integer
    Get
    Set
public:
property int Minor {
    int get ();
    void set (int value);
}
function get_Minor();
function set_Minor(value);

Property Value

Type: Int32
The minor version of the operating system.
See Also

Reference

OperatingSystemVersion Class
DoubleTake.Core.Contract Namespace


OperatingSystemVersion.Revision Property

OperatingSystemVersionRevision Property
This value is the revision number of the operating system.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int Revision { get; set; }
Public Property Revision As Integer
    Get
    Set
public:
property int Revision {
    int get ();
    void set (int value);
}
function get_Revision();
function set_Revision(value);

Property Value

Type: Int32
The revision number of the operating system.
See Also

Reference

OperatingSystemVersion Class
DoubleTake.Core.Contract Namespace


PathBlockingEntry Class

PathBlockingEntry Class
A path blocking entry.
Inheritance Hierarchy
SystemObject
DoubleTake.Core.ContractPathBlockingEntry

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class PathBlockingEntry : IExtensibleDataObject
Public Class PathBlockingEntry
    Implements IExtensibleDataObject
public ref class PathBlockingEntry : IExtensibleDataObject
DoubleTake.Core.Contract.PathBlockingEntry = function();

Type.createClass(
    'DoubleTake.Core.Contract.PathBlockingEntry',
    null,
    IExtensibleDataObject);

The PathBlockingEntry type exposes the following members.

Constructors
 | Name | Description
Public method | PathBlockingEntry | Initializes a new instance of the PathBlockingEntry class
Top
Properties
 | Name | Description
Public property | BlockingMode | The blocking mode.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Paths | The paths that are blocked.
Public property | SourceAddress | The source address corresponding to the connection having blocked paths.
Top
See Also

Reference

DoubleTake.Core.Contract Namespace


PathBlockingEntry Constructor

PathBlockingEntry Constructor
Initializes a new instance of the PathBlockingEntry class

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public PathBlockingEntry()
Public Sub New
public:
PathBlockingEntry()
DoubleTake.Core.Contract.PathBlockingEntry = function();
See Also

Reference

PathBlockingEntry Class
DoubleTake.Core.Contract Namespace


PathBlockingEntry Properties

PathBlockingEntry Properties

The PathBlockingEntry type exposes the following members.

Properties
 | Name | Description
Public property | BlockingMode | The blocking mode.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Paths | The paths that are blocked.
Public property | SourceAddress | The source address corresponding to the connection having blocked paths.
Top
See Also

Reference

PathBlockingEntry Class
DoubleTake.Core.Contract Namespace


PathBlockingEntry.BlockingMode Property

PathBlockingEntryBlockingMode Property
The blocking mode.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public PathBlockingMode BlockingMode { get; set; }
Public Property BlockingMode As PathBlockingMode
    Get
    Set
public:
property PathBlockingMode BlockingMode {
    PathBlockingMode get ();
    void set (PathBlockingMode value);
}
function get_BlockingMode();
function set_BlockingMode(value);

Property Value

Type: PathBlockingMode
See Also

Reference

PathBlockingEntry Class
DoubleTake.Core.Contract Namespace


PathBlockingEntry.ExtensionData Property

PathBlockingEntryExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

PathBlockingEntry Class
DoubleTake.Core.Contract Namespace


PathBlockingEntry.Paths Property

PathBlockingEntryPaths Property
The paths that are blocked.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string[] Paths { get; set; }
Public Property Paths As String()
    Get
    Set
public:
property array<String^>^ Paths {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
function get_Paths();
function set_Paths(value);

Property Value

Type: String
See Also

Reference

PathBlockingEntry Class
DoubleTake.Core.Contract Namespace


PathBlockingEntry.SourceAddress Property

PathBlockingEntrySourceAddress Property
The source address corresponding to the connection having blocked paths.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string SourceAddress { get; set; }
Public Property SourceAddress As String
    Get
    Set
public:
property String^ SourceAddress {
    String^ get ();
    void set (String^ value);
}
function get_SourceAddress();
function set_SourceAddress(value);

Property Value

Type: String
See Also

Reference

PathBlockingEntry Class
DoubleTake.Core.Contract Namespace


PathBlockingMode Enumeration

PathBlockingMode Enumeration
This value represents if the path is blocked.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public enum PathBlockingMode
Public Enumeration PathBlockingMode
public enum class PathBlockingMode
DoubleTake.Core.Contract.PathBlockingMode = function();
DoubleTake.Core.Contract.PathBlockingMode.createEnum('DoubleTake.Core.Contract.PathBlockingMode', false);
Members
Member name | Value | Description
Blocked | 0 | The path is blocked for writing, except by Double-Take.
Unblocked | 1 | The path is unblocked for writing.
See Also

Reference

DoubleTake.Core.Contract Namespace


ProductInfo Class

ProductInfo Class
Represents information about a product.
Inheritance Hierarchy
SystemObject
DoubleTake.Core.ContractProductInfo

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class ProductInfo : IExtensibleDataObject
Public Class ProductInfo
    Implements IExtensibleDataObject
public ref class ProductInfo : IExtensibleDataObject
DoubleTake.Core.Contract.ProductInfo = function();

Type.createClass(
    'DoubleTake.Core.Contract.ProductInfo',
    null,
    IExtensibleDataObject);

The ProductInfo type exposes the following members.

Constructors
 | Name | Description
Public method | ProductInfo | Initializes a new instance of the ProductInfo class
Top
Properties
 | Name | Description
Public property | ActivationStatus | This value represents the activation of the server.
Public property | CanPauseTarget | This value is true if target operations can be paused; otherwise, it is false.
Public property | CanResumeTarget | This value is true if target operations can be resumed; otherwise, it is false.
Public property | EngineModuleStatus | Do not use this property. Double-Take uses it internally.
Public property | EnginePort | This value is the port where the engine is listening.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | GatewaySessionKey | Do not use this property. Double-Take uses it internally.
Public property | InstallationPath | This value is the installation path.
Public property | LocalEndpoints | This value is the local endpoints.
Public property | MachineName | This value is the name of the machine.
Public property | ManagementServiceVersion | This value is the version of the Management Service on the server.
Public property | Name | This value is the name of the product on the server.
Public property | NatEndpoints | This value is the NAT endpoints.
Public property | ReservedAddress | This value is the reserved IP address for the server.
Public property | UniqueId | This value is the unique ID of the server.
Public property | Version | This value is the version of the product on the server.
Top
See Also

Reference

DoubleTake.Core.Contract Namespace


ProductInfo Constructor

ProductInfo Constructor
Initializes a new instance of the ProductInfo class

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ProductInfo()
Public Sub New
public:
ProductInfo()
DoubleTake.Core.Contract.ProductInfo = function();
See Also

Reference

ProductInfo Class
DoubleTake.Core.Contract Namespace


ProductInfo Properties

ProductInfo Properties

The ProductInfo type exposes the following members.

Properties
 | Name | Description
Public property | ActivationStatus | This value represents the activation of the server.
Public property | CanPauseTarget | This value is true if target operations can be paused; otherwise, it is false.
Public property | CanResumeTarget | This value is true if target operations can be resumed; otherwise, it is false.
Public property | EngineModuleStatus | Do not use this property. Double-Take uses it internally.
Public property | EnginePort | This value is the port where the engine is listening.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | GatewaySessionKey | Do not use this property. Double-Take uses it internally.
Public property | InstallationPath | This value is the installation path.
Public property | LocalEndpoints | This value is the local endpoints.
Public property | MachineName | This value is the name of the machine.
Public property | ManagementServiceVersion | This value is the version of the Management Service on the server.
Public property | Name | This value is the name of the product on the server.
Public property | NatEndpoints | This value is the NAT endpoints.
Public property | ReservedAddress | This value is the reserved IP address for the server.
Public property | UniqueId | This value is the unique ID of the server.
Public property | Version | This value is the version of the product on the server.
Top
See Also

Reference

ProductInfo Class
DoubleTake.Core.Contract Namespace


ProductInfo.ActivationStatus Property

ProductInfoActivationStatus Property
This value represents the activation of the server.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ActivationStatus ActivationStatus { get; set; }
Public Property ActivationStatus As ActivationStatus
    Get
    Set
public:
property ActivationStatus^ ActivationStatus {
    ActivationStatus^ get ();
    void set (ActivationStatus^ value);
}
function get_ActivationStatus();
function set_ActivationStatus(value);

Property Value

Type: ActivationStatus
The activation status of the server.
See Also

Reference

ProductInfo Class
DoubleTake.Core.Contract Namespace


ProductInfo.CanPauseTarget Property

ProductInfoCanPauseTarget Property
This value is true if target operations can be paused; otherwise, it is false.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool CanPauseTarget { get; set; }
Public Property CanPauseTarget As Boolean
    Get
    Set
public:
property bool CanPauseTarget {
    bool get ();
    void set (bool value);
}
function get_CanPauseTarget();
function set_CanPauseTarget(value);

Property Value

Type: Boolean
if target operations can be paused; otherwise, .
See Also

Reference

ProductInfo Class
DoubleTake.Core.Contract Namespace


ProductInfo.CanResumeTarget Property

ProductInfoCanResumeTarget Property
This value is true if target operations can be resumed; otherwise, it is false.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool CanResumeTarget { get; set; }
Public Property CanResumeTarget As Boolean
    Get
    Set
public:
property bool CanResumeTarget {
    bool get ();
    void set (bool value);
}
function get_CanResumeTarget();
function set_CanResumeTarget(value);

Property Value

Type: Boolean
if target operations can be resumed; otherwise, .
See Also

Reference

ProductInfo Class
DoubleTake.Core.Contract Namespace


ProductInfo.EngineModuleStatus Property

ProductInfoEngineModuleStatus Property
Do not use this property. Double-Take uses it internally.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int EngineModuleStatus { get; set; }
Public Property EngineModuleStatus As Integer
    Get
    Set
public:
property int EngineModuleStatus {
    int get ();
    void set (int value);
}
function get_EngineModuleStatus();
function set_EngineModuleStatus(value);

Property Value

Type: Int32
The engine module status.
Remarks
This value is only used internally and is not exposed as a data contract member.
See Also

Reference

ProductInfo Class
DoubleTake.Core.Contract Namespace


ProductInfo.EnginePort Property

ProductInfoEnginePort Property
This value is the port where the engine is listening.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int EnginePort { get; set; }
Public Property EnginePort As Integer
    Get
    Set
public:
property int EnginePort {
    int get ();
    void set (int value);
}
function get_EnginePort();
function set_EnginePort(value);

Property Value

Type: Int32
The port on which the engine is listening.
See Also

Reference

ProductInfo Class
DoubleTake.Core.Contract Namespace


ProductInfo.ExtensionData Property

ProductInfoExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

ProductInfo Class
DoubleTake.Core.Contract Namespace


ProductInfo.GatewaySessionKey Property

ProductInfoGatewaySessionKey Property
Do not use this property. Double-Take uses it internally.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public long GatewaySessionKey { get; set; }
Public Property GatewaySessionKey As Long
    Get
    Set
public:
property long long GatewaySessionKey {
    long long get ();
    void set (long long value);
}
function get_GatewaySessionKey();
function set_GatewaySessionKey(value);

Property Value

Type: Int64
The session key.
Remarks
The property supports the infrastructure and is not intended to be used by client code.
See Also

Reference

ProductInfo Class
DoubleTake.Core.Contract Namespace


ProductInfo.InstallationPath Property

ProductInfoInstallationPath Property
This value is the installation path.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string InstallationPath { get; set; }
Public Property InstallationPath As String
    Get
    Set
public:
property String^ InstallationPath {
    String^ get ();
    void set (String^ value);
}
function get_InstallationPath();
function set_InstallationPath(value);

Property Value

Type: String
The installation path.
See Also

Reference

ProductInfo Class
DoubleTake.Core.Contract Namespace


ProductInfo.LocalEndpoints Property

ProductInfoLocalEndpoints Property
This value is the local endpoints.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public IEnumerable<string> LocalEndpoints { get; set; }
Public Property LocalEndpoints As IEnumerable(Of String)
    Get
    Set
public:
property IEnumerable<String^>^ LocalEndpoints {
    IEnumerable<String^>^ get ();
    void set (IEnumerable<String^>^ value);
}
function get_LocalEndpoints();
function set_LocalEndpoints(value);

Property Value

Type: IEnumerable String
The local endpoints.
See Also

Reference

ProductInfo Class
DoubleTake.Core.Contract Namespace


ProductInfo.MachineName Property

ProductInfoMachineName Property
This value is the name of the machine.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string MachineName { get; set; }
Public Property MachineName As String
    Get
    Set
public:
property String^ MachineName {
    String^ get ();
    void set (String^ value);
}
function get_MachineName();
function set_MachineName(value);

Property Value

Type: String
The name of the machine.
See Also

Reference

ProductInfo Class
DoubleTake.Core.Contract Namespace


ProductInfo.ManagementServiceVersion Property

ProductInfoManagementServiceVersion Property
This value is the version of the Management Service on the server.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ProductVersion ManagementServiceVersion { get; set; }
Public Property ManagementServiceVersion As ProductVersion
    Get
    Set
public:
property ProductVersion^ ManagementServiceVersion {
    ProductVersion^ get ();
    void set (ProductVersion^ value);
}
function get_ManagementServiceVersion();
function set_ManagementServiceVersion(value);

Property Value

Type: ProductVersion
The version of the management service on the server.
See Also

Reference

ProductInfo Class
DoubleTake.Core.Contract Namespace


ProductInfo.Name Property

ProductInfoName Property
This value is the name of the product on the server.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
function get_Name();
function set_Name(value);

Property Value

Type: String
The name of the product on the server.
See Also

Reference

ProductInfo Class
DoubleTake.Core.Contract Namespace


ProductInfo.NatEndpoints Property

ProductInfoNatEndpoints Property
This value is the NAT endpoints.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public IEnumerable<string> NatEndpoints { get; set; }
Public Property NatEndpoints As IEnumerable(Of String)
    Get
    Set
public:
property IEnumerable<String^>^ NatEndpoints {
    IEnumerable<String^>^ get ();
    void set (IEnumerable<String^>^ value);
}
function get_NatEndpoints();
function set_NatEndpoints(value);

Property Value

Type: IEnumerable String
The NAT end points.
See Also

Reference

ProductInfo Class
DoubleTake.Core.Contract Namespace


ProductInfo.ReservedAddress Property

ProductInfoReservedAddress Property
This value is the reserved IP address for the server.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string ReservedAddress { get; set; }
Public Property ReservedAddress As String
    Get
    Set
public:
property String^ ReservedAddress {
    String^ get ();
    void set (String^ value);
}
function get_ReservedAddress();
function set_ReservedAddress(value);

Property Value

Type: String
The reserved IP address for the server.
See Also

Reference

ProductInfo Class
DoubleTake.Core.Contract Namespace


ProductInfo.UniqueId Property

ProductInfoUniqueId Property
This value is the unique ID of the server.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string UniqueId { get; set; }
Public Property UniqueId As String
    Get
    Set
public:
property String^ UniqueId {
    String^ get ();
    void set (String^ value);
}
function get_UniqueId();
function set_UniqueId(value);

Property Value

Type: String
The unique id of the server.
See Also

Reference

ProductInfo Class
DoubleTake.Core.Contract Namespace


ProductInfo.Version Property

ProductInfoVersion Property
This value is the version of the product on the server.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ProductVersion Version { get; set; }
Public Property Version As ProductVersion
    Get
    Set
public:
property ProductVersion^ Version {
    ProductVersion^ get ();
    void set (ProductVersion^ value);
}
function get_Version();
function set_Version(value);

Property Value

Type: ProductVersion
The version of the product on the server.
See Also

Reference

ProductInfo Class
DoubleTake.Core.Contract Namespace


ProductVersion Class

ProductVersion Class
Represents the version of a product.
Inheritance Hierarchy
SystemObject
DoubleTake.Core.ContractProductVersion

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class ProductVersion : IExtensibleDataObject
Public Class ProductVersion
    Implements IExtensibleDataObject
public ref class ProductVersion : IExtensibleDataObject
DoubleTake.Core.Contract.ProductVersion = function();

Type.createClass(
    'DoubleTake.Core.Contract.ProductVersion',
    null,
    IExtensibleDataObject);

The ProductVersion type exposes the following members.

Constructors
 | Name | Description
Public method | ProductVersion | Initializes a new instance of the ProductVersion class
Top
Properties
 | Name | Description
Public property | Build | This value is the build (or sequence number) of the product.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Hotfix | This value is the hotfix (or limited release) of the product.
Public property | Major | This value is the major version of the product.
Public property | Minor | This value is the minor version of the product.
Public property | ServicePack | This value is the service pack version of the product.
Top
Methods
 | Name | Description
Public method | ToString | Returns a String that represents this instance. (Overrides ObjectToString.)
Top
See Also

Reference

DoubleTake.Core.Contract Namespace


ProductVersion Constructor

ProductVersion Constructor
Initializes a new instance of the ProductVersion class

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ProductVersion()
Public Sub New
public:
ProductVersion()
DoubleTake.Core.Contract.ProductVersion = function();
See Also

Reference

ProductVersion Class
DoubleTake.Core.Contract Namespace


ProductVersion Properties

ProductVersion Properties

The ProductVersion type exposes the following members.

Properties
 | Name | Description
Public property | Build | This value is the build (or sequence number) of the product.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Hotfix | This value is the hotfix (or limited release) of the product.
Public property | Major | This value is the major version of the product.
Public property | Minor | This value is the minor version of the product.
Public property | ServicePack | This value is the service pack version of the product.
Top
See Also

Reference

ProductVersion Class
DoubleTake.Core.Contract Namespace


ProductVersion.Build Property

ProductVersionBuild Property
This value is the build (or sequence number) of the product.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int Build { get; set; }
Public Property Build As Integer
    Get
    Set
public:
property int Build {
    int get ();
    void set (int value);
}
function get_Build();
function set_Build(value);

Property Value

Type: Int32
The build (sequence) number.
See Also

Reference

ProductVersion Class
DoubleTake.Core.Contract Namespace


ProductVersion.ExtensionData Property

ProductVersionExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

ProductVersion Class
DoubleTake.Core.Contract Namespace


ProductVersion.Hotfix Property

ProductVersionHotfix Property
This value is the hotfix (or limited release) of the product.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int Hotfix { get; set; }
Public Property Hotfix As Integer
    Get
    Set
public:
property int Hotfix {
    int get ();
    void set (int value);
}
function get_Hotfix();
function set_Hotfix(value);

Property Value

Type: Int32
The hotfix number.
See Also

Reference

ProductVersion Class
DoubleTake.Core.Contract Namespace


ProductVersion.Major Property

ProductVersionMajor Property
This value is the major version of the product.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int Major { get; set; }
Public Property Major As Integer
    Get
    Set
public:
property int Major {
    int get ();
    void set (int value);
}
function get_Major();
function set_Major(value);

Property Value

Type: Int32
The major version number.
See Also

Reference

ProductVersion Class
DoubleTake.Core.Contract Namespace


ProductVersion.Minor Property

ProductVersionMinor Property
This value is the minor version of the product.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int Minor { get; set; }
Public Property Minor As Integer
    Get
    Set
public:
property int Minor {
    int get ();
    void set (int value);
}
function get_Minor();
function set_Minor(value);

Property Value

Type: Int32
The minor version number.
See Also

Reference

ProductVersion Class
DoubleTake.Core.Contract Namespace


ProductVersion.ServicePack Property

ProductVersionServicePack Property
This value is the service pack version of the product.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int ServicePack { get; set; }
Public Property ServicePack As Integer
    Get
    Set
public:
property int ServicePack {
    int get ();
    void set (int value);
}
function get_ServicePack();
function set_ServicePack(value);

Property Value

Type: Int32
The service pack number.
See Also

Reference

ProductVersion Class
DoubleTake.Core.Contract Namespace


ProductVersion Methods

ProductVersion Methods

The ProductVersion type exposes the following members.

Methods
 | Name | Description
Public method | ToString | Returns a String that represents this instance. (Overrides ObjectToString.)
Top
See Also

Reference

ProductVersion Class
DoubleTake.Core.Contract Namespace


ProductVersion.ToString Method

ProductVersionToString Method
Returns a String that represents this instance.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
function ToString();

Return Value

Type: String
A String that represents this instance.
See Also

Reference

ProductVersion Class
DoubleTake.Core.Contract Namespace


Property Class

Property Class
Inheritance Hierarchy
SystemObject
DoubleTake.Core.ContractProperty

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class Property
Public Class Property
public ref class Property
DoubleTake.Core.Contract.Property = function();

Type.createClass(
    'DoubleTake.Core.Contract.Property');

The Property type exposes the following members.

Constructors
 | Name | Description
Public method | Property | Initializes a new instance of the Property class
Top
Properties
 | Name | Description
Public property | Name |
Public property | Value |
Top
See Also

Reference

DoubleTake.Core.Contract Namespace


Property Constructor

Property Constructor
Initializes a new instance of the Property class

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Property()
Public Sub New
public:
Property()
DoubleTake.Core.Contract.Property = function();
See Also

Reference

Property Class
DoubleTake.Core.Contract Namespace


Property Properties

Property Properties

The Property type exposes the following members.

Properties
 | Name | Description
Public property | Name |
Public property | Value |
Top
See Also

Reference

Property Class
DoubleTake.Core.Contract Namespace


Property.Name Property

PropertyName Property

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
function get_Name();
function set_Name(value);

Property Value

Type: String
See Also

Reference

Property Class
DoubleTake.Core.Contract Namespace


Property.Value Property

PropertyValue Property

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Value { get; set; }
Public Property Value As String
    Get
    Set
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}
function get_Value();
function set_Value(value);

Property Value

Type: String
See Also

Reference

Property Class
DoubleTake.Core.Contract Namespace


RebootAction Enumeration

RebootAction Enumeration

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public enum RebootAction
Public Enumeration RebootAction
public enum class RebootAction
DoubleTake.Core.Contract.RebootAction = function();
DoubleTake.Core.Contract.RebootAction.createEnum('DoubleTake.Core.Contract.RebootAction', false);
Members
Member name | Value | Description
RebootAfterCutover | 0 |
DoNotRebootAfterCutover | 1 |
See Also

Reference

DoubleTake.Core.Contract Namespace


ReplicationSetUsageType Enumeration

ReplicationSetUsageType Enumeration
Defines possible usage types for a replication set.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public enum ReplicationSetUsageType
Public Enumeration ReplicationSetUsageType
public enum class ReplicationSetUsageType
DoubleTake.Core.Contract.ReplicationSetUsageType = function();
DoubleTake.Core.Contract.ReplicationSetUsageType.createEnum('DoubleTake.Core.Contract.ReplicationSetUsageType', false);
Members
Member name | Value | Description
Invalid | -1 | This value is an unknown data set type.
Normal | 0 | This value is a files and folders data set.
SystemState | 1 | This value is a full server data set.
GeoCluster | 2 | This value is a GeoCluster data set.
Remarks
Values of this enumeration should not be sent between client and server.
See Also

Reference

DoubleTake.Core.Contract Namespace


ServerInfo Class

ServerInfo Class
Represents information about a server.
Inheritance Hierarchy
SystemObject
DoubleTake.Core.ContractServerInfo

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class ServerInfo : IExtensibleDataObject
Public Class ServerInfo
    Implements IExtensibleDataObject
public ref class ServerInfo : IExtensibleDataObject
DoubleTake.Core.Contract.ServerInfo = function();

Type.createClass(
    'DoubleTake.Core.Contract.ServerInfo',
    null,
    IExtensibleDataObject);

The ServerInfo type exposes the following members.

Constructors
 | Name | Description
Public method | ServerInfo | Initializes a new instance of the ServerInfo class
Top
Properties
 | Name | Description
Public property | BiosGuid | This value is the BIOS unique ID.
Public property | BootVolume | This value is the server's boot volume.
Public property | Domain | This value is the domain the server is a member of.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | FullyQualifiedDomain | This value is the fully qualified domain name.
Public property | HalInternalName | This value is the internal name of the hardware abstraction layer (HAL).
Public property | HalVersion | The version of the hardware abstraction layer.
Public property | IsClustered | This value is true if this the server is part of a cluster; otherwise, it is false.
Public property | IsHostedByHyperV | This value is true if the server is hosted by Hyper-V; otherwise, it is false.
Public property | IsHostedByVMware | This value is true if the server is hosted by VMware; otherwise, it is false.
Public property | IsHostedByXen | This value is true if the server is hosted by Xen; otherwise, it is false.
Public property | IsHyperVHost | This value is true if the server is a Hyper-V host; otherwise, it is false.
Public property | IsReplicationEnabled | This value is true if replication is enabled; otherwise, it is false.
Public property | IsSBS | This value is true if the server is running Microsoft Windows Small Business Server; otherwise, it is false.
Public property | IsSSE | This value is true if the server is running Microsoft Windows Storage Server; otherwise, it is false.
Public property | LvmOptions | This value represents the Linux Volume Manager (LVM) options.
Public property | ManagementPort | This value is the port where the Management Service is listening.
Public property | MemorySize | This value is the amount of memory on the server.
Public property | Name | This value is the name of the server.
Public property | NetworkInterfaces | This value represents the NICs on the server.
Public property | NodeLockedServerInfo | This value is the server information needed for an activation key.
Public property | OperatingSystem | This value is the the operating system on the server.
Public property | ProcessorCount | This value is the processor count on the server.
Public property | ProgramFilesPath | This value is the server's program files path.
Public property | SystemPath | This value is the server's system path.
Public property | SystemRoot | This value is the sever's system root path.
Public property | SystemStateDefinition | Do not use this property. Double-Take uses it internally.
Public property | SystemVolume | This value is the server's system volume.
Public property | Volumes | This value represents the volumes on the server.
Top
See Also

Reference

DoubleTake.Core.Contract Namespace


ServerInfo Constructor

ServerInfo Constructor
Initializes a new instance of the ServerInfo class

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ServerInfo()
Public Sub New
public:
ServerInfo()
DoubleTake.Core.Contract.ServerInfo = function();
See Also

Reference

ServerInfo Class
DoubleTake.Core.Contract Namespace


ServerInfo Properties

ServerInfo Properties

The ServerInfo type exposes the following members.

Properties
 | Name | Description
Public property | BiosGuid | This value is the BIOS unique ID.
Public property | BootVolume | This value is the server's boot volume.
Public property | Domain | This value is the domain the server is a member of.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | FullyQualifiedDomain | This value is the fully qualified domain name.
Public property | HalInternalName | This value is the internal name of the hardware abstraction layer (HAL).
Public property | HalVersion | The version of the hardware abstraction layer.
Public property | IsClustered | This value is true if this the server is part of a cluster; otherwise, it is false.
Public property | IsHostedByHyperV | This value is true if the server is hosted by Hyper-V; otherwise, it is false.
Public property | IsHostedByVMware | This value is true if the server is hosted by VMware; otherwise, it is false.
Public property | IsHostedByXen | This value is true if the server is hosted by Xen; otherwise, it is false.
Public property | IsHyperVHost | This value is true if the server is a Hyper-V host; otherwise, it is false.
Public property | IsReplicationEnabled | This value is true if replication is enabled; otherwise, it is false.
Public property | IsSBS | This value is true if the server is running Microsoft Windows Small Business Server; otherwise, it is false.
Public property | IsSSE | This value is true if the server is running Microsoft Windows Storage Server; otherwise, it is false.
Public property | LvmOptions | This value represents the Linux Volume Manager (LVM) options.
Public property | ManagementPort | This value is the port where the Management Service is listening.
Public property | MemorySize | This value is the amount of memory on the server.
Public property | Name | This value is the name of the server.
Public property | NetworkInterfaces | This value represents the NICs on the server.
Public property | NodeLockedServerInfo | This value is the server information needed for an activation key.
Public property | OperatingSystem | This value is the the operating system on the server.
Public property | ProcessorCount | This value is the processor count on the server.
Public property | ProgramFilesPath | This value is the server's program files path.
Public property | SystemPath | This value is the server's system path.
Public property | SystemRoot | This value is the sever's system root path.
Public property | SystemStateDefinition | Do not use this property. Double-Take uses it internally.
Public property | SystemVolume | This value is the server's system volume.
Public property | Volumes | This value represents the volumes on the server.
Top
See Also

Reference

ServerInfo Class
DoubleTake.Core.Contract Namespace


ServerInfo.BiosGuid Property

ServerInfoBiosGuid Property
This value is the BIOS unique ID.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Guid BiosGuid { get; set; }
Public Property BiosGuid As Guid
    Get
    Set
public:
property Guid BiosGuid {
    Guid get ();
    void set (Guid value);
}
function get_BiosGuid();
function set_BiosGuid(value);

Property Value

Type: Guid
The BIOS GUID.
See Also

Reference

ServerInfo Class
DoubleTake.Core.Contract Namespace


ServerInfo.BootVolume Property

ServerInfoBootVolume Property
This value is the server's boot volume.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string BootVolume { get; set; }
Public Property BootVolume As String
    Get
    Set
public:
property String^ BootVolume {
    String^ get ();
    void set (String^ value);
}
function get_BootVolume();
function set_BootVolume(value);

Property Value

Type: String
The boot volume.
See Also

Reference

ServerInfo Class
DoubleTake.Core.Contract Namespace


ServerInfo.Domain Property

ServerInfoDomain Property
This value is the domain the server is a member of.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Domain { get; set; }
Public Property Domain As String
    Get
    Set
public:
property String^ Domain {
    String^ get ();
    void set (String^ value);
}
function get_Domain();
function set_Domain(value);

Property Value

Type: String
The domain the server is a member of.
See Also

Reference

ServerInfo Class
DoubleTake.Core.Contract Namespace


ServerInfo.ExtensionData Property

ServerInfoExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

ServerInfo Class
DoubleTake.Core.Contract Namespace


ServerInfo.FullyQualifiedDomain Property

ServerInfoFullyQualifiedDomain Property
This value is the fully qualified domain name.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string FullyQualifiedDomain { get; set; }
Public Property FullyQualifiedDomain As String
    Get
    Set
public:
property String^ FullyQualifiedDomain {
    String^ get ();
    void set (String^ value);
}
function get_FullyQualifiedDomain();
function set_FullyQualifiedDomain(value);

Property Value

Type: String
The fully qualified domain name of the server.
See Also

Reference

ServerInfo Class
DoubleTake.Core.Contract Namespace


ServerInfo.HalInternalName Property

ServerInfoHalInternalName Property
This value is the internal name of the hardware abstraction layer (HAL).

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string HalInternalName { get; set; }
Public Property HalInternalName As String
    Get
    Set
public:
property String^ HalInternalName {
    String^ get ();
    void set (String^ value);
}
function get_HalInternalName();
function set_HalInternalName(value);

Property Value

Type: String
The internal name of the hardware abstraction layer (HAL).
See Also

Reference

ServerInfo Class
DoubleTake.Core.Contract Namespace


ServerInfo.HalVersion Property

ServerInfoHalVersion Property
The version of the hardware abstraction layer.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string HalVersion { get; set; }
Public Property HalVersion As String
    Get
    Set
public:
property String^ HalVersion {
    String^ get ();
    void set (String^ value);
}
function get_HalVersion();
function set_HalVersion(value);

Property Value

Type: String
The version of the hardware abstraction layer.
See Also

Reference

ServerInfo Class
DoubleTake.Core.Contract Namespace


ServerInfo.IsClustered Property

ServerInfoIsClustered Property
This value is true if this the server is part of a cluster; otherwise, it is false.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsClustered { get; set; }
Public Property IsClustered As Boolean
    Get
    Set
public:
property bool IsClustered {
    bool get ();
    void set (bool value);
}
function get_IsClustered();
function set_IsClustered(value);

Property Value

Type: Boolean
if this the server is part of a cluster; otherwise, .
See Also

Reference

ServerInfo Class
DoubleTake.Core.Contract Namespace


ServerInfo.IsHostedByHyperV Property

ServerInfoIsHostedByHyperV Property
This value is true if the server is hosted by Hyper-V; otherwise, it is false.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsHostedByHyperV { get; set; }
Public Property IsHostedByHyperV As Boolean
    Get
    Set
public:
property bool IsHostedByHyperV {
    bool get ();
    void set (bool value);
}
function get_IsHostedByHyperV();
function set_IsHostedByHyperV(value);

Property Value

Type: Boolean
if the server is hosted by Hyper-V; otherwise, .
See Also

Reference

ServerInfo Class
DoubleTake.Core.Contract Namespace


ServerInfo.IsHostedByVMware Property

ServerInfoIsHostedByVMware Property
This value is true if the server is hosted by VMware; otherwise, it is false.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsHostedByVMware { get; set; }
Public Property IsHostedByVMware As Boolean
    Get
    Set
public:
property bool IsHostedByVMware {
    bool get ();
    void set (bool value);
}
function get_IsHostedByVMware();
function set_IsHostedByVMware(value);

Property Value

Type: Boolean
if the server is hosted by VMware; otherwise, .
See Also

Reference

ServerInfo Class
DoubleTake.Core.Contract Namespace


ServerInfo.IsHostedByXen Property

ServerInfoIsHostedByXen Property
This value is true if the server is hosted by Xen; otherwise, it is false.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsHostedByXen { get; set; }
Public Property IsHostedByXen As Boolean
    Get
    Set
public:
property bool IsHostedByXen {
    bool get ();
    void set (bool value);
}
function get_IsHostedByXen();
function set_IsHostedByXen(value);

Property Value

Type: Boolean
if the server is hosted by Xen; otherwise, .
See Also

Reference

ServerInfo Class
DoubleTake.Core.Contract Namespace


ServerInfo.IsHyperVHost Property

ServerInfoIsHyperVHost Property
This value is true if the server is a Hyper-V host; otherwise, it is false.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsHyperVHost { get; set; }
Public Property IsHyperVHost As Boolean
    Get
    Set
public:
property bool IsHyperVHost {
    bool get ();
    void set (bool value);
}
function get_IsHyperVHost();
function set_IsHyperVHost(value);

Property Value

Type: Boolean
if the server is a Hyper-V host; otherwise, .
See Also

Reference

ServerInfo Class
DoubleTake.Core.Contract Namespace


ServerInfo.IsReplicationEnabled Property

ServerInfoIsReplicationEnabled Property
This value is true if replication is enabled; otherwise, it is false.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsReplicationEnabled { get; set; }
Public Property IsReplicationEnabled As Boolean
    Get
    Set
public:
property bool IsReplicationEnabled {
    bool get ();
    void set (bool value);
}
function get_IsReplicationEnabled();
function set_IsReplicationEnabled(value);

Property Value

Type: Boolean
if replication is enabled; otherwise, .
See Also

Reference

ServerInfo Class
DoubleTake.Core.Contract Namespace


ServerInfo.IsSBS Property

ServerInfoIsSBS Property
This value is true if the server is running Microsoft Windows Small Business Server; otherwise, it is false.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsSBS { get; set; }
Public Property IsSBS As Boolean
    Get
    Set
public:
property bool IsSBS {
    bool get ();
    void set (bool value);
}
function get_IsSBS();
function set_IsSBS(value);

Property Value

Type: Boolean
if the server is running Microsoft Windows Small Business Server; otherwise, .
See Also

Reference

ServerInfo Class
DoubleTake.Core.Contract Namespace


ServerInfo.IsSSE Property

ServerInfoIsSSE Property
This value is true if the server is running Microsoft Windows Storage Server; otherwise, it is false.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsSSE { get; set; }
Public Property IsSSE As Boolean
    Get
    Set
public:
property bool IsSSE {
    bool get ();
    void set (bool value);
}
function get_IsSSE();
function set_IsSSE(value);

Property Value

Type: Boolean
if the server is running Microsoft Windows Storage Server; otherwise, .
See Also

Reference

ServerInfo Class
DoubleTake.Core.Contract Namespace


ServerInfo.LvmOptions Property

ServerInfoLvmOptions Property
This value represents the Linux Volume Manager (LVM) options.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public LvmOptions LvmOptions { get; set; }
Public Property LvmOptions As LvmOptions
    Get
    Set
public:
property LvmOptions^ LvmOptions {
    LvmOptions^ get ();
    void set (LvmOptions^ value);
}
function get_LvmOptions();
function set_LvmOptions(value);

Property Value

Type: LvmOptions
The LVM Options
See Also

Reference

ServerInfo Class
DoubleTake.Core.Contract Namespace


ServerInfo.ManagementPort Property

ServerInfoManagementPort Property
This value is the port where the Management Service is listening.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int ManagementPort { get; set; }
Public Property ManagementPort As Integer
    Get
    Set
public:
property int ManagementPort {
    int get ();
    void set (int value);
}
function get_ManagementPort();
function set_ManagementPort(value);

Property Value

Type: Int32
The port where the management service is listening.
See Also

Reference

ServerInfo Class
DoubleTake.Core.Contract Namespace


ServerInfo.MemorySize Property

ServerInfoMemorySize Property
This value is the amount of memory on the server.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public long MemorySize { get; set; }
Public Property MemorySize As Long
    Get
    Set
public:
property long long MemorySize {
    long long get ();
    void set (long long value);
}
function get_MemorySize();
function set_MemorySize(value);

Property Value

Type: Int64
The amount of memory on the server.
See Also

Reference

ServerInfo Class
DoubleTake.Core.Contract Namespace


ServerInfo.Name Property

ServerInfoName Property
This value is the name of the server.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
function get_Name();
function set_Name(value);

Property Value

Type: String
The name of the server.
See Also

Reference

ServerInfo Class
DoubleTake.Core.Contract Namespace


ServerInfo.NetworkInterfaces Property

ServerInfoNetworkInterfaces Property
This value represents the NICs on the server.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public NetworkInterfaceInfo[] NetworkInterfaces { get; set; }
Public Property NetworkInterfaces As NetworkInterfaceInfo()
    Get
    Set
public:
property array<NetworkInterfaceInfo^>^ NetworkInterfaces {
    array<NetworkInterfaceInfo^>^ get ();
    void set (array<NetworkInterfaceInfo^>^ value);
}
function get_NetworkInterfaces();
function set_NetworkInterfaces(value);

Property Value

Type: NetworkInterfaceInfo
An array of NetworkInterfaceInfo representing the network interfaces on the server.
See Also

Reference

ServerInfo Class
DoubleTake.Core.Contract Namespace


ServerInfo.NodeLockedServerInfo Property

ServerInfoNodeLockedServerInfo Property
This value is the server information needed for an activation key.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string NodeLockedServerInfo { get; set; }
Public Property NodeLockedServerInfo As String
    Get
    Set
public:
property String^ NodeLockedServerInfo {
    String^ get ();
    void set (String^ value);
}
function get_NodeLockedServerInfo();
function set_NodeLockedServerInfo(value);

Property Value

Type: String
See Also

Reference

ServerInfo Class
DoubleTake.Core.Contract Namespace


ServerInfo.OperatingSystem Property

ServerInfoOperatingSystem Property
This value is the the operating system on the server.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public OperatingSystemInfo OperatingSystem { get; set; }
Public Property OperatingSystem As OperatingSystemInfo
    Get
    Set
public:
property OperatingSystemInfo^ OperatingSystem {
    OperatingSystemInfo^ get ();
    void set (OperatingSystemInfo^ value);
}
function get_OperatingSystem();
function set_OperatingSystem(value);

Property Value

Type: OperatingSystemInfo
An OperatingSytemInfo representing the operating system on the server.
See Also

Reference

ServerInfo Class
DoubleTake.Core.Contract Namespace


ServerInfo.ProcessorCount Property

ServerInfoProcessorCount Property
This value is the processor count on the server.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int ProcessorCount { get; set; }
Public Property ProcessorCount As Integer
    Get
    Set
public:
property int ProcessorCount {
    int get ();
    void set (int value);
}
function get_ProcessorCount();
function set_ProcessorCount(value);

Property Value

Type: Int32
The processor count of the server.
See Also

Reference

ServerInfo Class
DoubleTake.Core.Contract Namespace


ServerInfo.ProgramFilesPath Property

ServerInfoProgramFilesPath Property
This value is the server's program files path.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string ProgramFilesPath { get; set; }
Public Property ProgramFilesPath As String
    Get
    Set
public:
property String^ ProgramFilesPath {
    String^ get ();
    void set (String^ value);
}
function get_ProgramFilesPath();
function set_ProgramFilesPath(value);

Property Value

Type: String
The program files path.
See Also

Reference

ServerInfo Class
DoubleTake.Core.Contract Namespace


ServerInfo.SystemPath Property

ServerInfoSystemPath Property
This value is the server's system path.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string SystemPath { get; set; }
Public Property SystemPath As String
    Get
    Set
public:
property String^ SystemPath {
    String^ get ();
    void set (String^ value);
}
function get_SystemPath();
function set_SystemPath(value);

Property Value

Type: String
The system path.
See Also

Reference

ServerInfo Class
DoubleTake.Core.Contract Namespace


ServerInfo.SystemRoot Property

ServerInfoSystemRoot Property
This value is the sever's system root path.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string SystemRoot { get; set; }
Public Property SystemRoot As String
    Get
    Set
public:
property String^ SystemRoot {
    String^ get ();
    void set (String^ value);
}
function get_SystemRoot();
function set_SystemRoot(value);

Property Value

Type: String
The system root path.
See Also

Reference

ServerInfo Class
DoubleTake.Core.Contract Namespace


ServerInfo.SystemStateDefinition Property

ServerInfoSystemStateDefinition Property
Do not use this property. Double-Take uses it internally.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string SystemStateDefinition { get; set; }
Public Property SystemStateDefinition As String
    Get
    Set
public:
property String^ SystemStateDefinition {
    String^ get ();
    void set (String^ value);
}
function get_SystemStateDefinition();
function set_SystemStateDefinition(value);

Property Value

Type: String
The system state definition as an XML string.
Remarks
This property is used to support the infrastructure and is not intended to be used by client code.
See Also

Reference

ServerInfo Class
DoubleTake.Core.Contract Namespace


ServerInfo.SystemVolume Property

ServerInfoSystemVolume Property
This value is the server's system volume.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string SystemVolume { get; set; }
Public Property SystemVolume As String
    Get
    Set
public:
property String^ SystemVolume {
    String^ get ();
    void set (String^ value);
}
function get_SystemVolume();
function set_SystemVolume(value);

Property Value

Type: String
The system volume.
See Also

Reference

ServerInfo Class
DoubleTake.Core.Contract Namespace


ServerInfo.Volumes Property

ServerInfoVolumes Property
This value represents the volumes on the server.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Volume[] Volumes { get; set; }
Public Property Volumes As Volume()
    Get
    Set
public:
property array<Volume^>^ Volumes {
    array<Volume^>^ get ();
    void set (array<Volume^>^ value);
}
function get_Volumes();
function set_Volumes(value);

Property Value

Type: Volume
An array of Volume representing the volumes on the server.
See Also

Reference

ServerInfo Class
DoubleTake.Core.Contract Namespace


ShutdownOption Enumeration

ShutdownOption Enumeration

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public enum ShutdownOption
Public Enumeration ShutdownOption
public enum class ShutdownOption
DoubleTake.Core.Contract.ShutdownOption = function();
DoubleTake.Core.Contract.ShutdownOption.createEnum('DoubleTake.Core.Contract.ShutdownOption', false);
Members
Member name | Value | Description
ShutdownOnly | 0 |
Restart | 1 |
See Also

Reference

DoubleTake.Core.Contract Namespace


StringSetting Class

StringSetting Class
Inheritance Hierarchy
SystemObject
ObservableObject
DoubleTake.Core.ContractNamedSetting
DoubleTake.Core.ContractStringSetting

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class StringSetting : NamedSetting
Public Class StringSetting
    Inherits NamedSetting
public ref class StringSetting : public NamedSetting
DoubleTake.Core.Contract.StringSetting = function();

Type.createClass(
    'DoubleTake.Core.Contract.StringSetting',
    DoubleTake.Core.Contract.NamedSetting);

The StringSetting type exposes the following members.

Constructors
 | Name | Description
Public method | StringSetting | Initializes a new instance of the StringSetting class
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from NamedSetting.)
Public property | Name | (Inherited from NamedSetting.)
Public property | TypeName | (Inherited from NamedSetting.)
Public property | Value |
Top
See Also

Reference

DoubleTake.Core.Contract Namespace


StringSetting Constructor

StringSetting Constructor
Initializes a new instance of the StringSetting class

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public StringSetting()
Public Sub New
public:
StringSetting()
DoubleTake.Core.Contract.StringSetting = function();
See Also

Reference

StringSetting Class
DoubleTake.Core.Contract Namespace


StringSetting Properties

StringSetting Properties

The StringSetting type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from NamedSetting.)
Public property | Name | (Inherited from NamedSetting.)
Public property | TypeName | (Inherited from NamedSetting.)
Public property | Value |
Top
See Also

Reference

StringSetting Class
DoubleTake.Core.Contract Namespace


StringSetting.Value Property

StringSettingValue Property

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Value { get; set; }
Public Property Value As String
    Get
    Set
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}
function get_Value();
function set_Value(value);

Property Value

Type: String
See Also

Reference

StringSetting Class
DoubleTake.Core.Contract Namespace


SystemStateCutoverStatus Class

SystemStateCutoverStatus Class
Wraps the System state cutover status
Inheritance Hierarchy
SystemObject
DoubleTake.Core.ContractSystemStateCutoverStatus

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class SystemStateCutoverStatus
Public Class SystemStateCutoverStatus
public ref class SystemStateCutoverStatus
DoubleTake.Core.Contract.SystemStateCutoverStatus = function();

Type.createClass(
    'DoubleTake.Core.Contract.SystemStateCutoverStatus');

The SystemStateCutoverStatus type exposes the following members.

Constructors
 | Name | Description
Public method | SystemStateCutoverStatus | Initializes a new instance of the SystemStateCutoverStatus class
Top
Properties
 | Name | Description
Public property | PercentComplete | Gets or sets the percent complete.
Public property | State | Gets or sets the state. If State > 0 SSM Cutover in progress If State = 0 No SSM Cutover activity If State is less 0 SSM Cutover failed in Phase : Math. Abs (State) If State > 0 AND PercentComplete = 100 SSM Cutover complete
Public property | TargetRebootFailed | Gets or sets a value indicating whether or not the call to reboot the target failed.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to this instance. (Overrides ObjectEquals(Object).)
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ObjectGetHashCode.)
Top
See Also

Reference

DoubleTake.Core.Contract Namespace


SystemStateCutoverStatus Constructor

SystemStateCutoverStatus Constructor
Initializes a new instance of the SystemStateCutoverStatus class

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public SystemStateCutoverStatus()
Public Sub New
public:
SystemStateCutoverStatus()
DoubleTake.Core.Contract.SystemStateCutoverStatus = function();
See Also

Reference

SystemStateCutoverStatus Class
DoubleTake.Core.Contract Namespace


SystemStateCutoverStatus Properties

SystemStateCutoverStatus Properties

The SystemStateCutoverStatus type exposes the following members.

Properties
 | Name | Description
Public property | PercentComplete | Gets or sets the percent complete.
Public property | State | Gets or sets the state. If State > 0 SSM Cutover in progress If State = 0 No SSM Cutover activity If State is less 0 SSM Cutover failed in Phase : Math. Abs (State) If State > 0 AND PercentComplete = 100 SSM Cutover complete
Public property | TargetRebootFailed | Gets or sets a value indicating whether or not the call to reboot the target failed.
Top
See Also

Reference

SystemStateCutoverStatus Class
DoubleTake.Core.Contract Namespace


SystemStateCutoverStatus.PercentComplete Property

SystemStateCutoverStatusPercentComplete Property
Gets or sets the percent complete.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int PercentComplete { get; set; }
Public Property PercentComplete As Integer
    Get
    Set
public:
property int PercentComplete {
    int get ();
    void set (int value);
}
function get_PercentComplete();
function set_PercentComplete(value);

Property Value

Type: Int32
The percent complete.
See Also

Reference

SystemStateCutoverStatus Class
DoubleTake.Core.Contract Namespace


SystemStateCutoverStatus.State Property

SystemStateCutoverStatusState Property
Gets or sets the state. If State > 0 SSM Cutover in progress If State = 0 No SSM Cutover activity If State is less 0 SSM Cutover failed in Phase : Math. Abs (State) If State > 0 AND PercentComplete = 100 SSM Cutover complete

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int State { get; set; }
Public Property State As Integer
    Get
    Set
public:
property int State {
    int get ();
    void set (int value);
}
function get_State();
function set_State(value);

Property Value

Type: Int32
The state.
See Also

Reference

SystemStateCutoverStatus Class
DoubleTake.Core.Contract Namespace


SystemStateCutoverStatus.TargetRebootFailed Property

SystemStateCutoverStatusTargetRebootFailed Property
Gets or sets a value indicating whether or not the call to reboot the target failed.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool TargetRebootFailed { get; set; }
Public Property TargetRebootFailed As Boolean
    Get
    Set
public:
property bool TargetRebootFailed {
    bool get ();
    void set (bool value);
}
function get_TargetRebootFailed();
function set_TargetRebootFailed(value);

Property Value

Type: Boolean
if the target reboot failed; otherwise, .
See Also

Reference

SystemStateCutoverStatus Class
DoubleTake.Core.Contract Namespace


SystemStateCutoverStatus Methods

SystemStateCutoverStatus Methods

The SystemStateCutoverStatus type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to this instance. (Overrides ObjectEquals(Object).)
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ObjectGetHashCode.)
Top
See Also

Reference

SystemStateCutoverStatus Class
DoubleTake.Core.Contract Namespace


SystemStateCutoverStatus.Equals Method

SystemStateCutoverStatusEquals Method
Determines whether the specified Object is equal to this instance.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
function Equals(obj);

Parameters

obj
Type: SystemObject
The Object to compare with this instance.

Return Value

Type: Boolean
true if the specified Object is equal to this instance; otherwise, false.
Exceptions
Exception | Condition
NullReferenceException | The obj parameter is null.
See Also

Reference

SystemStateCutoverStatus Class
DoubleTake.Core.Contract Namespace


SystemStateCutoverStatus.GetHashCode Method

SystemStateCutoverStatusGetHashCode Method
Returns a hash code for this instance.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
function GetHashCode();

Return Value

Type: Int32
A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.
See Also

Reference

SystemStateCutoverStatus Class
DoubleTake.Core.Contract Namespace


SystemStateDumpNonDiskSystemStateInfoStatus Class

SystemStateDumpNonDiskSystemStateInfoStatus Class
Wraps the System State DumpNonDiskSystemStateInfoStatus
Inheritance Hierarchy
SystemObject
DoubleTake.Core.ContractSystemStateDumpNonDiskSystemStateInfoStatus

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class SystemStateDumpNonDiskSystemStateInfoStatus
Public Class SystemStateDumpNonDiskSystemStateInfoStatus
public ref class SystemStateDumpNonDiskSystemStateInfoStatus
DoubleTake.Core.Contract.SystemStateDumpNonDiskSystemStateInfoStatus = function();

Type.createClass(
    'DoubleTake.Core.Contract.SystemStateDumpNonDiskSystemStateInfoStatus');

The SystemStateDumpNonDiskSystemStateInfoStatus type exposes the following members.

Constructors
 | Name | Description
Public method | SystemStateDumpNonDiskSystemStateInfoStatus | Initializes a new instance of the SystemStateDumpNonDiskSystemStateInfoStatus class
Top
Properties
 | Name | Description
Public property | Complete | Gets or sets a value indicating whether this SystemStateDumpNonDiskSystemStateInfoStatus is complete.
Public property | Log | Gets or sets the log.
Top
See Also

Reference

DoubleTake.Core.Contract Namespace


SystemStateDumpNonDiskSystemStateInfoStatus Constructor

SystemStateDumpNonDiskSystemStateInfoStatus Constructor
Initializes a new instance of the SystemStateDumpNonDiskSystemStateInfoStatus class

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public SystemStateDumpNonDiskSystemStateInfoStatus()
Public Sub New
public:
SystemStateDumpNonDiskSystemStateInfoStatus()
DoubleTake.Core.Contract.SystemStateDumpNonDiskSystemStateInfoStatus = function();
See Also

Reference

SystemStateDumpNonDiskSystemStateInfoStatus Class
DoubleTake.Core.Contract Namespace


SystemStateDumpNonDiskSystemStateInfoStatus Properties

SystemStateDumpNonDiskSystemStateInfoStatus Properties

The SystemStateDumpNonDiskSystemStateInfoStatus type exposes the following members.

Properties
 | Name | Description
Public property | Complete | Gets or sets a value indicating whether this SystemStateDumpNonDiskSystemStateInfoStatus is complete.
Public property | Log | Gets or sets the log.
Top
See Also

Reference

SystemStateDumpNonDiskSystemStateInfoStatus Class
DoubleTake.Core.Contract Namespace


SystemStateDumpNonDiskSystemStateInfoStatus.Complete Property

SystemStateDumpNonDiskSystemStateInfoStatusComplete Property
Gets or sets a value indicating whether this SystemStateDumpNonDiskSystemStateInfoStatus is complete.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool Complete { get; set; }
Public Property Complete As Boolean
    Get
    Set
public:
property bool Complete {
    bool get ();
    void set (bool value);
}
function get_Complete();
function set_Complete(value);

Property Value

Type: Boolean
true if complete; otherwise, false.
See Also

Reference

SystemStateDumpNonDiskSystemStateInfoStatus Class
DoubleTake.Core.Contract Namespace


SystemStateDumpNonDiskSystemStateInfoStatus.Log Property

SystemStateDumpNonDiskSystemStateInfoStatusLog Property
Gets or sets the log.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Log { get; set; }
Public Property Log As String
    Get
    Set
public:
property String^ Log {
    String^ get ();
    void set (String^ value);
}
function get_Log();
function set_Log(value);

Property Value

Type: String
The log.
See Also

Reference

SystemStateDumpNonDiskSystemStateInfoStatus Class
DoubleTake.Core.Contract Namespace


SystemStateVerificationResult Class

SystemStateVerificationResult Class
Inheritance Hierarchy
SystemObject
ObservableObject
DoubleTake.Core.ContractSystemStateVerificationResult

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class SystemStateVerificationResult : ObservableObject,
    IExtensibleDataObject
Public Class SystemStateVerificationResult
    Inherits ObservableObject
    Implements IExtensibleDataObject
public ref class SystemStateVerificationResult : public ObservableObject,
    IExtensibleDataObject
DoubleTake.Core.Contract.SystemStateVerificationResult = function();

Type.createClass(
    'DoubleTake.Core.Contract.SystemStateVerificationResult',
    DoubleTake.Common.ComponentModel.ObservableObject,
    IExtensibleDataObject);

The SystemStateVerificationResult type exposes the following members.

Constructors
 | Name | Description
Public method | SystemStateVerificationResult | Initializes a new instance of the SystemStateVerificationResult class
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | IsCompatible | Gets or sets a value indicating whether the system state is compatible.
Public property | ValidationResults | Gets or sets the validation results.
Top
See Also

Reference

DoubleTake.Core.Contract Namespace


SystemStateVerificationResult Constructor

SystemStateVerificationResult Constructor
Initializes a new instance of the SystemStateVerificationResult class

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public SystemStateVerificationResult()
Public Sub New
public:
SystemStateVerificationResult()
DoubleTake.Core.Contract.SystemStateVerificationResult = function();
See Also

Reference

SystemStateVerificationResult Class
DoubleTake.Core.Contract Namespace


SystemStateVerificationResult Properties

SystemStateVerificationResult Properties

The SystemStateVerificationResult type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | IsCompatible | Gets or sets a value indicating whether the system state is compatible.
Public property | ValidationResults | Gets or sets the validation results.
Top
See Also

Reference

SystemStateVerificationResult Class
DoubleTake.Core.Contract Namespace


SystemStateVerificationResult.ExtensionData Property

SystemStateVerificationResultExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

SystemStateVerificationResult Class
DoubleTake.Core.Contract Namespace


SystemStateVerificationResult.IsCompatible Property

SystemStateVerificationResultIsCompatible Property
Gets or sets a value indicating whether the system state is compatible.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsCompatible { get; set; }
Public Property IsCompatible As Boolean
    Get
    Set
public:
property bool IsCompatible {
    bool get ();
    void set (bool value);
}
function get_IsCompatible();
function set_IsCompatible(value);

Property Value

Type: Boolean
if the system state is compatible; otherwise, .
See Also

Reference

SystemStateVerificationResult Class
DoubleTake.Core.Contract Namespace


SystemStateVerificationResult.ValidationResults Property

SystemStateVerificationResultValidationResults Property
Gets or sets the validation results.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public SystemStateVerificationStep[] ValidationResults { get; set; }
Public Property ValidationResults As SystemStateVerificationStep()
    Get
    Set
public:
property array<SystemStateVerificationStep^>^ ValidationResults {
    array<SystemStateVerificationStep^>^ get ();
    void set (array<SystemStateVerificationStep^>^ value);
}
function get_ValidationResults();
function set_ValidationResults(value);

Property Value

Type: SystemStateVerificationStep
The validation results.
See Also

Reference

SystemStateVerificationResult Class
DoubleTake.Core.Contract Namespace


SystemStateVerificationStep Class

SystemStateVerificationStep Class
Inheritance Hierarchy
SystemObject
ObservableObject
DoubleTake.Core.ContractSystemStateVerificationStep

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class SystemStateVerificationStep : ObservableObject,
    IExtensibleDataObject
Public Class SystemStateVerificationStep
    Inherits ObservableObject
    Implements IExtensibleDataObject
public ref class SystemStateVerificationStep : public ObservableObject,
    IExtensibleDataObject
DoubleTake.Core.Contract.SystemStateVerificationStep = function();

Type.createClass(
    'DoubleTake.Core.Contract.SystemStateVerificationStep',
    DoubleTake.Common.ComponentModel.ObservableObject,
    IExtensibleDataObject);

The SystemStateVerificationStep type exposes the following members.

Constructors
 | Name | Description
Public method | SystemStateVerificationStep | Initializes a new instance of the SystemStateVerificationStep class
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Message | Gets or sets the message.
Public property | Name | Gets or sets the name.
Public property | Source | Gets or sets the source.
Public property | Status | Gets or sets the state.
Public property | Target | Gets or sets the target.
Public property | Task | Gets or sets the task.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to this instance. (Overrides ObjectEquals(Object).)
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ObjectGetHashCode.)
Public method | ToString | Returns a String that represents this instance. (Overrides ObjectToString.)
Top
See Also

Reference

DoubleTake.Core.Contract Namespace


SystemStateVerificationStep Constructor

SystemStateVerificationStep Constructor
Initializes a new instance of the SystemStateVerificationStep class

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public SystemStateVerificationStep()
Public Sub New
public:
SystemStateVerificationStep()
DoubleTake.Core.Contract.SystemStateVerificationStep = function();
See Also

Reference

SystemStateVerificationStep Class
DoubleTake.Core.Contract Namespace


SystemStateVerificationStep Properties

SystemStateVerificationStep Properties

The SystemStateVerificationStep type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Message | Gets or sets the message.
Public property | Name | Gets or sets the name.
Public property | Source | Gets or sets the source.
Public property | Status | Gets or sets the state.
Public property | Target | Gets or sets the target.
Public property | Task | Gets or sets the task.
Top
See Also

Reference

SystemStateVerificationStep Class
DoubleTake.Core.Contract Namespace


SystemStateVerificationStep.ExtensionData Property

SystemStateVerificationStepExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

SystemStateVerificationStep Class
DoubleTake.Core.Contract Namespace


SystemStateVerificationStep.Message Property

SystemStateVerificationStepMessage Property
Gets or sets the message.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Message { get; set; }
Public Property Message As String
    Get
    Set
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}
function get_Message();
function set_Message(value);

Property Value

Type: String
The message.
See Also

Reference

SystemStateVerificationStep Class
DoubleTake.Core.Contract Namespace


SystemStateVerificationStep.Name Property

SystemStateVerificationStepName Property
Gets or sets the name.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
function get_Name();
function set_Name(value);

Property Value

Type: String
The name.
See Also

Reference

SystemStateVerificationStep Class
DoubleTake.Core.Contract Namespace


SystemStateVerificationStep.Source Property

SystemStateVerificationStepSource Property
Gets or sets the source.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Source { get; set; }
Public Property Source As String
    Get
    Set
public:
property String^ Source {
    String^ get ();
    void set (String^ value);
}
function get_Source();
function set_Source(value);

Property Value

Type: String
The source.
See Also

Reference

SystemStateVerificationStep Class
DoubleTake.Core.Contract Namespace


SystemStateVerificationStep.Status Property

SystemStateVerificationStepStatus Property
Gets or sets the state.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VerificationStatus Status { get; set; }
Public Property Status As VerificationStatus
    Get
    Set
public:
property VerificationStatus Status {
    VerificationStatus get ();
    void set (VerificationStatus value);
}
function get_Status();
function set_Status(value);

Property Value

Type: VerificationStatus
The state.
See Also

Reference

SystemStateVerificationStep Class
DoubleTake.Core.Contract Namespace


SystemStateVerificationStep.Target Property

SystemStateVerificationStepTarget Property
Gets or sets the target.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Target { get; set; }
Public Property Target As String
    Get
    Set
public:
property String^ Target {
    String^ get ();
    void set (String^ value);
}
function get_Target();
function set_Target(value);

Property Value

Type: String
The target.
See Also

Reference

SystemStateVerificationStep Class
DoubleTake.Core.Contract Namespace


SystemStateVerificationStep.Task Property

SystemStateVerificationStepTask Property
Gets or sets the task.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public long Task { get; set; }
Public Property Task As Long
    Get
    Set
public:
property long long Task {
    long long get ();
    void set (long long value);
}
function get_Task();
function set_Task(value);

Property Value

Type: Int64
The task.
See Also

Reference

SystemStateVerificationStep Class
DoubleTake.Core.Contract Namespace


SystemStateVerificationStep Methods

SystemStateVerificationStep Methods

The SystemStateVerificationStep type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to this instance. (Overrides ObjectEquals(Object).)
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ObjectGetHashCode.)
Public method | ToString | Returns a String that represents this instance. (Overrides ObjectToString.)
Top
See Also

Reference

SystemStateVerificationStep Class
DoubleTake.Core.Contract Namespace


SystemStateVerificationStep.Equals Method

SystemStateVerificationStepEquals Method
Determines whether the specified Object is equal to this instance.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
function Equals(obj);

Parameters

obj
Type: SystemObject
The Object to compare with this instance.

Return Value

Type: Boolean
true if the specified Object is equal to this instance; otherwise, false.
Exceptions
Exception | Condition
NullReferenceException | The obj parameter is null.
See Also

Reference

SystemStateVerificationStep Class
DoubleTake.Core.Contract Namespace


SystemStateVerificationStep.GetHashCode Method

SystemStateVerificationStepGetHashCode Method
Returns a hash code for this instance.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
function GetHashCode();

Return Value

Type: Int32
A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.
See Also

Reference

SystemStateVerificationStep Class
DoubleTake.Core.Contract Namespace


SystemStateVerificationStep.ToString Method

SystemStateVerificationStepToString Method
Returns a String that represents this instance.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
function ToString();

Return Value

Type: String
A String that represents this instance.
See Also

Reference

SystemStateVerificationStep Class
DoubleTake.Core.Contract Namespace


UnicastIPAddressInfo Class

UnicastIPAddressInfo Class
Represents a unicast IP address.
Inheritance Hierarchy
SystemObject
DoubleTake.Core.ContractUnicastIPAddressInfo

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class UnicastIPAddressInfo : IExtensibleDataObject
Public Class UnicastIPAddressInfo
    Implements IExtensibleDataObject
public ref class UnicastIPAddressInfo : IExtensibleDataObject
DoubleTake.Core.Contract.UnicastIPAddressInfo = function();

Type.createClass(
    'DoubleTake.Core.Contract.UnicastIPAddressInfo',
    null,
    IExtensibleDataObject);

The UnicastIPAddressInfo type exposes the following members.

Constructors
 | Name | Description
Public method | UnicastIPAddressInfo | Initializes a new instance of the UnicastIPAddressInfo class
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | IPAddress | This value is the IP address as a string.
Public property | IPv4Mask | This value is the the IPv4 subnet mask.
Public property | IsDHCP | This value is true if the IP address is a DHCP assigned address; otherwise, it is false.
Public property | IsNAT | This value is true if the IP address is a public NAT address; otherwise, it is false.
Public property | IsOnline | This value is true if the IP address is online; otherwise, it is false.
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether the current object is equal to another object of the same type.
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ObjectGetHashCode.)
Top
See Also

Reference

DoubleTake.Core.Contract Namespace


UnicastIPAddressInfo Constructor

UnicastIPAddressInfo Constructor
Initializes a new instance of the UnicastIPAddressInfo class

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public UnicastIPAddressInfo()
Public Sub New
public:
UnicastIPAddressInfo()
DoubleTake.Core.Contract.UnicastIPAddressInfo = function();
See Also

Reference

UnicastIPAddressInfo Class
DoubleTake.Core.Contract Namespace


UnicastIPAddressInfo Properties

UnicastIPAddressInfo Properties

The UnicastIPAddressInfo type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | IPAddress | This value is the IP address as a string.
Public property | IPv4Mask | This value is the the IPv4 subnet mask.
Public property | IsDHCP | This value is true if the IP address is a DHCP assigned address; otherwise, it is false.
Public property | IsNAT | This value is true if the IP address is a public NAT address; otherwise, it is false.
Public property | IsOnline | This value is true if the IP address is online; otherwise, it is false.
Top
See Also

Reference

UnicastIPAddressInfo Class
DoubleTake.Core.Contract Namespace


UnicastIPAddressInfo.ExtensionData Property

UnicastIPAddressInfoExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

UnicastIPAddressInfo Class
DoubleTake.Core.Contract Namespace


UnicastIPAddressInfo.IPAddress Property

UnicastIPAddressInfoIPAddress Property
This value is the IP address as a string.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string IPAddress { get; set; }
Public Property IPAddress As String
    Get
    Set
public:
property String^ IPAddress {
    String^ get ();
    void set (String^ value);
}
function get_IPAddress();
function set_IPAddress(value);

Property Value

Type: String
The IP address as a string.
See Also

Reference

UnicastIPAddressInfo Class
DoubleTake.Core.Contract Namespace


UnicastIPAddressInfo.IPv4Mask Property

UnicastIPAddressInfoIPv4Mask Property
This value is the the IPv4 subnet mask.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string IPv4Mask { get; set; }
Public Property IPv4Mask As String
    Get
    Set
public:
property String^ IPv4Mask {
    String^ get ();
    void set (String^ value);
}
function get_IPv4Mask();
function set_IPv4Mask(value);

Property Value

Type: String
The IPv4 mask.
See Also

Reference

UnicastIPAddressInfo Class
DoubleTake.Core.Contract Namespace


UnicastIPAddressInfo.IsDHCP Property

UnicastIPAddressInfoIsDHCP Property
This value is true if the IP address is a DHCP assigned address; otherwise, it is false.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsDHCP { get; set; }
Public Property IsDHCP As Boolean
    Get
    Set
public:
property bool IsDHCP {
    bool get ();
    void set (bool value);
}
function get_IsDHCP();
function set_IsDHCP(value);

Property Value

Type: Boolean
if this address is a DHCP-assigned address; otherwise, .
See Also

Reference

UnicastIPAddressInfo Class
DoubleTake.Core.Contract Namespace


UnicastIPAddressInfo.IsNAT Property

UnicastIPAddressInfoIsNAT Property
This value is true if the IP address is a public NAT address; otherwise, it is false.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsNAT { get; set; }
Public Property IsNAT As Boolean
    Get
    Set
public:
property bool IsNAT {
    bool get ();
    void set (bool value);
}
function get_IsNAT();
function set_IsNAT(value);

Property Value

Type: Boolean
if this instance is NAT; otherwise, .
See Also

Reference

UnicastIPAddressInfo Class
DoubleTake.Core.Contract Namespace


UnicastIPAddressInfo.IsOnline Property

UnicastIPAddressInfoIsOnline Property
This value is true if the IP address is online; otherwise, it is false.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsOnline { get; set; }
Public Property IsOnline As Boolean
    Get
    Set
public:
property bool IsOnline {
    bool get ();
    void set (bool value);
}
function get_IsOnline();
function set_IsOnline(value);

Property Value

Type: Boolean
true if this instance is online; otherwise, false.
See Also

Reference

UnicastIPAddressInfo Class
DoubleTake.Core.Contract Namespace


UnicastIPAddressInfo Methods

UnicastIPAddressInfo Methods

The UnicastIPAddressInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether the current object is equal to another object of the same type.
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ObjectGetHashCode.)
Top
See Also

Reference

UnicastIPAddressInfo Class
DoubleTake.Core.Contract Namespace


UnicastIPAddressInfo.Equals Method

UnicastIPAddressInfoEquals Method
Indicates whether the current object is equal to another object of the same type.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool Equals(
    UnicastIPAddressInfo other
)
Public Function Equals (
    other As UnicastIPAddressInfo
) As Boolean
public:
virtual bool Equals(
    UnicastIPAddressInfo^ other
) sealed
function Equals(other);

Parameters

other
Type: DoubleTake.Core.ContractUnicastIPAddressInfo
An object to compare with this object.

Return Value

Type: Boolean
if the current object is equal to the other parameter; otherwise, .
See Also

Reference

UnicastIPAddressInfo Class
DoubleTake.Core.Contract Namespace


UnicastIPAddressInfo.GetHashCode Method

UnicastIPAddressInfoGetHashCode Method
Returns a hash code for this instance.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
function GetHashCode();

Return Value

Type: Int32
A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.
See Also

Reference

UnicastIPAddressInfo Class
DoubleTake.Core.Contract Namespace


VhdDeleteActionType Enumeration

VhdDeleteActionType Enumeration

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public enum VhdDeleteActionType
Public Enumeration VhdDeleteActionType
public enum class VhdDeleteActionType
DoubleTake.Core.Contract.VhdDeleteActionType = function();
DoubleTake.Core.Contract.VhdDeleteActionType.createEnum('DoubleTake.Core.Contract.VhdDeleteActionType', false);
Members
Member name | Value | Description
KeepAll | 0 | Keep all VHDs for this image
DeleteAll | 1 | Delete all VHDs for this image
UseVhdsToDelete | 2 | Keep only the VHDs specified in the VhdsToKeep member
See Also

Reference

DoubleTake.Core.Contract Namespace


VolumeOptions Class

VolumeOptions Class
Represents a volume to protect and any changes to it's base configuration
Inheritance Hierarchy
SystemObject
DoubleTake.Common.ContractPhysicalItem
DoubleTake.Common.ContractVolume
DoubleTake.Core.ContractVolumeOptions
DoubleTake.Core.Contract.UVRALogicalVolume
DoubleTake.Core.Contract.UVRAPhysicalVolume
DoubleTake.Virtualization.Contract.VRAUVRAVolumePersistedState
DoubleTake.Virtualization.Contract.VRAVRAVolumePersistedState

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class VolumeOptions : Volume
Public Class VolumeOptions
    Inherits Volume
public ref class VolumeOptions : public Volume
DoubleTake.Core.Contract.VolumeOptions = function();

Type.createClass(
    'DoubleTake.Core.Contract.VolumeOptions',
    DoubleTake.Common.Contract.Volume);

The VolumeOptions type exposes the following members.

Constructors
 | Name | Description
Public method | VolumeOptions | Initializes a new instance of the VolumeOptions class
Top
Properties
 | Name | Description
Public property | Attributes | This value represents the file system attributes. (Inherited from PhysicalItem.)
Public property | AvailableFreeSpace | This value is the amount of free space on the volume. (Inherited from Volume.)
Public property | CreationTime | This value is the time when the item was created. (Inherited from PhysicalItem.)
Public property | DesiredSize | This value is the desired size of the new volume.
Public property | DiskControllerType | This value is the disk controller. IDE—Use this value to create an IDE disk. SCSI—Use this value to create a SCSI disk.
Public property | DiskProvisioningType | This value is the disk type. Dynamic—Use this value for ESX thin disks and for Hyper-V dynamic disks. Fixed—Use this value for ESX thick disks and for Hyper-V fixed disks. Flat Disk—Use this value for ESX flat disks. This type is not supported on Hyper-V.
Public property | DriveFormat | This value is the file system format of the volume. (Inherited from Volume.)
Public property | DriveType | This value is the drive type. (Inherited from Volume.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from PhysicalItem.)
Public property | IsContainer | This value is true if the item is a container of other items; otherwise, it is false. (Inherited from PhysicalItem.)
Public property | IsReadOnly | This value is true if the item is read-only (meaning the Saturation cannot be changed); otherwise, it is false. (Inherited from PhysicalItem.)
Public property | IsSystemDrive | This value is true if the volume is the system volume; otherwise, it is false. (Inherited from Volume.)
Public property | ItemType | This value is the type of item. (Inherited from PhysicalItem.)
Public property | Label | This value is the label assigned to the volume. (Inherited from Volume.)
Public property | LastAccessTime | This value is the time when the item was last accessed. (Inherited from PhysicalItem.)
Public property | LastWriteTime | This value is the time when the item was last written to. (Inherited from PhysicalItem.)
Public property | Metadata | This value is any additional metadata that may be displayed for a particular type of item. This metadata is not in any particular format, but you must be able to determine the format and decipher the metadata based on the type. (Inherited from PhysicalItem.)
Public property | Name | This value is the name of the item. Typically, this name is used for display in the user interface. (Inherited from PhysicalItem.)
Public property | Path | This value is the path of the item. (Inherited from PhysicalItem.)
Public property | PreexistingDiskPath | This value is the full path and file name of an existing virtual disk that you want to reuse. If this value is null, a new virtual disk will be created.
Public property | Saturation | This value represents the saturation level of the item. Typically, this value is used to display a visual state in the user interface. (Inherited from PhysicalItem.)
Public property | Size | This value is the physical size of the item. (Inherited from PhysicalItem.)
Public property | TotalSize | This value is the total size of the volume. (Inherited from Volume.)
Public property | VirtualDiskPath | This value is the path on the host where the volume should be stored.
Public property | VolumeSignature | This value is the volume signature.
Public property | VolumeType | This value is the type of volume. (Inherited from Volume.)
Top
Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Top
See Also

Reference

DoubleTake.Core.Contract Namespace


VolumeOptions Constructor

VolumeOptions Constructor
Initializes a new instance of the VolumeOptions class

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VolumeOptions()
Public Sub New
public:
VolumeOptions()
DoubleTake.Core.Contract.VolumeOptions = function();
See Also

Reference

VolumeOptions Class
DoubleTake.Core.Contract Namespace


VolumeOptions Properties

VolumeOptions Properties

The VolumeOptions type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | This value represents the file system attributes. (Inherited from PhysicalItem.)
Public property | AvailableFreeSpace | This value is the amount of free space on the volume. (Inherited from Volume.)
Public property | CreationTime | This value is the time when the item was created. (Inherited from PhysicalItem.)
Public property | DesiredSize | This value is the desired size of the new volume.
Public property | DiskControllerType | This value is the disk controller. IDE—Use this value to create an IDE disk. SCSI—Use this value to create a SCSI disk.
Public property | DiskProvisioningType | This value is the disk type. Dynamic—Use this value for ESX thin disks and for Hyper-V dynamic disks. Fixed—Use this value for ESX thick disks and for Hyper-V fixed disks. Flat Disk—Use this value for ESX flat disks. This type is not supported on Hyper-V.
Public property | DriveFormat | This value is the file system format of the volume. (Inherited from Volume.)
Public property | DriveType | This value is the drive type. (Inherited from Volume.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from PhysicalItem.)
Public property | IsContainer | This value is true if the item is a container of other items; otherwise, it is false. (Inherited from PhysicalItem.)
Public property | IsReadOnly | This value is true if the item is read-only (meaning the Saturation cannot be changed); otherwise, it is false. (Inherited from PhysicalItem.)
Public property | IsSystemDrive | This value is true if the volume is the system volume; otherwise, it is false. (Inherited from Volume.)
Public property | ItemType | This value is the type of item. (Inherited from PhysicalItem.)
Public property | Label | This value is the label assigned to the volume. (Inherited from Volume.)
Public property | LastAccessTime | This value is the time when the item was last accessed. (Inherited from PhysicalItem.)
Public property | LastWriteTime | This value is the time when the item was last written to. (Inherited from PhysicalItem.)
Public property | Metadata | This value is any additional metadata that may be displayed for a particular type of item. This metadata is not in any particular format, but you must be able to determine the format and decipher the metadata based on the type. (Inherited from PhysicalItem.)
Public property | Name | This value is the name of the item. Typically, this name is used for display in the user interface. (Inherited from PhysicalItem.)
Public property | Path | This value is the path of the item. (Inherited from PhysicalItem.)
Public property | PreexistingDiskPath | This value is the full path and file name of an existing virtual disk that you want to reuse. If this value is null, a new virtual disk will be created.
Public property | Saturation | This value represents the saturation level of the item. Typically, this value is used to display a visual state in the user interface. (Inherited from PhysicalItem.)
Public property | Size | This value is the physical size of the item. (Inherited from PhysicalItem.)
Public property | TotalSize | This value is the total size of the volume. (Inherited from Volume.)
Public property | VirtualDiskPath | This value is the path on the host where the volume should be stored.
Public property | VolumeSignature | This value is the volume signature.
Public property | VolumeType | This value is the type of volume. (Inherited from Volume.)
Top
See Also

Reference

VolumeOptions Class
DoubleTake.Core.Contract Namespace


VolumeOptions.DesiredSize Property

VolumeOptionsDesiredSize Property
This value is the desired size of the new volume.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public long DesiredSize { get; set; }
Public Property DesiredSize As Long
    Get
    Set
public:
property long long DesiredSize {
    long long get ();
    void set (long long value);
}
function get_DesiredSize();
function set_DesiredSize(value);

Property Value

Type: Int64
The desired size.
See Also

Reference

VolumeOptions Class
DoubleTake.Core.Contract Namespace


VolumeOptions.DiskControllerType Property

VolumeOptionsDiskControllerType Property
This value is the disk controller. IDE—Use this value to create an IDE disk. SCSI—Use this value to create a SCSI disk.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string DiskControllerType { get; set; }
Public Property DiskControllerType As String
    Get
    Set
public:
property String^ DiskControllerType {
    String^ get ();
    void set (String^ value);
}
function get_DiskControllerType();
function set_DiskControllerType(value);

Property Value

Type: String
The type of the disk controller.
See Also

Reference

VolumeOptions Class
DoubleTake.Core.Contract Namespace


VolumeOptions.DiskProvisioningType Property

VolumeOptionsDiskProvisioningType Property
This value is the disk type. Dynamic—Use this value for ESX thin disks and for Hyper-V dynamic disks. Fixed—Use this value for ESX thick disks and for Hyper-V fixed disks. Flat Disk—Use this value for ESX flat disks. This type is not supported on Hyper-V.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string DiskProvisioningType { get; set; }
Public Property DiskProvisioningType As String
    Get
    Set
public:
property String^ DiskProvisioningType {
    String^ get ();
    void set (String^ value);
}
function get_DiskProvisioningType();
function set_DiskProvisioningType(value);

Property Value

Type: String
The type of the disk provisioning.
See Also

Reference

VolumeOptions Class
DoubleTake.Core.Contract Namespace


VolumeOptions.PreexistingDiskPath Property

VolumeOptionsPreexistingDiskPath Property
This value is the full path and file name of an existing virtual disk that you want to reuse. If this value is null, a new virtual disk will be created.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string PreexistingDiskPath { get; set; }
Public Property PreexistingDiskPath As String
    Get
    Set
public:
property String^ PreexistingDiskPath {
    String^ get ();
    void set (String^ value);
}
function get_PreexistingDiskPath();
function set_PreexistingDiskPath(value);

Property Value

Type: String
The path of this pre-existing path.
See Also

Reference

VolumeOptions Class
DoubleTake.Core.Contract Namespace


VolumeOptions.VirtualDiskPath Property

VolumeOptionsVirtualDiskPath Property
This value is the path on the host where the volume should be stored.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string VirtualDiskPath { get; set; }
Public Property VirtualDiskPath As String
    Get
    Set
public:
property String^ VirtualDiskPath {
    String^ get ();
    void set (String^ value);
}
function get_VirtualDiskPath();
function set_VirtualDiskPath(value);

Property Value

Type: String
The path of this item.
See Also

Reference

VolumeOptions Class
DoubleTake.Core.Contract Namespace


VolumeOptions.VolumeSignature Property

VolumeOptionsVolumeSignature Property
This value is the volume signature.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public byte[] VolumeSignature { get; set; }
Public Property VolumeSignature As Byte()
    Get
    Set
public:
property array<unsigned char>^ VolumeSignature {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
function get_VolumeSignature();
function set_VolumeSignature(value);

Property Value

Type: Byte
The volume signature.
See Also

Reference

VolumeOptions Class
DoubleTake.Core.Contract Namespace


VolumeOptions Methods

VolumeOptions Methods

The VolumeOptions type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Top
See Also

Reference

VolumeOptions Class
DoubleTake.Core.Contract Namespace


VolumeOptions.Clone Method

VolumeOptionsClone Method
Creates a new object that is a copy of the current instance.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
function Clone();

Return Value

Type: Object
A new object that is a copy of this instance.
See Also

Reference

VolumeOptions Class
DoubleTake.Core.Contract Namespace


DoubleTake.Core.Contract.Connection Namespace

DoubleTake.Core.Contract.Connection Namespace
Classes
 | Class | Description
Public class | ArchiveCriteria |
Public class | ArchiveSchedule |
Public class | BandwidthLimit | Used for specifying the current or new bandwidth limit and/or mode.
Public class | BandwidthSchedule | Specifies a bandwidth limiting schedule for a connection. Used for both displaying and configuring the bandwidth schedule.
Public class | BandwidthScheduleEntry | An entry in a bandwidth limiting schedule.
Public class | BandwidthSpecification | Represents a commonly-used bandwidth size, as identified by a text description and a numberic speed. For example, "T1" is assocated with 193,000 bytes per second.
Public class | CompressionLevel | Represents a compression level that can be applied to a connection.
Public class | ConnectionConfiguration | Describes the servers and settings involved in the connection.
Public class | ConnectionInfo | Contains connection configuration, status and statistics.
Public class | ConnectionQualificationResult |
Public class | ConnectionSchedule |
Public class | ConnectionStartParameters | Used to define the parameters used when creating a connection that mirrors and replicates the protected data from the source to the target.
Public class | ConnectionStatistics | Represents the raw statistics of a single Double-Take engine connection.
Public class | ConnectionStatus | The operational state of a connection.
Public class | MirrorParameters |
Public class | OrphansSchedule | This value is true if orphan files (files in the target path location that are not present on the source) will be deleted; otherwise, it is false. There is currently no schedule (time-related options) for orphan files. They can only be on or off.
Public class | QueueTaskParameters | Specifies the parameters for executing in-band tasks on a Double-Take connection.
Public class | RestoreParameters | Represents the parameters required to start a restore operation for a connection.
Public class | ScheduleItem |
Public class | ScriptPoint |
Public class | SnapshotEntry | Represents a snapshot created by the Windows Volume Snapshot Service.
Public class | SnapshotSchedule |
Public class | TargetStateInfo | Represents an engine connection from the perspective of the target server.
Public class | TaskParameters | Specifies a script or executable to be run along with its corresponding command-line arguments.
Public class | TimeWindow |
Public class | TransmissionSchedule |
Public class | VerifySchedule |
Enumerations
 | Enumeration | Description
Public enumeration | ArchiveRestoreOption | Defines options for how archived files are handled during a restore operation.
Public enumeration | BandwidthScheduleMode | Defines the mode of a bandwidth schedule.
Public enumeration | BandwidthSpecificationType | Defines possible types of bandwidth specifications.
Public enumeration | ClusterResourceState | Cluster Resource State Enumerations
Public enumeration | ConnectionMode |
Public enumeration | ConnectionQualificationFailures |
Public enumeration | MirrorComparisonCriteria | Specifies how to compare files during a difference mirror or when running a verification report.
Public enumeration | MirrorOperationOptions | Specifies what to do when a verify mirror operation is performed.
Public enumeration | MirrorState | The operational state of mirroring.
Public enumeration | QueueState | The operational state of a queue.
Public enumeration | ReplicationState | The operational state of replication.
Public enumeration | RestoreOptions | Defines options that can be applied when restoring data.
Public enumeration | ScriptExecutionMode |
Public enumeration | ScriptPointType |
Public enumeration | SnapshotAge |
Public enumeration | SnapshotCreationReason | Indicates possible triggers for how a snapshot was taken.
Public enumeration | SnapshotQuality |
Public enumeration | TargetStates | Represent possible states of the target server.
Public enumeration | TransmissionMode | The operational state of data transmission from the source to target server.
Public enumeration | Weekdays | Defines the days of the week and common combinations of weekdays.


ArchiveCriteria Class

ArchiveCriteria Class
Inheritance Hierarchy
SystemObject
ObservableObject
DoubleTake.Core.Contract.ConnectionArchiveCriteria

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public sealed class ArchiveCriteria : ObservableObject,
    IExtensibleDataObject
Public NotInheritable Class ArchiveCriteria
    Inherits ObservableObject
    Implements IExtensibleDataObject
public ref class ArchiveCriteria sealed : public ObservableObject,
    IExtensibleDataObject
DoubleTake.Core.Contract.Connection.ArchiveCriteria = function();

Type.createClass(
    'DoubleTake.Core.Contract.Connection.ArchiveCriteria',
    DoubleTake.Common.ComponentModel.ObservableObject,
    IExtensibleDataObject);

The ArchiveCriteria type exposes the following members.

Constructors
 | Name | Description
Public method | ArchiveCriteria | Initializes a new instance of the ArchiveCriteria class
Top
Properties
 | Name | Description
Public property | Age |
Public property | DiskUtilizationPercentage |
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | LogErrors |
Public property | MinimumFileSize |
Public property | Paths |
Top
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


ArchiveCriteria Constructor

ArchiveCriteria Constructor
Initializes a new instance of the ArchiveCriteria class

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ArchiveCriteria()
Public Sub New
public:
ArchiveCriteria()
DoubleTake.Core.Contract.Connection.ArchiveCriteria = function();
See Also

Reference

ArchiveCriteria Class
DoubleTake.Core.Contract.Connection Namespace


ArchiveCriteria Properties

ArchiveCriteria Properties

The ArchiveCriteria type exposes the following members.

Properties
 | Name | Description
Public property | Age |
Public property | DiskUtilizationPercentage |
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | LogErrors |
Public property | MinimumFileSize |
Public property | Paths |
Top
See Also

Reference

ArchiveCriteria Class
DoubleTake.Core.Contract.Connection Namespace


ArchiveCriteria.Age Property

ArchiveCriteriaAge Property

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public TimeSpan Age { get; set; }
Public Property Age As TimeSpan
    Get
    Set
public:
property TimeSpan Age {
    TimeSpan get ();
    void set (TimeSpan value);
}
function get_Age();
function set_Age(value);

Property Value

Type: TimeSpan
See Also

Reference

ArchiveCriteria Class
DoubleTake.Core.Contract.Connection Namespace


ArchiveCriteria.DiskUtilizationPercentage Property

ArchiveCriteriaDiskUtilizationPercentage Property

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int DiskUtilizationPercentage { get; set; }
Public Property DiskUtilizationPercentage As Integer
    Get
    Set
public:
property int DiskUtilizationPercentage {
    int get ();
    void set (int value);
}
function get_DiskUtilizationPercentage();
function set_DiskUtilizationPercentage(value);

Property Value

Type: Int32
See Also

Reference

ArchiveCriteria Class
DoubleTake.Core.Contract.Connection Namespace


ArchiveCriteria.ExtensionData Property

ArchiveCriteriaExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

ArchiveCriteria Class
DoubleTake.Core.Contract.Connection Namespace


ArchiveCriteria.LogErrors Property

ArchiveCriteriaLogErrors Property

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool LogErrors { get; set; }
Public Property LogErrors As Boolean
    Get
    Set
public:
property bool LogErrors {
    bool get ();
    void set (bool value);
}
function get_LogErrors();
function set_LogErrors(value);

Property Value

Type: Boolean
See Also

Reference

ArchiveCriteria Class
DoubleTake.Core.Contract.Connection Namespace


ArchiveCriteria.MinimumFileSize Property

ArchiveCriteriaMinimumFileSize Property

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public long MinimumFileSize { get; set; }
Public Property MinimumFileSize As Long
    Get
    Set
public:
property long long MinimumFileSize {
    long long get ();
    void set (long long value);
}
function get_MinimumFileSize();
function set_MinimumFileSize(value);

Property Value

Type: Int64
See Also

Reference

ArchiveCriteria Class
DoubleTake.Core.Contract.Connection Namespace


ArchiveCriteria.Paths Property

ArchiveCriteriaPaths Property

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string[] Paths { get; set; }
Public Property Paths As String()
    Get
    Set
public:
property array<String^>^ Paths {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
function get_Paths();
function set_Paths(value);

Property Value

Type: String
See Also

Reference

ArchiveCriteria Class
DoubleTake.Core.Contract.Connection Namespace


ArchiveRestoreOption Enumeration

ArchiveRestoreOption Enumeration
Defines options for how archived files are handled during a restore operation.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public enum ArchiveRestoreOption
Public Enumeration ArchiveRestoreOption
public enum class ArchiveRestoreOption
DoubleTake.Core.Contract.Connection.ArchiveRestoreOption = function();
DoubleTake.Core.Contract.Connection.ArchiveRestoreOption.createEnum('DoubleTake.Core.Contract.Connection.ArchiveRestoreOption', false);
Members
Member name | Value | Description
None | 0 | Do not process archived files when restoring.
ArchiveBeforeRestore | 1 | Archive all files before restoring.
RecallBeforeRestore | 2 | Recall all files before restoring.
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


ArchiveSchedule Class

ArchiveSchedule Class
Inheritance Hierarchy
SystemObject
DoubleTake.Core.Contract.ConnectionScheduleItem
DoubleTake.Core.Contract.ConnectionArchiveSchedule

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public sealed class ArchiveSchedule : ScheduleItem
Public NotInheritable Class ArchiveSchedule
    Inherits ScheduleItem
public ref class ArchiveSchedule sealed : public ScheduleItem
DoubleTake.Core.Contract.Connection.ArchiveSchedule = function();

Type.createClass(
    'DoubleTake.Core.Contract.Connection.ArchiveSchedule',
    DoubleTake.Core.Contract.Connection.ScheduleItem);

The ArchiveSchedule type exposes the following members.

Constructors
 | Name | Description
Public method | ArchiveSchedule | Initializes a new instance of the ArchiveSchedule class
Top
Properties
 | Name | Description
Public property | Criteria |
Public property | Days |
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from ScheduleItem.)
Public property | IsEnabled | (Inherited from ScheduleItem.)
Public property | StartTime |
Top
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


ArchiveSchedule Constructor

ArchiveSchedule Constructor
Initializes a new instance of the ArchiveSchedule class

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ArchiveSchedule()
Public Sub New
public:
ArchiveSchedule()
DoubleTake.Core.Contract.Connection.ArchiveSchedule = function();
See Also

Reference

ArchiveSchedule Class
DoubleTake.Core.Contract.Connection Namespace


ArchiveSchedule Properties

ArchiveSchedule Properties

The ArchiveSchedule type exposes the following members.

Properties
 | Name | Description
Public property | Criteria |
Public property | Days |
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from ScheduleItem.)
Public property | IsEnabled | (Inherited from ScheduleItem.)
Public property | StartTime |
Top
See Also

Reference

ArchiveSchedule Class
DoubleTake.Core.Contract.Connection Namespace


ArchiveSchedule.Criteria Property

ArchiveScheduleCriteria Property

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ArchiveCriteria Criteria { get; set; }
Public Property Criteria As ArchiveCriteria
    Get
    Set
public:
property ArchiveCriteria^ Criteria {
    ArchiveCriteria^ get ();
    void set (ArchiveCriteria^ value);
}
function get_Criteria();
function set_Criteria(value);

Property Value

Type: ArchiveCriteria
See Also

Reference

ArchiveSchedule Class
DoubleTake.Core.Contract.Connection Namespace


ArchiveSchedule.Days Property

ArchiveScheduleDays Property

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Weekdays Days { get; set; }
Public Property Days As Weekdays
    Get
    Set
public:
property Weekdays Days {
    Weekdays get ();
    void set (Weekdays value);
}
function get_Days();
function set_Days(value);

Property Value

Type: Weekdays
See Also

Reference

ArchiveSchedule Class
DoubleTake.Core.Contract.Connection Namespace


ArchiveSchedule.StartTime Property

ArchiveScheduleStartTime Property

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public DateTime StartTime { get; set; }
Public Property StartTime As DateTime
    Get
    Set
public:
property DateTime StartTime {
    DateTime get ();
    void set (DateTime value);
}
function get_StartTime();
function set_StartTime(value);

Property Value

Type: DateTime
See Also

Reference

ArchiveSchedule Class
DoubleTake.Core.Contract.Connection Namespace


BandwidthLimit Class

BandwidthLimit Class
Used for specifying the current or new bandwidth limit and/or mode.
Inheritance Hierarchy
SystemObject
DoubleTake.Core.Contract.ConnectionBandwidthLimit

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class BandwidthLimit : IExtensibleDataObject
Public Class BandwidthLimit
    Implements IExtensibleDataObject
public ref class BandwidthLimit : IExtensibleDataObject
DoubleTake.Core.Contract.Connection.BandwidthLimit = function();

Type.createClass(
    'DoubleTake.Core.Contract.Connection.BandwidthLimit',
    null,
    IExtensibleDataObject);

The BandwidthLimit type exposes the following members.

Constructors
 | Name | Description
Public method | BandwidthLimit | Initializes a new instance of the BandwidthLimit class
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Limit | This value is the bandwidth limit in bytes per second.
Public property | Mode | This value is the bandwidth limiting mode.
Top
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


BandwidthLimit Constructor

BandwidthLimit Constructor
Initializes a new instance of the BandwidthLimit class

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public BandwidthLimit()
Public Sub New
public:
BandwidthLimit()
DoubleTake.Core.Contract.Connection.BandwidthLimit = function();
See Also

Reference

BandwidthLimit Class
DoubleTake.Core.Contract.Connection Namespace


BandwidthLimit Properties

BandwidthLimit Properties

The BandwidthLimit type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Limit | This value is the bandwidth limit in bytes per second.
Public property | Mode | This value is the bandwidth limiting mode.
Top
See Also

Reference

BandwidthLimit Class
DoubleTake.Core.Contract.Connection Namespace


BandwidthLimit.ExtensionData Property

BandwidthLimitExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The structure that contains extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

BandwidthLimit Class
DoubleTake.Core.Contract.Connection Namespace


BandwidthLimit.Limit Property

BandwidthLimitLimit Property
This value is the bandwidth limit in bytes per second.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public long Limit { get; set; }
Public Property Limit As Long
    Get
    Set
public:
property long long Limit {
    long long get ();
    void set (long long value);
}
function get_Limit();
function set_Limit(value);

Property Value

Type: Int64
The limit in Bps (bytes/second).
See Also

Reference

BandwidthLimit Class
DoubleTake.Core.Contract.Connection Namespace


BandwidthLimit.Mode Property

BandwidthLimitMode Property
This value is the bandwidth limiting mode.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public BandwidthScheduleMode Mode { get; set; }
Public Property Mode As BandwidthScheduleMode
    Get
    Set
public:
property BandwidthScheduleMode Mode {
    BandwidthScheduleMode get ();
    void set (BandwidthScheduleMode value);
}
function get_Mode();
function set_Mode(value);

Property Value

Type: BandwidthScheduleMode
The mode bandwidth limiting mode.
See Also

Reference

BandwidthLimit Class
DoubleTake.Core.Contract.Connection Namespace


BandwidthSchedule Class

BandwidthSchedule Class
Specifies a bandwidth limiting schedule for a connection. Used for both displaying and configuring the bandwidth schedule.
Inheritance Hierarchy
SystemObject
DoubleTake.Core.Contract.ConnectionBandwidthSchedule

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public sealed class BandwidthSchedule : IExtensibleDataObject
Public NotInheritable Class BandwidthSchedule
    Implements IExtensibleDataObject
public ref class BandwidthSchedule sealed : IExtensibleDataObject
DoubleTake.Core.Contract.Connection.BandwidthSchedule = function();

Type.createClass(
    'DoubleTake.Core.Contract.Connection.BandwidthSchedule',
    null,
    IExtensibleDataObject);

The BandwidthSchedule type exposes the following members.

Constructors
 | Name | Description
Public method | BandwidthSchedule | Initializes a new instance of the BandwidthSchedule class
Top
Properties
 | Name | Description
Public property | Current | This value is the current bandwidth schedule entry being used.
Public property | Entries | This value represents the bandwidth schedule. This value is copied from BandwidthOptions.Entries.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Mode | This value is the bandwidth limiting mode. This value is copied from BandwidthOptions.Mode.
Public property | Specifications | This value represents a bandwidth specifications as identified by a common name (for example T1) and a numeric speed (for example, 193,000 bytes per second). This value is copied from BandwidthOptions.Specification.
Top
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


BandwidthSchedule Constructor

BandwidthSchedule Constructor
Initializes a new instance of the BandwidthSchedule class

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public BandwidthSchedule()
Public Sub New
public:
BandwidthSchedule()
DoubleTake.Core.Contract.Connection.BandwidthSchedule = function();
See Also

Reference

BandwidthSchedule Class
DoubleTake.Core.Contract.Connection Namespace


BandwidthSchedule Properties

BandwidthSchedule Properties

The BandwidthSchedule type exposes the following members.

Properties
 | Name | Description
Public property | Current | This value is the current bandwidth schedule entry being used.
Public property | Entries | This value represents the bandwidth schedule. This value is copied from BandwidthOptions.Entries.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Mode | This value is the bandwidth limiting mode. This value is copied from BandwidthOptions.Mode.
Public property | Specifications | This value represents a bandwidth specifications as identified by a common name (for example T1) and a numeric speed (for example, 193,000 bytes per second). This value is copied from BandwidthOptions.Specification.
Top
See Also

Reference

BandwidthSchedule Class
DoubleTake.Core.Contract.Connection Namespace


BandwidthSchedule.Current Property

BandwidthScheduleCurrent Property
This value is the current bandwidth schedule entry being used.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public BandwidthScheduleEntry Current { get; set; }
Public Property Current As BandwidthScheduleEntry
    Get
    Set
public:
property BandwidthScheduleEntry^ Current {
    BandwidthScheduleEntry^ get ();
    void set (BandwidthScheduleEntry^ value);
}
function get_Current();
function set_Current(value);

Property Value

Type: BandwidthScheduleEntry
The active bandwidth schedule entry.
See Also

Reference

BandwidthSchedule Class
DoubleTake.Core.Contract.Connection Namespace


BandwidthSchedule.Entries Property

BandwidthScheduleEntries Property
This value represents the bandwidth schedule. This value is copied from BandwidthOptions.Entries.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public BandwidthScheduleEntry[] Entries { get; set; }
Public Property Entries As BandwidthScheduleEntry()
    Get
    Set
public:
property array<BandwidthScheduleEntry^>^ Entries {
    array<BandwidthScheduleEntry^>^ get ();
    void set (array<BandwidthScheduleEntry^>^ value);
}
function get_Entries();
function set_Entries(value);

Property Value

Type: BandwidthScheduleEntry
The array of bandwidth schedule entries.
See Also

Reference

BandwidthSchedule Class
DoubleTake.Core.Contract.Connection Namespace


BandwidthSchedule.ExtensionData Property

BandwidthScheduleExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

BandwidthSchedule Class
DoubleTake.Core.Contract.Connection Namespace


BandwidthSchedule.Mode Property

BandwidthScheduleMode Property
This value is the bandwidth limiting mode. This value is copied from BandwidthOptions.Mode.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public BandwidthScheduleMode Mode { get; set; }
Public Property Mode As BandwidthScheduleMode
    Get
    Set
public:
property BandwidthScheduleMode Mode {
    BandwidthScheduleMode get ();
    void set (BandwidthScheduleMode value);
}
function get_Mode();
function set_Mode(value);

Property Value

Type: BandwidthScheduleMode
The current bandwidth schedule mode for a connection.
See Also

Reference

BandwidthSchedule Class
DoubleTake.Core.Contract.Connection Namespace
DoubleTake.Core.Contract.ConnectionBandwidthScheduleMode


BandwidthSchedule.Specifications Property

BandwidthScheduleSpecifications Property
This value represents a bandwidth specifications as identified by a common name (for example T1) and a numeric speed (for example, 193,000 bytes per second). This value is copied from BandwidthOptions.Specification.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public BandwidthSpecification[] Specifications { get; set; }
Public Property Specifications As BandwidthSpecification()
    Get
    Set
public:
property array<BandwidthSpecification^>^ Specifications {
    array<BandwidthSpecification^>^ get ();
    void set (array<BandwidthSpecification^>^ value);
}
function get_Specifications();
function set_Specifications(value);

Property Value

Type: BandwidthSpecification
The bandwidth specifications.
See Also

Reference

BandwidthSchedule Class
DoubleTake.Core.Contract.Connection Namespace


BandwidthScheduleEntry Class

BandwidthScheduleEntry Class
An entry in a bandwidth limiting schedule.
Inheritance Hierarchy
SystemObject
DoubleTake.Core.Contract.ConnectionBandwidthScheduleEntry

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public sealed class BandwidthScheduleEntry : IExtensibleDataObject
Public NotInheritable Class BandwidthScheduleEntry
    Implements IExtensibleDataObject
public ref class BandwidthScheduleEntry sealed : IExtensibleDataObject
DoubleTake.Core.Contract.Connection.BandwidthScheduleEntry = function();

Type.createClass(
    'DoubleTake.Core.Contract.Connection.BandwidthScheduleEntry',
    null,
    IExtensibleDataObject);

The BandwidthScheduleEntry type exposes the following members.

Constructors
 | Name | Description
Public method | BandwidthScheduleEntry | Initializes a new instance of the BandwidthScheduleEntry class
Top
Properties
 | Name | Description
Public property | DaysOfWeek | This values is the days of the week to which the entry applies.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | IsUnlimited | This value is true if the entry allows unlimited bandwidth; otherwise, it is false. entry is active.
Public property | Limit | This value is the bandwidth limit in bytes per second.
Public property | Name | This value is the name of the entry. It must be unique among all entries in the bandwidth schedule.
Public property | StartTime | This value is the start time of the entry. It should be between 00:00:00 and 23:59:59 (hh:mm:ss).
Top
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


BandwidthScheduleEntry Constructor

BandwidthScheduleEntry Constructor
Initializes a new instance of the BandwidthScheduleEntry class

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public BandwidthScheduleEntry()
Public Sub New
public:
BandwidthScheduleEntry()
DoubleTake.Core.Contract.Connection.BandwidthScheduleEntry = function();
See Also

Reference

BandwidthScheduleEntry Class
DoubleTake.Core.Contract.Connection Namespace


BandwidthScheduleEntry Properties

BandwidthScheduleEntry Properties

The BandwidthScheduleEntry type exposes the following members.

Properties
 | Name | Description
Public property | DaysOfWeek | This values is the days of the week to which the entry applies.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | IsUnlimited | This value is true if the entry allows unlimited bandwidth; otherwise, it is false. entry is active.
Public property | Limit | This value is the bandwidth limit in bytes per second.
Public property | Name | This value is the name of the entry. It must be unique among all entries in the bandwidth schedule.
Public property | StartTime | This value is the start time of the entry. It should be between 00:00:00 and 23:59:59 (hh:mm:ss).
Top
See Also

Reference

BandwidthScheduleEntry Class
DoubleTake.Core.Contract.Connection Namespace


BandwidthScheduleEntry.DaysOfWeek Property

BandwidthScheduleEntryDaysOfWeek Property
This values is the days of the week to which the entry applies.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Weekdays DaysOfWeek { get; set; }
Public Property DaysOfWeek As Weekdays
    Get
    Set
public:
property Weekdays DaysOfWeek {
    Weekdays get ();
    void set (Weekdays value);
}
function get_DaysOfWeek();
function set_DaysOfWeek(value);

Property Value

Type: Weekdays
See Also

Reference

BandwidthScheduleEntry Class
DoubleTake.Core.Contract.Connection Namespace


BandwidthScheduleEntry.ExtensionData Property

BandwidthScheduleEntryExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

BandwidthScheduleEntry Class
DoubleTake.Core.Contract.Connection Namespace


BandwidthScheduleEntry.IsUnlimited Property

BandwidthScheduleEntryIsUnlimited Property
This value is true if the entry allows unlimited bandwidth; otherwise, it is false. entry is active.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsUnlimited { get; set; }
Public Property IsUnlimited As Boolean
    Get
    Set
public:
property bool IsUnlimited {
    bool get ();
    void set (bool value);
}
function get_IsUnlimited();
function set_IsUnlimited(value);

Property Value

Type: Boolean
See Also

Reference

BandwidthScheduleEntry Class
DoubleTake.Core.Contract.Connection Namespace


BandwidthScheduleEntry.Limit Property

BandwidthScheduleEntryLimit Property
This value is the bandwidth limit in bytes per second.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public long Limit { get; set; }
Public Property Limit As Long
    Get
    Set
public:
property long long Limit {
    long long get ();
    void set (long long value);
}
function get_Limit();
function set_Limit(value);

Property Value

Type: Int64
See Also

Reference

BandwidthScheduleEntry Class
DoubleTake.Core.Contract.Connection Namespace


BandwidthScheduleEntry.Name Property

BandwidthScheduleEntryName Property
This value is the name of the entry. It must be unique among all entries in the bandwidth schedule.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
function get_Name();
function set_Name(value);

Property Value

Type: String
See Also

Reference

BandwidthScheduleEntry Class
DoubleTake.Core.Contract.Connection Namespace


BandwidthScheduleEntry.StartTime Property

BandwidthScheduleEntryStartTime Property
This value is the start time of the entry. It should be between 00:00:00 and 23:59:59 (hh:mm:ss).

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public DateTime StartTime { get; set; }
Public Property StartTime As DateTime
    Get
    Set
public:
property DateTime StartTime {
    DateTime get ();
    void set (DateTime value);
}
function get_StartTime();
function set_StartTime(value);

Property Value

Type: DateTime
See Also

Reference

BandwidthScheduleEntry Class
DoubleTake.Core.Contract.Connection Namespace


BandwidthScheduleMode Enumeration

BandwidthScheduleMode Enumeration
Defines the mode of a bandwidth schedule.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public enum BandwidthScheduleMode
Public Enumeration BandwidthScheduleMode
public enum class BandwidthScheduleMode
DoubleTake.Core.Contract.Connection.BandwidthScheduleMode = function();
DoubleTake.Core.Contract.Connection.BandwidthScheduleMode.createEnum('DoubleTake.Core.Contract.Connection.BandwidthScheduleMode', false);
Members
Member name | Value | Description
NotLimited | 0 | Bandwidth is not limited.
Fixed | 1 | Bandwidth is limited to a fixed value.
Scheduled | 2 | Bandwidth is limited according to scheduled values.
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


BandwidthSpecification Class

BandwidthSpecification Class
Represents a commonly-used bandwidth size, as identified by a text description and a numberic speed. For example, "T1" is assocated with 193,000 bytes per second.
Inheritance Hierarchy
SystemObject
ObservableObject
DoubleTake.Core.Contract.ConnectionBandwidthSpecification

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public sealed class BandwidthSpecification : ObservableObject,
    IExtensibleDataObject
Public NotInheritable Class BandwidthSpecification
    Inherits ObservableObject
    Implements IExtensibleDataObject
public ref class BandwidthSpecification sealed : public ObservableObject,
    IExtensibleDataObject
DoubleTake.Core.Contract.Connection.BandwidthSpecification = function();

Type.createClass(
    'DoubleTake.Core.Contract.Connection.BandwidthSpecification',
    DoubleTake.Common.ComponentModel.ObservableObject,
    IExtensibleDataObject);

The BandwidthSpecification type exposes the following members.

Constructors
 | Name | Description
Public method | BandwidthSpecification | Initializes a new instance of the BandwidthSpecification class
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Key | This value is a common name that represents a bandwidth specifications, for example T1.
Public property | Type | This value represents the bandwidth specification associated with the type of network (LAN or WAN).
Public property | Value | This value is the bandwidth limit in bytes per second.
Top
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


BandwidthSpecification Constructor

BandwidthSpecification Constructor
Initializes a new instance of the BandwidthSpecification class

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public BandwidthSpecification()
Public Sub New
public:
BandwidthSpecification()
DoubleTake.Core.Contract.Connection.BandwidthSpecification = function();
See Also

Reference

BandwidthSpecification Class
DoubleTake.Core.Contract.Connection Namespace


BandwidthSpecification Properties

BandwidthSpecification Properties

The BandwidthSpecification type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Key | This value is a common name that represents a bandwidth specifications, for example T1.
Public property | Type | This value represents the bandwidth specification associated with the type of network (LAN or WAN).
Public property | Value | This value is the bandwidth limit in bytes per second.
Top
See Also

Reference

BandwidthSpecification Class
DoubleTake.Core.Contract.Connection Namespace


BandwidthSpecification.ExtensionData Property

BandwidthSpecificationExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

BandwidthSpecification Class
DoubleTake.Core.Contract.Connection Namespace


BandwidthSpecification.Key Property

BandwidthSpecificationKey Property
This value is a common name that represents a bandwidth specifications, for example T1.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Key { get; set; }
Public Property Key As String
    Get
    Set
public:
property String^ Key {
    String^ get ();
    void set (String^ value);
}
function get_Key();
function set_Key(value);

Property Value

Type: String
The name of the bandwidth specification.
See Also

Reference

BandwidthSpecification Class
DoubleTake.Core.Contract.Connection Namespace


BandwidthSpecification.Type Property

BandwidthSpecificationType Property
This value represents the bandwidth specification associated with the type of network (LAN or WAN).

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public BandwidthSpecificationType Type { get; set; }
Public Property Type As BandwidthSpecificationType
    Get
    Set
public:
property BandwidthSpecificationType Type {
    BandwidthSpecificationType get ();
    void set (BandwidthSpecificationType value);
}
function get_Type();
function set_Type(value);

Property Value

Type: BandwidthSpecificationType
The type of the bandwidth specification.
See Also

Reference

BandwidthSpecification Class
DoubleTake.Core.Contract.Connection Namespace


BandwidthSpecification.Value Property

BandwidthSpecificationValue Property
This value is the bandwidth limit in bytes per second.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public long Value { get; set; }
Public Property Value As Long
    Get
    Set
public:
property long long Value {
    long long get ();
    void set (long long value);
}
function get_Value();
function set_Value(value);

Property Value

Type: Int64
The speed of the bandwidth specification, in bytes per second.
See Also

Reference

BandwidthSpecification Class
DoubleTake.Core.Contract.Connection Namespace


BandwidthSpecificationType Enumeration

BandwidthSpecificationType Enumeration
Defines possible types of bandwidth specifications.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public enum BandwidthSpecificationType
Public Enumeration BandwidthSpecificationType
public enum class BandwidthSpecificationType
DoubleTake.Core.Contract.Connection.BandwidthSpecificationType = function();
DoubleTake.Core.Contract.Connection.BandwidthSpecificationType.createEnum('DoubleTake.Core.Contract.Connection.BandwidthSpecificationType', false);
Members
Member name | Value | Description
LAN | 0 | This value is the bandwidth associated with local area networks.
WAN | 1 | This value is the bandwidth associated with wide area networks.
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


ClusterResourceState Enumeration

ClusterResourceState Enumeration
Cluster Resource State Enumerations

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public enum ClusterResourceState
Public Enumeration ClusterResourceState
public enum class ClusterResourceState
DoubleTake.Core.Contract.Connection.ClusterResourceState = function();
DoubleTake.Core.Contract.Connection.ClusterResourceState.createEnum('DoubleTake.Core.Contract.Connection.ClusterResourceState', false);
Members
Member name | Value | Description
Uninitialized | 0 | A cluster resource is not used.
OfflinePending | 1 | The resource state changed to offline pending.
Offline | 2 | The resource state changed to offline.
OnlinePending | 3 | The resource state changed to online pending.
Online | 4 | The resource state changed to online.
ResourceNotFound | 5 | The cluster resource was not found on the cluster.
Reconnected | 6 | The cluster resource reconnected. This could be due to a node roll.
Connected | 7 | The cluster resource is connected and online.
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


CompressionLevel Class

CompressionLevel Class
Represents a compression level that can be applied to a connection.
Inheritance Hierarchy
SystemObject
DoubleTake.Core.Contract.ConnectionCompressionLevel

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class CompressionLevel : IExtensibleDataObject
Public Class CompressionLevel
    Implements IExtensibleDataObject
public ref class CompressionLevel : IExtensibleDataObject
DoubleTake.Core.Contract.Connection.CompressionLevel = function();

Type.createClass(
    'DoubleTake.Core.Contract.Connection.CompressionLevel',
    null,
    IExtensibleDataObject);

The CompressionLevel type exposes the following members.

Constructors
 | Name | Description
Public method | CompressionLevel | Initializes a new instance of the CompressionLevel class
Top
Properties
 | Name | Description
Public property | Algorithm | The algorithm and level properties are used together in the following combinations. Disabled—Compression is disabled if the level equals -1. The algorithm value is ignored when level equals -1. Low compression—Compression is enabled at a low level if level equals 0 and algorithm equals 10. Medium compression—Compression is enabled at a medium level if level equals 1 and algorithm equals 21. High compression—Compression is enabled at a high level if level equals 2 and algorithm equals 31.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Level | The algorithm and level properties are used together in the following combinations. Disabled—Compression is disabled if the level equals -1. The algorithm value is ignored when level equals -1. Low compression—Compression is enabled at a low level if level equals 0 and algorithm equals 10. Medium compression—Compression is enabled at a medium level if level equals 1 and algorithm equals 21. High compression—Compression is enabled at a high level if level equals 2 and algorithm equals 31.
Top
Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | Equals | Determines whether the specified Object is equal to this instance. (Overrides ObjectEquals(Object).)
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ObjectGetHashCode.)
Top
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


CompressionLevel Constructor

CompressionLevel Constructor
Initializes a new instance of the CompressionLevel class

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public CompressionLevel()
Public Sub New
public:
CompressionLevel()
DoubleTake.Core.Contract.Connection.CompressionLevel = function();
See Also

Reference

CompressionLevel Class
DoubleTake.Core.Contract.Connection Namespace


CompressionLevel Properties

CompressionLevel Properties

The CompressionLevel type exposes the following members.

Properties
 | Name | Description
Public property | Algorithm | The algorithm and level properties are used together in the following combinations. Disabled—Compression is disabled if the level equals -1. The algorithm value is ignored when level equals -1. Low compression—Compression is enabled at a low level if level equals 0 and algorithm equals 10. Medium compression—Compression is enabled at a medium level if level equals 1 and algorithm equals 21. High compression—Compression is enabled at a high level if level equals 2 and algorithm equals 31.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Level | The algorithm and level properties are used together in the following combinations. Disabled—Compression is disabled if the level equals -1. The algorithm value is ignored when level equals -1. Low compression—Compression is enabled at a low level if level equals 0 and algorithm equals 10. Medium compression—Compression is enabled at a medium level if level equals 1 and algorithm equals 21. High compression—Compression is enabled at a high level if level equals 2 and algorithm equals 31.
Top
See Also

Reference

CompressionLevel Class
DoubleTake.Core.Contract.Connection Namespace


CompressionLevel.Algorithm Property

CompressionLevelAlgorithm Property
The algorithm and level properties are used together in the following combinations. Disabled—Compression is disabled if the level equals -1. The algorithm value is ignored when level equals -1. Low compression—Compression is enabled at a low level if level equals 0 and algorithm equals 10. Medium compression—Compression is enabled at a medium level if level equals 1 and algorithm equals 21. High compression—Compression is enabled at a high level if level equals 2 and algorithm equals 31.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int Algorithm { get; set; }
Public Property Algorithm As Integer
    Get
    Set
public:
property int Algorithm {
    int get ();
    void set (int value);
}
function get_Algorithm();
function set_Algorithm(value);

Property Value

Type: Int32
The compression algorithm.
Remarks
The specific compression algorithm that is used by the source server to compress the data and by the target server to decompress the data. This value doesn't have any inherent meaning; it is simply a value shared between servers.
See Also

Reference

CompressionLevel Class
DoubleTake.Core.Contract.Connection Namespace


CompressionLevel.ExtensionData Property

CompressionLevelExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

CompressionLevel Class
DoubleTake.Core.Contract.Connection Namespace


CompressionLevel.Level Property

CompressionLevelLevel Property
The algorithm and level properties are used together in the following combinations. Disabled—Compression is disabled if the level equals -1. The algorithm value is ignored when level equals -1. Low compression—Compression is enabled at a low level if level equals 0 and algorithm equals 10. Medium compression—Compression is enabled at a medium level if level equals 1 and algorithm equals 21. High compression—Compression is enabled at a high level if level equals 2 and algorithm equals 31.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int Level { get; set; }
Public Property Level As Integer
    Get
    Set
public:
property int Level {
    int get ();
    void set (int value);
}
function get_Level();
function set_Level(value);

Property Value

Type: Int32
The level of compression.
Remarks
This value is a 0-based index into the list of compression algorithms that are shared by both the source and target servers. Typically, there are three levels of compression: 0 (Low), 1 (Medium) and 2 (High). A value of -1 means that compression is not used.
See Also

Reference

CompressionLevel Class
DoubleTake.Core.Contract.Connection Namespace


CompressionLevel Methods

CompressionLevel Methods

The CompressionLevel type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | Equals | Determines whether the specified Object is equal to this instance. (Overrides ObjectEquals(Object).)
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ObjectGetHashCode.)
Top
See Also

Reference

CompressionLevel Class
DoubleTake.Core.Contract.Connection Namespace


CompressionLevel.Clone Method

CompressionLevelClone Method
Creates a new object that is a copy of the current instance.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
function Clone();

Return Value

Type: Object
A new object that is a copy of this instance.
See Also

Reference

CompressionLevel Class
DoubleTake.Core.Contract.Connection Namespace


CompressionLevel.Equals Method

CompressionLevelEquals Method
Determines whether the specified Object is equal to this instance.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
function Equals(obj);

Parameters

obj
Type: SystemObject
The Object to compare with this instance.

Return Value

Type: Boolean
if the specified Object is equal to this instance; otherwise, .
Exceptions
Exception | Condition
NullReferenceException | The obj parameter is null.
See Also

Reference

CompressionLevel Class
DoubleTake.Core.Contract.Connection Namespace


CompressionLevel.GetHashCode Method

CompressionLevelGetHashCode Method
Returns a hash code for this instance.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
function GetHashCode();

Return Value

Type: Int32
A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.
See Also

Reference

CompressionLevel Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionConfiguration Class

ConnectionConfiguration Class
Describes the servers and settings involved in the connection.
Inheritance Hierarchy
SystemObject
DoubleTake.Core.Contract.ConnectionConnectionConfiguration

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class ConnectionConfiguration : IExtensibleDataObject
Public Class ConnectionConfiguration
    Implements IExtensibleDataObject
public ref class ConnectionConfiguration : IExtensibleDataObject
DoubleTake.Core.Contract.Connection.ConnectionConfiguration = function();

Type.createClass(
    'DoubleTake.Core.Contract.Connection.ConnectionConfiguration',
    null,
    IExtensibleDataObject);

The ConnectionConfiguration type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectionConfiguration | Initializes a new instance of the ConnectionConfiguration class
Top
Properties
 | Name | Description
Public property | BandwidthCollar | The current bandwidth limit.
Public property | CompressionAlgorithm | Indicates the code for the compression algorithm being used for this connection.
Public property | CompressionEnabled | Indicates whether transmitted data is compressed.
Public property | CompressionLevel | The level of compression configured on the connection.
Public property | ConnectionId | A one-based index for each connection established in a Double-Take instance.
Public property | Encrypt | Indicates whether transmitted data is encrypted.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | JobType | A product specific string indicating the type of job or workload protected by this connection.
Public property | PathTransformations | The filepath transformations applied to files replicated by this connection.
Public property | ReplicationSetName | The name of the replication set used for this connection.
Public property | SourceRoute | The source endpoint used by the target for this connection.
Public property | TargetLoaded | Indicates whether the target is loaded.
Public property | TargetName | The host name of the target, if available.
Public property | TargetRoute | The target endpoint used by the source for this connection.
Top
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


ConnectionConfiguration Constructor

ConnectionConfiguration Constructor
Initializes a new instance of the ConnectionConfiguration class

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ConnectionConfiguration()
Public Sub New
public:
ConnectionConfiguration()
DoubleTake.Core.Contract.Connection.ConnectionConfiguration = function();
See Also

Reference

ConnectionConfiguration Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionConfiguration Properties

ConnectionConfiguration Properties

The ConnectionConfiguration type exposes the following members.

Properties
 | Name | Description
Public property | BandwidthCollar | The current bandwidth limit.
Public property | CompressionAlgorithm | Indicates the code for the compression algorithm being used for this connection.
Public property | CompressionEnabled | Indicates whether transmitted data is compressed.
Public property | CompressionLevel | The level of compression configured on the connection.
Public property | ConnectionId | A one-based index for each connection established in a Double-Take instance.
Public property | Encrypt | Indicates whether transmitted data is encrypted.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | JobType | A product specific string indicating the type of job or workload protected by this connection.
Public property | PathTransformations | The filepath transformations applied to files replicated by this connection.
Public property | ReplicationSetName | The name of the replication set used for this connection.
Public property | SourceRoute | The source endpoint used by the target for this connection.
Public property | TargetLoaded | Indicates whether the target is loaded.
Public property | TargetName | The host name of the target, if available.
Public property | TargetRoute | The target endpoint used by the source for this connection.
Top
See Also

Reference

ConnectionConfiguration Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionConfiguration.BandwidthCollar Property

ConnectionConfigurationBandwidthCollar Property
The current bandwidth limit.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int BandwidthCollar { get; set; }
Public Property BandwidthCollar As Integer
    Get
    Set
public:
property int BandwidthCollar {
    int get ();
    void set (int value);
}
function get_BandwidthCollar();
function set_BandwidthCollar(value);

Property Value

Type: Int32
Remarks
The bandwidth limit may vary according to the configured limit schedule.
See Also

Reference

ConnectionConfiguration Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionConfiguration.CompressionAlgorithm Property

ConnectionConfigurationCompressionAlgorithm Property
Indicates the code for the compression algorithm being used for this connection.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int CompressionAlgorithm { get; set; }
Public Property CompressionAlgorithm As Integer
    Get
    Set
public:
property int CompressionAlgorithm {
    int get ();
    void set (int value);
}
function get_CompressionAlgorithm();
function set_CompressionAlgorithm(value);

Property Value

Type: Int32
See Also

Reference

ConnectionConfiguration Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionConfiguration.CompressionEnabled Property

ConnectionConfigurationCompressionEnabled Property
Indicates whether transmitted data is compressed.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool CompressionEnabled { get; set; }
Public Property CompressionEnabled As Boolean
    Get
    Set
public:
property bool CompressionEnabled {
    bool get ();
    void set (bool value);
}
function get_CompressionEnabled();
function set_CompressionEnabled(value);

Property Value

Type: Boolean
See Also

Reference

ConnectionConfiguration Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionConfiguration.CompressionLevel Property

ConnectionConfigurationCompressionLevel Property
The level of compression configured on the connection.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int CompressionLevel { get; set; }
Public Property CompressionLevel As Integer
    Get
    Set
public:
property int CompressionLevel {
    int get ();
    void set (int value);
}
function get_CompressionLevel();
function set_CompressionLevel(value);

Property Value

Type: Int32
See Also

Reference

ConnectionConfiguration Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionConfiguration.ConnectionId Property

ConnectionConfigurationConnectionId Property
A one-based index for each connection established in a Double-Take instance.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int ConnectionId { get; set; }
Public Property ConnectionId As Integer
    Get
    Set
public:
property int ConnectionId {
    int get ();
    void set (int value);
}
function get_ConnectionId();
function set_ConnectionId(value);

Property Value

Type: Int32
Remarks
This series is reset each time the Double-Take service is restarted.
See Also

Reference

ConnectionConfiguration Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionConfiguration.Encrypt Property

ConnectionConfigurationEncrypt Property
Indicates whether transmitted data is encrypted.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool Encrypt { get; set; }
Public Property Encrypt As Boolean
    Get
    Set
public:
property bool Encrypt {
    bool get ();
    void set (bool value);
}
function get_Encrypt();
function set_Encrypt(value);

Property Value

Type: Boolean
See Also

Reference

ConnectionConfiguration Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionConfiguration.ExtensionData Property

ConnectionConfigurationExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

ConnectionConfiguration Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionConfiguration.JobType Property

ConnectionConfigurationJobType Property
A product specific string indicating the type of job or workload protected by this connection.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string JobType { get; set; }
Public Property JobType As String
    Get
    Set
public:
property String^ JobType {
    String^ get ();
    void set (String^ value);
}
function get_JobType();
function set_JobType(value);

Property Value

Type: String
See Also

Reference

ConnectionConfiguration Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionConfiguration.PathTransformations Property

ConnectionConfigurationPathTransformations Property
The filepath transformations applied to files replicated by this connection.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public PathTransformation[] PathTransformations { get; set; }
Public Property PathTransformations As PathTransformation()
    Get
    Set
public:
property array<PathTransformation^>^ PathTransformations {
    array<PathTransformation^>^ get ();
    void set (array<PathTransformation^>^ value);
}
function get_PathTransformations();
function set_PathTransformations(value);

Property Value

Type: PathTransformation
See Also

Reference

ConnectionConfiguration Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionConfiguration.ReplicationSetName Property

ConnectionConfigurationReplicationSetName Property
The name of the replication set used for this connection.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string ReplicationSetName { get; set; }
Public Property ReplicationSetName As String
    Get
    Set
public:
property String^ ReplicationSetName {
    String^ get ();
    void set (String^ value);
}
function get_ReplicationSetName();
function set_ReplicationSetName(value);

Property Value

Type: String
See Also

Reference

ConnectionConfiguration Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionConfiguration.SourceRoute Property

ConnectionConfigurationSourceRoute Property
The source endpoint used by the target for this connection.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string SourceRoute { get; set; }
Public Property SourceRoute As String
    Get
    Set
public:
property String^ SourceRoute {
    String^ get ();
    void set (String^ value);
}
function get_SourceRoute();
function set_SourceRoute(value);

Property Value

Type: String
Remarks
The address is specified in the format: [address]:[port]
See Also

Reference

ConnectionConfiguration Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionConfiguration.TargetLoaded Property

ConnectionConfigurationTargetLoaded Property
Indicates whether the target is loaded.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool TargetLoaded { get; set; }
Public Property TargetLoaded As Boolean
    Get
    Set
public:
property bool TargetLoaded {
    bool get ();
    void set (bool value);
}
function get_TargetLoaded();
function set_TargetLoaded(value);

Property Value

Type: Boolean
See Also

Reference

ConnectionConfiguration Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionConfiguration.TargetName Property

ConnectionConfigurationTargetName Property
The host name of the target, if available.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string TargetName { get; set; }
Public Property TargetName As String
    Get
    Set
public:
property String^ TargetName {
    String^ get ();
    void set (String^ value);
}
function get_TargetName();
function set_TargetName(value);

Property Value

Type: String
See Also

Reference

ConnectionConfiguration Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionConfiguration.TargetRoute Property

ConnectionConfigurationTargetRoute Property
The target endpoint used by the source for this connection.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string TargetRoute { get; set; }
Public Property TargetRoute As String
    Get
    Set
public:
property String^ TargetRoute {
    String^ get ();
    void set (String^ value);
}
function get_TargetRoute();
function set_TargetRoute(value);

Property Value

Type: String
Remarks
The address is specified in the format: [address]:[port]
See Also

Reference

ConnectionConfiguration Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionInfo Class

ConnectionInfo Class
Contains connection configuration, status and statistics.
Inheritance Hierarchy
SystemObject
DoubleTake.Core.Contract.ConnectionConnectionInfo

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class ConnectionInfo : IExtensibleDataObject
Public Class ConnectionInfo
    Implements IExtensibleDataObject
public ref class ConnectionInfo : IExtensibleDataObject
DoubleTake.Core.Contract.Connection.ConnectionInfo = function();

Type.createClass(
    'DoubleTake.Core.Contract.Connection.ConnectionInfo',
    null,
    IExtensibleDataObject);

The ConnectionInfo type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectionInfo | Initializes a new instance of the ConnectionInfo class
Top
Properties
 | Name | Description
Public property | Configuration | Gets or sets the servers and settings involved in the connection.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Guid | Gets or sets the unique ID of the connection.
Public property | SourceAddresses | Gets or sets the source addresses.
Public property | SourceName | Gets or sets the name of the source.
Public property | Statistics | Gets or sets various connection statistics collected by the Double-Take engine.
Public property | Status | Gets or sets the operational state of the connection.
Top
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


ConnectionInfo Constructor

ConnectionInfo Constructor
Initializes a new instance of the ConnectionInfo class

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ConnectionInfo()
Public Sub New
public:
ConnectionInfo()
DoubleTake.Core.Contract.Connection.ConnectionInfo = function();
See Also

Reference

ConnectionInfo Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionInfo Properties

ConnectionInfo Properties

The ConnectionInfo type exposes the following members.

Properties
 | Name | Description
Public property | Configuration | Gets or sets the servers and settings involved in the connection.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Guid | Gets or sets the unique ID of the connection.
Public property | SourceAddresses | Gets or sets the source addresses.
Public property | SourceName | Gets or sets the name of the source.
Public property | Statistics | Gets or sets various connection statistics collected by the Double-Take engine.
Public property | Status | Gets or sets the operational state of the connection.
Top
See Also

Reference

ConnectionInfo Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionInfo.Configuration Property

ConnectionInfoConfiguration Property
Gets or sets the servers and settings involved in the connection.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ConnectionConfiguration Configuration { get; set; }
Public Property Configuration As ConnectionConfiguration
    Get
    Set
public:
property ConnectionConfiguration^ Configuration {
    ConnectionConfiguration^ get ();
    void set (ConnectionConfiguration^ value);
}
function get_Configuration();
function set_Configuration(value);

Property Value

Type: ConnectionConfiguration
The configuration.
See Also

Reference

ConnectionInfo Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionInfo.ExtensionData Property

ConnectionInfoExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

ConnectionInfo Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionInfo.Guid Property

ConnectionInfoGuid Property
Gets or sets the unique ID of the connection.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Guid Guid { get; set; }
Public Property Guid As Guid
    Get
    Set
public:
property Guid Guid {
    Guid get ();
    void set (Guid value);
}
function get_Guid();
function set_Guid(value);

Property Value

Type: Guid
The GUID.
Remarks
This ID is generated by the Management Service and combines the multiple items required to uniquely identify a Double-Take engine connection into one. The two items required to uniquely identify a Double-Take engine connection are the replication set name and the target route.
See Also

Reference

ConnectionInfo Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionInfo.SourceAddresses Property

ConnectionInfoSourceAddresses Property
Gets or sets the source addresses.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public IEnumerable<string> SourceAddresses { get; set; }
Public Property SourceAddresses As IEnumerable(Of String)
    Get
    Set
public:
property IEnumerable<String^>^ SourceAddresses {
    IEnumerable<String^>^ get ();
    void set (IEnumerable<String^>^ value);
}
function get_SourceAddresses();
function set_SourceAddresses(value);

Property Value

Type: IEnumerable String
The source addresses.
See Also

Reference

ConnectionInfo Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionInfo.SourceName Property

ConnectionInfoSourceName Property
Gets or sets the name of the source.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string SourceName { get; set; }
Public Property SourceName As String
    Get
    Set
public:
property String^ SourceName {
    String^ get ();
    void set (String^ value);
}
function get_SourceName();
function set_SourceName(value);

Property Value

Type: String
The name of the source.
See Also

Reference

ConnectionInfo Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionInfo.Statistics Property

ConnectionInfoStatistics Property
Gets or sets various connection statistics collected by the Double-Take engine.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ConnectionStatistics Statistics { get; set; }
Public Property Statistics As ConnectionStatistics
    Get
    Set
public:
property ConnectionStatistics^ Statistics {
    ConnectionStatistics^ get ();
    void set (ConnectionStatistics^ value);
}
function get_Statistics();
function set_Statistics(value);

Property Value

Type: ConnectionStatistics
The statistics.
See Also

Reference

ConnectionInfo Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionInfo.Status Property

ConnectionInfoStatus Property
Gets or sets the operational state of the connection.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ConnectionStatus Status { get; set; }
Public Property Status As ConnectionStatus
    Get
    Set
public:
property ConnectionStatus^ Status {
    ConnectionStatus^ get ();
    void set (ConnectionStatus^ value);
}
function get_Status();
function set_Status(value);

Property Value

Type: ConnectionStatus
The status.
See Also

Reference

ConnectionInfo Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionMode Enumeration

ConnectionMode Enumeration

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public enum ConnectionMode
Public Enumeration ConnectionMode
public enum class ConnectionMode
DoubleTake.Core.Contract.Connection.ConnectionMode = function();
DoubleTake.Core.Contract.Connection.ConnectionMode.createEnum('DoubleTake.Core.Contract.Connection.ConnectionMode', false);
Members
Member name | Value | Description
Manual | 0 |
Scheduled | 1 |
ManualRestoreRequired | 2 |
ScheduledRestoreRequired | 3 |
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


ConnectionQualificationFailures Enumeration

ConnectionQualificationFailures Enumeration

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public enum ConnectionQualificationFailures
Public Enumeration ConnectionQualificationFailures
public enum class ConnectionQualificationFailures
DoubleTake.Core.Contract.Connection.ConnectionQualificationFailures = function();
DoubleTake.Core.Contract.Connection.ConnectionQualificationFailures.createEnum('DoubleTake.Core.Contract.Connection.ConnectionQualificationFailures', false);
Members
Member name | Value | Description
None | 0 |
RoutableAddressDetermination | 1 |
CompressionAlgorithmDetermination | 2 |
RestoreRequiredDetermination | 4 |
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


ConnectionQualificationResult Class

ConnectionQualificationResult Class
Inheritance Hierarchy
SystemObject
DoubleTake.Core.Contract.ConnectionConnectionQualificationResult

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class ConnectionQualificationResult : IExtensibleDataObject
Public Class ConnectionQualificationResult
    Implements IExtensibleDataObject
public ref class ConnectionQualificationResult : IExtensibleDataObject
DoubleTake.Core.Contract.Connection.ConnectionQualificationResult = function();

Type.createClass(
    'DoubleTake.Core.Contract.Connection.ConnectionQualificationResult',
    null,
    IExtensibleDataObject);

The ConnectionQualificationResult type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectionQualificationResult | Initializes a new instance of the ConnectionQualificationResult class
Top
Properties
 | Name | Description
Public property | CompressionLevels | Gets or sets the compression levels.
Public property | ConnectionPort | Gets or sets the connection port.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Failures | Gets or sets the failures.
Public property | IsQualified | Gets or sets a value indicating whether this instance is qualified.
Public property | IsRestoreRequired | Gets or sets a value indicating whether this instance is restore required.
Public property | RecommendedStartParameters | Gets or sets the recommended start parameters.
Public property | RoutableAddresses | Gets or sets the routable addresses.
Public property | TargetMachineName | Gets or sets the name of the target machine.
Top
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


ConnectionQualificationResult Constructor

ConnectionQualificationResult Constructor
Initializes a new instance of the ConnectionQualificationResult class

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ConnectionQualificationResult()
Public Sub New
public:
ConnectionQualificationResult()
DoubleTake.Core.Contract.Connection.ConnectionQualificationResult = function();
See Also

Reference

ConnectionQualificationResult Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionQualificationResult Properties

ConnectionQualificationResult Properties

The ConnectionQualificationResult type exposes the following members.

Properties
 | Name | Description
Public property | CompressionLevels | Gets or sets the compression levels.
Public property | ConnectionPort | Gets or sets the connection port.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Failures | Gets or sets the failures.
Public property | IsQualified | Gets or sets a value indicating whether this instance is qualified.
Public property | IsRestoreRequired | Gets or sets a value indicating whether this instance is restore required.
Public property | RecommendedStartParameters | Gets or sets the recommended start parameters.
Public property | RoutableAddresses | Gets or sets the routable addresses.
Public property | TargetMachineName | Gets or sets the name of the target machine.
Top
See Also

Reference

ConnectionQualificationResult Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionQualificationResult.CompressionLevels Property

ConnectionQualificationResultCompressionLevels Property
Gets or sets the compression levels.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public CompressionLevel[] CompressionLevels { get; set; }
Public Property CompressionLevels As CompressionLevel()
    Get
    Set
public:
property array<CompressionLevel^>^ CompressionLevels {
    array<CompressionLevel^>^ get ();
    void set (array<CompressionLevel^>^ value);
}
function get_CompressionLevels();
function set_CompressionLevels(value);

Property Value

Type: CompressionLevel
The compression levels.
See Also

Reference

ConnectionQualificationResult Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionQualificationResult.ConnectionPort Property

ConnectionQualificationResultConnectionPort Property
Gets or sets the connection port.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int ConnectionPort { get; set; }
Public Property ConnectionPort As Integer
    Get
    Set
public:
property int ConnectionPort {
    int get ();
    void set (int value);
}
function get_ConnectionPort();
function set_ConnectionPort(value);

Property Value

Type: Int32
The connection port.
See Also

Reference

ConnectionQualificationResult Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionQualificationResult.ExtensionData Property

ConnectionQualificationResultExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

ConnectionQualificationResult Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionQualificationResult.Failures Property

ConnectionQualificationResultFailures Property
Gets or sets the failures.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ConnectionQualificationFailures Failures { get; set; }
Public Property Failures As ConnectionQualificationFailures
    Get
    Set
public:
property ConnectionQualificationFailures Failures {
    ConnectionQualificationFailures get ();
    void set (ConnectionQualificationFailures value);
}
function get_Failures();
function set_Failures(value);

Property Value

Type: ConnectionQualificationFailures
The failures.
See Also

Reference

ConnectionQualificationResult Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionQualificationResult.IsQualified Property

ConnectionQualificationResultIsQualified Property
Gets or sets a value indicating whether this instance is qualified.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsQualified { get; set; }
Public Property IsQualified As Boolean
    Get
    Set
public:
property bool IsQualified {
    bool get ();
    void set (bool value);
}
function get_IsQualified();
function set_IsQualified(value);

Property Value

Type: Boolean
if this instance is qualified; otherwise, .
See Also

Reference

ConnectionQualificationResult Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionQualificationResult.IsRestoreRequired Property

ConnectionQualificationResultIsRestoreRequired Property
Gets or sets a value indicating whether this instance is restore required.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsRestoreRequired { get; set; }
Public Property IsRestoreRequired As Boolean
    Get
    Set
public:
property bool IsRestoreRequired {
    bool get ();
    void set (bool value);
}
function get_IsRestoreRequired();
function set_IsRestoreRequired(value);

Property Value

Type: Boolean
if this instance is restore required; otherwise, .
See Also

Reference

ConnectionQualificationResult Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionQualificationResult.RecommendedStartParameters Property

ConnectionQualificationResultRecommendedStartParameters Property
Gets or sets the recommended start parameters.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ConnectionStartParameters RecommendedStartParameters { get; set; }
Public Property RecommendedStartParameters As ConnectionStartParameters
    Get
    Set
public:
property ConnectionStartParameters^ RecommendedStartParameters {
    ConnectionStartParameters^ get ();
    void set (ConnectionStartParameters^ value);
}
function get_RecommendedStartParameters();
function set_RecommendedStartParameters(value);

Property Value

Type: ConnectionStartParameters
The recommended start parameters.
See Also

Reference

ConnectionQualificationResult Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionQualificationResult.RoutableAddresses Property

ConnectionQualificationResultRoutableAddresses Property
Gets or sets the routable addresses.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public UnicastIPAddressInfo[] RoutableAddresses { get; set; }
Public Property RoutableAddresses As UnicastIPAddressInfo()
    Get
    Set
public:
property array<UnicastIPAddressInfo^>^ RoutableAddresses {
    array<UnicastIPAddressInfo^>^ get ();
    void set (array<UnicastIPAddressInfo^>^ value);
}
function get_RoutableAddresses();
function set_RoutableAddresses(value);

Property Value

Type: UnicastIPAddressInfo
The routable addresses.
See Also

Reference

ConnectionQualificationResult Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionQualificationResult.TargetMachineName Property

ConnectionQualificationResultTargetMachineName Property
Gets or sets the name of the target machine.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string TargetMachineName { get; set; }
Public Property TargetMachineName As String
    Get
    Set
public:
property String^ TargetMachineName {
    String^ get ();
    void set (String^ value);
}
function get_TargetMachineName();
function set_TargetMachineName(value);

Property Value

Type: String
The name of the target machine.
See Also

Reference

ConnectionQualificationResult Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionSchedule Class

ConnectionSchedule Class
Inheritance Hierarchy
SystemObject
DoubleTake.Core.Contract.ConnectionConnectionSchedule

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public sealed class ConnectionSchedule : IExtensibleDataObject
Public NotInheritable Class ConnectionSchedule
    Implements IExtensibleDataObject
public ref class ConnectionSchedule sealed : IExtensibleDataObject
DoubleTake.Core.Contract.Connection.ConnectionSchedule = function();

Type.createClass(
    'DoubleTake.Core.Contract.Connection.ConnectionSchedule',
    null,
    IExtensibleDataObject);

The ConnectionSchedule type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectionSchedule | Initializes a new instance of the ConnectionSchedule class
Top
Properties
 | Name | Description
Public property | Archive | This property is no longer used.
Public property | Bandwidth | This value represents the bandwidth schedule.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Orphans | This value represents if orphan files (files in the target path location that are not present on the source) will be deleted. There is currently no schedule (time-related options) for orphan files. They can only be deleted or left on the target.
Public property | Transmission | This property is no longer used.
Public property | Verify | This value represents the verification schedule.
Top
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


ConnectionSchedule Constructor

ConnectionSchedule Constructor
Initializes a new instance of the ConnectionSchedule class

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ConnectionSchedule()
Public Sub New
public:
ConnectionSchedule()
DoubleTake.Core.Contract.Connection.ConnectionSchedule = function();
See Also

Reference

ConnectionSchedule Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionSchedule Properties

ConnectionSchedule Properties

The ConnectionSchedule type exposes the following members.

Properties
 | Name | Description
Public property | Archive | This property is no longer used.
Public property | Bandwidth | This value represents the bandwidth schedule.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Orphans | This value represents if orphan files (files in the target path location that are not present on the source) will be deleted. There is currently no schedule (time-related options) for orphan files. They can only be deleted or left on the target.
Public property | Transmission | This property is no longer used.
Public property | Verify | This value represents the verification schedule.
Top
See Also

Reference

ConnectionSchedule Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionSchedule.Archive Property

ConnectionScheduleArchive Property
This property is no longer used.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ArchiveSchedule Archive { get; set; }
Public Property Archive As ArchiveSchedule
    Get
    Set
public:
property ArchiveSchedule^ Archive {
    ArchiveSchedule^ get ();
    void set (ArchiveSchedule^ value);
}
function get_Archive();
function set_Archive(value);

Property Value

Type: ArchiveSchedule
The archive.
See Also

Reference

ConnectionSchedule Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionSchedule.Bandwidth Property

ConnectionScheduleBandwidth Property
This value represents the bandwidth schedule.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public BandwidthSchedule Bandwidth { get; set; }
Public Property Bandwidth As BandwidthSchedule
    Get
    Set
public:
property BandwidthSchedule^ Bandwidth {
    BandwidthSchedule^ get ();
    void set (BandwidthSchedule^ value);
}
function get_Bandwidth();
function set_Bandwidth(value);

Property Value

Type: BandwidthSchedule
See Also

Reference

ConnectionSchedule Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionSchedule.ExtensionData Property

ConnectionScheduleExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

ConnectionSchedule Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionSchedule.Orphans Property

ConnectionScheduleOrphans Property
This value represents if orphan files (files in the target path location that are not present on the source) will be deleted. There is currently no schedule (time-related options) for orphan files. They can only be deleted or left on the target.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public OrphansSchedule Orphans { get; set; }
Public Property Orphans As OrphansSchedule
    Get
    Set
public:
property OrphansSchedule^ Orphans {
    OrphansSchedule^ get ();
    void set (OrphansSchedule^ value);
}
function get_Orphans();
function set_Orphans(value);

Property Value

Type: OrphansSchedule
See Also

Reference

ConnectionSchedule Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionSchedule.Transmission Property

ConnectionScheduleTransmission Property
This property is no longer used.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public TransmissionSchedule Transmission { get; set; }
Public Property Transmission As TransmissionSchedule
    Get
    Set
public:
property TransmissionSchedule^ Transmission {
    TransmissionSchedule^ get ();
    void set (TransmissionSchedule^ value);
}
function get_Transmission();
function set_Transmission(value);

Property Value

Type: TransmissionSchedule
See Also

Reference

ConnectionSchedule Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionSchedule.Verify Property

ConnectionScheduleVerify Property
This value represents the verification schedule.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VerifySchedule Verify { get; set; }
Public Property Verify As VerifySchedule
    Get
    Set
public:
property VerifySchedule^ Verify {
    VerifySchedule^ get ();
    void set (VerifySchedule^ value);
}
function get_Verify();
function set_Verify(value);

Property Value

Type: VerifySchedule
See Also

Reference

ConnectionSchedule Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionStartParameters Class

ConnectionStartParameters Class
Used to define the parameters used when creating a connection that mirrors and replicates the protected data from the source to the target.
Inheritance Hierarchy
SystemObject
DoubleTake.Core.Contract.ConnectionConnectionStartParameters

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public sealed class ConnectionStartParameters : IExtensibleDataObject
Public NotInheritable Class ConnectionStartParameters
    Implements IExtensibleDataObject
public ref class ConnectionStartParameters sealed : IExtensibleDataObject
DoubleTake.Core.Contract.Connection.ConnectionStartParameters = function();

Type.createClass(
    'DoubleTake.Core.Contract.Connection.ConnectionStartParameters',
    null,
    IExtensibleDataObject);

The ConnectionStartParameters type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectionStartParameters | Initializes a new instance of the ConnectionStartParameters class
Top
Properties
 | Name | Description
Public property | ArchiveBinLocation | This property is no longer used.
Public property | CompressionLevel | This value represents the compression to use for data passed over the connection.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | IsEncrypted | This value is true if the connection data is to be encrypted; otherwise, it is false.
Public property | IsMirrorEnabled | This value is true if a mirror is started when the connection is created; otherwise, it is false.
Public property | IsPathBlockingEnabled | This value is true if the destination paths on the target are blocked for writing, except by Double-Take; otherwise, it is false.
Public property | IsReplicationEnabled | This value is true if replication is started when the connection is created; otherwise, it is false.
Public property | IsRestore | This value is true if the connection is a restoration mirror; otherwise, it is false.
Public property | MirrorParameters | This value represents the mirror parameters used for the connection. If this value is null, the default mirror parameters will be used.
Public property | Schedule | This value represents the bandwidth, orphans, and verification schedule. These schedule settings will be applied to all connections that share the same route to the same target. Therefore, if a connection exists over the same route to the same target as the connection you are creating, any schedule changes will be applied to that connection as well.
Public property | ScriptPoints | This value represents the scripts to be run at specific points during mirroring.
Public property | SnapshotSchedule | This value represents the snapshot schedule for the target.
Top
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


ConnectionStartParameters Constructor

ConnectionStartParameters Constructor
Initializes a new instance of the ConnectionStartParameters class

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ConnectionStartParameters()
Public Sub New
public:
ConnectionStartParameters()
DoubleTake.Core.Contract.Connection.ConnectionStartParameters = function();
See Also

Reference

ConnectionStartParameters Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionStartParameters Properties

ConnectionStartParameters Properties

The ConnectionStartParameters type exposes the following members.

Properties
 | Name | Description
Public property | ArchiveBinLocation | This property is no longer used.
Public property | CompressionLevel | This value represents the compression to use for data passed over the connection.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | IsEncrypted | This value is true if the connection data is to be encrypted; otherwise, it is false.
Public property | IsMirrorEnabled | This value is true if a mirror is started when the connection is created; otherwise, it is false.
Public property | IsPathBlockingEnabled | This value is true if the destination paths on the target are blocked for writing, except by Double-Take; otherwise, it is false.
Public property | IsReplicationEnabled | This value is true if replication is started when the connection is created; otherwise, it is false.
Public property | IsRestore | This value is true if the connection is a restoration mirror; otherwise, it is false.
Public property | MirrorParameters | This value represents the mirror parameters used for the connection. If this value is null, the default mirror parameters will be used.
Public property | Schedule | This value represents the bandwidth, orphans, and verification schedule. These schedule settings will be applied to all connections that share the same route to the same target. Therefore, if a connection exists over the same route to the same target as the connection you are creating, any schedule changes will be applied to that connection as well.
Public property | ScriptPoints | This value represents the scripts to be run at specific points during mirroring.
Public property | SnapshotSchedule | This value represents the snapshot schedule for the target.
Top
See Also

Reference

ConnectionStartParameters Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionStartParameters.ArchiveBinLocation Property

ConnectionStartParametersArchiveBinLocation Property
This property is no longer used.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string ArchiveBinLocation { get; set; }
Public Property ArchiveBinLocation As String
    Get
    Set
public:
property String^ ArchiveBinLocation {
    String^ get ();
    void set (String^ value);
}
function get_ArchiveBinLocation();
function set_ArchiveBinLocation(value);

Property Value

Type: String
The archive bin location.
See Also

Reference

ConnectionStartParameters Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionStartParameters.CompressionLevel Property

ConnectionStartParametersCompressionLevel Property
This value represents the compression to use for data passed over the connection.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public CompressionLevel CompressionLevel { get; set; }
Public Property CompressionLevel As CompressionLevel
    Get
    Set
public:
property CompressionLevel^ CompressionLevel {
    CompressionLevel^ get ();
    void set (CompressionLevel^ value);
}
function get_CompressionLevel();
function set_CompressionLevel(value);

Property Value

Type: CompressionLevel
The compression level.
See Also

Reference

ConnectionStartParameters Class
DoubleTake.Core.Contract.Connection Namespace
ConnectionStartParametersCompressionLevel


ConnectionStartParameters.ExtensionData Property

ConnectionStartParametersExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

ConnectionStartParameters Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionStartParameters.IsEncrypted Property

ConnectionStartParametersIsEncrypted Property
This value is true if the connection data is to be encrypted; otherwise, it is false.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsEncrypted { get; set; }
Public Property IsEncrypted As Boolean
    Get
    Set
public:
property bool IsEncrypted {
    bool get ();
    void set (bool value);
}
function get_IsEncrypted();
function set_IsEncrypted(value);

Property Value

Type: Boolean
if the connection data is to be encrypted; otherwise, .
See Also

Reference

ConnectionStartParameters Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionStartParameters.IsMirrorEnabled Property

ConnectionStartParametersIsMirrorEnabled Property
This value is true if a mirror is started when the connection is created; otherwise, it is false.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsMirrorEnabled { get; set; }
Public Property IsMirrorEnabled As Boolean
    Get
    Set
public:
property bool IsMirrorEnabled {
    bool get ();
    void set (bool value);
}
function get_IsMirrorEnabled();
function set_IsMirrorEnabled(value);

Property Value

Type: Boolean
if a mirror is to be started; otherwise, .
See Also

Reference

ConnectionStartParameters Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionStartParameters.IsPathBlockingEnabled Property

ConnectionStartParametersIsPathBlockingEnabled Property
This value is true if the destination paths on the target are blocked for writing, except by Double-Take; otherwise, it is false.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsPathBlockingEnabled { get; set; }
Public Property IsPathBlockingEnabled As Boolean
    Get
    Set
public:
property bool IsPathBlockingEnabled {
    bool get ();
    void set (bool value);
}
function get_IsPathBlockingEnabled();
function set_IsPathBlockingEnabled(value);

Property Value

Type: Boolean
if path blocking is enabled; otherwise, .
See Also

Reference

ConnectionStartParameters Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionStartParameters.IsReplicationEnabled Property

ConnectionStartParametersIsReplicationEnabled Property
This value is true if replication is started when the connection is created; otherwise, it is false.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsReplicationEnabled { get; set; }
Public Property IsReplicationEnabled As Boolean
    Get
    Set
public:
property bool IsReplicationEnabled {
    bool get ();
    void set (bool value);
}
function get_IsReplicationEnabled();
function set_IsReplicationEnabled(value);

Property Value

Type: Boolean
if replication will be enabled; otherwise, .
See Also

Reference

ConnectionStartParameters Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionStartParameters.IsRestore Property

ConnectionStartParametersIsRestore Property
This value is true if the connection is a restoration mirror; otherwise, it is false.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsRestore { get; set; }
Public Property IsRestore As Boolean
    Get
    Set
public:
property bool IsRestore {
    bool get ();
    void set (bool value);
}
function get_IsRestore();
function set_IsRestore(value);

Property Value

Type: Boolean
if this connection is a restore connection; otherwise, .
See Also

Reference

ConnectionStartParameters Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionStartParameters.MirrorParameters Property

ConnectionStartParametersMirrorParameters Property
This value represents the mirror parameters used for the connection. If this value is null, the default mirror parameters will be used.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public MirrorParameters MirrorParameters { get; set; }
Public Property MirrorParameters As MirrorParameters
    Get
    Set
public:
property MirrorParameters^ MirrorParameters {
    MirrorParameters^ get ();
    void set (MirrorParameters^ value);
}
function get_MirrorParameters();
function set_MirrorParameters(value);

Property Value

Type: MirrorParameters
The mirror parameters.
See Also

Reference

ConnectionStartParameters Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionStartParameters.Schedule Property

ConnectionStartParametersSchedule Property
This value represents the bandwidth, orphans, and verification schedule. These schedule settings will be applied to all connections that share the same route to the same target. Therefore, if a connection exists over the same route to the same target as the connection you are creating, any schedule changes will be applied to that connection as well.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ConnectionSchedule Schedule { get; set; }
Public Property Schedule As ConnectionSchedule
    Get
    Set
public:
property ConnectionSchedule^ Schedule {
    ConnectionSchedule^ get ();
    void set (ConnectionSchedule^ value);
}
function get_Schedule();
function set_Schedule(value);

Property Value

Type: ConnectionSchedule
The schedule.
Remarks
Note that some schedule settings will get applied to all connections that share the same route to the same target. Therefore, if a connection exists over the same route to the same target as the connection you're creating, these schedule changes will be applied to that connection as well.
See Also

Reference

ConnectionStartParameters Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionStartParameters.ScriptPoints Property

ConnectionStartParametersScriptPoints Property
This value represents the scripts to be run at specific points during mirroring.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ScriptPoint[] ScriptPoints { get; set; }
Public Property ScriptPoints As ScriptPoint()
    Get
    Set
public:
property array<ScriptPoint^>^ ScriptPoints {
    array<ScriptPoint^>^ get ();
    void set (array<ScriptPoint^>^ value);
}
function get_ScriptPoints();
function set_ScriptPoints(value);

Property Value

Type: ScriptPoint
See Also

Reference

ConnectionStartParameters Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionStartParameters.SnapshotSchedule Property

ConnectionStartParametersSnapshotSchedule Property
This value represents the snapshot schedule for the target.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public SnapshotSchedule SnapshotSchedule { get; set; }
Public Property SnapshotSchedule As SnapshotSchedule
    Get
    Set
public:
property SnapshotSchedule^ SnapshotSchedule {
    SnapshotSchedule^ get ();
    void set (SnapshotSchedule^ value);
}
function get_SnapshotSchedule();
function set_SnapshotSchedule(value);

Property Value

Type: SnapshotSchedule
See Also

Reference

ConnectionStartParameters Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionStatistics Class

ConnectionStatistics Class
Represents the raw statistics of a single Double-Take engine connection.
Inheritance Hierarchy
SystemObject
DoubleTake.Core.Contract.ConnectionConnectionStatistics

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class ConnectionStatistics : IExtensibleDataObject
Public Class ConnectionStatistics
    Implements IExtensibleDataObject
public ref class ConnectionStatistics : IExtensibleDataObject
DoubleTake.Core.Contract.Connection.ConnectionStatistics = function();

Type.createClass(
    'DoubleTake.Core.Contract.Connection.ConnectionStatistics',
    null,
    IExtensibleDataObject);

The ConnectionStatistics type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectionStatistics | Initializes a new instance of the ConnectionStatistics class
Top
Properties
 | Name | Description
Public property | DiskQueueBytes | Gets or sets the number of bytes in the disk queue.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | MirrorBytesRemaining | Gets or sets the mirror bytes remaining.
Public property | MirrorBytesSent | Gets or sets the mirror bytes sent.
Public property | MirrorBytesSkipped | Gets or sets the mirror bytes skipped.
Public property | MirrorBytesTransmitted | Gets or sets the mirror bytes transmitted.
Public property | MirrorOpsQueued | Gets or sets the mirror ops queued.
Public property | MirrorPermillage | Gets or sets the mirror permillage.
Public property | ReplicationBytesQueued | Gets or sets the replication bytes queued.
Public property | ReplicationBytesSent | Gets or sets the replication bytes sent.
Public property | ReplicationBytesTransmitted | Gets or sets the replication bytes transmitted.
Public property | ReplicationOpsQueued | Gets or sets the replication ops queued.
Public property | ReplicationSetCalcInProgress | Gets or sets the repset calc progress.
Public property | TotalBytesSent | Gets or sets the total bytes sent.
Public property | TotalBytesTransmitted | Gets or sets the total bytes transmitted.
Public property | TotalOpsQueued | Gets or sets the total ops queued.
Top
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


ConnectionStatistics Constructor

ConnectionStatistics Constructor
Initializes a new instance of the ConnectionStatistics class

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ConnectionStatistics()
Public Sub New
public:
ConnectionStatistics()
DoubleTake.Core.Contract.Connection.ConnectionStatistics = function();
See Also

Reference

ConnectionStatistics Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionStatistics Properties

ConnectionStatistics Properties

The ConnectionStatistics type exposes the following members.

Properties
 | Name | Description
Public property | DiskQueueBytes | Gets or sets the number of bytes in the disk queue.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | MirrorBytesRemaining | Gets or sets the mirror bytes remaining.
Public property | MirrorBytesSent | Gets or sets the mirror bytes sent.
Public property | MirrorBytesSkipped | Gets or sets the mirror bytes skipped.
Public property | MirrorBytesTransmitted | Gets or sets the mirror bytes transmitted.
Public property | MirrorOpsQueued | Gets or sets the mirror ops queued.
Public property | MirrorPermillage | Gets or sets the mirror permillage.
Public property | ReplicationBytesQueued | Gets or sets the replication bytes queued.
Public property | ReplicationBytesSent | Gets or sets the replication bytes sent.
Public property | ReplicationBytesTransmitted | Gets or sets the replication bytes transmitted.
Public property | ReplicationOpsQueued | Gets or sets the replication ops queued.
Public property | ReplicationSetCalcInProgress | Gets or sets the repset calc progress.
Public property | TotalBytesSent | Gets or sets the total bytes sent.
Public property | TotalBytesTransmitted | Gets or sets the total bytes transmitted.
Public property | TotalOpsQueued | Gets or sets the total ops queued.
Top
See Also

Reference

ConnectionStatistics Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionStatistics.DiskQueueBytes Property

ConnectionStatisticsDiskQueueBytes Property
Gets or sets the number of bytes in the disk queue.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public long DiskQueueBytes { get; set; }
Public Property DiskQueueBytes As Long
    Get
    Set
public:
property long long DiskQueueBytes {
    long long get ();
    void set (long long value);
}
function get_DiskQueueBytes();
function set_DiskQueueBytes(value);

Property Value

Type: Int64
The disk queue bytes.
See Also

Reference

ConnectionStatistics Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionStatistics.ExtensionData Property

ConnectionStatisticsExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

ConnectionStatistics Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionStatistics.MirrorBytesRemaining Property

ConnectionStatisticsMirrorBytesRemaining Property
Gets or sets the mirror bytes remaining.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public long MirrorBytesRemaining { get; set; }
Public Property MirrorBytesRemaining As Long
    Get
    Set
public:
property long long MirrorBytesRemaining {
    long long get ();
    void set (long long value);
}
function get_MirrorBytesRemaining();
function set_MirrorBytesRemaining(value);

Property Value

Type: Int64
The mirror bytes remaining.
See Also

Reference

ConnectionStatistics Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionStatistics.MirrorBytesSent Property

ConnectionStatisticsMirrorBytesSent Property
Gets or sets the mirror bytes sent.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public long MirrorBytesSent { get; set; }
Public Property MirrorBytesSent As Long
    Get
    Set
public:
property long long MirrorBytesSent {
    long long get ();
    void set (long long value);
}
function get_MirrorBytesSent();
function set_MirrorBytesSent(value);

Property Value

Type: Int64
The mirror bytes sent.
See Also

Reference

ConnectionStatistics Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionStatistics.MirrorBytesSkipped Property

ConnectionStatisticsMirrorBytesSkipped Property
Gets or sets the mirror bytes skipped.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public long MirrorBytesSkipped { get; set; }
Public Property MirrorBytesSkipped As Long
    Get
    Set
public:
property long long MirrorBytesSkipped {
    long long get ();
    void set (long long value);
}
function get_MirrorBytesSkipped();
function set_MirrorBytesSkipped(value);

Property Value

Type: Int64
The mirror bytes skipped.
See Also

Reference

ConnectionStatistics Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionStatistics.MirrorBytesTransmitted Property

ConnectionStatisticsMirrorBytesTransmitted Property
Gets or sets the mirror bytes transmitted.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public long MirrorBytesTransmitted { get; set; }
Public Property MirrorBytesTransmitted As Long
    Get
    Set
public:
property long long MirrorBytesTransmitted {
    long long get ();
    void set (long long value);
}
function get_MirrorBytesTransmitted();
function set_MirrorBytesTransmitted(value);

Property Value

Type: Int64
The mirror bytes transmitted.
See Also

Reference

ConnectionStatistics Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionStatistics.MirrorOpsQueued Property

ConnectionStatisticsMirrorOpsQueued Property
Gets or sets the mirror ops queued.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public long MirrorOpsQueued { get; set; }
Public Property MirrorOpsQueued As Long
    Get
    Set
public:
property long long MirrorOpsQueued {
    long long get ();
    void set (long long value);
}
function get_MirrorOpsQueued();
function set_MirrorOpsQueued(value);

Property Value

Type: Int64
The mirror ops queued.
See Also

Reference

ConnectionStatistics Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionStatistics.MirrorPermillage Property

ConnectionStatisticsMirrorPermillage Property
Gets or sets the mirror permillage.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public short MirrorPermillage { get; set; }
Public Property MirrorPermillage As Short
    Get
    Set
public:
property short MirrorPermillage {
    short get ();
    void set (short value);
}
function get_MirrorPermillage();
function set_MirrorPermillage(value);

Property Value

Type: Int16
The mirror permillage.
See Also

Reference

ConnectionStatistics Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionStatistics.ReplicationBytesQueued Property

ConnectionStatisticsReplicationBytesQueued Property
Gets or sets the replication bytes queued.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public long ReplicationBytesQueued { get; set; }
Public Property ReplicationBytesQueued As Long
    Get
    Set
public:
property long long ReplicationBytesQueued {
    long long get ();
    void set (long long value);
}
function get_ReplicationBytesQueued();
function set_ReplicationBytesQueued(value);

Property Value

Type: Int64
The replication bytes queued.
See Also

Reference

ConnectionStatistics Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionStatistics.ReplicationBytesSent Property

ConnectionStatisticsReplicationBytesSent Property
Gets or sets the replication bytes sent.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public long ReplicationBytesSent { get; set; }
Public Property ReplicationBytesSent As Long
    Get
    Set
public:
property long long ReplicationBytesSent {
    long long get ();
    void set (long long value);
}
function get_ReplicationBytesSent();
function set_ReplicationBytesSent(value);

Property Value

Type: Int64
The replication bytes sent.
See Also

Reference

ConnectionStatistics Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionStatistics.ReplicationBytesTransmitted Property

ConnectionStatisticsReplicationBytesTransmitted Property
Gets or sets the replication bytes transmitted.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public long ReplicationBytesTransmitted { get; set; }
Public Property ReplicationBytesTransmitted As Long
    Get
    Set
public:
property long long ReplicationBytesTransmitted {
    long long get ();
    void set (long long value);
}
function get_ReplicationBytesTransmitted();
function set_ReplicationBytesTransmitted(value);

Property Value

Type: Int64
The replication bytes transmitted.
See Also

Reference

ConnectionStatistics Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionStatistics.ReplicationOpsQueued Property

ConnectionStatisticsReplicationOpsQueued Property
Gets or sets the replication ops queued.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public long ReplicationOpsQueued { get; set; }
Public Property ReplicationOpsQueued As Long
    Get
    Set
public:
property long long ReplicationOpsQueued {
    long long get ();
    void set (long long value);
}
function get_ReplicationOpsQueued();
function set_ReplicationOpsQueued(value);

Property Value

Type: Int64
The replication ops queued.
See Also

Reference

ConnectionStatistics Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionStatistics.ReplicationSetCalcInProgress Property

ConnectionStatisticsReplicationSetCalcInProgress Property
Gets or sets the repset calc progress.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool ReplicationSetCalcInProgress { get; set; }
Public Property ReplicationSetCalcInProgress As Boolean
    Get
    Set
public:
property bool ReplicationSetCalcInProgress {
    bool get ();
    void set (bool value);
}
function get_ReplicationSetCalcInProgress();
function set_ReplicationSetCalcInProgress(value);

Property Value

Type: Boolean
if the repset calculation is in progress; otherwise, .
See Also

Reference

ConnectionStatistics Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionStatistics.TotalBytesSent Property

ConnectionStatisticsTotalBytesSent Property
Gets or sets the total bytes sent.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public long TotalBytesSent { get; set; }
Public Property TotalBytesSent As Long
    Get
    Set
public:
property long long TotalBytesSent {
    long long get ();
    void set (long long value);
}
function get_TotalBytesSent();
function set_TotalBytesSent(value);

Property Value

Type: Int64
The total bytes sent.
See Also

Reference

ConnectionStatistics Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionStatistics.TotalBytesTransmitted Property

ConnectionStatisticsTotalBytesTransmitted Property
Gets or sets the total bytes transmitted.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public long TotalBytesTransmitted { get; set; }
Public Property TotalBytesTransmitted As Long
    Get
    Set
public:
property long long TotalBytesTransmitted {
    long long get ();
    void set (long long value);
}
function get_TotalBytesTransmitted();
function set_TotalBytesTransmitted(value);

Property Value

Type: Int64
The total bytes transmitted.
See Also

Reference

ConnectionStatistics Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionStatistics.TotalOpsQueued Property

ConnectionStatisticsTotalOpsQueued Property
Gets or sets the total ops queued.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public long TotalOpsQueued { get; set; }
Public Property TotalOpsQueued As Long
    Get
    Set
public:
property long long TotalOpsQueued {
    long long get ();
    void set (long long value);
}
function get_TotalOpsQueued();
function set_TotalOpsQueued(value);

Property Value

Type: Int64
The total ops queued.
See Also

Reference

ConnectionStatistics Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionStatus Class

ConnectionStatus Class
The operational state of a connection.
Inheritance Hierarchy
SystemObject
DoubleTake.Core.Contract.ConnectionConnectionStatus

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class ConnectionStatus : IExtensibleDataObject
Public Class ConnectionStatus
    Implements IExtensibleDataObject
public ref class ConnectionStatus : IExtensibleDataObject
DoubleTake.Core.Contract.Connection.ConnectionStatus = function();

Type.createClass(
    'DoubleTake.Core.Contract.Connection.ConnectionStatus',
    null,
    IExtensibleDataObject);

The ConnectionStatus type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectionStatus | Initializes a new instance of the ConnectionStatus class
Top
Properties
 | Name | Description
Public property | Alive | Indicates whether the connection is active.
Public property | CmdRspQueueState | The QueueState of the command/response queue.
Public property | ConnectionMode |
Public property | Error | Indicates the connection experienced a network error.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | InitialMirrorComplete | Gets or sets a value indicating whether an initial mirror has completed for the connection.
Public property | IsRestoreRequired | Indicated the source/target data may be out of sync. A restore is required.
Public property | IsScheduled | Gets or sets a value indicating whether the transmission is in a scheduled state.
Public property | MirrorQueueState | The QueueState of the mirror queue.
Public property | MirrorSize | The size of the replication set in bytes, if it has been calculated.
Public property | MirrorState | The operational state of the mirror.
Public property | PeerMemoryLow | Indicates low memory on the target.
Public property | PendingAckQueueFull |
Public property | ReplicationQueueState | The QueueState of the replication queue.
Public property | ReplicationState | The operational state of replication.
Public property | Restoring | Gets or sets a value indicating whether the connection represented by this ConnectionStatus is restoring.
Public property | RetransmitQueueState | The QueueState of the retransmit queue.
Public property | StartTime |
Public property | TargetState | The known operational states of the connection target.
Public property | TransmissionMode | The operational state of replication and mirror.
Top
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


ConnectionStatus Constructor

ConnectionStatus Constructor
Initializes a new instance of the ConnectionStatus class

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ConnectionStatus()
Public Sub New
public:
ConnectionStatus()
DoubleTake.Core.Contract.Connection.ConnectionStatus = function();
See Also

Reference

ConnectionStatus Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionStatus Properties

ConnectionStatus Properties

The ConnectionStatus type exposes the following members.

Properties
 | Name | Description
Public property | Alive | Indicates whether the connection is active.
Public property | CmdRspQueueState | The QueueState of the command/response queue.
Public property | ConnectionMode |
Public property | Error | Indicates the connection experienced a network error.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | InitialMirrorComplete | Gets or sets a value indicating whether an initial mirror has completed for the connection.
Public property | IsRestoreRequired | Indicated the source/target data may be out of sync. A restore is required.
Public property | IsScheduled | Gets or sets a value indicating whether the transmission is in a scheduled state.
Public property | MirrorQueueState | The QueueState of the mirror queue.
Public property | MirrorSize | The size of the replication set in bytes, if it has been calculated.
Public property | MirrorState | The operational state of the mirror.
Public property | PeerMemoryLow | Indicates low memory on the target.
Public property | PendingAckQueueFull |
Public property | ReplicationQueueState | The QueueState of the replication queue.
Public property | ReplicationState | The operational state of replication.
Public property | Restoring | Gets or sets a value indicating whether the connection represented by this ConnectionStatus is restoring.
Public property | RetransmitQueueState | The QueueState of the retransmit queue.
Public property | StartTime |
Public property | TargetState | The known operational states of the connection target.
Public property | TransmissionMode | The operational state of replication and mirror.
Top
See Also

Reference

ConnectionStatus Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionStatus.Alive Property

ConnectionStatusAlive Property
Indicates whether the connection is active.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool Alive { get; set; }
Public Property Alive As Boolean
    Get
    Set
public:
property bool Alive {
    bool get ();
    void set (bool value);
}
function get_Alive();
function set_Alive(value);

Property Value

Type: Boolean
See Also

Reference

ConnectionStatus Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionStatus.CmdRspQueueState Property

ConnectionStatusCmdRspQueueState Property
The QueueState of the command/response queue.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public QueueState CmdRspQueueState { get; set; }
Public Property CmdRspQueueState As QueueState
    Get
    Set
public:
property QueueState CmdRspQueueState {
    QueueState get ();
    void set (QueueState value);
}
function get_CmdRspQueueState();
function set_CmdRspQueueState(value);

Property Value

Type: QueueState
See Also

Reference

ConnectionStatus Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionStatus.ConnectionMode Property

ConnectionStatusConnectionMode Property

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ConnectionMode ConnectionMode { get; set; }
Public Property ConnectionMode As ConnectionMode
    Get
    Set
public:
property ConnectionMode ConnectionMode {
    ConnectionMode get ();
    void set (ConnectionMode value);
}
function get_ConnectionMode();
function set_ConnectionMode(value);

Property Value

Type: ConnectionMode
See Also

Reference

ConnectionStatus Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionStatus.Error Property

ConnectionStatusError Property
Indicates the connection experienced a network error.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool Error { get; set; }
Public Property Error As Boolean
    Get
    Set
public:
property bool Error {
    bool get ();
    void set (bool value);
}
function get_Error();
function set_Error(value);

Property Value

Type: Boolean
See Also

Reference

ConnectionStatus Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionStatus.ExtensionData Property

ConnectionStatusExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

ConnectionStatus Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionStatus.InitialMirrorComplete Property

ConnectionStatusInitialMirrorComplete Property
Gets or sets a value indicating whether an initial mirror has completed for the connection.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool InitialMirrorComplete { get; set; }
Public Property InitialMirrorComplete As Boolean
    Get
    Set
public:
property bool InitialMirrorComplete {
    bool get ();
    void set (bool value);
}
function get_InitialMirrorComplete();
function set_InitialMirrorComplete(value);

Property Value

Type: Boolean
if an initial mirror has completed; otherwise, .
See Also

Reference

ConnectionStatus Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionStatus.IsRestoreRequired Property

ConnectionStatusIsRestoreRequired Property
Indicated the source/target data may be out of sync. A restore is required.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsRestoreRequired { get; set; }
Public Property IsRestoreRequired As Boolean
    Get
    Set
public:
property bool IsRestoreRequired {
    bool get ();
    void set (bool value);
}
function get_IsRestoreRequired();
function set_IsRestoreRequired(value);

Property Value

Type: Boolean
See Also

Reference

ConnectionStatus Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionStatus.IsScheduled Property

ConnectionStatusIsScheduled Property
Gets or sets a value indicating whether the transmission is in a scheduled state.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsScheduled { get; set; }
Public Property IsScheduled As Boolean
    Get
    Set
public:
property bool IsScheduled {
    bool get ();
    void set (bool value);
}
function get_IsScheduled();
function set_IsScheduled(value);

Property Value

Type: Boolean
if transmission for this instance is scheduled; otherwise, .
See Also

Reference

ConnectionStatus Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionStatus.MirrorQueueState Property

ConnectionStatusMirrorQueueState Property
The QueueState of the mirror queue.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public QueueState MirrorQueueState { get; set; }
Public Property MirrorQueueState As QueueState
    Get
    Set
public:
property QueueState MirrorQueueState {
    QueueState get ();
    void set (QueueState value);
}
function get_MirrorQueueState();
function set_MirrorQueueState(value);

Property Value

Type: QueueState
See Also

Reference

ConnectionStatus Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionStatus.MirrorSize Property

ConnectionStatusMirrorSize Property
The size of the replication set in bytes, if it has been calculated.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public long MirrorSize { get; set; }
Public Property MirrorSize As Long
    Get
    Set
public:
property long long MirrorSize {
    long long get ();
    void set (long long value);
}
function get_MirrorSize();
function set_MirrorSize(value);

Property Value

Type: Int64
See Also

Reference

ConnectionStatus Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionStatus.MirrorState Property

ConnectionStatusMirrorState Property
The operational state of the mirror.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public MirrorState MirrorState { get; set; }
Public Property MirrorState As MirrorState
    Get
    Set
public:
property MirrorState MirrorState {
    MirrorState get ();
    void set (MirrorState value);
}
function get_MirrorState();
function set_MirrorState(value);

Property Value

Type: MirrorState
See Also

Reference

ConnectionStatus Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionStatus.PeerMemoryLow Property

ConnectionStatusPeerMemoryLow Property
Indicates low memory on the target.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool PeerMemoryLow { get; set; }
Public Property PeerMemoryLow As Boolean
    Get
    Set
public:
property bool PeerMemoryLow {
    bool get ();
    void set (bool value);
}
function get_PeerMemoryLow();
function set_PeerMemoryLow(value);

Property Value

Type: Boolean
See Also

Reference

ConnectionStatus Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionStatus.PendingAckQueueFull Property

ConnectionStatusPendingAckQueueFull Property

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool PendingAckQueueFull { get; set; }
Public Property PendingAckQueueFull As Boolean
    Get
    Set
public:
property bool PendingAckQueueFull {
    bool get ();
    void set (bool value);
}
function get_PendingAckQueueFull();
function set_PendingAckQueueFull(value);

Property Value

Type: Boolean
See Also

Reference

ConnectionStatus Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionStatus.ReplicationQueueState Property

ConnectionStatusReplicationQueueState Property
The QueueState of the replication queue.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public QueueState ReplicationQueueState { get; set; }
Public Property ReplicationQueueState As QueueState
    Get
    Set
public:
property QueueState ReplicationQueueState {
    QueueState get ();
    void set (QueueState value);
}
function get_ReplicationQueueState();
function set_ReplicationQueueState(value);

Property Value

Type: QueueState
See Also

Reference

ConnectionStatus Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionStatus.ReplicationState Property

ConnectionStatusReplicationState Property
The operational state of replication.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ReplicationState ReplicationState { get; set; }
Public Property ReplicationState As ReplicationState
    Get
    Set
public:
property ReplicationState ReplicationState {
    ReplicationState get ();
    void set (ReplicationState value);
}
function get_ReplicationState();
function set_ReplicationState(value);

Property Value

Type: ReplicationState
See Also

Reference

ConnectionStatus Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionStatus.Restoring Property

ConnectionStatusRestoring Property
Gets or sets a value indicating whether the connection represented by this ConnectionStatus is restoring.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool Restoring { get; set; }
Public Property Restoring As Boolean
    Get
    Set
public:
property bool Restoring {
    bool get ();
    void set (bool value);
}
function get_Restoring();
function set_Restoring(value);

Property Value

Type: Boolean
if the connection is restoring; otherwise, .
See Also

Reference

ConnectionStatus Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionStatus.RetransmitQueueState Property

ConnectionStatusRetransmitQueueState Property
The QueueState of the retransmit queue.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public QueueState RetransmitQueueState { get; set; }
Public Property RetransmitQueueState As QueueState
    Get
    Set
public:
property QueueState RetransmitQueueState {
    QueueState get ();
    void set (QueueState value);
}
function get_RetransmitQueueState();
function set_RetransmitQueueState(value);

Property Value

Type: QueueState
See Also

Reference

ConnectionStatus Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionStatus.StartTime Property

ConnectionStatusStartTime Property

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public DateTimeOffset StartTime { get; set; }
Public Property StartTime As DateTimeOffset
    Get
    Set
public:
property DateTimeOffset StartTime {
    DateTimeOffset get ();
    void set (DateTimeOffset value);
}
function get_StartTime();
function set_StartTime(value);

Property Value

Type: DateTimeOffset
See Also

Reference

ConnectionStatus Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionStatus.TargetState Property

ConnectionStatusTargetState Property
The known operational states of the connection target.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public TargetStates TargetState { get; set; }
Public Property TargetState As TargetStates
    Get
    Set
public:
property TargetStates TargetState {
    TargetStates get ();
    void set (TargetStates value);
}
function get_TargetState();
function set_TargetState(value);

Property Value

Type: TargetStates
See Also

Reference

ConnectionStatus Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionStatus.TransmissionMode Property

ConnectionStatusTransmissionMode Property
The operational state of replication and mirror.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public TransmissionMode TransmissionMode { get; set; }
Public Property TransmissionMode As TransmissionMode
    Get
    Set
public:
property TransmissionMode TransmissionMode {
    TransmissionMode get ();
    void set (TransmissionMode value);
}
function get_TransmissionMode();
function set_TransmissionMode(value);

Property Value

Type: TransmissionMode
See Also

Reference

ConnectionStatus Class
DoubleTake.Core.Contract.Connection Namespace


MirrorComparisonCriteria Enumeration

MirrorComparisonCriteria Enumeration
Specifies how to compare files during a difference mirror or when running a verification report.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public enum MirrorComparisonCriteria
Public Enumeration MirrorComparisonCriteria
public enum class MirrorComparisonCriteria
DoubleTake.Core.Contract.Connection.MirrorComparisonCriteria = function();
DoubleTake.Core.Contract.Connection.MirrorComparisonCriteria.createEnum('DoubleTake.Core.Contract.Connection.MirrorComparisonCriteria', false);
Members
Member name | Value | Description
None | 0 | Double-Take will not perform any comparison between the files on the source and target.
Newer | 1 | Double-Take will compare file attributes between the files on the source and target.
Checksum | 2 | Double-Take will compare file attributes and file data between files on the source and target.
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


MirrorOperationOptions Enumeration

MirrorOperationOptions Enumeration
Specifies what to do when a verify mirror operation is performed.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public enum MirrorOperationOptions
Public Enumeration MirrorOperationOptions
public enum class MirrorOperationOptions
DoubleTake.Core.Contract.Connection.MirrorOperationOptions = function();
DoubleTake.Core.Contract.Connection.MirrorOperationOptions.createEnum('DoubleTake.Core.Contract.Connection.MirrorOperationOptions', false);
Members
Member name | Value | Description
None | 0 | Double-Take will not mirror any files.
Synchronize | 1 | Double-Take will mirror the files from the source to the target. If you use this property by itself, all files will be mirror. If you use this property with CalculateDifferences, only the differences will be mirrored.
Report | 2 | Double-Take will only report the differences found between the source protected data set and the replica on the target. You must use this option with CalculateDifferences in order for the differences to be reported.
CalculateDifferences | 4 | The mirroring operation will calculate the differences between the source protected data and the replica on the target using MirrorComparisonCriteria.
CalculateSize | 8 | The mirroring operation will calculate the size of the source protected data set.
ProcessOrphans | 16 | The mirroring operation will process orphan files (files in the target path location that are not present on the source).
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


MirrorParameters Class

MirrorParameters Class
Inheritance Hierarchy
SystemObject
DoubleTake.Core.Contract.ConnectionMirrorParameters

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public sealed class MirrorParameters : IExtensibleDataObject
Public NotInheritable Class MirrorParameters
    Implements IExtensibleDataObject
public ref class MirrorParameters sealed : IExtensibleDataObject
DoubleTake.Core.Contract.Connection.MirrorParameters = function();

Type.createClass(
    'DoubleTake.Core.Contract.Connection.MirrorParameters',
    null,
    IExtensibleDataObject);

The MirrorParameters type exposes the following members.

Constructors
 | Name | Description
Public method | MirrorParameters | Initializes a new instance of the MirrorParameters class
Top
Properties
 | Name | Description
Public property | ComparisonCriteria | This value represents how to compare the source protected data and the replica on the target.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Options | This value represents what mirror operation will be performed.
Public property | OverrideJobOrphansProcessing | This value is true if the job's orphan file setting is to be overridden; otherwise, it is false.
Top
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


MirrorParameters Constructor

MirrorParameters Constructor
Initializes a new instance of the MirrorParameters class

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public MirrorParameters()
Public Sub New
public:
MirrorParameters()
DoubleTake.Core.Contract.Connection.MirrorParameters = function();
See Also

Reference

MirrorParameters Class
DoubleTake.Core.Contract.Connection Namespace


MirrorParameters Properties

MirrorParameters Properties

The MirrorParameters type exposes the following members.

Properties
 | Name | Description
Public property | ComparisonCriteria | This value represents how to compare the source protected data and the replica on the target.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Options | This value represents what mirror operation will be performed.
Public property | OverrideJobOrphansProcessing | This value is true if the job's orphan file setting is to be overridden; otherwise, it is false.
Top
See Also

Reference

MirrorParameters Class
DoubleTake.Core.Contract.Connection Namespace


MirrorParameters.ComparisonCriteria Property

MirrorParametersComparisonCriteria Property
This value represents how to compare the source protected data and the replica on the target.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public MirrorComparisonCriteria ComparisonCriteria { get; set; }
Public Property ComparisonCriteria As MirrorComparisonCriteria
    Get
    Set
public:
property MirrorComparisonCriteria ComparisonCriteria {
    MirrorComparisonCriteria get ();
    void set (MirrorComparisonCriteria value);
}
function get_ComparisonCriteria();
function set_ComparisonCriteria(value);

Property Value

Type: MirrorComparisonCriteria
See Also

Reference

MirrorParameters Class
DoubleTake.Core.Contract.Connection Namespace


MirrorParameters.ExtensionData Property

MirrorParametersExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The structure that contains the extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

MirrorParameters Class
DoubleTake.Core.Contract.Connection Namespace


MirrorParameters.Options Property

MirrorParametersOptions Property
This value represents what mirror operation will be performed.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public MirrorOperationOptions Options { get; set; }
Public Property Options As MirrorOperationOptions
    Get
    Set
public:
property MirrorOperationOptions Options {
    MirrorOperationOptions get ();
    void set (MirrorOperationOptions value);
}
function get_Options();
function set_Options(value);

Property Value

Type: MirrorOperationOptions
See Also

Reference

MirrorParameters Class
DoubleTake.Core.Contract.Connection Namespace


MirrorParameters.OverrideJobOrphansProcessing Property

MirrorParametersOverrideJobOrphansProcessing Property
This value is true if the job's orphan file setting is to be overridden; otherwise, it is false.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool OverrideJobOrphansProcessing { get; set; }
Public Property OverrideJobOrphansProcessing As Boolean
    Get
    Set
public:
property bool OverrideJobOrphansProcessing {
    bool get ();
    void set (bool value);
}
function get_OverrideJobOrphansProcessing();
function set_OverrideJobOrphansProcessing(value);

Property Value

Type: Boolean
if the job's orphans processing setting is to be overridden; otherwise, .
See Also

Reference

MirrorParameters Class
DoubleTake.Core.Contract.Connection Namespace


MirrorState Enumeration

MirrorState Enumeration
The operational state of mirroring.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public enum MirrorState
Public Enumeration MirrorState
public enum class MirrorState
DoubleTake.Core.Contract.Connection.MirrorState = function();
DoubleTake.Core.Contract.Connection.MirrorState.createEnum('DoubleTake.Core.Contract.Connection.MirrorState', false);
Members
Member name | Value | Description
Calculating | 0 | The size of the replication set is being calculated.
Idle | 1 | No data is being mirrored to the target.
Mirror | 2 | Data is being mirrored to the target.
Pause | 3 | Mirroring is paused.
RemoveOrphans | 4 | Orphan files (files in the target path location that are not present on the source) are being deleted.
RepsetVerify | 5 | The source protected data set is being verified against the target replica data.
Restore | 6 | Replica data from the target is being restored to the source.
Stopped | 7 | Mirroring is stopped.
Waiting | 8 | Mirroring is complete, but data is still being written to the target.
Unknown | 9 | The mirror is in an unknown or error state.
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


OrphansSchedule Class

OrphansSchedule Class
This value is true if orphan files (files in the target path location that are not present on the source) will be deleted; otherwise, it is false. There is currently no schedule (time-related options) for orphan files. They can only be on or off.
Inheritance Hierarchy
SystemObject
DoubleTake.Core.Contract.ConnectionScheduleItem
DoubleTake.Core.Contract.ConnectionOrphansSchedule

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class OrphansSchedule : ScheduleItem
Public Class OrphansSchedule
    Inherits ScheduleItem
public ref class OrphansSchedule : public ScheduleItem
DoubleTake.Core.Contract.Connection.OrphansSchedule = function();

Type.createClass(
    'DoubleTake.Core.Contract.Connection.OrphansSchedule',
    DoubleTake.Core.Contract.Connection.ScheduleItem);

The OrphansSchedule type exposes the following members.

Constructors
 | Name | Description
Public method | OrphansSchedule | Initializes a new instance of the OrphansSchedule class
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from ScheduleItem.)
Public property | IsEnabled | (Inherited from ScheduleItem.)
Top
Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Top
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


OrphansSchedule Constructor

OrphansSchedule Constructor
Initializes a new instance of the OrphansSchedule class

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public OrphansSchedule()
Public Sub New
public:
OrphansSchedule()
DoubleTake.Core.Contract.Connection.OrphansSchedule = function();
See Also

Reference

OrphansSchedule Class
DoubleTake.Core.Contract.Connection Namespace


OrphansSchedule Properties

OrphansSchedule Properties

The OrphansSchedule type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from ScheduleItem.)
Public property | IsEnabled | (Inherited from ScheduleItem.)
Top
See Also

Reference

OrphansSchedule Class
DoubleTake.Core.Contract.Connection Namespace


OrphansSchedule Methods

OrphansSchedule Methods

The OrphansSchedule type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Top
See Also

Reference

OrphansSchedule Class
DoubleTake.Core.Contract.Connection Namespace


OrphansSchedule.Clone Method

OrphansScheduleClone Method
Creates a new object that is a copy of the current instance.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
function Clone();

Return Value

Type: Object
A new object that is a copy of this instance.
See Also

Reference

OrphansSchedule Class
DoubleTake.Core.Contract.Connection Namespace


QueueState Enumeration

QueueState Enumeration
The operational state of a queue.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public enum QueueState
Public Enumeration QueueState
public enum class QueueState
DoubleTake.Core.Contract.Connection.QueueState = function();
DoubleTake.Core.Contract.Connection.QueueState.createEnum('DoubleTake.Core.Contract.Connection.QueueState', false);
Members
Member name | Value | Description
Pause | 0 | Queue processing is paused.
Active | 1 | The queue is being processed.
Scheduled | 2 | Queue processing is pending.
Remarks
Describes the current state of a queue, not necessarily the desired operation.
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


QueueTaskParameters Class

QueueTaskParameters Class
Specifies the parameters for executing in-band tasks on a Double-Take connection.
Inheritance Hierarchy
SystemObject
DoubleTake.Core.Contract.ConnectionQueueTaskParameters

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class QueueTaskParameters : IExtensibleDataObject
Public Class QueueTaskParameters
    Implements IExtensibleDataObject
public ref class QueueTaskParameters : IExtensibleDataObject
DoubleTake.Core.Contract.Connection.QueueTaskParameters = function();

Type.createClass(
    'DoubleTake.Core.Contract.Connection.QueueTaskParameters',
    null,
    IExtensibleDataObject);

The QueueTaskParameters type exposes the following members.

Constructors
 | Name | Description
Public method | QueueTaskParameters | Initializes a new instance of the QueueTaskParameters class
Top
Properties
 | Name | Description
Public property | DesktopInteractionMode | Gets or sets the desktop interaction mode.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | OnExecute | Gets or sets the script to execute when the command is executed on the target.
Public property | OnQueue | Gets or sets the script to execute on the source when the command is queued.
Public property | OnReceive | Gets or sets the script to execute when the command is received on the target.
Public property | OnTransmit | Gets or sets the script to execute on the source when the command is transmitted to the target.
Public property | TaskName | Gets or sets the name of the task.
Public property | Timeout | Gets or sets the timeout.
Top
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


QueueTaskParameters Constructor

QueueTaskParameters Constructor
Initializes a new instance of the QueueTaskParameters class

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public QueueTaskParameters()
Public Sub New
public:
QueueTaskParameters()
DoubleTake.Core.Contract.Connection.QueueTaskParameters = function();
See Also

Reference

QueueTaskParameters Class
DoubleTake.Core.Contract.Connection Namespace


QueueTaskParameters Properties

QueueTaskParameters Properties

The QueueTaskParameters type exposes the following members.

Properties
 | Name | Description
Public property | DesktopInteractionMode | Gets or sets the desktop interaction mode.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | OnExecute | Gets or sets the script to execute when the command is executed on the target.
Public property | OnQueue | Gets or sets the script to execute on the source when the command is queued.
Public property | OnReceive | Gets or sets the script to execute when the command is received on the target.
Public property | OnTransmit | Gets or sets the script to execute on the source when the command is transmitted to the target.
Public property | TaskName | Gets or sets the name of the task.
Public property | Timeout | Gets or sets the timeout.
Top
See Also

Reference

QueueTaskParameters Class
DoubleTake.Core.Contract.Connection Namespace


QueueTaskParameters.DesktopInteractionMode Property

QueueTaskParametersDesktopInteractionMode Property
Gets or sets the desktop interaction mode.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public DesktopInteractionMode DesktopInteractionMode { get; set; }
Public Property DesktopInteractionMode As DesktopInteractionMode
    Get
    Set
public:
property DesktopInteractionMode DesktopInteractionMode {
    DesktopInteractionMode get ();
    void set (DesktopInteractionMode value);
}
function get_DesktopInteractionMode();
function set_DesktopInteractionMode(value);

Property Value

Type: DesktopInteractionMode
The desktop interaction mode.
Remarks
Use this parameter to specify whether or not you want the script or executable to be able to interact with the desktop.
See Also

Reference

QueueTaskParameters Class
DoubleTake.Core.Contract.Connection Namespace


QueueTaskParameters.ExtensionData Property

QueueTaskParametersExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The structure that contains extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

QueueTaskParameters Class
DoubleTake.Core.Contract.Connection Namespace


QueueTaskParameters.OnExecute Property

QueueTaskParametersOnExecute Property
Gets or sets the script to execute when the command is executed on the target.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public TaskParameters OnExecute { get; set; }
Public Property OnExecute As TaskParameters
    Get
    Set
public:
property TaskParameters^ OnExecute {
    TaskParameters^ get ();
    void set (TaskParameters^ value);
}
function get_OnExecute();
function set_OnExecute(value);

Property Value

Type: TaskParameters
The script to execute when the command is executed on the target.
See Also

Reference

QueueTaskParameters Class
DoubleTake.Core.Contract.Connection Namespace


QueueTaskParameters.OnQueue Property

QueueTaskParametersOnQueue Property
Gets or sets the script to execute on the source when the command is queued.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public TaskParameters OnQueue { get; set; }
Public Property OnQueue As TaskParameters
    Get
    Set
public:
property TaskParameters^ OnQueue {
    TaskParameters^ get ();
    void set (TaskParameters^ value);
}
function get_OnQueue();
function set_OnQueue(value);

Property Value

Type: TaskParameters
The script to execute on the source when the command is queued.
See Also

Reference

QueueTaskParameters Class
DoubleTake.Core.Contract.Connection Namespace


QueueTaskParameters.OnReceive Property

QueueTaskParametersOnReceive Property
Gets or sets the script to execute when the command is received on the target.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public TaskParameters OnReceive { get; set; }
Public Property OnReceive As TaskParameters
    Get
    Set
public:
property TaskParameters^ OnReceive {
    TaskParameters^ get ();
    void set (TaskParameters^ value);
}
function get_OnReceive();
function set_OnReceive(value);

Property Value

Type: TaskParameters
The script to execute when the command is received on the target.
See Also

Reference

QueueTaskParameters Class
DoubleTake.Core.Contract.Connection Namespace


QueueTaskParameters.OnTransmit Property

QueueTaskParametersOnTransmit Property
Gets or sets the script to execute on the source when the command is transmitted to the target.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public TaskParameters OnTransmit { get; set; }
Public Property OnTransmit As TaskParameters
    Get
    Set
public:
property TaskParameters^ OnTransmit {
    TaskParameters^ get ();
    void set (TaskParameters^ value);
}
function get_OnTransmit();
function set_OnTransmit(value);

Property Value

Type: TaskParameters
The script to execute on the source when the command is transmitted to the target.
See Also

Reference

QueueTaskParameters Class
DoubleTake.Core.Contract.Connection Namespace


QueueTaskParameters.TaskName Property

QueueTaskParametersTaskName Property
Gets or sets the name of the task.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string TaskName { get; set; }
Public Property TaskName As String
    Get
    Set
public:
property String^ TaskName {
    String^ get ();
    void set (String^ value);
}
function get_TaskName();
function set_TaskName(value);

Property Value

Type: String
The name of the task.
See Also

Reference

QueueTaskParameters Class
DoubleTake.Core.Contract.Connection Namespace


QueueTaskParameters.Timeout Property

QueueTaskParametersTimeout Property
Gets or sets the timeout.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public TimeSpan Timeout { get; set; }
Public Property Timeout As TimeSpan
    Get
    Set
public:
property TimeSpan Timeout {
    TimeSpan get ();
    void set (TimeSpan value);
}
function get_Timeout();
function set_Timeout(value);

Property Value

Type: TimeSpan
The timeout.
See Also

Reference

QueueTaskParameters Class
DoubleTake.Core.Contract.Connection Namespace


ReplicationState Enumeration

ReplicationState Enumeration
The operational state of replication.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public enum ReplicationState
Public Enumeration ReplicationState
public enum class ReplicationState
DoubleTake.Core.Contract.Connection.ReplicationState = function();
DoubleTake.Core.Contract.Connection.ReplicationState.createEnum('DoubleTake.Core.Contract.Connection.ReplicationState', false);
Members
Member name | Value | Description
NotReplicating | 0 | Replication is stopped.
OutOfMemory | 1 | Replication memory has been exhausted.
Pending | 2 | Replication is pending.
Replicating | 3 | Data is being replicated to the target.
Unknown | 4 | Replicationis in an unknown or error state.
Watchdog | 5 | The Double-Take service is not receiving replication operations from the Double-Take driver. Check the event log for driver related issues.
Ready | 6 | There is no data to replicate.
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


RestoreOptions Enumeration

RestoreOptions Enumeration
Defines options that can be applied when restoring data.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public enum RestoreOptions
Public Enumeration RestoreOptions
public enum class RestoreOptions
DoubleTake.Core.Contract.Connection.RestoreOptions = function();
DoubleTake.Core.Contract.Connection.RestoreOptions.createEnum('DoubleTake.Core.Contract.Connection.RestoreOptions', false);
Members
Member name | Value | Description
None | 0 | No additional restroration options will be used.
UseTargetWorkload | 1 | Use the workload information that is stored on the target instead of any workload information that is persisted on the source.
RestoreWorkloadToSource | 2 | Restore the workload information from the target to the source. This property can only be used with UseTargetWorkload.
OverwriteExistingFiles | 4 | Overwrite all existing files on the source during the restoration.
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


RestoreParameters Class

RestoreParameters Class
Represents the parameters required to start a restore operation for a connection.
Inheritance Hierarchy
SystemObject
DoubleTake.Core.Contract.ConnectionRestoreParameters

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class RestoreParameters : IExtensibleDataObject
Public Class RestoreParameters
    Implements IExtensibleDataObject
public ref class RestoreParameters : IExtensibleDataObject
DoubleTake.Core.Contract.Connection.RestoreParameters = function();

Type.createClass(
    'DoubleTake.Core.Contract.Connection.RestoreParameters',
    null,
    IExtensibleDataObject);

The RestoreParameters type exposes the following members.

Constructors
 | Name | Description
Public method | RestoreParameters | Initializes a new instance of the RestoreParameters class
Top
Properties
 | Name | Description
Public property | ArchiveBinLocation | This property is no longer used
Public property | ArchiveOption | This property is no longer used.
Public property | CompressionLevel | This value represents how data will be compressed when it is transmitted from the source to the target.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | MirrorComparisonCriteria | Gets or sets the comparison criteria.
Public property | OriginalSourceName | This value is the name of the original source server from the original protection job.
Public property | OriginalTargetRoute | This value is the route for the original target server from the original protection job.
Public property | PathTransformations | This value represents where the source protected data will be located on the target.
Public property | ProcessOrphans | This value is true if the orphan files (files in the target path location that are not present on the source) are to be deleted; otherwise, it is false.
Public property | ReplicationSetName | This value is the name of the protected data set.
Public property | RestoreOptions | This value represents addtional options used for the restoration process.
Top
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


RestoreParameters Constructor

RestoreParameters Constructor
Initializes a new instance of the RestoreParameters class

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public RestoreParameters()
Public Sub New
public:
RestoreParameters()
DoubleTake.Core.Contract.Connection.RestoreParameters = function();
See Also

Reference

RestoreParameters Class
DoubleTake.Core.Contract.Connection Namespace


RestoreParameters Properties

RestoreParameters Properties

The RestoreParameters type exposes the following members.

Properties
 | Name | Description
Public property | ArchiveBinLocation | This property is no longer used
Public property | ArchiveOption | This property is no longer used.
Public property | CompressionLevel | This value represents how data will be compressed when it is transmitted from the source to the target.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | MirrorComparisonCriteria | Gets or sets the comparison criteria.
Public property | OriginalSourceName | This value is the name of the original source server from the original protection job.
Public property | OriginalTargetRoute | This value is the route for the original target server from the original protection job.
Public property | PathTransformations | This value represents where the source protected data will be located on the target.
Public property | ProcessOrphans | This value is true if the orphan files (files in the target path location that are not present on the source) are to be deleted; otherwise, it is false.
Public property | ReplicationSetName | This value is the name of the protected data set.
Public property | RestoreOptions | This value represents addtional options used for the restoration process.
Top
See Also

Reference

RestoreParameters Class
DoubleTake.Core.Contract.Connection Namespace


RestoreParameters.ArchiveBinLocation Property

RestoreParametersArchiveBinLocation Property
This property is no longer used

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string ArchiveBinLocation { get; set; }
Public Property ArchiveBinLocation As String
    Get
    Set
public:
property String^ ArchiveBinLocation {
    String^ get ();
    void set (String^ value);
}
function get_ArchiveBinLocation();
function set_ArchiveBinLocation(value);

Property Value

Type: String
The archive bin location.
See Also

Reference

RestoreParameters Class
DoubleTake.Core.Contract.Connection Namespace


RestoreParameters.ArchiveOption Property

RestoreParametersArchiveOption Property
This property is no longer used.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ArchiveRestoreOption ArchiveOption { get; set; }
Public Property ArchiveOption As ArchiveRestoreOption
    Get
    Set
public:
property ArchiveRestoreOption ArchiveOption {
    ArchiveRestoreOption get ();
    void set (ArchiveRestoreOption value);
}
function get_ArchiveOption();
function set_ArchiveOption(value);

Property Value

Type: ArchiveRestoreOption
The archive option.
See Also

Reference

RestoreParameters Class
DoubleTake.Core.Contract.Connection Namespace


RestoreParameters.CompressionLevel Property

RestoreParametersCompressionLevel Property
This value represents how data will be compressed when it is transmitted from the source to the target.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public CompressionLevel CompressionLevel { get; set; }
Public Property CompressionLevel As CompressionLevel
    Get
    Set
public:
property CompressionLevel^ CompressionLevel {
    CompressionLevel^ get ();
    void set (CompressionLevel^ value);
}
function get_CompressionLevel();
function set_CompressionLevel(value);

Property Value

Type: CompressionLevel
The compression level.
See Also

Reference

RestoreParameters Class
DoubleTake.Core.Contract.Connection Namespace


RestoreParameters.ExtensionData Property

RestoreParametersExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

RestoreParameters Class
DoubleTake.Core.Contract.Connection Namespace


RestoreParameters.MirrorComparisonCriteria Property

RestoreParametersMirrorComparisonCriteria Property
Gets or sets the comparison criteria.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public MirrorComparisonCriteria MirrorComparisonCriteria { get; set; }
Public Property MirrorComparisonCriteria As MirrorComparisonCriteria
    Get
    Set
public:
property MirrorComparisonCriteria MirrorComparisonCriteria {
    MirrorComparisonCriteria get ();
    void set (MirrorComparisonCriteria value);
}
function get_MirrorComparisonCriteria();
function set_MirrorComparisonCriteria(value);

Property Value

Type: MirrorComparisonCriteria
The comparison criteria.
See Also

Reference

RestoreParameters Class
DoubleTake.Core.Contract.Connection Namespace


RestoreParameters.OriginalSourceName Property

RestoreParametersOriginalSourceName Property
This value is the name of the original source server from the original protection job.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string OriginalSourceName { get; set; }
Public Property OriginalSourceName As String
    Get
    Set
public:
property String^ OriginalSourceName {
    String^ get ();
    void set (String^ value);
}
function get_OriginalSourceName();
function set_OriginalSourceName(value);

Property Value

Type: String
The name of the original source.
See Also

Reference

RestoreParameters Class
DoubleTake.Core.Contract.Connection Namespace


RestoreParameters.OriginalTargetRoute Property

RestoreParametersOriginalTargetRoute Property
This value is the route for the original target server from the original protection job.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string OriginalTargetRoute { get; set; }
Public Property OriginalTargetRoute As String
    Get
    Set
public:
property String^ OriginalTargetRoute {
    String^ get ();
    void set (String^ value);
}
function get_OriginalTargetRoute();
function set_OriginalTargetRoute(value);

Property Value

Type: String
The original target route.
See Also

Reference

RestoreParameters Class
DoubleTake.Core.Contract.Connection Namespace


RestoreParameters.PathTransformations Property

RestoreParametersPathTransformations Property
This value represents where the source protected data will be located on the target.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public PathTransformation[] PathTransformations { get; set; }
Public Property PathTransformations As PathTransformation()
    Get
    Set
public:
property array<PathTransformation^>^ PathTransformations {
    array<PathTransformation^>^ get ();
    void set (array<PathTransformation^>^ value);
}
function get_PathTransformations();
function set_PathTransformations(value);

Property Value

Type: PathTransformation
The path transformations.
See Also

Reference

RestoreParameters Class
DoubleTake.Core.Contract.Connection Namespace


RestoreParameters.ProcessOrphans Property

RestoreParametersProcessOrphans Property
This value is true if the orphan files (files in the target path location that are not present on the source) are to be deleted; otherwise, it is false.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool ProcessOrphans { get; set; }
Public Property ProcessOrphans As Boolean
    Get
    Set
public:
property bool ProcessOrphans {
    bool get ();
    void set (bool value);
}
function get_ProcessOrphans();
function set_ProcessOrphans(value);

Property Value

Type: Boolean
if orphans are to be processed; otherwise, .
See Also

Reference

RestoreParameters Class
DoubleTake.Core.Contract.Connection Namespace


RestoreParameters.ReplicationSetName Property

RestoreParametersReplicationSetName Property
This value is the name of the protected data set.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string ReplicationSetName { get; set; }
Public Property ReplicationSetName As String
    Get
    Set
public:
property String^ ReplicationSetName {
    String^ get ();
    void set (String^ value);
}
function get_ReplicationSetName();
function set_ReplicationSetName(value);

Property Value

Type: String
The name of the replication set.
See Also

Reference

RestoreParameters Class
DoubleTake.Core.Contract.Connection Namespace


RestoreParameters.RestoreOptions Property

RestoreParametersRestoreOptions Property
This value represents addtional options used for the restoration process.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public RestoreOptions RestoreOptions { get; set; }
Public Property RestoreOptions As RestoreOptions
    Get
    Set
public:
property RestoreOptions RestoreOptions {
    RestoreOptions get ();
    void set (RestoreOptions value);
}
function get_RestoreOptions();
function set_RestoreOptions(value);

Property Value

Type: RestoreOptions
The options.
See Also

Reference

RestoreParameters Class
DoubleTake.Core.Contract.Connection Namespace


ScheduleItem Class

ScheduleItem Class
Inheritance Hierarchy
SystemObject
DoubleTake.Core.Contract.ConnectionScheduleItem
DoubleTake.Core.Contract.ConnectionArchiveSchedule
DoubleTake.Core.Contract.ConnectionOrphansSchedule
DoubleTake.Core.Contract.ConnectionSnapshotSchedule
DoubleTake.Core.Contract.ConnectionTransmissionSchedule
DoubleTake.Core.Contract.ConnectionVerifySchedule

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class ScheduleItem : IExtensibleDataObject
Public Class ScheduleItem
    Implements IExtensibleDataObject
public ref class ScheduleItem : IExtensibleDataObject
DoubleTake.Core.Contract.Connection.ScheduleItem = function();

Type.createClass(
    'DoubleTake.Core.Contract.Connection.ScheduleItem',
    null,
    IExtensibleDataObject);

The ScheduleItem type exposes the following members.

Constructors
 | Name | Description
Public method | ScheduleItem | Initializes a new instance of the ScheduleItem class
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | IsEnabled |
Top
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


ScheduleItem Constructor

ScheduleItem Constructor
Initializes a new instance of the ScheduleItem class

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ScheduleItem()
Public Sub New
public:
ScheduleItem()
DoubleTake.Core.Contract.Connection.ScheduleItem = function();
See Also

Reference

ScheduleItem Class
DoubleTake.Core.Contract.Connection Namespace


ScheduleItem Properties

ScheduleItem Properties

The ScheduleItem type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | IsEnabled |
Top
See Also

Reference

ScheduleItem Class
DoubleTake.Core.Contract.Connection Namespace


ScheduleItem.ExtensionData Property

ScheduleItemExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

ScheduleItem Class
DoubleTake.Core.Contract.Connection Namespace


ScheduleItem.IsEnabled Property

ScheduleItemIsEnabled Property

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsEnabled { get; set; }
Public Property IsEnabled As Boolean
    Get
    Set
public:
property bool IsEnabled {
    bool get ();
    void set (bool value);
}
function get_IsEnabled();
function set_IsEnabled(value);

Property Value

Type: Boolean
See Also

Reference

ScheduleItem Class
DoubleTake.Core.Contract.Connection Namespace


ScriptExecutionMode Enumeration

ScriptExecutionMode Enumeration

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public enum ScriptExecutionMode
Public Enumeration ScriptExecutionMode
public enum class ScriptExecutionMode
DoubleTake.Core.Contract.Connection.ScriptExecutionMode = function();
DoubleTake.Core.Contract.Connection.ScriptExecutionMode.createEnum('DoubleTake.Core.Contract.Connection.ScriptExecutionMode', false);
Members
Member name | Value | Description
Synchronous | 0 | Double-Take will wait while the script is executed.
Asynchronous | 1 | Double-Take will not wait while the script is executed.
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


ScriptPoint Class

ScriptPoint Class
Inheritance Hierarchy
SystemObject
ObservableObject
DoubleTake.Core.Contract.ConnectionScriptPoint

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public sealed class ScriptPoint : ObservableObject,
    IExtensibleDataObject
Public NotInheritable Class ScriptPoint
    Inherits ObservableObject
    Implements IExtensibleDataObject
public ref class ScriptPoint sealed : public ObservableObject,
    IExtensibleDataObject
DoubleTake.Core.Contract.Connection.ScriptPoint = function();

Type.createClass(
    'DoubleTake.Core.Contract.Connection.ScriptPoint',
    DoubleTake.Common.ComponentModel.ObservableObject,
    IExtensibleDataObject);

The ScriptPoint type exposes the following members.

Constructors
 | Name | Description
Public method | ScriptPoint | Initializes a new instance of the ScriptPoint class
Top
Properties
 | Name | Description
Public property | Arguments | This value is a comma-separated list of valid arguments required to execute the script.
Public property | ExecutionMode | This value represents if Double-Take will wait while executing the script.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | InteractionMode | This value represents if the script processing will dispaly on screen.
Public property | Path | This value is the full path and file name of the script.
Public property | Type | This value represents the type of script to execute.
Top
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


ScriptPoint Constructor

ScriptPoint Constructor
Initializes a new instance of the ScriptPoint class

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ScriptPoint()
Public Sub New
public:
ScriptPoint()
DoubleTake.Core.Contract.Connection.ScriptPoint = function();
See Also

Reference

ScriptPoint Class
DoubleTake.Core.Contract.Connection Namespace


ScriptPoint Properties

ScriptPoint Properties

The ScriptPoint type exposes the following members.

Properties
 | Name | Description
Public property | Arguments | This value is a comma-separated list of valid arguments required to execute the script.
Public property | ExecutionMode | This value represents if Double-Take will wait while executing the script.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | InteractionMode | This value represents if the script processing will dispaly on screen.
Public property | Path | This value is the full path and file name of the script.
Public property | Type | This value represents the type of script to execute.
Top
See Also

Reference

ScriptPoint Class
DoubleTake.Core.Contract.Connection Namespace


ScriptPoint.Arguments Property

ScriptPointArguments Property
This value is a comma-separated list of valid arguments required to execute the script.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Arguments { get; set; }
Public Property Arguments As String
    Get
    Set
public:
property String^ Arguments {
    String^ get ();
    void set (String^ value);
}
function get_Arguments();
function set_Arguments(value);

Property Value

Type: String
The arguments.
See Also

Reference

ScriptPoint Class
DoubleTake.Core.Contract.Connection Namespace


ScriptPoint.ExecutionMode Property

ScriptPointExecutionMode Property
This value represents if Double-Take will wait while executing the script.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ScriptExecutionMode ExecutionMode { get; set; }
Public Property ExecutionMode As ScriptExecutionMode
    Get
    Set
public:
property ScriptExecutionMode ExecutionMode {
    ScriptExecutionMode get ();
    void set (ScriptExecutionMode value);
}
function get_ExecutionMode();
function set_ExecutionMode(value);

Property Value

Type: ScriptExecutionMode
The execution mode.
See Also

Reference

ScriptPoint Class
DoubleTake.Core.Contract.Connection Namespace


ScriptPoint.ExtensionData Property

ScriptPointExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

ScriptPoint Class
DoubleTake.Core.Contract.Connection Namespace


ScriptPoint.InteractionMode Property

ScriptPointInteractionMode Property
This value represents if the script processing will dispaly on screen.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public DesktopInteractionMode InteractionMode { get; set; }
Public Property InteractionMode As DesktopInteractionMode
    Get
    Set
public:
property DesktopInteractionMode InteractionMode {
    DesktopInteractionMode get ();
    void set (DesktopInteractionMode value);
}
function get_InteractionMode();
function set_InteractionMode(value);

Property Value

Type: DesktopInteractionMode
The interaction mode.
See Also

Reference

ScriptPoint Class
DoubleTake.Core.Contract.Connection Namespace


ScriptPoint.Path Property

ScriptPointPath Property
This value is the full path and file name of the script.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Path { get; set; }
Public Property Path As String
    Get
    Set
public:
property String^ Path {
    String^ get ();
    void set (String^ value);
}
function get_Path();
function set_Path(value);

Property Value

Type: String
The path.
See Also

Reference

ScriptPoint Class
DoubleTake.Core.Contract.Connection Namespace


ScriptPoint.Type Property

ScriptPointType Property
This value represents the type of script to execute.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ScriptPointType Type { get; set; }
Public Property Type As ScriptPointType
    Get
    Set
public:
property ScriptPointType Type {
    ScriptPointType get ();
    void set (ScriptPointType value);
}
function get_Type();
function set_Type(value);

Property Value

Type: ScriptPointType
The type.
See Also

Reference

ScriptPoint Class
DoubleTake.Core.Contract.Connection Namespace


ScriptPointType Enumeration

ScriptPointType Enumeration

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public enum ScriptPointType
Public Enumeration ScriptPointType
public enum class ScriptPointType
DoubleTake.Core.Contract.Connection.ScriptPointType = function();
DoubleTake.Core.Contract.Connection.ScriptPointType.createEnum('DoubleTake.Core.Contract.Connection.ScriptPointType', false);
Members
Member name | Value | Description
MirrorStart | 0 | The script is executed when the target receives the first mirror operation. In the case of a difference mirror, this may be a long time after the mirror is started because the script does not start until the first different data is received on the target. If the data is synchronized and a difference mirror finds nothing to mirror, the script will not be executed.
MirrorComplete | 1 | The script is executed when a mirror is completed. Because the mirror statistics may indicate a mirror is at 99-100% when it is actually still processing (for example, if files were added after the job size was calculated, if there are alternate data streams, and so on), the script will not start until all of the mirror data has been completely processed on the target.
MirrorStop | 2 | The script is executed when a mirror is stopped, which may be caused by an auto-disconnect occurring while a mirror is running, the service is shutdown while a mirror is running, or if you stop a mirror manually.
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


SnapshotAge Enumeration

SnapshotAge Enumeration

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public enum SnapshotAge
Public Enumeration SnapshotAge
public enum class SnapshotAge
DoubleTake.Core.Contract.Connection.SnapshotAge = function();
DoubleTake.Core.Contract.Connection.SnapshotAge.createEnum('DoubleTake.Core.Contract.Connection.SnapshotAge', false);
Members
Member name | Value | Description
Old | 0 |
All | 1 |
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


SnapshotCreationReason Enumeration

SnapshotCreationReason Enumeration
Indicates possible triggers for how a snapshot was taken.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public enum SnapshotCreationReason
Public Enumeration SnapshotCreationReason
public enum class SnapshotCreationReason
DoubleTake.Core.Contract.Connection.SnapshotCreationReason = function();
DoubleTake.Core.Contract.Connection.SnapshotCreationReason.createEnum('DoubleTake.Core.Contract.Connection.SnapshotCreationReason', false);
Members
Member name | Value | Description
Manual | 0 | A user took the snapshot.
Automatic | 1 | Double-Take automatically took the snapshot.
Scheduled | 2 | Double-Take took the snapshot according to a snapshot schedule.
Deferred | 3 | Double-Take took the snapshot as part of a snapshot scheduled, although it did not occur at the specified interval because the job between the source and target was not in a good state.
DataTest | 4 | Double-Take took the snapshot as part of a test.
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


SnapshotEntry Class

SnapshotEntry Class
Represents a snapshot created by the Windows Volume Snapshot Service.
Inheritance Hierarchy
SystemObject
ObservableObject
DoubleTake.Core.Contract.ConnectionSnapshotEntry

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class SnapshotEntry : ObservableObject,
    IExtensibleDataObject
Public Class SnapshotEntry
    Inherits ObservableObject
    Implements IExtensibleDataObject
public ref class SnapshotEntry : public ObservableObject,
    IExtensibleDataObject
DoubleTake.Core.Contract.Connection.SnapshotEntry = function();

Type.createClass(
    'DoubleTake.Core.Contract.Connection.SnapshotEntry',
    DoubleTake.Common.ComponentModel.ObservableObject,
    IExtensibleDataObject);

The SnapshotEntry type exposes the following members.

Constructors
 | Name | Description
Public method | SnapshotEntry | Initializes a new instance of the SnapshotEntry class
Top
Properties
 | Name | Description
Public property | Comment | This value is any description associated with the snapshot.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Id | This value is the unique ID for the snapshot.
Public property | Reason | This value represents why the snapshot was taken.
Public property | States | This value represents the state of the target associated with the snapshot.
Public property | Timestamp | This value is the time when the snapshot was taken.
Top
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


SnapshotEntry Constructor

SnapshotEntry Constructor
Initializes a new instance of the SnapshotEntry class

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public SnapshotEntry()
Public Sub New
public:
SnapshotEntry()
DoubleTake.Core.Contract.Connection.SnapshotEntry = function();
See Also

Reference

SnapshotEntry Class
DoubleTake.Core.Contract.Connection Namespace


SnapshotEntry Properties

SnapshotEntry Properties

The SnapshotEntry type exposes the following members.

Properties
 | Name | Description
Public property | Comment | This value is any description associated with the snapshot.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Id | This value is the unique ID for the snapshot.
Public property | Reason | This value represents why the snapshot was taken.
Public property | States | This value represents the state of the target associated with the snapshot.
Public property | Timestamp | This value is the time when the snapshot was taken.
Top
See Also

Reference

SnapshotEntry Class
DoubleTake.Core.Contract.Connection Namespace


SnapshotEntry.Comment Property

SnapshotEntryComment Property
This value is any description associated with the snapshot.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Comment { get; set; }
Public Property Comment As String
    Get
    Set
public:
property String^ Comment {
    String^ get ();
    void set (String^ value);
}
function get_Comment();
function set_Comment(value);

Property Value

Type: String
The comment associate with this snapshot.
See Also

Reference

SnapshotEntry Class
DoubleTake.Core.Contract.Connection Namespace


SnapshotEntry.ExtensionData Property

SnapshotEntryExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

SnapshotEntry Class
DoubleTake.Core.Contract.Connection Namespace


SnapshotEntry.Id Property

SnapshotEntryId Property
This value is the unique ID for the snapshot.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Guid Id { get; set; }
Public Property Id As Guid
    Get
    Set
public:
property Guid Id {
    Guid get ();
    void set (Guid value);
}
function get_Id();
function set_Id(value);

Property Value

Type: Guid
The unique identifier of this snapshot.
See Also

Reference

SnapshotEntry Class
DoubleTake.Core.Contract.Connection Namespace


SnapshotEntry.Reason Property

SnapshotEntryReason Property
This value represents why the snapshot was taken.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public SnapshotCreationReason Reason { get; set; }
Public Property Reason As SnapshotCreationReason
    Get
    Set
public:
property SnapshotCreationReason Reason {
    SnapshotCreationReason get ();
    void set (SnapshotCreationReason value);
}
function get_Reason();
function set_Reason(value);

Property Value

Type: SnapshotCreationReason
The reason for taking this snapshot.
See Also

Reference

SnapshotEntry Class
DoubleTake.Core.Contract.Connection Namespace


SnapshotEntry.States Property

SnapshotEntryStates Property
This value represents the state of the target associated with the snapshot.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public TargetStates States { get; set; }
Public Property States As TargetStates
    Get
    Set
public:
property TargetStates States {
    TargetStates get ();
    void set (TargetStates value);
}
function get_States();
function set_States(value);

Property Value

Type: TargetStates
The states of the target server associated with this snapshot.
See Also

Reference

SnapshotEntry Class
DoubleTake.Core.Contract.Connection Namespace


SnapshotEntry.Timestamp Property

SnapshotEntryTimestamp Property
This value is the time when the snapshot was taken.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public DateTimeOffset Timestamp { get; set; }
Public Property Timestamp As DateTimeOffset
    Get
    Set
public:
property DateTimeOffset Timestamp {
    DateTimeOffset get ();
    void set (DateTimeOffset value);
}
function get_Timestamp();
function set_Timestamp(value);

Property Value

Type: DateTimeOffset
The time when this snapshot was taken.
See Also

Reference

SnapshotEntry Class
DoubleTake.Core.Contract.Connection Namespace


SnapshotQuality Enumeration

SnapshotQuality Enumeration

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public enum SnapshotQuality
Public Enumeration SnapshotQuality
public enum class SnapshotQuality
DoubleTake.Core.Contract.Connection.SnapshotQuality = function();
DoubleTake.Core.Contract.Connection.SnapshotQuality.createEnum('DoubleTake.Core.Contract.Connection.SnapshotQuality', false);
Members
Member name | Value | Description
Good | 0 |
Bad | 1 |
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


SnapshotSchedule Class

SnapshotSchedule Class
Inheritance Hierarchy
SystemObject
DoubleTake.Core.Contract.ConnectionScheduleItem
DoubleTake.Core.Contract.ConnectionSnapshotSchedule

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public sealed class SnapshotSchedule : ScheduleItem
Public NotInheritable Class SnapshotSchedule
    Inherits ScheduleItem
public ref class SnapshotSchedule sealed : public ScheduleItem
DoubleTake.Core.Contract.Connection.SnapshotSchedule = function();

Type.createClass(
    'DoubleTake.Core.Contract.Connection.SnapshotSchedule',
    DoubleTake.Core.Contract.Connection.ScheduleItem);

The SnapshotSchedule type exposes the following members.

Constructors
 | Name | Description
Public method | SnapshotSchedule | Initializes a new instance of the SnapshotSchedule class
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from ScheduleItem.)
Public property | Interval | This value is the interval for taking snapshots.
Public property | IsEnabled | (Inherited from ScheduleItem.)
Public property | MaxNumberOfSnapshots | This value is the maximum number of snapshots that will be retained.
Public property | StartTime | This value is the when the snapshot schedule should start.
Top
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


SnapshotSchedule Constructor

SnapshotSchedule Constructor
Initializes a new instance of the SnapshotSchedule class

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public SnapshotSchedule()
Public Sub New
public:
SnapshotSchedule()
DoubleTake.Core.Contract.Connection.SnapshotSchedule = function();
See Also

Reference

SnapshotSchedule Class
DoubleTake.Core.Contract.Connection Namespace


SnapshotSchedule Properties

SnapshotSchedule Properties

The SnapshotSchedule type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from ScheduleItem.)
Public property | Interval | This value is the interval for taking snapshots.
Public property | IsEnabled | (Inherited from ScheduleItem.)
Public property | MaxNumberOfSnapshots | This value is the maximum number of snapshots that will be retained.
Public property | StartTime | This value is the when the snapshot schedule should start.
Top
See Also

Reference

SnapshotSchedule Class
DoubleTake.Core.Contract.Connection Namespace


SnapshotSchedule.Interval Property

SnapshotScheduleInterval Property
This value is the interval for taking snapshots.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public TimeSpan Interval { get; set; }
Public Property Interval As TimeSpan
    Get
    Set
public:
property TimeSpan Interval {
    TimeSpan get ();
    void set (TimeSpan value);
}
function get_Interval();
function set_Interval(value);

Property Value

Type: TimeSpan
See Also

Reference

SnapshotSchedule Class
DoubleTake.Core.Contract.Connection Namespace


SnapshotSchedule.MaxNumberOfSnapshots Property

SnapshotScheduleMaxNumberOfSnapshots Property
This value is the maximum number of snapshots that will be retained.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int MaxNumberOfSnapshots { get; set; }
Public Property MaxNumberOfSnapshots As Integer
    Get
    Set
public:
property int MaxNumberOfSnapshots {
    int get ();
    void set (int value);
}
function get_MaxNumberOfSnapshots();
function set_MaxNumberOfSnapshots(value);

Property Value

Type: Int32
See Also

Reference

SnapshotSchedule Class
DoubleTake.Core.Contract.Connection Namespace


SnapshotSchedule.StartTime Property

SnapshotScheduleStartTime Property
This value is the when the snapshot schedule should start.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public DateTime StartTime { get; set; }
Public Property StartTime As DateTime
    Get
    Set
public:
property DateTime StartTime {
    DateTime get ();
    void set (DateTime value);
}
function get_StartTime();
function set_StartTime(value);

Property Value

Type: DateTime
See Also

Reference

SnapshotSchedule Class
DoubleTake.Core.Contract.Connection Namespace


TargetStateInfo Class

TargetStateInfo Class
Represents an engine connection from the perspective of the target server.
Inheritance Hierarchy
SystemObject
DoubleTake.Core.Contract.ConnectionTargetStateInfo

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class TargetStateInfo : IExtensibleDataObject
Public Class TargetStateInfo
    Implements IExtensibleDataObject
public ref class TargetStateInfo : IExtensibleDataObject
DoubleTake.Core.Contract.Connection.TargetStateInfo = function();

Type.createClass(
    'DoubleTake.Core.Contract.Connection.TargetStateInfo',
    null,
    IExtensibleDataObject);

The TargetStateInfo type exposes the following members.

Constructors
 | Name | Description
Public method | TargetStateInfo | Initializes a new instance of the TargetStateInfo class
Top
Properties
 | Name | Description
Public property | ConnectionId | This value is the unique ID assigned to the connection.
Public property | ConnectTime | This value is the time when the connection was created.
Public property | EngineConnectionId | This value is the unique ID assigned to the replication engine connection.
Public property | EngineJobType | This value is the job type according to the replication engine. (These jobs are not the same as JobInfo.JobType.)
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | HasSnapshotSchedule | This value is true if the connection has a snapshot schedule; otherwise, it is false.
Public property | LastUpdateTime | This value is the last time the target connection information was updated.
Public property | NextScheduledSnapshot | This value is the time of the next scheduled snapshot. This property is only valid when HasSnapshotSchedule is true.
Public property | Paths | This value is the paths of the replica data on the target.
Public property | QueueBytes | This value is the number of bytes in the target queue.
Public property | ReplicationSetName | This value is the name of the protected data set.
Public property | ReplicationSetUsageType | This value defines the possible usage types for the protected data set.
Public property | ScheduledSnapshotInterval | This value is the interval for the scheduled snapshot. This property is only valid when HasSnapshotSchedule is true.
Public property | Snapshots | This value represents the current list of snapshots for the connection.
Public property | SourceEndpoint | This value is the IP endpoint used to communcation with Double-Take on the source.
Public property | SourceEndpointFromSource | This value is the default address for the source server as provided by the source server.
Public property | SourceMachineName | This value is the name of the source server.
Public property | SourceVersion | This value is the Double-Take product version on the source.
Public property | TargetEndpoint | This value is the destination endpoint of the socket connection. If there is a NAT router between the source and target, this value represents the target's private address (translated from the public address). In other words, this will not match the target endpoint specified for the target route of the connection from the source's perspective.
Public property | TargetStates | This values is the state of the target.
Top
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


TargetStateInfo Constructor

TargetStateInfo Constructor
Initializes a new instance of the TargetStateInfo class

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public TargetStateInfo()
Public Sub New
public:
TargetStateInfo()
DoubleTake.Core.Contract.Connection.TargetStateInfo = function();
See Also

Reference

TargetStateInfo Class
DoubleTake.Core.Contract.Connection Namespace


TargetStateInfo Properties

TargetStateInfo Properties

The TargetStateInfo type exposes the following members.

Properties
 | Name | Description
Public property | ConnectionId | This value is the unique ID assigned to the connection.
Public property | ConnectTime | This value is the time when the connection was created.
Public property | EngineConnectionId | This value is the unique ID assigned to the replication engine connection.
Public property | EngineJobType | This value is the job type according to the replication engine. (These jobs are not the same as JobInfo.JobType.)
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | HasSnapshotSchedule | This value is true if the connection has a snapshot schedule; otherwise, it is false.
Public property | LastUpdateTime | This value is the last time the target connection information was updated.
Public property | NextScheduledSnapshot | This value is the time of the next scheduled snapshot. This property is only valid when HasSnapshotSchedule is true.
Public property | Paths | This value is the paths of the replica data on the target.
Public property | QueueBytes | This value is the number of bytes in the target queue.
Public property | ReplicationSetName | This value is the name of the protected data set.
Public property | ReplicationSetUsageType | This value defines the possible usage types for the protected data set.
Public property | ScheduledSnapshotInterval | This value is the interval for the scheduled snapshot. This property is only valid when HasSnapshotSchedule is true.
Public property | Snapshots | This value represents the current list of snapshots for the connection.
Public property | SourceEndpoint | This value is the IP endpoint used to communcation with Double-Take on the source.
Public property | SourceEndpointFromSource | This value is the default address for the source server as provided by the source server.
Public property | SourceMachineName | This value is the name of the source server.
Public property | SourceVersion | This value is the Double-Take product version on the source.
Public property | TargetEndpoint | This value is the destination endpoint of the socket connection. If there is a NAT router between the source and target, this value represents the target's private address (translated from the public address). In other words, this will not match the target endpoint specified for the target route of the connection from the source's perspective.
Public property | TargetStates | This values is the state of the target.
Top
See Also

Reference

TargetStateInfo Class
DoubleTake.Core.Contract.Connection Namespace


TargetStateInfo.ConnectionId Property

TargetStateInfoConnectionId Property
This value is the unique ID assigned to the connection.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Guid ConnectionId { get; set; }
Public Property ConnectionId As Guid
    Get
    Set
public:
property Guid ConnectionId {
    Guid get ();
    void set (Guid value);
}
function get_ConnectionId();
function set_ConnectionId(value);

Property Value

Type: Guid
The unique identifier of the connection.
See Also

Reference

TargetStateInfo Class
DoubleTake.Core.Contract.Connection Namespace


TargetStateInfo.ConnectTime Property

TargetStateInfoConnectTime Property
This value is the time when the connection was created.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public DateTimeOffset ConnectTime { get; set; }
Public Property ConnectTime As DateTimeOffset
    Get
    Set
public:
property DateTimeOffset ConnectTime {
    DateTimeOffset get ();
    void set (DateTimeOffset value);
}
function get_ConnectTime();
function set_ConnectTime(value);

Property Value

Type: DateTimeOffset
The time this connection was created.
See Also

Reference

TargetStateInfo Class
DoubleTake.Core.Contract.Connection Namespace


TargetStateInfo.EngineConnectionId Property

TargetStateInfoEngineConnectionId Property
This value is the unique ID assigned to the replication engine connection.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int EngineConnectionId { get; set; }
Public Property EngineConnectionId As Integer
    Get
    Set
public:
property int EngineConnectionId {
    int get ();
    void set (int value);
}
function get_EngineConnectionId();
function set_EngineConnectionId(value);

Property Value

Type: Int32
The engine connection id.
See Also

Reference

TargetStateInfo Class
DoubleTake.Core.Contract.Connection Namespace


TargetStateInfo.EngineJobType Property

TargetStateInfoEngineJobType Property
This value is the job type according to the replication engine. (These jobs are not the same as JobInfo.JobType.)

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public EngineJobType EngineJobType { get; set; }
Public Property EngineJobType As EngineJobType
    Get
    Set
public:
property EngineJobType EngineJobType {
    EngineJobType get ();
    void set (EngineJobType value);
}
function get_EngineJobType();
function set_EngineJobType(value);

Property Value

Type: EngineJobType
The engine job type of the connection.
See Also

Reference

TargetStateInfo Class
DoubleTake.Core.Contract.Connection Namespace


TargetStateInfo.ExtensionData Property

TargetStateInfoExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

TargetStateInfo Class
DoubleTake.Core.Contract.Connection Namespace


TargetStateInfo.HasSnapshotSchedule Property

TargetStateInfoHasSnapshotSchedule Property
This value is true if the connection has a snapshot schedule; otherwise, it is false.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool HasSnapshotSchedule { get; set; }
Public Property HasSnapshotSchedule As Boolean
    Get
    Set
public:
property bool HasSnapshotSchedule {
    bool get ();
    void set (bool value);
}
function get_HasSnapshotSchedule();
function set_HasSnapshotSchedule(value);

Property Value

Type: Boolean
if the connection has a snapshot schedule; otherwise, .
See Also

Reference

TargetStateInfo Class
DoubleTake.Core.Contract.Connection Namespace


TargetStateInfo.LastUpdateTime Property

TargetStateInfoLastUpdateTime Property
This value is the last time the target connection information was updated.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public DateTimeOffset LastUpdateTime { get; set; }
Public Property LastUpdateTime As DateTimeOffset
    Get
    Set
public:
property DateTimeOffset LastUpdateTime {
    DateTimeOffset get ();
    void set (DateTimeOffset value);
}
function get_LastUpdateTime();
function set_LastUpdateTime(value);

Property Value

Type: DateTimeOffset
The last time this target connection information was updated.
See Also

Reference

TargetStateInfo Class
DoubleTake.Core.Contract.Connection Namespace


TargetStateInfo.NextScheduledSnapshot Property

TargetStateInfoNextScheduledSnapshot Property
This value is the time of the next scheduled snapshot. This property is only valid when HasSnapshotSchedule is true.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public DateTimeOffset NextScheduledSnapshot { get; set; }
Public Property NextScheduledSnapshot As DateTimeOffset
    Get
    Set
public:
property DateTimeOffset NextScheduledSnapshot {
    DateTimeOffset get ();
    void set (DateTimeOffset value);
}
function get_NextScheduledSnapshot();
function set_NextScheduledSnapshot(value);

Property Value

Type: DateTimeOffset
The time of the next scheduled snapshot.
Remarks
This property is only valid when HasSnapshotSchedule is .
See Also

Reference

TargetStateInfo Class
DoubleTake.Core.Contract.Connection Namespace


TargetStateInfo.Paths Property

TargetStateInfoPaths Property
This value is the paths of the replica data on the target.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string[] Paths { get; set; }
Public Property Paths As String()
    Get
    Set
public:
property array<String^>^ Paths {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
function get_Paths();
function set_Paths(value);

Property Value

Type: String
The paths used on the target server.
See Also

Reference

TargetStateInfo Class
DoubleTake.Core.Contract.Connection Namespace


TargetStateInfo.QueueBytes Property

TargetStateInfoQueueBytes Property
This value is the number of bytes in the target queue.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public long QueueBytes { get; set; }
Public Property QueueBytes As Long
    Get
    Set
public:
property long long QueueBytes {
    long long get ();
    void set (long long value);
}
function get_QueueBytes();
function set_QueueBytes(value);

Property Value

Type: Int64
The target queue bytes.
See Also

Reference

TargetStateInfo Class
DoubleTake.Core.Contract.Connection Namespace


TargetStateInfo.ReplicationSetName Property

TargetStateInfoReplicationSetName Property
This value is the name of the protected data set.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string ReplicationSetName { get; set; }
Public Property ReplicationSetName As String
    Get
    Set
public:
property String^ ReplicationSetName {
    String^ get ();
    void set (String^ value);
}
function get_ReplicationSetName();
function set_ReplicationSetName(value);

Property Value

Type: String
The name of the replication set.
See Also

Reference

TargetStateInfo Class
DoubleTake.Core.Contract.Connection Namespace


TargetStateInfo.ReplicationSetUsageType Property

TargetStateInfoReplicationSetUsageType Property
This value defines the possible usage types for the protected data set.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ReplicationSetUsageType ReplicationSetUsageType { get; set; }
Public Property ReplicationSetUsageType As ReplicationSetUsageType
    Get
    Set
public:
property ReplicationSetUsageType ReplicationSetUsageType {
    ReplicationSetUsageType get ();
    void set (ReplicationSetUsageType value);
}
function get_ReplicationSetUsageType();
function set_ReplicationSetUsageType(value);

Property Value

Type: ReplicationSetUsageType
The usage type of the replication set that is connected.
See Also

Reference

TargetStateInfo Class
DoubleTake.Core.Contract.Connection Namespace


TargetStateInfo.ScheduledSnapshotInterval Property

TargetStateInfoScheduledSnapshotInterval Property
This value is the interval for the scheduled snapshot. This property is only valid when HasSnapshotSchedule is true.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public TimeSpan ScheduledSnapshotInterval { get; set; }
Public Property ScheduledSnapshotInterval As TimeSpan
    Get
    Set
public:
property TimeSpan ScheduledSnapshotInterval {
    TimeSpan get ();
    void set (TimeSpan value);
}
function get_ScheduledSnapshotInterval();
function set_ScheduledSnapshotInterval(value);

Property Value

Type: TimeSpan
The scheduled snapshot interval.
Remarks
This is only valid when HasSnapshotSchedule is .
See Also

Reference

TargetStateInfo Class
DoubleTake.Core.Contract.Connection Namespace


TargetStateInfo.Snapshots Property

TargetStateInfoSnapshots Property
This value represents the current list of snapshots for the connection.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public SnapshotEntry[] Snapshots { get; set; }
Public Property Snapshots As SnapshotEntry()
    Get
    Set
public:
property array<SnapshotEntry^>^ Snapshots {
    array<SnapshotEntry^>^ get ();
    void set (array<SnapshotEntry^>^ value);
}
function get_Snapshots();
function set_Snapshots(value);

Property Value

Type: SnapshotEntry
The current list of snapshots taken for this connection.
See Also

Reference

TargetStateInfo Class
DoubleTake.Core.Contract.Connection Namespace


TargetStateInfo.SourceEndpoint Property

TargetStateInfoSourceEndpoint Property
This value is the IP endpoint used to communcation with Double-Take on the source.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string SourceEndpoint { get; set; }
Public Property SourceEndpoint As String
    Get
    Set
public:
property String^ SourceEndpoint {
    String^ get ();
    void set (String^ value);
}
function get_SourceEndpoint();
function set_SourceEndpoint(value);

Property Value

Type: String
The source endpoint.
See Also

Reference

TargetStateInfo Class
DoubleTake.Core.Contract.Connection Namespace


TargetStateInfo.SourceEndpointFromSource Property

TargetStateInfoSourceEndpointFromSource Property
This value is the default address for the source server as provided by the source server.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string SourceEndpointFromSource { get; set; }
Public Property SourceEndpointFromSource As String
    Get
    Set
public:
property String^ SourceEndpointFromSource {
    String^ get ();
    void set (String^ value);
}
function get_SourceEndpointFromSource();
function set_SourceEndpointFromSource(value);

Property Value

Type: String
The default address for the source server as provided by the source server.
See Also

Reference

TargetStateInfo Class
DoubleTake.Core.Contract.Connection Namespace


TargetStateInfo.SourceMachineName Property

TargetStateInfoSourceMachineName Property
This value is the name of the source server.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string SourceMachineName { get; set; }
Public Property SourceMachineName As String
    Get
    Set
public:
property String^ SourceMachineName {
    String^ get ();
    void set (String^ value);
}
function get_SourceMachineName();
function set_SourceMachineName(value);

Property Value

Type: String
The name of the source machine.
See Also

Reference

TargetStateInfo Class
DoubleTake.Core.Contract.Connection Namespace


TargetStateInfo.SourceVersion Property

TargetStateInfoSourceVersion Property
This value is the Double-Take product version on the source.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ProductVersion SourceVersion { get; set; }
Public Property SourceVersion As ProductVersion
    Get
    Set
public:
property ProductVersion^ SourceVersion {
    ProductVersion^ get ();
    void set (ProductVersion^ value);
}
function get_SourceVersion();
function set_SourceVersion(value);

Property Value

Type: ProductVersion
The product version of the source machine.
See Also

Reference

TargetStateInfo Class
DoubleTake.Core.Contract.Connection Namespace


TargetStateInfo.TargetEndpoint Property

TargetStateInfoTargetEndpoint Property
This value is the destination endpoint of the socket connection. If there is a NAT router between the source and target, this value represents the target's private address (translated from the public address). In other words, this will not match the target endpoint specified for the target route of the connection from the source's perspective.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string TargetEndpoint { get; set; }
Public Property TargetEndpoint As String
    Get
    Set
public:
property String^ TargetEndpoint {
    String^ get ();
    void set (String^ value);
}
function get_TargetEndpoint();
function set_TargetEndpoint(value);

Property Value

Type: String
The destination endpoint of the socket connection.
Remarks
When there is a NAT firewall between the source and the target, this represents the target's private address (translated from the public address). In other words, this will not match the target endpoint specified for the target route of the connection from the source's perspective.
See Also

Reference

TargetStateInfo Class
DoubleTake.Core.Contract.Connection Namespace


TargetStateInfo.TargetStates Property

TargetStateInfoTargetStates Property
This values is the state of the target.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public TargetStates TargetStates { get; set; }
Public Property TargetStates As TargetStates
    Get
    Set
public:
property TargetStates TargetStates {
    TargetStates get ();
    void set (TargetStates value);
}
function get_TargetStates();
function set_TargetStates(value);

Property Value

Type: TargetStates
The target states.
See Also

Reference

TargetStateInfo Class
DoubleTake.Core.Contract.Connection Namespace


TargetStates Enumeration

TargetStates Enumeration
Represent possible states of the target server.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public enum TargetStates
Public Enumeration TargetStates
public enum class TargetStates
DoubleTake.Core.Contract.Connection.TargetStates = function();
DoubleTake.Core.Contract.Connection.TargetStates.createEnum('DoubleTake.Core.Contract.Connection.TargetStates', false);
Members
Member name | Value | Description
Good | 0 | The target is in a good state.
Mirroring | 1 | Mirroring is in progress.
MirrorStopped | 2 | Mirroring was stopped. A remirror should be performed.
OpDropped | 4 | The target detected than an operation was dropped on the network. A remirror should be performed.
Retrying | 8 | The target is retrying a write operation.
Paused | 16 | Writing to the target server has been paused by the user.
PausePending | 32 | Writing to the target server has been paused by the user.
RestoreRequired | 64 | The data on the source and target may not be synchronized because of a failover condition. This state will remain until a restore or remirror is completed.
ReplicationPending | 128 | The connection has been established and replication is enabled, but the first replication operation has not been transmitted yet.
SnapshotReverted | 256 | The data on the source and target may not be synchronized because a snapshot was applied on the target. This state will remain until a restore or remirror is completed.
FailoverUnblocked | 512 | This property is no longer used.
Disconnected | 1024 | The target server cannot be contacted.
SroImage | 2048 | The target server contains a Double-Take DR protection image.
FailoverMonitoring | 4096 | The target is monitoring the source for a failure.
TransactionsPending | 8192 | There are transactional NTFS (TxF) operations pending.
GCReplicationComplete | 16384 | GeoCluster replication is complete.
MarkedForDeletion | 32768 | The connection is marked for deletion when the source comes back online.
JobNotReadyOnTarget | 65536 | The target server may not be ready to resume transmission, for example due to disks being offline.
TargetPathBlocked | 2147483648 | Writing to the replica path location on the target is blocked.
Unknown | -4294967296 | The target state cannot be determined.
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


TaskParameters Class

TaskParameters Class
Specifies a script or executable to be run along with its corresponding command-line arguments.
Inheritance Hierarchy
SystemObject
DoubleTake.Core.Contract.ConnectionTaskParameters

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class TaskParameters : IExtensibleDataObject
Public Class TaskParameters
    Implements IExtensibleDataObject
public ref class TaskParameters : IExtensibleDataObject
DoubleTake.Core.Contract.Connection.TaskParameters = function();

Type.createClass(
    'DoubleTake.Core.Contract.Connection.TaskParameters',
    null,
    IExtensibleDataObject);

The TaskParameters type exposes the following members.

Constructors
 | Name | Description
Public method | TaskParameters | Initializes a new instance of the TaskParameters class
Top
Properties
 | Name | Description
Public property | Arguments | This value is a comma-separated list of valid arguments required to execute the script.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Script | This value is the full path and file name of the script.
Top
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


TaskParameters Constructor

TaskParameters Constructor
Initializes a new instance of the TaskParameters class

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public TaskParameters()
Public Sub New
public:
TaskParameters()
DoubleTake.Core.Contract.Connection.TaskParameters = function();
See Also

Reference

TaskParameters Class
DoubleTake.Core.Contract.Connection Namespace


TaskParameters Properties

TaskParameters Properties

The TaskParameters type exposes the following members.

Properties
 | Name | Description
Public property | Arguments | This value is a comma-separated list of valid arguments required to execute the script.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Script | This value is the full path and file name of the script.
Top
See Also

Reference

TaskParameters Class
DoubleTake.Core.Contract.Connection Namespace


TaskParameters.Arguments Property

TaskParametersArguments Property
This value is a comma-separated list of valid arguments required to execute the script.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Arguments { get; set; }
Public Property Arguments As String
    Get
    Set
public:
property String^ Arguments {
    String^ get ();
    void set (String^ value);
}
function get_Arguments();
function set_Arguments(value);

Property Value

Type: String
The command-line arguments.
See Also

Reference

TaskParameters Class
DoubleTake.Core.Contract.Connection Namespace


TaskParameters.ExtensionData Property

TaskParametersExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The structure that contains extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

TaskParameters Class
DoubleTake.Core.Contract.Connection Namespace


TaskParameters.Script Property

TaskParametersScript Property
This value is the full path and file name of the script.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Script { get; set; }
Public Property Script As String
    Get
    Set
public:
property String^ Script {
    String^ get ();
    void set (String^ value);
}
function get_Script();
function set_Script(value);

Property Value

Type: String
See Also

Reference

TaskParameters Class
DoubleTake.Core.Contract.Connection Namespace


TimeWindow Class

TimeWindow Class
Inheritance Hierarchy
SystemObject
ObservableObject
DoubleTake.Core.Contract.ConnectionTimeWindow

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public sealed class TimeWindow : ObservableObject,
    IExtensibleDataObject
Public NotInheritable Class TimeWindow
    Inherits ObservableObject
    Implements IExtensibleDataObject
public ref class TimeWindow sealed : public ObservableObject,
    IExtensibleDataObject
DoubleTake.Core.Contract.Connection.TimeWindow = function();

Type.createClass(
    'DoubleTake.Core.Contract.Connection.TimeWindow',
    DoubleTake.Common.ComponentModel.ObservableObject,
    IExtensibleDataObject);

The TimeWindow type exposes the following members.

Constructors
 | Name | Description
Public method | TimeWindow | Initializes a new instance of the TimeWindow class
Top
Properties
 | Name | Description
Public property | Duration |
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Start |
Top
Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Top
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


TimeWindow Constructor

TimeWindow Constructor
Initializes a new instance of the TimeWindow class

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public TimeWindow()
Public Sub New
public:
TimeWindow()
DoubleTake.Core.Contract.Connection.TimeWindow = function();
See Also

Reference

TimeWindow Class
DoubleTake.Core.Contract.Connection Namespace


TimeWindow Properties

TimeWindow Properties

The TimeWindow type exposes the following members.

Properties
 | Name | Description
Public property | Duration |
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Start |
Top
See Also

Reference

TimeWindow Class
DoubleTake.Core.Contract.Connection Namespace


TimeWindow.Duration Property

TimeWindowDuration Property

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public TimeSpan Duration { get; set; }
Public Property Duration As TimeSpan
    Get
    Set
public:
property TimeSpan Duration {
    TimeSpan get ();
    void set (TimeSpan value);
}
function get_Duration();
function set_Duration(value);

Property Value

Type: TimeSpan
See Also

Reference

TimeWindow Class
DoubleTake.Core.Contract.Connection Namespace


TimeWindow.ExtensionData Property

TimeWindowExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

TimeWindow Class
DoubleTake.Core.Contract.Connection Namespace


TimeWindow.Start Property

TimeWindowStart Property

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public DateTime Start { get; set; }
Public Property Start As DateTime
    Get
    Set
public:
property DateTime Start {
    DateTime get ();
    void set (DateTime value);
}
function get_Start();
function set_Start(value);

Property Value

Type: DateTime
See Also

Reference

TimeWindow Class
DoubleTake.Core.Contract.Connection Namespace


TimeWindow Methods

TimeWindow Methods

The TimeWindow type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Top
See Also

Reference

TimeWindow Class
DoubleTake.Core.Contract.Connection Namespace


TimeWindow.Clone Method

TimeWindowClone Method
Creates a new object that is a copy of the current instance.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
function Clone();

Return Value

Type: Object
A new object that is a copy of this instance.
See Also

Reference

TimeWindow Class
DoubleTake.Core.Contract.Connection Namespace


TransmissionMode Enumeration

TransmissionMode Enumeration
The operational state of data transmission from the source to target server.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public enum TransmissionMode
Public Enumeration TransmissionMode
public enum class TransmissionMode
DoubleTake.Core.Contract.Connection.TransmissionMode = function();
DoubleTake.Core.Contract.Connection.TransmissionMode.createEnum('DoubleTake.Core.Contract.Connection.TransmissionMode', false);
Members
Member name | Value | Description
Error | 0 | Transmission is in an error state.
Paused | 1 | Transmission is paused.
Started | 2 | Transmission is active.
Scheduled | 3 | Transmission is pending a schedule.
Stopped | 4 | Transmission is stopped.
Unknown | 5 | Transmission is unknown.
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


TransmissionSchedule Class

TransmissionSchedule Class
Inheritance Hierarchy
SystemObject
DoubleTake.Core.Contract.ConnectionScheduleItem
DoubleTake.Core.Contract.ConnectionTransmissionSchedule

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public sealed class TransmissionSchedule : ScheduleItem
Public NotInheritable Class TransmissionSchedule
    Inherits ScheduleItem
public ref class TransmissionSchedule sealed : public ScheduleItem
DoubleTake.Core.Contract.Connection.TransmissionSchedule = function();

Type.createClass(
    'DoubleTake.Core.Contract.Connection.TransmissionSchedule',
    DoubleTake.Core.Contract.Connection.ScheduleItem);

The TransmissionSchedule type exposes the following members.

Constructors
 | Name | Description
Public method | TransmissionSchedule | Initializes a new instance of the TransmissionSchedule class
Top
Properties
 | Name | Description
Public property | Duration |
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from ScheduleItem.)
Public property | Interval |
Public property | IsEnabled | (Inherited from ScheduleItem.)
Public property | MaxBytes |
Public property | StartTime |
Public property | ThresholdBytes |
Public property | ThresholdPercentage |
Public property | Window |
Top
Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Top
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


TransmissionSchedule Constructor

TransmissionSchedule Constructor
Initializes a new instance of the TransmissionSchedule class

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public TransmissionSchedule()
Public Sub New
public:
TransmissionSchedule()
DoubleTake.Core.Contract.Connection.TransmissionSchedule = function();
See Also

Reference

TransmissionSchedule Class
DoubleTake.Core.Contract.Connection Namespace


TransmissionSchedule Properties

TransmissionSchedule Properties

The TransmissionSchedule type exposes the following members.

Properties
 | Name | Description
Public property | Duration |
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from ScheduleItem.)
Public property | Interval |
Public property | IsEnabled | (Inherited from ScheduleItem.)
Public property | MaxBytes |
Public property | StartTime |
Public property | ThresholdBytes |
Public property | ThresholdPercentage |
Public property | Window |
Top
See Also

Reference

TransmissionSchedule Class
DoubleTake.Core.Contract.Connection Namespace


TransmissionSchedule.Duration Property

TransmissionScheduleDuration Property

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Nullable<TimeSpan> Duration { get; set; }
Public Property Duration As Nullable(Of TimeSpan)
    Get
    Set
public:
property Nullable<TimeSpan> Duration {
    Nullable<TimeSpan> get ();
    void set (Nullable<TimeSpan> value);
}
function get_Duration();
function set_Duration(value);

Property Value

Type: Nullable TimeSpan
See Also

Reference

TransmissionSchedule Class
DoubleTake.Core.Contract.Connection Namespace


TransmissionSchedule.Interval Property

TransmissionScheduleInterval Property

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Nullable<TimeSpan> Interval { get; set; }
Public Property Interval As Nullable(Of TimeSpan)
    Get
    Set
public:
property Nullable<TimeSpan> Interval {
    Nullable<TimeSpan> get ();
    void set (Nullable<TimeSpan> value);
}
function get_Interval();
function set_Interval(value);

Property Value

Type: Nullable TimeSpan
See Also

Reference

TransmissionSchedule Class
DoubleTake.Core.Contract.Connection Namespace


TransmissionSchedule.MaxBytes Property

TransmissionScheduleMaxBytes Property

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Nullable<long> MaxBytes { get; set; }
Public Property MaxBytes As Nullable(Of Long)
    Get
    Set
public:
property Nullable<long long> MaxBytes {
    Nullable<long long> get ();
    void set (Nullable<long long> value);
}
function get_MaxBytes();
function set_MaxBytes(value);

Property Value

Type: Nullable Int64
See Also

Reference

TransmissionSchedule Class
DoubleTake.Core.Contract.Connection Namespace


TransmissionSchedule.StartTime Property

TransmissionScheduleStartTime Property

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Nullable<DateTime> StartTime { get; set; }
Public Property StartTime As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> StartTime {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
function get_StartTime();
function set_StartTime(value);

Property Value

Type: Nullable DateTime
See Also

Reference

TransmissionSchedule Class
DoubleTake.Core.Contract.Connection Namespace


TransmissionSchedule.ThresholdBytes Property

TransmissionScheduleThresholdBytes Property

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Nullable<long> ThresholdBytes { get; set; }
Public Property ThresholdBytes As Nullable(Of Long)
    Get
    Set
public:
property Nullable<long long> ThresholdBytes {
    Nullable<long long> get ();
    void set (Nullable<long long> value);
}
function get_ThresholdBytes();
function set_ThresholdBytes(value);

Property Value

Type: Nullable Int64
See Also

Reference

TransmissionSchedule Class
DoubleTake.Core.Contract.Connection Namespace


TransmissionSchedule.ThresholdPercentage Property

TransmissionScheduleThresholdPercentage Property

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Nullable<long> ThresholdPercentage { get; set; }
Public Property ThresholdPercentage As Nullable(Of Long)
    Get
    Set
public:
property Nullable<long long> ThresholdPercentage {
    Nullable<long long> get ();
    void set (Nullable<long long> value);
}
function get_ThresholdPercentage();
function set_ThresholdPercentage(value);

Property Value

Type: Nullable Int64
See Also

Reference

TransmissionSchedule Class
DoubleTake.Core.Contract.Connection Namespace


TransmissionSchedule.Window Property

TransmissionScheduleWindow Property

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public TimeWindow Window { get; set; }
Public Property Window As TimeWindow
    Get
    Set
public:
property TimeWindow^ Window {
    TimeWindow^ get ();
    void set (TimeWindow^ value);
}
function get_Window();
function set_Window(value);

Property Value

Type: TimeWindow
See Also

Reference

TransmissionSchedule Class
DoubleTake.Core.Contract.Connection Namespace


TransmissionSchedule Methods

TransmissionSchedule Methods

The TransmissionSchedule type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Top
See Also

Reference

TransmissionSchedule Class
DoubleTake.Core.Contract.Connection Namespace


TransmissionSchedule.Clone Method

TransmissionScheduleClone Method
Creates a new object that is a copy of the current instance.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
function Clone();

Return Value

Type: Object
A new object that is a copy of this instance.
See Also

Reference

TransmissionSchedule Class
DoubleTake.Core.Contract.Connection Namespace


VerifySchedule Class

VerifySchedule Class
Inheritance Hierarchy
SystemObject
DoubleTake.Core.Contract.ConnectionScheduleItem
DoubleTake.Core.Contract.ConnectionVerifySchedule

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public sealed class VerifySchedule : ScheduleItem
Public NotInheritable Class VerifySchedule
    Inherits ScheduleItem
public ref class VerifySchedule sealed : public ScheduleItem
DoubleTake.Core.Contract.Connection.VerifySchedule = function();

Type.createClass(
    'DoubleTake.Core.Contract.Connection.VerifySchedule',
    DoubleTake.Core.Contract.Connection.ScheduleItem);

The VerifySchedule type exposes the following members.

Constructors
 | Name | Description
Public method | VerifySchedule | Initializes a new instance of the VerifySchedule class
Top
Properties
 | Name | Description
Public property | Criteria | This value represents how to compare the source protected data and the replica on the target.
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from ScheduleItem.)
Public property | Interval | This value is the interval for taking snapshots.
Public property | IsEnabled | (Inherited from ScheduleItem.)
Public property | Options | This value represents what mirror operation will be performed.
Public property | StartTime | This value is the when the verification schedule should start.
Top
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


VerifySchedule Constructor

VerifySchedule Constructor
Initializes a new instance of the VerifySchedule class

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VerifySchedule()
Public Sub New
public:
VerifySchedule()
DoubleTake.Core.Contract.Connection.VerifySchedule = function();
See Also

Reference

VerifySchedule Class
DoubleTake.Core.Contract.Connection Namespace


VerifySchedule Properties

VerifySchedule Properties

The VerifySchedule type exposes the following members.

Properties
 | Name | Description
Public property | Criteria | This value represents how to compare the source protected data and the replica on the target.
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from ScheduleItem.)
Public property | Interval | This value is the interval for taking snapshots.
Public property | IsEnabled | (Inherited from ScheduleItem.)
Public property | Options | This value represents what mirror operation will be performed.
Public property | StartTime | This value is the when the verification schedule should start.
Top
See Also

Reference

VerifySchedule Class
DoubleTake.Core.Contract.Connection Namespace


VerifySchedule.Criteria Property

VerifyScheduleCriteria Property
This value represents how to compare the source protected data and the replica on the target.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public MirrorComparisonCriteria Criteria { get; set; }
Public Property Criteria As MirrorComparisonCriteria
    Get
    Set
public:
property MirrorComparisonCriteria Criteria {
    MirrorComparisonCriteria get ();
    void set (MirrorComparisonCriteria value);
}
function get_Criteria();
function set_Criteria(value);

Property Value

Type: MirrorComparisonCriteria
See Also

Reference

VerifySchedule Class
DoubleTake.Core.Contract.Connection Namespace


VerifySchedule.Interval Property

VerifyScheduleInterval Property
This value is the interval for taking snapshots.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public TimeSpan Interval { get; set; }
Public Property Interval As TimeSpan
    Get
    Set
public:
property TimeSpan Interval {
    TimeSpan get ();
    void set (TimeSpan value);
}
function get_Interval();
function set_Interval(value);

Property Value

Type: TimeSpan
See Also

Reference

VerifySchedule Class
DoubleTake.Core.Contract.Connection Namespace


VerifySchedule.Options Property

VerifyScheduleOptions Property
This value represents what mirror operation will be performed.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public MirrorOperationOptions Options { get; set; }
Public Property Options As MirrorOperationOptions
    Get
    Set
public:
property MirrorOperationOptions Options {
    MirrorOperationOptions get ();
    void set (MirrorOperationOptions value);
}
function get_Options();
function set_Options(value);

Property Value

Type: MirrorOperationOptions
See Also

Reference

VerifySchedule Class
DoubleTake.Core.Contract.Connection Namespace


VerifySchedule.StartTime Property

VerifyScheduleStartTime Property
This value is the when the verification schedule should start.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public DateTime StartTime { get; set; }
Public Property StartTime As DateTime
    Get
    Set
public:
property DateTime StartTime {
    DateTime get ();
    void set (DateTime value);
}
function get_StartTime();
function set_StartTime(value);

Property Value

Type: DateTime
See Also

Reference

VerifySchedule Class
DoubleTake.Core.Contract.Connection Namespace


Weekdays Enumeration

Weekdays Enumeration
Defines the days of the week and common combinations of weekdays.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public enum Weekdays
Public Enumeration Weekdays
public enum class Weekdays
DoubleTake.Core.Contract.Connection.Weekdays = function();
DoubleTake.Core.Contract.Connection.Weekdays.createEnum('DoubleTake.Core.Contract.Connection.Weekdays', false);
Members
Member name | Value | Description
None | 0 | No days of the week are specified.
Sunday | 1 | Sunday is specified.
Monday | 2 | Monday is specified.
Tuesday | 4 | Tuesday is specified.
Wednesday | 8 | Wednesday is specified.
Thursday | 16 | Thursday is specified.
Friday | 32 | Friday is specified.
Saturday | 64 | Saturday is specified.
Weekends | 65 | Saturday and Sunday are specified.
Workdays | 62 | Monday, Tuesday, Wednesday, Thursday, and Friday are specified.
All | 127 | All days of the week are specified.
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


DoubleTake.Core.Contract.Job Namespace

DoubleTake.Core.Contract.Job Namespace
Classes
 | Class | Description
Public class | JobInfo | Used for storing the status information for a job. It tells you whether or not the job is started. If it is started, it provides the status information for each connection that is associated with this job.
Public class | JobParameters |
Public class | JobSourceInfo | Used to get the status of one or more connections that relate to a specific job. If the Guid is empty, the connection(s) is/are not related to a job.


JobInfo Class

JobInfo Class
Used for storing the status information for a job. It tells you whether or not the job is started. If it is started, it provides the status information for each connection that is associated with this job.
Inheritance Hierarchy
SystemObject
ObservableObject
DoubleTake.Core.Contract.JobJobInfo

Namespace: DoubleTake.Core.Contract.Job
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class JobInfo : ObservableObject, IExtensibleDataObject
Public Class JobInfo
    Inherits ObservableObject
    Implements IExtensibleDataObject
public ref class JobInfo : public ObservableObject,
    IExtensibleDataObject
DoubleTake.Core.Contract.Job.JobInfo = function();

Type.createClass(
    'DoubleTake.Core.Contract.Job.JobInfo',
    DoubleTake.Common.ComponentModel.ObservableObject,
    IExtensibleDataObject);

The JobInfo type exposes the following members.

Constructors
 | Name | Description
Public method | JobInfo | Initializes a new instance of the JobInfo class
Top
Properties
 | Name | Description
Public property | ConnectionInfo | Gets or sets the connection info array.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Guid | Gets or sets the GUID.
Public property | IsStarted | Gets or sets a value indicating whether this job is started.
Public property | Parameters | Gets or sets the parameters.
Public property | SourceAddress | Gets or sets the source address that the job host is using to talk to the source of this job.
Top
See Also

Reference

DoubleTake.Core.Contract.Job Namespace


JobInfo Constructor

JobInfo Constructor
Initializes a new instance of the JobInfo class

Namespace: DoubleTake.Core.Contract.Job
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public JobInfo()
Public Sub New
public:
JobInfo()
DoubleTake.Core.Contract.Job.JobInfo = function();
See Also

Reference

JobInfo Class
DoubleTake.Core.Contract.Job Namespace


JobInfo Properties

JobInfo Properties

The JobInfo type exposes the following members.

Properties
 | Name | Description
Public property | ConnectionInfo | Gets or sets the connection info array.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Guid | Gets or sets the GUID.
Public property | IsStarted | Gets or sets a value indicating whether this job is started.
Public property | Parameters | Gets or sets the parameters.
Public property | SourceAddress | Gets or sets the source address that the job host is using to talk to the source of this job.
Top
See Also

Reference

JobInfo Class
DoubleTake.Core.Contract.Job Namespace


JobInfo.ConnectionInfo Property

JobInfoConnectionInfo Property
Gets or sets the connection info array.

Namespace: DoubleTake.Core.Contract.Job
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ConnectionInfo[] ConnectionInfo { get; set; }
Public Property ConnectionInfo As ConnectionInfo()
    Get
    Set
public:
property array<ConnectionInfo^>^ ConnectionInfo {
    array<ConnectionInfo^>^ get ();
    void set (array<ConnectionInfo^>^ value);
}
function get_ConnectionInfo();
function set_ConnectionInfo(value);

Property Value

Type: ConnectionInfo
The connection info array.
See Also

Reference

JobInfo Class
DoubleTake.Core.Contract.Job Namespace


JobInfo.ExtensionData Property

JobInfoExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract.Job
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

JobInfo Class
DoubleTake.Core.Contract.Job Namespace


JobInfo.Guid Property

JobInfoGuid Property
Gets or sets the GUID.

Namespace: DoubleTake.Core.Contract.Job
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Guid Guid { get; set; }
Public Property Guid As Guid
    Get
    Set
public:
property Guid Guid {
    Guid get ();
    void set (Guid value);
}
function get_Guid();
function set_Guid(value);

Property Value

Type: Guid
The GUID.
Remarks
This data contract is new to 5.2.1. It is not used in 5.2.0.
See Also

Reference

JobInfo Class
DoubleTake.Core.Contract.Job Namespace


JobInfo.IsStarted Property

JobInfoIsStarted Property
Gets or sets a value indicating whether this job is started.

Namespace: DoubleTake.Core.Contract.Job
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsStarted { get; set; }
Public Property IsStarted As Boolean
    Get
    Set
public:
property bool IsStarted {
    bool get ();
    void set (bool value);
}
function get_IsStarted();
function set_IsStarted(value);

Property Value

Type: Boolean
true if this job is started; otherwise, false.
See Also

Reference

JobInfo Class
DoubleTake.Core.Contract.Job Namespace


JobInfo.Parameters Property

JobInfoParameters Property
Gets or sets the parameters.

Namespace: DoubleTake.Core.Contract.Job
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public JobParameters Parameters { get; set; }
Public Property Parameters As JobParameters
    Get
    Set
public:
property JobParameters^ Parameters {
    JobParameters^ get ();
    void set (JobParameters^ value);
}
function get_Parameters();
function set_Parameters(value);

Property Value

Type: JobParameters
The parameters.
See Also

Reference

JobInfo Class
DoubleTake.Core.Contract.Job Namespace


JobInfo.SourceAddress Property

JobInfoSourceAddress Property
Gets or sets the source address that the job host is using to talk to the source of this job.

Namespace: DoubleTake.Core.Contract.Job
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public UnicastIPAddressInfo SourceAddress { get; set; }
Public Property SourceAddress As UnicastIPAddressInfo
    Get
    Set
public:
property UnicastIPAddressInfo^ SourceAddress {
    UnicastIPAddressInfo^ get ();
    void set (UnicastIPAddressInfo^ value);
}
function get_SourceAddress();
function set_SourceAddress(value);

Property Value

Type: UnicastIPAddressInfo
The source address.
See Also

Reference

JobInfo Class
DoubleTake.Core.Contract.Job Namespace


JobParameters Class

JobParameters Class
Inheritance Hierarchy
SystemObject
DoubleTake.Core.Contract.JobJobParameters

Namespace: DoubleTake.Core.Contract.Job
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class JobParameters : IExtensibleDataObject
Public Class JobParameters
    Implements IExtensibleDataObject
public ref class JobParameters : IExtensibleDataObject
DoubleTake.Core.Contract.Job.JobParameters = function();

Type.createClass(
    'DoubleTake.Core.Contract.Job.JobParameters',
    null,
    IExtensibleDataObject);

The JobParameters type exposes the following members.

Constructors
 | Name | Description
Public method | JobParameters | Initializes a new instance of the JobParameters class
Top
Properties
 | Name | Description
Public property | ConnectionStartParameters | Gets or sets the connection start parameters.
Public property | EngineJobType | Gets or sets the engine job type.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | JobType | Gets or sets the the job type.
Public property | Monitor | The configuration of a monitor that is to be utilized for this job if it is to be an Availability job.
Public property | PathTransformations | Gets or sets the path transformations. These tell the service where on the target to mirror and replicate the data from where on the source. There must be at least one PathTransformation for each volume referenced in the workload rules.
Public property | Properties |
Public property | SourceAddresses | Gets or sets the source addresses.
Public property | TargetAddress | Gets or sets the target address over which the data will be mirrored and replicated from the source.
Public property | WorkloadRules | Gets or sets the workload rules. These rules define what data will be mirrored and replicated by this job.
Public property | WorkloadType | The type of workload to create. See Create
Top
See Also

Reference

DoubleTake.Core.Contract.Job Namespace


JobParameters Constructor

JobParameters Constructor
Initializes a new instance of the JobParameters class

Namespace: DoubleTake.Core.Contract.Job
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public JobParameters()
Public Sub New
public:
JobParameters()
DoubleTake.Core.Contract.Job.JobParameters = function();
See Also

Reference

JobParameters Class
DoubleTake.Core.Contract.Job Namespace


JobParameters Properties

JobParameters Properties

The JobParameters type exposes the following members.

Properties
 | Name | Description
Public property | ConnectionStartParameters | Gets or sets the connection start parameters.
Public property | EngineJobType | Gets or sets the engine job type.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | JobType | Gets or sets the the job type.
Public property | Monitor | The configuration of a monitor that is to be utilized for this job if it is to be an Availability job.
Public property | PathTransformations | Gets or sets the path transformations. These tell the service where on the target to mirror and replicate the data from where on the source. There must be at least one PathTransformation for each volume referenced in the workload rules.
Public property | Properties |
Public property | SourceAddresses | Gets or sets the source addresses.
Public property | TargetAddress | Gets or sets the target address over which the data will be mirrored and replicated from the source.
Public property | WorkloadRules | Gets or sets the workload rules. These rules define what data will be mirrored and replicated by this job.
Public property | WorkloadType | The type of workload to create. See Create
Top
See Also

Reference

JobParameters Class
DoubleTake.Core.Contract.Job Namespace


JobParameters.ConnectionStartParameters Property

JobParametersConnectionStartParameters Property
Gets or sets the connection start parameters.

Namespace: DoubleTake.Core.Contract.Job
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ConnectionStartParameters ConnectionStartParameters { get; set; }
Public Property ConnectionStartParameters As ConnectionStartParameters
    Get
    Set
public:
property ConnectionStartParameters^ ConnectionStartParameters {
    ConnectionStartParameters^ get ();
    void set (ConnectionStartParameters^ value);
}
function get_ConnectionStartParameters();
function set_ConnectionStartParameters(value);

Property Value

Type: ConnectionStartParameters
The connection start parameters.
See Also

Reference

JobParameters Class
DoubleTake.Core.Contract.Job Namespace


JobParameters.EngineJobType Property

JobParametersEngineJobType Property
Gets or sets the engine job type.

Namespace: DoubleTake.Core.Contract.Job
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public EngineJobType EngineJobType { get; set; }
Public Property EngineJobType As EngineJobType
    Get
    Set
public:
property EngineJobType EngineJobType {
    EngineJobType get ();
    void set (EngineJobType value);
}
function get_EngineJobType();
function set_EngineJobType(value);

Property Value

Type: EngineJobType
The engine job type.
See Also

Reference

JobParameters Class
DoubleTake.Core.Contract.Job Namespace


JobParameters.ExtensionData Property

JobParametersExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract.Job
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

JobParameters Class
DoubleTake.Core.Contract.Job Namespace


JobParameters.JobType Property

JobParametersJobType Property
Gets or sets the the job type.

Namespace: DoubleTake.Core.Contract.Job
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string JobType { get; set; }
Public Property JobType As String
    Get
    Set
public:
property String^ JobType {
    String^ get ();
    void set (String^ value);
}
function get_JobType();
function set_JobType(value);

Property Value

Type: String
The the job type.
See Also

Reference

JobParameters Class
DoubleTake.Core.Contract.Job Namespace


JobParameters.Monitor Property

JobParametersMonitor Property
The configuration of a monitor that is to be utilized for this job if it is to be an Availability job.

Namespace: DoubleTake.Core.Contract.Job
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public MonitorConfiguration Monitor { get; set; }
Public Property Monitor As MonitorConfiguration
    Get
    Set
public:
property MonitorConfiguration^ Monitor {
    MonitorConfiguration^ get ();
    void set (MonitorConfiguration^ value);
}
function get_Monitor();
function set_Monitor(value);

Property Value

Type: MonitorConfiguration
See Also

Reference

JobParameters Class
DoubleTake.Core.Contract.Job Namespace


JobParameters.PathTransformations Property

JobParametersPathTransformations Property
Gets or sets the path transformations. These tell the service where on the target to mirror and replicate the data from where on the source. There must be at least one PathTransformation for each volume referenced in the workload rules.

Namespace: DoubleTake.Core.Contract.Job
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public PathTransformation[] PathTransformations { get; set; }
Public Property PathTransformations As PathTransformation()
    Get
    Set
public:
property array<PathTransformation^>^ PathTransformations {
    array<PathTransformation^>^ get ();
    void set (array<PathTransformation^>^ value);
}
function get_PathTransformations();
function set_PathTransformations(value);

Property Value

Type: PathTransformation
The path transformations.
See Also

Reference

JobParameters Class
DoubleTake.Core.Contract.Job Namespace


JobParameters.Properties Property

JobParametersProperties Property

Namespace: DoubleTake.Core.Contract.Job
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Property[] Properties { get; set; }
Public Property Properties As Property()
    Get
    Set
public:
property array<Property^>^ Properties {
    array<Property^>^ get ();
    void set (array<Property^>^ value);
}
function get_Properties();
function set_Properties(value);

Property Value

Type: Property
See Also

Reference

JobParameters Class
DoubleTake.Core.Contract.Job Namespace


JobParameters.SourceAddresses Property

JobParametersSourceAddresses Property
Gets or sets the source addresses.

Namespace: DoubleTake.Core.Contract.Job
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public UnicastIPAddressInfo[] SourceAddresses { get; set; }
Public Property SourceAddresses As UnicastIPAddressInfo()
    Get
    Set
public:
property array<UnicastIPAddressInfo^>^ SourceAddresses {
    array<UnicastIPAddressInfo^>^ get ();
    void set (array<UnicastIPAddressInfo^>^ value);
}
function get_SourceAddresses();
function set_SourceAddresses(value);

Property Value

Type: UnicastIPAddressInfo
The source addresses.
Remarks
These addresses are used by the Management Service on the job host to communicate with the source. If there is a NAT firewall in between the source and the target
See Also

Reference

JobParameters Class
DoubleTake.Core.Contract.Job Namespace


JobParameters.TargetAddress Property

JobParametersTargetAddress Property
Gets or sets the target address over which the data will be mirrored and replicated from the source.

Namespace: DoubleTake.Core.Contract.Job
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public UnicastIPAddressInfo TargetAddress { get; set; }
Public Property TargetAddress As UnicastIPAddressInfo
    Get
    Set
public:
property UnicastIPAddressInfo^ TargetAddress {
    UnicastIPAddressInfo^ get ();
    void set (UnicastIPAddressInfo^ value);
}
function get_TargetAddress();
function set_TargetAddress(value);

Property Value

Type: UnicastIPAddressInfo
The target address.
See Also

Reference

JobParameters Class
DoubleTake.Core.Contract.Job Namespace


JobParameters.WorkloadRules Property

JobParametersWorkloadRules Property
Gets or sets the workload rules. These rules define what data will be mirrored and replicated by this job.

Namespace: DoubleTake.Core.Contract.Job
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public PhysicalRule[] WorkloadRules { get; set; }
Public Property WorkloadRules As PhysicalRule()
    Get
    Set
public:
property array<PhysicalRule^>^ WorkloadRules {
    array<PhysicalRule^>^ get ();
    void set (array<PhysicalRule^>^ value);
}
function get_WorkloadRules();
function set_WorkloadRules(value);

Property Value

Type: PhysicalRule
The workload rules.
See Also

Reference

JobParameters Class
DoubleTake.Core.Contract.Job Namespace


JobParameters.WorkloadType Property

JobParametersWorkloadType Property
The type of workload to create. See Create

Namespace: DoubleTake.Core.Contract.Job
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string WorkloadType { get; set; }
Public Property WorkloadType As String
    Get
    Set
public:
property String^ WorkloadType {
    String^ get ();
    void set (String^ value);
}
function get_WorkloadType();
function set_WorkloadType(value);

Property Value

Type: String
See Also

Reference

JobParameters Class
DoubleTake.Core.Contract.Job Namespace
ICoreWorkload.Create


JobSourceInfo Class

JobSourceInfo Class
Used to get the status of one or more connections that relate to a specific job. If the Guid is empty, the connection(s) is/are not related to a job.
Inheritance Hierarchy
SystemObject
ObservableObject
DoubleTake.Core.Contract.JobJobSourceInfo

Namespace: DoubleTake.Core.Contract.Job
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class JobSourceInfo : ObservableObject,
    IExtensibleDataObject
Public Class JobSourceInfo
    Inherits ObservableObject
    Implements IExtensibleDataObject
public ref class JobSourceInfo : public ObservableObject,
    IExtensibleDataObject
DoubleTake.Core.Contract.Job.JobSourceInfo = function();

Type.createClass(
    'DoubleTake.Core.Contract.Job.JobSourceInfo',
    DoubleTake.Common.ComponentModel.ObservableObject,
    IExtensibleDataObject);

The JobSourceInfo type exposes the following members.

Constructors
 | Name | Description
Public method | JobSourceInfo | Initializes a new instance of the JobSourceInfo class
Top
Properties
 | Name | Description
Public property | ConnectionInfo | Gets or sets the array of ConnectionInfo for connections related to the job indicated by Guid. If Guid is equal to Empty this array will only contain one item pertaining to a connection that was not created by a job.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Guid | Gets or sets the GUID. This is set to Empty if there is no job relation.
Public property | TargetRoute | Gets or sets the target route.
Top
Remarks
Typically, the job host is indicated by the TargetRoute.
See Also

Reference

DoubleTake.Core.Contract.Job Namespace


JobSourceInfo Constructor

JobSourceInfo Constructor
Initializes a new instance of the JobSourceInfo class

Namespace: DoubleTake.Core.Contract.Job
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public JobSourceInfo()
Public Sub New
public:
JobSourceInfo()
DoubleTake.Core.Contract.Job.JobSourceInfo = function();
See Also

Reference

JobSourceInfo Class
DoubleTake.Core.Contract.Job Namespace


JobSourceInfo Properties

JobSourceInfo Properties

The JobSourceInfo type exposes the following members.

Properties
 | Name | Description
Public property | ConnectionInfo | Gets or sets the array of ConnectionInfo for connections related to the job indicated by Guid. If Guid is equal to Empty this array will only contain one item pertaining to a connection that was not created by a job.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Guid | Gets or sets the GUID. This is set to Empty if there is no job relation.
Public property | TargetRoute | Gets or sets the target route.
Top
See Also

Reference

JobSourceInfo Class
DoubleTake.Core.Contract.Job Namespace


JobSourceInfo.ConnectionInfo Property

JobSourceInfoConnectionInfo Property
Gets or sets the array of ConnectionInfo for connections related to the job indicated by Guid.

If Guid is equal to Empty this array will only contain one item pertaining to a connection that was not created by a job.

Namespace: DoubleTake.Core.Contract.Job
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ConnectionInfo[] ConnectionInfo { get; set; }
Public Property ConnectionInfo As ConnectionInfo()
    Get
    Set
public:
property array<ConnectionInfo^>^ ConnectionInfo {
    array<ConnectionInfo^>^ get ();
    void set (array<ConnectionInfo^>^ value);
}
function get_ConnectionInfo();
function set_ConnectionInfo(value);

Property Value

Type: ConnectionInfo
The connection info.
See Also

Reference

JobSourceInfo Class
DoubleTake.Core.Contract.Job Namespace


JobSourceInfo.ExtensionData Property

JobSourceInfoExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract.Job
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

JobSourceInfo Class
DoubleTake.Core.Contract.Job Namespace


JobSourceInfo.Guid Property

JobSourceInfoGuid Property
Gets or sets the GUID. This is set to Empty if there is no job relation.

Namespace: DoubleTake.Core.Contract.Job
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Guid Guid { get; set; }
Public Property Guid As Guid
    Get
    Set
public:
property Guid Guid {
    Guid get ();
    void set (Guid value);
}
function get_Guid();
function set_Guid(value);

Property Value

Type: Guid
The GUID.
See Also

Reference

JobSourceInfo Class
DoubleTake.Core.Contract.Job Namespace


JobSourceInfo.TargetRoute Property

JobSourceInfoTargetRoute Property
Gets or sets the target route.

Namespace: DoubleTake.Core.Contract.Job
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string TargetRoute { get; set; }
Public Property TargetRoute As String
    Get
    Set
public:
property String^ TargetRoute {
    String^ get ();
    void set (String^ value);
}
function get_TargetRoute();
function set_TargetRoute(value);

Property Value

Type: String
The target route.
See Also

Reference

JobSourceInfo Class
DoubleTake.Core.Contract.Job Namespace


DoubleTake.Core.Contract.Monitor Namespace

DoubleTake.Core.Contract.Monitor Namespace
Classes
 | Class | Description
Public class | FailoverScriptConfiguration | Used to specify the paths of scripts to be run at different stages of the failover and failback operations. The script arguments may also be specified with this data contract.
Public class | MonitorableAddressInfo | Used to specify a monitorable IP address that can be used to configure a failover monitor.
Public class | MonitorConfiguration |
Public class | MonitoredAddressConfiguration | Used to specify the configuration of a single IP address that is to be monitored for failover.
Public class | MonitoredAddressStatus | Represents the status of a monitored IP address.
Public class | MonitorInfo |
Public class | MonitorQualificationResult | An instance of this class is returned from a QualifyMonitor operation on the ICoreService service.
Public class | MonitorStatus | Represents the status of an engine monitor.
Interfaces
 | Interface | Description
Public interface | IMonitoredAddress | Used to implement a monitored address.
Enumerations
 | Enumeration | Description
Public enumeration | ActiveDirectoryFailoverOptions | Used to indicate any Active Directory related options that should be set on a failover monitor.
Public enumeration | FailbackOption | Used to specify the action to take after failing back an identity on the target server using Failback.
Public enumeration | FailoverDataAction | Specifies the action to take on the queued or applied target data before failing over the source server identity to the target server.
Public enumeration | FailoverIPAddressesOption | Used to indicate which addresses should be applied to the target server when a failover operation is performed on a failover monitor.
Public enumeration | FailoverItems | Used to indicate what identity items are failed over to the target when a failover operation is performed on a failover monitor.
Public enumeration | FailoverProcessingOptions | Used to specify how the failover is processed.
Public enumeration | FailoverReplaceActions | Used to indicate what identity items are to be replaced on the target with the identity items from the source.
Public enumeration | FailoverTrigger | Used to specify when a failover operation is triggered with respect to the failure of the monitored IP addresses.
Public enumeration | FailoverType | Used to indicate whether we are failing over an entire server or not.
Public enumeration | HighAvailabilityState | Defines the state of a failover monitor.
Public enumeration | PingMethods |
Public enumeration | RestoreStates | Defines the state of a restore connection.
Public enumeration | SSMRecoveryType | Used to indicate the type of recovery for a full-server failover monitor.


ActiveDirectoryFailoverOptions Enumeration

ActiveDirectoryFailoverOptions Enumeration
Used to indicate any Active Directory related options that should be set on a failover monitor.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public enum ActiveDirectoryFailoverOptions
Public Enumeration ActiveDirectoryFailoverOptions
public enum class ActiveDirectoryFailoverOptions
DoubleTake.Core.Contract.Monitor.ActiveDirectoryFailoverOptions = function();
DoubleTake.Core.Contract.Monitor.ActiveDirectoryFailoverOptions.createEnum('DoubleTake.Core.Contract.Monitor.ActiveDirectoryFailoverOptions', false);
Members
Member name | Value | Description
None | 0 | There are no Active Directory options applied.
FailoverHostName | 1 | The host name of the source server should be moved to the Active Directory server object of the target when a failover occurs.
FailbackHostName | 2 | The host name of the target server should be reinstated in the Active Directory server object of the target when failback occurs.
See Also

Reference

DoubleTake.Core.Contract.Monitor Namespace


FailbackOption Enumeration

FailbackOption Enumeration
Used to specify the action to take after failing back an identity on the target server using Failback.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public enum FailbackOption
Public Enumeration FailbackOption
public enum class FailbackOption
DoubleTake.Core.Contract.Monitor.FailbackOption = function();
DoubleTake.Core.Contract.Monitor.FailbackOption.createEnum('DoubleTake.Core.Contract.Monitor.FailbackOption', false);
Members
Member name | Value | Description
FailbackOnly | 0 | Only the failback operation will occur. The command to resume monitoring or remove the monitor will not be issued.
RemoveMonitor | 1 | After the failback operation completes, issue the command to remove the monitor.
ResumeMonitoring | 2 | After failback operation completes, issue the command to resume monitoring.
See Also

Reference

DoubleTake.Core.Contract.Monitor Namespace


FailoverDataAction Enumeration

FailoverDataAction Enumeration
Specifies the action to take on the queued or applied target data before failing over the source server identity to the target server.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public enum FailoverDataAction
Public Enumeration FailoverDataAction
public enum class FailoverDataAction
DoubleTake.Core.Contract.Monitor.FailoverDataAction = function();
DoubleTake.Core.Contract.Monitor.FailoverDataAction.createEnum('DoubleTake.Core.Contract.Monitor.FailoverDataAction', false);
Members
Member name | Value | Description
Apply | 0 | This value will apply the data in the target queue before starting failover.
Flush | 1 | This value will discard the data in the target queue and start failover immediately.
Revert | 2 | If the target data is in a bad state, this value will revert to the last good snapshot, if snapshots are available. If the target data is in a good state or no snapshots are available, this value will apply the data in the target queue and then failover.
Unknown | 3 | The action is unknown.
See Also

Reference

DoubleTake.Core.Contract.Monitor Namespace


FailoverIPAddressesOption Enumeration

FailoverIPAddressesOption Enumeration
Used to indicate which addresses should be applied to the target server when a failover operation is performed on a failover monitor.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public enum FailoverIPAddressesOption
Public Enumeration FailoverIPAddressesOption
public enum class FailoverIPAddressesOption
DoubleTake.Core.Contract.Monitor.FailoverIPAddressesOption = function();
DoubleTake.Core.Contract.Monitor.FailoverIPAddressesOption.createEnum('DoubleTake.Core.Contract.Monitor.FailoverIPAddressesOption', false);
Members
Member name | Value | Description
Monitored | 0 | Failover only the IP addresses that are being monitored.
All | 1 | Failover all of the IP address on the source. server.
See Also

Reference

DoubleTake.Core.Contract.Monitor Namespace


FailoverItems Enumeration

FailoverItems Enumeration
Used to indicate what identity items are failed over to the target when a failover operation is performed on a failover monitor.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public enum FailoverItems
Public Enumeration FailoverItems
public enum class FailoverItems
DoubleTake.Core.Contract.Monitor.FailoverItems = function();
DoubleTake.Core.Contract.Monitor.FailoverItems.createEnum('DoubleTake.Core.Contract.Monitor.FailoverItems', false);
Members
Member name | Value | Description
None | 0 | Nothing will be failed over.
IPAddresses | 1 | The IP addresses specified by MonitorConfiguration.FailoverIPAddressesOption will be applied to the target during failover.
Name | 2 | The NetBIOS name of the source server will be applied to the target during failover.
Shares | 4 | Shares included in the source workload will be added to the target during failover.
See Also

Reference

DoubleTake.Core.Contract.Monitor Namespace


FailoverProcessingOptions Enumeration

FailoverProcessingOptions Enumeration
Used to specify how the failover is processed.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public enum FailoverProcessingOptions
Public Enumeration FailoverProcessingOptions
public enum class FailoverProcessingOptions
DoubleTake.Core.Contract.Monitor.FailoverProcessingOptions = function();
DoubleTake.Core.Contract.Monitor.FailoverProcessingOptions.createEnum('DoubleTake.Core.Contract.Monitor.FailoverProcessingOptions', false);
Members
Member name | Value | Description
None | 0 | This value resets the flags so no failover processing options will be used.
UserInterventionRequired | 1 | The user must manually initiate failover when a failover condition is met.
UseShareFile | 2 | When failing over file shares, the persisted share file on the target should be used to create the shares on the target. Without this value, the target will attempt to obtain the shares from the source during failover, however, if the source is unavailable, no shares will be created on the target.
See Also

Reference

DoubleTake.Core.Contract.Monitor Namespace


FailoverReplaceActions Enumeration

FailoverReplaceActions Enumeration
Used to indicate what identity items are to be replaced on the target with the identity items from the source.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public enum FailoverReplaceActions
Public Enumeration FailoverReplaceActions
public enum class FailoverReplaceActions
DoubleTake.Core.Contract.Monitor.FailoverReplaceActions = function();
DoubleTake.Core.Contract.Monitor.FailoverReplaceActions.createEnum('DoubleTake.Core.Contract.Monitor.FailoverReplaceActions', false);
Members
Member name | Value | Description
Address | 2 | The IP addresses on the target will be replaced by the IP address from the source during failover.
Name | 1 | The NetBIOS name of the target will be replaced by the NetBIOS name from the source during failover.
None | 0 | This value resets the flags so no failover replace actions will be used.
See Also

Reference

DoubleTake.Core.Contract.Monitor Namespace


FailoverScriptConfiguration Class

FailoverScriptConfiguration Class
Used to specify the paths of scripts to be run at different stages of the failover and failback operations. The script arguments may also be specified with this data contract.
Inheritance Hierarchy
SystemObject
ObservableObject
DoubleTake.Core.Contract.MonitorFailoverScriptConfiguration

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class FailoverScriptConfiguration : ObservableObject,
    IExtensibleDataObject
Public Class FailoverScriptConfiguration
    Inherits ObservableObject
    Implements IExtensibleDataObject
public ref class FailoverScriptConfiguration : public ObservableObject,
    IExtensibleDataObject
DoubleTake.Core.Contract.Monitor.FailoverScriptConfiguration = function();

Type.createClass(
    'DoubleTake.Core.Contract.Monitor.FailoverScriptConfiguration',
    DoubleTake.Common.ComponentModel.ObservableObject,
    IExtensibleDataObject);

The FailoverScriptConfiguration type exposes the following members.

Constructors
 | Name | Description
Public method | FailoverScriptConfiguration | Initializes a new instance of the FailoverScriptConfiguration class
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | PostFailbackScript | This value is the full path and file name of the script located on the target and to be run on the target after failback.
Public property | PostFailbackScriptArgs | This value is the comma-separated arguments for PostFailbackScript.
Public property | PostFailoverScript | This value is the full path and file name of the script located on the target and to be run on the target after failover.
Public property | PostFailoverScriptArgs | This value is the comma-separated arguments for PostFailoverScript.
Public property | PreFailbackScript | This value is the full path and file name of the script located on the target and to be run on the target before failback.
Public property | PreFailbackScriptArgs | This value is the comma-separated arguments for PreFailbackScript.
Public property | PreFailbackWait | This value is true if Double-Take will wait for PreFailbackScript to complete before continuing with the failback operation; otherwise, it is false.
Public property | PreFailoverScript | This value is the full path and file name of the script located on the target and to be run on the target before failover.
Public property | PreFailoverScriptArgs | This value is the comma-separated arguments for PreFailoverScript.
Public property | PreFailoverWait | This value is true if Double-Take will wait for PreFailoverScript to complete before continuing with the failover operation; otherwise, it is false.
Public property | SourcePostFailbackScript | This value is the full path and file name of the script located on the source and to be run on the source after failback.
Public property | SourcePostFailbackScriptArgs | This value is the comma-separated arguments for SourcePostFailbackScript.
Top
See Also

Reference

DoubleTake.Core.Contract.Monitor Namespace


FailoverScriptConfiguration Constructor

FailoverScriptConfiguration Constructor
Initializes a new instance of the FailoverScriptConfiguration class

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public FailoverScriptConfiguration()
Public Sub New
public:
FailoverScriptConfiguration()
DoubleTake.Core.Contract.Monitor.FailoverScriptConfiguration = function();
See Also

Reference

FailoverScriptConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


FailoverScriptConfiguration Properties

FailoverScriptConfiguration Properties

The FailoverScriptConfiguration type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | PostFailbackScript | This value is the full path and file name of the script located on the target and to be run on the target after failback.
Public property | PostFailbackScriptArgs | This value is the comma-separated arguments for PostFailbackScript.
Public property | PostFailoverScript | This value is the full path and file name of the script located on the target and to be run on the target after failover.
Public property | PostFailoverScriptArgs | This value is the comma-separated arguments for PostFailoverScript.
Public property | PreFailbackScript | This value is the full path and file name of the script located on the target and to be run on the target before failback.
Public property | PreFailbackScriptArgs | This value is the comma-separated arguments for PreFailbackScript.
Public property | PreFailbackWait | This value is true if Double-Take will wait for PreFailbackScript to complete before continuing with the failback operation; otherwise, it is false.
Public property | PreFailoverScript | This value is the full path and file name of the script located on the target and to be run on the target before failover.
Public property | PreFailoverScriptArgs | This value is the comma-separated arguments for PreFailoverScript.
Public property | PreFailoverWait | This value is true if Double-Take will wait for PreFailoverScript to complete before continuing with the failover operation; otherwise, it is false.
Public property | SourcePostFailbackScript | This value is the full path and file name of the script located on the source and to be run on the source after failback.
Public property | SourcePostFailbackScriptArgs | This value is the comma-separated arguments for SourcePostFailbackScript.
Top
See Also

Reference

FailoverScriptConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


FailoverScriptConfiguration.ExtensionData Property

FailoverScriptConfigurationExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

FailoverScriptConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


FailoverScriptConfiguration.PostFailbackScript Property

FailoverScriptConfigurationPostFailbackScript Property
This value is the full path and file name of the script located on the target and to be run on the target after failback.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string PostFailbackScript { get; set; }
Public Property PostFailbackScript As String
    Get
    Set
public:
property String^ PostFailbackScript {
    String^ get ();
    void set (String^ value);
}
function get_PostFailbackScript();
function set_PostFailbackScript(value);

Property Value

Type: String
Remarks
This script is run on the target machine and the path must be a path to a script on the target machine.
See Also

Reference

FailoverScriptConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


FailoverScriptConfiguration.PostFailbackScriptArgs Property

FailoverScriptConfigurationPostFailbackScriptArgs Property
This value is the comma-separated arguments for PostFailbackScript.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string PostFailbackScriptArgs { get; set; }
Public Property PostFailbackScriptArgs As String
    Get
    Set
public:
property String^ PostFailbackScriptArgs {
    String^ get ();
    void set (String^ value);
}
function get_PostFailbackScriptArgs();
function set_PostFailbackScriptArgs(value);

Property Value

Type: String
See Also

Reference

FailoverScriptConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


FailoverScriptConfiguration.PostFailoverScript Property

FailoverScriptConfigurationPostFailoverScript Property
This value is the full path and file name of the script located on the target and to be run on the target after failover.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string PostFailoverScript { get; set; }
Public Property PostFailoverScript As String
    Get
    Set
public:
property String^ PostFailoverScript {
    String^ get ();
    void set (String^ value);
}
function get_PostFailoverScript();
function set_PostFailoverScript(value);

Property Value

Type: String
Remarks
This script is run on the target machine and the path must be a path to a script on the target machine.
See Also

Reference

FailoverScriptConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


FailoverScriptConfiguration.PostFailoverScriptArgs Property

FailoverScriptConfigurationPostFailoverScriptArgs Property
This value is the comma-separated arguments for PostFailoverScript.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string PostFailoverScriptArgs { get; set; }
Public Property PostFailoverScriptArgs As String
    Get
    Set
public:
property String^ PostFailoverScriptArgs {
    String^ get ();
    void set (String^ value);
}
function get_PostFailoverScriptArgs();
function set_PostFailoverScriptArgs(value);

Property Value

Type: String
See Also

Reference

FailoverScriptConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


FailoverScriptConfiguration.PreFailbackScript Property

FailoverScriptConfigurationPreFailbackScript Property
This value is the full path and file name of the script located on the target and to be run on the target before failback.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string PreFailbackScript { get; set; }
Public Property PreFailbackScript As String
    Get
    Set
public:
property String^ PreFailbackScript {
    String^ get ();
    void set (String^ value);
}
function get_PreFailbackScript();
function set_PreFailbackScript(value);

Property Value

Type: String
Remarks
This script is run on the target machine and the path must be a path to a script on the target machine.
See Also

Reference

FailoverScriptConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


FailoverScriptConfiguration.PreFailbackScriptArgs Property

FailoverScriptConfigurationPreFailbackScriptArgs Property
This value is the comma-separated arguments for PreFailbackScript.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string PreFailbackScriptArgs { get; set; }
Public Property PreFailbackScriptArgs As String
    Get
    Set
public:
property String^ PreFailbackScriptArgs {
    String^ get ();
    void set (String^ value);
}
function get_PreFailbackScriptArgs();
function set_PreFailbackScriptArgs(value);

Property Value

Type: String
See Also

Reference

FailoverScriptConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


FailoverScriptConfiguration.PreFailbackWait Property

FailoverScriptConfigurationPreFailbackWait Property
This value is true if Double-Take will wait for PreFailbackScript to complete before continuing with the failback operation; otherwise, it is false.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool PreFailbackWait { get; set; }
Public Property PreFailbackWait As Boolean
    Get
    Set
public:
property bool PreFailbackWait {
    bool get ();
    void set (bool value);
}
function get_PreFailbackWait();
function set_PreFailbackWait(value);

Property Value

Type: Boolean
See Also

Reference

FailoverScriptConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


FailoverScriptConfiguration.PreFailoverScript Property

FailoverScriptConfigurationPreFailoverScript Property
This value is the full path and file name of the script located on the target and to be run on the target before failover.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string PreFailoverScript { get; set; }
Public Property PreFailoverScript As String
    Get
    Set
public:
property String^ PreFailoverScript {
    String^ get ();
    void set (String^ value);
}
function get_PreFailoverScript();
function set_PreFailoverScript(value);

Property Value

Type: String
Remarks
This script is run on the target machine and the path must be a path to a script on the target machine.
See Also

Reference

FailoverScriptConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


FailoverScriptConfiguration.PreFailoverScriptArgs Property

FailoverScriptConfigurationPreFailoverScriptArgs Property
This value is the comma-separated arguments for PreFailoverScript.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string PreFailoverScriptArgs { get; set; }
Public Property PreFailoverScriptArgs As String
    Get
    Set
public:
property String^ PreFailoverScriptArgs {
    String^ get ();
    void set (String^ value);
}
function get_PreFailoverScriptArgs();
function set_PreFailoverScriptArgs(value);

Property Value

Type: String
See Also

Reference

FailoverScriptConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


FailoverScriptConfiguration.PreFailoverWait Property

FailoverScriptConfigurationPreFailoverWait Property
This value is true if Double-Take will wait for PreFailoverScript to complete before continuing with the failover operation; otherwise, it is false.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool PreFailoverWait { get; set; }
Public Property PreFailoverWait As Boolean
    Get
    Set
public:
property bool PreFailoverWait {
    bool get ();
    void set (bool value);
}
function get_PreFailoverWait();
function set_PreFailoverWait(value);

Property Value

Type: Boolean
See Also

Reference

FailoverScriptConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


FailoverScriptConfiguration.SourcePostFailbackScript Property

FailoverScriptConfigurationSourcePostFailbackScript Property
This value is the full path and file name of the script located on the source and to be run on the source after failback.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string SourcePostFailbackScript { get; set; }
Public Property SourcePostFailbackScript As String
    Get
    Set
public:
property String^ SourcePostFailbackScript {
    String^ get ();
    void set (String^ value);
}
function get_SourcePostFailbackScript();
function set_SourcePostFailbackScript(value);

Property Value

Type: String
Remarks
This script is run on the source machine and the path must be a path to a script on the source machine.
See Also

Reference

FailoverScriptConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


FailoverScriptConfiguration.SourcePostFailbackScriptArgs Property

FailoverScriptConfigurationSourcePostFailbackScriptArgs Property
This value is the comma-separated arguments for SourcePostFailbackScript.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string SourcePostFailbackScriptArgs { get; set; }
Public Property SourcePostFailbackScriptArgs As String
    Get
    Set
public:
property String^ SourcePostFailbackScriptArgs {
    String^ get ();
    void set (String^ value);
}
function get_SourcePostFailbackScriptArgs();
function set_SourcePostFailbackScriptArgs(value);

Property Value

Type: String
See Also

Reference

FailoverScriptConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


FailoverTrigger Enumeration

FailoverTrigger Enumeration
Used to specify when a failover operation is triggered with respect to the failure of the monitored IP addresses.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public enum FailoverTrigger
Public Enumeration FailoverTrigger
public enum class FailoverTrigger
DoubleTake.Core.Contract.Monitor.FailoverTrigger = function();
DoubleTake.Core.Contract.Monitor.FailoverTrigger.createEnum('DoubleTake.Core.Contract.Monitor.FailoverTrigger', false);
Members
Member name | Value | Description
OneAddressFails | 0 | A failover condition is met when one monitored IP address fails.
AllAddressesFail | 1 | A failover condition is met when all monitored IP addresses fail.
See Also

Reference

DoubleTake.Core.Contract.Monitor Namespace


FailoverType Enumeration

FailoverType Enumeration
Used to indicate whether we are failing over an entire server or not.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public enum FailoverType
Public Enumeration FailoverType
public enum class FailoverType
DoubleTake.Core.Contract.Monitor.FailoverType = function();
DoubleTake.Core.Contract.Monitor.FailoverType.createEnum('DoubleTake.Core.Contract.Monitor.FailoverType', false);
Members
Member name | Value | Description
FullServer | 1 | The entire server is being failed over and internal Double-Take processing will determine what is failed over.
Normal | 0 | The parameters in MonitorConfiguration are used to process failover.
See Also

Reference

DoubleTake.Core.Contract.Monitor Namespace


HighAvailabilityState Enumeration

HighAvailabilityState Enumeration
Defines the state of a failover monitor.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public enum HighAvailabilityState
Public Enumeration HighAvailabilityState
public enum class HighAvailabilityState
DoubleTake.Core.Contract.Monitor.HighAvailabilityState = function();
DoubleTake.Core.Contract.Monitor.HighAvailabilityState.createEnum('DoubleTake.Core.Contract.Monitor.HighAvailabilityState', false);
Members
Member name | Value | Description
FailbackOccurring | 80 | Failback is occurring.
FailbackRemonitor | 96 | Failback is complete. The target is waiting to start monitoring the source again.
FailbackRequired | 64 | The source is failed over to the target. A failback needs to occur to restore the target to its original identity.
FailoverMonitoring | 16 | The target is monitoring the source for a failure. No failover condition has been met. triggered.
FailoverOccurring | 48 | Failover is occurring.
FailoverRequired | 32 | Failover is pending because a failover condition has been met but failover has not started yet.
Illegal | -1 | There is a problem determining the monitoring status.
None | 0 | The monitoring status has not yet been determined.
See Also

Reference

DoubleTake.Core.Contract.Monitor Namespace


IMonitoredAddress Interface

IMonitoredAddress Interface
Used to implement a monitored address.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public interface IMonitoredAddress
Public Interface IMonitoredAddress
public interface class IMonitoredAddress
DoubleTake.Core.Contract.Monitor.IMonitoredAddress = function();
DoubleTake.Core.Contract.Monitor.IMonitoredAddress.createInterface('DoubleTake.Core.Contract.Monitor.IMonitoredAddress');

The IMonitoredAddress type exposes the following members.

Properties
 | Name | Description
Public property | Address | Gets or sets the address.
Top
See Also

Reference

DoubleTake.Core.Contract.Monitor Namespace


IMonitoredAddress Properties

IMonitoredAddress Properties

The IMonitoredAddress type exposes the following members.

Properties
 | Name | Description
Public property | Address | Gets or sets the address.
Top
See Also

Reference

IMonitoredAddress Interface
DoubleTake.Core.Contract.Monitor Namespace


IMonitoredAddress.Address Property

IMonitoredAddressAddress Property
Gets or sets the address.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
string Address { get; set; }
Property Address As String
    Get
    Set
property String^ Address {
    String^ get ();
    void set (String^ value);
}
function get_Address();
function set_Address(value);

Property Value

Type: String
The address.
See Also

Reference

IMonitoredAddress Interface
DoubleTake.Core.Contract.Monitor Namespace


MonitorableAddressInfo Class

MonitorableAddressInfo Class
Used to specify a monitorable IP address that can be used to configure a failover monitor.
Inheritance Hierarchy
SystemObject
DoubleTake.Core.Contract.MonitorMonitorableAddressInfo

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class MonitorableAddressInfo : IExtensibleDataObject
Public Class MonitorableAddressInfo
    Implements IExtensibleDataObject
public ref class MonitorableAddressInfo : IExtensibleDataObject
DoubleTake.Core.Contract.Monitor.MonitorableAddressInfo = function();

Type.createClass(
    'DoubleTake.Core.Contract.Monitor.MonitorableAddressInfo',
    null,
    IExtensibleDataObject);

The MonitorableAddressInfo type exposes the following members.

Constructors
 | Name | Description
Public method | MonitorableAddressInfo | Initializes a new instance of the MonitorableAddressInfo class
Top
Properties
 | Name | Description
Public property | Address | The IP address and subnet mask (IPv4-only) of an address that can be monitored from the target.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | InterfaceMacAddress | The MAC address of the NIC on which this address resides.
Public property | TargetInterfaceGuids | A list of GUIDs specifying target NICs that can monitor this address.
Top
See Also

Reference

DoubleTake.Core.Contract.Monitor Namespace


MonitorableAddressInfo Constructor

MonitorableAddressInfo Constructor
Initializes a new instance of the MonitorableAddressInfo class

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public MonitorableAddressInfo()
Public Sub New
public:
MonitorableAddressInfo()
DoubleTake.Core.Contract.Monitor.MonitorableAddressInfo = function();
See Also

Reference

MonitorableAddressInfo Class
DoubleTake.Core.Contract.Monitor Namespace


MonitorableAddressInfo Properties

MonitorableAddressInfo Properties

The MonitorableAddressInfo type exposes the following members.

Properties
 | Name | Description
Public property | Address | The IP address and subnet mask (IPv4-only) of an address that can be monitored from the target.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | InterfaceMacAddress | The MAC address of the NIC on which this address resides.
Public property | TargetInterfaceGuids | A list of GUIDs specifying target NICs that can monitor this address.
Top
See Also

Reference

MonitorableAddressInfo Class
DoubleTake.Core.Contract.Monitor Namespace


MonitorableAddressInfo.Address Property

MonitorableAddressInfoAddress Property
The IP address and subnet mask (IPv4-only) of an address that can be monitored from the target.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public UnicastIPAddressInfo Address { get; set; }
Public Property Address As UnicastIPAddressInfo
    Get
    Set
public:
property UnicastIPAddressInfo^ Address {
    UnicastIPAddressInfo^ get ();
    void set (UnicastIPAddressInfo^ value);
}
function get_Address();
function set_Address(value);

Property Value

Type: UnicastIPAddressInfo
See Also

Reference

MonitorableAddressInfo Class
DoubleTake.Core.Contract.Monitor Namespace


MonitorableAddressInfo.ExtensionData Property

MonitorableAddressInfoExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

MonitorableAddressInfo Class
DoubleTake.Core.Contract.Monitor Namespace


MonitorableAddressInfo.InterfaceMacAddress Property

MonitorableAddressInfoInterfaceMacAddress Property
The MAC address of the NIC on which this address resides.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string InterfaceMacAddress { get; set; }
Public Property InterfaceMacAddress As String
    Get
    Set
public:
property String^ InterfaceMacAddress {
    String^ get ();
    void set (String^ value);
}
function get_InterfaceMacAddress();
function set_InterfaceMacAddress(value);

Property Value

Type: String
See Also

Reference

MonitorableAddressInfo Class
DoubleTake.Core.Contract.Monitor Namespace


MonitorableAddressInfo.TargetInterfaceGuids Property

MonitorableAddressInfoTargetInterfaceGuids Property
A list of GUIDs specifying target NICs that can monitor this address.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string[] TargetInterfaceGuids { get; set; }
Public Property TargetInterfaceGuids As String()
    Get
    Set
public:
property array<String^>^ TargetInterfaceGuids {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
function get_TargetInterfaceGuids();
function set_TargetInterfaceGuids(value);

Property Value

Type: String
See Also

Reference

MonitorableAddressInfo Class
DoubleTake.Core.Contract.Monitor Namespace


MonitorConfiguration Class

MonitorConfiguration Class
Inheritance Hierarchy
SystemObject
DoubleTake.Core.Contract.MonitorMonitorConfiguration

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class MonitorConfiguration : IExtensibleDataObject
Public Class MonitorConfiguration
    Implements IExtensibleDataObject
public ref class MonitorConfiguration : IExtensibleDataObject
DoubleTake.Core.Contract.Monitor.MonitorConfiguration = function();

Type.createClass(
    'DoubleTake.Core.Contract.Monitor.MonitorConfiguration',
    null,
    IExtensibleDataObject);

The MonitorConfiguration type exposes the following members.

Constructors
 | Name | Description
Public method | MonitorConfiguration | Initializes a new instance of the MonitorConfiguration class
Top
Properties
 | Name | Description
Public property | ActiveDirectoryCredentials | This value represents the Active Directory credentials.
Public property | ActiveDirectoryOptions | This value represents the Active Directory options.
Public property | Addresses | This value represents the configuration of the IP addresses that should be monitored for failure.
Public property | DataAction | This value represents the action to take on the queued target data before failover.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | FailoverIPAddressesOption | Gets or sets the FailoverIPAddressesOption.
Public property | FailoverType | This value represents if an entire server is being failed over.
Public property | ItemsToFailover | This value represents what will be failed over to the target.
Public property | MaxScriptFailures | This value is the number of times a monitoring script can fail when using MonitoredAddressConfiguration.PingMethods.Script.
Public property | Name | This value is the name of the failover monitor.
Public property | ProcessingOptions | This value represents how the failover is processed.
Public property | ReplaceActions | This value represents what identity items are to be replaced on the target during failover.
Public property | ScriptMonitorEngine | This property is no longer used.
Public property | ScriptMonitorName | This value is the full path and name of a monitoring script when using MonitoredAddressConfiguration.PingMethods.Script.
Public property | Scripts | This value represents the scripts that should be run at different stages of failover and failback.
Public property | SourceEndpoint | This value is the IP endpoint used to communcation with Double-Take on the source.
Public property | SSMLogPath | This value is the path of the system state (full server processor) log.
Public property | SSMManualReboot | This value is true if the server has to be manually rebooted to apply the system state after failover; otherwise, it is false.
Public property | SSMRecoveryType | This property is no longer used.
Public property | SSMSourceNicGuids | This value is the global unique IDs associated with the source NICs.
Public property | SSMStagingPath | This value is the path of the staged folders on the target.
Public property | SSMTargetNicGuids | This value is the global unique IDs associated with the target NICs.
Public property | Trigger | This value represents when a failover operation is triggered with respect to the monitored IP addresses.
Top
See Also

Reference

DoubleTake.Core.Contract.Monitor Namespace


MonitorConfiguration Constructor

MonitorConfiguration Constructor
Initializes a new instance of the MonitorConfiguration class

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public MonitorConfiguration()
Public Sub New
public:
MonitorConfiguration()
DoubleTake.Core.Contract.Monitor.MonitorConfiguration = function();
See Also

Reference

MonitorConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


MonitorConfiguration Properties

MonitorConfiguration Properties

The MonitorConfiguration type exposes the following members.

Properties
 | Name | Description
Public property | ActiveDirectoryCredentials | This value represents the Active Directory credentials.
Public property | ActiveDirectoryOptions | This value represents the Active Directory options.
Public property | Addresses | This value represents the configuration of the IP addresses that should be monitored for failure.
Public property | DataAction | This value represents the action to take on the queued target data before failover.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | FailoverIPAddressesOption | Gets or sets the FailoverIPAddressesOption.
Public property | FailoverType | This value represents if an entire server is being failed over.
Public property | ItemsToFailover | This value represents what will be failed over to the target.
Public property | MaxScriptFailures | This value is the number of times a monitoring script can fail when using MonitoredAddressConfiguration.PingMethods.Script.
Public property | Name | This value is the name of the failover monitor.
Public property | ProcessingOptions | This value represents how the failover is processed.
Public property | ReplaceActions | This value represents what identity items are to be replaced on the target during failover.
Public property | ScriptMonitorEngine | This property is no longer used.
Public property | ScriptMonitorName | This value is the full path and name of a monitoring script when using MonitoredAddressConfiguration.PingMethods.Script.
Public property | Scripts | This value represents the scripts that should be run at different stages of failover and failback.
Public property | SourceEndpoint | This value is the IP endpoint used to communcation with Double-Take on the source.
Public property | SSMLogPath | This value is the path of the system state (full server processor) log.
Public property | SSMManualReboot | This value is true if the server has to be manually rebooted to apply the system state after failover; otherwise, it is false.
Public property | SSMRecoveryType | This property is no longer used.
Public property | SSMSourceNicGuids | This value is the global unique IDs associated with the source NICs.
Public property | SSMStagingPath | This value is the path of the staged folders on the target.
Public property | SSMTargetNicGuids | This value is the global unique IDs associated with the target NICs.
Public property | Trigger | This value represents when a failover operation is triggered with respect to the monitored IP addresses.
Top
See Also

Reference

MonitorConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


MonitorConfiguration.ActiveDirectoryCredentials Property

MonitorConfigurationActiveDirectoryCredentials Property
This value represents the Active Directory credentials.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Credentials ActiveDirectoryCredentials { get; set; }
Public Property ActiveDirectoryCredentials As Credentials
    Get
    Set
public:
property Credentials^ ActiveDirectoryCredentials {
    Credentials^ get ();
    void set (Credentials^ value);
}
function get_ActiveDirectoryCredentials();
function set_ActiveDirectoryCredentials(value);

Property Value

Type: Credentials
The active directory credentials.
See Also

Reference

MonitorConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


MonitorConfiguration.ActiveDirectoryOptions Property

MonitorConfigurationActiveDirectoryOptions Property
This value represents the Active Directory options.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ActiveDirectoryFailoverOptions ActiveDirectoryOptions { get; set; }
Public Property ActiveDirectoryOptions As ActiveDirectoryFailoverOptions
    Get
    Set
public:
property ActiveDirectoryFailoverOptions ActiveDirectoryOptions {
    ActiveDirectoryFailoverOptions get ();
    void set (ActiveDirectoryFailoverOptions value);
}
function get_ActiveDirectoryOptions();
function set_ActiveDirectoryOptions(value);

Property Value

Type: ActiveDirectoryFailoverOptions
The active directory options.
See Also

Reference

MonitorConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


MonitorConfiguration.Addresses Property

MonitorConfigurationAddresses Property
This value represents the configuration of the IP addresses that should be monitored for failure.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public MonitoredAddressConfiguration[] Addresses { get; set; }
Public Property Addresses As MonitoredAddressConfiguration()
    Get
    Set
public:
property array<MonitoredAddressConfiguration^>^ Addresses {
    array<MonitoredAddressConfiguration^>^ get ();
    void set (array<MonitoredAddressConfiguration^>^ value);
}
function get_Addresses();
function set_Addresses(value);

Property Value

Type: MonitoredAddressConfiguration
An array of MonitoredAddressConfiguration.
See Also

Reference

MonitorConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


MonitorConfiguration.DataAction Property

MonitorConfigurationDataAction Property
This value represents the action to take on the queued target data before failover.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public FailoverDataAction DataAction { get; set; }
Public Property DataAction As FailoverDataAction
    Get
    Set
public:
property FailoverDataAction DataAction {
    FailoverDataAction get ();
    void set (FailoverDataAction value);
}
function get_DataAction();
function set_DataAction(value);

Property Value

Type: FailoverDataAction
The FailoverDataAction.
See Also

Reference

MonitorConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


MonitorConfiguration.ExtensionData Property

MonitorConfigurationExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

MonitorConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


MonitorConfiguration.FailoverIPAddressesOption Property

MonitorConfigurationFailoverIPAddressesOption Property
Gets or sets the FailoverIPAddressesOption.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public FailoverIPAddressesOption FailoverIPAddressesOption { get; set; }
Public Property FailoverIPAddressesOption As FailoverIPAddressesOption
    Get
    Set
public:
property FailoverIPAddressesOption FailoverIPAddressesOption {
    FailoverIPAddressesOption get ();
    void set (FailoverIPAddressesOption value);
}
function get_FailoverIPAddressesOption();
function set_FailoverIPAddressesOption(value);

Property Value

Type: FailoverIPAddressesOption
The FailoverIPAddressesOption.
See Also

Reference

MonitorConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


MonitorConfiguration.FailoverType Property

MonitorConfigurationFailoverType Property
This value represents if an entire server is being failed over.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public FailoverType FailoverType { get; set; }
Public Property FailoverType As FailoverType
    Get
    Set
public:
property FailoverType FailoverType {
    FailoverType get ();
    void set (FailoverType value);
}
function get_FailoverType();
function set_FailoverType(value);

Property Value

Type: FailoverType
The FailoverType.
See Also

Reference

MonitorConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


MonitorConfiguration.ItemsToFailover Property

MonitorConfigurationItemsToFailover Property
This value represents what will be failed over to the target.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public FailoverItems ItemsToFailover { get; set; }
Public Property ItemsToFailover As FailoverItems
    Get
    Set
public:
property FailoverItems ItemsToFailover {
    FailoverItems get ();
    void set (FailoverItems value);
}
function get_ItemsToFailover();
function set_ItemsToFailover(value);

Property Value

Type: FailoverItems
The FailoverItems.
See Also

Reference

MonitorConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


MonitorConfiguration.MaxScriptFailures Property

MonitorConfigurationMaxScriptFailures Property
This value is the number of times a monitoring script can fail when using MonitoredAddressConfiguration.PingMethods.Script.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int MaxScriptFailures { get; set; }
Public Property MaxScriptFailures As Integer
    Get
    Set
public:
property int MaxScriptFailures {
    int get ();
    void set (int value);
}
function get_MaxScriptFailures();
function set_MaxScriptFailures(value);

Property Value

Type: Int32
The max script failures.
See Also

Reference

MonitorConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


MonitorConfiguration.Name Property

MonitorConfigurationName Property
This value is the name of the failover monitor.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
function get_Name();
function set_Name(value);

Property Value

Type: String
The name of the failover monitor.
See Also

Reference

MonitorConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


MonitorConfiguration.ProcessingOptions Property

MonitorConfigurationProcessingOptions Property
This value represents how the failover is processed.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public FailoverProcessingOptions ProcessingOptions { get; set; }
Public Property ProcessingOptions As FailoverProcessingOptions
    Get
    Set
public:
property FailoverProcessingOptions ProcessingOptions {
    FailoverProcessingOptions get ();
    void set (FailoverProcessingOptions value);
}
function get_ProcessingOptions();
function set_ProcessingOptions(value);

Property Value

Type: FailoverProcessingOptions
The processing options.
See Also

Reference

MonitorConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


MonitorConfiguration.ReplaceActions Property

MonitorConfigurationReplaceActions Property
This value represents what identity items are to be replaced on the target during failover.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public FailoverReplaceActions ReplaceActions { get; set; }
Public Property ReplaceActions As FailoverReplaceActions
    Get
    Set
public:
property FailoverReplaceActions ReplaceActions {
    FailoverReplaceActions get ();
    void set (FailoverReplaceActions value);
}
function get_ReplaceActions();
function set_ReplaceActions(value);

Property Value

Type: FailoverReplaceActions
The replace actions.
See Also

Reference

MonitorConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


MonitorConfiguration.ScriptMonitorEngine Property

MonitorConfigurationScriptMonitorEngine Property
This property is no longer used.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string ScriptMonitorEngine { get; set; }
Public Property ScriptMonitorEngine As String
    Get
    Set
public:
property String^ ScriptMonitorEngine {
    String^ get ();
    void set (String^ value);
}
function get_ScriptMonitorEngine();
function set_ScriptMonitorEngine(value);

Property Value

Type: String
The script monitor engine.
See Also

Reference

MonitorConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


MonitorConfiguration.ScriptMonitorName Property

MonitorConfigurationScriptMonitorName Property
This value is the full path and name of a monitoring script when using MonitoredAddressConfiguration.PingMethods.Script.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string ScriptMonitorName { get; set; }
Public Property ScriptMonitorName As String
    Get
    Set
public:
property String^ ScriptMonitorName {
    String^ get ();
    void set (String^ value);
}
function get_ScriptMonitorName();
function set_ScriptMonitorName(value);

Property Value

Type: String
The name of the script monitor.
See Also

Reference

MonitorConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


MonitorConfiguration.Scripts Property

MonitorConfigurationScripts Property
This value represents the scripts that should be run at different stages of failover and failback.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public FailoverScriptConfiguration Scripts { get; set; }
Public Property Scripts As FailoverScriptConfiguration
    Get
    Set
public:
property FailoverScriptConfiguration^ Scripts {
    FailoverScriptConfiguration^ get ();
    void set (FailoverScriptConfiguration^ value);
}
function get_Scripts();
function set_Scripts(value);

Property Value

Type: FailoverScriptConfiguration
The FailoverScriptConfiguration.
See Also

Reference

MonitorConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


MonitorConfiguration.SourceEndpoint Property

MonitorConfigurationSourceEndpoint Property
This value is the IP endpoint used to communcation with Double-Take on the source.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string SourceEndpoint { get; set; }
Public Property SourceEndpoint As String
    Get
    Set
public:
property String^ SourceEndpoint {
    String^ get ();
    void set (String^ value);
}
function get_SourceEndpoint();
function set_SourceEndpoint(value);

Property Value

Type: String
The source IP endpoint to be used to communicate with Double-Take on the source.
See Also

Reference

MonitorConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


MonitorConfiguration.SSMLogPath Property

MonitorConfigurationSSMLogPath Property
This value is the path of the system state (full server processor) log.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string SSMLogPath { get; set; }
Public Property SSMLogPath As String
    Get
    Set
public:
property String^ SSMLogPath {
    String^ get ();
    void set (String^ value);
}
function get_SSMLogPath();
function set_SSMLogPath(value);

Property Value

Type: String
The SSM log path.
See Also

Reference

MonitorConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


MonitorConfiguration.SSMManualReboot Property

MonitorConfigurationSSMManualReboot Property
This value is true if the server has to be manually rebooted to apply the system state after failover; otherwise, it is false.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool SSMManualReboot { get; set; }
Public Property SSMManualReboot As Boolean
    Get
    Set
public:
property bool SSMManualReboot {
    bool get ();
    void set (bool value);
}
function get_SSMManualReboot();
function set_SSMManualReboot(value);

Property Value

Type: Boolean
if [SSM manual reboot]; otherwise, .
See Also

Reference

MonitorConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


MonitorConfiguration.SSMRecoveryType Property

MonitorConfigurationSSMRecoveryType Property
This property is no longer used.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public SSMRecoveryType SSMRecoveryType { get; set; }
Public Property SSMRecoveryType As SSMRecoveryType
    Get
    Set
public:
property SSMRecoveryType SSMRecoveryType {
    SSMRecoveryType get ();
    void set (SSMRecoveryType value);
}
function get_SSMRecoveryType();
function set_SSMRecoveryType(value);

Property Value

Type: SSMRecoveryType
The type of the SSM recovery.
See Also

Reference

MonitorConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


MonitorConfiguration.SSMSourceNicGuids Property

MonitorConfigurationSSMSourceNicGuids Property
This value is the global unique IDs associated with the source NICs.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string SSMSourceNicGuids { get; set; }
Public Property SSMSourceNicGuids As String
    Get
    Set
public:
property String^ SSMSourceNicGuids {
    String^ get ();
    void set (String^ value);
}
function get_SSMSourceNicGuids();
function set_SSMSourceNicGuids(value);

Property Value

Type: String
The SSM source nic guids.
See Also

Reference

MonitorConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


MonitorConfiguration.SSMStagingPath Property

MonitorConfigurationSSMStagingPath Property
This value is the path of the staged folders on the target.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string SSMStagingPath { get; set; }
Public Property SSMStagingPath As String
    Get
    Set
public:
property String^ SSMStagingPath {
    String^ get ();
    void set (String^ value);
}
function get_SSMStagingPath();
function set_SSMStagingPath(value);

Property Value

Type: String
The SSM staging path.
See Also

Reference

MonitorConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


MonitorConfiguration.SSMTargetNicGuids Property

MonitorConfigurationSSMTargetNicGuids Property
This value is the global unique IDs associated with the target NICs.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string SSMTargetNicGuids { get; set; }
Public Property SSMTargetNicGuids As String
    Get
    Set
public:
property String^ SSMTargetNicGuids {
    String^ get ();
    void set (String^ value);
}
function get_SSMTargetNicGuids();
function set_SSMTargetNicGuids(value);

Property Value

Type: String
The SSM target nic guids.
See Also

Reference

MonitorConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


MonitorConfiguration.Trigger Property

MonitorConfigurationTrigger Property
This value represents when a failover operation is triggered with respect to the monitored IP addresses.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public FailoverTrigger Trigger { get; set; }
Public Property Trigger As FailoverTrigger
    Get
    Set
public:
property FailoverTrigger Trigger {
    FailoverTrigger get ();
    void set (FailoverTrigger value);
}
function get_Trigger();
function set_Trigger(value);

Property Value

Type: FailoverTrigger
The trigger.
See Also

Reference

MonitorConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


MonitoredAddressConfiguration Class

MonitoredAddressConfiguration Class
Used to specify the configuration of a single IP address that is to be monitored for failover.
Inheritance Hierarchy
SystemObject
DoubleTake.Core.Contract.MonitorMonitoredAddressConfiguration

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class MonitoredAddressConfiguration : IMonitoredAddress,
    IExtensibleDataObject
Public Class MonitoredAddressConfiguration
    Implements IMonitoredAddress, IExtensibleDataObject
public ref class MonitoredAddressConfiguration : IMonitoredAddress,
    IExtensibleDataObject
DoubleTake.Core.Contract.Monitor.MonitoredAddressConfiguration = function();

Type.createClass(
    'DoubleTake.Core.Contract.Monitor.MonitoredAddressConfiguration',
    null,
    DoubleTake.Core.Contract.Monitor.IMonitoredAddress,
    IExtensibleDataObject);

The MonitoredAddressConfiguration type exposes the following members.

Constructors
 | Name | Description
Public method | MonitoredAddressConfiguration | Initializes a new instance of the MonitoredAddressConfiguration class
Top
Properties
 | Name | Description
Public property | Address | This value is the monitored IP address.
Public property | EnginePort |
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | MacAddress | This value is the MAC address of the NIC for the monitored IP address.
Public property | MaxPingAttempts | This value is the maximum number of ping attempts that will be attempted before considering the IP address to be failed.
Public property | NicName | This value is the name of the NIC. On a Windows server, this is typically a global unique ID.
Public property | PingInterval | This value is the interval for how often the monitored IP address is pinged.
Public property | PingMethods | This value represents how the IP address is pinged.
Public property | SubnetMask | This value is the subnet mask of an IPv4 IP address.
Top
See Also

Reference

DoubleTake.Core.Contract.Monitor Namespace


MonitoredAddressConfiguration Constructor

MonitoredAddressConfiguration Constructor
Initializes a new instance of the MonitoredAddressConfiguration class

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public MonitoredAddressConfiguration()
Public Sub New
public:
MonitoredAddressConfiguration()
DoubleTake.Core.Contract.Monitor.MonitoredAddressConfiguration = function();
See Also

Reference

MonitoredAddressConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


MonitoredAddressConfiguration Properties

MonitoredAddressConfiguration Properties

The MonitoredAddressConfiguration type exposes the following members.

Properties
 | Name | Description
Public property | Address | This value is the monitored IP address.
Public property | EnginePort |
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | MacAddress | This value is the MAC address of the NIC for the monitored IP address.
Public property | MaxPingAttempts | This value is the maximum number of ping attempts that will be attempted before considering the IP address to be failed.
Public property | NicName | This value is the name of the NIC. On a Windows server, this is typically a global unique ID.
Public property | PingInterval | This value is the interval for how often the monitored IP address is pinged.
Public property | PingMethods | This value represents how the IP address is pinged.
Public property | SubnetMask | This value is the subnet mask of an IPv4 IP address.
Top
See Also

Reference

MonitoredAddressConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


MonitoredAddressConfiguration.Address Property

MonitoredAddressConfigurationAddress Property
This value is the monitored IP address.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Address { get; set; }
Public Property Address As String
    Get
    Set
public:
virtual property String^ Address {
    String^ get () sealed;
    void set (String^ value) sealed;
}
function get_Address();
function set_Address(value);

Property Value

Type: String
The IP address.

Implements

IMonitoredAddressAddress
See Also

Reference

MonitoredAddressConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


MonitoredAddressConfiguration.EnginePort Property

MonitoredAddressConfigurationEnginePort Property

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Nullable<int> EnginePort { get; set; }
Public Property EnginePort As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> EnginePort {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
function get_EnginePort();
function set_EnginePort(value);

Property Value

Type: Nullable Int32
See Also

Reference

MonitoredAddressConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


MonitoredAddressConfiguration.ExtensionData Property

MonitoredAddressConfigurationExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

MonitoredAddressConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


MonitoredAddressConfiguration.MacAddress Property

MonitoredAddressConfigurationMacAddress Property
This value is the MAC address of the NIC for the monitored IP address.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string MacAddress { get; set; }
Public Property MacAddress As String
    Get
    Set
public:
property String^ MacAddress {
    String^ get ();
    void set (String^ value);
}
function get_MacAddress();
function set_MacAddress(value);

Property Value

Type: String
The MAC address of a source NIC.
See Also

Reference

MonitoredAddressConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


MonitoredAddressConfiguration.MaxPingAttempts Property

MonitoredAddressConfigurationMaxPingAttempts Property
This value is the maximum number of ping attempts that will be attempted before considering the IP address to be failed.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public short MaxPingAttempts { get; set; }
Public Property MaxPingAttempts As Short
    Get
    Set
public:
property short MaxPingAttempts {
    short get ();
    void set (short value);
}
function get_MaxPingAttempts();
function set_MaxPingAttempts(value);

Property Value

Type: Int16
The maximum number of ping attempts.
See Also

Reference

MonitoredAddressConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


MonitoredAddressConfiguration.NicName Property

MonitoredAddressConfigurationNicName Property
This value is the name of the NIC. On a Windows server, this is typically a global unique ID.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string NicName { get; set; }
Public Property NicName As String
    Get
    Set
public:
property String^ NicName {
    String^ get ();
    void set (String^ value);
}
function get_NicName();
function set_NicName(value);

Property Value

Type: String
The name of a NIC on the target.
Remarks
This is typically the GUID of the NIC on a Windows-based machine.
See Also

Reference

MonitoredAddressConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


MonitoredAddressConfiguration.PingInterval Property

MonitoredAddressConfigurationPingInterval Property
This value is the interval for how often the monitored IP address is pinged.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public TimeSpan PingInterval { get; set; }
Public Property PingInterval As TimeSpan
    Get
    Set
public:
property TimeSpan PingInterval {
    TimeSpan get ();
    void set (TimeSpan value);
}
function get_PingInterval();
function set_PingInterval(value);

Property Value

Type: TimeSpan
The ping interval as a TimeSpan.
See Also

Reference

MonitoredAddressConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


MonitoredAddressConfiguration.PingMethods Property

MonitoredAddressConfigurationPingMethods Property
This value represents how the IP address is pinged.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public PingMethods PingMethods { get; set; }
Public Property PingMethods As PingMethods
    Get
    Set
public:
property PingMethods PingMethods {
    PingMethods get ();
    void set (PingMethods value);
}
function get_PingMethods();
function set_PingMethods(value);

Property Value

Type: PingMethods
The PingMethods.
See Also

Reference

MonitoredAddressConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


MonitoredAddressConfiguration.SubnetMask Property

MonitoredAddressConfigurationSubnetMask Property
This value is the subnet mask of an IPv4 IP address.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string SubnetMask { get; set; }
Public Property SubnetMask As String
    Get
    Set
public:
property String^ SubnetMask {
    String^ get ();
    void set (String^ value);
}
function get_SubnetMask();
function set_SubnetMask(value);

Property Value

Type: String
The subnet mask.
Remarks
This only applies if this IP address is an IPv4 address.
See Also

Reference

MonitoredAddressConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


MonitoredAddressStatus Class

MonitoredAddressStatus Class
Represents the status of a monitored IP address.
Inheritance Hierarchy
SystemObject
DoubleTake.Core.Contract.MonitorMonitoredAddressStatus

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class MonitoredAddressStatus : IMonitoredAddress,
    IExtensibleDataObject
Public Class MonitoredAddressStatus
    Implements IMonitoredAddress, IExtensibleDataObject
public ref class MonitoredAddressStatus : IMonitoredAddress,
    IExtensibleDataObject
DoubleTake.Core.Contract.Monitor.MonitoredAddressStatus = function();

Type.createClass(
    'DoubleTake.Core.Contract.Monitor.MonitoredAddressStatus',
    null,
    DoubleTake.Core.Contract.Monitor.IMonitoredAddress,
    IExtensibleDataObject);

The MonitoredAddressStatus type exposes the following members.

Constructors
 | Name | Description
Public method | MonitoredAddressStatus | Initializes a new instance of the MonitoredAddressStatus class
Top
Properties
 | Name | Description
Public property | Address | This value is the monitored IP address.
Public property | Alive | This value is true if the IP address is responding to pings; otherwise, it is false.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | FailoverConditionMet | This value is true if the IP address is considered failed; otherwise, it is false.
Public property | RemainingTime | This value is the amount of time remaining before the IP address is considered failed.
Public property | WarningConditionMet | This value is true if the IP address is in a warning condition; otherwise, it is false. An IP address is considered to be in a warning condition if it has failed to respond to ping attempts for three quarters of the number of attempts allowed to be missed before the IP address is considered failed. For example, if the value for MonitoredAddressConfiguration.MaxPingAttempts is 20, then this property will be true after 15 failed attempts.
Top
See Also

Reference

DoubleTake.Core.Contract.Monitor Namespace


MonitoredAddressStatus Constructor

MonitoredAddressStatus Constructor
Initializes a new instance of the MonitoredAddressStatus class

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public MonitoredAddressStatus()
Public Sub New
public:
MonitoredAddressStatus()
DoubleTake.Core.Contract.Monitor.MonitoredAddressStatus = function();
See Also

Reference

MonitoredAddressStatus Class
DoubleTake.Core.Contract.Monitor Namespace


MonitoredAddressStatus Properties

MonitoredAddressStatus Properties

The MonitoredAddressStatus type exposes the following members.

Properties
 | Name | Description
Public property | Address | This value is the monitored IP address.
Public property | Alive | This value is true if the IP address is responding to pings; otherwise, it is false.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | FailoverConditionMet | This value is true if the IP address is considered failed; otherwise, it is false.
Public property | RemainingTime | This value is the amount of time remaining before the IP address is considered failed.
Public property | WarningConditionMet | This value is true if the IP address is in a warning condition; otherwise, it is false. An IP address is considered to be in a warning condition if it has failed to respond to ping attempts for three quarters of the number of attempts allowed to be missed before the IP address is considered failed. For example, if the value for MonitoredAddressConfiguration.MaxPingAttempts is 20, then this property will be true after 15 failed attempts.
Top
See Also

Reference

MonitoredAddressStatus Class
DoubleTake.Core.Contract.Monitor Namespace


MonitoredAddressStatus.Address Property

MonitoredAddressStatusAddress Property
This value is the monitored IP address.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Address { get; set; }
Public Property Address As String
    Get
    Set
public:
virtual property String^ Address {
    String^ get () sealed;
    void set (String^ value) sealed;
}
function get_Address();
function set_Address(value);

Property Value

Type: String
The IP address that is being monitored.

Implements

IMonitoredAddressAddress
See Also

Reference

MonitoredAddressStatus Class
DoubleTake.Core.Contract.Monitor Namespace


MonitoredAddressStatus.Alive Property

MonitoredAddressStatusAlive Property
This value is true if the IP address is responding to pings; otherwise, it is false.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool Alive { get; set; }
Public Property Alive As Boolean
    Get
    Set
public:
property bool Alive {
    bool get ();
    void set (bool value);
}
function get_Alive();
function set_Alive(value);

Property Value

Type: Boolean
if the IP address is responding to ping attempts; otherwise, .
See Also

Reference

MonitoredAddressStatus Class
DoubleTake.Core.Contract.Monitor Namespace


MonitoredAddressStatus.ExtensionData Property

MonitoredAddressStatusExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

MonitoredAddressStatus Class
DoubleTake.Core.Contract.Monitor Namespace


MonitoredAddressStatus.FailoverConditionMet Property

MonitoredAddressStatusFailoverConditionMet Property
This value is true if the IP address is considered failed; otherwise, it is false.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool FailoverConditionMet { get; set; }
Public Property FailoverConditionMet As Boolean
    Get
    Set
public:
property bool FailoverConditionMet {
    bool get ();
    void set (bool value);
}
function get_FailoverConditionMet();
function set_FailoverConditionMet(value);

Property Value

Type: Boolean
if the IP address is considered failed; otherwise, .
See Also

Reference

MonitoredAddressStatus Class
DoubleTake.Core.Contract.Monitor Namespace


MonitoredAddressStatus.RemainingTime Property

MonitoredAddressStatusRemainingTime Property
This value is the amount of time remaining before the IP address is considered failed.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public TimeSpan RemainingTime { get; set; }
Public Property RemainingTime As TimeSpan
    Get
    Set
public:
property TimeSpan RemainingTime {
    TimeSpan get ();
    void set (TimeSpan value);
}
function get_RemainingTime();
function set_RemainingTime(value);

Property Value

Type: TimeSpan
The time remaining before the IP address is considered failed.
See Also

Reference

MonitoredAddressStatus Class
DoubleTake.Core.Contract.Monitor Namespace


MonitoredAddressStatus.WarningConditionMet Property

MonitoredAddressStatusWarningConditionMet Property
This value is true if the IP address is in a warning condition; otherwise, it is false. An IP address is considered to be in a warning condition if it has failed to respond to ping attempts for three quarters of the number of attempts allowed to be missed before the IP address is considered failed. For example, if the value for MonitoredAddressConfiguration.MaxPingAttempts is 20, then this property will be true after 15 failed attempts.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool WarningConditionMet { get; set; }
Public Property WarningConditionMet As Boolean
    Get
    Set
public:
property bool WarningConditionMet {
    bool get ();
    void set (bool value);
}
function get_WarningConditionMet();
function set_WarningConditionMet(value);

Property Value

Type: Boolean
if the IP address is in a warning condition; otherwise, .
Remarks
An IP address is considered to be in a warning condition if it has failed to respond to ping attempts for 3/4 of the number of attempts are allowed to be missed before the IP address is considered failed. For example, if the value for MaxPingAttempts is 20, then this property will be after 15 failed attempts.
See Also

Reference

MonitoredAddressStatus Class
DoubleTake.Core.Contract.Monitor Namespace


MonitorInfo Class

MonitorInfo Class
Inheritance Hierarchy
SystemObject
DoubleTake.Core.Contract.MonitorMonitorInfo

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class MonitorInfo : IExtensibleDataObject
Public Class MonitorInfo
    Implements IExtensibleDataObject
public ref class MonitorInfo : IExtensibleDataObject
DoubleTake.Core.Contract.Monitor.MonitorInfo = function();

Type.createClass(
    'DoubleTake.Core.Contract.Monitor.MonitorInfo',
    null,
    IExtensibleDataObject);

The MonitorInfo type exposes the following members.

Constructors
 | Name | Description
Public method | MonitorInfo | Initializes a new instance of the MonitorInfo class
Top
Properties
 | Name | Description
Public property | Configuration | Gets or sets the MonitorConfiguration.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Guid | Gets or sets the unique id of the monitor.
Public property | Name | Gets or sets the name of the monitor.
Public property | Status | Gets or sets the MonitorStatus.
Top
See Also

Reference

DoubleTake.Core.Contract.Monitor Namespace


MonitorInfo Constructor

MonitorInfo Constructor
Initializes a new instance of the MonitorInfo class

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public MonitorInfo()
Public Sub New
public:
MonitorInfo()
DoubleTake.Core.Contract.Monitor.MonitorInfo = function();
See Also

Reference

MonitorInfo Class
DoubleTake.Core.Contract.Monitor Namespace


MonitorInfo Properties

MonitorInfo Properties

The MonitorInfo type exposes the following members.

Properties
 | Name | Description
Public property | Configuration | Gets or sets the MonitorConfiguration.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Guid | Gets or sets the unique id of the monitor.
Public property | Name | Gets or sets the name of the monitor.
Public property | Status | Gets or sets the MonitorStatus.
Top
See Also

Reference

MonitorInfo Class
DoubleTake.Core.Contract.Monitor Namespace


MonitorInfo.Configuration Property

MonitorInfoConfiguration Property
Gets or sets the MonitorConfiguration.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public MonitorConfiguration Configuration { get; set; }
Public Property Configuration As MonitorConfiguration
    Get
    Set
public:
property MonitorConfiguration^ Configuration {
    MonitorConfiguration^ get ();
    void set (MonitorConfiguration^ value);
}
function get_Configuration();
function set_Configuration(value);

Property Value

Type: MonitorConfiguration
The MonitorConfiguration.
See Also

Reference

MonitorInfo Class
DoubleTake.Core.Contract.Monitor Namespace


MonitorInfo.ExtensionData Property

MonitorInfoExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

MonitorInfo Class
DoubleTake.Core.Contract.Monitor Namespace


MonitorInfo.Guid Property

MonitorInfoGuid Property
Gets or sets the unique id of the monitor.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Guid Guid { get; set; }
Public Property Guid As Guid
    Get
    Set
public:
property Guid Guid {
    Guid get ();
    void set (Guid value);
}
function get_Guid();
function set_Guid(value);

Property Value

Type: Guid
The unique id of the monitor.
See Also

Reference

MonitorInfo Class
DoubleTake.Core.Contract.Monitor Namespace


MonitorInfo.Name Property

MonitorInfoName Property
Gets or sets the name of the monitor.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
function get_Name();
function set_Name(value);

Property Value

Type: String
The name of the monitor.
Remarks
This is typically the host name or IP address of the source machine.
See Also

Reference

MonitorInfo Class
DoubleTake.Core.Contract.Monitor Namespace


MonitorInfo.Status Property

MonitorInfoStatus Property
Gets or sets the MonitorStatus.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public MonitorStatus Status { get; set; }
Public Property Status As MonitorStatus
    Get
    Set
public:
property MonitorStatus^ Status {
    MonitorStatus^ get ();
    void set (MonitorStatus^ value);
}
function get_Status();
function set_Status(value);

Property Value

Type: MonitorStatus
The MonitorStatus.
See Also

Reference

MonitorInfo Class
DoubleTake.Core.Contract.Monitor Namespace


MonitorQualificationResult Class

MonitorQualificationResult Class
An instance of this class is returned from a QualifyMonitor operation on the ICoreService service.
Inheritance Hierarchy
SystemObject
DoubleTake.Core.Contract.MonitorMonitorQualificationResult

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class MonitorQualificationResult : IExtensibleDataObject
Public Class MonitorQualificationResult
    Implements IExtensibleDataObject
public ref class MonitorQualificationResult : IExtensibleDataObject
DoubleTake.Core.Contract.Monitor.MonitorQualificationResult = function();

Type.createClass(
    'DoubleTake.Core.Contract.Monitor.MonitorQualificationResult',
    null,
    IExtensibleDataObject);

The MonitorQualificationResult type exposes the following members.

Constructors
 | Name | Description
Public method | MonitorQualificationResult | Initializes a new instance of the MonitorQualificationResult class
Top
Properties
 | Name | Description
Public property | DefaultMonitor | A pre-populated monitor with default values for the configuration properties.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | IsQualified | Whether or not the machine in question can be monitored.
Public property | MonitorableAddresses | A list of monitorable addresses from the target's point of view.
Public property | SourceMachineName | The host name of the machine to be monitored. Use this name for the name of the monitor being created.
Public property | TargetInterfaces | Information about all the network interfaces on the target machine.
Top
See Also

Reference

DoubleTake.Core.Contract.Monitor Namespace


MonitorQualificationResult Constructor

MonitorQualificationResult Constructor
Initializes a new instance of the MonitorQualificationResult class

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public MonitorQualificationResult()
Public Sub New
public:
MonitorQualificationResult()
DoubleTake.Core.Contract.Monitor.MonitorQualificationResult = function();
See Also

Reference

MonitorQualificationResult Class
DoubleTake.Core.Contract.Monitor Namespace


MonitorQualificationResult Properties

MonitorQualificationResult Properties

The MonitorQualificationResult type exposes the following members.

Properties
 | Name | Description
Public property | DefaultMonitor | A pre-populated monitor with default values for the configuration properties.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | IsQualified | Whether or not the machine in question can be monitored.
Public property | MonitorableAddresses | A list of monitorable addresses from the target's point of view.
Public property | SourceMachineName | The host name of the machine to be monitored. Use this name for the name of the monitor being created.
Public property | TargetInterfaces | Information about all the network interfaces on the target machine.
Top
See Also

Reference

MonitorQualificationResult Class
DoubleTake.Core.Contract.Monitor Namespace


MonitorQualificationResult.DefaultMonitor Property

MonitorQualificationResultDefaultMonitor Property
A pre-populated monitor with default values for the configuration properties.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public MonitorConfiguration DefaultMonitor { get; set; }
Public Property DefaultMonitor As MonitorConfiguration
    Get
    Set
public:
property MonitorConfiguration^ DefaultMonitor {
    MonitorConfiguration^ get ();
    void set (MonitorConfiguration^ value);
}
function get_DefaultMonitor();
function set_DefaultMonitor(value);

Property Value

Type: MonitorConfiguration
See Also

Reference

MonitorQualificationResult Class
DoubleTake.Core.Contract.Monitor Namespace


MonitorQualificationResult.ExtensionData Property

MonitorQualificationResultExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

MonitorQualificationResult Class
DoubleTake.Core.Contract.Monitor Namespace


MonitorQualificationResult.IsQualified Property

MonitorQualificationResultIsQualified Property
Whether or not the machine in question can be monitored.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsQualified { get; set; }
Public Property IsQualified As Boolean
    Get
    Set
public:
property bool IsQualified {
    bool get ();
    void set (bool value);
}
function get_IsQualified();
function set_IsQualified(value);

Property Value

Type: Boolean
See Also

Reference

MonitorQualificationResult Class
DoubleTake.Core.Contract.Monitor Namespace


MonitorQualificationResult.MonitorableAddresses Property

MonitorQualificationResultMonitorableAddresses Property
A list of monitorable addresses from the target's point of view.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public MonitorableAddressInfo[] MonitorableAddresses { get; set; }
Public Property MonitorableAddresses As MonitorableAddressInfo()
    Get
    Set
public:
property array<MonitorableAddressInfo^>^ MonitorableAddresses {
    array<MonitorableAddressInfo^>^ get ();
    void set (array<MonitorableAddressInfo^>^ value);
}
function get_MonitorableAddresses();
function set_MonitorableAddresses(value);

Property Value

Type: MonitorableAddressInfo
See Also

Reference

MonitorQualificationResult Class
DoubleTake.Core.Contract.Monitor Namespace
DoubleTake.Core.Contract.MonitorMonitorableAddressInfo


MonitorQualificationResult.SourceMachineName Property

MonitorQualificationResultSourceMachineName Property
The host name of the machine to be monitored. Use this name for the name of the monitor being created.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string SourceMachineName { get; set; }
Public Property SourceMachineName As String
    Get
    Set
public:
property String^ SourceMachineName {
    String^ get ();
    void set (String^ value);
}
function get_SourceMachineName();
function set_SourceMachineName(value);

Property Value

Type: String
See Also

Reference

MonitorQualificationResult Class
DoubleTake.Core.Contract.Monitor Namespace


MonitorQualificationResult.TargetInterfaces Property

MonitorQualificationResultTargetInterfaces Property
Information about all the network interfaces on the target machine.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public NetworkInterfaceInfo[] TargetInterfaces { get; set; }
Public Property TargetInterfaces As NetworkInterfaceInfo()
    Get
    Set
public:
property array<NetworkInterfaceInfo^>^ TargetInterfaces {
    array<NetworkInterfaceInfo^>^ get ();
    void set (array<NetworkInterfaceInfo^>^ value);
}
function get_TargetInterfaces();
function set_TargetInterfaces(value);

Property Value

Type: NetworkInterfaceInfo
See Also

Reference

MonitorQualificationResult Class
DoubleTake.Core.Contract.Monitor Namespace


MonitorStatus Class

MonitorStatus Class
Represents the status of an engine monitor.
Inheritance Hierarchy
SystemObject
DoubleTake.Core.Contract.MonitorMonitorStatus

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class MonitorStatus : IExtensibleDataObject
Public Class MonitorStatus
    Implements IExtensibleDataObject
public ref class MonitorStatus : IExtensibleDataObject
DoubleTake.Core.Contract.Monitor.MonitorStatus = function();

Type.createClass(
    'DoubleTake.Core.Contract.Monitor.MonitorStatus',
    null,
    IExtensibleDataObject);

The MonitorStatus type exposes the following members.

Constructors
 | Name | Description
Public method | MonitorStatus | Initializes a new instance of the MonitorStatus class
Top
Properties
 | Name | Description
Public property | Addresses | Gets or sets the addresses that are being monitored.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Name | Gets or sets the name of the monitor.
Public property | RestoreStates | Gets or sets the RestoreStates.
Public property | Status | Gets or sets the HighAvailabilityState.
Top
See Also

Reference

DoubleTake.Core.Contract.Monitor Namespace


MonitorStatus Constructor

MonitorStatus Constructor
Initializes a new instance of the MonitorStatus class

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public MonitorStatus()
Public Sub New
public:
MonitorStatus()
DoubleTake.Core.Contract.Monitor.MonitorStatus = function();
See Also

Reference

MonitorStatus Class
DoubleTake.Core.Contract.Monitor Namespace


MonitorStatus Properties

MonitorStatus Properties

The MonitorStatus type exposes the following members.

Properties
 | Name | Description
Public property | Addresses | Gets or sets the addresses that are being monitored.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Name | Gets or sets the name of the monitor.
Public property | RestoreStates | Gets or sets the RestoreStates.
Public property | Status | Gets or sets the HighAvailabilityState.
Top
See Also

Reference

MonitorStatus Class
DoubleTake.Core.Contract.Monitor Namespace


MonitorStatus.Addresses Property

MonitorStatusAddresses Property
Gets or sets the addresses that are being monitored.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public MonitoredAddressStatus[] Addresses { get; set; }
Public Property Addresses As MonitoredAddressStatus()
    Get
    Set
public:
property array<MonitoredAddressStatus^>^ Addresses {
    array<MonitoredAddressStatus^>^ get ();
    void set (array<MonitoredAddressStatus^>^ value);
}
function get_Addresses();
function set_Addresses(value);

Property Value

Type: MonitoredAddressStatus
The addresses.
See Also

Reference

MonitorStatus Class
DoubleTake.Core.Contract.Monitor Namespace


MonitorStatus.ExtensionData Property

MonitorStatusExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

MonitorStatus Class
DoubleTake.Core.Contract.Monitor Namespace


MonitorStatus.Name Property

MonitorStatusName Property
Gets or sets the name of the monitor.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
function get_Name();
function set_Name(value);

Property Value

Type: String
The name of the monitor.
Remarks
The name of the monitor is usually the
See Also

Reference

MonitorStatus Class
DoubleTake.Core.Contract.Monitor Namespace


MonitorStatus.RestoreStates Property

MonitorStatusRestoreStates Property
Gets or sets the RestoreStates.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public RestoreStates RestoreStates { get; set; }
Public Property RestoreStates As RestoreStates
    Get
    Set
public:
property RestoreStates RestoreStates {
    RestoreStates get ();
    void set (RestoreStates value);
}
function get_RestoreStates();
function set_RestoreStates(value);

Property Value

Type: RestoreStates
The RestoreStates.
See Also

Reference

MonitorStatus Class
DoubleTake.Core.Contract.Monitor Namespace


MonitorStatus.Status Property

MonitorStatusStatus Property
Gets or sets the HighAvailabilityState.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public HighAvailabilityState Status { get; set; }
Public Property Status As HighAvailabilityState
    Get
    Set
public:
property HighAvailabilityState Status {
    HighAvailabilityState get ();
    void set (HighAvailabilityState value);
}
function get_Status();
function set_Status(value);

Property Value

Type: HighAvailabilityState
The HighAvailabilityState.
See Also

Reference

MonitorStatus Class
DoubleTake.Core.Contract.Monitor Namespace


PingMethods Enumeration

PingMethods Enumeration

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public enum PingMethods
Public Enumeration PingMethods
public enum class PingMethods
DoubleTake.Core.Contract.Monitor.PingMethods = function();
DoubleTake.Core.Contract.Monitor.PingMethods.createEnum('DoubleTake.Core.Contract.Monitor.PingMethods', false);
Members
Member name | Value | Description
ForceUpdate | 256 | Do not use this property. Double-Take uses it internally.
Manual | 4 | The IP address will not be monitored for failure but is still eligible for failover.
Network | 1 | The IP address will be monitored using an ICMP ping.
None | 0 | The IP address will not be monitored for failure and cannot be failed over.
Script | 8 | The IP address will be monitored using a user scripted ping method. If you use this value, you must set MonitorConfiguration.ScriptMonitorEngine and MonitorConfiguration.ScriptMonitorName.
Service | 2 | The IP address will be monitored using the Double-Take service.
See Also

Reference

DoubleTake.Core.Contract.Monitor Namespace


RestoreStates Enumeration

RestoreStates Enumeration
Defines the state of a restore connection.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public enum RestoreStates
Public Enumeration RestoreStates
public enum class RestoreStates
DoubleTake.Core.Contract.Monitor.RestoreStates = function();
DoubleTake.Core.Contract.Monitor.RestoreStates.createEnum('DoubleTake.Core.Contract.Monitor.RestoreStates', false);
Members
Member name | Value | Description
Connected | 4 | The restoration connection is active and is replicating.
Mirroring | 16 | The restoration connection is active and mirroring.
MirrorStopped | 32 | The restoration mirror has been stopped.
MultiConnect | 8 | There is more than one active restoration connection.
None | 0 | There is no restoration connection.
OldServer | 1 | The server is running an old version of Double-Take and the restoration status is not available.
OpDropped | 64 | A mirroring or replication operation has been dropped. A restoration remirorr is required.
OpRetrying | 128 | A mirorring or replication write operation is being retried.
Required | 2 | A restoration is required.
See Also

Reference

DoubleTake.Core.Contract.Monitor Namespace


SSMRecoveryType Enumeration

SSMRecoveryType Enumeration
Used to indicate the type of recovery for a full-server failover monitor.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public enum SSMRecoveryType
Public Enumeration SSMRecoveryType
public enum class SSMRecoveryType
DoubleTake.Core.Contract.Monitor.SSMRecoveryType = function();
DoubleTake.Core.Contract.Monitor.SSMRecoveryType.createEnum('DoubleTake.Core.Contract.Monitor.SSMRecoveryType', false);
Members
Member name | Value | Description
LAN | 0 | The recovery is to happen over a LAN. We are less lenient on failures relating to network timeouts.
WAN | 1 | The recovery is to happen over a LAN. We are more lenient on failures relating to network timeouts.
See Also

Reference

DoubleTake.Core.Contract.Monitor Namespace


DoubleTake.Core.Contract.Options Namespace

DoubleTake.Core.Contract.Options Namespace
Classes
 | Class | Description
Public class | DnsServerDetail | Represents a DNS server that will be updated during DNS failover.
Public class | FullServerNicMappings | Represent the network interface mappings in a full-server failover job.
Public class | IPAddressMap | Represents the mapping between source IP address and target IP address when using DNS failover.
Public class | TargetServicesToStop | Represents how a service is handled on the target server in full-server failover job.
Enumerations
 | Enumeration | Description
Public enumeration | TargetServiceStatus | Represents the state of a service.


DnsServerDetail Class

DnsServerDetail Class
Represents a DNS server that will be updated during DNS failover.
Inheritance Hierarchy
SystemObject
DoubleTake.Core.Contract.OptionsDnsServerDetail

Namespace: DoubleTake.Core.Contract.Options
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class DnsServerDetail : IExtensibleDataObject
Public Class DnsServerDetail
    Implements IExtensibleDataObject
public ref class DnsServerDetail : IExtensibleDataObject
DoubleTake.Core.Contract.Options.DnsServerDetail = function();

Type.createClass(
    'DoubleTake.Core.Contract.Options.DnsServerDetail',
    null,
    IExtensibleDataObject);

The DnsServerDetail type exposes the following members.

Constructors
 | Name | Description
Public method | DnsServerDetail | Initializes a new instance of the DnsServerDetail class
Top
Properties
 | Name | Description
Public property | Address | This value is the IP address of the DNS server.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Origin | This value is the origin of the DNS server, which indicates if the DNS server was discovered from the source server, the target server, both servers, or manually specified by the user.
Public property | SelectedForUpdate | This value is true if the DNS server will be updated during failover; otherwise, it is false.
Top
Methods
 | Name | Description
Public method | ToString | (Overrides ObjectToString.)
Top
See Also

Reference

DoubleTake.Core.Contract.Options Namespace


DnsServerDetail Constructor

DnsServerDetail Constructor
Initializes a new instance of the DnsServerDetail class

Namespace: DoubleTake.Core.Contract.Options
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public DnsServerDetail()
Public Sub New
public:
DnsServerDetail()
DoubleTake.Core.Contract.Options.DnsServerDetail = function();
See Also

Reference

DnsServerDetail Class
DoubleTake.Core.Contract.Options Namespace


DnsServerDetail Properties

DnsServerDetail Properties

The DnsServerDetail type exposes the following members.

Properties
 | Name | Description
Public property | Address | This value is the IP address of the DNS server.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Origin | This value is the origin of the DNS server, which indicates if the DNS server was discovered from the source server, the target server, both servers, or manually specified by the user.
Public property | SelectedForUpdate | This value is true if the DNS server will be updated during failover; otherwise, it is false.
Top
See Also

Reference

DnsServerDetail Class
DoubleTake.Core.Contract.Options Namespace


DnsServerDetail.Address Property

DnsServerDetailAddress Property
This value is the IP address of the DNS server.

Namespace: DoubleTake.Core.Contract.Options
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Address { get; set; }
Public Property Address As String
    Get
    Set
public:
property String^ Address {
    String^ get ();
    void set (String^ value);
}
function get_Address();
function set_Address(value);

Property Value

Type: String
The address of the DNS server.
See Also

Reference

DnsServerDetail Class
DoubleTake.Core.Contract.Options Namespace


DnsServerDetail.ExtensionData Property

DnsServerDetailExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract.Options
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

DnsServerDetail Class
DoubleTake.Core.Contract.Options Namespace


DnsServerDetail.Origin Property

DnsServerDetailOrigin Property
This value is the origin of the DNS server, which indicates if the DNS server was discovered from the source server, the target server, both servers, or manually specified by the user.

Namespace: DoubleTake.Core.Contract.Options
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Origin { get; set; }
Public Property Origin As String
    Get
    Set
public:
property String^ Origin {
    String^ get ();
    void set (String^ value);
}
function get_Origin();
function set_Origin(value);

Property Value

Type: String
The origin of the DNS server.
Remarks
This property indicates if the DNS server was discovered from the source server, the target server, both servers, or manually specified by the user.
See Also

Reference

DnsServerDetail Class
DoubleTake.Core.Contract.Options Namespace


DnsServerDetail.SelectedForUpdate Property

DnsServerDetailSelectedForUpdate Property
This value is true if the DNS server will be updated during failover; otherwise, it is false.

Namespace: DoubleTake.Core.Contract.Options
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool SelectedForUpdate { get; set; }
Public Property SelectedForUpdate As Boolean
    Get
    Set
public:
property bool SelectedForUpdate {
    bool get ();
    void set (bool value);
}
function get_SelectedForUpdate();
function set_SelectedForUpdate(value);

Property Value

Type: Boolean
if this DNS server will be updated during DNS failover; otherwise, .
See Also

Reference

DnsServerDetail Class
DoubleTake.Core.Contract.Options Namespace


DnsServerDetail Methods

DnsServerDetail Methods

The DnsServerDetail type exposes the following members.

Methods
 | Name | Description
Public method | ToString | (Overrides ObjectToString.)
Top
See Also

Reference

DnsServerDetail Class
DoubleTake.Core.Contract.Options Namespace


DnsServerDetail.ToString Method

DnsServerDetailToString Method

Namespace: DoubleTake.Core.Contract.Options
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
function ToString();

Return Value

Type: String
See Also

Reference

DnsServerDetail Class
DoubleTake.Core.Contract.Options Namespace


FullServerNicMappings Class

FullServerNicMappings Class
Represent the network interface mappings in a full-server failover job.
Inheritance Hierarchy
SystemObject
DoubleTake.Core.Contract.OptionsFullServerNicMappings

Namespace: DoubleTake.Core.Contract.Options
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class FullServerNicMappings : IExtensibleDataObject
Public Class FullServerNicMappings
    Implements IExtensibleDataObject
public ref class FullServerNicMappings : IExtensibleDataObject
DoubleTake.Core.Contract.Options.FullServerNicMappings = function();

Type.createClass(
    'DoubleTake.Core.Contract.Options.FullServerNicMappings',
    null,
    IExtensibleDataObject);

The FullServerNicMappings type exposes the following members.

Constructors
 | Name | Description
Public method | FullServerNicMappings | Initializes a new instance of the FullServerNicMappings class
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | SourceNic | This value is the NIC on the source server.
Public property | TargetNic | This value is the NIC on the target server.
Public property | TargetNicList | This value is the list of NICs on the target server.
Top
See Also

Reference

DoubleTake.Core.Contract.Options Namespace


FullServerNicMappings Constructor

FullServerNicMappings Constructor
Initializes a new instance of the FullServerNicMappings class

Namespace: DoubleTake.Core.Contract.Options
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public FullServerNicMappings()
Public Sub New
public:
FullServerNicMappings()
DoubleTake.Core.Contract.Options.FullServerNicMappings = function();
See Also

Reference

FullServerNicMappings Class
DoubleTake.Core.Contract.Options Namespace


FullServerNicMappings Properties

FullServerNicMappings Properties

The FullServerNicMappings type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | SourceNic | This value is the NIC on the source server.
Public property | TargetNic | This value is the NIC on the target server.
Public property | TargetNicList | This value is the list of NICs on the target server.
Top
See Also

Reference

FullServerNicMappings Class
DoubleTake.Core.Contract.Options Namespace


FullServerNicMappings.ExtensionData Property

FullServerNicMappingsExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract.Options
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

FullServerNicMappings Class
DoubleTake.Core.Contract.Options Namespace


FullServerNicMappings.SourceNic Property

FullServerNicMappingsSourceNic Property
This value is the NIC on the source server.

Namespace: DoubleTake.Core.Contract.Options
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string SourceNic { get; set; }
Public Property SourceNic As String
    Get
    Set
public:
property String^ SourceNic {
    String^ get ();
    void set (String^ value);
}
function get_SourceNic();
function set_SourceNic(value);

Property Value

Type: String
The network interface on the source server.
See Also

Reference

FullServerNicMappings Class
DoubleTake.Core.Contract.Options Namespace


FullServerNicMappings.TargetNic Property

FullServerNicMappingsTargetNic Property
This value is the NIC on the target server.

Namespace: DoubleTake.Core.Contract.Options
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string TargetNic { get; set; }
Public Property TargetNic As String
    Get
    Set
public:
property String^ TargetNic {
    String^ get ();
    void set (String^ value);
}
function get_TargetNic();
function set_TargetNic(value);

Property Value

Type: String
The network interface on the target server.
See Also

Reference

FullServerNicMappings Class
DoubleTake.Core.Contract.Options Namespace


FullServerNicMappings.TargetNicList Property

FullServerNicMappingsTargetNicList Property
This value is the list of NICs on the target server.

Namespace: DoubleTake.Core.Contract.Options
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string[] TargetNicList { get; set; }
Public Property TargetNicList As String()
    Get
    Set
public:
property array<String^>^ TargetNicList {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
function get_TargetNicList();
function set_TargetNicList(value);

Property Value

Type: String
The target list of network interfaces on the target server.
See Also

Reference

FullServerNicMappings Class
DoubleTake.Core.Contract.Options Namespace


IPAddressMap Class

IPAddressMap Class
Represents the mapping between source IP address and target IP address when using DNS failover.
Inheritance Hierarchy
SystemObject
DoubleTake.Core.Contract.OptionsIPAddressMap

Namespace: DoubleTake.Core.Contract.Options
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class IPAddressMap : IExtensibleDataObject
Public Class IPAddressMap
    Implements IExtensibleDataObject
public ref class IPAddressMap : IExtensibleDataObject
DoubleTake.Core.Contract.Options.IPAddressMap = function();

Type.createClass(
    'DoubleTake.Core.Contract.Options.IPAddressMap',
    null,
    IExtensibleDataObject);

The IPAddressMap type exposes the following members.

Constructors
 | Name | Description
Public method | IPAddressMap | Initializes a new instance of the IPAddressMap class
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | ShouldUpdateTtl | This value is true if the time to live value should be updated; otherwise, it is false.
Public property | SourceIP | This value is the IP address on the source server.
Public property | TargetIP | This value is the IP address on the target server.
Public property | TtlValue | This value is the time to live value in seconds.
Top
Methods
 | Name | Description
Public method | ToString | Returns a String that represents this instance. (Overrides ObjectToString.)
Top
See Also

Reference

DoubleTake.Core.Contract.Options Namespace


IPAddressMap Constructor

IPAddressMap Constructor
Initializes a new instance of the IPAddressMap class

Namespace: DoubleTake.Core.Contract.Options
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public IPAddressMap()
Public Sub New
public:
IPAddressMap()
DoubleTake.Core.Contract.Options.IPAddressMap = function();
See Also

Reference

IPAddressMap Class
DoubleTake.Core.Contract.Options Namespace


IPAddressMap Properties

IPAddressMap Properties

The IPAddressMap type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | ShouldUpdateTtl | This value is true if the time to live value should be updated; otherwise, it is false.
Public property | SourceIP | This value is the IP address on the source server.
Public property | TargetIP | This value is the IP address on the target server.
Public property | TtlValue | This value is the time to live value in seconds.
Top
See Also

Reference

IPAddressMap Class
DoubleTake.Core.Contract.Options Namespace


IPAddressMap.ExtensionData Property

IPAddressMapExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract.Options
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

IPAddressMap Class
DoubleTake.Core.Contract.Options Namespace


IPAddressMap.ShouldUpdateTtl Property

IPAddressMapShouldUpdateTtl Property
This value is true if the time to live value should be updated; otherwise, it is false.

Namespace: DoubleTake.Core.Contract.Options
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool ShouldUpdateTtl { get; set; }
Public Property ShouldUpdateTtl As Boolean
    Get
    Set
public:
property bool ShouldUpdateTtl {
    bool get ();
    void set (bool value);
}
function get_ShouldUpdateTtl();
function set_ShouldUpdateTtl(value);

Property Value

Type: Boolean
if the time-to-live value should be updated for this record; otherwise, .
See Also

Reference

IPAddressMap Class
DoubleTake.Core.Contract.Options Namespace


IPAddressMap.SourceIP Property

IPAddressMapSourceIP Property
This value is the IP address on the source server.

Namespace: DoubleTake.Core.Contract.Options
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string SourceIP { get; set; }
Public Property SourceIP As String
    Get
    Set
public:
property String^ SourceIP {
    String^ get ();
    void set (String^ value);
}
function get_SourceIP();
function set_SourceIP(value);

Property Value

Type: String
The IP address on the source server.
See Also

Reference

IPAddressMap Class
DoubleTake.Core.Contract.Options Namespace


IPAddressMap.TargetIP Property

IPAddressMapTargetIP Property
This value is the IP address on the target server.

Namespace: DoubleTake.Core.Contract.Options
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string TargetIP { get; set; }
Public Property TargetIP As String
    Get
    Set
public:
property String^ TargetIP {
    String^ get ();
    void set (String^ value);
}
function get_TargetIP();
function set_TargetIP(value);

Property Value

Type: String
The IP address on the target server.
See Also

Reference

IPAddressMap Class
DoubleTake.Core.Contract.Options Namespace


IPAddressMap.TtlValue Property

IPAddressMapTtlValue Property
This value is the time to live value in seconds.

Namespace: DoubleTake.Core.Contract.Options
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int TtlValue { get; set; }
Public Property TtlValue As Integer
    Get
    Set
public:
property int TtlValue {
    int get ();
    void set (int value);
}
function get_TtlValue();
function set_TtlValue(value);

Property Value

Type: Int32
The TTL value, in seconds.
See Also

Reference

IPAddressMap Class
DoubleTake.Core.Contract.Options Namespace


IPAddressMap Methods

IPAddressMap Methods

The IPAddressMap type exposes the following members.

Methods
 | Name | Description
Public method | ToString | Returns a String that represents this instance. (Overrides ObjectToString.)
Top
See Also

Reference

IPAddressMap Class
DoubleTake.Core.Contract.Options Namespace


IPAddressMap.ToString Method

IPAddressMapToString Method
Returns a String that represents this instance.

Namespace: DoubleTake.Core.Contract.Options
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
function ToString();

Return Value

Type: String
A String that represents this instance.
See Also

Reference

IPAddressMap Class
DoubleTake.Core.Contract.Options Namespace


TargetServiceStatus Enumeration

TargetServiceStatus Enumeration
Represents the state of a service.

Namespace: DoubleTake.Core.Contract.Options
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public enum TargetServiceStatus
Public Enumeration TargetServiceStatus
public enum class TargetServiceStatus
DoubleTake.Core.Contract.Options.TargetServiceStatus = function();
DoubleTake.Core.Contract.Options.TargetServiceStatus.createEnum('DoubleTake.Core.Contract.Options.TargetServiceStatus', false);
Members
Member name | Value | Description
Stopped | 0 | The service is stopped.
Started | 1 | The service is started.
StopPending | 2 | The service is pending a stop.
StartPending | 3 | The service is pending a start.
ResumePending | 4 | The service is pending a resume.
PausePending | 5 | The service is pending a pause.
Paused | 6 | The service is paused.
Unknown | 7 | The state of the service is unknown.
See Also

Reference

DoubleTake.Core.Contract.Options Namespace


TargetServicesToStop Class

TargetServicesToStop Class
Represents how a service is handled on the target server in full-server failover job.
Inheritance Hierarchy
SystemObject
DoubleTake.Core.Contract.OptionsTargetServicesToStop

Namespace: DoubleTake.Core.Contract.Options
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class TargetServicesToStop : IExtensibleDataObject
Public Class TargetServicesToStop
    Implements IExtensibleDataObject
public ref class TargetServicesToStop : IExtensibleDataObject
DoubleTake.Core.Contract.Options.TargetServicesToStop = function();

Type.createClass(
    'DoubleTake.Core.Contract.Options.TargetServicesToStop',
    null,
    IExtensibleDataObject);

The TargetServicesToStop type exposes the following members.

Constructors
 | Name | Description
Public method | TargetServicesToStop | Initializes a new instance of the TargetServicesToStop class
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Failover | This value is true if the service should be started after failover; otherwise, it is false. In addition to starting this service after failover, this value is whether the service will be stopped during failback.
Public property | IsCritical | This value is true if the service is considered critical; otherwise, it is false.
Public property | KeepRunningNonCritical | This value is true if the non-critical service should be kept running; otherwise, it is false.
Public property | ServiceDescription | This value is the service description.
Public property | ServiceName | This value is the name of the service.
Public property | State | This value represents the state of a service
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to this instance. (Overrides ObjectEquals(Object).)
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ObjectGetHashCode.)
Public method | ToString | Returns a System.String that represents the current object (Overrides ObjectToString.)
Top
See Also

Reference

DoubleTake.Core.Contract.Options Namespace


TargetServicesToStop Constructor

TargetServicesToStop Constructor
Initializes a new instance of the TargetServicesToStop class

Namespace: DoubleTake.Core.Contract.Options
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public TargetServicesToStop()
Public Sub New
public:
TargetServicesToStop()
DoubleTake.Core.Contract.Options.TargetServicesToStop = function();
See Also

Reference

TargetServicesToStop Class
DoubleTake.Core.Contract.Options Namespace


TargetServicesToStop Properties

TargetServicesToStop Properties

The TargetServicesToStop type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Failover | This value is true if the service should be started after failover; otherwise, it is false. In addition to starting this service after failover, this value is whether the service will be stopped during failback.
Public property | IsCritical | This value is true if the service is considered critical; otherwise, it is false.
Public property | KeepRunningNonCritical | This value is true if the non-critical service should be kept running; otherwise, it is false.
Public property | ServiceDescription | This value is the service description.
Public property | ServiceName | This value is the name of the service.
Public property | State | This value represents the state of a service
Top
See Also

Reference

TargetServicesToStop Class
DoubleTake.Core.Contract.Options Namespace


TargetServicesToStop.ExtensionData Property

TargetServicesToStopExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract.Options
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

TargetServicesToStop Class
DoubleTake.Core.Contract.Options Namespace


TargetServicesToStop.Failover Property

TargetServicesToStopFailover Property
This value is true if the service should be started after failover; otherwise, it is false. In addition to starting this service after failover, this value is whether the service will be stopped during failback.

Namespace: DoubleTake.Core.Contract.Options
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool Failover { get; set; }
Public Property Failover As Boolean
    Get
    Set
public:
property bool Failover {
    bool get ();
    void set (bool value);
}
function get_Failover();
function set_Failover(value);

Property Value

Type: Boolean
if this service should be started after failover; otherwise, .
Remarks
In addition to starting this service after failover, this value indicates whether the service will be stopped during failback.
See Also

Reference

TargetServicesToStop Class
DoubleTake.Core.Contract.Options Namespace


TargetServicesToStop.IsCritical Property

TargetServicesToStopIsCritical Property
This value is true if the service is considered critical; otherwise, it is false.

Namespace: DoubleTake.Core.Contract.Options
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsCritical { get; set; }
Public Property IsCritical As Boolean
    Get
    Set
public:
property bool IsCritical {
    bool get ();
    void set (bool value);
}
function get_IsCritical();
function set_IsCritical(value);

Property Value

Type: Boolean
if this service is critical; otherwise, .
See Also

Reference

TargetServicesToStop Class
DoubleTake.Core.Contract.Options Namespace


TargetServicesToStop.KeepRunningNonCritical Property

TargetServicesToStopKeepRunningNonCritical Property
This value is true if the non-critical service should be kept running; otherwise, it is false.

Namespace: DoubleTake.Core.Contract.Options
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool KeepRunningNonCritical { get; set; }
Public Property KeepRunningNonCritical As Boolean
    Get
    Set
public:
property bool KeepRunningNonCritical {
    bool get ();
    void set (bool value);
}
function get_KeepRunningNonCritical();
function set_KeepRunningNonCritical(value);

Property Value

Type: Boolean
if this non-critical service should be kept running; otherwise, .
See Also

Reference

TargetServicesToStop Class
DoubleTake.Core.Contract.Options Namespace


TargetServicesToStop.ServiceDescription Property

TargetServicesToStopServiceDescription Property
This value is the service description.

Namespace: DoubleTake.Core.Contract.Options
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string ServiceDescription { get; set; }
Public Property ServiceDescription As String
    Get
    Set
public:
property String^ ServiceDescription {
    String^ get ();
    void set (String^ value);
}
function get_ServiceDescription();
function set_ServiceDescription(value);

Property Value

Type: String
The service description.
See Also

Reference

TargetServicesToStop Class
DoubleTake.Core.Contract.Options Namespace


TargetServicesToStop.ServiceName Property

TargetServicesToStopServiceName Property
This value is the name of the service.

Namespace: DoubleTake.Core.Contract.Options
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string ServiceName { get; set; }
Public Property ServiceName As String
    Get
    Set
public:
property String^ ServiceName {
    String^ get ();
    void set (String^ value);
}
function get_ServiceName();
function set_ServiceName(value);

Property Value

Type: String
The name of the service.
See Also

Reference

TargetServicesToStop Class
DoubleTake.Core.Contract.Options Namespace


TargetServicesToStop.State Property

TargetServicesToStopState Property
This value represents the state of a service

Namespace: DoubleTake.Core.Contract.Options
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public TargetServiceStatus State { get; set; }
Public Property State As TargetServiceStatus
    Get
    Set
public:
property TargetServiceStatus State {
    TargetServiceStatus get ();
    void set (TargetServiceStatus value);
}
function get_State();
function set_State(value);

Property Value

Type: TargetServiceStatus
The state of this server.
See Also

Reference

TargetServicesToStop Class
DoubleTake.Core.Contract.Options Namespace


TargetServicesToStop Methods

TargetServicesToStop Methods

The TargetServicesToStop type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to this instance. (Overrides ObjectEquals(Object).)
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ObjectGetHashCode.)
Public method | ToString | Returns a System.String that represents the current object (Overrides ObjectToString.)
Top
See Also

Reference

TargetServicesToStop Class
DoubleTake.Core.Contract.Options Namespace


TargetServicesToStop.Equals Method

TargetServicesToStopEquals Method
Determines whether the specified Object is equal to this instance.

Namespace: DoubleTake.Core.Contract.Options
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
function Equals(obj);

Parameters

obj
Type: SystemObject
The Object to compare with this instance.

Return Value

Type: Boolean
if the specified Object is equal to this instance; otherwise, .
Exceptions
Exception | Condition
NullReferenceException | The obj parameter is null.
See Also

Reference

TargetServicesToStop Class
DoubleTake.Core.Contract.Options Namespace


TargetServicesToStop.GetHashCode Method

TargetServicesToStopGetHashCode Method
Returns a hash code for this instance.

Namespace: DoubleTake.Core.Contract.Options
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
function GetHashCode();

Return Value

Type: Int32
A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.
See Also

Reference

TargetServicesToStop Class
DoubleTake.Core.Contract.Options Namespace


TargetServicesToStop.ToString Method

TargetServicesToStopToString Method
Returns a System.String that represents the current object

Namespace: DoubleTake.Core.Contract.Options
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
function ToString();

Return Value

Type: String
See Also

Reference

TargetServicesToStop Class
DoubleTake.Core.Contract.Options Namespace


DoubleTake.Core.Contract.UVRA Namespace

DoubleTake.Core.Contract.UVRA Namespace
Classes
 | Class | Description
Public class | LogicalVolume |
Public class | LvmOptions |
Public class | PhysicalVolume |
Public class | VolumeGroup |


LogicalVolume Class

LogicalVolume Class
Inheritance Hierarchy
SystemObject
DoubleTake.Common.ContractPhysicalItem
DoubleTake.Common.ContractVolume
DoubleTake.Core.ContractVolumeOptions
DoubleTake.Core.Contract.UVRALogicalVolume

Namespace: DoubleTake.Core.Contract.UVRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class LogicalVolume : VolumeOptions
Public Class LogicalVolume
    Inherits VolumeOptions
public ref class LogicalVolume : public VolumeOptions
DoubleTake.Core.Contract.UVRA.LogicalVolume = function();

Type.createClass(
    'DoubleTake.Core.Contract.UVRA.LogicalVolume',
    DoubleTake.Core.Contract.VolumeOptions);

The LogicalVolume type exposes the following members.

Constructors
 | Name | Description
Public method | LogicalVolume | Initializes a new instance of the LogicalVolume class
Top
Properties
 | Name | Description
Public property | Attributes | This value represents the file system attributes. (Inherited from PhysicalItem.)
Public property | AvailableFreeSpace | This value is the amount of free space on the volume. (Inherited from Volume.)
Public property | CreationTime | This value is the time when the item was created. (Inherited from PhysicalItem.)
Public property | DesiredSize | This value is the desired size of the new volume. (Inherited from VolumeOptions.)
Public property | DiskControllerType | This value is the disk controller. IDE—Use this value to create an IDE disk. SCSI—Use this value to create a SCSI disk. (Inherited from VolumeOptions.)
Public property | DiskProvisioningType | This value is the disk type. Dynamic—Use this value for ESX thin disks and for Hyper-V dynamic disks. Fixed—Use this value for ESX thick disks and for Hyper-V fixed disks. Flat Disk—Use this value for ESX flat disks. This type is not supported on Hyper-V. (Inherited from VolumeOptions.)
Public property | DriveFormat | This value is the file system format of the volume. (Inherited from Volume.)
Public property | DriveType | This value is the drive type. (Inherited from Volume.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from PhysicalItem.)
Public property | IsContainer | This value is true if the item is a container of other items; otherwise, it is false. (Inherited from PhysicalItem.)
Public property | IsReadOnly | This value is true if the item is read-only (meaning the Saturation cannot be changed); otherwise, it is false. (Inherited from PhysicalItem.)
Public property | IsSystemDrive | This value is true if the volume is the system volume; otherwise, it is false. (Inherited from Volume.)
Public property | ItemType | This value is the type of item. (Inherited from PhysicalItem.)
Public property | Label | This value is the label assigned to the volume. (Inherited from Volume.)
Public property | LastAccessTime | This value is the time when the item was last accessed. (Inherited from PhysicalItem.)
Public property | LastWriteTime | This value is the time when the item was last written to. (Inherited from PhysicalItem.)
Public property | LogicalVolumeName | This value is the name of the logical volume.
Public property | Metadata | This value is any additional metadata that may be displayed for a particular type of item. This metadata is not in any particular format, but you must be able to determine the format and decipher the metadata based on the type. (Inherited from PhysicalItem.)
Public property | Name | This value is the name of the item. Typically, this name is used for display in the user interface. (Inherited from PhysicalItem.)
Public property | Path | This value is the path of the item. (Inherited from PhysicalItem.)
Public property | PreexistingDiskPath | This value is the full path and file name of an existing virtual disk that you want to reuse. If this value is null, a new virtual disk will be created. (Inherited from VolumeOptions.)
Public property | Saturation | This value represents the saturation level of the item. Typically, this value is used to display a visual state in the user interface. (Inherited from PhysicalItem.)
Public property | Size | This value is the physical size of the item. (Inherited from PhysicalItem.)
Public property | TotalSize | This value is the total size of the volume. (Inherited from Volume.)
Public property | VirtualDiskPath | This value is the path on the host where the volume should be stored. (Inherited from VolumeOptions.)
Public property | VolumeSignature | This value is the volume signature. (Inherited from VolumeOptions.)
Public property | VolumeType | This value is the type of volume. (Inherited from Volume.)
Top
Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from VolumeOptions.)
Top
See Also

Reference

DoubleTake.Core.Contract.UVRA Namespace


LogicalVolume Constructor

LogicalVolume Constructor
Initializes a new instance of the LogicalVolume class

Namespace: DoubleTake.Core.Contract.UVRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public LogicalVolume()
Public Sub New
public:
LogicalVolume()
DoubleTake.Core.Contract.UVRA.LogicalVolume = function();
See Also

Reference

LogicalVolume Class
DoubleTake.Core.Contract.UVRA Namespace


LogicalVolume Properties

LogicalVolume Properties

The LogicalVolume type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | This value represents the file system attributes. (Inherited from PhysicalItem.)
Public property | AvailableFreeSpace | This value is the amount of free space on the volume. (Inherited from Volume.)
Public property | CreationTime | This value is the time when the item was created. (Inherited from PhysicalItem.)
Public property | DesiredSize | This value is the desired size of the new volume. (Inherited from VolumeOptions.)
Public property | DiskControllerType | This value is the disk controller. IDE—Use this value to create an IDE disk. SCSI—Use this value to create a SCSI disk. (Inherited from VolumeOptions.)
Public property | DiskProvisioningType | This value is the disk type. Dynamic—Use this value for ESX thin disks and for Hyper-V dynamic disks. Fixed—Use this value for ESX thick disks and for Hyper-V fixed disks. Flat Disk—Use this value for ESX flat disks. This type is not supported on Hyper-V. (Inherited from VolumeOptions.)
Public property | DriveFormat | This value is the file system format of the volume. (Inherited from Volume.)
Public property | DriveType | This value is the drive type. (Inherited from Volume.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from PhysicalItem.)
Public property | IsContainer | This value is true if the item is a container of other items; otherwise, it is false. (Inherited from PhysicalItem.)
Public property | IsReadOnly | This value is true if the item is read-only (meaning the Saturation cannot be changed); otherwise, it is false. (Inherited from PhysicalItem.)
Public property | IsSystemDrive | This value is true if the volume is the system volume; otherwise, it is false. (Inherited from Volume.)
Public property | ItemType | This value is the type of item. (Inherited from PhysicalItem.)
Public property | Label | This value is the label assigned to the volume. (Inherited from Volume.)
Public property | LastAccessTime | This value is the time when the item was last accessed. (Inherited from PhysicalItem.)
Public property | LastWriteTime | This value is the time when the item was last written to. (Inherited from PhysicalItem.)
Public property | LogicalVolumeName | This value is the name of the logical volume.
Public property | Metadata | This value is any additional metadata that may be displayed for a particular type of item. This metadata is not in any particular format, but you must be able to determine the format and decipher the metadata based on the type. (Inherited from PhysicalItem.)
Public property | Name | This value is the name of the item. Typically, this name is used for display in the user interface. (Inherited from PhysicalItem.)
Public property | Path | This value is the path of the item. (Inherited from PhysicalItem.)
Public property | PreexistingDiskPath | This value is the full path and file name of an existing virtual disk that you want to reuse. If this value is null, a new virtual disk will be created. (Inherited from VolumeOptions.)
Public property | Saturation | This value represents the saturation level of the item. Typically, this value is used to display a visual state in the user interface. (Inherited from PhysicalItem.)
Public property | Size | This value is the physical size of the item. (Inherited from PhysicalItem.)
Public property | TotalSize | This value is the total size of the volume. (Inherited from Volume.)
Public property | VirtualDiskPath | This value is the path on the host where the volume should be stored. (Inherited from VolumeOptions.)
Public property | VolumeSignature | This value is the volume signature. (Inherited from VolumeOptions.)
Public property | VolumeType | This value is the type of volume. (Inherited from Volume.)
Top
See Also

Reference

LogicalVolume Class
DoubleTake.Core.Contract.UVRA Namespace


LogicalVolume.LogicalVolumeName Property

LogicalVolumeLogicalVolumeName Property
This value is the name of the logical volume.

Namespace: DoubleTake.Core.Contract.UVRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string LogicalVolumeName { get; set; }
Public Property LogicalVolumeName As String
    Get
    Set
public:
property String^ LogicalVolumeName {
    String^ get ();
    void set (String^ value);
}
function get_LogicalVolumeName();
function set_LogicalVolumeName(value);

Property Value

Type: String
The logical volume name.
See Also

Reference

LogicalVolume Class
DoubleTake.Core.Contract.UVRA Namespace


LogicalVolume Methods

LogicalVolume Methods

The LogicalVolume type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from VolumeOptions.)
Top
See Also

Reference

LogicalVolume Class
DoubleTake.Core.Contract.UVRA Namespace


LvmOptions Class

LvmOptions Class
Inheritance Hierarchy
SystemObject
DoubleTake.Core.Contract.UVRALvmOptions

Namespace: DoubleTake.Core.Contract.UVRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class LvmOptions : IExtensibleDataObject
Public Class LvmOptions
    Implements IExtensibleDataObject
public ref class LvmOptions : IExtensibleDataObject
DoubleTake.Core.Contract.UVRA.LvmOptions = function();

Type.createClass(
    'DoubleTake.Core.Contract.UVRA.LvmOptions',
    null,
    IExtensibleDataObject);

The LvmOptions type exposes the following members.

Constructors
 | Name | Description
Public method | LvmOptions | Initializes a new instance of the LvmOptions class
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | VolumeGroup | This value represents the volume group properties.
Top
See Also

Reference

DoubleTake.Core.Contract.UVRA Namespace


LvmOptions Constructor

LvmOptions Constructor
Initializes a new instance of the LvmOptions class

Namespace: DoubleTake.Core.Contract.UVRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public LvmOptions()
Public Sub New
public:
LvmOptions()
DoubleTake.Core.Contract.UVRA.LvmOptions = function();
See Also

Reference

LvmOptions Class
DoubleTake.Core.Contract.UVRA Namespace


LvmOptions Properties

LvmOptions Properties

The LvmOptions type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | VolumeGroup | This value represents the volume group properties.
Top
See Also

Reference

LvmOptions Class
DoubleTake.Core.Contract.UVRA Namespace


LvmOptions.ExtensionData Property

LvmOptionsExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract.UVRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

LvmOptions Class
DoubleTake.Core.Contract.UVRA Namespace


LvmOptions.VolumeGroup Property

LvmOptionsVolumeGroup Property
This value represents the volume group properties.

Namespace: DoubleTake.Core.Contract.UVRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VolumeGroup[] VolumeGroup { get; set; }
Public Property VolumeGroup As VolumeGroup()
    Get
    Set
public:
property array<VolumeGroup^>^ VolumeGroup {
    array<VolumeGroup^>^ get ();
    void set (array<VolumeGroup^>^ value);
}
function get_VolumeGroup();
function set_VolumeGroup(value);

Property Value

Type: VolumeGroup
See Also

Reference

LvmOptions Class
DoubleTake.Core.Contract.UVRA Namespace


PhysicalVolume Class

PhysicalVolume Class
Inheritance Hierarchy
SystemObject
DoubleTake.Common.ContractPhysicalItem
DoubleTake.Common.ContractVolume
DoubleTake.Core.ContractVolumeOptions
DoubleTake.Core.Contract.UVRAPhysicalVolume

Namespace: DoubleTake.Core.Contract.UVRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class PhysicalVolume : VolumeOptions
Public Class PhysicalVolume
    Inherits VolumeOptions
public ref class PhysicalVolume : public VolumeOptions
DoubleTake.Core.Contract.UVRA.PhysicalVolume = function();

Type.createClass(
    'DoubleTake.Core.Contract.UVRA.PhysicalVolume',
    DoubleTake.Core.Contract.VolumeOptions);

The PhysicalVolume type exposes the following members.

Constructors
 | Name | Description
Public method | PhysicalVolume | Initializes a new instance of the PhysicalVolume class
Top
Properties
 | Name | Description
Public property | Attributes | This value represents the file system attributes. (Inherited from PhysicalItem.)
Public property | AvailableFreeSpace | This value is the amount of free space on the volume. (Inherited from Volume.)
Public property | CreationTime | This value is the time when the item was created. (Inherited from PhysicalItem.)
Public property | DesiredSize | This value is the desired size of the new volume. (Inherited from VolumeOptions.)
Public property | DiskControllerType | This value is the disk controller. IDE—Use this value to create an IDE disk. SCSI—Use this value to create a SCSI disk. (Inherited from VolumeOptions.)
Public property | DiskProvisioningType | This value is the disk type. Dynamic—Use this value for ESX thin disks and for Hyper-V dynamic disks. Fixed—Use this value for ESX thick disks and for Hyper-V fixed disks. Flat Disk—Use this value for ESX flat disks. This type is not supported on Hyper-V. (Inherited from VolumeOptions.)
Public property | DriveFormat | This value is the file system format of the volume. (Inherited from Volume.)
Public property | DriveType | This value is the drive type. (Inherited from Volume.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from PhysicalItem.)
Public property | IsContainer | This value is true if the item is a container of other items; otherwise, it is false. (Inherited from PhysicalItem.)
Public property | IsReadOnly | This value is true if the item is read-only (meaning the Saturation cannot be changed); otherwise, it is false. (Inherited from PhysicalItem.)
Public property | IsSystemDrive | This value is true if the volume is the system volume; otherwise, it is false. (Inherited from Volume.)
Public property | ItemType | This value is the type of item. (Inherited from PhysicalItem.)
Public property | Label | This value is the label assigned to the volume. (Inherited from Volume.)
Public property | LastAccessTime | This value is the time when the item was last accessed. (Inherited from PhysicalItem.)
Public property | LastWriteTime | This value is the time when the item was last written to. (Inherited from PhysicalItem.)
Public property | Metadata | This value is any additional metadata that may be displayed for a particular type of item. This metadata is not in any particular format, but you must be able to determine the format and decipher the metadata based on the type. (Inherited from PhysicalItem.)
Public property | Name | This value is the name of the item. Typically, this name is used for display in the user interface. (Inherited from PhysicalItem.)
Public property | Path | This value is the path of the item. (Inherited from PhysicalItem.)
Public property | PreexistingDiskPath | This value is the full path and file name of an existing virtual disk that you want to reuse. If this value is null, a new virtual disk will be created. (Inherited from VolumeOptions.)
Public property | Saturation | This value represents the saturation level of the item. Typically, this value is used to display a visual state in the user interface. (Inherited from PhysicalItem.)
Public property | Size | This value is the physical size of the item. (Inherited from PhysicalItem.)
Public property | TotalSize | This value is the total size of the volume. (Inherited from Volume.)
Public property | VirtualDiskPath | This value is the path on the host where the volume should be stored. (Inherited from VolumeOptions.)
Public property | VolumeSignature | This value is the volume signature. (Inherited from VolumeOptions.)
Public property | VolumeType | This value is the type of volume. (Inherited from Volume.)
Top
Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from VolumeOptions.)
Top
See Also

Reference

DoubleTake.Core.Contract.UVRA Namespace


PhysicalVolume Constructor

PhysicalVolume Constructor
Initializes a new instance of the PhysicalVolume class

Namespace: DoubleTake.Core.Contract.UVRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public PhysicalVolume()
Public Sub New
public:
PhysicalVolume()
DoubleTake.Core.Contract.UVRA.PhysicalVolume = function();
See Also

Reference

PhysicalVolume Class
DoubleTake.Core.Contract.UVRA Namespace


PhysicalVolume Properties

PhysicalVolume Properties

The PhysicalVolume type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | This value represents the file system attributes. (Inherited from PhysicalItem.)
Public property | AvailableFreeSpace | This value is the amount of free space on the volume. (Inherited from Volume.)
Public property | CreationTime | This value is the time when the item was created. (Inherited from PhysicalItem.)
Public property | DesiredSize | This value is the desired size of the new volume. (Inherited from VolumeOptions.)
Public property | DiskControllerType | This value is the disk controller. IDE—Use this value to create an IDE disk. SCSI—Use this value to create a SCSI disk. (Inherited from VolumeOptions.)
Public property | DiskProvisioningType | This value is the disk type. Dynamic—Use this value for ESX thin disks and for Hyper-V dynamic disks. Fixed—Use this value for ESX thick disks and for Hyper-V fixed disks. Flat Disk—Use this value for ESX flat disks. This type is not supported on Hyper-V. (Inherited from VolumeOptions.)
Public property | DriveFormat | This value is the file system format of the volume. (Inherited from Volume.)
Public property | DriveType | This value is the drive type. (Inherited from Volume.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from PhysicalItem.)
Public property | IsContainer | This value is true if the item is a container of other items; otherwise, it is false. (Inherited from PhysicalItem.)
Public property | IsReadOnly | This value is true if the item is read-only (meaning the Saturation cannot be changed); otherwise, it is false. (Inherited from PhysicalItem.)
Public property | IsSystemDrive | This value is true if the volume is the system volume; otherwise, it is false. (Inherited from Volume.)
Public property | ItemType | This value is the type of item. (Inherited from PhysicalItem.)
Public property | Label | This value is the label assigned to the volume. (Inherited from Volume.)
Public property | LastAccessTime | This value is the time when the item was last accessed. (Inherited from PhysicalItem.)
Public property | LastWriteTime | This value is the time when the item was last written to. (Inherited from PhysicalItem.)
Public property | Metadata | This value is any additional metadata that may be displayed for a particular type of item. This metadata is not in any particular format, but you must be able to determine the format and decipher the metadata based on the type. (Inherited from PhysicalItem.)
Public property | Name | This value is the name of the item. Typically, this name is used for display in the user interface. (Inherited from PhysicalItem.)
Public property | Path | This value is the path of the item. (Inherited from PhysicalItem.)
Public property | PreexistingDiskPath | This value is the full path and file name of an existing virtual disk that you want to reuse. If this value is null, a new virtual disk will be created. (Inherited from VolumeOptions.)
Public property | Saturation | This value represents the saturation level of the item. Typically, this value is used to display a visual state in the user interface. (Inherited from PhysicalItem.)
Public property | Size | This value is the physical size of the item. (Inherited from PhysicalItem.)
Public property | TotalSize | This value is the total size of the volume. (Inherited from Volume.)
Public property | VirtualDiskPath | This value is the path on the host where the volume should be stored. (Inherited from VolumeOptions.)
Public property | VolumeSignature | This value is the volume signature. (Inherited from VolumeOptions.)
Public property | VolumeType | This value is the type of volume. (Inherited from Volume.)
Top
See Also

Reference

PhysicalVolume Class
DoubleTake.Core.Contract.UVRA Namespace


PhysicalVolume Methods

PhysicalVolume Methods

The PhysicalVolume type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from VolumeOptions.)
Top
See Also

Reference

PhysicalVolume Class
DoubleTake.Core.Contract.UVRA Namespace


VolumeGroup Class

VolumeGroup Class
Inheritance Hierarchy
SystemObject
DoubleTake.Core.Contract.UVRAVolumeGroup

Namespace: DoubleTake.Core.Contract.UVRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class VolumeGroup : IExtensibleDataObject
Public Class VolumeGroup
    Implements IExtensibleDataObject
public ref class VolumeGroup : IExtensibleDataObject
DoubleTake.Core.Contract.UVRA.VolumeGroup = function();

Type.createClass(
    'DoubleTake.Core.Contract.UVRA.VolumeGroup',
    null,
    IExtensibleDataObject);

The VolumeGroup type exposes the following members.

Constructors
 | Name | Description
Public method | VolumeGroup | Initializes a new instance of the VolumeGroup class
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | LogicalVolume | This value represents the logical volumes in the volume group.
Public property | MaxPhysicalVolumeSize | This value is the maximum size, in bytes, of the virtual disks used to create the volume group. The default value is equal to the maximum size that can be attached to the datastore you selected. That will depend on your ESX version, your file system version, and the block size of your datastore.
Public property | Name | This value is the name of the volume group on the source.
Public property | PhysicalVolume | This value represents the physical volumes in the volume group.
Public property | PreexistingDisksPath | This value is the full path and file name of an existing virtual disk that you want to reuse. If this value is null, a new virtual disk will be created.
Public property | SourceVolumeGroupSize | This value is the size of the volume group on the source.
Top
See Also

Reference

DoubleTake.Core.Contract.UVRA Namespace


VolumeGroup Constructor

VolumeGroup Constructor
Initializes a new instance of the VolumeGroup class

Namespace: DoubleTake.Core.Contract.UVRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VolumeGroup()
Public Sub New
public:
VolumeGroup()
DoubleTake.Core.Contract.UVRA.VolumeGroup = function();
See Also

Reference

VolumeGroup Class
DoubleTake.Core.Contract.UVRA Namespace


VolumeGroup Properties

VolumeGroup Properties

The VolumeGroup type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | LogicalVolume | This value represents the logical volumes in the volume group.
Public property | MaxPhysicalVolumeSize | This value is the maximum size, in bytes, of the virtual disks used to create the volume group. The default value is equal to the maximum size that can be attached to the datastore you selected. That will depend on your ESX version, your file system version, and the block size of your datastore.
Public property | Name | This value is the name of the volume group on the source.
Public property | PhysicalVolume | This value represents the physical volumes in the volume group.
Public property | PreexistingDisksPath | This value is the full path and file name of an existing virtual disk that you want to reuse. If this value is null, a new virtual disk will be created.
Public property | SourceVolumeGroupSize | This value is the size of the volume group on the source.
Top
See Also

Reference

VolumeGroup Class
DoubleTake.Core.Contract.UVRA Namespace


VolumeGroup.ExtensionData Property

VolumeGroupExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract.UVRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

VolumeGroup Class
DoubleTake.Core.Contract.UVRA Namespace


VolumeGroup.LogicalVolume Property

VolumeGroupLogicalVolume Property
This value represents the logical volumes in the volume group.

Namespace: DoubleTake.Core.Contract.UVRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public LogicalVolume[] LogicalVolume { get; set; }
Public Property LogicalVolume As LogicalVolume()
    Get
    Set
public:
property array<LogicalVolume^>^ LogicalVolume {
    array<LogicalVolume^>^ get ();
    void set (array<LogicalVolume^>^ value);
}
function get_LogicalVolume();
function set_LogicalVolume(value);

Property Value

Type: LogicalVolume
See Also

Reference

VolumeGroup Class
DoubleTake.Core.Contract.UVRA Namespace


VolumeGroup.MaxPhysicalVolumeSize Property

VolumeGroupMaxPhysicalVolumeSize Property
This value is the maximum size, in bytes, of the virtual disks used to create the volume group. The default value is equal to the maximum size that can be attached to the datastore you selected. That will depend on your ESX version, your file system version, and the block size of your datastore.

Namespace: DoubleTake.Core.Contract.UVRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public long MaxPhysicalVolumeSize { get; set; }
Public Property MaxPhysicalVolumeSize As Long
    Get
    Set
public:
property long long MaxPhysicalVolumeSize {
    long long get ();
    void set (long long value);
}
function get_MaxPhysicalVolumeSize();
function set_MaxPhysicalVolumeSize(value);

Property Value

Type: Int64
See Also

Reference

VolumeGroup Class
DoubleTake.Core.Contract.UVRA Namespace


VolumeGroup.Name Property

VolumeGroupName Property
This value is the name of the volume group on the source.

Namespace: DoubleTake.Core.Contract.UVRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
function get_Name();
function set_Name(value);

Property Value

Type: String
See Also

Reference

VolumeGroup Class
DoubleTake.Core.Contract.UVRA Namespace


VolumeGroup.PhysicalVolume Property

VolumeGroupPhysicalVolume Property
This value represents the physical volumes in the volume group.

Namespace: DoubleTake.Core.Contract.UVRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public PhysicalVolume[] PhysicalVolume { get; set; }
Public Property PhysicalVolume As PhysicalVolume()
    Get
    Set
public:
property array<PhysicalVolume^>^ PhysicalVolume {
    array<PhysicalVolume^>^ get ();
    void set (array<PhysicalVolume^>^ value);
}
function get_PhysicalVolume();
function set_PhysicalVolume(value);

Property Value

Type: PhysicalVolume
The PhysicalVolumes
See Also

Reference

VolumeGroup Class
DoubleTake.Core.Contract.UVRA Namespace


VolumeGroup.PreexistingDisksPath Property

VolumeGroupPreexistingDisksPath Property
This value is the full path and file name of an existing virtual disk that you want to reuse. If this value is null, a new virtual disk will be created.

Namespace: DoubleTake.Core.Contract.UVRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string[] PreexistingDisksPath { get; set; }
Public Property PreexistingDisksPath As String()
    Get
    Set
public:
property array<String^>^ PreexistingDisksPath {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
function get_PreexistingDisksPath();
function set_PreexistingDisksPath(value);

Property Value

Type: String
See Also

Reference

VolumeGroup Class
DoubleTake.Core.Contract.UVRA Namespace


VolumeGroup.SourceVolumeGroupSize Property

VolumeGroupSourceVolumeGroupSize Property
This value is the size of the volume group on the source.

Namespace: DoubleTake.Core.Contract.UVRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public long SourceVolumeGroupSize { get; set; }
Public Property SourceVolumeGroupSize As Long
    Get
    Set
public:
property long long SourceVolumeGroupSize {
    long long get ();
    void set (long long value);
}
function get_SourceVolumeGroupSize();
function set_SourceVolumeGroupSize(value);

Property Value

Type: Int64
See Also

Reference

VolumeGroup Class
DoubleTake.Core.Contract.UVRA Namespace


DoubleTake.Diagnostics.Contract Namespace

DoubleTake.Diagnostics.Contract Namespace
Classes
 | Class | Description
Public class | DtInfoCollectionStatus |
Public class | LogMessage | Represents an log message in a Double-Take message log.
Enumerations
 | Enumeration | Description
Public enumeration | DtInfoCollectionProgress |


DtInfoCollectionProgress Enumeration

DtInfoCollectionProgress Enumeration

Namespace: DoubleTake.Diagnostics.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public enum DtInfoCollectionProgress
Public Enumeration DtInfoCollectionProgress
public enum class DtInfoCollectionProgress
DoubleTake.Diagnostics.Contract.DtInfoCollectionProgress = function();
DoubleTake.Diagnostics.Contract.DtInfoCollectionProgress.createEnum('DoubleTake.Diagnostics.Contract.DtInfoCollectionProgress', false);
Members
Member name | Value | Description
Generating | 0 |
Buffering | 1 |
DataAvailable | 2 |
Complete | 3 |
Error | 4 |
Canceled | 5 |
See Also

Reference

DoubleTake.Diagnostics.Contract Namespace


DtInfoCollectionStatus Class

DtInfoCollectionStatus Class
Inheritance Hierarchy
SystemObject
DoubleTake.Diagnostics.ContractDtInfoCollectionStatus

Namespace: DoubleTake.Diagnostics.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class DtInfoCollectionStatus
Public Class DtInfoCollectionStatus
public ref class DtInfoCollectionStatus
DoubleTake.Diagnostics.Contract.DtInfoCollectionStatus = function();

Type.createClass(
    'DoubleTake.Diagnostics.Contract.DtInfoCollectionStatus');

The DtInfoCollectionStatus type exposes the following members.

Constructors
 | Name | Description
Public method | DtInfoCollectionStatus | Initializes a new instance of the DtInfoCollectionStatus class
Top
Fields
 | Name | Description
Public field | ArchiveName |
Public field | Data |
Public field | ErrorMessage |
Public field | Progress |
Top
See Also

Reference

DoubleTake.Diagnostics.Contract Namespace


DtInfoCollectionStatus Constructor

DtInfoCollectionStatus Constructor
Initializes a new instance of the DtInfoCollectionStatus class

Namespace: DoubleTake.Diagnostics.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public DtInfoCollectionStatus()
Public Sub New
public:
DtInfoCollectionStatus()
DoubleTake.Diagnostics.Contract.DtInfoCollectionStatus = function();
See Also

Reference

DtInfoCollectionStatus Class
DoubleTake.Diagnostics.Contract Namespace


DtInfoCollectionStatus Fields

DtInfoCollectionStatus Fields

The DtInfoCollectionStatus type exposes the following members.

Fields
 | Name | Description
Public field | ArchiveName |
Public field | Data |
Public field | ErrorMessage |
Public field | Progress |
Top
See Also

Reference

DtInfoCollectionStatus Class
DoubleTake.Diagnostics.Contract Namespace


DtInfoCollectionStatus.ArchiveName Field

DtInfoCollectionStatusArchiveName Field

Namespace: DoubleTake.Diagnostics.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string ArchiveName
Public ArchiveName As String
public:
String^ ArchiveName
var ArchiveName

Field Value

Type: String
See Also

Reference

DtInfoCollectionStatus Class
DoubleTake.Diagnostics.Contract Namespace


DtInfoCollectionStatus.Data Field

DtInfoCollectionStatusData Field

Namespace: DoubleTake.Diagnostics.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public byte[][] Data
Public Data As Byte()()
public:
array<array<unsigned char>^>^ Data
var Data

Field Value

Type: Byte
See Also

Reference

DtInfoCollectionStatus Class
DoubleTake.Diagnostics.Contract Namespace


DtInfoCollectionStatus.ErrorMessage Field

DtInfoCollectionStatusErrorMessage Field

Namespace: DoubleTake.Diagnostics.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string ErrorMessage
Public ErrorMessage As String
public:
String^ ErrorMessage
var ErrorMessage

Field Value

Type: String
See Also

Reference

DtInfoCollectionStatus Class
DoubleTake.Diagnostics.Contract Namespace


DtInfoCollectionStatus.Progress Field

DtInfoCollectionStatusProgress Field

Namespace: DoubleTake.Diagnostics.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public DtInfoCollectionProgress Progress
Public Progress As DtInfoCollectionProgress
public:
DtInfoCollectionProgress Progress
var Progress

Field Value

Type: DtInfoCollectionProgress
See Also

Reference

DtInfoCollectionStatus Class
DoubleTake.Diagnostics.Contract Namespace


LogMessage Class

LogMessage Class
Represents an log message in a Double-Take message log.
Inheritance Hierarchy
SystemObject
DoubleTake.Diagnostics.ContractLogMessage

Namespace: DoubleTake.Diagnostics.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class LogMessage : IExtensibleDataObject
Public Class LogMessage
    Implements IExtensibleDataObject
public ref class LogMessage : IExtensibleDataObject
DoubleTake.Diagnostics.Contract.LogMessage = function();

Type.createClass(
    'DoubleTake.Diagnostics.Contract.LogMessage',
    null,
    IExtensibleDataObject);

The LogMessage type exposes the following members.

Constructors
 | Name | Description
Public method | LogMessage | Initializes a new instance of the LogMessage class
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Id | This value is the message ID.
Public property | MessageType | This value is the type of log message.
Public property | ProcessId | This value is the process ID of the process that generated the message.
Public property | Sequence | This value is the sequence number of this message in the log file.
Public property | Text | This value is the content of the log message.
Public property | ThreadId | This value is the thread ID of the thread that generated the message.
Public property | Timestamp | This value is the local time when the message was generated.
Public property | TimestampOffset | This value is the relative UTC time when the message was generated.
Top
See Also

Reference

DoubleTake.Diagnostics.Contract Namespace


LogMessage Constructor

LogMessage Constructor
Initializes a new instance of the LogMessage class

Namespace: DoubleTake.Diagnostics.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public LogMessage()
Public Sub New
public:
LogMessage()
DoubleTake.Diagnostics.Contract.LogMessage = function();
See Also

Reference

LogMessage Class
DoubleTake.Diagnostics.Contract Namespace


LogMessage Properties

LogMessage Properties

The LogMessage type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Id | This value is the message ID.
Public property | MessageType | This value is the type of log message.
Public property | ProcessId | This value is the process ID of the process that generated the message.
Public property | Sequence | This value is the sequence number of this message in the log file.
Public property | Text | This value is the content of the log message.
Public property | ThreadId | This value is the thread ID of the thread that generated the message.
Public property | Timestamp | This value is the local time when the message was generated.
Public property | TimestampOffset | This value is the relative UTC time when the message was generated.
Top
See Also

Reference

LogMessage Class
DoubleTake.Diagnostics.Contract Namespace


LogMessage.ExtensionData Property

LogMessageExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Diagnostics.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

LogMessage Class
DoubleTake.Diagnostics.Contract Namespace


LogMessage.Id Property

LogMessageId Property
This value is the message ID.

Namespace: DoubleTake.Diagnostics.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int Id { get; set; }
Public Property Id As Integer
    Get
    Set
public:
property int Id {
    int get ();
    void set (int value);
}
function get_Id();
function set_Id(value);

Property Value

Type: Int32
The message id.
See Also

Reference

LogMessage Class
DoubleTake.Diagnostics.Contract Namespace


LogMessage.MessageType Property

LogMessageMessageType Property
This value is the type of log message.

Namespace: DoubleTake.Diagnostics.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int MessageType { get; set; }
Public Property MessageType As Integer
    Get
    Set
public:
property int MessageType {
    int get ();
    void set (int value);
}
function get_MessageType();
function set_MessageType(value);

Property Value

Type: Int32
The message type.
See Also

Reference

LogMessage Class
DoubleTake.Diagnostics.Contract Namespace


LogMessage.ProcessId Property

LogMessageProcessId Property
This value is the process ID of the process that generated the message.

Namespace: DoubleTake.Diagnostics.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int ProcessId { get; set; }
Public Property ProcessId As Integer
    Get
    Set
public:
property int ProcessId {
    int get ();
    void set (int value);
}
function get_ProcessId();
function set_ProcessId(value);

Property Value

Type: Int32
The process id.
See Also

Reference

LogMessage Class
DoubleTake.Diagnostics.Contract Namespace


LogMessage.Sequence Property

LogMessageSequence Property
This value is the sequence number of this message in the log file.

Namespace: DoubleTake.Diagnostics.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int Sequence { get; set; }
Public Property Sequence As Integer
    Get
    Set
public:
property int Sequence {
    int get ();
    void set (int value);
}
function get_Sequence();
function set_Sequence(value);

Property Value

Type: Int32
The message's sequence number within the log file.
See Also

Reference

LogMessage Class
DoubleTake.Diagnostics.Contract Namespace


LogMessage.Text Property

LogMessageText Property
This value is the content of the log message.

Namespace: DoubleTake.Diagnostics.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}
function get_Text();
function set_Text(value);

Property Value

Type: String
The textual part of the message.
See Also

Reference

LogMessage Class
DoubleTake.Diagnostics.Contract Namespace


LogMessage.ThreadId Property

LogMessageThreadId Property
This value is the thread ID of the thread that generated the message.

Namespace: DoubleTake.Diagnostics.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int ThreadId { get; set; }
Public Property ThreadId As Integer
    Get
    Set
public:
property int ThreadId {
    int get ();
    void set (int value);
}
function get_ThreadId();
function set_ThreadId(value);

Property Value

Type: Int32
The thread id.
See Also

Reference

LogMessage Class
DoubleTake.Diagnostics.Contract Namespace


LogMessage.Timestamp Property

LogMessageTimestamp Property
This value is the local time when the message was generated.

Namespace: DoubleTake.Diagnostics.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public DateTime Timestamp { get; set; }
Public Property Timestamp As DateTime
    Get
    Set
public:
property DateTime Timestamp {
    DateTime get ();
    void set (DateTime value);
}
function get_Timestamp();
function set_Timestamp(value);

Property Value

Type: DateTime
The message's timestamp.
See Also

Reference

LogMessage Class
DoubleTake.Diagnostics.Contract Namespace


LogMessage.TimestampOffset Property

LogMessageTimestampOffset Property
This value is the relative UTC time when the message was generated.

Namespace: DoubleTake.Diagnostics.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public DateTimeOffset TimestampOffset { get; set; }
Public Property TimestampOffset As DateTimeOffset
    Get
    Set
public:
property DateTimeOffset TimestampOffset {
    DateTimeOffset get ();
    void set (DateTimeOffset value);
}
function get_TimestampOffset();
function set_TimestampOffset(value);

Property Value

Type: DateTimeOffset
The message's timestamp relative to UTC.
See Also

Reference

LogMessage Class
DoubleTake.Diagnostics.Contract Namespace


DoubleTake.Discovery.Contract Namespace

DoubleTake.Discovery.Contract Namespace
Classes
 | Class | Description
Public class | DynamicServiceEndpoint | A service endpoint declared by the Double-Take metaservice.
Interfaces
 | Interface | Description
Public interface | IMetaservice | Describes the Double-Take services available on a host.


DynamicServiceEndpoint Class

DynamicServiceEndpoint Class
A service endpoint declared by the Double-Take metaservice.
Inheritance Hierarchy
SystemObject
DoubleTake.Discovery.ContractDynamicServiceEndpoint

Namespace: DoubleTake.Discovery.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class DynamicServiceEndpoint
Public Class DynamicServiceEndpoint
public ref class DynamicServiceEndpoint
DoubleTake.Discovery.Contract.DynamicServiceEndpoint = function();

Type.createClass(
    'DoubleTake.Discovery.Contract.DynamicServiceEndpoint');

The DynamicServiceEndpoint type exposes the following members.

Constructors
 | Name | Description
Public method | DynamicServiceEndpoint | Initializes a new instance of the DynamicServiceEndpoint class
Top
Fields
 | Name | Description
Public field | Port | The port where the service is hosted.
Public field | ProtocolTags | Attributes, information neccesary to connect.
Public field | RelativeUri | The relative uri where the service is hosted.
Public field | ServiceTag | A service tag associated with the endpoint.
Top
See Also

Reference

DoubleTake.Discovery.Contract Namespace


DynamicServiceEndpoint Constructor

DynamicServiceEndpoint Constructor
Initializes a new instance of the DynamicServiceEndpoint class

Namespace: DoubleTake.Discovery.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public DynamicServiceEndpoint()
Public Sub New
public:
DynamicServiceEndpoint()
DoubleTake.Discovery.Contract.DynamicServiceEndpoint = function();
See Also

Reference

DynamicServiceEndpoint Class
DoubleTake.Discovery.Contract Namespace


DynamicServiceEndpoint Fields

DynamicServiceEndpoint Fields

The DynamicServiceEndpoint type exposes the following members.

Fields
 | Name | Description
Public field | Port | The port where the service is hosted.
Public field | ProtocolTags | Attributes, information neccesary to connect.
Public field | RelativeUri | The relative uri where the service is hosted.
Public field | ServiceTag | A service tag associated with the endpoint.
Top
See Also

Reference

DynamicServiceEndpoint Class
DoubleTake.Discovery.Contract Namespace


DynamicServiceEndpoint.Port Field

DynamicServiceEndpointPort Field
The port where the service is hosted.

Namespace: DoubleTake.Discovery.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int Port
Public Port As Integer
public:
int Port
var Port

Field Value

Type: Int32
See Also

Reference

DynamicServiceEndpoint Class
DoubleTake.Discovery.Contract Namespace


DynamicServiceEndpoint.ProtocolTags Field

DynamicServiceEndpointProtocolTags Field
Attributes, information neccesary to connect.

Namespace: DoubleTake.Discovery.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public IEnumerable<string> ProtocolTags
Public ProtocolTags As IEnumerable(Of String)
public:
IEnumerable<String^>^ ProtocolTags
var ProtocolTags

Field Value

Type: IEnumerable String
Remarks
This list of protocol tags is intended to be a hint to clients. It may include schemes, authentication models, protocols necessary to connect to the service.
See Also

Reference

DynamicServiceEndpoint Class
DoubleTake.Discovery.Contract Namespace


DynamicServiceEndpoint.RelativeUri Field

DynamicServiceEndpointRelativeUri Field
The relative uri where the service is hosted.

Namespace: DoubleTake.Discovery.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string RelativeUri
Public RelativeUri As String
public:
String^ RelativeUri
var RelativeUri

Field Value

Type: String
See Also

Reference

DynamicServiceEndpoint Class
DoubleTake.Discovery.Contract Namespace


DynamicServiceEndpoint.ServiceTag Field

DynamicServiceEndpointServiceTag Field
A service tag associated with the endpoint.

Namespace: DoubleTake.Discovery.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string ServiceTag
Public ServiceTag As String
public:
String^ ServiceTag
var ServiceTag

Field Value

Type: String
See Also

Reference

DynamicServiceEndpoint Class
DoubleTake.Discovery.Contract Namespace


IMetaservice Interface

IMetaservice Interface
Describes the Double-Take services available on a host.

Namespace: DoubleTake.Discovery.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public interface IMetaservice
Public Interface IMetaservice
public interface class IMetaservice
DoubleTake.Discovery.Contract.IMetaservice = function();
DoubleTake.Discovery.Contract.IMetaservice.createInterface('DoubleTake.Discovery.Contract.IMetaservice');

The IMetaservice type exposes the following members.

Methods
 | Name | Description
Public method | BeginGetDynamicServiceEndpoints | Begins an asynchronous operation to get features or services hosted at endpoints that may not be known to clients.
Public method | BeginGetMachineId | Begins an asynchronous operation to get the unique ID of the physical or virtual machine running the service.
Public method | BeginGetServiceTags | Begins an asynchronous operation to get tags representing features or services running on the machine.
Public method | BeginGetVersion | Begins an asynchronous operation to get the install version of the service.
Public method | EndGetDynamicServiceEndpoints | Completes an asynchronous operation to get features or services hosted at endpoints that may not be known to clients.
Public method | EndGetMachineId | Completes an asynchronous operation to get the unique ID of the physical or virtual machine running the service.
Public method | EndGetServiceTags | Completes an asynchronous operation to get tags representing features or services running on the machine.
Public method | EndGetVersion | Completes an asynchronous operation to get the install version of the service.
Public method | GetDynamicServiceEndpoints | Features or services hosted at endpoints that may not be known to clients.
Public method | GetMachineId | The unique ID of the physical or virtual machine running the service.
Public method | GetServiceTags | Tags representing features or services running on the machine.
Public method | GetVersion | The install version of the service.
Top
See Also

Reference

DoubleTake.Discovery.Contract Namespace


IMetaservice Methods

IMetaservice Methods

The IMetaservice type exposes the following members.

Methods
 | Name | Description
Public method | BeginGetDynamicServiceEndpoints | Begins an asynchronous operation to get features or services hosted at endpoints that may not be known to clients.
Public method | BeginGetMachineId | Begins an asynchronous operation to get the unique ID of the physical or virtual machine running the service.
Public method | BeginGetServiceTags | Begins an asynchronous operation to get tags representing features or services running on the machine.
Public method | BeginGetVersion | Begins an asynchronous operation to get the install version of the service.
Public method | EndGetDynamicServiceEndpoints | Completes an asynchronous operation to get features or services hosted at endpoints that may not be known to clients.
Public method | EndGetMachineId | Completes an asynchronous operation to get the unique ID of the physical or virtual machine running the service.
Public method | EndGetServiceTags | Completes an asynchronous operation to get tags representing features or services running on the machine.
Public method | EndGetVersion | Completes an asynchronous operation to get the install version of the service.
Public method | GetDynamicServiceEndpoints | Features or services hosted at endpoints that may not be known to clients.
Public method | GetMachineId | The unique ID of the physical or virtual machine running the service.
Public method | GetServiceTags | Tags representing features or services running on the machine.
Public method | GetVersion | The install version of the service.
Top
See Also

Reference

IMetaservice Interface
DoubleTake.Discovery.Contract Namespace


IMetaservice.BeginGetDynamicServiceEndpoints Method

IMetaserviceBeginGetDynamicServiceEndpoints Method
Begins an asynchronous operation to get features or services hosted at endpoints that may not be known to clients.

Namespace: DoubleTake.Discovery.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
IAsyncResult BeginGetDynamicServiceEndpoints(
    string serviceTag,
    AsyncCallback callback,
    Object asyncState
)
Function BeginGetDynamicServiceEndpoints (
    serviceTag As String,
    callback As AsyncCallback,
    asyncState As Object
) As IAsyncResult
IAsyncResult^ BeginGetDynamicServiceEndpoints(
    String^ serviceTag,
    AsyncCallback^ callback,
    Object^ asyncState
)
function BeginGetDynamicServiceEndpoints(serviceTag, callback, asyncState);

Parameters

serviceTag
Type: SystemString
callback
Type: SystemAsyncCallback
The AsyncCallback delegate that receives notification of the completion of this asynchronous operation.
asyncState
Type: SystemObject
An object, specified by the application, that contains state information associated with this asynchronous operation.

Return Value

Type: IAsyncResult
The IAsyncResult that references this asynchronous operation.
See Also

Reference

IMetaservice Interface
DoubleTake.Discovery.Contract Namespace


IMetaservice.BeginGetMachineId Method

IMetaserviceBeginGetMachineId Method
Begins an asynchronous operation to get the unique ID of the physical or virtual machine running the service.

Namespace: DoubleTake.Discovery.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
IAsyncResult BeginGetMachineId(
    AsyncCallback callback,
    Object asyncState
)
Function BeginGetMachineId (
    callback As AsyncCallback,
    asyncState As Object
) As IAsyncResult
IAsyncResult^ BeginGetMachineId(
    AsyncCallback^ callback,
    Object^ asyncState
)
function BeginGetMachineId(callback, asyncState);

Parameters

callback
Type: SystemAsyncCallback
The AsyncCallback delegate that receives notification of the completion of this asynchronous operation.
asyncState
Type: SystemObject
An object, specified by the application, that contains state information associated with this asynchronous operation.

Return Value

Type: IAsyncResult
The IAsyncResult that references this asynchronous operation.
See Also

Reference

IMetaservice Interface
DoubleTake.Discovery.Contract Namespace


IMetaservice.BeginGetServiceTags Method

IMetaserviceBeginGetServiceTags Method
Begins an asynchronous operation to get tags representing features or services running on the machine.

Namespace: DoubleTake.Discovery.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
IAsyncResult BeginGetServiceTags(
    AsyncCallback callback,
    Object asyncState
)
Function BeginGetServiceTags (
    callback As AsyncCallback,
    asyncState As Object
) As IAsyncResult
IAsyncResult^ BeginGetServiceTags(
    AsyncCallback^ callback,
    Object^ asyncState
)
function BeginGetServiceTags(callback, asyncState);

Parameters

callback
Type: SystemAsyncCallback
The AsyncCallback delegate that receives notification of the completion of this asynchronous operation.
asyncState
Type: SystemObject
An object, specified by the application, that contains state information associated with this asynchronous operation.

Return Value

Type: IAsyncResult
The IAsyncResult that references this asynchronous operation.
See Also

Reference

IMetaservice Interface
DoubleTake.Discovery.Contract Namespace


IMetaservice.BeginGetVersion Method

IMetaserviceBeginGetVersion Method
Begins an asynchronous operation to get the install version of the service.

Namespace: DoubleTake.Discovery.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
IAsyncResult BeginGetVersion(
    AsyncCallback callback,
    Object asyncState
)
Function BeginGetVersion (
    callback As AsyncCallback,
    asyncState As Object
) As IAsyncResult
IAsyncResult^ BeginGetVersion(
    AsyncCallback^ callback,
    Object^ asyncState
)
function BeginGetVersion(callback, asyncState);

Parameters

callback
Type: SystemAsyncCallback
The AsyncCallback delegate that receives notification of the completion of this asynchronous operation.
asyncState
Type: SystemObject
An object, specified by the application, that contains state information associated with this asynchronous operation.

Return Value

Type: IAsyncResult
The IAsyncResult that references this asynchronous operation.
See Also

Reference

IMetaservice Interface
DoubleTake.Discovery.Contract Namespace


IMetaservice.EndGetDynamicServiceEndpoints Method

IMetaserviceEndGetDynamicServiceEndpoints Method
Completes an asynchronous operation to get features or services hosted at endpoints that may not be known to clients.

Namespace: DoubleTake.Discovery.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
IEnumerable<DynamicServiceEndpoint> EndGetDynamicServiceEndpoints(
    IAsyncResult result
)
Function EndGetDynamicServiceEndpoints (
    result As IAsyncResult
) As IEnumerable(Of DynamicServiceEndpoint)
IEnumerable<DynamicServiceEndpoint^>^ EndGetDynamicServiceEndpoints(
    IAsyncResult^ result
)
function EndGetDynamicServiceEndpoints(result);

Parameters

result
Type: SystemIAsyncResult
The IAsyncResult that is returned by a call to the BeginGetDynamicServiceEndpoints(String, AsyncCallback, Object) method.

Return Value

Type: IEnumerable DynamicServiceEndpoint
A list of DynamicServiceEndpoint describing access to each service.
See Also

Reference

IMetaservice Interface
DoubleTake.Discovery.Contract Namespace


IMetaservice.EndGetMachineId Method

IMetaserviceEndGetMachineId Method
Completes an asynchronous operation to get the unique ID of the physical or virtual machine running the service.

Namespace: DoubleTake.Discovery.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
Guid EndGetMachineId(
    IAsyncResult result
)
Function EndGetMachineId (
    result As IAsyncResult
) As Guid
Guid EndGetMachineId(
    IAsyncResult^ result
)
function EndGetMachineId(result);

Parameters

result
Type: SystemIAsyncResult
The IAsyncResult that is returned by a call to the BeginGetMachineId(AsyncCallback, Object) method.

Return Value

Type: Guid
A Guid specific to the machine running the service.
See Also

Reference

IMetaservice Interface
DoubleTake.Discovery.Contract Namespace


IMetaservice.EndGetServiceTags Method

IMetaserviceEndGetServiceTags Method
Completes an asynchronous operation to get tags representing features or services running on the machine.

Namespace: DoubleTake.Discovery.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
IEnumerable<string> EndGetServiceTags(
    IAsyncResult result
)
Function EndGetServiceTags (
    result As IAsyncResult
) As IEnumerable(Of String)
IEnumerable<String^>^ EndGetServiceTags(
    IAsyncResult^ result
)
function EndGetServiceTags(result);

Parameters

result
Type: SystemIAsyncResult
The IAsyncResult that is returned by a call to the BeginGetServiceTags(AsyncCallback, Object) method.

Return Value

Type: IEnumerable String
A collection of strings representing services.
See Also

Reference

IMetaservice Interface
DoubleTake.Discovery.Contract Namespace


IMetaservice.EndGetVersion Method

IMetaserviceEndGetVersion Method
Completes an asynchronous operation to get the install version of the service.

Namespace: DoubleTake.Discovery.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
string EndGetVersion(
    IAsyncResult result
)
Function EndGetVersion (
    result As IAsyncResult
) As String
String^ EndGetVersion(
    IAsyncResult^ result
)
function EndGetVersion(result);

Parameters

result
Type: SystemIAsyncResult
The IAsyncResult that is returned by a call to the BeginGetVersion(AsyncCallback, Object) method.

Return Value

Type: String
A string representation of the install version.
See Also

Reference

IMetaservice Interface
DoubleTake.Discovery.Contract Namespace


IMetaservice.GetDynamicServiceEndpoints Method

IMetaserviceGetDynamicServiceEndpoints Method
Features or services hosted at endpoints that may not be known to clients.

Namespace: DoubleTake.Discovery.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
IEnumerable<DynamicServiceEndpoint> GetDynamicServiceEndpoints(
    string serviceTag
)
Function GetDynamicServiceEndpoints (
    serviceTag As String
) As IEnumerable(Of DynamicServiceEndpoint)
IEnumerable<DynamicServiceEndpoint^>^ GetDynamicServiceEndpoints(
    String^ serviceTag
)
function GetDynamicServiceEndpoints(serviceTag);

Parameters

serviceTag
Type: SystemString
The service tag associated with the feature or service.

Return Value

Type: IEnumerable DynamicServiceEndpoint
A list of DynamicServiceEndpoint describing access to each service.
See Also

Reference

IMetaservice Interface
DoubleTake.Discovery.Contract Namespace


IMetaservice.GetMachineId Method

IMetaserviceGetMachineId Method
The unique ID of the physical or virtual machine running the service.

Namespace: DoubleTake.Discovery.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
Guid GetMachineId()
Function GetMachineId As Guid
Guid GetMachineId()
function GetMachineId();

Return Value

Type: Guid
A Guid specific to the machine running the service.
Remarks
The machine ID is generated at first run. It is a unique number, not a product of any other system identifiers. The machine ID is ignored by full server failover. It remains on the machine where it was generated. The machine ID is regenerated when a machine's BIOS UUID changes. Thus, in Hyper-V and ESX the machine ID is unique between cloned instances.
See Also

Reference

IMetaservice Interface
DoubleTake.Discovery.Contract Namespace


IMetaservice.GetServiceTags Method

IMetaserviceGetServiceTags Method
Tags representing features or services running on the machine.

Namespace: DoubleTake.Discovery.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
IEnumerable<string> GetServiceTags()
Function GetServiceTags As IEnumerable(Of String)
IEnumerable<String^>^ GetServiceTags()
function GetServiceTags();

Return Value

Type: IEnumerable String
A collection of strings representing services.
Remarks
This list of service tags is intended to be a hint to clients. It may include services that aren't currently running, or may not include features that should remain hidden from anonymous discovery.
See Also

Reference

IMetaservice Interface
DoubleTake.Discovery.Contract Namespace


IMetaservice.GetVersion Method

IMetaserviceGetVersion Method
The install version of the service.

Namespace: DoubleTake.Discovery.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
string GetVersion()
Function GetVersion As String
String^ GetVersion()
function GetVersion();

Return Value

Type: String
A string representation of the install version.
Remarks
This value comes from the registry: [HKEY_LOCAL_MACHINE\SOFTWARE\NSI Software\Double-Take\CurrentVersion] "VersionInfo"="[PROD_MAJVER].[PROD_MINVER].[PROD_SERVICEPACK].[PROD_SEQNUMBER].[PROD_HOTFIX].[PROD_BUILDTYPE]"
See Also

Reference

IMetaservice Interface
DoubleTake.Discovery.Contract Namespace


DoubleTake.Dtmu.Contract Namespace

DoubleTake.Dtmu.Contract Namespace
Classes
 | Class | Description
Public class | DtmuActivationStatus |
Public class | JobUsageData |
Public class | UsageData |
Enumerations
 | Enumeration | Description
Public enumeration | DtmuJobStatus |


DtmuActivationStatus Class

DtmuActivationStatus Class
Inheritance Hierarchy
SystemObject
DoubleTake.Dtmu.ContractDtmuActivationStatus

Namespace: DoubleTake.Dtmu.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public sealed class DtmuActivationStatus
Public NotInheritable Class DtmuActivationStatus
public ref class DtmuActivationStatus sealed
DoubleTake.Dtmu.Contract.DtmuActivationStatus = function();

Type.createClass(
    'DoubleTake.Dtmu.Contract.DtmuActivationStatus');

The DtmuActivationStatus type exposes the following members.

Constructors
 | Name | Description
Public method | DtmuActivationStatus | Initializes a new instance of the DtmuActivationStatus class
Top
Properties
 | Name | Description
Public property | Code |
Public property | IsValid |
Public property | MajorVersion |
Public property | MinorVersion |
Public property | ProductCode |
Public property | ProductName |
Top
See Also

Reference

DoubleTake.Dtmu.Contract Namespace


DtmuActivationStatus Constructor

DtmuActivationStatus Constructor
Initializes a new instance of the DtmuActivationStatus class

Namespace: DoubleTake.Dtmu.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public DtmuActivationStatus()
Public Sub New
public:
DtmuActivationStatus()
DoubleTake.Dtmu.Contract.DtmuActivationStatus = function();
See Also

Reference

DtmuActivationStatus Class
DoubleTake.Dtmu.Contract Namespace


DtmuActivationStatus Properties

DtmuActivationStatus Properties

The DtmuActivationStatus type exposes the following members.

Properties
 | Name | Description
Public property | Code |
Public property | IsValid |
Public property | MajorVersion |
Public property | MinorVersion |
Public property | ProductCode |
Public property | ProductName |
Top
See Also

Reference

DtmuActivationStatus Class
DoubleTake.Dtmu.Contract Namespace


DtmuActivationStatus.Code Property

DtmuActivationStatusCode Property

Namespace: DoubleTake.Dtmu.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Code { get; set; }
Public Property Code As String
    Get
    Set
public:
property String^ Code {
    String^ get ();
    void set (String^ value);
}
function get_Code();
function set_Code(value);

Property Value

Type: String
See Also

Reference

DtmuActivationStatus Class
DoubleTake.Dtmu.Contract Namespace


DtmuActivationStatus.IsValid Property

DtmuActivationStatusIsValid Property

Namespace: DoubleTake.Dtmu.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsValid { get; set; }
Public Property IsValid As Boolean
    Get
    Set
public:
property bool IsValid {
    bool get ();
    void set (bool value);
}
function get_IsValid();
function set_IsValid(value);

Property Value

Type: Boolean
See Also

Reference

DtmuActivationStatus Class
DoubleTake.Dtmu.Contract Namespace


DtmuActivationStatus.MajorVersion Property

DtmuActivationStatusMajorVersion Property

Namespace: DoubleTake.Dtmu.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int MajorVersion { get; set; }
Public Property MajorVersion As Integer
    Get
    Set
public:
property int MajorVersion {
    int get ();
    void set (int value);
}
function get_MajorVersion();
function set_MajorVersion(value);

Property Value

Type: Int32
See Also

Reference

DtmuActivationStatus Class
DoubleTake.Dtmu.Contract Namespace


DtmuActivationStatus.MinorVersion Property

DtmuActivationStatusMinorVersion Property

Namespace: DoubleTake.Dtmu.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int MinorVersion { get; set; }
Public Property MinorVersion As Integer
    Get
    Set
public:
property int MinorVersion {
    int get ();
    void set (int value);
}
function get_MinorVersion();
function set_MinorVersion(value);

Property Value

Type: Int32
See Also

Reference

DtmuActivationStatus Class
DoubleTake.Dtmu.Contract Namespace


DtmuActivationStatus.ProductCode Property

DtmuActivationStatusProductCode Property

Namespace: DoubleTake.Dtmu.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int ProductCode { get; set; }
Public Property ProductCode As Integer
    Get
    Set
public:
property int ProductCode {
    int get ();
    void set (int value);
}
function get_ProductCode();
function set_ProductCode(value);

Property Value

Type: Int32
See Also

Reference

DtmuActivationStatus Class
DoubleTake.Dtmu.Contract Namespace


DtmuActivationStatus.ProductName Property

DtmuActivationStatusProductName Property

Namespace: DoubleTake.Dtmu.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string ProductName { get; set; }
Public Property ProductName As String
    Get
    Set
public:
property String^ ProductName {
    String^ get ();
    void set (String^ value);
}
function get_ProductName();
function set_ProductName(value);

Property Value

Type: String
See Also

Reference

DtmuActivationStatus Class
DoubleTake.Dtmu.Contract Namespace


DtmuJobStatus Enumeration

DtmuJobStatus Enumeration

Namespace: DoubleTake.Dtmu.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public enum DtmuJobStatus
Public Enumeration DtmuJobStatus
public enum class DtmuJobStatus
DoubleTake.Dtmu.Contract.DtmuJobStatus = function();
DoubleTake.Dtmu.Contract.DtmuJobStatus.createEnum('DoubleTake.Dtmu.Contract.DtmuJobStatus', false);
Members
Member name | Value | Description
Unknown | 0 |
Ok | 1 |
SourceConnectivityError | 2 |
Error | 3 |
See Also

Reference

DoubleTake.Dtmu.Contract Namespace


JobUsageData Class

JobUsageData Class
Inheritance Hierarchy
SystemObject
DoubleTake.Dtmu.ContractJobUsageData

Namespace: DoubleTake.Dtmu.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public sealed class JobUsageData
Public NotInheritable Class JobUsageData
public ref class JobUsageData sealed
DoubleTake.Dtmu.Contract.JobUsageData = function();

Type.createClass(
    'DoubleTake.Dtmu.Contract.JobUsageData');

The JobUsageData type exposes the following members.

Constructors
 | Name | Description
Public method | JobUsageData | Initializes a new instance of the JobUsageData class
Top
Properties
 | Name | Description
Public property | IsInitialData | Is this the initial data recorded when the job was created?
Public property | JobOrConnectionId | Job or connection ID
Public property | JobOrConnectionName | Job or connection name
Public property | JobOrConnectionType | Job or connection type
Public property | JobStatus | Job status
Public property | PersistencePath | Job persistence path
Public property | SourceActivationStatus | Source activation status
Public property | SourceNetworkId | Source network ID (usually hostname)
Public property | SourceUniqueId | Source unique ID (aka hardware ID)
Public property | TargetNetworkId | Target network ID (usually hostname)
Public property | TargetUniqueId | Target unique ID (aka hardware ID)
Public property | Timestamp | The time when the data was collected
Top
See Also

Reference

DoubleTake.Dtmu.Contract Namespace


JobUsageData Constructor

JobUsageData Constructor
Initializes a new instance of the JobUsageData class

Namespace: DoubleTake.Dtmu.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public JobUsageData()
Public Sub New
public:
JobUsageData()
DoubleTake.Dtmu.Contract.JobUsageData = function();
See Also

Reference

JobUsageData Class
DoubleTake.Dtmu.Contract Namespace


JobUsageData Properties

JobUsageData Properties

The JobUsageData type exposes the following members.

Properties
 | Name | Description
Public property | IsInitialData | Is this the initial data recorded when the job was created?
Public property | JobOrConnectionId | Job or connection ID
Public property | JobOrConnectionName | Job or connection name
Public property | JobOrConnectionType | Job or connection type
Public property | JobStatus | Job status
Public property | PersistencePath | Job persistence path
Public property | SourceActivationStatus | Source activation status
Public property | SourceNetworkId | Source network ID (usually hostname)
Public property | SourceUniqueId | Source unique ID (aka hardware ID)
Public property | TargetNetworkId | Target network ID (usually hostname)
Public property | TargetUniqueId | Target unique ID (aka hardware ID)
Public property | Timestamp | The time when the data was collected
Top
See Also

Reference

JobUsageData Class
DoubleTake.Dtmu.Contract Namespace


JobUsageData.IsInitialData Property

JobUsageDataIsInitialData Property
Is this the initial data recorded when the job was created?

Namespace: DoubleTake.Dtmu.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsInitialData { get; set; }
Public Property IsInitialData As Boolean
    Get
    Set
public:
property bool IsInitialData {
    bool get ();
    void set (bool value);
}
function get_IsInitialData();
function set_IsInitialData(value);

Property Value

Type: Boolean
See Also

Reference

JobUsageData Class
DoubleTake.Dtmu.Contract Namespace


JobUsageData.JobOrConnectionId Property

JobUsageDataJobOrConnectionId Property
Job or connection ID

Namespace: DoubleTake.Dtmu.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Guid JobOrConnectionId { get; set; }
Public Property JobOrConnectionId As Guid
    Get
    Set
public:
property Guid JobOrConnectionId {
    Guid get ();
    void set (Guid value);
}
function get_JobOrConnectionId();
function set_JobOrConnectionId(value);

Property Value

Type: Guid
See Also

Reference

JobUsageData Class
DoubleTake.Dtmu.Contract Namespace


JobUsageData.JobOrConnectionName Property

JobUsageDataJobOrConnectionName Property
Job or connection name

Namespace: DoubleTake.Dtmu.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string JobOrConnectionName { get; set; }
Public Property JobOrConnectionName As String
    Get
    Set
public:
property String^ JobOrConnectionName {
    String^ get ();
    void set (String^ value);
}
function get_JobOrConnectionName();
function set_JobOrConnectionName(value);

Property Value

Type: String
See Also

Reference

JobUsageData Class
DoubleTake.Dtmu.Contract Namespace


JobUsageData.JobOrConnectionType Property

JobUsageDataJobOrConnectionType Property
Job or connection type

Namespace: DoubleTake.Dtmu.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string JobOrConnectionType { get; set; }
Public Property JobOrConnectionType As String
    Get
    Set
public:
property String^ JobOrConnectionType {
    String^ get ();
    void set (String^ value);
}
function get_JobOrConnectionType();
function set_JobOrConnectionType(value);

Property Value

Type: String
See Also

Reference

JobUsageData Class
DoubleTake.Dtmu.Contract Namespace


JobUsageData.JobStatus Property

JobUsageDataJobStatus Property
Job status

Namespace: DoubleTake.Dtmu.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public DtmuJobStatus JobStatus { get; set; }
Public Property JobStatus As DtmuJobStatus
    Get
    Set
public:
property DtmuJobStatus JobStatus {
    DtmuJobStatus get ();
    void set (DtmuJobStatus value);
}
function get_JobStatus();
function set_JobStatus(value);

Property Value

Type: DtmuJobStatus
See Also

Reference

JobUsageData Class
DoubleTake.Dtmu.Contract Namespace


JobUsageData.PersistencePath Property

JobUsageDataPersistencePath Property
Job persistence path

Namespace: DoubleTake.Dtmu.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string PersistencePath { get; set; }
Public Property PersistencePath As String
    Get
    Set
public:
property String^ PersistencePath {
    String^ get ();
    void set (String^ value);
}
function get_PersistencePath();
function set_PersistencePath(value);

Property Value

Type: String
See Also

Reference

JobUsageData Class
DoubleTake.Dtmu.Contract Namespace


JobUsageData.SourceActivationStatus Property

JobUsageDataSourceActivationStatus Property
Source activation status

Namespace: DoubleTake.Dtmu.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public DtmuActivationStatus SourceActivationStatus { get; set; }
Public Property SourceActivationStatus As DtmuActivationStatus
    Get
    Set
public:
property DtmuActivationStatus^ SourceActivationStatus {
    DtmuActivationStatus^ get ();
    void set (DtmuActivationStatus^ value);
}
function get_SourceActivationStatus();
function set_SourceActivationStatus(value);

Property Value

Type: DtmuActivationStatus
See Also

Reference

JobUsageData Class
DoubleTake.Dtmu.Contract Namespace


JobUsageData.SourceNetworkId Property

JobUsageDataSourceNetworkId Property
Source network ID (usually hostname)

Namespace: DoubleTake.Dtmu.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string SourceNetworkId { get; set; }
Public Property SourceNetworkId As String
    Get
    Set
public:
property String^ SourceNetworkId {
    String^ get ();
    void set (String^ value);
}
function get_SourceNetworkId();
function set_SourceNetworkId(value);

Property Value

Type: String
See Also

Reference

JobUsageData Class
DoubleTake.Dtmu.Contract Namespace


JobUsageData.SourceUniqueId Property

JobUsageDataSourceUniqueId Property
Source unique ID (aka hardware ID)

Namespace: DoubleTake.Dtmu.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Guid SourceUniqueId { get; set; }
Public Property SourceUniqueId As Guid
    Get
    Set
public:
property Guid SourceUniqueId {
    Guid get ();
    void set (Guid value);
}
function get_SourceUniqueId();
function set_SourceUniqueId(value);

Property Value

Type: Guid
See Also

Reference

JobUsageData Class
DoubleTake.Dtmu.Contract Namespace


JobUsageData.TargetNetworkId Property

JobUsageDataTargetNetworkId Property
Target network ID (usually hostname)

Namespace: DoubleTake.Dtmu.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string TargetNetworkId { get; set; }
Public Property TargetNetworkId As String
    Get
    Set
public:
property String^ TargetNetworkId {
    String^ get ();
    void set (String^ value);
}
function get_TargetNetworkId();
function set_TargetNetworkId(value);

Property Value

Type: String
See Also

Reference

JobUsageData Class
DoubleTake.Dtmu.Contract Namespace


JobUsageData.TargetUniqueId Property

JobUsageDataTargetUniqueId Property
Target unique ID (aka hardware ID)

Namespace: DoubleTake.Dtmu.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Guid TargetUniqueId { get; set; }
Public Property TargetUniqueId As Guid
    Get
    Set
public:
property Guid TargetUniqueId {
    Guid get ();
    void set (Guid value);
}
function get_TargetUniqueId();
function set_TargetUniqueId(value);

Property Value

Type: Guid
See Also

Reference

JobUsageData Class
DoubleTake.Dtmu.Contract Namespace


JobUsageData.Timestamp Property

JobUsageDataTimestamp Property
The time when the data was collected

Namespace: DoubleTake.Dtmu.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public DateTimeOffset Timestamp { get; set; }
Public Property Timestamp As DateTimeOffset
    Get
    Set
public:
property DateTimeOffset Timestamp {
    DateTimeOffset get ();
    void set (DateTimeOffset value);
}
function get_Timestamp();
function set_Timestamp(value);

Property Value

Type: DateTimeOffset
See Also

Reference

JobUsageData Class
DoubleTake.Dtmu.Contract Namespace


UsageData Class

UsageData Class
Inheritance Hierarchy
SystemObject
DoubleTake.Dtmu.ContractUsageData

Namespace: DoubleTake.Dtmu.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public sealed class UsageData
Public NotInheritable Class UsageData
public ref class UsageData sealed
DoubleTake.Dtmu.Contract.UsageData = function();

Type.createClass(
    'DoubleTake.Dtmu.Contract.UsageData');

The UsageData type exposes the following members.

Constructors
 | Name | Description
Public method | UsageData | Initializes a new instance of the UsageData class
Top
Properties
 | Name | Description
Public property | Data |
Public property | NextCollectionTime |
Top
See Also

Reference

DoubleTake.Dtmu.Contract Namespace


UsageData Constructor

UsageData Constructor
Initializes a new instance of the UsageData class

Namespace: DoubleTake.Dtmu.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public UsageData()
Public Sub New
public:
UsageData()
DoubleTake.Dtmu.Contract.UsageData = function();
See Also

Reference

UsageData Class
DoubleTake.Dtmu.Contract Namespace


UsageData Properties

UsageData Properties

The UsageData type exposes the following members.

Properties
 | Name | Description
Public property | Data |
Public property | NextCollectionTime |
Top
See Also

Reference

UsageData Class
DoubleTake.Dtmu.Contract Namespace


UsageData.Data Property

UsageDataData Property

Namespace: DoubleTake.Dtmu.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public List<JobUsageData> Data { get; set; }
Public Property Data As List(Of JobUsageData)
    Get
    Set
public:
property List<JobUsageData^>^ Data {
    List<JobUsageData^>^ get ();
    void set (List<JobUsageData^>^ value);
}
function get_Data();
function set_Data(value);

Property Value

Type: List JobUsageData
See Also

Reference

UsageData Class
DoubleTake.Dtmu.Contract Namespace


UsageData.NextCollectionTime Property

UsageDataNextCollectionTime Property

Namespace: DoubleTake.Dtmu.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public DateTimeOffset NextCollectionTime { get; set; }
Public Property NextCollectionTime As DateTimeOffset
    Get
    Set
public:
property DateTimeOffset NextCollectionTime {
    DateTimeOffset get ();
    void set (DateTimeOffset value);
}
function get_NextCollectionTime();
function set_NextCollectionTime(value);

Property Value

Type: DateTimeOffset
See Also

Reference

UsageData Class
DoubleTake.Dtmu.Contract Namespace


DoubleTake.Jobs.Contract Namespace

DoubleTake.Jobs.Contract Namespace
Classes
 | Class | Description
Public class | AddressPersistedState |
Public class | ApplicationOptions | Represents options for configuring an application protection job.
Public class | CloudOptions |
Public class | ClusterFilesAndFoldersQualificationResults |
Public class | ClusterOptions | Cluster related job options
Public class | ClusterPersistedState |
Public class | CoreConnectionDetails | Represents details of an underlying engine connection used by a job.
Public class | CoreConnectionOptions | Represents option for configuring an underlying engine connection used by a job.
Public class | CoreMonitorDetails | Represents details of an underlying engine monitor used by a job.
Public class | CoreMonitorOptions | Represents options for configuring an underlying engine monitor used by a job.
Public class | CoreQualificationResults | Represents information that may be needed to configure an engine connection.
Public class | CreateOptions | Represents the options required to create a job.
Public class | CutoverDetails | Represents the details of a cutover operation.
Public class | DeleteOptions | Defines the options provided when deleting a job.
Public class | DnsDomainDetails | Represents a DNS domain that will be updated during DNS failover.
Public class | DNSOptions | Represents the options for DNS failover on a job.
Public class | DnsRecordLockOptions |
Public class | DTAVOptions |
Public class | DTAVQualificationResults |
Public class | DTHVOptions | Represents options for configuring a virtual machine protection job.
Public class | DTHVQualificationResults | Represents information that may be needed to configure a DTHV job.
Public class | EngineControlStatus | Represents the status of an engine connection used by a job.
Public class | ExtendedLowLevelState | ExtendedLowLevelState defines additional information which can be used to describe a particular Low level state as low level state is implemented as a string.
Public class | FailbackOptions | Represents the options used when failing back a job.
Public class | FailoverOptions | Represents the options used when failing over a job.
Public class | FailoverPersistedState |
Public class | Feature | Represents a services endpoint that provides additional features for a job.
Public class | FixJobOptionsTaskStatus | Represents the status of a fixing task.
Public class | FullServerFailoverOptions | Represents options for working with the full server failover feature of a job.
Public class | ImageProtectionOptions | Represents options for working with the image protection feature of a job.
Public class | ImageRecoveryOptions | Represents options for working with the image recovery feature of a job.
Public class | JobAction | Represents an action recently reported by a job.
Public class | JobCredentials | Represents the connection information (address, port, and credentials) required to work with jobs.
Public class | JobDisplayInfo | Represents the current displayed information for a job.
Public class | JobInfo | Represents a job.
Public class | JobOptions | Represents the user-configurable options of a job.
Public class | JobQualificationResults | Defines a set of values that represent the possible options when creating or editing a job.
Public class | JobStatistics | Represents the current statistics for a job.
Public class | JobStatus | Represents the current status of a job.
Public class | JobTypeNames | Defines constants that represent known job type names. These constants are used as values for the JobType property.
Public class | MonitoringOptions |
Public class | RecommendedFailbackOptions | Includes the recommended options for failing back a job and additional information that can be used to customize failback options.
Public class | RecommendedFailoverOptions | Includes the recommended options for failing over a job and additional information that can be used to customize failover options.
Public class | RecommendedJobOptions | Represents the recommended options for a job and potential values for those options.
Public class | RecommendedRestoreOptions | Includes the recommended options for restoring job and additional information that can be used to customize restore options.
Public class | ResourceAndPassiveNodes |
Public class | RestoreOptions | Represents the options used when restoring a job.
Public class | ServiceInformation | Contains information about a service.
Public class | ServiceMonitoringOptions | A data contract representing the options for monitoring services on a source.
Public class | SimpleFailoverMonitorOptions | Represents simple failover monitor options for the jobs (like DTHV) which don't use IP address to monitor
Public class | SourceQualificationFault | This fault is raised when communications with the source server failed while attempting to retrieve data for the purposes of qualifying a job. Qualifying a job typically occurs during the job option recommendation process.
Public class | SystemStateOptions | Represents options for using the system state feature of a job.
Public class | TargetFileServerQualificationResults |
Public class | TargetServicesOptions | Represents options for configuring how target services function after failover.
Public class | UnmanagedConnectionOptions | Represents options for configuring an unmanaged connection job.
Public class | V2VQualificationResults | Represents information that may be needed to configure a V2V job.
Public class | VcdVappOptions | New DTVI for Linux
Public class | VerificationStep | Represents a step in a verification task.
Public class | VerificationTaskStatus | Represents the status of a verification task.
Public class | VRAOptions | Represents options for configuring the Virtual Recovery Assistant feature.
Public class | VRAQualificationResults | Represents information that may be needed to configure a VRA job.
Interfaces
 | Interface | Description
Public interface | IEngineControlManager |
Public interface | IJobConfigurationVerifier | Provides methods for getting default options and verifying those options prior to creating a job.
Public interface | IJobManager | Provides methods for creating and managing jobs on a server.
Public interface | IJobManagerPrivate | Private JobManager interface only to be used internally.
Enumerations
 | Enumeration | Description
Public enumeration | ActionStatus | Represents the status of a job action.
Public enumeration | FailoverMode | Indicates the style of failover.
Public enumeration | FailoverType | Indicates the type of failover.
Public enumeration | Health | Indicates the health of a job.
Public enumeration | HighLevelState | Defines the possible high-level states of a job.
Public enumeration | RestoreStatus | Indicates the status of a restore operation.
Public enumeration | VerificationStatus | Indicates the status of a verification task or step.


ActionStatus Enumeration

ActionStatus Enumeration
Represents the status of a job action.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public enum ActionStatus
Public Enumeration ActionStatus
public enum class ActionStatus
DoubleTake.Jobs.Contract.ActionStatus = function();
DoubleTake.Jobs.Contract.ActionStatus.createEnum('DoubleTake.Jobs.Contract.ActionStatus', false);
Members
Member name | Value | Description
Pending | 0 | The action has not yet started.
Running | 1 | The action is running.
Completed | 2 | The action has completed successfully.
Cancelled | 3 | The action was cancelled.
Faulted | 4 | The action encountered an error.
See Also

Reference

DoubleTake.Jobs.Contract Namespace


AddressPersistedState Class

AddressPersistedState Class
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractAddressPersistedState

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class AddressPersistedState
Public Class AddressPersistedState
public ref class AddressPersistedState
DoubleTake.Jobs.Contract.AddressPersistedState = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.AddressPersistedState');

The AddressPersistedState type exposes the following members.

Constructors
 | Name | Description
Public method | AddressPersistedState | Initializes a new instance of the AddressPersistedState class
Top
Fields
 | Name | Description
Public field | NteContext |
Public field | SourceAddresss |
Public field | TargetNic |
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


AddressPersistedState Constructor

AddressPersistedState Constructor
Initializes a new instance of the AddressPersistedState class

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public AddressPersistedState()
Public Sub New
public:
AddressPersistedState()
DoubleTake.Jobs.Contract.AddressPersistedState = function();
See Also

Reference

AddressPersistedState Class
DoubleTake.Jobs.Contract Namespace


AddressPersistedState Fields

AddressPersistedState Fields

The AddressPersistedState type exposes the following members.

Fields
 | Name | Description
Public field | NteContext |
Public field | SourceAddresss |
Public field | TargetNic |
Top
See Also

Reference

AddressPersistedState Class
DoubleTake.Jobs.Contract Namespace


AddressPersistedState.NteContext Field

AddressPersistedStateNteContext Field

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int NteContext
Public NteContext As Integer
public:
int NteContext
var NteContext

Field Value

Type: Int32
See Also

Reference

AddressPersistedState Class
DoubleTake.Jobs.Contract Namespace


AddressPersistedState.SourceAddresss Field

AddressPersistedStateSourceAddresss Field

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string SourceAddresss
Public SourceAddresss As String
public:
String^ SourceAddresss
var SourceAddresss

Field Value

Type: String
See Also

Reference

AddressPersistedState Class
DoubleTake.Jobs.Contract Namespace


AddressPersistedState.TargetNic Field

AddressPersistedStateTargetNic Field

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string TargetNic
Public TargetNic As String
public:
String^ TargetNic
var TargetNic

Field Value

Type: String
See Also

Reference

AddressPersistedState Class
DoubleTake.Jobs.Contract Namespace


ApplicationOptions Class

ApplicationOptions Class
Represents options for configuring an application protection job.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractApplicationOptions

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class ApplicationOptions : IExtensibleDataObject
Public Class ApplicationOptions
    Implements IExtensibleDataObject
public ref class ApplicationOptions : IExtensibleDataObject
DoubleTake.Jobs.Contract.ApplicationOptions = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.ApplicationOptions',
    null,
    IExtensibleDataObject);

The ApplicationOptions type exposes the following members.

Constructors
 | Name | Description
Public method | ApplicationOptions | Initializes a new instance of the ApplicationOptions class
Top
Properties
 | Name | Description
Public property | AagInstances | This value is the instance name corresponding to the SQL AlwaysOn Availability Group Server. This value should never contain more than one entry.
Public property | DagTargetPublicFolderDataPath | This value is the public folder data path for a DAG target.
Public property | DnsRecordLocks | Do not use this property. Double-Take uses it internally.
Public property | ExchangeCredentials | These values are for Exchange credentials.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | IsAag | Do not use this property. Double-Take uses it internally.
Public property | IsDag | This value is true if a DAG environment; otherwise, it is false.
Public property | MonitoredServiceRepeatCount | This property is no longer used. See MonitoringOptions.ServiceMonitoringOptions.
Public property | MonitoredServices | This property is no longer used. See MonitorConfiguration.ScriptMonitorName.
Public property | MonitorScript | This property is no longer used. See CoreMonitorOptions.MonitorConfiguration.ScriptMonitorName.
Public property | RestartService | This property is no longer used. See MonitoringOptions.ServiceMonitoringOptions.
Public property | SourceDomain | This value is the source server's primary domain.
Public property | SourceName | This value is the name of the source server.
Public property | TargetDomain | This value is the target server's primary domain.
Public property | TargetName | This value is the name of the target server.
Public property | TestPostFailoverScript | This value is the path and name of the script to run after the target is brought online during a test failover.
Public property | TestPostFailoverScriptArguments | This value is the arguments for the TestPostFailoverScript to run.
Public property | TestPreFailbackScript | This value is the path and name of the script to run before failing back after a test failover.
Public property | TestPreFailbackScriptArguments | This value is the arguments for the TestPreFailbackScript.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


ApplicationOptions Constructor

ApplicationOptions Constructor
Initializes a new instance of the ApplicationOptions class

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ApplicationOptions()
Public Sub New
public:
ApplicationOptions()
DoubleTake.Jobs.Contract.ApplicationOptions = function();
See Also

Reference

ApplicationOptions Class
DoubleTake.Jobs.Contract Namespace


ApplicationOptions Properties

ApplicationOptions Properties

The ApplicationOptions type exposes the following members.

Properties
 | Name | Description
Public property | AagInstances | This value is the instance name corresponding to the SQL AlwaysOn Availability Group Server. This value should never contain more than one entry.
Public property | DagTargetPublicFolderDataPath | This value is the public folder data path for a DAG target.
Public property | DnsRecordLocks | Do not use this property. Double-Take uses it internally.
Public property | ExchangeCredentials | These values are for Exchange credentials.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | IsAag | Do not use this property. Double-Take uses it internally.
Public property | IsDag | This value is true if a DAG environment; otherwise, it is false.
Public property | MonitoredServiceRepeatCount | This property is no longer used. See MonitoringOptions.ServiceMonitoringOptions.
Public property | MonitoredServices | This property is no longer used. See MonitorConfiguration.ScriptMonitorName.
Public property | MonitorScript | This property is no longer used. See CoreMonitorOptions.MonitorConfiguration.ScriptMonitorName.
Public property | RestartService | This property is no longer used. See MonitoringOptions.ServiceMonitoringOptions.
Public property | SourceDomain | This value is the source server's primary domain.
Public property | SourceName | This value is the name of the source server.
Public property | TargetDomain | This value is the target server's primary domain.
Public property | TargetName | This value is the name of the target server.
Public property | TestPostFailoverScript | This value is the path and name of the script to run after the target is brought online during a test failover.
Public property | TestPostFailoverScriptArguments | This value is the arguments for the TestPostFailoverScript to run.
Public property | TestPreFailbackScript | This value is the path and name of the script to run before failing back after a test failover.
Public property | TestPreFailbackScriptArguments | This value is the arguments for the TestPreFailbackScript.
Top
See Also

Reference

ApplicationOptions Class
DoubleTake.Jobs.Contract Namespace


ApplicationOptions.AagInstances Property

ApplicationOptionsAagInstances Property
This value is the instance name corresponding to the SQL AlwaysOn Availability Group Server. This value should never contain more than one entry.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public IEnumerable<string> AagInstances { get; set; }
Public Property AagInstances As IEnumerable(Of String)
    Get
    Set
public:
property IEnumerable<String^>^ AagInstances {
    IEnumerable<String^>^ get ();
    void set (IEnumerable<String^>^ value);
}
function get_AagInstances();
function set_AagInstances(value);

Property Value

Type: IEnumerable String
See Also

Reference

ApplicationOptions Class
DoubleTake.Jobs.Contract Namespace


ApplicationOptions.DagTargetPublicFolderDataPath Property

ApplicationOptionsDagTargetPublicFolderDataPath Property
This value is the public folder data path for a DAG target.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string DagTargetPublicFolderDataPath { get; set; }
Public Property DagTargetPublicFolderDataPath As String
    Get
    Set
public:
property String^ DagTargetPublicFolderDataPath {
    String^ get ();
    void set (String^ value);
}
function get_DagTargetPublicFolderDataPath();
function set_DagTargetPublicFolderDataPath(value);

Property Value

Type: String
See Also

Reference

ApplicationOptions Class
DoubleTake.Jobs.Contract Namespace


ApplicationOptions.DnsRecordLocks Property

ApplicationOptionsDnsRecordLocks Property
Do not use this property. Double-Take uses it internally.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public IEnumerable<DnsRecordLockOptions> DnsRecordLocks { get; set; }
Public Property DnsRecordLocks As IEnumerable(Of DnsRecordLockOptions)
    Get
    Set
public:
property IEnumerable<DnsRecordLockOptions^>^ DnsRecordLocks {
    IEnumerable<DnsRecordLockOptions^>^ get ();
    void set (IEnumerable<DnsRecordLockOptions^>^ value);
}
function get_DnsRecordLocks();
function set_DnsRecordLocks(value);

Property Value

Type: IEnumerable DnsRecordLockOptions
See Also

Reference

ApplicationOptions Class
DoubleTake.Jobs.Contract Namespace


ApplicationOptions.ExchangeCredentials Property

ApplicationOptionsExchangeCredentials Property
These values are for Exchange credentials.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Credentials ExchangeCredentials { get; set; }
Public Property ExchangeCredentials As Credentials
    Get
    Set
public:
property Credentials^ ExchangeCredentials {
    Credentials^ get ();
    void set (Credentials^ value);
}
function get_ExchangeCredentials();
function set_ExchangeCredentials(value);

Property Value

Type: Credentials
See Also

Reference

ApplicationOptions Class
DoubleTake.Jobs.Contract Namespace


ApplicationOptions.ExtensionData Property

ApplicationOptionsExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

ApplicationOptions Class
DoubleTake.Jobs.Contract Namespace


ApplicationOptions.IsAag Property

ApplicationOptionsIsAag Property
Do not use this property. Double-Take uses it internally.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsAag { get; set; }
Public Property IsAag As Boolean
    Get
    Set
public:
property bool IsAag {
    bool get ();
    void set (bool value);
}
function get_IsAag();
function set_IsAag(value);

Property Value

Type: Boolean
See Also

Reference

ApplicationOptions Class
DoubleTake.Jobs.Contract Namespace


ApplicationOptions.IsDag Property

ApplicationOptionsIsDag Property
This value is true if a DAG environment; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsDag { get; set; }
Public Property IsDag As Boolean
    Get
    Set
public:
property bool IsDag {
    bool get ();
    void set (bool value);
}
function get_IsDag();
function set_IsDag(value);

Property Value

Type: Boolean
See Also

Reference

ApplicationOptions Class
DoubleTake.Jobs.Contract Namespace


ApplicationOptions.MonitoredServiceRepeatCount Property

ApplicationOptionsMonitoredServiceRepeatCount Property
This property is no longer used. See MonitoringOptions.ServiceMonitoringOptions.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int MonitoredServiceRepeatCount { get; set; }
Public Property MonitoredServiceRepeatCount As Integer
    Get
    Set
public:
property int MonitoredServiceRepeatCount {
    int get ();
    void set (int value);
}
function get_MonitoredServiceRepeatCount();
function set_MonitoredServiceRepeatCount(value);

Property Value

Type: Int32
See Also

Reference

ApplicationOptions Class
DoubleTake.Jobs.Contract Namespace


ApplicationOptions.MonitoredServices Property

ApplicationOptionsMonitoredServices Property
This property is no longer used. See MonitorConfiguration.ScriptMonitorName.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ServiceInformation[] MonitoredServices { get; set; }
Public Property MonitoredServices As ServiceInformation()
    Get
    Set
public:
property array<ServiceInformation^>^ MonitoredServices {
    array<ServiceInformation^>^ get ();
    void set (array<ServiceInformation^>^ value);
}
function get_MonitoredServices();
function set_MonitoredServices(value);

Property Value

Type: ServiceInformation
See Also

Reference

ApplicationOptions Class
DoubleTake.Jobs.Contract Namespace


ApplicationOptions.MonitorScript Property

ApplicationOptionsMonitorScript Property
This property is no longer used. See CoreMonitorOptions.MonitorConfiguration.ScriptMonitorName.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string MonitorScript { get; set; }
Public Property MonitorScript As String
    Get
    Set
public:
property String^ MonitorScript {
    String^ get ();
    void set (String^ value);
}
function get_MonitorScript();
function set_MonitorScript(value);

Property Value

Type: String
See Also

Reference

ApplicationOptions Class
DoubleTake.Jobs.Contract Namespace


ApplicationOptions.RestartService Property

ApplicationOptionsRestartService Property
This property is no longer used. See MonitoringOptions.ServiceMonitoringOptions.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool RestartService { get; set; }
Public Property RestartService As Boolean
    Get
    Set
public:
property bool RestartService {
    bool get ();
    void set (bool value);
}
function get_RestartService();
function set_RestartService(value);

Property Value

Type: Boolean
See Also

Reference

ApplicationOptions Class
DoubleTake.Jobs.Contract Namespace


ApplicationOptions.SourceDomain Property

ApplicationOptionsSourceDomain Property
This value is the source server's primary domain.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string SourceDomain { get; set; }
Public Property SourceDomain As String
    Get
    Set
public:
property String^ SourceDomain {
    String^ get ();
    void set (String^ value);
}
function get_SourceDomain();
function set_SourceDomain(value);

Property Value

Type: String
See Also

Reference

ApplicationOptions Class
DoubleTake.Jobs.Contract Namespace


ApplicationOptions.SourceName Property

ApplicationOptionsSourceName Property
This value is the name of the source server.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string SourceName { get; set; }
Public Property SourceName As String
    Get
    Set
public:
property String^ SourceName {
    String^ get ();
    void set (String^ value);
}
function get_SourceName();
function set_SourceName(value);

Property Value

Type: String
See Also

Reference

ApplicationOptions Class
DoubleTake.Jobs.Contract Namespace


ApplicationOptions.TargetDomain Property

ApplicationOptionsTargetDomain Property
This value is the target server's primary domain.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string TargetDomain { get; set; }
Public Property TargetDomain As String
    Get
    Set
public:
property String^ TargetDomain {
    String^ get ();
    void set (String^ value);
}
function get_TargetDomain();
function set_TargetDomain(value);

Property Value

Type: String
See Also

Reference

ApplicationOptions Class
DoubleTake.Jobs.Contract Namespace


ApplicationOptions.TargetName Property

ApplicationOptionsTargetName Property
This value is the name of the target server.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string TargetName { get; set; }
Public Property TargetName As String
    Get
    Set
public:
property String^ TargetName {
    String^ get ();
    void set (String^ value);
}
function get_TargetName();
function set_TargetName(value);

Property Value

Type: String
See Also

Reference

ApplicationOptions Class
DoubleTake.Jobs.Contract Namespace


ApplicationOptions.TestPostFailoverScript Property

ApplicationOptionsTestPostFailoverScript Property
This value is the path and name of the script to run after the target is brought online during a test failover.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string TestPostFailoverScript { get; set; }
Public Property TestPostFailoverScript As String
    Get
    Set
public:
property String^ TestPostFailoverScript {
    String^ get ();
    void set (String^ value);
}
function get_TestPostFailoverScript();
function set_TestPostFailoverScript(value);

Property Value

Type: String
Remarks
If arguments are passed, file to be executed should be enclosed in quotations
See Also

Reference

ApplicationOptions Class
DoubleTake.Jobs.Contract Namespace


ApplicationOptions.TestPostFailoverScriptArguments Property

ApplicationOptionsTestPostFailoverScriptArguments Property
This value is the arguments for the TestPostFailoverScript to run.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string TestPostFailoverScriptArguments { get; set; }
Public Property TestPostFailoverScriptArguments As String
    Get
    Set
public:
property String^ TestPostFailoverScriptArguments {
    String^ get ();
    void set (String^ value);
}
function get_TestPostFailoverScriptArguments();
function set_TestPostFailoverScriptArguments(value);

Property Value

Type: String
See Also

Reference

ApplicationOptions Class
DoubleTake.Jobs.Contract Namespace


ApplicationOptions.TestPreFailbackScript Property

ApplicationOptionsTestPreFailbackScript Property
This value is the path and name of the script to run before failing back after a test failover.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string TestPreFailbackScript { get; set; }
Public Property TestPreFailbackScript As String
    Get
    Set
public:
property String^ TestPreFailbackScript {
    String^ get ();
    void set (String^ value);
}
function get_TestPreFailbackScript();
function set_TestPreFailbackScript(value);

Property Value

Type: String
Remarks
If arguments are passed, file to be executed should be enclosed in quotations
See Also

Reference

ApplicationOptions Class
DoubleTake.Jobs.Contract Namespace


ApplicationOptions.TestPreFailbackScriptArguments Property

ApplicationOptionsTestPreFailbackScriptArguments Property
This value is the arguments for the TestPreFailbackScript.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string TestPreFailbackScriptArguments { get; set; }
Public Property TestPreFailbackScriptArguments As String
    Get
    Set
public:
property String^ TestPreFailbackScriptArguments {
    String^ get ();
    void set (String^ value);
}
function get_TestPreFailbackScriptArguments();
function set_TestPreFailbackScriptArguments(value);

Property Value

Type: String
See Also

Reference

ApplicationOptions Class
DoubleTake.Jobs.Contract Namespace


CloudOptions Class

CloudOptions Class
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractCloudOptions

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class CloudOptions
Public Class CloudOptions
public ref class CloudOptions
DoubleTake.Jobs.Contract.CloudOptions = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.CloudOptions');

The CloudOptions type exposes the following members.

Constructors
 | Name | Description
Public method | CloudOptions | Initializes a new instance of the CloudOptions class
Top
Properties
 | Name | Description
Public property | EngineJobType | Gets or sets the engine job type for the connection.
Public property | HardLinkLogPath | Gets or sets the path for the hard link processing log/report.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


CloudOptions Constructor

CloudOptions Constructor
Initializes a new instance of the CloudOptions class

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public CloudOptions()
Public Sub New
public:
CloudOptions()
DoubleTake.Jobs.Contract.CloudOptions = function();
See Also

Reference

CloudOptions Class
DoubleTake.Jobs.Contract Namespace


CloudOptions Properties

CloudOptions Properties

The CloudOptions type exposes the following members.

Properties
 | Name | Description
Public property | EngineJobType | Gets or sets the engine job type for the connection.
Public property | HardLinkLogPath | Gets or sets the path for the hard link processing log/report.
Top
See Also

Reference

CloudOptions Class
DoubleTake.Jobs.Contract Namespace


CloudOptions.EngineJobType Property

CloudOptionsEngineJobType Property
Gets or sets the engine job type for the connection.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public EngineJobType EngineJobType { get; set; }
Public Property EngineJobType As EngineJobType
    Get
    Set
public:
property EngineJobType EngineJobType {
    EngineJobType get ();
    void set (EngineJobType value);
}
function get_EngineJobType();
function set_EngineJobType(value);

Property Value

Type: EngineJobType
See Also

Reference

CloudOptions Class
DoubleTake.Jobs.Contract Namespace


CloudOptions.HardLinkLogPath Property

CloudOptionsHardLinkLogPath Property
Gets or sets the path for the hard link processing log/report.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string HardLinkLogPath { get; set; }
Public Property HardLinkLogPath As String
    Get
    Set
public:
property String^ HardLinkLogPath {
    String^ get ();
    void set (String^ value);
}
function get_HardLinkLogPath();
function set_HardLinkLogPath(value);

Property Value

Type: String
See Also

Reference

CloudOptions Class
DoubleTake.Jobs.Contract Namespace


ClusterFilesAndFoldersQualificationResults Class

ClusterFilesAndFoldersQualificationResults Class
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractClusterFilesAndFoldersQualificationResults

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class ClusterFilesAndFoldersQualificationResults : IExtensibleDataObject
Public Class ClusterFilesAndFoldersQualificationResults
    Implements IExtensibleDataObject
public ref class ClusterFilesAndFoldersQualificationResults : IExtensibleDataObject
DoubleTake.Jobs.Contract.ClusterFilesAndFoldersQualificationResults = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.ClusterFilesAndFoldersQualificationResults',
    null,
    IExtensibleDataObject);

The ClusterFilesAndFoldersQualificationResults type exposes the following members.

Constructors
 | Name | Description
Public method | ClusterFilesAndFoldersQualificationResults | Initializes a new instance of the ClusterFilesAndFoldersQualificationResults class
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | TargetFileServerQualificationResults | This value represents target configuration information for clustered files and folders jobs.
Public property | TargetGroupDiskOffline | This value is true if the disk resource in the target cluster group is
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


ClusterFilesAndFoldersQualificationResults Constructor

ClusterFilesAndFoldersQualificationResults Constructor
Initializes a new instance of the ClusterFilesAndFoldersQualificationResults class

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ClusterFilesAndFoldersQualificationResults()
Public Sub New
public:
ClusterFilesAndFoldersQualificationResults()
DoubleTake.Jobs.Contract.ClusterFilesAndFoldersQualificationResults = function();
See Also

Reference

ClusterFilesAndFoldersQualificationResults Class
DoubleTake.Jobs.Contract Namespace


ClusterFilesAndFoldersQualificationResults Properties

ClusterFilesAndFoldersQualificationResults Properties

The ClusterFilesAndFoldersQualificationResults type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | TargetFileServerQualificationResults | This value represents target configuration information for clustered files and folders jobs.
Public property | TargetGroupDiskOffline | This value is true if the disk resource in the target cluster group is
Top
See Also

Reference

ClusterFilesAndFoldersQualificationResults Class
DoubleTake.Jobs.Contract Namespace


ClusterFilesAndFoldersQualificationResults.ExtensionData Property

ClusterFilesAndFoldersQualificationResultsExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

ClusterFilesAndFoldersQualificationResults Class
DoubleTake.Jobs.Contract Namespace


ClusterFilesAndFoldersQualificationResults.TargetFileServerQualificationResults Property

ClusterFilesAndFoldersQualificationResultsTargetFileServerQualificationResults Property
This value represents target configuration information for clustered files and folders jobs.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public TargetFileServerQualificationResults[] TargetFileServerQualificationResults { get; set; }
Public Property TargetFileServerQualificationResults As TargetFileServerQualificationResults()
    Get
    Set
public:
property array<TargetFileServerQualificationResults^>^ TargetFileServerQualificationResults {
    array<TargetFileServerQualificationResults^>^ get ();
    void set (array<TargetFileServerQualificationResults^>^ value);
}
function get_TargetFileServerQualificationResults();
function set_TargetFileServerQualificationResults(value);

Property Value

Type: TargetFileServerQualificationResults
See Also

Reference

ClusterFilesAndFoldersQualificationResults Class
DoubleTake.Jobs.Contract Namespace


ClusterFilesAndFoldersQualificationResults.TargetGroupDiskOffline Property

ClusterFilesAndFoldersQualificationResultsTargetGroupDiskOffline Property
This value is true if the disk resource in the target cluster group is

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool TargetGroupDiskOffline { get; set; }
Public Property TargetGroupDiskOffline As Boolean
    Get
    Set
public:
property bool TargetGroupDiskOffline {
    bool get ();
    void set (bool value);
}
function get_TargetGroupDiskOffline();
function set_TargetGroupDiskOffline(value);

Property Value

Type: Boolean
See Also

Reference

ClusterFilesAndFoldersQualificationResults Class
DoubleTake.Jobs.Contract Namespace


ClusterOptions Class

ClusterOptions Class
Cluster related job options
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractClusterOptions

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class ClusterOptions
Public Class ClusterOptions
public ref class ClusterOptions
DoubleTake.Jobs.Contract.ClusterOptions = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.ClusterOptions');

The ClusterOptions type exposes the following members.

Constructors
 | Name | Description
Public method | ClusterOptions | Initializes a new instance of the ClusterOptions class
Top
Properties
 | Name | Description
Public property | DependOnResources | This value is the dependent resources.
Public property | OriginalSourceClusterId | This value is the unique ID of the source cluster.
Public property | SourceClusterName | This value is the name of the source cluster.
Public property | SourceGroupName | The value is the name of the source group.
Public property | SourceIsCluster | This value is true if the source is a cluster; otherwise, it is false.
Public property | TargetClusterName | This value is the name of the target cluster.
Public property | TargetClusterResourceNamePrefix | This value is the optional name of the target cluster resource prefix.
Public property | TargetClusterStoragePath | This value is the location of the target cluster storage.
Public property | TargetGroupName | This value is the name of the target group.
Public property | TargetIsCluster | This value is true if the target is a cluster; otherwise, it is false.
Public property | TargetVirtualServers | This value is the name of the target virtual servers.
Top
Fields
 | Name | Description
Public field | InitializeOnTargetNodeMove | Do not use this property. Double-Take uses it internally.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


ClusterOptions Constructor

ClusterOptions Constructor
Initializes a new instance of the ClusterOptions class

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ClusterOptions()
Public Sub New
public:
ClusterOptions()
DoubleTake.Jobs.Contract.ClusterOptions = function();
See Also

Reference

ClusterOptions Class
DoubleTake.Jobs.Contract Namespace


ClusterOptions Properties

ClusterOptions Properties

The ClusterOptions type exposes the following members.

Properties
 | Name | Description
Public property | DependOnResources | This value is the dependent resources.
Public property | OriginalSourceClusterId | This value is the unique ID of the source cluster.
Public property | SourceClusterName | This value is the name of the source cluster.
Public property | SourceGroupName | The value is the name of the source group.
Public property | SourceIsCluster | This value is true if the source is a cluster; otherwise, it is false.
Public property | TargetClusterName | This value is the name of the target cluster.
Public property | TargetClusterResourceNamePrefix | This value is the optional name of the target cluster resource prefix.
Public property | TargetClusterStoragePath | This value is the location of the target cluster storage.
Public property | TargetGroupName | This value is the name of the target group.
Public property | TargetIsCluster | This value is true if the target is a cluster; otherwise, it is false.
Public property | TargetVirtualServers | This value is the name of the target virtual servers.
Top
See Also

Reference

ClusterOptions Class
DoubleTake.Jobs.Contract Namespace


ClusterOptions.DependOnResources Property

ClusterOptionsDependOnResources Property
This value is the dependent resources.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public IEnumerable<string> DependOnResources { get; set; }
Public Property DependOnResources As IEnumerable(Of String)
    Get
    Set
public:
property IEnumerable<String^>^ DependOnResources {
    IEnumerable<String^>^ get ();
    void set (IEnumerable<String^>^ value);
}
function get_DependOnResources();
function set_DependOnResources(value);

Property Value

Type: IEnumerable String
The list of resources to depend on.
See Also

Reference

ClusterOptions Class
DoubleTake.Jobs.Contract Namespace


ClusterOptions.OriginalSourceClusterId Property

ClusterOptionsOriginalSourceClusterId Property
This value is the unique ID of the source cluster.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string OriginalSourceClusterId { get; set; }
Public Property OriginalSourceClusterId As String
    Get
    Set
public:
property String^ OriginalSourceClusterId {
    String^ get ();
    void set (String^ value);
}
function get_OriginalSourceClusterId();
function set_OriginalSourceClusterId(value);

Property Value

Type: String
See Also

Reference

ClusterOptions Class
DoubleTake.Jobs.Contract Namespace


ClusterOptions.SourceClusterName Property

ClusterOptionsSourceClusterName Property
This value is the name of the source cluster.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string SourceClusterName { get; set; }
Public Property SourceClusterName As String
    Get
    Set
public:
property String^ SourceClusterName {
    String^ get ();
    void set (String^ value);
}
function get_SourceClusterName();
function set_SourceClusterName(value);

Property Value

Type: String
See Also

Reference

ClusterOptions Class
DoubleTake.Jobs.Contract Namespace


ClusterOptions.SourceGroupName Property

ClusterOptionsSourceGroupName Property
The value is the name of the source group.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string SourceGroupName { get; set; }
Public Property SourceGroupName As String
    Get
    Set
public:
property String^ SourceGroupName {
    String^ get ();
    void set (String^ value);
}
function get_SourceGroupName();
function set_SourceGroupName(value);

Property Value

Type: String
The name of the source group.
See Also

Reference

ClusterOptions Class
DoubleTake.Jobs.Contract Namespace


ClusterOptions.SourceIsCluster Property

ClusterOptionsSourceIsCluster Property
This value is true if the source is a cluster; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool SourceIsCluster { get; set; }
Public Property SourceIsCluster As Boolean
    Get
    Set
public:
property bool SourceIsCluster {
    bool get ();
    void set (bool value);
}
function get_SourceIsCluster();
function set_SourceIsCluster(value);

Property Value

Type: Boolean
true if [source is cluster]; otherwise, false.
See Also

Reference

ClusterOptions Class
DoubleTake.Jobs.Contract Namespace


ClusterOptions.TargetClusterName Property

ClusterOptionsTargetClusterName Property
This value is the name of the target cluster.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string TargetClusterName { get; set; }
Public Property TargetClusterName As String
    Get
    Set
public:
property String^ TargetClusterName {
    String^ get ();
    void set (String^ value);
}
function get_TargetClusterName();
function set_TargetClusterName(value);

Property Value

Type: String
The name of the target cluster.
See Also

Reference

ClusterOptions Class
DoubleTake.Jobs.Contract Namespace


ClusterOptions.TargetClusterResourceNamePrefix Property

ClusterOptionsTargetClusterResourceNamePrefix Property
This value is the optional name of the target cluster resource prefix.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string TargetClusterResourceNamePrefix { get; set; }
Public Property TargetClusterResourceNamePrefix As String
    Get
    Set
public:
property String^ TargetClusterResourceNamePrefix {
    String^ get ();
    void set (String^ value);
}
function get_TargetClusterResourceNamePrefix();
function set_TargetClusterResourceNamePrefix(value);

Property Value

Type: String
The target cluster resource name prefix.
See Also

Reference

ClusterOptions Class
DoubleTake.Jobs.Contract Namespace


ClusterOptions.TargetClusterStoragePath Property

ClusterOptionsTargetClusterStoragePath Property
This value is the location of the target cluster storage.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string TargetClusterStoragePath { get; set; }
Public Property TargetClusterStoragePath As String
    Get
    Set
public:
property String^ TargetClusterStoragePath {
    String^ get ();
    void set (String^ value);
}
function get_TargetClusterStoragePath();
function set_TargetClusterStoragePath(value);

Property Value

Type: String
The target cluster storage location.
See Also

Reference

ClusterOptions Class
DoubleTake.Jobs.Contract Namespace


ClusterOptions.TargetGroupName Property

ClusterOptionsTargetGroupName Property
This value is the name of the target group.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string TargetGroupName { get; set; }
Public Property TargetGroupName As String
    Get
    Set
public:
property String^ TargetGroupName {
    String^ get ();
    void set (String^ value);
}
function get_TargetGroupName();
function set_TargetGroupName(value);

Property Value

Type: String
The name of the target group.
See Also

Reference

ClusterOptions Class
DoubleTake.Jobs.Contract Namespace


ClusterOptions.TargetIsCluster Property

ClusterOptionsTargetIsCluster Property
This value is true if the target is a cluster; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool TargetIsCluster { get; set; }
Public Property TargetIsCluster As Boolean
    Get
    Set
public:
property bool TargetIsCluster {
    bool get ();
    void set (bool value);
}
function get_TargetIsCluster();
function set_TargetIsCluster(value);

Property Value

Type: Boolean
true if [target is cluster]; otherwise, false.
See Also

Reference

ClusterOptions Class
DoubleTake.Jobs.Contract Namespace


ClusterOptions.TargetVirtualServers Property

ClusterOptionsTargetVirtualServers Property
This value is the name of the target virtual servers.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public IEnumerable<string> TargetVirtualServers { get; set; }
Public Property TargetVirtualServers As IEnumerable(Of String)
    Get
    Set
public:
property IEnumerable<String^>^ TargetVirtualServers {
    IEnumerable<String^>^ get ();
    void set (IEnumerable<String^>^ value);
}
function get_TargetVirtualServers();
function set_TargetVirtualServers(value);

Property Value

Type: IEnumerable String
The name of the target virtual servers.
See Also

Reference

ClusterOptions Class
DoubleTake.Jobs.Contract Namespace


ClusterOptions Fields

ClusterOptions Fields

The ClusterOptions type exposes the following members.

Fields
 | Name | Description
Public field | InitializeOnTargetNodeMove | Do not use this property. Double-Take uses it internally.
Top
See Also

Reference

ClusterOptions Class
DoubleTake.Jobs.Contract Namespace


ClusterOptions.InitializeOnTargetNodeMove Field

ClusterOptionsInitializeOnTargetNodeMove Field
Do not use this property. Double-Take uses it internally.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool InitializeOnTargetNodeMove
Public InitializeOnTargetNodeMove As Boolean
public:
bool InitializeOnTargetNodeMove
var InitializeOnTargetNodeMove

Field Value

Type: Boolean
See Also

Reference

ClusterOptions Class
DoubleTake.Jobs.Contract Namespace


ClusterPersistedState Class

ClusterPersistedState Class
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractClusterPersistedState

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class ClusterPersistedState
Public Class ClusterPersistedState
public ref class ClusterPersistedState
DoubleTake.Jobs.Contract.ClusterPersistedState = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.ClusterPersistedState');

The ClusterPersistedState type exposes the following members.

Constructors
 | Name | Description
Public method | ClusterPersistedState | Initializes a new instance of the ClusterPersistedState class
Top
Properties
 | Name | Description
Public property | PossibleSourceClusterOwningNodes |
Public property | PossibleTargetClusterOwningNodes |
Public property | SourceClusterNodes |
Public property | TargetClusterMonitorId |
Top
Fields
 | Name | Description
Public field | SourceResourcesAndPassiveNodes |
Public field | TargetResourcesAndPassiveNodes |
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


ClusterPersistedState Constructor

ClusterPersistedState Constructor
Initializes a new instance of the ClusterPersistedState class

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ClusterPersistedState()
Public Sub New
public:
ClusterPersistedState()
DoubleTake.Jobs.Contract.ClusterPersistedState = function();
See Also

Reference

ClusterPersistedState Class
DoubleTake.Jobs.Contract Namespace


ClusterPersistedState Properties

ClusterPersistedState Properties

The ClusterPersistedState type exposes the following members.

Properties
 | Name | Description
Public property | PossibleSourceClusterOwningNodes |
Public property | PossibleTargetClusterOwningNodes |
Public property | SourceClusterNodes |
Public property | TargetClusterMonitorId |
Top
See Also

Reference

ClusterPersistedState Class
DoubleTake.Jobs.Contract Namespace


ClusterPersistedState.PossibleSourceClusterOwningNodes Property

ClusterPersistedStatePossibleSourceClusterOwningNodes Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string[] PossibleSourceClusterOwningNodes { get; set; }
Public Property PossibleSourceClusterOwningNodes As String()
    Get
    Set
public:
property array<String^>^ PossibleSourceClusterOwningNodes {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
function get_PossibleSourceClusterOwningNodes();
function set_PossibleSourceClusterOwningNodes(value);

Property Value

Type: String
See Also

Reference

ClusterPersistedState Class
DoubleTake.Jobs.Contract Namespace


ClusterPersistedState.PossibleTargetClusterOwningNodes Property

ClusterPersistedStatePossibleTargetClusterOwningNodes Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string[] PossibleTargetClusterOwningNodes { get; set; }
Public Property PossibleTargetClusterOwningNodes As String()
    Get
    Set
public:
property array<String^>^ PossibleTargetClusterOwningNodes {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
function get_PossibleTargetClusterOwningNodes();
function set_PossibleTargetClusterOwningNodes(value);

Property Value

Type: String
See Also

Reference

ClusterPersistedState Class
DoubleTake.Jobs.Contract Namespace


ClusterPersistedState.SourceClusterNodes Property

ClusterPersistedStateSourceClusterNodes Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string[] SourceClusterNodes { get; set; }
Public Property SourceClusterNodes As String()
    Get
    Set
public:
property array<String^>^ SourceClusterNodes {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
function get_SourceClusterNodes();
function set_SourceClusterNodes(value);

Property Value

Type: String
See Also

Reference

ClusterPersistedState Class
DoubleTake.Jobs.Contract Namespace


ClusterPersistedState.TargetClusterMonitorId Property

ClusterPersistedStateTargetClusterMonitorId Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Guid TargetClusterMonitorId { get; set; }
Public Property TargetClusterMonitorId As Guid
    Get
    Set
public:
property Guid TargetClusterMonitorId {
    Guid get ();
    void set (Guid value);
}
function get_TargetClusterMonitorId();
function set_TargetClusterMonitorId(value);

Property Value

Type: Guid
See Also

Reference

ClusterPersistedState Class
DoubleTake.Jobs.Contract Namespace


ClusterPersistedState Fields

ClusterPersistedState Fields

The ClusterPersistedState type exposes the following members.

Fields
 | Name | Description
Public field | SourceResourcesAndPassiveNodes |
Public field | TargetResourcesAndPassiveNodes |
Top
See Also

Reference

ClusterPersistedState Class
DoubleTake.Jobs.Contract Namespace


ClusterPersistedState.SourceResourcesAndPassiveNodes Field

ClusterPersistedStateSourceResourcesAndPassiveNodes Field

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ResourceAndPassiveNodes[] SourceResourcesAndPassiveNodes
Public SourceResourcesAndPassiveNodes As ResourceAndPassiveNodes()
public:
array<ResourceAndPassiveNodes^>^ SourceResourcesAndPassiveNodes
var SourceResourcesAndPassiveNodes

Field Value

Type: ResourceAndPassiveNodes
See Also

Reference

ClusterPersistedState Class
DoubleTake.Jobs.Contract Namespace


ClusterPersistedState.TargetResourcesAndPassiveNodes Field

ClusterPersistedStateTargetResourcesAndPassiveNodes Field

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ResourceAndPassiveNodes[] TargetResourcesAndPassiveNodes
Public TargetResourcesAndPassiveNodes As ResourceAndPassiveNodes()
public:
array<ResourceAndPassiveNodes^>^ TargetResourcesAndPassiveNodes
var TargetResourcesAndPassiveNodes

Field Value

Type: ResourceAndPassiveNodes
See Also

Reference

ClusterPersistedState Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails Class

CoreConnectionDetails Class
Represents details of an underlying engine connection used by a job.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractCoreConnectionDetails

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class CoreConnectionDetails : IExtensibleDataObject
Public Class CoreConnectionDetails
    Implements IExtensibleDataObject
public ref class CoreConnectionDetails : IExtensibleDataObject
DoubleTake.Jobs.Contract.CoreConnectionDetails = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.CoreConnectionDetails',
    null,
    IExtensibleDataObject);

The CoreConnectionDetails type exposes the following members.

Constructors
 | Name | Description
Public method | CoreConnectionDetails | Initializes a new instance of the CoreConnectionDetails class
Top
Properties
 | Name | Description
Public property | BandwidthCollar | This value is the current bandwidth limit. It may vary according to the bandwidth limit schedule.
Public property | CompressionEnabled | This value is true if compression is enabled; otherwise, it is false.
Public property | CompressionLevel | This value is the current compression level.
Public property | ConnectionId | This value is the ID assigned to the connection. The ID is a one-based index that resets each time the Double-Take service is restarted.
Public property | DiskQueueBytes | This value is the number of bytes queued on the target.
Public property | Encrypted | This value is true if Double-Take is encrypting data before sending it to the target; otherwise, it is false.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | InitialMirrorComplete | This value is true if the initial mirror has completed; otherwise, it is false.
Public property | ManagedConnectionId | This value is the ID assigned to the connection by the Management Service.
Public property | MirrorBytesRemaining | This value is the number of remaining mirror bytes.
Public property | MirrorBytesSent | This value is the number of mirror bytes sent.
Public property | MirrorBytesSkipped | This value is the number of mirror bytes skipped. Bytes are skipped because the data is not different on the source and target.
Public property | MirrorBytesTransmitted | The value is the number of mirror bytes transmitted.
Public property | MirrorOpsQueued | This value is the number of mirror operations queued on the target.
Public property | MirrorPermillage | This value is the percentage of the mirror that is complete. A mirror may be at 99-100% when it is actually still processing. For example, this may occur if files were added after the protected data set size was calculated or if there are alternate data streams in the protected data set.
Public property | MirrorState | This value represents the state of mirroring.
Public property | PeerMemoryLow | This value is true if memory on the target is low; otherwise it is false.
Public property | ReplicationBytesQueued | This value is the number of replication bytes queued on the target.
Public property | ReplicationBytesSent | This value is the number of replication bytes sent.
Public property | ReplicationBytesTransmitted | The value is the number of replication bytes transmitted.
Public property | ReplicationOpsQueued | This value is the number of replication operations queued on the target.
Public property | ReplicationSetCalcInProgress | This value is true if the size of the protected data set is being calculated; otherwise, it is false. Mirroring will start while the size of the protected data set is being determined. While the calculation is in progress, the remaining byte count is not valid.
Public property | ReplicationState | This value represents the state of replication.
Public property | Restoring | This value is true if the connection is restoring data; otherwise, it is false.
Public property | SourceAccessLevel | This value is the source security access. This value will be null if the Double-Take access level cannot be determined. If the value is not null and SourceAvailable is false, Double-Take can connect to the source but was not able to determine at least Double-Take monitor access with the provided credentials.
Public property | SourceAvailable | This value is true if the target can communicate with the source; otherwise, it is false.
Public property | SourceClusterResourceState | This value represents the state of the source cluster resource.
Public property | SourceEndpoint | This value is the source endpoint that is the route from the target back to the source.
Public property | SourceEngineAvailable | This value is true if the source replication engine is available; otherwise, it is false.
Public property | SourceMachineName | This value is the name of the source server.
Public property | SourceUniqueId | This value is a unique ID assigned to the source.
Public property | StartTime | This value is the time the connection was started.
Public property | TargetAccessLevel | This value is the target security access. This value will be null if the Double-Take access level cannot be determined. If the value is not null and TargetAvailable is false, Double-Take can connect to the target but was not able to determine at least Double-Take monitor access with the provided credentials.
Public property | TargetAvailable | This value is true if the target is available; otherwise, it is false.
Public property | TargetEngineAvailable | This value is true if the target replication engine is available; otherwise, it is false.
Public property | TargetLoaded | This value is true if the Double-Take target module is loaded on the server; otherwise, it is false.
Public property | TargetMachineName | This value is the name of the target server.
Public property | TargetQueueBytes | This value is the number of bytes in the target queue.
Public property | TargetRoute | This value is the endpoint on the target that is the route the source is using for the connection.This route is in the format [address]:[port].
Public property | TargetState | This value represents the state of the target.
Public property | TargetUniqueId | This value is a unique ID assigned to the target.
Public property | TotalBytesSent | This value is the total number of bytes that have been sent for the connection.
Public property | TotalBytesTransmitted | This value is the total number of bytes that have been transmitted for the connection.
Public property | TotalOpsQueued | This value is the total number of operations queued on the target.
Public property | TransmissionMode | This value represents the state of data transmission from the source to the target.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails Constructor

CoreConnectionDetails Constructor
Initializes a new instance of the CoreConnectionDetails class

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public CoreConnectionDetails()
Public Sub New
public:
CoreConnectionDetails()
DoubleTake.Jobs.Contract.CoreConnectionDetails = function();
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails Properties

CoreConnectionDetails Properties

The CoreConnectionDetails type exposes the following members.

Properties
 | Name | Description
Public property | BandwidthCollar | This value is the current bandwidth limit. It may vary according to the bandwidth limit schedule.
Public property | CompressionEnabled | This value is true if compression is enabled; otherwise, it is false.
Public property | CompressionLevel | This value is the current compression level.
Public property | ConnectionId | This value is the ID assigned to the connection. The ID is a one-based index that resets each time the Double-Take service is restarted.
Public property | DiskQueueBytes | This value is the number of bytes queued on the target.
Public property | Encrypted | This value is true if Double-Take is encrypting data before sending it to the target; otherwise, it is false.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | InitialMirrorComplete | This value is true if the initial mirror has completed; otherwise, it is false.
Public property | ManagedConnectionId | This value is the ID assigned to the connection by the Management Service.
Public property | MirrorBytesRemaining | This value is the number of remaining mirror bytes.
Public property | MirrorBytesSent | This value is the number of mirror bytes sent.
Public property | MirrorBytesSkipped | This value is the number of mirror bytes skipped. Bytes are skipped because the data is not different on the source and target.
Public property | MirrorBytesTransmitted | The value is the number of mirror bytes transmitted.
Public property | MirrorOpsQueued | This value is the number of mirror operations queued on the target.
Public property | MirrorPermillage | This value is the percentage of the mirror that is complete. A mirror may be at 99-100% when it is actually still processing. For example, this may occur if files were added after the protected data set size was calculated or if there are alternate data streams in the protected data set.
Public property | MirrorState | This value represents the state of mirroring.
Public property | PeerMemoryLow | This value is true if memory on the target is low; otherwise it is false.
Public property | ReplicationBytesQueued | This value is the number of replication bytes queued on the target.
Public property | ReplicationBytesSent | This value is the number of replication bytes sent.
Public property | ReplicationBytesTransmitted | The value is the number of replication bytes transmitted.
Public property | ReplicationOpsQueued | This value is the number of replication operations queued on the target.
Public property | ReplicationSetCalcInProgress | This value is true if the size of the protected data set is being calculated; otherwise, it is false. Mirroring will start while the size of the protected data set is being determined. While the calculation is in progress, the remaining byte count is not valid.
Public property | ReplicationState | This value represents the state of replication.
Public property | Restoring | This value is true if the connection is restoring data; otherwise, it is false.
Public property | SourceAccessLevel | This value is the source security access. This value will be null if the Double-Take access level cannot be determined. If the value is not null and SourceAvailable is false, Double-Take can connect to the source but was not able to determine at least Double-Take monitor access with the provided credentials.
Public property | SourceAvailable | This value is true if the target can communicate with the source; otherwise, it is false.
Public property | SourceClusterResourceState | This value represents the state of the source cluster resource.
Public property | SourceEndpoint | This value is the source endpoint that is the route from the target back to the source.
Public property | SourceEngineAvailable | This value is true if the source replication engine is available; otherwise, it is false.
Public property | SourceMachineName | This value is the name of the source server.
Public property | SourceUniqueId | This value is a unique ID assigned to the source.
Public property | StartTime | This value is the time the connection was started.
Public property | TargetAccessLevel | This value is the target security access. This value will be null if the Double-Take access level cannot be determined. If the value is not null and TargetAvailable is false, Double-Take can connect to the target but was not able to determine at least Double-Take monitor access with the provided credentials.
Public property | TargetAvailable | This value is true if the target is available; otherwise, it is false.
Public property | TargetEngineAvailable | This value is true if the target replication engine is available; otherwise, it is false.
Public property | TargetLoaded | This value is true if the Double-Take target module is loaded on the server; otherwise, it is false.
Public property | TargetMachineName | This value is the name of the target server.
Public property | TargetQueueBytes | This value is the number of bytes in the target queue.
Public property | TargetRoute | This value is the endpoint on the target that is the route the source is using for the connection.This route is in the format [address]:[port].
Public property | TargetState | This value represents the state of the target.
Public property | TargetUniqueId | This value is a unique ID assigned to the target.
Public property | TotalBytesSent | This value is the total number of bytes that have been sent for the connection.
Public property | TotalBytesTransmitted | This value is the total number of bytes that have been transmitted for the connection.
Public property | TotalOpsQueued | This value is the total number of operations queued on the target.
Public property | TransmissionMode | This value represents the state of data transmission from the source to the target.
Top
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.BandwidthCollar Property

CoreConnectionDetailsBandwidthCollar Property
This value is the current bandwidth limit. It may vary according to the bandwidth limit schedule.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int BandwidthCollar { get; set; }
Public Property BandwidthCollar As Integer
    Get
    Set
public:
property int BandwidthCollar {
    int get ();
    void set (int value);
}
function get_BandwidthCollar();
function set_BandwidthCollar(value);

Property Value

Type: Int32
The current bandwidth limit.
Remarks
The bandwidth limit may vary according to the bandwidth limit schedule.
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.CompressionEnabled Property

CoreConnectionDetailsCompressionEnabled Property
This value is true if compression is enabled; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool CompressionEnabled { get; set; }
Public Property CompressionEnabled As Boolean
    Get
    Set
public:
property bool CompressionEnabled {
    bool get ();
    void set (bool value);
}
function get_CompressionEnabled();
function set_CompressionEnabled(value);

Property Value

Type: Boolean
if compression is enabled; otherwise, .
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.CompressionLevel Property

CoreConnectionDetailsCompressionLevel Property
This value is the current compression level.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int CompressionLevel { get; set; }
Public Property CompressionLevel As Integer
    Get
    Set
public:
property int CompressionLevel {
    int get ();
    void set (int value);
}
function get_CompressionLevel();
function set_CompressionLevel(value);

Property Value

Type: Int32
The compression level.
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.ConnectionId Property

CoreConnectionDetailsConnectionId Property
This value is the ID assigned to the connection. The ID is a one-based index that resets each time the Double-Take service is restarted.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int ConnectionId { get; set; }
Public Property ConnectionId As Integer
    Get
    Set
public:
property int ConnectionId {
    int get ();
    void set (int value);
}
function get_ConnectionId();
function set_ConnectionId(value);

Property Value

Type: Int32
The connection id.
Remarks
This series is reset each time the Double-Take service is restarted.
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.DiskQueueBytes Property

CoreConnectionDetailsDiskQueueBytes Property
This value is the number of bytes queued on the target.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public long DiskQueueBytes { get; set; }
Public Property DiskQueueBytes As Long
    Get
    Set
public:
property long long DiskQueueBytes {
    long long get ();
    void set (long long value);
}
function get_DiskQueueBytes();
function set_DiskQueueBytes(value);

Property Value

Type: Int64
The disk queue bytes.
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.Encrypted Property

CoreConnectionDetailsEncrypted Property
This value is true if Double-Take is encrypting data before sending it to the target; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool Encrypted { get; set; }
Public Property Encrypted As Boolean
    Get
    Set
public:
property bool Encrypted {
    bool get ();
    void set (bool value);
}
function get_Encrypted();
function set_Encrypted(value);

Property Value

Type: Boolean
True if network data is being encrypted.
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.ExtensionData Property

CoreConnectionDetailsExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.InitialMirrorComplete Property

CoreConnectionDetailsInitialMirrorComplete Property
This value is true if the initial mirror has completed; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool InitialMirrorComplete { get; set; }
Public Property InitialMirrorComplete As Boolean
    Get
    Set
public:
property bool InitialMirrorComplete {
    bool get ();
    void set (bool value);
}
function get_InitialMirrorComplete();
function set_InitialMirrorComplete(value);

Property Value

Type: Boolean
if the initial mirror has completed; otherwise, .
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.ManagedConnectionId Property

CoreConnectionDetailsManagedConnectionId Property
This value is the ID assigned to the connection by the Management Service.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Guid ManagedConnectionId { get; set; }
Public Property ManagedConnectionId As Guid
    Get
    Set
public:
property Guid ManagedConnectionId {
    Guid get ();
    void set (Guid value);
}
function get_ManagedConnectionId();
function set_ManagedConnectionId(value);

Property Value

Type: Guid
The managed connection id.
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.MirrorBytesRemaining Property

CoreConnectionDetailsMirrorBytesRemaining Property
This value is the number of remaining mirror bytes.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public long MirrorBytesRemaining { get; set; }
Public Property MirrorBytesRemaining As Long
    Get
    Set
public:
property long long MirrorBytesRemaining {
    long long get ();
    void set (long long value);
}
function get_MirrorBytesRemaining();
function set_MirrorBytesRemaining(value);

Property Value

Type: Int64
The number of mirror bytes remaining.
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.MirrorBytesSent Property

CoreConnectionDetailsMirrorBytesSent Property
This value is the number of mirror bytes sent.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public long MirrorBytesSent { get; set; }
Public Property MirrorBytesSent As Long
    Get
    Set
public:
property long long MirrorBytesSent {
    long long get ();
    void set (long long value);
}
function get_MirrorBytesSent();
function set_MirrorBytesSent(value);

Property Value

Type: Int64
The number of mirror bytes sent.
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.MirrorBytesSkipped Property

CoreConnectionDetailsMirrorBytesSkipped Property
This value is the number of mirror bytes skipped. Bytes are skipped because the data is not different on the source and target.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public long MirrorBytesSkipped { get; set; }
Public Property MirrorBytesSkipped As Long
    Get
    Set
public:
property long long MirrorBytesSkipped {
    long long get ();
    void set (long long value);
}
function get_MirrorBytesSkipped();
function set_MirrorBytesSkipped(value);

Property Value

Type: Int64
The number of mirror bytes skipped.
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.MirrorBytesTransmitted Property

CoreConnectionDetailsMirrorBytesTransmitted Property
The value is the number of mirror bytes transmitted.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public long MirrorBytesTransmitted { get; set; }
Public Property MirrorBytesTransmitted As Long
    Get
    Set
public:
property long long MirrorBytesTransmitted {
    long long get ();
    void set (long long value);
}
function get_MirrorBytesTransmitted();
function set_MirrorBytesTransmitted(value);

Property Value

Type: Int64
The number of mirror bytes transmitted.
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.MirrorOpsQueued Property

CoreConnectionDetailsMirrorOpsQueued Property
This value is the number of mirror operations queued on the target.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public long MirrorOpsQueued { get; set; }
Public Property MirrorOpsQueued As Long
    Get
    Set
public:
property long long MirrorOpsQueued {
    long long get ();
    void set (long long value);
}
function get_MirrorOpsQueued();
function set_MirrorOpsQueued(value);

Property Value

Type: Int64
The number of mirror ops queued.
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.MirrorPermillage Property

CoreConnectionDetailsMirrorPermillage Property
This value is the percentage of the mirror that is complete. A mirror may be at 99-100% when it is actually still processing. For example, this may occur if files were added after the protected data set size was calculated or if there are alternate data streams in the protected data set.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public short MirrorPermillage { get; set; }
Public Property MirrorPermillage As Short
    Get
    Set
public:
property short MirrorPermillage {
    short get ();
    void set (short value);
}
function get_MirrorPermillage();
function set_MirrorPermillage(value);

Property Value

Type: Int16
The mirror permillage.
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.MirrorState Property

CoreConnectionDetailsMirrorState Property
This value represents the state of mirroring.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public MirrorState MirrorState { get; set; }
Public Property MirrorState As MirrorState
    Get
    Set
public:
property MirrorState MirrorState {
    MirrorState get ();
    void set (MirrorState value);
}
function get_MirrorState();
function set_MirrorState(value);

Property Value

Type: MirrorState
The operational state of the mirror.
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.PeerMemoryLow Property

CoreConnectionDetailsPeerMemoryLow Property
This value is true if memory on the target is low; otherwise it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool PeerMemoryLow { get; set; }
Public Property PeerMemoryLow As Boolean
    Get
    Set
public:
property bool PeerMemoryLow {
    bool get ();
    void set (bool value);
}
function get_PeerMemoryLow();
function set_PeerMemoryLow(value);

Property Value

Type: Boolean
if the peer's memory is low; otherwise, .
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.ReplicationBytesQueued Property

CoreConnectionDetailsReplicationBytesQueued Property
This value is the number of replication bytes queued on the target.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public long ReplicationBytesQueued { get; set; }
Public Property ReplicationBytesQueued As Long
    Get
    Set
public:
property long long ReplicationBytesQueued {
    long long get ();
    void set (long long value);
}
function get_ReplicationBytesQueued();
function set_ReplicationBytesQueued(value);

Property Value

Type: Int64
The number of replication bytes queued.
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.ReplicationBytesSent Property

CoreConnectionDetailsReplicationBytesSent Property
This value is the number of replication bytes sent.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public long ReplicationBytesSent { get; set; }
Public Property ReplicationBytesSent As Long
    Get
    Set
public:
property long long ReplicationBytesSent {
    long long get ();
    void set (long long value);
}
function get_ReplicationBytesSent();
function set_ReplicationBytesSent(value);

Property Value

Type: Int64
The number of replication bytes sent.
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.ReplicationBytesTransmitted Property

CoreConnectionDetailsReplicationBytesTransmitted Property
The value is the number of replication bytes transmitted.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public long ReplicationBytesTransmitted { get; set; }
Public Property ReplicationBytesTransmitted As Long
    Get
    Set
public:
property long long ReplicationBytesTransmitted {
    long long get ();
    void set (long long value);
}
function get_ReplicationBytesTransmitted();
function set_ReplicationBytesTransmitted(value);

Property Value

Type: Int64
The number of replication bytes transmitted.
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.ReplicationOpsQueued Property

CoreConnectionDetailsReplicationOpsQueued Property
This value is the number of replication operations queued on the target.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public long ReplicationOpsQueued { get; set; }
Public Property ReplicationOpsQueued As Long
    Get
    Set
public:
property long long ReplicationOpsQueued {
    long long get ();
    void set (long long value);
}
function get_ReplicationOpsQueued();
function set_ReplicationOpsQueued(value);

Property Value

Type: Int64
The number of replication ops queued.
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.ReplicationSetCalcInProgress Property

CoreConnectionDetailsReplicationSetCalcInProgress Property
This value is true if the size of the protected data set is being calculated; otherwise, it is false. Mirroring will start while the size of the protected data set is being determined. While the calculation is in progress, the remaining byte count is not valid.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool ReplicationSetCalcInProgress { get; set; }
Public Property ReplicationSetCalcInProgress As Boolean
    Get
    Set
public:
property bool ReplicationSetCalcInProgress {
    bool get ();
    void set (bool value);
}
function get_ReplicationSetCalcInProgress();
function set_ReplicationSetCalcInProgress(value);

Property Value

Type: Boolean
if the repset calculation is in progress; otherwise, .
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.ReplicationState Property

CoreConnectionDetailsReplicationState Property
This value represents the state of replication.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ReplicationState ReplicationState { get; set; }
Public Property ReplicationState As ReplicationState
    Get
    Set
public:
property ReplicationState ReplicationState {
    ReplicationState get ();
    void set (ReplicationState value);
}
function get_ReplicationState();
function set_ReplicationState(value);

Property Value

Type: ReplicationState
The operational state of the replication.
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.Restoring Property

CoreConnectionDetailsRestoring Property
This value is true if the connection is restoring data; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool Restoring { get; set; }
Public Property Restoring As Boolean
    Get
    Set
public:
property bool Restoring {
    bool get ();
    void set (bool value);
}
function get_Restoring();
function set_Restoring(value);

Property Value

Type: Boolean
if the connection is restoring; otherwise, .
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.SourceAccessLevel Property

CoreConnectionDetailsSourceAccessLevel Property
This value is the source security access. This value will be null if the Double-Take access level cannot be determined. If the value is not null and SourceAvailable is false, Double-Take can connect to the source but was not able to determine at least Double-Take monitor access with the provided credentials.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Nullable<AccessLevel> SourceAccessLevel { get; set; }
Public Property SourceAccessLevel As Nullable(Of AccessLevel)
    Get
    Set
public:
property Nullable<AccessLevel> SourceAccessLevel {
    Nullable<AccessLevel> get ();
    void set (Nullable<AccessLevel> value);
}
function get_SourceAccessLevel();
function set_SourceAccessLevel(value);

Property Value

Type: Nullable AccessLevel
The source access level.
Remarks
This nullable value will be if the access level has not been determined for whatever reason. If the value is non-null and [P:SourceAvailable] is , we were able to connect but not able to obtain at least monitor access with the provided credentials.
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.SourceAvailable Property

CoreConnectionDetailsSourceAvailable Property
This value is true if the target can communicate with the source; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool SourceAvailable { get; set; }
Public Property SourceAvailable As Boolean
    Get
    Set
public:
property bool SourceAvailable {
    bool get ();
    void set (bool value);
}
function get_SourceAvailable();
function set_SourceAvailable(value);

Property Value

Type: Boolean
if the source server is available; otherwise, .
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.SourceClusterResourceState Property

CoreConnectionDetailsSourceClusterResourceState Property
This value represents the state of the source cluster resource.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ClusterResourceState SourceClusterResourceState { get; set; }
Public Property SourceClusterResourceState As ClusterResourceState
    Get
    Set
public:
property ClusterResourceState SourceClusterResourceState {
    ClusterResourceState get ();
    void set (ClusterResourceState value);
}
function get_SourceClusterResourceState();
function set_SourceClusterResourceState(value);

Property Value

Type: ClusterResourceState
The state of the source cluster resource.
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.SourceEndpoint Property

CoreConnectionDetailsSourceEndpoint Property
This value is the source endpoint that is the route from the target back to the source.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string SourceEndpoint { get; set; }
Public Property SourceEndpoint As String
    Get
    Set
public:
property String^ SourceEndpoint {
    String^ get ();
    void set (String^ value);
}
function get_SourceEndpoint();
function set_SourceEndpoint(value);

Property Value

Type: String
The endpoint on the source server.
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.SourceEngineAvailable Property

CoreConnectionDetailsSourceEngineAvailable Property
This value is true if the source replication engine is available; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool SourceEngineAvailable { get; set; }
Public Property SourceEngineAvailable As Boolean
    Get
    Set
public:
property bool SourceEngineAvailable {
    bool get ();
    void set (bool value);
}
function get_SourceEngineAvailable();
function set_SourceEngineAvailable(value);

Property Value

Type: Boolean
if the source engine available; otherwise, .
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.SourceMachineName Property

CoreConnectionDetailsSourceMachineName Property
This value is the name of the source server.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string SourceMachineName { get; set; }
Public Property SourceMachineName As String
    Get
    Set
public:
property String^ SourceMachineName {
    String^ get ();
    void set (String^ value);
}
function get_SourceMachineName();
function set_SourceMachineName(value);

Property Value

Type: String
The name of the source server.
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.SourceUniqueId Property

CoreConnectionDetailsSourceUniqueId Property
This value is a unique ID assigned to the source.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string SourceUniqueId { get; set; }
Public Property SourceUniqueId As String
    Get
    Set
public:
property String^ SourceUniqueId {
    String^ get ();
    void set (String^ value);
}
function get_SourceUniqueId();
function set_SourceUniqueId(value);

Property Value

Type: String
The unique identifier of the source server.
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.StartTime Property

CoreConnectionDetailsStartTime Property
This value is the time the connection was started.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public DateTimeOffset StartTime { get; set; }
Public Property StartTime As DateTimeOffset
    Get
    Set
public:
property DateTimeOffset StartTime {
    DateTimeOffset get ();
    void set (DateTimeOffset value);
}
function get_StartTime();
function set_StartTime(value);

Property Value

Type: DateTimeOffset
The time the connection was started.
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.TargetAccessLevel Property

CoreConnectionDetailsTargetAccessLevel Property
This value is the target security access. This value will be null if the Double-Take access level cannot be determined. If the value is not null and TargetAvailable is false, Double-Take can connect to the target but was not able to determine at least Double-Take monitor access with the provided credentials.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Nullable<AccessLevel> TargetAccessLevel { get; set; }
Public Property TargetAccessLevel As Nullable(Of AccessLevel)
    Get
    Set
public:
property Nullable<AccessLevel> TargetAccessLevel {
    Nullable<AccessLevel> get ();
    void set (Nullable<AccessLevel> value);
}
function get_TargetAccessLevel();
function set_TargetAccessLevel(value);

Property Value

Type: Nullable AccessLevel
The target access level.
Remarks
This nullable value will be if the access level has not been determined for whatever reason. If the value is non-null and [P:TargetAvailable] is , we were able to connect but not able to obtain at least monitor access with the provided credentials.
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.TargetAvailable Property

CoreConnectionDetailsTargetAvailable Property
This value is true if the target is available; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool TargetAvailable { get; set; }
Public Property TargetAvailable As Boolean
    Get
    Set
public:
property bool TargetAvailable {
    bool get ();
    void set (bool value);
}
function get_TargetAvailable();
function set_TargetAvailable(value);

Property Value

Type: Boolean
if the target server is available; otherwise, .
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.TargetEngineAvailable Property

CoreConnectionDetailsTargetEngineAvailable Property
This value is true if the target replication engine is available; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool TargetEngineAvailable { get; set; }
Public Property TargetEngineAvailable As Boolean
    Get
    Set
public:
property bool TargetEngineAvailable {
    bool get ();
    void set (bool value);
}
function get_TargetEngineAvailable();
function set_TargetEngineAvailable(value);

Property Value

Type: Boolean
if the target engine available; otherwise, .
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.TargetLoaded Property

CoreConnectionDetailsTargetLoaded Property
This value is true if the Double-Take target module is loaded on the server; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool TargetLoaded { get; set; }
Public Property TargetLoaded As Boolean
    Get
    Set
public:
property bool TargetLoaded {
    bool get ();
    void set (bool value);
}
function get_TargetLoaded();
function set_TargetLoaded(value);

Property Value

Type: Boolean
if the target module is loaded; otherwise, .
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.TargetMachineName Property

CoreConnectionDetailsTargetMachineName Property
This value is the name of the target server.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string TargetMachineName { get; set; }
Public Property TargetMachineName As String
    Get
    Set
public:
property String^ TargetMachineName {
    String^ get ();
    void set (String^ value);
}
function get_TargetMachineName();
function set_TargetMachineName(value);

Property Value

Type: String
The name of the target server.
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.TargetQueueBytes Property

CoreConnectionDetailsTargetQueueBytes Property
This value is the number of bytes in the target queue.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public long TargetQueueBytes { get; set; }
Public Property TargetQueueBytes As Long
    Get
    Set
public:
property long long TargetQueueBytes {
    long long get ();
    void set (long long value);
}
function get_TargetQueueBytes();
function set_TargetQueueBytes(value);

Property Value

Type: Int64
The number of bytes in the target queue.
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.TargetRoute Property

CoreConnectionDetailsTargetRoute Property
This value is the endpoint on the target that is the route the source is using for the connection.This route is in the format [address]:[port].

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string TargetRoute { get; set; }
Public Property TargetRoute As String
    Get
    Set
public:
property String^ TargetRoute {
    String^ get ();
    void set (String^ value);
}
function get_TargetRoute();
function set_TargetRoute(value);

Property Value

Type: String
The target route.
Remarks
This route is in the format [address]:[port].
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.TargetState Property

CoreConnectionDetailsTargetState Property
This value represents the state of the target.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public TargetStates TargetState { get; set; }
Public Property TargetState As TargetStates
    Get
    Set
public:
property TargetStates TargetState {
    TargetStates get ();
    void set (TargetStates value);
}
function get_TargetState();
function set_TargetState(value);

Property Value

Type: TargetStates
The known operational states of the connection target.
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.TargetUniqueId Property

CoreConnectionDetailsTargetUniqueId Property
This value is a unique ID assigned to the target.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string TargetUniqueId { get; set; }
Public Property TargetUniqueId As String
    Get
    Set
public:
property String^ TargetUniqueId {
    String^ get ();
    void set (String^ value);
}
function get_TargetUniqueId();
function set_TargetUniqueId(value);

Property Value

Type: String
The unique identifier of the target server.
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.TotalBytesSent Property

CoreConnectionDetailsTotalBytesSent Property
This value is the total number of bytes that have been sent for the connection.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public long TotalBytesSent { get; set; }
Public Property TotalBytesSent As Long
    Get
    Set
public:
property long long TotalBytesSent {
    long long get ();
    void set (long long value);
}
function get_TotalBytesSent();
function set_TotalBytesSent(value);

Property Value

Type: Int64
The total bytes sent.
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.TotalBytesTransmitted Property

CoreConnectionDetailsTotalBytesTransmitted Property
This value is the total number of bytes that have been transmitted for the connection.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public long TotalBytesTransmitted { get; set; }
Public Property TotalBytesTransmitted As Long
    Get
    Set
public:
property long long TotalBytesTransmitted {
    long long get ();
    void set (long long value);
}
function get_TotalBytesTransmitted();
function set_TotalBytesTransmitted(value);

Property Value

Type: Int64
The total number of bytes transmitted.
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.TotalOpsQueued Property

CoreConnectionDetailsTotalOpsQueued Property
This value is the total number of operations queued on the target.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public long TotalOpsQueued { get; set; }
Public Property TotalOpsQueued As Long
    Get
    Set
public:
property long long TotalOpsQueued {
    long long get ();
    void set (long long value);
}
function get_TotalOpsQueued();
function set_TotalOpsQueued(value);

Property Value

Type: Int64
The total number of ops queued.
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.TransmissionMode Property

CoreConnectionDetailsTransmissionMode Property
This value represents the state of data transmission from the source to the target.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public TransmissionMode TransmissionMode { get; set; }
Public Property TransmissionMode As TransmissionMode
    Get
    Set
public:
property TransmissionMode TransmissionMode {
    TransmissionMode get ();
    void set (TransmissionMode value);
}
function get_TransmissionMode();
function set_TransmissionMode(value);

Property Value

Type: TransmissionMode
The operational state of replication and mirroring.
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionOptions Class

CoreConnectionOptions Class
Represents option for configuring an underlying engine connection used by a job.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractCoreConnectionOptions

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class CoreConnectionOptions : IExtensibleDataObject
Public Class CoreConnectionOptions
    Implements IExtensibleDataObject
public ref class CoreConnectionOptions : IExtensibleDataObject
DoubleTake.Jobs.Contract.CoreConnectionOptions = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.CoreConnectionOptions',
    null,
    IExtensibleDataObject);

The CoreConnectionOptions type exposes the following members.

Constructors
 | Name | Description
Public method | CoreConnectionOptions | Initializes a new instance of the CoreConnectionOptions class
Top
Properties
 | Name | Description
Public property | ConnectionStartParameters | This value represents the parameters used to start the connection between the source and target.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | PathTransformations | This value represents where the source protected data will be located on the target.
Public property | TargetAddress | This value is the target IP address.
Public property | TargetEnginePort | This value is the port where the engine is listening.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


CoreConnectionOptions Constructor

CoreConnectionOptions Constructor
Initializes a new instance of the CoreConnectionOptions class

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public CoreConnectionOptions()
Public Sub New
public:
CoreConnectionOptions()
DoubleTake.Jobs.Contract.CoreConnectionOptions = function();
See Also

Reference

CoreConnectionOptions Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionOptions Properties

CoreConnectionOptions Properties

The CoreConnectionOptions type exposes the following members.

Properties
 | Name | Description
Public property | ConnectionStartParameters | This value represents the parameters used to start the connection between the source and target.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | PathTransformations | This value represents where the source protected data will be located on the target.
Public property | TargetAddress | This value is the target IP address.
Public property | TargetEnginePort | This value is the port where the engine is listening.
Top
See Also

Reference

CoreConnectionOptions Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionOptions.ConnectionStartParameters Property

CoreConnectionOptionsConnectionStartParameters Property
This value represents the parameters used to start the connection between the source and target.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ConnectionStartParameters ConnectionStartParameters { get; set; }
Public Property ConnectionStartParameters As ConnectionStartParameters
    Get
    Set
public:
property ConnectionStartParameters^ ConnectionStartParameters {
    ConnectionStartParameters^ get ();
    void set (ConnectionStartParameters^ value);
}
function get_ConnectionStartParameters();
function set_ConnectionStartParameters(value);

Property Value

Type: ConnectionStartParameters
The parameters used to start the connection between source and target servers.
See Also

Reference

CoreConnectionOptions Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionOptions.ExtensionData Property

CoreConnectionOptionsExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

CoreConnectionOptions Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionOptions.PathTransformations Property

CoreConnectionOptionsPathTransformations Property
This value represents where the source protected data will be located on the target.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public PathTransformation[] PathTransformations { get; set; }
Public Property PathTransformations As PathTransformation()
    Get
    Set
public:
property array<PathTransformation^>^ PathTransformations {
    array<PathTransformation^>^ get ();
    void set (array<PathTransformation^>^ value);
}
function get_PathTransformations();
function set_PathTransformations(value);

Property Value

Type: PathTransformation
The path transformations.
See Also

Reference

CoreConnectionOptions Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionOptions.TargetAddress Property

CoreConnectionOptionsTargetAddress Property
This value is the target IP address.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string TargetAddress { get; set; }
Public Property TargetAddress As String
    Get
    Set
public:
property String^ TargetAddress {
    String^ get ();
    void set (String^ value);
}
function get_TargetAddress();
function set_TargetAddress(value);

Property Value

Type: String
The target address.
Remarks
This string must be a valid IPv4 or IPv6 address.
See Also

Reference

CoreConnectionOptions Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionOptions.TargetEnginePort Property

CoreConnectionOptionsTargetEnginePort Property
This value is the port where the engine is listening.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int TargetEnginePort { get; set; }
Public Property TargetEnginePort As Integer
    Get
    Set
public:
property int TargetEnginePort {
    int get ();
    void set (int value);
}
function get_TargetEnginePort();
function set_TargetEnginePort(value);

Property Value

Type: Int32
The engine port on the target server.
See Also

Reference

CoreConnectionOptions Class
DoubleTake.Jobs.Contract Namespace


CoreMonitorDetails Class

CoreMonitorDetails Class
Represents details of an underlying engine monitor used by a job.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractCoreMonitorDetails

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class CoreMonitorDetails : IExtensibleDataObject
Public Class CoreMonitorDetails
    Implements IExtensibleDataObject
public ref class CoreMonitorDetails : IExtensibleDataObject
DoubleTake.Jobs.Contract.CoreMonitorDetails = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.CoreMonitorDetails',
    null,
    IExtensibleDataObject);

The CoreMonitorDetails type exposes the following members.

Constructors
 | Name | Description
Public method | CoreMonitorDetails | Initializes a new instance of the CoreMonitorDetails class
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | HighAvailabilityState | This value represents the state of failover monitoring.
Public property | MonitoredAddressStatuses | This value represents the status of a monitored IP address.
Public property | MonitorId | This value is a unique ID for this failover monitor.
Public property | MonitorName | This value is the name for this failover monitor.
Public property | RestoreStates | This value represents the state of a restoration connection.
Public property | TargetAvailable | This value is true if the target is available; otherwise, it is false.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


CoreMonitorDetails Constructor

CoreMonitorDetails Constructor
Initializes a new instance of the CoreMonitorDetails class

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public CoreMonitorDetails()
Public Sub New
public:
CoreMonitorDetails()
DoubleTake.Jobs.Contract.CoreMonitorDetails = function();
See Also

Reference

CoreMonitorDetails Class
DoubleTake.Jobs.Contract Namespace


CoreMonitorDetails Properties

CoreMonitorDetails Properties

The CoreMonitorDetails type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | HighAvailabilityState | This value represents the state of failover monitoring.
Public property | MonitoredAddressStatuses | This value represents the status of a monitored IP address.
Public property | MonitorId | This value is a unique ID for this failover monitor.
Public property | MonitorName | This value is the name for this failover monitor.
Public property | RestoreStates | This value represents the state of a restoration connection.
Public property | TargetAvailable | This value is true if the target is available; otherwise, it is false.
Top
See Also

Reference

CoreMonitorDetails Class
DoubleTake.Jobs.Contract Namespace


CoreMonitorDetails.ExtensionData Property

CoreMonitorDetailsExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

CoreMonitorDetails Class
DoubleTake.Jobs.Contract Namespace


CoreMonitorDetails.HighAvailabilityState Property

CoreMonitorDetailsHighAvailabilityState Property
This value represents the state of failover monitoring.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public HighAvailabilityState HighAvailabilityState { get; set; }
Public Property HighAvailabilityState As HighAvailabilityState
    Get
    Set
public:
property HighAvailabilityState HighAvailabilityState {
    HighAvailabilityState get ();
    void set (HighAvailabilityState value);
}
function get_HighAvailabilityState();
function set_HighAvailabilityState(value);

Property Value

Type: HighAvailabilityState
The high availability state.
See Also

Reference

CoreMonitorDetails Class
DoubleTake.Jobs.Contract Namespace


CoreMonitorDetails.MonitoredAddressStatuses Property

CoreMonitorDetailsMonitoredAddressStatuses Property
This value represents the status of a monitored IP address.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public MonitoredAddressStatus[] MonitoredAddressStatuses { get; set; }
Public Property MonitoredAddressStatuses As MonitoredAddressStatus()
    Get
    Set
public:
property array<MonitoredAddressStatus^>^ MonitoredAddressStatuses {
    array<MonitoredAddressStatus^>^ get ();
    void set (array<MonitoredAddressStatus^>^ value);
}
function get_MonitoredAddressStatuses();
function set_MonitoredAddressStatuses(value);

Property Value

Type: MonitoredAddressStatus
An array of MonitoredAddressStatus that represents the status of the monitored addresses.
See Also

Reference

CoreMonitorDetails Class
DoubleTake.Jobs.Contract Namespace


CoreMonitorDetails.MonitorId Property

CoreMonitorDetailsMonitorId Property
This value is a unique ID for this failover monitor.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Guid MonitorId { get; set; }
Public Property MonitorId As Guid
    Get
    Set
public:
property Guid MonitorId {
    Guid get ();
    void set (Guid value);
}
function get_MonitorId();
function set_MonitorId(value);

Property Value

Type: Guid
The unique identifier of the monitor.
See Also

Reference

CoreMonitorDetails Class
DoubleTake.Jobs.Contract Namespace


CoreMonitorDetails.MonitorName Property

CoreMonitorDetailsMonitorName Property
This value is the name for this failover monitor.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string MonitorName { get; set; }
Public Property MonitorName As String
    Get
    Set
public:
property String^ MonitorName {
    String^ get ();
    void set (String^ value);
}
function get_MonitorName();
function set_MonitorName(value);

Property Value

Type: String
The name of the monitor.
See Also

Reference

CoreMonitorDetails Class
DoubleTake.Jobs.Contract Namespace


CoreMonitorDetails.RestoreStates Property

CoreMonitorDetailsRestoreStates Property
This value represents the state of a restoration connection.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public RestoreStates RestoreStates { get; set; }
Public Property RestoreStates As RestoreStates
    Get
    Set
public:
property RestoreStates RestoreStates {
    RestoreStates get ();
    void set (RestoreStates value);
}
function get_RestoreStates();
function set_RestoreStates(value);

Property Value

Type: RestoreStates
The state of the restore operation.
See Also

Reference

CoreMonitorDetails Class
DoubleTake.Jobs.Contract Namespace


CoreMonitorDetails.TargetAvailable Property

CoreMonitorDetailsTargetAvailable Property
This value is true if the target is available; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool TargetAvailable { get; set; }
Public Property TargetAvailable As Boolean
    Get
    Set
public:
property bool TargetAvailable {
    bool get ();
    void set (bool value);
}
function get_TargetAvailable();
function set_TargetAvailable(value);

Property Value

Type: Boolean
if the target machine is available; otherwise, .
See Also

Reference

CoreMonitorDetails Class
DoubleTake.Jobs.Contract Namespace


CoreMonitorOptions Class

CoreMonitorOptions Class
Represents options for configuring an underlying engine monitor used by a job.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractCoreMonitorOptions

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class CoreMonitorOptions : IExtensibleDataObject
Public Class CoreMonitorOptions
    Implements IExtensibleDataObject
public ref class CoreMonitorOptions : IExtensibleDataObject
DoubleTake.Jobs.Contract.CoreMonitorOptions = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.CoreMonitorOptions',
    null,
    IExtensibleDataObject);

The CoreMonitorOptions type exposes the following members.

Constructors
 | Name | Description
Public method | CoreMonitorOptions | Initializes a new instance of the CoreMonitorOptions class
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | MonitorConfiguration | This value represents the configuration of failover monitoring.
Public property | ShouldPerformLanFailover | This value is for display in the console to determine which failover option should be selected by default.
Public property | TotalTimeAllowed | This value is the amount of time allowed without a successful ping before a failover condition is met.
Public property | UseTotalTimeAllowed | This value is true if TotalTimeAllowed is used to determine when a failover condition is met; otherwise, it is false.
Top
Fields
 | Name | Description
Public field | SourceDomain | This value is the name of the source domain.
Public field | SourceServer | This value is the name of the source server.
Public field | TargetDomain | This value is the name of the target domain.
Public field | TargetServer | This value is the name of the target server.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


CoreMonitorOptions Constructor

CoreMonitorOptions Constructor
Initializes a new instance of the CoreMonitorOptions class

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public CoreMonitorOptions()
Public Sub New
public:
CoreMonitorOptions()
DoubleTake.Jobs.Contract.CoreMonitorOptions = function();
See Also

Reference

CoreMonitorOptions Class
DoubleTake.Jobs.Contract Namespace


CoreMonitorOptions Properties

CoreMonitorOptions Properties

The CoreMonitorOptions type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | MonitorConfiguration | This value represents the configuration of failover monitoring.
Public property | ShouldPerformLanFailover | This value is for display in the console to determine which failover option should be selected by default.
Public property | TotalTimeAllowed | This value is the amount of time allowed without a successful ping before a failover condition is met.
Public property | UseTotalTimeAllowed | This value is true if TotalTimeAllowed is used to determine when a failover condition is met; otherwise, it is false.
Top
See Also

Reference

CoreMonitorOptions Class
DoubleTake.Jobs.Contract Namespace


CoreMonitorOptions.ExtensionData Property

CoreMonitorOptionsExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

CoreMonitorOptions Class
DoubleTake.Jobs.Contract Namespace


CoreMonitorOptions.MonitorConfiguration Property

CoreMonitorOptionsMonitorConfiguration Property
This value represents the configuration of failover monitoring.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public MonitorConfiguration MonitorConfiguration { get; set; }
Public Property MonitorConfiguration As MonitorConfiguration
    Get
    Set
public:
property MonitorConfiguration^ MonitorConfiguration {
    MonitorConfiguration^ get ();
    void set (MonitorConfiguration^ value);
}
function get_MonitorConfiguration();
function set_MonitorConfiguration(value);

Property Value

Type: MonitorConfiguration
The monitor configuration.
See Also

Reference

CoreMonitorOptions Class
DoubleTake.Jobs.Contract Namespace


CoreMonitorOptions.ShouldPerformLanFailover Property

CoreMonitorOptionsShouldPerformLanFailover Property
This value is for display in the console to determine which failover option should be selected by default.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Nullable<bool> ShouldPerformLanFailover { get; set; }
Public Property ShouldPerformLanFailover As Nullable(Of Boolean)
    Get
    Set
public:
property Nullable<bool> ShouldPerformLanFailover {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}
function get_ShouldPerformLanFailover();
function set_ShouldPerformLanFailover(value);

Property Value

Type: Nullable Boolean
if LAN (identity) failover should be performed, if WAN failover should be performed, or if the version of the service doesn't support this property.
See Also

Reference

CoreMonitorOptions Class
DoubleTake.Jobs.Contract Namespace


CoreMonitorOptions.TotalTimeAllowed Property

CoreMonitorOptionsTotalTimeAllowed Property
This value is the amount of time allowed without a successful ping before a failover condition is met.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public TimeSpan TotalTimeAllowed { get; set; }
Public Property TotalTimeAllowed As TimeSpan
    Get
    Set
public:
property TimeSpan TotalTimeAllowed {
    TimeSpan get ();
    void set (TimeSpan value);
}
function get_TotalTimeAllowed();
function set_TotalTimeAllowed(value);

Property Value

Type: TimeSpan
The total time allowed.
See Also

Reference

CoreMonitorOptions Class
DoubleTake.Jobs.Contract Namespace


CoreMonitorOptions.UseTotalTimeAllowed Property

CoreMonitorOptionsUseTotalTimeAllowed Property
This value is true if TotalTimeAllowed is used to determine when a failover condition is met; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool UseTotalTimeAllowed { get; set; }
Public Property UseTotalTimeAllowed As Boolean
    Get
    Set
public:
property bool UseTotalTimeAllowed {
    bool get ();
    void set (bool value);
}
function get_UseTotalTimeAllowed();
function set_UseTotalTimeAllowed(value);

Property Value

Type: Boolean
if the TotalTimeAllowed property should be used; otherwise, .
See Also

Reference

CoreMonitorOptions Class
DoubleTake.Jobs.Contract Namespace


CoreMonitorOptions Fields

CoreMonitorOptions Fields

The CoreMonitorOptions type exposes the following members.

Fields
 | Name | Description
Public field | SourceDomain | This value is the name of the source domain.
Public field | SourceServer | This value is the name of the source server.
Public field | TargetDomain | This value is the name of the target domain.
Public field | TargetServer | This value is the name of the target server.
Top
See Also

Reference

CoreMonitorOptions Class
DoubleTake.Jobs.Contract Namespace


CoreMonitorOptions.SourceDomain Field

CoreMonitorOptionsSourceDomain Field
This value is the name of the source domain.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string SourceDomain
Public SourceDomain As String
public:
String^ SourceDomain
var SourceDomain

Field Value

Type: String
See Also

Reference

CoreMonitorOptions Class
DoubleTake.Jobs.Contract Namespace


CoreMonitorOptions.SourceServer Field

CoreMonitorOptionsSourceServer Field
This value is the name of the source server.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string SourceServer
Public SourceServer As String
public:
String^ SourceServer
var SourceServer

Field Value

Type: String
See Also

Reference

CoreMonitorOptions Class
DoubleTake.Jobs.Contract Namespace


CoreMonitorOptions.TargetDomain Field

CoreMonitorOptionsTargetDomain Field
This value is the name of the target domain.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string TargetDomain
Public TargetDomain As String
public:
String^ TargetDomain
var TargetDomain

Field Value

Type: String
See Also

Reference

CoreMonitorOptions Class
DoubleTake.Jobs.Contract Namespace


CoreMonitorOptions.TargetServer Field

CoreMonitorOptionsTargetServer Field
This value is the name of the target server.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string TargetServer
Public TargetServer As String
public:
String^ TargetServer
var TargetServer

Field Value

Type: String
See Also

Reference

CoreMonitorOptions Class
DoubleTake.Jobs.Contract Namespace


CoreQualificationResults Class

CoreQualificationResults Class
Represents information that may be needed to configure an engine connection.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractCoreQualificationResults

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class CoreQualificationResults : IExtensibleDataObject
Public Class CoreQualificationResults
    Implements IExtensibleDataObject
public ref class CoreQualificationResults : IExtensibleDataObject
DoubleTake.Jobs.Contract.CoreQualificationResults = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.CoreQualificationResults',
    null,
    IExtensibleDataObject);

The CoreQualificationResults type exposes the following members.

Constructors
 | Name | Description
Public method | CoreQualificationResults | Initializes a new instance of the CoreQualificationResults class
Top
Properties
 | Name | Description
Public property | CompressionLevels | This value is the compression level. It will be null if there is a problem getting the compression level from the source or target.
Public property | DefaultAllToOneBasePath | This value sets the default base path for the all to one path mapping, which configures the source replica data to be stored on a single volume on the target. The default is \source_name\volume_name. If you are protecting multiple volumes on the source, each volume would be stored on the same volume on the target. For example, C:\data and D:\files for the source Alpha would be stored in D:\alpha\C and D:\alpha\D, respectively.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | SourceEnginePort | This value is the port where the engine is listening.
Public property | SourceIPAddresses | This value represents the available IP addresses on the source.
Public property | SourceMachineName | This value is the name of the source server.
Public property | SourceNetworkId | This value is the source network ID used to communicate with the source from the target.
Public property | SourceNetworkInterfaces | This value represents the available NICs on the source.
Public property | SourceProductInfo | This value represents the Double-Take product info on the source.
Public property | SourceVolumes | This value represents the available volumes on the source.
Public property | TargetEnginePort | This value is the port where the engine is listening.
Public property | TargetIPAddresses | This value represents the available IP addresses on the target. These IP addresses are the possible values that can be used to populate CoreConnectionOptions.TargetAddress.
Public property | TargetMachineName | This value is the name of the target server.
Public property | TargetNetworkInterfaces | This value represents the available NICs on the target.
Public property | TargetProductInfo | This value represents the Double-Take product info on the target.
Public property | TargetVolumes | This value represents the available volumes on the target.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


CoreQualificationResults Constructor

CoreQualificationResults Constructor
Initializes a new instance of the CoreQualificationResults class

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public CoreQualificationResults()
Public Sub New
public:
CoreQualificationResults()
DoubleTake.Jobs.Contract.CoreQualificationResults = function();
See Also

Reference

CoreQualificationResults Class
DoubleTake.Jobs.Contract Namespace


CoreQualificationResults Properties

CoreQualificationResults Properties

The CoreQualificationResults type exposes the following members.

Properties
 | Name | Description
Public property | CompressionLevels | This value is the compression level. It will be null if there is a problem getting the compression level from the source or target.
Public property | DefaultAllToOneBasePath | This value sets the default base path for the all to one path mapping, which configures the source replica data to be stored on a single volume on the target. The default is \source_name\volume_name. If you are protecting multiple volumes on the source, each volume would be stored on the same volume on the target. For example, C:\data and D:\files for the source Alpha would be stored in D:\alpha\C and D:\alpha\D, respectively.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | SourceEnginePort | This value is the port where the engine is listening.
Public property | SourceIPAddresses | This value represents the available IP addresses on the source.
Public property | SourceMachineName | This value is the name of the source server.
Public property | SourceNetworkId | This value is the source network ID used to communicate with the source from the target.
Public property | SourceNetworkInterfaces | This value represents the available NICs on the source.
Public property | SourceProductInfo | This value represents the Double-Take product info on the source.
Public property | SourceVolumes | This value represents the available volumes on the source.
Public property | TargetEnginePort | This value is the port where the engine is listening.
Public property | TargetIPAddresses | This value represents the available IP addresses on the target. These IP addresses are the possible values that can be used to populate CoreConnectionOptions.TargetAddress.
Public property | TargetMachineName | This value is the name of the target server.
Public property | TargetNetworkInterfaces | This value represents the available NICs on the target.
Public property | TargetProductInfo | This value represents the Double-Take product info on the target.
Public property | TargetVolumes | This value represents the available volumes on the target.
Top
See Also

Reference

CoreQualificationResults Class
DoubleTake.Jobs.Contract Namespace


CoreQualificationResults.CompressionLevels Property

CoreQualificationResultsCompressionLevels Property
This value is the compression level. It will be null if there is a problem getting the compression level from the source or target.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public CompressionLevel[] CompressionLevels { get; set; }
Public Property CompressionLevels As CompressionLevel()
    Get
    Set
public:
property array<CompressionLevel^>^ CompressionLevels {
    array<CompressionLevel^>^ get ();
    void set (array<CompressionLevel^>^ value);
}
function get_CompressionLevels();
function set_CompressionLevels(value);

Property Value

Type: CompressionLevel
The compression levels.
Remarks
This property will be if there is a problem getting the compression levels from both source and target servers.
See Also

Reference

CoreQualificationResults Class
DoubleTake.Jobs.Contract Namespace


CoreQualificationResults.DefaultAllToOneBasePath Property

CoreQualificationResultsDefaultAllToOneBasePath Property
This value sets the default base path for the all to one path mapping, which configures the source replica data to be stored on a single volume on the target. The default is \source_name\volume_name. If you are protecting multiple volumes on the source, each volume would be stored on the same volume on the target. For example, C:\data and D:\files for the source Alpha would be stored in D:\alpha\C and D:\alpha\D, respectively.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string DefaultAllToOneBasePath { get; set; }
Public Property DefaultAllToOneBasePath As String
    Get
    Set
public:
property String^ DefaultAllToOneBasePath {
    String^ get ();
    void set (String^ value);
}
function get_DefaultAllToOneBasePath();
function set_DefaultAllToOneBasePath(value);

Property Value

Type: String
The default all-to-one base path.
See Also

Reference

CoreQualificationResults Class
DoubleTake.Jobs.Contract Namespace


CoreQualificationResults.ExtensionData Property

CoreQualificationResultsExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

CoreQualificationResults Class
DoubleTake.Jobs.Contract Namespace


CoreQualificationResults.SourceEnginePort Property

CoreQualificationResultsSourceEnginePort Property
This value is the port where the engine is listening.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int SourceEnginePort { get; set; }
Public Property SourceEnginePort As Integer
    Get
    Set
public:
property int SourceEnginePort {
    int get ();
    void set (int value);
}
function get_SourceEnginePort();
function set_SourceEnginePort(value);

Property Value

Type: Int32
The source engine port.
See Also

Reference

CoreQualificationResults Class
DoubleTake.Jobs.Contract Namespace


CoreQualificationResults.SourceIPAddresses Property

CoreQualificationResultsSourceIPAddresses Property
This value represents the available IP addresses on the source.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public UnicastIPAddressInfo[] SourceIPAddresses { get; set; }
Public Property SourceIPAddresses As UnicastIPAddressInfo()
    Get
    Set
public:
property array<UnicastIPAddressInfo^>^ SourceIPAddresses {
    array<UnicastIPAddressInfo^>^ get ();
    void set (array<UnicastIPAddressInfo^>^ value);
}
function get_SourceIPAddresses();
function set_SourceIPAddresses(value);

Property Value

Type: UnicastIPAddressInfo
The source machine's available IP addresses.
See Also

Reference

CoreQualificationResults Class
DoubleTake.Jobs.Contract Namespace


CoreQualificationResults.SourceMachineName Property

CoreQualificationResultsSourceMachineName Property
This value is the name of the source server.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string SourceMachineName { get; set; }
Public Property SourceMachineName As String
    Get
    Set
public:
property String^ SourceMachineName {
    String^ get ();
    void set (String^ value);
}
function get_SourceMachineName();
function set_SourceMachineName(value);

Property Value

Type: String
The name of the source machine.
See Also

Reference

CoreQualificationResults Class
DoubleTake.Jobs.Contract Namespace


CoreQualificationResults.SourceNetworkId Property

CoreQualificationResultsSourceNetworkId Property
This value is the source network ID used to communicate with the source from the target.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string SourceNetworkId { get; set; }
Public Property SourceNetworkId As String
    Get
    Set
public:
property String^ SourceNetworkId {
    String^ get ();
    void set (String^ value);
}
function get_SourceNetworkId();
function set_SourceNetworkId(value);

Property Value

Type: String
The source network id.
See Also

Reference

CoreQualificationResults Class
DoubleTake.Jobs.Contract Namespace


CoreQualificationResults.SourceNetworkInterfaces Property

CoreQualificationResultsSourceNetworkInterfaces Property
This value represents the available NICs on the source.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public NetworkInterfaceInfo[] SourceNetworkInterfaces { get; set; }
Public Property SourceNetworkInterfaces As NetworkInterfaceInfo()
    Get
    Set
public:
property array<NetworkInterfaceInfo^>^ SourceNetworkInterfaces {
    array<NetworkInterfaceInfo^>^ get ();
    void set (array<NetworkInterfaceInfo^>^ value);
}
function get_SourceNetworkInterfaces();
function set_SourceNetworkInterfaces(value);

Property Value

Type: NetworkInterfaceInfo
The source network interfaces.
See Also

Reference

CoreQualificationResults Class
DoubleTake.Jobs.Contract Namespace


CoreQualificationResults.SourceProductInfo Property

CoreQualificationResultsSourceProductInfo Property
This value represents the Double-Take product info on the source.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ProductInfo SourceProductInfo { get; set; }
Public Property SourceProductInfo As ProductInfo
    Get
    Set
public:
property ProductInfo^ SourceProductInfo {
    ProductInfo^ get ();
    void set (ProductInfo^ value);
}
function get_SourceProductInfo();
function set_SourceProductInfo(value);

Property Value

Type: ProductInfo
The source product info.
See Also

Reference

CoreQualificationResults Class
DoubleTake.Jobs.Contract Namespace


CoreQualificationResults.SourceVolumes Property

CoreQualificationResultsSourceVolumes Property
This value represents the available volumes on the source.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Volume[] SourceVolumes { get; set; }
Public Property SourceVolumes As Volume()
    Get
    Set
public:
property array<Volume^>^ SourceVolumes {
    array<Volume^>^ get ();
    void set (array<Volume^>^ value);
}
function get_SourceVolumes();
function set_SourceVolumes(value);

Property Value

Type: Volume
The source volumes.
See Also

Reference

CoreQualificationResults Class
DoubleTake.Jobs.Contract Namespace


CoreQualificationResults.TargetEnginePort Property

CoreQualificationResultsTargetEnginePort Property
This value is the port where the engine is listening.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int TargetEnginePort { get; set; }
Public Property TargetEnginePort As Integer
    Get
    Set
public:
property int TargetEnginePort {
    int get ();
    void set (int value);
}
function get_TargetEnginePort();
function set_TargetEnginePort(value);

Property Value

Type: Int32
The target engine port.
See Also

Reference

CoreQualificationResults Class
DoubleTake.Jobs.Contract Namespace


CoreQualificationResults.TargetIPAddresses Property

CoreQualificationResultsTargetIPAddresses Property
This value represents the available IP addresses on the target. These IP addresses are the possible values that can be used to populate CoreConnectionOptions.TargetAddress.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public UnicastIPAddressInfo[] TargetIPAddresses { get; set; }
Public Property TargetIPAddresses As UnicastIPAddressInfo()
    Get
    Set
public:
property array<UnicastIPAddressInfo^>^ TargetIPAddresses {
    array<UnicastIPAddressInfo^>^ get ();
    void set (array<UnicastIPAddressInfo^>^ value);
}
function get_TargetIPAddresses();
function set_TargetIPAddresses(value);

Property Value

Type: UnicastIPAddressInfo
The target machine's available IP addresses.
Remarks
These IP addresses are the possible values that can be used to populate the TargetAddress property in the CoreConnectionOptions class when configuring JobOptions.
See Also

Reference

CoreQualificationResults Class
DoubleTake.Jobs.Contract Namespace


CoreQualificationResults.TargetMachineName Property

CoreQualificationResultsTargetMachineName Property
This value is the name of the target server.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string TargetMachineName { get; set; }
Public Property TargetMachineName As String
    Get
    Set
public:
property String^ TargetMachineName {
    String^ get ();
    void set (String^ value);
}
function get_TargetMachineName();
function set_TargetMachineName(value);

Property Value

Type: String
The name of the target machine.
See Also

Reference

CoreQualificationResults Class
DoubleTake.Jobs.Contract Namespace


CoreQualificationResults.TargetNetworkInterfaces Property

CoreQualificationResultsTargetNetworkInterfaces Property
This value represents the available NICs on the target.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public NetworkInterfaceInfo[] TargetNetworkInterfaces { get; set; }
Public Property TargetNetworkInterfaces As NetworkInterfaceInfo()
    Get
    Set
public:
property array<NetworkInterfaceInfo^>^ TargetNetworkInterfaces {
    array<NetworkInterfaceInfo^>^ get ();
    void set (array<NetworkInterfaceInfo^>^ value);
}
function get_TargetNetworkInterfaces();
function set_TargetNetworkInterfaces(value);

Property Value

Type: NetworkInterfaceInfo
The target network interfaces.
See Also

Reference

CoreQualificationResults Class
DoubleTake.Jobs.Contract Namespace


CoreQualificationResults.TargetProductInfo Property

CoreQualificationResultsTargetProductInfo Property
This value represents the Double-Take product info on the target.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ProductInfo TargetProductInfo { get; set; }
Public Property TargetProductInfo As ProductInfo
    Get
    Set
public:
property ProductInfo^ TargetProductInfo {
    ProductInfo^ get ();
    void set (ProductInfo^ value);
}
function get_TargetProductInfo();
function set_TargetProductInfo(value);

Property Value

Type: ProductInfo
The target product info.
See Also

Reference

CoreQualificationResults Class
DoubleTake.Jobs.Contract Namespace


CoreQualificationResults.TargetVolumes Property

CoreQualificationResultsTargetVolumes Property
This value represents the available volumes on the target.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Volume[] TargetVolumes { get; set; }
Public Property TargetVolumes As Volume()
    Get
    Set
public:
property array<Volume^>^ TargetVolumes {
    array<Volume^>^ get ();
    void set (array<Volume^>^ value);
}
function get_TargetVolumes();
function set_TargetVolumes(value);

Property Value

Type: Volume
The target volumes.
See Also

Reference

CoreQualificationResults Class
DoubleTake.Jobs.Contract Namespace


CreateOptions Class

CreateOptions Class
Represents the options required to create a job.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractCreateOptions

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class CreateOptions : IExtensibleDataObject
Public Class CreateOptions
    Implements IExtensibleDataObject
public ref class CreateOptions : IExtensibleDataObject
DoubleTake.Jobs.Contract.CreateOptions = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.CreateOptions',
    null,
    IExtensibleDataObject);

The CreateOptions type exposes the following members.

Constructors
 | Name | Description
Public method | CreateOptions | Initializes a new instance of the CreateOptions class
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | JobCredentials | Gets or sets the job credentials.
Public property | JobOptions | Gets or sets the job options.
Public property | JobType | Gets or sets the type of the job.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


CreateOptions Constructor

CreateOptions Constructor
Initializes a new instance of the CreateOptions class

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public CreateOptions()
Public Sub New
public:
CreateOptions()
DoubleTake.Jobs.Contract.CreateOptions = function();
See Also

Reference

CreateOptions Class
DoubleTake.Jobs.Contract Namespace


CreateOptions Properties

CreateOptions Properties

The CreateOptions type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | JobCredentials | Gets or sets the job credentials.
Public property | JobOptions | Gets or sets the job options.
Public property | JobType | Gets or sets the type of the job.
Top
See Also

Reference

CreateOptions Class
DoubleTake.Jobs.Contract Namespace


CreateOptions.ExtensionData Property

CreateOptionsExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

CreateOptions Class
DoubleTake.Jobs.Contract Namespace


CreateOptions.JobCredentials Property

CreateOptionsJobCredentials Property
Gets or sets the job credentials.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public JobCredentials JobCredentials { get; set; }
Public Property JobCredentials As JobCredentials
    Get
    Set
public:
property JobCredentials^ JobCredentials {
    JobCredentials^ get ();
    void set (JobCredentials^ value);
}
function get_JobCredentials();
function set_JobCredentials(value);

Property Value

Type: JobCredentials
The connection information and credentials for the source and target servers.
See Also

Reference

CreateOptions Class
DoubleTake.Jobs.Contract Namespace


CreateOptions.JobOptions Property

CreateOptionsJobOptions Property
Gets or sets the job options.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public JobOptions JobOptions { get; set; }
Public Property JobOptions As JobOptions
    Get
    Set
public:
property JobOptions^ JobOptions {
    JobOptions^ get ();
    void set (JobOptions^ value);
}
function get_JobOptions();
function set_JobOptions(value);

Property Value

Type: JobOptions
The job options.
Remarks
The JobOptions value includes the Workload to be used by the job.
See Also

Reference

CreateOptions Class
DoubleTake.Jobs.Contract Namespace


CreateOptions.JobType Property

CreateOptionsJobType Property
Gets or sets the type of the job.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string JobType { get; set; }
Public Property JobType As String
    Get
    Set
public:
property String^ JobType {
    String^ get ();
    void set (String^ value);
}
function get_JobType();
function set_JobType(value);

Property Value

Type: String
The type of the job.
See Also

Reference

CreateOptions Class
DoubleTake.Jobs.Contract Namespace


CutoverDetails Class

CutoverDetails Class
Represents the details of a cutover operation.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractCutoverDetails

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class CutoverDetails : IExtensibleDataObject
Public Class CutoverDetails
    Implements IExtensibleDataObject
public ref class CutoverDetails : IExtensibleDataObject
DoubleTake.Jobs.Contract.CutoverDetails = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.CutoverDetails',
    null,
    IExtensibleDataObject);

The CutoverDetails type exposes the following members.

Constructors
 | Name | Description
Public method | CutoverDetails | Initializes a new instance of the CutoverDetails class
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | PercentComplete | This value is the percentage of the cutover that is complete.
Public property | State | This value is the state of the cutover. If this value is 1, the cutover is idle. If this value is 1000, the cutover processing is complete. Negative numbers are error codes.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


CutoverDetails Constructor

CutoverDetails Constructor
Initializes a new instance of the CutoverDetails class

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public CutoverDetails()
Public Sub New
public:
CutoverDetails()
DoubleTake.Jobs.Contract.CutoverDetails = function();
See Also

Reference

CutoverDetails Class
DoubleTake.Jobs.Contract Namespace


CutoverDetails Properties

CutoverDetails Properties

The CutoverDetails type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | PercentComplete | This value is the percentage of the cutover that is complete.
Public property | State | This value is the state of the cutover. If this value is 1, the cutover is idle. If this value is 1000, the cutover processing is complete. Negative numbers are error codes.
Top
See Also

Reference

CutoverDetails Class
DoubleTake.Jobs.Contract Namespace


CutoverDetails.ExtensionData Property

CutoverDetailsExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

CutoverDetails Class
DoubleTake.Jobs.Contract Namespace


CutoverDetails.PercentComplete Property

CutoverDetailsPercentComplete Property
This value is the percentage of the cutover that is complete.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int PercentComplete { get; set; }
Public Property PercentComplete As Integer
    Get
    Set
public:
property int PercentComplete {
    int get ();
    void set (int value);
}
function get_PercentComplete();
function set_PercentComplete(value);

Property Value

Type: Int32
The percentage complete of the cutover operation.
See Also

Reference

CutoverDetails Class
DoubleTake.Jobs.Contract Namespace


CutoverDetails.State Property

CutoverDetailsState Property
This value is the state of the cutover. If this value is 1, the cutover is idle. If this value is 1000, the cutover processing is complete. Negative numbers are error codes.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int State { get; set; }
Public Property State As Integer
    Get
    Set
public:
property int State {
    int get ();
    void set (int value);
}
function get_State();
function set_State(value);

Property Value

Type: Int32
The state of the cutover operation.
See Also

Reference

CutoverDetails Class
DoubleTake.Jobs.Contract Namespace


DeleteOptions Class

DeleteOptions Class
Defines the options provided when deleting a job.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractDeleteOptions

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class DeleteOptions : IExtensibleDataObject
Public Class DeleteOptions
    Implements IExtensibleDataObject
public ref class DeleteOptions : IExtensibleDataObject
DoubleTake.Jobs.Contract.DeleteOptions = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.DeleteOptions',
    null,
    IExtensibleDataObject);

The DeleteOptions type exposes the following members.

Constructors
 | Name | Description
Public method | DeleteOptions | Initializes a new instance of the DeleteOptions class
Top
Properties
 | Name | Description
Public property | DeleteOnClusterResourceOffline | This value is true if the job is deleted because the target cluster resource went offline; otherwise, it is false.
Public property | DeleteReplica | This value is true if the replica virtual machine should be deleted when the job is deleted; otherwise, it is false.
Public property | DiscardTargetQueue | This value is true if any operations in the target queue should be deleted when the job is deleted; otherwise, it is false.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | ImageOptions | Gets or sets the option for what to do with the image when the job is deleted.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


DeleteOptions Constructor

DeleteOptions Constructor
Initializes a new instance of the DeleteOptions class

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public DeleteOptions()
Public Sub New
public:
DeleteOptions()
DoubleTake.Jobs.Contract.DeleteOptions = function();
See Also

Reference

DeleteOptions Class
DoubleTake.Jobs.Contract Namespace


DeleteOptions Properties

DeleteOptions Properties

The DeleteOptions type exposes the following members.

Properties
 | Name | Description
Public property | DeleteOnClusterResourceOffline | This value is true if the job is deleted because the target cluster resource went offline; otherwise, it is false.
Public property | DeleteReplica | This value is true if the replica virtual machine should be deleted when the job is deleted; otherwise, it is false.
Public property | DiscardTargetQueue | This value is true if any operations in the target queue should be deleted when the job is deleted; otherwise, it is false.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | ImageOptions | Gets or sets the option for what to do with the image when the job is deleted.
Top
See Also

Reference

DeleteOptions Class
DoubleTake.Jobs.Contract Namespace


DeleteOptions.DeleteOnClusterResourceOffline Property

DeleteOptionsDeleteOnClusterResourceOffline Property
This value is true if the job is deleted because the target cluster resource went offline; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool DeleteOnClusterResourceOffline { get; set; }
Public Property DeleteOnClusterResourceOffline As Boolean
    Get
    Set
public:
property bool DeleteOnClusterResourceOffline {
    bool get ();
    void set (bool value);
}
function get_DeleteOnClusterResourceOffline();
function set_DeleteOnClusterResourceOffline(value);

Property Value

Type: Boolean
true if delete is caused by target cluster resource going offline; otherwise, false.
See Also

Reference

DeleteOptions Class
DoubleTake.Jobs.Contract Namespace


DeleteOptions.DeleteReplica Property

DeleteOptionsDeleteReplica Property
This value is true if the replica virtual machine should be deleted when the job is deleted; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool DeleteReplica { get; set; }
Public Property DeleteReplica As Boolean
    Get
    Set
public:
property bool DeleteReplica {
    bool get ();
    void set (bool value);
}
function get_DeleteReplica();
function set_DeleteReplica(value);

Property Value

Type: Boolean
if the replica virtual machine should be deleted; otherwise, .
See Also

Reference

DeleteOptions Class
DoubleTake.Jobs.Contract Namespace


DeleteOptions.DiscardTargetQueue Property

DeleteOptionsDiscardTargetQueue Property
This value is true if any operations in the target queue should be deleted when the job is deleted; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool DiscardTargetQueue { get; set; }
Public Property DiscardTargetQueue As Boolean
    Get
    Set
public:
property bool DiscardTargetQueue {
    bool get ();
    void set (bool value);
}
function get_DiscardTargetQueue();
function set_DiscardTargetQueue(value);

Property Value

Type: Boolean
to discard the target queue; otherwise, .
See Also

Reference

DeleteOptions Class
DoubleTake.Jobs.Contract Namespace


DeleteOptions.ExtensionData Property

DeleteOptionsExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

DeleteOptions Class
DoubleTake.Jobs.Contract Namespace


DeleteOptions.ImageOptions Property

DeleteOptionsImageOptions Property
Gets or sets the option for what to do with the image when the job is deleted.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ImageDeleteInfo ImageOptions { get; set; }
Public Property ImageOptions As ImageDeleteInfo
    Get
    Set
public:
property ImageDeleteInfo^ ImageOptions {
    ImageDeleteInfo^ get ();
    void set (ImageDeleteInfo^ value);
}
function get_ImageOptions();
function set_ImageOptions(value);

Property Value

Type: ImageDeleteInfo
See Also

Reference

DeleteOptions Class
DoubleTake.Jobs.Contract Namespace


DnsDomainDetails Class

DnsDomainDetails Class
Represents a DNS domain that will be updated during DNS failover.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractDnsDomainDetails

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class DnsDomainDetails : IExtensibleDataObject
Public Class DnsDomainDetails
    Implements IExtensibleDataObject
public ref class DnsDomainDetails : IExtensibleDataObject
DoubleTake.Jobs.Contract.DnsDomainDetails = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.DnsDomainDetails',
    null,
    IExtensibleDataObject);

The DnsDomainDetails type exposes the following members.

Constructors
 | Name | Description
Public method | DnsDomainDetails | Initializes a new instance of the DnsDomainDetails class.
Top
Properties
 | Name | Description
Public property | Credentials | This value represents the domain credentials.
Public property | DnsServers | This value represents a DNS server that will be updated during DNS failover.
Public property | DomainName | This value is the name of the domain.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | IPAddressMappings | This value represents the mapping between source IP address and target IP address when using DNS failover.
Public property | ShouldUpdateTtl | This value is true if the time to live value should be updated; otherwise, it is false.
Public property | TtlValue | This value is the time to live value in seconds.
Top
Methods
 | Name | Description
Public method | ToString | (Overrides ObjectToString.)
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


DnsDomainDetails Constructor

DnsDomainDetails Constructor
Initializes a new instance of the DnsDomainDetails class.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public DnsDomainDetails()
Public Sub New
public:
DnsDomainDetails()
DoubleTake.Jobs.Contract.DnsDomainDetails = function();
See Also

Reference

DnsDomainDetails Class
DoubleTake.Jobs.Contract Namespace


DnsDomainDetails Properties

DnsDomainDetails Properties

The DnsDomainDetails type exposes the following members.

Properties
 | Name | Description
Public property | Credentials | This value represents the domain credentials.
Public property | DnsServers | This value represents a DNS server that will be updated during DNS failover.
Public property | DomainName | This value is the name of the domain.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | IPAddressMappings | This value represents the mapping between source IP address and target IP address when using DNS failover.
Public property | ShouldUpdateTtl | This value is true if the time to live value should be updated; otherwise, it is false.
Public property | TtlValue | This value is the time to live value in seconds.
Top
See Also

Reference

DnsDomainDetails Class
DoubleTake.Jobs.Contract Namespace


DnsDomainDetails.Credentials Property

DnsDomainDetailsCredentials Property
This value represents the domain credentials.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Credentials Credentials { get; set; }
Public Property Credentials As Credentials
    Get
    Set
public:
property Credentials^ Credentials {
    Credentials^ get ();
    void set (Credentials^ value);
}
function get_Credentials();
function set_Credentials(value);

Property Value

Type: Credentials
The domain credentials.
See Also

Reference

DnsDomainDetails Class
DoubleTake.Jobs.Contract Namespace


DnsDomainDetails.DnsServers Property

DnsDomainDetailsDnsServers Property
This value represents a DNS server that will be updated during DNS failover.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public DnsServerDetail[] DnsServers { get; set; }
Public Property DnsServers As DnsServerDetail()
    Get
    Set
public:
property array<DnsServerDetail^>^ DnsServers {
    array<DnsServerDetail^>^ get ();
    void set (array<DnsServerDetail^>^ value);
}
function get_DnsServers();
function set_DnsServers(value);

Property Value

Type: DnsServerDetail
The list of DNS servers to be updated.
See Also

Reference

DnsDomainDetails Class
DoubleTake.Jobs.Contract Namespace


DnsDomainDetails.DomainName Property

DnsDomainDetailsDomainName Property
This value is the name of the domain.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string DomainName { get; set; }
Public Property DomainName As String
    Get
    Set
public:
property String^ DomainName {
    String^ get ();
    void set (String^ value);
}
function get_DomainName();
function set_DomainName(value);

Property Value

Type: String
The name of the domain.
See Also

Reference

DnsDomainDetails Class
DoubleTake.Jobs.Contract Namespace


DnsDomainDetails.ExtensionData Property

DnsDomainDetailsExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

DnsDomainDetails Class
DoubleTake.Jobs.Contract Namespace


DnsDomainDetails.IPAddressMappings Property

DnsDomainDetailsIPAddressMappings Property
This value represents the mapping between source IP address and target IP address when using DNS failover.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public IPAddressMap[] IPAddressMappings { get; set; }
Public Property IPAddressMappings As IPAddressMap()
    Get
    Set
public:
property array<IPAddressMap^>^ IPAddressMappings {
    array<IPAddressMap^>^ get ();
    void set (array<IPAddressMap^>^ value);
}
function get_IPAddressMappings();
function set_IPAddressMappings(value);

Property Value

Type: IPAddressMap
The list of IP addresses to be updated.
See Also

Reference

DnsDomainDetails Class
DoubleTake.Jobs.Contract Namespace


DnsDomainDetails.ShouldUpdateTtl Property

DnsDomainDetailsShouldUpdateTtl Property
This value is true if the time to live value should be updated; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool ShouldUpdateTtl { get; set; }
Public Property ShouldUpdateTtl As Boolean
    Get
    Set
public:
property bool ShouldUpdateTtl {
    bool get ();
    void set (bool value);
}
function get_ShouldUpdateTtl();
function set_ShouldUpdateTtl(value);

Property Value

Type: Boolean
if the time-to-live value should be updated for this record; otherwise, .
See Also

Reference

DnsDomainDetails Class
DoubleTake.Jobs.Contract Namespace


DnsDomainDetails.TtlValue Property

DnsDomainDetailsTtlValue Property
This value is the time to live value in seconds.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int TtlValue { get; set; }
Public Property TtlValue As Integer
    Get
    Set
public:
property int TtlValue {
    int get ();
    void set (int value);
}
function get_TtlValue();
function set_TtlValue(value);

Property Value

Type: Int32
The TTL value, in seconds.
See Also

Reference

DnsDomainDetails Class
DoubleTake.Jobs.Contract Namespace


DnsDomainDetails Methods

DnsDomainDetails Methods

The DnsDomainDetails type exposes the following members.

Methods
 | Name | Description
Public method | ToString | (Overrides ObjectToString.)
Top
See Also

Reference

DnsDomainDetails Class
DoubleTake.Jobs.Contract Namespace


DnsDomainDetails.ToString Method

DnsDomainDetailsToString Method

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
function ToString();

Return Value

Type: String
See Also

Reference

DnsDomainDetails Class
DoubleTake.Jobs.Contract Namespace


DNSOptions Class

DNSOptions Class
Represents the options for DNS failover on a job.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractDNSOptions

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class DNSOptions : IExtensibleDataObject
Public Class DNSOptions
    Implements IExtensibleDataObject
public ref class DNSOptions : IExtensibleDataObject
DoubleTake.Jobs.Contract.DNSOptions = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.DNSOptions',
    null,
    IExtensibleDataObject);

The DNSOptions type exposes the following members.

Constructors
 | Name | Description
Public method | DNSOptions | Initializes a new instance of the DNSOptions class
Top
Properties
 | Name | Description
Public property | AdditionalDns | This value identifies any additional source DNS servers to update.
Public property | AllIPAddressesNeedMapping | This value is true if all IP addresses need to be mapped to a target IP address; otherwise, it is false.
Public property | AlternateTrustees | This value is the source server trustee, which overrides the default trustees of "NT AUTHORITY\SYSTEM" and the source computer account (for clustered environments).
Public property | Domains | This value represents the domains that will be updated during failover.
Public property | Enabled | This value is true if DNS failover is enabled; otherwise, it is false.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | SourceServerInWorkgroup | This value is true if the source is in a workgroup; otherwise, it is false.
Public property | SourceServerName | This value is the name of the source server.
Public property | TargetServerName | This value is the name of the target server.
Top
Methods
 | Name | Description
Public method | ToString | (Overrides ObjectToString.)
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


DNSOptions Constructor

DNSOptions Constructor
Initializes a new instance of the DNSOptions class

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public DNSOptions()
Public Sub New
public:
DNSOptions()
DoubleTake.Jobs.Contract.DNSOptions = function();
See Also

Reference

DNSOptions Class
DoubleTake.Jobs.Contract Namespace


DNSOptions Properties

DNSOptions Properties

The DNSOptions type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalDns | This value identifies any additional source DNS servers to update.
Public property | AllIPAddressesNeedMapping | This value is true if all IP addresses need to be mapped to a target IP address; otherwise, it is false.
Public property | AlternateTrustees | This value is the source server trustee, which overrides the default trustees of "NT AUTHORITY\SYSTEM" and the source computer account (for clustered environments).
Public property | Domains | This value represents the domains that will be updated during failover.
Public property | Enabled | This value is true if DNS failover is enabled; otherwise, it is false.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | SourceServerInWorkgroup | This value is true if the source is in a workgroup; otherwise, it is false.
Public property | SourceServerName | This value is the name of the source server.
Public property | TargetServerName | This value is the name of the target server.
Top
See Also

Reference

DNSOptions Class
DoubleTake.Jobs.Contract Namespace


DNSOptions.AdditionalDns Property

DNSOptionsAdditionalDns Property
This value identifies any additional source DNS servers to update.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string[] AdditionalDns { get; set; }
Public Property AdditionalDns As String()
    Get
    Set
public:
property array<String^>^ AdditionalDns {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
function get_AdditionalDns();
function set_AdditionalDns(value);

Property Value

Type: String
See Also

Reference

DNSOptions Class
DoubleTake.Jobs.Contract Namespace


DNSOptions.AllIPAddressesNeedMapping Property

DNSOptionsAllIPAddressesNeedMapping Property
This value is true if all IP addresses need to be mapped to a target IP address; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Nullable<bool> AllIPAddressesNeedMapping { get; set; }
Public Property AllIPAddressesNeedMapping As Nullable(Of Boolean)
    Get
    Set
public:
property Nullable<bool> AllIPAddressesNeedMapping {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}
function get_AllIPAddressesNeedMapping();
function set_AllIPAddressesNeedMapping(value);

Property Value

Type: Nullable Boolean
See Also

Reference

DNSOptions Class
DoubleTake.Jobs.Contract Namespace


DNSOptions.AlternateTrustees Property

DNSOptionsAlternateTrustees Property
This value is the source server trustee, which overrides the default trustees of "NT AUTHORITY\SYSTEM" and the source computer account (for clustered environments).

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string[] AlternateTrustees { get; set; }
Public Property AlternateTrustees As String()
    Get
    Set
public:
property array<String^>^ AlternateTrustees {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
function get_AlternateTrustees();
function set_AlternateTrustees(value);

Property Value

Type: String
The source server trustees.
See Also

Reference

DNSOptions Class
DoubleTake.Jobs.Contract Namespace


DNSOptions.Domains Property

DNSOptionsDomains Property
This value represents the domains that will be updated during failover.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public DnsDomainDetails[] Domains { get; set; }
Public Property Domains As DnsDomainDetails()
    Get
    Set
public:
property array<DnsDomainDetails^>^ Domains {
    array<DnsDomainDetails^>^ get ();
    void set (array<DnsDomainDetails^>^ value);
}
function get_Domains();
function set_Domains(value);

Property Value

Type: DnsDomainDetails
The domains that will be updated during failover.
See Also

Reference

DNSOptions Class
DoubleTake.Jobs.Contract Namespace


DNSOptions.Enabled Property

DNSOptionsEnabled Property
This value is true if DNS failover is enabled; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool Enabled { get; set; }
Public Property Enabled As Boolean
    Get
    Set
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
function get_Enabled();
function set_Enabled(value);

Property Value

Type: Boolean
if DNS failover is enabled; otherwise, .
See Also

Reference

DNSOptions Class
DoubleTake.Jobs.Contract Namespace


DNSOptions.ExtensionData Property

DNSOptionsExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

DNSOptions Class
DoubleTake.Jobs.Contract Namespace


DNSOptions.SourceServerInWorkgroup Property

DNSOptionsSourceServerInWorkgroup Property
This value is true if the source is in a workgroup; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool SourceServerInWorkgroup { get; set; }
Public Property SourceServerInWorkgroup As Boolean
    Get
    Set
public:
property bool SourceServerInWorkgroup {
    bool get ();
    void set (bool value);
}
function get_SourceServerInWorkgroup();
function set_SourceServerInWorkgroup(value);

Property Value

Type: Boolean
See Also

Reference

DNSOptions Class
DoubleTake.Jobs.Contract Namespace


DNSOptions.SourceServerName Property

DNSOptionsSourceServerName Property
This value is the name of the source server.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string SourceServerName { get; set; }
Public Property SourceServerName As String
    Get
    Set
public:
property String^ SourceServerName {
    String^ get ();
    void set (String^ value);
}
function get_SourceServerName();
function set_SourceServerName(value);

Property Value

Type: String
The name of the source server.
See Also

Reference

DNSOptions Class
DoubleTake.Jobs.Contract Namespace


DNSOptions.TargetServerName Property

DNSOptionsTargetServerName Property
This value is the name of the target server.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string TargetServerName { get; set; }
Public Property TargetServerName As String
    Get
    Set
public:
property String^ TargetServerName {
    String^ get ();
    void set (String^ value);
}
function get_TargetServerName();
function set_TargetServerName(value);

Property Value

Type: String
The name of the target server.
See Also

Reference

DNSOptions Class
DoubleTake.Jobs.Contract Namespace


DNSOptions Methods

DNSOptions Methods

The DNSOptions type exposes the following members.

Methods
 | Name | Description
Public method | ToString | (Overrides ObjectToString.)
Top
See Also

Reference

DNSOptions Class
DoubleTake.Jobs.Contract Namespace


DNSOptions.ToString Method

DNSOptionsToString Method

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
function ToString();

Return Value

Type: String
See Also

Reference

DNSOptions Class
DoubleTake.Jobs.Contract Namespace


DnsRecordLockOptions Class

DnsRecordLockOptions Class
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractDnsRecordLockOptions

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class DnsRecordLockOptions : IExtensibleDataObject
Public Class DnsRecordLockOptions
    Implements IExtensibleDataObject
public ref class DnsRecordLockOptions : IExtensibleDataObject
DoubleTake.Jobs.Contract.DnsRecordLockOptions = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.DnsRecordLockOptions',
    null,
    IExtensibleDataObject);

The DnsRecordLockOptions type exposes the following members.

Constructors
 | Name | Description
Public method | DnsRecordLockOptions | Initializes a new instance of the DnsRecordLockOptions class
Top
Properties
 | Name | Description
Public property | AdditionalDns |
Public property | Addresses |
Public property | DnsServer |
Public property | ExtensionData |
Public property | Server |
Public property | Trustees |
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


DnsRecordLockOptions Constructor

DnsRecordLockOptions Constructor
Initializes a new instance of the DnsRecordLockOptions class

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public DnsRecordLockOptions()
Public Sub New
public:
DnsRecordLockOptions()
DoubleTake.Jobs.Contract.DnsRecordLockOptions = function();
See Also

Reference

DnsRecordLockOptions Class
DoubleTake.Jobs.Contract Namespace


DnsRecordLockOptions Properties

DnsRecordLockOptions Properties

The DnsRecordLockOptions type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalDns |
Public property | Addresses |
Public property | DnsServer |
Public property | ExtensionData |
Public property | Server |
Public property | Trustees |
Top
See Also

Reference

DnsRecordLockOptions Class
DoubleTake.Jobs.Contract Namespace


DnsRecordLockOptions.AdditionalDns Property

DnsRecordLockOptionsAdditionalDns Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public IEnumerable<string> AdditionalDns { get; set; }
Public Property AdditionalDns As IEnumerable(Of String)
    Get
    Set
public:
property IEnumerable<String^>^ AdditionalDns {
    IEnumerable<String^>^ get ();
    void set (IEnumerable<String^>^ value);
}
function get_AdditionalDns();
function set_AdditionalDns(value);

Property Value

Type: IEnumerable String
See Also

Reference

DnsRecordLockOptions Class
DoubleTake.Jobs.Contract Namespace


DnsRecordLockOptions.Addresses Property

DnsRecordLockOptionsAddresses Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public IEnumerable<string> Addresses { get; set; }
Public Property Addresses As IEnumerable(Of String)
    Get
    Set
public:
property IEnumerable<String^>^ Addresses {
    IEnumerable<String^>^ get ();
    void set (IEnumerable<String^>^ value);
}
function get_Addresses();
function set_Addresses(value);

Property Value

Type: IEnumerable String
See Also

Reference

DnsRecordLockOptions Class
DoubleTake.Jobs.Contract Namespace


DnsRecordLockOptions.DnsServer Property

DnsRecordLockOptionsDnsServer Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string DnsServer { get; set; }
Public Property DnsServer As String
    Get
    Set
public:
property String^ DnsServer {
    String^ get ();
    void set (String^ value);
}
function get_DnsServer();
function set_DnsServer(value);

Property Value

Type: String
See Also

Reference

DnsRecordLockOptions Class
DoubleTake.Jobs.Contract Namespace


DnsRecordLockOptions.ExtensionData Property

DnsRecordLockOptionsExtensionData Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

DnsRecordLockOptions Class
DoubleTake.Jobs.Contract Namespace


DnsRecordLockOptions.Server Property

DnsRecordLockOptionsServer Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Server { get; set; }
Public Property Server As String
    Get
    Set
public:
property String^ Server {
    String^ get ();
    void set (String^ value);
}
function get_Server();
function set_Server(value);

Property Value

Type: String
See Also

Reference

DnsRecordLockOptions Class
DoubleTake.Jobs.Contract Namespace


DnsRecordLockOptions.Trustees Property

DnsRecordLockOptionsTrustees Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public IEnumerable<string> Trustees { get; set; }
Public Property Trustees As IEnumerable(Of String)
    Get
    Set
public:
property IEnumerable<String^>^ Trustees {
    IEnumerable<String^>^ get ();
    void set (IEnumerable<String^>^ value);
}
function get_Trustees();
function set_Trustees(value);

Property Value

Type: IEnumerable String
See Also

Reference

DnsRecordLockOptions Class
DoubleTake.Jobs.Contract Namespace


DTAVOptions Class

DTAVOptions Class
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractDTAVOptions

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class DTAVOptions : IExtensibleDataObject
Public Class DTAVOptions
    Implements IExtensibleDataObject
public ref class DTAVOptions : IExtensibleDataObject
DoubleTake.Jobs.Contract.DTAVOptions = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.DTAVOptions',
    null,
    IExtensibleDataObject);

The DTAVOptions type exposes the following members.

Constructors
 | Name | Description
Public method | DTAVOptions | Initializes a new instance of the DTAVOptions class
Top
Properties
 | Name | Description
Public property | DiskFormat |
Public property | DoDiskDataEncryption |
Public property | ExtensionData |
Public property | GuestOS |
Public property | IsSnapshotQuiescenceEnabled |
Public property | IsWANFailoverEnabled |
Public property | LinuxScriptOptions |
Public property | PowerOnReplicaOnFailover |
Public property | ReplicationIntervalSeconds |
Public property | ReplicaVMNetworkInterfaceInfo |
Public property | SourceClusterName |
Public property | SourceDatastoreUrl |
Public property | SourceReplicationAppliance |
Public property | SourceVim |
Public property | SourceVmDisplayName |
Public property | SourceVmGuid |
Public property | SourceVmHostId |
Public property | SourceVMNetworkInterfaceInfo |
Public property | TargetClusterName |
Public property | TargetDatastoreName |
Public property | TargetDatastoreUrl |
Public property | TargetEsxHostId |
Public property | TargetEsxServer |
Public property | TargetPath |
Public property | TargetReplicationAppliance |
Public property | TargetResourcePool |
Public property | TargetVim |
Public property | TargetVmDisplayName |
Public property | TargetVmMemory |
Public property | TargetVmNumCPU |
Public property | VirtualSwitchMappings |
Public property | VmdkDatastoreMappings |
Public property | VmUserName |
Public property | WindowsScriptOptions |
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


DTAVOptions Constructor

DTAVOptions Constructor
Initializes a new instance of the DTAVOptions class

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public DTAVOptions()
Public Sub New
public:
DTAVOptions()
DoubleTake.Jobs.Contract.DTAVOptions = function();
See Also

Reference

DTAVOptions Class
DoubleTake.Jobs.Contract Namespace


DTAVOptions Properties

DTAVOptions Properties

The DTAVOptions type exposes the following members.

Properties
 | Name | Description
Public property | DiskFormat |
Public property | DoDiskDataEncryption |
Public property | ExtensionData |
Public property | GuestOS |
Public property | IsSnapshotQuiescenceEnabled |
Public property | IsWANFailoverEnabled |
Public property | LinuxScriptOptions |
Public property | PowerOnReplicaOnFailover |
Public property | ReplicationIntervalSeconds |
Public property | ReplicaVMNetworkInterfaceInfo |
Public property | SourceClusterName |
Public property | SourceDatastoreUrl |
Public property | SourceReplicationAppliance |
Public property | SourceVim |
Public property | SourceVmDisplayName |
Public property | SourceVmGuid |
Public property | SourceVmHostId |
Public property | SourceVMNetworkInterfaceInfo |
Public property | TargetClusterName |
Public property | TargetDatastoreName |
Public property | TargetDatastoreUrl |
Public property | TargetEsxHostId |
Public property | TargetEsxServer |
Public property | TargetPath |
Public property | TargetReplicationAppliance |
Public property | TargetResourcePool |
Public property | TargetVim |
Public property | TargetVmDisplayName |
Public property | TargetVmMemory |
Public property | TargetVmNumCPU |
Public property | VirtualSwitchMappings |
Public property | VmdkDatastoreMappings |
Public property | VmUserName |
Public property | WindowsScriptOptions |
Top
See Also

Reference

DTAVOptions Class
DoubleTake.Jobs.Contract Namespace


DTAVOptions.DiskFormat Property

DTAVOptionsDiskFormat Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string DiskFormat { get; set; }
Public Property DiskFormat As String
    Get
    Set
public:
property String^ DiskFormat {
    String^ get ();
    void set (String^ value);
}
function get_DiskFormat();
function set_DiskFormat(value);

Property Value

Type: String
See Also

Reference

DTAVOptions Class
DoubleTake.Jobs.Contract Namespace


DTAVOptions.DoDiskDataEncryption Property

DTAVOptionsDoDiskDataEncryption Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool DoDiskDataEncryption { get; set; }
Public Property DoDiskDataEncryption As Boolean
    Get
    Set
public:
property bool DoDiskDataEncryption {
    bool get ();
    void set (bool value);
}
function get_DoDiskDataEncryption();
function set_DoDiskDataEncryption(value);

Property Value

Type: Boolean
See Also

Reference

DTAVOptions Class
DoubleTake.Jobs.Contract Namespace


DTAVOptions.ExtensionData Property

DTAVOptionsExtensionData Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

DTAVOptions Class
DoubleTake.Jobs.Contract Namespace


DTAVOptions.GuestOS Property

DTAVOptionsGuestOS Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string GuestOS { get; set; }
Public Property GuestOS As String
    Get
    Set
public:
property String^ GuestOS {
    String^ get ();
    void set (String^ value);
}
function get_GuestOS();
function set_GuestOS(value);

Property Value

Type: String
See Also

Reference

DTAVOptions Class
DoubleTake.Jobs.Contract Namespace


DTAVOptions.IsSnapshotQuiescenceEnabled Property

DTAVOptionsIsSnapshotQuiescenceEnabled Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsSnapshotQuiescenceEnabled { get; set; }
Public Property IsSnapshotQuiescenceEnabled As Boolean
    Get
    Set
public:
property bool IsSnapshotQuiescenceEnabled {
    bool get ();
    void set (bool value);
}
function get_IsSnapshotQuiescenceEnabled();
function set_IsSnapshotQuiescenceEnabled(value);

Property Value

Type: Boolean
See Also

Reference

DTAVOptions Class
DoubleTake.Jobs.Contract Namespace


DTAVOptions.IsWANFailoverEnabled Property

DTAVOptionsIsWANFailoverEnabled Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsWANFailoverEnabled { get; set; }
Public Property IsWANFailoverEnabled As Boolean
    Get
    Set
public:
property bool IsWANFailoverEnabled {
    bool get ();
    void set (bool value);
}
function get_IsWANFailoverEnabled();
function set_IsWANFailoverEnabled(value);

Property Value

Type: Boolean
See Also

Reference

DTAVOptions Class
DoubleTake.Jobs.Contract Namespace


DTAVOptions.LinuxScriptOptions Property

DTAVOptionsLinuxScriptOptions Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public FailoverScriptConfiguration LinuxScriptOptions { get; set; }
Public Property LinuxScriptOptions As FailoverScriptConfiguration
    Get
    Set
public:
property FailoverScriptConfiguration^ LinuxScriptOptions {
    FailoverScriptConfiguration^ get ();
    void set (FailoverScriptConfiguration^ value);
}
function get_LinuxScriptOptions();
function set_LinuxScriptOptions(value);

Property Value

Type: FailoverScriptConfiguration
See Also

Reference

DTAVOptions Class
DoubleTake.Jobs.Contract Namespace


DTAVOptions.PowerOnReplicaOnFailover Property

DTAVOptionsPowerOnReplicaOnFailover Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool PowerOnReplicaOnFailover { get; set; }
Public Property PowerOnReplicaOnFailover As Boolean
    Get
    Set
public:
property bool PowerOnReplicaOnFailover {
    bool get ();
    void set (bool value);
}
function get_PowerOnReplicaOnFailover();
function set_PowerOnReplicaOnFailover(value);

Property Value

Type: Boolean
See Also

Reference

DTAVOptions Class
DoubleTake.Jobs.Contract Namespace


DTAVOptions.ReplicationIntervalSeconds Property

DTAVOptionsReplicationIntervalSeconds Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int ReplicationIntervalSeconds { get; set; }
Public Property ReplicationIntervalSeconds As Integer
    Get
    Set
public:
property int ReplicationIntervalSeconds {
    int get ();
    void set (int value);
}
function get_ReplicationIntervalSeconds();
function set_ReplicationIntervalSeconds(value);

Property Value

Type: Int32
See Also

Reference

DTAVOptions Class
DoubleTake.Jobs.Contract Namespace


DTAVOptions.ReplicaVMNetworkInterfaceInfo Property

DTAVOptionsReplicaVMNetworkInterfaceInfo Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VirtualNetworkInterfaceInfo[] ReplicaVMNetworkInterfaceInfo { get; set; }
Public Property ReplicaVMNetworkInterfaceInfo As VirtualNetworkInterfaceInfo()
    Get
    Set
public:
property array<VirtualNetworkInterfaceInfo^>^ ReplicaVMNetworkInterfaceInfo {
    array<VirtualNetworkInterfaceInfo^>^ get ();
    void set (array<VirtualNetworkInterfaceInfo^>^ value);
}
function get_ReplicaVMNetworkInterfaceInfo();
function set_ReplicaVMNetworkInterfaceInfo(value);

Property Value

Type: VirtualNetworkInterfaceInfo
See Also

Reference

DTAVOptions Class
DoubleTake.Jobs.Contract Namespace


DTAVOptions.SourceClusterName Property

DTAVOptionsSourceClusterName Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string SourceClusterName { get; set; }
Public Property SourceClusterName As String
    Get
    Set
public:
property String^ SourceClusterName {
    String^ get ();
    void set (String^ value);
}
function get_SourceClusterName();
function set_SourceClusterName(value);

Property Value

Type: String
See Also

Reference

DTAVOptions Class
DoubleTake.Jobs.Contract Namespace


DTAVOptions.SourceDatastoreUrl Property

DTAVOptionsSourceDatastoreUrl Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string SourceDatastoreUrl { get; set; }
Public Property SourceDatastoreUrl As String
    Get
    Set
public:
property String^ SourceDatastoreUrl {
    String^ get ();
    void set (String^ value);
}
function get_SourceDatastoreUrl();
function set_SourceDatastoreUrl(value);

Property Value

Type: String
See Also

Reference

DTAVOptions Class
DoubleTake.Jobs.Contract Namespace


DTAVOptions.SourceReplicationAppliance Property

DTAVOptionsSourceReplicationAppliance Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string SourceReplicationAppliance { get; set; }
Public Property SourceReplicationAppliance As String
    Get
    Set
public:
property String^ SourceReplicationAppliance {
    String^ get ();
    void set (String^ value);
}
function get_SourceReplicationAppliance();
function set_SourceReplicationAppliance(value);

Property Value

Type: String
See Also

Reference

DTAVOptions Class
DoubleTake.Jobs.Contract Namespace


DTAVOptions.SourceVim Property

DTAVOptionsSourceVim Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string SourceVim { get; set; }
Public Property SourceVim As String
    Get
    Set
public:
property String^ SourceVim {
    String^ get ();
    void set (String^ value);
}
function get_SourceVim();
function set_SourceVim(value);

Property Value

Type: String
See Also

Reference

DTAVOptions Class
DoubleTake.Jobs.Contract Namespace


DTAVOptions.SourceVmDisplayName Property

DTAVOptionsSourceVmDisplayName Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string SourceVmDisplayName { get; set; }
Public Property SourceVmDisplayName As String
    Get
    Set
public:
property String^ SourceVmDisplayName {
    String^ get ();
    void set (String^ value);
}
function get_SourceVmDisplayName();
function set_SourceVmDisplayName(value);

Property Value

Type: String
See Also

Reference

DTAVOptions Class
DoubleTake.Jobs.Contract Namespace


DTAVOptions.SourceVmGuid Property

DTAVOptionsSourceVmGuid Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string SourceVmGuid { get; set; }
Public Property SourceVmGuid As String
    Get
    Set
public:
property String^ SourceVmGuid {
    String^ get ();
    void set (String^ value);
}
function get_SourceVmGuid();
function set_SourceVmGuid(value);

Property Value

Type: String
See Also

Reference

DTAVOptions Class
DoubleTake.Jobs.Contract Namespace


DTAVOptions.SourceVmHostId Property

DTAVOptionsSourceVmHostId Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string SourceVmHostId { get; set; }
Public Property SourceVmHostId As String
    Get
    Set
public:
property String^ SourceVmHostId {
    String^ get ();
    void set (String^ value);
}
function get_SourceVmHostId();
function set_SourceVmHostId(value);

Property Value

Type: String
See Also

Reference

DTAVOptions Class
DoubleTake.Jobs.Contract Namespace


DTAVOptions.SourceVMNetworkInterfaceInfo Property

DTAVOptionsSourceVMNetworkInterfaceInfo Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VirtualNetworkInterfaceInfo[] SourceVMNetworkInterfaceInfo { get; set; }
Public Property SourceVMNetworkInterfaceInfo As VirtualNetworkInterfaceInfo()
    Get
    Set
public:
property array<VirtualNetworkInterfaceInfo^>^ SourceVMNetworkInterfaceInfo {
    array<VirtualNetworkInterfaceInfo^>^ get ();
    void set (array<VirtualNetworkInterfaceInfo^>^ value);
}
function get_SourceVMNetworkInterfaceInfo();
function set_SourceVMNetworkInterfaceInfo(value);

Property Value

Type: VirtualNetworkInterfaceInfo
See Also

Reference

DTAVOptions Class
DoubleTake.Jobs.Contract Namespace


DTAVOptions.TargetClusterName Property

DTAVOptionsTargetClusterName Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string TargetClusterName { get; set; }
Public Property TargetClusterName As String
    Get
    Set
public:
property String^ TargetClusterName {
    String^ get ();
    void set (String^ value);
}
function get_TargetClusterName();
function set_TargetClusterName(value);

Property Value

Type: String
See Also

Reference

DTAVOptions Class
DoubleTake.Jobs.Contract Namespace


DTAVOptions.TargetDatastoreName Property

DTAVOptionsTargetDatastoreName Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string TargetDatastoreName { get; set; }
Public Property TargetDatastoreName As String
    Get
    Set
public:
property String^ TargetDatastoreName {
    String^ get ();
    void set (String^ value);
}
function get_TargetDatastoreName();
function set_TargetDatastoreName(value);

Property Value

Type: String
See Also

Reference

DTAVOptions Class
DoubleTake.Jobs.Contract Namespace


DTAVOptions.TargetDatastoreUrl Property

DTAVOptionsTargetDatastoreUrl Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string TargetDatastoreUrl { get; set; }
Public Property TargetDatastoreUrl As String
    Get
    Set
public:
property String^ TargetDatastoreUrl {
    String^ get ();
    void set (String^ value);
}
function get_TargetDatastoreUrl();
function set_TargetDatastoreUrl(value);

Property Value

Type: String
See Also

Reference

DTAVOptions Class
DoubleTake.Jobs.Contract Namespace


DTAVOptions.TargetEsxHostId Property

DTAVOptionsTargetEsxHostId Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string TargetEsxHostId { get; set; }
Public Property TargetEsxHostId As String
    Get
    Set
public:
property String^ TargetEsxHostId {
    String^ get ();
    void set (String^ value);
}
function get_TargetEsxHostId();
function set_TargetEsxHostId(value);

Property Value

Type: String
See Also

Reference

DTAVOptions Class
DoubleTake.Jobs.Contract Namespace


DTAVOptions.TargetEsxServer Property

DTAVOptionsTargetEsxServer Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string TargetEsxServer { get; set; }
Public Property TargetEsxServer As String
    Get
    Set
public:
property String^ TargetEsxServer {
    String^ get ();
    void set (String^ value);
}
function get_TargetEsxServer();
function set_TargetEsxServer(value);

Property Value

Type: String
See Also

Reference

DTAVOptions Class
DoubleTake.Jobs.Contract Namespace


DTAVOptions.TargetPath Property

DTAVOptionsTargetPath Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string TargetPath { get; set; }
Public Property TargetPath As String
    Get
    Set
public:
property String^ TargetPath {
    String^ get ();
    void set (String^ value);
}
function get_TargetPath();
function set_TargetPath(value);

Property Value

Type: String
See Also

Reference

DTAVOptions Class
DoubleTake.Jobs.Contract Namespace


DTAVOptions.TargetReplicationAppliance Property

DTAVOptionsTargetReplicationAppliance Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string TargetReplicationAppliance { get; set; }
Public Property TargetReplicationAppliance As String
    Get
    Set
public:
property String^ TargetReplicationAppliance {
    String^ get ();
    void set (String^ value);
}
function get_TargetReplicationAppliance();
function set_TargetReplicationAppliance(value);

Property Value

Type: String
See Also

Reference

DTAVOptions Class
DoubleTake.Jobs.Contract Namespace


DTAVOptions.TargetResourcePool Property

DTAVOptionsTargetResourcePool Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string TargetResourcePool { get; set; }
Public Property TargetResourcePool As String
    Get
    Set
public:
property String^ TargetResourcePool {
    String^ get ();
    void set (String^ value);
}
function get_TargetResourcePool();
function set_TargetResourcePool(value);

Property Value

Type: String
See Also

Reference

DTAVOptions Class
DoubleTake.Jobs.Contract Namespace


DTAVOptions.TargetVim Property

DTAVOptionsTargetVim Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string TargetVim { get; set; }
Public Property TargetVim As String
    Get
    Set
public:
property String^ TargetVim {
    String^ get ();
    void set (String^ value);
}
function get_TargetVim();
function set_TargetVim(value);

Property Value

Type: String
See Also

Reference

DTAVOptions Class
DoubleTake.Jobs.Contract Namespace


DTAVOptions.TargetVmDisplayName Property

DTAVOptionsTargetVmDisplayName Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string TargetVmDisplayName { get; set; }
Public Property TargetVmDisplayName As String
    Get
    Set
public:
property String^ TargetVmDisplayName {
    String^ get ();
    void set (String^ value);
}
function get_TargetVmDisplayName();
function set_TargetVmDisplayName(value);

Property Value

Type: String
See Also

Reference

DTAVOptions Class
DoubleTake.Jobs.Contract Namespace


DTAVOptions.TargetVmMemory Property

DTAVOptionsTargetVmMemory Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public long TargetVmMemory { get; set; }
Public Property TargetVmMemory As Long
    Get
    Set
public:
property long long TargetVmMemory {
    long long get ();
    void set (long long value);
}
function get_TargetVmMemory();
function set_TargetVmMemory(value);

Property Value

Type: Int64
See Also

Reference

DTAVOptions Class
DoubleTake.Jobs.Contract Namespace


DTAVOptions.TargetVmNumCPU Property

DTAVOptionsTargetVmNumCPU Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int TargetVmNumCPU { get; set; }
Public Property TargetVmNumCPU As Integer
    Get
    Set
public:
property int TargetVmNumCPU {
    int get ();
    void set (int value);
}
function get_TargetVmNumCPU();
function set_TargetVmNumCPU(value);

Property Value

Type: Int32
See Also

Reference

DTAVOptions Class
DoubleTake.Jobs.Contract Namespace


DTAVOptions.VirtualSwitchMappings Property

DTAVOptionsVirtualSwitchMappings Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VirtualSwitchMapping[] VirtualSwitchMappings { get; set; }
Public Property VirtualSwitchMappings As VirtualSwitchMapping()
    Get
    Set
public:
property array<VirtualSwitchMapping^>^ VirtualSwitchMappings {
    array<VirtualSwitchMapping^>^ get ();
    void set (array<VirtualSwitchMapping^>^ value);
}
function get_VirtualSwitchMappings();
function set_VirtualSwitchMappings(value);

Property Value

Type: VirtualSwitchMapping
See Also

Reference

DTAVOptions Class
DoubleTake.Jobs.Contract Namespace


DTAVOptions.VmdkDatastoreMappings Property

DTAVOptionsVmdkDatastoreMappings Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VmdkDatastoreMapping[] VmdkDatastoreMappings { get; set; }
Public Property VmdkDatastoreMappings As VmdkDatastoreMapping()
    Get
    Set
public:
property array<VmdkDatastoreMapping^>^ VmdkDatastoreMappings {
    array<VmdkDatastoreMapping^>^ get ();
    void set (array<VmdkDatastoreMapping^>^ value);
}
function get_VmdkDatastoreMappings();
function set_VmdkDatastoreMappings(value);

Property Value

Type: VmdkDatastoreMapping
See Also

Reference

DTAVOptions Class
DoubleTake.Jobs.Contract Namespace


DTAVOptions.VmUserName Property

DTAVOptionsVmUserName Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string VmUserName { get; set; }
Public Property VmUserName As String
    Get
    Set
public:
property String^ VmUserName {
    String^ get ();
    void set (String^ value);
}
function get_VmUserName();
function set_VmUserName(value);

Property Value

Type: String
See Also

Reference

DTAVOptions Class
DoubleTake.Jobs.Contract Namespace


DTAVOptions.WindowsScriptOptions Property

DTAVOptionsWindowsScriptOptions Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public FailoverScriptConfiguration WindowsScriptOptions { get; set; }
Public Property WindowsScriptOptions As FailoverScriptConfiguration
    Get
    Set
public:
property FailoverScriptConfiguration^ WindowsScriptOptions {
    FailoverScriptConfiguration^ get ();
    void set (FailoverScriptConfiguration^ value);
}
function get_WindowsScriptOptions();
function set_WindowsScriptOptions(value);

Property Value

Type: FailoverScriptConfiguration
See Also

Reference

DTAVOptions Class
DoubleTake.Jobs.Contract Namespace


DTAVQualificationResults Class

DTAVQualificationResults Class
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractDTAVQualificationResults

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class DTAVQualificationResults : IExtensibleDataObject
Public Class DTAVQualificationResults
    Implements IExtensibleDataObject
public ref class DTAVQualificationResults : IExtensibleDataObject
DoubleTake.Jobs.Contract.DTAVQualificationResults = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.DTAVQualificationResults',
    null,
    IExtensibleDataObject);

The DTAVQualificationResults type exposes the following members.

Constructors
 | Name | Description
Public method | DTAVQualificationResults | Initializes a new instance of the DTAVQualificationResults class
Top
Properties
 | Name | Description
Public property | ExtensionData |
Public property | SourceCandidateReplicaitonAppliances |
Public property | SourceSelectedVirtualMachines |
Public property | SourceVirtualSwitches |
Public property | TargetCandidateEsxServers |
Public property | TargetCandidateReplicaitonAppliances |
Public property | TargetHost |
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


DTAVQualificationResults Constructor

DTAVQualificationResults Constructor
Initializes a new instance of the DTAVQualificationResults class

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public DTAVQualificationResults()
Public Sub New
public:
DTAVQualificationResults()
DoubleTake.Jobs.Contract.DTAVQualificationResults = function();
See Also

Reference

DTAVQualificationResults Class
DoubleTake.Jobs.Contract Namespace


DTAVQualificationResults Properties

DTAVQualificationResults Properties

The DTAVQualificationResults type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData |
Public property | SourceCandidateReplicaitonAppliances |
Public property | SourceSelectedVirtualMachines |
Public property | SourceVirtualSwitches |
Public property | TargetCandidateEsxServers |
Public property | TargetCandidateReplicaitonAppliances |
Public property | TargetHost |
Top
See Also

Reference

DTAVQualificationResults Class
DoubleTake.Jobs.Contract Namespace


DTAVQualificationResults.ExtensionData Property

DTAVQualificationResultsExtensionData Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

DTAVQualificationResults Class
DoubleTake.Jobs.Contract Namespace


DTAVQualificationResults.SourceCandidateReplicaitonAppliances Property

DTAVQualificationResultsSourceCandidateReplicaitonAppliances Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string[] SourceCandidateReplicaitonAppliances { get; set; }
Public Property SourceCandidateReplicaitonAppliances As String()
    Get
    Set
public:
property array<String^>^ SourceCandidateReplicaitonAppliances {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
function get_SourceCandidateReplicaitonAppliances();
function set_SourceCandidateReplicaitonAppliances(value);

Property Value

Type: String
See Also

Reference

DTAVQualificationResults Class
DoubleTake.Jobs.Contract Namespace


DTAVQualificationResults.SourceSelectedVirtualMachines Property

DTAVQualificationResultsSourceSelectedVirtualMachines Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public DtavVmQualificationResults[] SourceSelectedVirtualMachines { get; set; }
Public Property SourceSelectedVirtualMachines As DtavVmQualificationResults()
    Get
    Set
public:
property array<DtavVmQualificationResults^>^ SourceSelectedVirtualMachines {
    array<DtavVmQualificationResults^>^ get ();
    void set (array<DtavVmQualificationResults^>^ value);
}
function get_SourceSelectedVirtualMachines();
function set_SourceSelectedVirtualMachines(value);

Property Value

Type: DtavVmQualificationResults
See Also

Reference

DTAVQualificationResults Class
DoubleTake.Jobs.Contract Namespace


DTAVQualificationResults.SourceVirtualSwitches Property

DTAVQualificationResultsSourceVirtualSwitches Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VirtualSwitchInfo[] SourceVirtualSwitches { get; set; }
Public Property SourceVirtualSwitches As VirtualSwitchInfo()
    Get
    Set
public:
property array<VirtualSwitchInfo^>^ SourceVirtualSwitches {
    array<VirtualSwitchInfo^>^ get ();
    void set (array<VirtualSwitchInfo^>^ value);
}
function get_SourceVirtualSwitches();
function set_SourceVirtualSwitches(value);

Property Value

Type: VirtualSwitchInfo
See Also

Reference

DTAVQualificationResults Class
DoubleTake.Jobs.Contract Namespace


DTAVQualificationResults.TargetCandidateEsxServers Property

DTAVQualificationResultsTargetCandidateEsxServers Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string[] TargetCandidateEsxServers { get; set; }
Public Property TargetCandidateEsxServers As String()
    Get
    Set
public:
property array<String^>^ TargetCandidateEsxServers {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
function get_TargetCandidateEsxServers();
function set_TargetCandidateEsxServers(value);

Property Value

Type: String
See Also

Reference

DTAVQualificationResults Class
DoubleTake.Jobs.Contract Namespace


DTAVQualificationResults.TargetCandidateReplicaitonAppliances Property

DTAVQualificationResultsTargetCandidateReplicaitonAppliances Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string[] TargetCandidateReplicaitonAppliances { get; set; }
Public Property TargetCandidateReplicaitonAppliances As String()
    Get
    Set
public:
property array<String^>^ TargetCandidateReplicaitonAppliances {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
function get_TargetCandidateReplicaitonAppliances();
function set_TargetCandidateReplicaitonAppliances(value);

Property Value

Type: String
See Also

Reference

DTAVQualificationResults Class
DoubleTake.Jobs.Contract Namespace


DTAVQualificationResults.TargetHost Property

DTAVQualificationResultsTargetHost Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ServerQualificationResults TargetHost { get; set; }
Public Property TargetHost As ServerQualificationResults
    Get
    Set
public:
property ServerQualificationResults^ TargetHost {
    ServerQualificationResults^ get ();
    void set (ServerQualificationResults^ value);
}
function get_TargetHost();
function set_TargetHost(value);

Property Value

Type: ServerQualificationResults
See Also

Reference

DTAVQualificationResults Class
DoubleTake.Jobs.Contract Namespace


DTHVOptions Class

DTHVOptions Class
Represents options for configuring a virtual machine protection job.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractDTHVOptions

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class DTHVOptions : IExtensibleDataObject
Public Class DTHVOptions
    Implements IExtensibleDataObject
public ref class DTHVOptions : IExtensibleDataObject
DoubleTake.Jobs.Contract.DTHVOptions = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.DTHVOptions',
    null,
    IExtensibleDataObject);

The DTHVOptions type exposes the following members.

Constructors
 | Name | Description
Public method | DTHVOptions | Initializes a new instance of the DTHVOptions class
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | IsWANFailoverEnabled | This value is true if the job is configured for WAN failover; otherwise, it is false.
Public property | OriginalSourceVM | This value represents virtual machine information used for reverse. It is used to delete the original virtual machine before starting the job in the reverse direction.
Public property | ReplicaVMNetworkInterfaceInfo | This value represents the NIC information as you want it to be on the replica virtual machine.
Public property | ReverseVHDMappings | This value represents the mappings from one VHD to another during a reverse.
Public property | SelectedVirtualMachines | This value represents the source virtual machines selected for protection. This value is for multi-select usage in the console and is only used for validation during job creation or edit. This value should not be persisted.
Public property | SourceOsVersion | This value is the operating system version on the source.
Public property | SourceServerName | This value is the name of the source server.
Public property | SourceVM | This value represents the source virtual machine selected for protection.
Public property | SourceVMNetworkInterfaceInfo | This value represents the NIC information on the source.
Public property | TargetOsVersion | This value is the operating system version on the target.
Public property | TargetServerName | This value is the name of the target server.
Public property | TargetVM | This value represents the replica virtual machine on the target.
Public property | TotalSourceVHDSizeBytes | This value is the total size of all .vhd files in bytes. It is used to check for available disk space on the target.
Public property | VirtualSwitchMapping | This value represents the virtual switch mappings on the source and target.
Public property | VLanMapping | This value represents the LAN mapping ID on the source and replica virtual machine.
Top
Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


DTHVOptions Constructor

DTHVOptions Constructor
Initializes a new instance of the DTHVOptions class

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public DTHVOptions()
Public Sub New
public:
DTHVOptions()
DoubleTake.Jobs.Contract.DTHVOptions = function();
See Also

Reference

DTHVOptions Class
DoubleTake.Jobs.Contract Namespace


DTHVOptions Properties

DTHVOptions Properties

The DTHVOptions type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | IsWANFailoverEnabled | This value is true if the job is configured for WAN failover; otherwise, it is false.
Public property | OriginalSourceVM | This value represents virtual machine information used for reverse. It is used to delete the original virtual machine before starting the job in the reverse direction.
Public property | ReplicaVMNetworkInterfaceInfo | This value represents the NIC information as you want it to be on the replica virtual machine.
Public property | ReverseVHDMappings | This value represents the mappings from one VHD to another during a reverse.
Public property | SelectedVirtualMachines | This value represents the source virtual machines selected for protection. This value is for multi-select usage in the console and is only used for validation during job creation or edit. This value should not be persisted.
Public property | SourceOsVersion | This value is the operating system version on the source.
Public property | SourceServerName | This value is the name of the source server.
Public property | SourceVM | This value represents the source virtual machine selected for protection.
Public property | SourceVMNetworkInterfaceInfo | This value represents the NIC information on the source.
Public property | TargetOsVersion | This value is the operating system version on the target.
Public property | TargetServerName | This value is the name of the target server.
Public property | TargetVM | This value represents the replica virtual machine on the target.
Public property | TotalSourceVHDSizeBytes | This value is the total size of all .vhd files in bytes. It is used to check for available disk space on the target.
Public property | VirtualSwitchMapping | This value represents the virtual switch mappings on the source and target.
Public property | VLanMapping | This value represents the LAN mapping ID on the source and replica virtual machine.
Top
See Also

Reference

DTHVOptions Class
DoubleTake.Jobs.Contract Namespace


DTHVOptions.ExtensionData Property

DTHVOptionsExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

DTHVOptions Class
DoubleTake.Jobs.Contract Namespace


DTHVOptions.IsWANFailoverEnabled Property

DTHVOptionsIsWANFailoverEnabled Property
This value is true if the job is configured for WAN failover; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsWANFailoverEnabled { get; set; }
Public Property IsWANFailoverEnabled As Boolean
    Get
    Set
public:
property bool IsWANFailoverEnabled {
    bool get ();
    void set (bool value);
}
function get_IsWANFailoverEnabled();
function set_IsWANFailoverEnabled(value);

Property Value

Type: Boolean
true if this instance is WAN failover enabled; otherwise, false.
See Also

Reference

DTHVOptions Class
DoubleTake.Jobs.Contract Namespace


DTHVOptions.OriginalSourceVM Property

DTHVOptionsOriginalSourceVM Property
This value represents virtual machine information used for reverse. It is used to delete the original virtual machine before starting the job in the reverse direction.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VMInfo OriginalSourceVM { get; set; }
Public Property OriginalSourceVM As VMInfo
    Get
    Set
public:
property VMInfo^ OriginalSourceVM {
    VMInfo^ get ();
    void set (VMInfo^ value);
}
function get_OriginalSourceVM();
function set_OriginalSourceVM(value);

Property Value

Type: VMInfo
See Also

Reference

DTHVOptions Class
DoubleTake.Jobs.Contract Namespace


DTHVOptions.ReplicaVMNetworkInterfaceInfo Property

DTHVOptionsReplicaVMNetworkInterfaceInfo Property
This value represents the NIC information as you want it to be on the replica virtual machine.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VirtualNetworkInterfaceInfo[] ReplicaVMNetworkInterfaceInfo { get; set; }
Public Property ReplicaVMNetworkInterfaceInfo As VirtualNetworkInterfaceInfo()
    Get
    Set
public:
property array<VirtualNetworkInterfaceInfo^>^ ReplicaVMNetworkInterfaceInfo {
    array<VirtualNetworkInterfaceInfo^>^ get ();
    void set (array<VirtualNetworkInterfaceInfo^>^ value);
}
function get_ReplicaVMNetworkInterfaceInfo();
function set_ReplicaVMNetworkInterfaceInfo(value);

Property Value

Type: VirtualNetworkInterfaceInfo
The network interface info.
See Also

Reference

DTHVOptions Class
DoubleTake.Jobs.Contract Namespace


DTHVOptions.ReverseVHDMappings Property

DTHVOptionsReverseVHDMappings Property
This value represents the mappings from one VHD to another during a reverse.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VHDMapping[] ReverseVHDMappings { get; set; }
Public Property ReverseVHDMappings As VHDMapping()
    Get
    Set
public:
property array<VHDMapping^>^ ReverseVHDMappings {
    array<VHDMapping^>^ get ();
    void set (array<VHDMapping^>^ value);
}
function get_ReverseVHDMappings();
function set_ReverseVHDMappings(value);

Property Value

Type: VHDMapping
The reverse VHD mappings.
See Also

Reference

DTHVOptions Class
DoubleTake.Jobs.Contract Namespace


DTHVOptions.SelectedVirtualMachines Property

DTHVOptionsSelectedVirtualMachines Property
This value represents the source virtual machines selected for protection. This value is for multi-select usage in the console and is only used for validation during job creation or edit. This value should not be persisted.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public V2VVirtualMachine[] SelectedVirtualMachines { get; set; }
Public Property SelectedVirtualMachines As V2VVirtualMachine()
    Get
    Set
public:
property array<V2VVirtualMachine^>^ SelectedVirtualMachines {
    array<V2VVirtualMachine^>^ get ();
    void set (array<V2VVirtualMachine^>^ value);
}
function get_SelectedVirtualMachines();
function set_SelectedVirtualMachines(value);

Property Value

Type: V2VVirtualMachine
The source virtual machines.
See Also

Reference

DTHVOptions Class
DoubleTake.Jobs.Contract Namespace


DTHVOptions.SourceOsVersion Property

DTHVOptionsSourceOsVersion Property
This value is the operating system version on the source.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public OperatingSystemVersion SourceOsVersion { get; set; }
Public Property SourceOsVersion As OperatingSystemVersion
    Get
    Set
public:
property OperatingSystemVersion^ SourceOsVersion {
    OperatingSystemVersion^ get ();
    void set (OperatingSystemVersion^ value);
}
function get_SourceOsVersion();
function set_SourceOsVersion(value);

Property Value

Type: OperatingSystemVersion
The operating system version on the source server.
See Also

Reference

DTHVOptions Class
DoubleTake.Jobs.Contract Namespace


DTHVOptions.SourceServerName Property

DTHVOptionsSourceServerName Property
This value is the name of the source server.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string SourceServerName { get; set; }
Public Property SourceServerName As String
    Get
    Set
public:
property String^ SourceServerName {
    String^ get ();
    void set (String^ value);
}
function get_SourceServerName();
function set_SourceServerName(value);

Property Value

Type: String
See Also

Reference

DTHVOptions Class
DoubleTake.Jobs.Contract Namespace


DTHVOptions.SourceVM Property

DTHVOptionsSourceVM Property
This value represents the source virtual machine selected for protection.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VMInfo SourceVM { get; set; }
Public Property SourceVM As VMInfo
    Get
    Set
public:
property VMInfo^ SourceVM {
    VMInfo^ get ();
    void set (VMInfo^ value);
}
function get_SourceVM();
function set_SourceVM(value);

Property Value

Type: VMInfo
See Also

Reference

DTHVOptions Class
DoubleTake.Jobs.Contract Namespace


DTHVOptions.SourceVMNetworkInterfaceInfo Property

DTHVOptionsSourceVMNetworkInterfaceInfo Property
This value represents the NIC information on the source.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VirtualNetworkInterfaceInfo[] SourceVMNetworkInterfaceInfo { get; set; }
Public Property SourceVMNetworkInterfaceInfo As VirtualNetworkInterfaceInfo()
    Get
    Set
public:
property array<VirtualNetworkInterfaceInfo^>^ SourceVMNetworkInterfaceInfo {
    array<VirtualNetworkInterfaceInfo^>^ get ();
    void set (array<VirtualNetworkInterfaceInfo^>^ value);
}
function get_SourceVMNetworkInterfaceInfo();
function set_SourceVMNetworkInterfaceInfo(value);

Property Value

Type: VirtualNetworkInterfaceInfo
The network interface info.
See Also

Reference

DTHVOptions Class
DoubleTake.Jobs.Contract Namespace


DTHVOptions.TargetOsVersion Property

DTHVOptionsTargetOsVersion Property
This value is the operating system version on the target.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public OperatingSystemVersion TargetOsVersion { get; set; }
Public Property TargetOsVersion As OperatingSystemVersion
    Get
    Set
public:
property OperatingSystemVersion^ TargetOsVersion {
    OperatingSystemVersion^ get ();
    void set (OperatingSystemVersion^ value);
}
function get_TargetOsVersion();
function set_TargetOsVersion(value);

Property Value

Type: OperatingSystemVersion
The operating system version on the target server.
See Also

Reference

DTHVOptions Class
DoubleTake.Jobs.Contract Namespace


DTHVOptions.TargetServerName Property

DTHVOptionsTargetServerName Property
This value is the name of the target server.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string TargetServerName { get; set; }
Public Property TargetServerName As String
    Get
    Set
public:
property String^ TargetServerName {
    String^ get ();
    void set (String^ value);
}
function get_TargetServerName();
function set_TargetServerName(value);

Property Value

Type: String
See Also

Reference

DTHVOptions Class
DoubleTake.Jobs.Contract Namespace


DTHVOptions.TargetVM Property

DTHVOptionsTargetVM Property
This value represents the replica virtual machine on the target.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VMInfo TargetVM { get; set; }
Public Property TargetVM As VMInfo
    Get
    Set
public:
property VMInfo^ TargetVM {
    VMInfo^ get ();
    void set (VMInfo^ value);
}
function get_TargetVM();
function set_TargetVM(value);

Property Value

Type: VMInfo
See Also

Reference

DTHVOptions Class
DoubleTake.Jobs.Contract Namespace


DTHVOptions.TotalSourceVHDSizeBytes Property

DTHVOptionsTotalSourceVHDSizeBytes Property
This value is the total size of all .vhd files in bytes. It is used to check for available disk space on the target.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public long TotalSourceVHDSizeBytes { get; set; }
Public Property TotalSourceVHDSizeBytes As Long
    Get
    Set
public:
property long long TotalSourceVHDSizeBytes {
    long long get ();
    void set (long long value);
}
function get_TotalSourceVHDSizeBytes();
function set_TotalSourceVHDSizeBytes(value);

Property Value

Type: Int64
See Also

Reference

DTHVOptions Class
DoubleTake.Jobs.Contract Namespace


DTHVOptions.VirtualSwitchMapping Property

DTHVOptionsVirtualSwitchMapping Property
This value represents the virtual switch mappings on the source and target.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VirtualSwitchMapping[] VirtualSwitchMapping { get; set; }
Public Property VirtualSwitchMapping As VirtualSwitchMapping()
    Get
    Set
public:
property array<VirtualSwitchMapping^>^ VirtualSwitchMapping {
    array<VirtualSwitchMapping^>^ get ();
    void set (array<VirtualSwitchMapping^>^ value);
}
function get_VirtualSwitchMapping();
function set_VirtualSwitchMapping(value);

Property Value

Type: VirtualSwitchMapping
See Also

Reference

DTHVOptions Class
DoubleTake.Jobs.Contract Namespace


DTHVOptions.VLanMapping Property

DTHVOptionsVLanMapping Property
This value represents the LAN mapping ID on the source and replica virtual machine.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VLanMapping[] VLanMapping { get; set; }
Public Property VLanMapping As VLanMapping()
    Get
    Set
public:
property array<VLanMapping^>^ VLanMapping {
    array<VLanMapping^>^ get ();
    void set (array<VLanMapping^>^ value);
}
function get_VLanMapping();
function set_VLanMapping(value);

Property Value

Type: VLanMapping
See Also

Reference

DTHVOptions Class
DoubleTake.Jobs.Contract Namespace


DTHVOptions Methods

DTHVOptions Methods

The DTHVOptions type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Top
See Also

Reference

DTHVOptions Class
DoubleTake.Jobs.Contract Namespace


DTHVOptions.Clone Method

DTHVOptionsClone Method
Creates a new object that is a copy of the current instance.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
function Clone();

Return Value

Type: Object
A new object that is a copy of this instance.
See Also

Reference

DTHVOptions Class
DoubleTake.Jobs.Contract Namespace


DTHVQualificationResults Class

DTHVQualificationResults Class
Represents information that may be needed to configure a DTHV job.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractDTHVQualificationResults

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class DTHVQualificationResults : IExtensibleDataObject
Public Class DTHVQualificationResults
    Implements IExtensibleDataObject
public ref class DTHVQualificationResults : IExtensibleDataObject
DoubleTake.Jobs.Contract.DTHVQualificationResults = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.DTHVQualificationResults',
    null,
    IExtensibleDataObject);

The DTHVQualificationResults type exposes the following members.

Constructors
 | Name | Description
Public method | DTHVQualificationResults | Initializes a new instance of the DTHVQualificationResults class
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | SourceVirtualSwitches | This value represents the virtual switch information on the source.
Public property | SourceVM | This value represents the source virtual machine information.
Public property | TargetHost | This value represents the target host information.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


DTHVQualificationResults Constructor

DTHVQualificationResults Constructor
Initializes a new instance of the DTHVQualificationResults class

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public DTHVQualificationResults()
Public Sub New
public:
DTHVQualificationResults()
DoubleTake.Jobs.Contract.DTHVQualificationResults = function();
See Also

Reference

DTHVQualificationResults Class
DoubleTake.Jobs.Contract Namespace


DTHVQualificationResults Properties

DTHVQualificationResults Properties

The DTHVQualificationResults type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | SourceVirtualSwitches | This value represents the virtual switch information on the source.
Public property | SourceVM | This value represents the source virtual machine information.
Public property | TargetHost | This value represents the target host information.
Top
See Also

Reference

DTHVQualificationResults Class
DoubleTake.Jobs.Contract Namespace


DTHVQualificationResults.ExtensionData Property

DTHVQualificationResultsExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

DTHVQualificationResults Class
DoubleTake.Jobs.Contract Namespace


DTHVQualificationResults.SourceVirtualSwitches Property

DTHVQualificationResultsSourceVirtualSwitches Property
This value represents the virtual switch information on the source.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VirtualSwitchInfo[] SourceVirtualSwitches { get; set; }
Public Property SourceVirtualSwitches As VirtualSwitchInfo()
    Get
    Set
public:
property array<VirtualSwitchInfo^>^ SourceVirtualSwitches {
    array<VirtualSwitchInfo^>^ get ();
    void set (array<VirtualSwitchInfo^>^ value);
}
function get_SourceVirtualSwitches();
function set_SourceVirtualSwitches(value);

Property Value

Type: VirtualSwitchInfo
The source virtual machines.
See Also

Reference

DTHVQualificationResults Class
DoubleTake.Jobs.Contract Namespace


DTHVQualificationResults.SourceVM Property

DTHVQualificationResultsSourceVM Property
This value represents the source virtual machine information.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VMQualificationResults SourceVM { get; set; }
Public Property SourceVM As VMQualificationResults
    Get
    Set
public:
property VMQualificationResults^ SourceVM {
    VMQualificationResults^ get ();
    void set (VMQualificationResults^ value);
}
function get_SourceVM();
function set_SourceVM(value);

Property Value

Type: VMQualificationResults
See Also

Reference

DTHVQualificationResults Class
DoubleTake.Jobs.Contract Namespace


DTHVQualificationResults.TargetHost Property

DTHVQualificationResultsTargetHost Property
This value represents the target host information.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ServerQualificationResults TargetHost { get; set; }
Public Property TargetHost As ServerQualificationResults
    Get
    Set
public:
property ServerQualificationResults^ TargetHost {
    ServerQualificationResults^ get ();
    void set (ServerQualificationResults^ value);
}
function get_TargetHost();
function set_TargetHost(value);

Property Value

Type: ServerQualificationResults
See Also

Reference

DTHVQualificationResults Class
DoubleTake.Jobs.Contract Namespace


EngineControlStatus Class

EngineControlStatus Class
Represents the status of an engine connection used by a job.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractEngineControlStatus

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class EngineControlStatus : IExtensibleDataObject
Public Class EngineControlStatus
    Implements IExtensibleDataObject
public ref class EngineControlStatus : IExtensibleDataObject
DoubleTake.Jobs.Contract.EngineControlStatus = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.EngineControlStatus',
    null,
    IExtensibleDataObject);

The EngineControlStatus type exposes the following members.

Constructors
 | Name | Description
Public method | EngineControlStatus | Initializes a new instance of the EngineControlStatus class
Top
Properties
 | Name | Description
Public property | CanPauseMirror | This value is true if mirroring can be paused;otherwise, it is false.
Public property | CanPauseTarget | This value is true if the target can be paused;otherwise, it is false.
Public property | CanPauseTransmission | This value is true if transmission can be paused;otherwise, it is false.
Public property | CanProcessOrphans | This value is true if the orphan file removal process can be started;otherwise, it is false.
Public property | CanResumeMirror | This value is true if mirroring can be resumed;otherwise, it is false.
Public property | CanResumeTarget | This value is true if the target can be resumed;otherwise, it is false.
Public property | CanResumeTransmission | This value is true if transmission can be resumed;otherwise, it is false.
Public property | CanSetBandwidth | This value is true if a bandwidth limit can be set;otherwise, it is false.
Public property | CanStartMirror | This value is true if mirroring can be started;otherwise, it is false.
Public property | CanStartTransmission | This value is true if transmission can be started;otherwise, it is false.
Public property | CanStopMirror | This value is true if mirroring can be stopped;otherwise, it is false.
Public property | CanTakeSnapshot | This value is true if the target can take a snapshot of the replica data;otherwise, it is false.
Public property | CanUpdateShares | This value is true if source share information can be updated;otherwise, it is false.
Public property | CanVerify | This value is true if verification of the source data to the target replica data can be started;otherwise, it is false.
Public property | ConnectionId | This value is a unique ID that needs to be provided to the replication engine control methods for controlling the replication engine connection.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Role | This value is the role of the replication engine for the job. Jobs may use more than one replication engine connection in their operation. This property provides a way to differentiate between the replication engine connections for display purposes.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


EngineControlStatus Constructor

EngineControlStatus Constructor
Initializes a new instance of the EngineControlStatus class

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public EngineControlStatus()
Public Sub New
public:
EngineControlStatus()
DoubleTake.Jobs.Contract.EngineControlStatus = function();
See Also

Reference

EngineControlStatus Class
DoubleTake.Jobs.Contract Namespace


EngineControlStatus Properties

EngineControlStatus Properties

The EngineControlStatus type exposes the following members.

Properties
 | Name | Description
Public property | CanPauseMirror | This value is true if mirroring can be paused;otherwise, it is false.
Public property | CanPauseTarget | This value is true if the target can be paused;otherwise, it is false.
Public property | CanPauseTransmission | This value is true if transmission can be paused;otherwise, it is false.
Public property | CanProcessOrphans | This value is true if the orphan file removal process can be started;otherwise, it is false.
Public property | CanResumeMirror | This value is true if mirroring can be resumed;otherwise, it is false.
Public property | CanResumeTarget | This value is true if the target can be resumed;otherwise, it is false.
Public property | CanResumeTransmission | This value is true if transmission can be resumed;otherwise, it is false.
Public property | CanSetBandwidth | This value is true if a bandwidth limit can be set;otherwise, it is false.
Public property | CanStartMirror | This value is true if mirroring can be started;otherwise, it is false.
Public property | CanStartTransmission | This value is true if transmission can be started;otherwise, it is false.
Public property | CanStopMirror | This value is true if mirroring can be stopped;otherwise, it is false.
Public property | CanTakeSnapshot | This value is true if the target can take a snapshot of the replica data;otherwise, it is false.
Public property | CanUpdateShares | This value is true if source share information can be updated;otherwise, it is false.
Public property | CanVerify | This value is true if verification of the source data to the target replica data can be started;otherwise, it is false.
Public property | ConnectionId | This value is a unique ID that needs to be provided to the replication engine control methods for controlling the replication engine connection.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Role | This value is the role of the replication engine for the job. Jobs may use more than one replication engine connection in their operation. This property provides a way to differentiate between the replication engine connections for display purposes.
Top
See Also

Reference

EngineControlStatus Class
DoubleTake.Jobs.Contract Namespace


EngineControlStatus.CanPauseMirror Property

EngineControlStatusCanPauseMirror Property
This value is true if mirroring can be paused;otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool CanPauseMirror { get; set; }
Public Property CanPauseMirror As Boolean
    Get
    Set
public:
property bool CanPauseMirror {
    bool get ();
    void set (bool value);
}
function get_CanPauseMirror();
function set_CanPauseMirror(value);

Property Value

Type: Boolean
if mirroring can be paused; otherwise, .
See Also

Reference

EngineControlStatus Class
DoubleTake.Jobs.Contract Namespace


EngineControlStatus.CanPauseTarget Property

EngineControlStatusCanPauseTarget Property
This value is true if the target can be paused;otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool CanPauseTarget { get; set; }
Public Property CanPauseTarget As Boolean
    Get
    Set
public:
property bool CanPauseTarget {
    bool get ();
    void set (bool value);
}
function get_CanPauseTarget();
function set_CanPauseTarget(value);

Property Value

Type: Boolean
if the target can be paused; otherwise, .
See Also

Reference

EngineControlStatus Class
DoubleTake.Jobs.Contract Namespace


EngineControlStatus.CanPauseTransmission Property

EngineControlStatusCanPauseTransmission Property
This value is true if transmission can be paused;otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool CanPauseTransmission { get; set; }
Public Property CanPauseTransmission As Boolean
    Get
    Set
public:
property bool CanPauseTransmission {
    bool get ();
    void set (bool value);
}
function get_CanPauseTransmission();
function set_CanPauseTransmission(value);

Property Value

Type: Boolean
if transmission can be paused; otherwise, .
See Also

Reference

EngineControlStatus Class
DoubleTake.Jobs.Contract Namespace


EngineControlStatus.CanProcessOrphans Property

EngineControlStatusCanProcessOrphans Property
This value is true if the orphan file removal process can be started;otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool CanProcessOrphans { get; set; }
Public Property CanProcessOrphans As Boolean
    Get
    Set
public:
property bool CanProcessOrphans {
    bool get ();
    void set (bool value);
}
function get_CanProcessOrphans();
function set_CanProcessOrphans(value);

Property Value

Type: Boolean
if a process orphans operation can be performed; otherwise, .
See Also

Reference

EngineControlStatus Class
DoubleTake.Jobs.Contract Namespace


EngineControlStatus.CanResumeMirror Property

EngineControlStatusCanResumeMirror Property
This value is true if mirroring can be resumed;otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool CanResumeMirror { get; set; }
Public Property CanResumeMirror As Boolean
    Get
    Set
public:
property bool CanResumeMirror {
    bool get ();
    void set (bool value);
}
function get_CanResumeMirror();
function set_CanResumeMirror(value);

Property Value

Type: Boolean
if mirroring can be resumed; otherwise, .
See Also

Reference

EngineControlStatus Class
DoubleTake.Jobs.Contract Namespace


EngineControlStatus.CanResumeTarget Property

EngineControlStatusCanResumeTarget Property
This value is true if the target can be resumed;otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool CanResumeTarget { get; set; }
Public Property CanResumeTarget As Boolean
    Get
    Set
public:
property bool CanResumeTarget {
    bool get ();
    void set (bool value);
}
function get_CanResumeTarget();
function set_CanResumeTarget(value);

Property Value

Type: Boolean
if the target can be resumed; otherwise, .
See Also

Reference

EngineControlStatus Class
DoubleTake.Jobs.Contract Namespace


EngineControlStatus.CanResumeTransmission Property

EngineControlStatusCanResumeTransmission Property
This value is true if transmission can be resumed;otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool CanResumeTransmission { get; set; }
Public Property CanResumeTransmission As Boolean
    Get
    Set
public:
property bool CanResumeTransmission {
    bool get ();
    void set (bool value);
}
function get_CanResumeTransmission();
function set_CanResumeTransmission(value);

Property Value

Type: Boolean
if transmission can be resumed; otherwise, .
See Also

Reference

EngineControlStatus Class
DoubleTake.Jobs.Contract Namespace


EngineControlStatus.CanSetBandwidth Property

EngineControlStatusCanSetBandwidth Property
This value is true if a bandwidth limit can be set;otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool CanSetBandwidth { get; set; }
Public Property CanSetBandwidth As Boolean
    Get
    Set
public:
property bool CanSetBandwidth {
    bool get ();
    void set (bool value);
}
function get_CanSetBandwidth();
function set_CanSetBandwidth(value);

Property Value

Type: Boolean
if this the bandwidth limit can be set; otherwise, .
See Also

Reference

EngineControlStatus Class
DoubleTake.Jobs.Contract Namespace


EngineControlStatus.CanStartMirror Property

EngineControlStatusCanStartMirror Property
This value is true if mirroring can be started;otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool CanStartMirror { get; set; }
Public Property CanStartMirror As Boolean
    Get
    Set
public:
property bool CanStartMirror {
    bool get ();
    void set (bool value);
}
function get_CanStartMirror();
function set_CanStartMirror(value);

Property Value

Type: Boolean
if this instance can start mirror; otherwise, .
See Also

Reference

EngineControlStatus Class
DoubleTake.Jobs.Contract Namespace


EngineControlStatus.CanStartTransmission Property

EngineControlStatusCanStartTransmission Property
This value is true if transmission can be started;otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool CanStartTransmission { get; set; }
Public Property CanStartTransmission As Boolean
    Get
    Set
public:
property bool CanStartTransmission {
    bool get ();
    void set (bool value);
}
function get_CanStartTransmission();
function set_CanStartTransmission(value);

Property Value

Type: Boolean
if transmission can be started; otherwise, .
See Also

Reference

EngineControlStatus Class
DoubleTake.Jobs.Contract Namespace


EngineControlStatus.CanStopMirror Property

EngineControlStatusCanStopMirror Property
This value is true if mirroring can be stopped;otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool CanStopMirror { get; set; }
Public Property CanStopMirror As Boolean
    Get
    Set
public:
property bool CanStopMirror {
    bool get ();
    void set (bool value);
}
function get_CanStopMirror();
function set_CanStopMirror(value);

Property Value

Type: Boolean
if mirroring can be stopped; otherwise, .
See Also

Reference

EngineControlStatus Class
DoubleTake.Jobs.Contract Namespace


EngineControlStatus.CanTakeSnapshot Property

EngineControlStatusCanTakeSnapshot Property
This value is true if the target can take a snapshot of the replica data;otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool CanTakeSnapshot { get; set; }
Public Property CanTakeSnapshot As Boolean
    Get
    Set
public:
property bool CanTakeSnapshot {
    bool get ();
    void set (bool value);
}
function get_CanTakeSnapshot();
function set_CanTakeSnapshot(value);

Property Value

Type: Boolean
if a snapshot can be taken; otherwise, .
See Also

Reference

EngineControlStatus Class
DoubleTake.Jobs.Contract Namespace


EngineControlStatus.CanUpdateShares Property

EngineControlStatusCanUpdateShares Property
This value is true if source share information can be updated;otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool CanUpdateShares { get; set; }
Public Property CanUpdateShares As Boolean
    Get
    Set
public:
property bool CanUpdateShares {
    bool get ();
    void set (bool value);
}
function get_CanUpdateShares();
function set_CanUpdateShares(value);

Property Value

Type: Boolean
if shares can be updated; otherwise, .
See Also

Reference

EngineControlStatus Class
DoubleTake.Jobs.Contract Namespace


EngineControlStatus.CanVerify Property

EngineControlStatusCanVerify Property
This value is true if verification of the source data to the target replica data can be started;otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool CanVerify { get; set; }
Public Property CanVerify As Boolean
    Get
    Set
public:
property bool CanVerify {
    bool get ();
    void set (bool value);
}
function get_CanVerify();
function set_CanVerify(value);

Property Value

Type: Boolean
if verification can be performed; otherwise, .
See Also

Reference

EngineControlStatus Class
DoubleTake.Jobs.Contract Namespace


EngineControlStatus.ConnectionId Property

EngineControlStatusConnectionId Property
This value is a unique ID that needs to be provided to the replication engine control methods for controlling the replication engine connection.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Guid ConnectionId { get; set; }
Public Property ConnectionId As Guid
    Get
    Set
public:
property Guid ConnectionId {
    Guid get ();
    void set (Guid value);
}
function get_ConnectionId();
function set_ConnectionId(value);

Property Value

Type: Guid
The connection id.
Remarks
This is a unique id that needs be provided to the engine control methods for controlling the engine connection represented by this instance.
See Also

Reference

EngineControlStatus Class
DoubleTake.Jobs.Contract Namespace


EngineControlStatus.ExtensionData Property

EngineControlStatusExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
A structure that contains extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

EngineControlStatus Class
DoubleTake.Jobs.Contract Namespace


EngineControlStatus.Role Property

EngineControlStatusRole Property
This value is the role of the replication engine for the job. Jobs may use more than one replication engine connection in their operation. This property provides a way to differentiate between the replication engine connections for display purposes.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Role { get; set; }
Public Property Role As String
    Get
    Set
public:
property String^ Role {
    String^ get ();
    void set (String^ value);
}
function get_Role();
function set_Role(value);

Property Value

Type: String
The role.
Remarks
Jobs may use more than one engine connection in their operation. This property provides a way to differentiate between the engine connections for display purposes.
See Also

Reference

EngineControlStatus Class
DoubleTake.Jobs.Contract Namespace


ExtendedLowLevelState Class

ExtendedLowLevelState Class
ExtendedLowLevelState defines additional information which can be used to describe a particular Low level state as low level state is implemented as a string.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractExtendedLowLevelState

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class ExtendedLowLevelState : IExtensibleDataObject
Public Class ExtendedLowLevelState
    Implements IExtensibleDataObject
public ref class ExtendedLowLevelState : IExtensibleDataObject
DoubleTake.Jobs.Contract.ExtendedLowLevelState = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.ExtendedLowLevelState',
    null,
    IExtensibleDataObject);

The ExtendedLowLevelState type exposes the following members.

Constructors
 | Name | Description
Public method | ExtendedLowLevelState | Initializes a new instance of the ExtendedLowLevelState class
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Health | This value represents the health of the low level state. Possible uses include displaying an icon for a low level state.
Public property | MessageId | This value is a unique ID for the state message.
Public property | MessageIdFormatParameters | This value is the state message.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


ExtendedLowLevelState Constructor

ExtendedLowLevelState Constructor
Initializes a new instance of the ExtendedLowLevelState class

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtendedLowLevelState()
Public Sub New
public:
ExtendedLowLevelState()
DoubleTake.Jobs.Contract.ExtendedLowLevelState = function();
See Also

Reference

ExtendedLowLevelState Class
DoubleTake.Jobs.Contract Namespace


ExtendedLowLevelState Properties

ExtendedLowLevelState Properties

The ExtendedLowLevelState type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Health | This value represents the health of the low level state. Possible uses include displaying an icon for a low level state.
Public property | MessageId | This value is a unique ID for the state message.
Public property | MessageIdFormatParameters | This value is the state message.
Top
See Also

Reference

ExtendedLowLevelState Class
DoubleTake.Jobs.Contract Namespace


ExtendedLowLevelState.ExtensionData Property

ExtendedLowLevelStateExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

ExtendedLowLevelState Class
DoubleTake.Jobs.Contract Namespace


ExtendedLowLevelState.Health Property

ExtendedLowLevelStateHealth Property
This value represents the health of the low level state. Possible uses include displaying an icon for a low level state.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Health Health { get; set; }
Public Property Health As Health
    Get
    Set
public:
property Health Health {
    Health get ();
    void set (Health value);
}
function get_Health();
function set_Health(value);

Property Value

Type: Health
See Also

Reference

ExtendedLowLevelState Class
DoubleTake.Jobs.Contract Namespace


ExtendedLowLevelState.MessageId Property

ExtendedLowLevelStateMessageId Property
This value is a unique ID for the state message.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string MessageId { get; set; }
Public Property MessageId As String
    Get
    Set
public:
property String^ MessageId {
    String^ get ();
    void set (String^ value);
}
function get_MessageId();
function set_MessageId(value);

Property Value

Type: String
The message id for this low level state.
See Also

Reference

ExtendedLowLevelState Class
DoubleTake.Jobs.Contract Namespace


ExtendedLowLevelState.MessageIdFormatParameters Property

ExtendedLowLevelStateMessageIdFormatParameters Property
This value is the state message.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string[] MessageIdFormatParameters { get; set; }
Public Property MessageIdFormatParameters As String()
    Get
    Set
public:
property array<String^>^ MessageIdFormatParameters {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
function get_MessageIdFormatParameters();
function set_MessageIdFormatParameters(value);

Property Value

Type: String
The message format parameters for this low level state.
See Also

Reference

ExtendedLowLevelState Class
DoubleTake.Jobs.Contract Namespace


FailbackOptions Class

FailbackOptions Class
Represents the options used when failing back a job.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractFailbackOptions

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class FailbackOptions : IExtensibleDataObject
Public Class FailbackOptions
    Implements IExtensibleDataObject
public ref class FailbackOptions : IExtensibleDataObject
DoubleTake.Jobs.Contract.FailbackOptions = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.FailbackOptions',
    null,
    IExtensibleDataObject);

The FailbackOptions type exposes the following members.

Constructors
 | Name | Description
Public method | FailbackOptions | Initializes a new instance of the FailbackOptions class
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | NewMonitorOptions | This value represents the options for configuring failover monitoring after a job has been restored to a new source server.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


FailbackOptions Constructor

FailbackOptions Constructor
Initializes a new instance of the FailbackOptions class

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public FailbackOptions()
Public Sub New
public:
FailbackOptions()
DoubleTake.Jobs.Contract.FailbackOptions = function();
See Also

Reference

FailbackOptions Class
DoubleTake.Jobs.Contract Namespace


FailbackOptions Properties

FailbackOptions Properties

The FailbackOptions type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | NewMonitorOptions | This value represents the options for configuring failover monitoring after a job has been restored to a new source server.
Top
See Also

Reference

FailbackOptions Class
DoubleTake.Jobs.Contract Namespace


FailbackOptions.ExtensionData Property

FailbackOptionsExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

FailbackOptions Class
DoubleTake.Jobs.Contract Namespace


FailbackOptions.NewMonitorOptions Property

FailbackOptionsNewMonitorOptions Property
This value represents the options for configuring failover monitoring after a job has been restored to a new source server.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public CoreMonitorOptions NewMonitorOptions { get; set; }
Public Property NewMonitorOptions As CoreMonitorOptions
    Get
    Set
public:
property CoreMonitorOptions^ NewMonitorOptions {
    CoreMonitorOptions^ get ();
    void set (CoreMonitorOptions^ value);
}
function get_NewMonitorOptions();
function set_NewMonitorOptions(value);

Property Value

Type: CoreMonitorOptions
The monitor options for the new source server.
Remarks
These options are only relevant if the job has been restored to a new source server.
See Also

Reference

FailbackOptions Class
DoubleTake.Jobs.Contract Namespace


FailoverMode Enumeration

FailoverMode Enumeration
Indicates the style of failover.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public enum FailoverMode
Public Enumeration FailoverMode
public enum class FailoverMode
DoubleTake.Jobs.Contract.FailoverMode = function();
DoubleTake.Jobs.Contract.FailoverMode.createEnum('DoubleTake.Jobs.Contract.FailoverMode', false);
Members
Member name | Value | Description
Live | 0 | Failover is using live, current data and the target is started with network connectivity.
Test | 1 | Failover is using live current data, but is a test. The target is started without network connectivity.
Snapshot | 2 | Failover is using a data from a snapshot. The target is started with network connectivity.
SetRestoreRequiredOnly | 3 | Indicates that the "failover" should only set the restore required flag.
See Also

Reference

DoubleTake.Jobs.Contract Namespace


FailoverOptions Class

FailoverOptions Class
Represents the options used when failing over a job.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractFailoverOptions

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class FailoverOptions : IExtensibleDataObject
Public Class FailoverOptions
    Implements IExtensibleDataObject
public ref class FailoverOptions : IExtensibleDataObject
DoubleTake.Jobs.Contract.FailoverOptions = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.FailoverOptions',
    null,
    IExtensibleDataObject);

The FailoverOptions type exposes the following members.

Constructors
 | Name | Description
Public method | FailoverOptions | Initializes a new instance of the FailoverOptions class
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | FailoverDataAction | This value represents the action to take on the queued target data before failover.
Public property | FailoverMode | This value represents the live, test, or snapshot style of failover.
Public property | FailoverType | This value represents the automatic or manual style of failover.
Public property | PerformTestFailover | Gets or sets a value indicating whether to perform a test failover.
Public property | SnapshotId | This value is the snapshot ID that should be applied to the target during snapshot failover.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


FailoverOptions Constructor

FailoverOptions Constructor
Initializes a new instance of the FailoverOptions class

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public FailoverOptions()
Public Sub New
public:
FailoverOptions()
DoubleTake.Jobs.Contract.FailoverOptions = function();
See Also

Reference

FailoverOptions Class
DoubleTake.Jobs.Contract Namespace


FailoverOptions Properties

FailoverOptions Properties

The FailoverOptions type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | FailoverDataAction | This value represents the action to take on the queued target data before failover.
Public property | FailoverMode | This value represents the live, test, or snapshot style of failover.
Public property | FailoverType | This value represents the automatic or manual style of failover.
Public property | PerformTestFailover | Gets or sets a value indicating whether to perform a test failover.
Public property | SnapshotId | This value is the snapshot ID that should be applied to the target during snapshot failover.
Top
See Also

Reference

FailoverOptions Class
DoubleTake.Jobs.Contract Namespace


FailoverOptions.ExtensionData Property

FailoverOptionsExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

FailoverOptions Class
DoubleTake.Jobs.Contract Namespace


FailoverOptions.FailoverDataAction Property

FailoverOptionsFailoverDataAction Property
This value represents the action to take on the queued target data before failover.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public FailoverDataAction FailoverDataAction { get; set; }
Public Property FailoverDataAction As FailoverDataAction
    Get
    Set
public:
property FailoverDataAction FailoverDataAction {
    FailoverDataAction get ();
    void set (FailoverDataAction value);
}
function get_FailoverDataAction();
function set_FailoverDataAction(value);

Property Value

Type: FailoverDataAction
The failover data action.
See Also

Reference

FailoverOptions Class
DoubleTake.Jobs.Contract Namespace


FailoverOptions.FailoverMode Property

FailoverOptionsFailoverMode Property
This value represents the live, test, or snapshot style of failover.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public FailoverMode FailoverMode { get; set; }
Public Property FailoverMode As FailoverMode
    Get
    Set
public:
property FailoverMode FailoverMode {
    FailoverMode get ();
    void set (FailoverMode value);
}
function get_FailoverMode();
function set_FailoverMode(value);

Property Value

Type: FailoverMode
The failover mode.
See Also

Reference

FailoverOptions Class
DoubleTake.Jobs.Contract Namespace


FailoverOptions.FailoverType Property

FailoverOptionsFailoverType Property
This value represents the automatic or manual style of failover.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public FailoverType FailoverType { get; set; }
Public Property FailoverType As FailoverType
    Get
    Set
public:
property FailoverType FailoverType {
    FailoverType get ();
    void set (FailoverType value);
}
function get_FailoverType();
function set_FailoverType(value);

Property Value

Type: FailoverType
The failover mode.
See Also

Reference

FailoverOptions Class
DoubleTake.Jobs.Contract Namespace


FailoverOptions.PerformTestFailover Property

FailoverOptionsPerformTestFailover Property
Gets or sets a value indicating whether to perform a test failover.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool PerformTestFailover { get; set; }
Public Property PerformTestFailover As Boolean
    Get
    Set
public:
property bool PerformTestFailover {
    bool get ();
    void set (bool value);
}
function get_PerformTestFailover();
function set_PerformTestFailover(value);

Property Value

Type: Boolean
if performing a test failover; otherwise, .
See Also

Reference

FailoverOptions Class
DoubleTake.Jobs.Contract Namespace


FailoverOptions.SnapshotId Property

FailoverOptionsSnapshotId Property
This value is the snapshot ID that should be applied to the target during snapshot failover.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Guid SnapshotId { get; set; }
Public Property SnapshotId As Guid
    Get
    Set
public:
property Guid SnapshotId {
    Guid get ();
    void set (Guid value);
}
function get_SnapshotId();
function set_SnapshotId(value);

Property Value

Type: Guid
The snapshot id to apply to the target server during failover.
See Also

Reference

FailoverOptions Class
DoubleTake.Jobs.Contract Namespace


FailoverPersistedState Class

FailoverPersistedState Class
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractFailoverPersistedState

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class FailoverPersistedState
Public Class FailoverPersistedState
public ref class FailoverPersistedState
DoubleTake.Jobs.Contract.FailoverPersistedState = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.FailoverPersistedState');

The FailoverPersistedState type exposes the following members.

Constructors
 | Name | Description
Public method | FailoverPersistedState | Initializes a new instance of the FailoverPersistedState class
Top
Properties
 | Name | Description
Public property | FailedOverAddresses |
Public property | FailedOverShares |
Public property | LastKnownSourceShares |
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


FailoverPersistedState Constructor

FailoverPersistedState Constructor
Initializes a new instance of the FailoverPersistedState class

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public FailoverPersistedState()
Public Sub New
public:
FailoverPersistedState()
DoubleTake.Jobs.Contract.FailoverPersistedState = function();
See Also

Reference

FailoverPersistedState Class
DoubleTake.Jobs.Contract Namespace


FailoverPersistedState Properties

FailoverPersistedState Properties

The FailoverPersistedState type exposes the following members.

Properties
 | Name | Description
Public property | FailedOverAddresses |
Public property | FailedOverShares |
Public property | LastKnownSourceShares |
Top
See Also

Reference

FailoverPersistedState Class
DoubleTake.Jobs.Contract Namespace


FailoverPersistedState.FailedOverAddresses Property

FailoverPersistedStateFailedOverAddresses Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public IEnumerable<AddressPersistedState> FailedOverAddresses { get; set; }
Public Property FailedOverAddresses As IEnumerable(Of AddressPersistedState)
    Get
    Set
public:
property IEnumerable<AddressPersistedState^>^ FailedOverAddresses {
    IEnumerable<AddressPersistedState^>^ get ();
    void set (IEnumerable<AddressPersistedState^>^ value);
}
function get_FailedOverAddresses();
function set_FailedOverAddresses(value);

Property Value

Type: IEnumerable AddressPersistedState
See Also

Reference

FailoverPersistedState Class
DoubleTake.Jobs.Contract Namespace


FailoverPersistedState.FailedOverShares Property

FailoverPersistedStateFailedOverShares Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public IEnumerable<Share> FailedOverShares { get; set; }
Public Property FailedOverShares As IEnumerable(Of Share)
    Get
    Set
public:
property IEnumerable<Share^>^ FailedOverShares {
    IEnumerable<Share^>^ get ();
    void set (IEnumerable<Share^>^ value);
}
function get_FailedOverShares();
function set_FailedOverShares(value);

Property Value

Type: IEnumerable Share
See Also

Reference

FailoverPersistedState Class
DoubleTake.Jobs.Contract Namespace


FailoverPersistedState.LastKnownSourceShares Property

FailoverPersistedStateLastKnownSourceShares Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public IEnumerable<Share> LastKnownSourceShares { get; set; }
Public Property LastKnownSourceShares As IEnumerable(Of Share)
    Get
    Set
public:
property IEnumerable<Share^>^ LastKnownSourceShares {
    IEnumerable<Share^>^ get ();
    void set (IEnumerable<Share^>^ value);
}
function get_LastKnownSourceShares();
function set_LastKnownSourceShares(value);

Property Value

Type: IEnumerable Share
See Also

Reference

FailoverPersistedState Class
DoubleTake.Jobs.Contract Namespace


FailoverType Enumeration

FailoverType Enumeration
Indicates the type of failover.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public enum FailoverType
Public Enumeration FailoverType
public enum class FailoverType
DoubleTake.Jobs.Contract.FailoverType = function();
DoubleTake.Jobs.Contract.FailoverType.createEnum('DoubleTake.Jobs.Contract.FailoverType', false);
Members
Member name | Value | Description
Manual | 0 | Failover must be initiated by the user.
Automatic | 1 | Failover will occur automatically when a failover condition is met.
See Also

Reference

DoubleTake.Jobs.Contract Namespace


Feature Class

Feature Class
Represents a services endpoint that provides additional features for a job.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractFeature

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class Feature : IExtensibleDataObject
Public Class Feature
    Implements IExtensibleDataObject
public ref class Feature : IExtensibleDataObject
DoubleTake.Jobs.Contract.Feature = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.Feature',
    null,
    IExtensibleDataObject);

The Feature type exposes the following members.

Constructors
 | Name | Description
Public method | Feature | Initializes a new instance of the Feature class
Top
Properties
 | Name | Description
Public property | Endpoint | This value is the endpoint that identifies the location of the service.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Tag | This value is the tag that identifies the role of the service.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


Feature Constructor

Feature Constructor
Initializes a new instance of the Feature class

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Feature()
Public Sub New
public:
Feature()
DoubleTake.Jobs.Contract.Feature = function();
See Also

Reference

Feature Class
DoubleTake.Jobs.Contract Namespace


Feature Properties

Feature Properties

The Feature type exposes the following members.

Properties
 | Name | Description
Public property | Endpoint | This value is the endpoint that identifies the location of the service.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Tag | This value is the tag that identifies the role of the service.
Top
See Also

Reference

Feature Class
DoubleTake.Jobs.Contract Namespace


Feature.Endpoint Property

FeatureEndpoint Property
This value is the endpoint that identifies the location of the service.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Uri Endpoint { get; set; }
Public Property Endpoint As Uri
    Get
    Set
public:
property Uri^ Endpoint {
    Uri^ get ();
    void set (Uri^ value);
}
function get_Endpoint();
function set_Endpoint(value);

Property Value

Type: Uri
The endpoint that identifies the location of this service.
See Also

Reference

Feature Class
DoubleTake.Jobs.Contract Namespace


Feature.ExtensionData Property

FeatureExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

Feature Class
DoubleTake.Jobs.Contract Namespace


Feature.Tag Property

FeatureTag Property
This value is the tag that identifies the role of the service.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Tag { get; set; }
Public Property Tag As String
    Get
    Set
public:
property String^ Tag {
    String^ get ();
    void set (String^ value);
}
function get_Tag();
function set_Tag(value);

Property Value

Type: String
The tag that identifies the role of this service.
See Also

Reference

Feature Class
DoubleTake.Jobs.Contract Namespace


FixJobOptionsTaskStatus Class

FixJobOptionsTaskStatus Class
Represents the status of a fixing task.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractFixJobOptionsTaskStatus

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class FixJobOptionsTaskStatus : IExtensibleDataObject
Public Class FixJobOptionsTaskStatus
    Implements IExtensibleDataObject
public ref class FixJobOptionsTaskStatus : IExtensibleDataObject
DoubleTake.Jobs.Contract.FixJobOptionsTaskStatus = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.FixJobOptionsTaskStatus',
    null,
    IExtensibleDataObject);

The FixJobOptionsTaskStatus type exposes the following members.

Constructors
 | Name | Description
Public method | FixJobOptionsTaskStatus | Initializes a new instance of the FixJobOptionsTaskStatus class
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | JobOptions | This value represents the repaired job options. This value will be null until the repair has been completed.
Public property | Task | This value represents the status of the task being repaired.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


FixJobOptionsTaskStatus Constructor

FixJobOptionsTaskStatus Constructor
Initializes a new instance of the FixJobOptionsTaskStatus class

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public FixJobOptionsTaskStatus()
Public Sub New
public:
FixJobOptionsTaskStatus()
DoubleTake.Jobs.Contract.FixJobOptionsTaskStatus = function();
See Also

Reference

FixJobOptionsTaskStatus Class
DoubleTake.Jobs.Contract Namespace


FixJobOptionsTaskStatus Properties

FixJobOptionsTaskStatus Properties

The FixJobOptionsTaskStatus type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | JobOptions | This value represents the repaired job options. This value will be null until the repair has been completed.
Public property | Task | This value represents the status of the task being repaired.
Top
See Also

Reference

FixJobOptionsTaskStatus Class
DoubleTake.Jobs.Contract Namespace


FixJobOptionsTaskStatus.ExtensionData Property

FixJobOptionsTaskStatusExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

FixJobOptionsTaskStatus Class
DoubleTake.Jobs.Contract Namespace


FixJobOptionsTaskStatus.JobOptions Property

FixJobOptionsTaskStatusJobOptions Property
This value represents the repaired job options. This value will be null until the repair has been completed.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public JobOptions JobOptions { get; set; }
Public Property JobOptions As JobOptions
    Get
    Set
public:
property JobOptions^ JobOptions {
    JobOptions^ get ();
    void set (JobOptions^ value);
}
function get_JobOptions();
function set_JobOptions(value);

Property Value

Type: JobOptions
The fixed job options.
Remarks
This property will be until the fixing task has completed.
See Also

Reference

FixJobOptionsTaskStatus Class
DoubleTake.Jobs.Contract Namespace


FixJobOptionsTaskStatus.Task Property

FixJobOptionsTaskStatusTask Property
This value represents the status of the task being repaired.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ActivityStatusEntry Task { get; set; }
Public Property Task As ActivityStatusEntry
    Get
    Set
public:
property ActivityStatusEntry^ Task {
    ActivityStatusEntry^ get ();
    void set (ActivityStatusEntry^ value);
}
function get_Task();
function set_Task(value);

Property Value

Type: ActivityStatusEntry
A JobAction that represents the overall status of the fixing task.
See Also

Reference

FixJobOptionsTaskStatus Class
DoubleTake.Jobs.Contract Namespace


FullServerFailoverOptions Class

FullServerFailoverOptions Class
Represents options for working with the full server failover feature of a job.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractFullServerFailoverOptions

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class FullServerFailoverOptions : IExtensibleDataObject
Public Class FullServerFailoverOptions
    Implements IExtensibleDataObject
public ref class FullServerFailoverOptions : IExtensibleDataObject
DoubleTake.Jobs.Contract.FullServerFailoverOptions = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.FullServerFailoverOptions',
    null,
    IExtensibleDataObject);

The FullServerFailoverOptions type exposes the following members.

Constructors
 | Name | Description
Public method | FullServerFailoverOptions | Initializes a new instance of the FullServerFailoverOptions class
Top
Properties
 | Name | Description
Public property | AdditionalStagingFolders | This value is the folders that should be staged on the target. They will be applied to their actual installation location during failover.
Public property | CreateBackupConnection | This value is true if reverse protection should be configured for this job; otherwise, it is false.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | RemoveOrphans | This value is true if orphan files should be removed for the reverse connection; otherwise, it is false.
Public property | ReverseRoute |
Public property | ReverseRouteEnginePort |
Public property | ShutdownSourceServer | This value is true if the source server should be shut down during cutover; otherwise, it is false.
Public property | SourceChecksumAll | This value is true if a checksum should be used for all files when comparing them; otherwise, it is false.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


FullServerFailoverOptions Constructor

FullServerFailoverOptions Constructor
Initializes a new instance of the FullServerFailoverOptions class

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public FullServerFailoverOptions()
Public Sub New
public:
FullServerFailoverOptions()
DoubleTake.Jobs.Contract.FullServerFailoverOptions = function();
See Also

Reference

FullServerFailoverOptions Class
DoubleTake.Jobs.Contract Namespace


FullServerFailoverOptions Properties

FullServerFailoverOptions Properties

The FullServerFailoverOptions type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalStagingFolders | This value is the folders that should be staged on the target. They will be applied to their actual installation location during failover.
Public property | CreateBackupConnection | This value is true if reverse protection should be configured for this job; otherwise, it is false.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | RemoveOrphans | This value is true if orphan files should be removed for the reverse connection; otherwise, it is false.
Public property | ReverseRoute |
Public property | ReverseRouteEnginePort |
Public property | ShutdownSourceServer | This value is true if the source server should be shut down during cutover; otherwise, it is false.
Public property | SourceChecksumAll | This value is true if a checksum should be used for all files when comparing them; otherwise, it is false.
Top
See Also

Reference

FullServerFailoverOptions Class
DoubleTake.Jobs.Contract Namespace


FullServerFailoverOptions.AdditionalStagingFolders Property

FullServerFailoverOptionsAdditionalStagingFolders Property
This value is the folders that should be staged on the target. They will be applied to their actual installation location during failover.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string[] AdditionalStagingFolders { get; set; }
Public Property AdditionalStagingFolders As String()
    Get
    Set
public:
property array<String^>^ AdditionalStagingFolders {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
function get_AdditionalStagingFolders();
function set_AdditionalStagingFolders(value);

Property Value

Type: String
The additional folders that should be staged on the target server.
See Also

Reference

FullServerFailoverOptions Class
DoubleTake.Jobs.Contract Namespace


FullServerFailoverOptions.CreateBackupConnection Property

FullServerFailoverOptionsCreateBackupConnection Property
This value is true if reverse protection should be configured for this job; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool CreateBackupConnection { get; set; }
Public Property CreateBackupConnection As Boolean
    Get
    Set
public:
property bool CreateBackupConnection {
    bool get ();
    void set (bool value);
}
function get_CreateBackupConnection();
function set_CreateBackupConnection(value);

Property Value

Type: Boolean
if the job should create a backup connection; otherwise, .
See Also

Reference

FullServerFailoverOptions Class
DoubleTake.Jobs.Contract Namespace


FullServerFailoverOptions.ExtensionData Property

FullServerFailoverOptionsExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

FullServerFailoverOptions Class
DoubleTake.Jobs.Contract Namespace


FullServerFailoverOptions.RemoveOrphans Property

FullServerFailoverOptionsRemoveOrphans Property
This value is true if orphan files should be removed for the reverse connection; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool RemoveOrphans { get; set; }
Public Property RemoveOrphans As Boolean
    Get
    Set
public:
property bool RemoveOrphans {
    bool get ();
    void set (bool value);
}
function get_RemoveOrphans();
function set_RemoveOrphans(value);

Property Value

Type: Boolean
if orphans should be removed; otherwise, .
See Also

Reference

FullServerFailoverOptions Class
DoubleTake.Jobs.Contract Namespace


FullServerFailoverOptions.ReverseRoute Property

FullServerFailoverOptionsReverseRoute Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string ReverseRoute { get; set; }
Public Property ReverseRoute As String
    Get
    Set
public:
property String^ ReverseRoute {
    String^ get ();
    void set (String^ value);
}
function get_ReverseRoute();
function set_ReverseRoute(value);

Property Value

Type: String
See Also

Reference

FullServerFailoverOptions Class
DoubleTake.Jobs.Contract Namespace


FullServerFailoverOptions.ReverseRouteEnginePort Property

FullServerFailoverOptionsReverseRouteEnginePort Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Nullable<int> ReverseRouteEnginePort { get; set; }
Public Property ReverseRouteEnginePort As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> ReverseRouteEnginePort {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
function get_ReverseRouteEnginePort();
function set_ReverseRouteEnginePort(value);

Property Value

Type: Nullable Int32
See Also

Reference

FullServerFailoverOptions Class
DoubleTake.Jobs.Contract Namespace


FullServerFailoverOptions.ShutdownSourceServer Property

FullServerFailoverOptionsShutdownSourceServer Property
This value is true if the source server should be shut down during cutover; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool ShutdownSourceServer { get; set; }
Public Property ShutdownSourceServer As Boolean
    Get
    Set
public:
property bool ShutdownSourceServer {
    bool get ();
    void set (bool value);
}
function get_ShutdownSourceServer();
function set_ShutdownSourceServer(value);

Property Value

Type: Boolean
if the source server should be shut down during cutover; otherwise, .
See Also

Reference

FullServerFailoverOptions Class
DoubleTake.Jobs.Contract Namespace


FullServerFailoverOptions.SourceChecksumAll Property

FullServerFailoverOptionsSourceChecksumAll Property
This value is true if a checksum should be used for all files when comparing them; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool SourceChecksumAll { get; set; }
Public Property SourceChecksumAll As Boolean
    Get
    Set
public:
property bool SourceChecksumAll {
    bool get ();
    void set (bool value);
}
function get_SourceChecksumAll();
function set_SourceChecksumAll(value);

Property Value

Type: Boolean
if a checksum should be used for all files when comparing them; otherwise, .
See Also

Reference

FullServerFailoverOptions Class
DoubleTake.Jobs.Contract Namespace


Health Enumeration

Health Enumeration
Indicates the health of a job.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public enum Health
Public Enumeration Health
public enum class Health
DoubleTake.Jobs.Contract.Health = function();
DoubleTake.Jobs.Contract.Health.createEnum('DoubleTake.Jobs.Contract.Health', false);
Members
Member name | Value | Description
Unknown | 0 | The health of the job is unknown or not yet determined.
Ok | 1 | The health of the job is good and data is protected.
Warning | 2 | The job is taking corrective action. Data may not be protected. You should closely monitor a job in a warning state.
Error | 3 | The job has encountered an error that requires user attention. Data is not protected.
See Also

Reference

DoubleTake.Jobs.Contract Namespace


HighLevelState Enumeration

HighLevelState Enumeration
Defines the possible high-level states of a job.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public enum HighLevelState
Public Enumeration HighLevelState
public enum class HighLevelState
DoubleTake.Jobs.Contract.HighLevelState = function();
DoubleTake.Jobs.Contract.HighLevelState.createEnum('DoubleTake.Jobs.Contract.HighLevelState', false);
Members
Member name | Value | Description
Unknown | 0 | The job's state is unknown or not yet determined.
Created | 1 | The job is being created.
Deleting | 2 | The job is being deleted.
Editing | 3 | The job is being editing.
FailedBack | 4 | The job has failed back.
FailedOver | 5 | The job has failed over.
FailingBack | 6 | The job is failing back.
FailingOver | 7 | The job is failing over.
FailoverFailed | 8 | Failover has failed.
FailoverPending | 9 | The job has a failover condition met.
Mirroring | 10 | The job is mirroring.
MirrorRequired | 11 | The job requires a mirror to ensure data integrity.
Paused | 12 | The job is paused.
Pausing | 13 | The job is pausing.
Protecting | 14 | The job is started and protecting.
Provisioning | 15 | The job is provisioning resources required to start protection.
Restored | 16 | The job has completed restoring the data.
RestoreFailed | 17 | Restoration has failed.
RestorePaused | 18 | The job is restoring data but transmission is currently paused.
RestoreRequired | 19 | The job needs to restore data from the target to a new or the original source.
Restoring | 20 | The job is restoring data.
Resuming | 21 | The job is resuming.
Reversing | 22 | The job is reversing roles.
Reverting | 23 | The job is reverting.
Starting | 24 | The job is starting.
Stopped | 25 | The job is stopped.
Stopping | 26 | The job is stopping.
Undoing | 27 | The job is undoing a failover.
RevertingSnapshot | 28 | The job is reverting to a previous snapshot.
UpdatingTargetImage | 29 | The job is updating the target image on the source.
CredentialsRequired | 30 | The job does not have sufficient credentials to operate properly.
ActivationCodeWarning | 31 | The Double-Take replication engine is reporting a licensing warning.
ActivationCodeError | 32 | The Double-Take replication engine is reporting a licensing error.
EngineConnectionWarning | 33 | The connection associated with the job is reporting an error, but the threshold for failed communication has not yet been met.
EngineConnectionError | 34 | The connection associated with the job is reporting an error, and the threshold for failed communication has been exceeded.
EngineServiceWarning | 35 | The Management Service on the target cannot communicate with the target replication engine or the Management Service on the source cannot communicate with the source replication engine, but the threshold for failed communication has not yet been met.
EngineServiceError | 36 | The Management Service on the target cannot communicate with the target replication engine or the Management Service on the source cannot communicate with the source replication engine, and the threshold for failed communication has been exceeded.
ServerCommunicationWarning | 37 | The Management Service on the target cannot contact the Management Service on the source, but the threshold for failed communication has not yet been met.
ServerCommunicationError | 38 | The Management Service on the target cannot contact the Management Service on the source, and the threshold for failed communication has not yet been met.
TargetInfoNotAvailable | 39 | The controller appliance for an agentless vSphere job cannot communicate with the target.
See Also

Reference

DoubleTake.Jobs.Contract Namespace


IEngineControlManager Interface

IEngineControlManager Interface

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public interface IEngineControlManager
Public Interface IEngineControlManager
public interface class IEngineControlManager
DoubleTake.Jobs.Contract.IEngineControlManager = function();
DoubleTake.Jobs.Contract.IEngineControlManager.createInterface('DoubleTake.Jobs.Contract.IEngineControlManager');

The IEngineControlManager type exposes the following members.

Methods
 | Name | Description
Public method | DeleteSnapshot |
Public method | DeleteSnapshots |
Public method | GetBandwidthLimit |
Public method | GetConnectionDetails |
Public method | GetConnectionIds |
Public method | GetSnapshots |
Public method | PauseMirrorOperation |
Public method | PauseTargetOperations |
Public method | PauseTransmission |
Public method | QueueTask |
Public method | ResumeMirrorOperation |
Public method | ResumeTargetOperations |
Public method | ResumeTransmission |
Public method | SetBandwidthLimit |
Public method | StartMirrorOperation |
Public method | StartReplication |
Public method | StartTransmission |
Public method | StopMirrorOperation |
Public method | StopReplication |
Public method | TakeSnapshot |
Public method | UpdateShares |
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


IEngineControlManager Methods

IEngineControlManager Methods

The IEngineControlManager type exposes the following members.

Methods
 | Name | Description
Public method | DeleteSnapshot |
Public method | DeleteSnapshots |
Public method | GetBandwidthLimit |
Public method | GetConnectionDetails |
Public method | GetConnectionIds |
Public method | GetSnapshots |
Public method | PauseMirrorOperation |
Public method | PauseTargetOperations |
Public method | PauseTransmission |
Public method | QueueTask |
Public method | ResumeMirrorOperation |
Public method | ResumeTargetOperations |
Public method | ResumeTransmission |
Public method | SetBandwidthLimit |
Public method | StartMirrorOperation |
Public method | StartReplication |
Public method | StartTransmission |
Public method | StopMirrorOperation |
Public method | StopReplication |
Public method | TakeSnapshot |
Public method | UpdateShares |
Top
See Also

Reference

IEngineControlManager Interface
DoubleTake.Jobs.Contract Namespace


IEngineControlManager.DeleteSnapshot Method

IEngineControlManagerDeleteSnapshot Method

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
ActivityToken DeleteSnapshot(
    Guid jobId,
    Guid connectionId,
    Guid snapshotId
)
Function DeleteSnapshot (
    jobId As Guid,
    connectionId As Guid,
    snapshotId As Guid
) As ActivityToken
ActivityToken^ DeleteSnapshot(
    Guid jobId,
    Guid connectionId,
    Guid snapshotId
)
function DeleteSnapshot(jobId, connectionId, snapshotId);

Parameters

jobId
Type: SystemGuid
connectionId
Type: SystemGuid
snapshotId
Type: SystemGuid

Return Value

Type: ActivityToken
See Also

Reference

IEngineControlManager Interface
DoubleTake.Jobs.Contract Namespace


IEngineControlManager.DeleteSnapshots Method

IEngineControlManagerDeleteSnapshots Method

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
ActivityToken DeleteSnapshots(
    Guid jobId,
    Guid connectionId,
    SnapshotQuality snapshotQuality,
    SnapshotAge snapshotAge
)
Function DeleteSnapshots (
    jobId As Guid,
    connectionId As Guid,
    snapshotQuality As SnapshotQuality,
    snapshotAge As SnapshotAge
) As ActivityToken
ActivityToken^ DeleteSnapshots(
    Guid jobId,
    Guid connectionId,
    SnapshotQuality snapshotQuality,
    SnapshotAge snapshotAge
)
function DeleteSnapshots(jobId, connectionId, snapshotQuality, snapshotAge);

Parameters

jobId
Type: SystemGuid
connectionId
Type: SystemGuid
snapshotQuality
Type: DoubleTake.Core.Contract.ConnectionSnapshotQuality
snapshotAge
Type: DoubleTake.Core.Contract.ConnectionSnapshotAge

Return Value

Type: ActivityToken
See Also

Reference

IEngineControlManager Interface
DoubleTake.Jobs.Contract Namespace


IEngineControlManager.GetBandwidthLimit Method

IEngineControlManagerGetBandwidthLimit Method

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
BandwidthLimit GetBandwidthLimit(
    Guid jobId,
    Guid connectionId
)
Function GetBandwidthLimit (
    jobId As Guid,
    connectionId As Guid
) As BandwidthLimit
BandwidthLimit^ GetBandwidthLimit(
    Guid jobId,
    Guid connectionId
)
function GetBandwidthLimit(jobId, connectionId);

Parameters

jobId
Type: SystemGuid
connectionId
Type: SystemGuid

Return Value

Type: BandwidthLimit
See Also

Reference

IEngineControlManager Interface
DoubleTake.Jobs.Contract Namespace


IEngineControlManager.GetConnectionDetails Method

IEngineControlManagerGetConnectionDetails Method

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
CoreConnectionDetails GetConnectionDetails(
    Guid jobId,
    Guid connectionId
)
Function GetConnectionDetails (
    jobId As Guid,
    connectionId As Guid
) As CoreConnectionDetails
CoreConnectionDetails^ GetConnectionDetails(
    Guid jobId,
    Guid connectionId
)
function GetConnectionDetails(jobId, connectionId);

Parameters

jobId
Type: SystemGuid
connectionId
Type: SystemGuid

Return Value

Type: CoreConnectionDetails
See Also

Reference

IEngineControlManager Interface
DoubleTake.Jobs.Contract Namespace


IEngineControlManager.GetConnectionIds Method

IEngineControlManagerGetConnectionIds Method

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
IDictionary<string, Guid> GetConnectionIds(
    Guid jobId
)
Function GetConnectionIds (
    jobId As Guid
) As IDictionary(Of String, Guid)
IDictionary<String^, Guid>^ GetConnectionIds(
    Guid jobId
)
function GetConnectionIds(jobId);

Parameters

jobId
Type: SystemGuid

Return Value

Type: IDictionary String, Guid
See Also

Reference

IEngineControlManager Interface
DoubleTake.Jobs.Contract Namespace


IEngineControlManager.GetSnapshots Method

IEngineControlManagerGetSnapshots Method

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
SnapshotEntry[] GetSnapshots(
    Guid jobId,
    Guid connectionId
)
Function GetSnapshots (
    jobId As Guid,
    connectionId As Guid
) As SnapshotEntry()
array<SnapshotEntry^>^ GetSnapshots(
    Guid jobId,
    Guid connectionId
)
function GetSnapshots(jobId, connectionId);

Parameters

jobId
Type: SystemGuid
connectionId
Type: SystemGuid

Return Value

Type: SnapshotEntry
See Also

Reference

IEngineControlManager Interface
DoubleTake.Jobs.Contract Namespace


IEngineControlManager.PauseMirrorOperation Method

IEngineControlManagerPauseMirrorOperation Method

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
ActivityToken PauseMirrorOperation(
    Guid jobId,
    Guid connectionId
)
Function PauseMirrorOperation (
    jobId As Guid,
    connectionId As Guid
) As ActivityToken
ActivityToken^ PauseMirrorOperation(
    Guid jobId,
    Guid connectionId
)
function PauseMirrorOperation(jobId, connectionId);

Parameters

jobId
Type: SystemGuid
connectionId
Type: SystemGuid

Return Value

Type: ActivityToken
See Also

Reference

IEngineControlManager Interface
DoubleTake.Jobs.Contract Namespace


IEngineControlManager.PauseTargetOperations Method

IEngineControlManagerPauseTargetOperations Method

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
ActivityToken PauseTargetOperations(
    Guid jobId,
    Guid connectionId
)
Function PauseTargetOperations (
    jobId As Guid,
    connectionId As Guid
) As ActivityToken
ActivityToken^ PauseTargetOperations(
    Guid jobId,
    Guid connectionId
)
function PauseTargetOperations(jobId, connectionId);

Parameters

jobId
Type: SystemGuid
connectionId
Type: SystemGuid

Return Value

Type: ActivityToken
See Also

Reference

IEngineControlManager Interface
DoubleTake.Jobs.Contract Namespace


IEngineControlManager.PauseTransmission Method

IEngineControlManagerPauseTransmission Method

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
ActivityToken PauseTransmission(
    Guid jobId,
    Guid connectionId
)
Function PauseTransmission (
    jobId As Guid,
    connectionId As Guid
) As ActivityToken
ActivityToken^ PauseTransmission(
    Guid jobId,
    Guid connectionId
)
function PauseTransmission(jobId, connectionId);

Parameters

jobId
Type: SystemGuid
connectionId
Type: SystemGuid

Return Value

Type: ActivityToken
See Also

Reference

IEngineControlManager Interface
DoubleTake.Jobs.Contract Namespace


IEngineControlManager.QueueTask Method

IEngineControlManagerQueueTask Method

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
ActivityToken QueueTask(
    Guid jobId,
    Guid connectionId,
    QueueTaskParameters queueTaskParameters
)
Function QueueTask (
    jobId As Guid,
    connectionId As Guid,
    queueTaskParameters As QueueTaskParameters
) As ActivityToken
ActivityToken^ QueueTask(
    Guid jobId,
    Guid connectionId,
    QueueTaskParameters^ queueTaskParameters
)
function QueueTask(jobId, connectionId, queueTaskParameters);

Parameters

jobId
Type: SystemGuid
connectionId
Type: SystemGuid
queueTaskParameters
Type: DoubleTake.Core.Contract.ConnectionQueueTaskParameters

Return Value

Type: ActivityToken
See Also

Reference

IEngineControlManager Interface
DoubleTake.Jobs.Contract Namespace


IEngineControlManager.ResumeMirrorOperation Method

IEngineControlManagerResumeMirrorOperation Method

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
ActivityToken ResumeMirrorOperation(
    Guid jobId,
    Guid connectionId
)
Function ResumeMirrorOperation (
    jobId As Guid,
    connectionId As Guid
) As ActivityToken
ActivityToken^ ResumeMirrorOperation(
    Guid jobId,
    Guid connectionId
)
function ResumeMirrorOperation(jobId, connectionId);

Parameters

jobId
Type: SystemGuid
connectionId
Type: SystemGuid

Return Value

Type: ActivityToken
See Also

Reference

IEngineControlManager Interface
DoubleTake.Jobs.Contract Namespace


IEngineControlManager.ResumeTargetOperations Method

IEngineControlManagerResumeTargetOperations Method

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
ActivityToken ResumeTargetOperations(
    Guid jobId,
    Guid connectionId
)
Function ResumeTargetOperations (
    jobId As Guid,
    connectionId As Guid
) As ActivityToken
ActivityToken^ ResumeTargetOperations(
    Guid jobId,
    Guid connectionId
)
function ResumeTargetOperations(jobId, connectionId);

Parameters

jobId
Type: SystemGuid
connectionId
Type: SystemGuid

Return Value

Type: ActivityToken
See Also

Reference

IEngineControlManager Interface
DoubleTake.Jobs.Contract Namespace


IEngineControlManager.ResumeTransmission Method

IEngineControlManagerResumeTransmission Method

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
ActivityToken ResumeTransmission(
    Guid jobId,
    Guid connectionId
)
Function ResumeTransmission (
    jobId As Guid,
    connectionId As Guid
) As ActivityToken
ActivityToken^ ResumeTransmission(
    Guid jobId,
    Guid connectionId
)
function ResumeTransmission(jobId, connectionId);

Parameters

jobId
Type: SystemGuid
connectionId
Type: SystemGuid

Return Value

Type: ActivityToken
See Also

Reference

IEngineControlManager Interface
DoubleTake.Jobs.Contract Namespace


IEngineControlManager.SetBandwidthLimit Method

IEngineControlManagerSetBandwidthLimit Method

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
ActivityToken SetBandwidthLimit(
    Guid jobId,
    Guid connectionId,
    BandwidthLimit bandwidthLimit
)
Function SetBandwidthLimit (
    jobId As Guid,
    connectionId As Guid,
    bandwidthLimit As BandwidthLimit
) As ActivityToken
ActivityToken^ SetBandwidthLimit(
    Guid jobId,
    Guid connectionId,
    BandwidthLimit^ bandwidthLimit
)
function SetBandwidthLimit(jobId, connectionId, bandwidthLimit);

Parameters

jobId
Type: SystemGuid
connectionId
Type: SystemGuid
bandwidthLimit
Type: DoubleTake.Core.Contract.ConnectionBandwidthLimit

Return Value

Type: ActivityToken
See Also

Reference

IEngineControlManager Interface
DoubleTake.Jobs.Contract Namespace


IEngineControlManager.StartMirrorOperation Method

IEngineControlManagerStartMirrorOperation Method

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
ActivityToken StartMirrorOperation(
    Guid jobId,
    Guid connectionId,
    MirrorParameters mirrorParameters
)
Function StartMirrorOperation (
    jobId As Guid,
    connectionId As Guid,
    mirrorParameters As MirrorParameters
) As ActivityToken
ActivityToken^ StartMirrorOperation(
    Guid jobId,
    Guid connectionId,
    MirrorParameters^ mirrorParameters
)
function StartMirrorOperation(jobId, connectionId, mirrorParameters);

Parameters

jobId
Type: SystemGuid
connectionId
Type: SystemGuid
mirrorParameters
Type: DoubleTake.Core.Contract.ConnectionMirrorParameters

Return Value

Type: ActivityToken
See Also

Reference

IEngineControlManager Interface
DoubleTake.Jobs.Contract Namespace


IEngineControlManager.StartReplication Method

IEngineControlManagerStartReplication Method

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
ActivityToken StartReplication(
    Guid jobId,
    Guid connectionId
)
Function StartReplication (
    jobId As Guid,
    connectionId As Guid
) As ActivityToken
ActivityToken^ StartReplication(
    Guid jobId,
    Guid connectionId
)
function StartReplication(jobId, connectionId);

Parameters

jobId
Type: SystemGuid
connectionId
Type: SystemGuid

Return Value

Type: ActivityToken
See Also

Reference

IEngineControlManager Interface
DoubleTake.Jobs.Contract Namespace


IEngineControlManager.StartTransmission Method

IEngineControlManagerStartTransmission Method

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
ActivityToken StartTransmission(
    Guid jobId,
    Guid connectionId
)
Function StartTransmission (
    jobId As Guid,
    connectionId As Guid
) As ActivityToken
ActivityToken^ StartTransmission(
    Guid jobId,
    Guid connectionId
)
function StartTransmission(jobId, connectionId);

Parameters

jobId
Type: SystemGuid
connectionId
Type: SystemGuid

Return Value

Type: ActivityToken
See Also

Reference

IEngineControlManager Interface
DoubleTake.Jobs.Contract Namespace


IEngineControlManager.StopMirrorOperation Method

IEngineControlManagerStopMirrorOperation Method

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
ActivityToken StopMirrorOperation(
    Guid jobId,
    Guid connectionId
)
Function StopMirrorOperation (
    jobId As Guid,
    connectionId As Guid
) As ActivityToken
ActivityToken^ StopMirrorOperation(
    Guid jobId,
    Guid connectionId
)
function StopMirrorOperation(jobId, connectionId);

Parameters

jobId
Type: SystemGuid
connectionId
Type: SystemGuid

Return Value

Type: ActivityToken
See Also

Reference

IEngineControlManager Interface
DoubleTake.Jobs.Contract Namespace


IEngineControlManager.StopReplication Method

IEngineControlManagerStopReplication Method

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
ActivityToken StopReplication(
    Guid jobId,
    Guid connectionId
)
Function StopReplication (
    jobId As Guid,
    connectionId As Guid
) As ActivityToken
ActivityToken^ StopReplication(
    Guid jobId,
    Guid connectionId
)
function StopReplication(jobId, connectionId);

Parameters

jobId
Type: SystemGuid
connectionId
Type: SystemGuid

Return Value

Type: ActivityToken
See Also

Reference

IEngineControlManager Interface
DoubleTake.Jobs.Contract Namespace


IEngineControlManager.TakeSnapshot Method

IEngineControlManagerTakeSnapshot Method

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
ActivityToken TakeSnapshot(
    Guid jobId,
    Guid connectionId
)
Function TakeSnapshot (
    jobId As Guid,
    connectionId As Guid
) As ActivityToken
ActivityToken^ TakeSnapshot(
    Guid jobId,
    Guid connectionId
)
function TakeSnapshot(jobId, connectionId);

Parameters

jobId
Type: SystemGuid
connectionId
Type: SystemGuid

Return Value

Type: ActivityToken
See Also

Reference

IEngineControlManager Interface
DoubleTake.Jobs.Contract Namespace


IEngineControlManager.UpdateShares Method

IEngineControlManagerUpdateShares Method

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
ActivityToken UpdateShares(
    Guid jobId
)
Function UpdateShares (
    jobId As Guid
) As ActivityToken
ActivityToken^ UpdateShares(
    Guid jobId
)
function UpdateShares(jobId);

Parameters

jobId
Type: SystemGuid

Return Value

Type: ActivityToken
See Also

Reference

IEngineControlManager Interface
DoubleTake.Jobs.Contract Namespace


IJobConfigurationVerifier Interface

IJobConfigurationVerifier Interface
Provides methods for getting default options and verifying those options prior to creating a job.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public interface IJobConfigurationVerifier
Public Interface IJobConfigurationVerifier
public interface class IJobConfigurationVerifier
DoubleTake.Jobs.Contract.IJobConfigurationVerifier = function();
DoubleTake.Jobs.Contract.IJobConfigurationVerifier.createInterface('DoubleTake.Jobs.Contract.IJobConfigurationVerifier');

The IJobConfigurationVerifier type exposes the following members.

Methods
 | Name | Description
Public method | FixJobOptions | Attempts to fix items that failed verification.
Public method | GetDnsOptions(JobCredentials, NetworkCredential) |
Public method | GetDnsOptions(String, Workload, JobCredentials, Credentials) | Gets the DNS options.
Public method | GetFixJobOptionsStatus | Gets the status of the fixing operation.
Public method | GetRecommendedJobOptions | Gets the default job options.
Public method | GetRecommendedPathTransformations | Gets the recommended path transformations for a workload.
Public method | GetVerificationStatus | Gets the status of the verification operation.
Public method | UpdateRecommendedJobOptions | Updates the recommended job options.
Public method | VerifyJobOptions | Verifies the provided job options.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


IJobConfigurationVerifier Methods

IJobConfigurationVerifier Methods

The IJobConfigurationVerifier type exposes the following members.

Methods
 | Name | Description
Public method | FixJobOptions | Attempts to fix items that failed verification.
Public method | GetDnsOptions(JobCredentials, NetworkCredential) |
Public method | GetDnsOptions(String, Workload, JobCredentials, Credentials) | Gets the DNS options.
Public method | GetFixJobOptionsStatus | Gets the status of the fixing operation.
Public method | GetRecommendedJobOptions | Gets the default job options.
Public method | GetRecommendedPathTransformations | Gets the recommended path transformations for a workload.
Public method | GetVerificationStatus | Gets the status of the verification operation.
Public method | UpdateRecommendedJobOptions | Updates the recommended job options.
Public method | VerifyJobOptions | Verifies the provided job options.
Top
See Also

Reference

IJobConfigurationVerifier Interface
DoubleTake.Jobs.Contract Namespace


IJobConfigurationVerifier.FixJobOptions Method

IJobConfigurationVerifierFixJobOptions Method
Attempts to fix items that failed verification.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
ActivityToken FixJobOptions(
    VerificationStep[] stepsToFix,
    string jobType,
    JobOptions jobOptions,
    JobCredentials jobCredentials
)
Function FixJobOptions (
    stepsToFix As VerificationStep(),
    jobType As String,
    jobOptions As JobOptions,
    jobCredentials As JobCredentials
) As ActivityToken
ActivityToken^ FixJobOptions(
    array<VerificationStep^>^ stepsToFix,
    String^ jobType,
    JobOptions^ jobOptions,
    JobCredentials^ jobCredentials
)
function FixJobOptions(stepsToFix, jobType, jobOptions, jobCredentials);

Parameters

stepsToFix
Type: DoubleTake.Jobs.ContractVerificationStep
An array of VerificationStep indicating the items to fix.
jobType
Type: SystemString
Type of the job.
jobOptions
Type: DoubleTake.Jobs.ContractJobOptions
The job options to be verified.
jobCredentials
Type: DoubleTake.Jobs.ContractJobCredentials
The connection information and credentials for the source and target servers.

Return Value

Type: ActivityToken
An ActionToken that can be used to get the status of the fixing operation.
See Also

Reference

IJobConfigurationVerifier Interface
DoubleTake.Jobs.Contract Namespace


IJobConfigurationVerifier.GetDnsOptions Method

IJobConfigurationVerifierGetDnsOptions Method
Overload List
 | Name | Description
Public method | GetDnsOptions(JobCredentials, NetworkCredential) |
Public method | GetDnsOptions(String, Workload, JobCredentials, Credentials) | Gets the DNS options.
Top
See Also

Reference

IJobConfigurationVerifier Interface
DoubleTake.Jobs.Contract Namespace


IJobConfigurationVerifier.GetDnsOptions Method (JobCredentials, NetworkCredential)

IJobConfigurationVerifierGetDnsOptions Method (JobCredentials, NetworkCredential)

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
DNSOptions GetDnsOptions(
    JobCredentials jobCredentials,
    NetworkCredential domainCredentials
)
Function GetDnsOptions (
    jobCredentials As JobCredentials,
    domainCredentials As NetworkCredential
) As DNSOptions
DNSOptions^ GetDnsOptions(
    JobCredentials^ jobCredentials,
    NetworkCredential^ domainCredentials
)
function GetDnsOptions(jobCredentials, domainCredentials);

Parameters

jobCredentials
Type: DoubleTake.Jobs.ContractJobCredentials
domainCredentials
Type: System.NetNetworkCredential

Return Value

Type: DNSOptions
See Also

Reference

IJobConfigurationVerifier Interface
GetDnsOptions Overload
DoubleTake.Jobs.Contract Namespace


IJobConfigurationVerifier.GetDnsOptions Method (String, Workload, JobCredentials, Credentials)

IJobConfigurationVerifierGetDnsOptions Method (String, Workload, JobCredentials, Credentials)
Gets the DNS options.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
DNSOptions GetDnsOptions(
    string jobType,
    Workload workload,
    JobCredentials credentialsJob,
    Credentials credentialsDomain
)
Function GetDnsOptions (
    jobType As String,
    workload As Workload,
    credentialsJob As JobCredentials,
    credentialsDomain As Credentials
) As DNSOptions
DNSOptions^ GetDnsOptions(
    String^ jobType,
    Workload^ workload,
    JobCredentials^ credentialsJob,
    Credentials^ credentialsDomain
)
function GetDnsOptions(jobType, workload, credentialsJob, credentialsDomain);

Parameters

jobType
Type: SystemString
Type of the job.
workload
Type: DoubleTake.Common.ContractWorkload
The workload.
credentialsJob
Type: DoubleTake.Jobs.ContractJobCredentials
The job credentials.
credentialsDomain
Type: DoubleTake.Common.ContractCredentials
The domain credentials.

Return Value

Type: DNSOptions
A DNSOptions object that contains the DNS options for the domain.
See Also

Reference

IJobConfigurationVerifier Interface
GetDnsOptions Overload
DoubleTake.Jobs.Contract Namespace


IJobConfigurationVerifier.GetFixJobOptionsStatus Method

IJobConfigurationVerifierGetFixJobOptionsStatus Method
Gets the status of the fixing operation.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
FixJobOptionsTaskStatus GetFixJobOptionsStatus(
    ActivityToken taskToken
)
Function GetFixJobOptionsStatus (
    taskToken As ActivityToken
) As FixJobOptionsTaskStatus
FixJobOptionsTaskStatus^ GetFixJobOptionsStatus(
    ActivityToken^ taskToken
)
function GetFixJobOptionsStatus(taskToken);

Parameters

taskToken
Type: ActivityToken
The token that identifies the fixing operation

Return Value

Type: FixJobOptionsTaskStatus
A FixJobOptionsTaskStatus that indicates the progress and result of the fixing operation.
See Also

Reference

IJobConfigurationVerifier Interface
DoubleTake.Jobs.Contract Namespace


IJobConfigurationVerifier.GetRecommendedJobOptions Method

IJobConfigurationVerifierGetRecommendedJobOptions Method
Gets the default job options.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
RecommendedJobOptions GetRecommendedJobOptions(
    string jobType,
    Workload workload,
    JobCredentials jobCredentials
)
Function GetRecommendedJobOptions (
    jobType As String,
    workload As Workload,
    jobCredentials As JobCredentials
) As RecommendedJobOptions
RecommendedJobOptions^ GetRecommendedJobOptions(
    String^ jobType,
    Workload^ workload,
    JobCredentials^ jobCredentials
)
function GetRecommendedJobOptions(jobType, workload, jobCredentials);

Parameters

jobType
Type: SystemString
Type of the job.
workload
Type: DoubleTake.Common.ContractWorkload
The workload to be protected by this job.
jobCredentials
Type: DoubleTake.Jobs.ContractJobCredentials
The connection information and credentials for the source and target servers.

Return Value

Type: RecommendedJobOptions
A RecommendedJobOptions instance that includes the recommended job options and other potential values for those options.
See Also

Reference

IJobConfigurationVerifier Interface
DoubleTake.Jobs.Contract Namespace


IJobConfigurationVerifier.GetRecommendedPathTransformations Method

IJobConfigurationVerifierGetRecommendedPathTransformations Method
Gets the recommended path transformations for a workload.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
PathTransformation[] GetRecommendedPathTransformations(
    Workload workload,
    string basePath
)
Function GetRecommendedPathTransformations (
    workload As Workload,
    basePath As String
) As PathTransformation()
array<PathTransformation^>^ GetRecommendedPathTransformations(
    Workload^ workload,
    String^ basePath
)
function GetRecommendedPathTransformations(workload, basePath);

Parameters

workload
Type: DoubleTake.Common.ContractWorkload
The workload.
basePath
Type: SystemString
The base path.

Return Value

Type: PathTransformation
An array of PathTransformation objects, one element in the array for each volume.
Exceptions
Exception | Condition
ArgumentNullException | workload is .
Remarks
Providing a base path of will result in a one-to-one volume mapping; otherwise you will be provided with a many-to-one volume mapping based on the provided path.
See Also

Reference

IJobConfigurationVerifier Interface
DoubleTake.Jobs.Contract Namespace


IJobConfigurationVerifier.GetVerificationStatus Method

IJobConfigurationVerifierGetVerificationStatus Method
Gets the status of the verification operation.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
VerificationTaskStatus GetVerificationStatus(
    ActivityToken taskToken
)
Function GetVerificationStatus (
    taskToken As ActivityToken
) As VerificationTaskStatus
VerificationTaskStatus^ GetVerificationStatus(
    ActivityToken^ taskToken
)
function GetVerificationStatus(taskToken);

Parameters

taskToken
Type: ActivityToken
The token that identifies the verification operation.

Return Value

Type: VerificationTaskStatus
A VerificationTaskStatus that indicates the progress and result of the verification operation.
See Also

Reference

IJobConfigurationVerifier Interface
DoubleTake.Jobs.Contract Namespace


IJobConfigurationVerifier.UpdateRecommendedJobOptions Method

IJobConfigurationVerifierUpdateRecommendedJobOptions Method
Updates the recommended job options.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
RecommendedJobOptions UpdateRecommendedJobOptions(
    string jobType,
    JobOptions currentOptions,
    Workload newWorkload,
    JobCredentials jobCredentials
)
Function UpdateRecommendedJobOptions (
    jobType As String,
    currentOptions As JobOptions,
    newWorkload As Workload,
    jobCredentials As JobCredentials
) As RecommendedJobOptions
RecommendedJobOptions^ UpdateRecommendedJobOptions(
    String^ jobType,
    JobOptions^ currentOptions,
    Workload^ newWorkload,
    JobCredentials^ jobCredentials
)
function UpdateRecommendedJobOptions(jobType, currentOptions, newWorkload, jobCredentials);

Parameters

jobType
Type: SystemString
Type of the job.
currentOptions
Type: DoubleTake.Jobs.ContractJobOptions
The current options.
newWorkload
Type: DoubleTake.Common.ContractWorkload
The new workload.
jobCredentials
Type: DoubleTake.Jobs.ContractJobCredentials
The job credentials.

Return Value

Type: RecommendedJobOptions
A RecommendedJobOptions instance that includes the recommended job options and other potential values for those options.
See Also

Reference

IJobConfigurationVerifier Interface
DoubleTake.Jobs.Contract Namespace


IJobConfigurationVerifier.VerifyJobOptions Method

IJobConfigurationVerifierVerifyJobOptions Method
Verifies the provided job options.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
ActivityToken VerifyJobOptions(
    string jobType,
    JobOptions jobOptions,
    JobCredentials jobCredentials
)
Function VerifyJobOptions (
    jobType As String,
    jobOptions As JobOptions,
    jobCredentials As JobCredentials
) As ActivityToken
ActivityToken^ VerifyJobOptions(
    String^ jobType,
    JobOptions^ jobOptions,
    JobCredentials^ jobCredentials
)
function VerifyJobOptions(jobType, jobOptions, jobCredentials);

Parameters

jobType
Type: SystemString
Type of the job.
jobOptions
Type: DoubleTake.Jobs.ContractJobOptions
The job options to be verified.
jobCredentials
Type: DoubleTake.Jobs.ContractJobCredentials
The connection information and credentials for the source and target servers.

Return Value

Type: ActivityToken
An ActionToken that can be used to get the status of the verification operation.
See Also

Reference

IJobConfigurationVerifier Interface
DoubleTake.Jobs.Contract Namespace


IJobManager Interface

IJobManager Interface
Provides methods for creating and managing jobs on a server.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public interface IJobManager
Public Interface IJobManager
public interface class IJobManager
DoubleTake.Jobs.Contract.IJobManager = function();
DoubleTake.Jobs.Contract.IJobManager.createInterface('DoubleTake.Jobs.Contract.IJobManager');

The IJobManager type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an existing job to the job manager.
Public method | BeginGetJobDisplayInfo | Begins an asynchronous operation to get all job display info on a server.
Public method | BeginGetJobs | Begins an asynchronous operation to get all jobs on a server.
Public method | Create | Creates a job.
Public method | Delete | Deletes a job.
Public method | DeleteSnapshot |
Public method | Edit | Edits a job, that is, changes the user-facing job options.
Public method | EndGetJobDisplayInfo | Waits for the pending asynchronous operation to get all job display info on a server to complete.
Public method | EndGetJobs | Waits for the pending asynchronous operation to get all jobs on a server to complete.
Public method | Failback | Fails back a job.
Public method | Failover | Fails over a job.
Public method | FixJobOptions | Fixes the job options that are causing the verification to fail.
Public method | GetActionStatus | Gets the status of an action requested on the job.
Public method | GetFixJobOptionsStatus | Gets the status of the fixing operation.
Public method | GetJob | Gets a particular job on the server.
Public method | GetJobDisplayInfo | Gets all information the console displays consistently
Public method | GetJobs | Gets all jobs on a server.
Public method | GetLogMessages | Gets the messages in the job text log file.
Public method | GetQualificationResults | Gets the qualification results for job. The qualification results express the potential option that can be set for a job.
Public method | GetRecommendedFailbackOptions | Gets the recommended failback options.
Public method | GetRecommendedFailoverOptions | Gets the recommended failover options.
Public method | GetRecommendedRestoreOptions | Gets the recommended restore options.
Public method | GetSnapshots |
Public method | GetVerificationStatus | Gets the status of the verification task.
Public method | Pause | Pauses a job.
Public method | PersistShares |
Public method | Restore | Restores a job.
Public method | Reverse | Reverses a job.
Public method | Start | Starts a job.
Public method | Stop | Stops a job.
Public method | TakeSnapshot |
Public method | UndoFailover | Undoes the failover of a job.
Public method | UpdateCredentials | Update the credentials a job is using to connect to the servers involved.
Public method | UpdateRecommendedJobOptions | Updates the recommended job options.
Public method | VerifyFailbackOptions | Verifies the failback options.
Public method | VerifyFailoverOptions | Verifies the failover options.
Public method | VerifyJobOptions | Verifies the job options.
Public method | VerifyRestoreOptions | Verifies the restore options.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


IJobManager Methods

IJobManager Methods

The IJobManager type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an existing job to the job manager.
Public method | BeginGetJobDisplayInfo | Begins an asynchronous operation to get all job display info on a server.
Public method | BeginGetJobs | Begins an asynchronous operation to get all jobs on a server.
Public method | Create | Creates a job.
Public method | Delete | Deletes a job.
Public method | DeleteSnapshot |
Public method | Edit | Edits a job, that is, changes the user-facing job options.
Public method | EndGetJobDisplayInfo | Waits for the pending asynchronous operation to get all job display info on a server to complete.
Public method | EndGetJobs | Waits for the pending asynchronous operation to get all jobs on a server to complete.
Public method | Failback | Fails back a job.
Public method | Failover | Fails over a job.
Public method | FixJobOptions | Fixes the job options that are causing the verification to fail.
Public method | GetActionStatus | Gets the status of an action requested on the job.
Public method | GetFixJobOptionsStatus | Gets the status of the fixing operation.
Public method | GetJob | Gets a particular job on the server.
Public method | GetJobDisplayInfo | Gets all information the console displays consistently
Public method | GetJobs | Gets all jobs on a server.
Public method | GetLogMessages | Gets the messages in the job text log file.
Public method | GetQualificationResults | Gets the qualification results for job. The qualification results express the potential option that can be set for a job.
Public method | GetRecommendedFailbackOptions | Gets the recommended failback options.
Public method | GetRecommendedFailoverOptions | Gets the recommended failover options.
Public method | GetRecommendedRestoreOptions | Gets the recommended restore options.
Public method | GetSnapshots |
Public method | GetVerificationStatus | Gets the status of the verification task.
Public method | Pause | Pauses a job.
Public method | PersistShares |
Public method | Restore | Restores a job.
Public method | Reverse | Reverses a job.
Public method | Start | Starts a job.
Public method | Stop | Stops a job.
Public method | TakeSnapshot |
Public method | UndoFailover | Undoes the failover of a job.
Public method | UpdateCredentials | Update the credentials a job is using to connect to the servers involved.
Public method | UpdateRecommendedJobOptions | Updates the recommended job options.
Public method | VerifyFailbackOptions | Verifies the failback options.
Public method | VerifyFailoverOptions | Verifies the failover options.
Public method | VerifyJobOptions | Verifies the job options.
Public method | VerifyRestoreOptions | Verifies the restore options.
Top
See Also

Reference

IJobManager Interface
DoubleTake.Jobs.Contract Namespace


IJobManager.Add Method

IJobManagerAdd Method
Adds an existing job to the job manager.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
Guid Add(
    JobInfo jobInfo
)
Function Add (
    jobInfo As JobInfo
) As Guid
Guid Add(
    JobInfo^ jobInfo
)
function Add(jobInfo);

Parameters

jobInfo
Type: DoubleTake.Jobs.ContractJobInfo
The job information.

Return Value

Type: Guid
An id that uniquely identifies this job on the server.
Exceptions
Exception | Condition
ArgumentNullException | jobInfo is .
Remarks
This method is intended to be used by transitional implementations of jobs that want to allow their jobs to be visible to the job manager, but will be responsible for creating those jobs and managing their lifetime. Typically, jobs added to the job manager in this way will have [P:Managed] set to .
See Also

Reference

IJobManager Interface
DoubleTake.Jobs.Contract Namespace


IJobManager.BeginGetJobDisplayInfo Method

IJobManagerBeginGetJobDisplayInfo Method
Begins an asynchronous operation to get all job display info on a server.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
IAsyncResult BeginGetJobDisplayInfo(
    AsyncCallback callback,
    Object asyncState
)
Function BeginGetJobDisplayInfo (
    callback As AsyncCallback,
    asyncState As Object
) As IAsyncResult
IAsyncResult^ BeginGetJobDisplayInfo(
    AsyncCallback^ callback,
    Object^ asyncState
)
function BeginGetJobDisplayInfo(callback, asyncState);

Parameters

callback
Type: SystemAsyncCallback
An optional asynchronous callback, to be called when the operation is complete.
asyncState
Type: SystemObject
A user-provided object that distinguishes this particular request from other requests.

Return Value

Type: IAsyncResult
An IAsyncResult that represents the asynchronous operation, which could still be pending.
See Also

Reference

IJobManager Interface
DoubleTake.Jobs.Contract Namespace


IJobManager.BeginGetJobs Method

IJobManagerBeginGetJobs Method
Begins an asynchronous operation to get all jobs on a server.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
IAsyncResult BeginGetJobs(
    AsyncCallback callback,
    Object asyncState
)
Function BeginGetJobs (
    callback As AsyncCallback,
    asyncState As Object
) As IAsyncResult
IAsyncResult^ BeginGetJobs(
    AsyncCallback^ callback,
    Object^ asyncState
)
function BeginGetJobs(callback, asyncState);

Parameters

callback
Type: SystemAsyncCallback
An optional asynchronous callback, to be called when the operation is complete.
asyncState
Type: SystemObject
A user-provided object that distinguishes this particular request from other requests.

Return Value

Type: IAsyncResult
An IAsyncResult that represents the asynchronous operation, which could still be pending.
See Also

Reference

IJobManager Interface
DoubleTake.Jobs.Contract Namespace


IJobManager.Create Method

IJobManagerCreate Method
Creates a job.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
Guid Create(
    CreateOptions createOptions,
    Guid requestId
)
Function Create (
    createOptions As CreateOptions,
    requestId As Guid
) As Guid
Guid Create(
    CreateOptions^ createOptions,
    Guid requestId
)
function Create(createOptions, requestId);

Parameters

createOptions
Type: DoubleTake.Jobs.ContractCreateOptions
The creation options.
requestId
Type: SystemGuid
The request id. Callers should generate a unique id for all calls, except when re-calling this method because of a problem with the channel.

Return Value

Type: Guid
An id that uniquely identifies this job on the server.
Exceptions
Exception | Condition
ArgumentNullException | createOptions is .
See Also

Reference

IJobManager Interface
DoubleTake.Jobs.Contract Namespace


IJobManager.Delete Method

IJobManagerDelete Method
Deletes a job.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
ActivityToken Delete(
    Guid jobId,
    DeleteOptions deleteOptions
)
Function Delete (
    jobId As Guid,
    deleteOptions As DeleteOptions
) As ActivityToken
ActivityToken^ Delete(
    Guid jobId,
    DeleteOptions^ deleteOptions
)
function Delete(jobId, deleteOptions);

Parameters

jobId
Type: SystemGuid
The job id.
deleteOptions
Type: DoubleTake.Jobs.ContractDeleteOptions
The delete options.

Return Value

Type: ActivityToken
A ActionToken that can be used to get the status of the action.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | There is no job whose id matches jobId.
See Also

Reference

IJobManager Interface
DoubleTake.Jobs.Contract Namespace


IJobManager.DeleteSnapshot Method

IJobManagerDeleteSnapshot Method

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
ActivityToken DeleteSnapshot(
    Guid jobId,
    Guid connectionId,
    Guid snapshotId
)
Function DeleteSnapshot (
    jobId As Guid,
    connectionId As Guid,
    snapshotId As Guid
) As ActivityToken
ActivityToken^ DeleteSnapshot(
    Guid jobId,
    Guid connectionId,
    Guid snapshotId
)
function DeleteSnapshot(jobId, connectionId, snapshotId);

Parameters

jobId
Type: SystemGuid
connectionId
Type: SystemGuid
snapshotId
Type: SystemGuid

Return Value

Type: ActivityToken
See Also

Reference

IJobManager Interface
DoubleTake.Jobs.Contract Namespace


IJobManager.Edit Method

IJobManagerEdit Method
Edits a job, that is, changes the user-facing job options.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
ActivityToken Edit(
    Guid jobId,
    JobOptions jobOptions,
    Guid requestId
)
Function Edit (
    jobId As Guid,
    jobOptions As JobOptions,
    requestId As Guid
) As ActivityToken
ActivityToken^ Edit(
    Guid jobId,
    JobOptions^ jobOptions,
    Guid requestId
)
function Edit(jobId, jobOptions, requestId);

Parameters

jobId
Type: SystemGuid
The job id.
jobOptions
Type: DoubleTake.Jobs.ContractJobOptions
The job options.
requestId
Type: SystemGuid
The request id. Callers should generate a unique id for all calls, except when re-calling this method because of a problem with the channel.

Return Value

Type: ActivityToken
A ActionToken that can be used to get the status of the action.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | There is no job whose id matches jobId.
See Also

Reference

IJobManager Interface
DoubleTake.Jobs.Contract Namespace


IJobManager.EndGetJobDisplayInfo Method

IJobManagerEndGetJobDisplayInfo Method
Waits for the pending asynchronous operation to get all job display info on a server to complete.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
JobDisplayInfo[] EndGetJobDisplayInfo(
    IAsyncResult result
)
Function EndGetJobDisplayInfo (
    result As IAsyncResult
) As JobDisplayInfo()
array<JobDisplayInfo^>^ EndGetJobDisplayInfo(
    IAsyncResult^ result
)
function EndGetJobDisplayInfo(result);

Parameters

result
Type: SystemIAsyncResult
The reference to the pending asynchronous request to finish.

Return Value

Type: JobDisplayInfo
An array of JobStatistics that represents the jobs on the server.
See Also

Reference

IJobManager Interface
DoubleTake.Jobs.Contract Namespace


IJobManager.EndGetJobs Method

IJobManagerEndGetJobs Method
Waits for the pending asynchronous operation to get all jobs on a server to complete.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
JobInfo[] EndGetJobs(
    IAsyncResult result
)
Function EndGetJobs (
    result As IAsyncResult
) As JobInfo()
array<JobInfo^>^ EndGetJobs(
    IAsyncResult^ result
)
function EndGetJobs(result);

Parameters

result
Type: SystemIAsyncResult
The reference to the pending asynchronous request to finish.

Return Value

Type: JobInfo
An array of JobInfo that represents the jobs on the server.
See Also

Reference

IJobManager Interface
DoubleTake.Jobs.Contract Namespace


IJobManager.Failback Method

IJobManagerFailback Method
Fails back a job.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
ActivityToken Failback(
    Guid jobId,
    FailbackOptions parameters
)
Function Failback (
    jobId As Guid,
    parameters As FailbackOptions
) As ActivityToken
ActivityToken^ Failback(
    Guid jobId,
    FailbackOptions^ parameters
)
function Failback(jobId, parameters);

Parameters

jobId
Type: SystemGuid
The job id.
parameters
Type: DoubleTake.Jobs.ContractFailbackOptions
The parameters.

Return Value

Type: ActivityToken
A ActionToken that can be used to get the status of the action.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | There is no job whose id matches jobId.
See Also

Reference

IJobManager Interface
DoubleTake.Jobs.Contract Namespace


IJobManager.Failover Method

IJobManagerFailover Method
Fails over a job.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
ActivityToken Failover(
    Guid jobId,
    FailoverOptions parameters
)
Function Failover (
    jobId As Guid,
    parameters As FailoverOptions
) As ActivityToken
ActivityToken^ Failover(
    Guid jobId,
    FailoverOptions^ parameters
)
function Failover(jobId, parameters);

Parameters

jobId
Type: SystemGuid
The job id.
parameters
Type: DoubleTake.Jobs.ContractFailoverOptions
The parameters.

Return Value

Type: ActivityToken
A ActionToken that can be used to get the status of the action.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | There is no job whose id matches jobId.
See Also

Reference

IJobManager Interface
DoubleTake.Jobs.Contract Namespace


IJobManager.FixJobOptions Method

IJobManagerFixJobOptions Method
Fixes the job options that are causing the verification to fail.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
ActivityToken FixJobOptions(
    VerificationStep[] stepsToFix,
    Guid jobId,
    JobOptions jobOptions
)
Function FixJobOptions (
    stepsToFix As VerificationStep(),
    jobId As Guid,
    jobOptions As JobOptions
) As ActivityToken
ActivityToken^ FixJobOptions(
    array<VerificationStep^>^ stepsToFix,
    Guid jobId,
    JobOptions^ jobOptions
)
function FixJobOptions(stepsToFix, jobId, jobOptions);

Parameters

stepsToFix
Type: DoubleTake.Jobs.ContractVerificationStep
The verification steps to fix.
jobId
Type: SystemGuid
The job id.
jobOptions
Type: DoubleTake.Jobs.ContractJobOptions
The job options.

Return Value

Type: ActivityToken
A ActionToken that can be used to get the status of the action.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | There is no job whose id matches jobId.
See Also

Reference

IJobManager Interface
DoubleTake.Jobs.Contract Namespace


IJobManager.GetActionStatus Method

IJobManagerGetActionStatus Method
Gets the status of an action requested on the job.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
ActivityStatusEntry GetActionStatus(
    ActivityToken taskToken
)
Function GetActionStatus (
    taskToken As ActivityToken
) As ActivityStatusEntry
ActivityStatusEntry^ GetActionStatus(
    ActivityToken^ taskToken
)
function GetActionStatus(taskToken);

Parameters

taskToken
Type: ActivityToken
The token that identifies the action request.

Return Value

Type: ActivityStatusEntry
A JobAction that represents the status of the requested action.
See Also

Reference

IJobManager Interface
DoubleTake.Jobs.Contract Namespace


IJobManager.GetFixJobOptionsStatus Method

IJobManagerGetFixJobOptionsStatus Method
Gets the status of the fixing operation.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
FixJobOptionsTaskStatus GetFixJobOptionsStatus(
    ActivityToken taskToken
)
Function GetFixJobOptionsStatus (
    taskToken As ActivityToken
) As FixJobOptionsTaskStatus
FixJobOptionsTaskStatus^ GetFixJobOptionsStatus(
    ActivityToken^ taskToken
)
function GetFixJobOptionsStatus(taskToken);

Parameters

taskToken
Type: ActivityToken
The token that identifies the fixing operation

Return Value

Type: FixJobOptionsTaskStatus
A FixJobOptionsTaskStatus that indicates the progress and result of the fixing operation.
See Also

Reference

IJobManager Interface
DoubleTake.Jobs.Contract Namespace


IJobManager.GetJob Method

IJobManagerGetJob Method
Gets a particular job on the server.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
JobInfo GetJob(
    Guid jobId
)
Function GetJob (
    jobId As Guid
) As JobInfo
JobInfo^ GetJob(
    Guid jobId
)
function GetJob(jobId);

Parameters

jobId
Type: SystemGuid
The job id.

Return Value

Type: JobInfo
A JobInfo that represents the job on the server.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | There is no job whose id matches jobId.
See Also

Reference

IJobManager Interface
DoubleTake.Jobs.Contract Namespace


IJobManager.GetJobDisplayInfo Method

IJobManagerGetJobDisplayInfo Method
Gets all information the console displays consistently

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
JobDisplayInfo[] GetJobDisplayInfo()
Function GetJobDisplayInfo As JobDisplayInfo()
array<JobDisplayInfo^>^ GetJobDisplayInfo()
function GetJobDisplayInfo();

Return Value

Type: JobDisplayInfo
An array of JobDisplayInfo that represents the jobs on the server.
See Also

Reference

IJobManager Interface
DoubleTake.Jobs.Contract Namespace


IJobManager.GetJobs Method

IJobManagerGetJobs Method
Gets all jobs on a server.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
JobInfo[] GetJobs()
Function GetJobs As JobInfo()
array<JobInfo^>^ GetJobs()
function GetJobs();

Return Value

Type: JobInfo
An array of JobInfo that represents the jobs on the server.
See Also

Reference

IJobManager Interface
DoubleTake.Jobs.Contract Namespace


IJobManager.GetLogMessages Method

IJobManagerGetLogMessages Method
Gets the messages in the job text log file.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
IEnumerable<LogMessage> GetLogMessages(
    Guid jobId,
    int chunkSize,
    string source,
    int hash,
    DateTimeOffset lastTimestamp
)
Function GetLogMessages (
    jobId As Guid,
    chunkSize As Integer,
    source As String,
    hash As Integer,
    lastTimestamp As DateTimeOffset
) As IEnumerable(Of LogMessage)
IEnumerable<LogMessage^>^ GetLogMessages(
    Guid jobId,
    int chunkSize,
    String^ source,
    int hash,
    DateTimeOffset lastTimestamp
)
function GetLogMessages(jobId, chunkSize, source, hash, lastTimestamp);

Parameters

jobId
Type: SystemGuid
The job id.
chunkSize
Type: SystemInt32
Number of messages to get.
source
Type: SystemString
The log source.
hash
Type: SystemInt32
The hash of the message from where to start getting the messages.
lastTimestamp
Type: SystemDateTimeOffset
The timestamp from where to start getting the messages.

Return Value

Type: IEnumerable LogMessage
An array of LogMessage representing the messages in the job text log file.
See Also

Reference

IJobManager Interface
DoubleTake.Jobs.Contract Namespace


IJobManager.GetQualificationResults Method

IJobManagerGetQualificationResults Method
Gets the qualification results for job. The qualification results express the potential option that can be set for a job.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
JobQualificationResults GetQualificationResults(
    Guid jobId
)
Function GetQualificationResults (
    jobId As Guid
) As JobQualificationResults
JobQualificationResults^ GetQualificationResults(
    Guid jobId
)
function GetQualificationResults(jobId);

Parameters

jobId
Type: SystemGuid
The job id.

Return Value

Type: JobQualificationResults
A JobQualificationResults that represents the potential options for a job.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | There is no job whose id matches jobId.
See Also

Reference

IJobManager Interface
DoubleTake.Jobs.Contract Namespace


IJobManager.GetRecommendedFailbackOptions Method

IJobManagerGetRecommendedFailbackOptions Method
Gets the recommended failback options.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
RecommendedFailbackOptions GetRecommendedFailbackOptions(
    Guid jobId
)
Function GetRecommendedFailbackOptions (
    jobId As Guid
) As RecommendedFailbackOptions
RecommendedFailbackOptions^ GetRecommendedFailbackOptions(
    Guid jobId
)
function GetRecommendedFailbackOptions(jobId);

Parameters

jobId
Type: SystemGuid
The job id.

Return Value

Type: RecommendedFailbackOptions
A RecommendedFailbackOptions instance that includes the recommended failback options and other potential values for those options.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | There is no job whose id matches jobId.
See Also

Reference

IJobManager Interface
DoubleTake.Jobs.Contract Namespace


IJobManager.GetRecommendedFailoverOptions Method

IJobManagerGetRecommendedFailoverOptions Method
Gets the recommended failover options.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
RecommendedFailoverOptions GetRecommendedFailoverOptions(
    Guid jobId
)
Function GetRecommendedFailoverOptions (
    jobId As Guid
) As RecommendedFailoverOptions
RecommendedFailoverOptions^ GetRecommendedFailoverOptions(
    Guid jobId
)
function GetRecommendedFailoverOptions(jobId);

Parameters

jobId
Type: SystemGuid
The job id.

Return Value

Type: RecommendedFailoverOptions
A RecommendedFailoverOptions instance that includes the recommended failover options and other potential values for those options.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | There is no job whose id matches jobId.
See Also

Reference

IJobManager Interface
DoubleTake.Jobs.Contract Namespace


IJobManager.GetRecommendedRestoreOptions Method

IJobManagerGetRecommendedRestoreOptions Method
Gets the recommended restore options.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
RecommendedRestoreOptions GetRecommendedRestoreOptions(
    Guid jobId,
    JobCredentials credentials
)
Function GetRecommendedRestoreOptions (
    jobId As Guid,
    credentials As JobCredentials
) As RecommendedRestoreOptions
RecommendedRestoreOptions^ GetRecommendedRestoreOptions(
    Guid jobId,
    JobCredentials^ credentials
)
function GetRecommendedRestoreOptions(jobId, credentials);

Parameters

jobId
Type: SystemGuid
The job id.
credentials
Type: DoubleTake.Jobs.ContractJobCredentials
The credentials.

Return Value

Type: RecommendedRestoreOptions
A RecommendedRestoreOptions instance that includes the recommended restore options and other potential values for those options.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | There is no job whose id matches jobId.
See Also

Reference

IJobManager Interface
DoubleTake.Jobs.Contract Namespace


IJobManager.GetSnapshots Method

IJobManagerGetSnapshots Method

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
SnapshotEntry[] GetSnapshots(
    Guid jobId,
    Guid connectionId
)
Function GetSnapshots (
    jobId As Guid,
    connectionId As Guid
) As SnapshotEntry()
array<SnapshotEntry^>^ GetSnapshots(
    Guid jobId,
    Guid connectionId
)
function GetSnapshots(jobId, connectionId);

Parameters

jobId
Type: SystemGuid
connectionId
Type: SystemGuid

Return Value

Type: SnapshotEntry
See Also

Reference

IJobManager Interface
DoubleTake.Jobs.Contract Namespace


IJobManager.GetVerificationStatus Method

IJobManagerGetVerificationStatus Method
Gets the status of the verification task.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
VerificationTaskStatus GetVerificationStatus(
    ActivityToken taskToken
)
Function GetVerificationStatus (
    taskToken As ActivityToken
) As VerificationTaskStatus
VerificationTaskStatus^ GetVerificationStatus(
    ActivityToken^ taskToken
)
function GetVerificationStatus(taskToken);

Parameters

taskToken
Type: ActivityToken
The token that identifies the verification task.

Return Value

Type: VerificationTaskStatus
A VerificationTaskStatus that indicates the progress and result of the verification task.
See Also

Reference

IJobManager Interface
DoubleTake.Jobs.Contract Namespace


IJobManager.Pause Method

IJobManagerPause Method
Pauses a job.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
ActivityToken Pause(
    Guid jobId
)
Function Pause (
    jobId As Guid
) As ActivityToken
ActivityToken^ Pause(
    Guid jobId
)
function Pause(jobId);

Parameters

jobId
Type: SystemGuid
The job id.

Return Value

Type: ActivityToken
A ActionToken that can be used to get the status of the action.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | There is no job whose id matches jobId.
See Also

Reference

IJobManager Interface
DoubleTake.Jobs.Contract Namespace


IJobManager.PersistShares Method

IJobManagerPersistShares Method

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
ActivityToken PersistShares(
    Guid jobId,
    IEnumerable<Share> shares
)
Function PersistShares (
    jobId As Guid,
    shares As IEnumerable(Of Share)
) As ActivityToken
ActivityToken^ PersistShares(
    Guid jobId,
    IEnumerable<Share^>^ shares
)
function PersistShares(jobId, shares);

Parameters

jobId
Type: SystemGuid
shares
Type: System.Collections.GenericIEnumerable Share

Return Value

Type: ActivityToken
See Also

Reference

IJobManager Interface
DoubleTake.Jobs.Contract Namespace


IJobManager.Restore Method

IJobManagerRestore Method
Restores a job.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
ActivityToken Restore(
    Guid jobId,
    RestoreOptions parameters
)
Function Restore (
    jobId As Guid,
    parameters As RestoreOptions
) As ActivityToken
ActivityToken^ Restore(
    Guid jobId,
    RestoreOptions^ parameters
)
function Restore(jobId, parameters);

Parameters

jobId
Type: SystemGuid
The job id.
parameters
Type: DoubleTake.Jobs.ContractRestoreOptions
The parameters.

Return Value

Type: ActivityToken
A ActionToken that can be used to get the status of the action.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | There is no job whose id matches jobId.
See Also

Reference

IJobManager Interface
DoubleTake.Jobs.Contract Namespace


IJobManager.Reverse Method

IJobManagerReverse Method
Reverses a job.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
ActivityToken Reverse(
    Guid jobId
)
Function Reverse (
    jobId As Guid
) As ActivityToken
ActivityToken^ Reverse(
    Guid jobId
)
function Reverse(jobId);

Parameters

jobId
Type: SystemGuid
The job id.

Return Value

Type: ActivityToken
A ActionToken that can be used to get the status of the action.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | There is no job whose id matches jobId.
See Also

Reference

IJobManager Interface
DoubleTake.Jobs.Contract Namespace


IJobManager.Start Method

IJobManagerStart Method
Starts a job.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
ActivityToken Start(
    Guid jobId
)
Function Start (
    jobId As Guid
) As ActivityToken
ActivityToken^ Start(
    Guid jobId
)
function Start(jobId);

Parameters

jobId
Type: SystemGuid
The job id.

Return Value

Type: ActivityToken
A ActionToken that can be used to get the status of the action.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | There is no job whose id matches jobId.
See Also

Reference

IJobManager Interface
DoubleTake.Jobs.Contract Namespace


IJobManager.Stop Method

IJobManagerStop Method
Stops a job.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
ActivityToken Stop(
    Guid jobId
)
Function Stop (
    jobId As Guid
) As ActivityToken
ActivityToken^ Stop(
    Guid jobId
)
function Stop(jobId);

Parameters

jobId
Type: SystemGuid
The job id.

Return Value

Type: ActivityToken
A ActionToken that can be used to get the status of the action.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | There is no job whose id matches jobId.
See Also

Reference

IJobManager Interface
DoubleTake.Jobs.Contract Namespace


IJobManager.TakeSnapshot Method

IJobManagerTakeSnapshot Method

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
ActivityToken TakeSnapshot(
    Guid jobId,
    Guid connectionId
)
Function TakeSnapshot (
    jobId As Guid,
    connectionId As Guid
) As ActivityToken
ActivityToken^ TakeSnapshot(
    Guid jobId,
    Guid connectionId
)
function TakeSnapshot(jobId, connectionId);

Parameters

jobId
Type: SystemGuid
connectionId
Type: SystemGuid

Return Value

Type: ActivityToken
See Also

Reference

IJobManager Interface
DoubleTake.Jobs.Contract Namespace


IJobManager.UndoFailover Method

IJobManagerUndoFailover Method
Undoes the failover of a job.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
ActivityToken UndoFailover(
    Guid jobId
)
Function UndoFailover (
    jobId As Guid
) As ActivityToken
ActivityToken^ UndoFailover(
    Guid jobId
)
function UndoFailover(jobId);

Parameters

jobId
Type: SystemGuid
The job id.

Return Value

Type: ActivityToken
A ActionToken that can be used to get the status of the action.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | There is no job whose id matches jobId.
See Also

Reference

IJobManager Interface
DoubleTake.Jobs.Contract Namespace


IJobManager.UpdateCredentials Method

IJobManagerUpdateCredentials Method
Update the credentials a job is using to connect to the servers involved.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
ActivityToken UpdateCredentials(
    Guid jobId,
    JobCredentials credentials
)
Function UpdateCredentials (
    jobId As Guid,
    credentials As JobCredentials
) As ActivityToken
ActivityToken^ UpdateCredentials(
    Guid jobId,
    JobCredentials^ credentials
)
function UpdateCredentials(jobId, credentials);

Parameters

jobId
Type: SystemGuid
The job id.
credentials
Type: DoubleTake.Jobs.ContractJobCredentials
The updated credentials.

Return Value

Type: ActivityToken
A ActionToken that can be used to get the status of the action.
See Also

Reference

IJobManager Interface
DoubleTake.Jobs.Contract Namespace


IJobManager.UpdateRecommendedJobOptions Method

IJobManagerUpdateRecommendedJobOptions Method
Updates the recommended job options.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
RecommendedJobOptions UpdateRecommendedJobOptions(
    Guid jobId,
    JobOptions candidateOptions,
    Workload newWorkload
)
Function UpdateRecommendedJobOptions (
    jobId As Guid,
    candidateOptions As JobOptions,
    newWorkload As Workload
) As RecommendedJobOptions
RecommendedJobOptions^ UpdateRecommendedJobOptions(
    Guid jobId,
    JobOptions^ candidateOptions,
    Workload^ newWorkload
)
function UpdateRecommendedJobOptions(jobId, candidateOptions, newWorkload);

Parameters

jobId
Type: SystemGuid
The job id.
candidateOptions
Type: DoubleTake.Jobs.ContractJobOptions
The candidate options.
newWorkload
Type: DoubleTake.Common.ContractWorkload
The new workload.

Return Value

Type: RecommendedJobOptions
See Also

Reference

IJobManager Interface
DoubleTake.Jobs.Contract Namespace


IJobManager.VerifyFailbackOptions Method

IJobManagerVerifyFailbackOptions Method
Verifies the failback options.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
ActivityToken VerifyFailbackOptions(
    Guid jobId,
    FailbackOptions failbackOptions
)
Function VerifyFailbackOptions (
    jobId As Guid,
    failbackOptions As FailbackOptions
) As ActivityToken
ActivityToken^ VerifyFailbackOptions(
    Guid jobId,
    FailbackOptions^ failbackOptions
)
function VerifyFailbackOptions(jobId, failbackOptions);

Parameters

jobId
Type: SystemGuid
The job id.
failbackOptions
Type: DoubleTake.Jobs.ContractFailbackOptions
The failback options.

Return Value

Type: ActivityToken
A ActionToken that can be used to get the status of the action.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | There is no job whose id matches jobId.
See Also

Reference

IJobManager Interface
DoubleTake.Jobs.Contract Namespace


IJobManager.VerifyFailoverOptions Method

IJobManagerVerifyFailoverOptions Method
Verifies the failover options.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
ActivityToken VerifyFailoverOptions(
    Guid jobId,
    FailoverOptions failoverOptions
)
Function VerifyFailoverOptions (
    jobId As Guid,
    failoverOptions As FailoverOptions
) As ActivityToken
ActivityToken^ VerifyFailoverOptions(
    Guid jobId,
    FailoverOptions^ failoverOptions
)
function VerifyFailoverOptions(jobId, failoverOptions);

Parameters

jobId
Type: SystemGuid
The job id.
failoverOptions
Type: DoubleTake.Jobs.ContractFailoverOptions
The failover options.

Return Value

Type: ActivityToken
A ActionToken that can be used to get the status of the action.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | There is no job whose id matches jobId.
See Also

Reference

IJobManager Interface
DoubleTake.Jobs.Contract Namespace


IJobManager.VerifyJobOptions Method

IJobManagerVerifyJobOptions Method
Verifies the job options.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
ActivityToken VerifyJobOptions(
    Guid jobId,
    JobOptions jobOptions
)
Function VerifyJobOptions (
    jobId As Guid,
    jobOptions As JobOptions
) As ActivityToken
ActivityToken^ VerifyJobOptions(
    Guid jobId,
    JobOptions^ jobOptions
)
function VerifyJobOptions(jobId, jobOptions);

Parameters

jobId
Type: SystemGuid
The job id.
jobOptions
Type: DoubleTake.Jobs.ContractJobOptions
The job options.

Return Value

Type: ActivityToken
A ActionToken that can be used to get the status of the action.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | There is no job whose id matches jobId.
See Also

Reference

IJobManager Interface
DoubleTake.Jobs.Contract Namespace


IJobManager.VerifyRestoreOptions Method

IJobManagerVerifyRestoreOptions Method
Verifies the restore options.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
ActivityToken VerifyRestoreOptions(
    Guid jobId,
    RestoreOptions restoreOptions
)
Function VerifyRestoreOptions (
    jobId As Guid,
    restoreOptions As RestoreOptions
) As ActivityToken
ActivityToken^ VerifyRestoreOptions(
    Guid jobId,
    RestoreOptions^ restoreOptions
)
function VerifyRestoreOptions(jobId, restoreOptions);

Parameters

jobId
Type: SystemGuid
The job id.
restoreOptions
Type: DoubleTake.Jobs.ContractRestoreOptions
The restore options.

Return Value

Type: ActivityToken
A ActionToken that can be used to get the status of the action.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | There is no job whose id matches jobId.
See Also

Reference

IJobManager Interface
DoubleTake.Jobs.Contract Namespace


IJobManagerPrivate Interface

IJobManagerPrivate Interface
Private JobManager interface only to be used internally.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public interface IJobManagerPrivate
Public Interface IJobManagerPrivate
public interface class IJobManagerPrivate
DoubleTake.Jobs.Contract.IJobManagerPrivate = function();
DoubleTake.Jobs.Contract.IJobManagerPrivate.createInterface('DoubleTake.Jobs.Contract.IJobManagerPrivate');

The IJobManagerPrivate type exposes the following members.

Methods
 | Name | Description
Public method | CreateFromExistingJob | Creates a job using the provided job info.
Public method | SetCredentials |
Public method | StartClusteredJob |
Public method | TransferUsage | Transfers usage from one server to another
Public method | UpdateCredentials |
Public method | WriteDiagnosticToDisk | Causes service to dump diagnostic information to disk.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


IJobManagerPrivate Methods

IJobManagerPrivate Methods

The IJobManagerPrivate type exposes the following members.

Methods
 | Name | Description
Public method | CreateFromExistingJob | Creates a job using the provided job info.
Public method | SetCredentials |
Public method | StartClusteredJob |
Public method | TransferUsage | Transfers usage from one server to another
Public method | UpdateCredentials |
Public method | WriteDiagnosticToDisk | Causes service to dump diagnostic information to disk.
Top
See Also

Reference

IJobManagerPrivate Interface
DoubleTake.Jobs.Contract Namespace


IJobManagerPrivate.CreateFromExistingJob Method

IJobManagerPrivateCreateFromExistingJob Method
Creates a job using the provided job info.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
void CreateFromExistingJob(
    JobInfo info,
    JobCredentials credentials
)
Sub CreateFromExistingJob (
    info As JobInfo,
    credentials As JobCredentials
)
void CreateFromExistingJob(
    JobInfo^ info,
    JobCredentials^ credentials
)
function CreateFromExistingJob(info, credentials);

Parameters

info
Type: DoubleTake.Jobs.ContractJobInfo
The job info.
credentials
Type: DoubleTake.Jobs.ContractJobCredentials
The job credentials.
See Also

Reference

IJobManagerPrivate Interface
DoubleTake.Jobs.Contract Namespace


IJobManagerPrivate.SetCredentials Method

IJobManagerPrivateSetCredentials Method

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
void SetCredentials(
    Guid Id,
    JobCredentials credentials
)
Sub SetCredentials (
    Id As Guid,
    credentials As JobCredentials
)
void SetCredentials(
    Guid Id,
    JobCredentials^ credentials
)
function SetCredentials(Id, credentials);

Parameters

Id
Type: SystemGuid
credentials
Type: DoubleTake.Jobs.ContractJobCredentials
See Also

Reference

IJobManagerPrivate Interface
DoubleTake.Jobs.Contract Namespace


IJobManagerPrivate.StartClusteredJob Method

IJobManagerPrivateStartClusteredJob Method

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
void StartClusteredJob(
    string jobFile
)
Sub StartClusteredJob (
    jobFile As String
)
void StartClusteredJob(
    String^ jobFile
)
function StartClusteredJob(jobFile);

Parameters

jobFile
Type: SystemString
See Also

Reference

IJobManagerPrivate Interface
DoubleTake.Jobs.Contract Namespace


IJobManagerPrivate.TransferUsage Method

IJobManagerPrivateTransferUsage Method
Transfers usage from one server to another

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
void TransferUsage(
    UsageData usageData
)
Sub TransferUsage (
    usageData As UsageData
)
void TransferUsage(
    UsageData^ usageData
)
function TransferUsage(usageData);

Parameters

usageData
Type: DoubleTake.Dtmu.ContractUsageData
See Also

Reference

IJobManagerPrivate Interface
DoubleTake.Jobs.Contract Namespace


IJobManagerPrivate.UpdateCredentials Method

IJobManagerPrivateUpdateCredentials Method

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
void UpdateCredentials(
    Guid Id,
    JobCredentials credentials,
    JobOptions jobOptions
)
Sub UpdateCredentials (
    Id As Guid,
    credentials As JobCredentials,
    jobOptions As JobOptions
)
void UpdateCredentials(
    Guid Id,
    JobCredentials^ credentials,
    JobOptions^ jobOptions
)
function UpdateCredentials(Id, credentials, jobOptions);

Parameters

Id
Type: SystemGuid
credentials
Type: DoubleTake.Jobs.ContractJobCredentials
jobOptions
Type: DoubleTake.Jobs.ContractJobOptions
See Also

Reference

IJobManagerPrivate Interface
DoubleTake.Jobs.Contract Namespace


IJobManagerPrivate.WriteDiagnosticToDisk Method

IJobManagerPrivateWriteDiagnosticToDisk Method
Causes service to dump diagnostic information to disk.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
void WriteDiagnosticToDisk(
    string[] diagnosticName
)
Sub WriteDiagnosticToDisk (
    diagnosticName As String()
)
void WriteDiagnosticToDisk(
    array<String^>^ diagnosticName
)
function WriteDiagnosticToDisk(diagnosticName);

Parameters

diagnosticName
Type: SystemString
Array of diagnostic objects to write to disk.
See Also

Reference

IJobManagerPrivate Interface
DoubleTake.Jobs.Contract Namespace


ImageProtectionOptions Class

ImageProtectionOptions Class
Represents options for working with the image protection feature of a job.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractImageProtectionOptions

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class ImageProtectionOptions : IExtensibleDataObject
Public Class ImageProtectionOptions
    Implements IExtensibleDataObject
public ref class ImageProtectionOptions : IExtensibleDataObject
DoubleTake.Jobs.Contract.ImageProtectionOptions = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.ImageProtectionOptions',
    null,
    IExtensibleDataObject);

The ImageProtectionOptions type exposes the following members.

Constructors
 | Name | Description
Public method | ImageProtectionOptions | Initializes a new instance of the ImageProtectionOptions class
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | ImageId | This value is the unique ID of the image that contains the protected data from the source.
Public property | ImageName | This value is the name of the image that contains the protected data from the source.
Public property | VhdInfo | This value represents information about a virtual hard disk used to store an image.
Public property | VhdsToDeleteOnRemove | This value is a list of .vhd files to delete from disk when the corresponding protected volume is has been removed from the image. This value is specified by volume letter.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


ImageProtectionOptions Constructor

ImageProtectionOptions Constructor
Initializes a new instance of the ImageProtectionOptions class

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ImageProtectionOptions()
Public Sub New
public:
ImageProtectionOptions()
DoubleTake.Jobs.Contract.ImageProtectionOptions = function();
See Also

Reference

ImageProtectionOptions Class
DoubleTake.Jobs.Contract Namespace


ImageProtectionOptions Properties

ImageProtectionOptions Properties

The ImageProtectionOptions type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | ImageId | This value is the unique ID of the image that contains the protected data from the source.
Public property | ImageName | This value is the name of the image that contains the protected data from the source.
Public property | VhdInfo | This value represents information about a virtual hard disk used to store an image.
Public property | VhdsToDeleteOnRemove | This value is a list of .vhd files to delete from disk when the corresponding protected volume is has been removed from the image. This value is specified by volume letter.
Top
See Also

Reference

ImageProtectionOptions Class
DoubleTake.Jobs.Contract Namespace


ImageProtectionOptions.ExtensionData Property

ImageProtectionOptionsExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

ImageProtectionOptions Class
DoubleTake.Jobs.Contract Namespace


ImageProtectionOptions.ImageId Property

ImageProtectionOptionsImageId Property
This value is the unique ID of the image that contains the protected data from the source.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Guid ImageId { get; set; }
Public Property ImageId As Guid
    Get
    Set
public:
property Guid ImageId {
    Guid get ();
    void set (Guid value);
}
function get_ImageId();
function set_ImageId(value);

Property Value

Type: Guid
See Also

Reference

ImageProtectionOptions Class
DoubleTake.Jobs.Contract Namespace


ImageProtectionOptions.ImageName Property

ImageProtectionOptionsImageName Property
This value is the name of the image that contains the protected data from the source.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string ImageName { get; set; }
Public Property ImageName As String
    Get
    Set
public:
property String^ ImageName {
    String^ get ();
    void set (String^ value);
}
function get_ImageName();
function set_ImageName(value);

Property Value

Type: String
See Also

Reference

ImageProtectionOptions Class
DoubleTake.Jobs.Contract Namespace


ImageProtectionOptions.VhdInfo Property

ImageProtectionOptionsVhdInfo Property
This value represents information about a virtual hard disk used to store an image.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ImageVhdInfo[] VhdInfo { get; set; }
Public Property VhdInfo As ImageVhdInfo()
    Get
    Set
public:
property array<ImageVhdInfo^>^ VhdInfo {
    array<ImageVhdInfo^>^ get ();
    void set (array<ImageVhdInfo^>^ value);
}
function get_VhdInfo();
function set_VhdInfo(value);

Property Value

Type: ImageVhdInfo
See Also

Reference

ImageProtectionOptions Class
DoubleTake.Jobs.Contract Namespace


ImageProtectionOptions.VhdsToDeleteOnRemove Property

ImageProtectionOptionsVhdsToDeleteOnRemove Property
This value is a list of .vhd files to delete from disk when the corresponding protected volume is has been removed from the image. This value is specified by volume letter.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public IEnumerable<string> VhdsToDeleteOnRemove { get; set; }
Public Property VhdsToDeleteOnRemove As IEnumerable(Of String)
    Get
    Set
public:
property IEnumerable<String^>^ VhdsToDeleteOnRemove {
    IEnumerable<String^>^ get ();
    void set (IEnumerable<String^>^ value);
}
function get_VhdsToDeleteOnRemove();
function set_VhdsToDeleteOnRemove(value);

Property Value

Type: IEnumerable String
See Also

Reference

ImageProtectionOptions Class
DoubleTake.Jobs.Contract Namespace


ImageRecoveryOptions Class

ImageRecoveryOptions Class
Represents options for working with the image recovery feature of a job.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractImageRecoveryOptions

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class ImageRecoveryOptions : IExtensibleDataObject
Public Class ImageRecoveryOptions
    Implements IExtensibleDataObject
public ref class ImageRecoveryOptions : IExtensibleDataObject
DoubleTake.Jobs.Contract.ImageRecoveryOptions = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.ImageRecoveryOptions',
    null,
    IExtensibleDataObject);

The ImageRecoveryOptions type exposes the following members.

Constructors
 | Name | Description
Public method | ImageRecoveryOptions | Initializes a new instance of the ImageRecoveryOptions class
Top
Properties
 | Name | Description
Public property | AdditionalStagingFolders | This value is the additional folders that should be staged on the target server.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | ImageId | This value is the unique ID of the image that will be recovered.
Public property | ImageRecoveryDataLocation | This value is the location of the original source's protected data.
Public property | ShutdownSourceServer | This value is true if the source server should be shut down during cutover; otherwise, it is false.
Public property | UserInitiatedCutover | This value is true if the user is required to initiate cutover; otherwise, it is false.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


ImageRecoveryOptions Constructor

ImageRecoveryOptions Constructor
Initializes a new instance of the ImageRecoveryOptions class

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ImageRecoveryOptions()
Public Sub New
public:
ImageRecoveryOptions()
DoubleTake.Jobs.Contract.ImageRecoveryOptions = function();
See Also

Reference

ImageRecoveryOptions Class
DoubleTake.Jobs.Contract Namespace


ImageRecoveryOptions Properties

ImageRecoveryOptions Properties

The ImageRecoveryOptions type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalStagingFolders | This value is the additional folders that should be staged on the target server.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | ImageId | This value is the unique ID of the image that will be recovered.
Public property | ImageRecoveryDataLocation | This value is the location of the original source's protected data.
Public property | ShutdownSourceServer | This value is true if the source server should be shut down during cutover; otherwise, it is false.
Public property | UserInitiatedCutover | This value is true if the user is required to initiate cutover; otherwise, it is false.
Top
See Also

Reference

ImageRecoveryOptions Class
DoubleTake.Jobs.Contract Namespace


ImageRecoveryOptions.AdditionalStagingFolders Property

ImageRecoveryOptionsAdditionalStagingFolders Property
This value is the additional folders that should be staged on the target server.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string[] AdditionalStagingFolders { get; set; }
Public Property AdditionalStagingFolders As String()
    Get
    Set
public:
property array<String^>^ AdditionalStagingFolders {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
function get_AdditionalStagingFolders();
function set_AdditionalStagingFolders(value);

Property Value

Type: String
The additional folders that should be staged on the target server.
See Also

Reference

ImageRecoveryOptions Class
DoubleTake.Jobs.Contract Namespace


ImageRecoveryOptions.ExtensionData Property

ImageRecoveryOptionsExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

ImageRecoveryOptions Class
DoubleTake.Jobs.Contract Namespace


ImageRecoveryOptions.ImageId Property

ImageRecoveryOptionsImageId Property
This value is the unique ID of the image that will be recovered.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Guid ImageId { get; set; }
Public Property ImageId As Guid
    Get
    Set
public:
property Guid ImageId {
    Guid get ();
    void set (Guid value);
}
function get_ImageId();
function set_ImageId(value);

Property Value

Type: Guid
See Also

Reference

ImageRecoveryOptions Class
DoubleTake.Jobs.Contract Namespace


ImageRecoveryOptions.ImageRecoveryDataLocation Property

ImageRecoveryOptionsImageRecoveryDataLocation Property
This value is the location of the original source's protected data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string ImageRecoveryDataLocation { get; set; }
Public Property ImageRecoveryDataLocation As String
    Get
    Set
public:
property String^ ImageRecoveryDataLocation {
    String^ get ();
    void set (String^ value);
}
function get_ImageRecoveryDataLocation();
function set_ImageRecoveryDataLocation(value);

Property Value

Type: String
See Also

Reference

ImageRecoveryOptions Class
DoubleTake.Jobs.Contract Namespace


ImageRecoveryOptions.ShutdownSourceServer Property

ImageRecoveryOptionsShutdownSourceServer Property
This value is true if the source server should be shut down during cutover; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool ShutdownSourceServer { get; set; }
Public Property ShutdownSourceServer As Boolean
    Get
    Set
public:
property bool ShutdownSourceServer {
    bool get ();
    void set (bool value);
}
function get_ShutdownSourceServer();
function set_ShutdownSourceServer(value);

Property Value

Type: Boolean
if the source server should be shut down during cutover; otherwise, .
See Also

Reference

ImageRecoveryOptions Class
DoubleTake.Jobs.Contract Namespace


ImageRecoveryOptions.UserInitiatedCutover Property

ImageRecoveryOptionsUserInitiatedCutover Property
This value is true if the user is required to initiate cutover; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool UserInitiatedCutover { get; set; }
Public Property UserInitiatedCutover As Boolean
    Get
    Set
public:
property bool UserInitiatedCutover {
    bool get ();
    void set (bool value);
}
function get_UserInitiatedCutover();
function set_UserInitiatedCutover(value);

Property Value

Type: Boolean
if the user is required to initiate cutover; otherwise, .
See Also

Reference

ImageRecoveryOptions Class
DoubleTake.Jobs.Contract Namespace


JobAction Class

JobAction Class
Represents an action recently reported by a job.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractJobAction

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class JobAction : IExtensibleDataObject
Public Class JobAction
    Implements IExtensibleDataObject
public ref class JobAction : IExtensibleDataObject
DoubleTake.Jobs.Contract.JobAction = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.JobAction',
    null,
    IExtensibleDataObject);

The JobAction type exposes the following members.

Constructors
 | Name | Description
Public method | JobAction | Initializes a new instance of the JobAction class
Top
Properties
 | Name | Description
Public property | Duration | This value is the duration of the action.
Public property | ErrorCode | This value is the error code associated with the action.
Public property | ExceptionMessage | This value is a message from the underlying exception.The message stored in this property should not be displayed in the user interface, as it may not be available in the language used by the interface. This property should only be used for internal troubleshooting, and as a measure of last resort in the event of a completely unexpected error.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Id | This value is the unique ID of the action.
Public property | MessageFormatParameters | This value is the message format parameters.
Public property | MessageId | This value is the message ID for the action. This value can be used to look up a message associated with this action.
Public property | RequestingUserName | This value is the name of the user that requested the action.
Public property | Status | This value represents the status of the action.
Public property | Timestamp | This value is the time when the action occurred.
Public property | TitleFormatParameters | This value is the title format parameters for the action.
Public property | TitleId | This value is the title ID for the action. This value can be used to look up a title associated with this action.
Top
Remarks
Naturally, error information is logged for a job in the Windows event log and other locations. This class represents an action or error in a format that is convenient for displaying in the user interface.
See Also

Reference

DoubleTake.Jobs.Contract Namespace


JobAction Constructor

JobAction Constructor
Initializes a new instance of the JobAction class

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public JobAction()
Public Sub New
public:
JobAction()
DoubleTake.Jobs.Contract.JobAction = function();
See Also

Reference

JobAction Class
DoubleTake.Jobs.Contract Namespace


JobAction Properties

JobAction Properties

The JobAction type exposes the following members.

Properties
 | Name | Description
Public property | Duration | This value is the duration of the action.
Public property | ErrorCode | This value is the error code associated with the action.
Public property | ExceptionMessage | This value is a message from the underlying exception.The message stored in this property should not be displayed in the user interface, as it may not be available in the language used by the interface. This property should only be used for internal troubleshooting, and as a measure of last resort in the event of a completely unexpected error.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Id | This value is the unique ID of the action.
Public property | MessageFormatParameters | This value is the message format parameters.
Public property | MessageId | This value is the message ID for the action. This value can be used to look up a message associated with this action.
Public property | RequestingUserName | This value is the name of the user that requested the action.
Public property | Status | This value represents the status of the action.
Public property | Timestamp | This value is the time when the action occurred.
Public property | TitleFormatParameters | This value is the title format parameters for the action.
Public property | TitleId | This value is the title ID for the action. This value can be used to look up a title associated with this action.
Top
See Also

Reference

JobAction Class
DoubleTake.Jobs.Contract Namespace


JobAction.Duration Property

JobActionDuration Property
This value is the duration of the action.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public TimeSpan Duration { get; set; }
Public Property Duration As TimeSpan
    Get
    Set
public:
property TimeSpan Duration {
    TimeSpan get ();
    void set (TimeSpan value);
}
function get_Duration();
function set_Duration(value);

Property Value

Type: TimeSpan
The duration of action.
See Also

Reference

JobAction Class
DoubleTake.Jobs.Contract Namespace


JobAction.ErrorCode Property

JobActionErrorCode Property
This value is the error code associated with the action.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int ErrorCode { get; set; }
Public Property ErrorCode As Integer
    Get
    Set
public:
property int ErrorCode {
    int get ();
    void set (int value);
}
function get_ErrorCode();
function set_ErrorCode(value);

Property Value

Type: Int32
The error code.
See Also

Reference

JobAction Class
DoubleTake.Jobs.Contract Namespace


JobAction.ExceptionMessage Property

JobActionExceptionMessage Property
This value is a message from the underlying exception.The message stored in this property should not be displayed in the user interface, as it may not be available in the language used by the interface. This property should only be used for internal troubleshooting, and as a measure of last resort in the event of a completely unexpected error.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string ExceptionMessage { get; set; }
Public Property ExceptionMessage As String
    Get
    Set
public:
property String^ ExceptionMessage {
    String^ get ();
    void set (String^ value);
}
function get_ExceptionMessage();
function set_ExceptionMessage(value);

Property Value

Type: String
The exception message.
Remarks
Job implementations should define specific messages for all known errors that can occur during the lifetime of a job. The message stored in this property should not be displayed in the user interface, as it may not be available in the language used by the console. This property should only be used for internal troubleshooting, and as measure of last resort in the event of an completely unexpected error.
See Also

Reference

JobAction Class
DoubleTake.Jobs.Contract Namespace


JobAction.ExtensionData Property

JobActionExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

JobAction Class
DoubleTake.Jobs.Contract Namespace


JobAction.Id Property

JobActionId Property
This value is the unique ID of the action.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Guid Id { get; set; }
Public Property Id As Guid
    Get
    Set
public:
property Guid Id {
    Guid get ();
    void set (Guid value);
}
function get_Id();
function set_Id(value);

Property Value

Type: Guid
The unique identifier of this action.
See Also

Reference

JobAction Class
DoubleTake.Jobs.Contract Namespace


JobAction.MessageFormatParameters Property

JobActionMessageFormatParameters Property
This value is the message format parameters.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string[] MessageFormatParameters { get; set; }
Public Property MessageFormatParameters As String()
    Get
    Set
public:
property array<String^>^ MessageFormatParameters {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
function get_MessageFormatParameters();
function set_MessageFormatParameters(value);

Property Value

Type: String
The message format parameters for this action.
See Also

Reference

JobAction Class
DoubleTake.Jobs.Contract Namespace


JobAction.MessageId Property

JobActionMessageId Property
This value is the message ID for the action. This value can be used to look up a message associated with this action.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string MessageId { get; set; }
Public Property MessageId As String
    Get
    Set
public:
property String^ MessageId {
    String^ get ();
    void set (String^ value);
}
function get_MessageId();
function set_MessageId(value);

Property Value

Type: String
The message id for this action.
See Also

Reference

JobAction Class
DoubleTake.Jobs.Contract Namespace


JobAction.RequestingUserName Property

JobActionRequestingUserName Property
This value is the name of the user that requested the action.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string RequestingUserName { get; set; }
Public Property RequestingUserName As String
    Get
    Set
public:
property String^ RequestingUserName {
    String^ get ();
    void set (String^ value);
}
function get_RequestingUserName();
function set_RequestingUserName(value);

Property Value

Type: String
The name of the user that requested this action.
See Also

Reference

JobAction Class
DoubleTake.Jobs.Contract Namespace


JobAction.Status Property

JobActionStatus Property
This value represents the status of the action.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ActionStatus Status { get; set; }
Public Property Status As ActionStatus
    Get
    Set
public:
property ActionStatus Status {
    ActionStatus get ();
    void set (ActionStatus value);
}
function get_Status();
function set_Status(value);

Property Value

Type: ActionStatus
The status of this action.
See Also

Reference

JobAction Class
DoubleTake.Jobs.Contract Namespace


JobAction.Timestamp Property

JobActionTimestamp Property
This value is the time when the action occurred.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public DateTimeOffset Timestamp { get; set; }
Public Property Timestamp As DateTimeOffset
    Get
    Set
public:
property DateTimeOffset Timestamp {
    DateTimeOffset get ();
    void set (DateTimeOffset value);
}
function get_Timestamp();
function set_Timestamp(value);

Property Value

Type: DateTimeOffset
The timestamp when this action occurred.
See Also

Reference

JobAction Class
DoubleTake.Jobs.Contract Namespace


JobAction.TitleFormatParameters Property

JobActionTitleFormatParameters Property
This value is the title format parameters for the action.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string[] TitleFormatParameters { get; set; }
Public Property TitleFormatParameters As String()
    Get
    Set
public:
property array<String^>^ TitleFormatParameters {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
function get_TitleFormatParameters();
function set_TitleFormatParameters(value);

Property Value

Type: String
The title format parameters for this action.
See Also

Reference

JobAction Class
DoubleTake.Jobs.Contract Namespace


JobAction.TitleId Property

JobActionTitleId Property
This value is the title ID for the action. This value can be used to look up a title associated with this action.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string TitleId { get; set; }
Public Property TitleId As String
    Get
    Set
public:
property String^ TitleId {
    String^ get ();
    void set (String^ value);
}
function get_TitleId();
function set_TitleId(value);

Property Value

Type: String
The title id for this action.
See Also

Reference

JobAction Class
DoubleTake.Jobs.Contract Namespace


JobCredentials Class

JobCredentials Class
Represents the connection information (address, port, and credentials) required to work with jobs.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractJobCredentials

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class JobCredentials : IExtensibleDataObject
Public Class JobCredentials
    Implements IExtensibleDataObject
public ref class JobCredentials : IExtensibleDataObject
DoubleTake.Jobs.Contract.JobCredentials = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.JobCredentials',
    null,
    IExtensibleDataObject);

The JobCredentials type exposes the following members.

Constructors
 | Name | Description
Public method | JobCredentials | Initializes a new instance of the JobCredentials class
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | OtherHostUris | Gets or sets the other host URIs.
Public property | SourceHardwareId | Gets or sets the source hardware id.
Public property | SourceHostUri | Gets or sets the source host URI.
Public property | TargetHardwareId | Gets or sets the target hardware id.
Public property | TargetHostUri | Gets or sets the target host URI.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


JobCredentials Constructor

JobCredentials Constructor
Initializes a new instance of the JobCredentials class

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public JobCredentials()
Public Sub New
public:
JobCredentials()
DoubleTake.Jobs.Contract.JobCredentials = function();
See Also

Reference

JobCredentials Class
DoubleTake.Jobs.Contract Namespace


JobCredentials Properties

JobCredentials Properties

The JobCredentials type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | OtherHostUris | Gets or sets the other host URIs.
Public property | SourceHardwareId | Gets or sets the source hardware id.
Public property | SourceHostUri | Gets or sets the source host URI.
Public property | TargetHardwareId | Gets or sets the target hardware id.
Public property | TargetHostUri | Gets or sets the target host URI.
Top
See Also

Reference

JobCredentials Class
DoubleTake.Jobs.Contract Namespace


JobCredentials.ExtensionData Property

JobCredentialsExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

JobCredentials Class
DoubleTake.Jobs.Contract Namespace


JobCredentials.OtherHostUris Property

JobCredentialsOtherHostUris Property
Gets or sets the other host URIs.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public IDictionary<string, Uri> OtherHostUris { get; set; }
Public Property OtherHostUris As IDictionary(Of String, Uri)
    Get
    Set
public:
property IDictionary<String^, Uri^>^ OtherHostUris {
    IDictionary<String^, Uri^>^ get ();
    void set (IDictionary<String^, Uri^>^ value);
}
function get_OtherHostUris();
function set_OtherHostUris(value);

Property Value

Type: IDictionary String, Uri
The other host URIs.
Remarks
This property serves as a replacement for the deprecated OtherConnectionParameters property.
See Also

Reference

JobCredentials Class
DoubleTake.Jobs.Contract Namespace


JobCredentials.SourceHardwareId Property

JobCredentialsSourceHardwareId Property
Gets or sets the source hardware id.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string SourceHardwareId { get; set; }
Public Property SourceHardwareId As String
    Get
    Set
public:
property String^ SourceHardwareId {
    String^ get ();
    void set (String^ value);
}
function get_SourceHardwareId();
function set_SourceHardwareId(value);

Property Value

Type: String
The source hardware id.
See Also

Reference

JobCredentials Class
DoubleTake.Jobs.Contract Namespace


JobCredentials.SourceHostUri Property

JobCredentialsSourceHostUri Property
Gets or sets the source host URI.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Uri SourceHostUri { get; set; }
Public Property SourceHostUri As Uri
    Get
    Set
public:
property Uri^ SourceHostUri {
    Uri^ get ();
    void set (Uri^ value);
}
function get_SourceHostUri();
function set_SourceHostUri(value);

Property Value

Type: Uri
The source host URI.
Remarks
This property serves as a replacement for the deprecated SourceConnectionParameters property.
See Also

Reference

JobCredentials Class
DoubleTake.Jobs.Contract Namespace


JobCredentials.TargetHardwareId Property

JobCredentialsTargetHardwareId Property
Gets or sets the target hardware id.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string TargetHardwareId { get; set; }
Public Property TargetHardwareId As String
    Get
    Set
public:
property String^ TargetHardwareId {
    String^ get ();
    void set (String^ value);
}
function get_TargetHardwareId();
function set_TargetHardwareId(value);

Property Value

Type: String
The target hardware id.
See Also

Reference

JobCredentials Class
DoubleTake.Jobs.Contract Namespace


JobCredentials.TargetHostUri Property

JobCredentialsTargetHostUri Property
Gets or sets the target host URI.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Uri TargetHostUri { get; set; }
Public Property TargetHostUri As Uri
    Get
    Set
public:
property Uri^ TargetHostUri {
    Uri^ get ();
    void set (Uri^ value);
}
function get_TargetHostUri();
function set_TargetHostUri(value);

Property Value

Type: Uri
The target host URI.
Remarks
This property serves as a replacement for the deprecated TargetConnectionParameters property.
See Also

Reference

JobCredentials Class
DoubleTake.Jobs.Contract Namespace


JobDisplayInfo Class

JobDisplayInfo Class
Represents the current displayed information for a job.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractJobDisplayInfo

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class JobDisplayInfo : IExtensibleDataObject
Public Class JobDisplayInfo
    Implements IExtensibleDataObject
public ref class JobDisplayInfo : IExtensibleDataObject
DoubleTake.Jobs.Contract.JobDisplayInfo = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.JobDisplayInfo',
    null,
    IExtensibleDataObject);

The JobDisplayInfo type exposes the following members.

Constructors
 | Name | Description
Public method | JobDisplayInfo | Initializes a new instance of the JobDisplayInfo class
Top
Properties
 | Name | Description
Public property | EngineConnectionId | Gets or sets the unique identifier of this job.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | JobId | Gets or sets the unique identifier of this job.
Public property | JobStatistics | Gets or sets JobStatistics.
Public property | JobStatus | Gets or sets JobStatus.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


JobDisplayInfo Constructor

JobDisplayInfo Constructor
Initializes a new instance of the JobDisplayInfo class

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public JobDisplayInfo()
Public Sub New
public:
JobDisplayInfo()
DoubleTake.Jobs.Contract.JobDisplayInfo = function();
See Also

Reference

JobDisplayInfo Class
DoubleTake.Jobs.Contract Namespace


JobDisplayInfo Properties

JobDisplayInfo Properties

The JobDisplayInfo type exposes the following members.

Properties
 | Name | Description
Public property | EngineConnectionId | Gets or sets the unique identifier of this job.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | JobId | Gets or sets the unique identifier of this job.
Public property | JobStatistics | Gets or sets JobStatistics.
Public property | JobStatus | Gets or sets JobStatus.
Top
See Also

Reference

JobDisplayInfo Class
DoubleTake.Jobs.Contract Namespace


JobDisplayInfo.EngineConnectionId Property

JobDisplayInfoEngineConnectionId Property
Gets or sets the unique identifier of this job.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int EngineConnectionId { get; set; }
Public Property EngineConnectionId As Integer
    Get
    Set
public:
property int EngineConnectionId {
    int get ();
    void set (int value);
}
function get_EngineConnectionId();
function set_EngineConnectionId(value);

Property Value

Type: Int32
The unique identifier of this job.
See Also

Reference

JobDisplayInfo Class
DoubleTake.Jobs.Contract Namespace


JobDisplayInfo.ExtensionData Property

JobDisplayInfoExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

JobDisplayInfo Class
DoubleTake.Jobs.Contract Namespace


JobDisplayInfo.JobId Property

JobDisplayInfoJobId Property
Gets or sets the unique identifier of this job.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Guid JobId { get; set; }
Public Property JobId As Guid
    Get
    Set
public:
property Guid JobId {
    Guid get ();
    void set (Guid value);
}
function get_JobId();
function set_JobId(value);

Property Value

Type: Guid
The unique identifier of this job.
See Also

Reference

JobDisplayInfo Class
DoubleTake.Jobs.Contract Namespace


JobDisplayInfo.JobStatistics Property

JobDisplayInfoJobStatistics Property
Gets or sets JobStatistics.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public JobStatistics JobStatistics { get; set; }
Public Property JobStatistics As JobStatistics
    Get
    Set
public:
property JobStatistics^ JobStatistics {
    JobStatistics^ get ();
    void set (JobStatistics^ value);
}
function get_JobStatistics();
function set_JobStatistics(value);

Property Value

Type: JobStatistics
The JobStatistics details.
See Also

Reference

JobDisplayInfo Class
DoubleTake.Jobs.Contract Namespace


JobDisplayInfo.JobStatus Property

JobDisplayInfoJobStatus Property
Gets or sets JobStatus.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public JobStatus JobStatus { get; set; }
Public Property JobStatus As JobStatus
    Get
    Set
public:
property JobStatus^ JobStatus {
    JobStatus^ get ();
    void set (JobStatus^ value);
}
function get_JobStatus();
function set_JobStatus(value);

Property Value

Type: JobStatus
The JobStatus details.
See Also

Reference

JobDisplayInfo Class
DoubleTake.Jobs.Contract Namespace


JobInfo Class

JobInfo Class
Represents a job.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractJobInfo

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class JobInfo : IExtensibleDataObject
Public Class JobInfo
    Implements IExtensibleDataObject
public ref class JobInfo : IExtensibleDataObject
DoubleTake.Jobs.Contract.JobInfo = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.JobInfo',
    null,
    IExtensibleDataObject);

The JobInfo type exposes the following members.

Constructors
 | Name | Description
Public method | JobInfo | Initializes a new instance of the JobInfo class
Top
Properties
Name Description
Public property CreatorUserName
This value is the name of the user who created the job.
Public property ExtensionData
Gets or sets the structure that contains extra data.
Public property Features
This value represents a service endpoint that provides additional features for a job.
Public property Id
This value is the unique ID for the job.
Public property JobType
This value is the type of job. Specify the type of job from the following list. ClusterAwareDTHV—Cluster-aware agentless Hyper-V job ClusterAwareExchange—Cluster-aware Exchange job ClusterAwareFilesAndFolders—Cluster-aware files and folders job ClusterAwareHV2V—Cluster-aware virtual to Hyper-V job ClusterAwareMultiSelectDthv—Cluster-aware agentless Hyper-V job ClusterAwareSql—Cluster-aware SQL job DataOnlyImageProtection—DR data protection job DataOnlyImageRecovery—DR data recovery job Diagnostics—Throughput Diagnostic Utility job DTHV—Agentless Hyper-V job Exchange—Exchange job FilesAndFolders—Files and folders job FullServerFailover—Full server job FullServerImageProtection—DR full server protection job FullServerImageRecovery—DR full server recovery job Legacy—GeoCluster jobs LinuxFullServerFailover—Full server for Linux job Lvra—Full server to ESX appliance job MoveDataOnlyMigration—Data migration job MoveServerMigration—Full server migration job MultiSelectDTHV—Agentless Hyper-V job OrphanedConnection—Old, orphaned connection (if Double-Take was uninstalled and then reinstalled on a target server or possibly after failover, depending on the state of your servers before failover occurred) SQL—SQL job UnmanagedConnection—Double-Take versions 5.2.x and earlier UVRA—Double-Take version 7.0.1 or earler full server to ESX appliance job V2V—V to ESX or V to Hyper-V job VRA—Full server to ESX or full server to Hyper-V job VraMove—Full server to ESX migration or full server to Hyper-V migration job
Public property LoadedFromDisk
This value is true if the job was loaded from persistence; otherwise, it is false.
Public property Managed
This value is true if the job is managed; otherwise, it is false. This property is intended to be used by transitional implementations of jobs that want to allow their jobs to be visible to the job manager, but will be responsible for creating those jobs and managing their lifetime.
Public property Options
This value represents the current options for the job.
Public property OtherHostUris
This value is the URIs for other servers involved in the job.
Public property SourceHostUri
This value is the source URI.
Public property SourceUniqueId
This value is the unique ID of the source server.
Public property Statistics
This value represents the current statistics of the job
Public property Status
This value represents the current state of the job.
Public property TargetHostUri
This value is the target URI.
Public property TargetUniqueId
This value is the unique ID of the target server.
Top
Methods
 | Name | Description
Public method | GetDeserializedObject |
Public method | GetObjectToSerialize |
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


JobInfo Constructor

JobInfo Constructor
Initializes a new instance of the JobInfo class

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public JobInfo()
Public Sub New
public:
JobInfo()
DoubleTake.Jobs.Contract.JobInfo = function();
See Also

Reference

JobInfo Class
DoubleTake.Jobs.Contract Namespace


JobInfo Properties

JobInfo Properties

The JobInfo type exposes the following members.

Properties
Name Description
Public property CreatorUserName
This value is the name of the user who created the job.
Public property ExtensionData
Gets or sets the structure that contains extra data.
Public property Features
This value represents a service endpoint that provides additional features for a job.
Public property Id
This value is the unique ID for the job.
Public property JobType
This value is the type of job. Specify the type of job from the following list. ClusterAwareDTHV—Cluster-aware agentless Hyper-V job ClusterAwareExchange—Cluster-aware Exchange job ClusterAwareFilesAndFolders—Cluster-aware files and folders job ClusterAwareHV2V—Cluster-aware virtual to Hyper-V job ClusterAwareMultiSelectDthv—Cluster-aware agentless Hyper-V job ClusterAwareSql—Cluster-aware SQL job DataOnlyImageProtection—DR data protection job DataOnlyImageRecovery—DR data recovery job Diagnostics—Throughput Diagnostic Utility job DTHV—Agentless Hyper-V job Exchange—Exchange job FilesAndFolders—Files and folders job FullServerFailover—Full server job FullServerImageProtection—DR full server protection job FullServerImageRecovery—DR full server recovery job Legacy—GeoCluster jobs LinuxFullServerFailover—Full server for Linux job Lvra—Full server to ESX appliance job MoveDataOnlyMigration—Data migration job MoveServerMigration—Full server migration job MultiSelectDTHV—Agentless Hyper-V job OrphanedConnection—Old, orphaned connection (if Double-Take was uninstalled and then reinstalled on a target server or possibly after failover, depending on the state of your servers before failover occurred) SQL—SQL job UnmanagedConnection—Double-Take versions 5.2.x and earlier UVRA—Double-Take version 7.0.1 or earler full server to ESX appliance job V2V—V to ESX or V to Hyper-V job VRA—Full server to ESX or full server to Hyper-V job VraMove—Full server to ESX migration or full server to Hyper-V migration job
Public property LoadedFromDisk
This value is true if the job was loaded from persistence; otherwise, it is false.
Public property Managed
This value is true if the job is managed; otherwise, it is false. This property is intended to be used by transitional implementations of jobs that want to allow their jobs to be visible to the job manager, but will be responsible for creating those jobs and managing their lifetime.
Public property Options
This value represents the current options for the job.
Public property OtherHostUris
This value is the URIs for other servers involved in the job.
Public property SourceHostUri
This value is the source URI.
Public property SourceUniqueId
This value is the unique ID of the source server.
Public property Statistics
This value represents the current statistics of the job
Public property Status
This value represents the current state of the job.
Public property TargetHostUri
This value is the target URI.
Public property TargetUniqueId
This value is the unique ID of the target server.
Top
See Also

Reference

JobInfo Class
DoubleTake.Jobs.Contract Namespace


JobInfo.CreatorUserName Property

JobInfoCreatorUserName Property
This value is the name of the user who created the job.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string CreatorUserName { get; set; }
Public Property CreatorUserName As String
    Get
    Set
public:
property String^ CreatorUserName {
    String^ get ();
    void set (String^ value);
}
function get_CreatorUserName();
function set_CreatorUserName(value);

Property Value

Type: String
The name of the user who created this job.
See Also

Reference

JobInfo Class
DoubleTake.Jobs.Contract Namespace


JobInfo.ExtensionData Property

JobInfoExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

JobInfo Class
DoubleTake.Jobs.Contract Namespace


JobInfo.Features Property

JobInfoFeatures Property
This value represents a service endpoint that provides additional features for a job.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Feature[] Features { get; set; }
Public Property Features As Feature()
    Get
    Set
public:
property array<Feature^>^ Features {
    array<Feature^>^ get ();
    void set (array<Feature^>^ value);
}
function get_Features();
function set_Features(value);

Property Value

Type: Feature
An array of Feature that includes the additional features supported by this job.
See Also

Reference

JobInfo Class
DoubleTake.Jobs.Contract Namespace


JobInfo.Id Property

JobInfoId Property
This value is the unique ID for the job.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Guid Id { get; set; }
Public Property Id As Guid
    Get
    Set
public:
property Guid Id {
    Guid get ();
    void set (Guid value);
}
function get_Id();
function set_Id(value);

Property Value

Type: Guid
The unique identifier of this job.
See Also

Reference

JobInfo Class
DoubleTake.Jobs.Contract Namespace


JobInfo.JobType Property

JobInfoJobType Property
This value is the type of job. Specify the type of job from the following list. ClusterAwareDTHV—Cluster-aware agentless Hyper-V job ClusterAwareExchange—Cluster-aware Exchange job ClusterAwareFilesAndFolders—Cluster-aware files and folders job ClusterAwareHV2V—Cluster-aware virtual to Hyper-V job ClusterAwareMultiSelectDthv—Cluster-aware agentless Hyper-V job ClusterAwareSql—Cluster-aware SQL job DataOnlyImageProtection—DR data protection job DataOnlyImageRecovery—DR data recovery job Diagnostics—Throughput Diagnostic Utility job DTHV—Agentless Hyper-V job Exchange—Exchange job FilesAndFolders—Files and folders job FullServerFailover—Full server job FullServerImageProtection—DR full server protection job FullServerImageRecovery—DR full server recovery job Legacy—GeoCluster jobs LinuxFullServerFailover—Full server for Linux job Lvra—Full server to ESX appliance job MoveDataOnlyMigration—Data migration job MoveServerMigration—Full server migration job MultiSelectDTHV—Agentless Hyper-V job OrphanedConnection—Old, orphaned connection (if Double-Take was uninstalled and then reinstalled on a target server or possibly after failover, depending on the state of your servers before failover occurred) SQL—SQL job UnmanagedConnection—Double-Take versions 5.2.x and earlier UVRA—Double-Take version 7.0.1 or earler full server to ESX appliance job V2V—V to ESX or V to Hyper-V job VRA—Full server to ESX or full server to Hyper-V job VraMove—Full server to ESX migration or full server to Hyper-V migration job

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string JobType { get; set; }
Public Property JobType As String
    Get
    Set
public:
property String^ JobType {
    String^ get ();
    void set (String^ value);
}
function get_JobType();
function set_JobType(value);

Property Value

Type: String
The type of this job.
See Also

Reference

JobInfo Class
DoubleTake.Jobs.Contract Namespace


JobInfo.LoadedFromDisk Property

JobInfoLoadedFromDisk Property
This value is true if the job was loaded from persistence; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool LoadedFromDisk { get; set; }
Public Property LoadedFromDisk As Boolean
    Get
    Set
public:
property bool LoadedFromDisk {
    bool get ();
    void set (bool value);
}
function get_LoadedFromDisk();
function set_LoadedFromDisk(value);

Property Value

Type: Boolean
if this job was loaded from persistence; otherwise, .
See Also

Reference

JobInfo Class
DoubleTake.Jobs.Contract Namespace


JobInfo.Managed Property

JobInfoManaged Property
This value is true if the job is managed; otherwise, it is false. This property is intended to be used by transitional implementations of jobs that want to allow their jobs to be visible to the job manager, but will be responsible for creating those jobs and managing their lifetime.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool Managed { get; set; }
Public Property Managed As Boolean
    Get
    Set
public:
property bool Managed {
    bool get ();
    void set (bool value);
}
function get_Managed();
function set_Managed(value);

Property Value

Type: Boolean
if this job is managed; otherwise, .
Remarks
This property is intended to be used by transitional implementations of jobs that want to allow their jobs to be visible to the job manager, but will be responsible for creating those jobs and managing their lifetime. Typically, jobs who have this property set to will be added to the job manager using the [M:Add] method.
See Also

Reference

JobInfo Class
DoubleTake.Jobs.Contract Namespace


JobInfo.Options Property

JobInfoOptions Property
This value represents the current options for the job.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public JobOptions Options { get; set; }
Public Property Options As JobOptions
    Get
    Set
public:
property JobOptions^ Options {
    JobOptions^ get ();
    void set (JobOptions^ value);
}
function get_Options();
function set_Options(value);

Property Value

Type: JobOptions
A JobOptions that represents the current options for this job.
See Also

Reference

JobInfo Class
DoubleTake.Jobs.Contract Namespace


JobInfo.OtherHostUris Property

JobInfoOtherHostUris Property
This value is the URIs for other servers involved in the job.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public IDictionary<string, Uri> OtherHostUris { get; set; }
Public Property OtherHostUris As IDictionary(Of String, Uri)
    Get
    Set
public:
property IDictionary<String^, Uri^>^ OtherHostUris {
    IDictionary<String^, Uri^>^ get ();
    void set (IDictionary<String^, Uri^>^ value);
}
function get_OtherHostUris();
function set_OtherHostUris(value);

Property Value

Type: IDictionary String, Uri
The other server URIs.
Remarks
This property serves as a replacement for the OtherNetworkIds property. Please refrain from using the OtherNetworkIds property.
See Also

Reference

JobInfo Class
DoubleTake.Jobs.Contract Namespace


JobInfo.SourceHostUri Property

JobInfoSourceHostUri Property
This value is the source URI.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Uri SourceHostUri { get; set; }
Public Property SourceHostUri As Uri
    Get
    Set
public:
property Uri^ SourceHostUri {
    Uri^ get ();
    void set (Uri^ value);
}
function get_SourceHostUri();
function set_SourceHostUri(value);

Property Value

Type: Uri
The source URI.
Remarks
This property serves as a replacement for the SourceNetworkId and SourceManagementPort properties because both of these pieces of information can be provided in and extracted from the URI.
See Also

Reference

JobInfo Class
DoubleTake.Jobs.Contract Namespace


JobInfo.SourceUniqueId Property

JobInfoSourceUniqueId Property
This value is the unique ID of the source server.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string SourceUniqueId { get; set; }
Public Property SourceUniqueId As String
    Get
    Set
public:
property String^ SourceUniqueId {
    String^ get ();
    void set (String^ value);
}
function get_SourceUniqueId();
function set_SourceUniqueId(value);

Property Value

Type: String
The unique identifier of the source server.
See Also

Reference

JobInfo Class
DoubleTake.Jobs.Contract Namespace


JobInfo.Statistics Property

JobInfoStatistics Property
This value represents the current statistics of the job

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public JobStatistics Statistics { get; set; }
Public Property Statistics As JobStatistics
    Get
    Set
public:
property JobStatistics^ Statistics {
    JobStatistics^ get ();
    void set (JobStatistics^ value);
}
function get_Statistics();
function set_Statistics(value);

Property Value

Type: JobStatistics
A JobStatistics that represents the current statistics of this job.
See Also

Reference

JobInfo Class
DoubleTake.Jobs.Contract Namespace


JobInfo.Status Property

JobInfoStatus Property
This value represents the current state of the job.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public JobStatus Status { get; set; }
Public Property Status As JobStatus
    Get
    Set
public:
property JobStatus^ Status {
    JobStatus^ get ();
    void set (JobStatus^ value);
}
function get_Status();
function set_Status(value);

Property Value

Type: JobStatus
A JobStatus that represents the current status of this job.
See Also

Reference

JobInfo Class
DoubleTake.Jobs.Contract Namespace


JobInfo.TargetHostUri Property

JobInfoTargetHostUri Property
This value is the target URI.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Uri TargetHostUri { get; set; }
Public Property TargetHostUri As Uri
    Get
    Set
public:
property Uri^ TargetHostUri {
    Uri^ get ();
    void set (Uri^ value);
}
function get_TargetHostUri();
function set_TargetHostUri(value);

Property Value

Type: Uri
The target URI.
Remarks
This property serves as a replacement for the TargetNetworkId and TargetManagementPort properties because both of these pieces of information can be provided in and extracted from the URI.
See Also

Reference

JobInfo Class
DoubleTake.Jobs.Contract Namespace


JobInfo.TargetUniqueId Property

JobInfoTargetUniqueId Property
This value is the unique ID of the target server.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string TargetUniqueId { get; set; }
Public Property TargetUniqueId As String
    Get
    Set
public:
property String^ TargetUniqueId {
    String^ get ();
    void set (String^ value);
}
function get_TargetUniqueId();
function set_TargetUniqueId(value);

Property Value

Type: String
The unique identifier of the target server.
See Also

Reference

JobInfo Class
DoubleTake.Jobs.Contract Namespace


JobInfo Methods

JobInfo Methods

The JobInfo type exposes the following members.

Methods
 | Name | Description
Public method | GetDeserializedObject |
Public method | GetObjectToSerialize |
Top
See Also

Reference

JobInfo Class
DoubleTake.Jobs.Contract Namespace


JobInfo.GetDeserializedObject Method

JobInfoGetDeserializedObject Method

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Object GetDeserializedObject(
    Type targetType
)
Public Function GetDeserializedObject (
    targetType As Type
) As Object
public:
virtual Object^ GetDeserializedObject(
    Type^ targetType
) sealed
function GetDeserializedObject(targetType);

Parameters

targetType
Type: SystemType

Return Value

Type: Object
See Also

Reference

JobInfo Class
DoubleTake.Jobs.Contract Namespace


JobInfo.GetObjectToSerialize Method

JobInfoGetObjectToSerialize Method

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Object GetObjectToSerialize(
    Type targetType
)
Public Function GetObjectToSerialize (
    targetType As Type
) As Object
public:
virtual Object^ GetObjectToSerialize(
    Type^ targetType
) sealed
function GetObjectToSerialize(targetType);

Parameters

targetType
Type: SystemType

Return Value

Type: Object
See Also

Reference

JobInfo Class
DoubleTake.Jobs.Contract Namespace


JobOptions Class

JobOptions Class
Represents the user-configurable options of a job.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractJobOptions

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class JobOptions : IExtensibleDataObject
Public Class JobOptions
    Implements IExtensibleDataObject
public ref class JobOptions : IExtensibleDataObject
DoubleTake.Jobs.Contract.JobOptions = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.JobOptions',
    null,
    IExtensibleDataObject);

The JobOptions type exposes the following members.

Constructors
 | Name | Description
Public method | JobOptions | Initializes a new instance of the JobOptions class
Top
Properties
 | Name | Description
Public property | ApplicationOptions | This value represents the options for Exchange and SQL jobs.
Public property | BandwidthOptions | This value represents bandwidth limiting configuration.
Public property | CloudOptions | Gets or sets the options for cloud jobs.
Public property | ClusterOptions | This value represents cluster options.
Public property | CoreConnectionOptions | This value represents the options for the job connection.
Public property | CoreMonitorOptions | This value represents the options for configuring failover monitoring by using the service monitoring method.
Public property | DnsOptions | This value represents the options for jobs using DNS failover.
Public property | DtavOptions | This property is not applicable. It is reserved for future features.
Public property | DTHVOptions | This value represents the options for agentless Hyper-V jobs.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | FailoverMonitoringEnabled | This value is true if failover monitoring is enabled; otherwise, it is false.
Public property | FullServerFailoverOptions | This value represents the options for full server jobs.
Public property | ImageProtectionOptions | This value represents the options for Double-Take DR protection jobs.
Public property | ImageRecoveryOptions | This value represents the options for Double-Take DR recovery jobs.
Public property | ManagementServiceTargetPort |
Public property | MonitoringOptions | This value represents the options for configuring failover monitoring by using the service monitoring method.
Public property | Name | This value is the name of the job.
Public property | SimpleFailoverMonitorOptions | This value represents the options for failover monitoring without pinging an IP address. This value is only used by agentless Hyper-V jobs, however, that job type is not currently supported in PowerShell.
Public property | SystemStateOptions | This value represents the system state options for full server jobs.
Public property | TargetServicesOptions | This value represents which target services will be stopped and started during failover and failback.
Public property | UnmanagedConnectionOptions | This value represents the options for unmanaged connections which are connections that are not associated with a known job. These connections were created in a client outside of the job manager.
Public property | VcdVappOptions | This property is not applicable. It is reserved for future features.
Public property | VRAOptions | This value represents the options for guest-level virtual jobs.
Public property | Workload | This value represents the workload being protected by the job.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


JobOptions Constructor

JobOptions Constructor
Initializes a new instance of the JobOptions class

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public JobOptions()
Public Sub New
public:
JobOptions()
DoubleTake.Jobs.Contract.JobOptions = function();
See Also

Reference

JobOptions Class
DoubleTake.Jobs.Contract Namespace


JobOptions Properties

JobOptions Properties

The JobOptions type exposes the following members.

Properties
 | Name | Description
Public property | ApplicationOptions | This value represents the options for Exchange and SQL jobs.
Public property | BandwidthOptions | This value represents bandwidth limiting configuration.
Public property | CloudOptions | Gets or sets the options for cloud jobs.
Public property | ClusterOptions | This value represents cluster options.
Public property | CoreConnectionOptions | This value represents the options for the job connection.
Public property | CoreMonitorOptions | This value represents the options for configuring failover monitoring by using the service monitoring method.
Public property | DnsOptions | This value represents the options for jobs using DNS failover.
Public property | DtavOptions | This property is not applicable. It is reserved for future features.
Public property | DTHVOptions | This value represents the options for agentless Hyper-V jobs.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | FailoverMonitoringEnabled | This value is true if failover monitoring is enabled; otherwise, it is false.
Public property | FullServerFailoverOptions | This value represents the options for full server jobs.
Public property | ImageProtectionOptions | This value represents the options for Double-Take DR protection jobs.
Public property | ImageRecoveryOptions | This value represents the options for Double-Take DR recovery jobs.
Public property | ManagementServiceTargetPort |
Public property | MonitoringOptions | This value represents the options for configuring failover monitoring by using the service monitoring method.
Public property | Name | This value is the name of the job.
Public property | SimpleFailoverMonitorOptions | This value represents the options for failover monitoring without pinging an IP address. This value is only used by agentless Hyper-V jobs, however, that job type is not currently supported in PowerShell.
Public property | SystemStateOptions | This value represents the system state options for full server jobs.
Public property | TargetServicesOptions | This value represents which target services will be stopped and started during failover and failback.
Public property | UnmanagedConnectionOptions | This value represents the options for unmanaged connections which are connections that are not associated with a known job. These connections were created in a client outside of the job manager.
Public property | VcdVappOptions | This property is not applicable. It is reserved for future features.
Public property | VRAOptions | This value represents the options for guest-level virtual jobs.
Public property | Workload | This value represents the workload being protected by the job.
Top
See Also

Reference

JobOptions Class
DoubleTake.Jobs.Contract Namespace


JobOptions.ApplicationOptions Property

JobOptionsApplicationOptions Property
This value represents the options for Exchange and SQL jobs.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ApplicationOptions ApplicationOptions { get; set; }
Public Property ApplicationOptions As ApplicationOptions
    Get
    Set
public:
property ApplicationOptions^ ApplicationOptions {
    ApplicationOptions^ get ();
    void set (ApplicationOptions^ value);
}
function get_ApplicationOptions();
function set_ApplicationOptions(value);

Property Value

Type: ApplicationOptions
The options for application-specific protection jobs.
See Also

Reference

JobOptions Class
DoubleTake.Jobs.Contract Namespace


JobOptions.BandwidthOptions Property

JobOptionsBandwidthOptions Property
This value represents bandwidth limiting configuration.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public BandwidthOptions BandwidthOptions { get; set; }
Public Property BandwidthOptions As BandwidthOptions
    Get
    Set
public:
property BandwidthOptions^ BandwidthOptions {
    BandwidthOptions^ get ();
    void set (BandwidthOptions^ value);
}
function get_BandwidthOptions();
function set_BandwidthOptions(value);

Property Value

Type: BandwidthOptions
The options for bandwidth limiting.
See Also

Reference

JobOptions Class
DoubleTake.Jobs.Contract Namespace


JobOptions.CloudOptions Property

JobOptionsCloudOptions Property
Gets or sets the options for cloud jobs.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public CloudOptions CloudOptions { get; set; }
Public Property CloudOptions As CloudOptions
    Get
    Set
public:
property CloudOptions^ CloudOptions {
    CloudOptions^ get ();
    void set (CloudOptions^ value);
}
function get_CloudOptions();
function set_CloudOptions(value);

Property Value

Type: CloudOptions
See Also

Reference

JobOptions Class
DoubleTake.Jobs.Contract Namespace


JobOptions.ClusterOptions Property

JobOptionsClusterOptions Property
This value represents cluster options.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ClusterOptions ClusterOptions { get; set; }
Public Property ClusterOptions As ClusterOptions
    Get
    Set
public:
property ClusterOptions^ ClusterOptions {
    ClusterOptions^ get ();
    void set (ClusterOptions^ value);
}
function get_ClusterOptions();
function set_ClusterOptions(value);

Property Value

Type: ClusterOptions
The cluster options.
See Also

Reference

JobOptions Class
DoubleTake.Jobs.Contract Namespace


JobOptions.CoreConnectionOptions Property

JobOptionsCoreConnectionOptions Property
This value represents the options for the job connection.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public CoreConnectionOptions CoreConnectionOptions { get; set; }
Public Property CoreConnectionOptions As CoreConnectionOptions
    Get
    Set
public:
property CoreConnectionOptions^ CoreConnectionOptions {
    CoreConnectionOptions^ get ();
    void set (CoreConnectionOptions^ value);
}
function get_CoreConnectionOptions();
function set_CoreConnectionOptions(value);

Property Value

Type: CoreConnectionOptions
The core connection options.
See Also

Reference

JobOptions Class
DoubleTake.Jobs.Contract Namespace


JobOptions.CoreMonitorOptions Property

JobOptionsCoreMonitorOptions Property
This value represents the options for configuring failover monitoring by using the service monitoring method.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public CoreMonitorOptions CoreMonitorOptions { get; set; }
Public Property CoreMonitorOptions As CoreMonitorOptions
    Get
    Set
public:
property CoreMonitorOptions^ CoreMonitorOptions {
    CoreMonitorOptions^ get ();
    void set (CoreMonitorOptions^ value);
}
function get_CoreMonitorOptions();
function set_CoreMonitorOptions(value);

Property Value

Type: CoreMonitorOptions
The core monitor options.
See Also

Reference

JobOptions Class
DoubleTake.Jobs.Contract Namespace


JobOptions.DnsOptions Property

JobOptionsDnsOptions Property
This value represents the options for jobs using DNS failover.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public DNSOptions DnsOptions { get; set; }
Public Property DnsOptions As DNSOptions
    Get
    Set
public:
property DNSOptions^ DnsOptions {
    DNSOptions^ get ();
    void set (DNSOptions^ value);
}
function get_DnsOptions();
function set_DnsOptions(value);

Property Value

Type: DNSOptions
The DNS options.
See Also

Reference

JobOptions Class
DoubleTake.Jobs.Contract Namespace


JobOptions.DtavOptions Property

JobOptionsDtavOptions Property
This property is not applicable. It is reserved for future features.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public DTAVOptions DtavOptions { get; set; }
Public Property DtavOptions As DTAVOptions
    Get
    Set
public:
property DTAVOptions^ DtavOptions {
    DTAVOptions^ get ();
    void set (DTAVOptions^ value);
}
function get_DtavOptions();
function set_DtavOptions(value);

Property Value

Type: DTAVOptions
See Also

Reference

JobOptions Class
DoubleTake.Jobs.Contract Namespace


JobOptions.DTHVOptions Property

JobOptionsDTHVOptions Property
This value represents the options for agentless Hyper-V jobs.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public DTHVOptions DTHVOptions { get; set; }
Public Property DTHVOptions As DTHVOptions
    Get
    Set
public:
property DTHVOptions^ DTHVOptions {
    DTHVOptions^ get ();
    void set (DTHVOptions^ value);
}
function get_DTHVOptions();
function set_DTHVOptions(value);

Property Value

Type: DTHVOptions
The options for virtual machine protection jobs.
See Also

Reference

JobOptions Class
DoubleTake.Jobs.Contract Namespace


JobOptions.ExtensionData Property

JobOptionsExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

JobOptions Class
DoubleTake.Jobs.Contract Namespace


JobOptions.FailoverMonitoringEnabled Property

JobOptionsFailoverMonitoringEnabled Property
This value is true if failover monitoring is enabled; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Nullable<bool> FailoverMonitoringEnabled { get; set; }
Public Property FailoverMonitoringEnabled As Nullable(Of Boolean)
    Get
    Set
public:
property Nullable<bool> FailoverMonitoringEnabled {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}
function get_FailoverMonitoringEnabled();
function set_FailoverMonitoringEnabled(value);

Property Value

Type: Nullable Boolean
True if failover monitoring is enabled. Set to false for DR only jobs
See Also

Reference

JobOptions Class
DoubleTake.Jobs.Contract Namespace


JobOptions.FullServerFailoverOptions Property

JobOptionsFullServerFailoverOptions Property
This value represents the options for full server jobs.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public FullServerFailoverOptions FullServerFailoverOptions { get; set; }
Public Property FullServerFailoverOptions As FullServerFailoverOptions
    Get
    Set
public:
property FullServerFailoverOptions^ FullServerFailoverOptions {
    FullServerFailoverOptions^ get ();
    void set (FullServerFailoverOptions^ value);
}
function get_FullServerFailoverOptions();
function set_FullServerFailoverOptions(value);

Property Value

Type: FullServerFailoverOptions
The options for full server failover jobs.
See Also

Reference

JobOptions Class
DoubleTake.Jobs.Contract Namespace


JobOptions.ImageProtectionOptions Property

JobOptionsImageProtectionOptions Property
This value represents the options for Double-Take DR protection jobs.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ImageProtectionOptions ImageProtectionOptions { get; set; }
Public Property ImageProtectionOptions As ImageProtectionOptions
    Get
    Set
public:
property ImageProtectionOptions^ ImageProtectionOptions {
    ImageProtectionOptions^ get ();
    void set (ImageProtectionOptions^ value);
}
function get_ImageProtectionOptions();
function set_ImageProtectionOptions(value);

Property Value

Type: ImageProtectionOptions
The options for image protection jobs.
See Also

Reference

JobOptions Class
DoubleTake.Jobs.Contract Namespace


JobOptions.ImageRecoveryOptions Property

JobOptionsImageRecoveryOptions Property
This value represents the options for Double-Take DR recovery jobs.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ImageRecoveryOptions ImageRecoveryOptions { get; set; }
Public Property ImageRecoveryOptions As ImageRecoveryOptions
    Get
    Set
public:
property ImageRecoveryOptions^ ImageRecoveryOptions {
    ImageRecoveryOptions^ get ();
    void set (ImageRecoveryOptions^ value);
}
function get_ImageRecoveryOptions();
function set_ImageRecoveryOptions(value);

Property Value

Type: ImageRecoveryOptions
The options for image recovery jobs.
See Also

Reference

JobOptions Class
DoubleTake.Jobs.Contract Namespace


JobOptions.ManagementServiceTargetPort Property

JobOptionsManagementServiceTargetPort Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Nullable<int> ManagementServiceTargetPort { get; set; }
Public Property ManagementServiceTargetPort As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> ManagementServiceTargetPort {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
function get_ManagementServiceTargetPort();
function set_ManagementServiceTargetPort(value);

Property Value

Type: Nullable Int32
See Also

Reference

JobOptions Class
DoubleTake.Jobs.Contract Namespace


JobOptions.MonitoringOptions Property

JobOptionsMonitoringOptions Property
This value represents the options for configuring failover monitoring by using the service monitoring method.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public MonitoringOptions MonitoringOptions { get; set; }
Public Property MonitoringOptions As MonitoringOptions
    Get
    Set
public:
property MonitoringOptions^ MonitoringOptions {
    MonitoringOptions^ get ();
    void set (MonitoringOptions^ value);
}
function get_MonitoringOptions();
function set_MonitoringOptions(value);

Property Value

Type: MonitoringOptions
See Also

Reference

JobOptions Class
DoubleTake.Jobs.Contract Namespace


JobOptions.Name Property

JobOptionsName Property
This value is the name of the job.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
function get_Name();
function set_Name(value);

Property Value

Type: String
The name of this job.
See Also

Reference

JobOptions Class
DoubleTake.Jobs.Contract Namespace


JobOptions.SimpleFailoverMonitorOptions Property

JobOptionsSimpleFailoverMonitorOptions Property
This value represents the options for failover monitoring without pinging an IP address. This value is only used by agentless Hyper-V jobs, however, that job type is not currently supported in PowerShell.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public SimpleFailoverMonitorOptions SimpleFailoverMonitorOptions { get; set; }
Public Property SimpleFailoverMonitorOptions As SimpleFailoverMonitorOptions
    Get
    Set
public:
property SimpleFailoverMonitorOptions^ SimpleFailoverMonitorOptions {
    SimpleFailoverMonitorOptions^ get ();
    void set (SimpleFailoverMonitorOptions^ value);
}
function get_SimpleFailoverMonitorOptions();
function set_SimpleFailoverMonitorOptions(value);

Property Value

Type: SimpleFailoverMonitorOptions
The options for failover monitoring.
See Also

Reference

JobOptions Class
DoubleTake.Jobs.Contract Namespace


JobOptions.SystemStateOptions Property

JobOptionsSystemStateOptions Property
This value represents the system state options for full server jobs.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public SystemStateOptions SystemStateOptions { get; set; }
Public Property SystemStateOptions As SystemStateOptions
    Get
    Set
public:
property SystemStateOptions^ SystemStateOptions {
    SystemStateOptions^ get ();
    void set (SystemStateOptions^ value);
}
function get_SystemStateOptions();
function set_SystemStateOptions(value);

Property Value

Type: SystemStateOptions
The system state options.
See Also

Reference

JobOptions Class
DoubleTake.Jobs.Contract Namespace


JobOptions.TargetServicesOptions Property

JobOptionsTargetServicesOptions Property
This value represents which target services will be stopped and started during failover and failback.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public TargetServicesOptions TargetServicesOptions { get; set; }
Public Property TargetServicesOptions As TargetServicesOptions
    Get
    Set
public:
property TargetServicesOptions^ TargetServicesOptions {
    TargetServicesOptions^ get ();
    void set (TargetServicesOptions^ value);
}
function get_TargetServicesOptions();
function set_TargetServicesOptions(value);

Property Value

Type: TargetServicesOptions
See Also

Reference

JobOptions Class
DoubleTake.Jobs.Contract Namespace


JobOptions.UnmanagedConnectionOptions Property

JobOptionsUnmanagedConnectionOptions Property
This value represents the options for unmanaged connections which are connections that are not associated with a known job. These connections were created in a client outside of the job manager.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public UnmanagedConnectionOptions UnmanagedConnectionOptions { get; set; }
Public Property UnmanagedConnectionOptions As UnmanagedConnectionOptions
    Get
    Set
public:
property UnmanagedConnectionOptions^ UnmanagedConnectionOptions {
    UnmanagedConnectionOptions^ get ();
    void set (UnmanagedConnectionOptions^ value);
}
function get_UnmanagedConnectionOptions();
function set_UnmanagedConnectionOptions(value);

Property Value

Type: UnmanagedConnectionOptions
The options for jobs that use an unmanaged connection.
See Also

Reference

JobOptions Class
DoubleTake.Jobs.Contract Namespace


JobOptions.VcdVappOptions Property

JobOptionsVcdVappOptions Property
This property is not applicable. It is reserved for future features.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VcdVappOptions VcdVappOptions { get; set; }
Public Property VcdVappOptions As VcdVappOptions
    Get
    Set
public:
property VcdVappOptions^ VcdVappOptions {
    VcdVappOptions^ get ();
    void set (VcdVappOptions^ value);
}
function get_VcdVappOptions();
function set_VcdVappOptions(value);

Property Value

Type: VcdVappOptions
See Also

Reference

JobOptions Class
DoubleTake.Jobs.Contract Namespace


JobOptions.VRAOptions Property

JobOptionsVRAOptions Property
This value represents the options for guest-level virtual jobs.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VRAOptions VRAOptions { get; set; }
Public Property VRAOptions As VRAOptions
    Get
    Set
public:
property VRAOptions^ VRAOptions {
    VRAOptions^ get ();
    void set (VRAOptions^ value);
}
function get_VRAOptions();
function set_VRAOptions(value);

Property Value

Type: VRAOptions
The options for jobs that use Virtual Recovery Assistant.
See Also

Reference

JobOptions Class
DoubleTake.Jobs.Contract Namespace


JobOptions.Workload Property

JobOptionsWorkload Property
This value represents the workload being protected by the job.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Workload Workload { get; set; }
Public Property Workload As Workload
    Get
    Set
public:
property Workload^ Workload {
    Workload^ get ();
    void set (Workload^ value);
}
function get_Workload();
function set_Workload(value);

Property Value

Type: Workload
The workload to be protected by this job.
See Also

Reference

JobOptions Class
DoubleTake.Jobs.Contract Namespace


JobQualificationResults Class

JobQualificationResults Class
Defines a set of values that represent the possible options when creating or editing a job.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractJobQualificationResults

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class JobQualificationResults : IExtensibleDataObject
Public Class JobQualificationResults
    Implements IExtensibleDataObject
public ref class JobQualificationResults : IExtensibleDataObject
DoubleTake.Jobs.Contract.JobQualificationResults = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.JobQualificationResults',
    null,
    IExtensibleDataObject);

The JobQualificationResults type exposes the following members.

Constructors
 | Name | Description
Public method | JobQualificationResults | Initializes a new instance of the JobQualificationResults class
Top
Properties
 | Name | Description
Public property | ClusterFilesAndFoldersQualificationResults | This value represents configuration information for clustered files and folders jobs.
Public property | CoreQualificationResults | This value represents the replication engine connection configuration.
Public property | DtavQualificationResults | This property is not applicable. It is reserved for future features.
Public property | DTHVQualificationResults | This value represents configuration information for agentless Hyper-V jobs.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | SourceBehindNat | This value is true if the source is located behind a NAT router; otherwise, it is false.
Public property | SourceHostUri | This value is the source URI.
Public property | SupportsFrameworkMonitoring | This value is true if the server supports failover monitoring; otherwise, it is false.
Public property | SuppressFailoverMonitorOptions | This value is true if failover monitoring options are suppressed; otherwise, it is false.
Public property | VcdVappQualificationResults | This property is not applicable. It is reserved for future features.
Public property | VRAQualificationResults | This value represents configuration information for guest-level virtual jobs.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


JobQualificationResults Constructor

JobQualificationResults Constructor
Initializes a new instance of the JobQualificationResults class

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public JobQualificationResults()
Public Sub New
public:
JobQualificationResults()
DoubleTake.Jobs.Contract.JobQualificationResults = function();
See Also

Reference

JobQualificationResults Class
DoubleTake.Jobs.Contract Namespace


JobQualificationResults Properties

JobQualificationResults Properties

The JobQualificationResults type exposes the following members.

Properties
 | Name | Description
Public property | ClusterFilesAndFoldersQualificationResults | This value represents configuration information for clustered files and folders jobs.
Public property | CoreQualificationResults | This value represents the replication engine connection configuration.
Public property | DtavQualificationResults | This property is not applicable. It is reserved for future features.
Public property | DTHVQualificationResults | This value represents configuration information for agentless Hyper-V jobs.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | SourceBehindNat | This value is true if the source is located behind a NAT router; otherwise, it is false.
Public property | SourceHostUri | This value is the source URI.
Public property | SupportsFrameworkMonitoring | This value is true if the server supports failover monitoring; otherwise, it is false.
Public property | SuppressFailoverMonitorOptions | This value is true if failover monitoring options are suppressed; otherwise, it is false.
Public property | VcdVappQualificationResults | This property is not applicable. It is reserved for future features.
Public property | VRAQualificationResults | This value represents configuration information for guest-level virtual jobs.
Top
See Also

Reference

JobQualificationResults Class
DoubleTake.Jobs.Contract Namespace


JobQualificationResults.ClusterFilesAndFoldersQualificationResults Property

JobQualificationResultsClusterFilesAndFoldersQualificationResults Property
This value represents configuration information for clustered files and folders jobs.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ClusterFilesAndFoldersQualificationResults ClusterFilesAndFoldersQualificationResults { get; set; }
Public Property ClusterFilesAndFoldersQualificationResults As ClusterFilesAndFoldersQualificationResults
    Get
    Set
public:
property ClusterFilesAndFoldersQualificationResults^ ClusterFilesAndFoldersQualificationResults {
    ClusterFilesAndFoldersQualificationResults^ get ();
    void set (ClusterFilesAndFoldersQualificationResults^ value);
}
function get_ClusterFilesAndFoldersQualificationResults();
function set_ClusterFilesAndFoldersQualificationResults(value);

Property Value

Type: ClusterFilesAndFoldersQualificationResults
The cluster files and folders qualification results.
See Also

Reference

JobQualificationResults Class
DoubleTake.Jobs.Contract Namespace


JobQualificationResults.CoreQualificationResults Property

JobQualificationResultsCoreQualificationResults Property
This value represents the replication engine connection configuration.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public CoreQualificationResults CoreQualificationResults { get; set; }
Public Property CoreQualificationResults As CoreQualificationResults
    Get
    Set
public:
property CoreQualificationResults^ CoreQualificationResults {
    CoreQualificationResults^ get ();
    void set (CoreQualificationResults^ value);
}
function get_CoreQualificationResults();
function set_CoreQualificationResults(value);

Property Value

Type: CoreQualificationResults
The possible options that apply to engine connection and monitor.
See Also

Reference

JobQualificationResults Class
DoubleTake.Jobs.Contract Namespace


JobQualificationResults.DtavQualificationResults Property

JobQualificationResultsDtavQualificationResults Property
This property is not applicable. It is reserved for future features.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public DTAVQualificationResults DtavQualificationResults { get; set; }
Public Property DtavQualificationResults As DTAVQualificationResults
    Get
    Set
public:
property DTAVQualificationResults^ DtavQualificationResults {
    DTAVQualificationResults^ get ();
    void set (DTAVQualificationResults^ value);
}
function get_DtavQualificationResults();
function set_DtavQualificationResults(value);

Property Value

Type: DTAVQualificationResults
See Also

Reference

JobQualificationResults Class
DoubleTake.Jobs.Contract Namespace


JobQualificationResults.DTHVQualificationResults Property

JobQualificationResultsDTHVQualificationResults Property
This value represents configuration information for agentless Hyper-V jobs.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public DTHVQualificationResults DTHVQualificationResults { get; set; }
Public Property DTHVQualificationResults As DTHVQualificationResults
    Get
    Set
public:
property DTHVQualificationResults^ DTHVQualificationResults {
    DTHVQualificationResults^ get ();
    void set (DTHVQualificationResults^ value);
}
function get_DTHVQualificationResults();
function set_DTHVQualificationResults(value);

Property Value

Type: DTHVQualificationResults
The possible options that apply to DTHV job.
See Also

Reference

JobQualificationResults Class
DoubleTake.Jobs.Contract Namespace


JobQualificationResults.ExtensionData Property

JobQualificationResultsExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

JobQualificationResults Class
DoubleTake.Jobs.Contract Namespace


JobQualificationResults.SourceBehindNat Property

JobQualificationResultsSourceBehindNat Property
This value is true if the source is located behind a NAT router; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool SourceBehindNat { get; set; }
Public Property SourceBehindNat As Boolean
    Get
    Set
public:
property bool SourceBehindNat {
    bool get ();
    void set (bool value);
}
function get_SourceBehindNat();
function set_SourceBehindNat(value);

Property Value

Type: Boolean
if the source is behind a NAT firewall; otherwise, .
See Also

Reference

JobQualificationResults Class
DoubleTake.Jobs.Contract Namespace


JobQualificationResults.SourceHostUri Property

JobQualificationResultsSourceHostUri Property
This value is the source URI.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Uri SourceHostUri { get; set; }
Public Property SourceHostUri As Uri
    Get
    Set
public:
property Uri^ SourceHostUri {
    Uri^ get ();
    void set (Uri^ value);
}
function get_SourceHostUri();
function set_SourceHostUri(value);

Property Value

Type: Uri
The source host URI.
See Also

Reference

JobQualificationResults Class
DoubleTake.Jobs.Contract Namespace


JobQualificationResults.SupportsFrameworkMonitoring Property

JobQualificationResultsSupportsFrameworkMonitoring Property
This value is true if the server supports failover monitoring; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool SupportsFrameworkMonitoring { get; set; }
Public Property SupportsFrameworkMonitoring As Boolean
    Get
    Set
public:
property bool SupportsFrameworkMonitoring {
    bool get ();
    void set (bool value);
}
function get_SupportsFrameworkMonitoring();
function set_SupportsFrameworkMonitoring(value);

Property Value

Type: Boolean
if the machine supports framework monitoring; otherwise, .
See Also

Reference

JobQualificationResults Class
DoubleTake.Jobs.Contract Namespace


JobQualificationResults.SuppressFailoverMonitorOptions Property

JobQualificationResultsSuppressFailoverMonitorOptions Property
This value is true if failover monitoring options are suppressed; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool SuppressFailoverMonitorOptions { get; set; }
Public Property SuppressFailoverMonitorOptions As Boolean
    Get
    Set
public:
property bool SuppressFailoverMonitorOptions {
    bool get ();
    void set (bool value);
}
function get_SuppressFailoverMonitorOptions();
function set_SuppressFailoverMonitorOptions(value);

Property Value

Type: Boolean
if failover monitor options are to be suppressed; otherwise, .
See Also

Reference

JobQualificationResults Class
DoubleTake.Jobs.Contract Namespace


JobQualificationResults.VcdVappQualificationResults Property

JobQualificationResultsVcdVappQualificationResults Property
This property is not applicable. It is reserved for future features.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VcdVappOptions VcdVappQualificationResults { get; set; }
Public Property VcdVappQualificationResults As VcdVappOptions
    Get
    Set
public:
property VcdVappOptions^ VcdVappQualificationResults {
    VcdVappOptions^ get ();
    void set (VcdVappOptions^ value);
}
function get_VcdVappQualificationResults();
function set_VcdVappQualificationResults(value);

Property Value

Type: VcdVappOptions
The possible options that apply to new DTVI job.
See Also

Reference

JobQualificationResults Class
DoubleTake.Jobs.Contract Namespace


JobQualificationResults.VRAQualificationResults Property

JobQualificationResultsVRAQualificationResults Property
This value represents configuration information for guest-level virtual jobs.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VRAQualificationResults VRAQualificationResults { get; set; }
Public Property VRAQualificationResults As VRAQualificationResults
    Get
    Set
public:
property VRAQualificationResults^ VRAQualificationResults {
    VRAQualificationResults^ get ();
    void set (VRAQualificationResults^ value);
}
function get_VRAQualificationResults();
function set_VRAQualificationResults(value);

Property Value

Type: VRAQualificationResults
The possible options that apply to VRA job.
See Also

Reference

JobQualificationResults Class
DoubleTake.Jobs.Contract Namespace


JobStatistics Class

JobStatistics Class
Represents the current statistics for a job.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractJobStatistics

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class JobStatistics : IExtensibleDataObject
Public Class JobStatistics
    Implements IExtensibleDataObject
public ref class JobStatistics : IExtensibleDataObject
DoubleTake.Jobs.Contract.JobStatistics = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.JobStatistics',
    null,
    IExtensibleDataObject);

The JobStatistics type exposes the following members.

Constructors
 | Name | Description
Public method | JobStatistics | Initializes a new instance of the JobStatistics class
Top
Properties
 | Name | Description
Public property | CoreConnectionDetails | This value represents the details of the connection.
Public property | CoreMonitorDetails | This value represents the details of failover monitoring.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | FullServerJobDetails | This value represents the details of a full server job.
Public property | ImageProtectionJobDetails | This value represents the details of a Double-Take DR protection job.
Public property | ImageRecoveryJobDetails | This value represents the details of a Double-Take DR recovery job.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


JobStatistics Constructor

JobStatistics Constructor
Initializes a new instance of the JobStatistics class

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public JobStatistics()
Public Sub New
public:
JobStatistics()
DoubleTake.Jobs.Contract.JobStatistics = function();
See Also

Reference

JobStatistics Class
DoubleTake.Jobs.Contract Namespace


JobStatistics Properties

JobStatistics Properties

The JobStatistics type exposes the following members.

Properties
 | Name | Description
Public property | CoreConnectionDetails | This value represents the details of the connection.
Public property | CoreMonitorDetails | This value represents the details of failover monitoring.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | FullServerJobDetails | This value represents the details of a full server job.
Public property | ImageProtectionJobDetails | This value represents the details of a Double-Take DR protection job.
Public property | ImageRecoveryJobDetails | This value represents the details of a Double-Take DR recovery job.
Top
See Also

Reference

JobStatistics Class
DoubleTake.Jobs.Contract Namespace


JobStatistics.CoreConnectionDetails Property

JobStatisticsCoreConnectionDetails Property
This value represents the details of the connection.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public CoreConnectionDetails CoreConnectionDetails { get; set; }
Public Property CoreConnectionDetails As CoreConnectionDetails
    Get
    Set
public:
property CoreConnectionDetails^ CoreConnectionDetails {
    CoreConnectionDetails^ get ();
    void set (CoreConnectionDetails^ value);
}
function get_CoreConnectionDetails();
function set_CoreConnectionDetails(value);

Property Value

Type: CoreConnectionDetails
The core connection details.
See Also

Reference

JobStatistics Class
DoubleTake.Jobs.Contract Namespace


JobStatistics.CoreMonitorDetails Property

JobStatisticsCoreMonitorDetails Property
This value represents the details of failover monitoring.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public CoreMonitorDetails CoreMonitorDetails { get; set; }
Public Property CoreMonitorDetails As CoreMonitorDetails
    Get
    Set
public:
property CoreMonitorDetails^ CoreMonitorDetails {
    CoreMonitorDetails^ get ();
    void set (CoreMonitorDetails^ value);
}
function get_CoreMonitorDetails();
function set_CoreMonitorDetails(value);

Property Value

Type: CoreMonitorDetails
The core monitor details.
See Also

Reference

JobStatistics Class
DoubleTake.Jobs.Contract Namespace


JobStatistics.ExtensionData Property

JobStatisticsExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

JobStatistics Class
DoubleTake.Jobs.Contract Namespace


JobStatistics.FullServerJobDetails Property

JobStatisticsFullServerJobDetails Property
This value represents the details of a full server job.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public FullServerJobDetails FullServerJobDetails { get; set; }
Public Property FullServerJobDetails As FullServerJobDetails
    Get
    Set
public:
property FullServerJobDetails^ FullServerJobDetails {
    FullServerJobDetails^ get ();
    void set (FullServerJobDetails^ value);
}
function get_FullServerJobDetails();
function set_FullServerJobDetails(value);

Property Value

Type: FullServerJobDetails
The full server job details.
See Also

Reference

JobStatistics Class
DoubleTake.Jobs.Contract Namespace


JobStatistics.ImageProtectionJobDetails Property

JobStatisticsImageProtectionJobDetails Property
This value represents the details of a Double-Take DR protection job.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ImageProtectionJobDetails ImageProtectionJobDetails { get; set; }
Public Property ImageProtectionJobDetails As ImageProtectionJobDetails
    Get
    Set
public:
property ImageProtectionJobDetails^ ImageProtectionJobDetails {
    ImageProtectionJobDetails^ get ();
    void set (ImageProtectionJobDetails^ value);
}
function get_ImageProtectionJobDetails();
function set_ImageProtectionJobDetails(value);

Property Value

Type: ImageProtectionJobDetails
The image protection job details.
See Also

Reference

JobStatistics Class
DoubleTake.Jobs.Contract Namespace


JobStatistics.ImageRecoveryJobDetails Property

JobStatisticsImageRecoveryJobDetails Property
This value represents the details of a Double-Take DR recovery job.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ImageRecoveryJobDetails ImageRecoveryJobDetails { get; set; }
Public Property ImageRecoveryJobDetails As ImageRecoveryJobDetails
    Get
    Set
public:
property ImageRecoveryJobDetails^ ImageRecoveryJobDetails {
    ImageRecoveryJobDetails^ get ();
    void set (ImageRecoveryJobDetails^ value);
}
function get_ImageRecoveryJobDetails();
function set_ImageRecoveryJobDetails(value);

Property Value

Type: ImageRecoveryJobDetails
The image recovery job details.
See Also

Reference

JobStatistics Class
DoubleTake.Jobs.Contract Namespace


JobStatus Class

JobStatus Class
Represents the current status of a job.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractJobStatus

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class JobStatus : IExtensibleDataObject
Public Class JobStatus
    Implements IExtensibleDataObject
public ref class JobStatus : IExtensibleDataObject
DoubleTake.Jobs.Contract.JobStatus = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.JobStatus',
    null,
    IExtensibleDataObject);

The JobStatus type exposes the following members.

Constructors
 | Name | Description
Public method | JobStatus | Initializes a new instance of the JobStatus class
Top
Properties
 | Name | Description
Public property | Actions | This value represents an action recently reported by a job.
Public property | CanCreateImageRecovery | This value is true if the job can be used to create an image recovery; otherwise, it is false.
Public property | CanDelete | This value is true if you can delete the job; otherwise, it is false.
Public property | CanEdit | This value is true if the job can be edited; otherwise, it is false.
Public property | CanFailback | This value is true if the job can be failed back; otherwise, it is false.
Public property | CanFailover | This value is true if the job can be failed over; otherwise, it is false.
Public property | CanPause | This value is true if the job can be can be paused; otherwise, it is false.
Public property | CanRestore | This value is true if the job can be restored; otherwise, it is false.
Public property | CanReverse | This value is true if the job can be reversed; otherwise, it is false.
Public property | CanStart | This value is true if the job can be started; otherwise, it is false.
Public property | CanStop | This value is true if the job can be stopped; otherwise, it is false.
Public property | CanUndoFailover | This value is true if the failover of the job can be undone; otherwise, it is false.
Public property | EngineControlStatuses | This value represents the status of the replication engine.
Public property | ExtendedLowLevelStates | This value represents additional information about the low level job state.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Health | This value represents the high level health of the job.
Public property | HighLevelState | This value represents high level job states. High level states typically map to phases of the job's overall lifecycle, like mirroring or failing over. Jobs will pass through various high level states during their lifetime, and the types of high level states are usually shared between jobs, regardless of job type.
Public property | IsInError | This value is true if the job is in an error state; otherwise, it is false.
Public property | LowLevelState | This value is a low level job state. Low level states typically map to individual steps the job is performing at any given time, like attaching virtual disks or updating DNS. Low level states provide detailed information about a job's current state or action and will vary between different job types.
Public property | PermillageComplete | This value is the percentage of the current activity for that job that is complete. To display a percentage string for an arbitrary activity, jobs can provide a value for this property, and that value will be formatted and displayed in the client. To remove the display of the percentage, set this property to zero.
Public property | TargetState | This value is derived from TargetStates. Information from the connection is distilled into a string key which is sent to the client for display.
Top
Fields
Name | Description
EmptyPermillageComplete | Defines the value for [P:PermillageComplete] that will prevent the percentage from being displayed in the UI.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


JobStatus Constructor

JobStatus Constructor
Initializes a new instance of the JobStatus class

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public JobStatus()
Public Sub New
public:
JobStatus()
DoubleTake.Jobs.Contract.JobStatus = function();
See Also

Reference

JobStatus Class
DoubleTake.Jobs.Contract Namespace


JobStatus Properties

JobStatus Properties

The JobStatus type exposes the following members.

Properties
 | Name | Description
Public property | Actions | This value represents an action recently reported by a job.
Public property | CanCreateImageRecovery | This value is true if the job can be used to create an image recovery; otherwise, it is false.
Public property | CanDelete | This value is true if you can delete the job; otherwise, it is false.
Public property | CanEdit | This value is true if the job can be edited; otherwise, it is false.
Public property | CanFailback | This value is true if the job can be failed back; otherwise, it is false.
Public property | CanFailover | This value is true if the job can be failed over; otherwise, it is false.
Public property | CanPause | This value is true if the job can be can be paused; otherwise, it is false.
Public property | CanRestore | This value is true if the job can be restored; otherwise, it is false.
Public property | CanReverse | This value is true if the job can be reversed; otherwise, it is false.
Public property | CanStart | This value is true if the job can be started; otherwise, it is false.
Public property | CanStop | This value is true if the job can be stopped; otherwise, it is false.
Public property | CanUndoFailover | This value is true if the failover of the job can be undone; otherwise, it is false.
Public property | EngineControlStatuses | This value represents the status of the replication engine.
Public property | ExtendedLowLevelStates | This value represents additional information about the low level job state.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Health | This value represents the high level health of the job.
Public property | HighLevelState | This value represents high level job states. High level states typically map to phases of the job's overall lifecycle, like mirroring or failing over. Jobs will pass through various high level states during their lifetime, and the types of high level states are usually shared between jobs, regardless of job type.
Public property | IsInError | This value is true if the job is in an error state; otherwise, it is false.
Public property | LowLevelState | This value is a low level job state. Low level states typically map to individual steps the job is performing at any given time, like attaching virtual disks or updating DNS. Low level states provide detailed information about a job's current state or action and will vary between different job types.
Public property | PermillageComplete | This value is the percentage of the current activity for that job that is complete. To display a percentage string for an arbitrary activity, jobs can provide a value for this property, and that value will be formatted and displayed in the client. To remove the display of the percentage, set this property to zero.
Public property | TargetState | This value is derived from TargetStates. Information from the connection is distilled into a string key which is sent to the client for display.
Top
See Also

Reference

JobStatus Class
DoubleTake.Jobs.Contract Namespace


JobStatus.Actions Property

JobStatusActions Property
This value represents an action recently reported by a job.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public JobAction[] Actions { get; set; }
Public Property Actions As JobAction()
    Get
    Set
public:
property array<JobAction^>^ Actions {
    array<JobAction^>^ get ();
    void set (array<JobAction^>^ value);
}
function get_Actions();
function set_Actions(value);

Property Value

Type: JobAction
An array of JobAction that represents actions associated with this job.
See Also

Reference

JobStatus Class
DoubleTake.Jobs.Contract Namespace


JobStatus.CanCreateImageRecovery Property

JobStatusCanCreateImageRecovery Property
This value is true if the job can be used to create an image recovery; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool CanCreateImageRecovery { get; set; }
Public Property CanCreateImageRecovery As Boolean
    Get
    Set
public:
property bool CanCreateImageRecovery {
    bool get ();
    void set (bool value);
}
function get_CanCreateImageRecovery();
function set_CanCreateImageRecovery(value);

Property Value

Type: Boolean
if this job can currently be used to create an image recovery; otherwise, .
See Also

Reference

JobStatus Class
DoubleTake.Jobs.Contract Namespace


JobStatus.CanDelete Property

JobStatusCanDelete Property
This value is true if you can delete the job; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool CanDelete { get; set; }
Public Property CanDelete As Boolean
    Get
    Set
public:
property bool CanDelete {
    bool get ();
    void set (bool value);
}
function get_CanDelete();
function set_CanDelete(value);

Property Value

Type: Boolean
if this job can currently be deleted; otherwise, .
See Also

Reference

JobStatus Class
DoubleTake.Jobs.Contract Namespace


JobStatus.CanEdit Property

JobStatusCanEdit Property
This value is true if the job can be edited; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool CanEdit { get; set; }
Public Property CanEdit As Boolean
    Get
    Set
public:
property bool CanEdit {
    bool get ();
    void set (bool value);
}
function get_CanEdit();
function set_CanEdit(value);

Property Value

Type: Boolean
if this job can currently be edited; otherwise, .
See Also

Reference

JobStatus Class
DoubleTake.Jobs.Contract Namespace


JobStatus.CanFailback Property

JobStatusCanFailback Property
This value is true if the job can be failed back; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool CanFailback { get; set; }
Public Property CanFailback As Boolean
    Get
    Set
public:
property bool CanFailback {
    bool get ();
    void set (bool value);
}
function get_CanFailback();
function set_CanFailback(value);

Property Value

Type: Boolean
if this job can currently be failed back; otherwise, .
See Also

Reference

JobStatus Class
DoubleTake.Jobs.Contract Namespace


JobStatus.CanFailover Property

JobStatusCanFailover Property
This value is true if the job can be failed over; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool CanFailover { get; set; }
Public Property CanFailover As Boolean
    Get
    Set
public:
property bool CanFailover {
    bool get ();
    void set (bool value);
}
function get_CanFailover();
function set_CanFailover(value);

Property Value

Type: Boolean
if this job can currently be failed over; otherwise, .
See Also

Reference

JobStatus Class
DoubleTake.Jobs.Contract Namespace


JobStatus.CanPause Property

JobStatusCanPause Property
This value is true if the job can be can be paused; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool CanPause { get; set; }
Public Property CanPause As Boolean
    Get
    Set
public:
property bool CanPause {
    bool get ();
    void set (bool value);
}
function get_CanPause();
function set_CanPause(value);

Property Value

Type: Boolean
if this job can currently be paused; otherwise, .
See Also

Reference

JobStatus Class
DoubleTake.Jobs.Contract Namespace


JobStatus.CanRestore Property

JobStatusCanRestore Property
This value is true if the job can be restored; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool CanRestore { get; set; }
Public Property CanRestore As Boolean
    Get
    Set
public:
property bool CanRestore {
    bool get ();
    void set (bool value);
}
function get_CanRestore();
function set_CanRestore(value);

Property Value

Type: Boolean
if this job can currently be restored; otherwise, .
See Also

Reference

JobStatus Class
DoubleTake.Jobs.Contract Namespace


JobStatus.CanReverse Property

JobStatusCanReverse Property
This value is true if the job can be reversed; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool CanReverse { get; set; }
Public Property CanReverse As Boolean
    Get
    Set
public:
property bool CanReverse {
    bool get ();
    void set (bool value);
}
function get_CanReverse();
function set_CanReverse(value);

Property Value

Type: Boolean
if this job can currently be reversed; otherwise, .
See Also

Reference

JobStatus Class
DoubleTake.Jobs.Contract Namespace


JobStatus.CanStart Property

JobStatusCanStart Property
This value is true if the job can be started; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool CanStart { get; set; }
Public Property CanStart As Boolean
    Get
    Set
public:
property bool CanStart {
    bool get ();
    void set (bool value);
}
function get_CanStart();
function set_CanStart(value);

Property Value

Type: Boolean
if this job can currently be started; otherwise, .
See Also

Reference

JobStatus Class
DoubleTake.Jobs.Contract Namespace


JobStatus.CanStop Property

JobStatusCanStop Property
This value is true if the job can be stopped; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool CanStop { get; set; }
Public Property CanStop As Boolean
    Get
    Set
public:
property bool CanStop {
    bool get ();
    void set (bool value);
}
function get_CanStop();
function set_CanStop(value);

Property Value

Type: Boolean
if this job can currently be stopped.; otherwise, .
See Also

Reference

JobStatus Class
DoubleTake.Jobs.Contract Namespace


JobStatus.CanUndoFailover Property

JobStatusCanUndoFailover Property
This value is true if the failover of the job can be undone; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool CanUndoFailover { get; set; }
Public Property CanUndoFailover As Boolean
    Get
    Set
public:
property bool CanUndoFailover {
    bool get ();
    void set (bool value);
}
function get_CanUndoFailover();
function set_CanUndoFailover(value);

Property Value

Type: Boolean
if the failover of this job can be currently undone; otherwise, .
See Also

Reference

JobStatus Class
DoubleTake.Jobs.Contract Namespace


JobStatus.EngineControlStatuses Property

JobStatusEngineControlStatuses Property
This value represents the status of the replication engine.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public EngineControlStatus[] EngineControlStatuses { get; set; }
Public Property EngineControlStatuses As EngineControlStatus()
    Get
    Set
public:
property array<EngineControlStatus^>^ EngineControlStatuses {
    array<EngineControlStatus^>^ get ();
    void set (array<EngineControlStatus^>^ value);
}
function get_EngineControlStatuses();
function set_EngineControlStatuses(value);

Property Value

Type: EngineControlStatus
The engine control statuses.
See Also

Reference

JobStatus Class
DoubleTake.Jobs.Contract Namespace


JobStatus.ExtendedLowLevelStates Property

JobStatusExtendedLowLevelStates Property
This value represents additional information about the low level job state.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtendedLowLevelState[] ExtendedLowLevelStates { get; set; }
Public Property ExtendedLowLevelStates As ExtendedLowLevelState()
    Get
    Set
public:
property array<ExtendedLowLevelState^>^ ExtendedLowLevelStates {
    array<ExtendedLowLevelState^>^ get ();
    void set (array<ExtendedLowLevelState^>^ value);
}
function get_ExtendedLowLevelStates();
function set_ExtendedLowLevelStates(value);

Property Value

Type: ExtendedLowLevelState
The low level states of this job.
Remarks
Additional information about the low level state.
See Also

Reference

JobStatus Class
DoubleTake.Jobs.Contract Namespace


JobStatus.ExtensionData Property

JobStatusExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

JobStatus Class
DoubleTake.Jobs.Contract Namespace


JobStatus.Health Property

JobStatusHealth Property
This value represents the high level health of the job.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Health Health { get; set; }
Public Property Health As Health
    Get
    Set
public:
property Health Health {
    Health get ();
    void set (Health value);
}
function get_Health();
function set_Health(value);

Property Value

Type: Health
The health of this job.
Remarks
Job health is an at-a-glance indication of whether the job is working correctly. Users can be assured that a job whose health is [F:Ok] is working properly, while a job whose health is [F:Warning] should be more closely monitored, and a job whose health is [F:Error] requires immediate attention.
See Also

Reference

JobStatus Class
DoubleTake.Jobs.Contract Namespace


JobStatus.HighLevelState Property

JobStatusHighLevelState Property
This value represents high level job states. High level states typically map to phases of the job's overall lifecycle, like mirroring or failing over. Jobs will pass through various high level states during their lifetime, and the types of high level states are usually shared between jobs, regardless of job type.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public HighLevelState HighLevelState { get; set; }
Public Property HighLevelState As HighLevelState
    Get
    Set
public:
property HighLevelState HighLevelState {
    HighLevelState get ();
    void set (HighLevelState value);
}
function get_HighLevelState();
function set_HighLevelState(value);

Property Value

Type: HighLevelState
The high level state of this job.
Remarks
High level states of a job typically map to phases of the job's overall lifecycle. Examples include "mirroring", "replicating", "failing over", etc. Jobs will pass through various high level states during their lifetime, and the types of high level states are usually shared between jobs, regardless of the job's purpose.
See Also

Reference

JobStatus Class
DoubleTake.Jobs.Contract Namespace


JobStatus.IsInError Property

JobStatusIsInError Property
This value is true if the job is in an error state; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsInError { get; set; }
Public Property IsInError As Boolean
    Get
    Set
public:
property bool IsInError {
    bool get ();
    void set (bool value);
}
function get_IsInError();
function set_IsInError(value);

Property Value

Type: Boolean
if this job is in an error state; otherwise, .
See Also

Reference

JobStatus Class
DoubleTake.Jobs.Contract Namespace


JobStatus.LowLevelState Property

JobStatusLowLevelState Property
This value is a low level job state. Low level states typically map to individual steps the job is performing at any given time, like attaching virtual disks or updating DNS. Low level states provide detailed information about a job's current state or action and will vary between different job types.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string LowLevelState { get; set; }
Public Property LowLevelState As String
    Get
    Set
public:
property String^ LowLevelState {
    String^ get ();
    void set (String^ value);
}
function get_LowLevelState();
function set_LowLevelState(value);

Property Value

Type: String
The low level state of this job.
Remarks
Low level states of a job typically map to individual steps the job is performing at any given time. Examples include "attaching virtual disks", "system state processing", "updating DNS", etc. Low level state provides detailed information about what's going on with the job right now, and will widely vary between jobs with different purpose.
See Also

Reference

JobStatus Class
DoubleTake.Jobs.Contract Namespace


JobStatus.PermillageComplete Property

JobStatusPermillageComplete Property
This value is the percentage of the current activity for that job that is complete. To display a percentage string for an arbitrary activity, jobs can provide a value for this property, and that value will be formatted and displayed in the client. To remove the display of the percentage, set this property to zero.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int PermillageComplete { get; set; }
Public Property PermillageComplete As Integer
    Get
    Set
public:
property int PermillageComplete {
    int get ();
    void set (int value);
}
function get_PermillageComplete();
function set_PermillageComplete(value);

Property Value

Type: Int32
The permillage complete of the current activity of this job.
Remarks
To display a "percent complete" string for an arbitrary activity, jobs can provide a value for this property, and that value will be formatted and displayed in the console. To remove the display of the percentage, set this property to zero.
See Also

Reference

JobStatus Class
DoubleTake.Jobs.Contract Namespace


JobStatus.TargetState Property

JobStatusTargetState Property
This value is derived from TargetStates. Information from the connection is distilled into a string key which is sent to the client for display.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string TargetState { get; set; }
Public Property TargetState As String
    Get
    Set
public:
property String^ TargetState {
    String^ get ();
    void set (String^ value);
}
function get_TargetState();
function set_TargetState(value);

Property Value

Type: String
The state of the data on the target server.
Remarks
Target state is derived from a number TargetStates values. Information from the connection is distilled into a string key which is sent to the client for display.
See Also

Reference

JobStatus Class
DoubleTake.Jobs.Contract Namespace


JobStatus Fields

JobStatus Fields

The JobStatus type exposes the following members.

Fields
Name | Description
EmptyPermillageComplete | Defines the value for [P:PermillageComplete] that will prevent the percentage from being displayed in the UI.
Top
See Also

Reference

JobStatus Class
DoubleTake.Jobs.Contract Namespace


JobStatus.EmptyPermillageComplete Field

JobStatusEmptyPermillageComplete Field
Defines the value for [P:PermillageComplete] that will prevent the percentage from being displayed in the UI.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const int EmptyPermillageComplete
Public Const EmptyPermillageComplete As Integer
public:
literal int EmptyPermillageComplete
var DoubleTake.Jobs.Contract.JobStatus.EmptyPermillageComplete

Field Value

Type: Int32
See Also

Reference

JobStatus Class
DoubleTake.Jobs.Contract Namespace


JobTypeNames Class

JobTypeNames Class
Defines constants that represent known job type names. These constants are used as values for the JobType property.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractJobTypeNames

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public static class JobTypeNames
Public NotInheritable Class JobTypeNames
public ref class JobTypeNames abstract sealed
DoubleTake.Jobs.Contract.JobTypeNames = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.JobTypeNames');

The JobTypeNames type exposes the following members.

Properties
Name | Description
All |
LinuxJobTypes |
VirtualJobTypes |
WindowsJobTypes |
Top
Fields
Name | Description
Cloud |
ClusterAwareDthv | A job type for a cluster-aware Hyper-V job.
ClusterAwareFilesAndFolders | A Cluster Aware Files and Folders Job
ClusterAwareHV2V | A job type for a cluster-aware HV2V job.
ClusterAwareMultiSelectDthv | A job type for a cluster-aware multi select Hyper-V job.
DataOnlyImageProtection | A job type for a data-only image protection job.
DataOnlyImageRecovery | A job type for a data-only image recovery job.
Diagnostics | Throughput Diagnostic Utility connections.
DtavVapp | A job type for a VMware VApp to VApp Host-Level job.
DtavVm | A job type for a VMware virtual to virtual Host-Level job.
Dthv | A job type for a Host Hyper_V job.
Exchange | An Exchange application workload.
ExchangeClustered | An Exchange application workload.
FilesAndFolders | A job type for a files-and-folders job.
FullServerFailover | A job type for a full-server failover job.
FullServerImageProtection | A job type for a full-server image protection job.
FullServerImageRecovery | A job type for a full-server image recovery job.
Legacy | Legacy jobs (limited job operations).
LinuxCloud |
LinuxFullServerFailover | A job type for a linux full-server failover job.
LinuxMoveDataOnlyMigration | A job type for a Move data-only migration job.
LinuxMoveServerMigration | A job type for a Move server migration job.
Lvra | Linux Virtual recovery assistant job type.
MoveDataOnlyMigration | A job type for a Move data-only migration job.
MoveLvra | Linux Move Virtual recovery assistant job type.
MoveServerMigration | A job type for a Move server migration job.
MultiSelectDthv | A job type for a multi select Host Hyper_V job.
OrphanedConnection | Connections that have been orphaned by jobs (delete only).
Sql | A SQL application workload.
SqlClustered | A Cluster aware SQL application workload.
UnmanagedConnection | Connections that we can only display (pre-5.3 connections).
Uvra | Universal Virtual recovery assistant jobs.
V2V | A job type for a virtual to virtual VRA job.
Vra | A job type for VRA job.
VraMove | A Move-style VRA job
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


JobTypeNames Properties

JobTypeNames Properties

The JobTypeNames type exposes the following members.

Properties
Name | Description
All |
LinuxJobTypes |
VirtualJobTypes |
WindowsJobTypes |
Top
See Also

Reference

JobTypeNames Class
DoubleTake.Jobs.Contract Namespace


JobTypeNames.All Property

JobTypeNamesAll Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public static IEnumerable<string> All { get; }
Public Shared ReadOnly Property All As IEnumerable(Of String)
    Get
public:
static property IEnumerable<String^>^ All {
    IEnumerable<String^>^ get ();
}
DoubleTake.Jobs.Contract.JobTypeNames.get_All = function();

Property Value

Type: IEnumerable String
See Also

Reference

JobTypeNames Class
DoubleTake.Jobs.Contract Namespace


JobTypeNames.LinuxJobTypes Property

JobTypeNamesLinuxJobTypes Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public static IEnumerable<string> LinuxJobTypes { get; }
Public Shared ReadOnly Property LinuxJobTypes As IEnumerable(Of String)
    Get
public:
static property IEnumerable<String^>^ LinuxJobTypes {
    IEnumerable<String^>^ get ();
}
DoubleTake.Jobs.Contract.JobTypeNames.get_LinuxJobTypes = function();

Property Value

Type: IEnumerable String
See Also

Reference

JobTypeNames Class
DoubleTake.Jobs.Contract Namespace


JobTypeNames.VirtualJobTypes Property

JobTypeNamesVirtualJobTypes Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public static IEnumerable<string> VirtualJobTypes { get; }
Public Shared ReadOnly Property VirtualJobTypes As IEnumerable(Of String)
    Get
public:
static property IEnumerable<String^>^ VirtualJobTypes {
    IEnumerable<String^>^ get ();
}
DoubleTake.Jobs.Contract.JobTypeNames.get_VirtualJobTypes = function();

Property Value

Type: IEnumerable String
See Also

Reference

JobTypeNames Class
DoubleTake.Jobs.Contract Namespace


JobTypeNames.WindowsJobTypes Property

JobTypeNamesWindowsJobTypes Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public static IEnumerable<string> WindowsJobTypes { get; }
Public Shared ReadOnly Property WindowsJobTypes As IEnumerable(Of String)
    Get
public:
static property IEnumerable<String^>^ WindowsJobTypes {
    IEnumerable<String^>^ get ();
}
DoubleTake.Jobs.Contract.JobTypeNames.get_WindowsJobTypes = function();

Property Value

Type: IEnumerable String
See Also

Reference

JobTypeNames Class
DoubleTake.Jobs.Contract Namespace


JobTypeNames Fields

JobTypeNames Fields

The JobTypeNames type exposes the following members.

Fields
Name | Description
Cloud |
ClusterAwareDthv | A job type for a cluster-aware Hyper-V job.
ClusterAwareFilesAndFolders | A Cluster Aware Files and Folders Job
ClusterAwareHV2V | A job type for a cluster-aware HV2V job.
ClusterAwareMultiSelectDthv | A job type for a cluster-aware multi select Hyper-V job.
DataOnlyImageProtection | A job type for a data-only image protection job.
DataOnlyImageRecovery | A job type for a data-only image recovery job.
Diagnostics | Throughput Diagnostic Utility connections.
DtavVapp | A job type for a VMware VApp to VApp Host-Level job.
DtavVm | A job type for a VMware virtual to virtual Host-Level job.
Dthv | A job type for a Host Hyper_V job.
Exchange | An Exchange application workload.
ExchangeClustered | An Exchange application workload.
FilesAndFolders | A job type for a files-and-folders job.
FullServerFailover | A job type for a full-server failover job.
FullServerImageProtection | A job type for a full-server image protection job.
FullServerImageRecovery | A job type for a full-server image recovery job.
Legacy | Legacy jobs (limited job operations).
LinuxCloud |
LinuxFullServerFailover | A job type for a linux full-server failover job.
LinuxMoveDataOnlyMigration | A job type for a Move data-only migration job.
LinuxMoveServerMigration | A job type for a Move server migration job.
Lvra | Linux Virtual recovery assistant job type.
MoveDataOnlyMigration | A job type for a Move data-only migration job.
MoveLvra | Linux Move Virtual recovery assistant job type.
MoveServerMigration | A job type for a Move server migration job.
MultiSelectDthv | A job type for a multi select Host Hyper_V job.
OrphanedConnection | Connections that have been orphaned by jobs (delete only).
Sql | A SQL application workload.
SqlClustered | A Cluster aware SQL application workload.
UnmanagedConnection | Connections that we can only display (pre-5.3 connections).
Uvra | Universal Virtual recovery assistant jobs.
V2V | A job type for a virtual to virtual VRA job.
Vra | A job type for VRA job.
VraMove | A Move-style VRA job
Top
See Also

Reference

JobTypeNames Class
DoubleTake.Jobs.Contract Namespace


JobTypeNames.Cloud Field

JobTypeNamesCloud Field

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string Cloud
Public Const Cloud As String
public:
literal String^ Cloud
var DoubleTake.Jobs.Contract.JobTypeNames.Cloud

Field Value

Type: String
See Also

Reference

JobTypeNames Class
DoubleTake.Jobs.Contract Namespace


JobTypeNames.ClusterAwareDthv Field

JobTypeNamesClusterAwareDthv Field
A job type for a cluster-aware Hyper-V job.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string ClusterAwareDthv
Public Const ClusterAwareDthv As String
public:
literal String^ ClusterAwareDthv
var DoubleTake.Jobs.Contract.JobTypeNames.ClusterAwareDthv

Field Value

Type: String
See Also

Reference

JobTypeNames Class
DoubleTake.Jobs.Contract Namespace


JobTypeNames.ClusterAwareFilesAndFolders Field

JobTypeNamesClusterAwareFilesAndFolders Field
A Cluster Aware Files and Folders Job

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string ClusterAwareFilesAndFolders
Public Const ClusterAwareFilesAndFolders As String
public:
literal String^ ClusterAwareFilesAndFolders
var DoubleTake.Jobs.Contract.JobTypeNames.ClusterAwareFilesAndFolders

Field Value

Type: String
See Also

Reference

JobTypeNames Class
DoubleTake.Jobs.Contract Namespace


JobTypeNames.ClusterAwareHV2V Field

JobTypeNamesClusterAwareHV2V Field
A job type for a cluster-aware HV2V job.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string ClusterAwareHV2V
Public Const ClusterAwareHV2V As String
public:
literal String^ ClusterAwareHV2V
var DoubleTake.Jobs.Contract.JobTypeNames.ClusterAwareHV2V

Field Value

Type: String
See Also

Reference

JobTypeNames Class
DoubleTake.Jobs.Contract Namespace


JobTypeNames.ClusterAwareMultiSelectDthv Field

JobTypeNamesClusterAwareMultiSelectDthv Field
A job type for a cluster-aware multi select Hyper-V job.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string ClusterAwareMultiSelectDthv
Public Const ClusterAwareMultiSelectDthv As String
public:
literal String^ ClusterAwareMultiSelectDthv
var DoubleTake.Jobs.Contract.JobTypeNames.ClusterAwareMultiSelectDthv

Field Value

Type: String
See Also

Reference

JobTypeNames Class
DoubleTake.Jobs.Contract Namespace


JobTypeNames.DataOnlyImageProtection Field

JobTypeNamesDataOnlyImageProtection Field
A job type for a data-only image protection job.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string DataOnlyImageProtection
Public Const DataOnlyImageProtection As String
public:
literal String^ DataOnlyImageProtection
var DoubleTake.Jobs.Contract.JobTypeNames.DataOnlyImageProtection

Field Value

Type: String
See Also

Reference

JobTypeNames Class
DoubleTake.Jobs.Contract Namespace


JobTypeNames.DataOnlyImageRecovery Field

JobTypeNamesDataOnlyImageRecovery Field
A job type for a data-only image recovery job.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string DataOnlyImageRecovery
Public Const DataOnlyImageRecovery As String
public:
literal String^ DataOnlyImageRecovery
var DoubleTake.Jobs.Contract.JobTypeNames.DataOnlyImageRecovery

Field Value

Type: String
See Also

Reference

JobTypeNames Class
DoubleTake.Jobs.Contract Namespace


JobTypeNames.Diagnostics Field

JobTypeNamesDiagnostics Field
Throughput Diagnostic Utility connections.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string Diagnostics
Public Const Diagnostics As String
public:
literal String^ Diagnostics
var DoubleTake.Jobs.Contract.JobTypeNames.Diagnostics

Field Value

Type: String
See Also

Reference

JobTypeNames Class
DoubleTake.Jobs.Contract Namespace


JobTypeNames.DtavVapp Field

JobTypeNamesDtavVapp Field
A job type for a VMware VApp to VApp Host-Level job.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string DtavVapp
Public Const DtavVapp As String
public:
literal String^ DtavVapp
var DoubleTake.Jobs.Contract.JobTypeNames.DtavVapp

Field Value

Type: String
See Also

Reference

JobTypeNames Class
DoubleTake.Jobs.Contract Namespace


JobTypeNames.DtavVm Field

JobTypeNamesDtavVm Field
A job type for a VMware virtual to virtual Host-Level job.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string DtavVm
Public Const DtavVm As String
public:
literal String^ DtavVm
var DoubleTake.Jobs.Contract.JobTypeNames.DtavVm

Field Value

Type: String
See Also

Reference

JobTypeNames Class
DoubleTake.Jobs.Contract Namespace


JobTypeNames.Dthv Field

JobTypeNamesDthv Field
A job type for a Host Hyper_V job.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string Dthv
Public Const Dthv As String
public:
literal String^ Dthv
var DoubleTake.Jobs.Contract.JobTypeNames.Dthv

Field Value

Type: String
See Also

Reference

JobTypeNames Class
DoubleTake.Jobs.Contract Namespace


JobTypeNames.Exchange Field

JobTypeNamesExchange Field
An Exchange application workload.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string Exchange
Public Const Exchange As String
public:
literal String^ Exchange
var DoubleTake.Jobs.Contract.JobTypeNames.Exchange

Field Value

Type: String
See Also

Reference

JobTypeNames Class
DoubleTake.Jobs.Contract Namespace


JobTypeNames.ExchangeClustered Field

JobTypeNamesExchangeClustered Field
An Exchange application workload.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string ExchangeClustered
Public Const ExchangeClustered As String
public:
literal String^ ExchangeClustered
var DoubleTake.Jobs.Contract.JobTypeNames.ExchangeClustered

Field Value

Type: String
See Also

Reference

JobTypeNames Class
DoubleTake.Jobs.Contract Namespace


JobTypeNames.FilesAndFolders Field

JobTypeNamesFilesAndFolders Field
A job type for a files-and-folders job.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string FilesAndFolders
Public Const FilesAndFolders As String
public:
literal String^ FilesAndFolders
var DoubleTake.Jobs.Contract.JobTypeNames.FilesAndFolders

Field Value

Type: String
See Also

Reference

JobTypeNames Class
DoubleTake.Jobs.Contract Namespace


JobTypeNames.FullServerFailover Field

JobTypeNamesFullServerFailover Field
A job type for a full-server failover job.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string FullServerFailover
Public Const FullServerFailover As String
public:
literal String^ FullServerFailover
var DoubleTake.Jobs.Contract.JobTypeNames.FullServerFailover

Field Value

Type: String
See Also

Reference

JobTypeNames Class
DoubleTake.Jobs.Contract Namespace


JobTypeNames.FullServerImageProtection Field

JobTypeNamesFullServerImageProtection Field
A job type for a full-server image protection job.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string FullServerImageProtection
Public Const FullServerImageProtection As String
public:
literal String^ FullServerImageProtection
var DoubleTake.Jobs.Contract.JobTypeNames.FullServerImageProtection

Field Value

Type: String
See Also

Reference

JobTypeNames Class
DoubleTake.Jobs.Contract Namespace


JobTypeNames.FullServerImageRecovery Field

JobTypeNamesFullServerImageRecovery Field
A job type for a full-server image recovery job.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string FullServerImageRecovery
Public Const FullServerImageRecovery As String
public:
literal String^ FullServerImageRecovery
var DoubleTake.Jobs.Contract.JobTypeNames.FullServerImageRecovery

Field Value

Type: String
See Also

Reference

JobTypeNames Class
DoubleTake.Jobs.Contract Namespace


JobTypeNames.Legacy Field

JobTypeNamesLegacy Field
Legacy jobs (limited job operations).

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string Legacy
Public Const Legacy As String
public:
literal String^ Legacy
var DoubleTake.Jobs.Contract.JobTypeNames.Legacy

Field Value

Type: String
See Also

Reference

JobTypeNames Class
DoubleTake.Jobs.Contract Namespace


JobTypeNames.LinuxCloud Field

JobTypeNamesLinuxCloud Field

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string LinuxCloud
Public Const LinuxCloud As String
public:
literal String^ LinuxCloud
var DoubleTake.Jobs.Contract.JobTypeNames.LinuxCloud

Field Value

Type: String
See Also

Reference

JobTypeNames Class
DoubleTake.Jobs.Contract Namespace


JobTypeNames.LinuxFullServerFailover Field

JobTypeNamesLinuxFullServerFailover Field
A job type for a linux full-server failover job.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string LinuxFullServerFailover
Public Const LinuxFullServerFailover As String
public:
literal String^ LinuxFullServerFailover
var DoubleTake.Jobs.Contract.JobTypeNames.LinuxFullServerFailover

Field Value

Type: String
See Also

Reference

JobTypeNames Class
DoubleTake.Jobs.Contract Namespace


JobTypeNames.LinuxMoveDataOnlyMigration Field

JobTypeNamesLinuxMoveDataOnlyMigration Field
A job type for a Move data-only migration job.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string LinuxMoveDataOnlyMigration
Public Const LinuxMoveDataOnlyMigration As String
public:
literal String^ LinuxMoveDataOnlyMigration
var DoubleTake.Jobs.Contract.JobTypeNames.LinuxMoveDataOnlyMigration

Field Value

Type: String
See Also

Reference

JobTypeNames Class
DoubleTake.Jobs.Contract Namespace


JobTypeNames.LinuxMoveServerMigration Field

JobTypeNamesLinuxMoveServerMigration Field
A job type for a Move server migration job.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string LinuxMoveServerMigration
Public Const LinuxMoveServerMigration As String
public:
literal String^ LinuxMoveServerMigration
var DoubleTake.Jobs.Contract.JobTypeNames.LinuxMoveServerMigration

Field Value

Type: String
See Also

Reference

JobTypeNames Class
DoubleTake.Jobs.Contract Namespace


JobTypeNames.Lvra Field

JobTypeNamesLvra Field
Linux Virtual recovery assistant job type.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string Lvra
Public Const Lvra As String
public:
literal String^ Lvra
var DoubleTake.Jobs.Contract.JobTypeNames.Lvra

Field Value

Type: String
See Also

Reference

JobTypeNames Class
DoubleTake.Jobs.Contract Namespace


JobTypeNames.MoveDataOnlyMigration Field

JobTypeNamesMoveDataOnlyMigration Field
A job type for a Move data-only migration job.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string MoveDataOnlyMigration
Public Const MoveDataOnlyMigration As String
public:
literal String^ MoveDataOnlyMigration
var DoubleTake.Jobs.Contract.JobTypeNames.MoveDataOnlyMigration

Field Value

Type: String
See Also

Reference

JobTypeNames Class
DoubleTake.Jobs.Contract Namespace


JobTypeNames.MoveLvra Field

JobTypeNamesMoveLvra Field
Linux Move Virtual recovery assistant job type.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string MoveLvra
Public Const MoveLvra As String
public:
literal String^ MoveLvra
var DoubleTake.Jobs.Contract.JobTypeNames.MoveLvra

Field Value

Type: String
See Also

Reference

JobTypeNames Class
DoubleTake.Jobs.Contract Namespace


JobTypeNames.MoveServerMigration Field

JobTypeNamesMoveServerMigration Field
A job type for a Move server migration job.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string MoveServerMigration
Public Const MoveServerMigration As String
public:
literal String^ MoveServerMigration
var DoubleTake.Jobs.Contract.JobTypeNames.MoveServerMigration

Field Value

Type: String
See Also

Reference

JobTypeNames Class
DoubleTake.Jobs.Contract Namespace


JobTypeNames.MultiSelectDthv Field

JobTypeNamesMultiSelectDthv Field
A job type for a multi select Host Hyper_V job.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string MultiSelectDthv
Public Const MultiSelectDthv As String
public:
literal String^ MultiSelectDthv
var DoubleTake.Jobs.Contract.JobTypeNames.MultiSelectDthv

Field Value

Type: String
See Also

Reference

JobTypeNames Class
DoubleTake.Jobs.Contract Namespace


JobTypeNames.OrphanedConnection Field

JobTypeNamesOrphanedConnection Field
Connections that have been orphaned by jobs (delete only).

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string OrphanedConnection
Public Const OrphanedConnection As String
public:
literal String^ OrphanedConnection
var DoubleTake.Jobs.Contract.JobTypeNames.OrphanedConnection

Field Value

Type: String
See Also

Reference

JobTypeNames Class
DoubleTake.Jobs.Contract Namespace


JobTypeNames.Sql Field

JobTypeNamesSql Field
A SQL application workload.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string Sql
Public Const Sql As String
public:
literal String^ Sql
var DoubleTake.Jobs.Contract.JobTypeNames.Sql

Field Value

Type: String
See Also

Reference

JobTypeNames Class
DoubleTake.Jobs.Contract Namespace


JobTypeNames.SqlClustered Field

JobTypeNamesSqlClustered Field
A Cluster aware SQL application workload.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string SqlClustered
Public Const SqlClustered As String
public:
literal String^ SqlClustered
var DoubleTake.Jobs.Contract.JobTypeNames.SqlClustered

Field Value

Type: String
See Also

Reference

JobTypeNames Class
DoubleTake.Jobs.Contract Namespace


JobTypeNames.UnmanagedConnection Field

JobTypeNamesUnmanagedConnection Field
Connections that we can only display (pre-5.3 connections).

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string UnmanagedConnection
Public Const UnmanagedConnection As String
public:
literal String^ UnmanagedConnection
var DoubleTake.Jobs.Contract.JobTypeNames.UnmanagedConnection

Field Value

Type: String
See Also

Reference

JobTypeNames Class
DoubleTake.Jobs.Contract Namespace


JobTypeNames.Uvra Field

JobTypeNamesUvra Field
Universal Virtual recovery assistant jobs.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string Uvra
Public Const Uvra As String
public:
literal String^ Uvra
var DoubleTake.Jobs.Contract.JobTypeNames.Uvra

Field Value

Type: String
See Also

Reference

JobTypeNames Class
DoubleTake.Jobs.Contract Namespace


JobTypeNames.V2V Field

JobTypeNamesV2V Field
A job type for a virtual to virtual VRA job.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string V2V
Public Const V2V As String
public:
literal String^ V2V
var DoubleTake.Jobs.Contract.JobTypeNames.V2V

Field Value

Type: String
See Also

Reference

JobTypeNames Class
DoubleTake.Jobs.Contract Namespace


JobTypeNames.Vra Field

JobTypeNamesVra Field
A job type for VRA job.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string Vra
Public Const Vra As String
public:
literal String^ Vra
var DoubleTake.Jobs.Contract.JobTypeNames.Vra

Field Value

Type: String
See Also

Reference

JobTypeNames Class
DoubleTake.Jobs.Contract Namespace


JobTypeNames.VraMove Field

JobTypeNamesVraMove Field
A Move-style VRA job

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string VraMove
Public Const VraMove As String
public:
literal String^ VraMove
var DoubleTake.Jobs.Contract.JobTypeNames.VraMove

Field Value

Type: String
See Also

Reference

JobTypeNames Class
DoubleTake.Jobs.Contract Namespace


MonitoringOptions Class

MonitoringOptions Class
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractMonitoringOptions

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class MonitoringOptions : IExtensibleDataObject
Public Class MonitoringOptions
    Implements IExtensibleDataObject
public ref class MonitoringOptions : IExtensibleDataObject
DoubleTake.Jobs.Contract.MonitoringOptions = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.MonitoringOptions',
    null,
    IExtensibleDataObject);

The MonitoringOptions type exposes the following members.

Constructors
 | Name | Description
Public method | MonitoringOptions | Initializes a new instance of the MonitoringOptions class
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | ServiceMonitoringEnabled | This value is true if the service monitoring method for failover monitoring is enabled; otherwise it is false.
Public property | ServiceMonitoringOptions | This value represents the options used for the service monitoring method for failover monitoring.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


MonitoringOptions Constructor

MonitoringOptions Constructor
Initializes a new instance of the MonitoringOptions class

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public MonitoringOptions()
Public Sub New
public:
MonitoringOptions()
DoubleTake.Jobs.Contract.MonitoringOptions = function();
See Also

Reference

MonitoringOptions Class
DoubleTake.Jobs.Contract Namespace


MonitoringOptions Properties

MonitoringOptions Properties

The MonitoringOptions type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | ServiceMonitoringEnabled | This value is true if the service monitoring method for failover monitoring is enabled; otherwise it is false.
Public property | ServiceMonitoringOptions | This value represents the options used for the service monitoring method for failover monitoring.
Top
See Also

Reference

MonitoringOptions Class
DoubleTake.Jobs.Contract Namespace


MonitoringOptions.ExtensionData Property

MonitoringOptionsExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

MonitoringOptions Class
DoubleTake.Jobs.Contract Namespace


MonitoringOptions.ServiceMonitoringEnabled Property

MonitoringOptionsServiceMonitoringEnabled Property
This value is true if the service monitoring method for failover monitoring is enabled; otherwise it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool ServiceMonitoringEnabled { get; set; }
Public Property ServiceMonitoringEnabled As Boolean
    Get
    Set
public:
property bool ServiceMonitoringEnabled {
    bool get ();
    void set (bool value);
}
function get_ServiceMonitoringEnabled();
function set_ServiceMonitoringEnabled(value);

Property Value

Type: Boolean
if service monitoring is enabled; otherwise, .
See Also

Reference

MonitoringOptions Class
DoubleTake.Jobs.Contract Namespace


MonitoringOptions.ServiceMonitoringOptions Property

MonitoringOptionsServiceMonitoringOptions Property
This value represents the options used for the service monitoring method for failover monitoring.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ServiceMonitoringOptions ServiceMonitoringOptions { get; set; }
Public Property ServiceMonitoringOptions As ServiceMonitoringOptions
    Get
    Set
public:
property ServiceMonitoringOptions^ ServiceMonitoringOptions {
    ServiceMonitoringOptions^ get ();
    void set (ServiceMonitoringOptions^ value);
}
function get_ServiceMonitoringOptions();
function set_ServiceMonitoringOptions(value);

Property Value

Type: ServiceMonitoringOptions
The service monitoring options.
See Also

Reference

MonitoringOptions Class
DoubleTake.Jobs.Contract Namespace


RecommendedFailbackOptions Class

RecommendedFailbackOptions Class
Includes the recommended options for failing back a job and additional information that can be used to customize failback options.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractRecommendedFailbackOptions

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class RecommendedFailbackOptions : IExtensibleDataObject
Public Class RecommendedFailbackOptions
    Implements IExtensibleDataObject
public ref class RecommendedFailbackOptions : IExtensibleDataObject
DoubleTake.Jobs.Contract.RecommendedFailbackOptions = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.RecommendedFailbackOptions',
    null,
    IExtensibleDataObject);

The RecommendedFailbackOptions type exposes the following members.

Constructors
 | Name | Description
Public method | RecommendedFailbackOptions | Initializes a new instance of the RecommendedFailbackOptions class
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | FailbackOptions | This value represents the failback configuration.
Public property | IsSourceNew | This value is true if the data from the target was or is being restored to a new source server; otherwise, it is false.
Public property | RestoreStatus | This value represents the status of the restoration process.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


RecommendedFailbackOptions Constructor

RecommendedFailbackOptions Constructor
Initializes a new instance of the RecommendedFailbackOptions class

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public RecommendedFailbackOptions()
Public Sub New
public:
RecommendedFailbackOptions()
DoubleTake.Jobs.Contract.RecommendedFailbackOptions = function();
See Also

Reference

RecommendedFailbackOptions Class
DoubleTake.Jobs.Contract Namespace


RecommendedFailbackOptions Properties

RecommendedFailbackOptions Properties

The RecommendedFailbackOptions type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | FailbackOptions | This value represents the failback configuration.
Public property | IsSourceNew | This value is true if the data from the target was or is being restored to a new source server; otherwise, it is false.
Public property | RestoreStatus | This value represents the status of the restoration process.
Top
See Also

Reference

RecommendedFailbackOptions Class
DoubleTake.Jobs.Contract Namespace


RecommendedFailbackOptions.ExtensionData Property

RecommendedFailbackOptionsExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

RecommendedFailbackOptions Class
DoubleTake.Jobs.Contract Namespace


RecommendedFailbackOptions.FailbackOptions Property

RecommendedFailbackOptionsFailbackOptions Property
This value represents the failback configuration.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public FailbackOptions FailbackOptions { get; set; }
Public Property FailbackOptions As FailbackOptions
    Get
    Set
public:
property FailbackOptions^ FailbackOptions {
    FailbackOptions^ get ();
    void set (FailbackOptions^ value);
}
function get_FailbackOptions();
function set_FailbackOptions(value);

Property Value

Type: FailbackOptions
The failback options.
See Also

Reference

RecommendedFailbackOptions Class
DoubleTake.Jobs.Contract Namespace


RecommendedFailbackOptions.IsSourceNew Property

RecommendedFailbackOptionsIsSourceNew Property
This value is true if the data from the target was or is being restored to a new source server; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsSourceNew { get; set; }
Public Property IsSourceNew As Boolean
    Get
    Set
public:
property bool IsSourceNew {
    bool get ();
    void set (bool value);
}
function get_IsSourceNew();
function set_IsSourceNew(value);

Property Value

Type: Boolean
if the data was restored, or is being restored, to a new source; otherwise, .
See Also

Reference

RecommendedFailbackOptions Class
DoubleTake.Jobs.Contract Namespace


RecommendedFailbackOptions.RestoreStatus Property

RecommendedFailbackOptionsRestoreStatus Property
This value represents the status of the restoration process.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public RestoreStatus RestoreStatus { get; set; }
Public Property RestoreStatus As RestoreStatus
    Get
    Set
public:
property RestoreStatus RestoreStatus {
    RestoreStatus get ();
    void set (RestoreStatus value);
}
function get_RestoreStatus();
function set_RestoreStatus(value);

Property Value

Type: RestoreStatus
The status of the restore operation.
See Also

Reference

RecommendedFailbackOptions Class
DoubleTake.Jobs.Contract Namespace


RecommendedFailoverOptions Class

RecommendedFailoverOptions Class
Includes the recommended options for failing over a job and additional information that can be used to customize failover options.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractRecommendedFailoverOptions

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class RecommendedFailoverOptions : IExtensibleDataObject
Public Class RecommendedFailoverOptions
    Implements IExtensibleDataObject
public ref class RecommendedFailoverOptions : IExtensibleDataObject
DoubleTake.Jobs.Contract.RecommendedFailoverOptions = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.RecommendedFailoverOptions',
    null,
    IExtensibleDataObject);

The RecommendedFailoverOptions type exposes the following members.

Constructors
 | Name | Description
Public method | RecommendedFailoverOptions | Initializes a new instance of the RecommendedFailoverOptions class
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | FailoverOptions | This value represents the failover configuration.
Public property | IsTestFailoverSupported | This value is true if test failover is supported for the job type; otherwise, it is false.
Public property | Snapshots | This value represents the available snapshots on the target.
Public property | WarningTextTestFailover | This value is true if optional warning text to display if test failover is selected; otherwise, it is false.
Public property | WarnUserOfInconsistentProtectionData | This value is true if the data on the target may be in an inconsistent state; otherwise, it is false.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


RecommendedFailoverOptions Constructor

RecommendedFailoverOptions Constructor
Initializes a new instance of the RecommendedFailoverOptions class

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public RecommendedFailoverOptions()
Public Sub New
public:
RecommendedFailoverOptions()
DoubleTake.Jobs.Contract.RecommendedFailoverOptions = function();
See Also

Reference

RecommendedFailoverOptions Class
DoubleTake.Jobs.Contract Namespace


RecommendedFailoverOptions Properties

RecommendedFailoverOptions Properties

The RecommendedFailoverOptions type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | FailoverOptions | This value represents the failover configuration.
Public property | IsTestFailoverSupported | This value is true if test failover is supported for the job type; otherwise, it is false.
Public property | Snapshots | This value represents the available snapshots on the target.
Public property | WarningTextTestFailover | This value is true if optional warning text to display if test failover is selected; otherwise, it is false.
Public property | WarnUserOfInconsistentProtectionData | This value is true if the data on the target may be in an inconsistent state; otherwise, it is false.
Top
See Also

Reference

RecommendedFailoverOptions Class
DoubleTake.Jobs.Contract Namespace


RecommendedFailoverOptions.ExtensionData Property

RecommendedFailoverOptionsExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

RecommendedFailoverOptions Class
DoubleTake.Jobs.Contract Namespace


RecommendedFailoverOptions.FailoverOptions Property

RecommendedFailoverOptionsFailoverOptions Property
This value represents the failover configuration.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public FailoverOptions FailoverOptions { get; set; }
Public Property FailoverOptions As FailoverOptions
    Get
    Set
public:
property FailoverOptions^ FailoverOptions {
    FailoverOptions^ get ();
    void set (FailoverOptions^ value);
}
function get_FailoverOptions();
function set_FailoverOptions(value);

Property Value

Type: FailoverOptions
The recommended failover options.
See Also

Reference

RecommendedFailoverOptions Class
DoubleTake.Jobs.Contract Namespace


RecommendedFailoverOptions.IsTestFailoverSupported Property

RecommendedFailoverOptionsIsTestFailoverSupported Property
This value is true if test failover is supported for the job type; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsTestFailoverSupported { get; set; }
Public Property IsTestFailoverSupported As Boolean
    Get
    Set
public:
property bool IsTestFailoverSupported {
    bool get ();
    void set (bool value);
}
function get_IsTestFailoverSupported();
function set_IsTestFailoverSupported(value);

Property Value

Type: Boolean
if this test failover is supported; otherwise, .
See Also

Reference

RecommendedFailoverOptions Class
DoubleTake.Jobs.Contract Namespace


RecommendedFailoverOptions.Snapshots Property

RecommendedFailoverOptionsSnapshots Property
This value represents the available snapshots on the target.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public SnapshotEntry[] Snapshots { get; set; }
Public Property Snapshots As SnapshotEntry()
    Get
    Set
public:
property array<SnapshotEntry^>^ Snapshots {
    array<SnapshotEntry^>^ get ();
    void set (array<SnapshotEntry^>^ value);
}
function get_Snapshots();
function set_Snapshots(value);

Property Value

Type: SnapshotEntry
An array of SnapshotEntry that represents the snapshots on the target server.
See Also

Reference

RecommendedFailoverOptions Class
DoubleTake.Jobs.Contract Namespace


RecommendedFailoverOptions.WarningTextTestFailover Property

RecommendedFailoverOptionsWarningTextTestFailover Property
This value is true if optional warning text to display if test failover is selected; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool WarningTextTestFailover { get; set; }
Public Property WarningTextTestFailover As Boolean
    Get
    Set
public:
property bool WarningTextTestFailover {
    bool get ();
    void set (bool value);
}
function get_WarningTextTestFailover();
function set_WarningTextTestFailover(value);

Property Value

Type: Boolean
See Also

Reference

RecommendedFailoverOptions Class
DoubleTake.Jobs.Contract Namespace


RecommendedFailoverOptions.WarnUserOfInconsistentProtectionData Property

RecommendedFailoverOptionsWarnUserOfInconsistentProtectionData Property
This value is true if the data on the target may be in an inconsistent state; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool WarnUserOfInconsistentProtectionData { get; set; }
Public Property WarnUserOfInconsistentProtectionData As Boolean
    Get
    Set
public:
property bool WarnUserOfInconsistentProtectionData {
    bool get ();
    void set (bool value);
}
function get_WarnUserOfInconsistentProtectionData();
function set_WarnUserOfInconsistentProtectionData(value);

Property Value

Type: Boolean
if the data on the target server may be in an inconsistent state; otherwise, .
See Also

Reference

RecommendedFailoverOptions Class
DoubleTake.Jobs.Contract Namespace


RecommendedJobOptions Class

RecommendedJobOptions Class
Represents the recommended options for a job and potential values for those options.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractRecommendedJobOptions

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class RecommendedJobOptions : IExtensibleDataObject
Public Class RecommendedJobOptions
    Implements IExtensibleDataObject
public ref class RecommendedJobOptions : IExtensibleDataObject
DoubleTake.Jobs.Contract.RecommendedJobOptions = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.RecommendedJobOptions',
    null,
    IExtensibleDataObject);

The RecommendedJobOptions type exposes the following members.

Constructors
 | Name | Description
Public method | RecommendedJobOptions | Initializes a new instance of the RecommendedJobOptions class
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | JobOptions | This value represents the current options for the job.
Public property | JobQualificationResults | This value represents the job qualification results which are other possible job options, in addition to those that are strictly recommended. For example, JobOptions.CoreConnectionOptions. TargetAddress may be the recommended address, but JobQualificationResults.CoreQualificationResults.TargetIPAddresses may include other IP addresses on the server.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


RecommendedJobOptions Constructor

RecommendedJobOptions Constructor
Initializes a new instance of the RecommendedJobOptions class

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public RecommendedJobOptions()
Public Sub New
public:
RecommendedJobOptions()
DoubleTake.Jobs.Contract.RecommendedJobOptions = function();
See Also

Reference

RecommendedJobOptions Class
DoubleTake.Jobs.Contract Namespace


RecommendedJobOptions Properties

RecommendedJobOptions Properties

The RecommendedJobOptions type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | JobOptions | This value represents the current options for the job.
Public property | JobQualificationResults | This value represents the job qualification results which are other possible job options, in addition to those that are strictly recommended. For example, JobOptions.CoreConnectionOptions. TargetAddress may be the recommended address, but JobQualificationResults.CoreQualificationResults.TargetIPAddresses may include other IP addresses on the server.
Top
See Also

Reference

RecommendedJobOptions Class
DoubleTake.Jobs.Contract Namespace


RecommendedJobOptions.ExtensionData Property

RecommendedJobOptionsExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

RecommendedJobOptions Class
DoubleTake.Jobs.Contract Namespace


RecommendedJobOptions.JobOptions Property

RecommendedJobOptionsJobOptions Property
This value represents the current options for the job.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public JobOptions JobOptions { get; set; }
Public Property JobOptions As JobOptions
    Get
    Set
public:
property JobOptions^ JobOptions {
    JobOptions^ get ();
    void set (JobOptions^ value);
}
function get_JobOptions();
function set_JobOptions(value);

Property Value

Type: JobOptions
The recommended job options.
See Also

Reference

RecommendedJobOptions Class
DoubleTake.Jobs.Contract Namespace


RecommendedJobOptions.JobQualificationResults Property

RecommendedJobOptionsJobQualificationResults Property
This value represents the job qualification results which are other possible job options, in addition to those that are strictly recommended. For example, JobOptions.CoreConnectionOptions. TargetAddress may be the recommended address, but JobQualificationResults.CoreQualificationResults.TargetIPAddresses may include other IP addresses on the server.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public JobQualificationResults JobQualificationResults { get; set; }
Public Property JobQualificationResults As JobQualificationResults
    Get
    Set
public:
property JobQualificationResults^ JobQualificationResults {
    JobQualificationResults^ get ();
    void set (JobQualificationResults^ value);
}
function get_JobQualificationResults();
function set_JobQualificationResults(value);

Property Value

Type: JobQualificationResults
The job qualification results.
Remarks
The job qualification results are used to communicate other possible option for a job, outside of the options that are strictly recommended. For example, the [P:JobOptions] property may recommend a specific IP address as the target route, but the [P:JobQualificationResults] property may include the other IP addresses on the server.
See Also

Reference

RecommendedJobOptions Class
DoubleTake.Jobs.Contract Namespace


RecommendedRestoreOptions Class

RecommendedRestoreOptions Class
Includes the recommended options for restoring job and additional information that can be used to customize restore options.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractRecommendedRestoreOptions

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class RecommendedRestoreOptions : IExtensibleDataObject
Public Class RecommendedRestoreOptions
    Implements IExtensibleDataObject
public ref class RecommendedRestoreOptions : IExtensibleDataObject
DoubleTake.Jobs.Contract.RecommendedRestoreOptions = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.RecommendedRestoreOptions',
    null,
    IExtensibleDataObject);

The RecommendedRestoreOptions type exposes the following members.

Constructors
 | Name | Description
Public method | RecommendedRestoreOptions | Initializes a new instance of the RecommendedRestoreOptions class
Top
Properties
 | Name | Description
Public property | CanClearRestoreRequired | This value is true if the restore required flag can be cleared; otherwise, it is false.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | IsNat |
Public property | PossibleSourceAddresses | This value is the possible source IP addresses.
Public property | RestoreOptions | This value represents the restoration options.
Public property | SameSourceOnly | This value is true is the job can only be restored to the same source server; otherwise, it is false.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


RecommendedRestoreOptions Constructor

RecommendedRestoreOptions Constructor
Initializes a new instance of the RecommendedRestoreOptions class

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public RecommendedRestoreOptions()
Public Sub New
public:
RecommendedRestoreOptions()
DoubleTake.Jobs.Contract.RecommendedRestoreOptions = function();
See Also

Reference

RecommendedRestoreOptions Class
DoubleTake.Jobs.Contract Namespace


RecommendedRestoreOptions Properties

RecommendedRestoreOptions Properties

The RecommendedRestoreOptions type exposes the following members.

Properties
 | Name | Description
Public property | CanClearRestoreRequired | This value is true if the restore required flag can be cleared; otherwise, it is false.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | IsNat |
Public property | PossibleSourceAddresses | This value is the possible source IP addresses.
Public property | RestoreOptions | This value represents the restoration options.
Public property | SameSourceOnly | This value is true is the job can only be restored to the same source server; otherwise, it is false.
Top
See Also

Reference

RecommendedRestoreOptions Class
DoubleTake.Jobs.Contract Namespace


RecommendedRestoreOptions.CanClearRestoreRequired Property

RecommendedRestoreOptionsCanClearRestoreRequired Property
This value is true if the restore required flag can be cleared; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool CanClearRestoreRequired { get; set; }
Public Property CanClearRestoreRequired As Boolean
    Get
    Set
public:
property bool CanClearRestoreRequired {
    bool get ();
    void set (bool value);
}
function get_CanClearRestoreRequired();
function set_CanClearRestoreRequired(value);

Property Value

Type: Boolean
if restore required can be cleared; otherwise, .
See Also

Reference

RecommendedRestoreOptions Class
DoubleTake.Jobs.Contract Namespace


RecommendedRestoreOptions.ExtensionData Property

RecommendedRestoreOptionsExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

RecommendedRestoreOptions Class
DoubleTake.Jobs.Contract Namespace


RecommendedRestoreOptions.IsNat Property

RecommendedRestoreOptionsIsNat Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsNat { get; set; }
Public Property IsNat As Boolean
    Get
    Set
public:
property bool IsNat {
    bool get ();
    void set (bool value);
}
function get_IsNat();
function set_IsNat(value);

Property Value

Type: Boolean
See Also

Reference

RecommendedRestoreOptions Class
DoubleTake.Jobs.Contract Namespace


RecommendedRestoreOptions.PossibleSourceAddresses Property

RecommendedRestoreOptionsPossibleSourceAddresses Property
This value is the possible source IP addresses.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string[] PossibleSourceAddresses { get; set; }
Public Property PossibleSourceAddresses As String()
    Get
    Set
public:
property array<String^>^ PossibleSourceAddresses {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
function get_PossibleSourceAddresses();
function set_PossibleSourceAddresses(value);

Property Value

Type: String
The possible source addresses.
See Also

Reference

RecommendedRestoreOptions Class
DoubleTake.Jobs.Contract Namespace


RecommendedRestoreOptions.RestoreOptions Property

RecommendedRestoreOptionsRestoreOptions Property
This value represents the restoration options.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public RestoreOptions RestoreOptions { get; set; }
Public Property RestoreOptions As RestoreOptions
    Get
    Set
public:
property RestoreOptions^ RestoreOptions {
    RestoreOptions^ get ();
    void set (RestoreOptions^ value);
}
function get_RestoreOptions();
function set_RestoreOptions(value);

Property Value

Type: RestoreOptions
The restore options.
See Also

Reference

RecommendedRestoreOptions Class
DoubleTake.Jobs.Contract Namespace


RecommendedRestoreOptions.SameSourceOnly Property

RecommendedRestoreOptionsSameSourceOnly Property
This value is true is the job can only be restored to the same source server; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool SameSourceOnly { get; set; }
Public Property SameSourceOnly As Boolean
    Get
    Set
public:
property bool SameSourceOnly {
    bool get ();
    void set (bool value);
}
function get_SameSourceOnly();
function set_SameSourceOnly(value);

Property Value

Type: Boolean
if the job only allows restoring to the same source; otherwise, .
See Also

Reference

RecommendedRestoreOptions Class
DoubleTake.Jobs.Contract Namespace


ResourceAndPassiveNodes Class

ResourceAndPassiveNodes Class
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractResourceAndPassiveNodes

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class ResourceAndPassiveNodes
Public Class ResourceAndPassiveNodes
public ref class ResourceAndPassiveNodes
DoubleTake.Jobs.Contract.ResourceAndPassiveNodes = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.ResourceAndPassiveNodes');

The ResourceAndPassiveNodes type exposes the following members.

Constructors
 | Name | Description
Public method | ResourceAndPassiveNodes | Initializes a new instance of the ResourceAndPassiveNodes class
Top
Fields
 | Name | Description
Public field | passiveNodes |
Public field | resource |
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


ResourceAndPassiveNodes Constructor

ResourceAndPassiveNodes Constructor
Initializes a new instance of the ResourceAndPassiveNodes class

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ResourceAndPassiveNodes()
Public Sub New
public:
ResourceAndPassiveNodes()
DoubleTake.Jobs.Contract.ResourceAndPassiveNodes = function();
See Also

Reference

ResourceAndPassiveNodes Class
DoubleTake.Jobs.Contract Namespace


ResourceAndPassiveNodes Fields

ResourceAndPassiveNodes Fields

The ResourceAndPassiveNodes type exposes the following members.

Fields
 | Name | Description
Public field | passiveNodes |
Public field | resource |
Top
See Also

Reference

ResourceAndPassiveNodes Class
DoubleTake.Jobs.Contract Namespace


ResourceAndPassiveNodes.passiveNodes Field

ResourceAndPassiveNodespassiveNodes Field

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string[] passiveNodes
Public passiveNodes As String()
public:
array<String^>^ passiveNodes
var passiveNodes

Field Value

Type: String
See Also

Reference

ResourceAndPassiveNodes Class
DoubleTake.Jobs.Contract Namespace


ResourceAndPassiveNodes.resource Field

ResourceAndPassiveNodesresource Field

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string resource
Public resource As String
public:
String^ resource
var resource

Field Value

Type: String
See Also

Reference

ResourceAndPassiveNodes Class
DoubleTake.Jobs.Contract Namespace


RestoreOptions Class

RestoreOptions Class
Represents the options used when restoring a job.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractRestoreOptions

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class RestoreOptions : IExtensibleDataObject
Public Class RestoreOptions
    Implements IExtensibleDataObject
public ref class RestoreOptions : IExtensibleDataObject
DoubleTake.Jobs.Contract.RestoreOptions = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.RestoreOptions',
    null,
    IExtensibleDataObject);

The RestoreOptions type exposes the following members.

Constructors
 | Name | Description
Public method | RestoreOptions | Initializes a new instance of the RestoreOptions class
Top
Properties
 | Name | Description
Public property | ClearRestoreRequired | This value is true if the restore required flag can be cleared without restoring; otherwise, it is false.
Public property | EnginePort |
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | RestoreParameters | This value represents the restoration configuration.
Public property | RestoreTargetHostUri | This value is the target URI. (The target is the target of the restoration connection, not the original protection connection.)
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


RestoreOptions Constructor

RestoreOptions Constructor
Initializes a new instance of the RestoreOptions class

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public RestoreOptions()
Public Sub New
public:
RestoreOptions()
DoubleTake.Jobs.Contract.RestoreOptions = function();
See Also

Reference

RestoreOptions Class
DoubleTake.Jobs.Contract Namespace


RestoreOptions Properties

RestoreOptions Properties

The RestoreOptions type exposes the following members.

Properties
 | Name | Description
Public property | ClearRestoreRequired | This value is true if the restore required flag can be cleared without restoring; otherwise, it is false.
Public property | EnginePort |
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | RestoreParameters | This value represents the restoration configuration.
Public property | RestoreTargetHostUri | This value is the target URI. (The target is the target of the restoration connection, not the original protection connection.)
Top
See Also

Reference

RestoreOptions Class
DoubleTake.Jobs.Contract Namespace


RestoreOptions.ClearRestoreRequired Property

RestoreOptionsClearRestoreRequired Property
This value is true if the restore required flag can be cleared without restoring; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool ClearRestoreRequired { get; set; }
Public Property ClearRestoreRequired As Boolean
    Get
    Set
public:
property bool ClearRestoreRequired {
    bool get ();
    void set (bool value);
}
function get_ClearRestoreRequired();
function set_ClearRestoreRequired(value);

Property Value

Type: Boolean
to simply clear the "Restore required" state without restoring; otherwise, .
See Also

Reference

RestoreOptions Class
DoubleTake.Jobs.Contract Namespace


RestoreOptions.EnginePort Property

RestoreOptionsEnginePort Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Nullable<int> EnginePort { get; set; }
Public Property EnginePort As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> EnginePort {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
function get_EnginePort();
function set_EnginePort(value);

Property Value

Type: Nullable Int32
See Also

Reference

RestoreOptions Class
DoubleTake.Jobs.Contract Namespace


RestoreOptions.ExtensionData Property

RestoreOptionsExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

RestoreOptions Class
DoubleTake.Jobs.Contract Namespace


RestoreOptions.RestoreParameters Property

RestoreOptionsRestoreParameters Property
This value represents the restoration configuration.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public RestoreParameters RestoreParameters { get; set; }
Public Property RestoreParameters As RestoreParameters
    Get
    Set
public:
property RestoreParameters^ RestoreParameters {
    RestoreParameters^ get ();
    void set (RestoreParameters^ value);
}
function get_RestoreParameters();
function set_RestoreParameters(value);

Property Value

Type: RestoreParameters
The parameters for the restore operation.
See Also

Reference

RestoreOptions Class
DoubleTake.Jobs.Contract Namespace


RestoreOptions.RestoreTargetHostUri Property

RestoreOptionsRestoreTargetHostUri Property
This value is the target URI. (The target is the target of the restoration connection, not the original protection connection.)

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Uri RestoreTargetHostUri { get; set; }
Public Property RestoreTargetHostUri As Uri
    Get
    Set
public:
property Uri^ RestoreTargetHostUri {
    Uri^ get ();
    void set (Uri^ value);
}
function get_RestoreTargetHostUri();
function set_RestoreTargetHostUri(value);

Property Value

Type: Uri
The restore target host URI.
See Also

Reference

RestoreOptions Class
DoubleTake.Jobs.Contract Namespace


RestoreStatus Enumeration

RestoreStatus Enumeration
Indicates the status of a restore operation.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public enum RestoreStatus
Public Enumeration RestoreStatus
public enum class RestoreStatus
DoubleTake.Jobs.Contract.RestoreStatus = function();
DoubleTake.Jobs.Contract.RestoreStatus.createEnum('DoubleTake.Jobs.Contract.RestoreStatus', false);
Members
Member name | Value | Description
NotStarted | 0 | The restoration has not started.
Restoring | 1 | The restoration process is in progress.
Restored | 2 | The restoration process is complete. It is now safe to perform failback.
See Also

Reference

DoubleTake.Jobs.Contract Namespace


ServiceInformation Class

ServiceInformation Class
Contains information about a service.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractServiceInformation

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class ServiceInformation
Public Class ServiceInformation
public ref class ServiceInformation
DoubleTake.Jobs.Contract.ServiceInformation = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.ServiceInformation');

The ServiceInformation type exposes the following members.

Constructors
 | Name | Description
Public method | ServiceInformation | Initializes a new instance of the ServiceInformation class
Top
Fields
 | Name | Description
Public field | DisplayName | This value is the service display name.
Public field | Name | This value is the service name.
Public field | Selected | This value is true if the service is selected for service monitoring; otherwise, it is false.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


ServiceInformation Constructor

ServiceInformation Constructor
Initializes a new instance of the ServiceInformation class

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ServiceInformation()
Public Sub New
public:
ServiceInformation()
DoubleTake.Jobs.Contract.ServiceInformation = function();
See Also

Reference

ServiceInformation Class
DoubleTake.Jobs.Contract Namespace


ServiceInformation Fields

ServiceInformation Fields

The ServiceInformation type exposes the following members.

Fields
 | Name | Description
Public field | DisplayName | This value is the service display name.
Public field | Name | This value is the service name.
Public field | Selected | This value is true if the service is selected for service monitoring; otherwise, it is false.
Top
See Also

Reference

ServiceInformation Class
DoubleTake.Jobs.Contract Namespace


ServiceInformation.DisplayName Field

ServiceInformationDisplayName Field
This value is the service display name.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string DisplayName
Public DisplayName As String
public:
String^ DisplayName
var DisplayName

Field Value

Type: String
See Also

Reference

ServiceInformation Class
DoubleTake.Jobs.Contract Namespace


ServiceInformation.Name Field

ServiceInformationName Field
This value is the service name.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Name
Public Name As String
public:
String^ Name
var Name

Field Value

Type: String
See Also

Reference

ServiceInformation Class
DoubleTake.Jobs.Contract Namespace


ServiceInformation.Selected Field

ServiceInformationSelected Field
This value is true if the service is selected for service monitoring; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool Selected
Public Selected As Boolean
public:
bool Selected
var Selected

Field Value

Type: Boolean
See Also

Reference

ServiceInformation Class
DoubleTake.Jobs.Contract Namespace


ServiceMonitoringOptions Class

ServiceMonitoringOptions Class
A data contract representing the options for monitoring services on a source.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractServiceMonitoringOptions

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class ServiceMonitoringOptions : IExtensibleDataObject
Public Class ServiceMonitoringOptions
    Implements IExtensibleDataObject
public ref class ServiceMonitoringOptions : IExtensibleDataObject
DoubleTake.Jobs.Contract.ServiceMonitoringOptions = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.ServiceMonitoringOptions',
    null,
    IExtensibleDataObject);

The ServiceMonitoringOptions type exposes the following members.

Constructors
 | Name | Description
Public method | ServiceMonitoringOptions | Initializes a new instance of the ServiceMonitoringOptions class
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | RepeatCount | This value is the number of times to repeat the call to retrieve the service status.
Public property | Services | This value represents the services that should be monitored.
Public property | StartService | This value is true if the monitored service should be started if it is stopped; otherwise, it is false.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


ServiceMonitoringOptions Constructor

ServiceMonitoringOptions Constructor
Initializes a new instance of the ServiceMonitoringOptions class

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ServiceMonitoringOptions()
Public Sub New
public:
ServiceMonitoringOptions()
DoubleTake.Jobs.Contract.ServiceMonitoringOptions = function();
See Also

Reference

ServiceMonitoringOptions Class
DoubleTake.Jobs.Contract Namespace


ServiceMonitoringOptions Properties

ServiceMonitoringOptions Properties

The ServiceMonitoringOptions type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | RepeatCount | This value is the number of times to repeat the call to retrieve the service status.
Public property | Services | This value represents the services that should be monitored.
Public property | StartService | This value is true if the monitored service should be started if it is stopped; otherwise, it is false.
Top
See Also

Reference

ServiceMonitoringOptions Class
DoubleTake.Jobs.Contract Namespace


ServiceMonitoringOptions.ExtensionData Property

ServiceMonitoringOptionsExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

ServiceMonitoringOptions Class
DoubleTake.Jobs.Contract Namespace


ServiceMonitoringOptions.RepeatCount Property

ServiceMonitoringOptionsRepeatCount Property
This value is the number of times to repeat the call to retrieve the service status.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int RepeatCount { get; set; }
Public Property RepeatCount As Integer
    Get
    Set
public:
property int RepeatCount {
    int get ();
    void set (int value);
}
function get_RepeatCount();
function set_RepeatCount(value);

Property Value

Type: Int32
The number of times to repeat the call to retrieve the service status.
See Also

Reference

ServiceMonitoringOptions Class
DoubleTake.Jobs.Contract Namespace


ServiceMonitoringOptions.Services Property

ServiceMonitoringOptionsServices Property
This value represents the services that should be monitored.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ServiceInformation[] Services { get; set; }
Public Property Services As ServiceInformation()
    Get
    Set
public:
property array<ServiceInformation^>^ Services {
    array<ServiceInformation^>^ get ();
    void set (array<ServiceInformation^>^ value);
}
function get_Services();
function set_Services(value);

Property Value

Type: ServiceInformation
The services to be monitored.
See Also

Reference

ServiceMonitoringOptions Class
DoubleTake.Jobs.Contract Namespace


ServiceMonitoringOptions.StartService Property

ServiceMonitoringOptionsStartService Property
This value is true if the monitored service should be started if it is stopped; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool StartService { get; set; }
Public Property StartService As Boolean
    Get
    Set
public:
property bool StartService {
    bool get ();
    void set (bool value);
}
function get_StartService();
function set_StartService(value);

Property Value

Type: Boolean
if the monitored service is to be started when stopped; otherwise, .
See Also

Reference

ServiceMonitoringOptions Class
DoubleTake.Jobs.Contract Namespace


SimpleFailoverMonitorOptions Class

SimpleFailoverMonitorOptions Class
Represents simple failover monitor options for the jobs (like DTHV) which don't use IP address to monitor
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractSimpleFailoverMonitorOptions

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class SimpleFailoverMonitorOptions : IExtensibleDataObject
Public Class SimpleFailoverMonitorOptions
    Implements IExtensibleDataObject
public ref class SimpleFailoverMonitorOptions : IExtensibleDataObject
DoubleTake.Jobs.Contract.SimpleFailoverMonitorOptions = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.SimpleFailoverMonitorOptions',
    null,
    IExtensibleDataObject);

The SimpleFailoverMonitorOptions type exposes the following members.

Constructors
 | Name | Description
Public method | SimpleFailoverMonitorOptions | Initializes a new instance of the SimpleFailoverMonitorOptions class
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | IsUserInterventionRequired | Gets or sets if user intervention is required before triggering a failover.
Public property | MaxPingAttempts | Gets or sets the maximum number of ping attempts before the IP address is considered to be failed.
Public property | PingInterval | Gets or sets the interval at which the source address is pinged to determine a failure condition.
Public property | TimeAllowed | Gets or sets the total time to failover
Public property | UseTimeAllowed | Gets or sets a value indicating whether to use the TimeAllowed property.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


SimpleFailoverMonitorOptions Constructor

SimpleFailoverMonitorOptions Constructor
Initializes a new instance of the SimpleFailoverMonitorOptions class

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public SimpleFailoverMonitorOptions()
Public Sub New
public:
SimpleFailoverMonitorOptions()
DoubleTake.Jobs.Contract.SimpleFailoverMonitorOptions = function();
See Also

Reference

SimpleFailoverMonitorOptions Class
DoubleTake.Jobs.Contract Namespace


SimpleFailoverMonitorOptions Properties

SimpleFailoverMonitorOptions Properties

The SimpleFailoverMonitorOptions type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | IsUserInterventionRequired | Gets or sets if user intervention is required before triggering a failover.
Public property | MaxPingAttempts | Gets or sets the maximum number of ping attempts before the IP address is considered to be failed.
Public property | PingInterval | Gets or sets the interval at which the source address is pinged to determine a failure condition.
Public property | TimeAllowed | Gets or sets the total time to failover
Public property | UseTimeAllowed | Gets or sets a value indicating whether to use the TimeAllowed property.
Top
See Also

Reference

SimpleFailoverMonitorOptions Class
DoubleTake.Jobs.Contract Namespace


SimpleFailoverMonitorOptions.ExtensionData Property

SimpleFailoverMonitorOptionsExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

SimpleFailoverMonitorOptions Class
DoubleTake.Jobs.Contract Namespace


SimpleFailoverMonitorOptions.IsUserInterventionRequired Property

SimpleFailoverMonitorOptionsIsUserInterventionRequired Property
Gets or sets if user intervention is required before triggering a failover.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsUserInterventionRequired { get; set; }
Public Property IsUserInterventionRequired As Boolean
    Get
    Set
public:
property bool IsUserInterventionRequired {
    bool get ();
    void set (bool value);
}
function get_IsUserInterventionRequired();
function set_IsUserInterventionRequired(value);

Property Value

Type: Boolean
The user intervention required before failover as true or false
See Also

Reference

SimpleFailoverMonitorOptions Class
DoubleTake.Jobs.Contract Namespace


SimpleFailoverMonitorOptions.MaxPingAttempts Property

SimpleFailoverMonitorOptionsMaxPingAttempts Property
Gets or sets the maximum number of ping attempts before the IP address is considered to be failed.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public short MaxPingAttempts { get; set; }
Public Property MaxPingAttempts As Short
    Get
    Set
public:
property short MaxPingAttempts {
    short get ();
    void set (short value);
}
function get_MaxPingAttempts();
function set_MaxPingAttempts(value);

Property Value

Type: Int16
The maximum number of ping attempts.
See Also

Reference

SimpleFailoverMonitorOptions Class
DoubleTake.Jobs.Contract Namespace


SimpleFailoverMonitorOptions.PingInterval Property

SimpleFailoverMonitorOptionsPingInterval Property
Gets or sets the interval at which the source address is pinged to determine a failure condition.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public TimeSpan PingInterval { get; set; }
Public Property PingInterval As TimeSpan
    Get
    Set
public:
property TimeSpan PingInterval {
    TimeSpan get ();
    void set (TimeSpan value);
}
function get_PingInterval();
function set_PingInterval(value);

Property Value

Type: TimeSpan
The ping interval as a TimeSpan.
See Also

Reference

SimpleFailoverMonitorOptions Class
DoubleTake.Jobs.Contract Namespace


SimpleFailoverMonitorOptions.TimeAllowed Property

SimpleFailoverMonitorOptionsTimeAllowed Property
Gets or sets the total time to failover

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public TimeSpan TimeAllowed { get; set; }
Public Property TimeAllowed As TimeSpan
    Get
    Set
public:
property TimeSpan TimeAllowed {
    TimeSpan get ();
    void set (TimeSpan value);
}
function get_TimeAllowed();
function set_TimeAllowed(value);

Property Value

Type: TimeSpan
Total time to failover
See Also

Reference

SimpleFailoverMonitorOptions Class
DoubleTake.Jobs.Contract Namespace


SimpleFailoverMonitorOptions.UseTimeAllowed Property

SimpleFailoverMonitorOptionsUseTimeAllowed Property
Gets or sets a value indicating whether to use the TimeAllowed property.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool UseTimeAllowed { get; set; }
Public Property UseTimeAllowed As Boolean
    Get
    Set
public:
property bool UseTimeAllowed {
    bool get ();
    void set (bool value);
}
function get_UseTimeAllowed();
function set_UseTimeAllowed(value);

Property Value

Type: Boolean
if the TimeAllowed property will be used; otherwise, .
See Also

Reference

SimpleFailoverMonitorOptions Class
DoubleTake.Jobs.Contract Namespace


SourceQualificationFault Class

SourceQualificationFault Class
This fault is raised when communications with the source server failed while attempting to retrieve data for the purposes of qualifying a job. Qualifying a job typically occurs during the job option recommendation process.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractSourceQualificationFault

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class SourceQualificationFault : ICommonFault,
    IExtensibleDataObject
Public Class SourceQualificationFault
    Implements ICommonFault, IExtensibleDataObject
public ref class SourceQualificationFault : ICommonFault,
    IExtensibleDataObject
DoubleTake.Jobs.Contract.SourceQualificationFault = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.SourceQualificationFault',
    null,
    DoubleTake.Common.Contract.ICommonFault,
    IExtensibleDataObject);

The SourceQualificationFault type exposes the following members.

Constructors
 | Name | Description
Public method | SourceQualificationFault | Initializes a new instance of the SourceQualificationFault class
Top
Properties
 | Name | Description
Public property | DiscoveredSourceName | Gets or sets the discovered name of the source.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | InnerFault | Gets or sets the inner fault.
Public property | Message | Gets or sets the fault error message.
Public property | MessageFormatParameters | Gets or sets the message format parameters.
Public property | MessageKey | Gets or sets the message key.
Public property | Name | Gets or sets the name of the fault.
Public property | SourceHostUri | Gets or sets the source host URI that was used to attempt to communicate with the source.
Public property | StackTrace | Gets or sets the stack trace from the service that indicates where an unhandled exception occurred.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


SourceQualificationFault Constructor

SourceQualificationFault Constructor
Initializes a new instance of the SourceQualificationFault class

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public SourceQualificationFault()
Public Sub New
public:
SourceQualificationFault()
DoubleTake.Jobs.Contract.SourceQualificationFault = function();
See Also

Reference

SourceQualificationFault Class
DoubleTake.Jobs.Contract Namespace


SourceQualificationFault Properties

SourceQualificationFault Properties

The SourceQualificationFault type exposes the following members.

Properties
 | Name | Description
Public property | DiscoveredSourceName | Gets or sets the discovered name of the source.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | InnerFault | Gets or sets the inner fault.
Public property | Message | Gets or sets the fault error message.
Public property | MessageFormatParameters | Gets or sets the message format parameters.
Public property | MessageKey | Gets or sets the message key.
Public property | Name | Gets or sets the name of the fault.
Public property | SourceHostUri | Gets or sets the source host URI that was used to attempt to communicate with the source.
Public property | StackTrace | Gets or sets the stack trace from the service that indicates where an unhandled exception occurred.
Top
See Also

Reference

SourceQualificationFault Class
DoubleTake.Jobs.Contract Namespace


SourceQualificationFault.DiscoveredSourceName Property

SourceQualificationFaultDiscoveredSourceName Property
Gets or sets the discovered name of the source.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string DiscoveredSourceName { get; set; }
Public Property DiscoveredSourceName As String
    Get
    Set
public:
property String^ DiscoveredSourceName {
    String^ get ();
    void set (String^ value);
}
function get_DiscoveredSourceName();
function set_DiscoveredSourceName(value);

Property Value

Type: String
The discovered name of the source.
See Also

Reference

SourceQualificationFault Class
DoubleTake.Jobs.Contract Namespace


SourceQualificationFault.ExtensionData Property

SourceQualificationFaultExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The structure that contains extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

SourceQualificationFault Class
DoubleTake.Jobs.Contract Namespace


SourceQualificationFault.InnerFault Property

SourceQualificationFaultInnerFault Property
Gets or sets the inner fault.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ICommonFault InnerFault { get; set; }
Public Property InnerFault As ICommonFault
    Get
    Set
public:
virtual property ICommonFault^ InnerFault {
    ICommonFault^ get () sealed;
    void set (ICommonFault^ value) sealed;
}
function get_InnerFault();
function set_InnerFault(value);

Property Value

Type: ICommonFault
An instance of ICommonFault that represents the inner fault.

Implements

ICommonFaultInnerFault
See Also

Reference

SourceQualificationFault Class
DoubleTake.Jobs.Contract Namespace


SourceQualificationFault.Message Property

SourceQualificationFaultMessage Property
Gets or sets the fault error message.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Message { get; set; }
Public Property Message As String
    Get
    Set
public:
virtual property String^ Message {
    String^ get () sealed;
    void set (String^ value) sealed;
}
function get_Message();
function set_Message(value);

Property Value

Type: String
The fault error message.

Implements

ICommonFaultMessage
See Also

Reference

SourceQualificationFault Class
DoubleTake.Jobs.Contract Namespace


SourceQualificationFault.MessageFormatParameters Property

SourceQualificationFaultMessageFormatParameters Property
Gets or sets the message format parameters.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string[] MessageFormatParameters { get; set; }
Public Property MessageFormatParameters As String()
    Get
    Set
public:
property array<String^>^ MessageFormatParameters {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
function get_MessageFormatParameters();
function set_MessageFormatParameters(value);

Property Value

Type: String
The message format parameters.
See Also

Reference

SourceQualificationFault Class
DoubleTake.Jobs.Contract Namespace


SourceQualificationFault.MessageKey Property

SourceQualificationFaultMessageKey Property
Gets or sets the message key.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string MessageKey { get; set; }
Public Property MessageKey As String
    Get
    Set
public:
property String^ MessageKey {
    String^ get ();
    void set (String^ value);
}
function get_MessageKey();
function set_MessageKey(value);

Property Value

Type: String
The message key.
See Also

Reference

SourceQualificationFault Class
DoubleTake.Jobs.Contract Namespace


SourceQualificationFault.Name Property

SourceQualificationFaultName Property
Gets or sets the name of the fault.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get () sealed;
    void set (String^ value) sealed;
}
function get_Name();
function set_Name(value);

Property Value

Type: String
The name of the fault.

Implements

ICommonFaultName
See Also

Reference

SourceQualificationFault Class
DoubleTake.Jobs.Contract Namespace


SourceQualificationFault.SourceHostUri Property

SourceQualificationFaultSourceHostUri Property
Gets or sets the source host URI that was used to attempt to communicate with the source.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Uri SourceHostUri { get; set; }
Public Property SourceHostUri As Uri
    Get
    Set
public:
property Uri^ SourceHostUri {
    Uri^ get ();
    void set (Uri^ value);
}
function get_SourceHostUri();
function set_SourceHostUri(value);

Property Value

Type: Uri
The source host URI that was used to attempt to communicate with the source.
See Also

Reference

SourceQualificationFault Class
DoubleTake.Jobs.Contract Namespace


SourceQualificationFault.StackTrace Property

SourceQualificationFaultStackTrace Property
Gets or sets the stack trace from the service that indicates where an unhandled exception occurred.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string StackTrace { get; set; }
Public Property StackTrace As String
    Get
    Set
public:
virtual property String^ StackTrace {
    String^ get () sealed;
    void set (String^ value) sealed;
}
function get_StackTrace();
function set_StackTrace(value);

Property Value

Type: String
The stack trace from the service.

Implements

ICommonFaultStackTrace
See Also

Reference

SourceQualificationFault Class
DoubleTake.Jobs.Contract Namespace


SystemStateOptions Class

SystemStateOptions Class
Represents options for using the system state feature of a job.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractSystemStateOptions

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class SystemStateOptions : IExtensibleDataObject
Public Class SystemStateOptions
    Implements IExtensibleDataObject
public ref class SystemStateOptions : IExtensibleDataObject
DoubleTake.Jobs.Contract.SystemStateOptions = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.SystemStateOptions',
    null,
    IExtensibleDataObject);

The SystemStateOptions type exposes the following members.

Constructors
 | Name | Description
Public method | SystemStateOptions | Initializes a new instance of the SystemStateOptions class
Top
Properties
 | Name | Description
Public property | AlternateVolumeMapping | This value is the mapping of source volumes to target volumes for alternate volume staging, for example, C:;N:.
Public property | AlternateVolumeStaging | This value is true if volumes will be staged to an alternate volume; otherwise it is false.
Public property | ApplyPorts | Gets or sets a value indicating whether source engine and management service ports should be copied to the target.
Public property | ClearMonitor | This value is true if the failover monitor should be removed at cutover; otherwise, it is false.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | IsWanFailover | This value is true if the job uses WAN failover; otherwise,it is false.
Public property | KeepTargetActivationCode | This value is true if the target license key should be kept after failover; otherwise, it is false (and the source's license key will be applied to the target after failover).
Public property | NicMappings | This value represents the NIC mappings for a full server job.
Public property | ServicesToStopOptions | This value represents the services on the target to stop during protection.
Public property | ShouldApplyDiskSignatures | This value is true if disk signatures should be applied at cutover; otherwise, it is false.
Public property | SourceReservedAddress | This value is the reserved IP address on the source server.
Public property | StagingFolder | This value is the folder on the target where operating system files from the source will be staged.
Public property | TargetReservedAddress | This value is the reserved IP address on the target server.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


SystemStateOptions Constructor

SystemStateOptions Constructor
Initializes a new instance of the SystemStateOptions class

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public SystemStateOptions()
Public Sub New
public:
SystemStateOptions()
DoubleTake.Jobs.Contract.SystemStateOptions = function();
See Also

Reference

SystemStateOptions Class
DoubleTake.Jobs.Contract Namespace


SystemStateOptions Properties

SystemStateOptions Properties

The SystemStateOptions type exposes the following members.

Properties
 | Name | Description
Public property | AlternateVolumeMapping | This value is the mapping of source volumes to target volumes for alternate volume staging, for example, C:;N:.
Public property | AlternateVolumeStaging | This value is true if volumes will be staged to an alternate volume; otherwise it is false.
Public property | ApplyPorts | Gets or sets a value indicating whether source engine and management service ports should be copied to the target.
Public property | ClearMonitor | This value is true if the failover monitor should be removed at cutover; otherwise, it is false.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | IsWanFailover | This value is true if the job uses WAN failover; otherwise,it is false.
Public property | KeepTargetActivationCode | This value is true if the target license key should be kept after failover; otherwise, it is false (and the source's license key will be applied to the target after failover).
Public property | NicMappings | This value represents the NIC mappings for a full server job.
Public property | ServicesToStopOptions | This value represents the services on the target to stop during protection.
Public property | ShouldApplyDiskSignatures | This value is true if disk signatures should be applied at cutover; otherwise, it is false.
Public property | SourceReservedAddress | This value is the reserved IP address on the source server.
Public property | StagingFolder | This value is the folder on the target where operating system files from the source will be staged.
Public property | TargetReservedAddress | This value is the reserved IP address on the target server.
Top
See Also

Reference

SystemStateOptions Class
DoubleTake.Jobs.Contract Namespace


SystemStateOptions.AlternateVolumeMapping Property

SystemStateOptionsAlternateVolumeMapping Property
This value is the mapping of source volumes to target volumes for alternate volume staging, for example, C:;N:.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string AlternateVolumeMapping { get; set; }
Public Property AlternateVolumeMapping As String
    Get
    Set
public:
property String^ AlternateVolumeMapping {
    String^ get ();
    void set (String^ value);
}
function get_AlternateVolumeMapping();
function set_AlternateVolumeMapping(value);

Property Value

Type: String
The source to target alternate staging volume map. ie. "C:;N:"
See Also

Reference

SystemStateOptions Class
DoubleTake.Jobs.Contract Namespace


SystemStateOptions.AlternateVolumeStaging Property

SystemStateOptionsAlternateVolumeStaging Property
This value is true if volumes will be staged to an alternate volume; otherwise it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool AlternateVolumeStaging { get; set; }
Public Property AlternateVolumeStaging As Boolean
    Get
    Set
public:
property bool AlternateVolumeStaging {
    bool get ();
    void set (bool value);
}
function get_AlternateVolumeStaging();
function set_AlternateVolumeStaging(value);

Property Value

Type: Boolean
if the system volume staging will be done on an alternate volume; otherwise, .
See Also

Reference

SystemStateOptions Class
DoubleTake.Jobs.Contract Namespace


SystemStateOptions.ApplyPorts Property

SystemStateOptionsApplyPorts Property
Gets or sets a value indicating whether source engine and management service ports should be copied to the target.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Nullable<bool> ApplyPorts { get; set; }
Public Property ApplyPorts As Nullable(Of Boolean)
    Get
    Set
public:
property Nullable<bool> ApplyPorts {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}
function get_ApplyPorts();
function set_ApplyPorts(value);

Property Value

Type: Nullable Boolean
if the ports should be copied at cutover; otherwise, .
See Also

Reference

SystemStateOptions Class
DoubleTake.Jobs.Contract Namespace


SystemStateOptions.ClearMonitor Property

SystemStateOptionsClearMonitor Property
This value is true if the failover monitor should be removed at cutover; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool ClearMonitor { get; set; }
Public Property ClearMonitor As Boolean
    Get
    Set
public:
property bool ClearMonitor {
    bool get ();
    void set (bool value);
}
function get_ClearMonitor();
function set_ClearMonitor(value);

Property Value

Type: Boolean
if the failover monitor should be removed at cutover; otherwise, .
See Also

Reference

SystemStateOptions Class
DoubleTake.Jobs.Contract Namespace


SystemStateOptions.ExtensionData Property

SystemStateOptionsExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

SystemStateOptions Class
DoubleTake.Jobs.Contract Namespace


SystemStateOptions.IsWanFailover Property

SystemStateOptionsIsWanFailover Property
This value is true if the job uses WAN failover; otherwise,it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsWanFailover { get; set; }
Public Property IsWanFailover As Boolean
    Get
    Set
public:
property bool IsWanFailover {
    bool get ();
    void set (bool value);
}
function get_IsWanFailover();
function set_IsWanFailover(value);

Property Value

Type: Boolean
if this job uses WAN failover; otherwise, .
See Also

Reference

SystemStateOptions Class
DoubleTake.Jobs.Contract Namespace


SystemStateOptions.KeepTargetActivationCode Property

SystemStateOptionsKeepTargetActivationCode Property
This value is true if the target license key should be kept after failover; otherwise, it is false (and the source's license key will be applied to the target after failover).

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool KeepTargetActivationCode { get; set; }
Public Property KeepTargetActivationCode As Boolean
    Get
    Set
public:
property bool KeepTargetActivationCode {
    bool get ();
    void set (bool value);
}
function get_KeepTargetActivationCode();
function set_KeepTargetActivationCode(value);

Property Value

Type: Boolean
if the target activation code should be kept after failover. Otherwise the source's code will be applied
See Also

Reference

SystemStateOptions Class
DoubleTake.Jobs.Contract Namespace


SystemStateOptions.NicMappings Property

SystemStateOptionsNicMappings Property
This value represents the NIC mappings for a full server job.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public FullServerNicMappings[] NicMappings { get; set; }
Public Property NicMappings As FullServerNicMappings()
    Get
    Set
public:
property array<FullServerNicMappings^>^ NicMappings {
    array<FullServerNicMappings^>^ get ();
    void set (array<FullServerNicMappings^>^ value);
}
function get_NicMappings();
function set_NicMappings(value);

Property Value

Type: FullServerNicMappings
The network interface mappings.
See Also

Reference

SystemStateOptions Class
DoubleTake.Jobs.Contract Namespace


SystemStateOptions.ServicesToStopOptions Property

SystemStateOptionsServicesToStopOptions Property
This value represents the services on the target to stop during protection.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public TargetServicesToStop[] ServicesToStopOptions { get; set; }
Public Property ServicesToStopOptions As TargetServicesToStop()
    Get
    Set
public:
property array<TargetServicesToStop^>^ ServicesToStopOptions {
    array<TargetServicesToStop^>^ get ();
    void set (array<TargetServicesToStop^>^ value);
}
function get_ServicesToStopOptions();
function set_ServicesToStopOptions(value);

Property Value

Type: TargetServicesToStop
The services on the target server to stop during protection.
See Also

Reference

SystemStateOptions Class
DoubleTake.Jobs.Contract Namespace


SystemStateOptions.ShouldApplyDiskSignatures Property

SystemStateOptionsShouldApplyDiskSignatures Property
This value is true if disk signatures should be applied at cutover; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool ShouldApplyDiskSignatures { get; set; }
Public Property ShouldApplyDiskSignatures As Boolean
    Get
    Set
public:
property bool ShouldApplyDiskSignatures {
    bool get ();
    void set (bool value);
}
function get_ShouldApplyDiskSignatures();
function set_ShouldApplyDiskSignatures(value);

Property Value

Type: Boolean
if disk signatures should be applied at cutover; otherwise, .
See Also

Reference

SystemStateOptions Class
DoubleTake.Jobs.Contract Namespace


SystemStateOptions.SourceReservedAddress Property

SystemStateOptionsSourceReservedAddress Property
This value is the reserved IP address on the source server.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string SourceReservedAddress { get; set; }
Public Property SourceReservedAddress As String
    Get
    Set
public:
property String^ SourceReservedAddress {
    String^ get ();
    void set (String^ value);
}
function get_SourceReservedAddress();
function set_SourceReservedAddress(value);

Property Value

Type: String
The reserved IP address on the source server.
See Also

Reference

SystemStateOptions Class
DoubleTake.Jobs.Contract Namespace


SystemStateOptions.StagingFolder Property

SystemStateOptionsStagingFolder Property
This value is the folder on the target where operating system files from the source will be staged.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string StagingFolder { get; set; }
Public Property StagingFolder As String
    Get
    Set
public:
property String^ StagingFolder {
    String^ get ();
    void set (String^ value);
}
function get_StagingFolder();
function set_StagingFolder(value);

Property Value

Type: String
The folder where operating system files will be staged.
See Also

Reference

SystemStateOptions Class
DoubleTake.Jobs.Contract Namespace


SystemStateOptions.TargetReservedAddress Property

SystemStateOptionsTargetReservedAddress Property
This value is the reserved IP address on the target server.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string TargetReservedAddress { get; set; }
Public Property TargetReservedAddress As String
    Get
    Set
public:
property String^ TargetReservedAddress {
    String^ get ();
    void set (String^ value);
}
function get_TargetReservedAddress();
function set_TargetReservedAddress(value);

Property Value

Type: String
The reserved IP address on the target server.
See Also

Reference

SystemStateOptions Class
DoubleTake.Jobs.Contract Namespace


TargetFileServerQualificationResults Class

TargetFileServerQualificationResults Class
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractTargetFileServerQualificationResults

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class TargetFileServerQualificationResults : IExtensibleDataObject
Public Class TargetFileServerQualificationResults
    Implements IExtensibleDataObject
public ref class TargetFileServerQualificationResults : IExtensibleDataObject
DoubleTake.Jobs.Contract.TargetFileServerQualificationResults = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.TargetFileServerQualificationResults',
    null,
    IExtensibleDataObject);

The TargetFileServerQualificationResults type exposes the following members.

Constructors
 | Name | Description
Public method | TargetFileServerQualificationResults | Initializes a new instance of the TargetFileServerQualificationResults class
Top
Properties
 | Name | Description
Public property | ClusterResourceGroupIPAddresses | This value represents a unicast IP address.
Public property | ClusterResourceGroupName | This value is the name of the cluster group that contains the resource.
Public property | CurrentOwnerNodeName | This value is the name of the resource's current owning node.
Public property | DiskSize | This value is total disk size, in bytes, of the volume.
Public property | DriveLetter | This value is the volume drive letter.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | FreeSpace | This value is the free space, in bytes, available on the volume.
Public property | IsVolumeCSV | This value is true if it is a cluster shared volume; otherwise, it is false.
Public property | RecommendedGroup | This value is true if there is a file server group on the target cluster that matches the protected file server group from the source; otherwise, it is false. When this value is true, an IP address from the group will be used as the route for CoreConnectionOptions.TargetAddress
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


TargetFileServerQualificationResults Constructor

TargetFileServerQualificationResults Constructor
Initializes a new instance of the TargetFileServerQualificationResults class

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public TargetFileServerQualificationResults()
Public Sub New
public:
TargetFileServerQualificationResults()
DoubleTake.Jobs.Contract.TargetFileServerQualificationResults = function();
See Also

Reference

TargetFileServerQualificationResults Class
DoubleTake.Jobs.Contract Namespace


TargetFileServerQualificationResults Properties

TargetFileServerQualificationResults Properties

The TargetFileServerQualificationResults type exposes the following members.

Properties
 | Name | Description
Public property | ClusterResourceGroupIPAddresses | This value represents a unicast IP address.
Public property | ClusterResourceGroupName | This value is the name of the cluster group that contains the resource.
Public property | CurrentOwnerNodeName | This value is the name of the resource's current owning node.
Public property | DiskSize | This value is total disk size, in bytes, of the volume.
Public property | DriveLetter | This value is the volume drive letter.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | FreeSpace | This value is the free space, in bytes, available on the volume.
Public property | IsVolumeCSV | This value is true if it is a cluster shared volume; otherwise, it is false.
Public property | RecommendedGroup | This value is true if there is a file server group on the target cluster that matches the protected file server group from the source; otherwise, it is false. When this value is true, an IP address from the group will be used as the route for CoreConnectionOptions.TargetAddress
Top
See Also

Reference

TargetFileServerQualificationResults Class
DoubleTake.Jobs.Contract Namespace


TargetFileServerQualificationResults.ClusterResourceGroupIPAddresses Property

TargetFileServerQualificationResultsClusterResourceGroupIPAddresses Property
This value represents a unicast IP address.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public UnicastIPAddressInfo[] ClusterResourceGroupIPAddresses { get; set; }
Public Property ClusterResourceGroupIPAddresses As UnicastIPAddressInfo()
    Get
    Set
public:
property array<UnicastIPAddressInfo^>^ ClusterResourceGroupIPAddresses {
    array<UnicastIPAddressInfo^>^ get ();
    void set (array<UnicastIPAddressInfo^>^ value);
}
function get_ClusterResourceGroupIPAddresses();
function set_ClusterResourceGroupIPAddresses(value);

Property Value

Type: UnicastIPAddressInfo
See Also

Reference

TargetFileServerQualificationResults Class
DoubleTake.Jobs.Contract Namespace


TargetFileServerQualificationResults.ClusterResourceGroupName Property

TargetFileServerQualificationResultsClusterResourceGroupName Property
This value is the name of the cluster group that contains the resource.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string ClusterResourceGroupName { get; set; }
Public Property ClusterResourceGroupName As String
    Get
    Set
public:
property String^ ClusterResourceGroupName {
    String^ get ();
    void set (String^ value);
}
function get_ClusterResourceGroupName();
function set_ClusterResourceGroupName(value);

Property Value

Type: String
See Also

Reference

TargetFileServerQualificationResults Class
DoubleTake.Jobs.Contract Namespace


TargetFileServerQualificationResults.CurrentOwnerNodeName Property

TargetFileServerQualificationResultsCurrentOwnerNodeName Property
This value is the name of the resource's current owning node.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string CurrentOwnerNodeName { get; set; }
Public Property CurrentOwnerNodeName As String
    Get
    Set
public:
property String^ CurrentOwnerNodeName {
    String^ get ();
    void set (String^ value);
}
function get_CurrentOwnerNodeName();
function set_CurrentOwnerNodeName(value);

Property Value

Type: String
See Also

Reference

TargetFileServerQualificationResults Class
DoubleTake.Jobs.Contract Namespace


TargetFileServerQualificationResults.DiskSize Property

TargetFileServerQualificationResultsDiskSize Property
This value is total disk size, in bytes, of the volume.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public long DiskSize { get; set; }
Public Property DiskSize As Long
    Get
    Set
public:
property long long DiskSize {
    long long get ();
    void set (long long value);
}
function get_DiskSize();
function set_DiskSize(value);

Property Value

Type: Int64
See Also

Reference

TargetFileServerQualificationResults Class
DoubleTake.Jobs.Contract Namespace


TargetFileServerQualificationResults.DriveLetter Property

TargetFileServerQualificationResultsDriveLetter Property
This value is the volume drive letter.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string DriveLetter { get; set; }
Public Property DriveLetter As String
    Get
    Set
public:
property String^ DriveLetter {
    String^ get ();
    void set (String^ value);
}
function get_DriveLetter();
function set_DriveLetter(value);

Property Value

Type: String
See Also

Reference

TargetFileServerQualificationResults Class
DoubleTake.Jobs.Contract Namespace


TargetFileServerQualificationResults.ExtensionData Property

TargetFileServerQualificationResultsExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

TargetFileServerQualificationResults Class
DoubleTake.Jobs.Contract Namespace


TargetFileServerQualificationResults.FreeSpace Property

TargetFileServerQualificationResultsFreeSpace Property
This value is the free space, in bytes, available on the volume.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public long FreeSpace { get; set; }
Public Property FreeSpace As Long
    Get
    Set
public:
property long long FreeSpace {
    long long get ();
    void set (long long value);
}
function get_FreeSpace();
function set_FreeSpace(value);

Property Value

Type: Int64
See Also

Reference

TargetFileServerQualificationResults Class
DoubleTake.Jobs.Contract Namespace


TargetFileServerQualificationResults.IsVolumeCSV Property

TargetFileServerQualificationResultsIsVolumeCSV Property
This value is true if it is a cluster shared volume; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsVolumeCSV { get; set; }
Public Property IsVolumeCSV As Boolean
    Get
    Set
public:
property bool IsVolumeCSV {
    bool get ();
    void set (bool value);
}
function get_IsVolumeCSV();
function set_IsVolumeCSV(value);

Property Value

Type: Boolean
See Also

Reference

TargetFileServerQualificationResults Class
DoubleTake.Jobs.Contract Namespace


TargetFileServerQualificationResults.RecommendedGroup Property

TargetFileServerQualificationResultsRecommendedGroup Property
This value is true if there is a file server group on the target cluster that matches the protected file server group from the source; otherwise, it is false. When this value is true, an IP address from the group will be used as the route for CoreConnectionOptions.TargetAddress

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool RecommendedGroup { get; set; }
Public Property RecommendedGroup As Boolean
    Get
    Set
public:
property bool RecommendedGroup {
    bool get ();
    void set (bool value);
}
function get_RecommendedGroup();
function set_RecommendedGroup(value);

Property Value

Type: Boolean
See Also

Reference

TargetFileServerQualificationResults Class
DoubleTake.Jobs.Contract Namespace


TargetServicesOptions Class

TargetServicesOptions Class
Represents options for configuring how target services function after failover.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractTargetServicesOptions

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class TargetServicesOptions : IExtensibleDataObject
Public Class TargetServicesOptions
    Implements IExtensibleDataObject
public ref class TargetServicesOptions : IExtensibleDataObject
DoubleTake.Jobs.Contract.TargetServicesOptions = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.TargetServicesOptions',
    null,
    IExtensibleDataObject);

The TargetServicesOptions type exposes the following members.

Constructors
 | Name | Description
Public method | TargetServicesOptions | Initializes a new instance of the TargetServicesOptions class
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | FailoverServices | This value represents services that will be stopped on the source and started on the target during failover and started on the source and stopped on the target during failback.
Public property | StartAndStopServices | This value is true if the services will be stopped and started; otherwise, it is false (and the services will be left running).
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


TargetServicesOptions Constructor

TargetServicesOptions Constructor
Initializes a new instance of the TargetServicesOptions class

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public TargetServicesOptions()
Public Sub New
public:
TargetServicesOptions()
DoubleTake.Jobs.Contract.TargetServicesOptions = function();
See Also

Reference

TargetServicesOptions Class
DoubleTake.Jobs.Contract Namespace


TargetServicesOptions Properties

TargetServicesOptions Properties

The TargetServicesOptions type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | FailoverServices | This value represents services that will be stopped on the source and started on the target during failover and started on the source and stopped on the target during failback.
Public property | StartAndStopServices | This value is true if the services will be stopped and started; otherwise, it is false (and the services will be left running).
Top
See Also

Reference

TargetServicesOptions Class
DoubleTake.Jobs.Contract Namespace


TargetServicesOptions.ExtensionData Property

TargetServicesOptionsExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

TargetServicesOptions Class
DoubleTake.Jobs.Contract Namespace


TargetServicesOptions.FailoverServices Property

TargetServicesOptionsFailoverServices Property
This value represents services that will be stopped on the source and started on the target during failover and started on the source and stopped on the target during failback.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ServiceInformation[] FailoverServices { get; set; }
Public Property FailoverServices As ServiceInformation()
    Get
    Set
public:
property array<ServiceInformation^>^ FailoverServices {
    array<ServiceInformation^>^ get ();
    void set (array<ServiceInformation^>^ value);
}
function get_FailoverServices();
function set_FailoverServices(value);

Property Value

Type: ServiceInformation
See Also

Reference

TargetServicesOptions Class
DoubleTake.Jobs.Contract Namespace


TargetServicesOptions.StartAndStopServices Property

TargetServicesOptionsStartAndStopServices Property
This value is true if the services will be stopped and started; otherwise, it is false (and the services will be left running).

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool StartAndStopServices { get; set; }
Public Property StartAndStopServices As Boolean
    Get
    Set
public:
property bool StartAndStopServices {
    bool get ();
    void set (bool value);
}
function get_StartAndStopServices();
function set_StartAndStopServices(value);

Property Value

Type: Boolean
Remarks
The TargetServicesOptionsPresenter is overloaded to use the same widget for jobs that are starting and stopping the services and those that leave the services running. This value is used by the console to determine how the widget should look, feel and function.
See Also

Reference

TargetServicesOptions Class
DoubleTake.Jobs.Contract Namespace


UnmanagedConnectionOptions Class

UnmanagedConnectionOptions Class
Represents options for configuring an unmanaged connection job.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractUnmanagedConnectionOptions

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class UnmanagedConnectionOptions : IExtensibleDataObject
Public Class UnmanagedConnectionOptions
    Implements IExtensibleDataObject
public ref class UnmanagedConnectionOptions : IExtensibleDataObject
DoubleTake.Jobs.Contract.UnmanagedConnectionOptions = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.UnmanagedConnectionOptions',
    null,
    IExtensibleDataObject);

The UnmanagedConnectionOptions type exposes the following members.

Constructors
 | Name | Description
Public method | UnmanagedConnectionOptions | Initializes a new instance of the UnmanagedConnectionOptions class
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | TargetStateInfo | This value represents information on the state of the target.
Top
Remarks
An unmanaged connection job represents a connection that is not associated with a known job. This connection may have been created a client outside of the job manager.
See Also

Reference

DoubleTake.Jobs.Contract Namespace


UnmanagedConnectionOptions Constructor

UnmanagedConnectionOptions Constructor
Initializes a new instance of the UnmanagedConnectionOptions class

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public UnmanagedConnectionOptions()
Public Sub New
public:
UnmanagedConnectionOptions()
DoubleTake.Jobs.Contract.UnmanagedConnectionOptions = function();
See Also

Reference

UnmanagedConnectionOptions Class
DoubleTake.Jobs.Contract Namespace


UnmanagedConnectionOptions Properties

UnmanagedConnectionOptions Properties

The UnmanagedConnectionOptions type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | TargetStateInfo | This value represents information on the state of the target.
Top
See Also

Reference

UnmanagedConnectionOptions Class
DoubleTake.Jobs.Contract Namespace


UnmanagedConnectionOptions.ExtensionData Property

UnmanagedConnectionOptionsExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

UnmanagedConnectionOptions Class
DoubleTake.Jobs.Contract Namespace


UnmanagedConnectionOptions.TargetStateInfo Property

UnmanagedConnectionOptionsTargetStateInfo Property
This value represents information on the state of the target.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public TargetStateInfo TargetStateInfo { get; set; }
Public Property TargetStateInfo As TargetStateInfo
    Get
    Set
public:
property TargetStateInfo^ TargetStateInfo {
    TargetStateInfo^ get ();
    void set (TargetStateInfo^ value);
}
function get_TargetStateInfo();
function set_TargetStateInfo(value);

Property Value

Type: TargetStateInfo
The target state information for this connection.
See Also

Reference

UnmanagedConnectionOptions Class
DoubleTake.Jobs.Contract Namespace


V2VQualificationResults Class

V2VQualificationResults Class
Represents information that may be needed to configure a V2V job.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractV2VQualificationResults

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class V2VQualificationResults
Public Class V2VQualificationResults
public ref class V2VQualificationResults
DoubleTake.Jobs.Contract.V2VQualificationResults = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.V2VQualificationResults');

The V2VQualificationResults type exposes the following members.

Constructors
 | Name | Description
Public method | V2VQualificationResults | Initializes a new instance of the V2VQualificationResults class
Top
Properties
 | Name | Description
Public property | ReverseNetworkRoutes | This value is the available routes on the source.
Public property | SourceActivationCodeInfo | This value is the license key on the source.
Public property | SourceEnginePort | This value is the replication engine port on the source.
Public property | SourceHostAllVirtualMachines | This value represents the source virtual machines. This property is needed to select a reverse appliance for V to ESX jobs.
Public property | SourceHostVirtualSwitches | This value represents the source virtual switches on the source.
Public property | SourceHyperVHostSelectedVirtualMachines | This value represents the selected source virtual machines. This property is needed to get a workload for V to Hyper-V jobs.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


V2VQualificationResults Constructor

V2VQualificationResults Constructor
Initializes a new instance of the V2VQualificationResults class

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public V2VQualificationResults()
Public Sub New
public:
V2VQualificationResults()
DoubleTake.Jobs.Contract.V2VQualificationResults = function();
See Also

Reference

V2VQualificationResults Class
DoubleTake.Jobs.Contract Namespace


V2VQualificationResults Properties

V2VQualificationResults Properties

The V2VQualificationResults type exposes the following members.

Properties
 | Name | Description
Public property | ReverseNetworkRoutes | This value is the available routes on the source.
Public property | SourceActivationCodeInfo | This value is the license key on the source.
Public property | SourceEnginePort | This value is the replication engine port on the source.
Public property | SourceHostAllVirtualMachines | This value represents the source virtual machines. This property is needed to select a reverse appliance for V to ESX jobs.
Public property | SourceHostVirtualSwitches | This value represents the source virtual switches on the source.
Public property | SourceHyperVHostSelectedVirtualMachines | This value represents the selected source virtual machines. This property is needed to get a workload for V to Hyper-V jobs.
Top
See Also

Reference

V2VQualificationResults Class
DoubleTake.Jobs.Contract Namespace


V2VQualificationResults.ReverseNetworkRoutes Property

V2VQualificationResultsReverseNetworkRoutes Property
This value is the available routes on the source.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string[] ReverseNetworkRoutes { get; set; }
Public Property ReverseNetworkRoutes As String()
    Get
    Set
public:
property array<String^>^ ReverseNetworkRoutes {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
function get_ReverseNetworkRoutes();
function set_ReverseNetworkRoutes(value);

Property Value

Type: String
The source route.
See Also

Reference

V2VQualificationResults Class
DoubleTake.Jobs.Contract Namespace


V2VQualificationResults.SourceActivationCodeInfo Property

V2VQualificationResultsSourceActivationCodeInfo Property
This value is the license key on the source.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ActivationCodeInfo SourceActivationCodeInfo { get; set; }
Public Property SourceActivationCodeInfo As ActivationCodeInfo
    Get
    Set
public:
property ActivationCodeInfo^ SourceActivationCodeInfo {
    ActivationCodeInfo^ get ();
    void set (ActivationCodeInfo^ value);
}
function get_SourceActivationCodeInfo();
function set_SourceActivationCodeInfo(value);

Property Value

Type: ActivationCodeInfo
See Also

Reference

V2VQualificationResults Class
DoubleTake.Jobs.Contract Namespace


V2VQualificationResults.SourceEnginePort Property

V2VQualificationResultsSourceEnginePort Property
This value is the replication engine port on the source.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int SourceEnginePort { get; set; }
Public Property SourceEnginePort As Integer
    Get
    Set
public:
property int SourceEnginePort {
    int get ();
    void set (int value);
}
function get_SourceEnginePort();
function set_SourceEnginePort(value);

Property Value

Type: Int32
See Also

Reference

V2VQualificationResults Class
DoubleTake.Jobs.Contract Namespace


V2VQualificationResults.SourceHostAllVirtualMachines Property

V2VQualificationResultsSourceHostAllVirtualMachines Property
This value represents the source virtual machines. This property is needed to select a reverse appliance for V to ESX jobs.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VMInfo[] SourceHostAllVirtualMachines { get; set; }
Public Property SourceHostAllVirtualMachines As VMInfo()
    Get
    Set
public:
property array<VMInfo^>^ SourceHostAllVirtualMachines {
    array<VMInfo^>^ get ();
    void set (array<VMInfo^>^ value);
}
function get_SourceHostAllVirtualMachines();
function set_SourceHostAllVirtualMachines(value);

Property Value

Type: VMInfo
The source virtual machines.
See Also

Reference

V2VQualificationResults Class
DoubleTake.Jobs.Contract Namespace


V2VQualificationResults.SourceHostVirtualSwitches Property

V2VQualificationResultsSourceHostVirtualSwitches Property
This value represents the source virtual switches on the source.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VirtualSwitchInfo[] SourceHostVirtualSwitches { get; set; }
Public Property SourceHostVirtualSwitches As VirtualSwitchInfo()
    Get
    Set
public:
property array<VirtualSwitchInfo^>^ SourceHostVirtualSwitches {
    array<VirtualSwitchInfo^>^ get ();
    void set (array<VirtualSwitchInfo^>^ value);
}
function get_SourceHostVirtualSwitches();
function set_SourceHostVirtualSwitches(value);

Property Value

Type: VirtualSwitchInfo
The array of number of virtual switches.
See Also

Reference

V2VQualificationResults Class
DoubleTake.Jobs.Contract Namespace


V2VQualificationResults.SourceHyperVHostSelectedVirtualMachines Property

V2VQualificationResultsSourceHyperVHostSelectedVirtualMachines Property
This value represents the selected source virtual machines. This property is needed to get a workload for V to Hyper-V jobs.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public V2VVirtualMachine[] SourceHyperVHostSelectedVirtualMachines { get; set; }
Public Property SourceHyperVHostSelectedVirtualMachines As V2VVirtualMachine()
    Get
    Set
public:
property array<V2VVirtualMachine^>^ SourceHyperVHostSelectedVirtualMachines {
    array<V2VVirtualMachine^>^ get ();
    void set (array<V2VVirtualMachine^>^ value);
}
function get_SourceHyperVHostSelectedVirtualMachines();
function set_SourceHyperVHostSelectedVirtualMachines(value);

Property Value

Type: V2VVirtualMachine
The source virtual machines.
See Also

Reference

V2VQualificationResults Class
DoubleTake.Jobs.Contract Namespace


VcdVappOptions Class

VcdVappOptions Class
New DTVI for Linux
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractVcdVappOptions

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class VcdVappOptions : IExtensibleDataObject
Public Class VcdVappOptions
    Implements IExtensibleDataObject
public ref class VcdVappOptions : IExtensibleDataObject
DoubleTake.Jobs.Contract.VcdVappOptions = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.VcdVappOptions',
    null,
    IExtensibleDataObject);

The VcdVappOptions type exposes the following members.

Constructors
 | Name | Description
Public method | VcdVappOptions | Initializes a new instance of the VcdVappOptions class
Top
Properties
 | Name | Description
Public property | DoDiskDataEncryption |
Public property | ExtensionData |
Public property | IsSnapshotQuiescenceEnabled |
Public property | ReplicationIntervalSeconds |
Public property | SourceVappDisplayName |
Public property | SourceVappGuid |
Public property | TargetVappDisplayName |
Top
Fields
 | Name | Description
Public field | SourceOrgName |
Public field | TargetOrgName |
Public field | TargetOrgVdcName |
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


VcdVappOptions Constructor

VcdVappOptions Constructor
Initializes a new instance of the VcdVappOptions class

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VcdVappOptions()
Public Sub New
public:
VcdVappOptions()
DoubleTake.Jobs.Contract.VcdVappOptions = function();
See Also

Reference

VcdVappOptions Class
DoubleTake.Jobs.Contract Namespace


VcdVappOptions Properties

VcdVappOptions Properties

The VcdVappOptions type exposes the following members.

Properties
 | Name | Description
Public property | DoDiskDataEncryption |
Public property | ExtensionData |
Public property | IsSnapshotQuiescenceEnabled |
Public property | ReplicationIntervalSeconds |
Public property | SourceVappDisplayName |
Public property | SourceVappGuid |
Public property | TargetVappDisplayName |
Top
See Also

Reference

VcdVappOptions Class
DoubleTake.Jobs.Contract Namespace


VcdVappOptions.DoDiskDataEncryption Property

VcdVappOptionsDoDiskDataEncryption Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool DoDiskDataEncryption { get; set; }
Public Property DoDiskDataEncryption As Boolean
    Get
    Set
public:
property bool DoDiskDataEncryption {
    bool get ();
    void set (bool value);
}
function get_DoDiskDataEncryption();
function set_DoDiskDataEncryption(value);

Property Value

Type: Boolean
See Also

Reference

VcdVappOptions Class
DoubleTake.Jobs.Contract Namespace


VcdVappOptions.ExtensionData Property

VcdVappOptionsExtensionData Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

VcdVappOptions Class
DoubleTake.Jobs.Contract Namespace


VcdVappOptions.IsSnapshotQuiescenceEnabled Property

VcdVappOptionsIsSnapshotQuiescenceEnabled Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsSnapshotQuiescenceEnabled { get; set; }
Public Property IsSnapshotQuiescenceEnabled As Boolean
    Get
    Set
public:
property bool IsSnapshotQuiescenceEnabled {
    bool get ();
    void set (bool value);
}
function get_IsSnapshotQuiescenceEnabled();
function set_IsSnapshotQuiescenceEnabled(value);

Property Value

Type: Boolean
See Also

Reference

VcdVappOptions Class
DoubleTake.Jobs.Contract Namespace


VcdVappOptions.ReplicationIntervalSeconds Property

VcdVappOptionsReplicationIntervalSeconds Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int ReplicationIntervalSeconds { get; set; }
Public Property ReplicationIntervalSeconds As Integer
    Get
    Set
public:
property int ReplicationIntervalSeconds {
    int get ();
    void set (int value);
}
function get_ReplicationIntervalSeconds();
function set_ReplicationIntervalSeconds(value);

Property Value

Type: Int32
See Also

Reference

VcdVappOptions Class
DoubleTake.Jobs.Contract Namespace


VcdVappOptions.SourceVappDisplayName Property

VcdVappOptionsSourceVappDisplayName Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string SourceVappDisplayName { get; set; }
Public Property SourceVappDisplayName As String
    Get
    Set
public:
property String^ SourceVappDisplayName {
    String^ get ();
    void set (String^ value);
}
function get_SourceVappDisplayName();
function set_SourceVappDisplayName(value);

Property Value

Type: String
See Also

Reference

VcdVappOptions Class
DoubleTake.Jobs.Contract Namespace


VcdVappOptions.SourceVappGuid Property

VcdVappOptionsSourceVappGuid Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string SourceVappGuid { get; set; }
Public Property SourceVappGuid As String
    Get
    Set
public:
property String^ SourceVappGuid {
    String^ get ();
    void set (String^ value);
}
function get_SourceVappGuid();
function set_SourceVappGuid(value);

Property Value

Type: String
See Also

Reference

VcdVappOptions Class
DoubleTake.Jobs.Contract Namespace


VcdVappOptions.TargetVappDisplayName Property

VcdVappOptionsTargetVappDisplayName Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string TargetVappDisplayName { get; set; }
Public Property TargetVappDisplayName As String
    Get
    Set
public:
property String^ TargetVappDisplayName {
    String^ get ();
    void set (String^ value);
}
function get_TargetVappDisplayName();
function set_TargetVappDisplayName(value);

Property Value

Type: String
See Also

Reference

VcdVappOptions Class
DoubleTake.Jobs.Contract Namespace


VcdVappOptions Fields

VcdVappOptions Fields

The VcdVappOptions type exposes the following members.

Fields
 | Name | Description
Public field | SourceOrgName |
Public field | TargetOrgName |
Public field | TargetOrgVdcName |
Top
See Also

Reference

VcdVappOptions Class
DoubleTake.Jobs.Contract Namespace


VcdVappOptions.SourceOrgName Field

VcdVappOptionsSourceOrgName Field

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string SourceOrgName
Public SourceOrgName As String
public:
String^ SourceOrgName
var SourceOrgName

Field Value

Type: String
See Also

Reference

VcdVappOptions Class
DoubleTake.Jobs.Contract Namespace


VcdVappOptions.TargetOrgName Field

VcdVappOptionsTargetOrgName Field

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string TargetOrgName
Public TargetOrgName As String
public:
String^ TargetOrgName
var TargetOrgName

Field Value

Type: String
See Also

Reference

VcdVappOptions Class
DoubleTake.Jobs.Contract Namespace


VcdVappOptions.TargetOrgVdcName Field

VcdVappOptionsTargetOrgVdcName Field

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string TargetOrgVdcName
Public TargetOrgVdcName As String
public:
String^ TargetOrgVdcName
var TargetOrgVdcName

Field Value

Type: String
See Also

Reference

VcdVappOptions Class
DoubleTake.Jobs.Contract Namespace


VerificationStatus Enumeration

VerificationStatus Enumeration
Indicates the status of a verification task or step.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public enum VerificationStatus
Public Enumeration VerificationStatus
public enum class VerificationStatus
DoubleTake.Jobs.Contract.VerificationStatus = function();
DoubleTake.Jobs.Contract.VerificationStatus.createEnum('DoubleTake.Jobs.Contract.VerificationStatus', false);
Members
Member name | Value | Description
InProgress | 0 | Indicates the verification task or step is still running.
Success | 1 | Indicates the verification task or step has completed successfully.
Warning | 2 | Indicates the verification task or step has completed with a warning.
Error | 3 | Indicates the verification task or step has completed with an error.
See Also

Reference

DoubleTake.Jobs.Contract Namespace


VerificationStep Class

VerificationStep Class
Represents a step in a verification task.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractVerificationStep

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class VerificationStep : IExtensibleDataObject
Public Class VerificationStep
    Implements IExtensibleDataObject
public ref class VerificationStep : IExtensibleDataObject
DoubleTake.Jobs.Contract.VerificationStep = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.VerificationStep',
    null,
    IExtensibleDataObject);

The VerificationStep type exposes the following members.

Constructors
 | Name | Description
Public method | VerificationStep | Initializes a new instance of the VerificationStep class
Top
Properties
 | Name | Description
Public property | CanFix | This value is true if Double-Take can automatically fix the validation item; otherwise, it is false.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Id | This value is the ID for the validation item.
Public property | Index | This value is an index value used to impose an order to the validation items.
Public property | MessageFormatParameters | This value is the message format parameters.
Public property | MessageKey | This value is a message key for the validation item. This value can be used to look up the message text.
Public property | Progress | This value is the completion progress of the validation item.
Public property | Status | This value represents the status of the validation item.
Public property | TitleFormatParameters | This value is the title format parameters for the action.
Public property | TitleKey | This value is a title key for the validation item. This value can be used to look up the title text.
Top
Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


VerificationStep Constructor

VerificationStep Constructor
Initializes a new instance of the VerificationStep class

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VerificationStep()
Public Sub New
public:
VerificationStep()
DoubleTake.Jobs.Contract.VerificationStep = function();
See Also

Reference

VerificationStep Class
DoubleTake.Jobs.Contract Namespace


VerificationStep Properties

VerificationStep Properties

The VerificationStep type exposes the following members.

Properties
 | Name | Description
Public property | CanFix | This value is true if Double-Take can automatically fix the validation item; otherwise, it is false.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Id | This value is the ID for the validation item.
Public property | Index | This value is an index value used to impose an order to the validation items.
Public property | MessageFormatParameters | This value is the message format parameters.
Public property | MessageKey | This value is a message key for the validation item. This value can be used to look up the message text.
Public property | Progress | This value is the completion progress of the validation item.
Public property | Status | This value represents the status of the validation item.
Public property | TitleFormatParameters | This value is the title format parameters for the action.
Public property | TitleKey | This value is a title key for the validation item. This value can be used to look up the title text.
Top
See Also

Reference

VerificationStep Class
DoubleTake.Jobs.Contract Namespace


VerificationStep.CanFix Property

VerificationStepCanFix Property
This value is true if Double-Take can automatically fix the validation item; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool CanFix { get; set; }
Public Property CanFix As Boolean
    Get
    Set
public:
property bool CanFix {
    bool get ();
    void set (bool value);
}
function get_CanFix();
function set_CanFix(value);

Property Value

Type: Boolean
if this step can be fixed; otherwise, .
See Also

Reference

VerificationStep Class
DoubleTake.Jobs.Contract Namespace


VerificationStep.ExtensionData Property

VerificationStepExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

VerificationStep Class
DoubleTake.Jobs.Contract Namespace


VerificationStep.Id Property

VerificationStepId Property
This value is the ID for the validation item.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Id { get; set; }
Public Property Id As String
    Get
    Set
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}
function get_Id();
function set_Id(value);

Property Value

Type: String
The identifier of this verification step.
See Also

Reference

VerificationStep Class
DoubleTake.Jobs.Contract Namespace


VerificationStep.Index Property

VerificationStepIndex Property
This value is an index value used to impose an order to the validation items.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int Index { get; set; }
Public Property Index As Integer
    Get
    Set
public:
property int Index {
    int get ();
    void set (int value);
}
function get_Index();
function set_Index(value);

Property Value

Type: Int32
The index.
Remarks
This index can be used by job-level verifiers to impose an order to the steps being generated by the individual job aspect verifiers.
See Also

Reference

VerificationStep Class
DoubleTake.Jobs.Contract Namespace


VerificationStep.MessageFormatParameters Property

VerificationStepMessageFormatParameters Property
This value is the message format parameters.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string[] MessageFormatParameters { get; set; }
Public Property MessageFormatParameters As String()
    Get
    Set
public:
property array<String^>^ MessageFormatParameters {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
function get_MessageFormatParameters();
function set_MessageFormatParameters(value);

Property Value

Type: String
The message format parameters for this verification step.
See Also

Reference

VerificationStep Class
DoubleTake.Jobs.Contract Namespace


VerificationStep.MessageKey Property

VerificationStepMessageKey Property
This value is a message key for the validation item. This value can be used to look up the message text.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string MessageKey { get; set; }
Public Property MessageKey As String
    Get
    Set
public:
property String^ MessageKey {
    String^ get ();
    void set (String^ value);
}
function get_MessageKey();
function set_MessageKey(value);

Property Value

Type: String
The message key for this verification step.
See Also

Reference

VerificationStep Class
DoubleTake.Jobs.Contract Namespace


VerificationStep.Progress Property

VerificationStepProgress Property
This value is the completion progress of the validation item.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int Progress { get; set; }
Public Property Progress As Integer
    Get
    Set
public:
property int Progress {
    int get ();
    void set (int value);
}
function get_Progress();
function set_Progress(value);

Property Value

Type: Int32
The completion progress of this verification step.
See Also

Reference

VerificationStep Class
DoubleTake.Jobs.Contract Namespace


VerificationStep.Status Property

VerificationStepStatus Property
This value represents the status of the validation item.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VerificationStatus Status { get; set; }
Public Property Status As VerificationStatus
    Get
    Set
public:
property VerificationStatus Status {
    VerificationStatus get ();
    void set (VerificationStatus value);
}
function get_Status();
function set_Status(value);

Property Value

Type: VerificationStatus
The status of this verification step.
See Also

Reference

VerificationStep Class
DoubleTake.Jobs.Contract Namespace


VerificationStep.TitleFormatParameters Property

VerificationStepTitleFormatParameters Property
This value is the title format parameters for the action.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string[] TitleFormatParameters { get; set; }
Public Property TitleFormatParameters As String()
    Get
    Set
public:
property array<String^>^ TitleFormatParameters {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
function get_TitleFormatParameters();
function set_TitleFormatParameters(value);

Property Value

Type: String
The title format parameters for this verification step.
See Also

Reference

VerificationStep Class
DoubleTake.Jobs.Contract Namespace


VerificationStep.TitleKey Property

VerificationStepTitleKey Property
This value is a title key for the validation item. This value can be used to look up the title text.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string TitleKey { get; set; }
Public Property TitleKey As String
    Get
    Set
public:
property String^ TitleKey {
    String^ get ();
    void set (String^ value);
}
function get_TitleKey();
function set_TitleKey(value);

Property Value

Type: String
The title key for this verification step.
See Also

Reference

VerificationStep Class
DoubleTake.Jobs.Contract Namespace


VerificationStep Methods

VerificationStep Methods

The VerificationStep type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Top
See Also

Reference

VerificationStep Class
DoubleTake.Jobs.Contract Namespace


VerificationStep.Clone Method

VerificationStepClone Method
Creates a new object that is a copy of the current instance.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
function Clone();

Return Value

Type: Object
A new object that is a copy of this instance.
See Also

Reference

VerificationStep Class
DoubleTake.Jobs.Contract Namespace


VerificationTaskStatus Class

VerificationTaskStatus Class
Represents the status of a verification task.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractVerificationTaskStatus

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class VerificationTaskStatus : IExtensibleDataObject
Public Class VerificationTaskStatus
    Implements IExtensibleDataObject
public ref class VerificationTaskStatus : IExtensibleDataObject
DoubleTake.Jobs.Contract.VerificationTaskStatus = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.VerificationTaskStatus',
    null,
    IExtensibleDataObject);

The VerificationTaskStatus type exposes the following members.

Constructors
 | Name | Description
Public method | VerificationTaskStatus | Initializes a new instance of the VerificationTaskStatus class
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Steps | This value represents a step in the job validation process. Do not confuse this process with the verification process that confirms if the data between the source and target are synchronized.
Public property | Task | This value represents the status of the validation task.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


VerificationTaskStatus Constructor

VerificationTaskStatus Constructor
Initializes a new instance of the VerificationTaskStatus class

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VerificationTaskStatus()
Public Sub New
public:
VerificationTaskStatus()
DoubleTake.Jobs.Contract.VerificationTaskStatus = function();
See Also

Reference

VerificationTaskStatus Class
DoubleTake.Jobs.Contract Namespace


VerificationTaskStatus Properties

VerificationTaskStatus Properties

The VerificationTaskStatus type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Steps | This value represents a step in the job validation process. Do not confuse this process with the verification process that confirms if the data between the source and target are synchronized.
Public property | Task | This value represents the status of the validation task.
Top
See Also

Reference

VerificationTaskStatus Class
DoubleTake.Jobs.Contract Namespace


VerificationTaskStatus.ExtensionData Property

VerificationTaskStatusExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

VerificationTaskStatus Class
DoubleTake.Jobs.Contract Namespace


VerificationTaskStatus.Steps Property

VerificationTaskStatusSteps Property
This value represents a step in the job validation process. Do not confuse this process with the verification process that confirms if the data between the source and target are synchronized.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public IEnumerable<VerificationStep> Steps { get; set; }
Public Property Steps As IEnumerable(Of VerificationStep)
    Get
    Set
public:
property IEnumerable<VerificationStep^>^ Steps {
    IEnumerable<VerificationStep^>^ get ();
    void set (IEnumerable<VerificationStep^>^ value);
}
function get_Steps();
function set_Steps(value);

Property Value

Type: IEnumerable VerificationStep
An array of VerificationStep that represents the steps in the verification task.
See Also

Reference

VerificationTaskStatus Class
DoubleTake.Jobs.Contract Namespace


VerificationTaskStatus.Task Property

VerificationTaskStatusTask Property
This value represents the status of the validation task.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ActivityStatusEntry Task { get; set; }
Public Property Task As ActivityStatusEntry
    Get
    Set
public:
property ActivityStatusEntry^ Task {
    ActivityStatusEntry^ get ();
    void set (ActivityStatusEntry^ value);
}
function get_Task();
function set_Task(value);

Property Value

Type: ActivityStatusEntry
A JobAction that represents the overall status of the verification task.
See Also

Reference

VerificationTaskStatus Class
DoubleTake.Jobs.Contract Namespace


VRAOptions Class

VRAOptions Class
Represents options for configuring the Virtual Recovery Assistant feature.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractVRAOptions

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class VRAOptions : IExtensibleDataObject
Public Class VRAOptions
    Implements IExtensibleDataObject
public ref class VRAOptions : IExtensibleDataObject
DoubleTake.Jobs.Contract.VRAOptions = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.VRAOptions',
    null,
    IExtensibleDataObject);

The VRAOptions type exposes the following members.

Constructors
 | Name | Description
Public method | VRAOptions | Initializes a new instance of the VRAOptions class
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Hypervisor | This value is the name of the hypervisor.
Public property | IsSourceHostCluster | This value is true if the source host is clustered; otherwise, it is false.
Public property | IsWANFailoverEnabled | This value is true if WAN failover is enabled; otherwise, it is false.
Public property | LvmOptions | This value represents logical volume manager (LVM) options for a Linux server.
Public property | ReplicaApplianceInfo | This value represents the helper appliance information.
Public property | ReplicaESXHostName | This value is the name of the ESX host where the replica will be located.
Public property | ReplicaNetworkInterfaceInfo | This value represents the desired NIC configuration on the replica virtual machine.
Public property | ReplicaVMInfo | This value represents the desired configuration of the replica virtual machine.
Public property | ReverseCount | Do not use this property. Double-Take uses it internally.
Public property | ReverseRoute | This value is the route used for the reverse process.
Public property | SourceApplianceInfo | This value represents the appliance used during reverse.
Public property | SourceESXHostName | This value is the name of the ESX host where the source is located.
Public property | SourceNetworkInterfaceInfo | This value represents the available NICs on the source.
Public property | SourceProductLicense | This value is the license key used for automatic installations during the V to ESX and V to Hyper-V job creation process.
Public property | SourceVmInfo | This value represents the source information used during reverse.
Public property | VirtualSwitchMapping | This value represents the virtual switch mappings on the source and target.
Public property | VirtualSwitchMappingTestFailover | Gets or sets a value representing source and target virtual switch mappings for test failover
Public property | Volumes | This value represents a volume to protect and any changes to its base configuration.
Public property | WorkloadCustomizationOptions | This value represents workload customization options.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


VRAOptions Constructor

VRAOptions Constructor
Initializes a new instance of the VRAOptions class

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VRAOptions()
Public Sub New
public:
VRAOptions()
DoubleTake.Jobs.Contract.VRAOptions = function();
See Also

Reference

VRAOptions Class
DoubleTake.Jobs.Contract Namespace


VRAOptions Properties

VRAOptions Properties

The VRAOptions type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Hypervisor | This value is the name of the hypervisor.
Public property | IsSourceHostCluster | This value is true if the source host is clustered; otherwise, it is false.
Public property | IsWANFailoverEnabled | This value is true if WAN failover is enabled; otherwise, it is false.
Public property | LvmOptions | This value represents logical volume manager (LVM) options for a Linux server.
Public property | ReplicaApplianceInfo | This value represents the helper appliance information.
Public property | ReplicaESXHostName | This value is the name of the ESX host where the replica will be located.
Public property | ReplicaNetworkInterfaceInfo | This value represents the desired NIC configuration on the replica virtual machine.
Public property | ReplicaVMInfo | This value represents the desired configuration of the replica virtual machine.
Public property | ReverseCount | Do not use this property. Double-Take uses it internally.
Public property | ReverseRoute | This value is the route used for the reverse process.
Public property | SourceApplianceInfo | This value represents the appliance used during reverse.
Public property | SourceESXHostName | This value is the name of the ESX host where the source is located.
Public property | SourceNetworkInterfaceInfo | This value represents the available NICs on the source.
Public property | SourceProductLicense | This value is the license key used for automatic installations during the V to ESX and V to Hyper-V job creation process.
Public property | SourceVmInfo | This value represents the source information used during reverse.
Public property | VirtualSwitchMapping | This value represents the virtual switch mappings on the source and target.
Public property | VirtualSwitchMappingTestFailover | Gets or sets a value representing source and target virtual switch mappings for test failover
Public property | Volumes | This value represents a volume to protect and any changes to its base configuration.
Public property | WorkloadCustomizationOptions | This value represents workload customization options.
Top
See Also

Reference

VRAOptions Class
DoubleTake.Jobs.Contract Namespace


VRAOptions.ExtensionData Property

VRAOptionsExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

VRAOptions Class
DoubleTake.Jobs.Contract Namespace


VRAOptions.Hypervisor Property

VRAOptionsHypervisor Property
This value is the name of the hypervisor.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Hypervisor { get; set; }
Public Property Hypervisor As String
    Get
    Set
public:
property String^ Hypervisor {
    String^ get ();
    void set (String^ value);
}
function get_Hypervisor();
function set_Hypervisor(value);

Property Value

Type: String
The hypervisor.
See Also

Reference

VRAOptions Class
DoubleTake.Jobs.Contract Namespace


VRAOptions.IsSourceHostCluster Property

VRAOptionsIsSourceHostCluster Property
This value is true if the source host is clustered; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsSourceHostCluster { get; set; }
Public Property IsSourceHostCluster As Boolean
    Get
    Set
public:
property bool IsSourceHostCluster {
    bool get ();
    void set (bool value);
}
function get_IsSourceHostCluster();
function set_IsSourceHostCluster(value);

Property Value

Type: Boolean
See Also

Reference

VRAOptions Class
DoubleTake.Jobs.Contract Namespace


VRAOptions.IsWANFailoverEnabled Property

VRAOptionsIsWANFailoverEnabled Property
This value is true if WAN failover is enabled; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsWANFailoverEnabled { get; set; }
Public Property IsWANFailoverEnabled As Boolean
    Get
    Set
public:
property bool IsWANFailoverEnabled {
    bool get ();
    void set (bool value);
}
function get_IsWANFailoverEnabled();
function set_IsWANFailoverEnabled(value);

Property Value

Type: Boolean
true if this instance is WAN failover enabled; otherwise, false.
See Also

Reference

VRAOptions Class
DoubleTake.Jobs.Contract Namespace


VRAOptions.LvmOptions Property

VRAOptionsLvmOptions Property
This value represents logical volume manager (LVM) options for a Linux server.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public LvmOptions LvmOptions { get; set; }
Public Property LvmOptions As LvmOptions
    Get
    Set
public:
property LvmOptions^ LvmOptions {
    LvmOptions^ get ();
    void set (LvmOptions^ value);
}
function get_LvmOptions();
function set_LvmOptions(value);

Property Value

Type: LvmOptions
The LVM Options
See Also

Reference

VRAOptions Class
DoubleTake.Jobs.Contract Namespace


VRAOptions.ReplicaApplianceInfo Property

VRAOptionsReplicaApplianceInfo Property
This value represents the helper appliance information.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VMInfo ReplicaApplianceInfo { get; set; }
Public Property ReplicaApplianceInfo As VMInfo
    Get
    Set
public:
property VMInfo^ ReplicaApplianceInfo {
    VMInfo^ get ();
    void set (VMInfo^ value);
}
function get_ReplicaApplianceInfo();
function set_ReplicaApplianceInfo(value);

Property Value

Type: VMInfo
The replica appliance information
See Also

Reference

VRAOptions Class
DoubleTake.Jobs.Contract Namespace


VRAOptions.ReplicaESXHostName Property

VRAOptionsReplicaESXHostName Property
This value is the name of the ESX host where the replica will be located.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string ReplicaESXHostName { get; set; }
Public Property ReplicaESXHostName As String
    Get
    Set
public:
property String^ ReplicaESXHostName {
    String^ get ();
    void set (String^ value);
}
function get_ReplicaESXHostName();
function set_ReplicaESXHostName(value);

Property Value

Type: String
The target ESX host Info.
See Also

Reference

VRAOptions Class
DoubleTake.Jobs.Contract Namespace


VRAOptions.ReplicaNetworkInterfaceInfo Property

VRAOptionsReplicaNetworkInterfaceInfo Property
This value represents the desired NIC configuration on the replica virtual machine.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VirtualNetworkInterfaceInfo[] ReplicaNetworkInterfaceInfo { get; set; }
Public Property ReplicaNetworkInterfaceInfo As VirtualNetworkInterfaceInfo()
    Get
    Set
public:
property array<VirtualNetworkInterfaceInfo^>^ ReplicaNetworkInterfaceInfo {
    array<VirtualNetworkInterfaceInfo^>^ get ();
    void set (array<VirtualNetworkInterfaceInfo^>^ value);
}
function get_ReplicaNetworkInterfaceInfo();
function set_ReplicaNetworkInterfaceInfo(value);

Property Value

Type: VirtualNetworkInterfaceInfo
The network interface info.
See Also

Reference

VRAOptions Class
DoubleTake.Jobs.Contract Namespace


VRAOptions.ReplicaVMInfo Property

VRAOptionsReplicaVMInfo Property
This value represents the desired configuration of the replica virtual machine.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ReplicaVMInfo ReplicaVMInfo { get; set; }
Public Property ReplicaVMInfo As ReplicaVMInfo
    Get
    Set
public:
property ReplicaVMInfo^ ReplicaVMInfo {
    ReplicaVMInfo^ get ();
    void set (ReplicaVMInfo^ value);
}
function get_ReplicaVMInfo();
function set_ReplicaVMInfo(value);

Property Value

Type: ReplicaVMInfo
The replica VM information
See Also

Reference

VRAOptions Class
DoubleTake.Jobs.Contract Namespace


VRAOptions.ReverseCount Property

VRAOptionsReverseCount Property
Do not use this property. Double-Take uses it internally.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int ReverseCount { get; set; }
Public Property ReverseCount As Integer
    Get
    Set
public:
property int ReverseCount {
    int get ();
    void set (int value);
}
function get_ReverseCount();
function set_ReverseCount(value);

Property Value

Type: Int32
The reverse count.
See Also

Reference

VRAOptions Class
DoubleTake.Jobs.Contract Namespace


VRAOptions.ReverseRoute Property

VRAOptionsReverseRoute Property
This value is the route used for the reverse process.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string ReverseRoute { get; set; }
Public Property ReverseRoute As String
    Get
    Set
public:
property String^ ReverseRoute {
    String^ get ();
    void set (String^ value);
}
function get_ReverseRoute();
function set_ReverseRoute(value);

Property Value

Type: String
The reverse route.
See Also

Reference

VRAOptions Class
DoubleTake.Jobs.Contract Namespace


VRAOptions.SourceApplianceInfo Property

VRAOptionsSourceApplianceInfo Property
This value represents the appliance used during reverse.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VMInfo SourceApplianceInfo { get; set; }
Public Property SourceApplianceInfo As VMInfo
    Get
    Set
public:
property VMInfo^ SourceApplianceInfo {
    VMInfo^ get ();
    void set (VMInfo^ value);
}
function get_SourceApplianceInfo();
function set_SourceApplianceInfo(value);

Property Value

Type: VMInfo
The source appliance information.
See Also

Reference

VRAOptions Class
DoubleTake.Jobs.Contract Namespace


VRAOptions.SourceESXHostName Property

VRAOptionsSourceESXHostName Property
This value is the name of the ESX host where the source is located.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string SourceESXHostName { get; set; }
Public Property SourceESXHostName As String
    Get
    Set
public:
property String^ SourceESXHostName {
    String^ get ();
    void set (String^ value);
}
function get_SourceESXHostName();
function set_SourceESXHostName(value);

Property Value

Type: String
The source ESX host info.
See Also

Reference

VRAOptions Class
DoubleTake.Jobs.Contract Namespace


VRAOptions.SourceNetworkInterfaceInfo Property

VRAOptionsSourceNetworkInterfaceInfo Property
This value represents the available NICs on the source.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VirtualNetworkInterfaceInfo[] SourceNetworkInterfaceInfo { get; set; }
Public Property SourceNetworkInterfaceInfo As VirtualNetworkInterfaceInfo()
    Get
    Set
public:
property array<VirtualNetworkInterfaceInfo^>^ SourceNetworkInterfaceInfo {
    array<VirtualNetworkInterfaceInfo^>^ get ();
    void set (array<VirtualNetworkInterfaceInfo^>^ value);
}
function get_SourceNetworkInterfaceInfo();
function set_SourceNetworkInterfaceInfo(value);

Property Value

Type: VirtualNetworkInterfaceInfo
The network interface info.
See Also

Reference

VRAOptions Class
DoubleTake.Jobs.Contract Namespace


VRAOptions.SourceProductLicense Property

VRAOptionsSourceProductLicense Property
This value is the license key used for automatic installations during the V to ESX and V to Hyper-V job creation process.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string SourceProductLicense { get; set; }
Public Property SourceProductLicense As String
    Get
    Set
public:
property String^ SourceProductLicense {
    String^ get ();
    void set (String^ value);
}
function get_SourceProductLicense();
function set_SourceProductLicense(value);

Property Value

Type: String
The source product license.
See Also

Reference

VRAOptions Class
DoubleTake.Jobs.Contract Namespace


VRAOptions.SourceVmInfo Property

VRAOptionsSourceVmInfo Property
This value represents the source information used during reverse.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VMInfo SourceVmInfo { get; set; }
Public Property SourceVmInfo As VMInfo
    Get
    Set
public:
property VMInfo^ SourceVmInfo {
    VMInfo^ get ();
    void set (VMInfo^ value);
}
function get_SourceVmInfo();
function set_SourceVmInfo(value);

Property Value

Type: VMInfo
The source vm VMInfo
See Also

Reference

VRAOptions Class
DoubleTake.Jobs.Contract Namespace


VRAOptions.VirtualSwitchMapping Property

VRAOptionsVirtualSwitchMapping Property
This value represents the virtual switch mappings on the source and target.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VirtualSwitchMapping[] VirtualSwitchMapping { get; set; }
Public Property VirtualSwitchMapping As VirtualSwitchMapping()
    Get
    Set
public:
property array<VirtualSwitchMapping^>^ VirtualSwitchMapping {
    array<VirtualSwitchMapping^>^ get ();
    void set (array<VirtualSwitchMapping^>^ value);
}
function get_VirtualSwitchMapping();
function set_VirtualSwitchMapping(value);

Property Value

Type: VirtualSwitchMapping
See Also

Reference

VRAOptions Class
DoubleTake.Jobs.Contract Namespace


VRAOptions.VirtualSwitchMappingTestFailover Property

VRAOptionsVirtualSwitchMappingTestFailover Property
Gets or sets a value representing source and target virtual switch mappings for test failover

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VirtualSwitchMapping[] VirtualSwitchMappingTestFailover { get; set; }
Public Property VirtualSwitchMappingTestFailover As VirtualSwitchMapping()
    Get
    Set
public:
property array<VirtualSwitchMapping^>^ VirtualSwitchMappingTestFailover {
    array<VirtualSwitchMapping^>^ get ();
    void set (array<VirtualSwitchMapping^>^ value);
}
function get_VirtualSwitchMappingTestFailover();
function set_VirtualSwitchMappingTestFailover(value);

Property Value

Type: VirtualSwitchMapping
See Also

Reference

VRAOptions Class
DoubleTake.Jobs.Contract Namespace


VRAOptions.Volumes Property

VRAOptionsVolumes Property
This value represents a volume to protect and any changes to its base configuration.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VolumeOptions[] Volumes { get; set; }
Public Property Volumes As VolumeOptions()
    Get
    Set
public:
property array<VolumeOptions^>^ Volumes {
    array<VolumeOptions^>^ get ();
    void set (array<VolumeOptions^>^ value);
}
function get_Volumes();
function set_Volumes(value);

Property Value

Type: VolumeOptions
The volumes.
See Also

Reference

VRAOptions Class
DoubleTake.Jobs.Contract Namespace


VRAOptions.WorkloadCustomizationOptions Property

VRAOptionsWorkloadCustomizationOptions Property
This value represents workload customization options.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VRAWorkloadCustomizationOptions WorkloadCustomizationOptions { get; set; }
Public Property WorkloadCustomizationOptions As VRAWorkloadCustomizationOptions
    Get
    Set
public:
property VRAWorkloadCustomizationOptions^ WorkloadCustomizationOptions {
    VRAWorkloadCustomizationOptions^ get ();
    void set (VRAWorkloadCustomizationOptions^ value);
}
function get_WorkloadCustomizationOptions();
function set_WorkloadCustomizationOptions(value);

Property Value

Type: VRAWorkloadCustomizationOptions
The workload customization options.
See Also

Reference

VRAOptions Class
DoubleTake.Jobs.Contract Namespace


VRAQualificationResults Class

VRAQualificationResults Class
Represents information that may be needed to configure a VRA job.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractVRAQualificationResults

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class VRAQualificationResults : IExtensibleDataObject
Public Class VRAQualificationResults
    Implements IExtensibleDataObject
public ref class VRAQualificationResults : IExtensibleDataObject
DoubleTake.Jobs.Contract.VRAQualificationResults = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.VRAQualificationResults',
    null,
    IExtensibleDataObject);

The VRAQualificationResults type exposes the following members.

Constructors
 | Name | Description
Public method | VRAQualificationResults | Initializes a new instance of the VRAQualificationResults class
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | PreexistingDisksFileName | This value is the full path and file name of an existing virtual disk that you want to reuse. If this value is null, a new virtual disk will be created.
Public property | SourceServerMemorySize | This value is the amount of memory, in bytes, on the source.
Public property | SourceServerProcessorCount | This value is the number of processors on the source.
Public property | TargetHost | This value represents the target server information.
Public property | V2VQualificationResults | This value represents information that may be needed to configure a virtual to ESX or virtual to Hyper-V job.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


VRAQualificationResults Constructor

VRAQualificationResults Constructor
Initializes a new instance of the VRAQualificationResults class

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VRAQualificationResults()
Public Sub New
public:
VRAQualificationResults()
DoubleTake.Jobs.Contract.VRAQualificationResults = function();
See Also

Reference

VRAQualificationResults Class
DoubleTake.Jobs.Contract Namespace


VRAQualificationResults Properties

VRAQualificationResults Properties

The VRAQualificationResults type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | PreexistingDisksFileName | This value is the full path and file name of an existing virtual disk that you want to reuse. If this value is null, a new virtual disk will be created.
Public property | SourceServerMemorySize | This value is the amount of memory, in bytes, on the source.
Public property | SourceServerProcessorCount | This value is the number of processors on the source.
Public property | TargetHost | This value represents the target server information.
Public property | V2VQualificationResults | This value represents information that may be needed to configure a virtual to ESX or virtual to Hyper-V job.
Top
See Also

Reference

VRAQualificationResults Class
DoubleTake.Jobs.Contract Namespace


VRAQualificationResults.ExtensionData Property

VRAQualificationResultsExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

VRAQualificationResults Class
DoubleTake.Jobs.Contract Namespace


VRAQualificationResults.PreexistingDisksFileName Property

VRAQualificationResultsPreexistingDisksFileName Property
This value is the full path and file name of an existing virtual disk that you want to reuse. If this value is null, a new virtual disk will be created.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string[] PreexistingDisksFileName { get; set; }
Public Property PreexistingDisksFileName As String()
    Get
    Set
public:
property array<String^>^ PreexistingDisksFileName {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
function get_PreexistingDisksFileName();
function set_PreexistingDisksFileName(value);

Property Value

Type: String
See Also

Reference

VRAQualificationResults Class
DoubleTake.Jobs.Contract Namespace


VRAQualificationResults.SourceServerMemorySize Property

VRAQualificationResultsSourceServerMemorySize Property
This value is the amount of memory, in bytes, on the source.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public long SourceServerMemorySize { get; set; }
Public Property SourceServerMemorySize As Long
    Get
    Set
public:
property long long SourceServerMemorySize {
    long long get ();
    void set (long long value);
}
function get_SourceServerMemorySize();
function set_SourceServerMemorySize(value);

Property Value

Type: Int64
The amount of memory on the server.
See Also

Reference

VRAQualificationResults Class
DoubleTake.Jobs.Contract Namespace


VRAQualificationResults.SourceServerProcessorCount Property

VRAQualificationResultsSourceServerProcessorCount Property
This value is the number of processors on the source.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int SourceServerProcessorCount { get; set; }
Public Property SourceServerProcessorCount As Integer
    Get
    Set
public:
property int SourceServerProcessorCount {
    int get ();
    void set (int value);
}
function get_SourceServerProcessorCount();
function set_SourceServerProcessorCount(value);

Property Value

Type: Int32
The processor count of the server.
See Also

Reference

VRAQualificationResults Class
DoubleTake.Jobs.Contract Namespace


VRAQualificationResults.TargetHost Property

VRAQualificationResultsTargetHost Property
This value represents the target server information.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ServerQualificationResults TargetHost { get; set; }
Public Property TargetHost As ServerQualificationResults
    Get
    Set
public:
property ServerQualificationResults^ TargetHost {
    ServerQualificationResults^ get ();
    void set (ServerQualificationResults^ value);
}
function get_TargetHost();
function set_TargetHost(value);

Property Value

Type: ServerQualificationResults
See Also

Reference

VRAQualificationResults Class
DoubleTake.Jobs.Contract Namespace


VRAQualificationResults.V2VQualificationResults Property

VRAQualificationResultsV2VQualificationResults Property
This value represents information that may be needed to configure a virtual to ESX or virtual to Hyper-V job.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public V2VQualificationResults V2VQualificationResults { get; set; }
Public Property V2VQualificationResults As V2VQualificationResults
    Get
    Set
public:
property V2VQualificationResults^ V2VQualificationResults {
    V2VQualificationResults^ get ();
    void set (V2VQualificationResults^ value);
}
function get_V2VQualificationResults();
function set_V2VQualificationResults(value);

Property Value

Type: V2VQualificationResults
V2V qualification result.
See Also

Reference

VRAQualificationResults Class
DoubleTake.Jobs.Contract Namespace


DoubleTake.Jobs.Contract.Applications Namespace

DoubleTake.Jobs.Contract.Applications Namespace
Classes
 | Class | Description
Public class | SqlDatabasePersistedInfo |


SqlDatabasePersistedInfo Class

SqlDatabasePersistedInfo Class
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.Contract.ApplicationsSqlDatabasePersistedInfo

Namespace: DoubleTake.Jobs.Contract.Applications
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class SqlDatabasePersistedInfo
Public Class SqlDatabasePersistedInfo
public ref class SqlDatabasePersistedInfo
DoubleTake.Jobs.Contract.Applications.SqlDatabasePersistedInfo = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.Applications.SqlDatabasePersistedInfo');

The SqlDatabasePersistedInfo type exposes the following members.

Constructors
 | Name | Description
Public method | SqlDatabasePersistedInfo | Initializes a new instance of the SqlDatabasePersistedInfo class
Top
Properties
 | Name | Description
Public property | files |
Public property | name |
Top
See Also

Reference

DoubleTake.Jobs.Contract.Applications Namespace


SqlDatabasePersistedInfo Constructor

SqlDatabasePersistedInfo Constructor
Initializes a new instance of the SqlDatabasePersistedInfo class

Namespace: DoubleTake.Jobs.Contract.Applications
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public SqlDatabasePersistedInfo()
Public Sub New
public:
SqlDatabasePersistedInfo()
DoubleTake.Jobs.Contract.Applications.SqlDatabasePersistedInfo = function();
See Also

Reference

SqlDatabasePersistedInfo Class
DoubleTake.Jobs.Contract.Applications Namespace


SqlDatabasePersistedInfo Properties

SqlDatabasePersistedInfo Properties

The SqlDatabasePersistedInfo type exposes the following members.

Properties
 | Name | Description
Public property | files |
Public property | name |
Top
See Also

Reference

SqlDatabasePersistedInfo Class
DoubleTake.Jobs.Contract.Applications Namespace


SqlDatabasePersistedInfo.files Property

SqlDatabasePersistedInfofiles Property

Namespace: DoubleTake.Jobs.Contract.Applications
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public IEnumerable<string> files { get; set; }
Public Property files As IEnumerable(Of String)
    Get
    Set
public:
property IEnumerable<String^>^ files {
    IEnumerable<String^>^ get ();
    void set (IEnumerable<String^>^ value);
}
function get_files();
function set_files(value);

Property Value

Type: IEnumerable String
See Also

Reference

SqlDatabasePersistedInfo Class
DoubleTake.Jobs.Contract.Applications Namespace


SqlDatabasePersistedInfo.name Property

SqlDatabasePersistedInfoname Property

Namespace: DoubleTake.Jobs.Contract.Applications
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string name { get; set; }
Public Property name As String
    Get
    Set
public:
property String^ name {
    String^ get ();
    void set (String^ value);
}
function get_name();
function set_name(value);

Property Value

Type: String
See Also

Reference

SqlDatabasePersistedInfo Class
DoubleTake.Jobs.Contract.Applications Namespace


DoubleTake.Jobs.Contract.Diagnostics Namespace

DoubleTake.Jobs.Contract.Diagnostics Namespace
Classes
 | Class | Description
Public class | DiagnosticsPersistedState |


DiagnosticsPersistedState Class

DiagnosticsPersistedState Class
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.Contract.DiagnosticsDiagnosticsPersistedState

Namespace: DoubleTake.Jobs.Contract.Diagnostics
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class DiagnosticsPersistedState
Public Class DiagnosticsPersistedState
public ref class DiagnosticsPersistedState
DoubleTake.Jobs.Contract.Diagnostics.DiagnosticsPersistedState = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.Diagnostics.DiagnosticsPersistedState');

The DiagnosticsPersistedState type exposes the following members.

Constructors
 | Name | Description
Public method | DiagnosticsPersistedState | Initializes a new instance of the DiagnosticsPersistedState class
Top
Properties
 | Name | Description
Public property | DiagnosticsConnectionPersistedState | Gets or sets the state of the diagnostics connection.
Public property | State | Gets or sets the state.
Top
See Also

Reference

DoubleTake.Jobs.Contract.Diagnostics Namespace


DiagnosticsPersistedState Constructor

DiagnosticsPersistedState Constructor
Initializes a new instance of the DiagnosticsPersistedState class

Namespace: DoubleTake.Jobs.Contract.Diagnostics
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public DiagnosticsPersistedState()
Public Sub New
public:
DiagnosticsPersistedState()
DoubleTake.Jobs.Contract.Diagnostics.DiagnosticsPersistedState = function();
See Also

Reference

DiagnosticsPersistedState Class
DoubleTake.Jobs.Contract.Diagnostics Namespace


DiagnosticsPersistedState Properties

DiagnosticsPersistedState Properties

The DiagnosticsPersistedState type exposes the following members.

Properties
 | Name | Description
Public property | DiagnosticsConnectionPersistedState | Gets or sets the state of the diagnostics connection.
Public property | State | Gets or sets the state.
Top
See Also

Reference

DiagnosticsPersistedState Class
DoubleTake.Jobs.Contract.Diagnostics Namespace


DiagnosticsPersistedState.DiagnosticsConnectionPersistedState Property

DiagnosticsPersistedStateDiagnosticsConnectionPersistedState Property
Gets or sets the state of the diagnostics connection.

Namespace: DoubleTake.Jobs.Contract.Diagnostics
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public CoreConnectionPersistedState DiagnosticsConnectionPersistedState { get; set; }
Public Property DiagnosticsConnectionPersistedState As CoreConnectionPersistedState
    Get
    Set
public:
property CoreConnectionPersistedState^ DiagnosticsConnectionPersistedState {
    CoreConnectionPersistedState^ get ();
    void set (CoreConnectionPersistedState^ value);
}
function get_DiagnosticsConnectionPersistedState();
function set_DiagnosticsConnectionPersistedState(value);

Property Value

Type: CoreConnectionPersistedState
The state of the diagnostics connection.
See Also

Reference

DiagnosticsPersistedState Class
DoubleTake.Jobs.Contract.Diagnostics Namespace


DiagnosticsPersistedState.State Property

DiagnosticsPersistedStateState Property
Gets or sets the state.

Namespace: DoubleTake.Jobs.Contract.Diagnostics
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string State { get; set; }
Public Property State As String
    Get
    Set
public:
property String^ State {
    String^ get ();
    void set (String^ value);
}
function get_State();
function set_State(value);

Property Value

Type: String
The state.
See Also

Reference

DiagnosticsPersistedState Class
DoubleTake.Jobs.Contract.Diagnostics Namespace


DoubleTake.Jobs.Contract.FullServer Namespace

DoubleTake.Jobs.Contract.FullServer Namespace
Classes
 | Class | Description
Public class | FullServerJobDetails | Represents the details of a full-server failover job.


FullServerJobDetails Class

FullServerJobDetails Class
Represents the details of a full-server failover job.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.Contract.FullServerFullServerJobDetails

Namespace: DoubleTake.Jobs.Contract.FullServer
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class FullServerJobDetails : IExtensibleDataObject
Public Class FullServerJobDetails
    Implements IExtensibleDataObject
public ref class FullServerJobDetails : IExtensibleDataObject
DoubleTake.Jobs.Contract.FullServer.FullServerJobDetails = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.FullServer.FullServerJobDetails',
    null,
    IExtensibleDataObject);

The FullServerJobDetails type exposes the following members.

Constructors
 | Name | Description
Public method | FullServerJobDetails | Initializes a new instance of the FullServerJobDetails class
Top
Properties
 | Name | Description
Public property | BackupConnectionDetails | This value represents the details of the Double-Take Availability reverse connection.
Public property | CutoverDetails | This value represents the Double-Take Move cutover detail.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | ProtectionConnectionDetails | This value represents the details of the protection connection.
Public property | RecoveryConnectionDetails | This value represents the details of the Double-Take DR recovery connection.
Public property | SystemVolumeRevertConnectionDetails | This value represents the details of the system volume revert connection.
Top
See Also

Reference

DoubleTake.Jobs.Contract.FullServer Namespace


FullServerJobDetails Constructor

FullServerJobDetails Constructor
Initializes a new instance of the FullServerJobDetails class

Namespace: DoubleTake.Jobs.Contract.FullServer
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public FullServerJobDetails()
Public Sub New
public:
FullServerJobDetails()
DoubleTake.Jobs.Contract.FullServer.FullServerJobDetails = function();
See Also

Reference

FullServerJobDetails Class
DoubleTake.Jobs.Contract.FullServer Namespace


FullServerJobDetails Properties

FullServerJobDetails Properties

The FullServerJobDetails type exposes the following members.

Properties
 | Name | Description
Public property | BackupConnectionDetails | This value represents the details of the Double-Take Availability reverse connection.
Public property | CutoverDetails | This value represents the Double-Take Move cutover detail.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | ProtectionConnectionDetails | This value represents the details of the protection connection.
Public property | RecoveryConnectionDetails | This value represents the details of the Double-Take DR recovery connection.
Public property | SystemVolumeRevertConnectionDetails | This value represents the details of the system volume revert connection.
Top
See Also

Reference

FullServerJobDetails Class
DoubleTake.Jobs.Contract.FullServer Namespace


FullServerJobDetails.BackupConnectionDetails Property

FullServerJobDetailsBackupConnectionDetails Property
This value represents the details of the Double-Take Availability reverse connection.

Namespace: DoubleTake.Jobs.Contract.FullServer
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public CoreConnectionDetails BackupConnectionDetails { get; set; }
Public Property BackupConnectionDetails As CoreConnectionDetails
    Get
    Set
public:
property CoreConnectionDetails^ BackupConnectionDetails {
    CoreConnectionDetails^ get ();
    void set (CoreConnectionDetails^ value);
}
function get_BackupConnectionDetails();
function set_BackupConnectionDetails(value);

Property Value

Type: CoreConnectionDetails
The the details of the backup connection.
See Also

Reference

FullServerJobDetails Class
DoubleTake.Jobs.Contract.FullServer Namespace


FullServerJobDetails.CutoverDetails Property

FullServerJobDetailsCutoverDetails Property
This value represents the Double-Take Move cutover detail.

Namespace: DoubleTake.Jobs.Contract.FullServer
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public CutoverDetails CutoverDetails { get; set; }
Public Property CutoverDetails As CutoverDetails
    Get
    Set
public:
property CutoverDetails^ CutoverDetails {
    CutoverDetails^ get ();
    void set (CutoverDetails^ value);
}
function get_CutoverDetails();
function set_CutoverDetails(value);

Property Value

Type: CutoverDetails
The details of the cutover operation.
See Also

Reference

FullServerJobDetails Class
DoubleTake.Jobs.Contract.FullServer Namespace


FullServerJobDetails.ExtensionData Property

FullServerJobDetailsExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract.FullServer
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

FullServerJobDetails Class
DoubleTake.Jobs.Contract.FullServer Namespace


FullServerJobDetails.ProtectionConnectionDetails Property

FullServerJobDetailsProtectionConnectionDetails Property
This value represents the details of the protection connection.

Namespace: DoubleTake.Jobs.Contract.FullServer
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public CoreConnectionDetails ProtectionConnectionDetails { get; set; }
Public Property ProtectionConnectionDetails As CoreConnectionDetails
    Get
    Set
public:
property CoreConnectionDetails^ ProtectionConnectionDetails {
    CoreConnectionDetails^ get ();
    void set (CoreConnectionDetails^ value);
}
function get_ProtectionConnectionDetails();
function set_ProtectionConnectionDetails(value);

Property Value

Type: CoreConnectionDetails
The details of the protection connection.
See Also

Reference

FullServerJobDetails Class
DoubleTake.Jobs.Contract.FullServer Namespace


FullServerJobDetails.RecoveryConnectionDetails Property

FullServerJobDetailsRecoveryConnectionDetails Property
This value represents the details of the Double-Take DR recovery connection.

Namespace: DoubleTake.Jobs.Contract.FullServer
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public CoreConnectionDetails RecoveryConnectionDetails { get; set; }
Public Property RecoveryConnectionDetails As CoreConnectionDetails
    Get
    Set
public:
property CoreConnectionDetails^ RecoveryConnectionDetails {
    CoreConnectionDetails^ get ();
    void set (CoreConnectionDetails^ value);
}
function get_RecoveryConnectionDetails();
function set_RecoveryConnectionDetails(value);

Property Value

Type: CoreConnectionDetails
The details of the recovery connection.
See Also

Reference

FullServerJobDetails Class
DoubleTake.Jobs.Contract.FullServer Namespace


FullServerJobDetails.SystemVolumeRevertConnectionDetails Property

FullServerJobDetailsSystemVolumeRevertConnectionDetails Property
This value represents the details of the system volume revert connection.

Namespace: DoubleTake.Jobs.Contract.FullServer
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public CoreConnectionDetails SystemVolumeRevertConnectionDetails { get; set; }
Public Property SystemVolumeRevertConnectionDetails As CoreConnectionDetails
    Get
    Set
public:
property CoreConnectionDetails^ SystemVolumeRevertConnectionDetails {
    CoreConnectionDetails^ get ();
    void set (CoreConnectionDetails^ value);
}
function get_SystemVolumeRevertConnectionDetails();
function set_SystemVolumeRevertConnectionDetails(value);

Property Value

Type: CoreConnectionDetails
The details of the system volume revert connection.
See Also

Reference

FullServerJobDetails Class
DoubleTake.Jobs.Contract.FullServer Namespace


DoubleTake.Jobs.Contract.ImageBased Namespace

DoubleTake.Jobs.Contract.ImageBased Namespace
Classes
 | Class | Description
Public class | ImageProtectionJobDetails | Represents the details of an image protection job.
Public class | ImageRecoveryJobDetails | Represents the details of an image recovery job.


ImageProtectionJobDetails Class

ImageProtectionJobDetails Class
Represents the details of an image protection job.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.Contract.ImageBasedImageProtectionJobDetails

Namespace: DoubleTake.Jobs.Contract.ImageBased
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class ImageProtectionJobDetails : IExtensibleDataObject
Public Class ImageProtectionJobDetails
    Implements IExtensibleDataObject
public ref class ImageProtectionJobDetails : IExtensibleDataObject
DoubleTake.Jobs.Contract.ImageBased.ImageProtectionJobDetails = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.ImageBased.ImageProtectionJobDetails',
    null,
    IExtensibleDataObject);

The ImageProtectionJobDetails type exposes the following members.

Constructors
 | Name | Description
Public method | ImageProtectionJobDetails | Initializes a new instance of the ImageProtectionJobDetails class
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | ProtectionConnectionDetails | This value represents the details of the Double-Take DR protection connection.
Top
See Also

Reference

DoubleTake.Jobs.Contract.ImageBased Namespace


ImageProtectionJobDetails Constructor

ImageProtectionJobDetails Constructor
Initializes a new instance of the ImageProtectionJobDetails class

Namespace: DoubleTake.Jobs.Contract.ImageBased
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ImageProtectionJobDetails()
Public Sub New
public:
ImageProtectionJobDetails()
DoubleTake.Jobs.Contract.ImageBased.ImageProtectionJobDetails = function();
See Also

Reference

ImageProtectionJobDetails Class
DoubleTake.Jobs.Contract.ImageBased Namespace


ImageProtectionJobDetails Properties

ImageProtectionJobDetails Properties

The ImageProtectionJobDetails type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | ProtectionConnectionDetails | This value represents the details of the Double-Take DR protection connection.
Top
See Also

Reference

ImageProtectionJobDetails Class
DoubleTake.Jobs.Contract.ImageBased Namespace


ImageProtectionJobDetails.ExtensionData Property

ImageProtectionJobDetailsExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract.ImageBased
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

ImageProtectionJobDetails Class
DoubleTake.Jobs.Contract.ImageBased Namespace


ImageProtectionJobDetails.ProtectionConnectionDetails Property

ImageProtectionJobDetailsProtectionConnectionDetails Property
This value represents the details of the Double-Take DR protection connection.

Namespace: DoubleTake.Jobs.Contract.ImageBased
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public CoreConnectionDetails ProtectionConnectionDetails { get; set; }
Public Property ProtectionConnectionDetails As CoreConnectionDetails
    Get
    Set
public:
property CoreConnectionDetails^ ProtectionConnectionDetails {
    CoreConnectionDetails^ get ();
    void set (CoreConnectionDetails^ value);
}
function get_ProtectionConnectionDetails();
function set_ProtectionConnectionDetails(value);

Property Value

Type: CoreConnectionDetails
The details of the protection connection.
See Also

Reference

ImageProtectionJobDetails Class
DoubleTake.Jobs.Contract.ImageBased Namespace


ImageRecoveryJobDetails Class

ImageRecoveryJobDetails Class
Represents the details of an image recovery job.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.Contract.ImageBasedImageRecoveryJobDetails

Namespace: DoubleTake.Jobs.Contract.ImageBased
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class ImageRecoveryJobDetails : IExtensibleDataObject
Public Class ImageRecoveryJobDetails
    Implements IExtensibleDataObject
public ref class ImageRecoveryJobDetails : IExtensibleDataObject
DoubleTake.Jobs.Contract.ImageBased.ImageRecoveryJobDetails = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.ImageBased.ImageRecoveryJobDetails',
    null,
    IExtensibleDataObject);

The ImageRecoveryJobDetails type exposes the following members.

Constructors
 | Name | Description
Public method | ImageRecoveryJobDetails | Initializes a new instance of the ImageRecoveryJobDetails class
Top
Properties
 | Name | Description
Public property | CutoverDetails | This value represents the Double-Take DR cutover detail.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | RecoveryConnectionDetails | This value represents the details of the Double-Take DR recovery connection.
Top
See Also

Reference

DoubleTake.Jobs.Contract.ImageBased Namespace


ImageRecoveryJobDetails Constructor

ImageRecoveryJobDetails Constructor
Initializes a new instance of the ImageRecoveryJobDetails class

Namespace: DoubleTake.Jobs.Contract.ImageBased
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ImageRecoveryJobDetails()
Public Sub New
public:
ImageRecoveryJobDetails()
DoubleTake.Jobs.Contract.ImageBased.ImageRecoveryJobDetails = function();
See Also

Reference

ImageRecoveryJobDetails Class
DoubleTake.Jobs.Contract.ImageBased Namespace


ImageRecoveryJobDetails Properties

ImageRecoveryJobDetails Properties

The ImageRecoveryJobDetails type exposes the following members.

Properties
 | Name | Description
Public property | CutoverDetails | This value represents the Double-Take DR cutover detail.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | RecoveryConnectionDetails | This value represents the details of the Double-Take DR recovery connection.
Top
See Also

Reference

ImageRecoveryJobDetails Class
DoubleTake.Jobs.Contract.ImageBased Namespace


ImageRecoveryJobDetails.CutoverDetails Property

ImageRecoveryJobDetailsCutoverDetails Property
This value represents the Double-Take DR cutover detail.

Namespace: DoubleTake.Jobs.Contract.ImageBased
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public CutoverDetails CutoverDetails { get; set; }
Public Property CutoverDetails As CutoverDetails
    Get
    Set
public:
property CutoverDetails^ CutoverDetails {
    CutoverDetails^ get ();
    void set (CutoverDetails^ value);
}
function get_CutoverDetails();
function set_CutoverDetails(value);

Property Value

Type: CutoverDetails
The details of the cutover operation.
See Also

Reference

ImageRecoveryJobDetails Class
DoubleTake.Jobs.Contract.ImageBased Namespace


ImageRecoveryJobDetails.ExtensionData Property

ImageRecoveryJobDetailsExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract.ImageBased
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

ImageRecoveryJobDetails Class
DoubleTake.Jobs.Contract.ImageBased Namespace


ImageRecoveryJobDetails.RecoveryConnectionDetails Property

ImageRecoveryJobDetailsRecoveryConnectionDetails Property
This value represents the details of the Double-Take DR recovery connection.

Namespace: DoubleTake.Jobs.Contract.ImageBased
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public CoreConnectionDetails RecoveryConnectionDetails { get; set; }
Public Property RecoveryConnectionDetails As CoreConnectionDetails
    Get
    Set
public:
property CoreConnectionDetails^ RecoveryConnectionDetails {
    CoreConnectionDetails^ get ();
    void set (CoreConnectionDetails^ value);
}
function get_RecoveryConnectionDetails();
function set_RecoveryConnectionDetails(value);

Property Value

Type: CoreConnectionDetails
The details of the recovery connection.
See Also

Reference

ImageRecoveryJobDetails Class
DoubleTake.Jobs.Contract.ImageBased Namespace


DoubleTake.Jobs.Contract.Linux Namespace

DoubleTake.Jobs.Contract.Linux Namespace
Classes
 | Class | Description
Public class | LinuxJobPersistedState | Persisted state information specific to the Linux job implementations, shared by all Linux job types
Public class | LinuxJobStateFlag | String representation of a JobStateFlag, defined privately by the Linux job implementation
Public class | LinuxJobStateFlagStack | A stack levels containing LinuxJobStateFlag values, as managed privately by the Linux job implementation. Each level in the stack is contains an array of one or more JobStateFlag values.
Public class | LinuxJobStateFlagStackLevel | ...


LinuxJobPersistedState Class

LinuxJobPersistedState Class
Persisted state information specific to the Linux job implementations, shared by all Linux job types
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.Contract.LinuxLinuxJobPersistedState

Namespace: DoubleTake.Jobs.Contract.Linux
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class LinuxJobPersistedState : IExtensibleDataObject
Public Class LinuxJobPersistedState
    Implements IExtensibleDataObject
public ref class LinuxJobPersistedState : IExtensibleDataObject
DoubleTake.Jobs.Contract.Linux.LinuxJobPersistedState = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.Linux.LinuxJobPersistedState',
    null,
    IExtensibleDataObject);

The LinuxJobPersistedState type exposes the following members.

Constructors
 | Name | Description
Public method | LinuxJobPersistedState | Initializes a new instance of the LinuxJobPersistedState class
Top
Properties
 | Name | Description
Public property | CurrentJobStateFlagStack |
Public property | DeserializedJobStateFlagStack |
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | PreviousJobStateFlagStack |
Top
See Also

Reference

DoubleTake.Jobs.Contract.Linux Namespace


LinuxJobPersistedState Constructor

LinuxJobPersistedState Constructor
Initializes a new instance of the LinuxJobPersistedState class

Namespace: DoubleTake.Jobs.Contract.Linux
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public LinuxJobPersistedState()
Public Sub New
public:
LinuxJobPersistedState()
DoubleTake.Jobs.Contract.Linux.LinuxJobPersistedState = function();
See Also

Reference

LinuxJobPersistedState Class
DoubleTake.Jobs.Contract.Linux Namespace


LinuxJobPersistedState Properties

LinuxJobPersistedState Properties

The LinuxJobPersistedState type exposes the following members.

Properties
 | Name | Description
Public property | CurrentJobStateFlagStack |
Public property | DeserializedJobStateFlagStack |
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | PreviousJobStateFlagStack |
Top
See Also

Reference

LinuxJobPersistedState Class
DoubleTake.Jobs.Contract.Linux Namespace


LinuxJobPersistedState.CurrentJobStateFlagStack Property

LinuxJobPersistedStateCurrentJobStateFlagStack Property

Namespace: DoubleTake.Jobs.Contract.Linux
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public LinuxJobStateFlagStack CurrentJobStateFlagStack { get; set; }
Public Property CurrentJobStateFlagStack As LinuxJobStateFlagStack
    Get
    Set
public:
property LinuxJobStateFlagStack^ CurrentJobStateFlagStack {
    LinuxJobStateFlagStack^ get ();
    void set (LinuxJobStateFlagStack^ value);
}
function get_CurrentJobStateFlagStack();
function set_CurrentJobStateFlagStack(value);

Property Value

Type: LinuxJobStateFlagStack
See Also

Reference

LinuxJobPersistedState Class
DoubleTake.Jobs.Contract.Linux Namespace


LinuxJobPersistedState.DeserializedJobStateFlagStack Property

LinuxJobPersistedStateDeserializedJobStateFlagStack Property

Namespace: DoubleTake.Jobs.Contract.Linux
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public LinuxJobStateFlagStack DeserializedJobStateFlagStack { get; set; }
Public Property DeserializedJobStateFlagStack As LinuxJobStateFlagStack
    Get
    Set
public:
property LinuxJobStateFlagStack^ DeserializedJobStateFlagStack {
    LinuxJobStateFlagStack^ get ();
    void set (LinuxJobStateFlagStack^ value);
}
function get_DeserializedJobStateFlagStack();
function set_DeserializedJobStateFlagStack(value);

Property Value

Type: LinuxJobStateFlagStack
See Also

Reference

LinuxJobPersistedState Class
DoubleTake.Jobs.Contract.Linux Namespace


LinuxJobPersistedState.ExtensionData Property

LinuxJobPersistedStateExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract.Linux
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

LinuxJobPersistedState Class
DoubleTake.Jobs.Contract.Linux Namespace


LinuxJobPersistedState.PreviousJobStateFlagStack Property

LinuxJobPersistedStatePreviousJobStateFlagStack Property

Namespace: DoubleTake.Jobs.Contract.Linux
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public LinuxJobStateFlagStack PreviousJobStateFlagStack { get; set; }
Public Property PreviousJobStateFlagStack As LinuxJobStateFlagStack
    Get
    Set
public:
property LinuxJobStateFlagStack^ PreviousJobStateFlagStack {
    LinuxJobStateFlagStack^ get ();
    void set (LinuxJobStateFlagStack^ value);
}
function get_PreviousJobStateFlagStack();
function set_PreviousJobStateFlagStack(value);

Property Value

Type: LinuxJobStateFlagStack
See Also

Reference

LinuxJobPersistedState Class
DoubleTake.Jobs.Contract.Linux Namespace


LinuxJobStateFlag Class

LinuxJobStateFlag Class
String representation of a JobStateFlag, defined privately by the Linux job implementation
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.Contract.LinuxLinuxJobStateFlag

Namespace: DoubleTake.Jobs.Contract.Linux
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class LinuxJobStateFlag
Public Class LinuxJobStateFlag
public ref class LinuxJobStateFlag
DoubleTake.Jobs.Contract.Linux.LinuxJobStateFlag = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.Linux.LinuxJobStateFlag');

The LinuxJobStateFlag type exposes the following members.

Constructors
 | Name | Description
Public method | LinuxJobStateFlag | Initializes a new instance of the LinuxJobStateFlag class
Top
Properties
 | Name | Description
Public property | name |
Top
See Also

Reference

DoubleTake.Jobs.Contract.Linux Namespace


LinuxJobStateFlag Constructor

LinuxJobStateFlag Constructor
Initializes a new instance of the LinuxJobStateFlag class

Namespace: DoubleTake.Jobs.Contract.Linux
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public LinuxJobStateFlag()
Public Sub New
public:
LinuxJobStateFlag()
DoubleTake.Jobs.Contract.Linux.LinuxJobStateFlag = function();
See Also

Reference

LinuxJobStateFlag Class
DoubleTake.Jobs.Contract.Linux Namespace


LinuxJobStateFlag Properties

LinuxJobStateFlag Properties

The LinuxJobStateFlag type exposes the following members.

Properties
 | Name | Description
Public property | name |
Top
See Also

Reference

LinuxJobStateFlag Class
DoubleTake.Jobs.Contract.Linux Namespace


LinuxJobStateFlag.name Property

LinuxJobStateFlagname Property

Namespace: DoubleTake.Jobs.Contract.Linux
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string name { get; set; }
Public Property name As String
    Get
    Set
public:
property String^ name {
    String^ get ();
    void set (String^ value);
}
function get_name();
function set_name(value);

Property Value

Type: String
See Also

Reference

LinuxJobStateFlag Class
DoubleTake.Jobs.Contract.Linux Namespace


LinuxJobStateFlagStack Class

LinuxJobStateFlagStack Class
A stack levels containing LinuxJobStateFlag values, as managed privately by the Linux job implementation. Each level in the stack is contains an array of one or more JobStateFlag values.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.Contract.LinuxLinuxJobStateFlagStack

Namespace: DoubleTake.Jobs.Contract.Linux
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class LinuxJobStateFlagStack
Public Class LinuxJobStateFlagStack
public ref class LinuxJobStateFlagStack
DoubleTake.Jobs.Contract.Linux.LinuxJobStateFlagStack = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.Linux.LinuxJobStateFlagStack');

The LinuxJobStateFlagStack type exposes the following members.

Constructors
 | Name | Description
Public method | LinuxJobStateFlagStack | Initializes a new instance of the LinuxJobStateFlagStack class
Top
Properties
 | Name | Description
Public property | JobStateFlagStackLevels |
Top
See Also

Reference

DoubleTake.Jobs.Contract.Linux Namespace


LinuxJobStateFlagStack Constructor

LinuxJobStateFlagStack Constructor
Initializes a new instance of the LinuxJobStateFlagStack class

Namespace: DoubleTake.Jobs.Contract.Linux
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public LinuxJobStateFlagStack()
Public Sub New
public:
LinuxJobStateFlagStack()
DoubleTake.Jobs.Contract.Linux.LinuxJobStateFlagStack = function();
See Also

Reference

LinuxJobStateFlagStack Class
DoubleTake.Jobs.Contract.Linux Namespace


LinuxJobStateFlagStack Properties

LinuxJobStateFlagStack Properties

The LinuxJobStateFlagStack type exposes the following members.

Properties
 | Name | Description
Public property | JobStateFlagStackLevels |
Top
See Also

Reference

LinuxJobStateFlagStack Class
DoubleTake.Jobs.Contract.Linux Namespace


LinuxJobStateFlagStack.JobStateFlagStackLevels Property

LinuxJobStateFlagStackJobStateFlagStackLevels Property

Namespace: DoubleTake.Jobs.Contract.Linux
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public LinuxJobStateFlagStackLevel[] JobStateFlagStackLevels { get; set; }
Public Property JobStateFlagStackLevels As LinuxJobStateFlagStackLevel()
    Get
    Set
public:
property array<LinuxJobStateFlagStackLevel^>^ JobStateFlagStackLevels {
    array<LinuxJobStateFlagStackLevel^>^ get ();
    void set (array<LinuxJobStateFlagStackLevel^>^ value);
}
function get_JobStateFlagStackLevels();
function set_JobStateFlagStackLevels(value);

Property Value

Type: LinuxJobStateFlagStackLevel
See Also

Reference

LinuxJobStateFlagStack Class
DoubleTake.Jobs.Contract.Linux Namespace


LinuxJobStateFlagStackLevel Class

LinuxJobStateFlagStackLevel Class
...
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.Contract.LinuxLinuxJobStateFlagStackLevel

Namespace: DoubleTake.Jobs.Contract.Linux
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class LinuxJobStateFlagStackLevel
Public Class LinuxJobStateFlagStackLevel
public ref class LinuxJobStateFlagStackLevel
DoubleTake.Jobs.Contract.Linux.LinuxJobStateFlagStackLevel = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.Linux.LinuxJobStateFlagStackLevel');

Field Value

Type:
...

The LinuxJobStateFlagStackLevel type exposes the following members.

Constructors
 | Name | Description
Public method | LinuxJobStateFlagStackLevel | Initializes a new instance of the LinuxJobStateFlagStackLevel class
Top
Properties
 | Name | Description
Public property | JobStateFlags |
Top
See Also

Reference

DoubleTake.Jobs.Contract.Linux Namespace


LinuxJobStateFlagStackLevel Constructor

LinuxJobStateFlagStackLevel Constructor
Initializes a new instance of the LinuxJobStateFlagStackLevel class

Namespace: DoubleTake.Jobs.Contract.Linux
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public LinuxJobStateFlagStackLevel()
Public Sub New
public:
LinuxJobStateFlagStackLevel()
DoubleTake.Jobs.Contract.Linux.LinuxJobStateFlagStackLevel = function();
See Also

Reference

LinuxJobStateFlagStackLevel Class
DoubleTake.Jobs.Contract.Linux Namespace


LinuxJobStateFlagStackLevel Properties

LinuxJobStateFlagStackLevel Properties

The LinuxJobStateFlagStackLevel type exposes the following members.

Properties
 | Name | Description
Public property | JobStateFlags |
Top
See Also

Reference

LinuxJobStateFlagStackLevel Class
DoubleTake.Jobs.Contract.Linux Namespace


LinuxJobStateFlagStackLevel.JobStateFlags Property

LinuxJobStateFlagStackLevelJobStateFlags Property

Namespace: DoubleTake.Jobs.Contract.Linux
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public LinuxJobStateFlag[] JobStateFlags { get; set; }
Public Property JobStateFlags As LinuxJobStateFlag()
    Get
    Set
public:
property array<LinuxJobStateFlag^>^ JobStateFlags {
    array<LinuxJobStateFlag^>^ get ();
    void set (array<LinuxJobStateFlag^>^ value);
}
function get_JobStateFlags();
function set_JobStateFlags(value);

Property Value

Type: LinuxJobStateFlag
See Also

Reference

LinuxJobStateFlagStackLevel Class
DoubleTake.Jobs.Contract.Linux Namespace


DoubleTake.Jobs.Contract.Scheduling Namespace

DoubleTake.Jobs.Contract.Scheduling Namespace
Classes
 | Class | Description
Public class | BandwidthEntry | Represents an entry in a bandwidth limiting schedule.
Public class | BandwidthOptions | Represents options for configuring a bandwidth limit and bandwidth limiting schedule.
Enumerations
 | Enumeration | Description
Public enumeration | BandwidthEntryType | Defines the type of a entry is a bandwidth schedule entry.


BandwidthEntry Class

BandwidthEntry Class
Represents an entry in a bandwidth limiting schedule.
Inheritance Hierarchy
SystemObject
ObservableObject
DoubleTake.Jobs.Contract.SchedulingBandwidthEntry

Namespace: DoubleTake.Jobs.Contract.Scheduling
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public sealed class BandwidthEntry : ObservableObject,
    IExtensibleDataObject
Public NotInheritable Class BandwidthEntry
    Inherits ObservableObject
    Implements IExtensibleDataObject
public ref class BandwidthEntry sealed : public ObservableObject,
    IExtensibleDataObject
DoubleTake.Jobs.Contract.Scheduling.BandwidthEntry = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.Scheduling.BandwidthEntry',
    DoubleTake.Common.ComponentModel.ObservableObject,
    IExtensibleDataObject);

The BandwidthEntry type exposes the following members.

Constructors
 | Name | Description
Public method | BandwidthEntry | Initializes a new instance of the BandwidthEntry class
Top
Properties
 | Name | Description
Public property | DaysOfWeek | This values is the days of the week to which the entry applies.
Public property | EndTime | This value is the end time of the entry. It should be between 00:00:00 and 23:59:59 (hh:mm:ss). This value is only applicable if the BandwidthOptions.BandwidthScheduleMode is Scheduled.
Public property | EntryType | This value represents a daytime or overnight schedule.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | IsUnlimited | This value is true if the entry allows unlimited bandwidth; otherwise, it is false.
Public property | Limit | This value is the bandwidth limit in bytes per second.
Public property | Name | This value is the name of the entry. It must be unique among all entries in the bandwidth schedule.
Public property | StartTime | This value is the start time of the entry. It should be between 00:00:00 and 23:59:59 (hh:mm:ss).
Top
Methods
 | Name | Description
 | GetNextDay | Gets the next day of week, given a reference day.
Public method | Overlaps | Determines if this bandwidth entry overlaps with the provided entry.
Public method | ToString | Returns a String that represents this instance. (Overrides ObjectToString.)
Top
See Also

Reference

DoubleTake.Jobs.Contract.Scheduling Namespace


BandwidthEntry Constructor

BandwidthEntry Constructor
Initializes a new instance of the BandwidthEntry class

Namespace: DoubleTake.Jobs.Contract.Scheduling
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public BandwidthEntry()
Public Sub New
public:
BandwidthEntry()
DoubleTake.Jobs.Contract.Scheduling.BandwidthEntry = function();
See Also

Reference

BandwidthEntry Class
DoubleTake.Jobs.Contract.Scheduling Namespace


BandwidthEntry Properties

BandwidthEntry Properties

The BandwidthEntry type exposes the following members.

Properties
 | Name | Description
Public property | DaysOfWeek | This values is the days of the week to which the entry applies.
Public property | EndTime | This value is the end time of the entry. It should be between 00:00:00 and 23:59:59 (hh:mm:ss). This value is only applicable if the BandwidthOptions.BandwidthScheduleMode is Scheduled.
Public property | EntryType | This value represents a daytime or overnight schedule.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | IsUnlimited | This value is true if the entry allows unlimited bandwidth; otherwise, it is false.
Public property | Limit | This value is the bandwidth limit in bytes per second.
Public property | Name | This value is the name of the entry. It must be unique among all entries in the bandwidth schedule.
Public property | StartTime | This value is the start time of the entry. It should be between 00:00:00 and 23:59:59 (hh:mm:ss).
Top
See Also

Reference

BandwidthEntry Class
DoubleTake.Jobs.Contract.Scheduling Namespace


BandwidthEntry.DaysOfWeek Property

BandwidthEntryDaysOfWeek Property
This values is the days of the week to which the entry applies.

Namespace: DoubleTake.Jobs.Contract.Scheduling
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Weekdays DaysOfWeek { get; set; }
Public Property DaysOfWeek As Weekdays
    Get
    Set
public:
property Weekdays DaysOfWeek {
    Weekdays get ();
    void set (Weekdays value);
}
function get_DaysOfWeek();
function set_DaysOfWeek(value);

Property Value

Type: Weekdays
The days of the week to which the entry applies.
See Also

Reference

BandwidthEntry Class
DoubleTake.Jobs.Contract.Scheduling Namespace


BandwidthEntry.EndTime Property

BandwidthEntryEndTime Property
This value is the end time of the entry. It should be between 00:00:00 and 23:59:59 (hh:mm:ss). This value is only applicable if the BandwidthOptions.BandwidthScheduleMode is Scheduled.

Namespace: DoubleTake.Jobs.Contract.Scheduling
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public DateTime EndTime { get; set; }
Public Property EndTime As DateTime
    Get
    Set
public:
property DateTime EndTime {
    DateTime get ();
    void set (DateTime value);
}
function get_EndTime();
function set_EndTime(value);

Property Value

Type: DateTime
The end time of the entry.
Remarks
This value should be between 00:00:00 and 23:59:59 (hh:mm:ss). This value in only applicable to bandwidth schedules whose Mode is Scheduled.
See Also

Reference

BandwidthEntry Class
DoubleTake.Jobs.Contract.Scheduling Namespace


BandwidthEntry.EntryType Property

BandwidthEntryEntryType Property
This value represents a daytime or overnight schedule.

Namespace: DoubleTake.Jobs.Contract.Scheduling
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public BandwidthEntryType EntryType { get; }
Public ReadOnly Property EntryType As BandwidthEntryType
    Get
public:
property BandwidthEntryType EntryType {
    BandwidthEntryType get ();
}
function get_EntryType();

Property Value

Type: BandwidthEntryType
The type of the entry.
See Also

Reference

BandwidthEntry Class
DoubleTake.Jobs.Contract.Scheduling Namespace


BandwidthEntry.ExtensionData Property

BandwidthEntryExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract.Scheduling
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

BandwidthEntry Class
DoubleTake.Jobs.Contract.Scheduling Namespace


BandwidthEntry.IsUnlimited Property

BandwidthEntryIsUnlimited Property
This value is true if the entry allows unlimited bandwidth; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract.Scheduling
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsUnlimited { get; set; }
Public Property IsUnlimited As Boolean
    Get
    Set
public:
property bool IsUnlimited {
    bool get ();
    void set (bool value);
}
function get_IsUnlimited();
function set_IsUnlimited(value);

Property Value

Type: Boolean
if this entry allows unlimited bandwidth; otherwise, .
See Also

Reference

BandwidthEntry Class
DoubleTake.Jobs.Contract.Scheduling Namespace


BandwidthEntry.Limit Property

BandwidthEntryLimit Property
This value is the bandwidth limit in bytes per second.

Namespace: DoubleTake.Jobs.Contract.Scheduling
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public long Limit { get; set; }
Public Property Limit As Long
    Get
    Set
public:
property long long Limit {
    long long get ();
    void set (long long value);
}
function get_Limit();
function set_Limit(value);

Property Value

Type: Int64
The bandwidth limit for the entry, in bytes per second.
See Also

Reference

BandwidthEntry Class
DoubleTake.Jobs.Contract.Scheduling Namespace


BandwidthEntry.Name Property

BandwidthEntryName Property
This value is the name of the entry. It must be unique among all entries in the bandwidth schedule.

Namespace: DoubleTake.Jobs.Contract.Scheduling
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
function get_Name();
function set_Name(value);

Property Value

Type: String
The name of the bandwidth schedule entry.
Remarks
This name must be unique among all entries in the bandwidth schedule.
See Also

Reference

BandwidthEntry Class
DoubleTake.Jobs.Contract.Scheduling Namespace


BandwidthEntry.StartTime Property

BandwidthEntryStartTime Property
This value is the start time of the entry. It should be between 00:00:00 and 23:59:59 (hh:mm:ss).

Namespace: DoubleTake.Jobs.Contract.Scheduling
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public DateTime StartTime { get; set; }
Public Property StartTime As DateTime
    Get
    Set
public:
property DateTime StartTime {
    DateTime get ();
    void set (DateTime value);
}
function get_StartTime();
function set_StartTime(value);

Property Value

Type: DateTime
The start time of the entry.
Remarks
This value should be between 00:00:00 and 23:59:59 (hh:mm:ss).
See Also

Reference

BandwidthEntry Class
DoubleTake.Jobs.Contract.Scheduling Namespace


BandwidthEntry Methods

BandwidthEntry Methods

The BandwidthEntry type exposes the following members.

Methods
 | Name | Description
 | GetNextDay | Gets the next day of week, given a reference day.
Public method | Overlaps | Determines if this bandwidth entry overlaps with the provided entry.
Public method | ToString | Returns a String that represents this instance. (Overrides ObjectToString.)
Top
See Also

Reference

BandwidthEntry Class
DoubleTake.Jobs.Contract.Scheduling Namespace


BandwidthEntry.GetNextDay Method

BandwidthEntryGetNextDay Method
Gets the next day of week, given a reference day.

Namespace: DoubleTake.Jobs.Contract.Scheduling
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public static Weekdays GetNextDay(
    Weekdays weekdays
)
Public Shared Function GetNextDay (
    weekdays As Weekdays
) As Weekdays
public:
static Weekdays GetNextDay(
    Weekdays weekdays
)
DoubleTake.Jobs.Contract.Scheduling.BandwidthEntry.GetNextDay = function(weekdays);

Parameters

weekdays
Type: DoubleTake.Core.Contract.ConnectionWeekdays
The day from which the next day should be calculated.

Return Value

Type: Weekdays
The next day of the week.
See Also

Reference

BandwidthEntry Class
DoubleTake.Jobs.Contract.Scheduling Namespace


BandwidthEntry.Overlaps Method

BandwidthEntryOverlaps Method
Determines if this bandwidth entry overlaps with the provided entry.

Namespace: DoubleTake.Jobs.Contract.Scheduling
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool Overlaps(
    BandwidthEntry other
)
Public Function Overlaps (
    other As BandwidthEntry
) As Boolean
public:
bool Overlaps(
    BandwidthEntry^ other
)
function Overlaps(other);

Parameters

other
Type: DoubleTake.Jobs.Contract.SchedulingBandwidthEntry
The other entry.

Return Value

Type: Boolean
if this entry overlaps with the provided entry; otherwise, .
See Also

Reference

BandwidthEntry Class
DoubleTake.Jobs.Contract.Scheduling Namespace


BandwidthEntry.ToString Method

BandwidthEntryToString Method
Returns a String that represents this instance.

Namespace: DoubleTake.Jobs.Contract.Scheduling
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
function ToString();

Return Value

Type: String
A String that represents this instance.
See Also

Reference

BandwidthEntry Class
DoubleTake.Jobs.Contract.Scheduling Namespace


BandwidthEntryType Enumeration

BandwidthEntryType Enumeration
Defines the type of a entry is a bandwidth schedule entry.

Namespace: DoubleTake.Jobs.Contract.Scheduling
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public enum BandwidthEntryType
Public Enumeration BandwidthEntryType
public enum class BandwidthEntryType
DoubleTake.Jobs.Contract.Scheduling.BandwidthEntryType = function();
DoubleTake.Jobs.Contract.Scheduling.BandwidthEntryType.createEnum('DoubleTake.Jobs.Contract.Scheduling.BandwidthEntryType', false);
Members
Member name | Value | Description
Daytime | 0 | This value is an entry where the BandwidthEntry.StartTime and .EndTime are on the same day.
Overnight | 1 | This value is an entry where the BandwidthEntry.StartTime value is on one day and the .EndTime value is on the next day.
Remarks
[E:Overnight] indicates an entry that wraps around the end of the day and ends at the same or earlier time the following day or days than this entry begins. [E:Daytime] indicates that the entry begins and ends on the same day, in which case the end time occurs after the start time.
See Also

Reference

DoubleTake.Jobs.Contract.Scheduling Namespace


BandwidthOptions Class

BandwidthOptions Class
Represents options for configuring a bandwidth limit and bandwidth limiting schedule.
Inheritance Hierarchy
SystemObject
ObservableObject
DoubleTake.Jobs.Contract.SchedulingBandwidthOptions

Namespace: DoubleTake.Jobs.Contract.Scheduling
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public sealed class BandwidthOptions : ObservableObject,
    IExtensibleDataObject
Public NotInheritable Class BandwidthOptions
    Inherits ObservableObject
    Implements IExtensibleDataObject
public ref class BandwidthOptions sealed : public ObservableObject,
    IExtensibleDataObject
DoubleTake.Jobs.Contract.Scheduling.BandwidthOptions = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.Scheduling.BandwidthOptions',
    DoubleTake.Common.ComponentModel.ObservableObject,
    IExtensibleDataObject);

The BandwidthOptions type exposes the following members.

Constructors
 | Name | Description
Public method | BandwidthOptions | Initializes a new instance of the BandwidthOptions class
Top
Properties
 | Name | Description
Public property | Entries | This value represents the bandwidth schedule. This value is copied to CoreConnectionOptions.ConnectionStartParameters.Schedule.Bandwidth.Entries.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Limit | This value is the bandwidth limit in bytes per second.
Public property | Mode | This value is the bandwidth limiting mode. This value is copied to CoreConnectionOptions.ConnectionStartParameters.Schedule.Bandwidth.Mode.
Public property | Specifications | This value represents a bandwidth specifications as identified by a common name (for example T1) and a numeric speed (for example, 193,000 bytes per second). This value is copied to CoreConnectionOptions.ConnectionStartParameters.Schedule.Bandwidth.Specification.
Top
Methods
 | Name | Description
 | FromLegacy | Converts a legacy BandwithSchedule to an instance of BandwidthOptions.
Public method | ToLegacy | Converts this instance of BandwidthOptions to a legacy BandwidthSchedule.
Top
See Also

Reference

DoubleTake.Jobs.Contract.Scheduling Namespace


BandwidthOptions Constructor

BandwidthOptions Constructor
Initializes a new instance of the BandwidthOptions class

Namespace: DoubleTake.Jobs.Contract.Scheduling
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public BandwidthOptions()
Public Sub New
public:
BandwidthOptions()
DoubleTake.Jobs.Contract.Scheduling.BandwidthOptions = function();
See Also

Reference

BandwidthOptions Class
DoubleTake.Jobs.Contract.Scheduling Namespace


BandwidthOptions Properties

BandwidthOptions Properties

The BandwidthOptions type exposes the following members.

Properties
 | Name | Description
Public property | Entries | This value represents the bandwidth schedule. This value is copied to CoreConnectionOptions.ConnectionStartParameters.Schedule.Bandwidth.Entries.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Limit | This value is the bandwidth limit in bytes per second.
Public property | Mode | This value is the bandwidth limiting mode. This value is copied to CoreConnectionOptions.ConnectionStartParameters.Schedule.Bandwidth.Mode.
Public property | Specifications | This value represents a bandwidth specifications as identified by a common name (for example T1) and a numeric speed (for example, 193,000 bytes per second). This value is copied to CoreConnectionOptions.ConnectionStartParameters.Schedule.Bandwidth.Specification.
Top
See Also

Reference

BandwidthOptions Class
DoubleTake.Jobs.Contract.Scheduling Namespace


BandwidthOptions.Entries Property

BandwidthOptionsEntries Property
This value represents the bandwidth schedule. This value is copied to CoreConnectionOptions.ConnectionStartParameters.Schedule.Bandwidth.Entries.

Namespace: DoubleTake.Jobs.Contract.Scheduling
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public BandwidthEntry[] Entries { get; set; }
Public Property Entries As BandwidthEntry()
    Get
    Set
public:
property array<BandwidthEntry^>^ Entries {
    array<BandwidthEntry^>^ get ();
    void set (array<BandwidthEntry^>^ value);
}
function get_Entries();
function set_Entries(value);

Property Value

Type: BandwidthEntry
An array of BandwidthEntry that represents the entries in the bandwidth limiting schedule.
See Also

Reference

BandwidthOptions Class
DoubleTake.Jobs.Contract.Scheduling Namespace


BandwidthOptions.ExtensionData Property

BandwidthOptionsExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract.Scheduling
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

BandwidthOptions Class
DoubleTake.Jobs.Contract.Scheduling Namespace


BandwidthOptions.Limit Property

BandwidthOptionsLimit Property
This value is the bandwidth limit in bytes per second.

Namespace: DoubleTake.Jobs.Contract.Scheduling
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public long Limit { get; set; }
Public Property Limit As Long
    Get
    Set
public:
property long long Limit {
    long long get ();
    void set (long long value);
}
function get_Limit();
function set_Limit(value);

Property Value

Type: Int64
The bandwidth limit, in bytes per second.
See Also

Reference

BandwidthOptions Class
DoubleTake.Jobs.Contract.Scheduling Namespace


BandwidthOptions.Mode Property

BandwidthOptionsMode Property
This value is the bandwidth limiting mode. This value is copied to CoreConnectionOptions.ConnectionStartParameters.Schedule.Bandwidth.Mode.

Namespace: DoubleTake.Jobs.Contract.Scheduling
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public BandwidthScheduleMode Mode { get; set; }
Public Property Mode As BandwidthScheduleMode
    Get
    Set
public:
property BandwidthScheduleMode Mode {
    BandwidthScheduleMode get ();
    void set (BandwidthScheduleMode value);
}
function get_Mode();
function set_Mode(value);

Property Value

Type: BandwidthScheduleMode
The mode of the bandwidth schedule.
See Also

Reference

BandwidthOptions Class
DoubleTake.Jobs.Contract.Scheduling Namespace


BandwidthOptions.Specifications Property

BandwidthOptionsSpecifications Property
This value represents a bandwidth specifications as identified by a common name (for example T1) and a numeric speed (for example, 193,000 bytes per second). This value is copied to CoreConnectionOptions.ConnectionStartParameters.Schedule.Bandwidth.Specification.

Namespace: DoubleTake.Jobs.Contract.Scheduling
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public BandwidthSpecification[] Specifications { get; set; }
Public Property Specifications As BandwidthSpecification()
    Get
    Set
public:
property array<BandwidthSpecification^>^ Specifications {
    array<BandwidthSpecification^>^ get ();
    void set (array<BandwidthSpecification^>^ value);
}
function get_Specifications();
function set_Specifications(value);

Property Value

Type: BandwidthSpecification
An array of BandwidthSpecification that represents common bandwidth specifications.
See Also

Reference

BandwidthOptions Class
DoubleTake.Jobs.Contract.Scheduling Namespace


BandwidthOptions Methods

BandwidthOptions Methods

The BandwidthOptions type exposes the following members.

Methods
 | Name | Description
 | FromLegacy | Converts a legacy BandwithSchedule to an instance of BandwidthOptions.
Public method | ToLegacy | Converts this instance of BandwidthOptions to a legacy BandwidthSchedule.
Top
See Also

Reference

BandwidthOptions Class
DoubleTake.Jobs.Contract.Scheduling Namespace


BandwidthOptions.FromLegacy Method

BandwidthOptionsFromLegacy Method
Converts a legacy BandwithSchedule to an instance of BandwidthOptions.

Namespace: DoubleTake.Jobs.Contract.Scheduling
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public static BandwidthOptions FromLegacy(
    BandwidthSchedule gatewayType
)
Public Shared Function FromLegacy (
    gatewayType As BandwidthSchedule
) As BandwidthOptions
public:
static BandwidthOptions^ FromLegacy(
    BandwidthSchedule^ gatewayType
)
DoubleTake.Jobs.Contract.Scheduling.BandwidthOptions.FromLegacy = function(gatewayType);

Parameters

gatewayType
Type: DoubleTake.Core.Contract.ConnectionBandwidthSchedule
The instance of BandwidthSchedule to be converted.

Return Value

Type: BandwidthOptions
An instance of BandwidthOptions that contains the converted data.
See Also

Reference

BandwidthOptions Class
DoubleTake.Jobs.Contract.Scheduling Namespace


BandwidthOptions.ToLegacy Method

BandwidthOptionsToLegacy Method
Converts this instance of BandwidthOptions to a legacy BandwidthSchedule.

Namespace: DoubleTake.Jobs.Contract.Scheduling
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public void ToLegacy(
    BandwidthSchedule legacyType
)
Public Sub ToLegacy (
    legacyType As BandwidthSchedule
)
public:
void ToLegacy(
    BandwidthSchedule^ legacyType
)
function ToLegacy(legacyType);

Parameters

legacyType
Type: DoubleTake.Core.Contract.ConnectionBandwidthSchedule
An instance of BandwidthSchedule that will receive the configuration of this instance.
See Also

Reference

BandwidthOptions Class
DoubleTake.Jobs.Contract.Scheduling Namespace


DoubleTake.Jobs.Contract.Virtualization Namespace

DoubleTake.Jobs.Contract.Virtualization Namespace
Classes
 | Class | Description
Public class | DTAVPersistedState |


DTAVPersistedState Class

DTAVPersistedState Class
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.Contract.VirtualizationDTAVPersistedState

Namespace: DoubleTake.Jobs.Contract.Virtualization
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class DTAVPersistedState : IExtensibleDataObject
Public Class DTAVPersistedState
    Implements IExtensibleDataObject
public ref class DTAVPersistedState : IExtensibleDataObject
DoubleTake.Jobs.Contract.Virtualization.DTAVPersistedState = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.Virtualization.DTAVPersistedState',
    null,
    IExtensibleDataObject);

The DTAVPersistedState type exposes the following members.

Constructors
 | Name | Description
Public method | DTAVPersistedState | Initializes a new instance of the DTAVPersistedState class
Top
Properties
 | Name | Description
Public property | ExtensionData |
Public property | JobCreationDate |
Public property | JobState |
Public property | JobVersion |
Public property | Licensed |
Public property | LicenseData |
Public property | SnapshotName |
Public property | TargetVmGuid |
Public property | VmdkdInfoList |
Top
Fields
 | Name | Description
Public field | SavedSnapshots |
Top
See Also

Reference

DoubleTake.Jobs.Contract.Virtualization Namespace


DTAVPersistedState Constructor

DTAVPersistedState Constructor
Initializes a new instance of the DTAVPersistedState class

Namespace: DoubleTake.Jobs.Contract.Virtualization
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public DTAVPersistedState()
Public Sub New
public:
DTAVPersistedState()
DoubleTake.Jobs.Contract.Virtualization.DTAVPersistedState = function();
See Also

Reference

DTAVPersistedState Class
DoubleTake.Jobs.Contract.Virtualization Namespace


DTAVPersistedState Properties

DTAVPersistedState Properties

The DTAVPersistedState type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData |
Public property | JobCreationDate |
Public property | JobState |
Public property | JobVersion |
Public property | Licensed |
Public property | LicenseData |
Public property | SnapshotName |
Public property | TargetVmGuid |
Public property | VmdkdInfoList |
Top
See Also

Reference

DTAVPersistedState Class
DoubleTake.Jobs.Contract.Virtualization Namespace


DTAVPersistedState.ExtensionData Property

DTAVPersistedStateExtensionData Property

Namespace: DoubleTake.Jobs.Contract.Virtualization
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

DTAVPersistedState Class
DoubleTake.Jobs.Contract.Virtualization Namespace


DTAVPersistedState.JobCreationDate Property

DTAVPersistedStateJobCreationDate Property

Namespace: DoubleTake.Jobs.Contract.Virtualization
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public DateTimeOffset JobCreationDate { get; set; }
Public Property JobCreationDate As DateTimeOffset
    Get
    Set
public:
property DateTimeOffset JobCreationDate {
    DateTimeOffset get ();
    void set (DateTimeOffset value);
}
function get_JobCreationDate();
function set_JobCreationDate(value);

Property Value

Type: DateTimeOffset
See Also

Reference

DTAVPersistedState Class
DoubleTake.Jobs.Contract.Virtualization Namespace


DTAVPersistedState.JobState Property

DTAVPersistedStateJobState Property

Namespace: DoubleTake.Jobs.Contract.Virtualization
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public JobState JobState { get; set; }
Public Property JobState As JobState
    Get
    Set
public:
property JobState^ JobState {
    JobState^ get ();
    void set (JobState^ value);
}
function get_JobState();
function set_JobState(value);

Property Value

Type: JobState
See Also

Reference

DTAVPersistedState Class
DoubleTake.Jobs.Contract.Virtualization Namespace


DTAVPersistedState.JobVersion Property

DTAVPersistedStateJobVersion Property

Namespace: DoubleTake.Jobs.Contract.Virtualization
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ProductVersion JobVersion { get; set; }
Public Property JobVersion As ProductVersion
    Get
    Set
public:
property ProductVersion^ JobVersion {
    ProductVersion^ get ();
    void set (ProductVersion^ value);
}
function get_JobVersion();
function set_JobVersion(value);

Property Value

Type: ProductVersion
See Also

Reference

DTAVPersistedState Class
DoubleTake.Jobs.Contract.Virtualization Namespace


DTAVPersistedState.Licensed Property

DTAVPersistedStateLicensed Property

Namespace: DoubleTake.Jobs.Contract.Virtualization
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool Licensed { get; set; }
Public Property Licensed As Boolean
    Get
    Set
public:
property bool Licensed {
    bool get ();
    void set (bool value);
}
function get_Licensed();
function set_Licensed(value);

Property Value

Type: Boolean
See Also

Reference

DTAVPersistedState Class
DoubleTake.Jobs.Contract.Virtualization Namespace


DTAVPersistedState.LicenseData Property

DTAVPersistedStateLicenseData Property

Namespace: DoubleTake.Jobs.Contract.Virtualization
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string LicenseData { get; set; }
Public Property LicenseData As String
    Get
    Set
public:
property String^ LicenseData {
    String^ get ();
    void set (String^ value);
}
function get_LicenseData();
function set_LicenseData(value);

Property Value

Type: String
See Also

Reference

DTAVPersistedState Class
DoubleTake.Jobs.Contract.Virtualization Namespace


DTAVPersistedState.SnapshotName Property

DTAVPersistedStateSnapshotName Property

Namespace: DoubleTake.Jobs.Contract.Virtualization
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string SnapshotName { get; set; }
Public Property SnapshotName As String
    Get
    Set
public:
property String^ SnapshotName {
    String^ get ();
    void set (String^ value);
}
function get_SnapshotName();
function set_SnapshotName(value);

Property Value

Type: String
See Also

Reference

DTAVPersistedState Class
DoubleTake.Jobs.Contract.Virtualization Namespace


DTAVPersistedState.TargetVmGuid Property

DTAVPersistedStateTargetVmGuid Property

Namespace: DoubleTake.Jobs.Contract.Virtualization
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string TargetVmGuid { get; set; }
Public Property TargetVmGuid As String
    Get
    Set
public:
property String^ TargetVmGuid {
    String^ get ();
    void set (String^ value);
}
function get_TargetVmGuid();
function set_TargetVmGuid(value);

Property Value

Type: String
See Also

Reference

DTAVPersistedState Class
DoubleTake.Jobs.Contract.Virtualization Namespace


DTAVPersistedState.VmdkdInfoList Property

DTAVPersistedStateVmdkdInfoList Property

Namespace: DoubleTake.Jobs.Contract.Virtualization
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public List<VmdkInfo> VmdkdInfoList { get; set; }
Public Property VmdkdInfoList As List(Of VmdkInfo)
    Get
    Set
public:
property List<VmdkInfo^>^ VmdkdInfoList {
    List<VmdkInfo^>^ get ();
    void set (List<VmdkInfo^>^ value);
}
function get_VmdkdInfoList();
function set_VmdkdInfoList(value);

Property Value

Type: List VmdkInfo
See Also

Reference

DTAVPersistedState Class
DoubleTake.Jobs.Contract.Virtualization Namespace


DTAVPersistedState Fields

DTAVPersistedState Fields

The DTAVPersistedState type exposes the following members.

Fields
 | Name | Description
Public field | SavedSnapshots |
Top
See Also

Reference

DTAVPersistedState Class
DoubleTake.Jobs.Contract.Virtualization Namespace


DTAVPersistedState.SavedSnapshots Field

DTAVPersistedStateSavedSnapshots Field

Namespace: DoubleTake.Jobs.Contract.Virtualization
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public List<PITSnapshotRecord> SavedSnapshots
Public SavedSnapshots As List(Of PITSnapshotRecord)
public:
List<PITSnapshotRecord^>^ SavedSnapshots
var SavedSnapshots

Field Value

Type: List PITSnapshotRecord
See Also

Reference

DTAVPersistedState Class
DoubleTake.Jobs.Contract.Virtualization Namespace


DoubleTake.Monitoring.Contract Namespace

DoubleTake.Monitoring.Contract Namespace
Classes
 | Class | Description
Public class | Ace |
Public class | ActionInput | Represents input into a monitor action.
Public class | ActionResult | Represents the result of a monitor action.
Public class | ActivityResultNode | Represents the results obtained from the execution of a MonitorActivity. These results can be chained together to cover all branched activities executed while traversing the activity tree.
Public class | CompositeActionInput | Represents the input to a Composite action agent.
Public class | CompositeActionResult | Represents the results of a composite action.
Public class | CompositeQueryInput | Represents the input to a Composite query agent.
Public class | CompositeQueryResult | Represents the results of a composite query.
Public class | DtscStatusQueryInput |
Public class | DtscStatusQueryResult |
Public class | DTTargetResourceQueryInput |
Public class | HeartbeatPingQueryInput | Represents the input to a Double-Take heartbeat ping query agent.
Public class | HeartbeatPingQueryResult | Represents the results of a heartbeat ping query.
Public class | IcmpPingQueryInput | Represents the input to an ICMP ping query agent.
Public class | IcmpPingQueryResult | Represents the results of an ICMP ping query.
Public class | LogActionInput | Represents the input to a log action.
Public class | MonitorAction | Represents an action that is run in the context of a monitor.
Public class | MonitorActivity | This class represents one node in a monitor decision/action tree.
Public class | MonitorInfo | This class represents a complete definition of a monitor decision-action tree object.
Public class | MonitorOptions | Represents the configuration of a monitor. This class is used to either create a new monitor or modify the configuration of an existing monitor.
Public class | MonitorQuery | This class is part of the MonitorActivity class which contains both query and action.
Public class | MonitorStatus | Represents the current status of a monitor.
Public class | PerformanceCounterQueryInput | Represents the input to a performance counter query.
Public class | PerformanceCounterQueryResult |
Public class | PropertyFault |
Public class | QueryInput | Represents arguments to a monitoring query.
Public class | QueryResult | Represents the result of a monitoring query.
Public class | ScriptActionInput |
Public class | ScriptActionResult |
Public class | ScriptQueryInput | Defines the input into the script query.
Public class | ScriptQueryResult | Defines the result of a Script query.
Public class | ServiceOperationActionInput |
Public class | ServiceOperationActionResult | Represents the result of a service operation action.
Public class | ServiceStatusQueryInput |
Public class | ServiceStatusQueryResult |
Public class | Share |
Public class | ShareQueryInput |
Public class | ShareQueryResult |
Public class | SimpleMonitorInfo | This class represents a partial definition of a monitor object. Use this class if you only care about a few critical parts of the whole definition.
Public class | ValidationFault | Fault contract issued by validation methods when the validation fails.
Public class | VirtualSwitchConfigQueryInput |
Public class | VirtualSwitchConfigQueryResult |
Public class | VmConfigQueryInput |
Public class | VmConfigQueryResult |
Public class | VmHealthQueryInput |
Public class | VmHealthQueryResult |
Interfaces
 | Interface | Description
Public interface | IMonitorManager | The interface to be used for creating, configuring and controlling monitors.
Enumerations
 | Enumeration | Description
Public enumeration | ComparisonOperation | Represents the types of comparison operations.
Public enumeration | CompositeQueryOperation | Defines how to evaluate a composite query.
Public enumeration | MonitorResult |
Public enumeration | MonitorState | An enumeration of the monitor states for the Monitoring Framework.
Public enumeration | ServiceOperation | Represents the different types of Windows service operations.
Public enumeration | TriggerMode | Used to determine which criteria to use when triggering a monitor.


Ace Class

Ace Class
Inheritance Hierarchy
SystemObject
DoubleTake.Monitoring.ContractAce

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class Ace
Public Class Ace
public ref class Ace
DoubleTake.Monitoring.Contract.Ace = function();

Type.createClass(
    'DoubleTake.Monitoring.Contract.Ace');

The Ace type exposes the following members.

Constructors
 | Name | Description
Public method | Ace | Initializes a new instance of the Ace class
Public method | Ace(Ace) | Initializes a new instance of the Ace class
Top
Operators
Name | Description
(Ace to Ace) |
Top
Fields
 | Name | Description
Public field | AccessMask |
Public field | AceFlags |
Public field | AceType |
Public field | Domain |
Public field | Name |
Public field | Sid |
Top
See Also

Reference

DoubleTake.Monitoring.Contract Namespace


Ace Constructor

Ace Constructor
Overload List
 | Name | Description
Public method | Ace | Initializes a new instance of the Ace class
Public method | Ace(Ace) | Initializes a new instance of the Ace class
Top
See Also

Reference

Ace Class
DoubleTake.Monitoring.Contract Namespace


Ace Constructor

Ace Constructor
Initializes a new instance of the Ace class

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Ace()
Public Sub New
public:
Ace()
DoubleTake.Monitoring.Contract.Ace = function();
See Also

Reference

Ace Class
Ace Overload
DoubleTake.Monitoring.Contract Namespace


Ace Constructor (Ace)

Ace Constructor (Ace)
Initializes a new instance of the Ace class

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Ace(
    Ace ace
)
Public Sub New (
    ace As Ace
)
public:
Ace(
    Ace^ ace
)
DoubleTake.Monitoring.Contract.Ace = function(ace);

Parameters

ace
Type: Ace
See Also

Reference

Ace Class
Ace Overload
DoubleTake.Monitoring.Contract Namespace


Ace Type Conversions

Ace Type Conversions

The Ace type exposes the following members.

Operators
Name | Description
(Ace to Ace) |
Top
See Also

Reference

Ace Class
DoubleTake.Monitoring.Contract Namespace


Ace Explicit Conversion (Ace to Ace)

Ace Conversion (Ace to Ace)

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public static explicit operator Ace (
    Ace ace
)
Public Shared Narrowing Operator CType (
    ace As Ace
) As Ace
static explicit operator Ace^ (
    Ace^ ace
)
JavaScript does not support the declaration of new casting operators.

Parameters

ace
Type: DoubleTake.Monitoring.ContractAce

Return Value

Type: Ace
See Also

Reference

Ace Class
DoubleTake.Monitoring.Contract Namespace


Ace Fields

Ace Fields

The Ace type exposes the following members.

Fields
 | Name | Description
Public field | AccessMask |
Public field | AceFlags |
Public field | AceType |
Public field | Domain |
Public field | Name |
Public field | Sid |
Top
See Also

Reference

Ace Class
DoubleTake.Monitoring.Contract Namespace


Ace.AccessMask Field

AceAccessMask Field

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int AccessMask
Public AccessMask As Integer
public:
int AccessMask
var AccessMask

Field Value

Type: Int32
See Also

Reference

Ace Class
DoubleTake.Monitoring.Contract Namespace


Ace.AceFlags Field

AceAceFlags Field

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public AceFlags AceFlags
Public AceFlags As AceFlags
public:
AceFlags AceFlags
var AceFlags

Field Value

Type: AceFlags
See Also

Reference

Ace Class
DoubleTake.Monitoring.Contract Namespace


Ace.AceType Field

AceAceType Field

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public AceType AceType
Public AceType As AceType
public:
AceType AceType
var AceType

Field Value

Type: AceType
See Also

Reference

Ace Class
DoubleTake.Monitoring.Contract Namespace


Ace.Domain Field

AceDomain Field

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Domain
Public Domain As String
public:
String^ Domain
var Domain

Field Value

Type: String
See Also

Reference

Ace Class
DoubleTake.Monitoring.Contract Namespace


Ace.Name Field

AceName Field

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Name
Public Name As String
public:
String^ Name
var Name

Field Value

Type: String
See Also

Reference

Ace Class
DoubleTake.Monitoring.Contract Namespace


Ace.Sid Field

AceSid Field

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public byte[] Sid
Public Sid As Byte()
public:
array<unsigned char>^ Sid
var Sid

Field Value

Type: Byte
See Also

Reference

Ace Class
DoubleTake.Monitoring.Contract Namespace


ActionInput Class

ActionInput Class
Represents input into a monitor action.
Inheritance Hierarchy
SystemObject
DoubleTake.Monitoring.ContractActionInput
DoubleTake.Monitoring.ContractCompositeActionInput
DoubleTake.Monitoring.ContractLogActionInput
DoubleTake.Monitoring.ContractScriptActionInput
DoubleTake.Monitoring.ContractServiceOperationActionInput

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class ActionInput : IExtensibleDataObject
Public Class ActionInput
    Implements IExtensibleDataObject
public ref class ActionInput : IExtensibleDataObject
DoubleTake.Monitoring.Contract.ActionInput = function();

Type.createClass(
    'DoubleTake.Monitoring.Contract.ActionInput',
    null,
    IExtensibleDataObject);

The ActionInput type exposes the following members.

Constructors
 | Name | Description
Public method | ActionInput | Initializes a new instance of the ActionInput class
Top
Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the action.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | QueryResult | Gets or sets the query result.
Top
See Also

Reference

DoubleTake.Monitoring.Contract Namespace


ActionInput Constructor

ActionInput Constructor
Initializes a new instance of the ActionInput class

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ActionInput()
Public Sub New
public:
ActionInput()
DoubleTake.Monitoring.Contract.ActionInput = function();
See Also

Reference

ActionInput Class
DoubleTake.Monitoring.Contract Namespace


ActionInput Properties

ActionInput Properties

The ActionInput type exposes the following members.

Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the action.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | QueryResult | Gets or sets the query result.
Top
See Also

Reference

ActionInput Class
DoubleTake.Monitoring.Contract Namespace


ActionInput.Credentials Property

ActionInputCredentials Property
Gets or sets the credentials to be used by the action.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public IDictionary<string, Credentials> Credentials { get; set; }
Public Property Credentials As IDictionary(Of String, Credentials)
    Get
    Set
public:
property IDictionary<String^, Credentials^>^ Credentials {
    IDictionary<String^, Credentials^>^ get ();
    void set (IDictionary<String^, Credentials^>^ value);
}
function get_Credentials();
function set_Credentials(value);

Property Value

Type: IDictionary String, Credentials
The credentials.
See Also

Reference

ActionInput Class
DoubleTake.Monitoring.Contract Namespace


ActionInput.ExtensionData Property

ActionInputExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

ActionInput Class
DoubleTake.Monitoring.Contract Namespace


ActionInput.QueryResult Property

ActionInputQueryResult Property
Gets or sets the query result.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public QueryResult QueryResult { get; set; }
Public Property QueryResult As QueryResult
    Get
    Set
public:
property QueryResult^ QueryResult {
    QueryResult^ get ();
    void set (QueryResult^ value);
}
function get_QueryResult();
function set_QueryResult(value);

Property Value

Type: QueryResult
The query result.
Remarks
This property will be automatically populated in for all actions being executed as a CorrectiveAction for a MonitorActivity. It may be helpful for the action to have contextual information concerning why the query failed when performing the corrective action.
See Also

Reference

ActionInput Class
DoubleTake.Monitoring.Contract Namespace


ActionResult Class

ActionResult Class
Represents the result of a monitor action.
Inheritance Hierarchy
SystemObject
DoubleTake.Monitoring.ContractActionResult
DoubleTake.Monitoring.ContractCompositeActionResult
DoubleTake.Monitoring.ContractScriptActionResult
DoubleTake.Monitoring.ContractServiceOperationActionResult

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class ActionResult : IExtensibleDataObject
Public Class ActionResult
    Implements IExtensibleDataObject
public ref class ActionResult : IExtensibleDataObject
DoubleTake.Monitoring.Contract.ActionResult = function();

Type.createClass(
    'DoubleTake.Monitoring.Contract.ActionResult',
    null,
    IExtensibleDataObject);

The ActionResult type exposes the following members.

Constructors
 | Name | Description
Public method | ActionResult | Initializes a new instance of the ActionResult class
Top
Properties
 | Name | Description
Public property | Exception | Gets or sets the action exception.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Top
See Also

Reference

DoubleTake.Monitoring.Contract Namespace


ActionResult Constructor

ActionResult Constructor
Initializes a new instance of the ActionResult class

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ActionResult()
Public Sub New
public:
ActionResult()
DoubleTake.Monitoring.Contract.ActionResult = function();
See Also

Reference

ActionResult Class
DoubleTake.Monitoring.Contract Namespace


ActionResult Properties

ActionResult Properties

The ActionResult type exposes the following members.

Properties
 | Name | Description
Public property | Exception | Gets or sets the action exception.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Top
See Also

Reference

ActionResult Class
DoubleTake.Monitoring.Contract Namespace


ActionResult.Exception Property

ActionResultException Property
Gets or sets the action exception.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExceptionDetail Exception { get; set; }
Public Property Exception As ExceptionDetail
    Get
    Set
public:
property ExceptionDetail^ Exception {
    ExceptionDetail^ get ();
    void set (ExceptionDetail^ value);
}
function get_Exception();
function set_Exception(value);

Property Value

Type: ExceptionDetail
The action exception.
See Also

Reference

ActionResult Class
DoubleTake.Monitoring.Contract Namespace


ActionResult.ExtensionData Property

ActionResultExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

ActionResult Class
DoubleTake.Monitoring.Contract Namespace


ActivityResultNode Class

ActivityResultNode Class
Represents the results obtained from the execution of a MonitorActivity. These results can be chained together to cover all branched activities executed while traversing the activity tree.
Inheritance Hierarchy
SystemObject
DoubleTake.Monitoring.ContractActivityResultNode

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class ActivityResultNode : IExtensibleDataObject
Public Class ActivityResultNode
    Implements IExtensibleDataObject
public ref class ActivityResultNode : IExtensibleDataObject
DoubleTake.Monitoring.Contract.ActivityResultNode = function();

Type.createClass(
    'DoubleTake.Monitoring.Contract.ActivityResultNode',
    null,
    IExtensibleDataObject);

The ActivityResultNode type exposes the following members.

Constructors
 | Name | Description
Public method | ActivityResultNode | Initializes a new instance of the ActivityResultNode class
Top
Properties
 | Name | Description
Public property | ActivityName | Gets or sets the name of the activity.
Public property | CorrectiveActionResult | Gets or sets the corrective action result.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Previous | Gets or sets the previous activity's results.
Public property | QueryResult | Gets or sets the query result.
Public property | Result | Gets or sets a value indicating whether the activity succeeded.
Top
See Also

Reference

DoubleTake.Monitoring.Contract Namespace


ActivityResultNode Constructor

ActivityResultNode Constructor
Initializes a new instance of the ActivityResultNode class

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ActivityResultNode()
Public Sub New
public:
ActivityResultNode()
DoubleTake.Monitoring.Contract.ActivityResultNode = function();
See Also

Reference

ActivityResultNode Class
DoubleTake.Monitoring.Contract Namespace


ActivityResultNode Properties

ActivityResultNode Properties

The ActivityResultNode type exposes the following members.

Properties
 | Name | Description
Public property | ActivityName | Gets or sets the name of the activity.
Public property | CorrectiveActionResult | Gets or sets the corrective action result.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Previous | Gets or sets the previous activity's results.
Public property | QueryResult | Gets or sets the query result.
Public property | Result | Gets or sets a value indicating whether the activity succeeded.
Top
See Also

Reference

ActivityResultNode Class
DoubleTake.Monitoring.Contract Namespace


ActivityResultNode.ActivityName Property

ActivityResultNodeActivityName Property
Gets or sets the name of the activity.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string ActivityName { get; set; }
Public Property ActivityName As String
    Get
    Set
public:
property String^ ActivityName {
    String^ get ();
    void set (String^ value);
}
function get_ActivityName();
function set_ActivityName(value);

Property Value

Type: String
The name of the activity.
See Also

Reference

ActivityResultNode Class
DoubleTake.Monitoring.Contract Namespace


ActivityResultNode.CorrectiveActionResult Property

ActivityResultNodeCorrectiveActionResult Property
Gets or sets the corrective action result.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ActionResult CorrectiveActionResult { get; set; }
Public Property CorrectiveActionResult As ActionResult
    Get
    Set
public:
property ActionResult^ CorrectiveActionResult {
    ActionResult^ get ();
    void set (ActionResult^ value);
}
function get_CorrectiveActionResult();
function set_CorrectiveActionResult(value);

Property Value

Type: ActionResult
The corrective action result.
See Also

Reference

ActivityResultNode Class
DoubleTake.Monitoring.Contract Namespace


ActivityResultNode.ExtensionData Property

ActivityResultNodeExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

ActivityResultNode Class
DoubleTake.Monitoring.Contract Namespace


ActivityResultNode.Previous Property

ActivityResultNodePrevious Property
Gets or sets the previous activity's results.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ActivityResultNode Previous { get; set; }
Public Property Previous As ActivityResultNode
    Get
    Set
public:
property ActivityResultNode^ Previous {
    ActivityResultNode^ get ();
    void set (ActivityResultNode^ value);
}
function get_Previous();
function set_Previous(value);

Property Value

Type: ActivityResultNode
The previous activity's results.
See Also

Reference

ActivityResultNode Class
DoubleTake.Monitoring.Contract Namespace


ActivityResultNode.QueryResult Property

ActivityResultNodeQueryResult Property
Gets or sets the query result.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public QueryResult QueryResult { get; set; }
Public Property QueryResult As QueryResult
    Get
    Set
public:
property QueryResult^ QueryResult {
    QueryResult^ get ();
    void set (QueryResult^ value);
}
function get_QueryResult();
function set_QueryResult(value);

Property Value

Type: QueryResult
The query result.
See Also

Reference

ActivityResultNode Class
DoubleTake.Monitoring.Contract Namespace


ActivityResultNode.Result Property

ActivityResultNodeResult Property
Gets or sets a value indicating whether the activity succeeded.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public MonitorResult Result { get; set; }
Public Property Result As MonitorResult
    Get
    Set
public:
property MonitorResult Result {
    MonitorResult get ();
    void set (MonitorResult value);
}
function get_Result();
function set_Result(value);

Property Value

Type: MonitorResult
if the activity succeeded; otherwise, .
See Also

Reference

ActivityResultNode Class
DoubleTake.Monitoring.Contract Namespace


ComparisonOperation Enumeration

ComparisonOperation Enumeration
Represents the types of comparison operations.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public enum ComparisonOperation
Public Enumeration ComparisonOperation
public enum class ComparisonOperation
DoubleTake.Monitoring.Contract.ComparisonOperation = function();
DoubleTake.Monitoring.Contract.ComparisonOperation.createEnum('DoubleTake.Monitoring.Contract.ComparisonOperation', false);
Members
Member name | Value | Description
Equal | 0 | Indicates that the comparison operation succeeds of the items are equal.
LessThan | 1 | Indicates that the comparison operation succeeds if the first item is less than the second item.
LessThanOrEqual | 2 | Indicates that the comparison operation succeeds if the first item is less than or equal to the second item.
GreatherThan | 3 | Indicates that the comparison operation succeeds if the first item is greater than the second item.
GreatherThanOrEqual | 4 | Indicates that the comparison operation succeeds if the first item is greater than or equal to the second item.
See Also

Reference

DoubleTake.Monitoring.Contract Namespace


CompositeActionInput Class

CompositeActionInput Class
Represents the input to a Composite action agent.
Inheritance Hierarchy
SystemObject
DoubleTake.Monitoring.ContractActionInput
DoubleTake.Monitoring.ContractCompositeActionInput

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class CompositeActionInput : ActionInput
Public Class CompositeActionInput
    Inherits ActionInput
public ref class CompositeActionInput : public ActionInput
DoubleTake.Monitoring.Contract.CompositeActionInput = function();

Type.createClass(
    'DoubleTake.Monitoring.Contract.CompositeActionInput',
    DoubleTake.Monitoring.Contract.ActionInput);

The CompositeActionInput type exposes the following members.

Constructors
 | Name | Description
Public method | CompositeActionInput | Initializes a new instance of the CompositeActionInput class
Top
Properties
 | Name | Description
Public property | Actions | Gets or sets the enumerable collection of actions.
Public property | Credentials | Gets or sets the credentials to be used by the action. (Inherited from ActionInput.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from ActionInput.)
Public property | ParallelExecution | Gets or sets a value indicating whether the actions are to be executed in parallel.
Public property | QueryResult | Gets or sets the query result. (Inherited from ActionInput.)
Top
See Also

Reference

DoubleTake.Monitoring.Contract Namespace


CompositeActionInput Constructor

CompositeActionInput Constructor
Initializes a new instance of the CompositeActionInput class

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public CompositeActionInput()
Public Sub New
public:
CompositeActionInput()
DoubleTake.Monitoring.Contract.CompositeActionInput = function();
See Also

Reference

CompositeActionInput Class
DoubleTake.Monitoring.Contract Namespace


CompositeActionInput Properties

CompositeActionInput Properties

The CompositeActionInput type exposes the following members.

Properties
 | Name | Description
Public property | Actions | Gets or sets the enumerable collection of actions.
Public property | Credentials | Gets or sets the credentials to be used by the action. (Inherited from ActionInput.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from ActionInput.)
Public property | ParallelExecution | Gets or sets a value indicating whether the actions are to be executed in parallel.
Public property | QueryResult | Gets or sets the query result. (Inherited from ActionInput.)
Top
See Also

Reference

CompositeActionInput Class
DoubleTake.Monitoring.Contract Namespace


CompositeActionInput.Actions Property

CompositeActionInputActions Property
Gets or sets the enumerable collection of actions.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public IEnumerable<MonitorAction> Actions { get; set; }
Public Property Actions As IEnumerable(Of MonitorAction)
    Get
    Set
public:
property IEnumerable<MonitorAction^>^ Actions {
    IEnumerable<MonitorAction^>^ get ();
    void set (IEnumerable<MonitorAction^>^ value);
}
function get_Actions();
function set_Actions(value);

Property Value

Type: IEnumerable MonitorAction
The enumerable collection of actions.
See Also

Reference

CompositeActionInput Class
DoubleTake.Monitoring.Contract Namespace


CompositeActionInput.ParallelExecution Property

CompositeActionInputParallelExecution Property
Gets or sets a value indicating whether the actions are to be executed in parallel.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool ParallelExecution { get; set; }
Public Property ParallelExecution As Boolean
    Get
    Set
public:
property bool ParallelExecution {
    bool get ();
    void set (bool value);
}
function get_ParallelExecution();
function set_ParallelExecution(value);

Property Value

Type: Boolean
if the actions are to be executed in parallel; otherwise, .
Remarks
If this property is set to , the actions are executed synchronously in the order they exist in the Actions property.
See Also

Reference

CompositeActionInput Class
DoubleTake.Monitoring.Contract Namespace


CompositeActionResult Class

CompositeActionResult Class
Represents the results of a composite action.
Inheritance Hierarchy
SystemObject
DoubleTake.Monitoring.ContractActionResult
DoubleTake.Monitoring.ContractCompositeActionResult

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class CompositeActionResult : ActionResult
Public Class CompositeActionResult
    Inherits ActionResult
public ref class CompositeActionResult : public ActionResult
DoubleTake.Monitoring.Contract.CompositeActionResult = function();

Type.createClass(
    'DoubleTake.Monitoring.Contract.CompositeActionResult',
    DoubleTake.Monitoring.Contract.ActionResult);

The CompositeActionResult type exposes the following members.

Constructors
 | Name | Description
Public method | CompositeActionResult | Initializes a new instance of the CompositeActionResult class
Top
Properties
 | Name | Description
Public property | ActionResults | Gets or sets the action results.
Public property | Exception | Gets or sets the action exception. (Inherited from ActionResult.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from ActionResult.)
Top
See Also

Reference

DoubleTake.Monitoring.Contract Namespace


CompositeActionResult Constructor

CompositeActionResult Constructor
Initializes a new instance of the CompositeActionResult class

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public CompositeActionResult()
Public Sub New
public:
CompositeActionResult()
DoubleTake.Monitoring.Contract.CompositeActionResult = function();
See Also

Reference

CompositeActionResult Class
DoubleTake.Monitoring.Contract Namespace


CompositeActionResult Properties

CompositeActionResult Properties

The CompositeActionResult type exposes the following members.

Properties
 | Name | Description
Public property | ActionResults | Gets or sets the action results.
Public property | Exception | Gets or sets the action exception. (Inherited from ActionResult.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from ActionResult.)
Top
See Also

Reference

CompositeActionResult Class
DoubleTake.Monitoring.Contract Namespace


CompositeActionResult.ActionResults Property

CompositeActionResultActionResults Property
Gets or sets the action results.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public IEnumerable<ActionResult> ActionResults { get; set; }
Public Property ActionResults As IEnumerable(Of ActionResult)
    Get
    Set
public:
property IEnumerable<ActionResult^>^ ActionResults {
    IEnumerable<ActionResult^>^ get ();
    void set (IEnumerable<ActionResult^>^ value);
}
function get_ActionResults();
function set_ActionResults(value);

Property Value

Type: IEnumerable ActionResult
The action results.
See Also

Reference

CompositeActionResult Class
DoubleTake.Monitoring.Contract Namespace


CompositeQueryInput Class

CompositeQueryInput Class
Represents the input to a Composite query agent.
Inheritance Hierarchy
SystemObject
DoubleTake.Monitoring.ContractQueryInput
DoubleTake.Monitoring.ContractCompositeQueryInput

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class CompositeQueryInput : QueryInput
Public Class CompositeQueryInput
    Inherits QueryInput
public ref class CompositeQueryInput : public QueryInput
DoubleTake.Monitoring.Contract.CompositeQueryInput = function();

Type.createClass(
    'DoubleTake.Monitoring.Contract.CompositeQueryInput',
    DoubleTake.Monitoring.Contract.QueryInput);

The CompositeQueryInput type exposes the following members.

Constructors
 | Name | Description
Public method | CompositeQueryInput | Initializes a new instance of the CompositeQueryInput class
Top
Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the query. (Inherited from QueryInput.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from QueryInput.)
Public property | Operation | Gets or sets the mode of query aggregation.
Public property | ParallelExecution | Gets or sets a value indicating whether the queries are to be executed in parallel.
Public property | Queries | Gets or sets the enumerable collection of queries.
Top
See Also

Reference

DoubleTake.Monitoring.Contract Namespace


CompositeQueryInput Constructor

CompositeQueryInput Constructor
Initializes a new instance of the CompositeQueryInput class

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public CompositeQueryInput()
Public Sub New
public:
CompositeQueryInput()
DoubleTake.Monitoring.Contract.CompositeQueryInput = function();
See Also

Reference

CompositeQueryInput Class
DoubleTake.Monitoring.Contract Namespace


CompositeQueryInput Properties

CompositeQueryInput Properties

The CompositeQueryInput type exposes the following members.

Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the query. (Inherited from QueryInput.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from QueryInput.)
Public property | Operation | Gets or sets the mode of query aggregation.
Public property | ParallelExecution | Gets or sets a value indicating whether the queries are to be executed in parallel.
Public property | Queries | Gets or sets the enumerable collection of queries.
Top
See Also

Reference

CompositeQueryInput Class
DoubleTake.Monitoring.Contract Namespace


CompositeQueryInput.Operation Property

CompositeQueryInputOperation Property
Gets or sets the mode of query aggregation.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public CompositeQueryOperation Operation { get; set; }
Public Property Operation As CompositeQueryOperation
    Get
    Set
public:
property CompositeQueryOperation Operation {
    CompositeQueryOperation get ();
    void set (CompositeQueryOperation value);
}
function get_Operation();
function set_Operation(value);

Property Value

Type: CompositeQueryOperation
The mode.
See Also

Reference

CompositeQueryInput Class
DoubleTake.Monitoring.Contract Namespace


CompositeQueryInput.ParallelExecution Property

CompositeQueryInputParallelExecution Property
Gets or sets a value indicating whether the queries are to be executed in parallel.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool ParallelExecution { get; set; }
Public Property ParallelExecution As Boolean
    Get
    Set
public:
property bool ParallelExecution {
    bool get ();
    void set (bool value);
}
function get_ParallelExecution();
function set_ParallelExecution(value);

Property Value

Type: Boolean
if the queries are to be executed in parallel; otherwise, .
Remarks
If this property is set to
See Also

Reference

CompositeQueryInput Class
DoubleTake.Monitoring.Contract Namespace


CompositeQueryInput.Queries Property

CompositeQueryInputQueries Property
Gets or sets the enumerable collection of queries.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public MonitorQuery[] Queries { get; set; }
Public Property Queries As MonitorQuery()
    Get
    Set
public:
property array<MonitorQuery^>^ Queries {
    array<MonitorQuery^>^ get ();
    void set (array<MonitorQuery^>^ value);
}
function get_Queries();
function set_Queries(value);

Property Value

Type: MonitorQuery
The the numerable collection of queries.
See Also

Reference

CompositeQueryInput Class
DoubleTake.Monitoring.Contract Namespace


CompositeQueryOperation Enumeration

CompositeQueryOperation Enumeration
Defines how to evaluate a composite query.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public enum CompositeQueryOperation
Public Enumeration CompositeQueryOperation
public enum class CompositeQueryOperation
DoubleTake.Monitoring.Contract.CompositeQueryOperation = function();
DoubleTake.Monitoring.Contract.CompositeQueryOperation.createEnum('DoubleTake.Monitoring.Contract.CompositeQueryOperation', false);
Members
Member name | Value | Description
And | 0 | Conjunctive operation that fails the query if any of the queries fail.
Or | 1 | Disjunctive operation that fails the query if all of the queries fail.
See Also

Reference

DoubleTake.Monitoring.Contract Namespace


CompositeQueryResult Class

CompositeQueryResult Class
Represents the results of a composite query.
Inheritance Hierarchy
SystemObject
DoubleTake.Monitoring.ContractQueryResult
DoubleTake.Monitoring.ContractCompositeQueryResult

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class CompositeQueryResult : QueryResult
Public Class CompositeQueryResult
    Inherits QueryResult
public ref class CompositeQueryResult : public QueryResult
DoubleTake.Monitoring.Contract.CompositeQueryResult = function();

Type.createClass(
    'DoubleTake.Monitoring.Contract.CompositeQueryResult',
    DoubleTake.Monitoring.Contract.QueryResult);

The CompositeQueryResult type exposes the following members.

Constructors
 | Name | Description
Public method | CompositeQueryResult | Initializes a new instance of the CompositeQueryResult class
Top
Properties
 | Name | Description
Public property | Exception | Gets or sets the query exception. (Inherited from QueryResult.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from QueryResult.)
Public property | QueryResults | Gets or sets the query results.
Public property | Result | Gets or sets a value indicating whether or not the query was successful. (Inherited from QueryResult.)
Top
See Also

Reference

DoubleTake.Monitoring.Contract Namespace


CompositeQueryResult Constructor

CompositeQueryResult Constructor
Initializes a new instance of the CompositeQueryResult class

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public CompositeQueryResult()
Public Sub New
public:
CompositeQueryResult()
DoubleTake.Monitoring.Contract.CompositeQueryResult = function();
See Also

Reference

CompositeQueryResult Class
DoubleTake.Monitoring.Contract Namespace


CompositeQueryResult Properties

CompositeQueryResult Properties

The CompositeQueryResult type exposes the following members.

Properties
 | Name | Description
Public property | Exception | Gets or sets the query exception. (Inherited from QueryResult.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from QueryResult.)
Public property | QueryResults | Gets or sets the query results.
Public property | Result | Gets or sets a value indicating whether or not the query was successful. (Inherited from QueryResult.)
Top
See Also

Reference

CompositeQueryResult Class
DoubleTake.Monitoring.Contract Namespace


CompositeQueryResult.QueryResults Property

CompositeQueryResultQueryResults Property
Gets or sets the query results.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public IEnumerable<QueryResult> QueryResults { get; set; }
Public Property QueryResults As IEnumerable(Of QueryResult)
    Get
    Set
public:
property IEnumerable<QueryResult^>^ QueryResults {
    IEnumerable<QueryResult^>^ get ();
    void set (IEnumerable<QueryResult^>^ value);
}
function get_QueryResults();
function set_QueryResults(value);

Property Value

Type: IEnumerable QueryResult
The query results.
See Also

Reference

CompositeQueryResult Class
DoubleTake.Monitoring.Contract Namespace


DtscStatusQueryInput Class

DtscStatusQueryInput Class
Inheritance Hierarchy
SystemObject
DoubleTake.Monitoring.ContractQueryInput
DoubleTake.Monitoring.ContractDtscStatusQueryInput

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class DtscStatusQueryInput : QueryInput
Public Class DtscStatusQueryInput
    Inherits QueryInput
public ref class DtscStatusQueryInput : public QueryInput
DoubleTake.Monitoring.Contract.DtscStatusQueryInput = function();

Type.createClass(
    'DoubleTake.Monitoring.Contract.DtscStatusQueryInput',
    DoubleTake.Monitoring.Contract.QueryInput);

The DtscStatusQueryInput type exposes the following members.

Constructors
 | Name | Description
Public method | DtscStatusQueryInput | Initializes a new instance of the DtscStatusQueryInput class
Top
Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the query. (Inherited from QueryInput.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from QueryInput.)
Public property | replicationSetName |
Top
See Also

Reference

DoubleTake.Monitoring.Contract Namespace


DtscStatusQueryInput Constructor

DtscStatusQueryInput Constructor
Initializes a new instance of the DtscStatusQueryInput class

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public DtscStatusQueryInput()
Public Sub New
public:
DtscStatusQueryInput()
DoubleTake.Monitoring.Contract.DtscStatusQueryInput = function();
See Also

Reference

DtscStatusQueryInput Class
DoubleTake.Monitoring.Contract Namespace


DtscStatusQueryInput Properties

DtscStatusQueryInput Properties

The DtscStatusQueryInput type exposes the following members.

Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the query. (Inherited from QueryInput.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from QueryInput.)
Public property | replicationSetName |
Top
See Also

Reference

DtscStatusQueryInput Class
DoubleTake.Monitoring.Contract Namespace


DtscStatusQueryInput.replicationSetName Property

DtscStatusQueryInputreplicationSetName Property

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string replicationSetName { get; set; }
Public Property replicationSetName As String
    Get
    Set
public:
property String^ replicationSetName {
    String^ get ();
    void set (String^ value);
}
function get_replicationSetName();
function set_replicationSetName(value);

Property Value

Type: String
See Also

Reference

DtscStatusQueryInput Class
DoubleTake.Monitoring.Contract Namespace


DtscStatusQueryResult Class

DtscStatusQueryResult Class
Inheritance Hierarchy
SystemObject
DoubleTake.Monitoring.ContractQueryResult
DoubleTake.Monitoring.ContractDtscStatusQueryResult

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class DtscStatusQueryResult : QueryResult
Public Class DtscStatusQueryResult
    Inherits QueryResult
public ref class DtscStatusQueryResult : public QueryResult
DoubleTake.Monitoring.Contract.DtscStatusQueryResult = function();

Type.createClass(
    'DoubleTake.Monitoring.Contract.DtscStatusQueryResult',
    DoubleTake.Monitoring.Contract.QueryResult);

The DtscStatusQueryResult type exposes the following members.

Constructors
 | Name | Description
Public method | DtscStatusQueryResult | Initializes a new instance of the DtscStatusQueryResult class
Top
Properties
 | Name | Description
Public property | Exception | Gets or sets the query exception. (Inherited from QueryResult.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from QueryResult.)
Public property | OwningNode |
Public property | ResourceState |
Public property | Result | Gets or sets a value indicating whether or not the query was successful. (Inherited from QueryResult.)
Top
See Also

Reference

DoubleTake.Monitoring.Contract Namespace


DtscStatusQueryResult Constructor

DtscStatusQueryResult Constructor
Initializes a new instance of the DtscStatusQueryResult class

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public DtscStatusQueryResult()
Public Sub New
public:
DtscStatusQueryResult()
DoubleTake.Monitoring.Contract.DtscStatusQueryResult = function();
See Also

Reference

DtscStatusQueryResult Class
DoubleTake.Monitoring.Contract Namespace


DtscStatusQueryResult Properties

DtscStatusQueryResult Properties

The DtscStatusQueryResult type exposes the following members.

Properties
 | Name | Description
Public property | Exception | Gets or sets the query exception. (Inherited from QueryResult.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from QueryResult.)
Public property | OwningNode |
Public property | ResourceState |
Public property | Result | Gets or sets a value indicating whether or not the query was successful. (Inherited from QueryResult.)
Top
See Also

Reference

DtscStatusQueryResult Class
DoubleTake.Monitoring.Contract Namespace


DtscStatusQueryResult.OwningNode Property

DtscStatusQueryResultOwningNode Property

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string OwningNode { get; set; }
Public Property OwningNode As String
    Get
    Set
public:
property String^ OwningNode {
    String^ get ();
    void set (String^ value);
}
function get_OwningNode();
function set_OwningNode(value);

Property Value

Type: String
See Also

Reference

DtscStatusQueryResult Class
DoubleTake.Monitoring.Contract Namespace


DtscStatusQueryResult.ResourceState Property

DtscStatusQueryResultResourceState Property

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int ResourceState { get; set; }
Public Property ResourceState As Integer
    Get
    Set
public:
property int ResourceState {
    int get ();
    void set (int value);
}
function get_ResourceState();
function set_ResourceState(value);

Property Value

Type: Int32
See Also

Reference

DtscStatusQueryResult Class
DoubleTake.Monitoring.Contract Namespace


DTTargetResourceQueryInput Class

DTTargetResourceQueryInput Class
Inheritance Hierarchy
SystemObject
DoubleTake.Monitoring.ContractQueryInput
DoubleTake.Monitoring.ContractDTTargetResourceQueryInput

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class DTTargetResourceQueryInput : QueryInput
Public Class DTTargetResourceQueryInput
    Inherits QueryInput
public ref class DTTargetResourceQueryInput : public QueryInput
DoubleTake.Monitoring.Contract.DTTargetResourceQueryInput = function();

Type.createClass(
    'DoubleTake.Monitoring.Contract.DTTargetResourceQueryInput',
    DoubleTake.Monitoring.Contract.QueryInput);

The DTTargetResourceQueryInput type exposes the following members.

Constructors
 | Name | Description
Public method | DTTargetResourceQueryInput | Initializes a new instance of the DTTargetResourceQueryInput class
Top
Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the query. (Inherited from QueryInput.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from QueryInput.)
Public property | JobId |
Public property | ResourceName |
Public property | TargetHostName |
Top
See Also

Reference

DoubleTake.Monitoring.Contract Namespace


DTTargetResourceQueryInput Constructor

DTTargetResourceQueryInput Constructor
Initializes a new instance of the DTTargetResourceQueryInput class

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public DTTargetResourceQueryInput()
Public Sub New
public:
DTTargetResourceQueryInput()
DoubleTake.Monitoring.Contract.DTTargetResourceQueryInput = function();
See Also

Reference

DTTargetResourceQueryInput Class
DoubleTake.Monitoring.Contract Namespace


DTTargetResourceQueryInput Properties

DTTargetResourceQueryInput Properties

The DTTargetResourceQueryInput type exposes the following members.

Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the query. (Inherited from QueryInput.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from QueryInput.)
Public property | JobId |
Public property | ResourceName |
Public property | TargetHostName |
Top
See Also

Reference

DTTargetResourceQueryInput Class
DoubleTake.Monitoring.Contract Namespace


DTTargetResourceQueryInput.JobId Property

DTTargetResourceQueryInputJobId Property

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string JobId { get; set; }
Public Property JobId As String
    Get
    Set
public:
property String^ JobId {
    String^ get ();
    void set (String^ value);
}
function get_JobId();
function set_JobId(value);

Property Value

Type: String
See Also

Reference

DTTargetResourceQueryInput Class
DoubleTake.Monitoring.Contract Namespace


DTTargetResourceQueryInput.ResourceName Property

DTTargetResourceQueryInputResourceName Property

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string ResourceName { get; set; }
Public Property ResourceName As String
    Get
    Set
public:
property String^ ResourceName {
    String^ get ();
    void set (String^ value);
}
function get_ResourceName();
function set_ResourceName(value);

Property Value

Type: String
See Also

Reference

DTTargetResourceQueryInput Class
DoubleTake.Monitoring.Contract Namespace


DTTargetResourceQueryInput.TargetHostName Property

DTTargetResourceQueryInputTargetHostName Property

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string TargetHostName { get; set; }
Public Property TargetHostName As String
    Get
    Set
public:
property String^ TargetHostName {
    String^ get ();
    void set (String^ value);
}
function get_TargetHostName();
function set_TargetHostName(value);

Property Value

Type: String
See Also

Reference

DTTargetResourceQueryInput Class
DoubleTake.Monitoring.Contract Namespace


HeartbeatPingQueryInput Class

HeartbeatPingQueryInput Class
Represents the input to a Double-Take heartbeat ping query agent.
Inheritance Hierarchy
SystemObject
DoubleTake.Monitoring.ContractQueryInput
DoubleTake.Monitoring.ContractHeartbeatPingQueryInput

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class HeartbeatPingQueryInput : QueryInput
Public Class HeartbeatPingQueryInput
    Inherits QueryInput
public ref class HeartbeatPingQueryInput : public QueryInput
DoubleTake.Monitoring.Contract.HeartbeatPingQueryInput = function();

Type.createClass(
    'DoubleTake.Monitoring.Contract.HeartbeatPingQueryInput',
    DoubleTake.Monitoring.Contract.QueryInput);

The HeartbeatPingQueryInput type exposes the following members.

Constructors
 | Name | Description
Public method | HeartbeatPingQueryInput | Initializes a new instance of the HeartbeatPingQueryInput class
Top
Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the query. (Inherited from QueryInput.)
Public property | EnginePort | Gets or sets the engine port.
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from QueryInput.)
Public property | IPAddress | Gets or sets the IP address to ping for a heartbeat.
Top
See Also

Reference

DoubleTake.Monitoring.Contract Namespace


HeartbeatPingQueryInput Constructor

HeartbeatPingQueryInput Constructor
Initializes a new instance of the HeartbeatPingQueryInput class

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public HeartbeatPingQueryInput()
Public Sub New
public:
HeartbeatPingQueryInput()
DoubleTake.Monitoring.Contract.HeartbeatPingQueryInput = function();
See Also

Reference

HeartbeatPingQueryInput Class
DoubleTake.Monitoring.Contract Namespace


HeartbeatPingQueryInput Properties

HeartbeatPingQueryInput Properties

The HeartbeatPingQueryInput type exposes the following members.

Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the query. (Inherited from QueryInput.)
Public property | EnginePort | Gets or sets the engine port.
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from QueryInput.)
Public property | IPAddress | Gets or sets the IP address to ping for a heartbeat.
Top
See Also

Reference

HeartbeatPingQueryInput Class
DoubleTake.Monitoring.Contract Namespace


HeartbeatPingQueryInput.EnginePort Property

HeartbeatPingQueryInputEnginePort Property
Gets or sets the engine port.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Nullable<int> EnginePort { get; set; }
Public Property EnginePort As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> EnginePort {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
function get_EnginePort();
function set_EnginePort(value);

Property Value

Type: Nullable Int32
The engine port.
See Also

Reference

HeartbeatPingQueryInput Class
DoubleTake.Monitoring.Contract Namespace


HeartbeatPingQueryInput.IPAddress Property

HeartbeatPingQueryInputIPAddress Property
Gets or sets the IP address to ping for a heartbeat.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string IPAddress { get; set; }
Public Property IPAddress As String
    Get
    Set
public:
property String^ IPAddress {
    String^ get ();
    void set (String^ value);
}
function get_IPAddress();
function set_IPAddress(value);

Property Value

Type: String
The IP address to ping for a heartbeat.
See Also

Reference

HeartbeatPingQueryInput Class
DoubleTake.Monitoring.Contract Namespace


HeartbeatPingQueryResult Class

HeartbeatPingQueryResult Class
Represents the results of a heartbeat ping query.
Inheritance Hierarchy
SystemObject
DoubleTake.Monitoring.ContractQueryResult
DoubleTake.Monitoring.ContractHeartbeatPingQueryResult

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class HeartbeatPingQueryResult : QueryResult
Public Class HeartbeatPingQueryResult
    Inherits QueryResult
public ref class HeartbeatPingQueryResult : public QueryResult
DoubleTake.Monitoring.Contract.HeartbeatPingQueryResult = function();

Type.createClass(
    'DoubleTake.Monitoring.Contract.HeartbeatPingQueryResult',
    DoubleTake.Monitoring.Contract.QueryResult);

The HeartbeatPingQueryResult type exposes the following members.

Constructors
 | Name | Description
Public method | HeartbeatPingQueryResult | Initializes a new instance of the HeartbeatPingQueryResult class
Top
Properties
 | Name | Description
Public property | EnginePort | Gets or sets the engine port that was used to ping.
Public property | Exception | Gets or sets the query exception. (Inherited from QueryResult.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from QueryResult.)
Public property | IPAddress | Gets or sets the IP address that was pinged during this query.
Public property | Result | Gets or sets a value indicating whether or not the query was successful. (Inherited from QueryResult.)
Top
See Also

Reference

DoubleTake.Monitoring.Contract Namespace


HeartbeatPingQueryResult Constructor

HeartbeatPingQueryResult Constructor
Initializes a new instance of the HeartbeatPingQueryResult class

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public HeartbeatPingQueryResult()
Public Sub New
public:
HeartbeatPingQueryResult()
DoubleTake.Monitoring.Contract.HeartbeatPingQueryResult = function();
See Also

Reference

HeartbeatPingQueryResult Class
DoubleTake.Monitoring.Contract Namespace


HeartbeatPingQueryResult Properties

HeartbeatPingQueryResult Properties

The HeartbeatPingQueryResult type exposes the following members.

Properties
 | Name | Description
Public property | EnginePort | Gets or sets the engine port that was used to ping.
Public property | Exception | Gets or sets the query exception. (Inherited from QueryResult.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from QueryResult.)
Public property | IPAddress | Gets or sets the IP address that was pinged during this query.
Public property | Result | Gets or sets a value indicating whether or not the query was successful. (Inherited from QueryResult.)
Top
See Also

Reference

HeartbeatPingQueryResult Class
DoubleTake.Monitoring.Contract Namespace


HeartbeatPingQueryResult.EnginePort Property

HeartbeatPingQueryResultEnginePort Property
Gets or sets the engine port that was used to ping.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int EnginePort { get; set; }
Public Property EnginePort As Integer
    Get
    Set
public:
property int EnginePort {
    int get ();
    void set (int value);
}
function get_EnginePort();
function set_EnginePort(value);

Property Value

Type: Int32
The engine port that was used to ping.
See Also

Reference

HeartbeatPingQueryResult Class
DoubleTake.Monitoring.Contract Namespace


HeartbeatPingQueryResult.IPAddress Property

HeartbeatPingQueryResultIPAddress Property
Gets or sets the IP address that was pinged during this query.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string IPAddress { get; set; }
Public Property IPAddress As String
    Get
    Set
public:
property String^ IPAddress {
    String^ get ();
    void set (String^ value);
}
function get_IPAddress();
function set_IPAddress(value);

Property Value

Type: String
The IP address that was pinged during this query.
See Also

Reference

HeartbeatPingQueryResult Class
DoubleTake.Monitoring.Contract Namespace


IcmpPingQueryInput Class

IcmpPingQueryInput Class
Represents the input to an ICMP ping query agent.
Inheritance Hierarchy
SystemObject
DoubleTake.Monitoring.ContractQueryInput
DoubleTake.Monitoring.ContractIcmpPingQueryInput

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class IcmpPingQueryInput : QueryInput
Public Class IcmpPingQueryInput
    Inherits QueryInput
public ref class IcmpPingQueryInput : public QueryInput
DoubleTake.Monitoring.Contract.IcmpPingQueryInput = function();

Type.createClass(
    'DoubleTake.Monitoring.Contract.IcmpPingQueryInput',
    DoubleTake.Monitoring.Contract.QueryInput);

The IcmpPingQueryInput type exposes the following members.

Constructors
 | Name | Description
Public method | IcmpPingQueryInput | Initializes a new instance of the IcmpPingQueryInput class
Top
Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the query. (Inherited from QueryInput.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from QueryInput.)
Public property | NetworkId | Gets or sets the server name or IP address to ping.
Top
See Also

Reference

DoubleTake.Monitoring.Contract Namespace


IcmpPingQueryInput Constructor

IcmpPingQueryInput Constructor
Initializes a new instance of the IcmpPingQueryInput class

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public IcmpPingQueryInput()
Public Sub New
public:
IcmpPingQueryInput()
DoubleTake.Monitoring.Contract.IcmpPingQueryInput = function();
See Also

Reference

IcmpPingQueryInput Class
DoubleTake.Monitoring.Contract Namespace


IcmpPingQueryInput Properties

IcmpPingQueryInput Properties

The IcmpPingQueryInput type exposes the following members.

Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the query. (Inherited from QueryInput.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from QueryInput.)
Public property | NetworkId | Gets or sets the server name or IP address to ping.
Top
See Also

Reference

IcmpPingQueryInput Class
DoubleTake.Monitoring.Contract Namespace


IcmpPingQueryInput.NetworkId Property

IcmpPingQueryInputNetworkId Property
Gets or sets the server name or IP address to ping.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string NetworkId { get; set; }
Public Property NetworkId As String
    Get
    Set
public:
property String^ NetworkId {
    String^ get ();
    void set (String^ value);
}
function get_NetworkId();
function set_NetworkId(value);

Property Value

Type: String
The server name or IP address to ping.
See Also

Reference

IcmpPingQueryInput Class
DoubleTake.Monitoring.Contract Namespace


IcmpPingQueryResult Class

IcmpPingQueryResult Class
Represents the results of an ICMP ping query.
Inheritance Hierarchy
SystemObject
DoubleTake.Monitoring.ContractQueryResult
DoubleTake.Monitoring.ContractIcmpPingQueryResult

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class IcmpPingQueryResult : QueryResult
Public Class IcmpPingQueryResult
    Inherits QueryResult
public ref class IcmpPingQueryResult : public QueryResult
DoubleTake.Monitoring.Contract.IcmpPingQueryResult = function();

Type.createClass(
    'DoubleTake.Monitoring.Contract.IcmpPingQueryResult',
    DoubleTake.Monitoring.Contract.QueryResult);

The IcmpPingQueryResult type exposes the following members.

Constructors
 | Name | Description
Public method | IcmpPingQueryResult | Initializes a new instance of the IcmpPingQueryResult class
Top
Properties
 | Name | Description
Public property | Exception | Gets or sets the query exception. (Inherited from QueryResult.)
Public property | ExceptionDetail | Gets or sets the exception detail.
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from QueryResult.)
Public property | NetworkId | Gets or sets the network id that was pinged.
Public property | ReplyAddress | Gets or sets the IP address from which the reply was sent.
Public property | Result | Gets or sets a value indicating whether or not the query was successful. (Inherited from QueryResult.)
Public property | Roundtrip | Gets or sets the duration of the ICMP ping round-trip.
Public property | Status | Gets or sets the IPStatus from the ping reply as a string.
Top
See Also

Reference

DoubleTake.Monitoring.Contract Namespace


IcmpPingQueryResult Constructor

IcmpPingQueryResult Constructor
Initializes a new instance of the IcmpPingQueryResult class

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public IcmpPingQueryResult()
Public Sub New
public:
IcmpPingQueryResult()
DoubleTake.Monitoring.Contract.IcmpPingQueryResult = function();
See Also

Reference

IcmpPingQueryResult Class
DoubleTake.Monitoring.Contract Namespace


IcmpPingQueryResult Properties

IcmpPingQueryResult Properties

The IcmpPingQueryResult type exposes the following members.

Properties
 | Name | Description
Public property | Exception | Gets or sets the query exception. (Inherited from QueryResult.)
Public property | ExceptionDetail | Gets or sets the exception detail.
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from QueryResult.)
Public property | NetworkId | Gets or sets the network id that was pinged.
Public property | ReplyAddress | Gets or sets the IP address from which the reply was sent.
Public property | Result | Gets or sets a value indicating whether or not the query was successful. (Inherited from QueryResult.)
Public property | Roundtrip | Gets or sets the duration of the ICMP ping round-trip.
Public property | Status | Gets or sets the IPStatus from the ping reply as a string.
Top
See Also

Reference

IcmpPingQueryResult Class
DoubleTake.Monitoring.Contract Namespace


IcmpPingQueryResult.ExceptionDetail Property

IcmpPingQueryResultExceptionDetail Property
Gets or sets the exception detail.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExceptionDetail ExceptionDetail { get; set; }
Public Property ExceptionDetail As ExceptionDetail
    Get
    Set
public:
property ExceptionDetail^ ExceptionDetail {
    ExceptionDetail^ get ();
    void set (ExceptionDetail^ value);
}
function get_ExceptionDetail();
function set_ExceptionDetail(value);

Property Value

Type: ExceptionDetail
The exception detail.
Remarks
This property will only be non- if an exception was thrown by the ICMP ping operation.
See Also

Reference

IcmpPingQueryResult Class
DoubleTake.Monitoring.Contract Namespace


IcmpPingQueryResult.NetworkId Property

IcmpPingQueryResultNetworkId Property
Gets or sets the network id that was pinged.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string NetworkId { get; set; }
Public Property NetworkId As String
    Get
    Set
public:
property String^ NetworkId {
    String^ get ();
    void set (String^ value);
}
function get_NetworkId();
function set_NetworkId(value);

Property Value

Type: String
The network id that was pinged.
See Also

Reference

IcmpPingQueryResult Class
DoubleTake.Monitoring.Contract Namespace


IcmpPingQueryResult.ReplyAddress Property

IcmpPingQueryResultReplyAddress Property
Gets or sets the IP address from which the reply was sent.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string ReplyAddress { get; set; }
Public Property ReplyAddress As String
    Get
    Set
public:
property String^ ReplyAddress {
    String^ get ();
    void set (String^ value);
}
function get_ReplyAddress();
function set_ReplyAddress(value);

Property Value

Type: String
The IP address from which the reply was sent.
See Also

Reference

IcmpPingQueryResult Class
DoubleTake.Monitoring.Contract Namespace


IcmpPingQueryResult.Roundtrip Property

IcmpPingQueryResultRoundtrip Property
Gets or sets the duration of the ICMP ping round-trip.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public TimeSpan Roundtrip { get; set; }
Public Property Roundtrip As TimeSpan
    Get
    Set
public:
property TimeSpan Roundtrip {
    TimeSpan get ();
    void set (TimeSpan value);
}
function get_Roundtrip();
function set_Roundtrip(value);

Property Value

Type: TimeSpan
The duration of the ICMP ping round-trip.
See Also

Reference

IcmpPingQueryResult Class
DoubleTake.Monitoring.Contract Namespace


IcmpPingQueryResult.Status Property

IcmpPingQueryResultStatus Property
Gets or sets the IPStatus from the ping reply as a string.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Status { get; set; }
Public Property Status As String
    Get
    Set
public:
property String^ Status {
    String^ get ();
    void set (String^ value);
}
function get_Status();
function set_Status(value);

Property Value

Type: String
The IPStatus from the ping reply as a string.
See Also

Reference

IcmpPingQueryResult Class
DoubleTake.Monitoring.Contract Namespace


IMonitorManager Interface

IMonitorManager Interface
The interface to be used for creating, configuring and controlling monitors.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public interface IMonitorManager
Public Interface IMonitorManager
public interface class IMonitorManager
DoubleTake.Monitoring.Contract.IMonitorManager = function();
DoubleTake.Monitoring.Contract.IMonitorManager.createInterface('DoubleTake.Monitoring.Contract.IMonitorManager');

The IMonitorManager type exposes the following members.

Methods
 | Name | Description
Public method | BeginGetMonitorInfo | Begins an asynchronous operation to get the monitor info for a specific monitor.
Public method | BeginGetMonitors | Begins an asynchronous operation to the get information about all of the monitors.
Public method | BeginGetSimpleMonitorInfo | Begins an asynchronous operation to get the simple monitor info for a specific monitor.
Public method | BeginGetSimpleMonitors | Begins an asynchronous operation to the get simple information about all of the monitors.
Public method | Create | Creates a new monitor.
Public method | Delete | Removes a monitor.
Public method | Edit | Edits the monitor specified by the provided monitor id.
Public method | EndGetMonitorInfo | Completes an asynchronous operation to get the monitor info for a specific monitor.
Public method | EndGetMonitors | Completes an asynchronous operation to the get information about all of the monitors.
Public method | EndGetSimpleMonitorInfo | Completes an asynchronous operation to get the simple monitor info for a specific monitor.
Public method | EndGetSimpleMonitors | Completes an asynchronous operation to the get simple information about all of the monitors.
Public method | GetMonitorInfo | Gets the monitor info for a specific monitor.
Public method | GetMonitors | Gets all of the monitors.
Public method | GetSimpleMonitorInfo | Gets the simple monitor info for a specific monitor.
Public method | GetSimpleMonitors | Gets all of the monitors with a more abbreviated set of data for status purposes.
Public method | Start | Starts the monitor specified by the provided monitor id.
Public method | Stop | Stops the monitor specified by the provided monitor id.
Top
See Also

Reference

DoubleTake.Monitoring.Contract Namespace


IMonitorManager Methods

IMonitorManager Methods

The IMonitorManager type exposes the following members.

Methods
 | Name | Description
Public method | BeginGetMonitorInfo | Begins an asynchronous operation to get the monitor info for a specific monitor.
Public method | BeginGetMonitors | Begins an asynchronous operation to the get information about all of the monitors.
Public method | BeginGetSimpleMonitorInfo | Begins an asynchronous operation to get the simple monitor info for a specific monitor.
Public method | BeginGetSimpleMonitors | Begins an asynchronous operation to the get simple information about all of the monitors.
Public method | Create | Creates a new monitor.
Public method | Delete | Removes a monitor.
Public method | Edit | Edits the monitor specified by the provided monitor id.
Public method | EndGetMonitorInfo | Completes an asynchronous operation to get the monitor info for a specific monitor.
Public method | EndGetMonitors | Completes an asynchronous operation to the get information about all of the monitors.
Public method | EndGetSimpleMonitorInfo | Completes an asynchronous operation to get the simple monitor info for a specific monitor.
Public method | EndGetSimpleMonitors | Completes an asynchronous operation to the get simple information about all of the monitors.
Public method | GetMonitorInfo | Gets the monitor info for a specific monitor.
Public method | GetMonitors | Gets all of the monitors.
Public method | GetSimpleMonitorInfo | Gets the simple monitor info for a specific monitor.
Public method | GetSimpleMonitors | Gets all of the monitors with a more abbreviated set of data for status purposes.
Public method | Start | Starts the monitor specified by the provided monitor id.
Public method | Stop | Stops the monitor specified by the provided monitor id.
Top
See Also

Reference

IMonitorManager Interface
DoubleTake.Monitoring.Contract Namespace


IMonitorManager.BeginGetMonitorInfo Method

IMonitorManagerBeginGetMonitorInfo Method
Begins an asynchronous operation to get the monitor info for a specific monitor.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
IAsyncResult BeginGetMonitorInfo(
    Guid id,
    AsyncCallback callback,
    Object asyncState
)
Function BeginGetMonitorInfo (
    id As Guid,
    callback As AsyncCallback,
    asyncState As Object
) As IAsyncResult
IAsyncResult^ BeginGetMonitorInfo(
    Guid id,
    AsyncCallback^ callback,
    Object^ asyncState
)
function BeginGetMonitorInfo(id, callback, asyncState);

Parameters

id
Type: SystemGuid
The id that specifies a monitor.
callback
Type: SystemAsyncCallback
The AsyncCallback delegate that receives notification of the completion of this asynchronous operation.
asyncState
Type: SystemObject
An object, specified by the application, that contains state information associated with this asynchronous operation.

Return Value

Type: IAsyncResult
The IAsyncResult that references this asynchronous operation.
See Also

Reference

IMonitorManager Interface
DoubleTake.Monitoring.Contract Namespace


IMonitorManager.BeginGetMonitors Method

IMonitorManagerBeginGetMonitors Method
Begins an asynchronous operation to the get information about all of the monitors.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
IAsyncResult BeginGetMonitors(
    AsyncCallback callback,
    Object asyncState
)
Function BeginGetMonitors (
    callback As AsyncCallback,
    asyncState As Object
) As IAsyncResult
IAsyncResult^ BeginGetMonitors(
    AsyncCallback^ callback,
    Object^ asyncState
)
function BeginGetMonitors(callback, asyncState);

Parameters

callback
Type: SystemAsyncCallback
The AsyncCallback delegate that receives notification of the completion of this asynchronous operation.
asyncState
Type: SystemObject
An object, specified by the application, that contains state information associated with this asynchronous operation.

Return Value

Type: IAsyncResult
The IAsyncResult that references this asynchronous operation.
See Also

Reference

IMonitorManager Interface
DoubleTake.Monitoring.Contract Namespace


IMonitorManager.BeginGetSimpleMonitorInfo Method

IMonitorManagerBeginGetSimpleMonitorInfo Method
Begins an asynchronous operation to get the simple monitor info for a specific monitor.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
IAsyncResult BeginGetSimpleMonitorInfo(
    Guid id,
    AsyncCallback callback,
    Object asyncState
)
Function BeginGetSimpleMonitorInfo (
    id As Guid,
    callback As AsyncCallback,
    asyncState As Object
) As IAsyncResult
IAsyncResult^ BeginGetSimpleMonitorInfo(
    Guid id,
    AsyncCallback^ callback,
    Object^ asyncState
)
function BeginGetSimpleMonitorInfo(id, callback, asyncState);

Parameters

id
Type: SystemGuid
The id that specifies a monitor.
callback
Type: SystemAsyncCallback
The AsyncCallback delegate that receives notification of the completion of this asynchronous operation.
asyncState
Type: SystemObject
An object, specified by the application, that contains state information associated with this asynchronous operation.

Return Value

Type: IAsyncResult
The IAsyncResult that references this asynchronous operation.
See Also

Reference

IMonitorManager Interface
DoubleTake.Monitoring.Contract Namespace


IMonitorManager.BeginGetSimpleMonitors Method

IMonitorManagerBeginGetSimpleMonitors Method
Begins an asynchronous operation to the get simple information about all of the monitors.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
IAsyncResult BeginGetSimpleMonitors(
    AsyncCallback callback,
    Object asyncState
)
Function BeginGetSimpleMonitors (
    callback As AsyncCallback,
    asyncState As Object
) As IAsyncResult
IAsyncResult^ BeginGetSimpleMonitors(
    AsyncCallback^ callback,
    Object^ asyncState
)
function BeginGetSimpleMonitors(callback, asyncState);

Parameters

callback
Type: SystemAsyncCallback
The AsyncCallback delegate that receives notification of the completion of this asynchronous operation.
asyncState
Type: SystemObject
An object, specified by the application, that contains state information associated with this asynchronous operation.

Return Value

Type: IAsyncResult
The IAsyncResult that references this asynchronous operation.
See Also

Reference

IMonitorManager Interface
DoubleTake.Monitoring.Contract Namespace


IMonitorManager.Create Method

IMonitorManagerCreate Method
Creates a new monitor.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
Guid Create(
    MonitorOptions options
)
Function Create (
    options As MonitorOptions
) As Guid
Guid Create(
    MonitorOptions^ options
)
function Create(options);

Parameters

options
Type: DoubleTake.Monitoring.ContractMonitorOptions
The monitor options.

Return Value

Type: Guid
A GUID representing the id of the new monitor.
See Also

Reference

IMonitorManager Interface
DoubleTake.Monitoring.Contract Namespace


IMonitorManager.Delete Method

IMonitorManagerDelete Method
Removes a monitor.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
bool Delete(
    Guid id
)
Function Delete (
    id As Guid
) As Boolean
bool Delete(
    Guid id
)
function Delete(id);

Parameters

id
Type: SystemGuid
The monitor id.

Return Value

Type: Boolean
if the monitor was found and deleted; otherwise, .
See Also

Reference

IMonitorManager Interface
DoubleTake.Monitoring.Contract Namespace


IMonitorManager.Edit Method

IMonitorManagerEdit Method
Edits the monitor specified by the provided monitor id.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
void Edit(
    Guid id,
    MonitorOptions newOptions
)
Sub Edit (
    id As Guid,
    newOptions As MonitorOptions
)
void Edit(
    Guid id,
    MonitorOptions^ newOptions
)
function Edit(id, newOptions);

Parameters

id
Type: SystemGuid
The id of the monitor.
newOptions
Type: DoubleTake.Monitoring.ContractMonitorOptions
The new options.
See Also

Reference

IMonitorManager Interface
DoubleTake.Monitoring.Contract Namespace


IMonitorManager.EndGetMonitorInfo Method

IMonitorManagerEndGetMonitorInfo Method
Completes an asynchronous operation to get the monitor info for a specific monitor.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
MonitorInfo EndGetMonitorInfo(
    IAsyncResult result
)
Function EndGetMonitorInfo (
    result As IAsyncResult
) As MonitorInfo
MonitorInfo^ EndGetMonitorInfo(
    IAsyncResult^ result
)
function EndGetMonitorInfo(result);

Parameters

result
Type: SystemIAsyncResult
The IAsyncResult that is returned by a call to the BeginGetMonitorInfo(Guid, AsyncCallback, Object) method.

Return Value

Type: MonitorInfo
The MonitorInfo for the specific monitor.
See Also

Reference

IMonitorManager Interface
DoubleTake.Monitoring.Contract Namespace


IMonitorManager.EndGetMonitors Method

IMonitorManagerEndGetMonitors Method
Completes an asynchronous operation to the get information about all of the monitors.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
IEnumerable<MonitorInfo> EndGetMonitors(
    IAsyncResult result
)
Function EndGetMonitors (
    result As IAsyncResult
) As IEnumerable(Of MonitorInfo)
IEnumerable<MonitorInfo^>^ EndGetMonitors(
    IAsyncResult^ result
)
function EndGetMonitors(result);

Parameters

result
Type: SystemIAsyncResult
The IAsyncResult that is returned by a call to the BeginGetMonitorInfo(Guid, AsyncCallback, Object) method.

Return Value

Type: IEnumerable MonitorInfo
An enumerable collection of MonitorInfo instances.
See Also

Reference

IMonitorManager Interface
DoubleTake.Monitoring.Contract Namespace


IMonitorManager.EndGetSimpleMonitorInfo Method

IMonitorManagerEndGetSimpleMonitorInfo Method
Completes an asynchronous operation to get the simple monitor info for a specific monitor.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
SimpleMonitorInfo EndGetSimpleMonitorInfo(
    IAsyncResult result
)
Function EndGetSimpleMonitorInfo (
    result As IAsyncResult
) As SimpleMonitorInfo
SimpleMonitorInfo^ EndGetSimpleMonitorInfo(
    IAsyncResult^ result
)
function EndGetSimpleMonitorInfo(result);

Parameters

result
Type: SystemIAsyncResult
The IAsyncResult that is returned by a call to the BeginGetSimpleMonitorInfo(Guid, AsyncCallback, Object) method.

Return Value

Type: SimpleMonitorInfo
The MonitorInfo for the specific monitor.
See Also

Reference

IMonitorManager Interface
DoubleTake.Monitoring.Contract Namespace


IMonitorManager.EndGetSimpleMonitors Method

IMonitorManagerEndGetSimpleMonitors Method
Completes an asynchronous operation to the get simple information about all of the monitors.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
IEnumerable<SimpleMonitorInfo> EndGetSimpleMonitors(
    IAsyncResult result
)
Function EndGetSimpleMonitors (
    result As IAsyncResult
) As IEnumerable(Of SimpleMonitorInfo)
IEnumerable<SimpleMonitorInfo^>^ EndGetSimpleMonitors(
    IAsyncResult^ result
)
function EndGetSimpleMonitors(result);

Parameters

result
Type: SystemIAsyncResult
The IAsyncResult that is returned by a call to the BeginGetMonitorInfo(Guid, AsyncCallback, Object) method.

Return Value

Type: IEnumerable SimpleMonitorInfo
An enumerable collection of SimpleMonitorInfo instances.
See Also

Reference

IMonitorManager Interface
DoubleTake.Monitoring.Contract Namespace


IMonitorManager.GetMonitorInfo Method

IMonitorManagerGetMonitorInfo Method
Gets the monitor info for a specific monitor.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
MonitorInfo GetMonitorInfo(
    Guid id
)
Function GetMonitorInfo (
    id As Guid
) As MonitorInfo
MonitorInfo^ GetMonitorInfo(
    Guid id
)
function GetMonitorInfo(id);

Parameters

id
Type: SystemGuid
The monitor id.

Return Value

Type: MonitorInfo
See Also

Reference

IMonitorManager Interface
DoubleTake.Monitoring.Contract Namespace


IMonitorManager.GetMonitors Method

IMonitorManagerGetMonitors Method
Gets all of the monitors.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
IEnumerable<MonitorInfo> GetMonitors()
Function GetMonitors As IEnumerable(Of MonitorInfo)
IEnumerable<MonitorInfo^>^ GetMonitors()
function GetMonitors();

Return Value

Type: IEnumerable MonitorInfo
An enumerable collection of MonitorInfo.
See Also

Reference

IMonitorManager Interface
DoubleTake.Monitoring.Contract Namespace


IMonitorManager.GetSimpleMonitorInfo Method

IMonitorManagerGetSimpleMonitorInfo Method
Gets the simple monitor info for a specific monitor.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
SimpleMonitorInfo GetSimpleMonitorInfo(
    Guid id
)
Function GetSimpleMonitorInfo (
    id As Guid
) As SimpleMonitorInfo
SimpleMonitorInfo^ GetSimpleMonitorInfo(
    Guid id
)
function GetSimpleMonitorInfo(id);

Parameters

id
Type: SystemGuid
The monitor id.

Return Value

Type: SimpleMonitorInfo
See Also

Reference

IMonitorManager Interface
DoubleTake.Monitoring.Contract Namespace


IMonitorManager.GetSimpleMonitors Method

IMonitorManagerGetSimpleMonitors Method
Gets all of the monitors with a more abbreviated set of data for status purposes.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
IEnumerable<SimpleMonitorInfo> GetSimpleMonitors()
Function GetSimpleMonitors As IEnumerable(Of SimpleMonitorInfo)
IEnumerable<SimpleMonitorInfo^>^ GetSimpleMonitors()
function GetSimpleMonitors();

Return Value

Type: IEnumerable SimpleMonitorInfo
An enumerable collection of SimpleMonitorInfo.
See Also

Reference

IMonitorManager Interface
DoubleTake.Monitoring.Contract Namespace


IMonitorManager.Start Method

IMonitorManagerStart Method
Starts the monitor specified by the provided monitor id.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
void Start(
    Guid id
)
Sub Start (
    id As Guid
)
void Start(
    Guid id
)
function Start(id);

Parameters

id
Type: SystemGuid
The GUID.
See Also

Reference

IMonitorManager Interface
DoubleTake.Monitoring.Contract Namespace


IMonitorManager.Stop Method

IMonitorManagerStop Method
Stops the monitor specified by the provided monitor id.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
void Stop(
    Guid id
)
Sub Stop (
    id As Guid
)
void Stop(
    Guid id
)
function Stop(id);

Parameters

id
Type: SystemGuid
The GUID.
See Also

Reference

IMonitorManager Interface
DoubleTake.Monitoring.Contract Namespace


LogActionInput Class

LogActionInput Class
Represents the input to a log action.
Inheritance Hierarchy
SystemObject
DoubleTake.Monitoring.ContractActionInput
DoubleTake.Monitoring.ContractLogActionInput

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class LogActionInput : ActionInput
Public Class LogActionInput
    Inherits ActionInput
public ref class LogActionInput : public ActionInput
DoubleTake.Monitoring.Contract.LogActionInput = function();

Type.createClass(
    'DoubleTake.Monitoring.Contract.LogActionInput',
    DoubleTake.Monitoring.Contract.ActionInput);

The LogActionInput type exposes the following members.

Constructors
 | Name | Description
Public method | LogActionInput | Initializes a new instance of the LogActionInput class
Top
Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the action. (Inherited from ActionInput.)
Public property | EventType |
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from ActionInput.)
Public property | Message |
Public property | MessageFormatParameters |
Public property | QueryResult | Gets or sets the query result. (Inherited from ActionInput.)
Top
See Also

Reference

DoubleTake.Monitoring.Contract Namespace


LogActionInput Constructor

LogActionInput Constructor
Initializes a new instance of the LogActionInput class

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public LogActionInput()
Public Sub New
public:
LogActionInput()
DoubleTake.Monitoring.Contract.LogActionInput = function();
See Also

Reference

LogActionInput Class
DoubleTake.Monitoring.Contract Namespace


LogActionInput Properties

LogActionInput Properties

The LogActionInput type exposes the following members.

Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the action. (Inherited from ActionInput.)
Public property | EventType |
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from ActionInput.)
Public property | Message |
Public property | MessageFormatParameters |
Public property | QueryResult | Gets or sets the query result. (Inherited from ActionInput.)
Top
See Also

Reference

LogActionInput Class
DoubleTake.Monitoring.Contract Namespace


LogActionInput.EventType Property

LogActionInputEventType Property

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public TraceEventType EventType { get; set; }
Public Property EventType As TraceEventType
    Get
    Set
public:
property TraceEventType EventType {
    TraceEventType get ();
    void set (TraceEventType value);
}
function get_EventType();
function set_EventType(value);

Property Value

Type: TraceEventType
See Also

Reference

LogActionInput Class
DoubleTake.Monitoring.Contract Namespace


LogActionInput.Message Property

LogActionInputMessage Property

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Message { get; set; }
Public Property Message As String
    Get
    Set
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}
function get_Message();
function set_Message(value);

Property Value

Type: String
See Also

Reference

LogActionInput Class
DoubleTake.Monitoring.Contract Namespace


LogActionInput.MessageFormatParameters Property

LogActionInputMessageFormatParameters Property

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string[] MessageFormatParameters { get; set; }
Public Property MessageFormatParameters As String()
    Get
    Set
public:
property array<String^>^ MessageFormatParameters {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
function get_MessageFormatParameters();
function set_MessageFormatParameters(value);

Property Value

Type: String
See Also

Reference

LogActionInput Class
DoubleTake.Monitoring.Contract Namespace


MonitorAction Class

MonitorAction Class
Represents an action that is run in the context of a monitor.
Inheritance Hierarchy
SystemObject
DoubleTake.Monitoring.ContractMonitorAction

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class MonitorAction : IExtensibleDataObject
Public Class MonitorAction
    Implements IExtensibleDataObject
public ref class MonitorAction : IExtensibleDataObject
DoubleTake.Monitoring.Contract.MonitorAction = function();

Type.createClass(
    'DoubleTake.Monitoring.Contract.MonitorAction',
    null,
    IExtensibleDataObject);

The MonitorAction type exposes the following members.

Constructors
 | Name | Description
Public method | MonitorAction | Initializes a new instance of the MonitorAction class
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Input | Gets or sets the input arguments.
Public property | Name | Gets or sets the name.
Public property | RemoteServer | Gets or sets the remote server on which to run this action. Set this to to run the action locally.
Public property | RemoteServerCredentials |
Public property | RemoteServerUri |
Public property | Timeout | Gets or sets the timeout.
Public property | UniqueId | Gets or sets the unique id for this query.
Top
See Also

Reference

DoubleTake.Monitoring.Contract Namespace


MonitorAction Constructor

MonitorAction Constructor
Initializes a new instance of the MonitorAction class

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public MonitorAction()
Public Sub New
public:
MonitorAction()
DoubleTake.Monitoring.Contract.MonitorAction = function();
See Also

Reference

MonitorAction Class
DoubleTake.Monitoring.Contract Namespace


MonitorAction Properties

MonitorAction Properties

The MonitorAction type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Input | Gets or sets the input arguments.
Public property | Name | Gets or sets the name.
Public property | RemoteServer | Gets or sets the remote server on which to run this action. Set this to to run the action locally.
Public property | RemoteServerCredentials |
Public property | RemoteServerUri |
Public property | Timeout | Gets or sets the timeout.
Public property | UniqueId | Gets or sets the unique id for this query.
Top
See Also

Reference

MonitorAction Class
DoubleTake.Monitoring.Contract Namespace


MonitorAction.ExtensionData Property

MonitorActionExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

MonitorAction Class
DoubleTake.Monitoring.Contract Namespace


MonitorAction.Input Property

MonitorActionInput Property
Gets or sets the input arguments.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ActionInput Input { get; set; }
Public Property Input As ActionInput
    Get
    Set
public:
property ActionInput^ Input {
    ActionInput^ get ();
    void set (ActionInput^ value);
}
function get_Input();
function set_Input(value);

Property Value

Type: ActionInput
The input arguments.
See Also

Reference

MonitorAction Class
DoubleTake.Monitoring.Contract Namespace


MonitorAction.Name Property

MonitorActionName Property
Gets or sets the name.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
function get_Name();
function set_Name(value);

Property Value

Type: String
The name.
See Also

Reference

MonitorAction Class
DoubleTake.Monitoring.Contract Namespace


MonitorAction.RemoteServer Property

MonitorActionRemoteServer Property
Gets or sets the remote server on which to run this action. Set this to to run the action locally.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Uri RemoteServer { get; set; }
Public Property RemoteServer As Uri
    Get
    Set
public:
property Uri^ RemoteServer {
    Uri^ get ();
    void set (Uri^ value);
}
function get_RemoteServer();
function set_RemoteServer(value);

Property Value

Type: Uri
The remote server.
See Also

Reference

MonitorAction Class
DoubleTake.Monitoring.Contract Namespace


MonitorAction.RemoteServerCredentials Property

MonitorActionRemoteServerCredentials Property

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Credentials RemoteServerCredentials { get; }
Public ReadOnly Property RemoteServerCredentials As Credentials
    Get
public:
property Credentials^ RemoteServerCredentials {
    Credentials^ get ();
}
function get_RemoteServerCredentials();

Property Value

Type: Credentials
See Also

Reference

MonitorAction Class
DoubleTake.Monitoring.Contract Namespace


MonitorAction.RemoteServerUri Property

MonitorActionRemoteServerUri Property

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Uri RemoteServerUri { get; }
Public ReadOnly Property RemoteServerUri As Uri
    Get
public:
property Uri^ RemoteServerUri {
    Uri^ get ();
}
function get_RemoteServerUri();

Property Value

Type: Uri
See Also

Reference

MonitorAction Class
DoubleTake.Monitoring.Contract Namespace


MonitorAction.Timeout Property

MonitorActionTimeout Property
Gets or sets the timeout.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public TimeSpan Timeout { get; set; }
Public Property Timeout As TimeSpan
    Get
    Set
public:
property TimeSpan Timeout {
    TimeSpan get ();
    void set (TimeSpan value);
}
function get_Timeout();
function set_Timeout(value);

Property Value

Type: TimeSpan
The timeout.
See Also

Reference

MonitorAction Class
DoubleTake.Monitoring.Contract Namespace


MonitorAction.UniqueId Property

MonitorActionUniqueId Property
Gets or sets the unique id for this query.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Guid UniqueId { get; set; }
Public Property UniqueId As Guid
    Get
    Set
public:
property Guid UniqueId {
    Guid get ();
    void set (Guid value);
}
function get_UniqueId();
function set_UniqueId(value);

Property Value

Type: Guid
The unique id.
See Also

Reference

MonitorAction Class
DoubleTake.Monitoring.Contract Namespace


MonitorActivity Class

MonitorActivity Class
This class represents one node in a monitor decision/action tree.
Inheritance Hierarchy
SystemObject
DoubleTake.Monitoring.ContractMonitorActivity

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class MonitorActivity : IExtensibleDataObject
Public Class MonitorActivity
    Implements IExtensibleDataObject
public ref class MonitorActivity : IExtensibleDataObject
DoubleTake.Monitoring.Contract.MonitorActivity = function();

Type.createClass(
    'DoubleTake.Monitoring.Contract.MonitorActivity',
    null,
    IExtensibleDataObject);

The MonitorActivity type exposes the following members.

Constructors
 | Name | Description
Public method | MonitorActivity | Initializes a new instance of the MonitorActivity class
Top
Properties
 | Name | Description
Public property | CorrectiveAction | Gets or sets the corrective action to take when the query fails.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | FailureBranch | Gets or sets the activity to branch to when the query failed.
Public property | Name | Gets or sets the name of the activity.
Public property | NegateQueryResult | Gets or sets a value indicating whether to negate the query result when navigating the decision/action tree.
Public property | Query | Gets or sets the query.
Public property | RepeatCount | Gets or sets the number of times to repeat the query and corrective action pair of this activity when it fails.
Public property | SuccessBranch | Gets or sets the activity to branch to when the query succeeded.
Top
See Also

Reference

DoubleTake.Monitoring.Contract Namespace


MonitorActivity Constructor

MonitorActivity Constructor
Initializes a new instance of the MonitorActivity class

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public MonitorActivity()
Public Sub New
public:
MonitorActivity()
DoubleTake.Monitoring.Contract.MonitorActivity = function();
See Also

Reference

MonitorActivity Class
DoubleTake.Monitoring.Contract Namespace


MonitorActivity Properties

MonitorActivity Properties

The MonitorActivity type exposes the following members.

Properties
 | Name | Description
Public property | CorrectiveAction | Gets or sets the corrective action to take when the query fails.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | FailureBranch | Gets or sets the activity to branch to when the query failed.
Public property | Name | Gets or sets the name of the activity.
Public property | NegateQueryResult | Gets or sets a value indicating whether to negate the query result when navigating the decision/action tree.
Public property | Query | Gets or sets the query.
Public property | RepeatCount | Gets or sets the number of times to repeat the query and corrective action pair of this activity when it fails.
Public property | SuccessBranch | Gets or sets the activity to branch to when the query succeeded.
Top
See Also

Reference

MonitorActivity Class
DoubleTake.Monitoring.Contract Namespace


MonitorActivity.CorrectiveAction Property

MonitorActivityCorrectiveAction Property
Gets or sets the corrective action to take when the query fails.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public MonitorAction CorrectiveAction { get; set; }
Public Property CorrectiveAction As MonitorAction
    Get
    Set
public:
property MonitorAction^ CorrectiveAction {
    MonitorAction^ get ();
    void set (MonitorAction^ value);
}
function get_CorrectiveAction();
function set_CorrectiveAction(value);

Property Value

Type: MonitorAction
A MonitorAction representing the action to take when the query fails.
See Also

Reference

MonitorActivity Class
DoubleTake.Monitoring.Contract Namespace


MonitorActivity.ExtensionData Property

MonitorActivityExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

MonitorActivity Class
DoubleTake.Monitoring.Contract Namespace


MonitorActivity.FailureBranch Property

MonitorActivityFailureBranch Property
Gets or sets the activity to branch to when the query failed.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public MonitorActivity FailureBranch { get; set; }
Public Property FailureBranch As MonitorActivity
    Get
    Set
public:
property MonitorActivity^ FailureBranch {
    MonitorActivity^ get ();
    void set (MonitorActivity^ value);
}
function get_FailureBranch();
function set_FailureBranch(value);

Property Value

Type: MonitorActivity
A MonitorActivity representing the activity to execute on query failure.
See Also

Reference

MonitorActivity Class
DoubleTake.Monitoring.Contract Namespace


MonitorActivity.Name Property

MonitorActivityName Property
Gets or sets the name of the activity.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
function get_Name();
function set_Name(value);

Property Value

Type: String
The name of the activity.
See Also

Reference

MonitorActivity Class
DoubleTake.Monitoring.Contract Namespace


MonitorActivity.NegateQueryResult Property

MonitorActivityNegateQueryResult Property
Gets or sets a value indicating whether to negate the query result when navigating the decision/action tree.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool NegateQueryResult { get; set; }
Public Property NegateQueryResult As Boolean
    Get
    Set
public:
property bool NegateQueryResult {
    bool get ();
    void set (bool value);
}
function get_NegateQueryResult();
function set_NegateQueryResult(value);

Property Value

Type: Boolean
to negate the query result; otherwise, .
See Also

Reference

MonitorActivity Class
DoubleTake.Monitoring.Contract Namespace


MonitorActivity.Query Property

MonitorActivityQuery Property
Gets or sets the query.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public MonitorQuery Query { get; set; }
Public Property Query As MonitorQuery
    Get
    Set
public:
property MonitorQuery^ Query {
    MonitorQuery^ get ();
    void set (MonitorQuery^ value);
}
function get_Query();
function set_Query(value);

Property Value

Type: MonitorQuery
The query.
See Also

Reference

MonitorActivity Class
DoubleTake.Monitoring.Contract Namespace


MonitorActivity.RepeatCount Property

MonitorActivityRepeatCount Property
Gets or sets the number of times to repeat the query and corrective action pair of this activity when it fails.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int RepeatCount { get; set; }
Public Property RepeatCount As Integer
    Get
    Set
public:
property int RepeatCount {
    int get ();
    void set (int value);
}
function get_RepeatCount();
function set_RepeatCount(value);

Property Value

Type: Int32
The repeat count.
See Also

Reference

MonitorActivity Class
DoubleTake.Monitoring.Contract Namespace


MonitorActivity.SuccessBranch Property

MonitorActivitySuccessBranch Property
Gets or sets the activity to branch to when the query succeeded.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public MonitorActivity SuccessBranch { get; set; }
Public Property SuccessBranch As MonitorActivity
    Get
    Set
public:
property MonitorActivity^ SuccessBranch {
    MonitorActivity^ get ();
    void set (MonitorActivity^ value);
}
function get_SuccessBranch();
function set_SuccessBranch(value);

Property Value

Type: MonitorActivity
A MonitorActivity representing the activity to execute on query success.
See Also

Reference

MonitorActivity Class
DoubleTake.Monitoring.Contract Namespace


MonitorInfo Class

MonitorInfo Class
This class represents a complete definition of a monitor decision-action tree object.
Inheritance Hierarchy
SystemObject
DoubleTake.Monitoring.ContractMonitorInfo

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class MonitorInfo : IExtensibleDataObject
Public Class MonitorInfo
    Implements IExtensibleDataObject
public ref class MonitorInfo : IExtensibleDataObject
DoubleTake.Monitoring.Contract.MonitorInfo = function();

Type.createClass(
    'DoubleTake.Monitoring.Contract.MonitorInfo',
    null,
    IExtensibleDataObject);

The MonitorInfo type exposes the following members.

Constructors
 | Name | Description
Public method | MonitorInfo | Initializes a new instance of the MonitorInfo class
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Id | Gets or sets the GUID.
Public property | LoadedFromDisk | Gets or sets a value indicating whether this info was loaded from disk.
Public property | Options | Gets or sets the options.
Public property | Status | Gets or sets the status.
Top
See Also

Reference

DoubleTake.Monitoring.Contract Namespace


MonitorInfo Constructor

MonitorInfo Constructor
Initializes a new instance of the MonitorInfo class

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public MonitorInfo()
Public Sub New
public:
MonitorInfo()
DoubleTake.Monitoring.Contract.MonitorInfo = function();
See Also

Reference

MonitorInfo Class
DoubleTake.Monitoring.Contract Namespace


MonitorInfo Properties

MonitorInfo Properties

The MonitorInfo type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Id | Gets or sets the GUID.
Public property | LoadedFromDisk | Gets or sets a value indicating whether this info was loaded from disk.
Public property | Options | Gets or sets the options.
Public property | Status | Gets or sets the status.
Top
See Also

Reference

MonitorInfo Class
DoubleTake.Monitoring.Contract Namespace


MonitorInfo.ExtensionData Property

MonitorInfoExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

MonitorInfo Class
DoubleTake.Monitoring.Contract Namespace


MonitorInfo.Id Property

MonitorInfoId Property
Gets or sets the GUID.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Guid Id { get; set; }
Public Property Id As Guid
    Get
    Set
public:
property Guid Id {
    Guid get ();
    void set (Guid value);
}
function get_Id();
function set_Id(value);

Property Value

Type: Guid
The GUID.
See Also

Reference

MonitorInfo Class
DoubleTake.Monitoring.Contract Namespace


MonitorInfo.LoadedFromDisk Property

MonitorInfoLoadedFromDisk Property
Gets or sets a value indicating whether this info was loaded from disk.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool LoadedFromDisk { get; set; }
Public Property LoadedFromDisk As Boolean
    Get
    Set
public:
property bool LoadedFromDisk {
    bool get ();
    void set (bool value);
}
function get_LoadedFromDisk();
function set_LoadedFromDisk(value);

Property Value

Type: Boolean
if this info was loaded from disk; otherwise, .
Remarks
This provides a hint to the monitor and monitor factory that specialized logic for loading is to be exercised and not the specialized logic for creating. This property is not persisted to disk or sent across the wire.
See Also

Reference

MonitorInfo Class
DoubleTake.Monitoring.Contract Namespace


MonitorInfo.Options Property

MonitorInfoOptions Property
Gets or sets the options.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public MonitorOptions Options { get; set; }
Public Property Options As MonitorOptions
    Get
    Set
public:
property MonitorOptions^ Options {
    MonitorOptions^ get ();
    void set (MonitorOptions^ value);
}
function get_Options();
function set_Options(value);

Property Value

Type: MonitorOptions
The options.
See Also

Reference

MonitorInfo Class
DoubleTake.Monitoring.Contract Namespace


MonitorInfo.Status Property

MonitorInfoStatus Property
Gets or sets the status.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public MonitorStatus Status { get; set; }
Public Property Status As MonitorStatus
    Get
    Set
public:
property MonitorStatus^ Status {
    MonitorStatus^ get ();
    void set (MonitorStatus^ value);
}
function get_Status();
function set_Status(value);

Property Value

Type: MonitorStatus
The status.
See Also

Reference

MonitorInfo Class
DoubleTake.Monitoring.Contract Namespace


MonitorOptions Class

MonitorOptions Class
Represents the configuration of a monitor. This class is used to either create a new monitor or modify the configuration of an existing monitor.
Inheritance Hierarchy
SystemObject
DoubleTake.Monitoring.ContractMonitorOptions

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class MonitorOptions : IExtensibleDataObject
Public Class MonitorOptions
    Implements IExtensibleDataObject
public ref class MonitorOptions : IExtensibleDataObject
DoubleTake.Monitoring.Contract.MonitorOptions = function();

Type.createClass(
    'DoubleTake.Monitoring.Contract.MonitorOptions',
    null,
    IExtensibleDataObject);

The MonitorOptions type exposes the following members.

Constructors
 | Name | Description
Public method | MonitorOptions | Initializes a new instance of the MonitorOptions class
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Interval | Gets or sets the interval.
Public property | MissesAllowed | Gets or sets the misses allowed before the monitor is triggered.
Public property | Name | Gets or sets the name. If the monitor is associated with a repset, this should be the repset name.
Public property | PersistencePath | Gets or sets the persistence path.
Public property | Persistent | Gets or sets whether or not the monitor is to be persistent (i.e., save to disk).
Public property | Revision | Gets or sets the revision.
Public property | RootActivity | Gets or sets the root activity.
Public property | TimeAllowed | Gets or sets the time allowed after the first miss before the monitor is triggered.
Public property | TriggeredAction | Gets or sets the action to be run when the monitor enters the triggered state.
Public property | TriggerMode | Gets or sets the trigger mode.
Top
See Also

Reference

DoubleTake.Monitoring.Contract Namespace


MonitorOptions Constructor

MonitorOptions Constructor
Initializes a new instance of the MonitorOptions class

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public MonitorOptions()
Public Sub New
public:
MonitorOptions()
DoubleTake.Monitoring.Contract.MonitorOptions = function();
See Also

Reference

MonitorOptions Class
DoubleTake.Monitoring.Contract Namespace


MonitorOptions Properties

MonitorOptions Properties

The MonitorOptions type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Interval | Gets or sets the interval.
Public property | MissesAllowed | Gets or sets the misses allowed before the monitor is triggered.
Public property | Name | Gets or sets the name. If the monitor is associated with a repset, this should be the repset name.
Public property | PersistencePath | Gets or sets the persistence path.
Public property | Persistent | Gets or sets whether or not the monitor is to be persistent (i.e., save to disk).
Public property | Revision | Gets or sets the revision.
Public property | RootActivity | Gets or sets the root activity.
Public property | TimeAllowed | Gets or sets the time allowed after the first miss before the monitor is triggered.
Public property | TriggeredAction | Gets or sets the action to be run when the monitor enters the triggered state.
Public property | TriggerMode | Gets or sets the trigger mode.
Top
See Also

Reference

MonitorOptions Class
DoubleTake.Monitoring.Contract Namespace


MonitorOptions.ExtensionData Property

MonitorOptionsExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

MonitorOptions Class
DoubleTake.Monitoring.Contract Namespace


MonitorOptions.Interval Property

MonitorOptionsInterval Property
Gets or sets the interval.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public TimeSpan Interval { get; set; }
Public Property Interval As TimeSpan
    Get
    Set
public:
property TimeSpan Interval {
    TimeSpan get ();
    void set (TimeSpan value);
}
function get_Interval();
function set_Interval(value);

Property Value

Type: TimeSpan
The interval.
See Also

Reference

MonitorOptions Class
DoubleTake.Monitoring.Contract Namespace


MonitorOptions.MissesAllowed Property

MonitorOptionsMissesAllowed Property
Gets or sets the misses allowed before the monitor is triggered.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int MissesAllowed { get; set; }
Public Property MissesAllowed As Integer
    Get
    Set
public:
property int MissesAllowed {
    int get ();
    void set (int value);
}
function get_MissesAllowed();
function set_MissesAllowed(value);

Property Value

Type: Int32
The misses allowed before the monitor is triggered.
See Also

Reference

MonitorOptions Class
DoubleTake.Monitoring.Contract Namespace


MonitorOptions.Name Property

MonitorOptionsName Property
Gets or sets the name. If the monitor is associated with a repset, this should be the repset name.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
function get_Name();
function set_Name(value);

Property Value

Type: String
The name.
See Also

Reference

MonitorOptions Class
DoubleTake.Monitoring.Contract Namespace


MonitorOptions.PersistencePath Property

MonitorOptionsPersistencePath Property
Gets or sets the persistence path.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string PersistencePath { get; set; }
Public Property PersistencePath As String
    Get
    Set
public:
property String^ PersistencePath {
    String^ get ();
    void set (String^ value);
}
function get_PersistencePath();
function set_PersistencePath(value);

Property Value

Type: String
The persistence path.
See Also

Reference

MonitorOptions Class
DoubleTake.Monitoring.Contract Namespace


MonitorOptions.Persistent Property

MonitorOptionsPersistent Property
Gets or sets whether or not the monitor is to be persistent (i.e., save to disk).

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Nullable<bool> Persistent { get; set; }
Public Property Persistent As Nullable(Of Boolean)
    Get
    Set
public:
property Nullable<bool> Persistent {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}
function get_Persistent();
function set_Persistent(value);

Property Value

Type: Nullable Boolean
A value indicating whether or not the monitor is to be persistent.
See Also

Reference

MonitorOptions Class
DoubleTake.Monitoring.Contract Namespace


MonitorOptions.Revision Property

MonitorOptionsRevision Property
Gets or sets the revision.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int Revision { get; set; }
Public Property Revision As Integer
    Get
    Set
public:
property int Revision {
    int get ();
    void set (int value);
}
function get_Revision();
function set_Revision(value);

Property Value

Type: Int32
The revision.
Remarks
This property is only used internally by the Monitor Framework and is not sent across the wire or persisted to disk.
See Also

Reference

MonitorOptions Class
DoubleTake.Monitoring.Contract Namespace


MonitorOptions.RootActivity Property

MonitorOptionsRootActivity Property
Gets or sets the root activity.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public MonitorActivity RootActivity { get; set; }
Public Property RootActivity As MonitorActivity
    Get
    Set
public:
property MonitorActivity^ RootActivity {
    MonitorActivity^ get ();
    void set (MonitorActivity^ value);
}
function get_RootActivity();
function set_RootActivity(value);

Property Value

Type: MonitorActivity
The root activity.
See Also

Reference

MonitorOptions Class
DoubleTake.Monitoring.Contract Namespace


MonitorOptions.TimeAllowed Property

MonitorOptionsTimeAllowed Property
Gets or sets the time allowed after the first miss before the monitor is triggered.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public TimeSpan TimeAllowed { get; set; }
Public Property TimeAllowed As TimeSpan
    Get
    Set
public:
property TimeSpan TimeAllowed {
    TimeSpan get ();
    void set (TimeSpan value);
}
function get_TimeAllowed();
function set_TimeAllowed(value);

Property Value

Type: TimeSpan
The time allowed after the first miss before the monitor is triggered.
See Also

Reference

MonitorOptions Class
DoubleTake.Monitoring.Contract Namespace


MonitorOptions.TriggeredAction Property

MonitorOptionsTriggeredAction Property
Gets or sets the action to be run when the monitor enters the triggered state.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public MonitorAction TriggeredAction { get; set; }
Public Property TriggeredAction As MonitorAction
    Get
    Set
public:
property MonitorAction^ TriggeredAction {
    MonitorAction^ get ();
    void set (MonitorAction^ value);
}
function get_TriggeredAction();
function set_TriggeredAction(value);

Property Value

Type: MonitorAction
The action to be run.
See Also

Reference

MonitorOptions Class
DoubleTake.Monitoring.Contract Namespace


MonitorOptions.TriggerMode Property

MonitorOptionsTriggerMode Property
Gets or sets the trigger mode.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public TriggerMode TriggerMode { get; set; }
Public Property TriggerMode As TriggerMode
    Get
    Set
public:
property TriggerMode TriggerMode {
    TriggerMode get ();
    void set (TriggerMode value);
}
function get_TriggerMode();
function set_TriggerMode(value);

Property Value

Type: TriggerMode
The trigger mode.
See Also

Reference

MonitorOptions Class
DoubleTake.Monitoring.Contract Namespace


MonitorQuery Class

MonitorQuery Class
This class is part of the MonitorActivity class which contains both query and action.
Inheritance Hierarchy
SystemObject
DoubleTake.Monitoring.ContractMonitorQuery

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class MonitorQuery : IExtensibleDataObject
Public Class MonitorQuery
    Implements IExtensibleDataObject
public ref class MonitorQuery : IExtensibleDataObject
DoubleTake.Monitoring.Contract.MonitorQuery = function();

Type.createClass(
    'DoubleTake.Monitoring.Contract.MonitorQuery',
    null,
    IExtensibleDataObject);

The MonitorQuery type exposes the following members.

Constructors
 | Name | Description
Public method | MonitorQuery | Initializes a new instance of the MonitorQuery class
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Input | Gets or sets the input.
Public property | Name | Gets or sets the name.
Public property | RemoteServer | Gets or sets the remote server on which to run this query. Set this to to run the query locally.
Public property | RemoteServerCredentials |
Public property | RemoteServerUri |
Public property | Timeout | Gets or sets the timeout.
Public property | UniqueId | Gets or sets the unique id for this query.
Top
See Also

Reference

DoubleTake.Monitoring.Contract Namespace


MonitorQuery Constructor

MonitorQuery Constructor
Initializes a new instance of the MonitorQuery class

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public MonitorQuery()
Public Sub New
public:
MonitorQuery()
DoubleTake.Monitoring.Contract.MonitorQuery = function();
See Also

Reference

MonitorQuery Class
DoubleTake.Monitoring.Contract Namespace


MonitorQuery Properties

MonitorQuery Properties

The MonitorQuery type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Input | Gets or sets the input.
Public property | Name | Gets or sets the name.
Public property | RemoteServer | Gets or sets the remote server on which to run this query. Set this to to run the query locally.
Public property | RemoteServerCredentials |
Public property | RemoteServerUri |
Public property | Timeout | Gets or sets the timeout.
Public property | UniqueId | Gets or sets the unique id for this query.
Top
See Also

Reference

MonitorQuery Class
DoubleTake.Monitoring.Contract Namespace


MonitorQuery.ExtensionData Property

MonitorQueryExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

MonitorQuery Class
DoubleTake.Monitoring.Contract Namespace


MonitorQuery.Input Property

MonitorQueryInput Property
Gets or sets the input.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public QueryInput Input { get; set; }
Public Property Input As QueryInput
    Get
    Set
public:
property QueryInput^ Input {
    QueryInput^ get ();
    void set (QueryInput^ value);
}
function get_Input();
function set_Input(value);

Property Value

Type: QueryInput
The input.
See Also

Reference

MonitorQuery Class
DoubleTake.Monitoring.Contract Namespace


MonitorQuery.Name Property

MonitorQueryName Property
Gets or sets the name.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
function get_Name();
function set_Name(value);

Property Value

Type: String
The name.
See Also

Reference

MonitorQuery Class
DoubleTake.Monitoring.Contract Namespace


MonitorQuery.RemoteServer Property

MonitorQueryRemoteServer Property
Gets or sets the remote server on which to run this query. Set this to to run the query locally.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Uri RemoteServer { get; set; }
Public Property RemoteServer As Uri
    Get
    Set
public:
property Uri^ RemoteServer {
    Uri^ get ();
    void set (Uri^ value);
}
function get_RemoteServer();
function set_RemoteServer(value);

Property Value

Type: Uri
The remote server.
See Also

Reference

MonitorQuery Class
DoubleTake.Monitoring.Contract Namespace


MonitorQuery.RemoteServerCredentials Property

MonitorQueryRemoteServerCredentials Property

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Credentials RemoteServerCredentials { get; }
Public ReadOnly Property RemoteServerCredentials As Credentials
    Get
public:
property Credentials^ RemoteServerCredentials {
    Credentials^ get ();
}
function get_RemoteServerCredentials();

Property Value

Type: Credentials
See Also

Reference

MonitorQuery Class
DoubleTake.Monitoring.Contract Namespace


MonitorQuery.RemoteServerUri Property

MonitorQueryRemoteServerUri Property

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Uri RemoteServerUri { get; }
Public ReadOnly Property RemoteServerUri As Uri
    Get
public:
property Uri^ RemoteServerUri {
    Uri^ get ();
}
function get_RemoteServerUri();

Property Value

Type: Uri
See Also

Reference

MonitorQuery Class
DoubleTake.Monitoring.Contract Namespace


MonitorQuery.Timeout Property

MonitorQueryTimeout Property
Gets or sets the timeout.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public TimeSpan Timeout { get; set; }
Public Property Timeout As TimeSpan
    Get
    Set
public:
property TimeSpan Timeout {
    TimeSpan get ();
    void set (TimeSpan value);
}
function get_Timeout();
function set_Timeout(value);

Property Value

Type: TimeSpan
The timeout.
See Also

Reference

MonitorQuery Class
DoubleTake.Monitoring.Contract Namespace


MonitorQuery.UniqueId Property

MonitorQueryUniqueId Property
Gets or sets the unique id for this query.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Guid UniqueId { get; set; }
Public Property UniqueId As Guid
    Get
    Set
public:
property Guid UniqueId {
    Guid get ();
    void set (Guid value);
}
function get_UniqueId();
function set_UniqueId(value);

Property Value

Type: Guid
The unique id.
See Also

Reference

MonitorQuery Class
DoubleTake.Monitoring.Contract Namespace


MonitorResult Enumeration

MonitorResult Enumeration

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public enum MonitorResult
Public Enumeration MonitorResult
public enum class MonitorResult
DoubleTake.Monitoring.Contract.MonitorResult = function();
DoubleTake.Monitoring.Contract.MonitorResult.createEnum('DoubleTake.Monitoring.Contract.MonitorResult', false);
Members
Member name | Value | Description
Success | 0 |
Failure | 1 |
Indeterminate | 2 |
See Also

Reference

DoubleTake.Monitoring.Contract Namespace


MonitorState Enumeration

MonitorState Enumeration
An enumeration of the monitor states for the Monitoring Framework.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public enum MonitorState
Public Enumeration MonitorState
public enum class MonitorState
DoubleTake.Monitoring.Contract.MonitorState = function();
DoubleTake.Monitoring.Contract.MonitorState.createEnum('DoubleTake.Monitoring.Contract.MonitorState', false);
Members
Member name | Value | Description
Initial | 0 | Indicates that the monitor has just been created and has not been started.
Stopped | 1 | Indicates that the monitor has been started at least once and is now stopped.
Running | 2 | Indicates that the monitor is actively monitoring and there have not been any misses.
Missed | 3 | Indicates that the monitor is running and the current number of misses is greater than zero.
Triggering | 4 | Indicates that the monitor is running, the current number of misses equals the value specified in MissesAllowed and the triggered actions are currently being executing.
Triggered | 5 | Indicates that the monitor is running, the current number of misses equals the value specified in MissesAllowed and the triggered actions have been executed.
See Also

Reference

DoubleTake.Monitoring.Contract Namespace


MonitorStatus Class

MonitorStatus Class
Represents the current status of a monitor.
Inheritance Hierarchy
SystemObject
DoubleTake.Monitoring.ContractMonitorStatus

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class MonitorStatus : IExtensibleDataObject
Public Class MonitorStatus
    Implements IExtensibleDataObject
public ref class MonitorStatus : IExtensibleDataObject
DoubleTake.Monitoring.Contract.MonitorStatus = function();

Type.createClass(
    'DoubleTake.Monitoring.Contract.MonitorStatus',
    null,
    IExtensibleDataObject);

The MonitorStatus type exposes the following members.

Constructors
 | Name | Description
Public method | MonitorStatus | Initializes a new instance of the MonitorStatus class
Top
Properties
 | Name | Description
Public property | ActivityResult | Gets or sets the result chain.
Public property | CanStart | Gets or sets a value indicating whether this instance can start.
Public property | CanStop | Gets or sets a value indicating whether this instance can stop.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Misses | Gets or sets the number of misses that have occurred.
Public property | OptionsRevision | Gets or sets the options revision.
Public property | State | Gets or sets the state of the monitor.
Public property | TimeToTrigger | Gets or sets the time until this monitor is triggered.
Public property | TriggeredActionResult | Gets or sets the triggered action result.
Top
See Also

Reference

DoubleTake.Monitoring.Contract Namespace


MonitorStatus Constructor

MonitorStatus Constructor
Initializes a new instance of the MonitorStatus class

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public MonitorStatus()
Public Sub New
public:
MonitorStatus()
DoubleTake.Monitoring.Contract.MonitorStatus = function();
See Also

Reference

MonitorStatus Class
DoubleTake.Monitoring.Contract Namespace


MonitorStatus Properties

MonitorStatus Properties

The MonitorStatus type exposes the following members.

Properties
 | Name | Description
Public property | ActivityResult | Gets or sets the result chain.
Public property | CanStart | Gets or sets a value indicating whether this instance can start.
Public property | CanStop | Gets or sets a value indicating whether this instance can stop.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Misses | Gets or sets the number of misses that have occurred.
Public property | OptionsRevision | Gets or sets the options revision.
Public property | State | Gets or sets the state of the monitor.
Public property | TimeToTrigger | Gets or sets the time until this monitor is triggered.
Public property | TriggeredActionResult | Gets or sets the triggered action result.
Top
See Also

Reference

MonitorStatus Class
DoubleTake.Monitoring.Contract Namespace


MonitorStatus.ActivityResult Property

MonitorStatusActivityResult Property
Gets or sets the result chain.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ActivityResultNode ActivityResult { get; set; }
Public Property ActivityResult As ActivityResultNode
    Get
    Set
public:
property ActivityResultNode^ ActivityResult {
    ActivityResultNode^ get ();
    void set (ActivityResultNode^ value);
}
function get_ActivityResult();
function set_ActivityResult(value);

Property Value

Type: ActivityResultNode
The result chain.
See Also

Reference

MonitorStatus Class
DoubleTake.Monitoring.Contract Namespace


MonitorStatus.CanStart Property

MonitorStatusCanStart Property
Gets or sets a value indicating whether this instance can start.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool CanStart { get; set; }
Public Property CanStart As Boolean
    Get
    Set
public:
property bool CanStart {
    bool get ();
    void set (bool value);
}
function get_CanStart();
function set_CanStart(value);

Property Value

Type: Boolean
if this instance can start; otherwise, .
See Also

Reference

MonitorStatus Class
DoubleTake.Monitoring.Contract Namespace


MonitorStatus.CanStop Property

MonitorStatusCanStop Property
Gets or sets a value indicating whether this instance can stop.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool CanStop { get; set; }
Public Property CanStop As Boolean
    Get
    Set
public:
property bool CanStop {
    bool get ();
    void set (bool value);
}
function get_CanStop();
function set_CanStop(value);

Property Value

Type: Boolean
if this instance can stop; otherwise, .
See Also

Reference

MonitorStatus Class
DoubleTake.Monitoring.Contract Namespace


MonitorStatus.ExtensionData Property

MonitorStatusExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

MonitorStatus Class
DoubleTake.Monitoring.Contract Namespace


MonitorStatus.Misses Property

MonitorStatusMisses Property
Gets or sets the number of misses that have occurred.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int Misses { get; set; }
Public Property Misses As Integer
    Get
    Set
public:
property int Misses {
    int get ();
    void set (int value);
}
function get_Misses();
function set_Misses(value);

Property Value

Type: Int32
The number of misses that have occurred.
See Also

Reference

MonitorStatus Class
DoubleTake.Monitoring.Contract Namespace


MonitorStatus.OptionsRevision Property

MonitorStatusOptionsRevision Property
Gets or sets the options revision.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int OptionsRevision { get; set; }
Public Property OptionsRevision As Integer
    Get
    Set
public:
property int OptionsRevision {
    int get ();
    void set (int value);
}
function get_OptionsRevision();
function set_OptionsRevision(value);

Property Value

Type: Int32
The options revision.
Remarks
This property is only used internally by the Monitor Framework and is not sent across the wire or persisted to disk.
See Also

Reference

MonitorStatus Class
DoubleTake.Monitoring.Contract Namespace


MonitorStatus.State Property

MonitorStatusState Property
Gets or sets the state of the monitor.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public MonitorState State { get; set; }
Public Property State As MonitorState
    Get
    Set
public:
property MonitorState State {
    MonitorState get ();
    void set (MonitorState value);
}
function get_State();
function set_State(value);

Property Value

Type: MonitorState
The state of the monitor.
See Also

Reference

MonitorStatus Class
DoubleTake.Monitoring.Contract Namespace


MonitorStatus.TimeToTrigger Property

MonitorStatusTimeToTrigger Property
Gets or sets the time until this monitor is triggered.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public TimeSpan TimeToTrigger { get; set; }
Public Property TimeToTrigger As TimeSpan
    Get
    Set
public:
property TimeSpan TimeToTrigger {
    TimeSpan get ();
    void set (TimeSpan value);
}
function get_TimeToTrigger();
function set_TimeToTrigger(value);

Property Value

Type: TimeSpan
The time until this monitor is triggered.
See Also

Reference

MonitorStatus Class
DoubleTake.Monitoring.Contract Namespace


MonitorStatus.TriggeredActionResult Property

MonitorStatusTriggeredActionResult Property
Gets or sets the triggered action result.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ActionResult TriggeredActionResult { get; set; }
Public Property TriggeredActionResult As ActionResult
    Get
    Set
public:
property ActionResult^ TriggeredActionResult {
    ActionResult^ get ();
    void set (ActionResult^ value);
}
function get_TriggeredActionResult();
function set_TriggeredActionResult(value);

Property Value

Type: ActionResult
The triggered action result.
See Also

Reference

MonitorStatus Class
DoubleTake.Monitoring.Contract Namespace


PerformanceCounterQueryInput Class

PerformanceCounterQueryInput Class
Represents the input to a performance counter query.
Inheritance Hierarchy
SystemObject
DoubleTake.Monitoring.ContractQueryInput
DoubleTake.Monitoring.ContractPerformanceCounterQueryInput

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class PerformanceCounterQueryInput : QueryInput
Public Class PerformanceCounterQueryInput
    Inherits QueryInput
public ref class PerformanceCounterQueryInput : public QueryInput
DoubleTake.Monitoring.Contract.PerformanceCounterQueryInput = function();

Type.createClass(
    'DoubleTake.Monitoring.Contract.PerformanceCounterQueryInput',
    DoubleTake.Monitoring.Contract.QueryInput);

The PerformanceCounterQueryInput type exposes the following members.

Constructors
 | Name | Description
Public method | PerformanceCounterQueryInput | Initializes a new instance of the PerformanceCounterQueryInput class
Top
Properties
 | Name | Description
Public property | Category | Gets or sets the category.
Public property | ComparisonOperation | Gets or sets the comparison operation.
Public property | Counter | Gets or sets the counter.
Public property | Credentials | Gets or sets the credentials to be used by the query. (Inherited from QueryInput.)
Public property | Criteria | Gets or sets the criteria.
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from QueryInput.)
Public property | Instance | Gets or sets the instance.
Top
See Also

Reference

DoubleTake.Monitoring.Contract Namespace


PerformanceCounterQueryInput Constructor

PerformanceCounterQueryInput Constructor
Initializes a new instance of the PerformanceCounterQueryInput class

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public PerformanceCounterQueryInput()
Public Sub New
public:
PerformanceCounterQueryInput()
DoubleTake.Monitoring.Contract.PerformanceCounterQueryInput = function();
See Also

Reference

PerformanceCounterQueryInput Class
DoubleTake.Monitoring.Contract Namespace


PerformanceCounterQueryInput Properties

PerformanceCounterQueryInput Properties

The PerformanceCounterQueryInput type exposes the following members.

Properties
 | Name | Description
Public property | Category | Gets or sets the category.
Public property | ComparisonOperation | Gets or sets the comparison operation.
Public property | Counter | Gets or sets the counter.
Public property | Credentials | Gets or sets the credentials to be used by the query. (Inherited from QueryInput.)
Public property | Criteria | Gets or sets the criteria.
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from QueryInput.)
Public property | Instance | Gets or sets the instance.
Top
See Also

Reference

PerformanceCounterQueryInput Class
DoubleTake.Monitoring.Contract Namespace


PerformanceCounterQueryInput.Category Property

PerformanceCounterQueryInputCategory Property
Gets or sets the category.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Category { get; set; }
Public Property Category As String
    Get
    Set
public:
property String^ Category {
    String^ get ();
    void set (String^ value);
}
function get_Category();
function set_Category(value);

Property Value

Type: String
The category.
See Also

Reference

PerformanceCounterQueryInput Class
DoubleTake.Monitoring.Contract Namespace


PerformanceCounterQueryInput.ComparisonOperation Property

PerformanceCounterQueryInputComparisonOperation Property
Gets or sets the comparison operation.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ComparisonOperation ComparisonOperation { get; set; }
Public Property ComparisonOperation As ComparisonOperation
    Get
    Set
public:
property ComparisonOperation ComparisonOperation {
    ComparisonOperation get ();
    void set (ComparisonOperation value);
}
function get_ComparisonOperation();
function set_ComparisonOperation(value);

Property Value

Type: ComparisonOperation
The comparison operation.
See Also

Reference

PerformanceCounterQueryInput Class
DoubleTake.Monitoring.Contract Namespace


PerformanceCounterQueryInput.Counter Property

PerformanceCounterQueryInputCounter Property
Gets or sets the counter.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Counter { get; set; }
Public Property Counter As String
    Get
    Set
public:
property String^ Counter {
    String^ get ();
    void set (String^ value);
}
function get_Counter();
function set_Counter(value);

Property Value

Type: String
The counter.
See Also

Reference

PerformanceCounterQueryInput Class
DoubleTake.Monitoring.Contract Namespace


PerformanceCounterQueryInput.Criteria Property

PerformanceCounterQueryInputCriteria Property
Gets or sets the criteria.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public float Criteria { get; set; }
Public Property Criteria As Single
    Get
    Set
public:
property float Criteria {
    float get ();
    void set (float value);
}
function get_Criteria();
function set_Criteria(value);

Property Value

Type: Single
The criteria.
See Also

Reference

PerformanceCounterQueryInput Class
DoubleTake.Monitoring.Contract Namespace


PerformanceCounterQueryInput.Instance Property

PerformanceCounterQueryInputInstance Property
Gets or sets the instance.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Instance { get; set; }
Public Property Instance As String
    Get
    Set
public:
property String^ Instance {
    String^ get ();
    void set (String^ value);
}
function get_Instance();
function set_Instance(value);

Property Value

Type: String
The instance.
See Also

Reference

PerformanceCounterQueryInput Class
DoubleTake.Monitoring.Contract Namespace


PerformanceCounterQueryResult Class

PerformanceCounterQueryResult Class
Inheritance Hierarchy
SystemObject
DoubleTake.Monitoring.ContractQueryResult
DoubleTake.Monitoring.ContractPerformanceCounterQueryResult

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class PerformanceCounterQueryResult : QueryResult
Public Class PerformanceCounterQueryResult
    Inherits QueryResult
public ref class PerformanceCounterQueryResult : public QueryResult
DoubleTake.Monitoring.Contract.PerformanceCounterQueryResult = function();

Type.createClass(
    'DoubleTake.Monitoring.Contract.PerformanceCounterQueryResult',
    DoubleTake.Monitoring.Contract.QueryResult);

The PerformanceCounterQueryResult type exposes the following members.

Constructors
 | Name | Description
Public method | PerformanceCounterQueryResult | Initializes a new instance of the PerformanceCounterQueryResult class
Top
Properties
 | Name | Description
Public property | Exception | Gets or sets the query exception. (Inherited from QueryResult.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from QueryResult.)
Public property | Result | Gets or sets a value indicating whether or not the query was successful. (Inherited from QueryResult.)
Top
See Also

Reference

DoubleTake.Monitoring.Contract Namespace


PerformanceCounterQueryResult Constructor

PerformanceCounterQueryResult Constructor
Initializes a new instance of the PerformanceCounterQueryResult class

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public PerformanceCounterQueryResult()
Public Sub New
public:
PerformanceCounterQueryResult()
DoubleTake.Monitoring.Contract.PerformanceCounterQueryResult = function();
See Also

Reference

PerformanceCounterQueryResult Class
DoubleTake.Monitoring.Contract Namespace


PerformanceCounterQueryResult Properties

PerformanceCounterQueryResult Properties

The PerformanceCounterQueryResult type exposes the following members.

Properties
 | Name | Description
Public property | Exception | Gets or sets the query exception. (Inherited from QueryResult.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from QueryResult.)
Public property | Result | Gets or sets a value indicating whether or not the query was successful. (Inherited from QueryResult.)
Top
See Also

Reference

PerformanceCounterQueryResult Class
DoubleTake.Monitoring.Contract Namespace


PropertyFault Class

PropertyFault Class
Inheritance Hierarchy
SystemObject
DoubleTake.Monitoring.ContractPropertyFault

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class PropertyFault
Public Class PropertyFault
public ref class PropertyFault
DoubleTake.Monitoring.Contract.PropertyFault = function();

Type.createClass(
    'DoubleTake.Monitoring.Contract.PropertyFault');

The PropertyFault type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyFault | Initializes a new instance of the PropertyFault class
Top
Properties
 | Name | Description
Public property | ExceptionDetail | Gets or sets the exception detail.
Public property | PropertyName | Gets or sets the name of the property.
Top
See Also

Reference

DoubleTake.Monitoring.Contract Namespace


PropertyFault Constructor

PropertyFault Constructor
Initializes a new instance of the PropertyFault class

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public PropertyFault()
Public Sub New
public:
PropertyFault()
DoubleTake.Monitoring.Contract.PropertyFault = function();
See Also

Reference

PropertyFault Class
DoubleTake.Monitoring.Contract Namespace


PropertyFault Properties

PropertyFault Properties

The PropertyFault type exposes the following members.

Properties
 | Name | Description
Public property | ExceptionDetail | Gets or sets the exception detail.
Public property | PropertyName | Gets or sets the name of the property.
Top
See Also

Reference

PropertyFault Class
DoubleTake.Monitoring.Contract Namespace


PropertyFault.ExceptionDetail Property

PropertyFaultExceptionDetail Property
Gets or sets the exception detail.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExceptionDetail ExceptionDetail { get; set; }
Public Property ExceptionDetail As ExceptionDetail
    Get
    Set
public:
property ExceptionDetail^ ExceptionDetail {
    ExceptionDetail^ get ();
    void set (ExceptionDetail^ value);
}
function get_ExceptionDetail();
function set_ExceptionDetail(value);

Property Value

Type: ExceptionDetail
The exception detail.
See Also

Reference

PropertyFault Class
DoubleTake.Monitoring.Contract Namespace


PropertyFault.PropertyName Property

PropertyFaultPropertyName Property
Gets or sets the name of the property.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string PropertyName { get; set; }
Public Property PropertyName As String
    Get
    Set
public:
property String^ PropertyName {
    String^ get ();
    void set (String^ value);
}
function get_PropertyName();
function set_PropertyName(value);

Property Value

Type: String
The name of the property.
See Also

Reference

PropertyFault Class
DoubleTake.Monitoring.Contract Namespace


QueryInput Class

QueryInput Class
Represents arguments to a monitoring query.
Inheritance Hierarchy
SystemObject
DoubleTake.Monitoring.ContractQueryInput
More...

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class QueryInput : IExtensibleDataObject
Public Class QueryInput
    Implements IExtensibleDataObject
public ref class QueryInput : IExtensibleDataObject
DoubleTake.Monitoring.Contract.QueryInput = function();

Type.createClass(
    'DoubleTake.Monitoring.Contract.QueryInput',
    null,
    IExtensibleDataObject);

The QueryInput type exposes the following members.

Constructors
 | Name | Description
Public method | QueryInput | Initializes a new instance of the QueryInput class
Top
Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the query.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Top
See Also

Reference

DoubleTake.Monitoring.Contract Namespace
Inheritance Hierarchy
SystemObject
DoubleTake.Monitoring.ContractQueryInput
DoubleTake.Monitoring.ContractCompositeQueryInput
DoubleTake.Monitoring.ContractDtscStatusQueryInput
DoubleTake.Monitoring.ContractDTTargetResourceQueryInput
DoubleTake.Monitoring.ContractHeartbeatPingQueryInput
DoubleTake.Monitoring.ContractIcmpPingQueryInput
DoubleTake.Monitoring.ContractPerformanceCounterQueryInput
DoubleTake.Monitoring.ContractScriptQueryInput
DoubleTake.Monitoring.ContractServiceStatusQueryInput
DoubleTake.Monitoring.ContractShareQueryInput
DoubleTake.Monitoring.ContractVirtualSwitchConfigQueryInput
DoubleTake.Monitoring.ContractVmConfigQueryInput
DoubleTake.Monitoring.ContractVmHealthQueryInput


QueryInput Constructor

QueryInput Constructor
Initializes a new instance of the QueryInput class

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public QueryInput()
Public Sub New
public:
QueryInput()
DoubleTake.Monitoring.Contract.QueryInput = function();
See Also

Reference

QueryInput Class
DoubleTake.Monitoring.Contract Namespace


QueryInput Properties

QueryInput Properties

The QueryInput type exposes the following members.

Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the query.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Top
See Also

Reference

QueryInput Class
DoubleTake.Monitoring.Contract Namespace


QueryInput.Credentials Property

QueryInputCredentials Property
Gets or sets the credentials to be used by the query.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public IDictionary<string, Credentials> Credentials { get; set; }
Public Property Credentials As IDictionary(Of String, Credentials)
    Get
    Set
public:
property IDictionary<String^, Credentials^>^ Credentials {
    IDictionary<String^, Credentials^>^ get ();
    void set (IDictionary<String^, Credentials^>^ value);
}
function get_Credentials();
function set_Credentials(value);

Property Value

Type: IDictionary String, Credentials
The credentials.
See Also

Reference

QueryInput Class
DoubleTake.Monitoring.Contract Namespace


QueryInput.ExtensionData Property

QueryInputExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

QueryInput Class
DoubleTake.Monitoring.Contract Namespace


QueryResult Class

QueryResult Class
Represents the result of a monitoring query.
Inheritance Hierarchy
SystemObject
DoubleTake.Monitoring.ContractQueryResult
More...

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class QueryResult : IExtensibleDataObject
Public Class QueryResult
    Implements IExtensibleDataObject
public ref class QueryResult : IExtensibleDataObject
DoubleTake.Monitoring.Contract.QueryResult = function();

Type.createClass(
    'DoubleTake.Monitoring.Contract.QueryResult',
    null,
    IExtensibleDataObject);

The QueryResult type exposes the following members.

Constructors
 | Name | Description
Public method | QueryResult | Initializes a new instance of the QueryResult class
Top
Properties
 | Name | Description
Public property | Exception | Gets or sets the query exception.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Result | Gets or sets a value indicating whether or not the query was successful.
Top
See Also

Reference

DoubleTake.Monitoring.Contract Namespace
Inheritance Hierarchy
SystemObject
DoubleTake.Monitoring.ContractQueryResult
DoubleTake.Monitoring.ContractCompositeQueryResult
DoubleTake.Monitoring.ContractDtscStatusQueryResult
DoubleTake.Monitoring.ContractHeartbeatPingQueryResult
DoubleTake.Monitoring.ContractIcmpPingQueryResult
DoubleTake.Monitoring.ContractPerformanceCounterQueryResult
DoubleTake.Monitoring.ContractScriptQueryResult
DoubleTake.Monitoring.ContractServiceStatusQueryResult
DoubleTake.Monitoring.ContractShareQueryResult
DoubleTake.Monitoring.ContractVirtualSwitchConfigQueryResult
DoubleTake.Monitoring.ContractVmConfigQueryResult
DoubleTake.Monitoring.ContractVmHealthQueryResult


QueryResult Constructor

QueryResult Constructor
Initializes a new instance of the QueryResult class

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public QueryResult()
Public Sub New
public:
QueryResult()
DoubleTake.Monitoring.Contract.QueryResult = function();
See Also

Reference

QueryResult Class
DoubleTake.Monitoring.Contract Namespace


QueryResult Properties

QueryResult Properties

The QueryResult type exposes the following members.

Properties
 | Name | Description
Public property | Exception | Gets or sets the query exception.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Result | Gets or sets a value indicating whether or not the query was successful.
Top
See Also

Reference

QueryResult Class
DoubleTake.Monitoring.Contract Namespace


QueryResult.Exception Property

QueryResultException Property
Gets or sets the query exception.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExceptionDetail Exception { get; set; }
Public Property Exception As ExceptionDetail
    Get
    Set
public:
property ExceptionDetail^ Exception {
    ExceptionDetail^ get ();
    void set (ExceptionDetail^ value);
}
function get_Exception();
function set_Exception(value);

Property Value

Type: ExceptionDetail
The query exception.
See Also

Reference

QueryResult Class
DoubleTake.Monitoring.Contract Namespace


QueryResult.ExtensionData Property

QueryResultExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

QueryResult Class
DoubleTake.Monitoring.Contract Namespace


QueryResult.Result Property

QueryResultResult Property
Gets or sets a value indicating whether or not the query was successful.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public MonitorResult Result { get; set; }
Public Property Result As MonitorResult
    Get
    Set
public:
property MonitorResult Result {
    MonitorResult get ();
    void set (MonitorResult value);
}
function get_Result();
function set_Result(value);

Property Value

Type: MonitorResult
if query was successful; otherwise, .
See Also

Reference

QueryResult Class
DoubleTake.Monitoring.Contract Namespace


ScriptActionInput Class

ScriptActionInput Class
Inheritance Hierarchy
SystemObject
DoubleTake.Monitoring.ContractActionInput
DoubleTake.Monitoring.ContractScriptActionInput

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class ScriptActionInput : ActionInput
Public Class ScriptActionInput
    Inherits ActionInput
public ref class ScriptActionInput : public ActionInput
DoubleTake.Monitoring.Contract.ScriptActionInput = function();

Type.createClass(
    'DoubleTake.Monitoring.Contract.ScriptActionInput',
    DoubleTake.Monitoring.Contract.ActionInput);

The ScriptActionInput type exposes the following members.

Constructors
 | Name | Description
Public method | ScriptActionInput | Initializes a new instance of the ScriptActionInput class
Top
Properties
 | Name | Description
Public property | Arguments | Gets or sets the arguments to the script or executable.
Public property | Credentials | Gets or sets the credentials to be used by the action. (Inherited from ActionInput.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from ActionInput.)
Public property | FileName | Gets or sets the file name of the script or executable to run.
Public property | QueryResult | Gets or sets the query result. (Inherited from ActionInput.)
Public property | RunAs | Gets or sets the key to the credentials of the user as which the process will be run.
Public property | WaitForCompletion | Gets or sets a value indicating whether to wait for completion.
Public property | WaitForCompletionTimeout | Gets or sets the wait for completion timeout.
Public property | WorkingDirectory | Gets or sets the working directory.
Top
See Also

Reference

DoubleTake.Monitoring.Contract Namespace


ScriptActionInput Constructor

ScriptActionInput Constructor
Initializes a new instance of the ScriptActionInput class

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ScriptActionInput()
Public Sub New
public:
ScriptActionInput()
DoubleTake.Monitoring.Contract.ScriptActionInput = function();
See Also

Reference

ScriptActionInput Class
DoubleTake.Monitoring.Contract Namespace


ScriptActionInput Properties

ScriptActionInput Properties

The ScriptActionInput type exposes the following members.

Properties
 | Name | Description
Public property | Arguments | Gets or sets the arguments to the script or executable.
Public property | Credentials | Gets or sets the credentials to be used by the action. (Inherited from ActionInput.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from ActionInput.)
Public property | FileName | Gets or sets the file name of the script or executable to run.
Public property | QueryResult | Gets or sets the query result. (Inherited from ActionInput.)
Public property | RunAs | Gets or sets the key to the credentials of the user as which the process will be run.
Public property | WaitForCompletion | Gets or sets a value indicating whether to wait for completion.
Public property | WaitForCompletionTimeout | Gets or sets the wait for completion timeout.
Public property | WorkingDirectory | Gets or sets the working directory.
Top
See Also

Reference

ScriptActionInput Class
DoubleTake.Monitoring.Contract Namespace


ScriptActionInput.Arguments Property

ScriptActionInputArguments Property
Gets or sets the arguments to the script or executable.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Arguments { get; set; }
Public Property Arguments As String
    Get
    Set
public:
property String^ Arguments {
    String^ get ();
    void set (String^ value);
}
function get_Arguments();
function set_Arguments(value);

Property Value

Type: String
The arguments to the script or executable.
See Also

Reference

ScriptActionInput Class
DoubleTake.Monitoring.Contract Namespace


ScriptActionInput.FileName Property

ScriptActionInputFileName Property
Gets or sets the file name of the script or executable to run.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string FileName { get; set; }
Public Property FileName As String
    Get
    Set
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}
function get_FileName();
function set_FileName(value);

Property Value

Type: String
The file name of the script or executable to run.
See Also

Reference

ScriptActionInput Class
DoubleTake.Monitoring.Contract Namespace


ScriptActionInput.RunAs Property

ScriptActionInputRunAs Property
Gets or sets the key to the credentials of the user as which the process will be run.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string RunAs { get; set; }
Public Property RunAs As String
    Get
    Set
public:
property String^ RunAs {
    String^ get ();
    void set (String^ value);
}
function get_RunAs();
function set_RunAs(value);

Property Value

Type: String
The key to the credentials of the user as which the process will be run.
Remarks
This value is the key into the Credentials dictionary under which the credentials are stored.
See Also

Reference

ScriptActionInput Class
DoubleTake.Monitoring.Contract Namespace


ScriptActionInput.WaitForCompletion Property

ScriptActionInputWaitForCompletion Property
Gets or sets a value indicating whether to wait for completion.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool WaitForCompletion { get; set; }
Public Property WaitForCompletion As Boolean
    Get
    Set
public:
property bool WaitForCompletion {
    bool get ();
    void set (bool value);
}
function get_WaitForCompletion();
function set_WaitForCompletion(value);

Property Value

Type: Boolean
if the query should wait for completion; otherwise, .
See Also

Reference

ScriptActionInput Class
DoubleTake.Monitoring.Contract Namespace


ScriptActionInput.WaitForCompletionTimeout Property

ScriptActionInputWaitForCompletionTimeout Property
Gets or sets the wait for completion timeout.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Nullable<TimeSpan> WaitForCompletionTimeout { get; set; }
Public Property WaitForCompletionTimeout As Nullable(Of TimeSpan)
    Get
    Set
public:
property Nullable<TimeSpan> WaitForCompletionTimeout {
    Nullable<TimeSpan> get ();
    void set (Nullable<TimeSpan> value);
}
function get_WaitForCompletionTimeout();
function set_WaitForCompletionTimeout(value);

Property Value

Type: Nullable TimeSpan
The wait for completion timeout.
See Also

Reference

ScriptActionInput Class
DoubleTake.Monitoring.Contract Namespace


ScriptActionInput.WorkingDirectory Property

ScriptActionInputWorkingDirectory Property
Gets or sets the working directory.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string WorkingDirectory { get; set; }
Public Property WorkingDirectory As String
    Get
    Set
public:
property String^ WorkingDirectory {
    String^ get ();
    void set (String^ value);
}
function get_WorkingDirectory();
function set_WorkingDirectory(value);

Property Value

Type: String
The working directory.
See Also

Reference

ScriptActionInput Class
DoubleTake.Monitoring.Contract Namespace


ScriptActionResult Class

ScriptActionResult Class
Inheritance Hierarchy
SystemObject
DoubleTake.Monitoring.ContractActionResult
DoubleTake.Monitoring.ContractScriptActionResult

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class ScriptActionResult : ActionResult
Public Class ScriptActionResult
    Inherits ActionResult
public ref class ScriptActionResult : public ActionResult
DoubleTake.Monitoring.Contract.ScriptActionResult = function();

Type.createClass(
    'DoubleTake.Monitoring.Contract.ScriptActionResult',
    DoubleTake.Monitoring.Contract.ActionResult);

The ScriptActionResult type exposes the following members.

Constructors
 | Name | Description
Public method | ScriptActionResult | Initializes a new instance of the ScriptActionResult class
Top
Properties
 | Name | Description
Public property | Exception | Gets or sets the action exception. (Inherited from ActionResult.)
Public property | ExitCode | Gets or sets the exit code of the process.
Public property | ExitTime | Gets or sets the exit time.
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from ActionResult.)
Public property | StartTime | Gets or sets the start time.
Top
See Also

Reference

DoubleTake.Monitoring.Contract Namespace


ScriptActionResult Constructor

ScriptActionResult Constructor
Initializes a new instance of the ScriptActionResult class

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ScriptActionResult()
Public Sub New
public:
ScriptActionResult()
DoubleTake.Monitoring.Contract.ScriptActionResult = function();
See Also

Reference

ScriptActionResult Class
DoubleTake.Monitoring.Contract Namespace


ScriptActionResult Properties

ScriptActionResult Properties

The ScriptActionResult type exposes the following members.

Properties
 | Name | Description
Public property | Exception | Gets or sets the action exception. (Inherited from ActionResult.)
Public property | ExitCode | Gets or sets the exit code of the process.
Public property | ExitTime | Gets or sets the exit time.
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from ActionResult.)
Public property | StartTime | Gets or sets the start time.
Top
See Also

Reference

ScriptActionResult Class
DoubleTake.Monitoring.Contract Namespace


ScriptActionResult.ExitCode Property

ScriptActionResultExitCode Property
Gets or sets the exit code of the process.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Nullable<int> ExitCode { get; set; }
Public Property ExitCode As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> ExitCode {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
function get_ExitCode();
function set_ExitCode(value);

Property Value

Type: Nullable Int32
The exit code.
Remarks
This value will be if the user chose not to wait for completion.
See Also

Reference

ScriptActionResult Class
DoubleTake.Monitoring.Contract Namespace


ScriptActionResult.ExitTime Property

ScriptActionResultExitTime Property
Gets or sets the exit time.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Nullable<DateTimeOffset> ExitTime { get; set; }
Public Property ExitTime As Nullable(Of DateTimeOffset)
    Get
    Set
public:
property Nullable<DateTimeOffset> ExitTime {
    Nullable<DateTimeOffset> get ();
    void set (Nullable<DateTimeOffset> value);
}
function get_ExitTime();
function set_ExitTime(value);

Property Value

Type: Nullable DateTimeOffset
The exit time.
Remarks
This value will be if the user chose not to wait for completion.
See Also

Reference

ScriptActionResult Class
DoubleTake.Monitoring.Contract Namespace


ScriptActionResult.StartTime Property

ScriptActionResultStartTime Property
Gets or sets the start time.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public DateTimeOffset StartTime { get; set; }
Public Property StartTime As DateTimeOffset
    Get
    Set
public:
property DateTimeOffset StartTime {
    DateTimeOffset get ();
    void set (DateTimeOffset value);
}
function get_StartTime();
function set_StartTime(value);

Property Value

Type: DateTimeOffset
The start time.
See Also

Reference

ScriptActionResult Class
DoubleTake.Monitoring.Contract Namespace


ScriptQueryInput Class

ScriptQueryInput Class
Defines the input into the script query.
Inheritance Hierarchy
SystemObject
DoubleTake.Monitoring.ContractQueryInput
DoubleTake.Monitoring.ContractScriptQueryInput

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class ScriptQueryInput : QueryInput
Public Class ScriptQueryInput
    Inherits QueryInput
public ref class ScriptQueryInput : public QueryInput
DoubleTake.Monitoring.Contract.ScriptQueryInput = function();

Type.createClass(
    'DoubleTake.Monitoring.Contract.ScriptQueryInput',
    DoubleTake.Monitoring.Contract.QueryInput);

The ScriptQueryInput type exposes the following members.

Constructors
 | Name | Description
Public method | ScriptQueryInput | Initializes a new instance of the ScriptQueryInput class
Top
Properties
 | Name | Description
Public property | Arguments | Gets or sets the arguments to the script or executable.
Public property | Credentials | Gets or sets the credentials to be used by the query. (Inherited from QueryInput.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from QueryInput.)
Public property | FileName | Gets or sets the file name of the script or executable to run.
Public property | RunAs | Gets or sets the key to the credentials of the user as which the process will be run.
Public property | WaitForCompletion | Gets or sets a value indicating whether to wait for completion.
Public property | WaitForCompletionTimeout | Gets or sets the wait for completion timeout.
Public property | WorkingDirectory | Gets or sets the working directory.
Top
See Also

Reference

DoubleTake.Monitoring.Contract Namespace


ScriptQueryInput Constructor

ScriptQueryInput Constructor
Initializes a new instance of the ScriptQueryInput class

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ScriptQueryInput()
Public Sub New
public:
ScriptQueryInput()
DoubleTake.Monitoring.Contract.ScriptQueryInput = function();
See Also

Reference

ScriptQueryInput Class
DoubleTake.Monitoring.Contract Namespace


ScriptQueryInput Properties

ScriptQueryInput Properties

The ScriptQueryInput type exposes the following members.

Properties
 | Name | Description
Public property | Arguments | Gets or sets the arguments to the script or executable.
Public property | Credentials | Gets or sets the credentials to be used by the query. (Inherited from QueryInput.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from QueryInput.)
Public property | FileName | Gets or sets the file name of the script or executable to run.
Public property | RunAs | Gets or sets the key to the credentials of the user as which the process will be run.
Public property | WaitForCompletion | Gets or sets a value indicating whether to wait for completion.
Public property | WaitForCompletionTimeout | Gets or sets the wait for completion timeout.
Public property | WorkingDirectory | Gets or sets the working directory.
Top
See Also

Reference

ScriptQueryInput Class
DoubleTake.Monitoring.Contract Namespace


ScriptQueryInput.Arguments Property

ScriptQueryInputArguments Property
Gets or sets the arguments to the script or executable.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Arguments { get; set; }
Public Property Arguments As String
    Get
    Set
public:
property String^ Arguments {
    String^ get ();
    void set (String^ value);
}
function get_Arguments();
function set_Arguments(value);

Property Value

Type: String
The arguments to the script or executable.
See Also

Reference

ScriptQueryInput Class
DoubleTake.Monitoring.Contract Namespace


ScriptQueryInput.FileName Property

ScriptQueryInputFileName Property
Gets or sets the file name of the script or executable to run.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string FileName { get; set; }
Public Property FileName As String
    Get
    Set
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}
function get_FileName();
function set_FileName(value);

Property Value

Type: String
The file name of the script or executable to run.
See Also

Reference

ScriptQueryInput Class
DoubleTake.Monitoring.Contract Namespace


ScriptQueryInput.RunAs Property

ScriptQueryInputRunAs Property
Gets or sets the key to the credentials of the user as which the process will be run.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string RunAs { get; set; }
Public Property RunAs As String
    Get
    Set
public:
property String^ RunAs {
    String^ get ();
    void set (String^ value);
}
function get_RunAs();
function set_RunAs(value);

Property Value

Type: String
The key to the credentials of the user as which the process will be run.
Remarks
This value is the key into the Credentials dictionary under which the credentials are stored.
See Also

Reference

ScriptQueryInput Class
DoubleTake.Monitoring.Contract Namespace


ScriptQueryInput.WaitForCompletion Property

ScriptQueryInputWaitForCompletion Property
Gets or sets a value indicating whether to wait for completion.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool WaitForCompletion { get; set; }
Public Property WaitForCompletion As Boolean
    Get
    Set
public:
property bool WaitForCompletion {
    bool get ();
    void set (bool value);
}
function get_WaitForCompletion();
function set_WaitForCompletion(value);

Property Value

Type: Boolean
if the query should wait for completion; otherwise, .
See Also

Reference

ScriptQueryInput Class
DoubleTake.Monitoring.Contract Namespace


ScriptQueryInput.WaitForCompletionTimeout Property

ScriptQueryInputWaitForCompletionTimeout Property
Gets or sets the wait for completion timeout.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Nullable<TimeSpan> WaitForCompletionTimeout { get; set; }
Public Property WaitForCompletionTimeout As Nullable(Of TimeSpan)
    Get
    Set
public:
property Nullable<TimeSpan> WaitForCompletionTimeout {
    Nullable<TimeSpan> get ();
    void set (Nullable<TimeSpan> value);
}
function get_WaitForCompletionTimeout();
function set_WaitForCompletionTimeout(value);

Property Value

Type: Nullable TimeSpan
The wait for completion timeout.
See Also

Reference

ScriptQueryInput Class
DoubleTake.Monitoring.Contract Namespace


ScriptQueryInput.WorkingDirectory Property

ScriptQueryInputWorkingDirectory Property
Gets or sets the working directory.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string WorkingDirectory { get; set; }
Public Property WorkingDirectory As String
    Get
    Set
public:
property String^ WorkingDirectory {
    String^ get ();
    void set (String^ value);
}
function get_WorkingDirectory();
function set_WorkingDirectory(value);

Property Value

Type: String
The working directory.
See Also

Reference

ScriptQueryInput Class
DoubleTake.Monitoring.Contract Namespace


ScriptQueryResult Class

ScriptQueryResult Class
Defines the result of a Script query.
Inheritance Hierarchy
SystemObject
DoubleTake.Monitoring.ContractQueryResult
DoubleTake.Monitoring.ContractScriptQueryResult

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class ScriptQueryResult : QueryResult
Public Class ScriptQueryResult
    Inherits QueryResult
public ref class ScriptQueryResult : public QueryResult
DoubleTake.Monitoring.Contract.ScriptQueryResult = function();

Type.createClass(
    'DoubleTake.Monitoring.Contract.ScriptQueryResult',
    DoubleTake.Monitoring.Contract.QueryResult);

The ScriptQueryResult type exposes the following members.

Constructors
 | Name | Description
Public method | ScriptQueryResult | Initializes a new instance of the ScriptQueryResult class
Top
Properties
 | Name | Description
Public property | Exception | Gets or sets the query exception. (Inherited from QueryResult.)
Public property | ExitCode | Gets or sets the exit code of the process.
Public property | ExitTime | Gets or sets the exit time.
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from QueryResult.)
Public property | Result | Gets or sets a value indicating whether or not the query was successful. (Inherited from QueryResult.)
Public property | StartTime | Gets or sets the start time.
Top
See Also

Reference

DoubleTake.Monitoring.Contract Namespace


ScriptQueryResult Constructor

ScriptQueryResult Constructor
Initializes a new instance of the ScriptQueryResult class

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ScriptQueryResult()
Public Sub New
public:
ScriptQueryResult()
DoubleTake.Monitoring.Contract.ScriptQueryResult = function();
See Also

Reference

ScriptQueryResult Class
DoubleTake.Monitoring.Contract Namespace


ScriptQueryResult Properties

ScriptQueryResult Properties

The ScriptQueryResult type exposes the following members.

Properties
 | Name | Description
Public property | Exception | Gets or sets the query exception. (Inherited from QueryResult.)
Public property | ExitCode | Gets or sets the exit code of the process.
Public property | ExitTime | Gets or sets the exit time.
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from QueryResult.)
Public property | Result | Gets or sets a value indicating whether or not the query was successful. (Inherited from QueryResult.)
Public property | StartTime | Gets or sets the start time.
Top
See Also

Reference

ScriptQueryResult Class
DoubleTake.Monitoring.Contract Namespace


ScriptQueryResult.ExitCode Property

ScriptQueryResultExitCode Property
Gets or sets the exit code of the process.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Nullable<int> ExitCode { get; set; }
Public Property ExitCode As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> ExitCode {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
function get_ExitCode();
function set_ExitCode(value);

Property Value

Type: Nullable Int32
The exit code.
Remarks
This value will be if the user chose not to wait for completion.
See Also

Reference

ScriptQueryResult Class
DoubleTake.Monitoring.Contract Namespace


ScriptQueryResult.ExitTime Property

ScriptQueryResultExitTime Property
Gets or sets the exit time.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Nullable<DateTimeOffset> ExitTime { get; set; }
Public Property ExitTime As Nullable(Of DateTimeOffset)
    Get
    Set
public:
property Nullable<DateTimeOffset> ExitTime {
    Nullable<DateTimeOffset> get ();
    void set (Nullable<DateTimeOffset> value);
}
function get_ExitTime();
function set_ExitTime(value);

Property Value

Type: Nullable DateTimeOffset
The exit time.
Remarks
This value will be if the user chose not to wait for completion.
See Also

Reference

ScriptQueryResult Class
DoubleTake.Monitoring.Contract Namespace


ScriptQueryResult.StartTime Property

ScriptQueryResultStartTime Property
Gets or sets the start time.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public DateTimeOffset StartTime { get; set; }
Public Property StartTime As DateTimeOffset
    Get
    Set
public:
property DateTimeOffset StartTime {
    DateTimeOffset get ();
    void set (DateTimeOffset value);
}
function get_StartTime();
function set_StartTime(value);

Property Value

Type: DateTimeOffset
The start time.
See Also

Reference

ScriptQueryResult Class
DoubleTake.Monitoring.Contract Namespace


ServiceOperation Enumeration

ServiceOperation Enumeration
Represents the different types of Windows service operations.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public enum ServiceOperation
Public Enumeration ServiceOperation
public enum class ServiceOperation
DoubleTake.Monitoring.Contract.ServiceOperation = function();
DoubleTake.Monitoring.Contract.ServiceOperation.createEnum('DoubleTake.Monitoring.Contract.ServiceOperation', false);
Members
Member name | Value | Description
Start | 0 | Indicates to execute the 'Start' operation on the service.
Stop | 1 | Indicates to execute the 'Stop' operation on the service.
Pause | 2 | Indicates to execute the 'Pause' operation on the service.
Continue | 3 | Indicates to execute the 'Continue' operation on the service.
See Also

Reference

DoubleTake.Monitoring.Contract Namespace


ServiceOperationActionInput Class

ServiceOperationActionInput Class
Inheritance Hierarchy
SystemObject
DoubleTake.Monitoring.ContractActionInput
DoubleTake.Monitoring.ContractServiceOperationActionInput

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class ServiceOperationActionInput : ActionInput
Public Class ServiceOperationActionInput
    Inherits ActionInput
public ref class ServiceOperationActionInput : public ActionInput
DoubleTake.Monitoring.Contract.ServiceOperationActionInput = function();

Type.createClass(
    'DoubleTake.Monitoring.Contract.ServiceOperationActionInput',
    DoubleTake.Monitoring.Contract.ActionInput);

The ServiceOperationActionInput type exposes the following members.

Constructors
 | Name | Description
Public method | ServiceOperationActionInput | Initializes a new instance of the ServiceOperationActionInput class
Top
Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the action. (Inherited from ActionInput.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from ActionInput.)
Public property | QueryResult | Gets or sets the query result. (Inherited from ActionInput.)
Public property | ServiceName | Gets or sets the name of the service.
Public property | ServiceOperation | Gets or sets the service operation.
Public property | StartArguments | Gets or sets the arguments for the Start operation.
Public property | Timeout | Gets or sets the timeout for the wait operation.
Public property | WaitForStatus | Gets or sets a value indicating whether to wait for the service status to change as a result of the operation performed.
Top
See Also

Reference

DoubleTake.Monitoring.Contract Namespace


ServiceOperationActionInput Constructor

ServiceOperationActionInput Constructor
Initializes a new instance of the ServiceOperationActionInput class

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ServiceOperationActionInput()
Public Sub New
public:
ServiceOperationActionInput()
DoubleTake.Monitoring.Contract.ServiceOperationActionInput = function();
See Also

Reference

ServiceOperationActionInput Class
DoubleTake.Monitoring.Contract Namespace


ServiceOperationActionInput Properties

ServiceOperationActionInput Properties

The ServiceOperationActionInput type exposes the following members.

Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the action. (Inherited from ActionInput.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from ActionInput.)
Public property | QueryResult | Gets or sets the query result. (Inherited from ActionInput.)
Public property | ServiceName | Gets or sets the name of the service.
Public property | ServiceOperation | Gets or sets the service operation.
Public property | StartArguments | Gets or sets the arguments for the Start operation.
Public property | Timeout | Gets or sets the timeout for the wait operation.
Public property | WaitForStatus | Gets or sets a value indicating whether to wait for the service status to change as a result of the operation performed.
Top
See Also

Reference

ServiceOperationActionInput Class
DoubleTake.Monitoring.Contract Namespace


ServiceOperationActionInput.ServiceName Property

ServiceOperationActionInputServiceName Property
Gets or sets the name of the service.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string ServiceName { get; set; }
Public Property ServiceName As String
    Get
    Set
public:
property String^ ServiceName {
    String^ get ();
    void set (String^ value);
}
function get_ServiceName();
function set_ServiceName(value);

Property Value

Type: String
The name of the service.
See Also

Reference

ServiceOperationActionInput Class
DoubleTake.Monitoring.Contract Namespace


ServiceOperationActionInput.ServiceOperation Property

ServiceOperationActionInputServiceOperation Property
Gets or sets the service operation.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ServiceOperation ServiceOperation { get; set; }
Public Property ServiceOperation As ServiceOperation
    Get
    Set
public:
property ServiceOperation ServiceOperation {
    ServiceOperation get ();
    void set (ServiceOperation value);
}
function get_ServiceOperation();
function set_ServiceOperation(value);

Property Value

Type: ServiceOperation
The service operation.
See Also

Reference

ServiceOperationActionInput Class
DoubleTake.Monitoring.Contract Namespace


ServiceOperationActionInput.StartArguments Property

ServiceOperationActionInputStartArguments Property
Gets or sets the arguments for the Start operation.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string[] StartArguments { get; set; }
Public Property StartArguments As String()
    Get
    Set
public:
property array<String^>^ StartArguments {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
function get_StartArguments();
function set_StartArguments(value);

Property Value

Type: String
The arguments for the Start operation.
Remarks
This property is ignored for all [F:ServiceOperation] values other than the Start operation.
See Also

Reference

ServiceOperationActionInput Class
DoubleTake.Monitoring.Contract Namespace


ServiceOperationActionInput.Timeout Property

ServiceOperationActionInputTimeout Property
Gets or sets the timeout for the wait operation.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Nullable<TimeSpan> Timeout { get; set; }
Public Property Timeout As Nullable(Of TimeSpan)
    Get
    Set
public:
property Nullable<TimeSpan> Timeout {
    Nullable<TimeSpan> get ();
    void set (Nullable<TimeSpan> value);
}
function get_Timeout();
function set_Timeout(value);

Property Value

Type: Nullable TimeSpan
The timeout for the wait operation.
Remarks
If this value is , the action agent will wait indefinitely for the status to change.
See Also

Reference

ServiceOperationActionInput Class
DoubleTake.Monitoring.Contract Namespace


ServiceOperationActionInput.WaitForStatus Property

ServiceOperationActionInputWaitForStatus Property
Gets or sets a value indicating whether to wait for the service status to change as a result of the operation performed.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool WaitForStatus { get; set; }
Public Property WaitForStatus As Boolean
    Get
    Set
public:
property bool WaitForStatus {
    bool get ();
    void set (bool value);
}
function get_WaitForStatus();
function set_WaitForStatus(value);

Property Value

Type: Boolean
to wait for the service status to change; otherwise, .
Remarks
There is a corresponding service status change for each operation. For instance, if you've requested the Start operation, this action will wait for the service status to change to Running.
See Also

Reference

ServiceOperationActionInput Class
DoubleTake.Monitoring.Contract Namespace


ServiceOperationActionResult Class

ServiceOperationActionResult Class
Represents the result of a service operation action.
Inheritance Hierarchy
SystemObject
DoubleTake.Monitoring.ContractActionResult
DoubleTake.Monitoring.ContractServiceOperationActionResult

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class ServiceOperationActionResult : ActionResult
Public Class ServiceOperationActionResult
    Inherits ActionResult
public ref class ServiceOperationActionResult : public ActionResult
DoubleTake.Monitoring.Contract.ServiceOperationActionResult = function();

Type.createClass(
    'DoubleTake.Monitoring.Contract.ServiceOperationActionResult',
    DoubleTake.Monitoring.Contract.ActionResult);

The ServiceOperationActionResult type exposes the following members.

Constructors
 | Name | Description
Public method | ServiceOperationActionResult | Initializes a new instance of the ServiceOperationActionResult class
Top
Properties
 | Name | Description
Public property | Exception | Gets or sets the action exception. (Inherited from ActionResult.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from ActionResult.)
Public property | ServiceStatus | Gets or sets the service status after the operation has been executed.
Top
See Also

Reference

DoubleTake.Monitoring.Contract Namespace


ServiceOperationActionResult Constructor

ServiceOperationActionResult Constructor
Initializes a new instance of the ServiceOperationActionResult class

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ServiceOperationActionResult()
Public Sub New
public:
ServiceOperationActionResult()
DoubleTake.Monitoring.Contract.ServiceOperationActionResult = function();
See Also

Reference

ServiceOperationActionResult Class
DoubleTake.Monitoring.Contract Namespace


ServiceOperationActionResult Properties

ServiceOperationActionResult Properties

The ServiceOperationActionResult type exposes the following members.

Properties
 | Name | Description
Public property | Exception | Gets or sets the action exception. (Inherited from ActionResult.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from ActionResult.)
Public property | ServiceStatus | Gets or sets the service status after the operation has been executed.
Top
See Also

Reference

ServiceOperationActionResult Class
DoubleTake.Monitoring.Contract Namespace


ServiceOperationActionResult.ServiceStatus Property

ServiceOperationActionResultServiceStatus Property
Gets or sets the service status after the operation has been executed.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string ServiceStatus { get; set; }
Public Property ServiceStatus As String
    Get
    Set
public:
property String^ ServiceStatus {
    String^ get ();
    void set (String^ value);
}
function get_ServiceStatus();
function set_ServiceStatus(value);

Property Value

Type: String
The service status after the operation has been executed.
See Also

Reference

ServiceOperationActionResult Class
DoubleTake.Monitoring.Contract Namespace


ServiceStatusQueryInput Class

ServiceStatusQueryInput Class
Inheritance Hierarchy
SystemObject
DoubleTake.Monitoring.ContractQueryInput
DoubleTake.Monitoring.ContractServiceStatusQueryInput

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class ServiceStatusQueryInput : QueryInput
Public Class ServiceStatusQueryInput
    Inherits QueryInput
public ref class ServiceStatusQueryInput : public QueryInput
DoubleTake.Monitoring.Contract.ServiceStatusQueryInput = function();

Type.createClass(
    'DoubleTake.Monitoring.Contract.ServiceStatusQueryInput',
    DoubleTake.Monitoring.Contract.QueryInput);

The ServiceStatusQueryInput type exposes the following members.

Constructors
 | Name | Description
Public method | ServiceStatusQueryInput | Initializes a new instance of the ServiceStatusQueryInput class
Top
Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the query. (Inherited from QueryInput.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from QueryInput.)
Public property | ServiceName |
Top
See Also

Reference

DoubleTake.Monitoring.Contract Namespace


ServiceStatusQueryInput Constructor

ServiceStatusQueryInput Constructor
Initializes a new instance of the ServiceStatusQueryInput class

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ServiceStatusQueryInput()
Public Sub New
public:
ServiceStatusQueryInput()
DoubleTake.Monitoring.Contract.ServiceStatusQueryInput = function();
See Also

Reference

ServiceStatusQueryInput Class
DoubleTake.Monitoring.Contract Namespace


ServiceStatusQueryInput Properties

ServiceStatusQueryInput Properties

The ServiceStatusQueryInput type exposes the following members.

Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the query. (Inherited from QueryInput.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from QueryInput.)
Public property | ServiceName |
Top
See Also

Reference

ServiceStatusQueryInput Class
DoubleTake.Monitoring.Contract Namespace


ServiceStatusQueryInput.ServiceName Property

ServiceStatusQueryInputServiceName Property

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string ServiceName { get; set; }
Public Property ServiceName As String
    Get
    Set
public:
property String^ ServiceName {
    String^ get ();
    void set (String^ value);
}
function get_ServiceName();
function set_ServiceName(value);

Property Value

Type: String
See Also

Reference

ServiceStatusQueryInput Class
DoubleTake.Monitoring.Contract Namespace


ServiceStatusQueryResult Class

ServiceStatusQueryResult Class
Inheritance Hierarchy
SystemObject
DoubleTake.Monitoring.ContractQueryResult
DoubleTake.Monitoring.ContractServiceStatusQueryResult

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class ServiceStatusQueryResult : QueryResult
Public Class ServiceStatusQueryResult
    Inherits QueryResult
public ref class ServiceStatusQueryResult : public QueryResult
DoubleTake.Monitoring.Contract.ServiceStatusQueryResult = function();

Type.createClass(
    'DoubleTake.Monitoring.Contract.ServiceStatusQueryResult',
    DoubleTake.Monitoring.Contract.QueryResult);

The ServiceStatusQueryResult type exposes the following members.

Constructors
 | Name | Description
Public method | ServiceStatusQueryResult | Initializes a new instance of the ServiceStatusQueryResult class
Top
Properties
 | Name | Description
Public property | Exception | Gets or sets the query exception. (Inherited from QueryResult.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from QueryResult.)
Public property | Result | Gets or sets a value indicating whether or not the query was successful. (Inherited from QueryResult.)
Public property | ServiceName |
Top
See Also

Reference

DoubleTake.Monitoring.Contract Namespace


ServiceStatusQueryResult Constructor

ServiceStatusQueryResult Constructor
Initializes a new instance of the ServiceStatusQueryResult class

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ServiceStatusQueryResult()
Public Sub New
public:
ServiceStatusQueryResult()
DoubleTake.Monitoring.Contract.ServiceStatusQueryResult = function();
See Also

Reference

ServiceStatusQueryResult Class
DoubleTake.Monitoring.Contract Namespace


ServiceStatusQueryResult Properties

ServiceStatusQueryResult Properties

The ServiceStatusQueryResult type exposes the following members.

Properties
 | Name | Description
Public property | Exception | Gets or sets the query exception. (Inherited from QueryResult.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from QueryResult.)
Public property | Result | Gets or sets a value indicating whether or not the query was successful. (Inherited from QueryResult.)
Public property | ServiceName |
Top
See Also

Reference

ServiceStatusQueryResult Class
DoubleTake.Monitoring.Contract Namespace


ServiceStatusQueryResult.ServiceName Property

ServiceStatusQueryResultServiceName Property

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string ServiceName { get; set; }
Public Property ServiceName As String
    Get
    Set
public:
property String^ ServiceName {
    String^ get ();
    void set (String^ value);
}
function get_ServiceName();
function set_ServiceName(value);

Property Value

Type: String
See Also

Reference

ServiceStatusQueryResult Class
DoubleTake.Monitoring.Contract Namespace


Share Class

Share Class
Inheritance Hierarchy
SystemObject
DoubleTake.Monitoring.ContractShare

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class Share
Public Class Share
public ref class Share
DoubleTake.Monitoring.Contract.Share = function();

Type.createClass(
    'DoubleTake.Monitoring.Contract.Share');

The Share type exposes the following members.

Constructors
 | Name | Description
Public method | Share | Initializes a new instance of the Share class
Public method | Share(NetworkShareInfo) | Initializes a new instance of the Share class
Top
Properties
 | Name | Description
Public property | Aces |
Public property | MaxUsers |
Public property | Name |
Public property | Path |
Public property | Type |
Top
Operators
Name | Description
(Share to NetworkShareInfo) |
Top
See Also

Reference

DoubleTake.Monitoring.Contract Namespace


Share Constructor

Share Constructor
Overload List
 | Name | Description
Public method | Share | Initializes a new instance of the Share class
Public method | Share(NetworkShareInfo) | Initializes a new instance of the Share class
Top
See Also

Reference

Share Class
DoubleTake.Monitoring.Contract Namespace


Share Constructor

Share Constructor
Initializes a new instance of the Share class

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Share()
Public Sub New
public:
Share()
DoubleTake.Monitoring.Contract.Share = function();
See Also

Reference

Share Class
Share Overload
DoubleTake.Monitoring.Contract Namespace


Share Constructor (NetworkShareInfo)

Share Constructor (NetworkShareInfo)
Initializes a new instance of the Share class

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Share(
    NetworkShareInfo share
)
Public Sub New (
    share As NetworkShareInfo
)
public:
Share(
    NetworkShareInfo^ share
)
DoubleTake.Monitoring.Contract.Share = function(share);

Parameters

share
Type: NetworkShareInfo
See Also

Reference

Share Class
Share Overload
DoubleTake.Monitoring.Contract Namespace


Share Properties

Share Properties

The Share type exposes the following members.

Properties
 | Name | Description
Public property | Aces |
Public property | MaxUsers |
Public property | Name |
Public property | Path |
Public property | Type |
Top
See Also

Reference

Share Class
DoubleTake.Monitoring.Contract Namespace


Share.Aces Property

ShareAces Property

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public IEnumerable<Ace> Aces { get; set; }
Public Property Aces As IEnumerable(Of Ace)
    Get
    Set
public:
property IEnumerable<Ace^>^ Aces {
    IEnumerable<Ace^>^ get ();
    void set (IEnumerable<Ace^>^ value);
}
function get_Aces();
function set_Aces(value);

Property Value

Type: IEnumerable Ace
See Also

Reference

Share Class
DoubleTake.Monitoring.Contract Namespace


Share.MaxUsers Property

ShareMaxUsers Property

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Nullable<int> MaxUsers { get; set; }
Public Property MaxUsers As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> MaxUsers {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
function get_MaxUsers();
function set_MaxUsers(value);

Property Value

Type: Nullable Int32
See Also

Reference

Share Class
DoubleTake.Monitoring.Contract Namespace


Share.Name Property

ShareName Property

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
function get_Name();
function set_Name(value);

Property Value

Type: String
See Also

Reference

Share Class
DoubleTake.Monitoring.Contract Namespace


Share.Path Property

SharePath Property

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Path { get; set; }
Public Property Path As String
    Get
    Set
public:
property String^ Path {
    String^ get ();
    void set (String^ value);
}
function get_Path();
function set_Path(value);

Property Value

Type: String
See Also

Reference

Share Class
DoubleTake.Monitoring.Contract Namespace


Share.Type Property

ShareType Property

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int Type { get; set; }
Public Property Type As Integer
    Get
    Set
public:
property int Type {
    int get ();
    void set (int value);
}
function get_Type();
function set_Type(value);

Property Value

Type: Int32
See Also

Reference

Share Class
DoubleTake.Monitoring.Contract Namespace


Share Type Conversions

Share Type Conversions

The Share type exposes the following members.

Operators
Name | Description
(Share to NetworkShareInfo) |
Top
See Also

Reference

Share Class
DoubleTake.Monitoring.Contract Namespace


Share Explicit Conversion (Share to NetworkShareInfo)

Share Conversion (Share to NetworkShareInfo)

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public static explicit operator NetworkShareInfo (
    Share share
)
Public Shared Narrowing Operator CType (
    share As Share
) As NetworkShareInfo
static explicit operator NetworkShareInfo^ (
    Share^ share
)
JavaScript does not support the declaration of new casting operators.

Parameters

share
Type: DoubleTake.Monitoring.ContractShare

Return Value

Type: NetworkShareInfo
See Also

Reference

Share Class
DoubleTake.Monitoring.Contract Namespace


ShareQueryInput Class

ShareQueryInput Class
Inheritance Hierarchy
SystemObject
DoubleTake.Monitoring.ContractQueryInput
DoubleTake.Monitoring.ContractShareQueryInput

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class ShareQueryInput : QueryInput
Public Class ShareQueryInput
    Inherits QueryInput
public ref class ShareQueryInput : public QueryInput
DoubleTake.Monitoring.Contract.ShareQueryInput = function();

Type.createClass(
    'DoubleTake.Monitoring.Contract.ShareQueryInput',
    DoubleTake.Monitoring.Contract.QueryInput);

The ShareQueryInput type exposes the following members.

Constructors
 | Name | Description
Public method | ShareQueryInput | Initializes a new instance of the ShareQueryInput class
Top
Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the query. (Inherited from QueryInput.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from QueryInput.)
Top
Fields
 | Name | Description
Public field | idJob |
Public field | rules |
Public field | target |
Top
See Also

Reference

DoubleTake.Monitoring.Contract Namespace


ShareQueryInput Constructor

ShareQueryInput Constructor
Initializes a new instance of the ShareQueryInput class

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ShareQueryInput()
Public Sub New
public:
ShareQueryInput()
DoubleTake.Monitoring.Contract.ShareQueryInput = function();
See Also

Reference

ShareQueryInput Class
DoubleTake.Monitoring.Contract Namespace


ShareQueryInput Properties

ShareQueryInput Properties

The ShareQueryInput type exposes the following members.

Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the query. (Inherited from QueryInput.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from QueryInput.)
Top
See Also

Reference

ShareQueryInput Class
DoubleTake.Monitoring.Contract Namespace


ShareQueryInput Fields

ShareQueryInput Fields

The ShareQueryInput type exposes the following members.

Fields
 | Name | Description
Public field | idJob |
Public field | rules |
Public field | target |
Top
See Also

Reference

ShareQueryInput Class
DoubleTake.Monitoring.Contract Namespace


ShareQueryInput.idJob Field

ShareQueryInputidJob Field

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Guid idJob
Public idJob As Guid
public:
Guid idJob
var idJob

Field Value

Type: Guid
See Also

Reference

ShareQueryInput Class
DoubleTake.Monitoring.Contract Namespace


ShareQueryInput.rules Field

ShareQueryInputrules Field

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public IEnumerable<PhysicalRule> rules
Public rules As IEnumerable(Of PhysicalRule)
public:
IEnumerable<PhysicalRule^>^ rules
var rules

Field Value

Type: IEnumerable PhysicalRule
See Also

Reference

ShareQueryInput Class
DoubleTake.Monitoring.Contract Namespace


ShareQueryInput.target Field

ShareQueryInputtarget Field

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Uri target
Public target As Uri
public:
Uri^ target
var target

Field Value

Type: Uri
See Also

Reference

ShareQueryInput Class
DoubleTake.Monitoring.Contract Namespace


ShareQueryResult Class

ShareQueryResult Class
Inheritance Hierarchy
SystemObject
DoubleTake.Monitoring.ContractQueryResult
DoubleTake.Monitoring.ContractShareQueryResult

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class ShareQueryResult : QueryResult
Public Class ShareQueryResult
    Inherits QueryResult
public ref class ShareQueryResult : public QueryResult
DoubleTake.Monitoring.Contract.ShareQueryResult = function();

Type.createClass(
    'DoubleTake.Monitoring.Contract.ShareQueryResult',
    DoubleTake.Monitoring.Contract.QueryResult);

The ShareQueryResult type exposes the following members.

Constructors
 | Name | Description
Public method | ShareQueryResult | Initializes a new instance of the ShareQueryResult class
Top
Properties
 | Name | Description
Public property | Exception | Gets or sets the query exception. (Inherited from QueryResult.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from QueryResult.)
Public property | Result | Gets or sets a value indicating whether or not the query was successful. (Inherited from QueryResult.)
Top
Fields
 | Name | Description
Public field | Shares |
Top
See Also

Reference

DoubleTake.Monitoring.Contract Namespace


ShareQueryResult Constructor

ShareQueryResult Constructor
Initializes a new instance of the ShareQueryResult class

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ShareQueryResult()
Public Sub New
public:
ShareQueryResult()
DoubleTake.Monitoring.Contract.ShareQueryResult = function();
See Also

Reference

ShareQueryResult Class
DoubleTake.Monitoring.Contract Namespace


ShareQueryResult Properties

ShareQueryResult Properties

The ShareQueryResult type exposes the following members.

Properties
 | Name | Description
Public property | Exception | Gets or sets the query exception. (Inherited from QueryResult.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from QueryResult.)
Public property | Result | Gets or sets a value indicating whether or not the query was successful. (Inherited from QueryResult.)
Top
See Also

Reference

ShareQueryResult Class
DoubleTake.Monitoring.Contract Namespace


ShareQueryResult Fields

ShareQueryResult Fields

The ShareQueryResult type exposes the following members.

Fields
 | Name | Description
Public field | Shares |
Top
See Also

Reference

ShareQueryResult Class
DoubleTake.Monitoring.Contract Namespace


ShareQueryResult.Shares Field

ShareQueryResultShares Field

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public IEnumerable<Share> Shares
Public Shares As IEnumerable(Of Share)
public:
IEnumerable<Share^>^ Shares
var Shares

Field Value

Type: IEnumerable Share
See Also

Reference

ShareQueryResult Class
DoubleTake.Monitoring.Contract Namespace


SimpleMonitorInfo Class

SimpleMonitorInfo Class
This class represents a partial definition of a monitor object. Use this class if you only care about a few critical parts of the whole definition.
Inheritance Hierarchy
SystemObject
DoubleTake.Monitoring.ContractSimpleMonitorInfo

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class SimpleMonitorInfo : IExtensibleDataObject
Public Class SimpleMonitorInfo
    Implements IExtensibleDataObject
public ref class SimpleMonitorInfo : IExtensibleDataObject
DoubleTake.Monitoring.Contract.SimpleMonitorInfo = function();

Type.createClass(
    'DoubleTake.Monitoring.Contract.SimpleMonitorInfo',
    null,
    IExtensibleDataObject);

The SimpleMonitorInfo type exposes the following members.

Constructors
 | Name | Description
Public method | SimpleMonitorInfo | Initializes a new instance of the SimpleMonitorInfo class
Top
Properties
 | Name | Description
Public property | CanStart | Gets or sets a value indicating whether this instance can start.
Public property | CanStop | Gets or sets a value indicating whether this instance can stop.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Id | Gets or sets the id.
Public property | Misses | Gets or sets the misses.
Public property | Name | Gets or sets the name.
Public property | State | Gets or sets the state of the monitor.
Top
See Also

Reference

DoubleTake.Monitoring.Contract Namespace


SimpleMonitorInfo Constructor

SimpleMonitorInfo Constructor
Initializes a new instance of the SimpleMonitorInfo class

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public SimpleMonitorInfo()
Public Sub New
public:
SimpleMonitorInfo()
DoubleTake.Monitoring.Contract.SimpleMonitorInfo = function();
See Also

Reference

SimpleMonitorInfo Class
DoubleTake.Monitoring.Contract Namespace


SimpleMonitorInfo Properties

SimpleMonitorInfo Properties

The SimpleMonitorInfo type exposes the following members.

Properties
 | Name | Description
Public property | CanStart | Gets or sets a value indicating whether this instance can start.
Public property | CanStop | Gets or sets a value indicating whether this instance can stop.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Id | Gets or sets the id.
Public property | Misses | Gets or sets the misses.
Public property | Name | Gets or sets the name.
Public property | State | Gets or sets the state of the monitor.
Top
See Also

Reference

SimpleMonitorInfo Class
DoubleTake.Monitoring.Contract Namespace


SimpleMonitorInfo.CanStart Property

SimpleMonitorInfoCanStart Property
Gets or sets a value indicating whether this instance can start.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool CanStart { get; set; }
Public Property CanStart As Boolean
    Get
    Set
public:
property bool CanStart {
    bool get ();
    void set (bool value);
}
function get_CanStart();
function set_CanStart(value);

Property Value

Type: Boolean
if this instance can start; otherwise, .
See Also

Reference

SimpleMonitorInfo Class
DoubleTake.Monitoring.Contract Namespace


SimpleMonitorInfo.CanStop Property

SimpleMonitorInfoCanStop Property
Gets or sets a value indicating whether this instance can stop.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool CanStop { get; set; }
Public Property CanStop As Boolean
    Get
    Set
public:
property bool CanStop {
    bool get ();
    void set (bool value);
}
function get_CanStop();
function set_CanStop(value);

Property Value

Type: Boolean
if this instance can stop; otherwise, .
See Also

Reference

SimpleMonitorInfo Class
DoubleTake.Monitoring.Contract Namespace


SimpleMonitorInfo.ExtensionData Property

SimpleMonitorInfoExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

SimpleMonitorInfo Class
DoubleTake.Monitoring.Contract Namespace


SimpleMonitorInfo.Id Property

SimpleMonitorInfoId Property
Gets or sets the id.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Guid Id { get; set; }
Public Property Id As Guid
    Get
    Set
public:
property Guid Id {
    Guid get ();
    void set (Guid value);
}
function get_Id();
function set_Id(value);

Property Value

Type: Guid
The id.
See Also

Reference

SimpleMonitorInfo Class
DoubleTake.Monitoring.Contract Namespace


SimpleMonitorInfo.Misses Property

SimpleMonitorInfoMisses Property
Gets or sets the misses.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int Misses { get; set; }
Public Property Misses As Integer
    Get
    Set
public:
property int Misses {
    int get ();
    void set (int value);
}
function get_Misses();
function set_Misses(value);

Property Value

Type: Int32
The misses.
See Also

Reference

SimpleMonitorInfo Class
DoubleTake.Monitoring.Contract Namespace


SimpleMonitorInfo.Name Property

SimpleMonitorInfoName Property
Gets or sets the name.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
function get_Name();
function set_Name(value);

Property Value

Type: String
The name.
See Also

Reference

SimpleMonitorInfo Class
DoubleTake.Monitoring.Contract Namespace


SimpleMonitorInfo.State Property

SimpleMonitorInfoState Property
Gets or sets the state of the monitor.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public MonitorState State { get; set; }
Public Property State As MonitorState
    Get
    Set
public:
property MonitorState State {
    MonitorState get ();
    void set (MonitorState value);
}
function get_State();
function set_State(value);

Property Value

Type: MonitorState
The state of the monitor.
See Also

Reference

SimpleMonitorInfo Class
DoubleTake.Monitoring.Contract Namespace


TriggerMode Enumeration

TriggerMode Enumeration
Used to determine which criteria to use when triggering a monitor.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public enum TriggerMode
Public Enumeration TriggerMode
public enum class TriggerMode
DoubleTake.Monitoring.Contract.TriggerMode = function();
DoubleTake.Monitoring.Contract.TriggerMode.createEnum('DoubleTake.Monitoring.Contract.TriggerMode', false);
Members
Member name | Value | Description
MissesAllowed | 0 | Monitor will trigger when the number of allowed misses is reached.
TimeAllowed | 1 | Monitor will trigger when the time allowed expires.
See Also

Reference

DoubleTake.Monitoring.Contract Namespace


ValidationFault Class

ValidationFault Class
Fault contract issued by validation methods when the validation fails.
Inheritance Hierarchy
SystemObject
DoubleTake.Monitoring.ContractValidationFault

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class ValidationFault : IExtensibleDataObject
Public Class ValidationFault
    Implements IExtensibleDataObject
public ref class ValidationFault : IExtensibleDataObject
DoubleTake.Monitoring.Contract.ValidationFault = function();

Type.createClass(
    'DoubleTake.Monitoring.Contract.ValidationFault',
    null,
    IExtensibleDataObject);

The ValidationFault type exposes the following members.

Constructors
 | Name | Description
Public method | ValidationFault | Initializes a new instance of the ValidationFault class
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | PropertyFaults | Gets or sets the property faults.
Top
See Also

Reference

DoubleTake.Monitoring.Contract Namespace


ValidationFault Constructor

ValidationFault Constructor
Initializes a new instance of the ValidationFault class

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ValidationFault()
Public Sub New
public:
ValidationFault()
DoubleTake.Monitoring.Contract.ValidationFault = function();
See Also

Reference

ValidationFault Class
DoubleTake.Monitoring.Contract Namespace


ValidationFault Properties

ValidationFault Properties

The ValidationFault type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | PropertyFaults | Gets or sets the property faults.
Top
See Also

Reference

ValidationFault Class
DoubleTake.Monitoring.Contract Namespace


ValidationFault.ExtensionData Property

ValidationFaultExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

ValidationFault Class
DoubleTake.Monitoring.Contract Namespace


ValidationFault.PropertyFaults Property

ValidationFaultPropertyFaults Property
Gets or sets the property faults.

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public PropertyFault[] PropertyFaults { get; set; }
Public Property PropertyFaults As PropertyFault()
    Get
    Set
public:
property array<PropertyFault^>^ PropertyFaults {
    array<PropertyFault^>^ get ();
    void set (array<PropertyFault^>^ value);
}
function get_PropertyFaults();
function set_PropertyFaults(value);

Property Value

Type: PropertyFault
An array of PropertyFault instances.
See Also

Reference

ValidationFault Class
DoubleTake.Monitoring.Contract Namespace


VirtualSwitchConfigQueryInput Class

VirtualSwitchConfigQueryInput Class
Inheritance Hierarchy
SystemObject
DoubleTake.Monitoring.ContractQueryInput
DoubleTake.Monitoring.ContractVirtualSwitchConfigQueryInput

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class VirtualSwitchConfigQueryInput : QueryInput
Public Class VirtualSwitchConfigQueryInput
    Inherits QueryInput
public ref class VirtualSwitchConfigQueryInput : public QueryInput
DoubleTake.Monitoring.Contract.VirtualSwitchConfigQueryInput = function();

Type.createClass(
    'DoubleTake.Monitoring.Contract.VirtualSwitchConfigQueryInput',
    DoubleTake.Monitoring.Contract.QueryInput);

The VirtualSwitchConfigQueryInput type exposes the following members.

Constructors
 | Name | Description
Public method | VirtualSwitchConfigQueryInput | Initializes a new instance of the VirtualSwitchConfigQueryInput class
Top
Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the query. (Inherited from QueryInput.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from QueryInput.)
Public property | VirtualSwitchInfoColl |
Public property | VmId |
Top
See Also

Reference

DoubleTake.Monitoring.Contract Namespace


VirtualSwitchConfigQueryInput Constructor

VirtualSwitchConfigQueryInput Constructor
Initializes a new instance of the VirtualSwitchConfigQueryInput class

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VirtualSwitchConfigQueryInput()
Public Sub New
public:
VirtualSwitchConfigQueryInput()
DoubleTake.Monitoring.Contract.VirtualSwitchConfigQueryInput = function();
See Also

Reference

VirtualSwitchConfigQueryInput Class
DoubleTake.Monitoring.Contract Namespace


VirtualSwitchConfigQueryInput Properties

VirtualSwitchConfigQueryInput Properties

The VirtualSwitchConfigQueryInput type exposes the following members.

Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the query. (Inherited from QueryInput.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from QueryInput.)
Public property | VirtualSwitchInfoColl |
Public property | VmId |
Top
See Also

Reference

VirtualSwitchConfigQueryInput Class
DoubleTake.Monitoring.Contract Namespace


VirtualSwitchConfigQueryInput.VirtualSwitchInfoColl Property

VirtualSwitchConfigQueryInputVirtualSwitchInfoColl Property

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VirtualSwitchInfo[] VirtualSwitchInfoColl { get; set; }
Public Property VirtualSwitchInfoColl As VirtualSwitchInfo()
    Get
    Set
public:
property array<VirtualSwitchInfo^>^ VirtualSwitchInfoColl {
    array<VirtualSwitchInfo^>^ get ();
    void set (array<VirtualSwitchInfo^>^ value);
}
function get_VirtualSwitchInfoColl();
function set_VirtualSwitchInfoColl(value);

Property Value

Type: VirtualSwitchInfo
See Also

Reference

VirtualSwitchConfigQueryInput Class
DoubleTake.Monitoring.Contract Namespace


VirtualSwitchConfigQueryInput.VmId Property

VirtualSwitchConfigQueryInputVmId Property

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string VmId { get; set; }
Public Property VmId As String
    Get
    Set
public:
property String^ VmId {
    String^ get ();
    void set (String^ value);
}
function get_VmId();
function set_VmId(value);

Property Value

Type: String
See Also

Reference

VirtualSwitchConfigQueryInput Class
DoubleTake.Monitoring.Contract Namespace


VirtualSwitchConfigQueryResult Class

VirtualSwitchConfigQueryResult Class
Inheritance Hierarchy
SystemObject
DoubleTake.Monitoring.ContractQueryResult
DoubleTake.Monitoring.ContractVirtualSwitchConfigQueryResult

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class VirtualSwitchConfigQueryResult : QueryResult
Public Class VirtualSwitchConfigQueryResult
    Inherits QueryResult
public ref class VirtualSwitchConfigQueryResult : public QueryResult
DoubleTake.Monitoring.Contract.VirtualSwitchConfigQueryResult = function();

Type.createClass(
    'DoubleTake.Monitoring.Contract.VirtualSwitchConfigQueryResult',
    DoubleTake.Monitoring.Contract.QueryResult);

The VirtualSwitchConfigQueryResult type exposes the following members.

Constructors
 | Name | Description
Public method | VirtualSwitchConfigQueryResult | Initializes a new instance of the VirtualSwitchConfigQueryResult class
Top
Properties
 | Name | Description
Public property | Exception | Gets or sets the query exception. (Inherited from QueryResult.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from QueryResult.)
Public property | Result | Gets or sets a value indicating whether or not the query was successful. (Inherited from QueryResult.)
Public property | VirtualSwitchInfoColl |
Public property | VmId |
Top
See Also

Reference

DoubleTake.Monitoring.Contract Namespace


VirtualSwitchConfigQueryResult Constructor

VirtualSwitchConfigQueryResult Constructor
Initializes a new instance of the VirtualSwitchConfigQueryResult class

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VirtualSwitchConfigQueryResult()
Public Sub New
public:
VirtualSwitchConfigQueryResult()
DoubleTake.Monitoring.Contract.VirtualSwitchConfigQueryResult = function();
See Also

Reference

VirtualSwitchConfigQueryResult Class
DoubleTake.Monitoring.Contract Namespace


VirtualSwitchConfigQueryResult Properties

VirtualSwitchConfigQueryResult Properties

The VirtualSwitchConfigQueryResult type exposes the following members.

Properties
 | Name | Description
Public property | Exception | Gets or sets the query exception. (Inherited from QueryResult.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from QueryResult.)
Public property | Result | Gets or sets a value indicating whether or not the query was successful. (Inherited from QueryResult.)
Public property | VirtualSwitchInfoColl |
Public property | VmId |
Top
See Also

Reference

VirtualSwitchConfigQueryResult Class
DoubleTake.Monitoring.Contract Namespace


VirtualSwitchConfigQueryResult.VirtualSwitchInfoColl Property

VirtualSwitchConfigQueryResultVirtualSwitchInfoColl Property

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VirtualSwitchInfo[] VirtualSwitchInfoColl { get; set; }
Public Property VirtualSwitchInfoColl As VirtualSwitchInfo()
    Get
    Set
public:
property array<VirtualSwitchInfo^>^ VirtualSwitchInfoColl {
    array<VirtualSwitchInfo^>^ get ();
    void set (array<VirtualSwitchInfo^>^ value);
}
function get_VirtualSwitchInfoColl();
function set_VirtualSwitchInfoColl(value);

Property Value

Type: VirtualSwitchInfo
See Also

Reference

VirtualSwitchConfigQueryResult Class
DoubleTake.Monitoring.Contract Namespace


VirtualSwitchConfigQueryResult.VmId Property

VirtualSwitchConfigQueryResultVmId Property

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string VmId { get; set; }
Public Property VmId As String
    Get
    Set
public:
property String^ VmId {
    String^ get ();
    void set (String^ value);
}
function get_VmId();
function set_VmId(value);

Property Value

Type: String
See Also

Reference

VirtualSwitchConfigQueryResult Class
DoubleTake.Monitoring.Contract Namespace


VmConfigQueryInput Class

VmConfigQueryInput Class
Inheritance Hierarchy
SystemObject
DoubleTake.Monitoring.ContractQueryInput
DoubleTake.Monitoring.ContractVmConfigQueryInput

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class VmConfigQueryInput : QueryInput
Public Class VmConfigQueryInput
    Inherits QueryInput
public ref class VmConfigQueryInput : public QueryInput
DoubleTake.Monitoring.Contract.VmConfigQueryInput = function();

Type.createClass(
    'DoubleTake.Monitoring.Contract.VmConfigQueryInput',
    DoubleTake.Monitoring.Contract.QueryInput);

The VmConfigQueryInput type exposes the following members.

Constructors
 | Name | Description
Public method | VmConfigQueryInput | Initializes a new instance of the VmConfigQueryInput class
Top
Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the query. (Inherited from QueryInput.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from QueryInput.)
Public property | externalDataRoot |
Public property | snapshotDataRoot |
Public property | VhdPath |
Public property | VmId |
Top
See Also

Reference

DoubleTake.Monitoring.Contract Namespace


VmConfigQueryInput Constructor

VmConfigQueryInput Constructor
Initializes a new instance of the VmConfigQueryInput class

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VmConfigQueryInput()
Public Sub New
public:
VmConfigQueryInput()
DoubleTake.Monitoring.Contract.VmConfigQueryInput = function();
See Also

Reference

VmConfigQueryInput Class
DoubleTake.Monitoring.Contract Namespace


VmConfigQueryInput Properties

VmConfigQueryInput Properties

The VmConfigQueryInput type exposes the following members.

Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the query. (Inherited from QueryInput.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from QueryInput.)
Public property | externalDataRoot |
Public property | snapshotDataRoot |
Public property | VhdPath |
Public property | VmId |
Top
See Also

Reference

VmConfigQueryInput Class
DoubleTake.Monitoring.Contract Namespace


VmConfigQueryInput.externalDataRoot Property

VmConfigQueryInputexternalDataRoot Property

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string externalDataRoot { get; set; }
Public Property externalDataRoot As String
    Get
    Set
public:
property String^ externalDataRoot {
    String^ get ();
    void set (String^ value);
}
function get_externalDataRoot();
function set_externalDataRoot(value);

Property Value

Type: String
See Also

Reference

VmConfigQueryInput Class
DoubleTake.Monitoring.Contract Namespace


VmConfigQueryInput.snapshotDataRoot Property

VmConfigQueryInputsnapshotDataRoot Property

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string snapshotDataRoot { get; set; }
Public Property snapshotDataRoot As String
    Get
    Set
public:
property String^ snapshotDataRoot {
    String^ get ();
    void set (String^ value);
}
function get_snapshotDataRoot();
function set_snapshotDataRoot(value);

Property Value

Type: String
See Also

Reference

VmConfigQueryInput Class
DoubleTake.Monitoring.Contract Namespace


VmConfigQueryInput.VhdPath Property

VmConfigQueryInputVhdPath Property

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string[] VhdPath { get; set; }
Public Property VhdPath As String()
    Get
    Set
public:
property array<String^>^ VhdPath {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
function get_VhdPath();
function set_VhdPath(value);

Property Value

Type: String
See Also

Reference

VmConfigQueryInput Class
DoubleTake.Monitoring.Contract Namespace


VmConfigQueryInput.VmId Property

VmConfigQueryInputVmId Property

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string VmId { get; set; }
Public Property VmId As String
    Get
    Set
public:
property String^ VmId {
    String^ get ();
    void set (String^ value);
}
function get_VmId();
function set_VmId(value);

Property Value

Type: String
See Also

Reference

VmConfigQueryInput Class
DoubleTake.Monitoring.Contract Namespace


VmConfigQueryResult Class

VmConfigQueryResult Class
Inheritance Hierarchy
SystemObject
DoubleTake.Monitoring.ContractQueryResult
DoubleTake.Monitoring.ContractVmConfigQueryResult

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class VmConfigQueryResult : QueryResult
Public Class VmConfigQueryResult
    Inherits QueryResult
public ref class VmConfigQueryResult : public QueryResult
DoubleTake.Monitoring.Contract.VmConfigQueryResult = function();

Type.createClass(
    'DoubleTake.Monitoring.Contract.VmConfigQueryResult',
    DoubleTake.Monitoring.Contract.QueryResult);

The VmConfigQueryResult type exposes the following members.

Constructors
 | Name | Description
Public method | VmConfigQueryResult | Initializes a new instance of the VmConfigQueryResult class
Top
Properties
 | Name | Description
Public property | Exception | Gets or sets the query exception. (Inherited from QueryResult.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from QueryResult.)
Public property | Result | Gets or sets a value indicating whether or not the query was successful. (Inherited from QueryResult.)
Public property | VhdPath |
Public property | VirtualSwitchInfoColl |
Public property | VmId |
Public property | VmSnapshotDataRoot |
Public property | VmSnapshotFileNames |
Top
See Also

Reference

DoubleTake.Monitoring.Contract Namespace


VmConfigQueryResult Constructor

VmConfigQueryResult Constructor
Initializes a new instance of the VmConfigQueryResult class

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VmConfigQueryResult()
Public Sub New
public:
VmConfigQueryResult()
DoubleTake.Monitoring.Contract.VmConfigQueryResult = function();
See Also

Reference

VmConfigQueryResult Class
DoubleTake.Monitoring.Contract Namespace


VmConfigQueryResult Properties

VmConfigQueryResult Properties

The VmConfigQueryResult type exposes the following members.

Properties
 | Name | Description
Public property | Exception | Gets or sets the query exception. (Inherited from QueryResult.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from QueryResult.)
Public property | Result | Gets or sets a value indicating whether or not the query was successful. (Inherited from QueryResult.)
Public property | VhdPath |
Public property | VirtualSwitchInfoColl |
Public property | VmId |
Public property | VmSnapshotDataRoot |
Public property | VmSnapshotFileNames |
Top
See Also

Reference

VmConfigQueryResult Class
DoubleTake.Monitoring.Contract Namespace


VmConfigQueryResult.VhdPath Property

VmConfigQueryResultVhdPath Property

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string[] VhdPath { get; set; }
Public Property VhdPath As String()
    Get
    Set
public:
property array<String^>^ VhdPath {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
function get_VhdPath();
function set_VhdPath(value);

Property Value

Type: String
See Also

Reference

VmConfigQueryResult Class
DoubleTake.Monitoring.Contract Namespace


VmConfigQueryResult.VirtualSwitchInfoColl Property

VmConfigQueryResultVirtualSwitchInfoColl Property

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VirtualSwitchInfo[] VirtualSwitchInfoColl { get; set; }
Public Property VirtualSwitchInfoColl As VirtualSwitchInfo()
    Get
    Set
public:
property array<VirtualSwitchInfo^>^ VirtualSwitchInfoColl {
    array<VirtualSwitchInfo^>^ get ();
    void set (array<VirtualSwitchInfo^>^ value);
}
function get_VirtualSwitchInfoColl();
function set_VirtualSwitchInfoColl(value);

Property Value

Type: VirtualSwitchInfo
See Also

Reference

VmConfigQueryResult Class
DoubleTake.Monitoring.Contract Namespace


VmConfigQueryResult.VmId Property

VmConfigQueryResultVmId Property

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string VmId { get; set; }
Public Property VmId As String
    Get
    Set
public:
property String^ VmId {
    String^ get ();
    void set (String^ value);
}
function get_VmId();
function set_VmId(value);

Property Value

Type: String
See Also

Reference

VmConfigQueryResult Class
DoubleTake.Monitoring.Contract Namespace


VmConfigQueryResult.VmSnapshotDataRoot Property

VmConfigQueryResultVmSnapshotDataRoot Property

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string VmSnapshotDataRoot { get; set; }
Public Property VmSnapshotDataRoot As String
    Get
    Set
public:
property String^ VmSnapshotDataRoot {
    String^ get ();
    void set (String^ value);
}
function get_VmSnapshotDataRoot();
function set_VmSnapshotDataRoot(value);

Property Value

Type: String
See Also

Reference

VmConfigQueryResult Class
DoubleTake.Monitoring.Contract Namespace


VmConfigQueryResult.VmSnapshotFileNames Property

VmConfigQueryResultVmSnapshotFileNames Property

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string[] VmSnapshotFileNames { get; set; }
Public Property VmSnapshotFileNames As String()
    Get
    Set
public:
property array<String^>^ VmSnapshotFileNames {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
function get_VmSnapshotFileNames();
function set_VmSnapshotFileNames(value);

Property Value

Type: String
See Also

Reference

VmConfigQueryResult Class
DoubleTake.Monitoring.Contract Namespace


VmHealthQueryInput Class

VmHealthQueryInput Class
Inheritance Hierarchy
SystemObject
DoubleTake.Monitoring.ContractQueryInput
DoubleTake.Monitoring.ContractVmHealthQueryInput

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class VmHealthQueryInput : QueryInput
Public Class VmHealthQueryInput
    Inherits QueryInput
public ref class VmHealthQueryInput : public QueryInput
DoubleTake.Monitoring.Contract.VmHealthQueryInput = function();

Type.createClass(
    'DoubleTake.Monitoring.Contract.VmHealthQueryInput',
    DoubleTake.Monitoring.Contract.QueryInput);

The VmHealthQueryInput type exposes the following members.

Constructors
 | Name | Description
Public method | VmHealthQueryInput | Initializes a new instance of the VmHealthQueryInput class
Top
Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the query. (Inherited from QueryInput.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from QueryInput.)
Public property | VmId |
Top
See Also

Reference

DoubleTake.Monitoring.Contract Namespace


VmHealthQueryInput Constructor

VmHealthQueryInput Constructor
Initializes a new instance of the VmHealthQueryInput class

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VmHealthQueryInput()
Public Sub New
public:
VmHealthQueryInput()
DoubleTake.Monitoring.Contract.VmHealthQueryInput = function();
See Also

Reference

VmHealthQueryInput Class
DoubleTake.Monitoring.Contract Namespace


VmHealthQueryInput Properties

VmHealthQueryInput Properties

The VmHealthQueryInput type exposes the following members.

Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the query. (Inherited from QueryInput.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from QueryInput.)
Public property | VmId |
Top
See Also

Reference

VmHealthQueryInput Class
DoubleTake.Monitoring.Contract Namespace


VmHealthQueryInput.VmId Property

VmHealthQueryInputVmId Property

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string VmId { get; set; }
Public Property VmId As String
    Get
    Set
public:
property String^ VmId {
    String^ get ();
    void set (String^ value);
}
function get_VmId();
function set_VmId(value);

Property Value

Type: String
See Also

Reference

VmHealthQueryInput Class
DoubleTake.Monitoring.Contract Namespace


VmHealthQueryResult Class

VmHealthQueryResult Class
Inheritance Hierarchy
SystemObject
DoubleTake.Monitoring.ContractQueryResult
DoubleTake.Monitoring.ContractVmHealthQueryResult

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class VmHealthQueryResult : QueryResult
Public Class VmHealthQueryResult
    Inherits QueryResult
public ref class VmHealthQueryResult : public QueryResult
DoubleTake.Monitoring.Contract.VmHealthQueryResult = function();

Type.createClass(
    'DoubleTake.Monitoring.Contract.VmHealthQueryResult',
    DoubleTake.Monitoring.Contract.QueryResult);

The VmHealthQueryResult type exposes the following members.

Constructors
 | Name | Description
Public method | VmHealthQueryResult | Initializes a new instance of the VmHealthQueryResult class
Top
Properties
 | Name | Description
Public property | Exception | Gets or sets the query exception. (Inherited from QueryResult.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from QueryResult.)
Public property | Result | Gets or sets a value indicating whether or not the query was successful. (Inherited from QueryResult.)
Public property | VmId |
Top
See Also

Reference

DoubleTake.Monitoring.Contract Namespace


VmHealthQueryResult Constructor

VmHealthQueryResult Constructor
Initializes a new instance of the VmHealthQueryResult class

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VmHealthQueryResult()
Public Sub New
public:
VmHealthQueryResult()
DoubleTake.Monitoring.Contract.VmHealthQueryResult = function();
See Also

Reference

VmHealthQueryResult Class
DoubleTake.Monitoring.Contract Namespace


VmHealthQueryResult Properties

VmHealthQueryResult Properties

The VmHealthQueryResult type exposes the following members.

Properties
 | Name | Description
Public property | Exception | Gets or sets the query exception. (Inherited from QueryResult.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from QueryResult.)
Public property | Result | Gets or sets a value indicating whether or not the query was successful. (Inherited from QueryResult.)
Public property | VmId |
Top
See Also

Reference

VmHealthQueryResult Class
DoubleTake.Monitoring.Contract Namespace


VmHealthQueryResult.VmId Property

VmHealthQueryResultVmId Property

Namespace: DoubleTake.Monitoring.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string VmId { get; set; }
Public Property VmId As String
    Get
    Set
public:
property String^ VmId {
    String^ get ();
    void set (String^ value);
}
function get_VmId();
function set_VmId(value);

Property Value

Type: String
See Also

Reference

VmHealthQueryResult Class
DoubleTake.Monitoring.Contract Namespace


DoubleTake.PowerShell Namespace

DoubleTake.PowerShell Namespace
Classes
 | Class | Description
Public class | Server |


Server Class

Server Class
Inheritance Hierarchy
SystemObject
DoubleTake.PowerShellServer

Namespace: DoubleTake.PowerShell
Assembly: DoubleTake.PowerShell (in DoubleTake.PowerShell.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class Server
Public Class Server
public ref class Server
DoubleTake.PowerShell.Server = function();

Type.createClass(
    'DoubleTake.PowerShell.Server');

The Server type exposes the following members.

Constructors
 | Name | Description
Public method | Server | Initializes a new instance of the Server class
Top
Properties
 | Name | Description
Public property | Credentials |
Public property | HostName |
Public property | Port |
Public property | Role |
Top
Methods
 | Name | Description
Public method | GetProxyTClient |
Public method | RemoveAllAdapters |
Public method | UsingProxyTChannel(ActionTChannel) |
Public method | UsingProxyTChannel, TResult(FuncTChannel, TResult) |
Top
See Also

Reference

DoubleTake.PowerShell Namespace


Server Constructor

Server Constructor
Initializes a new instance of the Server class

Namespace: DoubleTake.PowerShell
Assembly: DoubleTake.PowerShell (in DoubleTake.PowerShell.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Server(
    string networkIdAndPort
)
Public Sub New (
    networkIdAndPort As String
)
public:
Server(
    String^ networkIdAndPort
)
DoubleTake.PowerShell.Server = function(networkIdAndPort);

Parameters

networkIdAndPort
Type: SystemString
See Also

Reference

Server Class
DoubleTake.PowerShell Namespace


Server Properties

Server Properties

The Server type exposes the following members.

Properties
 | Name | Description
Public property | Credentials |
Public property | HostName |
Public property | Port |
Public property | Role |
Top
See Also

Reference

Server Class
DoubleTake.PowerShell Namespace


Server.Credentials Property

ServerCredentials Property

Namespace: DoubleTake.PowerShell
Assembly: DoubleTake.PowerShell (in DoubleTake.PowerShell.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public PSCredential Credentials { get; set; }
Public Property Credentials As PSCredential
    Get
    Set
public:
property PSCredential^ Credentials {
    PSCredential^ get ();
    void set (PSCredential^ value);
}
function get_Credentials();
function set_Credentials(value);

Property Value

Type: PSCredential
See Also

Reference

Server Class
DoubleTake.PowerShell Namespace


Server.HostName Property

ServerHostName Property

Namespace: DoubleTake.PowerShell
Assembly: DoubleTake.PowerShell (in DoubleTake.PowerShell.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string HostName { get; }
Public ReadOnly Property HostName As String
    Get
public:
property String^ HostName {
    String^ get ();
}
function get_HostName();

Property Value

Type: String
See Also

Reference

Server Class
DoubleTake.PowerShell Namespace


Server.Port Property

ServerPort Property

Namespace: DoubleTake.PowerShell
Assembly: DoubleTake.PowerShell (in DoubleTake.PowerShell.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Nullable<int> Port { get; set; }
Public Property Port As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> Port {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
function get_Port();
function set_Port(value);

Property Value

Type: Nullable Int32
See Also

Reference

Server Class
DoubleTake.PowerShell Namespace


Server.Role Property

ServerRole Property

Namespace: DoubleTake.PowerShell
Assembly: DoubleTake.PowerShell (in DoubleTake.PowerShell.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Role { get; set; }
Public Property Role As String
    Get
    Set
public:
property String^ Role {
    String^ get ();
    void set (String^ value);
}
function get_Role();
function set_Role(value);

Property Value

Type: String
See Also

Reference

Server Class
DoubleTake.PowerShell Namespace


Server Methods

Server Methods

The Server type exposes the following members.

Methods
 | Name | Description
Public method | GetProxyTClient |
Public method | RemoveAllAdapters |
Public method | UsingProxyTChannel(ActionTChannel) |
Public method | UsingProxyTChannel, TResult(FuncTChannel, TResult) |
Top
See Also

Reference

Server Class
DoubleTake.PowerShell Namespace


Server.GetProxy(TClient) Method

ServerGetProxyTClient Method

Namespace: DoubleTake.PowerShell
Assembly: DoubleTake.PowerShell (in DoubleTake.PowerShell.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public TClient GetProxy<TClient>()
where TClient : class

Public Function GetProxy(Of TClient As Class) As TClient
public:
generic<typename TClient>
where TClient : ref class
TClient GetProxy()
JavaScript does not support generic types or methods.

Type Parameters

TClient

Return Value

Type: TClient
See Also

Reference

Server Class
DoubleTake.PowerShell Namespace


Server.RemoveAllAdapters Method

ServerRemoveAllAdapters Method

Namespace: DoubleTake.PowerShell
Assembly: DoubleTake.PowerShell (in DoubleTake.PowerShell.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public void RemoveAllAdapters()
Public Sub RemoveAllAdapters
public:
void RemoveAllAdapters()
function RemoveAllAdapters();
See Also

Reference

Server Class
DoubleTake.PowerShell Namespace


Server.UsingProxy Method

ServerUsingProxy Method
Overload List
 | Name | Description
Public method | UsingProxyTChannel(ActionTChannel) |
Public method | UsingProxyTChannel, TResult(FuncTChannel, TResult) |
Top
See Also

Reference

Server Class
DoubleTake.PowerShell Namespace


Server.UsingProxy(TChannel) Method (Action(TChannel))

ServerUsingProxyTChannel Method (ActionTChannel)

Namespace: DoubleTake.PowerShell
Assembly: DoubleTake.PowerShell (in DoubleTake.PowerShell.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public void UsingProxy<TChannel>(
    Action<TChannel> action
)
where TChannel : class

Public Sub UsingProxy(Of TChannel As Class) (
    action As Action(Of TChannel)
)
public:
generic<typename TChannel>
where TChannel : ref class
void UsingProxy(
    Action<TChannel>^ action
)
JavaScript does not support generic types or methods.

Parameters

action
Type: SystemAction TChannel

Type Parameters

TChannel
See Also

Reference

Server Class
UsingProxy Overload
DoubleTake.PowerShell Namespace


Server.UsingProxy(TChannel, TResult) Method (Func(TChannel, TResult))

ServerUsingProxyTChannel, TResult Method (FuncTChannel, TResult)

Namespace: DoubleTake.PowerShell
Assembly: DoubleTake.PowerShell (in DoubleTake.PowerShell.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public TResult UsingProxy<TChannel, TResult>(
    Func<TChannel, TResult> func
)
where TChannel : class

Public Function UsingProxy(Of TChannel As Class, TResult) (
    func As Func(Of TChannel, TResult)
) As TResult
public:
generic<typename TChannel, typename TResult>
where TChannel : ref class
TResult UsingProxy(
    Func<TChannel, TResult>^ func
)
JavaScript does not support generic types or methods.

Parameters

func
Type: SystemFunc TChannel, TResult

Type Parameters

TChannel
TResult

Return Value

Type: TResult
See Also

Reference

Server Class
UsingProxy Overload
DoubleTake.PowerShell Namespace


DoubleTake.Virtualization.Contract Namespace

DoubleTake.Virtualization.Contract Namespace
Classes
 | Class | Description
Public class | BootProcessingInfo | This class provides the information necessary for boot processing
Public class | BootProcessingLinuxVolumeInfo | Specifies information about the mount volumes.
Public class | BootProcessingNetworkResult | This class is used as a return result for the GetNetworkInterfaces operation.
Public class | BootProcessingResult | This class is used as a return result for the MakeBootable operation.
Public class | BootProcessingScrapeResult | This class is used as a return result for the Scrape operation.
Public class | BootProcessingTypes | These are the types of boot processing we can perform and are the constants used to fill the BootProcessingOptions.BootProcessingType field.
Public class | BootProcessingVolumeInfo | Specifies information about the mount volumes.
Public class | DiskInitializationInfo | Describes how a disk is to be partitioned and formatted. The DiskIdentifier is used to identify the disk to be partition. The Partitioning Scheme identifies if the disk is to use GPT or MBR. The array of PartitionInitializationInfo structures identifies how many partitions, what size and format they should have and other things.
Public class | DiskInitializationResult | This class is used as a return result for the InitializeDisk operation.
Public class | DiskManagementVolumeInfo |
Public class | DiskMountInfo |
Public class | DtServiceException_Fault |
Public class | ErrorInfo | Represents job error properties.
Public class | HyperVmNotFoundException_Fault |
Public class | JobState | Represents job state information.
Public class | LinuxBootProcessingOptions | Contains the information, not available from the source, to perform boot processing
Public class | NetworkAdapterInfo | Represents network adapter info
Public class | PartitionInitializationInfo | This class describes what a partition on the disk looks like and how it is formatted.
Public class | ServerQualificationResults | Represents server information to display on the Console
Public class | SwitchPortInfo | Represents virtual switch of Hyper-V/ESX
Public class | SystemInitializationInfo | Describes how a disk is to be partitioned and formatted. The DiskIdentifier is used to identify the disk to be partition. The Partitioning Scheme identifies if the disk is to use GPT or MBR. The array of PartitionInitializationInfo structures identifies how many partitions, what size and format they should have and other things.
Public class | VHDInfo | Part of VM configuration. Describes VHD that is part of VM VM configuration contains an array of these types: all VHDs of that VM.
Public class | VirtualizationConnectionInfo | This class represents the additional data required to create an manage an engine connection for a virtualization job
Public class | VirtualNetworkInterfaceInfo | This class adds the extra information we need for WAN Failover and host network mapping
Public class | VirtualSwitchInfo | Represents virtual switch of Hyper-V/ESX
Public class | VirtualSwitchMapping | Represents source and target virtual switch mappings
Public class | VMInfo | Represents properties of virtual machine.
Public class | VMQualificationResults | Represents server information to display on the Console
Public class | VolumeQualificationResults | Represents information of volume for console display.
Public class | WindowsBootProcessingOptions | Contains the information, not available from the source, to perform boot processing
Interfaces
 | Interface | Description
Public interface | IBootProcessing | This interface is for internal use only.
Public interface | IDiskManagement |
Public interface | IDTHVService | Public interace: Client to DTHV service Client is either console or a test script
Public interface | IVRAExtensionAPI |


BootProcessingInfo Class

BootProcessingInfo Class
This class provides the information necessary for boot processing
Inheritance Hierarchy
SystemObject
DoubleTake.Virtualization.ContractBootProcessingInfo

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class BootProcessingInfo : IExtensibleDataObject
Public Class BootProcessingInfo
    Implements IExtensibleDataObject
public ref class BootProcessingInfo : IExtensibleDataObject
DoubleTake.Virtualization.Contract.BootProcessingInfo = function();

Type.createClass(
    'DoubleTake.Virtualization.Contract.BootProcessingInfo',
    null,
    IExtensibleDataObject);

The BootProcessingInfo type exposes the following members.

Constructors
 | Name | Description
Public method | BootProcessingInfo | Initializes a new instance of the BootProcessingInfo class
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Hypervisor | Gets or sets a string representing the hypervisor. The values should come from the constants in DoubleTake.Virtualization.VRA.HyperVisorTypes
Public property | Id | Gets or sets the unique identifier of this boot processing job.
Public property | LinuxBootProcessingOptions |
Public property | SourceSystemStateXML | Gets or sets the source system state XML. If this property contains a filename, it will be opened and the XML read from that file, otherwise we will assume the property contains the actual XML text.
Public property | VmVersion | Gets or sets the vm version.
Public property | WindowsBootProcessingOptions |
Top
See Also

Reference

DoubleTake.Virtualization.Contract Namespace


BootProcessingInfo Constructor

BootProcessingInfo Constructor
Initializes a new instance of the BootProcessingInfo class

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public BootProcessingInfo()
Public Sub New
public:
BootProcessingInfo()
DoubleTake.Virtualization.Contract.BootProcessingInfo = function();
See Also

Reference

BootProcessingInfo Class
DoubleTake.Virtualization.Contract Namespace


BootProcessingInfo Properties

BootProcessingInfo Properties

The BootProcessingInfo type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Hypervisor | Gets or sets a string representing the hypervisor. The values should come from the constants in DoubleTake.Virtualization.VRA.HyperVisorTypes
Public property | Id | Gets or sets the unique identifier of this boot processing job.
Public property | LinuxBootProcessingOptions |
Public property | SourceSystemStateXML | Gets or sets the source system state XML. If this property contains a filename, it will be opened and the XML read from that file, otherwise we will assume the property contains the actual XML text.
Public property | VmVersion | Gets or sets the vm version.
Public property | WindowsBootProcessingOptions |
Top
See Also

Reference

BootProcessingInfo Class
DoubleTake.Virtualization.Contract Namespace


BootProcessingInfo.ExtensionData Property

BootProcessingInfoExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

BootProcessingInfo Class
DoubleTake.Virtualization.Contract Namespace


BootProcessingInfo.Hypervisor Property

BootProcessingInfoHypervisor Property
Gets or sets a string representing the hypervisor. The values should come from the constants in DoubleTake.Virtualization.VRA.HyperVisorTypes

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Hypervisor { get; set; }
Public Property Hypervisor As String
    Get
    Set
public:
property String^ Hypervisor {
    String^ get ();
    void set (String^ value);
}
function get_Hypervisor();
function set_Hypervisor(value);

Property Value

Type: String
The hyper visor.
See Also

Reference

BootProcessingInfo Class
DoubleTake.Virtualization.Contract Namespace


BootProcessingInfo.Id Property

BootProcessingInfoId Property
Gets or sets the unique identifier of this boot processing job.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Guid Id { get; set; }
Public Property Id As Guid
    Get
    Set
public:
property Guid Id {
    Guid get ();
    void set (Guid value);
}
function get_Id();
function set_Id(value);

Property Value

Type: Guid
The unique identifier of this boot processing job.
See Also

Reference

BootProcessingInfo Class
DoubleTake.Virtualization.Contract Namespace


BootProcessingInfo.LinuxBootProcessingOptions Property

BootProcessingInfoLinuxBootProcessingOptions Property

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public LinuxBootProcessingOptions LinuxBootProcessingOptions { get; set; }
Public Property LinuxBootProcessingOptions As LinuxBootProcessingOptions
    Get
    Set
public:
property LinuxBootProcessingOptions^ LinuxBootProcessingOptions {
    LinuxBootProcessingOptions^ get ();
    void set (LinuxBootProcessingOptions^ value);
}
function get_LinuxBootProcessingOptions();
function set_LinuxBootProcessingOptions(value);

Property Value

Type: LinuxBootProcessingOptions
See Also

Reference

BootProcessingInfo Class
DoubleTake.Virtualization.Contract Namespace


BootProcessingInfo.SourceSystemStateXML Property

BootProcessingInfoSourceSystemStateXML Property
Gets or sets the source system state XML. If this property contains a filename, it will be opened and the XML read from that file, otherwise we will assume the property contains the actual XML text.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string SourceSystemStateXML { get; set; }
Public Property SourceSystemStateXML As String
    Get
    Set
public:
property String^ SourceSystemStateXML {
    String^ get ();
    void set (String^ value);
}
function get_SourceSystemStateXML();
function set_SourceSystemStateXML(value);

Property Value

Type: String
The source system state XML.
See Also

Reference

BootProcessingInfo Class
DoubleTake.Virtualization.Contract Namespace


BootProcessingInfo.VmVersion Property

BootProcessingInfoVmVersion Property
Gets or sets the vm version.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string VmVersion { get; set; }
Public Property VmVersion As String
    Get
    Set
public:
property String^ VmVersion {
    String^ get ();
    void set (String^ value);
}
function get_VmVersion();
function set_VmVersion(value);

Property Value

Type: String
The vm version.
See Also

Reference

BootProcessingInfo Class
DoubleTake.Virtualization.Contract Namespace


BootProcessingInfo.WindowsBootProcessingOptions Property

BootProcessingInfoWindowsBootProcessingOptions Property

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public WindowsBootProcessingOptions WindowsBootProcessingOptions { get; set; }
Public Property WindowsBootProcessingOptions As WindowsBootProcessingOptions
    Get
    Set
public:
property WindowsBootProcessingOptions^ WindowsBootProcessingOptions {
    WindowsBootProcessingOptions^ get ();
    void set (WindowsBootProcessingOptions^ value);
}
function get_WindowsBootProcessingOptions();
function set_WindowsBootProcessingOptions(value);

Property Value

Type: WindowsBootProcessingOptions
See Also

Reference

BootProcessingInfo Class
DoubleTake.Virtualization.Contract Namespace


BootProcessingLinuxVolumeInfo Class

BootProcessingLinuxVolumeInfo Class
Specifies information about the mount volumes.
Inheritance Hierarchy
SystemObject
DoubleTake.Virtualization.ContractBootProcessingLinuxVolumeInfo

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class BootProcessingLinuxVolumeInfo : IExtensibleDataObject
Public Class BootProcessingLinuxVolumeInfo
    Implements IExtensibleDataObject
public ref class BootProcessingLinuxVolumeInfo : IExtensibleDataObject
DoubleTake.Virtualization.Contract.BootProcessingLinuxVolumeInfo = function();

Type.createClass(
    'DoubleTake.Virtualization.Contract.BootProcessingLinuxVolumeInfo',
    null,
    IExtensibleDataObject);

The BootProcessingLinuxVolumeInfo type exposes the following members.

Constructors
 | Name | Description
Public method | BootProcessingLinuxVolumeInfo | Initializes a new instance of the BootProcessingLinuxVolumeInfo class
Top
Properties
 | Name | Description
Public property | ApplianceDevice | Gets or sets the device the volume is attached to on the appliance.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Name | Gets or sets the name of the volume (usually source path on Linux)
Top
See Also

Reference

DoubleTake.Virtualization.Contract Namespace


BootProcessingLinuxVolumeInfo Constructor

BootProcessingLinuxVolumeInfo Constructor
Initializes a new instance of the BootProcessingLinuxVolumeInfo class

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public BootProcessingLinuxVolumeInfo()
Public Sub New
public:
BootProcessingLinuxVolumeInfo()
DoubleTake.Virtualization.Contract.BootProcessingLinuxVolumeInfo = function();
See Also

Reference

BootProcessingLinuxVolumeInfo Class
DoubleTake.Virtualization.Contract Namespace


BootProcessingLinuxVolumeInfo Properties

BootProcessingLinuxVolumeInfo Properties

The BootProcessingLinuxVolumeInfo type exposes the following members.

Properties
 | Name | Description
Public property | ApplianceDevice | Gets or sets the device the volume is attached to on the appliance.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Name | Gets or sets the name of the volume (usually source path on Linux)
Top
See Also

Reference

BootProcessingLinuxVolumeInfo Class
DoubleTake.Virtualization.Contract Namespace


BootProcessingLinuxVolumeInfo.ApplianceDevice Property

BootProcessingLinuxVolumeInfoApplianceDevice Property
Gets or sets the device the volume is attached to on the appliance.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string ApplianceDevice { get; set; }
Public Property ApplianceDevice As String
    Get
    Set
public:
property String^ ApplianceDevice {
    String^ get ();
    void set (String^ value);
}
function get_ApplianceDevice();
function set_ApplianceDevice(value);

Property Value

Type: String
Gets or sets the device the volume is attached to on the appliance.
See Also

Reference

BootProcessingLinuxVolumeInfo Class
DoubleTake.Virtualization.Contract Namespace


BootProcessingLinuxVolumeInfo.ExtensionData Property

BootProcessingLinuxVolumeInfoExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

BootProcessingLinuxVolumeInfo Class
DoubleTake.Virtualization.Contract Namespace


BootProcessingLinuxVolumeInfo.Name Property

BootProcessingLinuxVolumeInfoName Property
Gets or sets the name of the volume (usually source path on Linux)

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
function get_Name();
function set_Name(value);

Property Value

Type: String
The name.
See Also

Reference

BootProcessingLinuxVolumeInfo Class
DoubleTake.Virtualization.Contract Namespace


BootProcessingNetworkResult Class

BootProcessingNetworkResult Class
This class is used as a return result for the GetNetworkInterfaces operation.
Inheritance Hierarchy
SystemObject
DoubleTake.Virtualization.ContractBootProcessingNetworkResult

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class BootProcessingNetworkResult : IExtensibleDataObject
Public Class BootProcessingNetworkResult
    Implements IExtensibleDataObject
public ref class BootProcessingNetworkResult : IExtensibleDataObject
DoubleTake.Virtualization.Contract.BootProcessingNetworkResult = function();

Type.createClass(
    'DoubleTake.Virtualization.Contract.BootProcessingNetworkResult',
    null,
    IExtensibleDataObject);

The BootProcessingNetworkResult type exposes the following members.

Constructors
 | Name | Description
Public method | BootProcessingNetworkResult | Initializes a new instance of the BootProcessingNetworkResult class
Top
Properties
 | Name | Description
Public property | Completed | Gets or sets a value indicating whether this GetNetworkInterfaces() has completed running.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Message | Gets or sets the log.
Public property | NetworkInterface | Gets or sets a value indicating whether this GetNetworkInterfaces() is a success.
Top
See Also

Reference

DoubleTake.Virtualization.Contract Namespace


BootProcessingNetworkResult Constructor

BootProcessingNetworkResult Constructor
Initializes a new instance of the BootProcessingNetworkResult class

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public BootProcessingNetworkResult()
Public Sub New
public:
BootProcessingNetworkResult()
DoubleTake.Virtualization.Contract.BootProcessingNetworkResult = function();
See Also

Reference

BootProcessingNetworkResult Class
DoubleTake.Virtualization.Contract Namespace


BootProcessingNetworkResult Properties

BootProcessingNetworkResult Properties

The BootProcessingNetworkResult type exposes the following members.

Properties
 | Name | Description
Public property | Completed | Gets or sets a value indicating whether this GetNetworkInterfaces() has completed running.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Message | Gets or sets the log.
Public property | NetworkInterface | Gets or sets a value indicating whether this GetNetworkInterfaces() is a success.
Top
See Also

Reference

BootProcessingNetworkResult Class
DoubleTake.Virtualization.Contract Namespace


BootProcessingNetworkResult.Completed Property

BootProcessingNetworkResultCompleted Property
Gets or sets a value indicating whether this GetNetworkInterfaces() has completed running.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool Completed { get; set; }
Public Property Completed As Boolean
    Get
    Set
public:
property bool Completed {
    bool get ();
    void set (bool value);
}
function get_Completed();
function set_Completed(value);

Property Value

Type: Boolean
true if success; otherwise, false.
See Also

Reference

BootProcessingNetworkResult Class
DoubleTake.Virtualization.Contract Namespace


BootProcessingNetworkResult.ExtensionData Property

BootProcessingNetworkResultExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

BootProcessingNetworkResult Class
DoubleTake.Virtualization.Contract Namespace


BootProcessingNetworkResult.Message Property

BootProcessingNetworkResultMessage Property
Gets or sets the log.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Message { get; set; }
Public Property Message As String
    Get
    Set
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}
function get_Message();
function set_Message(value);

Property Value

Type: String
The log generated by the GetNetworkInterfaces() operation.
See Also

Reference

BootProcessingNetworkResult Class
DoubleTake.Virtualization.Contract Namespace


BootProcessingNetworkResult.NetworkInterface Property

BootProcessingNetworkResultNetworkInterface Property
Gets or sets a value indicating whether this GetNetworkInterfaces() is a success.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VirtualNetworkInterfaceInfo[] NetworkInterface { get; set; }
Public Property NetworkInterface As VirtualNetworkInterfaceInfo()
    Get
    Set
public:
property array<VirtualNetworkInterfaceInfo^>^ NetworkInterface {
    array<VirtualNetworkInterfaceInfo^>^ get ();
    void set (array<VirtualNetworkInterfaceInfo^>^ value);
}
function get_NetworkInterface();
function set_NetworkInterface(value);

Property Value

Type: VirtualNetworkInterfaceInfo
Network interface information.
See Also

Reference

BootProcessingNetworkResult Class
DoubleTake.Virtualization.Contract Namespace


BootProcessingResult Class

BootProcessingResult Class
This class is used as a return result for the MakeBootable operation.
Inheritance Hierarchy
SystemObject
DoubleTake.Virtualization.ContractBootProcessingResult

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class BootProcessingResult : IExtensibleDataObject
Public Class BootProcessingResult
    Implements IExtensibleDataObject
public ref class BootProcessingResult : IExtensibleDataObject
DoubleTake.Virtualization.Contract.BootProcessingResult = function();

Type.createClass(
    'DoubleTake.Virtualization.Contract.BootProcessingResult',
    null,
    IExtensibleDataObject);

The BootProcessingResult type exposes the following members.

Constructors
 | Name | Description
Public method | BootProcessingResult | Initializes a new instance of the BootProcessingResult class
Top
Properties
 | Name | Description
Public property | Completed | Gets or sets a value indicating whether this MakeBootable() has completed running.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Message | Gets or sets the log.
Public property | Success | Gets or sets a value indicating whether this MakeBootable() is a success.
Top
See Also

Reference

DoubleTake.Virtualization.Contract Namespace


BootProcessingResult Constructor

BootProcessingResult Constructor
Initializes a new instance of the BootProcessingResult class

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public BootProcessingResult()
Public Sub New
public:
BootProcessingResult()
DoubleTake.Virtualization.Contract.BootProcessingResult = function();
See Also

Reference

BootProcessingResult Class
DoubleTake.Virtualization.Contract Namespace


BootProcessingResult Properties

BootProcessingResult Properties

The BootProcessingResult type exposes the following members.

Properties
 | Name | Description
Public property | Completed | Gets or sets a value indicating whether this MakeBootable() has completed running.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Message | Gets or sets the log.
Public property | Success | Gets or sets a value indicating whether this MakeBootable() is a success.
Top
See Also

Reference

BootProcessingResult Class
DoubleTake.Virtualization.Contract Namespace


BootProcessingResult.Completed Property

BootProcessingResultCompleted Property
Gets or sets a value indicating whether this MakeBootable() has completed running.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool Completed { get; set; }
Public Property Completed As Boolean
    Get
    Set
public:
property bool Completed {
    bool get ();
    void set (bool value);
}
function get_Completed();
function set_Completed(value);

Property Value

Type: Boolean
true if success; otherwise, false.
See Also

Reference

BootProcessingResult Class
DoubleTake.Virtualization.Contract Namespace


BootProcessingResult.ExtensionData Property

BootProcessingResultExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

BootProcessingResult Class
DoubleTake.Virtualization.Contract Namespace


BootProcessingResult.Message Property

BootProcessingResultMessage Property
Gets or sets the log.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Message { get; set; }
Public Property Message As String
    Get
    Set
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}
function get_Message();
function set_Message(value);

Property Value

Type: String
The log generated by the MakeBootable() operation.
See Also

Reference

BootProcessingResult Class
DoubleTake.Virtualization.Contract Namespace


BootProcessingResult.Success Property

BootProcessingResultSuccess Property
Gets or sets a value indicating whether this MakeBootable() is a success.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool Success { get; set; }
Public Property Success As Boolean
    Get
    Set
public:
property bool Success {
    bool get ();
    void set (bool value);
}
function get_Success();
function set_Success(value);

Property Value

Type: Boolean
true if success; otherwise, false.
See Also

Reference

BootProcessingResult Class
DoubleTake.Virtualization.Contract Namespace


BootProcessingScrapeResult Class

BootProcessingScrapeResult Class
This class is used as a return result for the Scrape operation.
Inheritance Hierarchy
SystemObject
DoubleTake.Virtualization.ContractBootProcessingScrapeResult

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class BootProcessingScrapeResult : IExtensibleDataObject
Public Class BootProcessingScrapeResult
    Implements IExtensibleDataObject
public ref class BootProcessingScrapeResult : IExtensibleDataObject
DoubleTake.Virtualization.Contract.BootProcessingScrapeResult = function();

Type.createClass(
    'DoubleTake.Virtualization.Contract.BootProcessingScrapeResult',
    null,
    IExtensibleDataObject);

The BootProcessingScrapeResult type exposes the following members.

Constructors
 | Name | Description
Public method | BootProcessingScrapeResult | Initializes a new instance of the BootProcessingScrapeResult class
Top
Properties
 | Name | Description
Public property | Completed | Gets or sets a value indicating whether this Scrape() has completed running.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Message | Gets or sets the log.
Public property | ScrapeDescription | Gets or sets a system information value from Scrape().
Top
See Also

Reference

DoubleTake.Virtualization.Contract Namespace


BootProcessingScrapeResult Constructor

BootProcessingScrapeResult Constructor
Initializes a new instance of the BootProcessingScrapeResult class

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public BootProcessingScrapeResult()
Public Sub New
public:
BootProcessingScrapeResult()
DoubleTake.Virtualization.Contract.BootProcessingScrapeResult = function();
See Also

Reference

BootProcessingScrapeResult Class
DoubleTake.Virtualization.Contract Namespace


BootProcessingScrapeResult Properties

BootProcessingScrapeResult Properties

The BootProcessingScrapeResult type exposes the following members.

Properties
 | Name | Description
Public property | Completed | Gets or sets a value indicating whether this Scrape() has completed running.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Message | Gets or sets the log.
Public property | ScrapeDescription | Gets or sets a system information value from Scrape().
Top
See Also

Reference

BootProcessingScrapeResult Class
DoubleTake.Virtualization.Contract Namespace


BootProcessingScrapeResult.Completed Property

BootProcessingScrapeResultCompleted Property
Gets or sets a value indicating whether this Scrape() has completed running.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool Completed { get; set; }
Public Property Completed As Boolean
    Get
    Set
public:
property bool Completed {
    bool get ();
    void set (bool value);
}
function get_Completed();
function set_Completed(value);

Property Value

Type: Boolean
true if success; otherwise, false.
See Also

Reference

BootProcessingScrapeResult Class
DoubleTake.Virtualization.Contract Namespace


BootProcessingScrapeResult.ExtensionData Property

BootProcessingScrapeResultExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

BootProcessingScrapeResult Class
DoubleTake.Virtualization.Contract Namespace


BootProcessingScrapeResult.Message Property

BootProcessingScrapeResultMessage Property
Gets or sets the log.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Message { get; set; }
Public Property Message As String
    Get
    Set
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}
function get_Message();
function set_Message(value);

Property Value

Type: String
The log generated by the Scrape() operation.
See Also

Reference

BootProcessingScrapeResult Class
DoubleTake.Virtualization.Contract Namespace


BootProcessingScrapeResult.ScrapeDescription Property

BootProcessingScrapeResultScrapeDescription Property
Gets or sets a system information value from Scrape().

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string ScrapeDescription { get; set; }
Public Property ScrapeDescription As String
    Get
    Set
public:
property String^ ScrapeDescription {
    String^ get ();
    void set (String^ value);
}
function get_ScrapeDescription();
function set_ScrapeDescription(value);

Property Value

Type: String
String describing the source machine.
See Also

Reference

BootProcessingScrapeResult Class
DoubleTake.Virtualization.Contract Namespace


BootProcessingTypes Class

BootProcessingTypes Class
These are the types of boot processing we can perform and are the constants used to fill the BootProcessingOptions.BootProcessingType field.
Inheritance Hierarchy
SystemObject
DoubleTake.Virtualization.ContractBootProcessingTypes

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class BootProcessingTypes
Public Class BootProcessingTypes
public ref class BootProcessingTypes
DoubleTake.Virtualization.Contract.BootProcessingTypes = function();

Type.createClass(
    'DoubleTake.Virtualization.Contract.BootProcessingTypes');

The BootProcessingTypes type exposes the following members.

Constructors
 | Name | Description
Public method | BootProcessingTypes | Initializes a new instance of the BootProcessingTypes class
Top
Fields
Name | Description
Full | Indicates that the full boot processing should occur, including device driver injection and the registry fixups required to make the network adapters have the desired IP addresses.
SkipDeviceDriverInjection | Indicates that the drive is mostly correct, it just needs adjusted for the fact that the drive volumes aren't the same. We will skip the device driver injection and network adapter fixups. We do still do WANFailover things, domain controller adjustments and things like that.
Top
See Also

Reference

DoubleTake.Virtualization.Contract Namespace


BootProcessingTypes Constructor

BootProcessingTypes Constructor
Initializes a new instance of the BootProcessingTypes class

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public BootProcessingTypes()
Public Sub New
public:
BootProcessingTypes()
DoubleTake.Virtualization.Contract.BootProcessingTypes = function();
See Also

Reference

BootProcessingTypes Class
DoubleTake.Virtualization.Contract Namespace


BootProcessingTypes Fields

BootProcessingTypes Fields

The BootProcessingTypes type exposes the following members.

Fields
Name | Description
Full | Indicates that the full boot processing should occur, including device driver injection and the registry fixups required to make the network adapters have the desired IP addresses.
SkipDeviceDriverInjection | Indicates that the drive is mostly correct, it just needs adjusted for the fact that the drive volumes aren't the same. We will skip the device driver injection and network adapter fixups. We do still do WANFailover things, domain controller adjustments and things like that.
Top
See Also

Reference

BootProcessingTypes Class
DoubleTake.Virtualization.Contract Namespace


BootProcessingTypes.Full Field

BootProcessingTypesFull Field
Indicates that the full boot processing should occur, including device driver injection and the registry fixups required to make the network adapters have the desired IP addresses.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string Full
Public Const Full As String
public:
literal String^ Full
var DoubleTake.Virtualization.Contract.BootProcessingTypes.Full

Field Value

Type: String
See Also

Reference

BootProcessingTypes Class
DoubleTake.Virtualization.Contract Namespace


BootProcessingTypes.SkipDeviceDriverInjection Field

BootProcessingTypesSkipDeviceDriverInjection Field
Indicates that the drive is mostly correct, it just needs adjusted for the fact that the drive volumes aren't the same. We will skip the device driver injection and network adapter fixups. We do still do WANFailover things, domain controller adjustments and things like that.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public const string SkipDeviceDriverInjection
Public Const SkipDeviceDriverInjection As String
public:
literal String^ SkipDeviceDriverInjection
var DoubleTake.Virtualization.Contract.BootProcessingTypes.SkipDeviceDriverInjection

Field Value

Type: String
See Also

Reference

BootProcessingTypes Class
DoubleTake.Virtualization.Contract Namespace


BootProcessingVolumeInfo Class

BootProcessingVolumeInfo Class
Specifies information about the mount volumes.
Inheritance Hierarchy
SystemObject
DoubleTake.Virtualization.ContractBootProcessingVolumeInfo

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class BootProcessingVolumeInfo : IExtensibleDataObject
Public Class BootProcessingVolumeInfo
    Implements IExtensibleDataObject
public ref class BootProcessingVolumeInfo : IExtensibleDataObject
DoubleTake.Virtualization.Contract.BootProcessingVolumeInfo = function();

Type.createClass(
    'DoubleTake.Virtualization.Contract.BootProcessingVolumeInfo',
    null,
    IExtensibleDataObject);

The BootProcessingVolumeInfo type exposes the following members.

Constructors
 | Name | Description
Public method | BootProcessingVolumeInfo | Initializes a new instance of the BootProcessingVolumeInfo class
Top
Properties
 | Name | Description
Public property | DriveIndex | Gets or sets the index of the drive.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | MountPoint | Gets or sets the mount point where the volume can be found on the target
Public property | Name | Gets or sets the name of the volume (usually a drive letter for Windows, source path on Linux)
Public property | VolumeSignature | Gets or sets the volume signature.
Top
See Also

Reference

DoubleTake.Virtualization.Contract Namespace


BootProcessingVolumeInfo Constructor

BootProcessingVolumeInfo Constructor
Initializes a new instance of the BootProcessingVolumeInfo class

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public BootProcessingVolumeInfo()
Public Sub New
public:
BootProcessingVolumeInfo()
DoubleTake.Virtualization.Contract.BootProcessingVolumeInfo = function();
See Also

Reference

BootProcessingVolumeInfo Class
DoubleTake.Virtualization.Contract Namespace


BootProcessingVolumeInfo Properties

BootProcessingVolumeInfo Properties

The BootProcessingVolumeInfo type exposes the following members.

Properties
 | Name | Description
Public property | DriveIndex | Gets or sets the index of the drive.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | MountPoint | Gets or sets the mount point where the volume can be found on the target
Public property | Name | Gets or sets the name of the volume (usually a drive letter for Windows, source path on Linux)
Public property | VolumeSignature | Gets or sets the volume signature.
Top
See Also

Reference

BootProcessingVolumeInfo Class
DoubleTake.Virtualization.Contract Namespace


BootProcessingVolumeInfo.DriveIndex Property

BootProcessingVolumeInfoDriveIndex Property
Gets or sets the index of the drive.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int DriveIndex { get; set; }
Public Property DriveIndex As Integer
    Get
    Set
public:
property int DriveIndex {
    int get ();
    void set (int value);
}
function get_DriveIndex();
function set_DriveIndex(value);

Property Value

Type: Int32
The index of the disk. 0 or negative value will have the system query for this internally. (In other words, leave this alone.)
See Also

Reference

BootProcessingVolumeInfo Class
DoubleTake.Virtualization.Contract Namespace


BootProcessingVolumeInfo.ExtensionData Property

BootProcessingVolumeInfoExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

BootProcessingVolumeInfo Class
DoubleTake.Virtualization.Contract Namespace


BootProcessingVolumeInfo.MountPoint Property

BootProcessingVolumeInfoMountPoint Property
Gets or sets the mount point where the volume can be found on the target

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string MountPoint { get; set; }
Public Property MountPoint As String
    Get
    Set
public:
property String^ MountPoint {
    String^ get ();
    void set (String^ value);
}
function get_MountPoint();
function set_MountPoint(value);

Property Value

Type: String
The mount point.
See Also

Reference

BootProcessingVolumeInfo Class
DoubleTake.Virtualization.Contract Namespace


BootProcessingVolumeInfo.Name Property

BootProcessingVolumeInfoName Property
Gets or sets the name of the volume (usually a drive letter for Windows, source path on Linux)

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
function get_Name();
function set_Name(value);

Property Value

Type: String
The name.
See Also

Reference

BootProcessingVolumeInfo Class
DoubleTake.Virtualization.Contract Namespace


BootProcessingVolumeInfo.VolumeSignature Property

BootProcessingVolumeInfoVolumeSignature Property
Gets or sets the volume signature.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public byte[] VolumeSignature { get; set; }
Public Property VolumeSignature As Byte()
    Get
    Set
public:
property array<unsigned char>^ VolumeSignature {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
function get_VolumeSignature();
function set_VolumeSignature(value);

Property Value

Type: Byte
The volume signature. Leave blank externally as we will find this internally.
See Also

Reference

BootProcessingVolumeInfo Class
DoubleTake.Virtualization.Contract Namespace


DiskInitializationInfo Class

DiskInitializationInfo Class
Describes how a disk is to be partitioned and formatted. The DiskIdentifier is used to identify the disk to be partition. The Partitioning Scheme identifies if the disk is to use GPT or MBR. The array of PartitionInitializationInfo structures identifies how many partitions, what size and format they should have and other things.
Inheritance Hierarchy
SystemObject
DoubleTake.Virtualization.ContractDiskInitializationInfo

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class DiskInitializationInfo : IExtensibleDataObject
Public Class DiskInitializationInfo
    Implements IExtensibleDataObject
public ref class DiskInitializationInfo : IExtensibleDataObject
DoubleTake.Virtualization.Contract.DiskInitializationInfo = function();

Type.createClass(
    'DoubleTake.Virtualization.Contract.DiskInitializationInfo',
    null,
    IExtensibleDataObject);

The DiskInitializationInfo type exposes the following members.

Constructors
 | Name | Description
Public method | DiskInitializationInfo | Initializes a new instance of the DiskInitializationInfo class
Top
Properties
 | Name | Description
Public property | DiskIdentifier | The value used to identify the disk to the appliance. This would be the disk number in Windows and something else (device name?) in Linux.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | PartitioningScheme | Indicates what partitioning scheme to use. Example GPT or MBR
Public property | PartitionInitializationInfos | A list of partition descriptions for the entire disk. The number of entries here determines how many partitions you end up with.
Public property | ShouldPartitionDisk | Indicates whether we should partition the disk or not.
Top
See Also

Reference

DoubleTake.Virtualization.Contract Namespace


DiskInitializationInfo Constructor

DiskInitializationInfo Constructor
Initializes a new instance of the DiskInitializationInfo class

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public DiskInitializationInfo()
Public Sub New
public:
DiskInitializationInfo()
DoubleTake.Virtualization.Contract.DiskInitializationInfo = function();
See Also

Reference

DiskInitializationInfo Class
DoubleTake.Virtualization.Contract Namespace


DiskInitializationInfo Properties

DiskInitializationInfo Properties

The DiskInitializationInfo type exposes the following members.

Properties
 | Name | Description
Public property | DiskIdentifier | The value used to identify the disk to the appliance. This would be the disk number in Windows and something else (device name?) in Linux.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | PartitioningScheme | Indicates what partitioning scheme to use. Example GPT or MBR
Public property | PartitionInitializationInfos | A list of partition descriptions for the entire disk. The number of entries here determines how many partitions you end up with.
Public property | ShouldPartitionDisk | Indicates whether we should partition the disk or not.
Top
See Also

Reference

DiskInitializationInfo Class
DoubleTake.Virtualization.Contract Namespace


DiskInitializationInfo.DiskIdentifier Property

DiskInitializationInfoDiskIdentifier Property
The value used to identify the disk to the appliance. This would be the disk number in Windows and something else (device name?) in Linux.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string DiskIdentifier { get; set; }
Public Property DiskIdentifier As String
    Get
    Set
public:
property String^ DiskIdentifier {
    String^ get ();
    void set (String^ value);
}
function get_DiskIdentifier();
function set_DiskIdentifier(value);

Property Value

Type: String
See Also

Reference

DiskInitializationInfo Class
DoubleTake.Virtualization.Contract Namespace


DiskInitializationInfo.ExtensionData Property

DiskInitializationInfoExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

DiskInitializationInfo Class
DoubleTake.Virtualization.Contract Namespace


DiskInitializationInfo.PartitioningScheme Property

DiskInitializationInfoPartitioningScheme Property
Indicates what partitioning scheme to use. Example GPT or MBR

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string PartitioningScheme { get; set; }
Public Property PartitioningScheme As String
    Get
    Set
public:
property String^ PartitioningScheme {
    String^ get ();
    void set (String^ value);
}
function get_PartitioningScheme();
function set_PartitioningScheme(value);

Property Value

Type: String
See Also

Reference

DiskInitializationInfo Class
DoubleTake.Virtualization.Contract Namespace


DiskInitializationInfo.PartitionInitializationInfos Property

DiskInitializationInfoPartitionInitializationInfos Property
A list of partition descriptions for the entire disk. The number of entries here determines how many partitions you end up with.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public PartitionInitializationInfo[] PartitionInitializationInfos { get; set; }
Public Property PartitionInitializationInfos As PartitionInitializationInfo()
    Get
    Set
public:
property array<PartitionInitializationInfo^>^ PartitionInitializationInfos {
    array<PartitionInitializationInfo^>^ get ();
    void set (array<PartitionInitializationInfo^>^ value);
}
function get_PartitionInitializationInfos();
function set_PartitionInitializationInfos(value);

Property Value

Type: PartitionInitializationInfo
See Also

Reference

DiskInitializationInfo Class
DoubleTake.Virtualization.Contract Namespace


DiskInitializationInfo.ShouldPartitionDisk Property

DiskInitializationInfoShouldPartitionDisk Property
Indicates whether we should partition the disk or not.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool ShouldPartitionDisk { get; set; }
Public Property ShouldPartitionDisk As Boolean
    Get
    Set
public:
property bool ShouldPartitionDisk {
    bool get ();
    void set (bool value);
}
function get_ShouldPartitionDisk();
function set_ShouldPartitionDisk(value);

Property Value

Type: Boolean
See Also

Reference

DiskInitializationInfo Class
DoubleTake.Virtualization.Contract Namespace


DiskInitializationResult Class

DiskInitializationResult Class
This class is used as a return result for the InitializeDisk operation.
Inheritance Hierarchy
SystemObject
DoubleTake.Virtualization.ContractDiskInitializationResult

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class DiskInitializationResult : IExtensibleDataObject
Public Class DiskInitializationResult
    Implements IExtensibleDataObject
public ref class DiskInitializationResult : IExtensibleDataObject
DoubleTake.Virtualization.Contract.DiskInitializationResult = function();

Type.createClass(
    'DoubleTake.Virtualization.Contract.DiskInitializationResult',
    null,
    IExtensibleDataObject);

The DiskInitializationResult type exposes the following members.

Constructors
 | Name | Description
Public method | DiskInitializationResult | Initializes a new instance of the DiskInitializationResult class
Top
Properties
 | Name | Description
Public property | Completed | Gets or sets a value indicating whether this InitializeDisk() is has completed running.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Message | Gets or sets the log.
Public property | Success | Gets or sets a value indicating whether this InitializeDisk() is a success.
Top
See Also

Reference

DoubleTake.Virtualization.Contract Namespace


DiskInitializationResult Constructor

DiskInitializationResult Constructor
Initializes a new instance of the DiskInitializationResult class

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public DiskInitializationResult()
Public Sub New
public:
DiskInitializationResult()
DoubleTake.Virtualization.Contract.DiskInitializationResult = function();
See Also

Reference

DiskInitializationResult Class
DoubleTake.Virtualization.Contract Namespace


DiskInitializationResult Properties

DiskInitializationResult Properties

The DiskInitializationResult type exposes the following members.

Properties
 | Name | Description
Public property | Completed | Gets or sets a value indicating whether this InitializeDisk() is has completed running.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Message | Gets or sets the log.
Public property | Success | Gets or sets a value indicating whether this InitializeDisk() is a success.
Top
See Also

Reference

DiskInitializationResult Class
DoubleTake.Virtualization.Contract Namespace


DiskInitializationResult.Completed Property

DiskInitializationResultCompleted Property
Gets or sets a value indicating whether this InitializeDisk() is has completed running.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool Completed { get; set; }
Public Property Completed As Boolean
    Get
    Set
public:
property bool Completed {
    bool get ();
    void set (bool value);
}
function get_Completed();
function set_Completed(value);

Property Value

Type: Boolean
true if success; otherwise, false.
See Also

Reference

DiskInitializationResult Class
DoubleTake.Virtualization.Contract Namespace


DiskInitializationResult.ExtensionData Property

DiskInitializationResultExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

DiskInitializationResult Class
DoubleTake.Virtualization.Contract Namespace


DiskInitializationResult.Message Property

DiskInitializationResultMessage Property
Gets or sets the log.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Message { get; set; }
Public Property Message As String
    Get
    Set
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}
function get_Message();
function set_Message(value);

Property Value

Type: String
The log generated by the InitializeDisk() operation.
See Also

Reference

DiskInitializationResult Class
DoubleTake.Virtualization.Contract Namespace


DiskInitializationResult.Success Property

DiskInitializationResultSuccess Property
Gets or sets a value indicating whether this InitializeDisk() is a success.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool Success { get; set; }
Public Property Success As Boolean
    Get
    Set
public:
property bool Success {
    bool get ();
    void set (bool value);
}
function get_Success();
function set_Success(value);

Property Value

Type: Boolean
true if success; otherwise, false.
See Also

Reference

DiskInitializationResult Class
DoubleTake.Virtualization.Contract Namespace


DiskManagementVolumeInfo Class

DiskManagementVolumeInfo Class
Inheritance Hierarchy
SystemObject
DoubleTake.Virtualization.ContractDiskManagementVolumeInfo

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class DiskManagementVolumeInfo : IExtensibleDataObject
Public Class DiskManagementVolumeInfo
    Implements IExtensibleDataObject
public ref class DiskManagementVolumeInfo : IExtensibleDataObject
DoubleTake.Virtualization.Contract.DiskManagementVolumeInfo = function();

Type.createClass(
    'DoubleTake.Virtualization.Contract.DiskManagementVolumeInfo',
    null,
    IExtensibleDataObject);

The DiskManagementVolumeInfo type exposes the following members.

Constructors
 | Name | Description
Public method | DiskManagementVolumeInfo | Initializes a new instance of the DiskManagementVolumeInfo class
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | VolumeSignature |
Top
See Also

Reference

DoubleTake.Virtualization.Contract Namespace


DiskManagementVolumeInfo Constructor

DiskManagementVolumeInfo Constructor
Initializes a new instance of the DiskManagementVolumeInfo class

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public DiskManagementVolumeInfo()
Public Sub New
public:
DiskManagementVolumeInfo()
DoubleTake.Virtualization.Contract.DiskManagementVolumeInfo = function();
See Also

Reference

DiskManagementVolumeInfo Class
DoubleTake.Virtualization.Contract Namespace


DiskManagementVolumeInfo Properties

DiskManagementVolumeInfo Properties

The DiskManagementVolumeInfo type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | VolumeSignature |
Top
See Also

Reference

DiskManagementVolumeInfo Class
DoubleTake.Virtualization.Contract Namespace


DiskManagementVolumeInfo.ExtensionData Property

DiskManagementVolumeInfoExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

DiskManagementVolumeInfo Class
DoubleTake.Virtualization.Contract Namespace


DiskManagementVolumeInfo.VolumeSignature Property

DiskManagementVolumeInfoVolumeSignature Property

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public byte[] VolumeSignature { get; set; }
Public Property VolumeSignature As Byte()
    Get
    Set
public:
property array<unsigned char>^ VolumeSignature {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
function get_VolumeSignature();
function set_VolumeSignature(value);

Property Value

Type: Byte
See Also

Reference

DiskManagementVolumeInfo Class
DoubleTake.Virtualization.Contract Namespace


DiskMountInfo Class

DiskMountInfo Class
Inheritance Hierarchy
SystemObject
DoubleTake.Virtualization.ContractDiskMountInfo

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class DiskMountInfo : IExtensibleDataObject
Public Class DiskMountInfo
    Implements IExtensibleDataObject
public ref class DiskMountInfo : IExtensibleDataObject
DoubleTake.Virtualization.Contract.DiskMountInfo = function();

Type.createClass(
    'DoubleTake.Virtualization.Contract.DiskMountInfo',
    null,
    IExtensibleDataObject);

The DiskMountInfo type exposes the following members.

Constructors
 | Name | Description
Public method | DiskMountInfo | Initializes a new instance of the DiskMountInfo class
Top
Properties
 | Name | Description
Public property | DiskIdentifier | Gets or set disk intenfier
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | FileSystem | Gets or set file system
Public property | MountPath | Gets or set disk mount path where the disk is supposed to be mounted
Top
See Also

Reference

DoubleTake.Virtualization.Contract Namespace


DiskMountInfo Constructor

DiskMountInfo Constructor
Initializes a new instance of the DiskMountInfo class

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public DiskMountInfo()
Public Sub New
public:
DiskMountInfo()
DoubleTake.Virtualization.Contract.DiskMountInfo = function();
See Also

Reference

DiskMountInfo Class
DoubleTake.Virtualization.Contract Namespace


DiskMountInfo Properties

DiskMountInfo Properties

The DiskMountInfo type exposes the following members.

Properties
 | Name | Description
Public property | DiskIdentifier | Gets or set disk intenfier
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | FileSystem | Gets or set file system
Public property | MountPath | Gets or set disk mount path where the disk is supposed to be mounted
Top
See Also

Reference

DiskMountInfo Class
DoubleTake.Virtualization.Contract Namespace


DiskMountInfo.DiskIdentifier Property

DiskMountInfoDiskIdentifier Property
Gets or set disk intenfier

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string DiskIdentifier { get; set; }
Public Property DiskIdentifier As String
    Get
    Set
public:
property String^ DiskIdentifier {
    String^ get ();
    void set (String^ value);
}
function get_DiskIdentifier();
function set_DiskIdentifier(value);

Property Value

Type: String
Disk Identifier Information
See Also

Reference

DiskMountInfo Class
DoubleTake.Virtualization.Contract Namespace


DiskMountInfo.ExtensionData Property

DiskMountInfoExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

DiskMountInfo Class
DoubleTake.Virtualization.Contract Namespace


DiskMountInfo.FileSystem Property

DiskMountInfoFileSystem Property
Gets or set file system

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string FileSystem { get; set; }
Public Property FileSystem As String
    Get
    Set
public:
property String^ FileSystem {
    String^ get ();
    void set (String^ value);
}
function get_FileSystem();
function set_FileSystem(value);

Property Value

Type: String
Mount path Information
See Also

Reference

DiskMountInfo Class
DoubleTake.Virtualization.Contract Namespace


DiskMountInfo.MountPath Property

DiskMountInfoMountPath Property
Gets or set disk mount path where the disk is supposed to be mounted

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string MountPath { get; set; }
Public Property MountPath As String
    Get
    Set
public:
property String^ MountPath {
    String^ get ();
    void set (String^ value);
}
function get_MountPath();
function set_MountPath(value);

Property Value

Type: String
Mount path Information
See Also

Reference

DiskMountInfo Class
DoubleTake.Virtualization.Contract Namespace


DtServiceException_Fault Class

DtServiceException_Fault Class
Inheritance Hierarchy
SystemObject
DoubleTake.Virtualization.ContractDtServiceException_Fault

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public sealed class DtServiceException_Fault : ICommonFault
Public NotInheritable Class DtServiceException_Fault
    Implements ICommonFault
public ref class DtServiceException_Fault sealed : ICommonFault
DoubleTake.Virtualization.Contract.DtServiceException_Fault = function();

Type.createClass(
    'DoubleTake.Virtualization.Contract.DtServiceException_Fault',
    null,
    DoubleTake.Common.Contract.ICommonFault);

The DtServiceException_Fault type exposes the following members.

Constructors
 | Name | Description
Public method | DtServiceException_Fault | Initializes a new instance of the DtServiceException_Fault class
Top
Properties
 | Name | Description
Public property | InnerFault | Gets or sets the inner fault.
Public property | Message | Gets or sets the fault error message.
Public property | Name | Gets or sets the name of the fault.
Public property | StackTrace | Gets or sets the stack trace on the service that indicates where an unhandled exception occurred.
Top
See Also

Reference

DoubleTake.Virtualization.Contract Namespace


DtServiceException_Fault Constructor

DtServiceException_Fault Constructor
Initializes a new instance of the DtServiceException_Fault class

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public DtServiceException_Fault()
Public Sub New
public:
DtServiceException_Fault()
DoubleTake.Virtualization.Contract.DtServiceException_Fault = function();
See Also

Reference

DtServiceException_Fault Class
DoubleTake.Virtualization.Contract Namespace


DtServiceException_Fault Properties

DtServiceException_Fault Properties

The DtServiceException_Fault type exposes the following members.

Properties
 | Name | Description
Public property | InnerFault | Gets or sets the inner fault.
Public property | Message | Gets or sets the fault error message.
Public property | Name | Gets or sets the name of the fault.
Public property | StackTrace | Gets or sets the stack trace on the service that indicates where an unhandled exception occurred.
Top
See Also

Reference

DtServiceException_Fault Class
DoubleTake.Virtualization.Contract Namespace


DtServiceException_Fault.InnerFault Property

DtServiceException_FaultInnerFault Property
Gets or sets the inner fault.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ICommonFault InnerFault { get; set; }
Public Property InnerFault As ICommonFault
    Get
    Set
public:
virtual property ICommonFault^ InnerFault {
    ICommonFault^ get () sealed;
    void set (ICommonFault^ value) sealed;
}
function get_InnerFault();
function set_InnerFault(value);

Property Value

Type: ICommonFault
The inner fault.

Implements

ICommonFaultInnerFault
Remarks
Populate this property if this fault was triggered by another fault and you need to convey the information from that fault up to the consumer.
See Also

Reference

DtServiceException_Fault Class
DoubleTake.Virtualization.Contract Namespace


DtServiceException_Fault.Message Property

DtServiceException_FaultMessage Property
Gets or sets the fault error message.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Message { get; set; }
Public Property Message As String
    Get
    Set
public:
virtual property String^ Message {
    String^ get () sealed;
    void set (String^ value) sealed;
}
function get_Message();
function set_Message(value);

Property Value

Type: String
The fault error message.

Implements

ICommonFaultMessage
See Also

Reference

DtServiceException_Fault Class
DoubleTake.Virtualization.Contract Namespace


DtServiceException_Fault.Name Property

DtServiceException_FaultName Property
Gets or sets the name of the fault.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get () sealed;
    void set (String^ value) sealed;
}
function get_Name();
function set_Name(value);

Property Value

Type: String
The name of the fault.

Implements

ICommonFaultName
See Also

Reference

DtServiceException_Fault Class
DoubleTake.Virtualization.Contract Namespace


DtServiceException_Fault.StackTrace Property

DtServiceException_FaultStackTrace Property
Gets or sets the stack trace on the service that indicates where an unhandled exception occurred.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string StackTrace { get; set; }
Public Property StackTrace As String
    Get
    Set
public:
virtual property String^ StackTrace {
    String^ get () sealed;
    void set (String^ value) sealed;
}
function get_StackTrace();
function set_StackTrace(value);

Property Value

Type: String
The stack trace.

Implements

ICommonFaultStackTrace
See Also

Reference

DtServiceException_Fault Class
DoubleTake.Virtualization.Contract Namespace


ErrorInfo Class

ErrorInfo Class
Represents job error properties.
Inheritance Hierarchy
SystemObject
DoubleTake.Virtualization.ContractErrorInfo

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class ErrorInfo : IExtensibleDataObject
Public Class ErrorInfo
    Implements IExtensibleDataObject
public ref class ErrorInfo : IExtensibleDataObject
DoubleTake.Virtualization.Contract.ErrorInfo = function();

Type.createClass(
    'DoubleTake.Virtualization.Contract.ErrorInfo',
    null,
    IExtensibleDataObject);

The ErrorInfo type exposes the following members.

Constructors
 | Name | Description
Public method | ErrorInfo | Initializes a new instance of the ErrorInfo class
Top
Properties
 | Name | Description
Public property | Details | Gets or sets a value of error details
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Health | Gets or sets the health.
Public property | Id | Gets or sets a value of error Id
Public property | Message | Gets or sets a value of error message
Public property | Timestamp | Gets or sets a value of error time stamp
Top
See Also

Reference

DoubleTake.Virtualization.Contract Namespace


ErrorInfo Constructor

ErrorInfo Constructor
Initializes a new instance of the ErrorInfo class

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ErrorInfo()
Public Sub New
public:
ErrorInfo()
DoubleTake.Virtualization.Contract.ErrorInfo = function();
See Also

Reference

ErrorInfo Class
DoubleTake.Virtualization.Contract Namespace


ErrorInfo Properties

ErrorInfo Properties

The ErrorInfo type exposes the following members.

Properties
 | Name | Description
Public property | Details | Gets or sets a value of error details
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Health | Gets or sets the health.
Public property | Id | Gets or sets a value of error Id
Public property | Message | Gets or sets a value of error message
Public property | Timestamp | Gets or sets a value of error time stamp
Top
See Also

Reference

ErrorInfo Class
DoubleTake.Virtualization.Contract Namespace


ErrorInfo.Details Property

ErrorInfoDetails Property
Gets or sets a value of error details

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Details { get; set; }
Public Property Details As String
    Get
    Set
public:
property String^ Details {
    String^ get ();
    void set (String^ value);
}
function get_Details();
function set_Details(value);

Property Value

Type: String
See Also

Reference

ErrorInfo Class
DoubleTake.Virtualization.Contract Namespace


ErrorInfo.ExtensionData Property

ErrorInfoExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

ErrorInfo Class
DoubleTake.Virtualization.Contract Namespace


ErrorInfo.Health Property

ErrorInfoHealth Property
Gets or sets the health.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Health Health { get; set; }
Public Property Health As Health
    Get
    Set
public:
property Health Health {
    Health get ();
    void set (Health value);
}
function get_Health();
function set_Health(value);

Property Value

Type: Health
The health.
See Also

Reference

ErrorInfo Class
DoubleTake.Virtualization.Contract Namespace


ErrorInfo.Id Property

ErrorInfoId Property
Gets or sets a value of error Id

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int Id { get; set; }
Public Property Id As Integer
    Get
    Set
public:
property int Id {
    int get ();
    void set (int value);
}
function get_Id();
function set_Id(value);

Property Value

Type: Int32
See Also

Reference

ErrorInfo Class
DoubleTake.Virtualization.Contract Namespace


ErrorInfo.Message Property

ErrorInfoMessage Property
Gets or sets a value of error message

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Message { get; set; }
Public Property Message As String
    Get
    Set
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}
function get_Message();
function set_Message(value);

Property Value

Type: String
See Also

Reference

ErrorInfo Class
DoubleTake.Virtualization.Contract Namespace


ErrorInfo.Timestamp Property

ErrorInfoTimestamp Property
Gets or sets a value of error time stamp

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public DateTime Timestamp { get; set; }
Public Property Timestamp As DateTime
    Get
    Set
public:
property DateTime Timestamp {
    DateTime get ();
    void set (DateTime value);
}
function get_Timestamp();
function set_Timestamp(value);

Property Value

Type: DateTime
See Also

Reference

ErrorInfo Class
DoubleTake.Virtualization.Contract Namespace


HyperVmNotFoundException_Fault Class

HyperVmNotFoundException_Fault Class
Inheritance Hierarchy
SystemObject
DoubleTake.Virtualization.ContractHyperVmNotFoundException_Fault

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public sealed class HyperVmNotFoundException_Fault : ICommonFault
Public NotInheritable Class HyperVmNotFoundException_Fault
    Implements ICommonFault
public ref class HyperVmNotFoundException_Fault sealed : ICommonFault
DoubleTake.Virtualization.Contract.HyperVmNotFoundException_Fault = function();

Type.createClass(
    'DoubleTake.Virtualization.Contract.HyperVmNotFoundException_Fault',
    null,
    DoubleTake.Common.Contract.ICommonFault);

The HyperVmNotFoundException_Fault type exposes the following members.

Constructors
 | Name | Description
Public method | HyperVmNotFoundException_Fault | Initializes a new instance of the HyperVmNotFoundException_Fault class
Top
Properties
 | Name | Description
Public property | InnerFault | Gets or sets the inner fault.
Public property | Message | Gets or sets the fault error message.
Public property | Name | Gets or sets the name of the fault.
Public property | StackTrace | Gets or sets the stack trace on the service that indicates where an unhandled exception occurred.
Top
See Also

Reference

DoubleTake.Virtualization.Contract Namespace


HyperVmNotFoundException_Fault Constructor

HyperVmNotFoundException_Fault Constructor
Initializes a new instance of the HyperVmNotFoundException_Fault class

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public HyperVmNotFoundException_Fault()
Public Sub New
public:
HyperVmNotFoundException_Fault()
DoubleTake.Virtualization.Contract.HyperVmNotFoundException_Fault = function();
See Also

Reference

HyperVmNotFoundException_Fault Class
DoubleTake.Virtualization.Contract Namespace


HyperVmNotFoundException_Fault Properties

HyperVmNotFoundException_Fault Properties

The HyperVmNotFoundException_Fault type exposes the following members.

Properties
 | Name | Description
Public property | InnerFault | Gets or sets the inner fault.
Public property | Message | Gets or sets the fault error message.
Public property | Name | Gets or sets the name of the fault.
Public property | StackTrace | Gets or sets the stack trace on the service that indicates where an unhandled exception occurred.
Top
See Also

Reference

HyperVmNotFoundException_Fault Class
DoubleTake.Virtualization.Contract Namespace


HyperVmNotFoundException_Fault.InnerFault Property

HyperVmNotFoundException_FaultInnerFault Property
Gets or sets the inner fault.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ICommonFault InnerFault { get; set; }
Public Property InnerFault As ICommonFault
    Get
    Set
public:
virtual property ICommonFault^ InnerFault {
    ICommonFault^ get () sealed;
    void set (ICommonFault^ value) sealed;
}
function get_InnerFault();
function set_InnerFault(value);

Property Value

Type: ICommonFault
The inner fault.

Implements

ICommonFaultInnerFault
Remarks
Populate this property if this fault was triggered by another fault and you need to convey the information from that fault up to the consumer.
See Also

Reference

HyperVmNotFoundException_Fault Class
DoubleTake.Virtualization.Contract Namespace


HyperVmNotFoundException_Fault.Message Property

HyperVmNotFoundException_FaultMessage Property
Gets or sets the fault error message.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Message { get; set; }
Public Property Message As String
    Get
    Set
public:
virtual property String^ Message {
    String^ get () sealed;
    void set (String^ value) sealed;
}
function get_Message();
function set_Message(value);

Property Value

Type: String
The fault error message.

Implements

ICommonFaultMessage
See Also

Reference

HyperVmNotFoundException_Fault Class
DoubleTake.Virtualization.Contract Namespace


HyperVmNotFoundException_Fault.Name Property

HyperVmNotFoundException_FaultName Property
Gets or sets the name of the fault.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get () sealed;
    void set (String^ value) sealed;
}
function get_Name();
function set_Name(value);

Property Value

Type: String
The name of the fault.

Implements

ICommonFaultName
See Also

Reference

HyperVmNotFoundException_Fault Class
DoubleTake.Virtualization.Contract Namespace


HyperVmNotFoundException_Fault.StackTrace Property

HyperVmNotFoundException_FaultStackTrace Property
Gets or sets the stack trace on the service that indicates where an unhandled exception occurred.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string StackTrace { get; set; }
Public Property StackTrace As String
    Get
    Set
public:
virtual property String^ StackTrace {
    String^ get () sealed;
    void set (String^ value) sealed;
}
function get_StackTrace();
function set_StackTrace(value);

Property Value

Type: String
The stack trace.

Implements

ICommonFaultStackTrace
See Also

Reference

HyperVmNotFoundException_Fault Class
DoubleTake.Virtualization.Contract Namespace


IBootProcessing Interface

IBootProcessing Interface
This interface is for internal use only.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public interface IBootProcessing
Public Interface IBootProcessing
public interface class IBootProcessing
DoubleTake.Virtualization.Contract.IBootProcessing = function();
DoubleTake.Virtualization.Contract.IBootProcessing.createInterface('DoubleTake.Virtualization.Contract.IBootProcessing');

The IBootProcessing type exposes the following members.

Methods
 | Name | Description
Public method | GetNetworkInterfaces | Gets the network interfaces.
Public method | MakeBootable | Takes the information provided in the bootProcessingInfo and performs the processing required to make the volumes bootable. A log of the operations performed is kept in the logFile.
Public method | Scrape | This routine examines the current system for its hardware, OS and OS version info and writes it to the file specified by systemStateXML. A log is kept in the logFile
Top
See Also

Reference

DoubleTake.Virtualization.Contract Namespace


IBootProcessing Methods

IBootProcessing Methods

The IBootProcessing type exposes the following members.

Methods
 | Name | Description
Public method | GetNetworkInterfaces | Gets the network interfaces.
Public method | MakeBootable | Takes the information provided in the bootProcessingInfo and performs the processing required to make the volumes bootable. A log of the operations performed is kept in the logFile.
Public method | Scrape | This routine examines the current system for its hardware, OS and OS version info and writes it to the file specified by systemStateXML. A log is kept in the logFile
Top
See Also

Reference

IBootProcessing Interface
DoubleTake.Virtualization.Contract Namespace


IBootProcessing.GetNetworkInterfaces Method

IBootProcessingGetNetworkInterfaces Method
Gets the network interfaces.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
BootProcessingNetworkResult GetNetworkInterfaces(
    string scrape
)
Function GetNetworkInterfaces (
    scrape As String
) As BootProcessingNetworkResult
BootProcessingNetworkResult^ GetNetworkInterfaces(
    String^ scrape
)
function GetNetworkInterfaces(scrape);

Parameters

scrape
Type: SystemString
This is either the XML text representing the source system or it is a fully qualified file which contains that XML.

Return Value

Type: BootProcessingNetworkResult
List of host network interface data for mapping to the source NICs.
See Also

Reference

IBootProcessing Interface
DoubleTake.Virtualization.Contract Namespace


IBootProcessing.MakeBootable Method

IBootProcessingMakeBootable Method
Takes the information provided in the bootProcessingInfo and performs the processing required to make the volumes bootable. A log of the operations performed is kept in the logFile.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
BootProcessingResult MakeBootable(
    BootProcessingInfo bootProcessingInfo
)
Function MakeBootable (
    bootProcessingInfo As BootProcessingInfo
) As BootProcessingResult
BootProcessingResult^ MakeBootable(
    BootProcessingInfo^ bootProcessingInfo
)
function MakeBootable(bootProcessingInfo);

Parameters

bootProcessingInfo
Type: DoubleTake.Virtualization.ContractBootProcessingInfo
The boot processing information.

Return Value

Type: BootProcessingResult
true if the processing was successful, false otherwise.
See Also

Reference

IBootProcessing Interface
DoubleTake.Virtualization.Contract Namespace


IBootProcessing.Scrape Method

IBootProcessingScrape Method
This routine examines the current system for its hardware, OS and OS version info and writes it to the file specified by systemStateXML. A log is kept in the logFile

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
BootProcessingScrapeResult Scrape()
Function Scrape As BootProcessingScrapeResult
BootProcessingScrapeResult^ Scrape()
function Scrape();

Return Value

Type: BootProcessingScrapeResult
The XML text of the system scrape.
See Also

Reference

IBootProcessing Interface
DoubleTake.Virtualization.Contract Namespace


IDiskManagement Interface

IDiskManagement Interface

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public interface IDiskManagement
Public Interface IDiskManagement
public interface class IDiskManagement
DoubleTake.Virtualization.Contract.IDiskManagement = function();
DoubleTake.Virtualization.Contract.IDiskManagement.createInterface('DoubleTake.Virtualization.Contract.IDiskManagement');

The IDiskManagement type exposes the following members.

Methods
 | Name | Description
Public method | BeginInitializeDisk | Begins the initialization of a disk.
Public method | EndInitializeDisk |
Public method | GetDiskIdentifiers | Get a list of unique identifiers which can be used to represent a disk to the other APIs in this interface.
Public method | GetDiskVolumeInfo | Gets the disk volume information.
Public method | GetFileSystemInitializationStatus | Initializes the disk using the input DiskInitializationInfo
Public method | InitializeDisk | Initializes the disk using the input DiskInitializationInfo
Public method | InitializeFileSystemOnDisks | Initializes file systems on all the disk associated with job provided in SystemInitializationInfo
Public method | MountDisks | Mount all the disk required based on DiskMountInfo
Public method | PartitionDisk | Partition the disk based on partitionIfo collection in DiskInitializationInfo
Public method | RemoveMountpoint | Removes the mount point directory.
Public method | UnmountDisk | Unmounts all the mountpoints associated with partitions on the disk.
Public method | UnmountVolumeFromMountpoint | Unmounts the volume from mountpoint.
Top
See Also

Reference

DoubleTake.Virtualization.Contract Namespace


IDiskManagement Methods

IDiskManagement Methods

The IDiskManagement type exposes the following members.

Methods
 | Name | Description
Public method | BeginInitializeDisk | Begins the initialization of a disk.
Public method | EndInitializeDisk |
Public method | GetDiskIdentifiers | Get a list of unique identifiers which can be used to represent a disk to the other APIs in this interface.
Public method | GetDiskVolumeInfo | Gets the disk volume information.
Public method | GetFileSystemInitializationStatus | Initializes the disk using the input DiskInitializationInfo
Public method | InitializeDisk | Initializes the disk using the input DiskInitializationInfo
Public method | InitializeFileSystemOnDisks | Initializes file systems on all the disk associated with job provided in SystemInitializationInfo
Public method | MountDisks | Mount all the disk required based on DiskMountInfo
Public method | PartitionDisk | Partition the disk based on partitionIfo collection in DiskInitializationInfo
Public method | RemoveMountpoint | Removes the mount point directory.
Public method | UnmountDisk | Unmounts all the mountpoints associated with partitions on the disk.
Public method | UnmountVolumeFromMountpoint | Unmounts the volume from mountpoint.
Top
See Also

Reference

IDiskManagement Interface
DoubleTake.Virtualization.Contract Namespace


IDiskManagement.BeginInitializeDisk Method

IDiskManagementBeginInitializeDisk Method
Begins the initialization of a disk.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
IAsyncResult BeginInitializeDisk(
    DiskInitializationInfo diskInfo,
    AsyncCallback callback,
    Object asyncState
)
Function BeginInitializeDisk (
    diskInfo As DiskInitializationInfo,
    callback As AsyncCallback,
    asyncState As Object
) As IAsyncResult
IAsyncResult^ BeginInitializeDisk(
    DiskInitializationInfo^ diskInfo,
    AsyncCallback^ callback,
    Object^ asyncState
)
function BeginInitializeDisk(diskInfo, callback, asyncState);

Parameters

diskInfo
Type: DoubleTake.Virtualization.ContractDiskInitializationInfo
This class contains information about how the disk should be partitioned and formatted.
callback
Type: SystemAsyncCallback
An optional asynchronous callback, to be called when the operation is complete.
asyncState
Type: SystemObject
A user-provided object that distinguishes this particular request from other requests.

Return Value

Type: IAsyncResult
An IAsyncResult that represents the asynchronous operation, which could still be pending.
See Also

Reference

IDiskManagement Interface
DoubleTake.Virtualization.Contract Namespace


IDiskManagement.EndInitializeDisk Method

IDiskManagementEndInitializeDisk Method

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
DiskInitializationResult EndInitializeDisk(
    IAsyncResult result
)
Function EndInitializeDisk (
    result As IAsyncResult
) As DiskInitializationResult
DiskInitializationResult^ EndInitializeDisk(
    IAsyncResult^ result
)
function EndInitializeDisk(result);

Parameters

result
Type: SystemIAsyncResult

Return Value

Type: DiskInitializationResult
See Also

Reference

IDiskManagement Interface
DoubleTake.Virtualization.Contract Namespace


IDiskManagement.GetDiskIdentifiers Method

IDiskManagementGetDiskIdentifiers Method
Get a list of unique identifiers which can be used to represent a disk to the other APIs in this interface.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
string[] GetDiskIdentifiers()
Function GetDiskIdentifiers As String()
array<String^>^ GetDiskIdentifiers()
function GetDiskIdentifiers();

Return Value

Type: String
An array of strings containing one identifier per string
See Also

Reference

IDiskManagement Interface
DoubleTake.Virtualization.Contract Namespace


IDiskManagement.GetDiskVolumeInfo Method

IDiskManagementGetDiskVolumeInfo Method
Gets the disk volume information.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
DiskManagementVolumeInfo GetDiskVolumeInfo(
    string mountPoint
)
Function GetDiskVolumeInfo (
    mountPoint As String
) As DiskManagementVolumeInfo
DiskManagementVolumeInfo^ GetDiskVolumeInfo(
    String^ mountPoint
)
function GetDiskVolumeInfo(mountPoint);

Parameters

mountPoint
Type: SystemString
The mount point of the desired volume

Return Value

Type: DiskManagementVolumeInfo
DiskManagementVolumeInfo instance containing data
See Also

Reference

IDiskManagement Interface
DoubleTake.Virtualization.Contract Namespace


IDiskManagement.GetFileSystemInitializationStatus Method

IDiskManagementGetFileSystemInitializationStatus Method
Initializes the disk using the input DiskInitializationInfo

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
ActivityStatusEntry GetFileSystemInitializationStatus(
    ActivityToken activityToken
)
Function GetFileSystemInitializationStatus (
    activityToken As ActivityToken
) As ActivityStatusEntry
ActivityStatusEntry^ GetFileSystemInitializationStatus(
    ActivityToken^ activityToken
)
function GetFileSystemInitializationStatus(activityToken);

Parameters

activityToken
Type: ActivityToken
This class contains information about how the disk should be partitioned and formatted.

Return Value

Type: ActivityStatusEntry
A ActivityStatusEntry object where Success is the success or failure of the operation. The status is pending if the work is still going on. The logs are collected and sent in message object of ActivityStatusEntry
See Also

Reference

IDiskManagement Interface
DoubleTake.Virtualization.Contract Namespace


IDiskManagement.InitializeDisk Method

IDiskManagementInitializeDisk Method
Initializes the disk using the input DiskInitializationInfo

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
DiskInitializationResult InitializeDisk(
    DiskInitializationInfo diskInfo
)
Function InitializeDisk (
    diskInfo As DiskInitializationInfo
) As DiskInitializationResult
DiskInitializationResult^ InitializeDisk(
    DiskInitializationInfo^ diskInfo
)
function InitializeDisk(diskInfo);

Parameters

diskInfo
Type: DoubleTake.Virtualization.ContractDiskInitializationInfo
This class contains information about how the disk should be partitioned and formatted.

Return Value

Type: DiskInitializationResult
A DiskInitialization object where Success is the success or failure of the operation and Log is the log generated.
See Also

Reference

IDiskManagement Interface
DoubleTake.Virtualization.Contract Namespace


IDiskManagement.InitializeFileSystemOnDisks Method

IDiskManagementInitializeFileSystemOnDisks Method
Initializes file systems on all the disk associated with job provided in SystemInitializationInfo

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
ActivityToken InitializeFileSystemOnDisks(
    SystemInitializationInfo systemDiskInfo
)
Function InitializeFileSystemOnDisks (
    systemDiskInfo As SystemInitializationInfo
) As ActivityToken
ActivityToken^ InitializeFileSystemOnDisks(
    SystemInitializationInfo^ systemDiskInfo
)
function InitializeFileSystemOnDisks(systemDiskInfo);

Parameters

systemDiskInfo
Type: DoubleTake.Virtualization.ContractSystemInitializationInfo
This class contains information about how the disks should be formatted.

Return Value

Type: ActivityToken
An ActivityToken object with a unique ID so that management service can queried about the status of ongoing formatting.
See Also

Reference

IDiskManagement Interface
DoubleTake.Virtualization.Contract Namespace


IDiskManagement.MountDisks Method

IDiskManagementMountDisks Method
Mount all the disk required based on DiskMountInfo

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
DiskInitializationResult MountDisks(
    DiskMountInfo[] diskInfo
)
Function MountDisks (
    diskInfo As DiskMountInfo()
) As DiskInitializationResult
DiskInitializationResult^ MountDisks(
    array<DiskMountInfo^>^ diskInfo
)
function MountDisks(diskInfo);

Parameters

diskInfo
Type: DoubleTake.Virtualization.ContractDiskMountInfo
This class contains information about how the disks should be mounted on appliance.

Return Value

Type: DiskInitializationResult
A DiskInitialization object where Success is the success or failure of the operation and Log is the log generated.
See Also

Reference

IDiskManagement Interface
DoubleTake.Virtualization.Contract Namespace


IDiskManagement.PartitionDisk Method

IDiskManagementPartitionDisk Method
Partition the disk based on partitionIfo collection in DiskInitializationInfo

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
DiskInitializationResult PartitionDisk(
    DiskInitializationInfo diskInfo
)
Function PartitionDisk (
    diskInfo As DiskInitializationInfo
) As DiskInitializationResult
DiskInitializationResult^ PartitionDisk(
    DiskInitializationInfo^ diskInfo
)
function PartitionDisk(diskInfo);

Parameters

diskInfo
Type: DoubleTake.Virtualization.ContractDiskInitializationInfo
This class contains information about how the disks should be partitioned.

Return Value

Type: DiskInitializationResult
A DiskInitialization object where Success is the success or failure of the operation and Log is the log generated.
See Also

Reference

IDiskManagement Interface
DoubleTake.Virtualization.Contract Namespace


IDiskManagement.RemoveMountpoint Method

IDiskManagementRemoveMountpoint Method
Removes the mount point directory.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
bool RemoveMountpoint(
    string mountPoint
)
Function RemoveMountpoint (
    mountPoint As String
) As Boolean
bool RemoveMountpoint(
    String^ mountPoint
)
function RemoveMountpoint(mountPoint);

Parameters

mountPoint
Type: SystemString
The mount point.

Return Value

Type: Boolean
true if the operation was successful, false otherwise.
See Also

Reference

IDiskManagement Interface
DoubleTake.Virtualization.Contract Namespace


IDiskManagement.UnmountDisk Method

IDiskManagementUnmountDisk Method
Unmounts all the mountpoints associated with partitions on the disk.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
bool UnmountDisk(
    string diskIdentifier
)
Function UnmountDisk (
    diskIdentifier As String
) As Boolean
bool UnmountDisk(
    String^ diskIdentifier
)
function UnmountDisk(diskIdentifier);

Parameters

diskIdentifier
Type: SystemString
The disk identifier.

Return Value

Type: Boolean
true if the operation was successful, false otherwise
See Also

Reference

IDiskManagement Interface
DoubleTake.Virtualization.Contract Namespace


IDiskManagement.UnmountVolumeFromMountpoint Method

IDiskManagementUnmountVolumeFromMountpoint Method
Unmounts the volume from mountpoint.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
bool UnmountVolumeFromMountpoint(
    string mountPoint
)
Function UnmountVolumeFromMountpoint (
    mountPoint As String
) As Boolean
bool UnmountVolumeFromMountpoint(
    String^ mountPoint
)
function UnmountVolumeFromMountpoint(mountPoint);

Parameters

mountPoint
Type: SystemString
The mount point.

Return Value

Type: Boolean
true if the operation succeeded, false otherwise.
See Also

Reference

IDiskManagement Interface
DoubleTake.Virtualization.Contract Namespace


IDTHVService Interface

IDTHVService Interface
Public interace: Client to DTHV service Client is either console or a test script

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public interface IDTHVService
Public Interface IDTHVService
public interface class IDTHVService
DoubleTake.Virtualization.Contract.IDTHVService = function();
DoubleTake.Virtualization.Contract.IDTHVService.createInterface('DoubleTake.Virtualization.Contract.IDTHVService');

The IDTHVService type exposes the following members.

Methods
 | Name | Description
Public method | GetVMSystemState(String, Credentials, String) |
Public method | GetVMSystemState(String, String, String, String, String) |
Public method | PopulateDnsOptions |
Top
See Also

Reference

DoubleTake.Virtualization.Contract Namespace


IDTHVService Methods

IDTHVService Methods

The IDTHVService type exposes the following members.

Methods
 | Name | Description
Public method | GetVMSystemState(String, Credentials, String) |
Public method | GetVMSystemState(String, String, String, String, String) |
Public method | PopulateDnsOptions |
Top
See Also

Reference

IDTHVService Interface
DoubleTake.Virtualization.Contract Namespace


IDTHVService.GetVMSystemState Method

IDTHVServiceGetVMSystemState Method
Overload List
 | Name | Description
Public method | GetVMSystemState(String, Credentials, String) |
Public method | GetVMSystemState(String, String, String, String, String) |
Top
See Also

Reference

IDTHVService Interface
DoubleTake.Virtualization.Contract Namespace


IDTHVService.GetVMSystemState Method (String, Credentials, String)

IDTHVServiceGetVMSystemState Method (String, Credentials, String)

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
VMSystemState GetVMSystemState(
    string vmGuestDNSName,
    Credentials vmCredentials,
    string vmBiosGuid
)
Function GetVMSystemState (
    vmGuestDNSName As String,
    vmCredentials As Credentials,
    vmBiosGuid As String
) As VMSystemState
VMSystemState^ GetVMSystemState(
    String^ vmGuestDNSName,
    Credentials^ vmCredentials,
    String^ vmBiosGuid
)
function GetVMSystemState(vmGuestDNSName, vmCredentials, vmBiosGuid);

Parameters

vmGuestDNSName
Type: SystemString
vmCredentials
Type: DoubleTake.Common.ContractCredentials
vmBiosGuid
Type: SystemString

Return Value

Type: VMSystemState
See Also

Reference

IDTHVService Interface
GetVMSystemState Overload
DoubleTake.Virtualization.Contract Namespace


IDTHVService.GetVMSystemState Method (String, String, String, String, String)

IDTHVServiceGetVMSystemState Method (String, String, String, String, String)

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
VMSystemState GetVMSystemState(
    string vmGuestDNSName,
    string vmUsername,
    string vmPassword,
    string vmDomain,
    string vmBiosGuid
)
Function GetVMSystemState (
    vmGuestDNSName As String,
    vmUsername As String,
    vmPassword As String,
    vmDomain As String,
    vmBiosGuid As String
) As VMSystemState
VMSystemState^ GetVMSystemState(
    String^ vmGuestDNSName,
    String^ vmUsername,
    String^ vmPassword,
    String^ vmDomain,
    String^ vmBiosGuid
)
function GetVMSystemState(vmGuestDNSName, vmUsername, vmPassword, vmDomain, vmBiosGuid);

Parameters

vmGuestDNSName
Type: SystemString
vmUsername
Type: SystemString
vmPassword
Type: SystemString
vmDomain
Type: SystemString
vmBiosGuid
Type: SystemString

Return Value

Type: VMSystemState
See Also

Reference

IDTHVService Interface
GetVMSystemState Overload
DoubleTake.Virtualization.Contract Namespace


IDTHVService.PopulateDnsOptions Method

IDTHVServicePopulateDnsOptions Method

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
DNSOptions PopulateDnsOptions(
    string vmHostName,
    VMSystemState vmSystemState,
    string targetHostName,
    Credentials targetHostCredentials
)
Function PopulateDnsOptions (
    vmHostName As String,
    vmSystemState As VMSystemState,
    targetHostName As String,
    targetHostCredentials As Credentials
) As DNSOptions
DNSOptions^ PopulateDnsOptions(
    String^ vmHostName,
    VMSystemState^ vmSystemState,
    String^ targetHostName,
    Credentials^ targetHostCredentials
)
function PopulateDnsOptions(vmHostName, vmSystemState, targetHostName, targetHostCredentials);

Parameters

vmHostName
Type: SystemString
vmSystemState
Type: DoubleTake.Virtualization.Contract.DTHVVMSystemState
targetHostName
Type: SystemString
targetHostCredentials
Type: DoubleTake.Common.ContractCredentials

Return Value

Type: DNSOptions
See Also

Reference

IDTHVService Interface
DoubleTake.Virtualization.Contract Namespace


IVRAExtensionAPI Interface

IVRAExtensionAPI Interface

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public interface IVRAExtensionAPI
Public Interface IVRAExtensionAPI
public interface class IVRAExtensionAPI
DoubleTake.Virtualization.Contract.IVRAExtensionAPI = function();
DoubleTake.Virtualization.Contract.IVRAExtensionAPI.createInterface('DoubleTake.Virtualization.Contract.IVRAExtensionAPI');

The IVRAExtensionAPI type exposes the following members.

Methods
 | Name | Description
Public method | MakeVolumeBootable | Makes the volume bootable. The job should be in a stopped state and the volume to be made bootable should be mounted as a directory.
Public method | PrepareForBooting | Using the info provided, we make the volume ready to be a system volume for a Vm.
Top
See Also

Reference

DoubleTake.Virtualization.Contract Namespace


IVRAExtensionAPI Methods

IVRAExtensionAPI Methods

The IVRAExtensionAPI type exposes the following members.

Methods
 | Name | Description
Public method | MakeVolumeBootable | Makes the volume bootable. The job should be in a stopped state and the volume to be made bootable should be mounted as a directory.
Public method | PrepareForBooting | Using the info provided, we make the volume ready to be a system volume for a Vm.
Top
See Also

Reference

IVRAExtensionAPI Interface
DoubleTake.Virtualization.Contract Namespace


IVRAExtensionAPI.MakeVolumeBootable Method

IVRAExtensionAPIMakeVolumeBootable Method
Makes the volume bootable. The job should be in a stopped state and the volume to be made bootable should be mounted as a directory.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
void MakeVolumeBootable(
    string jobUuid,
    string bootDiskMountPoint,
    string logFile
)
Sub MakeVolumeBootable (
    jobUuid As String,
    bootDiskMountPoint As String,
    logFile As String
)
void MakeVolumeBootable(
    String^ jobUuid,
    String^ bootDiskMountPoint,
    String^ logFile
)
function MakeVolumeBootable(jobUuid, bootDiskMountPoint, logFile);

Parameters

jobUuid
Type: SystemString
The job UUID.
bootDiskMountPoint
Type: SystemString
The boot disk mount point.
logFile
Type: SystemString
The log file.
See Also

Reference

IVRAExtensionAPI Interface
DoubleTake.Virtualization.Contract Namespace


IVRAExtensionAPI.PrepareForBooting Method

IVRAExtensionAPIPrepareForBooting Method
Using the info provided, we make the volume ready to be a system volume for a Vm.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Service (in DoubleTake.PowerShell.Contract.Service.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
void PrepareForBooting(
    string bootInformationXMLFile,
    string logFile
)
Sub PrepareForBooting (
    bootInformationXMLFile As String,
    logFile As String
)
void PrepareForBooting(
    String^ bootInformationXMLFile,
    String^ logFile
)
function PrepareForBooting(bootInformationXMLFile, logFile);

Parameters

bootInformationXMLFile
Type: SystemString
The path to an XML file containing the info in a PrepareVmInformation data contract
logFile
Type: SystemString
The path to a file which should contain the log messages for this invokation.
See Also

Reference

IVRAExtensionAPI Interface
DoubleTake.Virtualization.Contract Namespace


JobState Class

JobState Class
Represents job state information.
Inheritance Hierarchy
SystemObject
DoubleTake.Virtualization.ContractJobState

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class JobState : IExtensibleDataObject
Public Class JobState
    Implements IExtensibleDataObject
public ref class JobState : IExtensibleDataObject
DoubleTake.Virtualization.Contract.JobState = function();

Type.createClass(
    'DoubleTake.Virtualization.Contract.JobState',
    null,
    IExtensibleDataObject);

The JobState type exposes the following members.

Constructors
 | Name | Description
Public method | JobState | Initializes a new instance of the JobState class
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | HasError | Gets or sets a value if job has an error
Public property | HighLevel |
Public property | IsInSync | Gets or sets a value that if job is already in synch
Public property | LowLevel | Gets or sets a value of low level state
Public property | SourceActivationCodeMessages | Gets or sets the activation code messages.
Public property | TargetActivationCodeMessages | Gets or sets the activation code messages.
Top
Methods
 | Name | Description
Public method | AppendToRecentErrors |
Public method | Clone |
Public method | Equals | In the case of a VraJobState type struct, compare the singular fields. RecentErrors aren't used, because comparisons could be complex. Comparison of RecentErrors fields should be done by caller if required. (Overrides ObjectEquals(Object).)
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | SetError |
Top
Fields
 | Name | Description
Public field | RecentErrors | Gets or sets a value of list of recenet errors
Top
See Also

Reference

DoubleTake.Virtualization.Contract Namespace


JobState Constructor

JobState Constructor
Initializes a new instance of the JobState class

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public JobState()
Public Sub New
public:
JobState()
DoubleTake.Virtualization.Contract.JobState = function();
See Also

Reference

JobState Class
DoubleTake.Virtualization.Contract Namespace


JobState Properties

JobState Properties

The JobState type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | HasError | Gets or sets a value if job has an error
Public property | HighLevel |
Public property | IsInSync | Gets or sets a value that if job is already in synch
Public property | LowLevel | Gets or sets a value of low level state
Public property | SourceActivationCodeMessages | Gets or sets the activation code messages.
Public property | TargetActivationCodeMessages | Gets or sets the activation code messages.
Top
See Also

Reference

JobState Class
DoubleTake.Virtualization.Contract Namespace


JobState.ExtensionData Property

JobStateExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

JobState Class
DoubleTake.Virtualization.Contract Namespace


JobState.HasError Property

JobStateHasError Property
Gets or sets a value if job has an error

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool HasError { get; set; }
Public Property HasError As Boolean
    Get
    Set
public:
property bool HasError {
    bool get ();
    void set (bool value);
}
function get_HasError();
function set_HasError(value);

Property Value

Type: Boolean
See Also

Reference

JobState Class
DoubleTake.Virtualization.Contract Namespace


JobState.HighLevel Property

JobStateHighLevel Property

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string HighLevel { get; set; }
Public Property HighLevel As String
    Get
    Set
public:
property String^ HighLevel {
    String^ get ();
    void set (String^ value);
}
function get_HighLevel();
function set_HighLevel(value);

Property Value

Type: String
See Also

Reference

JobState Class
DoubleTake.Virtualization.Contract Namespace


JobState.IsInSync Property

JobStateIsInSync Property
Gets or sets a value that if job is already in synch

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsInSync { get; set; }
Public Property IsInSync As Boolean
    Get
    Set
public:
property bool IsInSync {
    bool get ();
    void set (bool value);
}
function get_IsInSync();
function set_IsInSync(value);

Property Value

Type: Boolean
See Also

Reference

JobState Class
DoubleTake.Virtualization.Contract Namespace


JobState.LowLevel Property

JobStateLowLevel Property
Gets or sets a value of low level state

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string LowLevel { get; set; }
Public Property LowLevel As String
    Get
    Set
public:
property String^ LowLevel {
    String^ get ();
    void set (String^ value);
}
function get_LowLevel();
function set_LowLevel(value);

Property Value

Type: String
See Also

Reference

JobState Class
DoubleTake.Virtualization.Contract Namespace


JobState.SourceActivationCodeMessages Property

JobStateSourceActivationCodeMessages Property
Gets or sets the activation code messages.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtendedLowLevelState[] SourceActivationCodeMessages { get; set; }
Public Property SourceActivationCodeMessages As ExtendedLowLevelState()
    Get
    Set
public:
property array<ExtendedLowLevelState^>^ SourceActivationCodeMessages {
    array<ExtendedLowLevelState^>^ get ();
    void set (array<ExtendedLowLevelState^>^ value);
}
function get_SourceActivationCodeMessages();
function set_SourceActivationCodeMessages(value);

Property Value

Type: ExtendedLowLevelState
The activation code messages.
See Also

Reference

JobState Class
DoubleTake.Virtualization.Contract Namespace


JobState.TargetActivationCodeMessages Property

JobStateTargetActivationCodeMessages Property
Gets or sets the activation code messages.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtendedLowLevelState[] TargetActivationCodeMessages { get; set; }
Public Property TargetActivationCodeMessages As ExtendedLowLevelState()
    Get
    Set
public:
property array<ExtendedLowLevelState^>^ TargetActivationCodeMessages {
    array<ExtendedLowLevelState^>^ get ();
    void set (array<ExtendedLowLevelState^>^ value);
}
function get_TargetActivationCodeMessages();
function set_TargetActivationCodeMessages(value);

Property Value

Type: ExtendedLowLevelState
The activation code messages.
See Also

Reference

JobState Class
DoubleTake.Virtualization.Contract Namespace


JobState Methods

JobState Methods

The JobState type exposes the following members.

Methods
 | Name | Description
Public method | AppendToRecentErrors |
Public method | Clone |
Public method | Equals | In the case of a VraJobState type struct, compare the singular fields. RecentErrors aren't used, because comparisons could be complex. Comparison of RecentErrors fields should be done by caller if required. (Overrides ObjectEquals(Object).)
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | SetError |
Top
See Also

Reference

JobState Class
DoubleTake.Virtualization.Contract Namespace


JobState.AppendToRecentErrors Method

JobStateAppendToRecentErrors Method

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public void AppendToRecentErrors(
    string message,
    string details
)
Public Sub AppendToRecentErrors (
    message As String,
    details As String
)
public:
void AppendToRecentErrors(
    String^ message,
    String^ details
)
function AppendToRecentErrors(message, details);

Parameters

message
Type: SystemString
details
Type: SystemString
See Also

Reference

JobState Class
DoubleTake.Virtualization.Contract Namespace


JobState.Clone Method

JobStateClone Method

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public JobState Clone()
Public Function Clone As JobState
public:
JobState^ Clone()
function Clone();

Return Value

Type: JobState
See Also

Reference

JobState Class
DoubleTake.Virtualization.Contract Namespace


JobState.Equals Method

JobStateEquals Method
In the case of a VraJobState type struct, compare the singular fields. RecentErrors aren't used, because comparisons could be complex. Comparison of RecentErrors fields should be done by caller if required.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
function Equals(obj);

Parameters

obj
Type: SystemObject
the other state to compare this instance with

Return Value

Type: Boolean
See Also

Reference

JobState Class
DoubleTake.Virtualization.Contract Namespace


JobState.GetHashCode Method

JobStateGetHashCode Method

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
function GetHashCode();

Return Value

Type: Int32
See Also

Reference

JobState Class
DoubleTake.Virtualization.Contract Namespace


JobState.SetError Method

JobStateSetError Method

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public void SetError(
    string message,
    string details
)
Public Sub SetError (
    message As String,
    details As String
)
public:
void SetError(
    String^ message,
    String^ details
)
function SetError(message, details);

Parameters

message
Type: SystemString
details
Type: SystemString
See Also

Reference

JobState Class
DoubleTake.Virtualization.Contract Namespace


JobState Fields

JobState Fields

The JobState type exposes the following members.

Fields
 | Name | Description
Public field | RecentErrors | Gets or sets a value of list of recenet errors
Top
See Also

Reference

JobState Class
DoubleTake.Virtualization.Contract Namespace


JobState.RecentErrors Field

JobStateRecentErrors Field
Gets or sets a value of list of recenet errors

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public List<ErrorInfo> RecentErrors
Public RecentErrors As List(Of ErrorInfo)
public:
List<ErrorInfo^>^ RecentErrors
var RecentErrors

Field Value

Type: List ErrorInfo
See Also

Reference

JobState Class
DoubleTake.Virtualization.Contract Namespace


LinuxBootProcessingOptions Class

LinuxBootProcessingOptions Class
Contains the information, not available from the source, to perform boot processing
Inheritance Hierarchy
SystemObject
DoubleTake.Virtualization.ContractLinuxBootProcessingOptions

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class LinuxBootProcessingOptions : IExtensibleDataObject
Public Class LinuxBootProcessingOptions
    Implements IExtensibleDataObject
public ref class LinuxBootProcessingOptions : IExtensibleDataObject
DoubleTake.Virtualization.Contract.LinuxBootProcessingOptions = function();

Type.createClass(
    'DoubleTake.Virtualization.Contract.LinuxBootProcessingOptions',
    null,
    IExtensibleDataObject);

The LinuxBootProcessingOptions type exposes the following members.

Constructors
 | Name | Description
Public method | LinuxBootProcessingOptions | Initializes a new instance of the LinuxBootProcessingOptions class
Top
Properties
 | Name | Description
Public property | BootDiskPath | Gets or sets the boot disk.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | IsWanFailover | Gets or sets a value indicating whether this instance is wan failover.
Public property | MountRoot | Gets or sets the mount point where the system will be mounted for processing.
Public property | ReplicaNetworkInterfaceInfo | Gets or sets the replica network interface info. This is the information as we want it to be on the replica.
Public property | SwapVolumes | Gets or sets the volume information.
Public property | VolumeInformation | Gets or sets the volume information.
Top
See Also

Reference

DoubleTake.Virtualization.Contract Namespace


LinuxBootProcessingOptions Constructor

LinuxBootProcessingOptions Constructor
Initializes a new instance of the LinuxBootProcessingOptions class

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public LinuxBootProcessingOptions()
Public Sub New
public:
LinuxBootProcessingOptions()
DoubleTake.Virtualization.Contract.LinuxBootProcessingOptions = function();
See Also

Reference

LinuxBootProcessingOptions Class
DoubleTake.Virtualization.Contract Namespace


LinuxBootProcessingOptions Properties

LinuxBootProcessingOptions Properties

The LinuxBootProcessingOptions type exposes the following members.

Properties
 | Name | Description
Public property | BootDiskPath | Gets or sets the boot disk.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | IsWanFailover | Gets or sets a value indicating whether this instance is wan failover.
Public property | MountRoot | Gets or sets the mount point where the system will be mounted for processing.
Public property | ReplicaNetworkInterfaceInfo | Gets or sets the replica network interface info. This is the information as we want it to be on the replica.
Public property | SwapVolumes | Gets or sets the volume information.
Public property | VolumeInformation | Gets or sets the volume information.
Top
See Also

Reference

LinuxBootProcessingOptions Class
DoubleTake.Virtualization.Contract Namespace


LinuxBootProcessingOptions.BootDiskPath Property

LinuxBootProcessingOptionsBootDiskPath Property
Gets or sets the boot disk.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string BootDiskPath { get; set; }
Public Property BootDiskPath As String
    Get
    Set
public:
property String^ BootDiskPath {
    String^ get ();
    void set (String^ value);
}
function get_BootDiskPath();
function set_BootDiskPath(value);

Property Value

Type: String
The name of the boot disk. (e.g. /dev/sdb)
See Also

Reference

LinuxBootProcessingOptions Class
DoubleTake.Virtualization.Contract Namespace


LinuxBootProcessingOptions.ExtensionData Property

LinuxBootProcessingOptionsExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

LinuxBootProcessingOptions Class
DoubleTake.Virtualization.Contract Namespace


LinuxBootProcessingOptions.IsWanFailover Property

LinuxBootProcessingOptionsIsWanFailover Property
Gets or sets a value indicating whether this instance is wan failover.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsWanFailover { get; set; }
Public Property IsWanFailover As Boolean
    Get
    Set
public:
property bool IsWanFailover {
    bool get ();
    void set (bool value);
}
function get_IsWanFailover();
function set_IsWanFailover(value);

Property Value

Type: Boolean
true if this instance is wan failover; otherwise, false.
See Also

Reference

LinuxBootProcessingOptions Class
DoubleTake.Virtualization.Contract Namespace


LinuxBootProcessingOptions.MountRoot Property

LinuxBootProcessingOptionsMountRoot Property
Gets or sets the mount point where the system will be mounted for processing.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string MountRoot { get; set; }
Public Property MountRoot As String
    Get
    Set
public:
property String^ MountRoot {
    String^ get ();
    void set (String^ value);
}
function get_MountRoot();
function set_MountRoot(value);

Property Value

Type: String
Path on the appliance where the system is mounted. e.g. /opt/dbtk/mnt
See Also

Reference

LinuxBootProcessingOptions Class
DoubleTake.Virtualization.Contract Namespace


LinuxBootProcessingOptions.ReplicaNetworkInterfaceInfo Property

LinuxBootProcessingOptionsReplicaNetworkInterfaceInfo Property
Gets or sets the replica network interface info. This is the information as we want it to be on the replica.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VirtualNetworkInterfaceInfo[] ReplicaNetworkInterfaceInfo { get; set; }
Public Property ReplicaNetworkInterfaceInfo As VirtualNetworkInterfaceInfo()
    Get
    Set
public:
property array<VirtualNetworkInterfaceInfo^>^ ReplicaNetworkInterfaceInfo {
    array<VirtualNetworkInterfaceInfo^>^ get ();
    void set (array<VirtualNetworkInterfaceInfo^>^ value);
}
function get_ReplicaNetworkInterfaceInfo();
function set_ReplicaNetworkInterfaceInfo(value);

Property Value

Type: VirtualNetworkInterfaceInfo
The network interface info.
See Also

Reference

LinuxBootProcessingOptions Class
DoubleTake.Virtualization.Contract Namespace


LinuxBootProcessingOptions.SwapVolumes Property

LinuxBootProcessingOptionsSwapVolumes Property
Gets or sets the volume information.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public BootProcessingLinuxVolumeInfo[] SwapVolumes { get; set; }
Public Property SwapVolumes As BootProcessingLinuxVolumeInfo()
    Get
    Set
public:
property array<BootProcessingLinuxVolumeInfo^>^ SwapVolumes {
    array<BootProcessingLinuxVolumeInfo^>^ get ();
    void set (array<BootProcessingLinuxVolumeInfo^>^ value);
}
function get_SwapVolumes();
function set_SwapVolumes(value);

Property Value

Type: BootProcessingLinuxVolumeInfo
The volume information.
See Also

Reference

LinuxBootProcessingOptions Class
DoubleTake.Virtualization.Contract Namespace


LinuxBootProcessingOptions.VolumeInformation Property

LinuxBootProcessingOptionsVolumeInformation Property
Gets or sets the volume information.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public BootProcessingLinuxVolumeInfo[] VolumeInformation { get; set; }
Public Property VolumeInformation As BootProcessingLinuxVolumeInfo()
    Get
    Set
public:
property array<BootProcessingLinuxVolumeInfo^>^ VolumeInformation {
    array<BootProcessingLinuxVolumeInfo^>^ get ();
    void set (array<BootProcessingLinuxVolumeInfo^>^ value);
}
function get_VolumeInformation();
function set_VolumeInformation(value);

Property Value

Type: BootProcessingLinuxVolumeInfo
The volume information.
See Also

Reference

LinuxBootProcessingOptions Class
DoubleTake.Virtualization.Contract Namespace


NetworkAdapterInfo Class

NetworkAdapterInfo Class
Represents network adapter info
Inheritance Hierarchy
SystemObject
DoubleTake.Virtualization.ContractNetworkAdapterInfo

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class NetworkAdapterInfo : IExtensibleDataObject
Public Class NetworkAdapterInfo
    Implements IExtensibleDataObject
public ref class NetworkAdapterInfo : IExtensibleDataObject
DoubleTake.Virtualization.Contract.NetworkAdapterInfo = function();

Type.createClass(
    'DoubleTake.Virtualization.Contract.NetworkAdapterInfo',
    null,
    IExtensibleDataObject);

The NetworkAdapterInfo type exposes the following members.

Constructors
 | Name | Description
Public method | NetworkAdapterInfo | Initializes a new instance of the NetworkAdapterInfo class
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | SwitchPort | This value represents the switch port.
Public property | VirtualSwitch | This value represents the virtual switch.
Top
See Also

Reference

DoubleTake.Virtualization.Contract Namespace


NetworkAdapterInfo Constructor

NetworkAdapterInfo Constructor
Initializes a new instance of the NetworkAdapterInfo class

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public NetworkAdapterInfo()
Public Sub New
public:
NetworkAdapterInfo()
DoubleTake.Virtualization.Contract.NetworkAdapterInfo = function();
See Also

Reference

NetworkAdapterInfo Class
DoubleTake.Virtualization.Contract Namespace


NetworkAdapterInfo Properties

NetworkAdapterInfo Properties

The NetworkAdapterInfo type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | SwitchPort | This value represents the switch port.
Public property | VirtualSwitch | This value represents the virtual switch.
Top
See Also

Reference

NetworkAdapterInfo Class
DoubleTake.Virtualization.Contract Namespace


NetworkAdapterInfo.ExtensionData Property

NetworkAdapterInfoExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

NetworkAdapterInfo Class
DoubleTake.Virtualization.Contract Namespace


NetworkAdapterInfo.SwitchPort Property

NetworkAdapterInfoSwitchPort Property
This value represents the switch port.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public SwitchPortInfo SwitchPort { get; set; }
Public Property SwitchPort As SwitchPortInfo
    Get
    Set
public:
property SwitchPortInfo^ SwitchPort {
    SwitchPortInfo^ get ();
    void set (SwitchPortInfo^ value);
}
function get_SwitchPort();
function set_SwitchPort(value);

Property Value

Type: SwitchPortInfo
See Also

Reference

NetworkAdapterInfo Class
DoubleTake.Virtualization.Contract Namespace


NetworkAdapterInfo.VirtualSwitch Property

NetworkAdapterInfoVirtualSwitch Property
This value represents the virtual switch.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VirtualSwitchInfo VirtualSwitch { get; set; }
Public Property VirtualSwitch As VirtualSwitchInfo
    Get
    Set
public:
property VirtualSwitchInfo^ VirtualSwitch {
    VirtualSwitchInfo^ get ();
    void set (VirtualSwitchInfo^ value);
}
function get_VirtualSwitch();
function set_VirtualSwitch(value);

Property Value

Type: VirtualSwitchInfo
See Also

Reference

NetworkAdapterInfo Class
DoubleTake.Virtualization.Contract Namespace


PartitionInitializationInfo Class

PartitionInitializationInfo Class
This class describes what a partition on the disk looks like and how it is formatted.
Inheritance Hierarchy
SystemObject
DoubleTake.Virtualization.ContractPartitionInitializationInfo

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class PartitionInitializationInfo : IExtensibleDataObject
Public Class PartitionInitializationInfo
    Implements IExtensibleDataObject
public ref class PartitionInitializationInfo : IExtensibleDataObject
DoubleTake.Virtualization.Contract.PartitionInitializationInfo = function();

Type.createClass(
    'DoubleTake.Virtualization.Contract.PartitionInitializationInfo',
    null,
    IExtensibleDataObject);

The PartitionInitializationInfo type exposes the following members.

Constructors
 | Name | Description
Public method | PartitionInitializationInfo | Initializes a new instance of the PartitionInitializationInfo class
Top
Properties
 | Name | Description
Public property | Active | Should the partition be made active.
Public property | Align | The partition offset will be a multiple of this value. If the Offset value is given, it will be round to the closest multiple of this value.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | FileSystemType | The file system type such as NTFS, RFS. See FileSystemTypes class. If null, RECOMMENDED is used.
Public property | INodeSize | Used when initialize the Linux disk.
Public property | IsBoot | Used when initialize the Linux disk. Determine whether this partition is boot.
Public property | Label | The string to be used as the label of the volume. This is optional.
Public property | MountPoint | Where you want the partition mounted. (If the mountpoint looks like a {driveletter}: We will attempt to assign that drive letter to the volume.
Public property | Offset | The offset, in kilobytes, at which the partition is created. If offset is 0, the partition will start at the beginning of the first free space on the disk that is large enough to hold the new partition.
Public property | PartitionType | One of the partition types from the PartitionTypes class
Public property | QuickFormat | Gets or sets a value indicating whether we should use a "quick" format.
Public property | ShouldCreateMountPointDirectory | Gets or sets a value indicating whether InitializeDisk should create mount point directory or not.
Public property | ShouldFormatPartition | Indicates whether the partition should be formatted.
Public property | Size | The size in Megabytes of the partition. If the size is 0 then it will consume the rest of the space.
Top
See Also

Reference

DoubleTake.Virtualization.Contract Namespace


PartitionInitializationInfo Constructor

PartitionInitializationInfo Constructor
Initializes a new instance of the PartitionInitializationInfo class

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public PartitionInitializationInfo()
Public Sub New
public:
PartitionInitializationInfo()
DoubleTake.Virtualization.Contract.PartitionInitializationInfo = function();
See Also

Reference

PartitionInitializationInfo Class
DoubleTake.Virtualization.Contract Namespace


PartitionInitializationInfo Properties

PartitionInitializationInfo Properties

The PartitionInitializationInfo type exposes the following members.

Properties
 | Name | Description
Public property | Active | Should the partition be made active.
Public property | Align | The partition offset will be a multiple of this value. If the Offset value is given, it will be round to the closest multiple of this value.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | FileSystemType | The file system type such as NTFS, RFS. See FileSystemTypes class. If null, RECOMMENDED is used.
Public property | INodeSize | Used when initialize the Linux disk.
Public property | IsBoot | Used when initialize the Linux disk. Determine whether this partition is boot.
Public property | Label | The string to be used as the label of the volume. This is optional.
Public property | MountPoint | Where you want the partition mounted. (If the mountpoint looks like a {driveletter}: We will attempt to assign that drive letter to the volume.
Public property | Offset | The offset, in kilobytes, at which the partition is created. If offset is 0, the partition will start at the beginning of the first free space on the disk that is large enough to hold the new partition.
Public property | PartitionType | One of the partition types from the PartitionTypes class
Public property | QuickFormat | Gets or sets a value indicating whether we should use a "quick" format.
Public property | ShouldCreateMountPointDirectory | Gets or sets a value indicating whether InitializeDisk should create mount point directory or not.
Public property | ShouldFormatPartition | Indicates whether the partition should be formatted.
Public property | Size | The size in Megabytes of the partition. If the size is 0 then it will consume the rest of the space.
Top
See Also

Reference

PartitionInitializationInfo Class
DoubleTake.Virtualization.Contract Namespace


PartitionInitializationInfo.Active Property

PartitionInitializationInfoActive Property
Should the partition be made active.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool Active { get; set; }
Public Property Active As Boolean
    Get
    Set
public:
property bool Active {
    bool get ();
    void set (bool value);
}
function get_Active();
function set_Active(value);

Property Value

Type: Boolean
true if active; otherwise, false.
See Also

Reference

PartitionInitializationInfo Class
DoubleTake.Virtualization.Contract Namespace


PartitionInitializationInfo.Align Property

PartitionInitializationInfoAlign Property
The partition offset will be a multiple of this value. If the Offset value is given, it will be round to the closest multiple of this value.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int Align { get; set; }
Public Property Align As Integer
    Get
    Set
public:
property int Align {
    int get ();
    void set (int value);
}
function get_Align();
function set_Align(value);

Property Value

Type: Int32
See Also

Reference

PartitionInitializationInfo Class
DoubleTake.Virtualization.Contract Namespace


PartitionInitializationInfo.ExtensionData Property

PartitionInitializationInfoExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

PartitionInitializationInfo Class
DoubleTake.Virtualization.Contract Namespace


PartitionInitializationInfo.FileSystemType Property

PartitionInitializationInfoFileSystemType Property
The file system type such as NTFS, RFS. See FileSystemTypes class. If null, RECOMMENDED is used.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string FileSystemType { get; set; }
Public Property FileSystemType As String
    Get
    Set
public:
property String^ FileSystemType {
    String^ get ();
    void set (String^ value);
}
function get_FileSystemType();
function set_FileSystemType(value);

Property Value

Type: String
See Also

Reference

PartitionInitializationInfo Class
DoubleTake.Virtualization.Contract Namespace


PartitionInitializationInfo.INodeSize Property

PartitionInitializationInfoINodeSize Property
Used when initialize the Linux disk.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int INodeSize { get; set; }
Public Property INodeSize As Integer
    Get
    Set
public:
property int INodeSize {
    int get ();
    void set (int value);
}
function get_INodeSize();
function set_INodeSize(value);

Property Value

Type: Int32
See Also

Reference

PartitionInitializationInfo Class
DoubleTake.Virtualization.Contract Namespace


PartitionInitializationInfo.IsBoot Property

PartitionInitializationInfoIsBoot Property
Used when initialize the Linux disk. Determine whether this partition is boot.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsBoot { get; set; }
Public Property IsBoot As Boolean
    Get
    Set
public:
property bool IsBoot {
    bool get ();
    void set (bool value);
}
function get_IsBoot();
function set_IsBoot(value);

Property Value

Type: Boolean
See Also

Reference

PartitionInitializationInfo Class
DoubleTake.Virtualization.Contract Namespace


PartitionInitializationInfo.Label Property

PartitionInitializationInfoLabel Property
The string to be used as the label of the volume. This is optional.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Label { get; set; }
Public Property Label As String
    Get
    Set
public:
property String^ Label {
    String^ get ();
    void set (String^ value);
}
function get_Label();
function set_Label(value);

Property Value

Type: String
See Also

Reference

PartitionInitializationInfo Class
DoubleTake.Virtualization.Contract Namespace


PartitionInitializationInfo.MountPoint Property

PartitionInitializationInfoMountPoint Property
Where you want the partition mounted. (If the mountpoint looks like a {driveletter}: We will attempt to assign that drive letter to the volume.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string MountPoint { get; set; }
Public Property MountPoint As String
    Get
    Set
public:
property String^ MountPoint {
    String^ get ();
    void set (String^ value);
}
function get_MountPoint();
function set_MountPoint(value);

Property Value

Type: String
See Also

Reference

PartitionInitializationInfo Class
DoubleTake.Virtualization.Contract Namespace


PartitionInitializationInfo.Offset Property

PartitionInitializationInfoOffset Property
The offset, in kilobytes, at which the partition is created. If offset is 0, the partition will start at the beginning of the first free space on the disk that is large enough to hold the new partition.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int Offset { get; set; }
Public Property Offset As Integer
    Get
    Set
public:
property int Offset {
    int get ();
    void set (int value);
}
function get_Offset();
function set_Offset(value);

Property Value

Type: Int32
See Also

Reference

PartitionInitializationInfo Class
DoubleTake.Virtualization.Contract Namespace


PartitionInitializationInfo.PartitionType Property

PartitionInitializationInfoPartitionType Property
One of the partition types from the PartitionTypes class

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string PartitionType { get; set; }
Public Property PartitionType As String
    Get
    Set
public:
property String^ PartitionType {
    String^ get ();
    void set (String^ value);
}
function get_PartitionType();
function set_PartitionType(value);

Property Value

Type: String
See Also

Reference

PartitionInitializationInfo Class
DoubleTake.Virtualization.Contract Namespace


PartitionInitializationInfo.QuickFormat Property

PartitionInitializationInfoQuickFormat Property
Gets or sets a value indicating whether we should use a "quick" format.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool QuickFormat { get; set; }
Public Property QuickFormat As Boolean
    Get
    Set
public:
property bool QuickFormat {
    bool get ();
    void set (bool value);
}
function get_QuickFormat();
function set_QuickFormat(value);

Property Value

Type: Boolean
true if Quick format is desired; otherwise, false.
See Also

Reference

PartitionInitializationInfo Class
DoubleTake.Virtualization.Contract Namespace


PartitionInitializationInfo.ShouldCreateMountPointDirectory Property

PartitionInitializationInfoShouldCreateMountPointDirectory Property
Gets or sets a value indicating whether InitializeDisk should create mount point directory or not.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool ShouldCreateMountPointDirectory { get; set; }
Public Property ShouldCreateMountPointDirectory As Boolean
    Get
    Set
public:
property bool ShouldCreateMountPointDirectory {
    bool get ();
    void set (bool value);
}
function get_ShouldCreateMountPointDirectory();
function set_ShouldCreateMountPointDirectory(value);

Property Value

Type: Boolean
true if InitializeDisk should create mount point directory; otherwise, false.
See Also

Reference

PartitionInitializationInfo Class
DoubleTake.Virtualization.Contract Namespace


PartitionInitializationInfo.ShouldFormatPartition Property

PartitionInitializationInfoShouldFormatPartition Property
Indicates whether the partition should be formatted.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool ShouldFormatPartition { get; set; }
Public Property ShouldFormatPartition As Boolean
    Get
    Set
public:
property bool ShouldFormatPartition {
    bool get ();
    void set (bool value);
}
function get_ShouldFormatPartition();
function set_ShouldFormatPartition(value);

Property Value

Type: Boolean
See Also

Reference

PartitionInitializationInfo Class
DoubleTake.Virtualization.Contract Namespace


PartitionInitializationInfo.Size Property

PartitionInitializationInfoSize Property
The size in Megabytes of the partition. If the size is 0 then it will consume the rest of the space.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int Size { get; set; }
Public Property Size As Integer
    Get
    Set
public:
property int Size {
    int get ();
    void set (int value);
}
function get_Size();
function set_Size(value);

Property Value

Type: Int32
See Also

Reference

PartitionInitializationInfo Class
DoubleTake.Virtualization.Contract Namespace


ServerQualificationResults Class

ServerQualificationResults Class
Represents server information to display on the Console
Inheritance Hierarchy
SystemObject
DoubleTake.Virtualization.ContractServerQualificationResults

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class ServerQualificationResults : IExtensibleDataObject
Public Class ServerQualificationResults
    Implements IExtensibleDataObject
public ref class ServerQualificationResults : IExtensibleDataObject
DoubleTake.Virtualization.Contract.ServerQualificationResults = function();

Type.createClass(
    'DoubleTake.Virtualization.Contract.ServerQualificationResults',
    null,
    IExtensibleDataObject);

The ServerQualificationResults type exposes the following members.

Constructors
 | Name | Description
Public method | ServerQualificationResults | Initializes a new instance of the ServerQualificationResults class
Top
Properties
 | Name | Description
Public property | Cpus | This value is the number of processors.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Memory | This value is the amount of memory in bytes.
Public property | Version | This value is the version of the target host hypervisor.
Public property | VirtualSwitches | This value represents the virtual switch information.
Public property | Volumes | This value represents the volume information.
Top
See Also

Reference

DoubleTake.Virtualization.Contract Namespace


ServerQualificationResults Constructor

ServerQualificationResults Constructor
Initializes a new instance of the ServerQualificationResults class

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ServerQualificationResults()
Public Sub New
public:
ServerQualificationResults()
DoubleTake.Virtualization.Contract.ServerQualificationResults = function();
See Also

Reference

ServerQualificationResults Class
DoubleTake.Virtualization.Contract Namespace


ServerQualificationResults Properties

ServerQualificationResults Properties

The ServerQualificationResults type exposes the following members.

Properties
 | Name | Description
Public property | Cpus | This value is the number of processors.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Memory | This value is the amount of memory in bytes.
Public property | Version | This value is the version of the target host hypervisor.
Public property | VirtualSwitches | This value represents the virtual switch information.
Public property | Volumes | This value represents the volume information.
Top
See Also

Reference

ServerQualificationResults Class
DoubleTake.Virtualization.Contract Namespace


ServerQualificationResults.Cpus Property

ServerQualificationResultsCpus Property
This value is the number of processors.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int Cpus { get; set; }
Public Property Cpus As Integer
    Get
    Set
public:
property int Cpus {
    int get ();
    void set (int value);
}
function get_Cpus();
function set_Cpus(value);

Property Value

Type: Int32
The number of cpus.
See Also

Reference

ServerQualificationResults Class
DoubleTake.Virtualization.Contract Namespace


ServerQualificationResults.ExtensionData Property

ServerQualificationResultsExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

ServerQualificationResults Class
DoubleTake.Virtualization.Contract Namespace


ServerQualificationResults.Memory Property

ServerQualificationResultsMemory Property
This value is the amount of memory in bytes.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public long Memory { get; set; }
Public Property Memory As Long
    Get
    Set
public:
property long long Memory {
    long long get ();
    void set (long long value);
}
function get_Memory();
function set_Memory(value);

Property Value

Type: Int64
The number of bytes of memory.
See Also

Reference

ServerQualificationResults Class
DoubleTake.Virtualization.Contract Namespace


ServerQualificationResults.Version Property

ServerQualificationResultsVersion Property
This value is the version of the target host hypervisor.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Version { get; set; }
Public Property Version As String
    Get
    Set
public:
property String^ Version {
    String^ get ();
    void set (String^ value);
}
function get_Version();
function set_Version(value);

Property Value

Type: String
See Also

Reference

ServerQualificationResults Class
DoubleTake.Virtualization.Contract Namespace


ServerQualificationResults.VirtualSwitches Property

ServerQualificationResultsVirtualSwitches Property
This value represents the virtual switch information.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VirtualSwitchInfo[] VirtualSwitches { get; set; }
Public Property VirtualSwitches As VirtualSwitchInfo()
    Get
    Set
public:
property array<VirtualSwitchInfo^>^ VirtualSwitches {
    array<VirtualSwitchInfo^>^ get ();
    void set (array<VirtualSwitchInfo^>^ value);
}
function get_VirtualSwitches();
function set_VirtualSwitches(value);

Property Value

Type: VirtualSwitchInfo
The array of number of virtual switches.
See Also

Reference

ServerQualificationResults Class
DoubleTake.Virtualization.Contract Namespace


ServerQualificationResults.Volumes Property

ServerQualificationResultsVolumes Property
This value represents the volume information.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VolumeQualificationResults[] Volumes { get; set; }
Public Property Volumes As VolumeQualificationResults()
    Get
    Set
public:
property array<VolumeQualificationResults^>^ Volumes {
    array<VolumeQualificationResults^>^ get ();
    void set (array<VolumeQualificationResults^>^ value);
}
function get_Volumes();
function set_Volumes(value);

Property Value

Type: VolumeQualificationResults
See Also

Reference

ServerQualificationResults Class
DoubleTake.Virtualization.Contract Namespace


SwitchPortInfo Class

SwitchPortInfo Class
Represents virtual switch of Hyper-V/ESX
Inheritance Hierarchy
SystemObject
DoubleTake.Virtualization.ContractSwitchPortInfo

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class SwitchPortInfo : IExtensibleDataObject
Public Class SwitchPortInfo
    Implements IExtensibleDataObject
public ref class SwitchPortInfo : IExtensibleDataObject
DoubleTake.Virtualization.Contract.SwitchPortInfo = function();

Type.createClass(
    'DoubleTake.Virtualization.Contract.SwitchPortInfo',
    null,
    IExtensibleDataObject);

The SwitchPortInfo type exposes the following members.

Constructors
 | Name | Description
Public method | SwitchPortInfo | Initializes a new instance of the SwitchPortInfo class
Top
Properties
 | Name | Description
Public property | AccessVLanId | This value is the VLAN ID.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Guid | This value is the switch port unique ID.
Public property | Name | This value is the switch port label.
Top
See Also

Reference

DoubleTake.Virtualization.Contract Namespace


SwitchPortInfo Constructor

SwitchPortInfo Constructor
Initializes a new instance of the SwitchPortInfo class

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public SwitchPortInfo()
Public Sub New
public:
SwitchPortInfo()
DoubleTake.Virtualization.Contract.SwitchPortInfo = function();
See Also

Reference

SwitchPortInfo Class
DoubleTake.Virtualization.Contract Namespace


SwitchPortInfo Properties

SwitchPortInfo Properties

The SwitchPortInfo type exposes the following members.

Properties
 | Name | Description
Public property | AccessVLanId | This value is the VLAN ID.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Guid | This value is the switch port unique ID.
Public property | Name | This value is the switch port label.
Top
See Also

Reference

SwitchPortInfo Class
DoubleTake.Virtualization.Contract Namespace


SwitchPortInfo.AccessVLanId Property

SwitchPortInfoAccessVLanId Property
This value is the VLAN ID.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int AccessVLanId { get; set; }
Public Property AccessVLanId As Integer
    Get
    Set
public:
property int AccessVLanId {
    int get ();
    void set (int value);
}
function get_AccessVLanId();
function set_AccessVLanId(value);

Property Value

Type: Int32
See Also

Reference

SwitchPortInfo Class
DoubleTake.Virtualization.Contract Namespace


SwitchPortInfo.ExtensionData Property

SwitchPortInfoExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

SwitchPortInfo Class
DoubleTake.Virtualization.Contract Namespace


SwitchPortInfo.Guid Property

SwitchPortInfoGuid Property
This value is the switch port unique ID.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Guid { get; set; }
Public Property Guid As String
    Get
    Set
public:
property String^ Guid {
    String^ get ();
    void set (String^ value);
}
function get_Guid();
function set_Guid(value);

Property Value

Type: String
See Also

Reference

SwitchPortInfo Class
DoubleTake.Virtualization.Contract Namespace


SwitchPortInfo.Name Property

SwitchPortInfoName Property
This value is the switch port label.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
function get_Name();
function set_Name(value);

Property Value

Type: String
See Also

Reference

SwitchPortInfo Class
DoubleTake.Virtualization.Contract Namespace


SystemInitializationInfo Class

SystemInitializationInfo Class
Describes how a disk is to be partitioned and formatted. The DiskIdentifier is used to identify the disk to be partition. The Partitioning Scheme identifies if the disk is to use GPT or MBR. The array of PartitionInitializationInfo structures identifies how many partitions, what size and format they should have and other things.
Inheritance Hierarchy
SystemObject
DoubleTake.Virtualization.ContractSystemInitializationInfo

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class SystemInitializationInfo : IExtensibleDataObject
Public Class SystemInitializationInfo
    Implements IExtensibleDataObject
public ref class SystemInitializationInfo : IExtensibleDataObject
DoubleTake.Virtualization.Contract.SystemInitializationInfo = function();

Type.createClass(
    'DoubleTake.Virtualization.Contract.SystemInitializationInfo',
    null,
    IExtensibleDataObject);

The SystemInitializationInfo type exposes the following members.

Constructors
 | Name | Description
Public method | SystemInitializationInfo | Initializes a new instance of the SystemInitializationInfo class
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | PartitionVolumeInitializationInfo | Gets or set Partition Volume information which are non-LVM
Public property | VolumeGroupInitializationInfo | Gets or set Volume Group information including Logical Volume and Physical Volume
Top
See Also

Reference

DoubleTake.Virtualization.Contract Namespace


SystemInitializationInfo Constructor

SystemInitializationInfo Constructor
Initializes a new instance of the SystemInitializationInfo class

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public SystemInitializationInfo()
Public Sub New
public:
SystemInitializationInfo()
DoubleTake.Virtualization.Contract.SystemInitializationInfo = function();
See Also

Reference

SystemInitializationInfo Class
DoubleTake.Virtualization.Contract Namespace


SystemInitializationInfo Properties

SystemInitializationInfo Properties

The SystemInitializationInfo type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | PartitionVolumeInitializationInfo | Gets or set Partition Volume information which are non-LVM
Public property | VolumeGroupInitializationInfo | Gets or set Volume Group information including Logical Volume and Physical Volume
Top
See Also

Reference

SystemInitializationInfo Class
DoubleTake.Virtualization.Contract Namespace


SystemInitializationInfo.ExtensionData Property

SystemInitializationInfoExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

SystemInitializationInfo Class
DoubleTake.Virtualization.Contract Namespace


SystemInitializationInfo.PartitionVolumeInitializationInfo Property

SystemInitializationInfoPartitionVolumeInitializationInfo Property
Gets or set Partition Volume information which are non-LVM

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public PartitionInitializationInfo[] PartitionVolumeInitializationInfo { get; set; }
Public Property PartitionVolumeInitializationInfo As PartitionInitializationInfo()
    Get
    Set
public:
property array<PartitionInitializationInfo^>^ PartitionVolumeInitializationInfo {
    array<PartitionInitializationInfo^>^ get ();
    void set (array<PartitionInitializationInfo^>^ value);
}
function get_PartitionVolumeInitializationInfo();
function set_PartitionVolumeInitializationInfo(value);

Property Value

Type: PartitionInitializationInfo
Partition Volumes Information
See Also

Reference

SystemInitializationInfo Class
DoubleTake.Virtualization.Contract Namespace


SystemInitializationInfo.VolumeGroupInitializationInfo Property

SystemInitializationInfoVolumeGroupInitializationInfo Property
Gets or set Volume Group information including Logical Volume and Physical Volume

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VolumeGroup[] VolumeGroupInitializationInfo { get; set; }
Public Property VolumeGroupInitializationInfo As VolumeGroup()
    Get
    Set
public:
property array<VolumeGroup^>^ VolumeGroupInitializationInfo {
    array<VolumeGroup^>^ get ();
    void set (array<VolumeGroup^>^ value);
}
function get_VolumeGroupInitializationInfo();
function set_VolumeGroupInitializationInfo(value);

Property Value

Type: VolumeGroup
Volume Group Information
See Also

Reference

SystemInitializationInfo Class
DoubleTake.Virtualization.Contract Namespace


VHDInfo Class

VHDInfo Class
Part of VM configuration. Describes VHD that is part of VM VM configuration contains an array of these types: all VHDs of that VM.
Inheritance Hierarchy
SystemObject
DoubleTake.Virtualization.ContractVHDInfo

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
[SerializableAttribute]
public class VHDInfo : IExtensibleDataObject
<SerializableAttribute>
Public Class VHDInfo
    Implements IExtensibleDataObject
[SerializableAttribute]
public ref class VHDInfo : IExtensibleDataObject
DoubleTake.Virtualization.Contract.VHDInfo = function();

Type.createClass(
    'DoubleTake.Virtualization.Contract.VHDInfo',
    null,
    IExtensibleDataObject);

The VHDInfo type exposes the following members.

Constructors
 | Name | Description
Public method | VHDInfo | Initializes a new instance of the VHDInfo class
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Top
Fields
 | Name | Description
Public field | Drive | Gets or sets the drive of the VHD
Public field | FileSize | Gets or sets the current size of the VHD
Public field | MaxInternalSize | Used by CreateJob to check for free space
Public field | ParentPath | Full path to the parent of VHD file
Public field | Path | Full path to VHD file
Public field | Type | Gets or sets the VHD type
Top
See Also

Reference

DoubleTake.Virtualization.Contract Namespace


VHDInfo Constructor

VHDInfo Constructor
Initializes a new instance of the VHDInfo class

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VHDInfo()
Public Sub New
public:
VHDInfo()
DoubleTake.Virtualization.Contract.VHDInfo = function();
See Also

Reference

VHDInfo Class
DoubleTake.Virtualization.Contract Namespace


VHDInfo Properties

VHDInfo Properties

The VHDInfo type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Top
See Also

Reference

VHDInfo Class
DoubleTake.Virtualization.Contract Namespace


VHDInfo.ExtensionData Property

VHDInfoExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

VHDInfo Class
DoubleTake.Virtualization.Contract Namespace


VHDInfo Fields

VHDInfo Fields

The VHDInfo type exposes the following members.

Fields
 | Name | Description
Public field | Drive | Gets or sets the drive of the VHD
Public field | FileSize | Gets or sets the current size of the VHD
Public field | MaxInternalSize | Used by CreateJob to check for free space
Public field | ParentPath | Full path to the parent of VHD file
Public field | Path | Full path to VHD file
Public field | Type | Gets or sets the VHD type
Top
See Also

Reference

VHDInfo Class
DoubleTake.Virtualization.Contract Namespace


VHDInfo.Drive Field

VHDInfoDrive Field
Gets or sets the drive of the VHD

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Drive
Public Drive As String
public:
String^ Drive
var Drive

Field Value

Type: String
See Also

Reference

VHDInfo Class
DoubleTake.Virtualization.Contract Namespace


VHDInfo.FileSize Field

VHDInfoFileSize Field
Gets or sets the current size of the VHD

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public long FileSize
Public FileSize As Long
public:
long long FileSize
var FileSize

Field Value

Type: Int64
See Also

Reference

VHDInfo Class
DoubleTake.Virtualization.Contract Namespace


VHDInfo.MaxInternalSize Field

VHDInfoMaxInternalSize Field
Used by CreateJob to check for free space

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public long MaxInternalSize
Public MaxInternalSize As Long
public:
long long MaxInternalSize
var MaxInternalSize

Field Value

Type: Int64
See Also

Reference

VHDInfo Class
DoubleTake.Virtualization.Contract Namespace


VHDInfo.ParentPath Field

VHDInfoParentPath Field
Full path to the parent of VHD file

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string ParentPath
Public ParentPath As String
public:
String^ ParentPath
var ParentPath

Field Value

Type: String
See Also

Reference

VHDInfo Class
DoubleTake.Virtualization.Contract Namespace


VHDInfo.Path Field

VHDInfoPath Field
Full path to VHD file

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Path
Public Path As String
public:
String^ Path
var Path

Field Value

Type: String
See Also

Reference

VHDInfo Class
DoubleTake.Virtualization.Contract Namespace


VHDInfo.Type Field

VHDInfoType Field
Gets or sets the VHD type

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int Type
Public Type As Integer
public:
int Type
var Type

Field Value

Type: Int32
See Also

Reference

VHDInfo Class
DoubleTake.Virtualization.Contract Namespace


VirtualizationConnectionInfo Class

VirtualizationConnectionInfo Class
This class represents the additional data required to create an manage an engine connection for a virtualization job
Inheritance Hierarchy
SystemObject
DoubleTake.Virtualization.ContractVirtualizationConnectionInfo

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class VirtualizationConnectionInfo : IExtensibleDataObject
Public Class VirtualizationConnectionInfo
    Implements IExtensibleDataObject
public ref class VirtualizationConnectionInfo : IExtensibleDataObject
DoubleTake.Virtualization.Contract.VirtualizationConnectionInfo = function();

Type.createClass(
    'DoubleTake.Virtualization.Contract.VirtualizationConnectionInfo',
    null,
    IExtensibleDataObject);

The VirtualizationConnectionInfo type exposes the following members.

Constructors
 | Name | Description
Public method | VirtualizationConnectionInfo | Initializes a new instance of the VirtualizationConnectionInfo class
Top
Properties
 | Name | Description
Public property | Attach |
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | MonitorId | Gets or sets the monitor id.
Public property | PathTransformations | Gets or sets the path transformations.
Public property | ProcessHardlinks | Gets or sets a value indicating whether Double-Take should process hardlinks.
Public property | RepsetName | Gets or sets the name of the repset.
Top
See Also

Reference

DoubleTake.Virtualization.Contract Namespace


VirtualizationConnectionInfo Constructor

VirtualizationConnectionInfo Constructor
Initializes a new instance of the VirtualizationConnectionInfo class

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VirtualizationConnectionInfo()
Public Sub New
public:
VirtualizationConnectionInfo()
DoubleTake.Virtualization.Contract.VirtualizationConnectionInfo = function();
See Also

Reference

VirtualizationConnectionInfo Class
DoubleTake.Virtualization.Contract Namespace


VirtualizationConnectionInfo Properties

VirtualizationConnectionInfo Properties

The VirtualizationConnectionInfo type exposes the following members.

Properties
 | Name | Description
Public property | Attach |
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | MonitorId | Gets or sets the monitor id.
Public property | PathTransformations | Gets or sets the path transformations.
Public property | ProcessHardlinks | Gets or sets a value indicating whether Double-Take should process hardlinks.
Public property | RepsetName | Gets or sets the name of the repset.
Top
See Also

Reference

VirtualizationConnectionInfo Class
DoubleTake.Virtualization.Contract Namespace


VirtualizationConnectionInfo.Attach Property

VirtualizationConnectionInfoAttach Property

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool Attach { get; set; }
Public Property Attach As Boolean
    Get
    Set
public:
property bool Attach {
    bool get ();
    void set (bool value);
}
function get_Attach();
function set_Attach(value);

Property Value

Type: Boolean
See Also

Reference

VirtualizationConnectionInfo Class
DoubleTake.Virtualization.Contract Namespace


VirtualizationConnectionInfo.ExtensionData Property

VirtualizationConnectionInfoExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

VirtualizationConnectionInfo Class
DoubleTake.Virtualization.Contract Namespace


VirtualizationConnectionInfo.MonitorId Property

VirtualizationConnectionInfoMonitorId Property
Gets or sets the monitor id.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Guid MonitorId { get; set; }
Public Property MonitorId As Guid
    Get
    Set
public:
property Guid MonitorId {
    Guid get ();
    void set (Guid value);
}
function get_MonitorId();
function set_MonitorId(value);

Property Value

Type: Guid
The monitor id.
See Also

Reference

VirtualizationConnectionInfo Class
DoubleTake.Virtualization.Contract Namespace


VirtualizationConnectionInfo.PathTransformations Property

VirtualizationConnectionInfoPathTransformations Property
Gets or sets the path transformations.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public PathTransformation[] PathTransformations { get; set; }
Public Property PathTransformations As PathTransformation()
    Get
    Set
public:
property array<PathTransformation^>^ PathTransformations {
    array<PathTransformation^>^ get ();
    void set (array<PathTransformation^>^ value);
}
function get_PathTransformations();
function set_PathTransformations(value);

Property Value

Type: PathTransformation
The path transformations.
See Also

Reference

VirtualizationConnectionInfo Class
DoubleTake.Virtualization.Contract Namespace


VirtualizationConnectionInfo.ProcessHardlinks Property

VirtualizationConnectionInfoProcessHardlinks Property
Gets or sets a value indicating whether Double-Take should process hardlinks.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool ProcessHardlinks { get; set; }
Public Property ProcessHardlinks As Boolean
    Get
    Set
public:
property bool ProcessHardlinks {
    bool get ();
    void set (bool value);
}
function get_ProcessHardlinks();
function set_ProcessHardlinks(value);

Property Value

Type: Boolean
true if Double-Take should process hardlinks; otherwise, false.
See Also

Reference

VirtualizationConnectionInfo Class
DoubleTake.Virtualization.Contract Namespace


VirtualizationConnectionInfo.RepsetName Property

VirtualizationConnectionInfoRepsetName Property
Gets or sets the name of the repset.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string RepsetName { get; set; }
Public Property RepsetName As String
    Get
    Set
public:
property String^ RepsetName {
    String^ get ();
    void set (String^ value);
}
function get_RepsetName();
function set_RepsetName(value);

Property Value

Type: String
The name of the repset.
See Also

Reference

VirtualizationConnectionInfo Class
DoubleTake.Virtualization.Contract Namespace


VirtualNetworkInterfaceInfo Class

VirtualNetworkInterfaceInfo Class
This class adds the extra information we need for WAN Failover and host network mapping
Inheritance Hierarchy
SystemObject
DoubleTake.Core.ContractNetworkInterfaceInfo
DoubleTake.Virtualization.ContractVirtualNetworkInterfaceInfo
DoubleTake.Virtualization.Contract.VRAVRAInternalVirtualNetworkInterfaceInfo

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class VirtualNetworkInterfaceInfo : NetworkInterfaceInfo
Public Class VirtualNetworkInterfaceInfo
    Inherits NetworkInterfaceInfo
public ref class VirtualNetworkInterfaceInfo : public NetworkInterfaceInfo
DoubleTake.Virtualization.Contract.VirtualNetworkInterfaceInfo = function();

Type.createClass(
    'DoubleTake.Virtualization.Contract.VirtualNetworkInterfaceInfo',
    DoubleTake.Core.Contract.NetworkInterfaceInfo);

The VirtualNetworkInterfaceInfo type exposes the following members.

Constructors
 | Name | Description
Public method | VirtualNetworkInterfaceInfo | Initializes a new instance of the VirtualNetworkInterfaceInfo class
Top
Properties
 | Name | Description
Public property | Description | This value is the description of the NIC. (Inherited from NetworkInterfaceInfo.)
Public property | DnsDomain | This value is the DNS domain assigned to the NIC. (Inherited from NetworkInterfaceInfo.)
Public property | DnsServers | This value is the DNS server assigned to the NIC. (Inherited from NetworkInterfaceInfo.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from NetworkInterfaceInfo.)
Public property | Gateways | This value is the gateway assigned to the NIC. (Inherited from NetworkInterfaceInfo.)
Public property | Guid | This value is the unique ID for the NIC. It is equivalent to the SettingID property of the Win32_NetworkAdapterConfiguration WMI class as well as the NetworkInterface.Id property in the Base Class Library (BCL). (Inherited from NetworkInterfaceInfo.)
Public property | Index | Do not use this property. Double-Take uses it internally. (Inherited from NetworkInterfaceInfo.)
Public property | InterfaceIndex | Do not use this property. Double-Take uses it internally. (Inherited from NetworkInterfaceInfo.)
Public property | IPAddresses | This value represents the IP addresses assigned to the NIC. (Inherited from NetworkInterfaceInfo.)
Public property | MacAddress | This value represents the MAC address of the NIC. (Inherited from NetworkInterfaceInfo.)
Public property | Name | This value is the friendly name of the NIC. (Inherited from NetworkInterfaceInfo.)
Public property | PnpInstanceId | This value is the plug and play instance ID of the NIC. (Inherited from NetworkInterfaceInfo.)
Public property | ServiceName | This value is the service name of the NIC. (Inherited from NetworkInterfaceInfo.)
Public property | VirtualNetwork | This value is the virtual network.
Public property | VirtualNicType | This value is the virtual NIC.
Public property | VLAN_ID | Gets or sets the replica's VLan ID.
Public property | VLAN_ID_TestFailover | Gets or sets the replica's test failover VLan ID.
Top
See Also

Reference

DoubleTake.Virtualization.Contract Namespace


VirtualNetworkInterfaceInfo Constructor

VirtualNetworkInterfaceInfo Constructor
Initializes a new instance of the VirtualNetworkInterfaceInfo class

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VirtualNetworkInterfaceInfo()
Public Sub New
public:
VirtualNetworkInterfaceInfo()
DoubleTake.Virtualization.Contract.VirtualNetworkInterfaceInfo = function();
See Also

Reference

VirtualNetworkInterfaceInfo Class
DoubleTake.Virtualization.Contract Namespace


VirtualNetworkInterfaceInfo Properties

VirtualNetworkInterfaceInfo Properties

The VirtualNetworkInterfaceInfo type exposes the following members.

Properties
 | Name | Description
Public property | Description | This value is the description of the NIC. (Inherited from NetworkInterfaceInfo.)
Public property | DnsDomain | This value is the DNS domain assigned to the NIC. (Inherited from NetworkInterfaceInfo.)
Public property | DnsServers | This value is the DNS server assigned to the NIC. (Inherited from NetworkInterfaceInfo.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from NetworkInterfaceInfo.)
Public property | Gateways | This value is the gateway assigned to the NIC. (Inherited from NetworkInterfaceInfo.)
Public property | Guid | This value is the unique ID for the NIC. It is equivalent to the SettingID property of the Win32_NetworkAdapterConfiguration WMI class as well as the NetworkInterface.Id property in the Base Class Library (BCL). (Inherited from NetworkInterfaceInfo.)
Public property | Index | Do not use this property. Double-Take uses it internally. (Inherited from NetworkInterfaceInfo.)
Public property | InterfaceIndex | Do not use this property. Double-Take uses it internally. (Inherited from NetworkInterfaceInfo.)
Public property | IPAddresses | This value represents the IP addresses assigned to the NIC. (Inherited from NetworkInterfaceInfo.)
Public property | MacAddress | This value represents the MAC address of the NIC. (Inherited from NetworkInterfaceInfo.)
Public property | Name | This value is the friendly name of the NIC. (Inherited from NetworkInterfaceInfo.)
Public property | PnpInstanceId | This value is the plug and play instance ID of the NIC. (Inherited from NetworkInterfaceInfo.)
Public property | ServiceName | This value is the service name of the NIC. (Inherited from NetworkInterfaceInfo.)
Public property | VirtualNetwork | This value is the virtual network.
Public property | VirtualNicType | This value is the virtual NIC.
Public property | VLAN_ID | Gets or sets the replica's VLan ID.
Public property | VLAN_ID_TestFailover | Gets or sets the replica's test failover VLan ID.
Top
See Also

Reference

VirtualNetworkInterfaceInfo Class
DoubleTake.Virtualization.Contract Namespace


VirtualNetworkInterfaceInfo.VirtualNetwork Property

VirtualNetworkInterfaceInfoVirtualNetwork Property
This value is the virtual network.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string VirtualNetwork { get; set; }
Public Property VirtualNetwork As String
    Get
    Set
public:
property String^ VirtualNetwork {
    String^ get ();
    void set (String^ value);
}
function get_VirtualNetwork();
function set_VirtualNetwork(value);

Property Value

Type: String
The virtual network.
See Also

Reference

VirtualNetworkInterfaceInfo Class
DoubleTake.Virtualization.Contract Namespace


VirtualNetworkInterfaceInfo.VirtualNicType Property

VirtualNetworkInterfaceInfoVirtualNicType Property
This value is the virtual NIC.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string VirtualNicType { get; set; }
Public Property VirtualNicType As String
    Get
    Set
public:
property String^ VirtualNicType {
    String^ get ();
    void set (String^ value);
}
function get_VirtualNicType();
function set_VirtualNicType(value);

Property Value

Type: String
The type of the virtual nic.
See Also

Reference

VirtualNetworkInterfaceInfo Class
DoubleTake.Virtualization.Contract Namespace


VirtualNetworkInterfaceInfo.VLAN_ID Property

VirtualNetworkInterfaceInfoVLAN_ID Property
Gets or sets the replica's VLan ID.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int VLAN_ID { get; set; }
Public Property VLAN_ID As Integer
    Get
    Set
public:
property int VLAN_ID {
    int get ();
    void set (int value);
}
function get_VLAN_ID();
function set_VLAN_ID(value);

Property Value

Type: Int32
The replica's VLan ID. Possible values: -1 - indicates that the vlan should not be set at failover time and the service supports setting it. 0 - indicates that the server does not support setting the vlan id at failover time. (1 - 4095) - indicates that the vlan for this nic should be set at failover time. all other values are not supported.
See Also

Reference

VirtualNetworkInterfaceInfo Class
DoubleTake.Virtualization.Contract Namespace


VirtualNetworkInterfaceInfo.VLAN_ID_TestFailover Property

VirtualNetworkInterfaceInfoVLAN_ID_TestFailover Property
Gets or sets the replica's test failover VLan ID.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int VLAN_ID_TestFailover { get; set; }
Public Property VLAN_ID_TestFailover As Integer
    Get
    Set
public:
property int VLAN_ID_TestFailover {
    int get ();
    void set (int value);
}
function get_VLAN_ID_TestFailover();
function set_VLAN_ID_TestFailover(value);

Property Value

Type: Int32
The replica's VLan ID during test failover. Possible values: -1 - indicates that the vlan should not be set at failover time and the service supports setting it. 0 - indicates that the server does not support setting the vlan id at failover time. (1 - 4095) - indicates that the vlan for this nic should be set at failover time. all other values are not supported.
See Also

Reference

VirtualNetworkInterfaceInfo Class
DoubleTake.Virtualization.Contract Namespace


VirtualSwitchInfo Class

VirtualSwitchInfo Class
Represents virtual switch of Hyper-V/ESX
Inheritance Hierarchy
SystemObject
DoubleTake.Virtualization.ContractVirtualSwitchInfo

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class VirtualSwitchInfo : IExtensibleDataObject
Public Class VirtualSwitchInfo
    Implements IExtensibleDataObject
public ref class VirtualSwitchInfo : IExtensibleDataObject
DoubleTake.Virtualization.Contract.VirtualSwitchInfo = function();

Type.createClass(
    'DoubleTake.Virtualization.Contract.VirtualSwitchInfo',
    null,
    IExtensibleDataObject);

The VirtualSwitchInfo type exposes the following members.

Constructors
 | Name | Description
Public method | VirtualSwitchInfo | Initializes a new instance of the VirtualSwitchInfo class
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Label | This value is the virtual switch label.
Public property | SwitchUuid | This value is the virtual switch unique ID.
Top
See Also

Reference

DoubleTake.Virtualization.Contract Namespace


VirtualSwitchInfo Constructor

VirtualSwitchInfo Constructor
Initializes a new instance of the VirtualSwitchInfo class

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VirtualSwitchInfo()
Public Sub New
public:
VirtualSwitchInfo()
DoubleTake.Virtualization.Contract.VirtualSwitchInfo = function();
See Also

Reference

VirtualSwitchInfo Class
DoubleTake.Virtualization.Contract Namespace


VirtualSwitchInfo Properties

VirtualSwitchInfo Properties

The VirtualSwitchInfo type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Label | This value is the virtual switch label.
Public property | SwitchUuid | This value is the virtual switch unique ID.
Top
See Also

Reference

VirtualSwitchInfo Class
DoubleTake.Virtualization.Contract Namespace


VirtualSwitchInfo.ExtensionData Property

VirtualSwitchInfoExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

VirtualSwitchInfo Class
DoubleTake.Virtualization.Contract Namespace


VirtualSwitchInfo.Label Property

VirtualSwitchInfoLabel Property
This value is the virtual switch label.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Label { get; set; }
Public Property Label As String
    Get
    Set
public:
property String^ Label {
    String^ get ();
    void set (String^ value);
}
function get_Label();
function set_Label(value);

Property Value

Type: String
See Also

Reference

VirtualSwitchInfo Class
DoubleTake.Virtualization.Contract Namespace


VirtualSwitchInfo.SwitchUuid Property

VirtualSwitchInfoSwitchUuid Property
This value is the virtual switch unique ID.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string SwitchUuid { get; set; }
Public Property SwitchUuid As String
    Get
    Set
public:
property String^ SwitchUuid {
    String^ get ();
    void set (String^ value);
}
function get_SwitchUuid();
function set_SwitchUuid(value);

Property Value

Type: String
See Also

Reference

VirtualSwitchInfo Class
DoubleTake.Virtualization.Contract Namespace


VirtualSwitchMapping Class

VirtualSwitchMapping Class
Represents source and target virtual switch mappings
Inheritance Hierarchy
SystemObject
DoubleTake.Virtualization.ContractVirtualSwitchMapping

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class VirtualSwitchMapping : IExtensibleDataObject
Public Class VirtualSwitchMapping
    Implements IExtensibleDataObject
public ref class VirtualSwitchMapping : IExtensibleDataObject
DoubleTake.Virtualization.Contract.VirtualSwitchMapping = function();

Type.createClass(
    'DoubleTake.Virtualization.Contract.VirtualSwitchMapping',
    null,
    IExtensibleDataObject);

The VirtualSwitchMapping type exposes the following members.

Constructors
 | Name | Description
Public method | VirtualSwitchMapping | Initializes a new instance of the VirtualSwitchMapping class
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | SourceVirtualSwitch | This value represents the virtual switch on the source.
Public property | TargetVirtualSwitch | This value represents the virtual switch on the target.
Top
See Also

Reference

DoubleTake.Virtualization.Contract Namespace


VirtualSwitchMapping Constructor

VirtualSwitchMapping Constructor
Initializes a new instance of the VirtualSwitchMapping class

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VirtualSwitchMapping()
Public Sub New
public:
VirtualSwitchMapping()
DoubleTake.Virtualization.Contract.VirtualSwitchMapping = function();
See Also

Reference

VirtualSwitchMapping Class
DoubleTake.Virtualization.Contract Namespace


VirtualSwitchMapping Properties

VirtualSwitchMapping Properties

The VirtualSwitchMapping type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | SourceVirtualSwitch | This value represents the virtual switch on the source.
Public property | TargetVirtualSwitch | This value represents the virtual switch on the target.
Top
See Also

Reference

VirtualSwitchMapping Class
DoubleTake.Virtualization.Contract Namespace


VirtualSwitchMapping.ExtensionData Property

VirtualSwitchMappingExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

VirtualSwitchMapping Class
DoubleTake.Virtualization.Contract Namespace


VirtualSwitchMapping.SourceVirtualSwitch Property

VirtualSwitchMappingSourceVirtualSwitch Property
This value represents the virtual switch on the source.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VirtualSwitchInfo SourceVirtualSwitch { get; set; }
Public Property SourceVirtualSwitch As VirtualSwitchInfo
    Get
    Set
public:
property VirtualSwitchInfo^ SourceVirtualSwitch {
    VirtualSwitchInfo^ get ();
    void set (VirtualSwitchInfo^ value);
}
function get_SourceVirtualSwitch();
function set_SourceVirtualSwitch(value);

Property Value

Type: VirtualSwitchInfo
See Also

Reference

VirtualSwitchMapping Class
DoubleTake.Virtualization.Contract Namespace


VirtualSwitchMapping.TargetVirtualSwitch Property

VirtualSwitchMappingTargetVirtualSwitch Property
This value represents the virtual switch on the target.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VirtualSwitchInfo TargetVirtualSwitch { get; set; }
Public Property TargetVirtualSwitch As VirtualSwitchInfo
    Get
    Set
public:
property VirtualSwitchInfo^ TargetVirtualSwitch {
    VirtualSwitchInfo^ get ();
    void set (VirtualSwitchInfo^ value);
}
function get_TargetVirtualSwitch();
function set_TargetVirtualSwitch(value);

Property Value

Type: VirtualSwitchInfo
See Also

Reference

VirtualSwitchMapping Class
DoubleTake.Virtualization.Contract Namespace


VMInfo Class

VMInfo Class
Represents properties of virtual machine.
Inheritance Hierarchy
SystemObject
DoubleTake.Virtualization.ContractVMInfo
DoubleTake.Virtualization.Contract.VRAReplicaVMInfo

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class VMInfo : IExtensibleDataObject
Public Class VMInfo
    Implements IExtensibleDataObject
public ref class VMInfo : IExtensibleDataObject
DoubleTake.Virtualization.Contract.VMInfo = function();

Type.createClass(
    'DoubleTake.Virtualization.Contract.VMInfo',
    null,
    IExtensibleDataObject);

The VMInfo type exposes the following members.

Constructors
 | Name | Description
Public method | VMInfo | Initializes a new instance of the VMInfo class
Top
Properties
 | Name | Description
Public property | Address | This value is the virtual machine guest name or IP address.
Public property | BootVolumeSignature | This value is the virtual machine boot volume signature which is required for agentless Hyper-V WAN failover.
Public property | DisplayName | This value is the virtual machine display name.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | GuestOS | This value is the virtual machine guest operating system.
Public property | GuestUri | This value is the guest URI.
Public property | Id | This value is the virtual machine unique ID.
Public property | Path | This value is the virtual machine configuration file location.
Public property | PathTransformations | This value represents where the protected source virtual machine will be located on the target.
Public property | SnapshotDataPath | This value is the virtual machine snapshot location.
Public property | SnapshotFileNames | This value is the virtual machine snapshot file names.
Public property | SystemDirectory | This value is the virtual machine system directory which is required for agentless Hyper-V WAN failover.
Public property | VirtualHardDiskPath | This value is the virtual machine hard disk location.
Top
Fields
 | Name | Description
Public field | BiosGuid | This value is the virtual machine BIOS unique ID.
Top
See Also

Reference

DoubleTake.Virtualization.Contract Namespace


VMInfo Constructor

VMInfo Constructor
Initializes a new instance of the VMInfo class

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VMInfo()
Public Sub New
public:
VMInfo()
DoubleTake.Virtualization.Contract.VMInfo = function();
See Also

Reference

VMInfo Class
DoubleTake.Virtualization.Contract Namespace


VMInfo Properties

VMInfo Properties

The VMInfo type exposes the following members.

Properties
 | Name | Description
Public property | Address | This value is the virtual machine guest name or IP address.
Public property | BootVolumeSignature | This value is the virtual machine boot volume signature which is required for agentless Hyper-V WAN failover.
Public property | DisplayName | This value is the virtual machine display name.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | GuestOS | This value is the virtual machine guest operating system.
Public property | GuestUri | This value is the guest URI.
Public property | Id | This value is the virtual machine unique ID.
Public property | Path | This value is the virtual machine configuration file location.
Public property | PathTransformations | This value represents where the protected source virtual machine will be located on the target.
Public property | SnapshotDataPath | This value is the virtual machine snapshot location.
Public property | SnapshotFileNames | This value is the virtual machine snapshot file names.
Public property | SystemDirectory | This value is the virtual machine system directory which is required for agentless Hyper-V WAN failover.
Public property | VirtualHardDiskPath | This value is the virtual machine hard disk location.
Top
See Also

Reference

VMInfo Class
DoubleTake.Virtualization.Contract Namespace


VMInfo.Address Property

VMInfoAddress Property
This value is the virtual machine guest name or IP address.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Address { get; set; }
Public Property Address As String
    Get
    Set
public:
property String^ Address {
    String^ get ();
    void set (String^ value);
}
function get_Address();
function set_Address(value);

Property Value

Type: String
See Also

Reference

VMInfo Class
DoubleTake.Virtualization.Contract Namespace


VMInfo.BootVolumeSignature Property

VMInfoBootVolumeSignature Property
This value is the virtual machine boot volume signature which is required for agentless Hyper-V WAN failover.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public byte[] BootVolumeSignature { get; set; }
Public Property BootVolumeSignature As Byte()
    Get
    Set
public:
property array<unsigned char>^ BootVolumeSignature {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
function get_BootVolumeSignature();
function set_BootVolumeSignature(value);

Property Value

Type: Byte
Boot volume signature.
See Also

Reference

VMInfo Class
DoubleTake.Virtualization.Contract Namespace


VMInfo.DisplayName Property

VMInfoDisplayName Property
This value is the virtual machine display name.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string DisplayName { get; set; }
Public Property DisplayName As String
    Get
    Set
public:
property String^ DisplayName {
    String^ get ();
    void set (String^ value);
}
function get_DisplayName();
function set_DisplayName(value);

Property Value

Type: String
See Also

Reference

VMInfo Class
DoubleTake.Virtualization.Contract Namespace


VMInfo.ExtensionData Property

VMInfoExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

VMInfo Class
DoubleTake.Virtualization.Contract Namespace


VMInfo.GuestOS Property

VMInfoGuestOS Property
This value is the virtual machine guest operating system.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string GuestOS { get; set; }
Public Property GuestOS As String
    Get
    Set
public:
property String^ GuestOS {
    String^ get ();
    void set (String^ value);
}
function get_GuestOS();
function set_GuestOS(value);

Property Value

Type: String
See Also

Reference

VMInfo Class
DoubleTake.Virtualization.Contract Namespace


VMInfo.GuestUri Property

VMInfoGuestUri Property
This value is the guest URI.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Uri GuestUri { get; set; }
Public Property GuestUri As Uri
    Get
    Set
public:
property Uri^ GuestUri {
    Uri^ get ();
    void set (Uri^ value);
}
function get_GuestUri();
function set_GuestUri(value);

Property Value

Type: Uri
The guest URI.
See Also

Reference

VMInfo Class
DoubleTake.Virtualization.Contract Namespace


VMInfo.Id Property

VMInfoId Property
This value is the virtual machine unique ID.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Guid Id { get; set; }
Public Property Id As Guid
    Get
    Set
public:
property Guid Id {
    Guid get ();
    void set (Guid value);
}
function get_Id();
function set_Id(value);

Property Value

Type: Guid
See Also

Reference

VMInfo Class
DoubleTake.Virtualization.Contract Namespace


VMInfo.Path Property

VMInfoPath Property
This value is the virtual machine configuration file location.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Path { get; set; }
Public Property Path As String
    Get
    Set
public:
property String^ Path {
    String^ get ();
    void set (String^ value);
}
function get_Path();
function set_Path(value);

Property Value

Type: String
See Also

Reference

VMInfo Class
DoubleTake.Virtualization.Contract Namespace


VMInfo.PathTransformations Property

VMInfoPathTransformations Property
This value represents where the protected source virtual machine will be located on the target.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public PathTransformation[] PathTransformations { get; set; }
Public Property PathTransformations As PathTransformation()
    Get
    Set
public:
property array<PathTransformation^>^ PathTransformations {
    array<PathTransformation^>^ get ();
    void set (array<PathTransformation^>^ value);
}
function get_PathTransformations();
function set_PathTransformations(value);

Property Value

Type: PathTransformation
The path transformations
See Also

Reference

VMInfo Class
DoubleTake.Virtualization.Contract Namespace


VMInfo.SnapshotDataPath Property

VMInfoSnapshotDataPath Property
This value is the virtual machine snapshot location.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string SnapshotDataPath { get; set; }
Public Property SnapshotDataPath As String
    Get
    Set
public:
property String^ SnapshotDataPath {
    String^ get ();
    void set (String^ value);
}
function get_SnapshotDataPath();
function set_SnapshotDataPath(value);

Property Value

Type: String
See Also

Reference

VMInfo Class
DoubleTake.Virtualization.Contract Namespace


VMInfo.SnapshotFileNames Property

VMInfoSnapshotFileNames Property
This value is the virtual machine snapshot file names.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string[] SnapshotFileNames { get; set; }
Public Property SnapshotFileNames As String()
    Get
    Set
public:
property array<String^>^ SnapshotFileNames {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
function get_SnapshotFileNames();
function set_SnapshotFileNames(value);

Property Value

Type: String
System directory.
See Also

Reference

VMInfo Class
DoubleTake.Virtualization.Contract Namespace


VMInfo.SystemDirectory Property

VMInfoSystemDirectory Property
This value is the virtual machine system directory which is required for agentless Hyper-V WAN failover.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string SystemDirectory { get; set; }
Public Property SystemDirectory As String
    Get
    Set
public:
property String^ SystemDirectory {
    String^ get ();
    void set (String^ value);
}
function get_SystemDirectory();
function set_SystemDirectory(value);

Property Value

Type: String
System directory.
See Also

Reference

VMInfo Class
DoubleTake.Virtualization.Contract Namespace


VMInfo.VirtualHardDiskPath Property

VMInfoVirtualHardDiskPath Property
This value is the virtual machine hard disk location.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string[] VirtualHardDiskPath { get; set; }
Public Property VirtualHardDiskPath As String()
    Get
    Set
public:
property array<String^>^ VirtualHardDiskPath {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
function get_VirtualHardDiskPath();
function set_VirtualHardDiskPath(value);

Property Value

Type: String
The virtual hard disk path.
See Also

Reference

VMInfo Class
DoubleTake.Virtualization.Contract Namespace


VMInfo Fields

VMInfo Fields

The VMInfo type exposes the following members.

Fields
 | Name | Description
Public field | BiosGuid | This value is the virtual machine BIOS unique ID.
Top
See Also

Reference

VMInfo Class
DoubleTake.Virtualization.Contract Namespace


VMInfo.BiosGuid Field

VMInfoBiosGuid Field
This value is the virtual machine BIOS unique ID.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Guid BiosGuid
Public BiosGuid As Guid
public:
Guid BiosGuid
var BiosGuid

Field Value

Type: Guid
See Also

Reference

VMInfo Class
DoubleTake.Virtualization.Contract Namespace


VMQualificationResults Class

VMQualificationResults Class
Represents server information to display on the Console
Inheritance Hierarchy
SystemObject
DoubleTake.Virtualization.ContractVMQualificationResults

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class VMQualificationResults : IExtensibleDataObject
Public Class VMQualificationResults
    Implements IExtensibleDataObject
public ref class VMQualificationResults : IExtensibleDataObject
DoubleTake.Virtualization.Contract.VMQualificationResults = function();

Type.createClass(
    'DoubleTake.Virtualization.Contract.VMQualificationResults',
    null,
    IExtensibleDataObject);

The VMQualificationResults type exposes the following members.

Constructors
 | Name | Description
Public method | VMQualificationResults | Initializes a new instance of the VMQualificationResults class
Top
Properties
 | Name | Description
Public property | Address | This value is the virtual machine guest name or IP address.
Public property | DisplayName | This value is the virtual machine display name.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | IsHeartbeatInstalled | Do not use this property. Double-Take uses it internally.
Public property | NetworkAdapters | This value represents the NIC information.
Top
Fields
 | Name | Description
Public field | VHDInfo | This value represents the .vhd files for the virtual machine.
Top
See Also

Reference

DoubleTake.Virtualization.Contract Namespace


VMQualificationResults Constructor

VMQualificationResults Constructor
Initializes a new instance of the VMQualificationResults class

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VMQualificationResults()
Public Sub New
public:
VMQualificationResults()
DoubleTake.Virtualization.Contract.VMQualificationResults = function();
See Also

Reference

VMQualificationResults Class
DoubleTake.Virtualization.Contract Namespace


VMQualificationResults Properties

VMQualificationResults Properties

The VMQualificationResults type exposes the following members.

Properties
 | Name | Description
Public property | Address | This value is the virtual machine guest name or IP address.
Public property | DisplayName | This value is the virtual machine display name.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | IsHeartbeatInstalled | Do not use this property. Double-Take uses it internally.
Public property | NetworkAdapters | This value represents the NIC information.
Top
See Also

Reference

VMQualificationResults Class
DoubleTake.Virtualization.Contract Namespace


VMQualificationResults.Address Property

VMQualificationResultsAddress Property
This value is the virtual machine guest name or IP address.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Address { get; set; }
Public Property Address As String
    Get
    Set
public:
property String^ Address {
    String^ get ();
    void set (String^ value);
}
function get_Address();
function set_Address(value);

Property Value

Type: String
See Also

Reference

VMQualificationResults Class
DoubleTake.Virtualization.Contract Namespace


VMQualificationResults.DisplayName Property

VMQualificationResultsDisplayName Property
This value is the virtual machine display name.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string DisplayName { get; set; }
Public Property DisplayName As String
    Get
    Set
public:
property String^ DisplayName {
    String^ get ();
    void set (String^ value);
}
function get_DisplayName();
function set_DisplayName(value);

Property Value

Type: String
See Also

Reference

VMQualificationResults Class
DoubleTake.Virtualization.Contract Namespace


VMQualificationResults.ExtensionData Property

VMQualificationResultsExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

VMQualificationResults Class
DoubleTake.Virtualization.Contract Namespace


VMQualificationResults.IsHeartbeatInstalled Property

VMQualificationResultsIsHeartbeatInstalled Property
Do not use this property. Double-Take uses it internally.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsHeartbeatInstalled { get; set; }
Public Property IsHeartbeatInstalled As Boolean
    Get
    Set
public:
property bool IsHeartbeatInstalled {
    bool get ();
    void set (bool value);
}
function get_IsHeartbeatInstalled();
function set_IsHeartbeatInstalled(value);

Property Value

Type: Boolean
See Also

Reference

VMQualificationResults Class
DoubleTake.Virtualization.Contract Namespace


VMQualificationResults.NetworkAdapters Property

VMQualificationResultsNetworkAdapters Property
This value represents the NIC information.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public NetworkAdapterInfo[] NetworkAdapters { get; set; }
Public Property NetworkAdapters As NetworkAdapterInfo()
    Get
    Set
public:
property array<NetworkAdapterInfo^>^ NetworkAdapters {
    array<NetworkAdapterInfo^>^ get ();
    void set (array<NetworkAdapterInfo^>^ value);
}
function get_NetworkAdapters();
function set_NetworkAdapters(value);

Property Value

Type: NetworkAdapterInfo
See Also

Reference

VMQualificationResults Class
DoubleTake.Virtualization.Contract Namespace


VMQualificationResults Fields

VMQualificationResults Fields

The VMQualificationResults type exposes the following members.

Fields
 | Name | Description
Public field | VHDInfo | This value represents the .vhd files for the virtual machine.
Top
See Also

Reference

VMQualificationResults Class
DoubleTake.Virtualization.Contract Namespace


VMQualificationResults.VHDInfo Field

VMQualificationResultsVHDInfo Field
This value represents the .vhd files for the virtual machine.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VHDInfo[] VHDInfo
Public VHDInfo As VHDInfo()
public:
array<VHDInfo^>^ VHDInfo
var VHDInfo

Field Value

Type: VHDInfo
See Also

Reference

VMQualificationResults Class
DoubleTake.Virtualization.Contract Namespace


VolumeQualificationResults Class

VolumeQualificationResults Class
Represents information of volume for console display.
Inheritance Hierarchy
SystemObject
DoubleTake.Virtualization.ContractVolumeQualificationResults

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class VolumeQualificationResults : IExtensibleDataObject
Public Class VolumeQualificationResults
    Implements IExtensibleDataObject
public ref class VolumeQualificationResults : IExtensibleDataObject
DoubleTake.Virtualization.Contract.VolumeQualificationResults = function();

Type.createClass(
    'DoubleTake.Virtualization.Contract.VolumeQualificationResults',
    null,
    IExtensibleDataObject);

The VolumeQualificationResults type exposes the following members.

Constructors
 | Name | Description
Public method | VolumeQualificationResults | Initializes a new instance of the VolumeQualificationResults class
Top
Properties
 | Name | Description
Public property | ClusterResourceGroupName | This value is the name of the group that contains the resource.
Public property | CurrentOwnerNodeName | This value is the name of the resource's current owning node.
Public property | DiskSize | This value is the total size, in bytes, of the volume.
Public property | DriveLetter | This value is the drive letter of the volume.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | FreeSpace | This value is the available free space, in bytes, on the volume.
Public property | IsSystemVolume | This value is true if the volume is the system volume; otherwise, it is false.
Public property | IsVolumeCSV | This value is true if the volume is a cluster shared volume; otherwise, it is false.
Public property | MaxFileSize | This value is the maximum file size, in mebabytes, of the virtual hard disk file.
Public property | ProvisionedSpace | This value is the amount of provisioned space, in bytes, on the volume.
Public property | Url | This value is the URL of an ESX datastore.
Top
See Also

Reference

DoubleTake.Virtualization.Contract Namespace


VolumeQualificationResults Constructor

VolumeQualificationResults Constructor
Initializes a new instance of the VolumeQualificationResults class

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VolumeQualificationResults()
Public Sub New
public:
VolumeQualificationResults()
DoubleTake.Virtualization.Contract.VolumeQualificationResults = function();
See Also

Reference

VolumeQualificationResults Class
DoubleTake.Virtualization.Contract Namespace


VolumeQualificationResults Properties

VolumeQualificationResults Properties

The VolumeQualificationResults type exposes the following members.

Properties
 | Name | Description
Public property | ClusterResourceGroupName | This value is the name of the group that contains the resource.
Public property | CurrentOwnerNodeName | This value is the name of the resource's current owning node.
Public property | DiskSize | This value is the total size, in bytes, of the volume.
Public property | DriveLetter | This value is the drive letter of the volume.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | FreeSpace | This value is the available free space, in bytes, on the volume.
Public property | IsSystemVolume | This value is true if the volume is the system volume; otherwise, it is false.
Public property | IsVolumeCSV | This value is true if the volume is a cluster shared volume; otherwise, it is false.
Public property | MaxFileSize | This value is the maximum file size, in mebabytes, of the virtual hard disk file.
Public property | ProvisionedSpace | This value is the amount of provisioned space, in bytes, on the volume.
Public property | Url | This value is the URL of an ESX datastore.
Top
See Also

Reference

VolumeQualificationResults Class
DoubleTake.Virtualization.Contract Namespace


VolumeQualificationResults.ClusterResourceGroupName Property

VolumeQualificationResultsClusterResourceGroupName Property
This value is the name of the group that contains the resource.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string ClusterResourceGroupName { get; set; }
Public Property ClusterResourceGroupName As String
    Get
    Set
public:
property String^ ClusterResourceGroupName {
    String^ get ();
    void set (String^ value);
}
function get_ClusterResourceGroupName();
function set_ClusterResourceGroupName(value);

Property Value

Type: String
See Also

Reference

VolumeQualificationResults Class
DoubleTake.Virtualization.Contract Namespace


VolumeQualificationResults.CurrentOwnerNodeName Property

VolumeQualificationResultsCurrentOwnerNodeName Property
This value is the name of the resource's current owning node.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string CurrentOwnerNodeName { get; set; }
Public Property CurrentOwnerNodeName As String
    Get
    Set
public:
property String^ CurrentOwnerNodeName {
    String^ get ();
    void set (String^ value);
}
function get_CurrentOwnerNodeName();
function set_CurrentOwnerNodeName(value);

Property Value

Type: String
See Also

Reference

VolumeQualificationResults Class
DoubleTake.Virtualization.Contract Namespace


VolumeQualificationResults.DiskSize Property

VolumeQualificationResultsDiskSize Property
This value is the total size, in bytes, of the volume.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public long DiskSize { get; set; }
Public Property DiskSize As Long
    Get
    Set
public:
property long long DiskSize {
    long long get ();
    void set (long long value);
}
function get_DiskSize();
function set_DiskSize(value);

Property Value

Type: Int64
See Also

Reference

VolumeQualificationResults Class
DoubleTake.Virtualization.Contract Namespace


VolumeQualificationResults.DriveLetter Property

VolumeQualificationResultsDriveLetter Property
This value is the drive letter of the volume.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string DriveLetter { get; set; }
Public Property DriveLetter As String
    Get
    Set
public:
property String^ DriveLetter {
    String^ get ();
    void set (String^ value);
}
function get_DriveLetter();
function set_DriveLetter(value);

Property Value

Type: String
See Also

Reference

VolumeQualificationResults Class
DoubleTake.Virtualization.Contract Namespace


VolumeQualificationResults.ExtensionData Property

VolumeQualificationResultsExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

VolumeQualificationResults Class
DoubleTake.Virtualization.Contract Namespace


VolumeQualificationResults.FreeSpace Property

VolumeQualificationResultsFreeSpace Property
This value is the available free space, in bytes, on the volume.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public long FreeSpace { get; set; }
Public Property FreeSpace As Long
    Get
    Set
public:
property long long FreeSpace {
    long long get ();
    void set (long long value);
}
function get_FreeSpace();
function set_FreeSpace(value);

Property Value

Type: Int64
See Also

Reference

VolumeQualificationResults Class
DoubleTake.Virtualization.Contract Namespace


VolumeQualificationResults.IsSystemVolume Property

VolumeQualificationResultsIsSystemVolume Property
This value is true if the volume is the system volume; otherwise, it is false.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsSystemVolume { get; set; }
Public Property IsSystemVolume As Boolean
    Get
    Set
public:
property bool IsSystemVolume {
    bool get ();
    void set (bool value);
}
function get_IsSystemVolume();
function set_IsSystemVolume(value);

Property Value

Type: Boolean
See Also

Reference

VolumeQualificationResults Class
DoubleTake.Virtualization.Contract Namespace


VolumeQualificationResults.IsVolumeCSV Property

VolumeQualificationResultsIsVolumeCSV Property
This value is true if the volume is a cluster shared volume; otherwise, it is false.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsVolumeCSV { get; set; }
Public Property IsVolumeCSV As Boolean
    Get
    Set
public:
property bool IsVolumeCSV {
    bool get ();
    void set (bool value);
}
function get_IsVolumeCSV();
function set_IsVolumeCSV(value);

Property Value

Type: Boolean
See Also

Reference

VolumeQualificationResults Class
DoubleTake.Virtualization.Contract Namespace


VolumeQualificationResults.MaxFileSize Property

VolumeQualificationResultsMaxFileSize Property
This value is the maximum file size, in mebabytes, of the virtual hard disk file.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public long MaxFileSize { get; set; }
Public Property MaxFileSize As Long
    Get
    Set
public:
property long long MaxFileSize {
    long long get ();
    void set (long long value);
}
function get_MaxFileSize();
function set_MaxFileSize(value);

Property Value

Type: Int64
See Also

Reference

VolumeQualificationResults Class
DoubleTake.Virtualization.Contract Namespace


VolumeQualificationResults.ProvisionedSpace Property

VolumeQualificationResultsProvisionedSpace Property
This value is the amount of provisioned space, in bytes, on the volume.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public long ProvisionedSpace { get; set; }
Public Property ProvisionedSpace As Long
    Get
    Set
public:
property long long ProvisionedSpace {
    long long get ();
    void set (long long value);
}
function get_ProvisionedSpace();
function set_ProvisionedSpace(value);

Property Value

Type: Int64
See Also

Reference

VolumeQualificationResults Class
DoubleTake.Virtualization.Contract Namespace


VolumeQualificationResults.Url Property

VolumeQualificationResultsUrl Property
This value is the URL of an ESX datastore.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Url { get; set; }
Public Property Url As String
    Get
    Set
public:
property String^ Url {
    String^ get ();
    void set (String^ value);
}
function get_Url();
function set_Url(value);

Property Value

Type: String
See Also

Reference

VolumeQualificationResults Class
DoubleTake.Virtualization.Contract Namespace


WindowsBootProcessingOptions Class

WindowsBootProcessingOptions Class
Contains the information, not available from the source, to perform boot processing
Inheritance Hierarchy
SystemObject
DoubleTake.Virtualization.ContractWindowsBootProcessingOptions

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class WindowsBootProcessingOptions : IExtensibleDataObject
Public Class WindowsBootProcessingOptions
    Implements IExtensibleDataObject
public ref class WindowsBootProcessingOptions : IExtensibleDataObject
DoubleTake.Virtualization.Contract.WindowsBootProcessingOptions = function();

Type.createClass(
    'DoubleTake.Virtualization.Contract.WindowsBootProcessingOptions',
    null,
    IExtensibleDataObject);

The WindowsBootProcessingOptions type exposes the following members.

Constructors
 | Name | Description
Public method | WindowsBootProcessingOptions | Initializes a new instance of the WindowsBootProcessingOptions class
Top
Properties
 | Name | Description
Public property | BootProcessingType | Gets or sets the type of the boot processing.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | HardLinkMappingFile | Gets or sets the hard link mapping file.
Public property | IsWanFailover | Gets or sets a value indicating whether this instance is wan failover.
Public property | ReplicaNetworkInterfaceInfo | Gets or sets the replica network interface info. This is the information as we want it to be on the replica.
Public property | RunOnceAtReplicaStartup | Gets or sets the run once at replica startup entry.
Public property | RunOnceScriptPath | Gets or sets the path where the Run.
Public property | SystemVolumeName | Gets or sets the drive letter which represents the system volume.
Public property | VolumeInformation | Gets or sets the volume information.
Top
See Also

Reference

DoubleTake.Virtualization.Contract Namespace


WindowsBootProcessingOptions Constructor

WindowsBootProcessingOptions Constructor
Initializes a new instance of the WindowsBootProcessingOptions class

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public WindowsBootProcessingOptions()
Public Sub New
public:
WindowsBootProcessingOptions()
DoubleTake.Virtualization.Contract.WindowsBootProcessingOptions = function();
See Also

Reference

WindowsBootProcessingOptions Class
DoubleTake.Virtualization.Contract Namespace


WindowsBootProcessingOptions Properties

WindowsBootProcessingOptions Properties

The WindowsBootProcessingOptions type exposes the following members.

Properties
 | Name | Description
Public property | BootProcessingType | Gets or sets the type of the boot processing.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | HardLinkMappingFile | Gets or sets the hard link mapping file.
Public property | IsWanFailover | Gets or sets a value indicating whether this instance is wan failover.
Public property | ReplicaNetworkInterfaceInfo | Gets or sets the replica network interface info. This is the information as we want it to be on the replica.
Public property | RunOnceAtReplicaStartup | Gets or sets the run once at replica startup entry.
Public property | RunOnceScriptPath | Gets or sets the path where the Run.
Public property | SystemVolumeName | Gets or sets the drive letter which represents the system volume.
Public property | VolumeInformation | Gets or sets the volume information.
Top
See Also

Reference

WindowsBootProcessingOptions Class
DoubleTake.Virtualization.Contract Namespace


WindowsBootProcessingOptions.BootProcessingType Property

WindowsBootProcessingOptionsBootProcessingType Property
Gets or sets the type of the boot processing.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string BootProcessingType { get; set; }
Public Property BootProcessingType As String
    Get
    Set
public:
property String^ BootProcessingType {
    String^ get ();
    void set (String^ value);
}
function get_BootProcessingType();
function set_BootProcessingType(value);

Property Value

Type: String
The type of the boot processing.
See Also

Reference

WindowsBootProcessingOptions Class
DoubleTake.Virtualization.Contract Namespace


WindowsBootProcessingOptions.ExtensionData Property

WindowsBootProcessingOptionsExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

WindowsBootProcessingOptions Class
DoubleTake.Virtualization.Contract Namespace


WindowsBootProcessingOptions.HardLinkMappingFile Property

WindowsBootProcessingOptionsHardLinkMappingFile Property
Gets or sets the hard link mapping file.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string HardLinkMappingFile { get; set; }
Public Property HardLinkMappingFile As String
    Get
    Set
public:
property String^ HardLinkMappingFile {
    String^ get ();
    void set (String^ value);
}
function get_HardLinkMappingFile();
function set_HardLinkMappingFile(value);

Property Value

Type: String
The hard link mapping file.
See Also

Reference

WindowsBootProcessingOptions Class
DoubleTake.Virtualization.Contract Namespace


WindowsBootProcessingOptions.IsWanFailover Property

WindowsBootProcessingOptionsIsWanFailover Property
Gets or sets a value indicating whether this instance is wan failover.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsWanFailover { get; set; }
Public Property IsWanFailover As Boolean
    Get
    Set
public:
property bool IsWanFailover {
    bool get ();
    void set (bool value);
}
function get_IsWanFailover();
function set_IsWanFailover(value);

Property Value

Type: Boolean
true if this instance is wan failover; otherwise, false.
See Also

Reference

WindowsBootProcessingOptions Class
DoubleTake.Virtualization.Contract Namespace


WindowsBootProcessingOptions.ReplicaNetworkInterfaceInfo Property

WindowsBootProcessingOptionsReplicaNetworkInterfaceInfo Property
Gets or sets the replica network interface info. This is the information as we want it to be on the replica.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VirtualNetworkInterfaceInfo[] ReplicaNetworkInterfaceInfo { get; set; }
Public Property ReplicaNetworkInterfaceInfo As VirtualNetworkInterfaceInfo()
    Get
    Set
public:
property array<VirtualNetworkInterfaceInfo^>^ ReplicaNetworkInterfaceInfo {
    array<VirtualNetworkInterfaceInfo^>^ get ();
    void set (array<VirtualNetworkInterfaceInfo^>^ value);
}
function get_ReplicaNetworkInterfaceInfo();
function set_ReplicaNetworkInterfaceInfo(value);

Property Value

Type: VirtualNetworkInterfaceInfo
The network interface info.
See Also

Reference

WindowsBootProcessingOptions Class
DoubleTake.Virtualization.Contract Namespace


WindowsBootProcessingOptions.RunOnceAtReplicaStartup Property

WindowsBootProcessingOptionsRunOnceAtReplicaStartup Property
Gets or sets the run once at replica startup entry.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string RunOnceAtReplicaStartup { get; set; }
Public Property RunOnceAtReplicaStartup As String
    Get
    Set
public:
property String^ RunOnceAtReplicaStartup {
    String^ get ();
    void set (String^ value);
}
function get_RunOnceAtReplicaStartup();
function set_RunOnceAtReplicaStartup(value);

Property Value

Type: String
The run once at replica startup.
See Also

Reference

WindowsBootProcessingOptions Class
DoubleTake.Virtualization.Contract Namespace


WindowsBootProcessingOptions.RunOnceScriptPath Property

WindowsBootProcessingOptionsRunOnceScriptPath Property
Gets or sets the path where the Run.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string RunOnceScriptPath { get; set; }
Public Property RunOnceScriptPath As String
    Get
    Set
public:
property String^ RunOnceScriptPath {
    String^ get ();
    void set (String^ value);
}
function get_RunOnceScriptPath();
function set_RunOnceScriptPath(value);

Property Value

Type: String
The script path.
See Also

Reference

WindowsBootProcessingOptions Class
DoubleTake.Virtualization.Contract Namespace


WindowsBootProcessingOptions.SystemVolumeName Property

WindowsBootProcessingOptionsSystemVolumeName Property
Gets or sets the drive letter which represents the system volume.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string SystemVolumeName { get; set; }
Public Property SystemVolumeName As String
    Get
    Set
public:
property String^ SystemVolumeName {
    String^ get ();
    void set (String^ value);
}
function get_SystemVolumeName();
function set_SystemVolumeName(value);

Property Value

Type: String
The name of the system volume.
See Also

Reference

WindowsBootProcessingOptions Class
DoubleTake.Virtualization.Contract Namespace


WindowsBootProcessingOptions.VolumeInformation Property

WindowsBootProcessingOptionsVolumeInformation Property
Gets or sets the volume information.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public BootProcessingVolumeInfo[] VolumeInformation { get; set; }
Public Property VolumeInformation As BootProcessingVolumeInfo()
    Get
    Set
public:
property array<BootProcessingVolumeInfo^>^ VolumeInformation {
    array<BootProcessingVolumeInfo^>^ get ();
    void set (array<BootProcessingVolumeInfo^>^ value);
}
function get_VolumeInformation();
function set_VolumeInformation(value);

Property Value

Type: BootProcessingVolumeInfo
The volume information.
See Also

Reference

WindowsBootProcessingOptions Class
DoubleTake.Virtualization.Contract Namespace


DoubleTake.Virtualization.Contract.DTAV Namespace

DoubleTake.Virtualization.Contract.DTAV Namespace
Classes
 | Class | Description
Public class | DtavVmdkInfo |
Public class | DtavVmQualificationResults |
Public class | VmdkDatastoreMapping |


DtavVmdkInfo Class

DtavVmdkInfo Class
Inheritance Hierarchy
SystemObject
DoubleTake.Virtualization.Contract.DTAVDtavVmdkInfo

Namespace: DoubleTake.Virtualization.Contract.DTAV
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class DtavVmdkInfo : IExtensibleDataObject
Public Class DtavVmdkInfo
    Implements IExtensibleDataObject
public ref class DtavVmdkInfo : IExtensibleDataObject
DoubleTake.Virtualization.Contract.DTAV.DtavVmdkInfo = function();

Type.createClass(
    'DoubleTake.Virtualization.Contract.DTAV.DtavVmdkInfo',
    null,
    IExtensibleDataObject);

The DtavVmdkInfo type exposes the following members.

Constructors
 | Name | Description
Public method | DtavVmdkInfo | Initializes a new instance of the DtavVmdkInfo class
Top
Properties
 | Name | Description
Public property | DiskFormat |
Public property | DiskSize |
Public property | ExtensionData |
Public property | Path |
Public property | Uuid |
Top
See Also

Reference

DoubleTake.Virtualization.Contract.DTAV Namespace


DtavVmdkInfo Constructor

DtavVmdkInfo Constructor
Initializes a new instance of the DtavVmdkInfo class

Namespace: DoubleTake.Virtualization.Contract.DTAV
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public DtavVmdkInfo()
Public Sub New
public:
DtavVmdkInfo()
DoubleTake.Virtualization.Contract.DTAV.DtavVmdkInfo = function();
See Also

Reference

DtavVmdkInfo Class
DoubleTake.Virtualization.Contract.DTAV Namespace


DtavVmdkInfo Properties

DtavVmdkInfo Properties

The DtavVmdkInfo type exposes the following members.

Properties
 | Name | Description
Public property | DiskFormat |
Public property | DiskSize |
Public property | ExtensionData |
Public property | Path |
Public property | Uuid |
Top
See Also

Reference

DtavVmdkInfo Class
DoubleTake.Virtualization.Contract.DTAV Namespace


DtavVmdkInfo.DiskFormat Property

DtavVmdkInfoDiskFormat Property

Namespace: DoubleTake.Virtualization.Contract.DTAV
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string DiskFormat { get; set; }
Public Property DiskFormat As String
    Get
    Set
public:
property String^ DiskFormat {
    String^ get ();
    void set (String^ value);
}
function get_DiskFormat();
function set_DiskFormat(value);

Property Value

Type: String
See Also

Reference

DtavVmdkInfo Class
DoubleTake.Virtualization.Contract.DTAV Namespace


DtavVmdkInfo.DiskSize Property

DtavVmdkInfoDiskSize Property

Namespace: DoubleTake.Virtualization.Contract.DTAV
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public long DiskSize { get; set; }
Public Property DiskSize As Long
    Get
    Set
public:
property long long DiskSize {
    long long get ();
    void set (long long value);
}
function get_DiskSize();
function set_DiskSize(value);

Property Value

Type: Int64
See Also

Reference

DtavVmdkInfo Class
DoubleTake.Virtualization.Contract.DTAV Namespace


DtavVmdkInfo.ExtensionData Property

DtavVmdkInfoExtensionData Property

Namespace: DoubleTake.Virtualization.Contract.DTAV
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

DtavVmdkInfo Class
DoubleTake.Virtualization.Contract.DTAV Namespace


DtavVmdkInfo.Path Property

DtavVmdkInfoPath Property

Namespace: DoubleTake.Virtualization.Contract.DTAV
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Path { get; set; }
Public Property Path As String
    Get
    Set
public:
property String^ Path {
    String^ get ();
    void set (String^ value);
}
function get_Path();
function set_Path(value);

Property Value

Type: String
See Also

Reference

DtavVmdkInfo Class
DoubleTake.Virtualization.Contract.DTAV Namespace


DtavVmdkInfo.Uuid Property

DtavVmdkInfoUuid Property

Namespace: DoubleTake.Virtualization.Contract.DTAV
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Uuid { get; set; }
Public Property Uuid As String
    Get
    Set
public:
property String^ Uuid {
    String^ get ();
    void set (String^ value);
}
function get_Uuid();
function set_Uuid(value);

Property Value

Type: String
See Also

Reference

DtavVmdkInfo Class
DoubleTake.Virtualization.Contract.DTAV Namespace


DtavVmQualificationResults Class

DtavVmQualificationResults Class
Inheritance Hierarchy
SystemObject
DoubleTake.Virtualization.Contract.DTAVDtavVmQualificationResults

Namespace: DoubleTake.Virtualization.Contract.DTAV
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class DtavVmQualificationResults : IExtensibleDataObject
Public Class DtavVmQualificationResults
    Implements IExtensibleDataObject
public ref class DtavVmQualificationResults : IExtensibleDataObject
DoubleTake.Virtualization.Contract.DTAV.DtavVmQualificationResults = function();

Type.createClass(
    'DoubleTake.Virtualization.Contract.DTAV.DtavVmQualificationResults',
    null,
    IExtensibleDataObject);

The DtavVmQualificationResults type exposes the following members.

Constructors
 | Name | Description
Public method | DtavVmQualificationResults | Initializes a new instance of the DtavVmQualificationResults class
Top
Properties
 | Name | Description
Public property | DiskFormat | Gets or sets disk format for virtual machne disks
Public property | DisplayName | Gets or sets a value of virtual machine display name
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Id | Gets or sets a value of virtual machine Guid
Public property | IsWANFailoverEnabled |
Public property | SourceDatastore | Gets or sets source datastore
Public property | SourceRA | Gets or sets source replication appliance
Public property | SourceVmHostId |
Public property | TargetDatastore | Gets or sets target datastore
Public property | TargetHost | Gets or sets a value of target virtual machine host
Public property | TargetHostId |
Public property | TargetPath | Gets or sets a value of target virtual machine location
Public property | TargetRA | Gets or sets target replication appliance
Public property | TargetVmDisplayName | Gets or sets a value of target virtual machine display name
Public property | VmdkDatastoreMappings |
Top
See Also

Reference

DoubleTake.Virtualization.Contract.DTAV Namespace


DtavVmQualificationResults Constructor

DtavVmQualificationResults Constructor
Initializes a new instance of the DtavVmQualificationResults class

Namespace: DoubleTake.Virtualization.Contract.DTAV
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public DtavVmQualificationResults()
Public Sub New
public:
DtavVmQualificationResults()
DoubleTake.Virtualization.Contract.DTAV.DtavVmQualificationResults = function();
See Also

Reference

DtavVmQualificationResults Class
DoubleTake.Virtualization.Contract.DTAV Namespace


DtavVmQualificationResults Properties

DtavVmQualificationResults Properties

The DtavVmQualificationResults type exposes the following members.

Properties
 | Name | Description
Public property | DiskFormat | Gets or sets disk format for virtual machne disks
Public property | DisplayName | Gets or sets a value of virtual machine display name
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Id | Gets or sets a value of virtual machine Guid
Public property | IsWANFailoverEnabled |
Public property | SourceDatastore | Gets or sets source datastore
Public property | SourceRA | Gets or sets source replication appliance
Public property | SourceVmHostId |
Public property | TargetDatastore | Gets or sets target datastore
Public property | TargetHost | Gets or sets a value of target virtual machine host
Public property | TargetHostId |
Public property | TargetPath | Gets or sets a value of target virtual machine location
Public property | TargetRA | Gets or sets target replication appliance
Public property | TargetVmDisplayName | Gets or sets a value of target virtual machine display name
Public property | VmdkDatastoreMappings |
Top
See Also

Reference

DtavVmQualificationResults Class
DoubleTake.Virtualization.Contract.DTAV Namespace


DtavVmQualificationResults.DiskFormat Property

DtavVmQualificationResultsDiskFormat Property
Gets or sets disk format for virtual machne disks

Namespace: DoubleTake.Virtualization.Contract.DTAV
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string DiskFormat { get; set; }
Public Property DiskFormat As String
    Get
    Set
public:
property String^ DiskFormat {
    String^ get ();
    void set (String^ value);
}
function get_DiskFormat();
function set_DiskFormat(value);

Property Value

Type: String
See Also

Reference

DtavVmQualificationResults Class
DoubleTake.Virtualization.Contract.DTAV Namespace


DtavVmQualificationResults.DisplayName Property

DtavVmQualificationResultsDisplayName Property
Gets or sets a value of virtual machine display name

Namespace: DoubleTake.Virtualization.Contract.DTAV
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string DisplayName { get; set; }
Public Property DisplayName As String
    Get
    Set
public:
property String^ DisplayName {
    String^ get ();
    void set (String^ value);
}
function get_DisplayName();
function set_DisplayName(value);

Property Value

Type: String
See Also

Reference

DtavVmQualificationResults Class
DoubleTake.Virtualization.Contract.DTAV Namespace


DtavVmQualificationResults.ExtensionData Property

DtavVmQualificationResultsExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Virtualization.Contract.DTAV
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

DtavVmQualificationResults Class
DoubleTake.Virtualization.Contract.DTAV Namespace


DtavVmQualificationResults.Id Property

DtavVmQualificationResultsId Property
Gets or sets a value of virtual machine Guid

Namespace: DoubleTake.Virtualization.Contract.DTAV
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Guid Id { get; set; }
Public Property Id As Guid
    Get
    Set
public:
property Guid Id {
    Guid get ();
    void set (Guid value);
}
function get_Id();
function set_Id(value);

Property Value

Type: Guid
See Also

Reference

DtavVmQualificationResults Class
DoubleTake.Virtualization.Contract.DTAV Namespace


DtavVmQualificationResults.IsWANFailoverEnabled Property

DtavVmQualificationResultsIsWANFailoverEnabled Property

Namespace: DoubleTake.Virtualization.Contract.DTAV
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsWANFailoverEnabled { get; set; }
Public Property IsWANFailoverEnabled As Boolean
    Get
    Set
public:
property bool IsWANFailoverEnabled {
    bool get ();
    void set (bool value);
}
function get_IsWANFailoverEnabled();
function set_IsWANFailoverEnabled(value);

Property Value

Type: Boolean
See Also

Reference

DtavVmQualificationResults Class
DoubleTake.Virtualization.Contract.DTAV Namespace


DtavVmQualificationResults.SourceDatastore Property

DtavVmQualificationResultsSourceDatastore Property
Gets or sets source datastore

Namespace: DoubleTake.Virtualization.Contract.DTAV
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VolumeQualificationResults SourceDatastore { get; set; }
Public Property SourceDatastore As VolumeQualificationResults
    Get
    Set
public:
property VolumeQualificationResults^ SourceDatastore {
    VolumeQualificationResults^ get ();
    void set (VolumeQualificationResults^ value);
}
function get_SourceDatastore();
function set_SourceDatastore(value);

Property Value

Type: VolumeQualificationResults
See Also

Reference

DtavVmQualificationResults Class
DoubleTake.Virtualization.Contract.DTAV Namespace


DtavVmQualificationResults.SourceRA Property

DtavVmQualificationResultsSourceRA Property
Gets or sets source replication appliance

Namespace: DoubleTake.Virtualization.Contract.DTAV
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string SourceRA { get; set; }
Public Property SourceRA As String
    Get
    Set
public:
property String^ SourceRA {
    String^ get ();
    void set (String^ value);
}
function get_SourceRA();
function set_SourceRA(value);

Property Value

Type: String
See Also

Reference

DtavVmQualificationResults Class
DoubleTake.Virtualization.Contract.DTAV Namespace


DtavVmQualificationResults.SourceVmHostId Property

DtavVmQualificationResultsSourceVmHostId Property

Namespace: DoubleTake.Virtualization.Contract.DTAV
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string SourceVmHostId { get; set; }
Public Property SourceVmHostId As String
    Get
    Set
public:
property String^ SourceVmHostId {
    String^ get ();
    void set (String^ value);
}
function get_SourceVmHostId();
function set_SourceVmHostId(value);

Property Value

Type: String
See Also

Reference

DtavVmQualificationResults Class
DoubleTake.Virtualization.Contract.DTAV Namespace


DtavVmQualificationResults.TargetDatastore Property

DtavVmQualificationResultsTargetDatastore Property
Gets or sets target datastore

Namespace: DoubleTake.Virtualization.Contract.DTAV
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VolumeQualificationResults TargetDatastore { get; set; }
Public Property TargetDatastore As VolumeQualificationResults
    Get
    Set
public:
property VolumeQualificationResults^ TargetDatastore {
    VolumeQualificationResults^ get ();
    void set (VolumeQualificationResults^ value);
}
function get_TargetDatastore();
function set_TargetDatastore(value);

Property Value

Type: VolumeQualificationResults
See Also

Reference

DtavVmQualificationResults Class
DoubleTake.Virtualization.Contract.DTAV Namespace


DtavVmQualificationResults.TargetHost Property

DtavVmQualificationResultsTargetHost Property
Gets or sets a value of target virtual machine host

Namespace: DoubleTake.Virtualization.Contract.DTAV
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string TargetHost { get; set; }
Public Property TargetHost As String
    Get
    Set
public:
property String^ TargetHost {
    String^ get ();
    void set (String^ value);
}
function get_TargetHost();
function set_TargetHost(value);

Property Value

Type: String
See Also

Reference

DtavVmQualificationResults Class
DoubleTake.Virtualization.Contract.DTAV Namespace


DtavVmQualificationResults.TargetHostId Property

DtavVmQualificationResultsTargetHostId Property

Namespace: DoubleTake.Virtualization.Contract.DTAV
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string TargetHostId { get; set; }
Public Property TargetHostId As String
    Get
    Set
public:
property String^ TargetHostId {
    String^ get ();
    void set (String^ value);
}
function get_TargetHostId();
function set_TargetHostId(value);

Property Value

Type: String
See Also

Reference

DtavVmQualificationResults Class
DoubleTake.Virtualization.Contract.DTAV Namespace


DtavVmQualificationResults.TargetPath Property

DtavVmQualificationResultsTargetPath Property
Gets or sets a value of target virtual machine location

Namespace: DoubleTake.Virtualization.Contract.DTAV
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string TargetPath { get; set; }
Public Property TargetPath As String
    Get
    Set
public:
property String^ TargetPath {
    String^ get ();
    void set (String^ value);
}
function get_TargetPath();
function set_TargetPath(value);

Property Value

Type: String
See Also

Reference

DtavVmQualificationResults Class
DoubleTake.Virtualization.Contract.DTAV Namespace


DtavVmQualificationResults.TargetRA Property

DtavVmQualificationResultsTargetRA Property
Gets or sets target replication appliance

Namespace: DoubleTake.Virtualization.Contract.DTAV
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string TargetRA { get; set; }
Public Property TargetRA As String
    Get
    Set
public:
property String^ TargetRA {
    String^ get ();
    void set (String^ value);
}
function get_TargetRA();
function set_TargetRA(value);

Property Value

Type: String
See Also

Reference

DtavVmQualificationResults Class
DoubleTake.Virtualization.Contract.DTAV Namespace


DtavVmQualificationResults.TargetVmDisplayName Property

DtavVmQualificationResultsTargetVmDisplayName Property
Gets or sets a value of target virtual machine display name

Namespace: DoubleTake.Virtualization.Contract.DTAV
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string TargetVmDisplayName { get; set; }
Public Property TargetVmDisplayName As String
    Get
    Set
public:
property String^ TargetVmDisplayName {
    String^ get ();
    void set (String^ value);
}
function get_TargetVmDisplayName();
function set_TargetVmDisplayName(value);

Property Value

Type: String
See Also

Reference

DtavVmQualificationResults Class
DoubleTake.Virtualization.Contract.DTAV Namespace


DtavVmQualificationResults.VmdkDatastoreMappings Property

DtavVmQualificationResultsVmdkDatastoreMappings Property

Namespace: DoubleTake.Virtualization.Contract.DTAV
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VmdkDatastoreMapping[] VmdkDatastoreMappings { get; set; }
Public Property VmdkDatastoreMappings As VmdkDatastoreMapping()
    Get
    Set
public:
property array<VmdkDatastoreMapping^>^ VmdkDatastoreMappings {
    array<VmdkDatastoreMapping^>^ get ();
    void set (array<VmdkDatastoreMapping^>^ value);
}
function get_VmdkDatastoreMappings();
function set_VmdkDatastoreMappings(value);

Property Value

Type: VmdkDatastoreMapping
See Also

Reference

DtavVmQualificationResults Class
DoubleTake.Virtualization.Contract.DTAV Namespace


VmdkDatastoreMapping Class

VmdkDatastoreMapping Class
Inheritance Hierarchy
SystemObject
DoubleTake.Virtualization.Contract.DTAVVmdkDatastoreMapping

Namespace: DoubleTake.Virtualization.Contract.DTAV
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class VmdkDatastoreMapping : IExtensibleDataObject
Public Class VmdkDatastoreMapping
    Implements IExtensibleDataObject
public ref class VmdkDatastoreMapping : IExtensibleDataObject
DoubleTake.Virtualization.Contract.DTAV.VmdkDatastoreMapping = function();

Type.createClass(
    'DoubleTake.Virtualization.Contract.DTAV.VmdkDatastoreMapping',
    null,
    IExtensibleDataObject);

The VmdkDatastoreMapping type exposes the following members.

Constructors
 | Name | Description
Public method | VmdkDatastoreMapping | Initializes a new instance of the VmdkDatastoreMapping class
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | PrestagedVmdkInfo |
Public property | SourceVmdkInfo |
Public property | TargetDatastoreName |
Public property | TargetDatastoreUrl |
Top
See Also

Reference

DoubleTake.Virtualization.Contract.DTAV Namespace


VmdkDatastoreMapping Constructor

VmdkDatastoreMapping Constructor
Initializes a new instance of the VmdkDatastoreMapping class

Namespace: DoubleTake.Virtualization.Contract.DTAV
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VmdkDatastoreMapping()
Public Sub New
public:
VmdkDatastoreMapping()
DoubleTake.Virtualization.Contract.DTAV.VmdkDatastoreMapping = function();
See Also

Reference

VmdkDatastoreMapping Class
DoubleTake.Virtualization.Contract.DTAV Namespace


VmdkDatastoreMapping Properties

VmdkDatastoreMapping Properties

The VmdkDatastoreMapping type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | PrestagedVmdkInfo |
Public property | SourceVmdkInfo |
Public property | TargetDatastoreName |
Public property | TargetDatastoreUrl |
Top
See Also

Reference

VmdkDatastoreMapping Class
DoubleTake.Virtualization.Contract.DTAV Namespace


VmdkDatastoreMapping.ExtensionData Property

VmdkDatastoreMappingExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Virtualization.Contract.DTAV
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

VmdkDatastoreMapping Class
DoubleTake.Virtualization.Contract.DTAV Namespace


VmdkDatastoreMapping.PrestagedVmdkInfo Property

VmdkDatastoreMappingPrestagedVmdkInfo Property

Namespace: DoubleTake.Virtualization.Contract.DTAV
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public DtavVmdkInfo PrestagedVmdkInfo { get; set; }
Public Property PrestagedVmdkInfo As DtavVmdkInfo
    Get
    Set
public:
property DtavVmdkInfo^ PrestagedVmdkInfo {
    DtavVmdkInfo^ get ();
    void set (DtavVmdkInfo^ value);
}
function get_PrestagedVmdkInfo();
function set_PrestagedVmdkInfo(value);

Property Value

Type: DtavVmdkInfo
See Also

Reference

VmdkDatastoreMapping Class
DoubleTake.Virtualization.Contract.DTAV Namespace


VmdkDatastoreMapping.SourceVmdkInfo Property

VmdkDatastoreMappingSourceVmdkInfo Property

Namespace: DoubleTake.Virtualization.Contract.DTAV
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public DtavVmdkInfo SourceVmdkInfo { get; set; }
Public Property SourceVmdkInfo As DtavVmdkInfo
    Get
    Set
public:
property DtavVmdkInfo^ SourceVmdkInfo {
    DtavVmdkInfo^ get ();
    void set (DtavVmdkInfo^ value);
}
function get_SourceVmdkInfo();
function set_SourceVmdkInfo(value);

Property Value

Type: DtavVmdkInfo
See Also

Reference

VmdkDatastoreMapping Class
DoubleTake.Virtualization.Contract.DTAV Namespace


VmdkDatastoreMapping.TargetDatastoreName Property

VmdkDatastoreMappingTargetDatastoreName Property

Namespace: DoubleTake.Virtualization.Contract.DTAV
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string TargetDatastoreName { get; set; }
Public Property TargetDatastoreName As String
    Get
    Set
public:
property String^ TargetDatastoreName {
    String^ get ();
    void set (String^ value);
}
function get_TargetDatastoreName();
function set_TargetDatastoreName(value);

Property Value

Type: String
See Also

Reference

VmdkDatastoreMapping Class
DoubleTake.Virtualization.Contract.DTAV Namespace


VmdkDatastoreMapping.TargetDatastoreUrl Property

VmdkDatastoreMappingTargetDatastoreUrl Property

Namespace: DoubleTake.Virtualization.Contract.DTAV
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string TargetDatastoreUrl { get; set; }
Public Property TargetDatastoreUrl As String
    Get
    Set
public:
property String^ TargetDatastoreUrl {
    String^ get ();
    void set (String^ value);
}
function get_TargetDatastoreUrl();
function set_TargetDatastoreUrl(value);

Property Value

Type: String
See Also

Reference

VmdkDatastoreMapping Class
DoubleTake.Virtualization.Contract.DTAV Namespace


DoubleTake.Virtualization.Contract.DTHV Namespace

DoubleTake.Virtualization.Contract.DTHV Namespace
Classes
 | Class | Description
Public class | VHDMapping | Represents source and target VHD mappings
Public class | VLanMapping | Maps source server VLans to target server VLans.
Public class | VMSystemState | Represents virtual machine system state


VHDMapping Class

VHDMapping Class
Represents source and target VHD mappings
Inheritance Hierarchy
SystemObject
DoubleTake.Virtualization.Contract.DTHVVHDMapping

Namespace: DoubleTake.Virtualization.Contract.DTHV
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class VHDMapping : IExtensibleDataObject
Public Class VHDMapping
    Implements IExtensibleDataObject
public ref class VHDMapping : IExtensibleDataObject
DoubleTake.Virtualization.Contract.DTHV.VHDMapping = function();

Type.createClass(
    'DoubleTake.Virtualization.Contract.DTHV.VHDMapping',
    null,
    IExtensibleDataObject);

The VHDMapping type exposes the following members.

Constructors
 | Name | Description
Public method | VHDMapping | Initializes a new instance of the VHDMapping class
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | SourceVHD | This value is the source .vhd file.
Public property | TargetVHD | This value is the target .vhd file.
Top
See Also

Reference

DoubleTake.Virtualization.Contract.DTHV Namespace


VHDMapping Constructor

VHDMapping Constructor
Initializes a new instance of the VHDMapping class

Namespace: DoubleTake.Virtualization.Contract.DTHV
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VHDMapping()
Public Sub New
public:
VHDMapping()
DoubleTake.Virtualization.Contract.DTHV.VHDMapping = function();
See Also

Reference

VHDMapping Class
DoubleTake.Virtualization.Contract.DTHV Namespace


VHDMapping Properties

VHDMapping Properties

The VHDMapping type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | SourceVHD | This value is the source .vhd file.
Public property | TargetVHD | This value is the target .vhd file.
Top
See Also

Reference

VHDMapping Class
DoubleTake.Virtualization.Contract.DTHV Namespace


VHDMapping.ExtensionData Property

VHDMappingExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Virtualization.Contract.DTHV
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

VHDMapping Class
DoubleTake.Virtualization.Contract.DTHV Namespace


VHDMapping.SourceVHD Property

VHDMappingSourceVHD Property
This value is the source .vhd file.

Namespace: DoubleTake.Virtualization.Contract.DTHV
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string SourceVHD { get; set; }
Public Property SourceVHD As String
    Get
    Set
public:
property String^ SourceVHD {
    String^ get ();
    void set (String^ value);
}
function get_SourceVHD();
function set_SourceVHD(value);

Property Value

Type: String
See Also

Reference

VHDMapping Class
DoubleTake.Virtualization.Contract.DTHV Namespace


VHDMapping.TargetVHD Property

VHDMappingTargetVHD Property
This value is the target .vhd file.

Namespace: DoubleTake.Virtualization.Contract.DTHV
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string TargetVHD { get; set; }
Public Property TargetVHD As String
    Get
    Set
public:
property String^ TargetVHD {
    String^ get ();
    void set (String^ value);
}
function get_TargetVHD();
function set_TargetVHD(value);

Property Value

Type: String
See Also

Reference

VHDMapping Class
DoubleTake.Virtualization.Contract.DTHV Namespace


VLanMapping Class

VLanMapping Class
Maps source server VLans to target server VLans.
Inheritance Hierarchy
SystemObject
DoubleTake.Virtualization.Contract.DTHVVLanMapping

Namespace: DoubleTake.Virtualization.Contract.DTHV
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class VLanMapping : IExtensibleDataObject
Public Class VLanMapping
    Implements IExtensibleDataObject
public ref class VLanMapping : IExtensibleDataObject
DoubleTake.Virtualization.Contract.DTHV.VLanMapping = function();

Type.createClass(
    'DoubleTake.Virtualization.Contract.DTHV.VLanMapping',
    null,
    IExtensibleDataObject);

The VLanMapping type exposes the following members.

Constructors
 | Name | Description
Public method | VLanMapping | Initializes a new instance of the VLanMapping class
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | SourceSwitchPort | This value represents the source switch port.
Public property | TargetSwitchPort | This value represents the target switch port.
Top
See Also

Reference

DoubleTake.Virtualization.Contract.DTHV Namespace


VLanMapping Constructor

VLanMapping Constructor
Initializes a new instance of the VLanMapping class

Namespace: DoubleTake.Virtualization.Contract.DTHV
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VLanMapping()
Public Sub New
public:
VLanMapping()
DoubleTake.Virtualization.Contract.DTHV.VLanMapping = function();
See Also

Reference

VLanMapping Class
DoubleTake.Virtualization.Contract.DTHV Namespace


VLanMapping Properties

VLanMapping Properties

The VLanMapping type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | SourceSwitchPort | This value represents the source switch port.
Public property | TargetSwitchPort | This value represents the target switch port.
Top
See Also

Reference

VLanMapping Class
DoubleTake.Virtualization.Contract.DTHV Namespace


VLanMapping.ExtensionData Property

VLanMappingExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Virtualization.Contract.DTHV
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

VLanMapping Class
DoubleTake.Virtualization.Contract.DTHV Namespace


VLanMapping.SourceSwitchPort Property

VLanMappingSourceSwitchPort Property
This value represents the source switch port.

Namespace: DoubleTake.Virtualization.Contract.DTHV
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public SwitchPortInfo SourceSwitchPort { get; set; }
Public Property SourceSwitchPort As SwitchPortInfo
    Get
    Set
public:
property SwitchPortInfo^ SourceSwitchPort {
    SwitchPortInfo^ get ();
    void set (SwitchPortInfo^ value);
}
function get_SourceSwitchPort();
function set_SourceSwitchPort(value);

Property Value

Type: SwitchPortInfo
The source switch port.
See Also

Reference

VLanMapping Class
DoubleTake.Virtualization.Contract.DTHV Namespace


VLanMapping.TargetSwitchPort Property

VLanMappingTargetSwitchPort Property
This value represents the target switch port.

Namespace: DoubleTake.Virtualization.Contract.DTHV
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public SwitchPortInfo TargetSwitchPort { get; set; }
Public Property TargetSwitchPort As SwitchPortInfo
    Get
    Set
public:
property SwitchPortInfo^ TargetSwitchPort {
    SwitchPortInfo^ get ();
    void set (SwitchPortInfo^ value);
}
function get_TargetSwitchPort();
function set_TargetSwitchPort(value);

Property Value

Type: SwitchPortInfo
The target switch port.
See Also

Reference

VLanMapping Class
DoubleTake.Virtualization.Contract.DTHV Namespace


VMSystemState Class

VMSystemState Class
Represents virtual machine system state
Inheritance Hierarchy
SystemObject
DoubleTake.Virtualization.Contract.DTHVVMSystemState

Namespace: DoubleTake.Virtualization.Contract.DTHV
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class VMSystemState : IExtensibleDataObject
Public Class VMSystemState
    Implements IExtensibleDataObject
public ref class VMSystemState : IExtensibleDataObject
DoubleTake.Virtualization.Contract.DTHV.VMSystemState = function();

Type.createClass(
    'DoubleTake.Virtualization.Contract.DTHV.VMSystemState',
    null,
    IExtensibleDataObject);

The VMSystemState type exposes the following members.

Constructors
 | Name | Description
Public method | VMSystemState | Initializes a new instance of the VMSystemState class
Top
Properties
 | Name | Description
Public property | BootVolumeSignature | Gets or sets a value of virtual machine boot volume signature
Public property | Domain | Gets or sets a value of virtual machine Domain
Public property | DomainRole | Gets or sets a value of virtual machine DomainRole
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | NetworkInterfaces | Gets or sets a value of virtual machine network interfaces
Public property | SystemDirectory | Gets or sets a value of virtual machine system directory
Top
See Also

Reference

DoubleTake.Virtualization.Contract.DTHV Namespace


VMSystemState Constructor

VMSystemState Constructor
Initializes a new instance of the VMSystemState class

Namespace: DoubleTake.Virtualization.Contract.DTHV
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VMSystemState()
Public Sub New
public:
VMSystemState()
DoubleTake.Virtualization.Contract.DTHV.VMSystemState = function();
See Also

Reference

VMSystemState Class
DoubleTake.Virtualization.Contract.DTHV Namespace


VMSystemState Properties

VMSystemState Properties

The VMSystemState type exposes the following members.

Properties
 | Name | Description
Public property | BootVolumeSignature | Gets or sets a value of virtual machine boot volume signature
Public property | Domain | Gets or sets a value of virtual machine Domain
Public property | DomainRole | Gets or sets a value of virtual machine DomainRole
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | NetworkInterfaces | Gets or sets a value of virtual machine network interfaces
Public property | SystemDirectory | Gets or sets a value of virtual machine system directory
Top
See Also

Reference

VMSystemState Class
DoubleTake.Virtualization.Contract.DTHV Namespace


VMSystemState.BootVolumeSignature Property

VMSystemStateBootVolumeSignature Property
Gets or sets a value of virtual machine boot volume signature

Namespace: DoubleTake.Virtualization.Contract.DTHV
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public byte[] BootVolumeSignature { get; set; }
Public Property BootVolumeSignature As Byte()
    Get
    Set
public:
property array<unsigned char>^ BootVolumeSignature {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
function get_BootVolumeSignature();
function set_BootVolumeSignature(value);

Property Value

Type: Byte
See Also

Reference

VMSystemState Class
DoubleTake.Virtualization.Contract.DTHV Namespace


VMSystemState.Domain Property

VMSystemStateDomain Property
Gets or sets a value of virtual machine Domain

Namespace: DoubleTake.Virtualization.Contract.DTHV
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Domain { get; set; }
Public Property Domain As String
    Get
    Set
public:
property String^ Domain {
    String^ get ();
    void set (String^ value);
}
function get_Domain();
function set_Domain(value);

Property Value

Type: String
See Also

Reference

VMSystemState Class
DoubleTake.Virtualization.Contract.DTHV Namespace


VMSystemState.DomainRole Property

VMSystemStateDomainRole Property
Gets or sets a value of virtual machine DomainRole

Namespace: DoubleTake.Virtualization.Contract.DTHV
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int DomainRole { get; set; }
Public Property DomainRole As Integer
    Get
    Set
public:
property int DomainRole {
    int get ();
    void set (int value);
}
function get_DomainRole();
function set_DomainRole(value);

Property Value

Type: Int32
See Also

Reference

VMSystemState Class
DoubleTake.Virtualization.Contract.DTHV Namespace


VMSystemState.ExtensionData Property

VMSystemStateExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Virtualization.Contract.DTHV
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

VMSystemState Class
DoubleTake.Virtualization.Contract.DTHV Namespace


VMSystemState.NetworkInterfaces Property

VMSystemStateNetworkInterfaces Property
Gets or sets a value of virtual machine network interfaces

Namespace: DoubleTake.Virtualization.Contract.DTHV
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VirtualNetworkInterfaceInfo[] NetworkInterfaces { get; set; }
Public Property NetworkInterfaces As VirtualNetworkInterfaceInfo()
    Get
    Set
public:
property array<VirtualNetworkInterfaceInfo^>^ NetworkInterfaces {
    array<VirtualNetworkInterfaceInfo^>^ get ();
    void set (array<VirtualNetworkInterfaceInfo^>^ value);
}
function get_NetworkInterfaces();
function set_NetworkInterfaces(value);

Property Value

Type: VirtualNetworkInterfaceInfo
See Also

Reference

VMSystemState Class
DoubleTake.Virtualization.Contract.DTHV Namespace


VMSystemState.SystemDirectory Property

VMSystemStateSystemDirectory Property
Gets or sets a value of virtual machine system directory

Namespace: DoubleTake.Virtualization.Contract.DTHV
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string SystemDirectory { get; set; }
Public Property SystemDirectory As String
    Get
    Set
public:
property String^ SystemDirectory {
    String^ get ();
    void set (String^ value);
}
function get_SystemDirectory();
function set_SystemDirectory(value);

Property Value

Type: String
See Also

Reference

VMSystemState Class
DoubleTake.Virtualization.Contract.DTHV Namespace


DoubleTake.Virtualization.Contract.VcdVapp Namespace

DoubleTake.Virtualization.Contract.VcdVapp Namespace
Classes
 | Class | Description
Public class | PITSnapshotRecord |
Public class | VmdkInfo | New DTVI (Linux)


PITSnapshotRecord Class

PITSnapshotRecord Class
Inheritance Hierarchy
SystemObject
DoubleTake.Virtualization.Contract.VcdVappPITSnapshotRecord

Namespace: DoubleTake.Virtualization.Contract.VcdVapp
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class PITSnapshotRecord
Public Class PITSnapshotRecord
public ref class PITSnapshotRecord
DoubleTake.Virtualization.Contract.VcdVapp.PITSnapshotRecord = function();

Type.createClass(
    'DoubleTake.Virtualization.Contract.VcdVapp.PITSnapshotRecord');

The PITSnapshotRecord type exposes the following members.

Constructors
 | Name | Description
Public method | PITSnapshotRecord | Initializes a new instance of the PITSnapshotRecord class
Top
See Also

Reference

DoubleTake.Virtualization.Contract.VcdVapp Namespace


PITSnapshotRecord Constructor

PITSnapshotRecord Constructor
Initializes a new instance of the PITSnapshotRecord class

Namespace: DoubleTake.Virtualization.Contract.VcdVapp
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public PITSnapshotRecord()
Public Sub New
public:
PITSnapshotRecord()
DoubleTake.Virtualization.Contract.VcdVapp.PITSnapshotRecord = function();
See Also

Reference

PITSnapshotRecord Class
DoubleTake.Virtualization.Contract.VcdVapp Namespace


VmdkInfo Class

VmdkInfo Class
New DTVI (Linux)
Inheritance Hierarchy
SystemObject
DoubleTake.Virtualization.Contract.VcdVappVmdkInfo

Namespace: DoubleTake.Virtualization.Contract.VcdVapp
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class VmdkInfo : IExtensibleDataObject
Public Class VmdkInfo
    Implements IExtensibleDataObject
public ref class VmdkInfo : IExtensibleDataObject
DoubleTake.Virtualization.Contract.VcdVapp.VmdkInfo = function();

Type.createClass(
    'DoubleTake.Virtualization.Contract.VcdVapp.VmdkInfo',
    null,
    IExtensibleDataObject);

The VmdkInfo type exposes the following members.

Constructors
 | Name | Description
Public method | VmdkInfo | Initializes a new instance of the VmdkInfo class
Top
Properties
 | Name | Description
Public property | doDifferenceMirror |
Public property | ExtensionData |
Public property | sourceVmdkUuid |
Public property | sourceVmUuid |
Public property | targetChangeId |
Public property | targetDeviceKey |
Public property | targetDiskOffset |
Public property | targetVmdkPath |
Public property | targetVmdkUuid |
Public property | targetVmUuid |
Top
See Also

Reference

DoubleTake.Virtualization.Contract.VcdVapp Namespace


VmdkInfo Constructor

VmdkInfo Constructor
Initializes a new instance of the VmdkInfo class

Namespace: DoubleTake.Virtualization.Contract.VcdVapp
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VmdkInfo()
Public Sub New
public:
VmdkInfo()
DoubleTake.Virtualization.Contract.VcdVapp.VmdkInfo = function();
See Also

Reference

VmdkInfo Class
DoubleTake.Virtualization.Contract.VcdVapp Namespace


VmdkInfo Properties

VmdkInfo Properties

The VmdkInfo type exposes the following members.

Properties
 | Name | Description
Public property | doDifferenceMirror |
Public property | ExtensionData |
Public property | sourceVmdkUuid |
Public property | sourceVmUuid |
Public property | targetChangeId |
Public property | targetDeviceKey |
Public property | targetDiskOffset |
Public property | targetVmdkPath |
Public property | targetVmdkUuid |
Public property | targetVmUuid |
Top
See Also

Reference

VmdkInfo Class
DoubleTake.Virtualization.Contract.VcdVapp Namespace


VmdkInfo.doDifferenceMirror Property

VmdkInfodoDifferenceMirror Property

Namespace: DoubleTake.Virtualization.Contract.VcdVapp
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool doDifferenceMirror { get; set; }
Public Property doDifferenceMirror As Boolean
    Get
    Set
public:
property bool doDifferenceMirror {
    bool get ();
    void set (bool value);
}
function get_doDifferenceMirror();
function set_doDifferenceMirror(value);

Property Value

Type: Boolean
See Also

Reference

VmdkInfo Class
DoubleTake.Virtualization.Contract.VcdVapp Namespace


VmdkInfo.ExtensionData Property

VmdkInfoExtensionData Property

Namespace: DoubleTake.Virtualization.Contract.VcdVapp
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

VmdkInfo Class
DoubleTake.Virtualization.Contract.VcdVapp Namespace


VmdkInfo.sourceVmdkUuid Property

VmdkInfosourceVmdkUuid Property

Namespace: DoubleTake.Virtualization.Contract.VcdVapp
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string sourceVmdkUuid { get; set; }
Public Property sourceVmdkUuid As String
    Get
    Set
public:
property String^ sourceVmdkUuid {
    String^ get ();
    void set (String^ value);
}
function get_sourceVmdkUuid();
function set_sourceVmdkUuid(value);

Property Value

Type: String
See Also

Reference

VmdkInfo Class
DoubleTake.Virtualization.Contract.VcdVapp Namespace


VmdkInfo.sourceVmUuid Property

VmdkInfosourceVmUuid Property

Namespace: DoubleTake.Virtualization.Contract.VcdVapp
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string sourceVmUuid { get; set; }
Public Property sourceVmUuid As String
    Get
    Set
public:
property String^ sourceVmUuid {
    String^ get ();
    void set (String^ value);
}
function get_sourceVmUuid();
function set_sourceVmUuid(value);

Property Value

Type: String
See Also

Reference

VmdkInfo Class
DoubleTake.Virtualization.Contract.VcdVapp Namespace


VmdkInfo.targetChangeId Property

VmdkInfotargetChangeId Property

Namespace: DoubleTake.Virtualization.Contract.VcdVapp
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string targetChangeId { get; set; }
Public Property targetChangeId As String
    Get
    Set
public:
property String^ targetChangeId {
    String^ get ();
    void set (String^ value);
}
function get_targetChangeId();
function set_targetChangeId(value);

Property Value

Type: String
See Also

Reference

VmdkInfo Class
DoubleTake.Virtualization.Contract.VcdVapp Namespace


VmdkInfo.targetDeviceKey Property

VmdkInfotargetDeviceKey Property

Namespace: DoubleTake.Virtualization.Contract.VcdVapp
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int targetDeviceKey { get; set; }
Public Property targetDeviceKey As Integer
    Get
    Set
public:
property int targetDeviceKey {
    int get ();
    void set (int value);
}
function get_targetDeviceKey();
function set_targetDeviceKey(value);

Property Value

Type: Int32
See Also

Reference

VmdkInfo Class
DoubleTake.Virtualization.Contract.VcdVapp Namespace


VmdkInfo.targetDiskOffset Property

VmdkInfotargetDiskOffset Property

Namespace: DoubleTake.Virtualization.Contract.VcdVapp
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public long targetDiskOffset { get; set; }
Public Property targetDiskOffset As Long
    Get
    Set
public:
property long long targetDiskOffset {
    long long get ();
    void set (long long value);
}
function get_targetDiskOffset();
function set_targetDiskOffset(value);

Property Value

Type: Int64
See Also

Reference

VmdkInfo Class
DoubleTake.Virtualization.Contract.VcdVapp Namespace


VmdkInfo.targetVmdkPath Property

VmdkInfotargetVmdkPath Property

Namespace: DoubleTake.Virtualization.Contract.VcdVapp
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string targetVmdkPath { get; set; }
Public Property targetVmdkPath As String
    Get
    Set
public:
property String^ targetVmdkPath {
    String^ get ();
    void set (String^ value);
}
function get_targetVmdkPath();
function set_targetVmdkPath(value);

Property Value

Type: String
See Also

Reference

VmdkInfo Class
DoubleTake.Virtualization.Contract.VcdVapp Namespace


VmdkInfo.targetVmdkUuid Property

VmdkInfotargetVmdkUuid Property

Namespace: DoubleTake.Virtualization.Contract.VcdVapp
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string targetVmdkUuid { get; set; }
Public Property targetVmdkUuid As String
    Get
    Set
public:
property String^ targetVmdkUuid {
    String^ get ();
    void set (String^ value);
}
function get_targetVmdkUuid();
function set_targetVmdkUuid(value);

Property Value

Type: String
See Also

Reference

VmdkInfo Class
DoubleTake.Virtualization.Contract.VcdVapp Namespace


VmdkInfo.targetVmUuid Property

VmdkInfotargetVmUuid Property

Namespace: DoubleTake.Virtualization.Contract.VcdVapp
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string targetVmUuid { get; set; }
Public Property targetVmUuid As String
    Get
    Set
public:
property String^ targetVmUuid {
    String^ get ();
    void set (String^ value);
}
function get_targetVmUuid();
function set_targetVmUuid(value);

Property Value

Type: String
See Also

Reference

VmdkInfo Class
DoubleTake.Virtualization.Contract.VcdVapp Namespace


DoubleTake.Virtualization.Contract.VRA Namespace

DoubleTake.Virtualization.Contract.VRA Namespace
Classes
 | Class | Description
Public class | ActivationCodeInfo | Activation code information on appliance for V2V push install
Public class | ReplicaVMInfo | Represents replica virtual machine information
Public class | UVRAVolumePersistedState | This class represents that internal information that VRA needs to keep about a volume.
Public class | V2VVirtualMachine | Describes a virtual machine to be protected by the V2V feature.
Public class | VRAInternalVirtualNetworkInterfaceInfo | This class is for internal use only.
Public class | VRAVolumePersistedState | This class represents that internal information that VRA needs to keep about a volume.
Public class | VRAWorkloadCustomizationOptions | This class contains options used to customize the workload


ActivationCodeInfo Class

ActivationCodeInfo Class
Activation code information on appliance for V2V push install
Inheritance Hierarchy
SystemObject
DoubleTake.Virtualization.Contract.VRAActivationCodeInfo

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class ActivationCodeInfo
Public Class ActivationCodeInfo
public ref class ActivationCodeInfo
DoubleTake.Virtualization.Contract.VRA.ActivationCodeInfo = function();

Type.createClass(
    'DoubleTake.Virtualization.Contract.VRA.ActivationCodeInfo');

The ActivationCodeInfo type exposes the following members.

Constructors
 | Name | Description
Public method | ActivationCodeInfo | Initializes a new instance of the ActivationCodeInfo class
Top
Fields
 | Name | Description
Public field | ActivationCode | This value is a 24 character, alpha-numeric key which applies the appropriate license to the server.
Public field | DaysToExpire | This value is the number of days until the license expires.
Public field | IsEval | This value is true if the license key is an evaluation license; otherwise, it is false.
Public field | IsNodeLocked | This value is true if the license key must be activated; otherwise, it is false.
Public field | IsValid | This value is true if the license key is valid; otherwise, it is false.
Top
See Also

Reference

DoubleTake.Virtualization.Contract.VRA Namespace


ActivationCodeInfo Constructor

ActivationCodeInfo Constructor
Initializes a new instance of the ActivationCodeInfo class

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ActivationCodeInfo()
Public Sub New
public:
ActivationCodeInfo()
DoubleTake.Virtualization.Contract.VRA.ActivationCodeInfo = function();
See Also

Reference

ActivationCodeInfo Class
DoubleTake.Virtualization.Contract.VRA Namespace


ActivationCodeInfo Fields

ActivationCodeInfo Fields

The ActivationCodeInfo type exposes the following members.

Fields
 | Name | Description
Public field | ActivationCode | This value is a 24 character, alpha-numeric key which applies the appropriate license to the server.
Public field | DaysToExpire | This value is the number of days until the license expires.
Public field | IsEval | This value is true if the license key is an evaluation license; otherwise, it is false.
Public field | IsNodeLocked | This value is true if the license key must be activated; otherwise, it is false.
Public field | IsValid | This value is true if the license key is valid; otherwise, it is false.
Top
See Also

Reference

ActivationCodeInfo Class
DoubleTake.Virtualization.Contract.VRA Namespace


ActivationCodeInfo.ActivationCode Field

ActivationCodeInfoActivationCode Field
This value is a 24 character, alpha-numeric key which applies the appropriate license to the server.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string ActivationCode
Public ActivationCode As String
public:
String^ ActivationCode
var ActivationCode

Field Value

Type: String
See Also

Reference

ActivationCodeInfo Class
DoubleTake.Virtualization.Contract.VRA Namespace


ActivationCodeInfo.DaysToExpire Field

ActivationCodeInfoDaysToExpire Field
This value is the number of days until the license expires.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int DaysToExpire
Public DaysToExpire As Integer
public:
int DaysToExpire
var DaysToExpire

Field Value

Type: Int32
See Also

Reference

ActivationCodeInfo Class
DoubleTake.Virtualization.Contract.VRA Namespace


ActivationCodeInfo.IsEval Field

ActivationCodeInfoIsEval Field
This value is true if the license key is an evaluation license; otherwise, it is false.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsEval
Public IsEval As Boolean
public:
bool IsEval
var IsEval

Field Value

Type: Boolean
See Also

Reference

ActivationCodeInfo Class
DoubleTake.Virtualization.Contract.VRA Namespace


ActivationCodeInfo.IsNodeLocked Field

ActivationCodeInfoIsNodeLocked Field
This value is true if the license key must be activated; otherwise, it is false.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsNodeLocked
Public IsNodeLocked As Boolean
public:
bool IsNodeLocked
var IsNodeLocked

Field Value

Type: Boolean
See Also

Reference

ActivationCodeInfo Class
DoubleTake.Virtualization.Contract.VRA Namespace


ActivationCodeInfo.IsValid Field

ActivationCodeInfoIsValid Field
This value is true if the license key is valid; otherwise, it is false.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsValid
Public IsValid As Boolean
public:
bool IsValid
var IsValid

Field Value

Type: Boolean
See Also

Reference

ActivationCodeInfo Class
DoubleTake.Virtualization.Contract.VRA Namespace


ReplicaVMInfo Class

ReplicaVMInfo Class
Represents replica virtual machine information
Inheritance Hierarchy
SystemObject
DoubleTake.Virtualization.ContractVMInfo
DoubleTake.Virtualization.Contract.VRAReplicaVMInfo

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class ReplicaVMInfo : VMInfo
Public Class ReplicaVMInfo
    Inherits VMInfo
public ref class ReplicaVMInfo : public VMInfo
DoubleTake.Virtualization.Contract.VRA.ReplicaVMInfo = function();

Type.createClass(
    'DoubleTake.Virtualization.Contract.VRA.ReplicaVMInfo',
    DoubleTake.Virtualization.Contract.VMInfo);

The ReplicaVMInfo type exposes the following members.

Constructors
 | Name | Description
Public method | ReplicaVMInfo | Initializes a new instance of the ReplicaVMInfo class
Top
Properties
 | Name | Description
Public property | Address | This value is the virtual machine guest name or IP address. (Inherited from VMInfo.)
Public property | BootVolumeSignature | This value is the virtual machine boot volume signature which is required for agentless Hyper-V WAN failover. (Inherited from VMInfo.)
Public property | Cpus | This value is the number of processors.
Public property | DisplayName | This value is the virtual machine display name. (Inherited from VMInfo.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from VMInfo.)
Public property | GuestOS | This value is the virtual machine guest operating system. (Inherited from VMInfo.)
Public property | GuestUri | This value is the guest URI. (Inherited from VMInfo.)
Public property | Id | This value is the virtual machine unique ID. (Inherited from VMInfo.)
Public property | Memory | This value is the amount of memory in bytes.
Public property | OperatingSystem | This value is the ESX operating system.
Public property | Path | This value is the virtual machine configuration file location. (Inherited from VMInfo.)
Public property | PathTransformations | This value represents where the protected source virtual machine will be located on the target. (Inherited from VMInfo.)
Public property | PrestageFolder | This value is the full path to a location that contains an existing virtual disk that you want to reuse.
Public property | ReplicaVmVersion | Gets or sets the version of the Vm hardware.
Public property | RunOnceAtStartup | This value is a command to run when the replica virtual machine is first powered on.
Public property | SnapshotDataPath | This value is the virtual machine snapshot location. (Inherited from VMInfo.)
Public property | SnapshotFileNames | This value is the virtual machine snapshot file names. (Inherited from VMInfo.)
Public property | SystemDirectory | This value is the virtual machine system directory which is required for agentless Hyper-V WAN failover. (Inherited from VMInfo.)
Public property | VirtualHardDiskPath | This value is the virtual machine hard disk location. (Inherited from VMInfo.)
Top
Fields
 | Name | Description
Public field | BiosGuid | This value is the virtual machine BIOS unique ID. (Inherited from VMInfo.)
Top
See Also

Reference

DoubleTake.Virtualization.Contract.VRA Namespace


ReplicaVMInfo Constructor

ReplicaVMInfo Constructor
Initializes a new instance of the ReplicaVMInfo class

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ReplicaVMInfo()
Public Sub New
public:
ReplicaVMInfo()
DoubleTake.Virtualization.Contract.VRA.ReplicaVMInfo = function();
See Also

Reference

ReplicaVMInfo Class
DoubleTake.Virtualization.Contract.VRA Namespace


ReplicaVMInfo Properties

ReplicaVMInfo Properties

The ReplicaVMInfo type exposes the following members.

Properties
 | Name | Description
Public property | Address | This value is the virtual machine guest name or IP address. (Inherited from VMInfo.)
Public property | BootVolumeSignature | This value is the virtual machine boot volume signature which is required for agentless Hyper-V WAN failover. (Inherited from VMInfo.)
Public property | Cpus | This value is the number of processors.
Public property | DisplayName | This value is the virtual machine display name. (Inherited from VMInfo.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from VMInfo.)
Public property | GuestOS | This value is the virtual machine guest operating system. (Inherited from VMInfo.)
Public property | GuestUri | This value is the guest URI. (Inherited from VMInfo.)
Public property | Id | This value is the virtual machine unique ID. (Inherited from VMInfo.)
Public property | Memory | This value is the amount of memory in bytes.
Public property | OperatingSystem | This value is the ESX operating system.
Public property | Path | This value is the virtual machine configuration file location. (Inherited from VMInfo.)
Public property | PathTransformations | This value represents where the protected source virtual machine will be located on the target. (Inherited from VMInfo.)
Public property | PrestageFolder | This value is the full path to a location that contains an existing virtual disk that you want to reuse.
Public property | ReplicaVmVersion | Gets or sets the version of the Vm hardware.
Public property | RunOnceAtStartup | This value is a command to run when the replica virtual machine is first powered on.
Public property | SnapshotDataPath | This value is the virtual machine snapshot location. (Inherited from VMInfo.)
Public property | SnapshotFileNames | This value is the virtual machine snapshot file names. (Inherited from VMInfo.)
Public property | SystemDirectory | This value is the virtual machine system directory which is required for agentless Hyper-V WAN failover. (Inherited from VMInfo.)
Public property | VirtualHardDiskPath | This value is the virtual machine hard disk location. (Inherited from VMInfo.)
Top
See Also

Reference

ReplicaVMInfo Class
DoubleTake.Virtualization.Contract.VRA Namespace


ReplicaVMInfo.Cpus Property

ReplicaVMInfoCpus Property
This value is the number of processors.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int Cpus { get; set; }
Public Property Cpus As Integer
    Get
    Set
public:
property int Cpus {
    int get ();
    void set (int value);
}
function get_Cpus();
function set_Cpus(value);

Property Value

Type: Int32
The number of cpus.
See Also

Reference

ReplicaVMInfo Class
DoubleTake.Virtualization.Contract.VRA Namespace


ReplicaVMInfo.Memory Property

ReplicaVMInfoMemory Property
This value is the amount of memory in bytes.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public long Memory { get; set; }
Public Property Memory As Long
    Get
    Set
public:
property long long Memory {
    long long get ();
    void set (long long value);
}
function get_Memory();
function set_Memory(value);

Property Value

Type: Int64
The number of bytes of memory.
See Also

Reference

ReplicaVMInfo Class
DoubleTake.Virtualization.Contract.VRA Namespace


ReplicaVMInfo.OperatingSystem Property

ReplicaVMInfoOperatingSystem Property
This value is the ESX operating system.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string OperatingSystem { get; set; }
Public Property OperatingSystem As String
    Get
    Set
public:
property String^ OperatingSystem {
    String^ get ();
    void set (String^ value);
}
function get_OperatingSystem();
function set_OperatingSystem(value);

Property Value

Type: String
The operating system name.
See Also

Reference

ReplicaVMInfo Class
DoubleTake.Virtualization.Contract.VRA Namespace


ReplicaVMInfo.PrestageFolder Property

ReplicaVMInfoPrestageFolder Property
This value is the full path to a location that contains an existing virtual disk that you want to reuse.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string PrestageFolder { get; set; }
Public Property PrestageFolder As String
    Get
    Set
public:
property String^ PrestageFolder {
    String^ get ();
    void set (String^ value);
}
function get_PrestageFolder();
function set_PrestageFolder(value);

Property Value

Type: String
The prestage folder.
See Also

Reference

ReplicaVMInfo Class
DoubleTake.Virtualization.Contract.VRA Namespace


ReplicaVMInfo.ReplicaVmVersion Property

ReplicaVMInfoReplicaVmVersion Property
Gets or sets the version of the Vm hardware.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string ReplicaVmVersion { get; set; }
Public Property ReplicaVmVersion As String
    Get
    Set
public:
property String^ ReplicaVmVersion {
    String^ get ();
    void set (String^ value);
}
function get_ReplicaVmVersion();
function set_ReplicaVmVersion(value);

Property Value

Type: String
The version of the Vm hardware.
See Also

Reference

ReplicaVMInfo Class
DoubleTake.Virtualization.Contract.VRA Namespace


ReplicaVMInfo.RunOnceAtStartup Property

ReplicaVMInfoRunOnceAtStartup Property
This value is a command to run when the replica virtual machine is first powered on.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string RunOnceAtStartup { get; set; }
Public Property RunOnceAtStartup As String
    Get
    Set
public:
property String^ RunOnceAtStartup {
    String^ get ();
    void set (String^ value);
}
function get_RunOnceAtStartup();
function set_RunOnceAtStartup(value);

Property Value

Type: String
The command to execute.
See Also

Reference

ReplicaVMInfo Class
DoubleTake.Virtualization.Contract.VRA Namespace


ReplicaVMInfo Fields

ReplicaVMInfo Fields

The ReplicaVMInfo type exposes the following members.

Fields
 | Name | Description
Public field | BiosGuid | This value is the virtual machine BIOS unique ID. (Inherited from VMInfo.)
Top
See Also

Reference

ReplicaVMInfo Class
DoubleTake.Virtualization.Contract.VRA Namespace


UVRAVolumePersistedState Class

UVRAVolumePersistedState Class
This class represents that internal information that VRA needs to keep about a volume.
Inheritance Hierarchy
SystemObject
DoubleTake.Common.ContractPhysicalItem
DoubleTake.Common.ContractVolume
DoubleTake.Core.ContractVolumeOptions
DoubleTake.Virtualization.Contract.VRAUVRAVolumePersistedState

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class UVRAVolumePersistedState : VolumeOptions
Public Class UVRAVolumePersistedState
    Inherits VolumeOptions
public ref class UVRAVolumePersistedState : public VolumeOptions
DoubleTake.Virtualization.Contract.VRA.UVRAVolumePersistedState = function();

Type.createClass(
    'DoubleTake.Virtualization.Contract.VRA.UVRAVolumePersistedState',
    DoubleTake.Core.Contract.VolumeOptions);

The UVRAVolumePersistedState type exposes the following members.

Constructors
 | Name | Description
Public method | UVRAVolumePersistedState | Initializes a new instance of the UVRAVolumePersistedState class
Top
Properties
 | Name | Description
Public property | ApplianceSCSIBus | Gets or sets the SCSI bus number the volume has on the replica appliance.
Public property | ApplianceSCSIUnitNumber | Gets or sets the SCSI unit number the volume has on the replica appliance.
Public property | Attributes | This value represents the file system attributes. (Inherited from PhysicalItem.)
Public property | AvailableFreeSpace | This value is the amount of free space on the volume. (Inherited from Volume.)
Public property | CreationTime | This value is the time when the item was created. (Inherited from PhysicalItem.)
Public property | DesiredSize | This value is the desired size of the new volume. (Inherited from VolumeOptions.)
Public property | DeviceID | Gets or sets the device ID the volume has on the replica appliance
Public property | DiskControllerType | This value is the disk controller. IDE—Use this value to create an IDE disk. SCSI—Use this value to create a SCSI disk. (Inherited from VolumeOptions.)
Public property | DiskProvisioningType | This value is the disk type. Dynamic—Use this value for ESX thin disks and for Hyper-V dynamic disks. Fixed—Use this value for ESX thick disks and for Hyper-V fixed disks. Flat Disk—Use this value for ESX flat disks. This type is not supported on Hyper-V. (Inherited from VolumeOptions.)
Public property | DriveFormat | This value is the file system format of the volume. (Inherited from Volume.)
Public property | DriveIndex | Gets or sets the index of the drive the volume has on the replica appliance
Public property | DriveName | Gets or sets the name of the drive on the helper (\\.\PHYSICALDRIVEX)
Public property | DriveType | This value is the drive type. (Inherited from Volume.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from PhysicalItem.)
Public property | IsContainer | This value is true if the item is a container of other items; otherwise, it is false. (Inherited from PhysicalItem.)
Public property | IsReadOnly | This value is true if the item is read-only (meaning the Saturation cannot be changed); otherwise, it is false. (Inherited from PhysicalItem.)
Public property | IsSystemDrive | This value is true if the volume is the system volume; otherwise, it is false. (Inherited from Volume.)
Public property | ItemType | This value is the type of item. (Inherited from PhysicalItem.)
Public property | Label | This value is the label assigned to the volume. (Inherited from Volume.)
Public property | LastAccessTime | This value is the time when the item was last accessed. (Inherited from PhysicalItem.)
Public property | LastWriteTime | This value is the time when the item was last written to. (Inherited from PhysicalItem.)
Public property | Metadata | This value is any additional metadata that may be displayed for a particular type of item. This metadata is not in any particular format, but you must be able to determine the format and decipher the metadata based on the type. (Inherited from PhysicalItem.)
Public property | MountPoint | Gets or sets the mount point.
Public property | Name | This value is the name of the item. Typically, this name is used for display in the user interface. (Inherited from PhysicalItem.)
Public property | OriginalPath | Gets or sets the path where the volume was stored on the source host.
Public property | Path | This value is the path of the item. (Inherited from PhysicalItem.)
Public property | PNPDeviceID | Gets or sets the PNP device ID.
Public property | PreexistingDiskPath | This value is the full path and file name of an existing virtual disk that you want to reuse. If this value is null, a new virtual disk will be created. (Inherited from VolumeOptions.)
Public property | ReplicaVmSCSIBus | Gets or sets the SCSI bus number the volume has on the replica Vm.
Public property | ReplicaVmSCSIUnitNumber | Gets or sets the SCSI unit number the volume has on the replica Vm.
Public property | ReverseVolumeSignature | Gets or sets the reverse volume signature. This represents the signature of the volume on the Source.
Public property | Saturation | This value represents the saturation level of the item. Typically, this value is used to display a visual state in the user interface. (Inherited from PhysicalItem.)
Public property | Size | This value is the physical size of the item. (Inherited from PhysicalItem.)
Public property | SourceISCSIBus | Gets or sets the iSCSI bus number used in mapping the source disk.
Public property | SourceISCSIUnitNumber | Gets or sets the iSCSI unit number used in mapping the source disk.
Public property | TotalSize | This value is the total size of the volume. (Inherited from Volume.)
Public property | VirtualDiskFilename | Gets or sets the filename for the virtual disk.
Public property | VirtualDiskPath | This value is the path on the host where the volume should be stored. (Inherited from VolumeOptions.)
Public property | VolumeName | Gets or sets the name of the volume.
Public property | VolumeSignature | This value is the volume signature. (Inherited from VolumeOptions.)
Public property | VolumeType | This value is the type of volume. (Inherited from Volume.)
Top
Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from VolumeOptions.)
 | Create | Creates a VRAVolumePersistedState from a VolumeOptions instance.
Top
See Also

Reference

DoubleTake.Virtualization.Contract.VRA Namespace


UVRAVolumePersistedState Constructor

UVRAVolumePersistedState Constructor
Initializes a new instance of the UVRAVolumePersistedState class

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public UVRAVolumePersistedState()
Public Sub New
public:
UVRAVolumePersistedState()
DoubleTake.Virtualization.Contract.VRA.UVRAVolumePersistedState = function();
See Also

Reference

UVRAVolumePersistedState Class
DoubleTake.Virtualization.Contract.VRA Namespace


UVRAVolumePersistedState Properties

UVRAVolumePersistedState Properties

The UVRAVolumePersistedState type exposes the following members.

Properties
 | Name | Description
Public property | ApplianceSCSIBus | Gets or sets the SCSI bus number the volume has on the replica appliance.
Public property | ApplianceSCSIUnitNumber | Gets or sets the SCSI unit number the volume has on the replica appliance.
Public property | Attributes | This value represents the file system attributes. (Inherited from PhysicalItem.)
Public property | AvailableFreeSpace | This value is the amount of free space on the volume. (Inherited from Volume.)
Public property | CreationTime | This value is the time when the item was created. (Inherited from PhysicalItem.)
Public property | DesiredSize | This value is the desired size of the new volume. (Inherited from VolumeOptions.)
Public property | DeviceID | Gets or sets the device ID the volume has on the replica appliance
Public property | DiskControllerType | This value is the disk controller. IDE—Use this value to create an IDE disk. SCSI—Use this value to create a SCSI disk. (Inherited from VolumeOptions.)
Public property | DiskProvisioningType | This value is the disk type. Dynamic—Use this value for ESX thin disks and for Hyper-V dynamic disks. Fixed—Use this value for ESX thick disks and for Hyper-V fixed disks. Flat Disk—Use this value for ESX flat disks. This type is not supported on Hyper-V. (Inherited from VolumeOptions.)
Public property | DriveFormat | This value is the file system format of the volume. (Inherited from Volume.)
Public property | DriveIndex | Gets or sets the index of the drive the volume has on the replica appliance
Public property | DriveName | Gets or sets the name of the drive on the helper (\\.\PHYSICALDRIVEX)
Public property | DriveType | This value is the drive type. (Inherited from Volume.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from PhysicalItem.)
Public property | IsContainer | This value is true if the item is a container of other items; otherwise, it is false. (Inherited from PhysicalItem.)
Public property | IsReadOnly | This value is true if the item is read-only (meaning the Saturation cannot be changed); otherwise, it is false. (Inherited from PhysicalItem.)
Public property | IsSystemDrive | This value is true if the volume is the system volume; otherwise, it is false. (Inherited from Volume.)
Public property | ItemType | This value is the type of item. (Inherited from PhysicalItem.)
Public property | Label | This value is the label assigned to the volume. (Inherited from Volume.)
Public property | LastAccessTime | This value is the time when the item was last accessed. (Inherited from PhysicalItem.)
Public property | LastWriteTime | This value is the time when the item was last written to. (Inherited from PhysicalItem.)
Public property | Metadata | This value is any additional metadata that may be displayed for a particular type of item. This metadata is not in any particular format, but you must be able to determine the format and decipher the metadata based on the type. (Inherited from PhysicalItem.)
Public property | MountPoint | Gets or sets the mount point.
Public property | Name | This value is the name of the item. Typically, this name is used for display in the user interface. (Inherited from PhysicalItem.)
Public property | OriginalPath | Gets or sets the path where the volume was stored on the source host.
Public property | Path | This value is the path of the item. (Inherited from PhysicalItem.)
Public property | PNPDeviceID | Gets or sets the PNP device ID.
Public property | PreexistingDiskPath | This value is the full path and file name of an existing virtual disk that you want to reuse. If this value is null, a new virtual disk will be created. (Inherited from VolumeOptions.)
Public property | ReplicaVmSCSIBus | Gets or sets the SCSI bus number the volume has on the replica Vm.
Public property | ReplicaVmSCSIUnitNumber | Gets or sets the SCSI unit number the volume has on the replica Vm.
Public property | ReverseVolumeSignature | Gets or sets the reverse volume signature. This represents the signature of the volume on the Source.
Public property | Saturation | This value represents the saturation level of the item. Typically, this value is used to display a visual state in the user interface. (Inherited from PhysicalItem.)
Public property | Size | This value is the physical size of the item. (Inherited from PhysicalItem.)
Public property | SourceISCSIBus | Gets or sets the iSCSI bus number used in mapping the source disk.
Public property | SourceISCSIUnitNumber | Gets or sets the iSCSI unit number used in mapping the source disk.
Public property | TotalSize | This value is the total size of the volume. (Inherited from Volume.)
Public property | VirtualDiskFilename | Gets or sets the filename for the virtual disk.
Public property | VirtualDiskPath | This value is the path on the host where the volume should be stored. (Inherited from VolumeOptions.)
Public property | VolumeName | Gets or sets the name of the volume.
Public property | VolumeSignature | This value is the volume signature. (Inherited from VolumeOptions.)
Public property | VolumeType | This value is the type of volume. (Inherited from Volume.)
Top
See Also

Reference

UVRAVolumePersistedState Class
DoubleTake.Virtualization.Contract.VRA Namespace


UVRAVolumePersistedState.ApplianceSCSIBus Property

UVRAVolumePersistedStateApplianceSCSIBus Property
Gets or sets the SCSI bus number the volume has on the replica appliance.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int ApplianceSCSIBus { get; set; }
Public Property ApplianceSCSIBus As Integer
    Get
    Set
public:
property int ApplianceSCSIBus {
    int get ();
    void set (int value);
}
function get_ApplianceSCSIBus();
function set_ApplianceSCSIBus(value);

Property Value

Type: Int32
The replica appliance SCSI bus.
See Also

Reference

UVRAVolumePersistedState Class
DoubleTake.Virtualization.Contract.VRA Namespace


UVRAVolumePersistedState.ApplianceSCSIUnitNumber Property

UVRAVolumePersistedStateApplianceSCSIUnitNumber Property
Gets or sets the SCSI unit number the volume has on the replica appliance.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int ApplianceSCSIUnitNumber { get; set; }
Public Property ApplianceSCSIUnitNumber As Integer
    Get
    Set
public:
property int ApplianceSCSIUnitNumber {
    int get ();
    void set (int value);
}
function get_ApplianceSCSIUnitNumber();
function set_ApplianceSCSIUnitNumber(value);

Property Value

Type: Int32
The replica appliance SCSI unit number.
See Also

Reference

UVRAVolumePersistedState Class
DoubleTake.Virtualization.Contract.VRA Namespace


UVRAVolumePersistedState.DeviceID Property

UVRAVolumePersistedStateDeviceID Property
Gets or sets the device ID the volume has on the replica appliance

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string DeviceID { get; set; }
Public Property DeviceID As String
    Get
    Set
public:
property String^ DeviceID {
    String^ get ();
    void set (String^ value);
}
function get_DeviceID();
function set_DeviceID(value);

Property Value

Type: String
The device ID.
See Also

Reference

UVRAVolumePersistedState Class
DoubleTake.Virtualization.Contract.VRA Namespace


UVRAVolumePersistedState.DriveIndex Property

UVRAVolumePersistedStateDriveIndex Property
Gets or sets the index of the drive the volume has on the replica appliance

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int DriveIndex { get; set; }
Public Property DriveIndex As Integer
    Get
    Set
public:
property int DriveIndex {
    int get ();
    void set (int value);
}
function get_DriveIndex();
function set_DriveIndex(value);

Property Value

Type: Int32
The index of the drive.
See Also

Reference

UVRAVolumePersistedState Class
DoubleTake.Virtualization.Contract.VRA Namespace


UVRAVolumePersistedState.DriveName Property

UVRAVolumePersistedStateDriveName Property
Gets or sets the name of the drive on the helper (\\.\PHYSICALDRIVEX)

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string DriveName { get; set; }
Public Property DriveName As String
    Get
    Set
public:
property String^ DriveName {
    String^ get ();
    void set (String^ value);
}
function get_DriveName();
function set_DriveName(value);

Property Value

Type: String
The index of the drive.
See Also

Reference

UVRAVolumePersistedState Class
DoubleTake.Virtualization.Contract.VRA Namespace


UVRAVolumePersistedState.MountPoint Property

UVRAVolumePersistedStateMountPoint Property
Gets or sets the mount point.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string MountPoint { get; set; }
Public Property MountPoint As String
    Get
    Set
public:
property String^ MountPoint {
    String^ get ();
    void set (String^ value);
}
function get_MountPoint();
function set_MountPoint(value);

Property Value

Type: String
The mount point.
See Also

Reference

UVRAVolumePersistedState Class
DoubleTake.Virtualization.Contract.VRA Namespace


UVRAVolumePersistedState.OriginalPath Property

UVRAVolumePersistedStateOriginalPath Property
Gets or sets the path where the volume was stored on the source host.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string OriginalPath { get; set; }
Public Property OriginalPath As String
    Get
    Set
public:
property String^ OriginalPath {
    String^ get ();
    void set (String^ value);
}
function get_OriginalPath();
function set_OriginalPath(value);

Property Value

Type: String
The original path.
See Also

Reference

UVRAVolumePersistedState Class
DoubleTake.Virtualization.Contract.VRA Namespace


UVRAVolumePersistedState.PNPDeviceID Property

UVRAVolumePersistedStatePNPDeviceID Property
Gets or sets the PNP device ID.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string PNPDeviceID { get; set; }
Public Property PNPDeviceID As String
    Get
    Set
public:
property String^ PNPDeviceID {
    String^ get ();
    void set (String^ value);
}
function get_PNPDeviceID();
function set_PNPDeviceID(value);

Property Value

Type: String
The PNP device ID.
See Also

Reference

UVRAVolumePersistedState Class
DoubleTake.Virtualization.Contract.VRA Namespace


UVRAVolumePersistedState.ReplicaVmSCSIBus Property

UVRAVolumePersistedStateReplicaVmSCSIBus Property
Gets or sets the SCSI bus number the volume has on the replica Vm.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int ReplicaVmSCSIBus { get; set; }
Public Property ReplicaVmSCSIBus As Integer
    Get
    Set
public:
property int ReplicaVmSCSIBus {
    int get ();
    void set (int value);
}
function get_ReplicaVmSCSIBus();
function set_ReplicaVmSCSIBus(value);

Property Value

Type: Int32
The replica vm SCSI bus.
See Also

Reference

UVRAVolumePersistedState Class
DoubleTake.Virtualization.Contract.VRA Namespace


UVRAVolumePersistedState.ReplicaVmSCSIUnitNumber Property

UVRAVolumePersistedStateReplicaVmSCSIUnitNumber Property
Gets or sets the SCSI unit number the volume has on the replica Vm.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int ReplicaVmSCSIUnitNumber { get; set; }
Public Property ReplicaVmSCSIUnitNumber As Integer
    Get
    Set
public:
property int ReplicaVmSCSIUnitNumber {
    int get ();
    void set (int value);
}
function get_ReplicaVmSCSIUnitNumber();
function set_ReplicaVmSCSIUnitNumber(value);

Property Value

Type: Int32
The replica vm SCSI unit number.
See Also

Reference

UVRAVolumePersistedState Class
DoubleTake.Virtualization.Contract.VRA Namespace


UVRAVolumePersistedState.ReverseVolumeSignature Property

UVRAVolumePersistedStateReverseVolumeSignature Property
Gets or sets the reverse volume signature. This represents the signature of the volume on the Source.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public byte[] ReverseVolumeSignature { get; set; }
Public Property ReverseVolumeSignature As Byte()
    Get
    Set
public:
property array<unsigned char>^ ReverseVolumeSignature {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
function get_ReverseVolumeSignature();
function set_ReverseVolumeSignature(value);

Property Value

Type: Byte
The reverse volume signature.
See Also

Reference

UVRAVolumePersistedState Class
DoubleTake.Virtualization.Contract.VRA Namespace


UVRAVolumePersistedState.SourceISCSIBus Property

UVRAVolumePersistedStateSourceISCSIBus Property
Gets or sets the iSCSI bus number used in mapping the source disk.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int SourceISCSIBus { get; set; }
Public Property SourceISCSIBus As Integer
    Get
    Set
public:
property int SourceISCSIBus {
    int get ();
    void set (int value);
}
function get_SourceISCSIBus();
function set_SourceISCSIBus(value);

Property Value

Type: Int32
The replica appliance SCSI bus.
See Also

Reference

UVRAVolumePersistedState Class
DoubleTake.Virtualization.Contract.VRA Namespace


UVRAVolumePersistedState.SourceISCSIUnitNumber Property

UVRAVolumePersistedStateSourceISCSIUnitNumber Property
Gets or sets the iSCSI unit number used in mapping the source disk.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int SourceISCSIUnitNumber { get; set; }
Public Property SourceISCSIUnitNumber As Integer
    Get
    Set
public:
property int SourceISCSIUnitNumber {
    int get ();
    void set (int value);
}
function get_SourceISCSIUnitNumber();
function set_SourceISCSIUnitNumber(value);

Property Value

Type: Int32
The replica appliance SCSI unit number.
See Also

Reference

UVRAVolumePersistedState Class
DoubleTake.Virtualization.Contract.VRA Namespace


UVRAVolumePersistedState.VirtualDiskFilename Property

UVRAVolumePersistedStateVirtualDiskFilename Property
Gets or sets the filename for the virtual disk.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string VirtualDiskFilename { get; set; }
Public Property VirtualDiskFilename As String
    Get
    Set
public:
property String^ VirtualDiskFilename {
    String^ get ();
    void set (String^ value);
}
function get_VirtualDiskFilename();
function set_VirtualDiskFilename(value);

Property Value

Type: String
The virtual disk filename.
See Also

Reference

UVRAVolumePersistedState Class
DoubleTake.Virtualization.Contract.VRA Namespace


UVRAVolumePersistedState.VolumeName Property

UVRAVolumePersistedStateVolumeName Property
Gets or sets the name of the volume.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string VolumeName { get; set; }
Public Property VolumeName As String
    Get
    Set
public:
property String^ VolumeName {
    String^ get ();
    void set (String^ value);
}
function get_VolumeName();
function set_VolumeName(value);

Property Value

Type: String
The name of the volume.
See Also

Reference

UVRAVolumePersistedState Class
DoubleTake.Virtualization.Contract.VRA Namespace


UVRAVolumePersistedState Methods

UVRAVolumePersistedState Methods

The UVRAVolumePersistedState type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from VolumeOptions.)
 | Create | Creates a VRAVolumePersistedState from a VolumeOptions instance.
Top
See Also

Reference

UVRAVolumePersistedState Class
DoubleTake.Virtualization.Contract.VRA Namespace


UVRAVolumePersistedState.Create Method

UVRAVolumePersistedStateCreate Method
Creates a VRAVolumePersistedState from a VolumeOptions instance.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public static VRAVolumePersistedState Create(
    VolumeOptions volume
)
Public Shared Function Create (
    volume As VolumeOptions
) As VRAVolumePersistedState
public:
static VRAVolumePersistedState^ Create(
    VolumeOptions^ volume
)
DoubleTake.Virtualization.Contract.VRA.UVRAVolumePersistedState.Create = function(volume);

Parameters

volume
Type: DoubleTake.Core.ContractVolumeOptions
The volume.

Return Value

Type: VRAVolumePersistedState
See Also

Reference

UVRAVolumePersistedState Class
DoubleTake.Virtualization.Contract.VRA Namespace


V2VVirtualMachine Class

V2VVirtualMachine Class
Describes a virtual machine to be protected by the V2V feature.
Inheritance Hierarchy
SystemObject
DoubleTake.Virtualization.Contract.VRAV2VVirtualMachine

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class V2VVirtualMachine
Public Class V2VVirtualMachine
public ref class V2VVirtualMachine
DoubleTake.Virtualization.Contract.VRA.V2VVirtualMachine = function();

Type.createClass(
    'DoubleTake.Virtualization.Contract.VRA.V2VVirtualMachine');

The V2VVirtualMachine type exposes the following members.

Constructors
 | Name | Description
Public method | V2VVirtualMachine | Initializes a new instance of the V2VVirtualMachine class
Top
Properties
 | Name | Description
Public property | ActivationCode | This value is license key on the virtual machine.
Public property | BiosGuid | This value is the BIOS unique ID for the virtual machine.
Public property | CPUs | This value is the number of processors on the virtual machine.
Public property | Credentials | This value represents the credentials used to access the virtual machine.
Public property | DiskFormat | This value is the disk format. Dynamic—Use this value for ESX thin disks and for Hyper-V dynamic disks. Fixed—Use this value for ESX thick disks and for Hyper-V fixed disks. Flat Disk—Use this value for ESX flat disks. This type is not supported on Hyper-V.
Public property | DisplayName | This value is the virtual machine display name.
Public property | GuestOS | This value is guest operating system.
Public property | Guid | This value is unique ID of the virtual machine.
Public property | Memory | This value is the amount of memory, in bytes, on the virtual machine.
Public property | NetworkId | This value is unique ID of the virtual machine network.
Public property | NetworkInterfaceInfo | This value represents the desired NIC configuration on the replica virtual machine.
Public property | Path | This value is the path of the original source virtual machine.
Public property | SnapshotPath | This value is the location of the virtual machine's snapshot files.
Public property | SystemDirectory | This value is the location of the system directory.
Public property | TargetPath | Do not use this property. Double-Take uses it internally.
Public property | Volumes | This value represents a volume to protect and any changes to its base configuration.
Top
See Also

Reference

DoubleTake.Virtualization.Contract.VRA Namespace


V2VVirtualMachine Constructor

V2VVirtualMachine Constructor
Initializes a new instance of the V2VVirtualMachine class

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public V2VVirtualMachine()
Public Sub New
public:
V2VVirtualMachine()
DoubleTake.Virtualization.Contract.VRA.V2VVirtualMachine = function();
See Also

Reference

V2VVirtualMachine Class
DoubleTake.Virtualization.Contract.VRA Namespace


V2VVirtualMachine Properties

V2VVirtualMachine Properties

The V2VVirtualMachine type exposes the following members.

Properties
 | Name | Description
Public property | ActivationCode | This value is license key on the virtual machine.
Public property | BiosGuid | This value is the BIOS unique ID for the virtual machine.
Public property | CPUs | This value is the number of processors on the virtual machine.
Public property | Credentials | This value represents the credentials used to access the virtual machine.
Public property | DiskFormat | This value is the disk format. Dynamic—Use this value for ESX thin disks and for Hyper-V dynamic disks. Fixed—Use this value for ESX thick disks and for Hyper-V fixed disks. Flat Disk—Use this value for ESX flat disks. This type is not supported on Hyper-V.
Public property | DisplayName | This value is the virtual machine display name.
Public property | GuestOS | This value is guest operating system.
Public property | Guid | This value is unique ID of the virtual machine.
Public property | Memory | This value is the amount of memory, in bytes, on the virtual machine.
Public property | NetworkId | This value is unique ID of the virtual machine network.
Public property | NetworkInterfaceInfo | This value represents the desired NIC configuration on the replica virtual machine.
Public property | Path | This value is the path of the original source virtual machine.
Public property | SnapshotPath | This value is the location of the virtual machine's snapshot files.
Public property | SystemDirectory | This value is the location of the system directory.
Public property | TargetPath | Do not use this property. Double-Take uses it internally.
Public property | Volumes | This value represents a volume to protect and any changes to its base configuration.
Top
See Also

Reference

V2VVirtualMachine Class
DoubleTake.Virtualization.Contract.VRA Namespace


V2VVirtualMachine.ActivationCode Property

V2VVirtualMachineActivationCode Property
This value is license key on the virtual machine.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string ActivationCode { get; set; }
Public Property ActivationCode As String
    Get
    Set
public:
property String^ ActivationCode {
    String^ get ();
    void set (String^ value);
}
function get_ActivationCode();
function set_ActivationCode(value);

Property Value

Type: String
The activation code.
See Also

Reference

V2VVirtualMachine Class
DoubleTake.Virtualization.Contract.VRA Namespace


V2VVirtualMachine.BiosGuid Property

V2VVirtualMachineBiosGuid Property
This value is the BIOS unique ID for the virtual machine.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Guid BiosGuid { get; set; }
Public Property BiosGuid As Guid
    Get
    Set
public:
property Guid BiosGuid {
    Guid get ();
    void set (Guid value);
}
function get_BiosGuid();
function set_BiosGuid(value);

Property Value

Type: Guid
The bios GUID.
See Also

Reference

V2VVirtualMachine Class
DoubleTake.Virtualization.Contract.VRA Namespace


V2VVirtualMachine.CPUs Property

V2VVirtualMachineCPUs Property
This value is the number of processors on the virtual machine.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int CPUs { get; set; }
Public Property CPUs As Integer
    Get
    Set
public:
property int CPUs {
    int get ();
    void set (int value);
}
function get_CPUs();
function set_CPUs(value);

Property Value

Type: Int32
The CP us.
See Also

Reference

V2VVirtualMachine Class
DoubleTake.Virtualization.Contract.VRA Namespace


V2VVirtualMachine.Credentials Property

V2VVirtualMachineCredentials Property
This value represents the credentials used to access the virtual machine.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Credentials Credentials { get; set; }
Public Property Credentials As Credentials
    Get
    Set
public:
property Credentials^ Credentials {
    Credentials^ get ();
    void set (Credentials^ value);
}
function get_Credentials();
function set_Credentials(value);

Property Value

Type: Credentials
The credentials.
See Also

Reference

V2VVirtualMachine Class
DoubleTake.Virtualization.Contract.VRA Namespace


V2VVirtualMachine.DiskFormat Property

V2VVirtualMachineDiskFormat Property
This value is the disk format. Dynamic—Use this value for ESX thin disks and for Hyper-V dynamic disks. Fixed—Use this value for ESX thick disks and for Hyper-V fixed disks. Flat Disk—Use this value for ESX flat disks. This type is not supported on Hyper-V.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string DiskFormat { get; set; }
Public Property DiskFormat As String
    Get
    Set
public:
property String^ DiskFormat {
    String^ get ();
    void set (String^ value);
}
function get_DiskFormat();
function set_DiskFormat(value);

Property Value

Type: String
The disk format.
See Also

Reference

V2VVirtualMachine Class
DoubleTake.Virtualization.Contract.VRA Namespace


V2VVirtualMachine.DisplayName Property

V2VVirtualMachineDisplayName Property
This value is the virtual machine display name.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string DisplayName { get; set; }
Public Property DisplayName As String
    Get
    Set
public:
property String^ DisplayName {
    String^ get ();
    void set (String^ value);
}
function get_DisplayName();
function set_DisplayName(value);

Property Value

Type: String
The display name.
See Also

Reference

V2VVirtualMachine Class
DoubleTake.Virtualization.Contract.VRA Namespace


V2VVirtualMachine.GuestOS Property

V2VVirtualMachineGuestOS Property
This value is guest operating system.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string GuestOS { get; set; }
Public Property GuestOS As String
    Get
    Set
public:
property String^ GuestOS {
    String^ get ();
    void set (String^ value);
}
function get_GuestOS();
function set_GuestOS(value);

Property Value

Type: String
The guest OS.
See Also

Reference

V2VVirtualMachine Class
DoubleTake.Virtualization.Contract.VRA Namespace


V2VVirtualMachine.Guid Property

V2VVirtualMachineGuid Property
This value is unique ID of the virtual machine.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public Guid Guid { get; set; }
Public Property Guid As Guid
    Get
    Set
public:
property Guid Guid {
    Guid get ();
    void set (Guid value);
}
function get_Guid();
function set_Guid(value);

Property Value

Type: Guid
The GUID.
See Also

Reference

V2VVirtualMachine Class
DoubleTake.Virtualization.Contract.VRA Namespace


V2VVirtualMachine.Memory Property

V2VVirtualMachineMemory Property
This value is the amount of memory, in bytes, on the virtual machine.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public long Memory { get; set; }
Public Property Memory As Long
    Get
    Set
public:
property long long Memory {
    long long get ();
    void set (long long value);
}
function get_Memory();
function set_Memory(value);

Property Value

Type: Int64
The memory.
See Also

Reference

V2VVirtualMachine Class
DoubleTake.Virtualization.Contract.VRA Namespace


V2VVirtualMachine.NetworkId Property

V2VVirtualMachineNetworkId Property
This value is unique ID of the virtual machine network.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string NetworkId { get; set; }
Public Property NetworkId As String
    Get
    Set
public:
property String^ NetworkId {
    String^ get ();
    void set (String^ value);
}
function get_NetworkId();
function set_NetworkId(value);

Property Value

Type: String
The network id.
See Also

Reference

V2VVirtualMachine Class
DoubleTake.Virtualization.Contract.VRA Namespace


V2VVirtualMachine.NetworkInterfaceInfo Property

V2VVirtualMachineNetworkInterfaceInfo Property
This value represents the desired NIC configuration on the replica virtual machine.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VirtualNetworkInterfaceInfo[] NetworkInterfaceInfo { get; set; }
Public Property NetworkInterfaceInfo As VirtualNetworkInterfaceInfo()
    Get
    Set
public:
property array<VirtualNetworkInterfaceInfo^>^ NetworkInterfaceInfo {
    array<VirtualNetworkInterfaceInfo^>^ get ();
    void set (array<VirtualNetworkInterfaceInfo^>^ value);
}
function get_NetworkInterfaceInfo();
function set_NetworkInterfaceInfo(value);

Property Value

Type: VirtualNetworkInterfaceInfo
The network interface info.
See Also

Reference

V2VVirtualMachine Class
DoubleTake.Virtualization.Contract.VRA Namespace


V2VVirtualMachine.Path Property

V2VVirtualMachinePath Property
This value is the path of the original source virtual machine.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string Path { get; set; }
Public Property Path As String
    Get
    Set
public:
property String^ Path {
    String^ get ();
    void set (String^ value);
}
function get_Path();
function set_Path(value);

Property Value

Type: String
The path.
See Also

Reference

V2VVirtualMachine Class
DoubleTake.Virtualization.Contract.VRA Namespace


V2VVirtualMachine.SnapshotPath Property

V2VVirtualMachineSnapshotPath Property
This value is the location of the virtual machine's snapshot files.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string SnapshotPath { get; set; }
Public Property SnapshotPath As String
    Get
    Set
public:
property String^ SnapshotPath {
    String^ get ();
    void set (String^ value);
}
function get_SnapshotPath();
function set_SnapshotPath(value);

Property Value

Type: String
The snapshot path.
See Also

Reference

V2VVirtualMachine Class
DoubleTake.Virtualization.Contract.VRA Namespace


V2VVirtualMachine.SystemDirectory Property

V2VVirtualMachineSystemDirectory Property
This value is the location of the system directory.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string SystemDirectory { get; set; }
Public Property SystemDirectory As String
    Get
    Set
public:
property String^ SystemDirectory {
    String^ get ();
    void set (String^ value);
}
function get_SystemDirectory();
function set_SystemDirectory(value);

Property Value

Type: String
The system directory.
See Also

Reference

V2VVirtualMachine Class
DoubleTake.Virtualization.Contract.VRA Namespace


V2VVirtualMachine.TargetPath Property

V2VVirtualMachineTargetPath Property
Do not use this property. Double-Take uses it internally.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string TargetPath { get; set; }
Public Property TargetPath As String
    Get
    Set
public:
property String^ TargetPath {
    String^ get ();
    void set (String^ value);
}
function get_TargetPath();
function set_TargetPath(value);

Property Value

Type: String
The target path.
See Also

Reference

V2VVirtualMachine Class
DoubleTake.Virtualization.Contract.VRA Namespace


V2VVirtualMachine.Volumes Property

V2VVirtualMachineVolumes Property
This value represents a volume to protect and any changes to its base configuration.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VolumeOptions[] Volumes { get; set; }
Public Property Volumes As VolumeOptions()
    Get
    Set
public:
property array<VolumeOptions^>^ Volumes {
    array<VolumeOptions^>^ get ();
    void set (array<VolumeOptions^>^ value);
}
function get_Volumes();
function set_Volumes(value);

Property Value

Type: VolumeOptions
The volumes.
See Also

Reference

V2VVirtualMachine Class
DoubleTake.Virtualization.Contract.VRA Namespace


VRAInternalVirtualNetworkInterfaceInfo Class

VRAInternalVirtualNetworkInterfaceInfo Class
This class is for internal use only.
Inheritance Hierarchy
SystemObject
DoubleTake.Core.ContractNetworkInterfaceInfo
DoubleTake.Virtualization.ContractVirtualNetworkInterfaceInfo
DoubleTake.Virtualization.Contract.VRAVRAInternalVirtualNetworkInterfaceInfo

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class VRAInternalVirtualNetworkInterfaceInfo : VirtualNetworkInterfaceInfo
Public Class VRAInternalVirtualNetworkInterfaceInfo
    Inherits VirtualNetworkInterfaceInfo
public ref class VRAInternalVirtualNetworkInterfaceInfo : public VirtualNetworkInterfaceInfo
DoubleTake.Virtualization.Contract.VRA.VRAInternalVirtualNetworkInterfaceInfo = function();

Type.createClass(
    'DoubleTake.Virtualization.Contract.VRA.VRAInternalVirtualNetworkInterfaceInfo',
    DoubleTake.Virtualization.Contract.VirtualNetworkInterfaceInfo);

The VRAInternalVirtualNetworkInterfaceInfo type exposes the following members.

Constructors
 | Name | Description
Public method | VRAInternalVirtualNetworkInterfaceInfo | Initializes a new instance of the VRAInternalVirtualNetworkInterfaceInfo class
Top
Properties
 | Name | Description
Public property | BusNumber | Gets or sets the bus number to be used on the replica.
Public property | Description | This value is the description of the NIC. (Inherited from NetworkInterfaceInfo.)
Public property | DeviceNumber | Gets or sets the device number to be used on the replica.
Public property | DnsDomain | This value is the DNS domain assigned to the NIC. (Inherited from NetworkInterfaceInfo.)
Public property | DnsServers | This value is the DNS server assigned to the NIC. (Inherited from NetworkInterfaceInfo.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from NetworkInterfaceInfo.)
Public property | Gateways | This value is the gateway assigned to the NIC. (Inherited from NetworkInterfaceInfo.)
Public property | Guid | This value is the unique ID for the NIC. It is equivalent to the SettingID property of the Win32_NetworkAdapterConfiguration WMI class as well as the NetworkInterface.Id property in the Base Class Library (BCL). (Inherited from NetworkInterfaceInfo.)
Public property | Index | Do not use this property. Double-Take uses it internally. (Inherited from NetworkInterfaceInfo.)
Public property | InterfaceIndex | Do not use this property. Double-Take uses it internally. (Inherited from NetworkInterfaceInfo.)
Public property | IPAddresses | This value represents the IP addresses assigned to the NIC. (Inherited from NetworkInterfaceInfo.)
Public property | MacAddress | This value represents the MAC address of the NIC. (Inherited from NetworkInterfaceInfo.)
Public property | Name | This value is the friendly name of the NIC. (Inherited from NetworkInterfaceInfo.)
Public property | PnpInstanceId | This value is the plug and play instance ID of the NIC. (Inherited from NetworkInterfaceInfo.)
Public property | ServiceName | This value is the service name of the NIC. (Inherited from NetworkInterfaceInfo.)
Public property | VirtualNetwork | This value is the virtual network. (Inherited from VirtualNetworkInterfaceInfo.)
Public property | VirtualNicType | This value is the virtual NIC. (Inherited from VirtualNetworkInterfaceInfo.)
Public property | VLAN_ID | Gets or sets the replica's VLan ID. (Inherited from VirtualNetworkInterfaceInfo.)
Public property | VLAN_ID_TestFailover | Gets or sets the replica's test failover VLan ID. (Inherited from VirtualNetworkInterfaceInfo.)
Public property | VRANicId | Gets or sets the VRA nic id.
Top
Methods
Name | Description
Create |
Top
See Also

Reference

DoubleTake.Virtualization.Contract.VRA Namespace


VRAInternalVirtualNetworkInterfaceInfo Constructor

VRAInternalVirtualNetworkInterfaceInfo Constructor
Initializes a new instance of the VRAInternalVirtualNetworkInterfaceInfo class

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VRAInternalVirtualNetworkInterfaceInfo()
Public Sub New
public:
VRAInternalVirtualNetworkInterfaceInfo()
DoubleTake.Virtualization.Contract.VRA.VRAInternalVirtualNetworkInterfaceInfo = function();
See Also

Reference

VRAInternalVirtualNetworkInterfaceInfo Class
DoubleTake.Virtualization.Contract.VRA Namespace


VRAInternalVirtualNetworkInterfaceInfo Properties

VRAInternalVirtualNetworkInterfaceInfo Properties

The VRAInternalVirtualNetworkInterfaceInfo type exposes the following members.

Properties
 | Name | Description
Public property | BusNumber | Gets or sets the bus number to be used on the replica.
Public property | Description | This value is the description of the NIC. (Inherited from NetworkInterfaceInfo.)
Public property | DeviceNumber | Gets or sets the device number to be used on the replica.
Public property | DnsDomain | This value is the DNS domain assigned to the NIC. (Inherited from NetworkInterfaceInfo.)
Public property | DnsServers | This value is the DNS server assigned to the NIC. (Inherited from NetworkInterfaceInfo.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from NetworkInterfaceInfo.)
Public property | Gateways | This value is the gateway assigned to the NIC. (Inherited from NetworkInterfaceInfo.)
Public property | Guid | This value is the unique ID for the NIC. It is equivalent to the SettingID property of the Win32_NetworkAdapterConfiguration WMI class as well as the NetworkInterface.Id property in the Base Class Library (BCL). (Inherited from NetworkInterfaceInfo.)
Public property | Index | Do not use this property. Double-Take uses it internally. (Inherited from NetworkInterfaceInfo.)
Public property | InterfaceIndex | Do not use this property. Double-Take uses it internally. (Inherited from NetworkInterfaceInfo.)
Public property | IPAddresses | This value represents the IP addresses assigned to the NIC. (Inherited from NetworkInterfaceInfo.)
Public property | MacAddress | This value represents the MAC address of the NIC. (Inherited from NetworkInterfaceInfo.)
Public property | Name | This value is the friendly name of the NIC. (Inherited from NetworkInterfaceInfo.)
Public property | PnpInstanceId | This value is the plug and play instance ID of the NIC. (Inherited from NetworkInterfaceInfo.)
Public property | ServiceName | This value is the service name of the NIC. (Inherited from NetworkInterfaceInfo.)
Public property | VirtualNetwork | This value is the virtual network. (Inherited from VirtualNetworkInterfaceInfo.)
Public property | VirtualNicType | This value is the virtual NIC. (Inherited from VirtualNetworkInterfaceInfo.)
Public property | VLAN_ID | Gets or sets the replica's VLan ID. (Inherited from VirtualNetworkInterfaceInfo.)
Public property | VLAN_ID_TestFailover | Gets or sets the replica's test failover VLan ID. (Inherited from VirtualNetworkInterfaceInfo.)
Public property | VRANicId | Gets or sets the VRA nic id.
Top
See Also

Reference

VRAInternalVirtualNetworkInterfaceInfo Class
DoubleTake.Virtualization.Contract.VRA Namespace


VRAInternalVirtualNetworkInterfaceInfo.BusNumber Property

VRAInternalVirtualNetworkInterfaceInfoBusNumber Property
Gets or sets the bus number to be used on the replica.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int BusNumber { get; set; }
Public Property BusNumber As Integer
    Get
    Set
public:
property int BusNumber {
    int get ();
    void set (int value);
}
function get_BusNumber();
function set_BusNumber(value);

Property Value

Type: Int32
The bus number.
See Also

Reference

VRAInternalVirtualNetworkInterfaceInfo Class
DoubleTake.Virtualization.Contract.VRA Namespace


VRAInternalVirtualNetworkInterfaceInfo.DeviceNumber Property

VRAInternalVirtualNetworkInterfaceInfoDeviceNumber Property
Gets or sets the device number to be used on the replica.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int DeviceNumber { get; set; }
Public Property DeviceNumber As Integer
    Get
    Set
public:
property int DeviceNumber {
    int get ();
    void set (int value);
}
function get_DeviceNumber();
function set_DeviceNumber(value);

Property Value

Type: Int32
The device number.
See Also

Reference

VRAInternalVirtualNetworkInterfaceInfo Class
DoubleTake.Virtualization.Contract.VRA Namespace


VRAInternalVirtualNetworkInterfaceInfo.VRANicId Property

VRAInternalVirtualNetworkInterfaceInfoVRANicId Property
Gets or sets the VRA nic id.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string VRANicId { get; set; }
Public Property VRANicId As String
    Get
    Set
public:
property String^ VRANicId {
    String^ get ();
    void set (String^ value);
}
function get_VRANicId();
function set_VRANicId(value);

Property Value

Type: String
The VRA nic id.
See Also

Reference

VRAInternalVirtualNetworkInterfaceInfo Class
DoubleTake.Virtualization.Contract.VRA Namespace


VRAInternalVirtualNetworkInterfaceInfo Methods

VRAInternalVirtualNetworkInterfaceInfo Methods

The VRAInternalVirtualNetworkInterfaceInfo type exposes the following members.

Methods
Name | Description
Create |
Top
See Also

Reference

VRAInternalVirtualNetworkInterfaceInfo Class
DoubleTake.Virtualization.Contract.VRA Namespace


VRAInternalVirtualNetworkInterfaceInfo.Create Method

VRAInternalVirtualNetworkInterfaceInfoCreate Method

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public static VRAInternalVirtualNetworkInterfaceInfo Create(
    VirtualNetworkInterfaceInfo nic
)
Public Shared Function Create (
    nic As VirtualNetworkInterfaceInfo
) As VRAInternalVirtualNetworkInterfaceInfo
public:
static VRAInternalVirtualNetworkInterfaceInfo^ Create(
    VirtualNetworkInterfaceInfo^ nic
)
DoubleTake.Virtualization.Contract.VRA.VRAInternalVirtualNetworkInterfaceInfo.Create = function(nic);

Parameters

nic
Type: DoubleTake.Virtualization.ContractVirtualNetworkInterfaceInfo

Return Value

Type: VRAInternalVirtualNetworkInterfaceInfo
See Also

Reference

VRAInternalVirtualNetworkInterfaceInfo Class
DoubleTake.Virtualization.Contract.VRA Namespace


VRAVolumePersistedState Class

VRAVolumePersistedState Class
This class represents that internal information that VRA needs to keep about a volume.
Inheritance Hierarchy
SystemObject
DoubleTake.Common.ContractPhysicalItem
DoubleTake.Common.ContractVolume
DoubleTake.Core.ContractVolumeOptions
DoubleTake.Virtualization.Contract.VRAVRAVolumePersistedState

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class VRAVolumePersistedState : VolumeOptions
Public Class VRAVolumePersistedState
    Inherits VolumeOptions
public ref class VRAVolumePersistedState : public VolumeOptions
DoubleTake.Virtualization.Contract.VRA.VRAVolumePersistedState = function();

Type.createClass(
    'DoubleTake.Virtualization.Contract.VRA.VRAVolumePersistedState',
    DoubleTake.Core.Contract.VolumeOptions);

The VRAVolumePersistedState type exposes the following members.

Constructors
 | Name | Description
Public method | VRAVolumePersistedState | Initializes a new instance of the VRAVolumePersistedState class
Top
Properties
 | Name | Description
Public property | ApplianceSCSIBus | Gets or sets the SCSI bus number the volume has on the replica appliance.
Public property | ApplianceSCSIUnitNumber | Gets or sets the SCSI unit number the volume has on the replica appliance.
Public property | Attributes | This value represents the file system attributes. (Inherited from PhysicalItem.)
Public property | AvailableFreeSpace | This value is the amount of free space on the volume. (Inherited from Volume.)
Public property | CreationTime | This value is the time when the item was created. (Inherited from PhysicalItem.)
Public property | DesiredSize | This value is the desired size of the new volume. (Inherited from VolumeOptions.)
Public property | DeviceID | Gets or sets the device ID the volume has on the replica appliance
Public property | DiskControllerType | This value is the disk controller. IDE—Use this value to create an IDE disk. SCSI—Use this value to create a SCSI disk. (Inherited from VolumeOptions.)
Public property | DiskProvisioningType | This value is the disk type. Dynamic—Use this value for ESX thin disks and for Hyper-V dynamic disks. Fixed—Use this value for ESX thick disks and for Hyper-V fixed disks. Flat Disk—Use this value for ESX flat disks. This type is not supported on Hyper-V. (Inherited from VolumeOptions.)
Public property | DriveFormat | This value is the file system format of the volume. (Inherited from Volume.)
Public property | DriveIndex | Gets or sets the index of the drive the volume has on the replica appliance
Public property | DriveName | Gets or sets the name of the drive on the helper (\\.\PHYSICALDRIVEX)
Public property | DriveType | This value is the drive type. (Inherited from Volume.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from PhysicalItem.)
Public property | IsContainer | This value is true if the item is a container of other items; otherwise, it is false. (Inherited from PhysicalItem.)
Public property | IsGpt | Gets or sets a value indicating whether this instance is a GPT disk.
Public property | IsReadOnly | This value is true if the item is read-only (meaning the Saturation cannot be changed); otherwise, it is false. (Inherited from PhysicalItem.)
Public property | IsSystemDrive | This value is true if the volume is the system volume; otherwise, it is false. (Inherited from Volume.)
Public property | ItemType | This value is the type of item. (Inherited from PhysicalItem.)
Public property | Label | This value is the label assigned to the volume. (Inherited from Volume.)
Public property | LastAccessTime | This value is the time when the item was last accessed. (Inherited from PhysicalItem.)
Public property | LastWriteTime | This value is the time when the item was last written to. (Inherited from PhysicalItem.)
Public property | Metadata | This value is any additional metadata that may be displayed for a particular type of item. This metadata is not in any particular format, but you must be able to determine the format and decipher the metadata based on the type. (Inherited from PhysicalItem.)
Public property | MountPoint | Gets or sets the mount point.
Public property | Name | This value is the name of the item. Typically, this name is used for display in the user interface. (Inherited from PhysicalItem.)
Public property | OriginalPath | Gets or sets the path where the volume was stored on the source host.
Public property | Path | This value is the path of the item. (Inherited from PhysicalItem.)
Public property | PNPDeviceID | Gets or sets the PNP device ID.
Public property | PreexistingDiskPath | This value is the full path and file name of an existing virtual disk that you want to reuse. If this value is null, a new virtual disk will be created. (Inherited from VolumeOptions.)
Public property | ReplicaVmSCSIBus | Gets or sets the SCSI bus number the volume has on the replica Vm.
Public property | ReplicaVmSCSIUnitNumber | Gets or sets the SCSI unit number the volume has on the replica Vm.
Public property | ReverseVolumeSignature | Gets or sets the reverse volume signature. This represents the signature of the volume on the Source.
Public property | Saturation | This value represents the saturation level of the item. Typically, this value is used to display a visual state in the user interface. (Inherited from PhysicalItem.)
Public property | Size | This value is the physical size of the item. (Inherited from PhysicalItem.)
Public property | TotalSize | This value is the total size of the volume. (Inherited from Volume.)
Public property | VirtualDiskFilename | Gets or sets the filename for the virtual disk.
Public property | VirtualDiskPath | This value is the path on the host where the volume should be stored. (Inherited from VolumeOptions.)
Public property | VolumeName | Gets or sets the name of the volume.
Public property | VolumeSignature | This value is the volume signature. (Inherited from VolumeOptions.)
Public property | VolumeType | This value is the type of volume. (Inherited from Volume.)
Top
Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from VolumeOptions.)
 | Create | Creates a VRAVolumePersistedState from a VolumeOptions instance.
Top
See Also

Reference

DoubleTake.Virtualization.Contract.VRA Namespace


VRAVolumePersistedState Constructor

VRAVolumePersistedState Constructor
Initializes a new instance of the VRAVolumePersistedState class

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VRAVolumePersistedState()
Public Sub New
public:
VRAVolumePersistedState()
DoubleTake.Virtualization.Contract.VRA.VRAVolumePersistedState = function();
See Also

Reference

VRAVolumePersistedState Class
DoubleTake.Virtualization.Contract.VRA Namespace


VRAVolumePersistedState Properties

VRAVolumePersistedState Properties

The VRAVolumePersistedState type exposes the following members.

Properties
 | Name | Description
Public property | ApplianceSCSIBus | Gets or sets the SCSI bus number the volume has on the replica appliance.
Public property | ApplianceSCSIUnitNumber | Gets or sets the SCSI unit number the volume has on the replica appliance.
Public property | Attributes | This value represents the file system attributes. (Inherited from PhysicalItem.)
Public property | AvailableFreeSpace | This value is the amount of free space on the volume. (Inherited from Volume.)
Public property | CreationTime | This value is the time when the item was created. (Inherited from PhysicalItem.)
Public property | DesiredSize | This value is the desired size of the new volume. (Inherited from VolumeOptions.)
Public property | DeviceID | Gets or sets the device ID the volume has on the replica appliance
Public property | DiskControllerType | This value is the disk controller. IDE—Use this value to create an IDE disk. SCSI—Use this value to create a SCSI disk. (Inherited from VolumeOptions.)
Public property | DiskProvisioningType | This value is the disk type. Dynamic—Use this value for ESX thin disks and for Hyper-V dynamic disks. Fixed—Use this value for ESX thick disks and for Hyper-V fixed disks. Flat Disk—Use this value for ESX flat disks. This type is not supported on Hyper-V. (Inherited from VolumeOptions.)
Public property | DriveFormat | This value is the file system format of the volume. (Inherited from Volume.)
Public property | DriveIndex | Gets or sets the index of the drive the volume has on the replica appliance
Public property | DriveName | Gets or sets the name of the drive on the helper (\\.\PHYSICALDRIVEX)
Public property | DriveType | This value is the drive type. (Inherited from Volume.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from PhysicalItem.)
Public property | IsContainer | This value is true if the item is a container of other items; otherwise, it is false. (Inherited from PhysicalItem.)
Public property | IsGpt | Gets or sets a value indicating whether this instance is a GPT disk.
Public property | IsReadOnly | This value is true if the item is read-only (meaning the Saturation cannot be changed); otherwise, it is false. (Inherited from PhysicalItem.)
Public property | IsSystemDrive | This value is true if the volume is the system volume; otherwise, it is false. (Inherited from Volume.)
Public property | ItemType | This value is the type of item. (Inherited from PhysicalItem.)
Public property | Label | This value is the label assigned to the volume. (Inherited from Volume.)
Public property | LastAccessTime | This value is the time when the item was last accessed. (Inherited from PhysicalItem.)
Public property | LastWriteTime | This value is the time when the item was last written to. (Inherited from PhysicalItem.)
Public property | Metadata | This value is any additional metadata that may be displayed for a particular type of item. This metadata is not in any particular format, but you must be able to determine the format and decipher the metadata based on the type. (Inherited from PhysicalItem.)
Public property | MountPoint | Gets or sets the mount point.
Public property | Name | This value is the name of the item. Typically, this name is used for display in the user interface. (Inherited from PhysicalItem.)
Public property | OriginalPath | Gets or sets the path where the volume was stored on the source host.
Public property | Path | This value is the path of the item. (Inherited from PhysicalItem.)
Public property | PNPDeviceID | Gets or sets the PNP device ID.
Public property | PreexistingDiskPath | This value is the full path and file name of an existing virtual disk that you want to reuse. If this value is null, a new virtual disk will be created. (Inherited from VolumeOptions.)
Public property | ReplicaVmSCSIBus | Gets or sets the SCSI bus number the volume has on the replica Vm.
Public property | ReplicaVmSCSIUnitNumber | Gets or sets the SCSI unit number the volume has on the replica Vm.
Public property | ReverseVolumeSignature | Gets or sets the reverse volume signature. This represents the signature of the volume on the Source.
Public property | Saturation | This value represents the saturation level of the item. Typically, this value is used to display a visual state in the user interface. (Inherited from PhysicalItem.)
Public property | Size | This value is the physical size of the item. (Inherited from PhysicalItem.)
Public property | TotalSize | This value is the total size of the volume. (Inherited from Volume.)
Public property | VirtualDiskFilename | Gets or sets the filename for the virtual disk.
Public property | VirtualDiskPath | This value is the path on the host where the volume should be stored. (Inherited from VolumeOptions.)
Public property | VolumeName | Gets or sets the name of the volume.
Public property | VolumeSignature | This value is the volume signature. (Inherited from VolumeOptions.)
Public property | VolumeType | This value is the type of volume. (Inherited from Volume.)
Top
See Also

Reference

VRAVolumePersistedState Class
DoubleTake.Virtualization.Contract.VRA Namespace


VRAVolumePersistedState.ApplianceSCSIBus Property

VRAVolumePersistedStateApplianceSCSIBus Property
Gets or sets the SCSI bus number the volume has on the replica appliance.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int ApplianceSCSIBus { get; set; }
Public Property ApplianceSCSIBus As Integer
    Get
    Set
public:
property int ApplianceSCSIBus {
    int get ();
    void set (int value);
}
function get_ApplianceSCSIBus();
function set_ApplianceSCSIBus(value);

Property Value

Type: Int32
The replica appliance SCSI bus.
See Also

Reference

VRAVolumePersistedState Class
DoubleTake.Virtualization.Contract.VRA Namespace


VRAVolumePersistedState.ApplianceSCSIUnitNumber Property

VRAVolumePersistedStateApplianceSCSIUnitNumber Property
Gets or sets the SCSI unit number the volume has on the replica appliance.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int ApplianceSCSIUnitNumber { get; set; }
Public Property ApplianceSCSIUnitNumber As Integer
    Get
    Set
public:
property int ApplianceSCSIUnitNumber {
    int get ();
    void set (int value);
}
function get_ApplianceSCSIUnitNumber();
function set_ApplianceSCSIUnitNumber(value);

Property Value

Type: Int32
The replica appliance SCSI unit number.
See Also

Reference

VRAVolumePersistedState Class
DoubleTake.Virtualization.Contract.VRA Namespace


VRAVolumePersistedState.DeviceID Property

VRAVolumePersistedStateDeviceID Property
Gets or sets the device ID the volume has on the replica appliance

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string DeviceID { get; set; }
Public Property DeviceID As String
    Get
    Set
public:
property String^ DeviceID {
    String^ get ();
    void set (String^ value);
}
function get_DeviceID();
function set_DeviceID(value);

Property Value

Type: String
The device ID.
See Also

Reference

VRAVolumePersistedState Class
DoubleTake.Virtualization.Contract.VRA Namespace


VRAVolumePersistedState.DriveIndex Property

VRAVolumePersistedStateDriveIndex Property
Gets or sets the index of the drive the volume has on the replica appliance

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int DriveIndex { get; set; }
Public Property DriveIndex As Integer
    Get
    Set
public:
property int DriveIndex {
    int get ();
    void set (int value);
}
function get_DriveIndex();
function set_DriveIndex(value);

Property Value

Type: Int32
The index of the drive.
See Also

Reference

VRAVolumePersistedState Class
DoubleTake.Virtualization.Contract.VRA Namespace


VRAVolumePersistedState.DriveName Property

VRAVolumePersistedStateDriveName Property
Gets or sets the name of the drive on the helper (\\.\PHYSICALDRIVEX)

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string DriveName { get; set; }
Public Property DriveName As String
    Get
    Set
public:
property String^ DriveName {
    String^ get ();
    void set (String^ value);
}
function get_DriveName();
function set_DriveName(value);

Property Value

Type: String
The index of the drive.
See Also

Reference

VRAVolumePersistedState Class
DoubleTake.Virtualization.Contract.VRA Namespace


VRAVolumePersistedState.IsGpt Property

VRAVolumePersistedStateIsGpt Property
Gets or sets a value indicating whether this instance is a GPT disk.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsGpt { get; set; }
Public Property IsGpt As Boolean
    Get
    Set
public:
property bool IsGpt {
    bool get ();
    void set (bool value);
}
function get_IsGpt();
function set_IsGpt(value);

Property Value

Type: Boolean
true if this instance is GPT; otherwise, false.
See Also

Reference

VRAVolumePersistedState Class
DoubleTake.Virtualization.Contract.VRA Namespace


VRAVolumePersistedState.MountPoint Property

VRAVolumePersistedStateMountPoint Property
Gets or sets the mount point.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string MountPoint { get; set; }
Public Property MountPoint As String
    Get
    Set
public:
property String^ MountPoint {
    String^ get ();
    void set (String^ value);
}
function get_MountPoint();
function set_MountPoint(value);

Property Value

Type: String
The mount point.
See Also

Reference

VRAVolumePersistedState Class
DoubleTake.Virtualization.Contract.VRA Namespace


VRAVolumePersistedState.OriginalPath Property

VRAVolumePersistedStateOriginalPath Property
Gets or sets the path where the volume was stored on the source host.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string OriginalPath { get; set; }
Public Property OriginalPath As String
    Get
    Set
public:
property String^ OriginalPath {
    String^ get ();
    void set (String^ value);
}
function get_OriginalPath();
function set_OriginalPath(value);

Property Value

Type: String
The original path.
See Also

Reference

VRAVolumePersistedState Class
DoubleTake.Virtualization.Contract.VRA Namespace


VRAVolumePersistedState.PNPDeviceID Property

VRAVolumePersistedStatePNPDeviceID Property
Gets or sets the PNP device ID.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string PNPDeviceID { get; set; }
Public Property PNPDeviceID As String
    Get
    Set
public:
property String^ PNPDeviceID {
    String^ get ();
    void set (String^ value);
}
function get_PNPDeviceID();
function set_PNPDeviceID(value);

Property Value

Type: String
The PNP device ID.
See Also

Reference

VRAVolumePersistedState Class
DoubleTake.Virtualization.Contract.VRA Namespace


VRAVolumePersistedState.ReplicaVmSCSIBus Property

VRAVolumePersistedStateReplicaVmSCSIBus Property
Gets or sets the SCSI bus number the volume has on the replica Vm.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int ReplicaVmSCSIBus { get; set; }
Public Property ReplicaVmSCSIBus As Integer
    Get
    Set
public:
property int ReplicaVmSCSIBus {
    int get ();
    void set (int value);
}
function get_ReplicaVmSCSIBus();
function set_ReplicaVmSCSIBus(value);

Property Value

Type: Int32
The replica vm SCSI bus.
See Also

Reference

VRAVolumePersistedState Class
DoubleTake.Virtualization.Contract.VRA Namespace


VRAVolumePersistedState.ReplicaVmSCSIUnitNumber Property

VRAVolumePersistedStateReplicaVmSCSIUnitNumber Property
Gets or sets the SCSI unit number the volume has on the replica Vm.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public int ReplicaVmSCSIUnitNumber { get; set; }
Public Property ReplicaVmSCSIUnitNumber As Integer
    Get
    Set
public:
property int ReplicaVmSCSIUnitNumber {
    int get ();
    void set (int value);
}
function get_ReplicaVmSCSIUnitNumber();
function set_ReplicaVmSCSIUnitNumber(value);

Property Value

Type: Int32
The replica vm SCSI unit number.
See Also

Reference

VRAVolumePersistedState Class
DoubleTake.Virtualization.Contract.VRA Namespace


VRAVolumePersistedState.ReverseVolumeSignature Property

VRAVolumePersistedStateReverseVolumeSignature Property
Gets or sets the reverse volume signature. This represents the signature of the volume on the Source.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public byte[] ReverseVolumeSignature { get; set; }
Public Property ReverseVolumeSignature As Byte()
    Get
    Set
public:
property array<unsigned char>^ ReverseVolumeSignature {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
function get_ReverseVolumeSignature();
function set_ReverseVolumeSignature(value);

Property Value

Type: Byte
The reverse volume signature.
See Also

Reference

VRAVolumePersistedState Class
DoubleTake.Virtualization.Contract.VRA Namespace


VRAVolumePersistedState.VirtualDiskFilename Property

VRAVolumePersistedStateVirtualDiskFilename Property
Gets or sets the filename for the virtual disk.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string VirtualDiskFilename { get; set; }
Public Property VirtualDiskFilename As String
    Get
    Set
public:
property String^ VirtualDiskFilename {
    String^ get ();
    void set (String^ value);
}
function get_VirtualDiskFilename();
function set_VirtualDiskFilename(value);

Property Value

Type: String
The virtual disk filename.
See Also

Reference

VRAVolumePersistedState Class
DoubleTake.Virtualization.Contract.VRA Namespace


VRAVolumePersistedState.VolumeName Property

VRAVolumePersistedStateVolumeName Property
Gets or sets the name of the volume.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public string VolumeName { get; set; }
Public Property VolumeName As String
    Get
    Set
public:
property String^ VolumeName {
    String^ get ();
    void set (String^ value);
}
function get_VolumeName();
function set_VolumeName(value);

Property Value

Type: String
The name of the volume.
See Also

Reference

VRAVolumePersistedState Class
DoubleTake.Virtualization.Contract.VRA Namespace


VRAVolumePersistedState Methods

VRAVolumePersistedState Methods

The VRAVolumePersistedState type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from VolumeOptions.)
 | Create | Creates a VRAVolumePersistedState from a VolumeOptions instance.
Top
See Also

Reference

VRAVolumePersistedState Class
DoubleTake.Virtualization.Contract.VRA Namespace


VRAVolumePersistedState.Create Method

VRAVolumePersistedStateCreate Method
Creates a VRAVolumePersistedState from a VolumeOptions instance.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public static VRAVolumePersistedState Create(
    VolumeOptions volume
)
Public Shared Function Create (
    volume As VolumeOptions
) As VRAVolumePersistedState
public:
static VRAVolumePersistedState^ Create(
    VolumeOptions^ volume
)
DoubleTake.Virtualization.Contract.VRA.VRAVolumePersistedState.Create = function(volume);

Parameters

volume
Type: DoubleTake.Core.ContractVolumeOptions
The volume.

Return Value

Type: VRAVolumePersistedState
See Also

Reference

VRAVolumePersistedState Class
DoubleTake.Virtualization.Contract.VRA Namespace


VRAWorkloadCustomizationOptions Class

VRAWorkloadCustomizationOptions Class
This class contains options used to customize the workload
Inheritance Hierarchy
SystemObject
DoubleTake.Virtualization.Contract.VRAVRAWorkloadCustomizationOptions

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public class VRAWorkloadCustomizationOptions : IExtensibleDataObject
Public Class VRAWorkloadCustomizationOptions
    Implements IExtensibleDataObject
public ref class VRAWorkloadCustomizationOptions : IExtensibleDataObject
DoubleTake.Virtualization.Contract.VRA.VRAWorkloadCustomizationOptions = function();

Type.createClass(
    'DoubleTake.Virtualization.Contract.VRA.VRAWorkloadCustomizationOptions',
    null,
    IExtensibleDataObject);

The VRAWorkloadCustomizationOptions type exposes the following members.

Constructors
 | Name | Description
Public method | VRAWorkloadCustomizationOptions | Initializes a new instance of the VRAWorkloadCustomizationOptions class
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | NoReplication | Do not use this property. Double-Take uses it internally.
Public property | PowerupReplicaAfterFailover | This value is true if the replica should be powered on after failover; otherwise, it is false.
Public property | ShouldShutdownSource | This value is true if the source should be shut down during failover; otherwise, it is false.
Public property | UseWin32 | Do not use this property. Double-Take uses it internally.
Top
See Also

Reference

DoubleTake.Virtualization.Contract.VRA Namespace


VRAWorkloadCustomizationOptions Constructor

VRAWorkloadCustomizationOptions Constructor
Initializes a new instance of the VRAWorkloadCustomizationOptions class

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public VRAWorkloadCustomizationOptions()
Public Sub New
public:
VRAWorkloadCustomizationOptions()
DoubleTake.Virtualization.Contract.VRA.VRAWorkloadCustomizationOptions = function();
See Also

Reference

VRAWorkloadCustomizationOptions Class
DoubleTake.Virtualization.Contract.VRA Namespace


VRAWorkloadCustomizationOptions Properties

VRAWorkloadCustomizationOptions Properties

The VRAWorkloadCustomizationOptions type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | NoReplication | Do not use this property. Double-Take uses it internally.
Public property | PowerupReplicaAfterFailover | This value is true if the replica should be powered on after failover; otherwise, it is false.
Public property | ShouldShutdownSource | This value is true if the source should be shut down during failover; otherwise, it is false.
Public property | UseWin32 | Do not use this property. Double-Take uses it internally.
Top
See Also

Reference

VRAWorkloadCustomizationOptions Class
DoubleTake.Virtualization.Contract.VRA Namespace


VRAWorkloadCustomizationOptions.ExtensionData Property

VRAWorkloadCustomizationOptionsExtensionData Property
Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

VRAWorkloadCustomizationOptions Class
DoubleTake.Virtualization.Contract.VRA Namespace


VRAWorkloadCustomizationOptions.NoReplication Property

VRAWorkloadCustomizationOptionsNoReplication Property
Do not use this property. Double-Take uses it internally.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool NoReplication { get; set; }
Public Property NoReplication As Boolean
    Get
    Set
public:
property bool NoReplication {
    bool get ();
    void set (bool value);
}
function get_NoReplication();
function set_NoReplication(value);

Property Value

Type: Boolean
true if data replication desired; otherwise, false.
See Also

Reference

VRAWorkloadCustomizationOptions Class
DoubleTake.Virtualization.Contract.VRA Namespace


VRAWorkloadCustomizationOptions.PowerupReplicaAfterFailover Property

VRAWorkloadCustomizationOptionsPowerupReplicaAfterFailover Property
This value is true if the replica should be powered on after failover; otherwise, it is false.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool PowerupReplicaAfterFailover { get; set; }
Public Property PowerupReplicaAfterFailover As Boolean
    Get
    Set
public:
property bool PowerupReplicaAfterFailover {
    bool get ();
    void set (bool value);
}
function get_PowerupReplicaAfterFailover();
function set_PowerupReplicaAfterFailover(value);

Property Value

Type: Boolean
true if we should powerup the replica after failover; otherwise, false.
See Also

Reference

VRAWorkloadCustomizationOptions Class
DoubleTake.Virtualization.Contract.VRA Namespace


VRAWorkloadCustomizationOptions.ShouldShutdownSource Property

VRAWorkloadCustomizationOptionsShouldShutdownSource Property
This value is true if the source should be shut down during failover; otherwise, it is false.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool ShouldShutdownSource { get; set; }
Public Property ShouldShutdownSource As Boolean
    Get
    Set
public:
property bool ShouldShutdownSource {
    bool get ();
    void set (bool value);
}
function get_ShouldShutdownSource();
function set_ShouldShutdownSource(value);

Property Value

Type: Boolean
true if the source should be shutdown; otherwise, false.
See Also

Reference

VRAWorkloadCustomizationOptions Class
DoubleTake.Virtualization.Contract.VRA Namespace


VRAWorkloadCustomizationOptions.UseWin32 Property

VRAWorkloadCustomizationOptionsUseWin32 Property
Do not use this property. Double-Take uses it internally.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.0.0.1008
Syntax
C#
VB
C++
JavaScript
Copy
public bool UseWin32 { get; set; }
Public Property UseWin32 As Boolean
    Get
    Set
public:
property bool UseWin32 {
    bool get ();
    void set (bool value);
}
function get_UseWin32();
function set_UseWin32(value);

Property Value

Type: Boolean
true if we should have a USEWIN32; otherwise, false.
See Also

Reference

VRAWorkloadCustomizationOptions Class
DoubleTake.Virtualization.Contract.VRA Namespace